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Product What's New

Pro/ENGINEER Advanced Assembly
Top-Down Design with Mechanism Assemblies

Enhanced skeleton models now support motion so that you can create an
assembly using top-down design techniques and connections.

●   



Product What's New

Top-Down Design with Mechanism
Assemblies
Enhanced skeleton models now support motion so that you can create an assembly
using top-down design techniques and connections.

Product Information

Product Pro/ENGINEER Advanced Assembly
PTC Support Release Wildfire 3.0

Product Functional Area Assembly

User Interface Location Click Insert > Component > Create > Skeleton Model
> Motion or Body.

Benefits and Description

With motion skeleton models,  you can use mechanism design at the beginning of
the design process. Thus, you eliminate the need to recreate assemblies that require
mechanism analysis but were fully constrained by skeleton models and data
sharing features.

You can create mechanism bodies within the motion skeleton and define
connections. A simple kinematic analysis can ensures that the mechanism skeleton
provides the appropriate degrees of freedom. You can then create and assemble
parts to the individual skeleton bodies. Because motion skeletons are true skeleton
models, they have reference control settings and will not show in the bill of
materials for the assembly.



Product What's New

Pro/ENGINEER Advanced Rendering
LWA Material Archive Support

Lightworks LWA material archives are now supported in Pro/ENGINEER
Wildfire 3.0

●   

Material Editing

The ability to edit parameters of the advanced material shaders used with the
Advanced Rendering Extension (ARX) has been added for Pro/ENGINEER
Wildfire 3.0.

●   



Product What's New

LWA Material Archive Support
Lightworks LWA material archives are now supported in Pro/ENGINEER
Wildfire 3.0

Product Information

Product Pro/ENGINEER Advanced Rendering
PTC Support Release Wildfire 3.0

Product Functional Area Rendering

User Interface Location LWA file formats are now supported in the appearance
editor for .lwa material files.

Benefits and Description

The extensive libraries of material files in .lwa format are now supported for the
Wildfire 3.0 release within the Advanced Rendering Extension.  Choose from
thousands of free and purchasable product design materials provided by numerous
suppliers and LightWork Design. For more information see
http://www.lightworks-user.com/aboutlwa.htm

http://www.lightworks-user.com/aboutlwa.htm


Product What's New

Material Editing
The ability to edit parameters of the advanced material shaders used with the
Advanced Rendering Extension (ARX) has been added for Pro/ENGINEER
Wildfire 3.0.

Product Information

Product Pro/ENGINEER Advanced Rendering
PTC Support Release Wildfire 3.0

Product Functional Area Rendering

User Interface Location View->Color and Appearance (Shortcut icon also
available)

Benefits and Description

Enhancements to the Appearance editor in Wildfire 3.0 gives users the power to
edit the many parameters such as color, reflectivity, scale etc. of the advanced
materials that are availible with the Advanced Rendering Extension (ARX)



Product What's New

Pro/ENGINEER Advanced Structural and
Thermal

ANSYS Solver Improvements

More modeling entities are output to the ANSYS solver in FEM mode.

●   

Advanced Springs

More capabilities have been added to advanced springs.

●   

Rigid and Weighted Links for FEM Mode

Rigid and weighted links have been enhanced for FEM mode.

●   



Product What's New

ANSYS Solver Improvements
More modeling entities are output to the ANSYS solver in FEM mode.

Product Information

Product Pro/ENGINEER Advanced Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Analysis > FEM Solution.

Benefits and Description

Rigid links and beam releases defined in the model are now output to the ANSYS
solver at run time. As a result, FEM analysis of your model is improved.



Product What's New

Advanced Springs
More capabilities have been added to advanced springs.

Product Information

Product Pro/ENGINEER Advanced Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Properties > Spring Properties.

Benefits and Description

Advanced spring properties have been enhanced to allow greater control. You can
now turn off the automatic computation of coupling terms. With automatic
coupling turned off, the individual coupling terms can be entered manually .



Product What's New

Rigid and Weighted Links for FEM Mode
Rigid and weighted links have been enhanced for FEM mode.

Product Information

Product Pro/ENGINEER Advanced Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Insert > Connection > Rigid Link.

Benefits and Description

Previously, when defining rigid and weighted links, you could only define them
between two surfaces or between two points. Now you can define these modeling
entities between a point and define a distribution along an edge or surface.  When
you select a point-edge or a point-surface reference, the option to distribute a
project appears.  This new functionality allows you to build complex FEM models
more easily .



Product What's New

Pro/ENGINEER Cabling Design

Hierarchal Cables

You can now use the hierarchal nature of multilevel cables of Routed
Systems Designer within Cabling Design.

●   

New Harness Manufacture Configuration Option

A new configuration option allows you to control if parent connectors are to
be assembled during the creation of flattened harnesses.

●   

Start Parts for Cabling Design

The new start part option for the creation of 3D and flattened harnesses
enables you to store predefined views and parameters in a template part. In
addition, three new configuration options are available.

●   



Product What's New

Hierarchal Cables
You can now use the hierarchal nature of multilevel cables of Routed Systems
Designer within Cabling Design.

Product Information

Product Pro/ENGINEER Cabling Design
PTC Support Release Wildfire 3.0

Product Functional Area Cabling Design
User Interface Location Click Feature > Create > Overbraid.

Benefits and Description

In Cabling Design, creating a multilevel cable from the 2D Schematic XML data
automatically creates all lower-level cables, conductors, and wires. You can then
either manually or automatically route them. Because of the hierarchical setup, you
can verify your 2D schematic to your 3D harness design for routing conformance.

Multimedia

Videos

Hierarchal Cables

http://www.ptc.com/WCMS/files/26313en_vid_vid_step_1.avi


Product What's New

New Harness Manufacture Configuration
Option
A new configuration option allows you to control if parent connectors are to be
assembled during the creation of flattened harnesses.

Product Information

Product Pro/ENGINEER Cabling Design
PTC Support Release Wildfire 3.0

Product Functional Area Cabling Design
User Interface Location Tools > Options

Benefits and Description

Prior to Pro/ENGINEER Wildfire 3.0 if wires, conductors, or cables were
connected to the contents (parts) of a subassembly, such as NOC.prt and NCC.prt
of RELAY.asm, in Harness Manufacture during the assembly of components, the
Relay subassembly would be assembled by default. The configuration option
assemble_parent_connector provides control over how components must be
assembled. A YES value assembles a parent connector on locations referencing a
subconductor (RELAY.asm). A NO value only assembles the connected
components NOC.prt and NCC.prt.

Multimedia

Videos

Assembling Parent Connector

http://www.ptc.com/WCMS/files/26308en_vid_vid_step_1.avi


Product What's New

Start Parts for Cabling Design
The new start part option for the creation of 3D and flattened harnesses enables
you to store predefined views and parameters in a template part. In addition, three
new configuration options are available.

Product Information

Product Pro/ENGINEER Cabling Design
PTC Support Release Wildfire 3.0

Product Functional Area Cabling Design

User Interface Location Click Harness > Create & New > Manufacturing >
Harness.

Benefits and Description

On creation of a harness or a flattened harness, you can use the defined start part
for greater adherence to company standards, and, if you use ModelCHECK, for
smoother verification. Three new configuration options for cabling and harness
manufacture allow you to define the start part directory, the template for harness,
and the template for the flat harness start part.

Multimedia

Videos

Cabling Start Parts

http://www.ptc.com/WCMS/files/26302en_vid_vid_step_1.avi


Product What's New

Pro/ENGINEER Complete Machining

3D Equidistant Finishing

A spiral finish with constant step over on surface is now possible.

●   

Assembly Step in Process Manager

With a new assembly step, you can assemble other components within a NC
process and use them to continue the NC process.

●   

Automated Setting for Manufacturing Model Accuracy

An automated setting for absolute accuracy for the manufacturing model is
now available.

●   

Automatic Filleting of Corners

For high-speed machining, you can automatically generate corner filleting.

●   

Compliance Checking in the Manufacturing Process

The Process Manager shows a status for each NC step and each operation.

●   



Control of Slowdown in Corners

Better control of slowdown of the feed in corners is available for roughing
toolpaths.

●   

Creation of Datum Features in Mold and NC

The tools from Part mode for creating Datum features are now accessible in
Mold and NC.

●   

Custom Cycle Improvements

The custom cycle descriptions for defining cycle motions have been
enhanced.

●   

Custom Cycles for Drilling

Custom cycles for drilling are fully supported within the Manufacturing
Process Manager.

●   

Customization of 3-Axis Trajectory Toolpath

New options improve the customization for the 3-axis trajectory and provide
more control on the tool tip selection and spindle orientation.

●   

Export and Synchronize the Manufacturing Step Table
●   



You can export the Step Table to a CSV format for manipulation in an
external application and then synchronize the result with the Process
Manager.

Finishing Toolpath Enhancements

More options have been added to control the finishing toolpath behavior.

●   

Global Parameters and Global Relations

You can create a single, global parameter or global relation that applies to all
steps of a NC process.

●   

Improved Time Computation in Machining

Time computation now takes into account cutting time, approach, exit, and
connection times.

●   

Machine Tool Manager User Interface

The Machine Tool Manager has been redesigned with an intuitive user
interface to simplify tool definition.

●   

Manual Cycle in the Manufacturing Process Manager

A manual cycle can be used in manufacturing templates.

●   

●   



Manufacturing Annotation Features and Extraction

Manufacturing information, such as steps and Annotation features, can be
assigned to the design models with a template and extracted.

Manufacturing Operation Model

Instances of the workpiece are created automatically with the removal of
material in the manufacturing process.

●   

Manufacturing Process Template

A complete process intent can be captured in a manufacturing process
template that can be reproduced to create a new process.

●   

Manufacturing Step Dependencies

Allowing user-defined dependencies between steps helps control reordering.

●   

Manufacturing Step Locking

You can lock and unlock any steps so that the steps cannot be modified by
accident.

●   

Manufacturing Template Replacement during Extraction

During extraction, you can extract manufacturing templates other than those
stored in the design model.

●   



Mirror Toolpath

With added functionality for the milling NC sequence feature, you can
mirror a toolpath while keeping the cutting condition.

●   

Model Views and the Process Manager

The Model View displays manufacturing templates in the design model,
grouped according to the Z-axis orientation and the manufacturing criteria. It
facilitiate the creation of a process plan during extraction in the Process
Manager.

●   

Mold and NC Geometry User Interface

Modern user interface tools for manufacturing, mold volume, and surface
definition have been implemented.

●   

Process Manager Usability Improvements

Several usability improvements increase your productivity when using the
Process Manager.

●   

Step Depth for Area Turning

A new computation technique for step depth in area turning is available.

●   

Time Analysis for the Manufacturing Process
●   



Tools for time analysis help optimize a NC process.



Product What's New

3D Equidistant Finishing
A spiral finish with constant step over on surface is now possible.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Use Manufacturing / NC Sequence / Finishing / NC
Sequence parameter.

Benefits and Description

3D equidistant finishing (finishing with constant step over on surface) guarantees a
high surface quality while simultaneously reducing the cutter load even on steep
surfaces.

The step over is computed on the surface to be machined. As a result, the step over
remains unchanged over the entire path. This new scan type
SPIRAL_3D_EQUIDISTANT is available in the Finishing toolpath as an option
for SHALLOW_AREA_SCAN.

Multimedia

Images

3D Equidistant



Product What's New

Assembly Step in Process Manager
With a new assembly step, you can assemble other components within a NC
process and use them to continue the NC process.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click Insert > Step > Assembly Step in the Process
Manager.

Benefits and Description

To be very accurate, some assemblies must be machined assembled. This new
assembly step within a NC process provides for the assembly a new component.
As a result, the new component becomes part of the manufacturing process and can
be used to create new tool paths. For instance, a very accurate hole that goes
between two models can be created with the two models assembled.

Multimedia

Images

Assembly Step

Videos

Assembly Step

http://www.ptc.com/WCMS/files/26035en_vid_vid_step_1.avi


Product What's New

Automated Setting for Manufacturing
Model Accuracy
An automated setting for absolute accuracy for the manufacturing model is now
available.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location N/A

Benefits and Description

Automated settings for absolute accuracy of the manufacturing model save time.
Toolpath issues due to innacurate geometry are reduced for later in the
computations of manufacturing toolpath.

After you place the reference part, a prompt appears if the reference part and the
manufacturing assembly accuracy do not match. You can choose whether to
change the manufacturing assembly accuracy to be equal to the reference model
accuracy.

Multimedia

Images

Absolute Accuracy Setting Dialog



Product What's New

Automatic Filleting of Corners
For high-speed machining, you can automatically generate corner filleting.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0
Product Functional

Area
Manufacturing (NC, Expert Machinist)

User Interface Location Click NC Parameter > SMOOTH_SHARP_CORNERS.

Benefits and Description

To improve the scan type for high-speed machining, a optional corner filleting has
been added to the roughing toolpaths: roughing, re-roughing, volume milling, and
local milling.

You can control how to round or smooth sharp edges on a roughing toolpath. The
value of the round is proportional to the angle of the sharp corner. An additional
option allows for fitting the largest fillet possible between the two edges.

Multimedia

Images

Toolpath filleting



Product What's New

Compliance Checking in the
Manufacturing Process
The Process Manager shows a status for each NC step and each operation.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Not applicable

Benefits and Description

The status available with the Process Manager provides information on the missing
elements, so you can create a new NC step or or operation. When the NC Step (or
Operation) definition is completed, you can set an electronic signature by changing
manually the status value to OK. The value will not change if the step is
incomplete.

Multimedia

Images

Compliance Checking

Videos

Compliance Checking

http://www.ptc.com/WCMS/files/26036en_vid_vid_step_1.avi


Product What's New

Control of Slowdown in Corners
Better control of slowdown of the feed in corners is available for roughing
toolpaths.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Use the NC Sequence Parameters.

Benefits and Description

For control of slowdown in corners, you can set the length, starting location, and
the rate of the slowdown for roughing toolpaths. When toggled on with the
CORNER_SLOWDOWN parameter, you can set the following parameters:

SLOWDOWN_LENGTH specifies the distance along which the tool will
slow down.

●   

SLOWDOWN_PERCENT specifies the slowest feed rate during slowdown
as a percent of the cut feed rate.

●   

NUMBER_SLOWDOWN_STEP sets the abruptness of the slowdown. The
greater the number, the more even the slowdown.

●   

Combined with corner filleting, this control for slowdown in corners ensures a
smooth cutter transition between walls. As the cutter leaves the corner, it
accelerates back to the cut feed rate.

Multimedia

Images

Slowdown Control



Product What's New

Creation of Datum Features in Mold and
NC
The tools from Part mode for creating Datum features are now accessible in Mold
and NC.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Use the Datum toolbar or the Insert menu.

Benefits and Description

With this modern user interface, you can create datum features in Mold and
NC. (The Menu Manager is no longer available.)

Multimedia

Images

CSYS Datum creation



Product What's New

Custom Cycle Improvements
The custom cycle descriptions for defining cycle motions have been enhanced.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Use Machining / NC Sequence / Holemaking / Custom
/ Cycle Type.

Benefits and Description

Overall improvements to custom cycle functionality, combined with the support of
multi-tip tools, provide greater flexibility and power in the definition of the custom
cycles. Improvements are as follows:

Support for TIP number selection as a cycle point modifier.●   

Insertion of CL commands at a specific location in the cycle description.●   

Naming of the GOTO point in the cycle definition, making the cycle
description easier to understand.

●   

Support for SPINDL/ORIENT with angle and jog distance, particularly
practical for back-boring operations.

●   

In addition, the panel for custom cycle definition can be resized for improved
usability.

Multimedia

Images

Custom Cycle



Product What's New

Custom Cycles for Drilling
Custom cycles for drilling are fully supported within the Manufacturing Process
Manager.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location New drilling step Custom Drill

Benefits and Description

Custom Drill is a new step the Manufacturing Process Manager to describe drilling
cycles. You can capture the description of the custom drilling cycle in a
manufacturing template as an Annotation Element in a design model. You can
use custom cycles for creating and automating new drilling steps.

Multimedia

Images

Custom Cycles



Product What's New

Customization of 3-Axis Trajectory
Toolpath
New options improve the customization for the 3-axis trajectory and provide more
control on the tool tip selection and spindle orientation.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location On the MACHINING menu, click NC Sequence and
select the Trajectory option.

Benefits and Description

The following options have been added to the GOTO Point dialog box  for
improved customization:

TIP Number selection for multi-tip tools allows you to select the control
point for the current tool. This option is available for GOTO Point, GO
Delta, Plunge, Retract, and GO HOME motions.

●   

Additional controls for SPINDL parameters support orientation and jog
distance.

●   

Multimedia

Images

Trajectory Customize



Product What's New

Export and Synchronize the
Manufacturing Step Table
You can export the Step Table to a CSV format for manipulation in an external
application and then synchronize the result with the Process Manager.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click File > Export Table (CSV) and Tools >
Synchronize Process.

Benefits and Description

With an external application, like Excel, you can take the exported CSV format
and reorder steps, delete steps, change parameters values, and perform other
operations. The content exported from the Step Table is from the active view.
After  you complete the manipulation of the table, you can synchronize the new
content with the Process Manager, so that the modifications are present in the Step
Table in Manufacturing NC.

Multimedia

Images

Export the Process Table

Videos

Export and Import

http://www.ptc.com/WCMS/files/26532en_vid_vid_step_1.avi


Product What's New

Finishing Toolpath Enhancements
More options have been added to control the finishing toolpath behavior.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location On the MACHINING menu, click NC Sequence and
then click Finishing | Done.

Benefits and Description

The finishing toolpath now provides more control to the NC programmer :

Loop connection is now available. Neighboring endpoints are connected by
vertical loops, with the tool leaving and entering material tangent to the
surface being machined.

●   

Negative stock allowance is allowed.●   

Separate control is provided for steep and shallow surfaces, step over, and
scallop height.

●   

The spiral direction (SPIRAL_SCAN_DIRECTION) for shallow surface
machining can be controled  : INSIDE_OUT and OUTSIDE_IN 

●   

Individual surfaces can be removed from the toolpath computation.●   



Product What's New

Global Parameters and Global Relations
You can create a single, global parameter or global relation that applies to all steps
of a NC process.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click Tools > Global Parameters and click Tools >
Global Relations.

Benefits and Description

You no longer must create a parameter or relation for each step in the NC process.
With the new global parameter and global relation, you can create one or more
parameters or relations for all steps in Process Table at once.

Multimedia

Images

Global Parameters and relations

Videos

Creating global parameters and relations

http://www.ptc.com/WCMS/files/26506en_vid_vid_step_1.avi


Product What's New

Improved Time Computation in
Machining
Time computation now takes into account cutting time, approach, exit, and
connection times.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Use the PLAY Path of Time Calculation icons.

Benefits and Description

NC Manufacturing considers more information for the time computation of each
NC sequence, such as for the following factors:

The time between the steps to calculate the total operation time.●   

The time to change tools and the rapid feedrate motions to calculate the
time for NC steps or for complete operations. (Use the Workcell option)

●   

Multimedia

Images

Time Computation



Product What's New

Machine Tool Manager User Interface
The Machine Tool Manager has been redesigned with an intuitive user interface to
simplify tool definition.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click NC Setup > Machine Tool Manager or click the
icon in the Operation Setup dialog box.

Benefits and Description

The Machine Tool Manager provides more information for defining tools:

Provides for intuitive definition of  the machining tool shape.●   

Supports flute length and holder definition. Holders are used for
graphic simulation and are degouged in surface and trajectory milling.

●   

Attaches technology parameters to the machining tool: spindle direction,
coolant type, and pressure. You can also define any custom parameters or
attributes to store with the tool. These parameters can automatically be
propagated to the NC sequence settings based on the
MFG_PARAM_AUTO_COPY_FROM_TOOL config.pro value.

●   

Associates CL commands to the machining tool. They are issued
automatically in the CL file at each tool change.

●   

Stores the machining tool parameter file in XML format, simplifying the
interface to the external tool database management system. This single file,
combining tool geometry and cutting technology, can also be easily
managed by PDMLink.

●   

Multimedia

Images

Tool Shape Definition



Product What's New

Manual Cycle in the Manufacturing
Process Manager
A manual cycle can be used in manufacturing templates.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Milling NC Sequence

Benefits and Description

The manual cycle supports all the main commands for customization and motion:
GOTO Point, GO DELTA, Follow a Curve (2D or 3D curve sare allowed), Go to a
plane, Go to an axis, and the Insert CL commands.

You describe the manual cycle in a manufacturing template, and then place it in an
Annotation Element in a design model. This is a productive manner in which to
assign manufacturing information into a design model.  For an example of its use,
see Manufacturing Annotation Features and Extraction.

Multimedia

Images

Manual Cycle menu locations

Manual Cycle Definition

Videos

Manual Cycle Creation

Manual Cycle in a Template

http://www.ptc.com/WCMS/files/26530en_vid_vid_step_1.avi
http://www.ptc.com/WCMS/files/26530en_vid_vid_step_2.avi


Product What's New

Manufacturing Annotation Features and
Extraction
Manufacturing information, such as steps and Annotation features, can be assigned
to the design models with a template and extracted.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Process Manager and Annotation features

Benefits and Description

Using the Process Manager, you can create a manufacturing template based on a
selection of steps, and then use the template to perform the manufacturing steps in
a different model.  A manufacturing template is an XML file containing
information necessary to perform the step.

In the design model, you can also add manufacturing information as an annotation
to a referenced part or assembly. The manufacturing template contains the
information to perform the NC machining of the selected references. You can
automatically extract all NC information from the design model to create the NC
process. 
 

Multimedia
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Create MFG Template

Place MFG Template

Extract Mfg Templates

Videos

Create an MFG Template

Place MFG Template

Extract MFG Templates

http://www.ptc.com/WCMS/files/26502en_vid_vid_step_1.avi
http://www.ptc.com/WCMS/files/26502en_vid_vid_step_2.avi
http://www.ptc.com/WCMS/files/26502en_vid_vid_step_3.avi


Product What's New

Manufacturing Operation Model
Instances of the workpiece are created automatically with the removal of material
in the manufacturing process.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click Features > Update Workpiece Instances in the
Process Manager.

Benefits and Description

In production machining, the fixtures and jigs are often designed for each
operation. To create the design, you must have a clear understanding of the state of
the workpiece at the end of each operation. This simple and automatic tool
removes material for each NC step of a complete process.

During the automatic removal of all material for each NC step, the necessary
number of family instances in the workpiece are created. As a result, each instance
that represents the machining state at the end of each operation can be used as a
manufacturing operation model in a different assembly to start the design of the
fixtures.

Multimedia
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Create Operation Model

Familly Table of Operation Models

Videos

Create an Operation Model

http://www.ptc.com/WCMS/files/26037en_vid_vid_step_1.avi


Product What's New

Manufacturing Process Template
A complete process intent can be captured in a manufacturing process template
that can be reproduced to create a new process.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click File > Create Process Template and choose Use
Process Template in Extract.

Benefits and Description

A high productivity tool, the manufacturing process template is an XML file that
stores the description of an existing process. It captures the intent of the process to
reproduce it easily to develop a new process. A process template includes all
information about a NC Manufacturing process. It can create a new process for the
following common cases:

On a similar, independent model●   

For the same model but in a different factory or in a different production line●   

For the same model but with different productivity intent●   

For each case, you create an original template to describe the expected
organization of NC steps. This description, stored as a process template, is used
during the automatic extraction of manufacturing templates in models.
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Product What's New

Manufacturing Step Dependencies
Allowing user-defined dependencies between steps helps control reordering.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Add prerequisites during a Step definition.

Benefits and Description

A complete NC process can be made of hundreds of steps. Reordering those steps
to optimize the complete process can become a nightmare if you must think about
all dependencies between the NC steps.

With the Process Manager, you can define prerequisite steps. For example, you can
set a center drilling of the material as a prerequisite for a step. In other words, a
step cannot occur if the center drilling has not already been done. The prerequisite
is checked against reordering of steps.
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Product What's New

Manufacturing Step Locking
You can lock and unlock any steps so that the steps cannot be modified by
accident.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location In the Icon Bar, Lock and Unlock icons

Benefits and Description

Using the Step Table, you can lock any completed and validated step to prevent its
being accidently modified. You cannot edit or delete a locked step.
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Product What's New

Manufacturing Template Replacement
during Extraction
During extraction, you can extract manufacturing templates other than those stored
in the design model.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location In the Options tab, click Use External Template.

Benefits and Description

The design model can include many Annotation Elements in the manufacturing
templates, and those templates may not be the one that the NC process designer
must use to create the process. In that case, you can exchange the templates
directly in the design model (using Tools > Update Mfg AEs in Solid mode). If
you have no permission to overwrite the design model, then, you can extract
processes from templates different from those stored in the design model.

To allow this exchange, the configuration option mfg_process_template_dir must
point to the directory for the storage of manufacturing templates used
for replacements. The exchange occurs if the templates are compatible (same
references in use). If no equivalent template is found, the exchange is not done.
The NC process will be created with the templates present in the design model
itself.
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Product What's New

Mirror Toolpath
With added functionality for the milling NC sequence feature, you can mirror a
toolpath while keeping the cutting condition.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location On the MACHINING menu, choose NC Sequence.
Click Mirror / Done.

Benefits and Description

To automatically create a new NC sequence feature, select a milling NC sequence
and a plane for the mirrored toolpath. The resultant sequence feature is a parent of
the original sequence. If you keep the cutting condition (CLIMB/UPCUT) in the
mirrored toolpath, the resultant NC sequence is a child feature of the original NC
sequence. You can place this child feature anywhere after its parent in the Model
Tree. Any change to the original NC sequence impacts the mirrored feature.

Creation of the mirrored geometry is not required. Only the original sequence and
a mirror plane is necessary. Mirrored toolpaths are available for all NC sequences
in milling.
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Product What's New

Model Views and the Process Manager
The Model View displays manufacturing templates in the design model, grouped
according to the Z-axis orientation and the manufacturing criteria. It facilitiate the
creation of a process plan during extraction in the Process Manager.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click the Model View tab in the Mfg Template AE
Extraction dialog box.

Benefits and Description

During extraction of the manufacturing templates from a design model, the Model
View provides the process engineer with information to facilitate the creation of
the process plan. The Model View includes manufacturing templates, sorted by
orientation, and the parameters for manufacturing criteria in the current model.

When placing an Annotation Element for a manufacturing template, you can
enter manufacturing criteria. These parameters describe the area that is machined,
like "oil pump fixturing hole" or "top face facing." These Annotation Elements
provides a better understanding of what areas of the model are machined during the
extraction process in the Process Manager.
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Product What's New

Mold and NC Geometry User Interface
Modern user interface tools for manufacturing, mold volume, and surface
definition have been implemented.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Use the Mill Volume and Surface icons.

Benefits and Description

The redesigned user interface for manufacturing and mold geometry definition
incorporates feature creation tools from core and part.
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Product What's New

Process Manager Usability
Improvements
Several usability improvements increase your productivity when using the Process
Manager.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)
User Interface Location Not applicable

Benefits and Description

The Step Table improvements for the Process Manager promote increased
productivity:

Reordering of several steps, even if they do not follow each other●   

Modifying steps in the Information Layout●   

Modifying directly the content of the cells●   
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Product What's New

Step Depth for Area Turning
A new computation technique for step depth in area turning is available.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location
On the MACHINING menu, click NC Sequence.
Select the Area Turning option and click NC
Parameters.

Benefits and Description

In area turning, the toolpath is generated by scanning an area in the model cross
section (turn profile) where you want the material to be removed in step-depth
increments. The area is subdivided in regions corresponding to the diameters of the
intermediate reference part to be machined. Two options are available for the NC
parameter STEP_DEPTH_COMPUTATION  to compute the pass resulting from
the STEP_DEPTH parameter:

BY_REGION: Takes into account the diameter of the intermediate reference
part to be machined in the default value and in current behavior.

●   

BY_AREA: Ignores completely the diameters of the intermediate reference
part and provides a constant step depth on the overall area.

●   

Additionally, a new NC parameter controls the distance traveled along the surface
of the part, above the previous pass, and before the rapid connection:
CONNECT_OVERLAP.

Multimedia

Images

Area Turning



Product What's New

Time Analysis for the Manufacturing
Process
Tools for time analysis help optimize a NC process.

Product Information

Product Pro/ENGINEER Complete Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Click the icon in process Manager to display the Time
Graph.

Benefits and Description

The Process Manager provides time graphs for a direct analysis of the process
times. These graphs show the times for each operation, each orientation, each tool,
and even each NC step.

A time graph helps to equalize the time for each operation. It also helps you to
quickly understand and predict the lifetime for each cutting tool.
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Product What's New

Pro/ENGINEER Flex3C
Auto Propagate Strong AE Point References

Automatically propagate datum points that are defined as strong AE
references to data sharing features.

●   



Product What's New

Auto Propagate Strong AE Point
References
Automatically propagate datum points that are defined as strong AE references to
data sharing features.

Product Information

Product Pro/ENGINEER Flex3C
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas

User Interface Location Select Annotation Feature > Edit Definition > Select
Annotation Element > Set reference to auto propagate

Benefits and Description

When an annotation element contains datum points as references, users can
designate them to be automatically propagated to data sharing features when the
annotation element that contains them is propagated. This enables users to define
annotation elements that contain measurement or target points on surfaces - and to
propagate the annotation element and the datum points to downstream models.

This ensures that critical datum points are accurately communicated to downstream
models and processes.



Product What's New

Pro/ENGINEER Foundation Advantage
3D Quick Print

Quickly create drawing layouts and plot directly from the 3D environment.

●   

3D Section Display in Drawings

In Pro/ENGINEER Wildfire 3.0, drawing views can display 3D sections
(zones) from models.

●   

3D Set Datum Tags on Surfaces

We've implemented a new option for displaying set datums in 3D. Users can
now place ASME Y14.41 style set datum tags on surfaces.

●   

Activate Layer

Now you can set a layer to be active and all layer-able entities created from
that point forward will automatically be added to that layer.

●   

Additional Language Support for Pro/ENGINEER on Linux

Responding to the growing demand from global Linux users,
Pro/ENGINEER Wildfire 3.0 offers additional language support.

●   

Align Angular Dimensions

Angular and linear dimensions can now be aligned at the same time.

●   

Annotation Feature and UDF Interaction

Users can now add annotation features to UDFs. Users can choose to vary
surface finish values, geometric tolerance values, or driven dimension
tolerances.

●   

Annotation Features in UDFs

You can select Annotation features for inclusion in user-defined features.
Annotation features and Annotation Element parameters and some
annotation values can also be marked as variable items in the feature
definitions.

●   

Attach Geometric Tolerances to Leader Elbows

New placement options for geometric tolerance attachment have been added
to support ISO and JIS standards.

●   

Autodetection of a Windows Locale

Pro/ENGINEER and PTC.Setup have been enhanced to detect the system
default locale on Windows and attempt to run Pro/ENGINEER in that
locale.

●   

Automatic Annotation Display in Drawings●   



Maximize the value of detailing your 3D models. When you create a
drawing view of a model with 3D annotations, they are automatically shown
when appropriate.

Automatic Clipped Dimensions

We've added a new way to create clipped dimensions in Pro/ENGINEER
Wildfire 3.0 and improved the ability to create small, acute, angular
dimensions.

●   

Chamfer Dimension Witness Lines

Now when shown chamfer dimensions are repositioned, a witness line will
automatically be created.

●   

Component Interface Definition Enhancements

Component Interfaces are now easier to define, easier to place in an
assembly, and viewable in the Model Tree.

●   

Component Placement Dashboard

The Component Placement dashboard, drag handles, and feedback in the
graphics window provide a faster, easier method to assemble components in
Pro/ENGINEER assemblies.

●   

Component Replace Enhancements

All methods of replacing components in an assembly have been enhanced
and combined into a single, easy-to-use dialog box.

●   

Consolidated Cut and the Both Sides Option

The sheetmetal cut is consolidated with the solid Cut.

●   

Copy and Paste in Assembly

The Windows style copy and paste is now available in Assembly mode.

●   

Create Snap Lines Offset 2D Entities

Snap lines can now reference 2D draft entities in drawings.

●   

Cross Section Analysis

The Section Analysis tool has an option to automatically span the selection
set with cross sections at a defined spacing for analysis.

●   

Curved Patterns

The Curve option on the Pattern dashboard allows you to create instances of
a feature along a sketched curve.

●   

Cut, Copy, and Paste in Sketcher

Sketcher now uses the Microsoft cut, copy, and paste operations for

●   



consistency with Pro/ENGINEER.

Data Sharing Dashboard

The Data Sharing dashboard modernizes the user interface and consolidates
the Merge, Cutout, and Inheritance features.

●   

Defining the text direction for annotations

When placing annotations, users are presented with the default text
direction. This can be changed using default angle selections or by entering
an angle.

●   

Dependant Copy Enhancements for Annotation Features

When creating dependant copies of annotation features, the annotations
included will also be dependant. Dependant behavior of annotations is
limited to text input, text style, color, and parameters.

●   

Dependent 3D Cross Section Views

By default, when a new view is created that is dependent upon a view using
a 3D section, the dependent view's section will be linked to its parent's
section setting.

●   

Detailing 'On-Item' Note Position Enhancements

Detailing has been enhanced enabling users to control the vertical and
horizontal justification of On-Entity notes.

●   

Difference Report support of 3D Drawings

The Pro/ENGINEER Wildfire 3.0 difference report now includes the ability
to analyze and determine the difference between two versions of the same
part for Annotation Features, their Annotation Elements and Annotations.

●   

Direct Manipulation of Lights

The way that users interact with lights has been completely overhauled
within Pro/ENGINEER Wildfire 3.0

●   

Draft Analysis and Color Display

Draft Analysis enhancements to color display provide three-colors with
control over the transition between color regions.

●   

Drawing Template Improvements

Drawing templates now support 3D sections and combination states, and
they provide better scaling options.

●   

Enhancements to Asynchronous Datum Creation

Datums created during other feature creation tools will be embedded into the
feature. Users can embed datum axis, datum points, datum planes, and
datum coordinate systems.

●   

Enhancements to the Annotation Feature User Interface

Enhancements to the annotation feature interface include having the ability

●   



to enter descriptions for the references selected, to replace references using
the right mouse button, and to define the text direction of the annotations.

Entering Sketcher without a Clear Orientation Reference

After you select a sketching plane, you can enter Sketcher mode even if no
default orientation reference exists.

●   

Exact Placement Updates

We've improved Move Special and enabled symbol placement at exact
coordinates in Pro/ENGINEER Wildfire 3.0.

●   

Excluding Datum Curves from HLR Calculations

You can exclude datum curves from hidden line removal calculations. This
helps to improve performance in large drawings.

●   

Export Drawing Tables as CSV Files

We've added a new option during Save Table operations that allows
Pro/ENGINEER drawing tables to be exported as CSV files.

●   

Flip Arrows Command for Diameter and Radius Dimensions

Diameter and Radius dimensions now each have a Flip Arrows style.

●   

Full Mechanism Dragging Capabilities in Assembly Mode

Mechanism's Drag dialog box is available in Assembly mode and allows full
body dragging capabilities.

●   

Fully Dependent Copied Features

The fully dependent and associative type of copied feature offers significant
flexibility by making the copied set of features dependent on the source in
varying degrees.

●   

Geometric Tolerance Display Options

New dtl setup options have been created to enable users to ensure geometric
tolerances can be created according to ISO and JIS standards

●   

Highlight Sketcher Entity Improvements when Explaining Constraints

Sketcher entity highlighting has been enhanced, improving awareness of a
particular constraints defined geometry and references when a user has
selected to explain a constraint.

●   

Horizontal Text for Radius Dimensions

Now radius dimensions with parallel extension lines can be shown with a
horizontal text orientation.

●   

ISO Tolerance Table Verification

We've added a check to validate automatically assigned ISO dimension
tolerance values.

●   

Improved Chain & Surface UI●   



Within feature tools, customers can define the chain of edges or set of
surfaces for the feature. Customers now have a more streamlined dialog to
define these references.

Improved Copy, Paste and Paste Special Tools

Copy and paste or paste special has been improved to include a number of
workflow improvements including the concept of a clipboard to allow a
repeated paste operation.

●   

Improved Dimensioning for Unfolded Views

The allowed attachment references for dimensioning unfolded views has
been expanded.

●   

Improved ModelCHECK Support for 3D-Drawings

New checks have been added to core ModelCHECK for Annotation Features
to help companies validate and confirm these features are not left in a state
of incompleteness.

●   

Improved Ordinate Dimensioning

You can now directly create ordinate dimensions, add dimensions to an
existing ordinate dimension, and group or redefine the attachment of
ordinate dimensions.

●   

Improved Parameter Table Interaction for Restricted Parameters

The parameters table has been enhanced to allow for auto-complete input, as
well as, name filtering for all restricted parameters specified in an external
parameter file.

●   

Improved Sketcher Performance with Large Sections

Sketcher performance has been drastically improved when dealing with
large sections of more then 40 entities and when adding additional entities.

●   

Improved Undo/Redo View Orientation in Sketcher

The undo/redo view orientation in sketcher has been improved, providing
users with more control over sketcher commands and action sequences
during an undo/redo operation.

●   

Improved Usability of the ModelCHECK Configurator

The ModelCHECK Configurator, introduced in the previous release to make
it easy to create, find, and edit ModelCHECK files to meet company
standards and best practices, has been enhanced in Pro/ENGINEER Wildfire
3.0.

●   

JIS Ordinate Baselines

Ordinate baselines have been improved to better support JIS standard.

●   

JIS Thread Display in Drawings

We've improved the display of thread features in drawings to better support

●   



JIS standards.

Light Weld Feature Enhancements

Several enhancements to the Light Weld feature improve performance and
use of light welds.

●   

Lightweight Preview for Warp Features

With the Facet Preview option, you can easily preview Warp features for
large datasets.

●   

Locked Dimensions in Sketcher

Locked dimensions in a sketch remain locked after completing the sketch in
Sketcher and throughout the design of a model.

●   

Materials Capabilities Improved

Materials capabilities have been dramatically improved with a new Materials
dialog box for defining materials and a completely overhauled library.

●   

Measure User Interface

The Measure user interface now conforms to the Pro/ENGINEER user
model.

●   

Mechanism Body Folder in Assembly Mode

View the mechanism body definition of an assembly in the new split Model
Tree within Assembly mode.

●   

Minimize Overlap of Copied Annotations

The position of annotation elements during copy/paste special, group
pattern, or UDF placement operations has been adjusted to minimize
overlap.

●   

Mirror Command Enhancements for Subassemblies

Components and assemblies can now be mirrored independently of the
assembly of origin.

●   

ModelCHECK Toolkit Provides for Custom Checks

With ModelCHECK you can now develop your own custom checks.

●   

Multiple Walls Using the Flange Tool

The Flange tool can create multiple walls when you select multiple,
nontangent edges.

●   

New Display Options for Per Unit Tolerances

We've added several new display options for flatness geometric tolerances.

●   



New Envelope Manager

The redesigned Envelope Manager is easier to use.

●   

New Sketcher Palette

With the new Sketcher palette, you can capture common shapes and sections
for reuse in future sketches without having to recreate them.

●   

New Unattached Extruded Wall User Interface

The Unattached Extruded wall feature has been consolidated with the Core
Extrude feature into a new user interface.

●   

New Unattached Flat Wall User Interface

The Unattached Flat Wall feature has a new dashboard interface.

●   

On Item Text Placement Improvements

We've added functionality to help users align text that is placed using the
''On Item'' placement type.

●   

Orientation and Projection of Fill Pattern Members

The enhancements to Fill Patterns offer the ability to project and orient fill
pattern members onto surfaces.

●   

Parameter Enhancements

With enhancements to parameters, you can quickly and easily complete such
operations as converting units of parameters.

●   

Parametric Draft Fillets and Chamfers

Improved sketching in drawings includes the ability to create draft fillets and
chamfers that are parametric to model edges.

●   

Part Simplified Representations in Drawings

In response to an overwhelming number of enhancement requests, we've
added support for part simplified reps in drawing views.

●   

Partial Shells

The Shell tool can now exclude surfaces when you hollow out a solid to
create a partial shell.

●   

Pattern Tool Enhancements

The Pattern tool offers significant enhancements, including the preview of

●   



patterns, roll back of features, and many other additions.

Placement of User-Defined Features

The User-Defined Feature (UFD) tool streamlines workflow, offering
increased flexibility and capabilities for placement of UFDs in a modern
user interface.

●   

RMB Actions for Moving and Rotating Annotations

Users can now easily move and rotate the text direction of annotation after
selecting the annotation element from the model tree.

●   

Real-Time Collision Detection in Assembly Mode

Real-time collision detection is now available in Assembly mode using
dragging operations.

●   

Reduced File Size of Merged Drawings

An internal process reduces the size of the final drawing when two drawings
are merged.

●   

Rendering Scene File

Rendering Scene files have been added to Wildfire 3.0 allowing users to
save the render room, lighting and environment settings to a single file.

●   

Restricted Parameter Names and Values

By specifying an external file, you can define restricted parameter names
and values. When adding these parameters using the Parameters Dialog, you
are required to select from a list of values or to define a value within a
specified range.

●   

Separate Layer Dialog

Customers can now set a config.pro option to allow a floating layer dialog.
This has been reintroduced back into Pro/ENGINEER Wildfire 3.0 as one of
the top enhancement requests.

●   

Set Datum Attachment to Gtols

Enable attachment of set datum tags to geometric tolerances in models and
drawings.

●   

Set Up of Sketching Planes and Orientation References in Sketcher

With the improved creation and modification workflow for Sketcher, you
can directly modify the setup of a sketch and orientation references.

●   

Shaded Views in Drawings

You can now include shaded views of models in drawings. This capability
improves plotting drawings with OLE objects and shaded views.

●   



Sheetmetal Reports

The Sheetmetal Info reports are consolidated within the Model Info report.

●   

Show Frozen Components in Assembly Model Tree

This enhancement will change the model tree icon so that a user can quickly
inspect the model tree to determine what components are currently frozen

●   

Simultaneous Retrieval of Components and Graphics

Pro/ENGINEER now displays the graphics of each component in the
graphics window during retrieval of the assembly.

●   

Sketched Text Positions

Sketcher has been enhanced for control of the vertical and horizontal
justification of sketched text.

●   

Slot Connections in Assembly Mode

Mechanism slot connections can now be defined as an Assembly connection.

●   

Specifying Joint Axis Limits during Component Placement

You can now set joint axis settings when you are defining component
placement, making it easier and simpler to limit the motion of components
within Assembly mode.

●   

Streamlined Board Import and Export

Side menus for the import and export of ECAD data have been consolidated
into a single dialog box.

●   

Streamlined Creation of ECAD Areas

An ECAD Area dialog box for the creation of ECAD areas consolidates the
previous side menus.

●   

Support for Flexible Components in Kinematic Assemblies

Pro/ENGINEER Assemblies with packaged components can now be
kinematically dragged in real time with flexible components, such as springs
and pipes, that fully constrain the assembly.

●   

Support of OpenType Fonts

With Universal Font Scaling Technology 4.7, you can use and place
OpenType Fonts for multi-language support in all areas, including Sketcher

●   



and drawings.

Swept Blend Dashboard

The new Swept Blend tool uses a smooth-flow workflow with a dashboard
user interface.

●   

Undo and Redo Support for Assembly Operations

Undo and Redo are now available in Assembly mode for all of the general
assembly operations and commands.

●   

Updated Default Setting for Importing Holes

The default value for the configuration option
ecad_import_holes_as_features has been changed from NO to YES.

●   

Updates to Surface Finish Annotations

Now it is possible to collect surface finish reference surfaces separately from
the symbol attachment reference in 3D. We've also enabled advanced
selection for surface finish annotation elements in annotation features.

●   

View Manager States for Drawing Views

You can reuse all states created in 3D models to help configure drawing
views.

●   



Product What's New

3D Quick Print
Quickly create drawing layouts and plot directly from the 3D environment.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location File > Quick Print

Benefits and Description

We've added a new option to the File menu to enable users to quickly create plots
of 3D models directly from the 3D modeling environment. There are several view
layout options and 2 new config.pro options to help you create just the plot you
need.

View Layouts

Set up a projection layout using our pre-defined projection view layout
options

●   

Set up your own user defined layout●   

Use an existing drawing template file to define the views, format, tables, etc
for your 3D model

●   

Config.pro options

quick_print_drawing_template - sets the path to the default drawing template
file

●   

quick_print_plotter_config_file - sets the path to your preferred plot config
file

●   

This is great functionality to get a quick check plot, or to generate a pre-defined
drawing.



Product What's New

3D Section Display in Drawings
In Pro/ENGINEER Wildfire 3.0, drawing views can display 3D sections (zones)
from models.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Select drawing view > RMB > Properties > Sections

Benefits and Description

We've added support in drawings to display 3D cross sections in drawing views.
To use this functionality, create a 3D section using the View Manager in the
model. Then activate the 3D section in the drawing view properties. By default, the
cross hatching for the section is turned off, but can be easily turned on by checking
the "Show X-Hatching" option. This allows even better re-use of 3D functionality
in drawings. Shaded cannot be used with 2D cross sections, but 3D section views
can be shaded (hatching is not displayed in 3D section views regardless of the
"Show X-Hatching" status).



Product What's New

3D Set Datum Tags on Surfaces
We've implemented a new option for displaying set datums in 3D. Users can now
place ASME Y14.41 style set datum tags on surfaces.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location Datum > Properties OR Insert > Model Datum >
Annotation

Benefits and Description

There is a new option in Pro/ENGINEER Wildfire 3.0 that enables users to create
ASME Y14.41 set datum tags. This style of tag can be placed upon planar and
cylindrical surfaces, circular edges and curves, and the datum itself. ASME Y14.41
style set datum tags can be accessed by editing the properties of an existing datum
OR they can be included in Annotation Features as a new Annotation Element
type.

We've also added the ability to create a new set datum through a surface or at the
center of a cylindrical surface, edge, or curve automatically from Annotation
Features. To do this, the user creates a new, set datum tag annotation
element, enters a name for the datum, selects the geometry reference, and places
the tag annotation. A new datum is created which is embedded in the annotation
feature.

This functionality will enable users to continue their migration towards
"drawingless" models by supporting more detail types in 3D models. Set
Datum Tag annotations support the ASME Y14.41 standard. 



Product What's New

Activate Layer
Now you can set a layer to be active and all layer-able entities created from that
point forward will automatically be added to that layer.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Layer Tree > Select Layer > RMB > Activate

Benefits and Description

Many of our users use layers in drawings to manage their display as well as to
facilitate drawing creation and modification. We've created a better, faster way to
add items to layers. Simply select the layer in the layer tree, RMB > Activate.
From that point forward, all newly created items will automatically be added to
that layer. Activating a different layer will de-activate any currently active layer
enabling detailers to quickly switch to a different layer.



Product What's New

Additional Language Support for
Pro/ENGINEER on Linux
Responding to the growing demand from global Linux users, Pro/ENGINEER
Wildfire 3.0 offers additional language support.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location N/A

Benefits and Description

Pro/ENGINEER Wildfire 3.0 on Linux now extends language support beyond
English and German in the following locales:

French●   

Italian●   

Spanish●   

PTC is excited about the extended language support in response to
customer requests.



Product What's New

Align Angular Dimensions
Angular and linear dimensions can now be aligned at the same time.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Select Dimensions > RMB > Align Dimensions

Benefits and Description

Now you can align angular and linear dimensions at the same time. When aligning
mixed dimension types, dimensions are aligned based upon the selection order; all
selected dimensions are aligned to the first dimension. This will allow users to
reduce the number of steps required to adjust dimensions in drawings resulting if
faster drawing creation or modification.



Product What's New

Annotation Feature and UDF Interaction
Users can now add annotation features to UDFs. Users can choose to vary surface
finish values, geometric tolerance values, or driven dimension tolerances.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Insert / User-defined Feature

Benefits and Description

By allowing annotation features to be added to UDFs, users can now add
supplemental information to their standard features and parts. Users can embed
dimensioning schemes, geometric tolerances, surfaces finishes, and other
annotation directly into the UDF to ensure that when placed the correct
information is added. Additionally, by adding the information to the UDF, users do
not need to document the features already created. This added information can be
shown on the drawing easily without many extra steps.



Product What's New

Annotation Features in UDFs
You can select Annotation features for inclusion in user-defined features.
Annotation features and Annotation Element parameters and some annotation
values can also be marked as variable items in the feature definitions.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Click Tools > UDF Library.

Benefits and Description

With Annotation features in UFDs, you can capture critical detailing, design, and
manufacturing information in standard feature libraries. A reused feature contains
all of its defined information. Reusing data stored in a UFD ensures accurate,
up-to-date information for deliverables from models and manufacturing processes
to detailed drawings.

In addition, you can define some values in Annotation Elements to be variable: the
surface finish roughness_height value, the geometric tolerance primary value, and
the driven dimension tolerance values.



Product What's New

Attach Geometric Tolerances to Leader
Elbows
New placement options for geometric tolerance attachment have been added to
support ISO and JIS standards.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Insert > Geometric Tolerance > Placement Options >
Note or Dimension Elbow

Benefits and Description

Two, new placement options have been introduced in Pro/ENGINEER Wildfire
3.0 to allow users to attach geometric tolerances to leader elbows. These
options will allow users to attach geometric tolerances to diameter, radius, and
chamfer dimensions that are shown with leaders as well as leadered notes.
Drawings that more correctly conform to ISO and JIS standards can be created
using these placement options.



Product What's New

Autodetection of a Windows Locale
Pro/ENGINEER and PTC.Setup have been enhanced to detect the system default
locale on Windows and attempt to run Pro/ENGINEER in that locale.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location NA

Benefits and Description

To make it easier to run Pro/ENGINEER in different locales on Windows, you no
longer must define the environment variable %LANG% to the appropriate
locale. By default, Pro/ENGINEER detects the existing locale and attempts to run
using it. The locale must be a known locale and the appropriate language files must
be installed. If these conditions are not met, Pro/ENGINEER starts in English. The
use of %LANG% will be retained and will override the autodetection of locale if
set.



Product What's New

Automatic Annotation Display in
Drawings
Maximize the value of detailing your 3D models. When you create a drawing view
of a model with 3D annotations, they are automatically shown when appropriate.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Tools > Options

Benefits and Description

A new config.pro option has been introduced in Pro/ENGINEER Wildfire 3.0 to
help you get maximum benefit from detailing your 3D models. When you create a
drawing view of a model that has 3D detailing items that use an annotation plane,
those annotations are automatically shown if the orientation and viewing direction
in the drawing view matches the annotation plane.

In Pro/ENGINEER Wildfire 2.0, detailers needed to enter the Show & Erase dialog
and activate all annotation types to show 3D annotations. Then select to keep only
those annotations that were appropriate for the view. In Wildfire 3.0, this work is
done automatically using the config.pro option "auto_show_3D_detail_items". By
default, this option is set to yes.



Product What's New

Automatic Clipped Dimensions
We've added a new way to create clipped dimensions in Pro/ENGINEER Wildfire
3.0 and improved the ability to create small, acute, angular dimensions.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Insert > Dimension

Benefits and Description

Users can now more easily create clipped dimensions in Pro/E drawings. To create
a clipped dimension, a user simply selects the edge to be dimensioned, then selects
the center object (line, axis, etc), then selects the first edge again and places the
dimenson. This creates a clipped dimension according to the settings defined in the
drawing that calls out twice the measured value between the first entity and the
centerline. This functionality is available during the creation of linear and angular
clipped dimensions.

We've also added a minimum selection area for small, acute, angular dimensions.
Previously when a detailer wanted to create a small angular dimension, s/he needed
to zoom in far enough to enable placement of the dimension inside the actual
angle. For very small angles, this was difficult. We've added a selection buffer
zone of 15 degrees to make creating angular dimensions easier.

Automatic clipped dimensioning helps to reduce the amount of time it takes
to dimension partial and half drawing views where only one of the references
required for the dimension and the centerline is available.



Product What's New

Chamfer Dimension Witness Lines
Now when shown chamfer dimensions are repositioned, a witness line will
automatically be created.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Select Chamfer Dimension > Move

Benefits and Description

In previous releases of Pro/ENGINEER, when a chamfer dimension was shown
and re-positioned, its movement was similar to a leadered note. In Pro/ENGINEER
Wildfire 3.0, when a chamfer dimension is moved, it maintains its normal
attachment and a witness line is created if the dimension is moved beyond the edge
it is attached to. This allows users to reposition chamfer dimensions in accordance
with ISO and JIS standards.



Product What's New

Component Interface Definition
Enhancements
Component Interfaces are now easier to define, easier to place in an assembly, and
viewable in the Model Tree.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Click Insert > Model Datum > Component Interface.

Benefits and Description

You can quickly set up multiple placement interfaces for components and
assemblies using the Interface Definition dialog box. Nested interfaces can define
super sets of interface definitions from existing component interfaces. Simple
geometry placement constraints and advanced search rules further speed the
process of defining components for an assembly.

For mechanism connections, such as pins and sliders, you can create and store
them as a component interface. In an interface, you can define the fit, form, and
function of a moving component. The interface eliminates the need to convert
placement constraints to mechanism connections after you place the part in the
assembly. 

The Model Tree displays the component interfaces in individual components as
well as in assemblies and subassemblies. To assist in the assembly of parts, you
can create placement notes in the graphics window.



Product What's New

Component Placement Dashboard
The Component Placement dashboard, drag handles, and feedback in the graphics
window provide a faster, easier method to assemble components in
Pro/ENGINEER assemblies.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Click Insert > Component > Assemble.

Benefits and Description

With the Component Placement dashboard, you can quickly place components in
Assembly mode using standard geometric constraints, component interfaces from
the part, and component interfaces in the assembly. All placement constraints for
both components and assemblies appear in the Model Tree. You can query the
model to understand how a part was assembled without having to completely edit
the component's location. In addition, Mechanism connections are available at the
beginning of component placement without having to convert assembly
constraints.

During component placement in Assembly mode, you can perform the following
operations:

Specify the joint axis motion limits of components placed with mechanism
constraints directly.

●   

Use shortcut menus for default and fixed constraints.●   

Use drag handles to position parts with offset constraints.●   

Snap offset constraints to coincident or offset with shortcut menu
commands.

●   

Move components into exact positions.●   

Access dragging operations from mechanism to move the component in the
remaining degrees of freedom.

●   



Product What's New

Component Replace Enhancements
All methods of replacing components in an assembly have been enhanced and
combined into a single, easy-to-use dialog box.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Click Edit > Replace.

Benefits and Description

The Replace dialog box makes replacing components easier. Family Tables and
Pro/PROGRAM are both fully supported. With the New Copy option, you can
create Shrinkwrap, Inheritance, Merge, or Instance models on the fly. You no
longer need to create the component before you begin the replacement operation.



Product What's New

Consolidated Cut and the Both Sides
Option
The sheetmetal cut is consolidated with the solid Cut.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Sheetmetal Design and Manufacturing
User Interface Location Click Insert > Extrude.

Benefits and Description

The sheetmetal CUT command is consolidated with the solid Cut command to
produce a unique feature with numerous possibilities.

In addition to the Sheetmetal options of  Normal to Green Side and Normal to
White Side, the new option Normal to Both Sides creates the cut that will allow the
proper assemly with no interference of a component placed at an angle.

Multimedia

Images

Sheetmetal Cut

Videos

Creating a CUT with Sheetmetal

http://www.ptc.com/WCMS/files/26573en_vid_vid_step_1.avi


Product What's New

Copy and Paste in Assembly
The Windows style copy and paste is now available in Assembly mode.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly

User Interface Location Click Edit > Copy, Edit > Paste, and Edit > Paste
Special. Shortcut keys are CTRL+C and CTRL+V.

Benefits and Description

You can quickly and easily move, translate, and rotate components to other areas
of the assembly using the familiar Copy (CTRL+C), Paste (CTRL+V) and Paste
Special commands. During the operation, multiple transformations are possible.
You can now edit the moved components, so you can redefine the transformation
without recreating the moved components from scratch. While using the Paste
Special command, you can use the Component Placement dashboard and see an
immediate preview of the features being moved.



Product What's New

Create Snap Lines Offset 2D Entities
Snap lines can now reference 2D draft entities in drawings.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Insert > Snap Line > Offset Object

Benefits and Description

Now you can create snap lines that are offset draft entities in drawings. Created
and shown annotations will snap and maintain associativity to these snap lines.
This provides the ability to create a snap line based upon a user sketched line to
help maintain the position of draft and model annotations.



Product What's New

Cross Section Analysis
The Section Analysis tool has an option to automatically span the selection set with
cross sections at a defined spacing for analysis.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas

User Interface Location Click Analysis > Geometry > Sections. On the
Definition tab, click the Cross option.

Benefits and Description

With the enhancements to the Section analysis tool, you no longer need to define
the number, spacing, and start location for cross sections to begin an analysis.



Product What's New

Curved Patterns
The Curve option on the Pattern dashboard allows you to create instances of a
feature along a sketched curve.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location

Select the feature or group to be patterned. Click the
Pattern tool on the right toolbar or click Edit > Pattern.
Select the Curve option from Pattern Type list on the
Pattern dashboard.

Benefits and Description

The main benefits of the Curve option for patterns are as follows:

Causes the patterned feature or group to follow the shape of the curve●   

Provides control of the spacing or the number of members ●   

Offers the ability to specify the start point and direction of the curve●   



Product What's New

Cut, Copy, and Paste in Sketcher
Sketcher now uses the Microsoft cut, copy, and paste operations for consistency
with Pro/ENGINEER.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas

User Interface Location

For Cut, use CTRL+X, Edit > Cut, or right-click and
choose Cut. For Copy, use CTR+C, Edit > Copy, or
right-click and choose Copy. For Paste, use CTRL+V,
Edit > Paste, or right-click and choose Paste.

Benefits and Description

Right-click a specific entity in a sketch, and you can cut or copy it. Supported
objects include sketched geometry, construction geometry, strong dimensions, and
constraints. Only strong dimensions and constraints involving the selected
sketched and construction geometry can be cut or copied. 

The Sketcher clipboard saves the cut or copied information for a paste
operation. Additionally, you can use the entities from the clipboard in a new
sketch. With a paste operation, you can place a entity wherever you like and define
its scale and rotation.



Product What's New

Data Sharing Dashboard
The Data Sharing dashboard modernizes the user interface and consolidates the
Merge, Cutout, and Inheritance features.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location Click Insert > Shared Data. Choose the type of shared
data from the menu.

Benefits and Description

Enhancements to Data Sharing features and their conversion to a dashboard offer
many benefits:

Consolidates Data Sharing features, such as Merge, Cutout, and Inheritance●   

Allows changing of multiple feature types at any point●   

Offers a user-friendly user interface with easy access to commands●   

Supports object-action workflow for increased productivity●   



Product What's New

Defining the text direction for
annotations
When placing annotations, users are presented with the default text direction. This
can be changed using default angle selections or by entering an angle.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location N/A

Benefits and Description

Users now have full control over the text direction of placed annotations. Users can
choose to place the annotations using one of the four default angles provided, or
users can enter an arbitrary angle to define the text direction



Product What's New

Dependant Copy Enhancements for
Annotation Features
When creating dependant copies of annotation features, the annotations included
will also be dependant. Dependant behavior of annotations is limited to text input,
text style, color, and parameters.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Edit / Copy / Paste Special

Benefits and Description

When copying annotation features along with other features, users can now be sure
that any changes to the text, style, color or parameters of the parent annotation will
be passed to downstream annotations.

Parameters or colors that are used to classify annotation elements can be modified
to indicate a new characteristic and this change will be passed to all downstream
annotation elements.



Product What's New

Dependent 3D Cross Section Views
By default, when a new view is created that is dependent upon a view using a 3D
section, the dependent view's section will be linked to its parent's section setting.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Drawing View > Properties > Sections > 3D cross
section

Benefits and Description

In Pro/ENGINEER Wildfire 3.0, users can create drawing views that show a 3D
cross section as defined in the model. If a dependent view is created from a view
using a 3D section, the dependent view's cross section setting will automatically be
driven by the parent view. If the parent view's 3D section is changed, all of its
dependent views will update to the new section as well.



Product What's New

Detailing 'On-Item' Note Position
Enhancements
Detailing has been enhanced enabling users to control the vertical and horizontal
justification of On-Entity notes.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Format / Text Style Gallery / New

Benefits and Description

Enhancements in detail drawing mode of Pro/ENGINEER Wildfire 3.0 enable
users to control the justification for 'On-Item' notes placed in a drawing.  Users are
able to create custom text styles and define both the vertical and horizontal
justification for the style.  The vertical justification of the text style can be
constrained to; Top, Middle, Bottom, Bottom of Origin or As Is, while the
horizontal justification of the text style can be constrained to; Left, Center, Right,
Default or As Is.  For 'On-Item' notes, the defined text styles justification (both
vertical and horizontal) will be interpreted and utilized when the note is placed on
the drawing.  Users will be able to highlight and edit the notes properties,
modifying either the horizontal or vertical justification.  The resulting change will
update the note around the on-item reference point.  The resulting note boundary
box will be tight against the text string, providing addition control on its exact
position in the drawing.  Like all 2D notes, users will also be able to create a multi
line note, which will also exhibit the defined justification.     

Additionally, users will be able to allow font kerning in the text style allowing
Pro/ENGINEER to interpret the kerning values incorporated into the font
characters.  This is controlled by a new option check box in the text style dialog or
note properties dialog. 



Product What's New

Difference Report support of 3D
Drawings
The Pro/ENGINEER Wildfire 3.0 difference report now includes the ability to
analyze and determine the difference between two versions of the same part for
Annotation Features, their Annotation Elements and Annotations.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location Analysis / Part Compare / By Feature

Benefits and Description

In the Wildfire series of Pro/NGINEER, the difference report takes advantage of
the embedded browser.  Users can compare the features of two parts or two
versions of the same part.  For example, if you have two part files that contain the
same basic part with the same basic features, but the dimensions of the features
differ, you can use part comparison to analyze the difference in size between the
two parts.  A list of features that have been modified, along with any features that
exist in only one of the part files, is displayed in the difference report.
Pro/ENGINEER also displays an overlay of the second part on the first part and
highlights the feature being compared.

In Pro/ENGINEER Wildfire 3.0, the difference report includes the capability to
report Annotation Features, Annotation Elements and Annotations differences. 
The type of information that will be reported for these items will be:

The difference report will be able to show the differences between
Annotation Features in two versions in the following manner.

Annotation Feature Name❍   

Number of the Annotation Elements in the Annotation Feature❍   

●   

The difference report will be able to show the differences between
Annotation Elements in two versions in the following manner.

 Annotation Element Type❍   

Annotation Element Name/Annotation Name❍   

Annotation Element Dependent/Independent Option❍   

●   



Annotation Element References

Number of Annotation Element References■   

 ID of Annotation Element References■   

Type of Annotation Element References (Weak or Strong)■   

❍   

Annotation Element Parameters

Number of Annotation Element Parameters■   

Name of Annotation Element Parameters■   

Value of Annotation Element Parameters■   

❍   

If the Annotation Element is incomplete❍   

The difference report will be able to show the differences between
Annotations in two versions in the following manner.

Display Status of the Annotation❍   

If the Annotation is Active or Inactive❍   

Annotation Plane Reference❍   

Note Properties

Text Field Value of a Note■   

URL Value of a Note■   

Attachment Reference■   

❍   

Symbol Properties

If the Symbol has changed■   

Attachment Reference■   

❍   

Geometric Tolerance Properties

Sub-Type■   

Tolerance Value■   

Attachment Reference■   

Text Note Value■   

❍   

Surface Finish Properties

Surface Finish Value■   

Attachment Reference■   

❍   

Driven Dimension and Tolerance

References■   

Tolerance Value■   

❍   

●   



Product What's New

Direct Manipulation of Lights
The way that users interact with lights has been completely overhauled within
Pro/ENGINEER Wildfire 3.0

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Rendering
User Interface Location View->Model Setup->Lights (Shortcut icon available)

Benefits and Description

The way that users interact with lights has been completely overhauled within
Pro/ENGINEER Wildfire 3.0.  The new lighting model allows users to
interactively adjust the lights and their associated parameters directly on screen
resulting in an unprecedented level of usability.  Whether adjusting your lights for
modeling operations or setting up a rendered image lighting has never been so fast
and easy.



Product What's New

Draft Analysis and Color Display
Draft Analysis enhancements to color display provide three-colors with control
over the transition between color regions.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location Click Analysis > Geometry > Draft.

Benefits and Description

The three-color display option for draft analysis provides control over the
transition between these distinct color regions. The three regions identify areas
inside or outside of the draft requirement (in both directions). You can set up the
transition zone to display discrete increments very close to the draft requirement.



Product What's New

Drawing Template Improvements
Drawing templates now support 3D sections and combination states, and they
provide better scaling options.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Click Applications >Template.

Benefits and Description

Now you can create a single drawing template for use for models of all sizes. 
Improvements to drawing templates include:

Support for 3D cross sections (zones)●   

Support for shaded views●   

Use of 3D View Manager "All" states to configure template views●   

Option to drag the view boundary during placement to define the space used
on the paper

●   

You can drag the view boundary during placement to define the space on the
drawing sheet the view should occupy.  When the template is used, the model is
automatically scaled to fit inside the space defined by the template view boundary.



Product What's New

Enhancements to Asynchronous Datum
Creation
Datums created during other feature creation tools will be embedded into the
feature. Users can embed datum axis, datum points, datum planes, and datum
coordinate systems.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location N/A

Benefits and Description

Embedding the construction datums created while inside another features allows
for a number of benefits. Firstly, users will not have a group automatically created
that holds both the datums and the feature. Users can also directly select the feature
from the graphics screen and upon edit, see all the dimensions used to create the
feature including the dimensions of the datum features embedded. Additionally,
when showing the dimensions of the feature in drawing mode, all the dimensions
appear after selecting the parent feature.

Users will also be able to drag the datums outside of the feature and re-use these as
references for other features. If users keep the datum embedded, when deleting the
parent feature, users will be prompted to keep the planes using a checkbox within
the confirmation window. This will allow for the retention of the construction
planes while still deleting the parent feature. Another benefit is that during pattern
operations, an identical pattern can be used to ensure quick regeneration rather than
defaulting to a group pattern mechanism.



Product What's New

Enhancements to the Annotation
Feature User Interface
Enhancements to the annotation feature interface include having the ability to enter
descriptions for the references selected, to replace references using the right mouse
button, and to define the text direction of the annotations.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Insert / Model Datum / Annotation

Benefits and Description

In many instances, it is desired to place annotations in an alternate orientation that
the default text direction defined by the annotation plane. Users can now
completely define the orientation of text direction when placing annotations.
Annotations that are already placed can easily be rotated by using right mouse
button commands to rotate the text. A graphical arrow will appear allowing the
user to quickly understand that current text direction.

Users can clearly document the purpose of the references using an input field that
hold the description of references. By default, Pro/ENGINEER will populate this
field with information indicating the purpose of the reference, but this information
can be modified by simply entering alternate text in the field.

Users can also quickly replace any reference by selecting the reference and using
the right mouse button to replace the reference. In the past, users were forced to
place the annotation again to change only one reference. Now this change is as
easy as selecting one reference and replacing it with another reference of the same
type.



Product What's New

Entering Sketcher without a Clear
Orientation Reference
After you select a sketching plane, you can enter Sketcher mode even if no default
orientation reference exists.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location N/A

Benefits and Description

If the orientation reference is not obvious for the sketching plane, you can accept
an automatically generated default orientation and enter Sketcher. The References
dialog box opens, and you are prompted to select dimensioning references.



Product What's New

Exact Placement Updates
We've improved Move Special and enabled symbol placement at exact coordinates
in Pro/ENGINEER Wildfire 3.0.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Edit > Move Special OR Insert > Drawing Symbol >
Custom > Placement Type

Benefits and Description

We've added a new button to the Move Special dialog to enable easier access to
relative coordinates. We've also integrated functionality previously available in
Pro/ENGINEER 2001 into our symbol placement dialog. Now you have the ability
to place drawing symbols at absolute drawing coordinates and at the vertex of a
selected object.



Product What's New

Excluding Datum Curves from HLR
Calculations
You can exclude datum curves from hidden line removal calculations. This helps
to improve performance in large drawings.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Set hlr_for_datum_curves to No.

Benefits and Description

This Drawing Setup File option improves performance in drawings with many
datum curves.



Product What's New

Export Drawing Tables as CSV Files
We've added a new option during Save Table operations that allows
Pro/ENGINEER drawing tables to be exported as CSV files.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Table > Save Table > As CSV File

Benefits and Description

Many of our customers use Microsoft Excel or other spreadsheet programs along
with Pro/ENGINEER as part of their normal processes. To enable better
information re-use, we've added a new "Save As" option that's compatible with
most spreadsheet programs. Pro/ENGINEER drawing tables can now be stored as
CSV files.



Product What's New

Flip Arrows Command for Diameter and
Radius Dimensions
Diameter and Radius dimensions now each have a Flip Arrows style.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Right-click the dimension and choose Flip Arrows
from the shortcut menu.

Benefits and Description

With the Flip Arrows command, you can create drawings with dimensions that
more closely support industry standards. The styles are as follows:

Diameter dimensions with arrows on the outside and a connecting line
through the dimensioned item

●   

Radius dimensions with an arrow on the outside and a line extending to the
center of the arc.

●   



Product What's New

Full Mechanism Dragging Capabilities in
Assembly Mode
Mechanism's Drag dialog box is available in Assembly mode and allows full body
dragging capabilities.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Select the Drag icon from the Assembly toolbar.

Benefits and Description

Within Assembly mode, you can perform the all body dragging operations
formerly only available from Mechanism, such as: 

Save snapshots of assemblies in different positions and orientations and
make them available in Pro/ENGINEER drawings as exploded views.

●   

Create temporary constraints to explore motion of an assembly or even just
one or more sections of an entire kinematic assembly.

●   

Highlight the dragging point, and the assembly moves with respect to this
point. 

●   

Move an entire body keeping its orientation constant with respect to the
assembly's coordinate system.

●   



Product What's New

Fully Dependent Copied Features
The fully dependent and associative type of copied feature offers significant
flexibility by making the copied set of features dependent on the source in varying
degrees.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location
Select the feature or group to be copied. On the
top-level toolbar, click Copy and then click Paste
Special.

Benefits and Description

Highlights of the benefits of this new copying function follow:

Ensures that the copied set starts as a fully dependent set of features driven
by source reference set

●   

Introduces a wide range of variations to a select set of elements in the copied
set while maintaining an associative update from the source set

●   

Offers variations to selected dimensions, sketches, references,
parameters, and annotations through a variational table user interface

●   

Provides for a smart reference resolution during placement (requires
selection of missing references only)

●   

Gives an extended flexibility, such as Move/Rotate transformation during
copying

●   

Illustrates clearly the copied features dependency in the Model Tree with a
â€œCopiedâ€• label

●   



Product What's New

Geometric Tolerance Display Options
New dtl setup options have been created to enable users to ensure geometric
tolerances can be created according to ISO and JIS standards

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location File > Properties > Drawing Options

Benefits and Description

A new dtl setup option "stacked_gtol_align" allows users to create geometric
tolerance stacks that comform to JIS standard. This option aligns the ends of the
control frame.

Another new dtl setup option "gtol_symbols_same_size" ensures that the symbol
box portion of the geometric tolerance control frame is the same size regardless of
the symbol displayed.

These new options enable users to create drawings that more accurately conform to
industry standards.



Product What's New

Highlight Sketcher Entity Improvements
when Explaining Constraints
Sketcher entity highlighting has been enhanced, improving awareness of a
particular constraints defined geometry and references when a user has selected to
explain a constraint.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location Select constraint - RMB / Explain

Benefits and Description

Currently, in sketcher, users are unable to easily interrogate a constraint to
understand what geometry or references are being used in that specific constraint.
Performing an explain operation displays all geometry and references of a
constraint in red.  Since red is the default color for selection, it makes it very
difficult for a user to distinguish the entities.  With this enhancement users will be
provided with better visual cues as to the geometry or references used to create the
specific constraints.

Selecting a single constraint (i.e. vertical, horizontal) and performing an explain
operation the entities will be displayed in purple.  Selecting a group constraint,
such as parallel, equal segments, equal radii constraints and performing an explain
operation will also display the entities in purple.  However, when a constraint
refers to two entities playing different roles in the constraint, they will be displayed
as green and purple depending on their priority in the constraint.



Product What's New

Horizontal Text for Radius Dimensions
Now radius dimensions with parallel extension lines can be shown with a
horizontal text orientation.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Select one or more radius dimension, and click Edit >
Properties.

Benefits and Description

You can modify the properties of radius dimensions to display text horizontally in
drawings to meet some industry standards.



Product What's New

ISO Tolerance Table Verification
We've added a check to validate automatically assigned ISO dimension tolerance
values.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location Tools > Options AND Info > Session Info > Message
Log

Benefits and Description

For modelers who use our built-in, automatic ISO tolerance value assignment
functionality, we've added a check to help validate the assigned tolerances. The
ISO standard has some large dimensional values for which a tolerance value has
not been approved. For modelers who use large dimensions, Pro/ENGINEER
assigns the largest, approved ISO tolerance value from the assigned table to the
dimension. To help modelers and detailers verify these tolerance values, we've
added a check (controlled by config.pro option "warn_if_iso_tol_missing" - default
is no) to confirm that there is a value in the tolerance table for the dimension of the
model. When there is no approved value, a message is written into the message log
during regeneration to help identify dimensions without an approved tolerance
value in the ISO table file. Modelers and detailers can access the message log to
identify any dimensions that may need to have their tolerance values reviewed.

Modelers and detailers will also be warned when they select an ISO tolerance table
to be applied to a dimension if an approved value is not present in the stored ISO
tolerance table file.

Users can access the message log using Info > Session Info > Message Log 



Product What's New

Improved Chain & Surface UI
Within feature tools, customers can define the chain of edges or set of surfaces for
the feature. Customers now have a more streamlined dialog to define these
references.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Fundamentals & Pro/PROGRAM
User Interface Location References Slide Panel / Details

Benefits and Description

Inside the sets panel, there are separate collectors for appended items and excluded
items which provide a clearer representation of the set.

When defining surface sets, users can now quickly define loop surfaces as the
boundary surfaces for surfaces created from a seed to boundaries. Additionally,
users have the ability to see a preview of the surface set constructed and have the
option to turn off the preview so that Pro/ENGINEER is not re-shading the
geometry after every selection.



Product What's New

Improved Copy, Paste and Paste Special
Tools
Copy and paste or paste special has been improved to include a number of
workflow improvements including the concept of a clipboard to allow a repeated
paste operation.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Edit / Copy / Paste

Benefits and Description

Users can now execute copy and paste or paste special commands quickly by
simply picking the paste button or Ctrl â€“ V command repeatedly. The
introduction of a clipboard frees users from having to recopy features or geometry
before every paste operation.

Other workflows have been improved such as when canceling a paste operation
while defining a feature the user will be presented with an options dialog in the
majority of cases. This provides the user with flexibility to keep those features that
have already been pasted or remove the entire operation. Additionally, when using
the paste operation, Pro/ENGINEER will copy all the setting from the original
feature and use them for the default in the new feature.



Product What's New

Improved Dimensioning for Unfolded
Views
The allowed attachment references for dimensioning unfolded views has been
expanded.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Click Insert > Dimension.

Benefits and Description

The expanded the references that can be selected for linear dimensions now
include additional silhouette edges. With these additional references, you
can better create fully dimensioned, unfolded views.



Product What's New

Improved ModelCHECK Support for
3D-Drawings
New checks have been added to core ModelCHECK for Annotation Features to
help companies validate and confirm these features are not left in a state of
incompleteness.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area ModelCHECK
User Interface Location NA

Benefits and Description

In Pro/ENGINEER Wildfire 2.0, PTC introduced new functionality called
3D-Drawings. Utilizing intelligent Annotation Features (AF), users are able to
capture drawing specific information directly on the 3D model following ASME
Y14.41 standards.  Like any other feature, AF can potentially exist in various states
of incompleteness. Some examples of this are as follows

Annotation Element (AE) or AE Annotation References can be left
undefined during a User Defined Feature (UDF) placement. The UDF can be
placed without these selections. When this happens, the entire Annotation
Feature contained in the UDF is incomplete.

●   

AEs can have references to geometry (either automatic from AE annotations
or user defined). If a reference is no longer visible to the AE and an alternate
reference cannot be found, the AE has a missing reference and could become
incomplete.

●   

Surface Finish and GTOL AEs can be considered a duplicate if they have the
exact same references, parameters and AE Annotation definition as another
AE.

●   

AE Annotations will not be displayed if they are inactive.  For an AE
Annotation to be inactive all of the attachment references for that AE
Annotation are mission.   If 1 or more of the attachment references are still
available, the AE annotation will still be active and be displayed.

●   

AE and AE Annotations can have undefined references.●   

While AF have these capabilities, it is undesirable to release the model while in



this state.  ModelCHECK has been enhanced with new checks to find these issues
described above.  Furthermore, ModelCHECK will have the ability to aid in the
completion and activation of these entities.

The new checks included into ModelCHECK for AF are:

AE_GTOL_DUPLICATE - Finds duplicate GTOL Annotation Elements●   

AE_SF_DUPLICATE - Finds duplicate Surface Finish Annotation Elements●   

AF_INCOMPLETE - Finds incomplete Annotattion Features●   

ANNTN_INACTIVE - Finds inactive Annotattion Elements●   



Product What's New

Improved Ordinate Dimensioning
You can now directly create ordinate dimensions, add dimensions to an existing
ordinate dimension, and group or redefine the attachment of ordinate dimensions.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Click Insert > Dimension > Ordinate.

Benefits and Description

With the direct creation of ordinate dimensons, you no longer must create linear
dimensions that share a common reference and toggle them to ordinate. Faster
dimensioning in drawings is the result. You have two creation methods to choose
from:

 Select the baseline, select the items to be dimensioned, then place all of the
dimensions at once.

●   

 Select the baseline, select an attachment point, then place the dimension,
select another attachment point, place the dimension and so on.

●   

In addition, you can add a new dimension to an existing ordinate dimension group
by inserting the new dimension and referencing any dimension already in an
ordinate dimension group. If an existing ordinate dimension is no longer valid in a
modified drawing, you can now edit its attachment instead of re-creating
it. Ordinate dimension groups can also be deleted by selecting only the baseline
and deleting it.

To directly create ordinate dimensions use Insert > Dimension > Ordinate.●   

To add an ordinate dimension to an existing ordinate dimension group use
Insert > Dimension > Ordinate and select an existing dimension (or the
baseline) when prompted for a baseline.

●   

To edit the attachment of an ordinate dimension, select the dimension's
witness line, right-click, and select Edit Attachment (or use the Edit
Attachment option in the dimension's properties.

●   

To delete an entire ordinate dimension group, select all the dimensions in the
group, right-click, and choose Delete, or  select only the baseline,
right-click, and choose Delete.

●   



Product What's New

Improved Parameter Table Interaction
for Restricted Parameters
The parameters table has been enhanced to allow for auto-complete input, as well
as, name filtering for all restricted parameters specified in an external parameter
file.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location Tools / Parameters / Add New Parameter / Restricted

Benefits and Description

The workflow for finding and applying restricted parameters has been improved in
Pro/ENGINEER Wildfire 3.0.  Defining a parameter as restricted, users can select
a parameter from the restricted parameter pull down menu.  However, if the
restricted parameter list is lengthy, users are forced to manual search for the
needed restricted parameter.  With the new auto-complete and name filtering
enhancements for restricted parameters, users no longer have to spend time sifting
through a parameter list to find the desired one.   Users can start typing the initial
characters of a restricted parameter, which will show and highlight in the
parameter field the first available parameter that matches the characters typed.  If
the user types characters that do not match an existing restricted parameter from
the list, the parameter field will become blank.  The user can continue to type and
refine the selection or use the pull down menu, which will show and highlight the
matching parameter in the pull down list.  Selecting the specific restricted
parameter, users can perform the same type of auto-searching and filtering with the
parameter values.   

These new enhancements will interpret not only for English characters, but all the
PTC standard language characters; including Japanese, Korean and both Chinese
languages.



Product What's New

Improved Sketcher Performance with
Large Sections
Sketcher performance has been drastically improved when dealing with large
sections of more then 40 entities and when adding additional entities.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location N/A

Benefits and Description

The optimized Sketcher solver deals with large sections with improved
performance. It now interrogates the sketch and solves only those entities impacted
by the change. Once an entity has been solved, it will not need to be solved again
unless it has been modified or is used as a reference to added entities.



Product What's New

Improved Undo/Redo View Orientation in
Sketcher
The undo/redo view orientation in sketcher has been improved, providing users
with more control over sketcher commands and action sequences during an
undo/redo operation.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas

User Interface Location Undo - Edit / Undo Sketcher Operations or Undo icon,
Redo - Edit / Redo or Redo icon

Benefits and Description

In this release of Pro/ENGINEER, a large effort was made to make similar type
actions consistent in all areas of Pro/ENGINER.  In previous releases one of those
actions that were confusing to users was Undo/Redo in sketcher.  On many
occasions the undo operation was not predictable with user's expectations, due to
the inclusion of semi view manipulations in the undo stack.  The result of this
unpredictable undo forced users to perform manual orientation of the model in
sketcher to get to the proper state.

In Pro/ENGINEER Wildfire 3.0, sketcher Undo/Redo has become consistent with
Undo/Redo outside of Sketcher.  This enhancement removes any view
manipulation actions from the Undo string, thus leaving the Undo/Redo operation
act on creation and editing actions only.  When a user performs an Undo/redo
operation, the users view will not change from the current state, however the model
will step back to previous iterations prior to a change.  The new Undo/Redo
operation in sketcher will perform in-line with user's expectations, as Undo/Redo
does outside of sketcher.



Product What's New

Improved Usability of the ModelCHECK
Configurator
The ModelCHECK Configurator, introduced in the previous release to make it
easy to create, find, and edit ModelCHECK files to meet company standards and
best practices, has been enhanced in Pro/ENGINEER Wildfire 3.0.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area ModelCHECK
User Interface Location Click Tools > Configure ModelCHECK.

Benefits and Description

Key enhancements to the ModelCHECK Configuration for improved usability
include multiple-item selection and shortcut menus for performing quick copy and
paste actions. Additionally, interactive messages remind you to save the
configuration settings when you change to different configuration files.

The Configurator has compressed free space to minimize its size. The redefined
user interface simplifies the look and feel of the dialog boxes. With these new
enhancements, ModelCHECK is even easier to set up, modify, and deploy.



Product What's New

JIS Ordinate Baselines
Ordinate baselines have been improved to better support JIS standard.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location File > Properties > Drawing Options

Benefits and Description

When the dtl setup option "ord_dim_standard" is set to JIS, the ordinate baseline
will be displayed without the zero value. This enables detailers to create drawings
that conform better to the JIS standard.



Product What's New

JIS Thread Display in Drawings
We've improved the display of thread features in drawings to better support JIS
standards.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location File > Properties > Drawing Options

Benefits and Description

We've added a new value for the dtl setup option "thread_standard" to support JIS
standard. When a drawing view with hidden threads is created in a
Pro/ENGINEER drawing using the dtl setup option "thread_standard" set to
std_jis, hidden threads are displayed according to JIS standard.



Product What's New

Light Weld Feature Enhancements
Several enhancements to the Light Weld feature improve performance and use of
light welds.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Welding
User Interface Location Click Insert > Weld > Weld Geometry Type > Light.

Benefits and Description

You can create Light Weld features easier and quicker with a combination of
curves and edges. This creation method provides an accurate representation of the
weld for manufacturing. The mass property information in light welds ensures
correct mass property calculations and takes into account all the welds in a model.

Light Weld features appear as a thick line for improved visability. They are now
also visible in 3D mode. Right-click a light weld in the graphics window or in the
Model Tree and a shortcut menu appears.

You can create light intermittent-groove welds and light intermittent-fillet
welds. In addition, all Light Weld features adhere to hidden line removal
operations in 3D mode and in Drawing mode. As a result, you can easily visualize
and detail weldments.  As with solid welds, all light weld drawing symbols can be
quickly shown on drawings.



Product What's New

Lightweight Preview for Warp Features
With the Facet Preview option, you can easily preview Warp features for large
datasets.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - WARP

User Interface Location
Click Insert > Warp, click References on the Warp
dashboard, and select the Facet Preview check box on
the slide-up panel.

Benefits and Description

The lightweight preview of the Warp feature using the Facet Preview option
increases the dynamic performance for large datasets.



Product What's New

Locked Dimensions in Sketcher
Locked dimensions in a sketch remain locked after completing the sketch in
Sketcher and throughout the design of a model.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas

User Interface Location Select a dimension, click Edit > Toggle Lock, or
right-click and choose Lock from the shortcut menu.

Benefits and Description

Any dimension locked in Sketcher stays that way until it is unlocked. A locked
dimension cannot be modified outside of Sketcher by any changes to its related
geometry. Inside and outside Sketcher, a locked dimension is now displayed in
orange.



Product What's New

Materials Capabilities Improved
Materials capabilities have been dramatically improved with a new Materials
dialog box for defining materials and a completely overhauled library.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Click Edit > Setup > Material.

Benefits and Description

Material properties are now parameters with a system of units associated with
them. You can store user-defined parameters with a materials file. This allows for
model data, such as vendor or test data, to be stored in the library. All of these
pieces of information can be pulled out and used in documenting the model.

Other functional enhancements include the ability to set the material of a model by
Family Table and to have the appearance of models controlled by the material.  



Product What's New

Measure User Interface
The Measure user interface now conforms to the Pro/ENGINEER user model.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location Click Analysis > Measure.

Benefits and Description

The new measurement tools provide improved workflow and greater efficiency in
the analysis of distance, angle, diameter, and so forth.



Product What's New

Mechanism Body Folder in Assembly
Mode
View the mechanism body definition of an assembly in the new split Model Tree
within Assembly mode.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Mechanism Design & Dynamics
User Interface Location Click Show > Mechanism Tree.

Benefits and Description

With the introduction of the split Model Tree, you can now see what components
are part of which mechanism body while in Assembly mode. This dramatically
increases understanding of the design when building an assembly that incorporates
movement. 

The Body Folder is beneath the Mechanism Tree in the split Model Tree for the
assembly. You can access or edit the definition of the assembly, while at the same
time viewing what components belong to which body of the mechanism. 

You can also select a component, right-click, and exclude any component from the
assembly and quickly evaluate the assembly's motion characteristics.



Product What's New

Minimize Overlap of Copied Annotations
The position of annotation elements during copy/paste special, group pattern, or
UDF placement operations has been adjusted to minimize overlap.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Copy/Paste, Group pattern, UDF placement

Benefits and Description

By reducing the overlap of annotation elements that have been duplicated, we have
minimized the amount of placement adjustment required to ensure annotations in
the model are read-able.



Product What's New

Mirror Command Enhancements for
Subassemblies
Components and assemblies can now be mirrored independently of the assembly of
origin.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly

User Interface Location Click Insert > Component > Create > Mirror, or click
File > Mirror Geometry.

Benefits and Description

You can make the parts and placement constraints of a mirrored assembly
independent or dependent of the source part during the creation of an assembly.
Using mirrroring operations, you can preserve the component constraints and have
them depend on the original source part.

In addition, the component placement of the mirrored part can be edited
independently of the part of origin. A mirrored subassembly can now have
individual component placement constraints redefined within the context of the
mirrored subassembly and not be affected by the original source subassembly.



Product What's New

ModelCHECK Toolkit Provides for
Custom Checks
With ModelCHECK you can now develop your own custom checks.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area ModelCHECK
User Interface Location N/A

Benefits and Description

ModelCHECK now provides the framework to define and execute custom
checks. You can hook the custom check functions to the Pro/ENGINEER Toolkit
and flag any item considered an error.

Through the ModelCHECK Toolkit, administrators can control these custom
checks like any other check and expose them in the ModelCHECK Configurator
with the appropriate flag options. Additionally, the administrator can provide the
details of what gets displayed in the ModelCHECK report, such as options to
update the model, open the reference viewer, and to highlight items.



Product What's New

Multiple Walls Using the Flange Tool
The Flange tool can create multiple walls when you select multiple, nontangent
edges.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Sheetmetal Design and Manufacturing
User Interface Location Click Insert > Sheetmetal Walls > Flange.

Benefits and Description

When you select multiple edges, even those not following each other, multiple
walls are created using the Flange tool. You have full control to set up the corner
relieves and the overlap between each wall.

Multimedia

Images

Multiple Walls

Overlap control

Corner Relieves

Videos

Creating a Multiple Walls Flange

http://www.ptc.com/WCMS/files/26572en_vid_vid_step_1.avi


Product What's New

New Display Options for Per Unit
Tolerances
We've added several new display options for flatness geometric tolerances.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Insert > Geometric Tolerance > Flatness Type >
Tolerance Value > Per Unit Tolerance

Benefits and Description

You have more flexibility now when creating flatness geometric tolerances. We've
added options to indicate a circular (diameter) or square area in a new display
pull-down. You can enter the actual dimension and add a square or diameter
symbol to the area dimension if you like. These options are intended to support
industry standards.



Product What's New

New Envelope Manager
The redesigned Envelope Manager is easier to use.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Click View > Envelope Manager.

Benefits and Description

In Assembly mode, you can now create envelope parts in the same way as other
part types, such as skeletons and bulk items, during the workflow for creating
components. The Envelope Manager is easier to access to create, edit, and delete
the envelope parts for large assemblies. The commands are in the Envelope
Manager dialog box and in a shortcut menu available on the Model Tree.



Product What's New

New Sketcher Palette
With the new Sketcher palette, you can capture common shapes and sections for
reuse in future sketches without having to recreate them.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas

User Interface Location Click Sketcher > Data from File > Palette or use the
Sketcher Palette icon from Sketcher toolbar.

Benefits and Description

To streamline sketching, the new Sketcher palette allows you to capture commonly
used sections and reuse them in future sketching operations. You can save and
organize these sections within the Sketcher palette under custom tabs. Default
sections in the palette, such as polygons, special profiles, general shapes, and stars,
can be modified and enhanced.       

The Sketcher pallette is available from the Sketcher toolbar or main menu. You
can click a shape in the palette, click in the graphics window to paste the shape,
and then scale it to the desired size. The shape can also be translated and rotated
before final placement.



Product What's New

New Unattached Extruded Wall User
Interface
The Unattached Extruded wall feature has been consolidated with the Core Extrude
feature into a new user interface.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Sheetmetal Design and Manufacturing
User Interface Location Click Insert > Extrude.

Benefits and Description

The Unattached Extruded Wall feature provides greater usability, as this feature is
very similar to the existing Core Extrude. Sheetmetal-specific options allow the
rounding of sketched corners and the definition of feature-specific bend
information.

Multimedia

Images

Unattached Extruded Wall

Videos

Unattached Extruded Wall

http://www.ptc.com/WCMS/files/26068en_vid_vid_step_1.avi


Product What's New

New Unattached Flat Wall User Interface
The Unattached Flat Wall feature has a new dashboard interface.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Sheetmetal Design and Manufacturing
User Interface Location Click Insert > Sheetmetal Wall > Unattached > Flat.

Benefits and Description

The Unattached Flat Wall feature fully supports the object-action and action-object
principles. Using the dashboard, you are guided through the steps to build an
unattached flat wall.

Multimedia

Images

Unattached Flat

Videos

Creating an Unattached Flat Wall

http://www.ptc.com/WCMS/files/26065en_vid_vid_step_1.avi


Product What's New

On Item Text Placement Improvements
We've added functionality to help users align text that is placed using the ''On
Item'' placement type.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Text Properties > Horizontal and Vertical Alignment

Benefits and Description

Many detailers use the "On Item" text placement option to position notes
parametrically on model geometry. The most common attachment entity is a model
datum point. Now users can use 3 horizontal and 3 vertical alignment options to
achieve the desired text position. Horizontal alignment options include Left,
Center, and Right. Vertical alignment options include Top, Middle, and Bottom.

This functionality provides text positioning options that were previously
unavailable in Pro/ENGINEEER. When these options are use in conjunction with
stored fonts, company logo's, etc can be exactly positioned as needed.



Product What's New

Orientation and Projection of Fill Pattern
Members
The enhancements to Fill Patterns offer the ability to project and orient fill pattern
members onto surfaces.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location Select the feature or group to be patterned. Click the
Pattern tool on the right toolbar, or click Edit > Pattern.

Benefits and Description

As a result of the Fill Pattern enhancements, you can now have a more
precise control of pattern members. Fill pattern members can be:

Projected onto surfaces●   

Oriented either normal to the surface or kept in their original positions●   



Product What's New

Parameter Enhancements
With enhancements to parameters, you can quickly and easily complete such
operations as converting units of parameters.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Click Tools > Parameters.

Benefits and Description

Using the Parameter dialog box, you can convert units that have been assigned to
parameters when you modify the units.  A new and improved filtering capability
allows you to filter out system parameters, for example. The Find option lets you
find a specific parameter in a list of existing parameters in a model.

Pro/ENGINEER now reserves the prefixes PROI_  and PTC_ for only system uses.
This prevents undesired creation of specific parameters that are critical in your
PDM environment.



Product What's New

Parametric Draft Fillets and Chamfers
Improved sketching in drawings includes the ability to create draft fillets and
chamfers that are parametric to model edges.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Sketch > Sketcher Preferences > Parametric Sketching

Benefits and Description

Users can now create parametric draft fillets and chamfers. Enabling parametric
sketching will allow users to create fillets and chamfers referencing model edges.
There is a sketcher preference that allows model edges to be automatically hidden
and various trim options for chamfers. Since these draft entities are parametric to
the model geometry, they will update automatically when changes are made to the
model. We've also added a new fillet type - 3 tangent. This allows users to create
fillets that are tangent to 3 edges.

This new functionality reduces the amount of time it takes to make revision
changes to drawings where chamfers and fillets have been added as drawing
documentation.



Product What's New

Part Simplified Representations in
Drawings
In response to an overwhelming number of enhancement requests, we've added
support for part simplified reps in drawing views.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location File > Properties >Drawing Models > Set/Add

Benefits and Description

Users can now place individual views of simplified parts in drawings.  When a
drawing is created using a part model with simplified representations, the user will
be prompted to select the rep to add as the active drawing model. To place a view
of a part simplified rep in a drawing, the user must set the desired rep as the active
model before placing the view. A drawing view of a part simplified rep cannot be
changed to a different rep after definition.

This functionality eliminates the need for a "dummy" assembly or family table
instances to create a drawing view representing a simplified version of a part.



Product What's New

Partial Shells
The Shell tool can now exclude surfaces when you hollow out a solid to create a
partial shell.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location Click the Shell tool on the right toolbar or click Insert
> Shell.

Benefits and Description

Excluding surfaces from the shelling operation allows for a flexible definition of
the desired result. Areas that are not to be shelled or where thickness cannot be
accommodated can be easily excluded from the operation.



Product What's New

Pattern Tool Enhancements
The Pattern tool offers significant enhancements, including the preview of patterns,
roll back of features, and many other additions.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location Select the feature or group to be patterned. Click or the
Pattern tool on the right toolbar, or click Edit > Pattern.

Benefits and Description

Highlights of improvements to patterning tasks follow:

Use an existing pattern to create another pattern●   

Mirror and Transform of Direction, Axis and Fill pattern●   

Preview patterns in new ways●   

Convert pattern types, including Direction and Axis, to the Table pattern●   

Exclude manually random pattern members for a Reference pattern●   



Product What's New

Placement of User-Defined Features
The User-Defined Feature (UFD) tool streamlines workflow, offering increased
flexibility and capabilities for placement of UFDs in a modern user interface.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location Click Insert > User-Defined Feature.

Benefits and Description

The improvements to user-defined features provide many benefits:

Introduces a familiar user interface similar to Copy and Paste dialog boxes●   

Provides a placement tool with flexible and selective reference selection
with clear instructions 

●   

Offers flexibility during UDF placement to redefine individual features
without a required reference

●   

Consolidates the Variables list (Dimension, Parameters, Annotation
Element, and so forth) into a convenient, tabular format

●   

Improves the preview and graphical feedback●   



Product What's New

RMB Actions for Moving and Rotating
Annotations
Users can now easily move and rotate the text direction of annotation after
selecting the annotation element from the model tree.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling
User Interface Location N/A

Benefits and Description

Users can now have control of the position and text direction of annotations in
annotation features. Using the right mouse button, user can now manipulate the
position and text direction of annotations after they are selected in the model tree.

Users can quickly place annotations in the new location by simply selecting a new
location. Users can also rotate the text direction of annotation using one of the four
defaults provided or by entering an angle.  



Product What's New

Real-Time Collision Detection in
Assembly Mode
Real-time collision detection is now available in Assembly mode using dragging
operations.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Select the Drag Icon in the Assembly toolbar.

Benefits and Description

You can quickly and easily see component interference in Assembly mode while
dragging components during kinematic studies. You can configure the various
collision settings depending on the results being examined:

 Intersecting Volume:  During assembly dragging, the intersecting volume
highlights and updates in real time during the movement of the components
as they intersect. 

●   

Stop on Collision:  When a component is being moved and intersects with
another component, the component stops when the surfaces come into
contact. The components are not permitted to pass through one another.

●   

Push on Collision:  When a component is moved and collides with another
component with remaining degrees of freedom, the moving component
pushes the other component out of the way in the direction of the movement
of the dragged component.

●   



Product What's New

Reduced File Size of Merged Drawings
An internal process reduces the size of the final drawing when two drawings are
merged.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Click Insert > Shared Data > From File. Select the
drawing to be added to current drawing file.

Benefits and Description

Smaller file size for merged drawings improves the usability of Pro/ENGINEER
drawings for companies who use a concurrent drawing design processes.



Product What's New

Rendering Scene File
Rendering Scene files have been added to Wildfire 3.0 allowing users to save the
render room, lighting and environment settings to a single file.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Rendering

User Interface Location
View->Model Setup->Render Control (select the
Scenes icon from the render control tool bar.) Shortcut
icon is also available.

Benefits and Description

Rendering Scene files have been added to Wildfire 3.0 allowing users to save the
render room, lighting and environment settings to a single file. Scene files may be
saved out as a single file or embedded in the model file.  The render room and
lighting components of the scene file scale based on the model geometry allowing
them to be used with other model files with minimal adjustments required by the
user.  Scene files provide the ability to save out the rendering environment for later
use. 



Product What's New

Restricted Parameter Names and Values
By specifying an external file, you can define restricted parameter names and
values. When adding these parameters using the Parameters Dialog, you are
required to select from a list of values or to define a value within a specified range.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Fundamentals & Pro/PROGRAM
User Interface Location Tools / Parameters

Benefits and Description

Companies can now set up distinct lists of values or constrained ranges for
parameters to ensure that users are selecting from a distinct set of values. The
names of the parameters are also explicitly defined which allow for a user to easily
add a parameter using a drop down list and define the value by either selecting
from a list of possible values or entering a value within a range.

Restricted parameters will only have allowed predefined values to by defining the
names of the parameters and possible values in an external file.  Restrictions can
either be defined by a list of valid values for strings, integers or real numbers.
Restricted can also be a range of values for integers and real numbers.

When a restricted parameter is created in a model the definition of the restriction
will be copied into the model. This allows for the definition to remain intact even if
the external file is lost. The parameterâ€™s definition will remain the same even if
changes are made to the external file. If a user wants to update the restriction
definition, they can use tools within the parameters dialog to update the
restrictions. Users can also run a conflict report from the parameters dialog to
determine if a discrepancy exists between the model and the external restriction
file

Users can direct Pro/ENGINEER to an external file definition using the config.pro
option restricted_val_definition. Users must also set the config.pro option
restricted_values to yes.



Product What's New

Separate Layer Dialog
Customers can now set a config.pro option to allow a floating layer dialog. This
has been reintroduced back into Pro/ENGINEER Wildfire 3.0 as one of the top
enhancement requests.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Fundamentals & Pro/PROGRAM
User Interface Location View / Layers

Benefits and Description

Customers can now undock the layer tree and be placed anywhere on the screen
while the model tree remains embedded. A config.pro option will be used to
control the display of the layer tree. Once the layer tree is separated, all windows
will have the layer trees undocked. The commands in the separate layer tree will
remain the same as they are in the docked layer tree. The layer dialog will have a
filter to select the focus of the layer tree when dealing with assemblies



Product What's New

Set Datum Attachment to Gtols
Enable attachment of set datum tags to geometric tolerances in models and
drawings.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing
User Interface Location Datum > Properties

Benefits and Description

In drawings when the dtl setup option "gtol_datums" is set to std_iso, users can
attach set datum tags to geometric tolerances as necessary. In 3D models, set
datum tags can be attached to geometric tolerances as well. Because 3D set datums
cannot be displayed in models if they are attached to draft geometric tolerances,
this functionality is restricted based upon geometric tolerance and set datum
owner. 2D set datum tags can be attached to 2D geometric tolerances and 3D set
datum tags can be attached to 3D geometric tolerances.

This gives detailers more functionality in 3D to support drawingless model
standards and allows more flexibility and associativity in drawings.



Product What's New

Set Up of Sketching Planes and
Orientation References in Sketcher
With the improved creation and modification workflow for Sketcher, you can
directly modify the setup of a sketch and orientation references.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location Click Sketch > Sketch Setup and Sketch > References.

Benefits and Description

Entering and exiting Sketcher is streamlined in all modeling modes, such as Part
and Assembly. You can quickly change the sketching plane or the orientation
reference of a section without having to leave Sketcher and to break the design
flow. In addition, you can configure the automatic selection of default dimensions.
For automatic selections, you are not prompted for acceptance. If you wants to
change a default dimension, you can quickly modify it.



Product What's New

Shaded Views in Drawings
You can now include shaded views of models in drawings. This capability
improves plotting drawings with OLE objects and shaded views.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Click Drawing View Properties > View Display >
Display Style > Shading.

Benefits and Description

Using shaded views in drawings gives more options for communicating critical
design information. Colors can provide visual cues to help describe designs. By
using shading, drawings can include more detail. Updated plotter drivers support
plotting drawings with shaded views and improve plotting of drawings with
embedded objects.



Product What's New

Sheetmetal Reports
The Sheetmetal Info reports are consolidated within the Model Info report.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Sheetmetal Design and Manufacturing
User Interface Location Click Info > Model.

Benefits and Description

The Model Info report now includes complete information about the model,
including sheetmetal information. This replaces the Sheetmetal Info report.

Within the same report, using the Pro/ENGINEER browser, you see all
information about the model, including the bend report, the design rule report ,and
the radius report. The reporting is enhanced to allow highlighting on the 3D model.

Multimedia

Images

Sheetmetal Info

Videos

Info about a Sheetmetal Model

http://www.ptc.com/WCMS/files/26574en_vid_vid_step_1.avi


Product What's New

Show Frozen Components in Assembly
Model Tree
This enhancement will change the model tree icon so that a user can quickly
inspect the model tree to determine what components are currently frozen

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Model Tree

Benefits and Description

Users can quickly determine what components and child components are frozen
with an assembly by scanning the model tree. This will allow for a quick visual
inspection rather than having to add the status column in the model tree.



Product What's New

Simultaneous Retrieval of Components
and Graphics
Pro/ENGINEER now displays the graphics of each component in the graphics
window during retrieval of the assembly.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly
User Interface Location Click File > Open.

Benefits and Description

While the assembly is being retrieved, you can view the components and plan the
work for that session. You can also see changes to components as they are
retrieved, instead of waiting for the assembly to open in the graphics window. In
addition, retrieval time for assemblies has been decreased.



Product What's New

Sketched Text Positions
Sketcher has been enhanced for control of the vertical and horizontal justification
of sketched text.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas

User Interface Location Click Sketch > Text, or click the Sketched Text icon
from the Sketcher toolbar.

Benefits and Description

To help visualize the direction of the initial sketched curve and the orientation of
the text string, an arrowhead appears at the start point of the text. When you
change the vertical and horizontal justification values, the text string justification
updates around its start point. Vertical options include Top, Middle, or Bottom,
and horizontal options include Left, Center, or Right. The default dimensioning
scheme for the text string is consistent regardless of its orientation. The resulting
boundary box for the text string is tight against the text string, providing addition
control on its exact position in Sketcher.

In regard to kerning, you can choose to allow Sketcher to apply kerning values
incorporated into the text font. 

If you select another sketched curve for the text string to follow, the text
string moves along the selected curve. You can control both its horizontal and
vertical justification. Changing the horizontal position moves the text string to the
right or left side of the defined curve.  



Product What's New

Slot Connections in Assembly Mode
Mechanism slot connections can now be defined as an Assembly connection.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Mechanism Design & Dynamics
User Interface Location Click Insert > Component > Assemble > Slot.

Benefits and Description

You can quickly and easily create slot connections in Assembly mode without
switching into Mechanism mode, as was previously required.  This eliminates
having to enter another mode to define this common type of component placement
constraint. 

In addition, with the powerful kinematic dragging within Assembly mode, you can
verify that the slot connection completely defines the component in the assembly.



Product What's New

Specifying Joint Axis Limits during
Component Placement
You can now set joint axis settings when you are defining component placement,
making it easier and simpler to limit the motion of components within Assembly
mode.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly

User Interface Location Select the Joint Axis icon in the Component Placement
dashboard.

Benefits and Description

Being able to specify joint axis settings or motion limits on remaining degrees of
freedom of a component during component placement eliminates the extra steps.
You no longer must change to mechanism mode in which you are restricted to only
setting the motion limits.

By setting the motion limits on the components during component placement, you
can evaluate the kinematic movement of the component  while constraining the
component.  Thuse, you reduce the time it takes to make sure a moving part is
correctly functioning and located.



Product What's New

Streamlined Board Import and Export
Side menus for the import and export of ECAD data have been consolidated into a
single dialog box.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area ECAD
User Interface Location Click Insert > Shared Data > From File.

Benefits and Description

A single dialog box for the import and export of ECAD data provides a
consolidated approach for greater productivity. A new option automatically
displays the log file in an information window after the exchange of data.

Multimedia

Images

Improved Import and Export User
Interface

Videos

Improved Import and Export User
Interface

http://www.ptc.com/WCMS/files/26242en_vid_vid_step_1.avi


Product What's New

Streamlined Creation of ECAD Areas
An ECAD Area dialog box for the creation of ECAD areas consolidates the
previous side menus.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area ECAD
User Interface Location Click Insert > Cosmetic > ECAD Area.

Benefits and Description

You can now work within a single dialog box to create ECAD areas. This
consolidated approach enhances your productivity. For improved access and faster
editing, the features of an ECAD area are displayed in the Model Tree.

Multimedia

Images

Streamlined User Interface for ECAD
Areas

Videos

Streamlined User Interface for ECAD
Areas

http://www.ptc.com/WCMS/files/26294en_vid_vid_step_1.avi


Product What's New

Support for Flexible Components in
Kinematic Assemblies
Pro/ENGINEER Assemblies with packaged components can now be kinematically
dragged in real time with flexible components, such as springs and pipes, that fully
constrain the assembly.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Mechanism Design & Dynamics
User Interface Location N/A

Benefits and Description

You can now quickly and easily see a mechanism in motion in Assembly mode
without suppressing or deleting the flexible part that fully constrains the assembly.
Pro/ENGINEER temporarily suppress the flexible part or component from the
calculation of mechanism bodies. The mechanism can then move as if the flexible
part was not present in the assembly. After the dragging operation, the flexible part
regenerates to the correct geometry based on its defined flexibility. 



Product What's New

Support of OpenType Fonts
With Universal Font Scaling Technology 4.7, you can use and place OpenType
Fonts for multi-language support in all areas, including Sketcher and drawings.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Other Functional Areas
User Interface Location N/A

Benefits and Description

Becoming a global font standard, OpenType fonts can be viewed as a superset of
TrueType fonts. The fonts are based on Unicode, which enables the framework for
multi-language support. OpenType fonts offer an expanded character set and
layout features to provide richer linguistic support and advanced typographic
control.

You can read and place these custom fonts, including symbols and logos that have
been mapped to specific function keys. You can place these fonts in
Pro/ENGINEER as single entities and maintain proportions and ratios.   



Product What's New

Swept Blend Dashboard
The new Swept Blend tool uses a smooth-flow workflow with a dashboard user
interface.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location
Click the Swept Blend tool on the right toolbar, or
click Insert > Swept Blend. (See Tools > Customize
Screen).

Benefits and Description

The Swept Blend tool with its dashboard has many benefits:

Consolidates different feature types into a single feature, such as protrusion,
cut, surface, surface trim, thin protrusion, thin cut, and thin trim

●   

Allows changing of the multiple feature types at any point●   

Provides smart selection of various sections through analyzing the
accessibility for different options (for example, selection of open sections for
the Surface option)

●   

Offers a more accurate method of specifying the cross-sectional area of the
Swept Blend geometry at desired locations on the origin trajectory

●   



Product What's New

Undo and Redo Support for Assembly
Operations
Undo and Redo are now available in Assembly mode for all of the general
assembly operations and commands.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Assembly

User Interface Location Click Edit > Undo and Edit > Redo. Shortcut keys use
CTRL+Z and CTRL+Y.

Benefits and Description

With the Undo and Redo commands within Assembly mode, you can revert to a
state prior to the last action. Often unintentionally, you delete an assembly feature
or component. Now you can undo the Delete command. Additionally, the Undo
command also resets some operations. When you understand the impact that
operations have on a model or assembly, you can prevent tedious rework by using
these two commands.



Product What's New

Updated Default Setting for Importing
Holes
The default value for the configuration option ecad_import_holes_as_features has
been changed from NO to YES.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area ECAD
User Interface Location Tools > Options

Benefits and Description

The change of the default configuration option for the importing of holes
to YES ensures that design intent is not lost during the ECAD to MCAD data
communication. By default all holes are now created as features as apposed to as
an extruded sketch. As a result, design intent is maintained during the initial board
creation, and very small holes do not cause regeneration problems during the
redefinition of board features.

Multimedia

Images

Holes Created as Features



Product What's New

Updates to Surface Finish Annotations
Now it is possible to collect surface finish reference surfaces separately from the
symbol attachment reference in 3D. We've also enabled advanced selection for
surface finish annotation elements in annotation features.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Part Modeling

User Interface Location Edit > Setup > Surface Finish > Create OR Insert >
Model Datum > Annotation > Surface Finish

Benefits and Description

The surface finish definition dialog has been enhanced to allow users to apply
surface finishes to many surfaces and attach the surface finish symbol to only one
of the surfaces in the collection. We've added a special area to define the surfaces
the surface finish is to be applied to and a different area to specify the symbol
attachment. We've also enabled users to use advanced collection options (like seed
& boundary) to select the application surfaces when creating surface finish
annotation elements in annotation features.



Product What's New

View Manager States for Drawing Views
You can reuse all states created in 3D models to help configure drawing views.

Product Information

Product Pro/ENGINEER Foundation Advantage
PTC Support Release Wildfire 3.0

Product Functional Area Detail Drawing

User Interface Location Use Create/Modify Drawing View > View States >
Presentation State.

Benefits and Description

The View Manager provides for faster creation of drawing views with a greater
degree of design reuse. You define orientation, explode state, cross sections, and so
forth and store them in the 3D model using the View Manager.  While creating or
modifing drawing views, you can select a presentation in a model (View Manager
> All). Many of the the configured options are automatically used to help define
the drawing view when you choose the Presentation State command.



Product What's New

Pro/ENGINEER Interactive Surface
Design

Circle and Arc Tools for Primitive Shapes

Two new curve creation tools approximate circles and arcs.

●   

Copying and Moving Curves

The enhanced Move and Copy commands provide for rotation as well as for
scaling of curves.

●   

Creating a Curve on Surface

You can create a Curve on Surface (COS) by intersecting either two surfaces
or a surface and a plane.

●   

Drafted Curve and Surface Connections

The Draft Tangent option for both curves and surface allows for connections
with draft to a plane or a surface.

●   

Offset Curve Enhancements

You can now create offset curves from free and planar curves as well as
from curves on surfaces.

●   

Redefinition of Internal Datum Planes

Datum planes created internally to a Style feature can now be redefined.

●   

Single Approximate Curves

Using keyboard shortcuts with the Curve from Datum command, you can
create a single approximate curve from a chain of curves and edges.

●   

Smart Curve Connections for Surfaces

When connecting surfaces, you can now consider relevant connections by
responding to system prompts for ''smart'' connections.

●   



Product What's New

Circle and Arc Tools for Primitive
Shapes
Two new curve creation tools approximate circles and arcs.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX

User Interface Location On the Style toolbar, click the curve flyout, or click
Styling > Circle or Styling > Arc.

Benefits and Description

The Circle and Arc tools for Style features provide quick ways to lay out some
primitive spline shapes. These tools provide dynamic dragging and snapping of
center point and boundary points as well as provide for numeric input.  The editing
options are the same as for other spline curves. These tools are not intended to
replace Sketcher functions.



Product What's New

Copying and Moving Curves
The enhanced Move and Copy commands provide for rotation as well as for
scaling of curves.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX
User Interface Location Click Edit > Move or click Edit > Copy.

Benefits and Description

The Style interface provides greater control while dragging dynamically, including
the ability to snap the jack to other geometry.  Numeric control of the
transformations is provided in the dashboard tabs.



Product What's New

Creating a Curve on Surface
You can create a Curve on Surface (COS) by intersecting either two surfaces or a
surface and a plane.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX

User Interface Location On the Style toolbar, click the COS by Intersect icon,
or click Styling > COS by Intersect.

Benefits and Description

The resulting COS is dependant on both surfaces, so it updates if the surfaces
change shape.  When converting or offsetting a COS created by intersection, you
choose whether the resulting COS will live on one or both of the parent surfaces.



Product What's New

Drafted Curve and Surface Connections
The Draft Tangent option for both curves and surface allows for connections with
draft to a plane or a surface.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX

User Interface Location Click Styling >Curve Edit or Styling > Surface
Connect. On the dashboard, click Tangent.

Benefits and Description

You can quickly create a connections with draft for a curve or surface with
commands and with the following shortcuts:

For a curve, right-click the tangent vector and choose Draft Tangent from
the shortct menu.

●   

For a surface, press and hold CTRL+ALT and click on a connection icon.●   

You can also access the different surface connection options by
right-clicking on the connection icon and choosing a connection type from
the shortcut menu.

●   



Product What's New

Offset Curve Enhancements
You can now create offset curves from free and planar curves as well as from
curves on surfaces.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX
User Interface Location Click Styling > Offset Curve.

Benefits and Description

Offset curves from free and planar curves can be offset normal or parallel to a
reference plane. They can be redefined to change the offset direction and distance.



Product What's New

Redefinition of Internal Datum Planes
Datum planes created internally to a Style feature can now be redefined.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX

User Interface Location Click Edit > Definition, or right-click on plane and
choose Edit Definition from the shortcut menu.

Benefits and Description

When redefining internal datum planes, you can use all the creation options
including references and dimensions.



Product What's New

Single Approximate Curves
Using keyboard shortcuts with the Curve from Datum command, you can create a
single approximate curve from a chain of curves and edges.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX
User Interface Location Click Styling > Curve from Datum.

Benefits and Description

The keyboard shortcuts make it easy to quickly create an approximate curve from a
chain of curves and edges:

To create a single approximate curve, press and hold SHIFT and select the
chain.

●   

To create individual curves, one per element, press and hold CTRL and
select the chain.

●   



Product What's New

Smart Curve Connections for Surfaces
When connecting surfaces, you can now consider relevant connections by
responding to system prompts for ''smart'' connections.

Product Information

Product Pro/ENGINEER Interactive Surface Design
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - ISDX

User Interface Location On the Style toolbar, click the Surface Connect icon, or
click Styling > Surface Connect.

Benefits and Description

During the process of creating or connecting surfaces in Style, you can choose
whether to make certain curve connections that might be missing directly from the
surface create or surface connect tools. This saves times and works for both an
initial surface connection with tangency as well as the promotion to curvature
continuity.



Product What's New

Pro/ENGINEER Mechanism Dynamics
Family Table Parameters for Joint Axis Limits

Use the Joint Axis Limits parameters in Family Tables to vary motion limits
in assembly instances.

●   

Mechanism Operations Enhancements

The redesigned Mechanism operations are integrated with the workflow and
are consistent with the user interface in Assembly mode.

●   



Product What's New

Family Table Parameters for Joint Axis
Limits
Use the Joint Axis Limits parameters in Family Tables to vary motion limits in
assembly instances.

Product Information

Product Pro/ENGINEER Mechanism Dynamics
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Mechanism Design & Dynamics
User Interface Location Click Tools > Family Table > Parameters.

Benefits and Description

You can now specify  maximum and minimum motion limits inside Family Tables
for a joint axis. You can add the following parameters for a joint axis to the Family
Table instance: static coefficient of friction, the dynamic coefficient of friction, the
coefficient of restitution, and regen value. Using Family Tables instances, you can
create different limits or different dynamic properties all within the same model.



Product What's New

Mechanism Operations Enhancements
The redesigned Mechanism operations are integrated with the workflow and are
consistent with the user interface in Assembly mode.

Product Information

Product Pro/ENGINEER Mechanism Dynamics
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Mechanism Design & Dynamics
User Interface Location N/A

Benefits and Description

Mechanism mode simplifies the work with mechanisms in Pro/ENGINEER. The
following enhancements make working with assemblies easier: 

Standard Copy (CTRL+C) and Paste (CTRL+V) of mechanism objects such
as motors, analyses, and constraints.

●   

Connections highlight in the graphics window when selected via the
Mechanism Tree.

●   

Collection and selection for mechanism entities are consistent with
Assembly mode.

●   

The Pro/ENGINEER search tool provides a full-search for mechanism
objects.

●   



Product What's New

Pro/ENGINEER Piping Design

Designated Reports

Piping Design takes advantage of the report designation functionality
available in mechanical piping.

●   

Non-Breaking Fittings for Pipelines

Fittings that do not break the pipeline can now be inserted using Piping
Design.

●   

Routing Continuous Fittings

Using Piping Design, you can now route a series of fittings prior to routing a
pipe centerline.

●   



Product What's New

Designated Reports
Piping Design takes advantage of the report designation functionality available in
mechanical piping.

Product Information

Product Pro/ENGINEER Piping Design
PTC Support Release Wildfire 3.0

Product Functional Area Piping (Spec Driven & Non-Spec Driven)
User Interface Location Info > Piping

Benefits and Description

You can use Piping Design for creation and Detailed Drawing (rather than the
Alias ISOGEN interface) for documentation. Set the configuration option
piping_enable_designate_report to YES. This setting stores Bend Location, Bend
Machine, Clocking Angle, and Hole reports with the piping assembly. You
can then access these reports automatically using Pro/REPORT.

Multimedia

Images

Designatable Reports



Product What's New

Non-Breaking Fittings for Pipelines
Fittings that do not break the pipeline can now be inserted using Piping Design.

Product Information

Product Pro/ENGINEER Piping Design
PTC Support Release Wildfire 3.0

Product Functional Area Piping (Spec Driven & Non-Spec Driven)
User Interface Location Click Fitting > Insert.

Benefits and Description

Pipelines often contain fittings that do not break pipelines, such as a pipe
clamp. You can now insert non-breaking fittings and ensure automatic selection
and propagation during the creation and modification of pipelines.

Multimedia

Videos

Non-Breaking Fitting

http://www.ptc.com/WCMS/files/26334en_vid_vid_step_1.avi


Product What's New

Routing Continuous Fittings
Using Piping Design, you can now route a series of fittings prior to routing a pipe
centerline.

Product Information

Product Pro/ENGINEER Piping Design
PTC Support Release Wildfire 3.0

Product Functional Area Piping (Spec Driven & Non-Spec Driven)
User Interface Location Click Fitting > Insert.

Benefits and Description

Routing fittings lowers manufacturing costs by minimizing pipe segments in
between fittings and the associated welding required. You can still choose to route
a pipe centerline, and then assemble fittings. However, for greater flexibility you
can use a new option to route a series of continuous fittings prior to the routing of a
centerline, or you can use a combination of the two methods. 

Multimedia

Videos

Routing Continuous Fittings

http://www.ptc.com/WCMS/files/26335en_vid_vid_step_1.avi


Product What's New

Pro/ENGINEER Production Machining

Grouping Steps for the Same Behavior

Independent NC steps in a complete process can be defined to include the
same behavior. Any change to a behavior is done on each member of a
group for each step.

●   

Support for Gang Tools

Special Gang tools for production machining are available in NC
Manufacturing to combine NC drilling steps.

●   



Product What's New

Grouping Steps for the Same Behavior
Independent NC steps in a complete process can be defined to include the same
behavior. Any change to a behavior is done on each member of a group for each
step.

Product Information

Product Pro/ENGINEER Production Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Select multiple NC steps and right-click to open the
shortcut menu.

Benefits and Description

In a NC process, different NC steps can use the same tool with the same cutting
conditions but in different operations. Virtual groups based on behaviors reduce
your efforts to complete a complex NC Process.

Using the Process Manager, any step of the same type, such as drilling or milling,
can be regrouped in a virtual group. Any change on the leader of this group is then
passed to each group member in each NC step. For instance, if you change the tool
affecting the leader of a group, then all NC steps members of this group will have
the tool changed to the new selection.

Multimedia

Images

Create a Same Behavior Group

Videos

Create a Same Behavior Group

http://www.ptc.com/WCMS/files/26034en_vid_vid_step_1.avi


Product What's New

Support for Gang Tools
Special Gang tools for production machining are available in NC Manufacturing to
combine NC drilling steps.

Product Information

Product Pro/ENGINEER Production Machining
PTC Support Release Wildfire 3.0

Product Functional Area Manufacturing (NC, Expert Machinist)

User Interface Location Select multiple drilling steps and right-click for a
shortcut menu.

Benefits and Description

Using the Process Manager, several NC drilling steps can be regrouped and
machined at once with a Gang tool to reduce machining time. Material removal is
calculated automatically and accurately.

To define the gang drilling, you select the drilling steps to be machined with the
same Gang tool and select a â€œleaderâ€• for the machine code.

Multimedia

Images

Gang Tool Sample

Gang Too Creation

Material Removal

Videos

Gang Tool Creation

http://www.ptc.com/WCMS/files/25888en_vid_vid_step_1.avi




Product What's New

Pro/ENGINEER Reverse Engineering
Symmetry Plane

The ability to locate a plane of symmetry relative to facet geometry has been
added to the Restyle feature for the Wildfire 3.0 release.

●   



Product What's New

Symmetry Plane
The ability to locate a plane of symmetry relative to facet geometry has been added
to the Restyle feature for the Wildfire 3.0 release.

Product Information

Product Pro/ENGINEER Reverse Engineering
PTC Support Release Wildfire 3.0

Product Functional Area Surfacing - Restyle
User Interface Location Restley->Analytical Surfaces->Symmetery Plane

Benefits and Description

The ability to locate a plane of symmetry relative to facet geometry has been added
to the Restyle feature for the Wildfire 3.0 release.  A plane of symmetry can be
located based on the entire facet feature or by selecting user defined domains. 
With the symmetry plane functionality comes the ability to specify normal to plane
conditions for surfaces allowing geometry to be mirrored  while maintaining
surface continuity about the mirror plane.



Product What's New

Pro/ENGINEER Structural and Thermal
Automatic Creation of Contact Regions

Contact regions can now be automatically created between a set of selected
parts in an assembly.

●   

Contact Definition Improvements

Contact definition and editing has been simplified.

●   

Control of the Spin Center in a Result Window

The spin center of a model can be toggled on and off in a result window.

●   

Copy and Paste

Simulation modeling objects can be copied and pasted.

●   

Design Study User Interface

The definiton of design studies has been dramatically improved with a new
user interface.

●   

Exploded Views

Exploded views are now available when defining your simulation model.

●   

Heat Loads on Volumes

Heat loads can be assigned to volume regions of of parts and assemblies in
Simulation.

●   

Hide and Unhide

With the Hide and Unhide commands, you can control the display of
simulation objects.

●   

Inertial Relief

Inertial relief is now supported as an analysis option in Mechanica.

●   

Legend Customization

Customization of legends in result windows is not affected by editing the
window.

●   

Materials Now Meet Requirements in Simulation

Materials in Pro/ENGINEER have been enhanced to support requirements in
Simulation.

●   

Mechanica on Linux

Mechanica is supported on Linux.

●   

Meshing More Robust●   



Both the AutoGEM and FEM meshers have improved robustness.

Midsurface Modeling in FEM Mode

Modeling midsurfaced assemblies has been simplified in FEM mode.

●   

Multiple Selections for Deletions

Multiple selections are now valid for the Delete command.

●   

New Material Assignments

More flexibility is possible when you assign new materials to Simulation
parts and assemblies.

●   

Previewing Models before Output to FEM Solvers

An option to display the model before output to FEM solvers has been added
to the FEM Solution dialog box.

●   

Process Guide Wizard for Mechanica

The Process Guide, a user-customizable wizard for Mechanica, can be used
with the standard user interface.

●   

Query Labels

Dynamic query labels rotate with model.

●   

Removal of 8-GB Memory Limit

The 8-GB memory limit on 64-bit operating systems has been removed for
Mechanica solvers.

●   

Rigid Connection Improvements

Defining and editing rigid connections is easier.

●   

Spot Weld Improvements

Spot weld definition and display has been improved.

●   

Spot Welds in FEM

FEM mode now supports spot welds.

●   

Tolerance Report

The tolerance report has been enhanced to display not only the model
tolerance but also the current accuracy setting.

●   

Weighted Links

Weighted links capability is now available.

●   



Product What's New

Automatic Creation of Contact Regions
Contact regions can now be automatically created between a set of selected parts in
an assembly.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal

User Interface Location Click Insert > Connection > Auto Detect and Create
Contacts.

Benefits and Description

After you create contact regions automatically, they can be edited and deleted
individually. You can select them and specify a maximum separation and angle
between the parts.



Product What's New

Contact Definition Improvements
Contact definition and editing has been simplified.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Insert > Connection > Contact.

Benefits and Description

Contact regions have been enhanced to make definition and editing much
easier. Some of these improvements include:

Improved display●   

Direct editing (object-action)●   

Layers support●   

New definition user interface●   



Product What's New

Control of the Spin Center in a Result
Window
The spin center of a model can be toggled on and off in a result window.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click View > Spin Center on/off.

Benefits and Description

In a result window, if the spin center is toggled off, the model rotates about a
user-selected point. If the spin center is toggled on, the model rotates about the
spin center.



Product What's New

Copy and Paste
Simulation modeling objects can be copied and pasted.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Edit > Copy.

Benefits and Description

You can easily copy Simulation modeling objects, such as fasteners and
loads. Select the object from either the graphics window or Model Tree and
right-click. Choose the Copy command from the shortcut menu. After you paste
the object, you can edited it and select new references.



Product What's New

Design Study User Interface
The definiton of design studies has been dramatically improved with a new user
interface.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Analysis > Mechanica Analysis/Studies.

Benefits and Description

The revamped user interface includes enhancements to dialog boxes for defining
design studies, sensitivity studies, and optimizations.  Workflow is
simplified. You can vary design parameters and dimensions directly from the
model.  In addition, you can access more optimization settings and can define
feasibility studies.



Product What's New

Exploded Views
Exploded views are now available when defining your simulation model.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click View > Explode > Explode View.

Benefits and Description

Exploded views greatly simplify the creation of connections such as contacts or
free interfaces on complex assembly models.



Product What's New

Heat Loads on Volumes
Heat loads can be assigned to volume regions of of parts and assemblies in
Simulation.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal

User Interface Location Click Insert > Heat Load and choose the Volume
option.

Benefits and Description

The Volume option expands the use of heat loads beyond components, surfaces,
edges, and points.



Product What's New

Hide and Unhide
With the Hide and Unhide commands, you can control the display of simulation
objects.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click View > Visibility > Hide.

Benefits and Description

By hiding simulation objects, you can more effectively control the visual clutter on
complex models. Select the object, right-click, and choose Hide from the shortcut
menu.



Product What's New

Inertial Relief
Inertial relief is now supported as an analysis option in Mechanica.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Analysis > Mechanica Analyses/Studies.

Benefits and Description

Inertia relief helps in the definition of models where it may be difficult to constrain
the model without artificially stiffening it, such as when components of a dynamic
linkage are analyzed. With the Inertia Relief option, you can run underconstrained
models in static analysis. When solving a model with this option set, the externally
applied loads and moments are balanced by equal and opposite body forces and
accelerations. 



Product What's New

Legend Customization
Customization of legends in result windows is not affected by editing the window.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Format > Legend.

Benefits and Description

You can edit a results window with no loss of any legend customization. Only
changing the results quantity will reset the legend to the defaults. Editing the
appearance of result windows is also much easier.



Product What's New

Materials Now Meet Requirements in
Simulation
Materials in Pro/ENGINEER have been enhanced to support requirements in
Simulation.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Edit > Setup > Materials.

Benefits and Description

Simulating designs created in Pro/ENGINEER is much faster and easier. You no
longer must reapply materials solely for analysis. All materials definition and
assignment can be done in standard mode, and these assignments and properties
will be seen when the models are used in Mechanica.

The new materials definition interface improves usability and adds new
functionality, such as the ability to define user parameters and save these with
materials definitions.  



Product What's New

Mechanica on Linux
Mechanica is supported on Linux.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location N/A

Benefits and Description

You can run Mechanica on the Redhat Linux operating system.



Product What's New

Meshing More Robust
Both the AutoGEM and FEM meshers have improved robustness.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click AutoGEM > Create.

Benefits and Description

AutoGEM enhancements in the area of meshing of large models ensures success
when modeling large, complex structures. The FEM mesher continues to become
more robust.



Product What's New

Midsurface Modeling in FEM Mode
Modeling midsurfaced assemblies has been simplified in FEM mode.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Insert > Midsurface.

Benefits and Description

Modeling of midsurfaced, compressed assemblies is easier and faster than ever. In
FEM mode, Mechanica detects where the parts were touching before they were
compressed, and rigid links are created between the corresponding nodes. If a
user-defined connection is detected between the parts, automatic linking does not
occur. You no longer must connect the parts that were compressed using welds,
connections, or other methods.



Product What's New

Multiple Selections for Deletions
Multiple selections are now valid for the Delete command.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Edit > Delete.

Benefits and Description

In one operation, you can select multiple simulation modeling objects to be
deleted.



Product What's New

New Material Assignments
More flexibility is possible when you assign new materials to Simulation parts and
assemblies.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Properties > Material Assignment.

Benefits and Description

You can define material assignments in Simulation parts and assemblies that
override those inherited from Pro/ENGINEER models. The new material
assignments can also be assigned volume regions. In this way multiple
materials can be assigned to separate volumes in a single part.



Product What's New

Previewing Models before Output to
FEM Solvers
An option to display the model before output to FEM solvers has been added to the
FEM Solution dialog box.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Analysis > FEM Solution.

Benefits and Description

On the FEM Solution dialog box, select the Display option to preview the model
before selecting to output it.



Product What's New

Process Guide Wizard for Mechanica
The Process Guide, a user-customizable wizard for Mechanica, can be used with
the standard user interface.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Help > Process Guide.

Benefits and Description

The Process Guide guide instructs infrequent users on the steps of common
analyses or directs more sophisticated users in unfamiliar tasks. Experts or
consultants can create an XML file that will populate the Process Guide. 

The Process Guide lists a set of tasks, or steps, that must be completed for a given
process. The steps consists of either actions, such as creating a load, or
information, such as a link to online Help or an intranet page.

As the process progresses, tasks are marked as completed or invalidated. For
example, if a load created in the Process Guide is deleted from the Model Tree, the
step is marked as invalidated. If you quit the Process Guide in mid session, you can
save the steps taken to that point with the model.



Product What's New

Query Labels
Dynamic query labels rotate with model.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Info > Dynamic Query.

Benefits and Description

If the model is rotated or resized, all the labels stay attached. 



Product What's New

Removal of 8-GB Memory Limit
The 8-GB memory limit on 64-bit operating systems has been removed for
Mechanica solvers.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Analysis > Mechanica Analyses/Studies.

Benefits and Description

With the memory limit removed, the model size that can be run is practically
unlimited. The solvers are no longer constrained to models up to 4-5 million
degrees of freedom. 



Product What's New

Rigid Connection Improvements
Defining and editing rigid connections is easier.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Insert > Connection > Rigid Link.

Benefits and Description

You can edited rigid connections directly by selecting them on the model or on the
Model Tree. You can control visibilityy, and you can place the connections onto
layers.



Product What's New

Spot Weld Improvements
Spot weld definition and display has been improved.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Insert > Connection > Weld.

Benefits and Description

A new user interface has been merged into the Weld (end and perimeter)
Definition dialog box. Spot weld capabilities have been dramatically improved in
areas such as the following:

Model  Tree support●   

Improved user interface●   

Layers support●   

Direct editing (object-action)●   

Improved display and control●   



Product What's New

Spot Welds in FEM
FEM mode now supports spot welds.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Insert > Connection > Weld.

Benefits and Description

Spot welds defined in Mechanica Native mode or FEM mode are now supported
and output to the FEM solvers.



Product What's New

Tolerance Report
The tolerance report has been enhanced to display not only the model tolerance but
also the current accuracy setting.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Info > Tolerance Report.

Benefits and Description

You can easily see model tolerance and the current accuracy setting in the
tolerance report. This information is important when you attempt to mesh assembly
models. Sometimes if the tolerance of the components is similar, the robustness of
the mesher improves.



Product What's New

Weighted Links
Weighted links capability is now available.

Product Information

Product Pro/ENGINEER Structural and Thermal
PTC Support Release Wildfire 3.0

Product Functional Area Simulation - Structural & Thermal
User Interface Location Click Insert > Connection > Weighted Link.

Benefits and Description

With weighted links, you can select independent geometry, including
points, curves/edges, surfaces, and a dependent point.  The weighted link ties the
dependent point to move the average of the displacements of the independent
geometry.

Weighted links "smear" out local, singular effects over larger areas of the model. 
For example, a point load can be applied at the dependent point, and this point load
will be applied to all of the independent geometry.



Product What's New

Assembly
Component Interface Definition Enhancements

Component Interfaces are now easier to define, easier to place in an
assembly, and viewable in the Model Tree.

●   

Component Placement Dashboard

The Component Placement dashboard, drag handles, and feedback in the
graphics window provide a faster, easier method to assemble components in
Pro/ENGINEER assemblies.

●   

Component Replace Enhancements

All methods of replacing components in an assembly have been enhanced
and combined into a single, easy-to-use dialog box.

●   

Copy and Paste in Assembly

The Windows style copy and paste is now available in Assembly mode.

●   

Full Mechanism Dragging Capabilities in Assembly Mode

Mechanism's Drag dialog box is available in Assembly mode and allows full
body dragging capabilities.

●   

Mirror Command Enhancements for Subassemblies

Components and assemblies can now be mirrored independently of the
assembly of origin.

●   

New Envelope Manager

The redesigned Envelope Manager is easier to use.

●   

Real-Time Collision Detection in Assembly Mode

Real-time collision detection is now available in Assembly mode using
dragging operations.

●   

Show Frozen Components in Assembly Model Tree

This enhancement will change the model tree icon so that a user can quickly
inspect the model tree to determine what components are currently frozen

●   

Simultaneous Retrieval of Components and Graphics

Pro/ENGINEER now displays the graphics of each component in the
graphics window during retrieval of the assembly.

●   

Specifying Joint Axis Limits during Component Placement

You can now set joint axis settings when you are defining component
placement, making it easier and simpler to limit the motion of components

●   



within Assembly mode.

Top-Down Design with Mechanism Assemblies

Enhanced skeleton models now support motion so that you can create an
assembly using top-down design techniques and connections.

●   

Undo and Redo Support for Assembly Operations

Undo and Redo are now available in Assembly mode for all of the general
assembly operations and commands.

●   



Product What's New

Cabling Design

Hierarchal Cables

You can now use the hierarchal nature of multilevel cables of Routed
Systems Designer within Cabling Design.

●   

New Harness Manufacture Configuration Option

A new configuration option allows you to control if parent connectors are to
be assembled during the creation of flattened harnesses.

●   

Start Parts for Cabling Design

The new start part option for the creation of 3D and flattened harnesses
enables you to store predefined views and parameters in a template part. In
addition, three new configuration options are available.

●   



Product What's New

Detail Drawing
3D Section Display in Drawings

In Pro/ENGINEER Wildfire 3.0, drawing views can display 3D sections
(zones) from models.

●   

Activate Layer

Now you can set a layer to be active and all layer-able entities created from
that point forward will automatically be added to that layer.

●   

Align Angular Dimensions

Angular and linear dimensions can now be aligned at the same time.

●   

Attach Geometric Tolerances to Leader Elbows

New placement options for geometric tolerance attachment have been added
to support ISO and JIS standards.

●   

Automatic Annotation Display in Drawings

Maximize the value of detailing your 3D models. When you create a
drawing view of a model with 3D annotations, they are automatically shown
when appropriate.

●   

Automatic Clipped Dimensions

We've added a new way to create clipped dimensions in Pro/ENGINEER
Wildfire 3.0 and improved the ability to create small, acute, angular
dimensions.

●   

Chamfer Dimension Witness Lines

Now when shown chamfer dimensions are repositioned, a witness line will
automatically be created.

●   

Create Snap Lines Offset 2D Entities

Snap lines can now reference 2D draft entities in drawings.

●   

Dependent 3D Cross Section Views

By default, when a new view is created that is dependent upon a view using
a 3D section, the dependent view's section will be linked to its parent's
section setting.

●   

Detailing 'On-Item' Note Position Enhancements

Detailing has been enhanced enabling users to control the vertical and
horizontal justification of On-Entity notes.

●   

Drawing Template Improvements●   



Drawing templates now support 3D sections and combination states, and
they provide better scaling options.

Exact Placement Updates

We've improved Move Special and enabled symbol placement at exact
coordinates in Pro/ENGINEER Wildfire 3.0.

●   

Excluding Datum Curves from HLR Calculations

You can exclude datum curves from hidden line removal calculations. This
helps to improve performance in large drawings.

●   

Export Drawing Tables as CSV Files

We've added a new option during Save Table operations that allows
Pro/ENGINEER drawing tables to be exported as CSV files.

●   

Flip Arrows Command for Diameter and Radius Dimensions

Diameter and Radius dimensions now each have a Flip Arrows style.

●   

Geometric Tolerance Display Options

New dtl setup options have been created to enable users to ensure geometric
tolerances can be created according to ISO and JIS standards

●   

Horizontal Text for Radius Dimensions

Now radius dimensions with parallel extension lines can be shown with a
horizontal text orientation.

●   

Improved Dimensioning for Unfolded Views

The allowed attachment references for dimensioning unfolded views has
been expanded.

●   

Improved Ordinate Dimensioning

You can now directly create ordinate dimensions, add dimensions to an
existing ordinate dimension, and group or redefine the attachment of
ordinate dimensions.

●   

JIS Ordinate Baselines

Ordinate baselines have been improved to better support JIS standard.

●   

JIS Thread Display in Drawings

We've improved the display of thread features in drawings to better support
JIS standards.

●   

New Display Options for Per Unit Tolerances

We've added several new display options for flatness geometric tolerances.

●   

On Item Text Placement Improvements

We've added functionality to help users align text that is placed using the
''On Item'' placement type.

●   

Parametric Draft Fillets and Chamfers●   



Improved sketching in drawings includes the ability to create draft fillets and
chamfers that are parametric to model edges.

Part Simplified Representations in Drawings

In response to an overwhelming number of enhancement requests, we've
added support for part simplified reps in drawing views.

●   

Reduced File Size of Merged Drawings

An internal process reduces the size of the final drawing when two drawings
are merged.

●   

Set Datum Attachment to Gtols

Enable attachment of set datum tags to geometric tolerances in models and
drawings.

●   

Shaded Views in Drawings

You can now include shaded views of models in drawings. This capability
improves plotting drawings with OLE objects and shaded views.

●   

View Manager States for Drawing Views

You can reuse all states created in 3D models to help configure drawing
views.

●   



Product What's New

ECAD
Streamlined Board Import and Export

Side menus for the import and export of ECAD data have been consolidated
into a single dialog box.

●   

Streamlined Creation of ECAD Areas

An ECAD Area dialog box for the creation of ECAD areas consolidates the
previous side menus.

●   

Updated Default Setting for Importing Holes

The default value for the configuration option
ecad_import_holes_as_features has been changed from NO to YES.

●   



Product What's New

Fundamentals & Pro/PROGRAM
Improved Chain & Surface UI

Within feature tools, customers can define the chain of edges or set of
surfaces for the feature. Customers now have a more streamlined dialog to
define these references.

●   

Restricted Parameter Names and Values

By specifying an external file, you can define restricted parameter names
and values. When adding these parameters using the Parameters Dialog, you
are required to select from a list of values or to define a value within a
specified range.

●   

Separate Layer Dialog

Customers can now set a config.pro option to allow a floating layer dialog.
This has been reintroduced back into Pro/ENGINEER Wildfire 3.0 as one of
the top enhancement requests.

●   



Product What's New

Manufacturing (NC, Expert Machinist)

3D Equidistant Finishing

A spiral finish with constant step over on surface is now possible.

●   

Assembly Step in Process Manager

With a new assembly step, you can assemble other components within a NC
process and use them to continue the NC process.

●   

Automated Setting for Manufacturing Model Accuracy

An automated setting for absolute accuracy for the manufacturing model is
now available.

●   

Automatic Filleting of Corners

For high-speed machining, you can automatically generate corner filleting.

●   

Compliance Checking in the Manufacturing Process

The Process Manager shows a status for each NC step and each operation.

●   



Control of Slowdown in Corners

Better control of slowdown of the feed in corners is available for roughing
toolpaths.

●   

Creation of Datum Features in Mold and NC

The tools from Part mode for creating Datum features are now accessible in
Mold and NC.

●   

Custom Cycle Improvements

The custom cycle descriptions for defining cycle motions have been
enhanced.

●   

Custom Cycles for Drilling

Custom cycles for drilling are fully supported within the Manufacturing
Process Manager.

●   

Customization of 3-Axis Trajectory Toolpath

New options improve the customization for the 3-axis trajectory and provide
more control on the tool tip selection and spindle orientation.

●   

Export and Synchronize the Manufacturing Step Table
●   



You can export the Step Table to a CSV format for manipulation in an
external application and then synchronize the result with the Process
Manager.

Finishing Toolpath Enhancements

More options have been added to control the finishing toolpath behavior.

●   

Global Parameters and Global Relations

You can create a single, global parameter or global relation that applies to all
steps of a NC process.

●   

Grouping Steps for the Same Behavior

Independent NC steps in a complete process can be defined to include the
same behavior. Any change to a behavior is done on each member of a
group for each step.

●   

Improved Time Computation in Machining

Time computation now takes into account cutting time, approach, exit, and
connection times.

●   

Machine Tool Manager User Interface

The Machine Tool Manager has been redesigned with an intuitive user
interface to simplify tool definition.

●   



Manual Cycle in the Manufacturing Process Manager

A manual cycle can be used in manufacturing templates.

●   

Manufacturing Annotation Features and Extraction

Manufacturing information, such as steps and Annotation features, can be
assigned to the design models with a template and extracted.

●   

Manufacturing Operation Model

Instances of the workpiece are created automatically with the removal of
material in the manufacturing process.

●   

Manufacturing Process Template

A complete process intent can be captured in a manufacturing process
template that can be reproduced to create a new process.

●   

Manufacturing Step Dependencies

Allowing user-defined dependencies between steps helps control reordering.

●   

Manufacturing Step Locking

You can lock and unlock any steps so that the steps cannot be modified by
accident.

●   



Manufacturing Template Replacement during Extraction

During extraction, you can extract manufacturing templates other than those
stored in the design model.

●   

Mirror Toolpath

With added functionality for the milling NC sequence feature, you can
mirror a toolpath while keeping the cutting condition.

●   

Model Views and the Process Manager

The Model View displays manufacturing templates in the design model,
grouped according to the Z-axis orientation and the manufacturing criteria. It
facilitiate the creation of a process plan during extraction in the Process
Manager.

●   

Mold and NC Geometry User Interface

Modern user interface tools for manufacturing, mold volume, and surface
definition have been implemented.

●   

Process Manager Usability Improvements

Several usability improvements increase your productivity when using the
Process Manager.

●   

●   



Step Depth for Area Turning

A new computation technique for step depth in area turning is available.

Support for Gang Tools

Special Gang tools for production machining are available in NC
Manufacturing to combine NC drilling steps.

●   

Time Analysis for the Manufacturing Process

Tools for time analysis help optimize a NC process.

●   



Product What's New

ModelCHECK
Improved ModelCHECK Support for 3D-Drawings

New checks have been added to core ModelCHECK for Annotation Features
to help companies validate and confirm these features are not left in a state
of incompleteness.

●   

Improved Usability of the ModelCHECK Configurator

The ModelCHECK Configurator, introduced in the previous release to make
it easy to create, find, and edit ModelCHECK files to meet company
standards and best practices, has been enhanced in Pro/ENGINEER Wildfire
3.0.

●   

ModelCHECK Toolkit Provides for Custom Checks

With ModelCHECK you can now develop your own custom checks.

●   



Product What's New

Other Functional Areas
Additional Language Support for Pro/ENGINEER on Linux

Responding to the growing demand from global Linux users,
Pro/ENGINEER Wildfire 3.0 offers additional language support.

●   

Auto Propagate Strong AE Point References

Automatically propagate datum points that are defined as strong AE
references to data sharing features.

●   

Autodetection of a Windows Locale

Pro/ENGINEER and PTC.Setup have been enhanced to detect the system
default locale on Windows and attempt to run Pro/ENGINEER in that
locale.

●   

Cross Section Analysis

The Section Analysis tool has an option to automatically span the selection
set with cross sections at a defined spacing for analysis.

●   

Cut, Copy, and Paste in Sketcher

Sketcher now uses the Microsoft cut, copy, and paste operations for
consistency with Pro/ENGINEER.

●   

Difference Report support of 3D Drawings

The Pro/ENGINEER Wildfire 3.0 difference report now includes the ability
to analyze and determine the difference between two versions of the same
part for Annotation Features, their Annotation Elements and Annotations.

●   

Draft Analysis and Color Display

Draft Analysis enhancements to color display provide three-colors with
control over the transition between color regions.

●   

Entering Sketcher without a Clear Orientation Reference

After you select a sketching plane, you can enter Sketcher mode even if no
default orientation reference exists.

●   

Highlight Sketcher Entity Improvements when Explaining Constraints

Sketcher entity highlighting has been enhanced, improving awareness of a
particular constraints defined geometry and references when a user has
selected to explain a constraint.

●   

Improved Parameter Table Interaction for Restricted Parameters

The parameters table has been enhanced to allow for auto-complete input, as
well as, name filtering for all restricted parameters specified in an external

●   



parameter file.

Improved Sketcher Performance with Large Sections

Sketcher performance has been drastically improved when dealing with
large sections of more then 40 entities and when adding additional entities.

●   

Improved Undo/Redo View Orientation in Sketcher

The undo/redo view orientation in sketcher has been improved, providing
users with more control over sketcher commands and action sequences
during an undo/redo operation.

●   

Locked Dimensions in Sketcher

Locked dimensions in a sketch remain locked after completing the sketch in
Sketcher and throughout the design of a model.

●   

Measure User Interface

The Measure user interface now conforms to the Pro/ENGINEER user
model.

●   

New Sketcher Palette

With the new Sketcher palette, you can capture common shapes and sections
for reuse in future sketches without having to recreate them.

●   

Set Up of Sketching Planes and Orientation References in Sketcher

With the improved creation and modification workflow for Sketcher, you
can directly modify the setup of a sketch and orientation references.

●   

Sketched Text Positions

Sketcher has been enhanced for control of the vertical and horizontal
justification of sketched text.

●   

Support of OpenType Fonts

With Universal Font Scaling Technology 4.7, you can use and place
OpenType Fonts for multi-language support in all areas, including Sketcher
and drawings.

●   



Product What's New

Part Modeling
3D Quick Print

Quickly create drawing layouts and plot directly from the 3D environment.

●   

3D Set Datum Tags on Surfaces

We've implemented a new option for displaying set datums in 3D. Users can
now place ASME Y14.41 style set datum tags on surfaces.

●   

Annotation Feature and UDF Interaction

Users can now add annotation features to UDFs. Users can choose to vary
surface finish values, geometric tolerance values, or driven dimension
tolerances.

●   

Annotation Features in UDFs

You can select Annotation features for inclusion in user-defined features.
Annotation features and Annotation Element parameters and some
annotation values can also be marked as variable items in the feature
definitions.

●   

Curved Patterns

The Curve option on the Pattern dashboard allows you to create instances of
a feature along a sketched curve.

●   

Data Sharing Dashboard

The Data Sharing dashboard modernizes the user interface and consolidates
the Merge, Cutout, and Inheritance features.

●   

Defining the text direction for annotations

When placing annotations, users are presented with the default text
direction. This can be changed using default angle selections or by entering
an angle.

●   

Dependant Copy Enhancements for Annotation Features

When creating dependant copies of annotation features, the annotations
included will also be dependant. Dependant behavior of annotations is
limited to text input, text style, color, and parameters.

●   

Enhancements to Asynchronous Datum Creation

Datums created during other feature creation tools will be embedded into the
feature. Users can embed datum axis, datum points, datum planes, and
datum coordinate systems.

●   

Enhancements to the Annotation Feature User Interface●   



Enhancements to the annotation feature interface include having the ability
to enter descriptions for the references selected, to replace references using
the right mouse button, and to define the text direction of the annotations.

Fully Dependent Copied Features

The fully dependent and associative type of copied feature offers significant
flexibility by making the copied set of features dependent on the source in
varying degrees.

●   

ISO Tolerance Table Verification

We've added a check to validate automatically assigned ISO dimension
tolerance values.

●   

Improved Copy, Paste and Paste Special Tools

Copy and paste or paste special has been improved to include a number of
workflow improvements including the concept of a clipboard to allow a
repeated paste operation.

●   

Materials Capabilities Improved

Materials capabilities have been dramatically improved with a new Materials
dialog box for defining materials and a completely overhauled library.

●   

Minimize Overlap of Copied Annotations

The position of annotation elements during copy/paste special, group
pattern, or UDF placement operations has been adjusted to minimize
overlap.

●   

Orientation and Projection of Fill Pattern Members

The enhancements to Fill Patterns offer the ability to project and orient fill
pattern members onto surfaces.

●   

Parameter Enhancements

With enhancements to parameters, you can quickly and easily complete such
operations as converting units of parameters.

●   

Partial Shells

The Shell tool can now exclude surfaces when you hollow out a solid to
create a partial shell.

●   

Pattern Tool Enhancements

The Pattern tool offers significant enhancements, including the preview of
patterns, roll back of features, and many other additions.

●   

Placement of User-Defined Features

The User-Defined Feature (UFD) tool streamlines workflow, offering
increased flexibility and capabilities for placement of UFDs in a modern
user interface.

●   

RMB Actions for Moving and Rotating Annotations●   



Users can now easily move and rotate the text direction of annotation after
selecting the annotation element from the model tree.

Swept Blend Dashboard

The new Swept Blend tool uses a smooth-flow workflow with a dashboard
user interface.

●   

Updates to Surface Finish Annotations

Now it is possible to collect surface finish reference surfaces separately from
the symbol attachment reference in 3D. We've also enabled advanced
selection for surface finish annotation elements in annotation features.

●   



Product What's New

Piping (Spec Driven & Non-Spec Driven)

Designated Reports

Piping Design takes advantage of the report designation functionality
available in mechanical piping.

●   

Non-Breaking Fittings for Pipelines

Fittings that do not break the pipeline can now be inserted using Piping
Design.

●   

Routing Continuous Fittings

Using Piping Design, you can now route a series of fittings prior to routing a
pipe centerline.

●   



Product What's New

Rendering
Direct Manipulation of Lights

The way that users interact with lights has been completely overhauled
within Pro/ENGINEER Wildfire 3.0

●   

LWA Material Archive Support

Lightworks LWA material archives are now supported in Pro/ENGINEER
Wildfire 3.0

●   

Material Editing

The ability to edit parameters of the advanced material shaders used with the
Advanced Rendering Extension (ARX) has been added for Pro/ENGINEER
Wildfire 3.0.

●   

Rendering Scene File

Rendering Scene files have been added to Wildfire 3.0 allowing users to
save the render room, lighting and environment settings to a single file.

●   



Product What's New

Sheetmetal Design and Manufacturing

Consolidated Cut and the Both Sides Option

The sheetmetal cut is consolidated with the solid Cut.

●   

Multiple Walls Using the Flange Tool

The Flange tool can create multiple walls when you select multiple,
nontangent edges.

●   

New Unattached Extruded Wall User Interface

The Unattached Extruded wall feature has been consolidated with the Core
Extrude feature into a new user interface.

●   

New Unattached Flat Wall User Interface

The Unattached Flat Wall feature has a new dashboard interface.

●   

Sheetmetal Reports

The Sheetmetal Info reports are consolidated within the Model Info report.

●   



Product What's New

Simulation - Mechanism Design &
Dynamics

Family Table Parameters for Joint Axis Limits

Use the Joint Axis Limits parameters in Family Tables to vary motion limits
in assembly instances.

●   

Mechanism Body Folder in Assembly Mode

View the mechanism body definition of an assembly in the new split Model
Tree within Assembly mode.

●   

Mechanism Operations Enhancements

The redesigned Mechanism operations are integrated with the workflow and
are consistent with the user interface in Assembly mode.

●   

Slot Connections in Assembly Mode

Mechanism slot connections can now be defined as an Assembly connection.

●   

Support for Flexible Components in Kinematic Assemblies

Pro/ENGINEER Assemblies with packaged components can now be
kinematically dragged in real time with flexible components, such as springs
and pipes, that fully constrain the assembly.

●   



Product What's New

Simulation - Structural & Thermal
ANSYS Solver Improvements

More modeling entities are output to the ANSYS solver in FEM mode.

●   

Advanced Springs

More capabilities have been added to advanced springs.

●   

Automatic Creation of Contact Regions

Contact regions can now be automatically created between a set of selected
parts in an assembly.

●   

Contact Definition Improvements

Contact definition and editing has been simplified.

●   

Control of the Spin Center in a Result Window

The spin center of a model can be toggled on and off in a result window.

●   

Copy and Paste

Simulation modeling objects can be copied and pasted.

●   

Design Study User Interface

The definiton of design studies has been dramatically improved with a new
user interface.

●   

Exploded Views

Exploded views are now available when defining your simulation model.

●   

Heat Loads on Volumes

Heat loads can be assigned to volume regions of of parts and assemblies in
Simulation.

●   

Hide and Unhide

With the Hide and Unhide commands, you can control the display of
simulation objects.

●   

Inertial Relief

Inertial relief is now supported as an analysis option in Mechanica.

●   

Legend Customization

Customization of legends in result windows is not affected by editing the
window.

●   

Materials Now Meet Requirements in Simulation

Materials in Pro/ENGINEER have been enhanced to support requirements in

●   



Simulation.

Mechanica on Linux

Mechanica is supported on Linux.

●   

Meshing More Robust

Both the AutoGEM and FEM meshers have improved robustness.

●   

Midsurface Modeling in FEM Mode

Modeling midsurfaced assemblies has been simplified in FEM mode.

●   

Multiple Selections for Deletions

Multiple selections are now valid for the Delete command.

●   

New Material Assignments

More flexibility is possible when you assign new materials to Simulation
parts and assemblies.

●   

Previewing Models before Output to FEM Solvers

An option to display the model before output to FEM solvers has been added
to the FEM Solution dialog box.

●   

Process Guide Wizard for Mechanica

The Process Guide, a user-customizable wizard for Mechanica, can be used
with the standard user interface.

●   

Query Labels

Dynamic query labels rotate with model.

●   

Removal of 8-GB Memory Limit

The 8-GB memory limit on 64-bit operating systems has been removed for
Mechanica solvers.

●   

Rigid Connection Improvements

Defining and editing rigid connections is easier.

●   

Rigid and Weighted Links for FEM Mode

Rigid and weighted links have been enhanced for FEM mode.

●   

Spot Weld Improvements

Spot weld definition and display has been improved.

●   

Spot Welds in FEM

FEM mode now supports spot welds.

●   

Tolerance Report

The tolerance report has been enhanced to display not only the model
tolerance but also the current accuracy setting.

●   

Weighted Links●   



Weighted links capability is now available.



Product What's New

Surfacing - ISDX
Circle and Arc Tools for Primitive Shapes

Two new curve creation tools approximate circles and arcs.

●   

Copying and Moving Curves

The enhanced Move and Copy commands provide for rotation as well as for
scaling of curves.

●   

Creating a Curve on Surface

You can create a Curve on Surface (COS) by intersecting either two surfaces
or a surface and a plane.

●   

Drafted Curve and Surface Connections

The Draft Tangent option for both curves and surface allows for connections
with draft to a plane or a surface.

●   

Offset Curve Enhancements

You can now create offset curves from free and planar curves as well as
from curves on surfaces.

●   

Redefinition of Internal Datum Planes

Datum planes created internally to a Style feature can now be redefined.

●   

Single Approximate Curves

Using keyboard shortcuts with the Curve from Datum command, you can
create a single approximate curve from a chain of curves and edges.

●   

Smart Curve Connections for Surfaces

When connecting surfaces, you can now consider relevant connections by
responding to system prompts for ''smart'' connections.

●   



Product What's New

Surfacing - Restyle
Symmetry Plane

The ability to locate a plane of symmetry relative to facet geometry has been
added to the Restyle feature for the Wildfire 3.0 release.

●   



Product What's New

Surfacing - WARP
Lightweight Preview for Warp Features

With the Facet Preview option, you can easily preview Warp features for
large datasets.

●   



Product What's New

Welding
Light Weld Feature Enhancements

Several enhancements to the Light Weld feature improve performance and
use of light welds.

●   
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