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Pro/CABLING 

Using Pro/CABLING 

About Pro/CABLING 

Use the Pro/CABLING module to define 3D cable harnesses in Pro/ENGINEER 

assemblies. In Pro/CABLING, you can route cables concurrently with the design and 

assembly of electrical and mechanical components. 

 

A Harness Part Within an Assembly 

If you use Pro/DIAGRAM to create two-dimensional schematic representations of 

electrical assemblies, you can use the logical reference capability in Pro/CABLING 

and Pro/DIAGRAM to compare logical connections and parameters in both modules. 

To enter the Cabling mode, click Applications > Cabling in the Pro/ENGINEER main 

menu. 

Using the Cabling Workflow 

This workflow is a sample of the basic steps used to create a cabling assembly. In 

the assembly design, use Applications > Cabling. You can perform the following 

operations in Pro/CABLING: 

• Create a Harness Part 

Use CABLING > Harness > Create to create a new harness part. The harness 

part is a .prt file and is a part of the assembly, but cannot be opened as a 

separate part. A harness part cannot be opened in the Part mode. For 

manufacturing output, the part is extracted from the assembly and represented 

as flattened. 
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The new harness is the active harness or work harness as shown in the lower 

right corner of the graphics window. You can create more than one harness in an 

assembly. Only one harness is active at a time. You can only select and edit cable 

entities of the active harness in the cabling assembly. Any item you create is 

saved to the active harness. 

• Read in a Logical Reference (Optional) 

Use CABLING > Logical Ref to read in a file if you are using a logical reference 

from Pro/DIAGRAM or another formatted wire list. A logical reference can pass 

spools, wires, and cables with preset parameters and values from the diagram to 

the cabling database. 

• Add Spools to the Database 

Use CABLING > Spools > Create to either add new spool definitions to the 

database or read them in from your logical reference. Use Create > From 

Logical to bring in selected spools from the logical reference that you have 

specified. 

• Designate Components 

Use CABLING > Components > Designate to designate 3D parts in the 

assembly as connectors. This procedure adds parameters to the definition of the 

components such that the components become the start and end point of the 

cables. If a diagram connector is referenced to a part in the assembly with a 

model_name parameter, the referenced model can be automatically designated as 

a connector. 

• Create Wires and Cables 

Use CABLING > Feature > Create > Wire or Cable to add wires and cables to 

the harness. These wires and cables are added to the database and not physically 

added to the design. If you are importing a logical reference, you can use the 

From Logical command to import cables, else you are prompted to type a new 

wire or cable name. If you are importing a cable, the conductor properties of the 

cable are also imported, if they are not then you must define them. 

• Route or Autoroute Cables between Locations 

If you are routing manually, you can begin adding a routed cable to the harness 

as soon as you have created it in the database and defined its conductors. Use 

the CABLING > Route command to define a point-by-point path of locations 

that the cable follows as it is added. Locations can be fixed, offset, or dependent 

on other locations, to capture the design intent of the cable in case of changes in 

the assembly. Offsetting a part of the network, offsets all the locations on the 

network. 

Alternatively, you can use autorouting for larger wire lists. To autoroute, use the 

CABLING > Network Ops command to add a network of locations between the 

components that will be connected by the harness. When the network is 

complete, you can autoroute the entire wire list. 
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Configuring Pro/CABLING 

About Configuring Pro/CABLING 

You can set environment options by specifying config.pro configuration file options 

and their values in the Options dialog box (Tools > Options). For example, the 

align_cable_bundles option allows you to align newly-created bundles where they 

meet or branch out. Setting the auto_xml_on_save option automatically creates an 

XML Logical Reference when saving a cabling assembly. 

In the Options dialog box, in Current Session, under the Electromechanical 

category, a list of configuration options is available in alphabetical order for 

CABLING, DIAGRAM, and HARNESS. Each option contains the following information: 

• Configuration option name 

• Default and available variables or values. All default values are in italics. 

• Brief description and notes describing the configuration option 

Note: After you set the configuration options, all settings take effect immediately in 

the current Pro/ENGINEER session. 

To Set Pro/CABLING Configuration Options 

1. Click Tools > Options. The Options dialog box opens. 

2. Select By Category in the Sort box. 

3. Select Current Session in the Showing box. 

4. Clear the Show only options loaded from file box to see all configuration 

options or to see configuration options that are available for the current session. 

5. In Current Session, select the Electromechanical category. A list of 

configuration options arranged in alphabetical order for CABLING, DIAGRAM, and 

HARNESS appears. 

6. Select a Cabling-specific configuration option from the list or type the valid 

configuration option name in the Option box. 

7. When you select a configuration option from the list, its corresponding value 

appears in the Value box. Modify this value. 

or 

Type a new value to be assigned to the configuration option in the Value box. 

Note: The default value is followed by an asterisk (*). 

8. Click Add/Change. The configuration option and its value appear in the list. The 

status of the configuration option changes to . 

Note: The Add/Change option is enabled only when you change the 

configuration option name or the value of an existing configuration option or type 

a value for a new configuration option. 
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9. When you finish configuring Pro/CABLING, click Apply or OK. 

Note: It is recommended that you set the Pro/CABLING configuration options before 

starting or opening a new cabling assembly. 

align_cable_bundles 

yes,no 

Aligns or unaligns newly created bundles at a point where they meet or branch out. 

By default, the bundles are aligned. If not, ensure that this option is set to yes 

before creating a network. 

Note: Only the new bundles that are created after setting this configuration option 

will be aligned. 

autoroute_path_param_name 

USE_PATH 

Sets the wire parameter to be used while selecting a path during autorouting. 

auto_xml_on_retrieve 

no, yes 

Automatically loads Cabling Logical Reference from a XML file when retrieving the 

cabling assembly. 

auto_xml_on_save 

no, yes 

Automatically creates an XML Logical Reference when saving a cabling assembly. 

cable_int_portions_for_clr 

no, yes 

no—Global clearance check for internal cable portions is excluded. 

yes—Global clearance check for internal cable portions is included. 

display_internal_cable_portion 

no, yes 

If yes, internal cable portions are displayed for wires that have been manually set to 

yes in the Cable Paths Setup dialog box for each individual splice and custom 

component. This option can be overridden in the Environment dialog box. 
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display_thick_cables 

no, yes 

Sets the default startup mode. 

yes—Displays thick cables and wires. 

no—Displays centerlines of wires and cables only. 

You can override this option in the Cabling mode using the Environment dialog box, 

Model Display dialog box, or by selecting Thick Cables from the menu bar. 

full_hlr_for_cables 

full, partial, none 

If set to partial or none, some lines that should be hidden behind cables are visible 

in the wireframe mode. Using the Model Display dialog box, under the Edge/Line 

tab, you can set the Cable HLR options for the current session. 

full—Removes hidden lines from view when cables hide other geometry. Use when 

the Display Style is Hidden Line in the Environment dialog box. 

partial—Cables hide other non-interfering cables except when cables route 

together between same locations. 

none—Display hidden lines (faster) that should be hidden behind cables or wires. 

Note: Effects of using this configuration option are visible only in the hidden-line 

display mode. Helps speed up the display of hidden lines, but at the loss of some 

quality. 

harn_tang_line_display 

yes, no 

Display the tangent lines between the segments of a cable in the Thick Cable Display 

mode. 

multipoint_location_count 

1 

Specifies the maximum number of cable locations to allow in one feature. To create 

locations as features, set this configuration option to 1. To limit the number of 

locations in one feature, set to a number between 2 and 100. The suggested number 

of locations in one feature must range from 10 to 20. If you set the number of 

locations to be greater than 1, then up to the specified number of locations are 

created in one feature. Features with multiple locations are automatically created 

during routing. 

Note: If a single feature has several locations, you can only suppress or reorder 

them all together. 
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pro_spool_dir 

<home directory> 

Sets the default directory from which the spools are retrieved by default. Use the full 

path name, for example: /home/users/spools. 

The current working directory is the default directory. 

pro_cbltrm_dir 

<home directory> 

Sets the default directory from which terminators are retrieved by default. Use the 

full path name, for example: /home/users/terminators. 

The default is the current working directory. 

update_pre_16_cable_layers 

no, yes 

Updates the pre-release 16.0 harnesses. 

If yes, automatically updates the harnesses containing cables routed prior to Release 

16.0 when retrieved to comply with new display standards. 

fan_with_network 

yes, no 

If yes, the network is visible in flat harness. 

Cable-specific Display Setups 

About Setting Up the Pro/CABLING Display Environment 

You can set up the Pro/CABLING display environment in the following ways: 

• Using the configuration options. 

• Using the Environment dialog box. 

Use the following options from the Environment dialog box to change the 

Pro/CABLING display settings: 

• Thick Cables or Centerline Cables—Shows cables with true width or as 

centerlines. Centerline shows the cable’s centerline with defining location points. 

Mass property calculations are performed using the correct thickness regardless 

of the display state. 

• Internal Cable Portions—Determines if all cable portions inside the splice and 

custom components are displayed. 

• Reference Designators—Determines if the reference designator for the 

component is displayed. 
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Note: You can also access these options directly from the menu bar. 

• Use Fast HLR (Hidden Line Removal)—Displays hidden lines while spinning and 

reduces time to compute HLR. 

Note: The display style must be set to Hidden Line in the Environment dialog box. 

To Display Cables as Thick or Centerline 

1. Click Tools > Environment. The Environment dialog box opens. 

2. Select either Thick Cables or Centerline Cables. 

3. Click Apply and then OK to close the dialog box. 

Note: You can also access the Thick Cables, Centerline Cables, and Reference 

Designator options directly from the menu bar in the Cabling mode. 

or 

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. Click the Edge/Line tab. 

3. Under Cable Display, select either Thick Cables or Centerline Cables. 

4. Click Apply and then OK to close the dialog box. 

Note: To manually route cables, select Centerline Cables. 

Displaying Hidden Lines 

Hidden lines are drawn lines that appear behind other objects in a 3D view. When 

you set the display style to Hidden Line, the hidden lines appear behind solid 

objects, but are displayed in grey. When you set the display style to No Hidden, 

lines behind the solid objects are removed from the display. 

Cable HLR is available only if the display style is set to Hidden Line in the 

Environment dialog box. 

The cable is hidden by geometry and can also hide other geometry, depending on 

the setting for the FULL_HLR_FOR_CABLES configuration option. 

Note: Hidden line display does not always work as expected. In cases where cables 

physically intersect a part or another cable, the entire cable may be incorrectly 

displayed. This condition indicates cable routing interference. 

To reduce cable interference, additional locations can be added. If you use routing 

commands,such as Use Dir or Along Axis, greater control is provided over cable 

tangency at selected locations and the possibility of interference between cables is 

reduced. 
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Other Cabling Hidden Line Display Options 

Use the View > Display Settings > Model Display command to display the hidden 

lines of a cable. The following options are available under the Edge/Line tab in the 

Cable HLR (Hidden Line Removal) box to display the hidden lines of a cable. 

• Full—Cables are hidden by other objects and hide other objects and wires within 

harnesses. 

• None—Hidden lines are displayed and the overall display process is faster. 

Cables are hidden by other objects, but do not hide other objects or hidden 

cables within the harness. This is the most recommended method. 

• Partial—Similar to Full, but does not perform calculations within the harness. 

About Cable Colors 

Cable or wire spools contain parameters such as name, type, color, gauge, and so on 

for a single insulated conductor. Cable spools contain parameters for a specific 

number of conductors and property descriptions for each conductor in the cable. 

Using the cable's spool file, you can set a default color for a cable. The value of the 

COLOR parameter for a cable or wire specified in the spool file appears in the Color 

and Appearance dialog box. Cables can be created using the spool parameters 

specified in the cable's spool file. You can retrieve the cable color and appearance 

data from the .dmt or .map files. 

Note: The .dmt and .map files must exist in the directory from where you start 

Pro/ENGINEER. Ensure that the color that you assign to the cable exists in the 

color.map file. 

If the COLOR parameter for the spool is not defined or if you want to override the 

default value of this parameter, use the Color and Appearance dialog box to 

update the color of a selected cable. If you edit the color of a cable using the Color 

and Appearance dialog box, all cable segments created from its spool are also 

updated with the new color. Cables created from the spool after editing the COLOR 

parameter use the new color. However, the new color is local to the design file and 

the value of the COLOR parameter is not updated in the spool file. By default, the 

system color "Letter" is applied to the wires or cables that have unknown color 

assigned to it. 

Save the new colors that you have added to the appearance palette in the Color and 

Appearance dialog box as a .dmt file. 

To Switch Model Color Display 

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. Click the General tab. 

3. Under Display, select Colors. The model is displayed with colors. 

4. Click Apply and then OK to close the dialog box. 



Pro/CABLING 

9 

or 

1. Click Tools > Environment. The Environment dialog box opens. 

2. Under Display, select Colors. The model is displayed with colors 

3. Click Apply and then OK to close the dialog box. 

To Display Cable Portions Inside Components 

1. Open a harness part in the Assembly or Harness-Mfg mode. 

2. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

3. Click the General tab. 

4. Under Display, select Internal cable portions. The internal cable portions 

routed through splices and components are globally displayed for wires that have 

Show set to Yes in the Cable Paths Setup dialog box 

5. Click Apply and then OK to close the dialog box. 

or 

1. Click Tools > Environment. The Environment dialog box opens. 

2. Under Display, select Internal Cable Portions. 

3. Click Apply and then OK to close the dialog box. 

Cabling Drawing Setup Options 

 

Command Description 

ref_des_display Sets whether the reference designator is to 

be displayed or not: 

When set to yes, the reference designator is 

displayed on connectors in a cabling or flat 

harness assembly. When set to no, the 

reference designator is not displayed on the 

connectors in the assembly. 

show_cbl_term_in_region Allows use of the report symbols 

&asm.mbr.name and &asm.mbr.type to show 

terminators in Pro/REPORT tables for cable 

assemblies having connectors with 

terminator parameters. 

Shows terminators if set to yes and if the 

Cable Info attribute is set for the repeat 

region. When creating new drawings, the 

default value is yes. For existing drawings, 

the default value is no. 
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Logical Referencing to Pro/DIAGRAM 

About Logical Referencing 

Use the CABLING > Logical Ref command to reference Pro/DIAGRAM information 

directly in Pro/CABLING. This information includes the reference designator, pin-to-

pin connection information, and parameter values of connectors, pins, spools, wires, 

and cables. You can reference the whole diagram or only items on selected layers. 

You can also autoroute wires and cables, and designate connectors. 

You can also import the same information from an ASCII text file, either in the PTC 

neutral wire list format (.nwf), the Mentor Graphics wire list format, or the Routed 

Systems Designer format (.xml). You can use the information to automatically 

designate connectors and autoroute complete cables. At any point in the design 

process, you can compare logical information with the original wire list or diagram 

reference for accuracy. If you change the diagram later, you must run the Logical 

Ref command again to update the cabling assembly accordingly. 

You must have unique reference designators across the Pro/CABLING assembly This 

is because you perform a logical referencing operation on the entire assembly and 

not specifically with respect to any harness part. 

If you export a logical reference, you can write physical data of the wires, 

connectors, and components in your assembly to a file, for analysis purposes in other 

systems. 

On comparing the current logical information with the referenced data, the output 

can be displayed on the screen or written to a file. 

You can update the parameter data from the referenced data. All specified spools, 

connectors, and wires in the assembly are updated. For example, if you change the 

characteristics of a spool in your referenced data, you can automatically update the 

information in Pro/CABLING using the Update command and selecting the spool 

from the list of mismatched objects. 

To Reference a Diagram 

 

1. Click CABLING > Logical Ref > Ref Diagram. The Open dialog box opens. The 

REF DIAGRAM menu also appears. 

2. Choose one of the following REF DIAGRAM commands: 

o Full Diagram 

o Chosen Layers 

By default, you can reference the full diagram. 

3. Select a diagram from the Open dialog box and click OK to reference the full 

diagram. 

4. If you want to logically refer to specific layers in a Pro/DIAGRAM diagram, click 

Chosen Layers and select a diagram from the Open dialog box. You must 
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provide the name of the diagram to be referenced. If no layers are present in the 

diagram, Pro/CABLING displays an appropriate message. Else, Pro/CABLING 

fetches a complete list of layers that are available in the referenced diagram and 

displays them in the Layer Sel menu. 

5. Select one or more layers to be referenced from the list of layers available in the 

referenced diagram or select Select All to select all the available layers. 

6. Click Done Sel. 

Updating Logical References 

Use the Update command in the LOGICAL REF menu to update not only the cable 

or wire parameters, but also the spool, component, and connector parameters for 

any linked logical references.  

Note: Prior to using the Update command, ensure that you again logically refer the 

diagram in order to get to the latest changes. 

About Comparing Data Output 

When you compare model data and reference data, a comparison file is generated. 

This comparison file lists all the items in both the parameter data and the reference 

data. One line is generated for two corresponding items. Additional lines are added if 

the parameter data and the reference data do not match. 

The object of the comparison such as a wire list or diagram is identified as the 

REFERENCE DATA while the active Pro/CABLING 3D assembly is identified as the 

DESIGN DATA in the INFORMATION WINDOW <assembly_name.cmp> window. 

When you select the Compare command on the LOGICAL REF menu to compare 

the design data and the reference data, Pro/ENGINEER compares the following: 

• Spools—A match occurs if the design data and the reference data have the same 

parameters with the same values. If the parameters common to both the 

reference and the design data have the same values, the comparison file 

indicates a subset match, denoted by the word subset in parentheses. The 

spools are identified by the spool names. 

• Connectors and Components—Connectors and components match when they 

have the same parameters with the same values. Connectors and components 

are identified by their reference designators. 

• Wires and Cables—The logical end connections of a wire or cable are matched 

and the cable and wire parameters are compared. A wire is said to be matched if 

it runs between the same connectors and pins, has the same name, and has the 

same parameters with the same values. Wires are identified by the names. 

• Cable Conductors—If you specify cable conductors separately in the reference 

information, their From/To and parameter information is compared. 

You can use the Matched and Alphabetical commands from the LOGICAL REF 

menu to display the details of the missing, unmatched, or matched items, in 

alphabetical order. 
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The Neutral Format Wire List 

NEW CONNECTOR T2 

PARAMETER MODEL_NAME CLEANCONN2 

PARAMETER NUM_OF_PINS 4 

PARAMETER GENDER MALE 

PIN 1 

PARAMETER ENTRY_PORT sys1 

PARAMETER GROUPING ROUND 

PARAMETER INTERNAL_LEN 0 

PIN 2 

PARAMETER ENTRY_PORT sys2 

PARAMETER GROUPING ROUND 

PARAMETER INTERNAL_LEN 0 

PIN 3 

PARAMETER ENTRY_PORT sys3 

PARAMETER GROUPING ROUND 

PARAMETER INTERNAL_LEN 0 

PIN 4 

PARAMETER ENTRY_PORT sys4 

PARAMETER GROUPING ROUND 

PARAMETER INTERNAL_LEN 0 

! Rails 

! Wires and cables 

NEW CABLE CABLE0002 F_SPOOL 

ATTACH T1 "" T2 "" 

CONDUCTOR 4 

ATTACH T1 4 T2 4 

PARAMETER NAME WIRE4 

CONDUCTOR 3 

ATTACH T1 3 T2 3 

PARAMETER NAME WIRE3 
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CONDUCTOR 2 

ATTACH T1 2 T2 2 

PARAMETER NAME WIRE2 

CONDUCTOR 1 

ATTACH T1 1 T2 1 

PARAMETER NAME WIRE1 

! comment 

NEW WIRE_SPOOL <wire spool name> 

PARAMETER <param> <value> 

PARAMETERS <param1> <param2> <param3> 

VALUES<param1 val> <param2 val> <param3 val> 

NEW CABLE_SPOOL <cable spool name> <number of conductors> 

PARAMETER <param> <value> 

PARAMETERS <param1 name> <param2 name> 

VALUES <param1 val> <param2 val> 

CONDUCTOR <id> <optional cond name> 

PARAMETER <param> <value> 

PARAMETERS <param1 name> <param2 name> <param3 name> 

VALUES <param1 val> <param2 val> <param3 val> 

CONDUCTOR <id> <optional cond name> 

VALUES <param1 val> <param2 val> <param3 val> 

CONDUCTOR <id> 

NEW WIRE <wire name> <wire spool name> 

ATTACH <from conn or comp name> <from pin name> <to conn or comp name> 
<to pin name> 

PARAMETER <name> <value> 

PARAMETERS <param1> <param2> <param3> 

VALUES<param1 val> <param2 val> <param3 val> 

NEW WIRE <wire name> <wire spool name> 

ATTACH <from rail name> "" <to conn or comp name> <to pin name> 

NEW CABLE <cable name> <cable spool name> 
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PARAMETER <name> <value> 

PARAMETERS <param1 name> <param2 name> 

VALUES <param1 val> <param2 val> 

CONDUCTOR <id> 

PARAMETER <param name> <value> 

PARAMETERS <param1 name> <param2 name> <param3 name> 

VALUES <param1 val> <param2 val> <param3 val> 

CONDUCTOR <id> 

PARAMETER <param name> < value> 

ATTACH <from conn or comp name> <from pin name> <to conn or comp name> 
<to pin name> 

VALUES <param1 val> <param2 val> <param3 val> 

NEW CONNECTOR <name> 

PARAMETER <param> <value> 

PARAMETERS <param1 name> <param2 name> 

VALUES <param1 val> <param2 val> 

PIN <pin name> 

PARAMETERS <param1 name> <param2 name> 

VALUES <param1 val> <param2 val> 

PIN <pin name> 

PARAMETER <name> <value> 

PARAMETERS <param1 name> <param2 name> 

VALUES <param1 val> <param2 val> 

PIN <pin name> 

PIN <pin name> 

VALUES <param1 val> <param2 val> 

NEW COMPONENT <name> 

PARAMETER <name> <value> 

PARAMETERS <param1 name> <param2 name> 

VALUES <param1 val> <param2 val> 

PIN <pin name> 
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PARAMETERS <param1 name> <param2 name> 

VALUES <param1 val> <param2 val> 

PIN <pin name> 

PARAMETERS <param1 name> <param2 name> 

PARAMETER <name> <value> 

VALUES <param1 val> <param2 val> 

PIN <pin name> 

VALUES <param1 val> <param2 val> 

NEW RAIL <name> 

PARAMETER <param name> <param value> 

To Export a Wire List 

 

1. Click CABLING > Logical Ref > Export. The WIRELIST EXP menu appears. 

2. Click one of the following options to write logical information of the wires, 

connectors, and components in your assembly to a Routed System Designer XML 

wire list file, PTC Neutral wire list file, or the Mentor Graphics Format wire list file, 

 respectively, for analysis purposes in other systems: 

o RS Designer 

o PTC Neutral 

o Mentor Graph 

3. In case of Mentor Graph file output, the output wire list file is written to the 

current directory. To write this file to another directory, at the prompt, type the 

full path including the file name and click . 

Note: Pro/CABLING can output a wire list as a back annotation file for export to the 

Mentor Graphics application. 

To Import a Wire List 

 

1. Click CABLING > Logical Ref > Import. The WIRELIST IMP menu appears. 

2. Click one of the following options to import logical information of the wires, 

connectors, and components in your assembly from a Routed System Designer 

XML wire list file, PTC Neutral wire list file, or the Mentor Graphics Format wire 

list file, respectively: 

o RS Designer 
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o PTC Neutral 

o Mentor Graph 

3. If you select PTC Neutral, you can either select a Routed Systems Designer 

created .xml file or a Neutral Wire List .nwf file using the Open dialog box. If 

you select Mentor Graph, you can select any Mentor Graphics file. 

4. Click OK. 

Creating the Harness Part 

About Creating Harnesses 

Before routing wires or cables in an assembly, you must create a harness. A harness 

is a part file that contains cables and wires within the assembly. When you create a 

harness, it is named and saved as a .prt file, but it can only be accessed within a 

Pro/CABLING assembly. 

However, a harness part can only be accessed in Assembly mode and cannot be 

opened in Part mode. You can output a harness to a drawing view: by selecting a 

harness part and setting it as the active model using Set Model or by selecting a flat 

harness. 

You can create several harnesses in the same assembly. In assemblies with multiple 

harnesses, you can work on only one harness part at a time. The name of the active 

harness is displayed below the assembly name in the graphics window, with the label 

WORK HARNESS. While this harness is active, every feature you add to the cabling is 

added to the active harness part. You can select cabling entities that have been 

added to other harnesses only when the respective harness is active. 

To organize a large design, you can divide the harness into subharnesses. A 

subharness is a subset of a harness part and not a separate file. Subharnesses can 

use all the entities available to a harness, but you can also create them separately in 

Harness Manufacturing mode. 

Use the CABLING > Set Up command to create and edit harness parameters, 

names, notes, and reference dimensions. 

To Create a Harness 

1. Click CABLING > Harness > Create. 

2. At the prompt, type a new harness name and press ENTER. The harness part is 

created and added to the model tree. The newly created harness becomes the 

active harness. 

To Modify a Harness 

 

1. Ensure that a harness is active. 
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2. Click CABLING > Set Up. The HARN SETUP menu appears. 

3. Edit units of measure, harness names, report definitions, notes, parameters, 

terminator tables, or strip tables. Changes affect only the active harness part. 

4. Click Done. 

Using the Harn Setup Menu 

 

You can specify the following options to modify a harness: 

• Units—Determines the length of the harness in units. 

• Name—Sets up a name for the harness. The NAME SETUP menu appears: 

o Component 

o Feature 

o Detail Item 

o Other 

• Report Defs—Sets default values for cable type locations as From/To in report 

tables. 

o Cable Jacket 

o Cable Shield 

o Cable Pin 

o Show Current 

o Notes—Modifies, adds, or removes notes from a cabling assembly. 

o Parameters—Sets up parameters for the harness. 

o Term Table—Accesses terminator table operations. 

o Strip Table—Accesses strip table operations. 

To Delete a Harness 

1. Select the harness part to be deleted from the assembly or from the model tree. 

2. Click Edit > Delete. The harness part is removed from the assembly and all 

cabling data in the harness part is lost. 

Note: Use the Delete command only when you want to completely remove a 

harness and start over or if you have created a harness part and never used it. If 

you do not delete a harness part, it appears as a part in the Bill of Materials. 
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To Set the Working Harness 

1. Click Cabling > Harness. The HARNESSES menu appears. 

2. Select the harness name you want to set as the working or active harness. 

To Copy a Harness 

1. Click CABLING > Harness > Copy Harness. The Open dialog box opens. 

2. Select the harness that you want to copy and click Open. The Open Rep dialog 

box opens. 

3. Select the required representation and click OK. The selected harness with its 

corresponding assembly is displayed in a separate window. 

The Copy Harness dialog box opens and the Select menu appears. 

4. Select a connector in an assembly to which you want to copy the harness 

corresponding to the reference designator of the component or connector in the 

assembly from which the harness is being copied. 

A new reference designator is assigned to the reference model. 

5. Once you have selected all connectors, specify a new harness name in the Copy 

Harness dialog box and click OK. 

The harness is copied to the assembly. 

To Create Datum Features for Harness Parts 

1. Click Insert > Model Datum. 

2. All datum features support harness design. Click an appropriate command from 

the following to specify the datum types. 

o Plane 

o Axis 

o Point 

o Coordinate System 

o Default Coordinate System 

o Sketched Curve 

o Curve 

Refer to the Part Modeling module for details on how to create different datum 

features. 

To Create Subharnesses 

1. Click CABLING > Harness > Create. You are prompted to name a harness. 
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2. Do not type a name. Click  to cancel. The SUBHARNESS menu appears. 

3. Click Setup > Add. 

4. At the prompt, type a new name for the subharness. 

To Set the Default Subharness 

1. Click CABLING > Harness > Create. You are prompted to name a harness 

name. 

2. Do not type a name. Click  to cancel. The SUBHARNESS menu appears. 

3. Click Set Default. 

4. Select the name of the subharness that you want to set as the default 

subharness. 

Defining Report Object Names 

 

Use the CABLING > Set Up > Report Defs command to assign names to the 

following objects for use in Pro/REPORT: 

• Cable Jacket—Name for unshielded cable type locations 

• Cable Shield—Name for shielded cable type locations 

• Cable Pin—Pin name for cable type locations 

Clicking Show Current displays the currently assigned objects. 

Adding Harnesses to a Family Table 

About Adding Harnesses to a Family Table 

When you add a family table to a part, the part is first opened in the Part mode 

before the creation of part instances. If you choose the parent assembly as the 

reference model, it is added as a reference to the base part object in the part family 

table. 

The assembly instance in the assembly family table is modified to include the part 

instance. For more information on family tables, refer to Managing Model 

Composition under Pro/ENGINEER Fundamentals. 

To Add a Harness Part to a Family Table 

1. After you set the working harness, click CABLING > Family Tab. The Family 

Table : <harness_name> dialog box opens. 
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2. Click  to add or delete table columns. The Family Items, Generic 

:<harness name> dialog box opens. You can add dimensions, parameters, 

features, components, groups, a feature from a table driven pattern, a merged 

part, or a referenced model to the family table. 

3. Under Add Item, you can select Ref Model. The REFERENCES menu appears 

with a list of available reference models. 

4. Select a reference assembly from the list and click DONE. 

5. Click OK in the Family Items, Generic :<harness name> dialog box. 

6. If you do not want to add more reference models to the family table, click OK in 

the Family Table <harness_name> dialog box. 

To Use Family Tables with Harnesses 

1. Click Applications > Standard. 

2. Click Tools > Family Tab. The Family Table <assembly_name> dialog box 

opens. 

3. Add a family table to the parent assembly. 

4. Click  to create an instance of a part by opening it in the Part mode. 

5. When you have completed adding the required number of instances, click OK. 

You can modify the assembly instance in the assembly family table to include the 

harness part instance. 

Creating Spools 

About Spools 

A spool has a unique set of parameters and values that are passed to the wire or 

cable when a wire or cable is created. Each wire and cable in the design must be 

created from a predefined spool. The spool, when defined, is saved within the 

assembly and can be written to a text file with the .spl extension. You can reference 

this file in a new diagram or cabling designs. 

The types of spools are: 

• Wire spools—You must set wire spool parameters such as NAME and TYPE. The 

name of the wire spool must be unique. The TYPE parameter is set to WIRE to 

differentiate it from a cable spool. Other common but optional parameters 

defined in the wire spool are COLOR and WIRE_GAUGE. The parameter, 

MIN_BEND_RADIUS is automatically generated. This parameter provides values for 

calculations in Pro/HARNESS. 

• Cable spools—Cable spools have parameters that are similar to those required 

for wire spools. You must set the NUM_CONDUCTORS parameter to define the 
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number of insulated conductors in the cables that are created from the spool. 

Assign an appropriate integer value to the NUM_CONDUCTORS parameter. 

• Sheath spools—Sheath spools are created for bundles. You must set the sheath 

spool parameters such as SHEATH_TYPE and PRESHRINK_INNER_DIAMETER. Other 

common parameters are NAME , TYPE, and UNITS. The parameters, 

MIN_BEND_RADIUS and WALL_THICKNESS are automatically generated. 

Note: 

• Setting the pro_spool_dir configuration option allows you to specify a directory 

from which spools can be read. If you do not specify a directory, the current 

working directory is the default. 

• You can retrieve the spool parameters using the Pro/REPORT table and also use 

these parameters to display the wire or cable labels. 

• If you create spool files in a text editor outside of Pro/ENGINEER, the name of 

the spool file must be identical to the spool name in Pro/ENGINEER. You can also 

save a spool file in the ASCII format to be retrieved for use in other diagrams or 

a Pro/CABLING assembly. 

Cable Spool Parameters 

The following is a list of predefined parameters that are unique to cable spools. A 

cable has a defined number of conductors, and each conductor has its own defining 

parameters, for example gauge or color, within the spool file. All wire spool 

parameters are valid for cable spools. Required parameters are shown in bold. 

NAME The name of the spool file. 

Format: NAME text_string 

TYPE (read only) Determines a cable spool or wire 

spool. Cables are of type PREFAB. 

NUM_CONDUCTORS The number of conductors present 

in a cable. The default value is zero. 

DENSITY The linear density of the spool (in 

mass/unit length). Not used in 

Pro/DIAGRAM, but used in 

Pro/CABLING when referencing a 

diagram to determine Mass 

Properties. 

INSUL_TYPE Insulation type. (Text string) NONE is 

the default. 

SHIELD_TYPE 

(cable spools only) 

The shield type for a cable. (Text 

string) If you set this parameter, it 

alters the cable symbol and makes 

it a dashed line to specify shielding. 
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CABLE_JACKET_REPORT_NAME Use the default value DEFAULT, in 

which case the name of the cable 

shows in the report table. Any other 

value is interpreted as plain text. 

For example, &cable_name has no 

special meaning. 

CABLE_SHIELD_REPORT_NAME Use this name for the cable symbol 

if the cable is shielded. The default 

value is SHIELD. 

CABLE_NODE_REPORT_NAME Use this name for the nodes of a 

cable symbol. The default value is 

"-".  

SHIELD_LINEAR_RESISTANCE Specifies linear resistance of the 

wire's shielding. 

OUTER_SHIELD_LINEAR_RESISTANCE Specifies linear resistance of the 

wire's outer shielding. 

LIN_CAP_TO_ITEM Specifies linear electric capacity 

between items. 

LIN_CAP_ITEM_TO_SHIELD Specifies linear electric capacity 

between items and shield. 

LIN_CAP_ASSEM_ITEM_TO_SHIELD Specifies linear electric capacity 

between assembly items and shield. 

OUTER_SHIELD_THICKNESS Specifies thickness of the outer 

shielding of the wire. 

To Create a Spool 

 

1. Click CABLING > Spools > Create. The CREATE SPOOL menu appears. 

2. Select one of the following filters to specify the type of spool that you want to 

create. 

o Wire—Creates a wire spool. 

o Cable—Creates a pre-fabricated cable spool. 

o Sheath—Creates a sheath spool. Sheath spools are referenced by bundles. 

o From Logical—Creates a spool using a logical reference. The REF SPOOL 

menu appears. 

Select the required spools from the list and click Done Sel to copy spool 

parameters from the referenced diagram. You can select one or more wire 
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or cable spool names from the list or click Select All to select all the 

available spools. 

Note: If the logical data is imported from a wire list, the From Logical 

command is available for wire creation only. This is because the imported 

wire list format does not support cables. 

If you use CABLING > Spools > Create > From Logical, Pro/CABLING 

automatically creates all spools associated with the created cables and wires. The 

information that is used to create these spools is taken from the logically 

referenced data from which the wires and cables were created. 

If the cabling assembly does not have a reference to a diagram or a wire list, 

select a spool from which the cable or wire draws its characteristics. 

3. To create a new spool for a wire, cable, or sheath, at the prompt, type a new 

spool name and press ENTER. The Electrical Parameters dialog box opens. 

4. Under Display For, select Connections to add parameters to wires or cables or 

Conductors to add parameters to conductors of a cable spool. 

5. If you have selected Conductors, select a parameter in the NUM_CONDUCTORS 

column, specify a value for the number of conductors for a cable spool in the 

Value box, and click Apply. 

6. Click View > Columns . The Model Tree Columns dialog box opens. 

7. Add the required parameters to the spool, click Apply, and then OK. 

8. When finished, click File > Save or File > Save As to save the file to disk. 

9. Click OK to apply the spool parameters. 

To Modify Spools 

1. Click CABLING > Spools > Edit. The Select Spools dialog box opens. 

2. Select one of the following filter to specify the type of spool to be modified: 

o All Spools 

o Wire Spools 

o Cable Spools 

o Cable Spools by Num Cond 

3. Click a spool name from the spool list. You can filter the spools by spool type or 

number of conductors. 

or 

Click  or  to select or remove all spools from the list, respectively. 

4. Click OK. The Electrical Parameters dialog box opens. 



Cabling - Help Topic Collection 

24 

5. Modify the required spool parameters, click Apply, and then OK. 

6. Click Done/Return in the SPOOLS menu. 

Note: 

• Use CABLING > Spools > Read to read in spool parameter data from a 

previously created spool that was saved to disk. This file must have a .spl 

extension. 

• Use CABLING > Spools > Write to write the selected spool parameter data to 

your current directory. These files have a .spl extension. 

To Rename Spools 

1. Click CABLING > Spools > Rename. The Select Spools dialog box opens. 

2. Select one of the following filters to specify the type of spool to be modified: 

o All Spools 

o Wire Spools 

o Cable Spools 

o Cable Spools by Num Cond 

3. Click a spool name from the spool list. You can filter the spools by spool type or 

number of conductors. 

4. Click OK in the Select Spools dialog box. You are prompted for a new spool 

name. 

5. At the prompt, type a new spool name and press ENTER. The spool is renamed. 

6. Click Done/Return in the SPOOLS menu. 

Note: If you have renamed spools using the Select Spools dialog box, all wires or 

cables in the Pro/CABLING assembly reference the renamed spool. If the assembly 

logically references a diagram, then renaming a spool in the diagram and updating 

the logical reference also causes the corresponding spools in the assembly to be 

renamed. Use CABLING > Logical Ref > Update to overwrite the existing cabling 

spool parameters with the modified spool parameters of the logically referenced 

diagram. 

In a comparison between an assembly and a logically referenced diagram, if a spool 

in the assembly has the same parameter values as the spool in the logically 

referenced diagram, then both these spools are recognized to be the same. 

To Write Spools 

1. Click CABLING > Spools > Write. The Select Spools dialog box opens. 

2. Select one of the following filters to specify the type of spool to be modified: 

o All Spools 
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o Wire Spools 

o Cable Spools 

o Cable Spools by Num Cond 

3. Click a spool name from the spool list. You can filter the spools by spool type or 

number of conductors. 

4. Click OK. The selected spool file is output to the directory from where you started 

the Pro/ENGINEER session or to the Spool Dir directory, if you have set the 

pro_spool_dir configuration option. 

To Remove Spools 

1. Click CABLING > Spools > Remove. The Select Spools dialog box opens. 

2. Select one of the following to specify the type of spool to be modified: 

o All Spools 

o Wire Spools 

o Cable Spools 

o Cable Spools by Num Cond 

3. Click a spool name from the spool list. You can filter the spools by spool type or 

number of conductors. 

or 

Click  or  to select or remove all spools from the list, respectively. 

4. Click OK. If the spool has cables referencing to it, you are prompted to confirm 

the deletion. 

5. Click Yes at the prompt, the selected spools are deleted successfully. 

To List Spools 

1. Click CABLING > Spools > List to view the list of spools in the diagram or 

cabling assembly. The INFORMATION WINDOW opens listing the spools and the 

spool type. 

2. Click File > Save As to save the spool information to the required location. 

3. Click Close to close the INFORMATION WINDOW. 

Modifying Spool Color 

If you set the COLOR parameter of a spool to a color that is available in the 

color.map file or one that was created and named in the Appearance Editor dialog 

box, all cables or wires created from this spool are created with the specified color. If 

you change the value of the COLOR parameter and regenerate the model, the color is 
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replaced with the new color. You can change the color of a cable in the design 

without editing the spool. Use the Appearance Editor dialog box to set a color for 

the cables without editing the spool. All the segments of the selected cable take the 

new color. Any new segments you create for this cable after setting a new color will 

use the new color. However, the spool remains unedited. The COLOR value for the 

spool is overridden at the design level. 

To Add Spools from a Logical Reference 

1. Click CABLING > Logical Ref > Ref Diagram to reference Pro/DIAGRAM 

information directly in Pro/CABLING. This information includes the reference 

designator, pin-to-pin connection information, and parameter values of 

connectors, pins, spools, wires, and cables. 

2. Click CABLING > Spools > Create > From Logical. The REF SPOOL menu 

appears. 

3. Select the spools that you want to add to the cabling file or click Select All to 

add all spools. 

4. Click Done Sel. 

Note: If you use From Logical, Pro/CABLING automatically creates all spools 

associated with the created cables and wires. The information used to create these 

spools is taken from the logically referenced data from which the wires were created. 

Adding Wires and Cables 

About Wires and Cables 

A wire has one conductor. When wires or cables are first created, only the name and 

a set of default parameters inherited from the spool are present for the wire or cable. 

Later, you can add additional features or parameters to further define the physical 

shape of the connection. The wires or cables in the database must also be named 

and defined before you route them. 

Spools contain physical properties and a set of parameters for the cables or wires 

that can be reused as needed, the same way as the length of a reel wire is rolled off 

a reel spool. You can import wires, cables, and spools from Pro/DIAGRAM or create 

them within the Pro/CABLING assembly. 

To Create a Wire or Cable 

1. After creating or activating a harness part, click CABLING > Feature > Create. 

The CABLE FEAT menu appears. 

2. Click Cable to create a cable or Wire to create a wire and associate parameters 

with it. If the assembly has no reference to a diagram, you are prompted to 

specify a new cable name. The SPOOL NAMES menu appears. 

3. Select an existing spool from which the cable or wire draws its characteristics or 

create a new spool. A new wire or cable is created. 
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4. Click Done/Return in the CABLE FEAT menu. 

To Add a Wire or Cable to the Database by Reference 

 

1. After creating or activating a harness part, click CABLING > Feature > Create. 

The CABLE FEAT menu appears. 

2. Click Cable to create a cable or Wire to create a wire and associate parameters 

with it. If the assembly has a reference to a diagram, the CREATE CBL menu 

appears. 

3. Click From Logical, select one or more wire or cable names from a list of names 

generated from the diagram or wire list displayed in the REF CABLE menu, and 

click Done Sel to select the referenced cable or wire. 

or 

Click Enter Name to create a cable or wire without using referenced information 

from a diagram or wire list and type a name for the cable or wire when 

prompted. 

Note: If the logical data is imported from a wire list, the From Logical command 

is available for wire creation only. This is because the imported wire list format 

does not support cables. 

4. Click Done/Return in the CABLE FEAT menu. 

To Modify Cables and Wires 

1. Click CABLING > Modify to edit dimensions, parameters, lengths, or locations of 

cables and wires. The MOD CABLE menu appears. 

2. Click one of the following commands to modify cables or wires: 

o Mod Dim—Modifies the values of cable dimensions. 

o Parameters—Modifies parameters of a cable, wires, or bundle for selected 

cables, wires, or bundles through the Electrical Parameters dialog box. 

o Length—Allows you to access commands to measure any continuous 

portion of the selected cable or to fix the length of cable between locations. 

o Split Cable—Creates a new cable or bundle by splitting the existing cable 

or bundle into two parts. 

o Mod Bundle—Adds or deletes cables or wires from a bundle. 

o Cosmetics—Modifies tiewrap, tape, and marker features through the 

Electrical Parameters dialog box. 
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About Strip Length Table 

A strip length table automatically assigns wire strip information to wires in a cabling 

assembly. The strip length table is similar to a terminator table. 

The first column of the table must contain the required strip length of a conductor. 

By default, the second column specifies the terminator whose connected wire is 

stripped. You can modify this value. 

As in terminator tables, the valid objects are COND, SPOOL, CONN, or PIN. Items 

specified in the parameter heading can be any parameter from the object heading 

above it. An asterisk (*) indicates that it applies to all values for the specified 

parameters. 

Wire Strip Information 

Use the STRIP_LENGTH parameter to specify the amount of insulation to be stripped 

off from the end of the wire. The STRIP_LENGTH parameter specifies the name of the 

wire to be stripped, the amount of insulation to be removed from the wire, and the 

end of the wire to be stripped. 

You can use a strip length table to automatically assign strip lengths in a batch 

process. 

To Create a Strip Length Table 

1. Click CABLING > Set Up > Strip Table. The Strip Table dialog box opens. 

2. Click in a cell in the COND STRIP_LENGTH column and click Insert > Insert 

Row After. A new row is added to the table. 

3. Type the required strip length in the new cell in the COND STRIP_LENGTH 

column. This column is reserved for the strip length parameter value. 

4. Identify a valid object and parameter that you want to associate the strip length 

with. The valid objects are COND, SPOOL, CONN, or PIN. Depending on the object 

that you specify, you can select a parameter from the list for the second cell. 

5. Add new columns to refine the selection. For example, in the following table, the 

strip length value 0.5 is assigned to all pins that have the term name, GND, and 

have 18-gauge wires. 

COND 

STRIP_LENGTH 

PIN 

TERM_NAME 

SPOOL 

WIRE_GAUGE 

COND PIN SPOOL 

STRIP_LENGTH TERM_NAME WIRE_GAUGE 

0.5 GND 18 

Note: Wildcards such as an asterisk (*) indicate that it applies to all values for 

the specified parameters. 

6. Click File > ExportTable to save the strip table file to disk. 
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7. Click Execute to update all the connector parameters with the valid strip 

information. The Execute command updates all wire parameters with an 

AUTO_ASSIGN value of the STRIP_LENGTH parameter set to true. 

Note: Strip table files are run every time you regenerate a cabling assembly. 

8. Click OK. 

Adding Components 

About Components 

In Pro/CABLING, components are divided into the following types. All components 

referenced by a 3D harness can be assembled into a flattened harness assembly for 

the selected 3D harness. 

• Connector—A part or assembly that serves to connect the harness electrically 

into a piece of equipment or another harness. You must designate a part as a 

connector, and define one or more c-systems to use as an entry port before you 

can route the wire or cable to it. Wires or cables need not end at a connector, 

they can be ended in space. However, if you move the connector in the assembly 

and you want the cable to move with it, you must route the wire or cable to a 

connector entry port. 

• In-line connector—An inline connector is a male-female pair assembly. It must 

have an assembly level coordinate system on either side representing an entry 

point and an exit point. When placed on an existing cable, an inline connector 

splits the cable into two separately-named entities. The length of each entity is 

calculated from the entry or exit location point. Internal lengths are added 

through the entry port int_length parameter on the component. 

• Splice—A part or assembly that electrically connects wires within a harness. 

Wires can stop at or pass through a splice. A splice does not split the wire into 

two entities. 

• Mechanical Component—A part or assembly that serves as a mechanical 

support for the wiring harness. A mechanical component is a necessary part or 

assembly in manufacturing a grommet or a formed support piece. Wires must 

pass completely through this type of component to be electrically meaningful. If 

you stop routing at a component, the wire is considered incomplete. 

The subtypes of mechanical components are: 

o Custom Component—A component that has no parameters but, in other 

capabilities, is exactly like a splice. Used for items that would not need a 

reference designator. 

o Attached Component—A component that was referenced while routing a 

harness and then attached to the harness using the Attach to Harn 

command on the CABLE COMPONENTS menu. The referenced component 

at the routing location must be of the type Along Axis or Pnt/Vtx/Csys, 
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with a coordinate system as the reference so that you can attach it to a 

harness. 

About Component Parameters 

Components use parameters to indicate electrical information at the connector- and 

pin-level. 

When you first designate a connector using the CABLE COMPONENTS > Designate 

command, the connector-level default parameters are established. The pin-level 

parameters can be specified when you either use a logical reference to read them 

from a diagram or manually specify them in the Electrical Parameters dialog box. 

When you designate a connector, Pro/CABLING sets the component parameters at 

the assembly-level. This allows you to use the same model to represent different 

electrical components. 

Note: 

• You can view only the following cabling parameters in the Model Tree: 

o Designation 

o Diameter 

o Logical From 

o Logical To 

o Physical From 

o Physical To 

o Length 

o You cannot access or show component parameters in the Model Tree because 

they are stored differently from the normal parameters. 

o The custom components and attached components do not have electrical 

parameters. 

• Splices can use all connector parameters, but the TYPE parameter value is 

SPLICE, not CONNECTOR. 

Component Parameters for Splices before Pro/ENGINEER Release 
20 

For splices inserted before Release 20.0, a LINK connector parameter is necessary to 

indicate that the two entry ports are connected for routing. 

To route a wire through a splice, add the following connector parameter to the 

splice’s parameters: 

LINK <entryport1> <entryport2> 
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where, entryport1 and entryport2 are the entry ports on the connector through 

which the wire enters and exits. Multiple entries of the LINK connector parameter 

can be used to indicate multiple links between entry ports in a splice. 

For example, a splice with a connector parameter, LINK ENTRY_2 ENTRY_7; links 

ENTRY_2 and ENTRY_7 so that when you route a wire to the ENTRY_2 entry port, the 

wire can automatically be continued from the ENTRY_7 entry port. If a wire is routed 

through a splice, the information is not displayed in the wire list. 

For splices and custom components assembled in Release 20.0 or later releases, all 

the entry ports are considered to be automatically linked, without using the LINK 

parameter. 

Cable Paths Setup Options 

The Cable Paths Setup dialog box contains the following options: 

• Component Items—Displays a list of all cables that touch the component. In 

the Components Item group, the cable name and path (entry ports) are 

displayed. Each network segment is listed as a row with information in the Entry 

and Exit boxes. You can, therefore, control every network segment. 

• Items to Modify—Displays selected items in the Components Item group that 

you want to modify. For all selected items, you can set the following in the Path 

group: 

o Entry—Click  to select a location where you want to place the 

component or select an item from the Component Items group to display 

its entry port name in the Entry box. If all items do not have the same 

setting for the entry, the text defaults to As Is to allow you to keep 

individual settings for one while setting another value for the other items. 

You can specify an entry port to override this setting. 

o Exit—Click  to select the exit port or select an item from the 

Component Items group to display its exit port in the Exit box. 

In the Show group, you can set and modify the visibility of cable paths inside a 

splice: 

o Yes—The internal segment for a cable is displayed between the entry and 

exit location in the 3D view. 

o No—The wire display terminates at one entry port and resumes at another 

entry port. This option is selected by default. 

o As Is—The visibility of the cable path remains unchanged. 

Note: 

• The minimum bend radius is ignored for internal segments. Pro/CABLING 

assumes that the selected path is the shortest path that maintains tangency 

between the entry and exit z-axis unless the internal path has and shows 

manually added locations. 



Cabling - Help Topic Collection 

32 

• Pro/HARNESS cannot flatten loops. However, it can flatten the internal portions of 

splices and components even if they form a loop. Pro/HARNESS can also flatten a 

virtual loop. 

To Edit Component Parameters 

1. Click CABLING > Components > Modify Parameters. The SELECT dialog box 

opens. 

2. Select one or more components to modify. Press CTRL to select multiple 

components. 

3. Click OK. The Electrical Parameters dialog box opens. 

4. Modify the required parameters. 

5. Click Apply and then OK. 

To Modify Placement of Splices and Custom Components 

1. Click CABLING > Components > Modify Component. 

2. Select one or more Cabling components to modify. To select multiple 

components, press CTRL and select the required components. The MOD CONN 

menu appears. 

3. Click Placement. The COMPONENT WINDOW and the Place Component 

dialog box open. 

4. Modify the component placement by applying one of the following constraint 

types. 

o Tangent to Cable—The attachment coordinate system attaches to the 

location that you selected earlier with its z-axis tangent to the cable 

segment at the location. 

o Perpendicular to Plane—Select a Plane, Crv/Edg/Axis, or Csys from 

the GEN SEL DIR menu as a constraint to assemble the splice or custom 

component. The z-axis of the coordinate system is normal to the selected 

plane or aligned to the selected curve, edge, axis, or coordinate system. 

You can modify the direction of the attachment location to be parallel to the 

z-axis of the attachment entry port. 

5. Click OK. 

To Modify the Internal Portions of Splices or Custom Components 

1. Click CABLING > Components > Modify Component. The SELECT dialog box 

opens. 

2. Select the cabling component you want to modify. The MOD CONN menu 

appears. 

3. Click Internal Portions. The Cable Paths Setup dialog box opens. 
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4. Modify the internal portions of a component. 

5. Click Apply and then OK. 

Note: You can modify internal portions of a inline connector, splice, or a custom type 

of component. 

To Add a Component to a Flat Harness 

1. Ensure that the referenced component at the routing location is of the type 

Along Axis or Pnt/Vtx/Csys, with a coordinate system as the reference so that 

you can attach the component to a flat harness. 

2. Click CABLING > Components > Attach to Harn > Add. The SELECT dialog 

box opens. 

3. Select one or more components to attach to the flat harness. 

4. If the component references multiple locations, select a location along the axis on 

the component at the routing location. The component is attached to the flat 

harness. 

5. Click OK. 

To Modify the Attachment Location of a Component to a Harness 

1. Ensure that the referenced component at the routing location is of the type 

Along Axis or Pnt/Vtx/Csys, with a coordinate system as the reference so that 

you can attach the component to a flat harness. 

2. Click CABLING > Components > Attach to Harn > Mod Location. The 

SELECT dialog box opens. 

3. Select a component to modify its attachment location. 

4. Select a location to which you want to attach the component and click OK. The 

attachment location of the component is modified. 

To Remove a Component from a Flat Harness 

1. Ensure that the referenced component at the routing location is of the type 

Along Axis or Pnt/Vtx/Csys, with a coordinate system as the reference so that 

you can attach the component to a flat harness. 

2. Click CABLING > Components > Attach to Harn > Remove. The SELECT 

dialog box opens. 

3. Select one or more components to remove from the flat harness and click OK. 
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Splices and Inline Connectors 

About Adding Components to the Cable Path 

You can add the following components to a location along the cable path, between 

the two cable-terminating entry ports: 

• Splice components—These are components added along the length of a cable. 

The cable name and the length from connector to connector is not affected after 

the splice component is installed. You can insert both Through and Butt type of 

splice components that are created in Pro/DIAGRAM. 

• Custom components—These are similar to splice components, except that they 

do not use parameters. You can use custom components for cabling objects that 

do not need a reference designator. 

• In-line connectors—This is a pair of male and female connectors that break the 

cable into two physical cables but maintain signal continuity between them. The 

connector assembly must have an assembly-level coordinate system on either 

side representing an entry point and an exit point. When placed on an existing 

cable it splits the cable into two separately named entities. The length of each 

entity is calculated from the entry or exit location point. To add internal lengths, 

use the entry port parameter int_length on the component. 

To Insert a Splice or Custom Component 

1. Click CABLING > Components > Create. The Place Component and the 

Open dialog boxes open. 

2. In the Open dialog box, select a part or assembly and click Open. You can select 

a part that has only a surface or datum curve or atleast a datum coordinate 

system to define the entry ports. The selected part or assembly appears in the 

Component Window and its name appears in the Model Name box. 

3. Select an attachment entry port on the model being assembled. 

4. Click Edit > Find in the Component Window to select a coordinate system 

from the model or directly select the coordinate system in the model that is 

displayed in the Component Window. The selected coordinate system appears 

in the Entry Port box of the Place Component dialog box. 

5. Select the component type. If you select the Custom component type, you 

cannot select a reference designator. 

6. Select the constraint type. 

o If you select Tangent to Cable, the attachment coordinate system 

attaches to the location that you selected earlier with its z-axis tangent to 

the cable segment at the location. 

o If you select Perpendicular to Plane, select a Plane, Crv/Edg/Axis, or 

Csys from the GEN SEL DIR menu as a constraint to assemble the splice 

or custom component. The z-axis of the coordinate system is normal to the 
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selected plane or aligned to the selected curve, edge, axis, or coordinate 

system. You can modify the direction of the attachment location to be 

parallel to the z-axis of the attachment entry port. 

7. Select an existing location for the component placement in the Cable Location 

box. 

8. Select an existing reference designator or create a new one. 

9. Click OK in the Place Component dialog box as well as in the Component 

Window. The component is placed at the specified location and the ORIENT FIT 

menu appears. This menu determines the orientation of the component. 

10. Specify the required orientation. 

o Flip—Changes the orientation from the positive-z to the negative-z of the 

coordinate system, or vice-versa. 

o Twist—Type an angle value and change the orientation of the splice or 

component by aligning the x- or y-axis of the attachment entry port to a 

selected reference. A dimension is created for the twist. You can modify the 

dimension using the CABLING > Modify command. 

11. Click Done or Quit. The Cable Paths Setup dialog box opens. 

12. Use the Cable Paths Setup dialog box to select the paths that each cable takes 

inside the component or splice. Initially, all items are shown as routed to or 

through the attachment location. 

Note: 

• Whole cables cannot enter the component while individual conductors exit the 

components. Bundles must stop at the last location that is common to all cables. 

A new bundle that is manually created cannot continue after the component 

unless all cables in the bundle enter and leave together. 

• If the item goes into a component and does not stop at an entry port, it must 

come out as itself, and not as part of a cable or bundle. Items that go in and 

continue must exit as well. 

To Delete a Splice or Component 

1. Click CABLING > Components > Delete. The DELETE/SUPP and SELECT 

FEAT menus appear. By default, Select is selected. 

2. Select one of the following commands from the DELETE/SUPP menu: 

o Normal—Deletes or suppresses selected features. 

o Clip—Deletes or suppresses selected features and all features created later. 

o Unrelated—Deletes or suppresses all features other than those selected. 

3. Use the SELECT dialog box to select one or more components to delete and click 

Done in the SELECT FEAT menu. 
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To Insert Multiple Splices at a Single Location 

1. Click CABLING > Components > Create. The Place Component and the 

Open dialog boxes open. 

2. In the Open dialog box, select a part or assembly and click Open. You can select 

a part that has only a surface or datum curve or atleast a datum coordinate 

system to define the entry ports. The selected part or assembly appears in the 

Component Window and its name appears in the Model Name box. 

3. Select the attachment entry port on the model being assembled. 

4. Click Edit > Find in the Component Window to select a coordinate system 

from the model or directly select the coordinate system in the model that is 

displayed in the Component Window. The selected coordinate system appears 

in the Entry Port box of the Place Component dialog box. 

5. Select Splice as the component type. 

6. Select the constraint type. 

o If you select Tangent to Cable, the attachment coordinate system 

attaches to the location that you selected earlier with its z-axis tangent to 

the cable segment at the location. 

o If you select Perpendicular to Plane, select a Plane, Crv/Edg/Axis, or 

Csys from the GEN SEL DIR menu as a constraint to assemble the splice 

or custom component. The z-axis of the coordinate system is normal to the 

selected plane or aligned to the selected curve, edge, axis, or coordinate 

system. You can modify the direction of the attachment location to be 

parallel to the z-axis of the attachment entry port. 

7. Select an existing location for the component in the Cable Location box. 

8. Select an existing reference designator or create a new one. To select multiple 

reference designators, hold down the SHIFT or CTRL key and select the required 

reference designators. 

9. Click OK. Multiple splices are placed at the selected location. 

Note: If you insert multiple splices at a location using this procedure, you cannot 

modify the orientation of the individual splices. To modify the orientation of the 

splices, insert single splices and not multiple splices. 

To Insert an Inline Connector 

1. Click CABLING > Components > Create. The Place Component and the 

Open dialog boxes open. 

2. Select a part or assembly and click Open in the Open dialog box. The selected 

part or assembly appears in the Component Window and its name appears in 

the Model Name box. 

3. Select the attachment entry port on the model being assembled. 
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4. Click Edit > Find in the Component Window to select a coordinate system 

from the model or select a model name from a list of all coordinate system in the 

model. The selected attachment entry port appears in the Entry Port box of the 

Place Component dialog box. 

5. Select In-line connector as the component type. 

6. Select an existing reference designator or create a new one. If you do not specify 

a reference designator, the part name is used as the reference designator. 

7. Select the constraint type. 

o If you select Tangent to Cable, the attachment coordinate system 

attaches to the location selected earlier with its z-axis tangent to the cable 

segment at the location. 

o If you select Perpendicular to Plane, select a Plane, Crv/Edg/Axis, or 

Csys from the GEN SEL DIR menu as a constraint to assemble the splice 

or custom component. The z-axis of the coordinate system is normal to the 

selected plane or aligned to the selected curve, edge, axis, or coordinate 

system. You can modify the direction of the attachment location to be 

parallel to the z-axis of the attachment entry port. 

8. Select an existing location for the component in the Cable Location box. 

9. Click OK in the Place Component dialog box as well as the Component 

Window. The component is placed at the specified location and the ORIENT FIT 

menu appears. This menu determines the orientation of the component. 

10. Specify the required orientation. 

o Flip—Changes the orientation from the positive-z to the negative-z of the 

coordinate system, or vice-versa. 

o Twist—Type an angle value and change the orientation of the splice or 

component by aligning the x- or y-axis of the attachment entry port to a 

selected reference. A dimension is created for the twist. You can modify the 

dimension using the CABLING > Modify command. 

11. Click Done or Quit. You are prompted to name one of the new wires that you 

have created. The new wire is highlighted. 

12. At the prompt, type a new name for the wire. The other section of the wire is 

highlighted and you are prompted to name it. 

13. At the prompt, type a name for this section of the wire. You are prompted to 

select another entry port on the splice. 

14. Select the second entry port on the other side of the connector assembly. A new 

location is created for the exit point. 

15. If there are any locations inside the connector, manually delete them. 

Note: Cable lengths are calculated from the originating terminals to the inline 

connector's coordinate system of the entry port. To add internal lengths, use the 

component entry port parameter, int_length, on the inline connector. 
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Designating Connectors 

About Designating Components as Connectors 

An assembly component must be designated as a connector before you use it as a 

connector. This makes the component eligible to carry pin and entry port information 

for starting and ending cables. 

If you are using a logical reference from a Pro/DIAGRAM file, you can use the 

model_name diagram connector parameter to automatically designate specific 

components as connectors. After the part is designated, you can route wires or 

cables to it. 

Subconnectors 

Pro/CABLING also supports the concept of subconnectors. An example of 

subconnectors would be the ports in a PC case. The logical reference refers to the 

case as a connector and uses a node or pin for each port. 

In a 3D assembly, the case is referred to as a connector and the parts assembled to 

the case representing the ports are designated as subconnectors. 

Note: The coordinate systems for the entry ports must be defined in the part before 

the part is designated as a connector in the Pro/CABLING mode. 

You can change the designation of a connector by designating it again or by 

modifying it. When you undesignate a connector, you must strip it of all connector 

data. Use Undesignate/Designate to replace all information in the connector 

parameters. 

To Designate a Component as a Connector 

1. Click Cabling > Components > Designate. 

2. Select the part or subassembly geometry that you want to represent or designate 

as a connector. The DES CONN menu appears. 

3. Click Logical Ref to select a component from the components defined in the 

logical reference diagram. 

or 

Click Enter Name. You are prompted for a filename (.con) to read connector 

parameters from. At the prompt, type the name and press ENTER. If you do not 

specify a filename, the connector is defined using the default values. When the 

connection is defined, you can modify parameters or entry ports. 

Specify the entry ports, that is, the coordinate systems where cables enter the 

connector. 

After the part is designated, you can route wires or cables to it. 

Note: If you select a component that is logically referenced from a Pro/DIAGRAM 

file, components are automatically designated as connectors. 
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About Autodesignating Components as Connectors 

If the Pro/CABLING assembly has a logical reference to a diagram file or an XML file, 

you can automatically designate a component in the assembly as a connector. 

Automatic designation of a component as a connector is possible only when the 

corresponding connector in the diagram file or the XML file has the <model_name 
nnn> parameter associated with it. In this parameter, nnn is the model name of the 

3D part in the Pro/CABLING assembly that you want to represent as the connector. 

If you have not set the model_name parameter in your logical reference, you can still 

use the Auto Designator dialog box to select and match assembly components to 

connectors from the logical reference. 

Note: Select Allow Mismatch in the Auto Designator dialog box to match the 

components manually. 

To Autodesignate Connectors 

1. Click CABLING > Components > AutoDesignate. The Auto Designator 

dialog box opens. 

2. Match a listed connector with a selected 3D component. 

3. After matching a component with a diagram connector, use the editing tools for 

parameters and entry ports from the Auto Designator dialog box. 

To Undesignate a Connector 

1. Click CABLING > Components > Undesignate. 

2. Select the connector or splice. 

3. Click Done/Return. 

To Edit Parameters for Components, Pin, or Entry Port Data 

1. Click CABLING > Components > Modify Parameters. The SELECT dialog box 

opens. 

2. Select one or more connectors to modify and click OK. The Electrical 

Parameters dialog box opens. The selected connectors appear in the left panel 

in a tree navigation format. 

3. Click the plus sign for a component to expand the component you want to edit. 

The parameters of the pins and entry ports are displayed in the right panel. 

4. Under Display For, click Components, Pins or Entry Ports to show the 

parameters associated with them. 

5. Modify the required parameters. 

6. Click Apply and then OK. 
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To Redefine Splice Placement 

1. Open the assembly in Standard mode to change the orientation of the splice. 

2. Click CABLING > Components > Modify Components. 

3. Select the splice that you want to redefine. The MOD CONN menu appears. 

4. Click Placement. The COMPONENT WINDOW and Place Component dialog 

box open. 

5. Change the constraint type to one of the following: 

o Tangent to Cable—The attachment coordinate system attaches to the 

location that you selected earlier with its z-axis tangent to the cable 

segment at the location. 

o Perpendicular to Plane—select a Plane, Crv/Edg/Axis, or Csys from 

the GEN SEL DIR menu as a constraint to assemble the splice or custom 

component. The z-axis of the coordinate system is normal to the selected 

plane or aligned to the selected curve, edge, axis, or coordinate system. 

You can modify the direction of the attachment location to be parallel to the 

z-axis of the attachment entry port. 

6. Click OK in the Place Component dialog box. The splice is repositioned to the 

new location. 

About Replacing Connectors 

Use the functional interchange group members (INTRCH GROUP) to replace the 

assembly components that represent a connector with wires routed to it. In a 

functional interchange assembly, each coordinate system that has a wire routed to it 

on the connector being replaced must have a corresponding coordinate system on 

the replacement connector with an assigned tag. 

Note: 

• The harness part must be regenerated to show the wires being routed to the new 

entry ports on the new connector. 

• If the connector is a subassembly, any entry port of any connector must be 

represented by a coordinate system that resides on the top level of that 

connector. 

To Replace a Connector 

1. Select the connector you want to replace. 

2. Click Edit > Replace. The Replace Comp dialog box opens. You are prompted 

to select the components to replace. 

3. Click the By Model tab and select one of the following: 

o Reference Model—Replaces a component model with a model containing 

an external reference of the model. 
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o Layout—Replaces a component model with a model associated through a 

layout. 

o Manually—Replaces a component model by specifying placement of a new 

model. 

4. In the Selected Model box, select a model to replace. 

5. Click OK. The Component Placement dialog box opens. 

6. Select the constraints and references. 

7. Click OK. 

Using Subconnectors 

About Subconnectors 

When you attach a subconnector to a connector, the entry port information on the 

subconnector is associated with the parent connector. 

A 3D assembly may have components designated as connectors, but no entry ports. 

The entry ports for these connectors may be on separate parts or subassemblies on 

the assembly, for example, a PC case and its serial and parallel connectors. 

Subconnectors are necessary when a Pro/DIAGRAM file represents the PC case as 

one reference designator, and the connectors as pins. In the 3D assembly, if each 

serial or parallel connector part is assigned as a subconnector of the case part, the 

logical reference searches the subconnectors for entry port names listed in the 

diagram connector's pin information. 

 

A represents a Pro/DIAGRAM connector C1, for example a computer case, showing 

the case's ports as pins 1, 2, and 3. Each pin has the entry_port parameter with a 

value matching the entry_port pin parameter on the subconnector part. 

B represents the 3D assembly with parts D1, D2, and D3 as subconnectors of C1. C1 

has no entry ports of its own, but each subconnector has one. Each subconnector 

entry port is available to be assigned to the entry_port parameter for pins on C1. 

Use Modify Parameters to assign the parameters to the subconnectors. 

To Assign a Connector as a Subconnector 

1. Click Cabling > Components > Modify Component. 
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2. Select the component that will receive the subconnector. The MOD CONN menu 

appears. 

3. Click Add SubConn. Select the connector to be added as a subconnector. A 

message appears that the subconnector has been added successfully. 

Note: 

• To remove the subconnector, click Remove SubConn. 

• To highlight a connectors assigned subconnectors, click Show Subconns. 

• To list all connector with subconnectors, click List Subconns. 

To Assign Subconnector Entry Ports 

1. Click CABLING > Components > Modify Parameters. The SELECT dialog box 

opens. 

2. Select the parent component and click OK. The Electrical Parameters dialog 

box opens. 

3. Under Display For, select Pins. 

4. Expand Pins to display the pins used in the assembly. 

5. In the right panel, select an ENTRY_PORT parameter. 

6. In the Value box, type a new value or select the entry port name from the list. 

7. Repeat this procedure for each pin. Subconnector entry ports are assigned to pin 

numbers on the parent connector: 

Note: Entry ports must first be defined on each subconnector. 

Using Entry Ports 

About Entry Ports 

An entry port is a coordinate system of a connector that you designate as accessible 

to route a wire, cable, or bundle. Entry ports represent the pins in pin-to-pin cabling 

connections. A conductor always leaves an entry port tangent to the positive z-axis 

at the origin of the entry port coordinate system. You can define any coordinate 

system on a part as an entry port. Typically, you do this when you designate the part 

as a connector. 

Note: To be an entry port, the coordinate system must be at the top level of the 

model representing the component, that is, at the part level for a part or at the top 

level of a subassembly. 

After a coordinate system is designated as an entry port, you can assign this 

coordinate system to a specific pin on the connector. You do not have to do this to 

route a cable to an entry port manually, but the coordinate system is required for 

autorouting individual conductors within a cable. 
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To Designate a Coordinate System as an Entry Port 

1. Click CABLING > Components > Designate to designate a component as a 

connector. 

2. Select the component. The MOD CONN menu appears. 

3. Click MOD CONN > Entry Ports. The ENTRY PORT menu appears. 

4. Click Add/Modify and select a coordinate system. 

5. You are prompted to enter the internal length of the cable. 

6. Type the length and press ENTER. The PORT TYPE menu appears. 

7. Select WIRE, ROUND or FLAT as the port type. Wire denotes a single wire 

whereas, round or flat refer to the packing for cables. You cannot route a cable to 

a wire entry port. 

You can also use the Autodesignate dialog box to designate the entry ports. 

8. Continue to define all the entry ports. When finished, exit the command 

sequence. 

The internal length is not actually routed, but is specified in a numerical 

parameter for each entry port. These lengths are automatically added to the 

routed length of a wire when Pro/CABLING provides length information. 

When you have designated one or more coordinate systems as entry ports on a 

connector, the parameters EP_TYPE (round, flat, wire) and INT_LENGTH (integer) 

are added for each at the entry port level of the connector in the Electrical 

Parameters dialog box. 

To Assign an Entry Port to a Pin Number 

1. Click Cabling > Components > Modify Parameters. 

2. Select one or more connectors with the pins you want to associate. The 

Electrical Parameters dialog box opens. 

Ensure that the NUM_OF_PINS parameter has an appropriate value to be assigned 

to the entry ports. 

3. Under Display For, click Pins. 

4. If no column are displayed, click View > Columns to add the required 

parameters. 

5. In the Value box, for each pin, type the name of the coordinate system you want 

to associate with the pin as a value for the ENTRY_PORT parameter or select the 

entry port name from the list. 

To Redefine an Entry Port 

1. Click CABLING > Components > Modify Component. 
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2. Select the target component from the assembly. 

3. Click MOD CONN > Entry Ports > Add/Modify. The SELECT dialog box opens. 

4. Select an entry port or ports to modify. 

5. Click OK. You are prompted to assign new values for the internal length and the 

wire, flat, and round designation for all selected entry ports. 

Using Terminators and Terminator Tables 

About Terminators and Terminator Tables 

 

A terminator is a cabling object with a set of parameters. Terminators are attached 

to the pins of a connector to represent contact, crimp, or other terminator style 

information. The term_name parameter is used to assign a terminator to a pin. 

Use CABLING > Terminators > Create to create a terminator. For a given 

terminator, you can create any number of user-defined parameters using the 

Electrical Parameters dialog box. 

You must first create a terminator and then attach its name to a pin either manually 

or through a terminator table. In a large design, instead of manually attaching 

terminators to each pin, you can create a terminator table to automatically assign 

specific terminators to a specific group of pins. 

A terminator table defines the criteria for a terminator to be matched to a particular 

pin. Specify such criteria in the Terminator Table dialog box and run the table. You 

can add or modify the default criteria to include any connector, connector pin, spool, 

or spool conductor parameter. By specifying combinations of parameters in a 

terminator table, any connector pin that meets the required criteria is automatically 

assigned the specified terminator. 

The terminator table columns define the connector and spool parameters. The first 

column contains the term_name value. This value is the terminator name that is to be 

associated with connections that match the criteria in the remaining columns. 

Use the terminator table to assign terminators based on the diameter of the wire and 

the connector model name. When you regenerate the cabling assembly, the 

connector terminator statement is updated according to the latest terminator table 

that you have run. Settings in a terminator table do not override terminators that 

you have manually assigned, unless you specify otherwise. 

Note: Before you assign a terminator to a connector manually or by a table, the 

NUM_OF_PINS parameter must be defined in the connector parameter file. 
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To Use a Terminator Table 

1. Click CABLING > Set Up > Term Table. The Terminator Table dialog box 

opens. 

2. Type the required terminator name values in the first column as shown in the 

table below. 

3. Use the remaining columns to set the criteria for the term_name assignment. 

Asterisks mean that the value applies to all values of the parameter in the 

column header. For example: 

SET 

PIN 

TERM_NAME 

MATCH 

CONN 

MODEL_NAME 

MATCH 

SPOOL 

WIRE_GUAGE 

MATCH 

COND 

MATERIAL 

mil_14324 conn_A 18 * 

mil_14587 conn_B * copper 

The terminator value mil_14324 is assigned to all pins that have 18 gauge wires 

of any material, using the conn_A part model. The mil_14587 value is assigned to 

all pins on connectors that use the conn_B part model that uses a copper 

conductor of any wire gauge. 

4. After specifying the required parameter constraints in the terminator table, click 

OK. 

5. Click File > ExportTable to save the terminator table to a file. 

6. Click Execute to update all the connector terminator parameters. The term_name 

parameter with the appropriate value is attached to each pin that meets the set 

criteria. 

7. If required, click Insert or Edit to add or delete columns. 

To Create a Terminator 

1. Click CABLING > Terminators > Create. 

2. At the prompt, type a new name for the terminator. The Electrical Parameters 

dialog box opens. 

3. Click View > Columns. The Model Tree Columns dialog box opens. 

4. Move parameters back and forth from the Not Displayed to the Displayed 

windows as necessary. 

5. If required, define a new parameter by typing the parameter name in the Name 

box and clicking >> to move it to the Displayed window. The new parameter is 

added to the current list with Nonexistent as the value. This means a value has 

never been assigned. You can change the value for a single parameter or for 

multiple parameters. 
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6. Click Apply and then OK in the Model Tree Columns dialog box. 

7. Assign a value to the new parameter in the Electrical Parameters dialog box. 

8. Click Apply and then OK to add parameters. 

To Read a Terminator 

1. Click CABLING > Terminators > Read. The Open dialog box opens. 

2. Select the terminator that you want to read from the disk. 

3. At the prompt, type Yes if you want to overwrite the existing terminator. 

To Modify Terminators 

 

1. Click CABLING > Terminators > Edit to modify the terminator parameters. The 

Select Terminators dialog box opens. 

2. Select the required terminator or all the terminators from the list and click OK. 

The Electrical Parameters dialog box opens. 

3. Modify the value of the required parameter in the Electrical Parameters dialog 

box and click OK to apply the changes. 

Note:  

• Use CABLING > Terminators > Read to read in terminator parameter data 

from a previously created terminator that was saved to disk. This file must have 

a .trm extension. 

• Use CABLING > Terminators > Write to write the selected terminator 

parameter data to your current directory. These files have a .trm extension. 

To Write a Terminator 

1. Use CABLING > Terminators > Write to write the terminator parameters to 

the disk. The Select Terminators dialog box opens. 

2. Select the required terminator or all the terminators from the listed that you want 

to save to the disk and click OK. 

3. Modify the value of the required parameter in the Electrical Parameters dialog 

box and click OK to apply the changes. 

Note:  

• Use CABLING > Terminators > Read to read in terminator parameter data 

from a previously created terminator that was saved to the disk. The file must 

have a .trm extension. 

• Use CABLING > Terminators > Write to write the selected terminator 

parameter data to your current directory. These files are given a .trm extension. 
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To Rename a Terminator 

1. Use CABLING > Terminators > Rename to rename the terminator. The Select 

Terminators dialog box opens. 

2. Select the required terminator from the list and click OK. 

3. At the prompt, type a new terminator name and press ENTER. The terminator is 

renamed. 

To Remove a Terminator 

1. Click CABLING > Terminators > Remove. The Select Terminators dialog box 

opens. 

2. Select the required terminator from the list and click OK. The selected 

terminators are removed from the diagram or cabling assembly. 

To Get Information on Terminators 

1. Click Info > Bill of Materials. The BOM dialog box opens. 

2. Select the required options and click OK. 

A list of all the terminators used and the quantity of these terminators is 

displayed in the embedded browser. 

3. To retrieve terminator information for a given harness or for the cabling 

assembly, ensure that you have set the required harness part or the cabling 

assembly as the active model. 

The report symbols available to retrieve complete terminator information for a 

given harness are: 

o &harn.term.name 

o &harn.term.qty 

o &harn.term.<User Defined> 

The report symbols available to retrieve complete terminator information for the 

cabling assembly are: 

o &asm.mbr.connprm.name 

o &asm.mbr.connprm.pin.name 

o &asm.mbr.connprm.pin.term.name 

o &asm.mbr.connprm.pin.term.<User Defined> 

Where <User Defined> is the parameter defined by you as per your requirement. 

Note: Use CABLING > Terminators > List to view the list of terminators in the 

diagram or cabling assembly. 
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Assigning a Terminator Based on the Sum of Multiple Wire Widths 

Use the MIN_SUM and MAX_SUM parameters to choose terminators based on the total 

summed area of potentially multiple wires routed to a pin. 

SET 

PIN 

TERM_NAME 

MATCH 

CONN 

NAME 

MATCH 

CONN 

VENDOR 

MIN_SUM

SPOOL 

AREA 

MAX_SUM 

SPOOL 

AREA 

term1 conn1 amp .1 .25 

term2 conn1 amp .25 .5 

term3 conn1 amp * *  

Note: The term_auto_assign pin parameter determines whether the pin's 

term_name value can be automatically changed. Before you run a terminator table, 

ensure that all the terminators you want to edit are eligible for modification, or 

whether all or some terminators are protected when this parameter is set to False. 

If the term_auto_assign parameter has never been set for a terminator, its value 

does not exist in the Electrical Parameters dialog box. You can update such a 

terminator. 

Using Parameters in Pro/CABLING 

About Modifying Cable and Wire Parameters 

You can modify cable, wire, or bundle parameters by 

• Editing the current values 

• Retrieving a file containing new parameter data 

• Updating the parameters from logical reference data for any matched spool, 

cable, or wire 

When modifying the THICKNESS value, remember the following: 

• If you modify surface offsets for locations individually, then when you modify the 

dimension, the offset values are considered fixed and are no longer automatically 

updated. 

You must change the offset dimension manually to ensure that the cable does not 

interfere with the surface as the diameter at the location increases. Either make 

the surface offset larger to raise the cable above the surface, or change the 

location offset back to Free Height, and let Pro/CABLING do so. 

• If the bundle parameter, THICKNESS, is less than the sum of the thickness of all 

its packed components, Pro/CABLING issues a warning. 

• Changing the thickness of a spool does not automatically update the THICKNESS 

parameter of a bundle created from the cables referencing the spool. To update 

the bundle thickness, you must regenerate the harness part from the CABLING 

menu. This is valid for regular cables as well. 
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You can add columns to the Model Tree that display the status of a particular 

feature, the type of feature, or information about a feature (such as parameters). 

Feature parameters can apply to any feature in an object, while model parameters 

apply only to an entire model. 

Note: You can use the Wire, Cable, or Sheath spool parameters to define the shape 

of the cabling objects, such as wires and cables. For example, THICKNESS, 

MIN_BEND_RADIUS, and so on. 

To Add or Delete Parameters of the Cabling Objects 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Parameters from the MOD CABLE menu. The SELECT dialog box opens. 

3. Select the wires, cables, components, or connectors to modify. 

4. Click OK. The Electrical Parameters dialog box opens. 

5. Under Display For, select appropriately to show or hide the display of 

parameters for different levels of the tree in the left panel. For example, for a 

component, pin, conductor, entry port, and so on. 

6. Click View > Columns. The Model Tree Columns dialog box opens. 

7. Move parameters back and forth from Not Displayed to Displayed windows as 

necessary. 

8. If required, define a new parameter by typing the parameter name in the Name 

box and clicking >> to move it to the Displayed window. The new parameter is 

added to the current list with Nonexistent as the value. This means a value has 

never been assigned. You can change the value for a single parameter or for 

multiple parameters. If you click <<, the parameter name in the Displayed 

window is moved to the Not Displayed window and removed from the current 

list of parameters. 

9. Click Apply and then OK in the Model Tree Columns dialog box. 

10. Assign a value to the new parameter of any object in the Electrical Parameters 

dialog box. 

11. To delete a parameter, select the parameter that you want to delete in the right 

panel of the dialog box and click Delete Parameter. 

12. Click Apply and then OK. 

To Specify Parameter Values Individually 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Parameters from the MOD CABLE menu. The SELECT dialog box opens. 

3. To ensure that you select a correct cabling object, click  or Edit > Find, and 

select the required object. 
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or 

Select the wires, cables, components, or connectors that you want to modify. 

4. Click OK in the SELECT dialog box. The Electrical Parameters dialog box 

opens. 

5. Under Display For, select appropriately to show or hide the parameters display 

for different levels of the tree in the left panel. For example, for a component, 

pin, conductor, entry port, and so on. 

6. Select the parameter you want to edit in the right panel of the dialog box. 

7. Type a new value for the parameter in the Value box and press ENTER. The new 

value for the selected parameter appears in the right panel of the Electrical 

Parameters dialog box. 

8. Click Apply and then OK. 

Note: Both the cable or wires and bundles cannot be displayed together in the 

Electrical Parameters dialog box. 

To Specify Parameter Values for Multiple Objects 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Parameters from the MOD CABLE menu. The SELECT dialog box opens. 

3. To ensure that you select a correct cabling object, click  or Edit > Find, and 

select the required object. 

or 

Select the wires, cables, components, or connectors that you want to modify. 

4. Click OK in the SELECT dialog box. The Electrical Parameters dialog box 

opens. 

5. Under Display For, select appropriately to show or hide the parameters for 

different levels of the tree in the left panel. For example, for a component, pin, 

conductor, entry port, and so on. 

6. In the right panel of the dialog box, click multi-select for the object type that 

you have selected. If a parameter for the object has any nonexistent values, you 

can change all values, including nonexistent values, to the new value or ignore 

the Nonexistent values. 

If the column has any nonexistent values, you can choose between: 

o Create and Set—Changes all values, including nonexistent values, to the 

new value. 

o Set Existing Only—Ignores nonexistent fields. 
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7. Type a new value for the parameter in the Value box and press ENTER. The new 

value for the selected parameter appears in the right panel of the Electrical 

Parameters dialog box. 

8. Click Apply and then OK. All values in a column for a selected object are 

changed to the new value. 

Note: Both the cable or wires and bundles cannot be displayed together in the 

Electrical Parameters dialog box. 

To Specify a Value for Pin Names Across Multiple Connectors 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Parameters from the MOD CABLE menu. The SELECT dialog box opens. 

3. Select the connectors that you want to modify. 

4. Click OK in the SELECT dialog box. The Electrical Parameters dialog box 

opens. 

5. Under Display For, click Pins. 

6. Expand Common Pins. 

7. In the right panel of the Electrical Parameters dialog box, select the specific 

pin name and the parameter value that you want to edit. Values for most 

columns are As Is. This means that values differ for the same pin name across 

connectors. 

8. Type a new value for the parameter in the Value box and press ENTER. The 

values for the selected parameter are updated across all listed connectors for the 

specified pin. 

9. Click Apply and then OK. 

To Specify a Single Value for Parameters Across Multiple 
Connectors 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Parameters from the MOD CABLE menu. The SELECT dialog box opens. 

3. Select the connectors that you want to modify. 

4. Click OK in the SELECT dialog box. The Electrical Parameters dialog box 

opens. 

5. Under Display For, click Pins. 

6. Expand Common Pins. 

7. In the right panel of the dialog box, click multi select to the right of Common 

Pins and above the parameter you want to edit. A prompt appears above the 

tree headings. Values for most columns are As Is. This means that values differ 

for the same pin name across connectors. 
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8. Type a new value for the parameter in the Value box and press ENTER. The 

values for the selected parameter are updated across all listed connectors for the 

specified pin. 

9. Click Apply and then OK. 

To Flip Cable Ends 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Parameters from the MOD CABLE menu. The SELECT dialog box opens. 

3. Select a cable or wire that you want to modify. The cable or wire must have both 

from and to connectors. 

4. Click OK in the SELECT dialog box. The Electrical Parameters dialog box 

opens. 

5. Click Flip Cable Ends to flip the from/to connectors of the selected cable. 

To Display Cable or Wire Parameters in the Model Tree 

1. In the left pane of the Pro/CABLING window, click Settings > Tree Filters. The 

Model Tree Items dialog box opens. 

2. Select the features of the Pro/CABLING assembly that you want to view in the left 

pane of the Pro/CABLING window. 

3. Click OK to apply the changes and close the Model Tree Items dialog box. 

4. Click Settings > Tree Columns. The Model Tree Columns dialog box opens. 

5. In the Type list, select Cabling Params. 

6. Type a parameter name in the Name box at the bottom left of the dialog box or 

select a parameter name from the list of available parameters and press ENTER. 

The new parameter is added to the Displayed list. 

7. Click Apply and then OK. The dialog box closes and the new parameter column 

is added to the model tree. 

8. If required, add more columns to the model tree to display the status of a 

particular feature. 

Adding a Parameter to a Note 

The value of a parameter evaluated in your cabling assembly can be placed as a note 

in drawings of 3D or flat harnesses. You can attach the note to a connector, bundle, 

cable, or wire with or without a leader. 

A parameter can be included in the note by adding &param_name:att to the note 

where param_name is the name of the parameter whose value you want to use in the 

note. The parameter value must exist before the note is created. By default, the 
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value of the parameter that is extracted is based on the item to which the note is 

connected. 

If you attach &name:att as a note to a cable, the name of the cable appears in the 

note. However, if you want a specific type of parameter to be used, add 

_param_type to the note, where param_type is the type of parameter you want to 

use. For example, you can use the name of a spool used for a wire in a note by using 

the note, &name:att_spool. Attaching this note to a wire shows the name of the 

spool that was used to create the wire instead of the name of the wire itself. 

Cabling Parameters 

The following is a list of cabling parameters arranged by object. 

Component Parameters 

REF_DES (Text String) 

MODEL_NAME (Text String) 

NUM_OF_PINS (Integer) 

TYPE (Text String) 

CONN_PLUG (Text String) 

USER_DEFINED (Text String) 

OBJ_TYPE (Text String) 

DEF_INTERNAL_LENGTH (Integer) 

DEF_GROUPING 

TABLE_AUTO_ASSIGN (True/False) 

Connection Parameters 

NAME (Text String) 

SPOOL (Text String) 

REF_DES_FROM (Text String) 

ENTRY_PORT_FR (Text String) 

REF_DES_TO (Text String) 

ENTRY_PORT_TO (Text String) 

MAX_ALLOWED_LENGTH (Integer) 

MAX_ALLOWED_DST (Integer) 

TARGET_LENGTH (Integer) 

FROM_TO_CABLE_REPORT_NAME (Text String) 

TO_CABLE_REPORT_NAME (Text String) 

FROM_CABLE_REPORT_NAME (Text String) 
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USE_PATH (Text String) 

NETWIRE (Integer) 

MIN_ALLOWED_DIST (Integer) 

TYPE (Text String) 

Pin Parameters 

SIGNAL_NAME (Text String) 

SIGNAL_VALUE (Text String) 

ENTRY_PORT (Text String) 

TERM_NAME (Text String) 

TERM_AUTO_ASSIGN (True/False) 

CABLE_NAME_SHIELD (Text String) 

PLUG_MODEL_NAME (Text String) 

PIN_NAME (Text String) 

CABLE_NAME_# (Text String) 

COND_ID_# (Integer) 

TABLE_AUTO_ASSIGN (True/False) 

TERM_PIN_ID (Integer) 

Entry Port Parameters 

TYPE_EP (ROUND, FLAT, WIRE) 

INT_LENGTH (Integer) 

LINK (Text String, another entry port's name) 

Bundle Parameters 

NAME (Text String) 

BUNDLE_TYPE (ROUND, FLAT) 

MIN_BEND_RADIUS (Integer) 

THICKNESS (Integer) 

SPOOL(Text String) 

SHEATH SPOOL(Text String) 

ADDITIONAL NAMES (Text String) 

ASSIGNED_MIN_BEND_RADIUS 

ASSIGNED_THICKNESS(Integer) 

LINESTYLE 
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MATERIAL DENSITY (Integer) 

MIN_ALLOWED_LENGTH (Integer) 

MAX_THICKNESS (Integer) 

MIN_ALLOWED_DIST (Integer) 

OVERLAP_FACTOR 

Conductor Parameters 

WIRE_NAME (Text String) 

STRIP_LENGTH_FROM (Text String) 

AUTO_ASSIGN_FROM (Text String) 

STRIP_LENGTH_TO (Text String) 

AUTO_ASSIGN_TO (Text String) 

COLOR (Text String) (If a string matches the string present in View > Colors and 

Appearance, cables are displayed in that color.) 

LINESTYLE (Text String) (solidfont, dotfont, and so on) 

Routing Cables 

About Routing Cables 

When you have defined spools in the database and created wires or cables from the 

spools, you are ready to add actual cables to the design. You can do this manually or 

automatically. 

Routing manually, you first add a cable or cables to a routing set, then install 

dimensionally constrained points called locations to identify the path of the set. The 

first location can reference a point on an assembly surface or can be attached to an 

entry port on a connector. To capture the design intent, the locations may be fixed 

on surfaces, offset, or dependent on other locations. Therefore, if the assembly 

surfaces are moved, the cable moves with them. 

As you are routing, you can click Switch End to activate the opposite end of the 

cable or Reset Loc to reset the start location. Use Del Portion to remove a 

segment between two selected locations. 

Autorouting 

Using autorouting, you first lay out a default backbone or network of locations where 

you want the main trunk of the harness. Like cables, the network is associated with 

the current working harness. The network location points have the same properties 

as location points used in interactive routing. Additionally they can be assigned 

priorities by connection to better define the paths for the autorouter. 

Networks are by default harness-specific, but you can elect to share a network 

across harnesses, if one network will define a suitable path for two harnesses. 
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When you have added the network, use the Cabling > Route menu to select cables 

to route, then use the Autoroute subcommand to complete the routing. 

Manual Routing 

To add cables interactively, you first select the cable or cables you want to route, 

then you use the cursor to add locations along the path of the cable. The first and 

last locations are usually entry ports on connector components. 

Locations along the path of the cable can be free or dependent. Free locations move 

when you move the cable. Dependent locations associate the cable with an offset 

from a component, so if the component dimensions are edited, the cable length or 

position is edited accordingly. Cables that you route are added to the current 

working harness. Use the commands on the Cabling > Route menu to start the 

interactive routing process. In the following figure, the individual conductors of a 

cable routed to entry ports represent pins. 

 

In the following figure, all conductors of a cable are routed to one entry port. 
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Routing Individual Cable Conductors 

You may need the detail of information provided when you route each conductor of 

the cable separately, as shown in the illustration below. You can accomplish this 

interactively or automatically through autorouting, if you provide the pin-to-pin from-

to and conductor ID information. The most common source of from-to information is 

a logically referenced ASCII wire list or a Pro/Diagram binary file. To route individual 

conductors, you must set the NUM_CONDUCTORS parameter with an appropriate value 

for the respective cable spool. 

 

To Control Cable Shape 

1. Click CABLING > Route. 



Cabling - Help Topic Collection 

58 

2. Select the items to route. The CABLE SEL, ADD CABLES, and ADD CBL SEL 

menus appear. 

3. Use the ADD CBL SEL menu to select or create a cable.  

4. Click Done Sel. The CBL ROUTE menu appears. 

5. Click Cable Envr. The CABLE ENVR menu appears. 

This command lets you control the shape of the routed cable. The settings are 

stored with the assembly and are recalled from one routing operation to the next, 

and for all harnesses, until you change the setting. The settings are applicable 

only for the current Pro/ENGINEER session. 

When you route the cable using straight conditions, the cable appears more as a 

line/arc combination with straight line segments and connecting splines 

alternating as close to arcs as possible. However, smooth routing is used by 

default when straight conditions cannot be maintained. 

The Round or Flat type of grouping does not control the grouping of individual 

items within a bundle routed through a location; that is determined by the 

bundle-type parameter value. 

6. Select the appropriate shape of the routed cable and click Done/Return to 

establish the shape of the cable's cross section. 

To Select Cables to Route 

 

1. Click CABLING > Route. The CABLE SEL menu appears. The SELECT dialog 

box also opens. 

2. Select a wire. 

3. Click OK to complete your cable selection. The CABLE SEL, ADD CABLES, and 

ADD CBL SEL menus appear. 

Using the CABLE SEL menu, you can: 

o Add selected cables to the routing set 

o Remove selected or all cables currently being routed from the set. Use the 

Add command to create a new set before routing. 

o Create a bundle containing the selected cables. 

You can select conductors from several cables before choosing and routing 

wires. Use the multiple selection operations, for instance, you can select 

conductors from several cables before choosing and routing wires. 

To filter your selection for routing using the ADD CABLES menu, you can: 

o Route a continuous segment between two connectors 
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o Limit your choice of cable selection to only those cables or wires not yet 

completely routed (that is, attached to two connectors with a continuous 

length of cable). 

Note: If a component of a bundle is completely routed, it is considered 

complete and does not show in the selection menu if you specify the 

Incomplete command. 

If any conductor in a cable is completely routed, that cable is considered 

complete and does not show in the selection menu. 

Any segment of a wire or cable that is already partially routed either 

between an entry port and a location or between two locations using 

manual routing is considered incomplete. 

o You can select entire cable features for routing or select individual cable 

conductors for routing if they have been defined individually in the cable 

spool. 

Using the ADD CBL SEL menu you can: 

o Select existing wires, cables, bundles, or cable conductors to add to the set 

and a location that will select all items routed through the location. 

o Select wires routed to the connector if there is no logical reference; selects 

those wires routed to the connector in the reference data if there is a logical 

reference 

o Create a cable or wire to be added to the set 

If you select the Create command, you are prompted to create a new wire 

or cable. After choosing either Wire or Cable, you can continue creating 

the new feature as if you had chosen CABLE FEAT > Wire or CABLE FEAT 

> Cable. Wires or cables created now are automatically added to the set of 

cables you select to route. 

The Create command allows you to remove all the cables in the set to 

select a completely new set of cables to route without leaving the CBL 

ROUTE menu or remove the selected cables. 

If the current set contains more than one wire or cable, you can create a 

bundle from any of the cables in the current set. The current set remains 

active until you change it or end the routing process. 

4. Click Done/ Return to end the routing process. 

To Add or Remove Cables from the Routing Set 

 

1. Click CABLING > Route. 

2. Select the items to route. The CABLE SEL, ADD CABLES, and ADD CBL SEL 

menus appear. 
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3. Use the ADD CBL SEL menu to select or create a cable. 

4. Click Done Sel. The CBL ROUTE menu appears. 

5. Click the Change Cbls command from the CBL ROUTE menu. 

6. Click the Add or Remove command from the CABLE SEL menu. 

To Split Cables 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Split Cable from the MOD CABLE menu. The SELECT dialog box opens. 

3. Select a cable that you want to split. 

4. Select a location at which you want to split the cable and click OK. The harness is 

regenerated. 

5. At the prompt, type different names for the two separate cables. The cable is 

successfully split into two separate cables at the selected location. 

To Route Along an Existing Cable 

1. Click CABLING > Route. 

2. Select the items to route. The CABLE SEL, ADD CABLES, and ADD CBL SEL 

menus appear. 

3. Click Select from the ADD CBL SEL menu. The SELECT dialog box opens. 

4. Select the cable and click OK. 

5. Click Done Sel in the CABLE SEL menu. The CBL ROUTE menu appears. 

6. Route to a network location that is used by the cable that you want to follow. 

7. Click Follow Cable and select the cable to follow the same path as an existing 

cable. 

8. To ensure that you follow the correct cable, click  or Edit > Find, and select 

the required cable. 

9. Select another location on the cable that you are following. The cable being 

routed is now automatically routed upto this second location through all the 

intermediate locations that the cable being followed goes through. 

To Route Through a Hole 

1. Click CABLING > Route. 

2. Select the items to route. The CABLE SEL, ADD CABLES, and ADD CBL SEL 

menus appear. 

3. Click Select from the ADD CBL SEL menu. The SELECT dialog box opens. 
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4. Select the cable and click OK. 

5. Click Done Sel in the CABLE SEL menu. The CBL ROUTE menu appears. 

6. Click Along Axis and select an axis to route the cable along an existing axis. 

When you select the Along Axis command as the first routing command for a 

segment, you are prompted to select the direction in which the cable is to be 

routed. 

7. To ensure that you select the correct axis, click  or Edit > Find, and select 

the required axis. The Along Axis command creates two locations at the 

endpoints of an axis in one step. The cable is tangent to the axis at the locations. 

This guarantees that the cable entity passes through the hole normal to the 

surfaces. (The assumption is that the axis is in a hole.) 

If a cable must pass through a hole but does not have to be tangent to the axis, 

you can create a Free location and select the axis. Only a single location on the 

axis is created. 

Note: If you want to route through clamp-down clips, these parts should be 

created with an axis and assembled first. Then, route from axis to axis. This 

method guarantees a smooth trajectory through the parts. 

To Route Through an Axis Offset From Surfaces 

1. Click CABLING > Route. 

2. Select the items to route. The CABLE SEL, ADD CABLES, and ADD CBL SEL 

menus appear. 

3. Click Select from the ADD CBL SEL menu. The SELECT dialog box opens. 

4. Select the cable and click OK. 

5. Click Done Sel in the CABLE SEL menu. The CBL ROUTE menu appears. 

6. Click Offset Axis. You are prompted to select an axis and wire/cable direction. 

7. To ensure that you select the correct axis, click  or Edit > Find, and select 

the required axis. The wire/cable is created along this axis and keeps the offset 

from the surfaces that define the axis placement. 

Single flat surface 

When creating an axis using a surface and a datum plane, the selected surface will 

be considered as a boundary for the cable. The cable moves perpendicular to this 

surface and keeps no interference and no clearance. 
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"V" shape 

When creating an axis using two surfaces, the selected surfaces are considered a 

boundary for the cable. The cable moves perpendicular to those surfaces and keeps 

no interference and no clearance. 

To Copy a Cable Path 

1. Click CABLING > Route. 

2. Select the items to route. The CABLE SEL, ADD CABLES, and ADD CBL SEL 

menus appear. 

3. Click Select from the ADD CBL SEL menu. The SELECT dialog box opens. 

4. Select the cable and click OK. 

5. Click Done Sel in the CABLE SEL menu. The CBL ROUTE menu appears. 

6. With a routing set selected, click Copy Routing. 

7. Select the cable whose path you want to copy. 

The path and the sources of the new cable follow the selected cable. 

Each cable selected for routing is routed along a path of the same shape as the 

source cable. If the source cable has a fixed length, the newly-routed cables have 

the same fixed length. If a portion of the source cable has a fixed length, the 

corresponding portion of the newly-routed cables have the same fixed length. 

The copied cable starts at one of its designated entry ports. It goes through 

locations offset from the entry port's coordinate system; these locations are 

offset from each other by the same amount as the source cable's locations are. 

If any cables cannot be completed you are prompted about the problem. 

Tip: Updating Locations During Routing 

When a cable is routed, Pro/CABLING creates new features to represent both the 

cable and the locations that the cable passes through. 

A cable retains information about where it passes through a location, but the location 

is responsible for packing all entities that pass through it. Subsequent cables routed 

to the same location are arranged by the location relative to their neighbors. 

During routing, Pro/CABLING may display a message prompting you to regenerate 

the cables, to see the correct packing on the screen. 

In this case, Pro/CABLING is updating the location, but it is possible that some of the 

earlier cable features are not aware of the location's changes. As a result, not all 

cables are updated immediately on the screen. 

When you regenerate the cables, Pro/CABLING goes back and updates not only each 

location, but each cable entity as well, giving a completely updated model. 
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To Set a Cable to a Fixed Length 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Length from the MOD CABLE menu. The CABLE LENGTH menu appears. 

3. Click Fix. You are prompted to select locations that are the endpoints of the 

segment. 

4. Select the two required locations on the cable to apply a fixed length to a 

segment. The system displays the current length of the segment which you can 

accept or modify. You can then use this dimension in a relation. 

Note:  

• Use CABLING > Modify > Length > Show to display the dimensions of a fixed 

length cable. 

• Use CABLING > Modify > Length > Change to modify the value of a fixed 

length cable. 

• Use CABLING > Modify > Length > Free to remove the fixed length constraint 

of the cable so that the cable no longer has a fixed length. 

To Calculate the Current Length of a Segment 

1. Click CABLING > Relations. The Relations dialog box opens. 

2. Click Utilities > Evaluate. The Evaluate Expression dialog box opens. 

3. Specify Cabling mode function cable_len() in the Expression box to calculate 

the length of a cable. 

To calculate the current length of any segment of a cable or bundle, use the 

following syntax: 

cable_len ("cable_name",location_id1,location_id2) 

To calculate the length for the complete cable from end to end, use the following 

syntax: 

cable_len ("cable_name",-1,-1) 

where 

• cable_name is the name of the cable being measured in the current 

harness. 

• location_id is the internal feature ID of the location through which the 

cable_name is routed. Where 1 and 2 denote the two cable locations 

between which the length is to be calculated. 

4. Click Evaluate. The length of the cable or bundle is displayed in the Result box. 

5. Click Close in the Evaluate Expression dialog box. 

6. Click OK in the Relations dialog box. 
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Using Bundles During Manual Routing 

 

You can automatically place wires in a bundle during manual routing, thus reducing 

the number of picks required to clean-up the routing, and simplify the display of the 

harness. 

When you select CBL ROUTE > Cable Env and check the Rt in Bndls checkbox, 

manually routed wires behave the same way as autorouted wires. If wires are 

manually routed using FOLLOW CABLE along a path occupied by a bundle, these 

wires are automatically added to that bundle. If more than one bundle exists along 

that path, you are prompted to select which you want to use. 

To Delete All or Part of an Individual Cable Segment 

1. Click CABLING > Feature > Delete. The DELETE CABLE menu appears. 

2. Click Cable Portion and select the bounding locations of the portion to be 

deleted. 

3. If more than one cable is routed through the selected locations, a DEL CABLE 

menu appears that contains a list of all the cables that are routed through the 

selected locations. 

4. Select the cables to be deleted from the menu, and a check mark appears next to 

the selections. 

Note: Deleting a location using Del Feature deletes all children (cables and 

bundles that are routed through the location). 

5. If you want to remove a location from the harness but not delete the cable, or to 

remove a single wire or wires from a location, use CABLING > Location > 

Remove. 

6. When you select a cable to delete, the first entity that appears is the cable 

segment. If you want to delete the entire cable, use Edit > Find and select the 

cable you want to delete. 

Note: If you delete all cable or bundle portions from the assembly, this still does 

not remove it from the list of available cables that can be routed. The cable or 

bundle feature still exists. 

To Get Cable and Wire Info from the Display 

1. Click Info > Cabling from the menu bar to get information about selected 

harnesses and cables in the assembly. The Cabling Information dialog box 

opens. 

2. Use the Information Type options and the associated options to set up an 

information readout. When you have set up the query, click Apply. 

3. If you choose any one of the harness options say, Individual or Partial, the 

HARNESSES menu appears with a list of existing harnesses in the part. Select 
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the harness whose information you want to display, the INFORMATION WINDOW 

appears. 

Using this procedure, you can get the name, conductor contents, and highlight the 

path of any selected cable or harness feature. 

To Check Cable Clearance 

1. Click Analysis > Model Analysis from the main menu line. The Model Analysis 

dialog box opens. 

2. Select Pairs Clearance in the Type box. 

3. Select From/To items to measure the clearance. 

4. Select whether you want to check the clearance along the whole cable feature by 

Cable or only for a segment by choosing Single entity. 

5. Select a cable from the assembly. If you chose the Cable command in the 

previous step, the entire harness is used to measure clearance. If you chose the 

Single entity command in the previous step, the segment you select is used to 

measure clearance. 

6. You can select the Whole subasm, Whole part, and Surface commands as 

items to measure clearance From and/or To. You can select a harness part using 

the Whole Part command. 

7. When you select a harness part with the Whole part selection type, 

Pro/CABLING calculates the clearance between the entire harness part and the 

other selection (such as a second harness part) in the same way an individual 

cable is chosen with the Cable command. 

8. Select the second cable or assembly component. 

9. Click Compute. The clearance between the selected items is displayed in the 

Results box. If you click Info, an INFORMATION WINDOW opens with the 

clearance results displayed in the window. 

10. Click Close to exit the Model Analysis dialog box. 

Note: You can determine the clearance between cables, and between cables and 

assembly members. 

To Check Global Clearance for Harnesses 

1. Click Analysis > Model Analysis. The Model Analysis dialog box opens. 

2. Select Global Clearance in the Type box. 

3. Click the Include to include harness parts in the Harness box. 

4. Click Compute. Pro/CABLING calculates the global clearance of each harness 

part and the information appears in the Clearance window in the Setup box. 

5. Click Close to exit the Model Analysis dialog box. 
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Note: You can include harness parts in the global clearance checking process. The 

checking of harness parts does not include the checking of interferences between 

cables within a harness part. The check is between the entire harness part and other 

parts, such as assemblies and harness parts. 

To Route Individual Conductors 

Use this procedure to route individual cable conductors to selected entry ports. 

Cables must be in the Centerline mode. Ensure that you set the NUM_OF_CONDUCTORS 

parameter for the respective cable spools before routing. 

1. Click CABLING > Route. 

2. Select the items to route. The CABLE SEL, ADD CABLES, and ADD CBL SEL 

menus appear. 

3. Select Conductors from the ADD CABLES menu. 

4. Click Select from the ADD CBL SEL menu. The SELECT dialog box opens. 

5. Select the wire or cable to route conductors from and click OK. The SEL 

CONDUCTORS menu appears. 

6. Check the boxes for the conductor or conductors you want to select an entry port 

for. To route a wire to an entry port, check the wire before you proceed. If you 

want to route more than one wire to an entry port, check the multiple boxes. 

7. Click Done Sel, and CABLE SEL > Done Sel. The CBL ROUTE menu appears. 

8. Click Entry Port and identify the connector and entry port you want to connect 

to. A location is established on the entry port. 

9. Click Location and click on the location at the end of the cable segment, where 

you want the conductor to come from. The conductor is routed to the entry port. 

Repeat from step 1 for each separate conductor you want to route. 

In the following figure, individual conductors are routed to different entry ports. 
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Using Locations 

About Locations 

 

Locations are points, similar to datum points, that cables follow during routing. The 

locations describe the offsets and fixed points of the cable's path through an 

assembly. Use the locations to capture the design intent in case of changes to the 

assembly's dimensions. You can assign dimensions and constraints to capture the 

design intent of the cable and harness if changes are made to the assembly. 

Locations are also required for autorouting. When you define a path, multiple wires 

and cables can follow the path during autorouting. Two kinds of location points are: 

• Free—You can place a free location as a point on any surface, curve, axis, or 

network segment. It is automatically offset by 0.6 of the radius of the cable or 

cables passing through the location. Free locations on curves, axes, or other 

cable entities are always centered on the entity and tangency is not constrained. 

• Dependent—A dependent location has the same default offset and directional 

values as the free location, but you are prompted for a dimension from the 

previously specified location, and an offset from a second selected surface. When 

the reference entity is moved, the locations move with it. 

Use the dependent location when you must route along a complex surface, when 

the cable must follow a straight line as seen from the top or side view. If you 

must move the cable, you can move only the reference location, and the 

dependent locations move with it. 

An offset location is similar to a dependent location, but lets you define the 

location relative to three dimensions. Other location types place the path along a 

selected axis or parallel to a channel. Use an Offset location to place cables in a 

tight passage or cramped volume; the cables move relative to assembly 

geometry. You can use the Offset command to create locations relative to a 

global coordinate system, but you should avoid this exclusively because the 

resulting trajectory has no reference to the assembly and does not capture your 

design intent. As with Dependent type locations, Offset locations cannot be used 

as a starting point for routing a cable set. 

After specifying locations of any kind, you can optionally attach a width constraint 

to them for the cable to be routed through the location. 

To Create a Dependent Location 

1. Click CABLING > Route > Select or CABLING > Network Ops > Route. For 

the both routines, the CBL ROUTE menu appears. 

2. Click Free. Use the pointer to make a new free location as a reference for the 

Dependent location. 

or 

Select an existing free location. 
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3. Click Dependent to route from or to a point and dimension to the previous 

location. 

4. Select a point on a curve or surface where you want to install a dependent 

location. You are prompted to select the first direction. 

5. Click  or Edit > Find to select an edge, axis, or curve. You are prompted to 

select a reference for the second direction. 

6. Similarly, select an edge, axis, or curve for the second direction. The location is 

installed where you clicked in step 3. 

To Create a Use Dir Location 

1. Click CABLING > Route > Select or CABLING > Network Ops > Route. For 

the both routines, the CBL ROUTE menu appears. 

2. Click Use Dir. 

3. Select a straight curve or cable portion, axis, edge, or channel. The OFFSET 

menu appears. 

4. Select one of the following: 

o Thru_Point—Creates a parallel datum plane that intersects the point that 

you specify on the part surface. 

o Enter Value—Type an exact dimensional value for the datum to be offset 

from the plane in the direction of the red arrow. If the arrow points in a 

direction that is opposite the one where you want to send the location, type 

a negative number. 

Note: To modify the dimensional value of the offset, choose CABLING > Modify 

and then select the location. Click Regenerate to view the results. 

To Create an Offset Location 

1. Click CABLING > Route or CABLING > Network Ops > Route routines. The 

CBL ROUTE menu appears. 

2. Click Offset. The OFFSET LOC menu appears. 

3. Select three straight edges or a coordinate system. No tangency is enforced at 

the location. 

4. Specify the point from which the offsets are measured. 

5. Select a command from the OFFSET LOC menu. 

o Specify Dirs—Specify directions for dimensioning a new location. 

o Specify Portion—Select a portion of network to create a offset copy. 
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o Specify From—Specify the point you are offsetting from. Note that this 

point need not refer to the location from which you are routing. The 

commands in the Specify From menu are: 

Previous Loc—(default) The new locations are offset from the previous 

location. The previous location is highlighted. You can use the Reset Loc 

command to specify the location to be referenced before you start creating 

the offset location. 

Select Pnt—The new locations are offset from a selected datum point or 

edge or curve vertex. 

6. After specifying reference directions and origins, select Make Locs from the 

OFFSET LOC menu. 

This begins the creation of offset locations based upon given references. An 

arrow appears for each direction. Type the offset value for each as required. After 

every three offsets, a new location is created. The command is modal, that is, 

you can continue to enter offset values using the current directions. 

7. When you are finished entering offsets, or want to specify a new direction or from 

point, press ESC. This exits the prompt and you can begin again with Step 1. 

8. To return to the CBL ROUTE menu, click Done/Return. 

To Get Information on Locations 

1. Click Info > Location. 

2. Select a location that you want to query. An INFORMATION WINDOW appears 

that displays the location ID, the cables passing through the location, the feature 

the location is attached to, and other design-specific information. 

To Redefine Location Types 

1. Click CABLING > Location > Redefine. 

2. Select the location to redefine. The REDEFINE_LOC menu appears. 

3. Redefine the location using one of the following commands: 

o Pt/Vtx/Csys 

o Free 

o Dependent 

o Use Dir 

o Offset 

4. Select a new type of location and recreate the feature. 

Note:  

o You cannot redefine one free location to be multiple offset locations. 
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o You cannot redefine a connector location. 

Note: Use CABLING > Location > Reroute to reroute locations to other 

references. 

To Redefine a Location Along an Axis 

 

1. Click CABLING > Location > Redefine. The SELECT dialog box opens. 

2. Select a location along an axis that you want to redefine. You are prompted to 

move all the wires, cables, or bundles to another axis instead of redefining the 

selected location. 

Note: You cannot redefine connector type locations. 

3. At the prompt, click Yes. You are prompted to select an another axis. 

4. To ensure that you select the correct axis, click  or Edit > Find, select the 

required axis, and click OK. The DIRECTION menu appears. You are prompted 

to define the required direction for the selected axis. 

5. Click Flip to specify the reverse direction of the arrow. The selected end of the 

new axis is highlighted. 

6. Click Okay to accept the direction of arrow. The harness is regenerated and the 

cables and wires are autorouted to follow the new direction that you have 

defined. 

Note: 

• You can switch between Flat and Round to indicate the grouping of cables as 

they pass through locations. 

• You can modify the rotation of a location with the Rotate command on the MOD 

LOCATION menu. 

To Edit Location Dimension Values 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Mod Dim. The SELECT dialog box appears. 

3. Select one or more locations to show its dimensions. You can select any number 

of locations. 

4. After they are displayed, you can select the dimension and type a new value in 

the box. 

The dimensions for locations that can be modified are: 

o Free location—The offset from the surface. If you modify this dimension 

directly, free locations will not automatically maintain their relative distance 

off the surface as they change thickness. 
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o Dependent location—For dependent locations on surfaces, there are three 

dimensions: two for the references selected and one for the offset from the 

surface. For a dependent location on a curve or cable, only the offset from 

the previous location, in the direction specified, can be modified. 

o Offset location—The three dimensions for the three directions specified. 

o Use Dir location—The offset dimension from the previous location in the 

direction of the reference. 

Note: Alternatively, you can also use CABLING > Location > Free Height to 

adjust the height of the location to the thickness of the cables. 

To Constrain Cable Thickness at Locations 

1. Click CABLING > Location >Max Diameter. The MAX DIAMETER appears. 

The SELECT dialog box opens. 

2. Click Set. You are prompted to select a location or locations to specify a 

maximum diameter for. 

3. Select a location and click OK. The current diameter is displayed at the prompt. 

4. Accept the current diameter or type a new maximum diameter for the selected 

location or locations and press ENTER. The selected locations are now constrained 

to the specified diameter. If adding wires to the cables passing through these 

locations results in a violation of the constraint, the wires are not added and you 

are notified of the violation. 

Use the MAX DIAMETER menu to remove the limit on the maximum diameter 

for items routed through locations or from all locations in the active harness. 

To Move a Location 

 

1. Click CABLING > Location > Move. The MOVE LOC menu appears. 

2. Click Move to select a location to move, select a different point on the current 

surface, and position it using the SELECT dialog box. Use Discard to undo any 

relocated positions. When the new positions have been defined, click Update to 

regenerate the new path. 

or 

Click Drag to select a location and visibly drag the location along current 

direction to a new position. Click to select a new placement and middle-click to 

cancel. Drag allows you to make small adjustments in a rubberband view by 

selecting a location on the surface or axis. 

3. Click Done in the MOVE LOC menu. 

Note: Movement in either move or drag mode depends on the location type and any 

directional constraints associated with it. You can not move fixed length segments 
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beyond the length constraint. If you drag a parent location, the child locations follow 

accordingly. 

To Modify Packing at Locations 

1. Click CABLING > Location > Packing. 

2. Select a flat location to modify packing, the Modify Packing dialog box opens. 

3. Modify the Cable name or Thickness and set the other settings appropriately. 

You can cut and paste items in the list of items at that location to modify the 

shape of the flat grouping. When you select an item in the list, the item is 

highlighted in Pro/ENGINEER. 

4. Click Apply to preview the visual changes to the packing in your assembly 

without making them permanent and OK to close the dialog box. 

To Add Locations to Previously Routed Cables 

 

1. Click CABLING > Location > Add. You are prompted to select a point on a 

segment.  

2. After selecting a point, click the type of location from the ADD LOCATION menu. 

You are prompted to select a point to add a location between existing locations 

on previously routed cables. 

3. Click to select a point on a curve or surface. You are prompted to define the 

necessary constraints for the location type. 

To Modify the Size of Location Nodes in Drawing 

1. Specify a value in drawing units of the detail setting, location_radius. This sets 

the radius of the nodes displayed. You can specify the word DEFAULT as the value 

of this setup option. The default value is 2. 

2. If you specify the setting as 0.0, the location nodes are displayed, but do not 

print. 

Note: Modifying the size of the location nodes is helpful when printing drawings. 

To Remove Locations 

1. Click CABLING > Location > Remove. The LOC REMOVE menu appears and 

the SELECT dialog box opens. 

2. Click ItemFromLocs to remove a single item from multiple locations. Select a 

location to remove. If you select a location at a branch, Pro/ENGINEER identifies 

a segment, and the SELECT SEG menu appears. Click OK, choose the second 

location at the end of the selected segment to delete both the locations, and click 

Yes at the prompt to accept the changes. To remove a single location, select the 

location and middle-click. the location is removed. 
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or 

Click ItemsFromLocs to remove multiple items from multiple locations. Use the 

SEL CABLES menu to select all the items passing through the selected locations 

and click Done Sel. Select another location and click OK in the SELECT dialog 

box. To remove the items and the locations, you are prompted to click YES at the 

prompt. 

Note: Any location except a Use Dir or Connector location can be removed as long 

as at least two locations remain to define a cable segment. A location with children 

cannot be removed. 

Using Locations with Channels 

About Channels 

Channels are conduits for defining direction, or for terminating cables to a conductive 

strip (as a ground or as part of the live circuit). Channels are also the basis for 

modifying cables using cross sections. You can remove an existing channel with the 

Remove command. 

To Define a Channel 

1. Click CABLING > Channel > Add. 

2. At the prompt, type a new name for the channel. 

3. Select the type of channel you want to add: 

o Ground—The channel is a conductive strip connected to ground. 

o Conduct—The channel is a conductive strip. 

o Direction—The channel establishes a direction for the cable being routed 

with respect to it. 

4. Click Done or Quit. 

5. Select the geometry representing the channel. You can select a surface for a 

conductive surface and a straight edge, axis, or curve to establish the direction. 

To Place Locations in Channels 

1. Click CABLING > Route or CABLING > Network Ops > Route. The CBL 

ROUTE menu appears. 

2. Click Free or Dependent to place a location on a surface in the channel. This 

surface need not actually belong to the channel. 

3. To use the direction of the channel, edge, or axis to route parallel to, click Use 

Dir and select the channel as the reference. 
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Note: The method to create a loopback in the channel, that is, change direction is to 

add a Free location on the surface and then continue with more Use Dir type 

locations selecting the channel. 

To Move Locations in a Channel Cross Section 

If you have created a network using a free location and the second location using the 

CABLING > Network Ops > Route > Use Dir command based on the direction of 

the channel: 

1. Click CABLING > Location > ByXsec. 

2. Select a channel to cross-section. You can modify locations routed through a 

channel by cutting a cross-section through the channel, selecting the cables, and 

moving them to new location. 

Note: You can redefine only a free location. 

3. Select a point through which the cross-section must pass. You are prompted to 

confirm the selection point. 

4. Click Yes. The model appears in a drawing window. You are prompted to select 

the top edge to orient the cross-section. 

5. When you select the top edge, the model orients to the cross-section of the 

channel. Use the Zoom dialog box to zoom in or out of the view and click OK in 

the dialog box. 

6. Use the CABLING > Location > Move. The MOVE LOC menu appears. Use 

these move commands to move locations in the cross-section. 

7. When the edits are complete, click Done. 

Note: The location must be routed such that there are no other locations that lock 

the location into a specific place, such as an Offset or Dependent location. 

Using Bundles 

About Bundles 

A bundle is a sheath feature containing one or more cables, wires, or other bundles 

that pass through the same location. Bundles are created from sheath spools. You 

can also create a bundle without a SHEATH spool. They have thickness, color, and 

minimum bend radius parameters of their own. In lists of cables or wires, bundle 

names are marked by an asterisk. 

You can add cables to a bundle after they are routed or create the bundle as 

unrouted, add the cables to it, and then route the bundle (and all its cables) at once. 

To sheath wires that branch from the bundle in a T-junction, you can add a branch 

bundle at a selected location along the main bundle. The following figure displays a 

single bundle with two branch bundles. 
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Branch Bundles 

Branch bundles allow cables to leave a bundle in sheathed branches. Use the 

following ways to determine the branch location: 

• Select a existing location on the original bundle, or 

• If cables diverge in two directions, select both the locations where the cables 

diverge from the original bundle and find a midpoint between the two locations. 

Note: 

• While creating bundles before routing, it is not necessary to create a bundle to 

route multiple cables at the same time. 

• The minimum bend radius of bundled wires is the larger of one-half of the bundle 

diameter or the largest min_bend_radius of any component of the bundle. 

Bundle Grouping Property 

Bundles can be grouped as round or flat. After you create a bundle, you must group 

the cables. Use one of the following grouping types: 

• Round—Packs the cables together in a round grouping. This corresponds to the 

ROUND value for the BUNDLE_TYPE parameter. 

 

• Flat—Packs the cable together in a flat grouping. This corresponds to the FLAT 

value for the BUNDLE_TYPE parameter. The bundle diameter is equivalent to the 

total thickness of each individual component of the bundle. 
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To Bundle Existing Cables 

1. Click CABLING > Feature > Create.> Bundle. 

2. At the prompt, type a new name for the bundle. The GROUPING menu appears. 

3. Select the grouping type that is the way the bundle components are packed 

together in the bundle. The bundle diameter is equivalent to the total thickness of 

each individual component of the bundle. 

The SPOOL NAMES menu appears, listing all sheath spools available in this 

cabling assembly. 

4. Select an existing sheath spool to be used to sheath the new bundle or create a 

sheath spool for the bundle being created. If you select None, it specifies that no 

sheath spool should be used for this bundle. The bundle is created from default 

parameters. When you have assigned a spool, the BUNDLE OPTS menu 

appears. 

5. Select a set of cables for this bundle and click OK in the SELECT dialog box. 

6. At the prompt, type the file name to read bundle parameters from. 

7. Click Along Path. The SELECT dialog box opens. You are prompted to select two 

locations defining the extents of the sheath. 

8. Select the two locations. If any cables branch from the path between the two 

selected points, you are prompted to specify whether to include the partially 

routed cables in the bundle. Partially routed cables in this case are the cables 

that diverge from the bundle path. If the path contains cables that you want to 

include in the sheath as branches, type Yes. If you want these cables to be 

outside the bundle, type No. You are prompted for a parameter file to read into 

the new bundle. 

9. At the prompt, type a file name containing the bundle parameters and press 

Enter. You can modify these parameters later. The new bundle is created. You 

can add a bundle sheath feature to a group of cables that share the same path. 

To share a path, cables use the same location. In thin Cable mode, a single line 

marks the path of the bundled cables. In thick Cable mode, the sheathing is 

displayed. 

To Create an Unrouted Bundle 

1. Click CABLING > Feature > Create.> Bundle. 

2. At the prompt, type a new name for the bundle. The GROUPING menu appears. 

3. Select the grouping type that is the way the bundle components are packed 

together in the bundle. For a Flat grouping type, the bundle diameter is 

equivalent to the total thickness of each individual component of the bundle. 

The SPOOL NAMES menu appears, listing all available sheath spools. 
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4. Select an existing sheath spool for the new bundle, click Create to create a new 

sheath spool or None to specify that the bundle does not have any sheathing. 

When you have assigned a spool, the BUNDLE OPTS menu appears. 

5. Click Unrouted. 

6. Select a set of cables and bundles that are not yet completely routed.and click 

OK in the SELECT dialog box. A dialog box opens with a list of cables and 

bundles. 

7. Click Done Sel. 

8. At the prompt, type a file name containing the bundle parameters and press 

ENTER. You can modify these parameters later. 

The new bundle is created in the database and appears as a selection when you 

are adding items to be routed. 

To Create a Branch Bundle 

1. Ensure that you have created the main bundle before creating a branch bundle. 

2. Click Feature > Create > Bundle. 

3. At the prompt, type a new a name for the bundle. 

4. Select the grouping type to specify the way the bundle components are packed 

together in the bundle. For a Flat grouping type, the bundle diameter is 

equivalent to the total thickness of each individual component of the bundle. 

The SPOOL NAMES menu appears listing all available sheath spools. 

5. Select an existing sheath spool for the new bundle, click Create to create a new 

sheath spool or None to specify that the bundle does not have any sheathing. 

When you have assigned a spool, the BUNDLE OPTS menu appears. 

6. Click Branch. You are prompted to define the extents of the branch. 

o If your cables converge into the branch from both directions: 

a. Select the two locations on the main bundle defining the extents of the top 

of the "T" connection. (Locations 1 and 2 in the figure below.) When you 

have selected the two locations, you are prompted to select the third 

location, defining the end of the branch. (Location 3 in the figure below.) 

b. Select the third location, Pro/Cabling places a new location on the main 

bundle midway between the extents you defined, and draws the proposed 

branch bundle as a centerline. You are prompted to enter parameters for 

the new branch bundle. 

c. At the prompt, type the parameters or press ENTER to use default 

parameters, the new branch bundle is created. 

o If cables enter the branch from one direction: 
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a. Select the location where the cable leaves the path, then click OK. You are 

prompted to select the location to be used as the outer extent of the 

branch. 

b. Select the location, Pro/Cabling draws the proposed branch bundle as a 

centerline. You are prompted to enter parameters for the new branch 

bundle. 

c. At the prompt, type the parameters or press ENTER to use default 

parameters, the new branch bundle is created. 

 

Selecting the branch bundle locations

 

The completed bundle 

7. Click Done/Return. 

Note: Use this procedure to add a branch bundle to a regular bundle, where cables 

leave the shared bundle path. You must use Along Path to create the main bundle 

before you create the branch. 

To Modify a Bundle 

1. Click CABLING > Modify. The MOD CABLE and MODIFY menus appear. 

2. Click Mod Bundle from the MOD CABLE menu. 

3. Select a bundle to modify. The MOD BUNDLE menu appears. 

4. Click  or Edit > Find to select the bundles by name. 

o If you select a branch bundle, a warning message appears at the prompt. 

Click Yes to extract all cables and remove the bundle itself. After 

extracting, the cables are left routed, running parallel to the bundle. 

o If you select a straight bundle, use the appropriate MOD BUNDLE 

commands to add or remove cables from an existing bundle, or to extract 

all cables from an existing branch bundle. 

NOTE: Sections only within the bundle are deleted. 

5. Select the appropriate bundle using the Search Tool dialog box. 
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6. Click Apply and then OK or click OK to apply and close the Search Tool dialog 

box. 

About Aligning and Unaligning Bundles 

When several bundles meet at a single location, the bundle ends may be aligned or 

unaligned by default. If bundle ends at a single location are aligned by default, they 

can be unaligned. Similarly, if bundle ends at a single location are unaligned by 

default, they can be aligned. 

The following figure shows a bundle that has been split into three smaller bundles. 

The bundles are unaligned. 

 

The following figure shows bundles after they are aligned. 

 

To Align or Unalign Bundles 

1. Click CABLING > Location > Bundle Alignment. The Bundle Alignment 

dialog box opens. 
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2. Select one of the following to align or unalign bundles: 

o Locations—Select the locations at which you want to change the 

alignment. The selected locations are displayed. You can select only those 

locations at which the bundles end or start. 

o Align—Aligns the bundles at the specified location. 

o Unalign—Unaligns the bundles at the specified location. 

3. Click Apply to continue aligning or unaligning bundles at new locations or OK to 

close the Bundle Alignment dialog box. 

4. Click CABLING > Regenerate. 

Note: The align_cable_bundles configuration file option is used to align or unalign 

bundles but applies to bundle locations and not the bundles themselves. The default 

value is Yes. 

When creating locations, if the align_cable_bundles configuration file option is set 

to Yes, bundles at such locations are aligned by default. But if this option is set to 

No, bundles at such locations are unaligned by default. 

Use this procedure to align bundles at locations created with the 

align_cable_bundles option set to No or to unalign bundles at locations created 

with the align_cable_bundles option set to Yes. 

To Query Bundle Contents 

1. Click Info > Cabling. The Cabling Information dialog box opens. 

2. Under Information Type, click Physical Routing. 

3. Click Bundle Items. 

4. Select a bundle to query. The bundle contents are displayed in the INFORMATION 

WINDOW. 

5. Click Close to close the Cabling Information dialog box. 

To Extract Cables from a Bundle 

1. Click CABLING > Modify > Mod Bundle. The SELECT dialog box opens. 

2. To ensure that you select the correct bundle, click  or Edit > Find, select the 

required bundle, and click OK. The MOD BUNDLE menu appears. 

3. Click Extract. The SEL BUNDLES menu appears. All the wires and cables inside 

the selected bundle are available for selection. 

4. Select the wires and cables that you want to extract or click Select All to select 

all the wires and cables. 

5. Click Done Sel to extract the selected wires and cables or all the wires and 

cables from the selected bundle. 
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Autorouting 

About Autorouting 

Before autorouting the cables or wires, you must establish a logical reference to a 

Pro/ENGINEER diagram file or a wire list text file in a supported format. Cabling 

depends on the information in the wire list for the from-to connection information 

that associates conductors and cables with individual entry ports (pins) on 

connectors. In a logically referenced diagram, the ENTRY_PORT pin parameter must 

be assigned to the corresponding coordinate system in the selected Cabling 

assembly. If the ENTRY_PORT parameter is not defined in the logically referenced 

diagram, the wires or cables cannot be autorouted. 

After establishing a logical reference, you must set up a network using the CABLING 

> Network Ops command. The network is defined by location points that are not 

routed. You can specify location priorities in the network, for example, allowed or 

disallowed, as needed for the network locations. Optionally, you can define paths 

within the network and assign specific cables to them. 

You can accept or reject the resulting routing. In case of errors in your autorouting 

procedure, the failure information for the wires, cables, or incomplete conductors is 

saved in the autoroute.fails file. 

Use the CABLING > Network Ops > Route > Autoroute command to route the 

selected wires or cables between their from and to connectors. The wires 

automatically follow the shortest path through the network that you set up. 

Note: You can use autorouting to complete a harness part without a logical 

reference if you manually route a small piece of each cable from its last location to 

its terminating connector. This establishes the connection of the wires, cables, or 

cable conductors with the pins or connectors. The logical reference method is a faster 

method. 

To Autoroute Wires and Cables 

1. If you have performed the setups described in the About Autorouting topic, you 

can start the autorouting process. 

2. Regenerate the harness before you autoroute. 

3. Use the Cabling > Route commands to add cables and wires to the routing set 

as you would for manual routing. The CABLE SEL, ADD CABLES, and ADD CBL 

SEL menus appear. 

4. Click Select from the ADD CBL SEL menu. The SELECT dialog box opens. 

5. Select the cables or wires and click OK. 

6. Click Done Sel in the CABLE SEL menu. The CBL ROUTE menu appears. 

7. Click Autoroute. Pro/CABLING autoroutes the cables you have selected to be 

routed in the network. The AUTOROUTING menu appears. 
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8. Click Rehighlight to display the autorouted cables in your assembly. The wires 

and cables that you have added are highlighted. 

9. Click Accept or Reject to accept or reject the resulting routing, respectively. In 

case of errors in your autorouting procedure, the Autorouting Failure 

Information dialog box opens. 

10. Click More Info. The INFORMATION WINDOW opens and prompts you to look at 

the autorte.fails file information. This error file contains the following 

information: 

o Wire number 

o Explanation of the problem, for example, insufficient entry_port 

information 

o Suggested fix 

Autorouting Bundles 

Bundles by themselves cannot be autorouted as they do not extend completely from 

connector to connector and thus have no From or To logical information. If you select 

a bundle for routing and attempt to autoroute, the bundles are not autorouted. Use 

the Route Wires command on the RMV BNDLE menu to autoroute the items 

contained in the bundle, but not the bundle itself. 

If you select the Ignore Wires command on the RMV BNDLE menu, the contents of 

the bundle are not autorouted. 

Autorouting to Splices 

If you designate a splice as the connector for a wire, autorouting routes the wire to 

the splice as it routes to any connector. 

If the splice is not assembled, you can autoroute the wire with one connector and 

one required location, and later insert the splice at the required location. 

Tip: Autorouting through Components 

Wires can be autorouted through components. There need not be any network 

segment that contact two entry ports with an internal cable portion between them. 

Instead, Pro/CABLING assumes that each time a network segment is routed to a 

different entry port, all network segments are connected, even though the internal 

segments do not show. 

Troubleshooting for Autorouting 

If autorouting fails, read the autorte.fails file for solutions to the problem. Other 

areas that you could investigate are as in the following table: 
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Autorouting Failure 

IF... THEN... 

Autorouting fails, some of the items may 

have failed or been in a state of failure 

before the autorouting 

Regenerate these items and 

autoroute again. 

Regeneration fails during autorouting Ensure that you have 

regenerated the harness 

before you autoroute. 

The harness was regenerated and the 

autorouting still fails 

An autorouted wire may 

have caused a 

min_bend_radius violation 

Autorouting fails because you added items 

to a bundle which increased the 

min_bend_radius, that is now violated 

Decrease the 

min_bend_radius of the 

bundle by modifying its 

parameters or modify its 

routing and autoroute again 

The cable is already completed and a 

continuous segment already exists 

between two connector entry ports. 

Check if the cable is already 

routed according to the 

diagram. 

The conductor logical information does not 

match, the cable is completely routed, but 

the logical information specifies that the 

cable conductors be routed to separate 

entry ports on the connector (s). 

Delete cable segments 

nearest to connectors using 

Del Portion and reroute the 

individual conductors 

manually. 

There is insufficient entry-port 

information, the cable cannot be 

autorouted because the system cannot 

determine where to attach to the 

connector(s). Either there is no entry port 

designated, or there is more than one 

entry port designated but the pin signal 

ENTRY_PORT parameter has no value. 

Ensure that the entry ports 

are designated and the pin 

signal ENTRY_PORT 

parameter has a value 

assigned to it. 

The logical and physical entry ports do not 

match, a cable may only attach to two 

connector locations (except when routing 

through a splice). For the cable above, the 

system cannot determine the correct From 

and To connectors because there are two 

correct logical connectors in addition to 

one or two physically routed cable 

segments routed from other connectors. 

Ensure that the names of the 

logical and physical entry 

ports for both diagram and 

cabling match. 
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No path through the network is found, the 

location priorities may be set so that the 

required or disallowed locations prevent a 

complete path from existing. Autorouting 

with a network that is not all connected 

may mean there is no path between 

connectors. Also, the tangencies of the 

existing network locations do not allow 

routing between connectors. 

Add additional network 

segments and autoroute 

again. 

The cable has too many ends to route too 

many independent segments touching the 

network for the system to determine 

which should be used for routing. 

Ensure that the cable does 

not contain more than one 

manually routed segment. 

Using the MBR Failure Diagnostic 

If autorouting fails because of an MBR (Minimum Bend Radius) violation, the 

segment where the violation occurred is highlighted, and a new dialog box opens. 

This dialog box provides tools to collect more information about the failure and how 

to fix the failure. 

Use this dialog box to: 

• Highlight failures in a wire 

• Route the wire and ignore failures 

If the routing of the wire segments fail upon regeneration, fix the failure using 

Resolve options, or fix it before regeneration. 

• Select not to route the failed wire. 

Autorouting Networks 

About Routing with Networks 

A network is a series of locations that defines default paths for autorouted cables. 

Use the Network Ops > Route commands to add locations as you would when 

routing a cable. The difference is that you do not have a cable attached for the path 

you are defining. The path is represented by a dotted line. 

A network is associated with the cables of the active harness. Cables assigned to 

other harnesses in the assembly are not routed until their harnesses are made 

active. A network created in one harness may be made available for routing by 

another harness if you designate the network as shared. A network is associated 

with the harness part in which it is created. If you want to make a network available 

to route more than one harness part, you can share the network between selected 

harness parts. Sharing makes a network created in a non-active harness available to 

the active harness. 
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You can copy a network or network branches at a specified offset distance from the 

original network. The original locations forming the network are copied at the offset 

distance. The existing network portion is also copied at the new locations. 

Network Properties 

When you add network locations, you can also assign priorities to them to further 

define the autorouting process. 

Network bundles and sheathing are created in the same way as other bundles, 

except that they exist along a branch of the network. Pro/CABLING does not 

automatically create bundles for the network, but you can assign bundles and 

sheathing to network segments even if no wires are present yet. 

Sheathing on the network can be used for space planning for the harness in early 

stages of the design. 

Assigning Location Priority for Network Locations 

To control the path in the network that autorouting uses, you can assign the 

following priorities to network locations. 

Type Description 

Primary (Default) These network locations are used whenever 

possible. 

Required Forces all wires being autorouted to pass 

through the specified location or locations in 

the same direction directions, even if this does 

not create the shortest path for each wire. 

This priority is used to handle wires that are 

routed through a common splice or to a splice 

that is to be inserted. You can also use this 

priority to ensure that wires travel through a 

specific hole or duct. 

Disallowed Disallowed network locations cannot be used 

for autorouting. You can avoid overfilling of 

channels, interference with a fixed size hole in 

a bulkhead, or creation of loops in an 

individual harness. 

Secondary A network location that is used for autorouting 

only if no complete path using primary 

locations is available. 
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To Use Location Priority for Autorouting 

 

1. Click CABLING > Network Ops. The NETWORK OPS menu appears. 

2. Select the type of priority you want to assign. 

o Required Loc 

o Primary Loc 

o Secondary Loc 

o Disallow Loc 

o Reset All 

If you click the Required Loc command, the REQD LOCS menu appears. Select 

one of the following options: 

Select—Select locations through which all autorouted cables must pass. You can 

have multiple required locations of this type. 

Optimize—System finds the shortest paths with at least one common location 

for autorouted items. This location becomes a required location after autorouting 

so that you know the location that was selected. This removes all previously set 

required priority locations. 

Put on Wire—System finds the best and shortest paths with a common location 

on a selected wire. This location becomes a required location after autorouting so 

that you know the location that was selected. This removes all previously set 

required priority locations. 

Click Reset All to reset all network locations used for autorouting to the default 

primary location. 

Note: Modifying the location priority only affects subsequent autorouting operations. 

Previously autorouted wires are not affected. 

To Define the Tangency Direction at Network Branches 

 

1. Click Cabling > Network Ops. The NETWORK OPS menu appears. 

2. Define the tangency of the network branch by using one of the following 

commands: 

Flip Direction—Flips the direction of the network branch at the selected location 

or locations and also fixes the tangency direction. 

Fix Tangency—Fixes the tangency of the network branch at the selected 

location or locations. The branch direction remains unchanged even if the shape 

of the network changes. 
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Display Tangency—Displays an arrow to indicate the direction of the tangency 

for all the network branch locations that have a fixed tangency. 

Clear Fixed Tangency—Clears the fixed tangency for the selected location or 

locations. 

Clear All—Clears the fixed tangency from all the network locations. The branches 

revert to the shape defined by the system, depending on the geometry of the 

main network segment.  

3. Select the network branch location or locations for which you want to modify the 

tangency direction. 

To Modify Network Locations 

 

1. Click Cabling > Network Ops > Route. 

2. Use the CBL ROUTE commands to edit location placing or type. 

You can add, modify, or remove locations from the network. 

Note:  

• If assembly references are updated, so does the network shape. 

• To delete a network segment, use the CBL ROUTE > Del Portion command. If 

you delete a network, the cable locations remain and the cable/network color 

changes. 

To Copy a Network 

1. Click CABLING > Network Ops > Route > Offset. 

2. Select three straight edges or a coordinate system. No tangency is enforced at 

the location. 

3. Specify the network direction. 

4. Click Specify Portion to select a portion of the cable that you want to copy 

using the SELECT dialog box. 

5. Specify the reference directions and network portions. 

6. Click Make Locs to begin the creation of offset locations based on the given 

references. 

7. An arrow appears for each direction. Type the offset value for each of the three 

directions. A new network is created that is offset from the original. 

8. To create another network at a different offset value from the original network, 

click Make Locs again. 

9. When you have finished creating copied networks, and want to return to the CBL 

ROUTE menu, click Done/Return. 
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Note:  

• The copied network offset locations are parametric with the existing network 

locations. If the distances between the locations of the original network are 

changed, the distances between the locations of the copied network change 

similarly. 

• The offset between the original network and the copied network is controlled by a 

single dimension that can vary. 

• You can use Modify > Make Indep to make the dimensions of each copied 

location independent of the network. 

• If the original network is deleted, the copied network is not deleted as the copy is 

independent of the original network. 

To Flatten the Network of a Harness 

1. Click Tools > Options. The Options dialog box opens. 

2. Type a new parameter, fan_with_network in the Option box. 

3. Type a value for the fan_with_network variable in the Value box. Type Yes if 

you want to see the network in flat harness else, type No. 

4. Click Add/Change. 

5. Click Apply and then OK. 

To Share Networks Between Harness Parts 

1. Click Cabling > Network Ops > Share. You are prompted to select the harness 

associated with the network you want to share with the current harness. 

2. When you select the harness, the model is regenerated and the locations in the 

shared network are available to the current harness. To directly connect networks 

across shared harness parts, use the Connect command. To undo the sharing, 

use the Unshare command. 

Sharing makes a network created in a non-active harness available to the active 

harness 

About Network Paths 

After you have defined an autorouting network, you can define paths within the 

network and associate specific cables or wires with them to further control the 

autorouting. In the following figure, a part of the network is defined as a path. 
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When you define a path, you are prompted to name it. The name is attached to the 

path as a note. 

To associate a cable or wire with the path, attach a parameter named use_path to 

the cable or wire and use the path name as the value. 

If a path conflicts with other network location priorities, maximum diameter 

restrictions, or other autoroute restrictions, the autorouting of the wire fails. 

Autorouting the wire fails, for example, if the specified path contains disallowed 

locations. 

As a network path acts like any other cable, you can modify it so that some portion 

of the path may no longer be on the network. If both ends of a path are on the 

network, autorouted cables follow the path (leaving the network and returning). If 

only one end of a path is on the network, that path is ignored. 

To Define and Edit Network Paths 

1. Ensure that an autorouting network exists. 

2. Click CABLING > Network Ops > Define Path. 

3. Select a start and end location to define the path. 

4. Click Done Sel. You are prompted to name the path. 

5. At the prompt, type a name and press ENTER. The path is created and the name 

is attached to a note on the path. 

6. To extend or remove the path, click Network Ops > Extend Path or Network 

Ops > Rename Path. 

To Associate Connections With Network Paths 

To specify that a wire or cable must use a predefined network path, add a use_path 
<path name> parameter and its value to the wire or cable feature. 

Note: To use a different name for the parameter, use the 

autoroute_path_param_name configuration option. 

Adding Cabling Cosmetic Features 

About Cabling Cosmetic Features 

The three types of cabling cosmetic features are tie wraps, markers, and tape. Each 

is described below. 

Note: When creating cosmetic features that represent tie wraps, markers, and tape, 

you can only select cables and locations that belong to the active harness. 

Tie wraps, markers, and tape features have feature parameters. You can assign 

user-defined colors to the Pro/CABLING cosmetic features. Use the Appearance 

Editor dialog box to change the colors of the cosmetic features. By default, all 

cosmetic features are assigned the system color, Sheetmetal. You can access all tie 
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wrap and marker feature parameters in Pro/REPORT through the &asm.mbr.cblprms 

category. 

Tie Wraps 

A tie wrap is used to hold one cable or several cables together. The representation 

for the tie wrap is as follows: 

• In centerline cable display, a circle with a circumference that corresponds to the 

length of the tie wrap. 

• In thick cables environment, a cylinder that shows the appropriate circumference, 

thickness, and width. 

Tie wraps have no required parameters. However, if you specify a name during tie 

wrap creation, Pro/CABLING implements it as a parameter in the parameter file. You 

can also assign user-defined parameters to tie wraps using the Electrical 

Parameters dialog box. 

Tape Feature 

Use this cosmetic feature to show where wires are taped to a thicker portion of the 

harness in the cabling assembly. The tape feature is located at a single location 

whereas tape sheathing is wrapped around entire bundle segments of the harness. 

As in other cabling features, each tape feature has its own set of feature parameters. 

Tape features have three required feature parameters: 

• NAME 

• NUM_OF_WINDS 

• SPOOL 

Markers 

Markers represent shrink wrap tubing that is placed on a cable during the 

manufacturing process to identify the cable for assembly, maintenance, and repair 

purposes. Pro/CABLING represents markers as cylindrical features around the 

selected cable with a name tag to identify the marker. The tag switches on and off 

with the display of the datum point. 

The only required feature parameter is NAME. Pro/CABLING automatically includes the 

value of this parameter in the parameter file when you specify the name of the 

marker during creation. You can also assign user-defined parameters to markers. 

Marker dimensions are assigned when you create the markers. 

To Create a Marker 

1. Click CABLING > Feature > Create > Marker. 

2. At the prompt, type a new marker name. The marker name can have a maximum 

of 31 characters. 
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3. Select a point or location on the segment of a cable or wire to use as the center 

for the marker on the cable. The marker length is displayed at the prompt. 

o Click  to accept the default length. The marker expanded diameter 

value is displayed at the prompt. 

o Type the new marker length, if you want to change the existing length. 

o Click  to cancel the operation. The marker expanded diameter value is 

displayed at the prompt. 

4. Click  to accept the existing value or type a new marker expanded diameter 

value. The marker reduced diameter value is displayed at the prompt. 

5. Click  to accept the existing value or type a new marker reduced diameter 

value. The cable cosmetic is created successfully. 

Note: The thickness of the marker is assigned automatically. You can modify the 

expanded diameter, reduced diameter, length, and position along the selected cable 

with the Modify > Mod Dim commands. 

Marker Default Dimensions and Labels 

Default Dimension 

Name (at Marker 

Creation) 

Default Value System-generated 

Dimension Label 

length maximum possible 

length*/2.0 

LENGTH 

expanded diameter cable thickness MAX Ø 

reduced diameter cable thickness MIN Ø 

thickness cable thickness/2.0 THICK 

Note: The maximum possible length is twice the distance from the point you 

selected to the closest segment end. 

To Create a Tape Feature 

1. Click CABLING > Feature > Create > Tape. 

2. At the prompt, type a unique name for the tape feature. 

3. Select an existing tape spool on which to base the new tape feature. 

4. Click Create, if a tape spool does not exist yet or you want to create a new tape 

spool. 

5. At the prompt, type a unique name for the tape spool. The SPOOL NAMES menu 

appears. 
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6. Click Create or select an existing spool. 

7. If you click Create, at the prompt type a new name for the spool. The Electrical 

Parameters dialog box appears with the default spool parameters. 

8. Modify the required spool parameter values. 

9. Click Apply and then OK in the Electrical Parameters dialog box. 

10. At the prompt, type the number of times the tape is to wind around the cable or 

set of cables. The default is 2 times. 

11. Select a cable location to use as center for the new tape feature. Pro/CABLING 

wraps all items at the selected location with the tape feature. 

Note: There are no dimensions to modify in a tape feature, as the size is determined 

by the tape spool parameters. You can modify the tape feature using the Electrical 

Parameters dialog box only. 

To Create a Tie Wrap 

1. Click CABLING > Feature > Create > Tie Wrap. 

2. At the prompt, type a new tie wrap feature name. 

3. Select a location or point on the segment of the cable to use as a center for the 

tie wrap. The selected segment of the cable is highlighted. The dimension that 

locates the tie wrap is created automatically from the start of the cable portion, 

and all other dimension values are assigned. 

o If a location is chosen, the tie wrap wraps around all cables at that location. 

o If a point along a segment portion is chosen, only the selected item is 

wrapped by the tie wrap. 

The default tie wrap dimension values are assigned automatically as follows: 

o THICK—cable thickness / 4.0 

o WIDTH—cable thickness / 4.0 

o LENGTH—cable thickness * pi 

Note: The tie wrap length is not used to calculate the tie wrap diameter. 

To Modify Cosmetic Feature Dimensions 

1. Click CABLING > Modify > Mod Dim. 

2. Select the required feature, the feature’s dimensions appear. 

3. Modify the dimensions press ENTER. 

Note: The Datum Point display must be set in the Environment dialog box to 

display the tape, tie wrap, and marker labels and the location where they are placed. 
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To Modify Cosmetic Feature Parameters 

1. Click CABLING > Modify > Cosmetics. 

2. Select the required cosmetic feature (tie wrap, tape, or a marker) you want to 

edit and middle-click. The Electrical Parameters dialog box opens. 

3. Edit the parameters of the required cosmetic features using the Electrical 

Parameters dialog box. 

Exporting Cabling Geometry 

To Export Cabling Geometry 

You can export the complete geometry of wires and cables, or just the centerlines, 

from a Pro/CABLING assembly to IGES and other common formats. 

1. Click File > Save a Copy. 

2. Select the export format in the Type box. The Export Environment dialog box 

for the selected environment opens. If the functionality is supported in the 

selected format: 

o Select Export Cable Surfaces to export the cables as surfaces (as seen in 

thick Cable mode.) 

o Select Datum Curves and Points to export cabling harness as centerlines. 

Select neither to exclude any cabling geometry information from the export. 

3. Click OK. 

Pro/Report Parameters 

Pro/REPORT Parameters for Assemblies 

Use the following Pro/REPORT parameters for cabling assemblies: 

&asm.mbr.connprm.<User Defined>—Lists the values of the specified user-defined 

parameter for each connector. 

&asm.mbr.connprm.name—Lists the reference designators of connectors used in the 

assembly. 

&asm.mbr.connprm.pin.entry_port—Lists the entry port of the pin of the specified 

user-defined parameter for each connector. 

&asm.mbr.connprm.pin.name—Lists the pin names for each connector in the 

assembly. 

&asm.mbr.connprm.pin.run.<User Defined>—Lists the specified user-defined 

parameters for wires, cables, or bundles connected to each connector pin. 
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&asm.mbr.connprm.pin.run.cond.<User Defined>—Lists the user-defined 

parameters of the given conductor of wires, cables, or bundles connected to each 

connector pin. 

&asm.mbr.connprm.pin.run.cond.color—Lists the color of the given conductor of 

wires, cables, or bundles connected to each connector pin. 

&asm.mbr.connprm.pin.run.cond.name—Lists the name of the given conductor of 

wires, cables, or bundles connected to each connector pin. 

&asm.mbr.connprm.pin.run.cond.strip.len—Lists the strip length of a wire 

attached to a specified pin connector. 

&asm.mbr.connprm.pin.run.len—Lists the length of wires, cables, or bundles 

connected to each connector pin. 

&asm.mbr.connprm.pin.run.name—Lists the names of wires, cables, or bundles 

connected to each connector pin. 

&asm.mbr.connprm.pin.run.spool.<User Defined>—Lists the specified user-

defined spool parameters of wires, cables, or bundles connected to each connector 

pin. 

&asm.mbr.connprm.pin.run.spool.name—Lists the spool names of wires, cables, or 

bundles connected to each connector pin. 

&asm.mbr.connprm.pin.signal.name—Lists the signal names of each connector pin. 

&asm.mbr.connprm.pin.signal.type—Lists the signal types of each connector pin. 

&asm.mbr.connprm.pin.term.<User Defined>—Lists the specified user-defined 

parameters used in the terminators attached to connector pins. 

&asm.mbr.connprm.pin.term.name—Lists the terminator names attached to 

connector pins. 

Pro/REPORT Parameters for Terminators 

Use the following terminator-related parameters in Pro/REPORT: 

&harn.run.cond.from—Lists the terminator name that every wire and cable is 

routed from, in the harness. 

&harn.run.cond.to—Lists the terminator name that every wire and cable is routed 

to, in the harness. 

&harn.term.qty—Lists the numbers of every terminator used in the harness. 

&harn.term.name—Lists all the terminator names used in the harness. 

&harn.term.<User Defined>—Lists the specific user-defined parameter for every 

terminator used in the harness.  

Note: The parameters &harn.term.qty, &harn.term.name, and &harn.term.<User 
Defined> must have the harness part as the drawing model. 
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Harness Related Pro/Report Parameters 

You can use several Pro/REPORT parameters in Pro/CABLING cabling assemblies and 

flat harnesses. You can also use an item's parameters as user-defined parameters in 

a Pro/REPORT table. 

Perform the following steps to set the model before creating a table. Using this table 

you can access the Pro/REPORT parameters. 

1. Open the required drawing and click File > Properties. The FILE PROPERTIES 

menu appears. 

2. Click Drawing Models. The DWG MODELS menu appears. 

3. Click Add Model to add a new part or assembly to the drawing. The selected 

model becomes the default or current model. 

4. If you have added multiple parts or assemblies, click Set Model to set the 

required harness part or flat assembly as the current model. 

The report parameters in the following table use cond to refer to all wires and cable 

conductors in a harness and run to refer to all wires and cables in a harness. The 

term from/to indicates that the parameter exists for both From and To direction. 

The User Defined category indicates that you can specify user-defined parameters 

and also system parameters. 

For example, although &harn.run.spool.color is not specifically defined, you can 

specify &harn.run.spool<User Defined> and type the system parameter color. 

Pro/REPORT Parameter Name Definition 

&asm.mbr.cblprm<User Defined> Lists the specified 

user-defined 

parameter in the 

cabling components 

&asm.mbr.cblprms.name Lists names of all the 

user-defined 

parameters in the 

cabling components 

&asm.mbr.cblprms.value Lists values of all 

user-defined 

parameters in the 

cabling components 

&asm.mbr.connprm.name Lists reference 

designators of 

connectors in the 

assembly 

&asm.mbr.connprm.pin.name Lists names of pins 

for each connector in 
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the assembly 

&asm.mbr.connprm.pin.run.cond.color Lists the color of the 

wires and conductors 

connected to each 

connector pin 

&asm.mbr.connprm.pin.run.cond.name Lists names of the 

conductors and wires 

connected to each pin 

&asm.mbr.connprm.pin.run.cond.strip.len Lists the strip length 

of wires and 

conductors attached 

to each pin 

&asm.mbr.connprm.pin.run.cond<User 
Defined> 

Lists the specified 

user-defined 

parameter in 

conductors or wires, 

connected to each pin 

&asm.mbr.connprm.pin.run.len Lists the length of 

wires and cables 

connected to each pin 

&asm.mbr.connprm.pin.run.name Lists the names of 

wires, cables, or 

bundles connected to 

each connector pin 

&asm.mbr.connprm.pin.run.spool.name Lists spool names of 

wires or cables 

connected to each 

connector pin 

&asm.mbr.connprm.pin.run.spool<User 
Defined> 

Lists the specified 

user-defined spool 

parameter of wires 

and cables connected 

to each pin 

&asm.mbr.connprm.pin.run<User Defined> Lists the specified 

user-defined 

parameter for wires 

and cables connected 

to each pin 

&asm.mbr.connprm.pin.signal.name Lists signal names of 

each pin 
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&asm.mbr.connprm.pin.signal.type Lists signal types of 

each pin 

&asm.mbr.connprm.pin.term.name Lists the terminator 

name of each pin 

&asm.mbr.connprm.pin.term<User Defined> Lists the user-defined 

parameters set for 

the terminators 

&asm.mbr.connprm<User Defined> Lists values of the 

specified user-defined 

parameter for each 

connector 

&asm.mbr.connprm.pin.entry_port Lists the entry port 

parameter of each pin 

for each connector 

&asm.mbr.connprm.pin.signal<User 
Defined> 

Lists the specified 

user-defined 

parameter for each 

pin 

&asm.mbr.cparams.name  Lists the names of all 

user-defined 

parameters in the 

assembly components 

&asm.mbr.cparams<User Defined> Lists the specified 

user-defined 

parameters used in 

the assembly 

components 

&asm.mbr.cparams.value Lists the values of all 

user-defined 

parameters in an 

assembly component 

&asm.mbr.name Lists the names of 

assembly members 

&asm.mbr.param.name Lists the names of all 

user-defined 

parameters in an 

assembly member  

&asm.mbr.param.value Lists the values of all 

user-defined 

parameters in an 
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assembly member 

&asm.mbr.type Lists the type (part, 

assembly, or 

terminator) of an 

assembly member 

&asm.mbr<User Defined> Lists the specified 

user-defined 

parameter for the 

respective assembly 

components 

&harn.run.cond.color Lists the color for 

every routed wire or 

cable in the harness 

&harn.run.cond.from/to.conn.name Lists connector 

reference designators 

that every wire or 

cable conductor is 

routed from 

connector to 

connector 

&harn.run.cond.from/to.pin.name Lists pin names that 

every wire or cable 

conductor is routed 

from connector to 

connector 

&harn.run.cond.from/to.conn<User 
Defined> 

Lists the specified 

user-defined 

connector parameter 

for every wire or 

cable conductor 

&harn.run.cond.spool<User Defined> Lists the specified 

user-defined spool 

parameter for every 

wire or cable 

conductor 

&harn.run.cond.from/to.pin.entry_port Lists the pin entry 

port for every wire or 

cable conductor 

&harn.run.cond.from/to.pin.sig.name Lists the pin signal 

name for every wire 

or cable conductor 
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&harn.run.cond.from/to.pin.sig.type Lists the pin signal 

type for every wire or 

cable conductor 

&harn.run.cond.from/to.pin.sig<User 
Defined> 

Lists the specified 

user-defined pin 

parameter for every 

wire or cable 

conductor 

&harn.run.cond.from/to.strip.len Lists the strip length 

of each wire or cable 

conductor 

&harn.run.cond.from/to.term.name Lists the terminator 

name for every wire 

or cable conductor 

&harn.run.cond.name Lists every routed 

wire or cable 

conductor in the 

harness 

&harn.run.cond<User Defined> Lists the specified 

user-defined 

parameter for every 

wire or cable 

conductor in the 

harness 

&harn.run.from/to.conn.name Lists connector 

reference designators 

that every wire and 

cable is routed from 

connector to 

connector 

&harn.run.from/to.conn<User Defined> Lists the specified 

connector user-

defined parameter 

that every wire or 

cable is routed from 

connector to 

connector 

&harn.run.len Lists lengths of 

routed wires or cables 

&harn.run.name Lists names of routed 

wires or cables 
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&harn.run.spool.name Lists the spool name 

for every routed cable 

or wire 

&harn.run.spool<User Defined> Lists the specified 

user-defined spool 

parameter for every 

wire or cable 

&harn.run.subharn.name Lists subharness 

names used 

&harn.run<User Defined> Lists the specified 

user-defined wire, 

cable, or bundle 

parameter for every 

harness 

&harn.spool.len Lists the total lengths 

of routed wire spools 

and cable spools 

&harn.spool.name Lists the wire or cable 

spool names used 

&harn.spool<User Defined> Lists the specified 

user defined 

parameter for every 

wire or cable spool 

used 

The following conditions apply: 

Report Parameter Active Model Attribute 

&harn... harness part NA 

&asm.mbr.cblprm(s)... 3D assembly Cable Info 

&asm.mbr.connprm... 3D assembly/Flat 

assembly 

NA 

Note: The Cable Info attribute is available only when you select at least one cable 

parameter in the repeat region. 

To assign a different model to a region: 

1. Click Table > Repeat Region. The TBL REGIONS menu appears. 

2. Click Model/Rep to display a different model or simplified representation to 

control a region. If you change the model associated with the repeat region, data 

in the repeat region reflects the new model data. 

3. Select a region. The Open dialog box opens. 
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4. Select a new part or assembly to be associated with the repeat region. 

Glossary 

Glossary of Terms 

Term Definition 

Harnesses A harness is a cable part you create within the assembly 

context and has a complete information of wires, cables, 

and cosmetic features in a cabling assembly. One assembly 

can contain several harnesses, and one harness can contain 

different cables, as connected or unconnected segments. 

Bundles A bundle is made up of one or more cables, wires, or other 

bundles that are represented as sheathed or wrapped. 

Bundles are created from spools that carry properties like 

min_bend_radius, color, and bundle_type (round or flat 

shape). You must add cables to a bundle after you have 

added them to the routing set and before you begin to 

route. 

Channels Channels are conduits for defining direction or for 

terminating cables to a conductive strip as a ground or as 

part of the live circuit. Channels are also the basis for 

modifying cable or network locations in cross sections. 

Connectors Connectors are parts that have parameters you can use to 

define the beginning and end of cables. You must designate 

a part as a connector, and define one or more coordinate 

systems to use as an entry port before you can route the 

wire or cable to it. 

Custom 

components 

Custom components are similar to spliced components 

except they do not use parameters. You can use custom 

components in place of cabling components that do not 

need a reference designator. 

In line 

connectors 

In line connectors are pairs of male-female connectors 

which break the cable into two physical cables but maintain 

signal continuity between them. 

Locations Locations are the user-defined points within the assembly 

that describe the path that cable routing should follow. 

Locations can be free-floating on one selected surface. 

Network A network is a string of locations without cables attached to 

them that define a path for autorouting. Networks are not 

cable specific; any number of cables or wires can share a 
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network. 

Network Paths A network path is a portion of the network with a name, 

defined between two locations, and passes through a series 

of locations in an network. This path can be assigned to a 

specific cable using the use_path config option. 

Splice 

components 

The splice components are components added somewhere 

along the length of a cable. The cable name and length 

from connector to connector is not affected after the splice 

component is installed. 

Through 

Splice 

Added along the length of the cable and will not split the 

cable. 

Butt Splice Splits the cable into two parts 

Spools A spool is similar to an actual spool from which you roll off 

an amount of cable or wire, as needed. Spools are 

collections of parameters like color, gauge, and so on that 

you reference when you create individual wires and cables. 

When you edit the spool, the edits are passed to the wires 

or cables that were created from it. 

Wire spools Contains the basic descriptive parameters such as color, 

thickness, and so on for one conductor or import them. 

Cable spools Describes the cable sheath and certain number of 

conductors. You must create spools in the cabling assembly 

or import them from a logical reference before you route 

the wire or cable. Spool files are saved with the .spl 

extension. 
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