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Pro/DIAGRAM 

Using Pro/DIAGRAM 

About Pro/DIAGRAM 

Pro/DIAGRAM captures logical connection information and represents it graphically 

as wires, cables, components and pins. You can use Pro/DIAGRAM to output 

component lists and wire lists, either as schematic reports or as formatted ASCII text 

files. 

Diagram-specific tools allow you to: 

• Use symbol libraries of electrical and mechanical components.  

• Perform quick and easy routing of connections between components with 

automatic generation of wire lists. 

• Compare the diagram to its corresponding cabling assembly or wirelist 

information from an ASCII file.  

• Organize the diagram by layers. You can place wires, connectors, and cables on a 

layer, even if they are on different sheets.  

• Produce BOMs and wire and connection lists that you can pass to Pro/CABLING. 

 

A basic wiring diagram showing connectors, nodes, wires wire labels and wire 

breaks.  

Additional standard tools in Pro/DIAGRAM include the ability to add formats, draft 

geometry, and notes. Also, all standard Pro/ENGINEER import and export functions, 
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such as IGES and DXF, and all standard plotting options are available within the 

Pro/DIAGRAM environment. 

To Create a New Diagram 

Before you start to create diagram objects: 

• Make sure you have access to the necessary symbols. Set up your configuration 

file to point to the appropriate library directories.  

• If you are going to work with Grid Snap On, modify your grid spacing to 

correspond to the required pin spacing in the diagram. 

To Create a New Diagram: 

1. Click File > New. The New dialog box opens.  

2. Click Diagram in the Type box to start the Diagram module. 

3. Type a new diagram file name or use the default file name format (dgm000#) and 
click OK. The New Diagram dialog box opens. 

4. Click one of the following options. The New Diagram dialog box contains the 

following group boxes: 

Specify Template 

o Empty With Format— Lets you retrieve a saved format. 

o Empty—Lets you use the Orientation and Size Controls. 

Orientation 

o Portrait—Uses standard sizes for portrait, for example, 8.5 inches x 11 

inches. 

o Landscape—Uses the standard sizes for landscape, for example, 11 inches 

x 8.5 inches. 

o Variable—Lets you create a size. If you select this command, the Inches 

and Millimeters command buttons become available as do the Width and 

Height boxes. 

Size 

o Standard Size—You can click a size, for example, Size A. As you change 

the standard size, the values of the width and height change in the grayed 

boxes. 

o Width—When you select the Variable button, you can set the width in 

inches or millimeters. 

o Height—Set the height in inches or millimeters. 

5. Click OK. The DIAGRAM window opens. You are now ready to create objects for 

your diagram. 
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Note: If the Diagram menu structure ever disappears from view, click Window 

> Activate or click the current diagram, and the module menu reappears. This is 

true only if you have one diagram in session. 

Tip: Case in Filenames 

The diagram can be saved to disk using the standard Save and Save As options. 

Diagram files are saved as diagramname.dgm.#, where diagramname is the name of 
the diagram, and # is the version number. 

Note: In UNIX, Windows NT, and Windows 95, the actual filenames on disk must use 

lowercase characters only. 

In both UNIX and Windows NT, directory names can contain a mix of uppercase and 

lowercase characters. However, if Pro/ENGINEER encounters two or more directories 

in a path that have the same parent and the same name except for a different mix of 

uppercase and lowercase characters, it accesses only the directory with the earliest 

uppercase letters (because their ASCII values are lower). This occurs even if you 

enter the full pathname with the correct case sensitivity. 

Drawing Setup File Options for Diagram 

The following drawing setup options can also apply to diagrams.  

Drawing Option Description 

drawing_text_height Sets the default text height for all text in the 

drawing using the value set for 

drawing_units. 

text_thickness Sets the default text thickness for new text 

after you regenerate and existing text whose 

thickness has not been modified. Enter the 

value in drawing units. 

text_width_factor Sets the default ratio between the text width 

and text height. The system maintains this 

ratio until you change the width with the 

Text Width option. 

default_font Sets the default text fonts to be those fonts 

listed in the specified font index. Do not 

include the .ndx extension. The fonts font 
and filled are in the setup file. 

draw_arrow_length Sets the length of the leader line arrows. 

draw_arrow_style Sets the style of arrows. 

draw_arrow_width Sets the width of leader line arrows. This 

drawing setup file option drives these other 
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drawing setup file options: 

• draw_attach_sym_height 

• draw_attach_sym_width 

• draw_dot_diameter 

draw_attach_sym_height Sets the height of leader line slashes, integral 

signs, and boxes. If you specify default, uses 

the value set for draw_arrow_width. 

draw_attach_sym_width Sets the width of leader line slashes, integral 

signs, and boxes. If you specify default, uses 

the value set for draw_arrow_width. 

draw_dot_diameter Sets the diameter of leader line dots. If you 

specify default, uses the value set for 

draw_arrow_width. 

leader_elbow_length Determines the length of the leader elbow 

(the horizontal leg attached to the text). 

decimal_marker Determines which character marks the 

decimal point in secondary dimensions. 

drawing_units  Sets the units for all drawing parameters. 

line_style_standard Controls text color in drawings. Unless you 

set this option to STD_ANSI, shows all text in 
drawings in blue, and shows the boundary of 

the detail view in yellow. 

max_balloon_radius Sets the maximum allowable balloon radius. 

If set to 0, balloon radius depends only on 
text size. 

min_balloon_radius Sets the minimum allowable balloon radius. If 

set to 0, balloon radius depends only on text 
size. 

sym_flip_rotated_text Flips any text in a Rotate Text symbol that 

is upside down, making it right-side up. If set 

to yes. and the symbol orientation is +/- 90 
degrees, flips the text, rotating it along with 

the symbol. 

text_thickness Sets the default text thickness for new text 

after you regenerate and existing text whose 

thickness has not been modified. Enter the 

value in drawing units. 



Pro/DIAGRAM 

5 

pos_loc_format Controls appearance of &pos_loc text in 
notes and report tables. %%=<a single 
%>,%s=<sheet number>, %x=<horizontal 
position> %y=<vertical position> 
%r=<end of repeatable substring> 
(Default is %s%x%y,%r)  

To Display Diagram Information 

The following commands in the Info menu can help you obtain information about 

your diagram: 

• Bill of Materials—Lets you generate a bill of materials (dgm_bom.inf) of all the 
objects in the diagram. 

• Bill of Materials for Layer—Lets you generate a bill of materials only for one 

layer. 

• Wire List—Lets you generate a from-to wire list for all the wire connections in 

the diagram. 

• Wire List for Layer—Lets you generate a from-to wire list for only one layer. 

• MVC Instance—Displays information of a multi-view component. 

• Component Group—Displays information of a component group instance. 

• Draft Entity—Displays entity information. 

• Draft Grid—Displays grid information in the message area. 

• Save Note—Writes note to a file. 

• Session Info 

o Object List—Displays names of all objects in the current session. 

o Message Log—Displays old messages. 

o Date and Time—Displays date and time. 

To Search for Diagram Objects 

To locate objects in a large, complex diagram: 

1. Click Edit > Search in diagram. The Select By Type dialog box opens. 

2. Use the dialog box to set up a search by parameter or parameters. Define each 

parameter with its value and use the down arrows to add them to the search list. 

Select the And and Or option as required. 

Note: Reference objects are components or connectors. 

3. Click Find to highlight any of the found items on the current sheet. 
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4. Click Info to open an INFORMATION WINDOW that displays object details and 

the sheet number location. 

Using Layers in Pro/DIAGRAM 

You can manage diagram objects by placing them on layers You can then produce 

report tables, a wirelist or a BOM for all layers, or all objects on selected layers. Use 

the Edit tab options from the left pane of the Drawing window to control layers. 

Tip: Selection Shortcut: the Modify Item Pop Up 

1. Select a diagram item and right-click. The shortcut menu appears. 

2. Select Properties. The commands that are displayed depend on the item you 

have selected. 

3. Click Done to complete the task and close the shortcut menu. 

Undo Redo Operations in Pro/DIAGRAM 

To limit the number of undo and redo action to fewer than the default of 50, set the 

general_undo_stack_limit configuration option to a lower number. When available, 
Undo and Redo commands appear on the menus. 

Undo and redo operations are not available for the following commands: 

Edit Menu Commands 

• Edit > Transfer All Connections 

• Edit > Cable Contents > Add Wires 

• Edit > Cable Contents > Remove Wires 

• Edit > Highway Wires > Add Wires 

• Edit > Highway Wires > Remove Wires 

• Edit > Search in diagram 

View Menu Commands 

• View > Update Labels 

Insert Menu Commands 

• Insert > Wire 

• Insert > Cable 

• Insert > Highway 

• Insert > Rail 
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• Insert > Ladder 

• Insert > Connector > Single View 

• Insert > Connector > Multi-View 

• Insert > Connector > Parametric 

• Insert > Connector > Inline 

• Insert > Component > Single View 

• Insert > Component > Multi-View 

• Insert > Component Group 

• Insert > Splice > Butt 

• Insert > Splice > Through 

• Insert > MVC View 

• Insert > Component Group View 

• Insert > Cable Symbol 

Format Menu Commands 

• Format > Spools 

• Format > Default Wire Spool 

• Format > Default Cable Spool 

• Format > Conductor Direction 

• Format > Multi-View Connector Gallery 

• Format > Multi-View Component Gallery 

• Format > Component Group Gallery 

• Format > Rung Labels 

• Format > Reference Zones 

Info Menu Commands 

• Info > Wire List  

• Info > Wire List for Layer 

• Info > MVC Instance 

• Info > Component Group 
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Tools Menu Commands 

• Tools > Parameters 

• Tools > Diagram 

• Tools > Pattern 

• Tools > Objects 

• Tools > Terminator Tables 

• Tools > Logical Reference 

Configuring Pro/DIAGRAM 

About Configuring Pro/DIAGRAM 

You can preset environment options by setting configuration options and their values 

in the config.pro file. 

A list of configuration options arranged in alphabetical order for Pro/CABLING, 

Pro/DIAGRAM, and Pro/HARNESS is available under the Electromechanical 

category in Current Session. Each option contains the following information: 

• Configuration option name. 

• Default and available variables or values. All default values are in italics. 

• Brief description and notes describing the configuration option 

From this list, only the following configuration options are available for 

Pro/DIAGRAM: 

• Diagram_pin_edit_multi_line 

• Orthogonal_snap 

• pro_spool_dir 

Note: After you set the configuration options, all settings take effect immediately in 

the current Pro/ENGINEER session. 

Many of the Drawing configuration options also apply to Pro/DIAGRAM. 

To Set Pro/DIAGRAM Configuration Options 

1. Click Tools > Options. The Options dialog box opens. 

2. Select By Category in the Sort box. 

3. Select Current Session in the Showing box. 

4. Clear the Show only options loaded from file check box to see all 

configuration options or select this option to see currently loaded configuration 

options. 
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5. In Current Session, select the Electromechanical category. A list of 

configuration options arranged in alphabetical order for CABLING, DIAGRAM, and 

HARNESS appears. 

6. Select a Diagram-specific configuration option from the list or type the 

configuration option name in the Option box. 

7. When you select a configuration option from the list, its corresponding value 

appears in the Value box. You can modify this value.  

or 

Type a value to be assigned to the configuration option in the Value box. 

Note: The default value is followed by an asterisk (*). 

8. Click Add/Change, the configuration option and its value appear in the list. The 

status of the configuration option changes to  symbol. 

Note: The Add/Change option is enabled only when you try to change the 

configuration option name or the value of an existing configuration option, or 

type a value for a new configuration option. 

9. When you finish configuring Pro/DIAGRAM, click Apply or OK. 

Note: It is recommended that you set the Pro/DIAGRAM configuration options before 

starting or opening a new diagram for a cabling assembly. 

diagram_pin_edit_multi_line 

no, yes 

yes—You can add user defined pin parameters by including them between the 
DEFINE and ENDDEF statements for each pin. 

no—The system uses a columnar format. Determines the Pro/TABLE format used 
when you are modifying pin parameters. 

pro_spool_dir 

<home directory> 

Sets the default directory from which the spools are retrieved by default. Use the full 

path name, for example: /home/users/spools 

The current working directory is the default directory. 

general_undo_stack_limit 

50 

Sets the number of undo or redo operations. If the number of operations exceeds 

50, the first operation in the stack is removed first, and so on. 

 



Pro/DIAGRAM™ - Help Topic Collection 

10 

orthogonal_snap 

yes, no 

Controls non-90 degree routing in Pro/DIAGRAM.  

yes—Turns the Ortho Snap function on; allowing you to sketch wires only at the 
default horizontal and vertical orientations. 

no—Allows you to sketch wires in drawings at angles other than the default 
horizontal and vertical orientations. 

Logical Referencing 

About Logical Referencing 

Logical referencing is transferring electrical design data between a diagram and 

a.corresponding 3D cabling model, so that they can both store and use the same 

information, and reflect engineering change orders accurately. 

Cabling assemblies can directly reference diagram (.dgm) files. You can also import a 
wirelist to a diagram or cabling assembly in Mentor Graphics, PTC Neutral format 

(.nwf), or XML format (.xml). You can export data from a diagram in PTC Neutral 
format or XML format (.xml). During the design process, you can compare the 
diagram and the 3D model object by object, to be sure that data is synchronized for 

both designs. 

To Import or Export a Wire List 

1. Click Tools > Logical Reference > Import (or Export). 

2. If you choose Import, select the format from the WIRELIST IMP menu. You 

can import logical information from a Mentor Graphics format wire list file, PTC 

neutral wire list file or an XML format (.xml) file. 

3. If you choose Export, use the browser to name the export file. 

To Compare Logical References 

You can compare the logical connections of the diagram with either a cabling 

assembly or an ASCII wire list. This allows you to see if any logical connection in the 

diagram is missing or incorrect in the 3D harness. 

1. Click Tools > Logical Reference > Compare. The COMPARE menu appears 

with checkboxes for each diagram object on the wirelist. Check each object you 

want to compare: 

o Wire and Cable Spools—A match occurs if they all have the same 

parameters with the same values. A subset match, indicated by the word 

SUBSET in parentheses in the comparison output file, occurs if all the 
parameters common to both referenced and design data have the same 

values. The spools are identified by the spool names. 
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o Conns/Comps—Connectors and components can match when they have 

the same parameters with the same values. Connectors and components 

are identified by their reference designators. 

o Wires and cables—The logical connection of a wire to a connector or 

component is compared. A wire is matched if it runs between the same 

matched connectors and pins, even if the names of the wires are not the 

same. Wires connected to rails are also listed in the logical reference 

information as being connected to rails. Wires are identified by the wire 

name. 

Note: Cabling assemblies do not contain pin attachment information until it is 

explicitly entered when you edit the connector parameters. 

If you check Matched, matched items are listed first in the listing. 

2. Click Execute. The comparison list appears in a text reader. 

Tip: Layers and Logical Referencing 

When you reference a diagram in Pro/CABLING, you can reference the whole 

diagram file or only specified layers, so it can be convenient to create harness 

specific layers in Pro/DIAGRAM. 

Example: PTC Neutral Wire List 

This is an incomplete PTC neutral wire list, meant to show examples of each object 

type: 

! Wire and cable spools 

NEW WIRE_SPOOL 14BL 
PARAMETER COLOR BLUE 
PARAMETER MIN_BEND_RADIUS 0.125 
PARAMETER THICKNESS 0.06 
PARAMETER WIRE_GAUGE 14 
PARAMETER UNITS INCH 
PARAMETER MASS_UNITS POUND 
PARAMETER WIRE_CONSTRUCTION STRANDED 
 
NEW CABLE_SPOOL GRN4C 4 
PARAMETER COLOR GREEN 
PARAMETER MIN_BEND_RADIUS 0.18 
PARAMETER THICKNESS 0.08 
PARAMETER MASS_UNITS POUND 
PARAMETER UNITS INCH 
CONDUCTOR 1  
PARAMETER COLOR BLACK 
PARAMETER WIRE_GAUGE 8 
CONDUCTOR 2  
PARAMETER COLOR RED 
PARAMETER WIRE_GAUGE 7 
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CONDUCTOR 3  
PARAMETER COLOR ORANGE 
PARAMETER WIRE_GAUGE 8 
CONDUCTOR 4  
PARAMETER COLOR WHITE 
PARAMETER WIRE_GAUGE 7 
 
! Components and connectors 
 
NEW CONNECTOR J1 
PARAMETER MODEL_NAME CONN_Y15 
PARAMETER NUM_OF_PINS 15 
PARAMETER GENDER FEMALE 
PIN 1 
PARAMETER SIGNAL_NAME X24-1 
PARAMETER SIGNAL_VALUE +5V 
PARAMETER ENTRY_PORT ENTRY1 
PARAMETER GROUPING ROUND 
PARAMETER INTERNAL_LEN 0 
PIN 2 
PARAMETER SIGNAL_NAME X24-1 
PARAMETER SIGNAL_VALUE +5V 
PARAMETER ENTRY_PORT ENTRY2 
PARAMETER GROUPING ROUND 
PARAMETER INTERNAL_LEN 0 
PIN 3 
PARAMETER SIGNAL_NAME X24-1 
PARAMETER SIGNAL_VALUE +5V 
PARAMETER ENTRY_PORT ENTRY3 
PARAMETER GROUPING ROUND 
PARAMETER INTERNAL_LEN 0 
PIN 4 
PARAMETER SIGNAL_NAME X24-1 
PARAMETER SIGNAL_VALUE +5V 
PARAMETER ENTRY_PORT ENTRY4 
PARAMETER GROUPING ROUND 
PARAMETER INTERNAL_LEN 0 
 
! Wires and cables 
 
NEW WIRE WIRE_01 14BL 
ATTACH P1 1 C1 1 
 
NEW WIRE WIRE_02 14GRY 
ATTACH P1 2 C1 2 
 
NEW WIRE WIRE_03 14GRY 
ATTACH P2 1 C1 3 
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NEW WIRE WIRE_04 16RD 
ATTACH J7 8 C2 6 
 
NEW WIRE WIRE_05 16RD 
ATTACH J7 7 C2 5 
 
NEW WIRE WIRE_06 16YL 
ATTACH J7 6 C2 4 
 
NEW CABLE CABLE_01 GRN4C 
ATTACH J1 "" C3 "" 
CONDUCTOR 1  
ATTACH J1 1 C3 1 
PARAMETER NAME WIRE_13 
CONDUCTOR 2  
ATTACH J1 2 C3 2 
PARAMETER NAME WIRE_14 
CONDUCTOR 3  
ATTACH J1 3 C3 3 
PARAMETER NAME WIRE_15 
CONDUCTOR 4  
ATTACH J1 4 C3 4 
PARAMETER NAME WIRE_16 

Setup Options for Pro/DIAGRAM 

To Set Up Pro/DIAGRAM Preferences 

To set up the diagram file with options of your choice: 

1. Click File > Properties. The Options dialog box opens. 

2. Select and edit the required configuration options. 

To Set the Grid 

1. Click View > Draft Grid. The GRID MODIFY menu appears. 

2. Use the commands in the GRID MODIFY menu to set the grid display and 

spacing as follows: 

• Show Grid—Turns on the display of the grid. This does not affect the snapping of 

sketched entities to grid intersections. To change the grid snap, use the Snap to 

Grid option in the ENVIRONMENT dialog box (Tools > Environment). This 

insures that all nodes lie on the drawing grid. 

Note: When routing wires, you can work with the grid on but with grid snap off. 

• Hide Grid—Turns off the display of the grid. 

• Type—Establishes the type of grid as Cartesian (default) or Polar. In 

Pro/DIAGRAM, you use the Cartesian grid. 
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• Origin—Places the grid origin anywhere on the screen and shows coordinate 

axes at the current grid origin.  

• Grid Params—Establishes the spacing and angle of the grid. The Cart Params 

menu appears with the following options: 

o X&Y Spacing—Sets the spacing in both X- and Y-direction to the same 

value. 

o X Spacing—Sets the X-spacing only. 

o Y Spacing—Sets the Y-spacing only. 

o Angle—Modifies the angle between the horizontal and the X-direction grid. 

Note: Before creating wires it is helpful to: 

• Modify the grid parameters and/or the component locations so that all the nodes 

are located on grid intersections. 

• Click Tools > Environment and check Snap to Grid to turn the grid snap on. 

If you turn on the grid before creating connectors, it ensures that any pins (nodes) 

you create are on the grid and are spaced properly. 

To Switch Snap to Grid 

1. Select Tools > Environment. The Environment dialog box opens. 

2. In the Default Actions box, check or clear Snap to Grid and Snap to XY Axes 

as required. 

Note: If grid snap is on, objects only snap to the grid if the grid spacing is set 

large enough to be visible. On an A-size drawing, the grid is not visible if the grid 

spacing is less than 0.7 mm or 0.07 inches. 

The visibility of the drawing also depends on the size of the window and whether 

you have collapsed the left panel of the window or not. 

3. Click Apply or OK for the changes to affect your current diagram. 

To Set Default Conductor Names 

Use the Pro/DIAGRAM setup options to customize default names of the wires, cables, 

rails, and highways. 

1. Click File > Properties. The Options dialog box opens. 

2. Use the options below for wires as a guideline for all conductor objects; each 

object (highways and rails for example) uses similar setup options. 

o wire_default_prefix defines the prefix of wirenames. Use the characters 
that are allowed for parameters. The default value is WIRE. 

o wire_default_suffix defines the first number or letter of the wirename 
that is incremented as you add a new wire. The value must either be only 
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numerical or alphabetical and must not contain characters such as 

underscores or hyphens, or a mix of numerical and alphabetical characters. 

The default value is 0001. 

o wire_default_increment defines the increment between two consecutive 
wires. The increment value must be numerical. The default value is 1. 

Diagram-Specific Drawing Setup Options 

These Drawing Setup options apply specifically to Pro/DIAGRAM. 

Label Position 

label_default_position Position of labels on wire lines. Can be 

START, MIDDLE, END or any combination 
separated by commas. 

label_ends_gap Measures the gap erased from a wire on 

each side of a label, when labels are inside 

wires. Real number (floating point). 

label_parallel If YES, the wire label is always parallel to 
the wire, if NO, labels are always parallel to 
the orientation of the sheet. 

Wires 

break_point_size Sets the size of the wire break symbol. 

There is a certain limit for the value of 

break_point_size. 

If the value is larger or equal to 0.0014 
(=<0.0014), the cross (wire break 

symbol) at the wire break point displays 

even if it is very small. 

If the value is less than 0.0014 
(<0.0014), the cross (wire break symbol) 

does not display, but the number in the 

setup file is the one entered by the user. 

def_wire_break_label  Sets the default wire break label name. 

To create leading spaces in default wire-

break labels, you must enter two sets of 

quotation marks before the spaces (such 

as, " sht&wire_opp_sheet"); otherwise, 
the system does not accept the syntax as 

input, and does not create the leading 

spaces in the label. 
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def_wire_label  Sets the default string to display in the 

wire label.  

default_wire_label_style Sets the default wire label style, which is 

a user-defined text style. 

default_wire_line_style Sets the default wire line style, which is a 

user-defined text style or a system line 

style.  

wire_default_increment  Defines the increment numerical value 

between two consecutively created wires. 

Used with wire default-prefix and wire-

default suffix. 

wire_default_prefix  Defines the text prefix of default wire 

names.  

wire_default_suffix  Defines the start number or letter of the 

default wirename. If 

wire_default_suffix is 1, and 
wire_default_increment is 2, 
consecutive wires are named wire1, 
wire3, wire5, and so on. If 
wire_default_suffix is A, and 
wire_default_increment is 2, 
consecutive wires are named wireA, 
wireC, wireE, and so on. (Cannot 
contain underscores, dashes, or a mix of 

numerical and alphabetical characters.) 

wire_notes_above  If Yes, the wire notes are set above the 
wire. If No, they intersect the wire. You 
can also enter a real number (floating 

point) for exact offset from the wire. 

Cables 

cable_cond_delimiter If cable_cond_from_cable is set to Yes, 
the value of cable_cond_delimiter is 
inserted between the cable and spool 

conductor name when forming the name 

of the cable conductor. 

cable_default_increment  Defines the increment numerical value 

between two consecutively created 

cables. Used with cable_default_prefix 
and cable_default_suffix. 
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cable_default_prefix Defines the text prefix of default cable 

names.  

cable_default_suffix  Defines the start number or letter of the 

default cable name. If 

cable_default_suffix is 1, and 
cable_default_increment is 2, 
consecutive cables are named cable1, 
cable3, cable5, and so on. If 
cable_default_suffix is A, and 
cable_default_increment is 2, 
consecutive cables are named cableA, 
cableC, cableE, and so on. (Cannot 
contain underscores, dashes, or a mix of 

numerical and alphabetical characters.) 

cable_jacket_report_name If you use the default value (DEFAULT), 
the name of the cable shows in the report 

table. Any other value is interpreted as 

plain text. For example, &cable_name has 
no special meaning. 

cable_shield_report_name Use this name for the cable symbol if the 

cable is shielded. The default value is 

SHIELD. 

cable_node_report_name Use this name for the nodes of a cable 

symbol. The default value is "-".  

cond_name_from_cable If Yes, the conductor name is derived by 
concatenating the cable name, the value 

of cable_cond_delimiter, and the spool 

conductor name. 

def_cable_label  Defines the default cable note contents 

that appears when a cable symbol is 

created. 

def_cond_label Sets the default cable conductor label 

name. 

Rails 

def_rail_label Sets the default contents of the rail label. 

default_rail_label_style Sets the default rail label style, which can 

be any valid named text style that is user-

defined. 
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default_rail_line_style Sets the default rail line style, which is a 

user-defined text style or a system line 

style. 

rail_default_increment Defines the increment numerical value 

between two consecutively created rails. 

Used with rail_default_prefix and 
rail_default_suffix. 

rail_default_prefix Defines the text prefix of default rail 

names.  

rail_default_suffix Defines the start number or letter of the 

default railname. If rail_default_suffix 
is 1, and rail_default_increment is 2, 
consecutive rails are named rail1, 
rail3, rail5, and so on. If 
rail_default_suffix is A, and 
rail_default_increment is 2, 
consecutive rails are named railA, 
railC, railE, and so on. (Cannot 
contain underscores, dashes, or a mix of 

numerical and alphabetical characters.) 

rail_node_radius  Sets the size of the nodes displayed at 

attachment points between two rails or 

between a wire and a rail for printing and 

display. 

rail_notes_above  Places the rail notes at a specified real 

number (floating point) above the 

highway. The default is .01. Enter NO to 
center the label on the rail. 

Highways 

def_highway_label Defines the highway label contents. 

This sets the highway label name. The 

default is no label. Enter &hway_name as 
a value to show the name; with the 

assigned prefix, suffix, and increment.  

default_highway_label_style Sets the default label style, which can 

be any valid named text style that is 

user-defined. 

default_highway_line_style  Sets the default highway line style, 

which is a user-defined text style or a 

system line style. 
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highway_default_increment Defines the increment numerical value 

between two consecutively created 

highways. Used with 

highway_default_prefix and 
highway_default_suffix. 

highway_default_prefix Defines the text prefix of default 

highway names.  

highway_default_suffix Defines the start number or letter of 

the default highway name. If 

highway_default_suffix is 1, and 
highway_default_increment is 2, 
consecutive highways are named 

highway1, highway3, highway5, and 
so on. If highway_default_suffix is 
A, and highway_default_increment is 
2, consecutive highways are named 
highwayA, highwayC, highwayE, and 
so on. (Cannot contain underscores, 

dashes, or a mix of numerical and 

alphabetical characters.) 

highway_notes_above Places the highway notes at a specified 

real number (floating point) above the 

highway. The default is .01. Enter NO to 
center the label on the highway. 

Connectors 

def_para_conn_text_height Sets the default parametric connector 

text height. 

node_radius  Sets the radius of the nodes. By default, 

the node radius value is DEFAULT. You 
can change this value as required. 

para_conn_mirror Allow or disallow mirroring for PCs or 

associated text. (Yes, No, geom_only, 
text_only) 

pc_ident_label Sets content of parametric connector 

label. 

pc_node_label  Sets the content of the node label for 

parametric connectors. The value of this 

option can be text, a pin parameter, or 

any combination, including a user-

defined pin parameter.  
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Setup Options: Default Report Names 

The setup options determine the report name of the default cable symbol for 

shielded and unshielded cable symbols and the default name for nodes on cable 

symbols. These options apply to all cable symbols in a diagram. 

Parameter or Option Description 

cable_jacket_report_name Use the default value DEFAULT, in which 
case the name of the cable shows in the 

report table. Any other value is 

interpreted as plain text. For example, 

&cable_name has no special meaning. 

cable_shield_report_name Use this name for the cable symbol if the 

cable is shielded. The default value is 

SHIELD. 

cable_node_report_name Use this name for the nodes of a cable 

symbol. The default value is "-". 

cable_shield_report_name 

cable_node_report_name 

Use the same names for cables of the 

same type, for example, a coaxial cable or 

a two wire, twisted-pair cable. 

from_cable_report_name 

to_cable_report_name 

from_to_cable_report_name

Use these to represent mechanical 

differences that can be important for 

manufacturing. Override cable spool 

parameters and Drawing setup options. 

Defining Symbols in Pro/DIAGRAM 

About Defining Pro/DIAGRAM Symbols 

Components and fixed (non-parametric) connectors in Pro/DIAGRAM are represented 

by drawn symbols. Symbols can be defined and saved in both Drawing and in 

Diagram mode. When you place a symbol in the drawing, you place an instance of 

the symbol based on a definition that has already been created. There can be many 

symbol instances referencing the same symbol definition, each with a different 

reference designator to distinguish between them. 

You can select cable symbols or break symbols using the Diagram Item filter and the 

drawing or custom symbols using the Symbol filter. 

A connector or component symbol in Pro/DIAGRAM must have a certain set of 

parameters. Two parameters types can be included: 

• Symbol definition parameters to identify the symbol. 

• Node parameters identifying nodes. (If nodes are necessary in the symbol.) 

Symbols may be assigned to any component or connector parameters. 
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You can modify symbolic representations of components and fixed connectors (such 

as the shape of the symbol, nodes, and the location of notes) only by redefining the 

reference symbol definition. If the symbols are defined as Variable Drawing Units in 

the symbol definition, then you do not need to redefine the symbol to change its 

size. 

If you redefine a symbol, all component/connector instances in the diagram that 

reference the same symbol also change. 

Note: You cannot redefine a Parametric connector. 

Symbol Instances 

When you add a symbol instance, you specify: 

• The symbol definition to be used 

• Where to place it in the diagram 

• How large to make the symbol  

• Its parameters (diagram objects only) 

To add symbol instances you can: 

• Place them as you would in a drawing. 

• Place them as a diagram object such as a single-view component, a single-view 

connector, or a parametric connector. In the case of the parametric connector, 

the definition is actually a part of the instance. 

• Place them as part of a multiple view component or a multiple view connector. 

If an application uses a symbol with required parameters, but they are missing, the 

system issues an error message and you can edit the symbol parameter file. The 

next figure shows the format of the parameter file. 
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Parameter Set Format 

 

Pro/ENGINEER uses symbols containing an individual parameter set to create 

electrical diagrams. You can define Pro/DIAGRAM symbols in Drawing mode and 

Diagram mode. However, if you want to use them in Pro/DIAGRAM, you must define 

them as components or connectors by providing the parameter set appropriate for 

the type of object the symbol represents (component or connector). The following 

tables list component and connector parameters (the required parameters are shown 

in bold type). 

To Define a Drawing Symbol for a Component or Connector 

1. Click Format > Symbol Gallery. The DEFINITION menu appears. 

2. Click Define. 

3. At the prompt, type a new symbol name and press ENTER. The 

(SYM_EDIT_<NAME>) drawing window opens and the SYMBOL EDIT menu 

appears. 

4. Click Sketch in the drawing window to access the Pro/ENGINEER drawing tools to 

create the shape for the connector. 

5. When you have created the symbol shape, click Insert > Node. The SYMBOL 

NODE menu appears. 

6. Click Make Node. You are prompted to specify a node name. 

7. Type a name or number for the node at the prompt in the drawing window and 

press ENTER. You are prompted to name the next node. Name the node or 

middle-click to end the command. Node points are added as small circles. The 

Symbol Definition Attributes dialog box opens. 

Use the General tab to set origin points for the symbol and leaders you may 

attach to it. Use the Symbol Instance Height options to determine whether the 

symbol can be scaled or should remain of fixed dimensions. Use the Attributes 

check boxes to allow angle or mirror attributes. 

8. When you are finished with the Symbol Attributes dialog box, click OK. 
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9. To add connector or component parameters to the symbol definition, click 

Symbol Edit > Parameters > Read. The READ SYM PRM menu appears. Use 

any of the following commands to read in parameters of the diagram objects: 

o Comp DefaultAllows to read in default parameter set for a component. 

o Conn DefaultAllows to read in default parameter set for a connector. 

o OtherOpens a browser to read in a previously-saved parameter file. 

10. Click Done in the SYMBOL EDIT menu. The symbol is created. 

Note: You cannot use this procedure to add a symbol instance to the diagram. Use 

Insert > Drawing Symbol > Custom to add instances. 

To Add a Drawing Symbol from a Standard Palette to the Diagram 

1. Click Insert > Drawing Symbol > From Palette. The Symbol Instance 

Palette dialog box opens. 

2. Select the required symbol from the palette. The SELECT dialog box opens. 

3. Select an edge, entity, dimension, dimension witness line, coordinate system, 

curve, or a symbol entity to insert the symbol and click OK. The symbol is 

inserted at the selected location. 

4. Click Close in the Symbol Instance Palette dialog box. 

To Redefine a Symbol 

1. Click Format > Symbol Gallery. The DEFINITION menu appears. 

2. Click Redefine. The GET SYMBOL menu appears. Use the Diagram Item or 

Symbol filters to select the required symbol. 

3. Select an instance of the symbol to edit or click Name to select a predefined 

symbol from the Select Symbol Definitions dialog box and click OK. The 

symbol is placed in the drawing. 

4. Use the SYMBOL EDIT menu to make the edits. 

If you edit the drawn symbol, all instances are updated. If you edit symbol 

parameters, you can check the Propagate option to globally update the symbol 

instances in the design. 

5. Click Done/Return, when you finish. 

To Modify Symbol Size 

1. Select a symbol to modify. You can use the Diagram Item or Symbol filters to 

select the required symbol. 

2. Click Edit > Properties. The EDIT CONN and CONN VIEW menus appear. 

3. Click Resize from the CONN VIEW menu. 
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4. Enter a value, for instance, height. Pro/DIAGRAM displays the current value as 

the default and rescales the symbol. 

Note: If the symbols are defined as Fixed, you cannot modify them. 

To Modify a Drawing Symbol 

1. Select a drawing symbol to modify. You can use the Symbol filter to select the 

required drawing symbol. 

2. Click Edit > Properties or double-click on the symbol. The Custom Drawing 

Symbol dialog box opens. 

3. Under Placement, you can change the placement type. 

4. Under Properties, specify the height, angle, or color of the symbol instance 

according to the specifications. 

5. Under Origin, specify the origin as defined in the symbol definition or specify a 

custom origin for the symbol instance. 

6. Click OK. 

Note: If the symbols are defined as Fixed, you cannot modify them. 

Using Parameters in Pro/DIAGRAM 

About Parameters in Pro/DIAGRAM 

Diagram reference objects (components and connectors) and connections (wires, 

cables, and rails) have parameters associated with them. For connections, some 

parameters are passed from the spool that the wire or cable is added from, and 

other parameters are specified for the individual wire or cable after it is added to the 

diagram. Every entity has the following parameter types: 

• Required—The conductor or component must have values defined for these 

parameters. 

• Optional—These are not required to define the object, but are included as 

commonly used informational fields, for example, COLOR_CODE (Wht, Blk, Rd, 
and so on.). If the value is numeric, the parameter may be used in 

manufacturing design calculations, for example, MINIMUM_BEND_RADIUS for a 
cable. 

• Optional user-defined—You can define a new parameter and value for 

informational output as required, for example, SUPPLIER_NAME. 

Double clicking on a wire, rail, cable conductor, cable symbol, component view, or a 

connector view for a MVC, Parametric, inline, or a component group opens the 

Electrical Parameters dialog box. Use the Electrical Parameters dialog box to 

add or edit parameters for the selected diagram objects. You can edit a single 

parameter or make global edits. For example, you can assign a common value to all 

parameters of the same name, across selected objects. 
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Components vs. Connectors 

A component is a symbol with the OBJ_TYPE = COMPONENT parameter associated with 
it. Components use reference designators as unique identifiers and include properties 

for pins. 

Connectors are a subtype of components with the OBJ_TYPE value of CONNECTOR. A 
connector can use two additional parameters: 

• GENDER (MALE or FEMALE)—At the component level 

The gender is a design reference for the intended solid model and is required for 

connectors. 

• ENTRY_PORT—At the pin level 

The entry port is the name of a coordinate system on the solid model that 

specifies the beginning or end of a connection. 

These parameters are specifically used to pass information to Pro/CABLING. In 

Pro/CABLING, the ENTRY_PORT parameter designates pin to pin wire and cable 
connections for manual cabling or autorouting. 

To Add or Delete Parameters on the List 

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 

2. In the Object Type box, select the appropriate object type. 

3. Select the wires, cables, components, or connectors to modify. 

4. Click OK in the SELECT dialog box. 

5. When you set all the required options, click Modify in the Select By Type dialog 

box. 

or 

Select the wires, cables, components, or connectors to modify and right-click to 

select Parameters from the shortcut menu. 

or 

Double-click the wires, cables, components, or connectors that you want to 

modify. 

The Electrical Parameters dialog box opens. 

6. Set the appropriate Display For option to show or hide the display of parameters 

for different levels of the tree. For example, for a component, pin, conductor, 

entry port, and so on. 

7. Click View > Columns. The Model Tree Columns dialog box opens. 

8. Use the Model Tree Columns dialog box to move parameters back and forth 

from the Not Displayed to the Displayed windows as necessary. 
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To define a new parameter, type it in the Name box and click >> to move it to 

the Displayed window. The new parameter is added to the current list with 

<Nonexistent> as the value. Nonexistent means no value has been assigned to 
the parameter. You can change the values individually or globally. 

9. Click Apply and then OK. 

10. Add the new parameter to any object in the Electrical Parameters dialog box. 

11. Click Apply and then OK in the Electrical Parameters dialog box 

12. Click Close in the Select By Type dialog box. 

To Edit Electrical Parameters 

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 

2. In the Object Type box, select the appropriate object type. 

3. Select the objects in the diagram to modify. 

4. Click OK in the SELECT dialog box. 

5. Click Modify in the Select By Type dialog box. 

or 

Select the wires, cables, components, or connectors to modify and right-click to 

select Parameters from the shortcut menu. 

or 

Double-click the wires, cables, components, or connectors that you want to 

modify. You can also select multiple wires, cables, components, or connectors 

that you want to modify and double-click. 

The Electrical Parameters dialog box opens. 

The left pane of the dialog box contains a tree representing the selected objects 

and any associated subobjects, for example, connectors and their associated 

pins. The right pane contains columns for the parameters associated with each 

object. 

Depending on the object that you have selected, use the Display For box to 

show or hide the display of parameters for different levels of the tree. 

6. Click Apply and then OK in the Electrical Parameters dialog box. 

7. Click Close in the Select By Type dialog box. 

To Specify Parameter Values Individually 

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 
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2. In the Object Type box, select the appropriate object type. 

3. Select the wires, cables, components, or connectors to modify. 

4. Click OK in the SELECT dialog box. 

5. When all the options are set, click Modify in the Select By Type dialog box. 

or 

Select the wires, cables, components, or connectors to modify and right-click to 

select Parameters from the shortcut menu. 

or 

Double-click the wires, cables, components, or connectors that you want to 

modify. 

The Electrical Parameters dialog box opens. 

6. Set the appropriate Display For option to show or hide the parameters display 

for different levels of the tree. For example, for a component, pin, conductor, 

entry port, and so on. 

7. Select the parameter you want to edit in the right panel of the dialog box. 

8. Type a new value for the parameter in the Value box and press ENTER. 

The new value for the selected parameter appears in the right panel of the 

Electrical Parameters dialog box. 

To Specify Parameter Values Globally 

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 

2. In the Object Type box, select the appropriate object type. 

3. Select the wires, cables, components, or connectors to modify. 

4. Click OK in the SELECT dialog box. 

5. When all the options are set, click Modify in the Select By Type dialog box. 

or 

Select the wires, cables, components, or connectors to modify and right-click to 

select Parameters from the shortcut menu. 

or 

Double-click the wires, cables, components, or connectors that you want to 

modify. 

The Electrical Parameters dialog box opens. 
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6. Set the appropriate Display For option to show or hide the parameters display 

for different levels of the tree. For example, for a component, pin, conductor, 

entry port, and so on. 

7. In the right panel of the dialog box, select <multi-select> for the object type 

that you have selected. 

If a parameter for the object has any nonexistent values, you can change all 

values to a new value. 

8. Type a new value for the parameter in the Value box and press ENTER. 

The new value for the selected parameter appears in the right panel of the 

Electrical Parameters dialog box. 

To Change a Value for Pin Names across Multiple Connectors 

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 

2. In the Object Type box, select the appropriate object type. 

3. Select the components or connectors to modify. 

4. Click OK in the SELECT dialog box. 

5. When all the options are set, click Modify in the Select By Type dialog box. 

or 

Select the wires, cables, components, or connectors to modify and right-click to 

select Parameters from the shortcut menu. 

or 

Double-click the wires, cables, components, or connectors that you want to 

modify. 

The Electrical Parameters dialog box opens. 

6. Click Pins under Display For in the Electrical Parameters dialog box. 

7. Expand the Common Pins tree. 

8. In the right panel of the Electrical Parameters dialog box, select the specific 

pin name line and the parameter value you want to edit. 

Note: Values for most columns are <As Is>. This means that values differ for the 
same pin name across connectors. 

9. Type a new value for the parameter in the Value box and press ENTER. The 

values for the selected parameter are updated across all listed connectors for the 

specified pin. 

Note: Do not click Connections or Spools. 
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To Change a Single Value for Parameters across Multiple 
Connectors 

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 

2. In the Object Type box, select the appropriate object type. 

3. Select the components or connectors to modify. 

4. Click OK in the SELECT dialog box. 

5. When all the options are set, click Modify in the Select By Type dialog box. 

or 

Select the components or connectors to modify and right-click to select 

Parameters from the shortcut menu. 

or 

Double-click the components or connectors that you want to modify. 

The Electrical Parameters dialog box opens. 

When several connectors are selected in the Electrical Parameters dialog box, 

you can use the Common Pins tree to change values for a selected parameter 

across all listed connectors. 

6. Click Pins under Display For in the Electrical Parameters dialog box. 

7. Expand the Common tree. 

8. In the right panel of the dialog box, click <multi select> to the right of 

Common Pins and above the parameter you want to edit. A prompt appears 

above the tree headings. 

Note: Values for most columns will read as <As Is>. This means that values 
differ for the same pin name across connectors. 

9. At the prompt, type the new value and press ENTER. The values for the selected 

parameters are updated across all listed connectors. 

To Create a Parameter File from Object Parameters  

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 

2. Select the object or objects for which you want to create files and click OK in the 

SELECT dialog box. 

3. Click Modify in the Select By Type dialog box. 

or 

Select the wires, cables, components, or connectors to modify and right-click to 

select Parameters from the shortcut menu. 
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or 

Double-click the wires, cables, components, or connectors that you want to 

modify. 

The Electrical Parameters dialog box opens. 

4. Highlight an object in the object tree. 

5. Click File > Write in the Electrical Parameters dialog box. 

6. Enter a filename for the new parameter file to write the parameters of the 

selected diagram object to a file. 

To Read a Parameter File Into a Connector or Component  

1. Click Tools > Parameters > Objects. The Select By Type and SELECT dialog 

boxes open simultaneously. 

2. Select the object or objects to receive the parameters and click OK in the Select 

menu. 

3. Click Modify in the Select By Type dialog box.  

or 

Select the components or connectors to modify and right-click to select 

Parameters from the shortcut menu. 

or 

Double-click the components or connectors that you want to modify. 

The Electrical Parameters dialog box opens. 

4. Select the first target object in the tree. 

5. Click File > Read in the Electrical Parameters dialog box. 

6. Use the Open dialog box to select the target parameter file to import. 

7. Click Apply and then OK in the Electrical Parameters dialog box. 

8. Click Close in the Select By Type dialog box. 

Component Parameters 

OBJECT_TYPE 

(Required) 

The object type (COMPONENT OR CONNECTOR). 

Format: OBJ_TYPE text string 

REF_DES 

(Required) 

The reference designator name. When placing a 

component symbol in a diagram, you must supply 

a unique REF_DES name. The system saves this 
name with the symbol instance and uses it in wire 

lists, and the like.  
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Format: REF_DES text string 

NUM_OF_PINS 

(Required) 

The number of logical pins. The number of visible 

pins is determined by number of nodes in the 

symbol definition. 

Format: NUM_OF_PINS integer 

GENDER Required If object type is connector (Male or 
Female.). 

MODEL_NAME The name of the reference solid model in 

Pro/CABLING—the physical model that the 

component symbol represents. This helps 

Pro/CABLING to designate components 

automatically. 

Format: MODEL_NAME text string 

DESCRIPTION The description of the component. 

Format: DESCRIPTION text string. 

DEF_GROUPING The default grouping for entry ports in the 

connector, ROUND, WIRE or FLAT. Default value 
ROUND 

DEF_INTERNAL_LEN The default internal length value for all entry ports 

in connector, default value 0.0  

TABLE_AUTO_ASSIGN Optional, True, False, defaults to True. You can 
also set this parameter at the component level so 

that the parameter is applicable to all the pins of 

the component. 

Example: If you set the 

SIGNAL_VALUE_AUTO_ASSIGN parameter to FALSE 
for a terminator table, you cannot set the 

corresponding parameter for that pin. 

User Defined Establishes a user-defined parameter. Format: 

<parameter name> text string or value 

Example: SUPPLIER KGY_Supply_Co 

Connector Parameters 

 

REF_DES 

(Required) 

The reference designator name. When placing a 

connector or component symbol in a diagram, you 

must supply a unique REF_DES name. The system 
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saves this name with the symbol instance and 

uses it in wire lists, and the like. 

Format: REF_DES text string 

MODEL_NAME The name of the reference solid model in 

Pro/CABLING—the physical model that the 

component symbol represents. This helps 

Pro/CABLING to designate components or 

connectors automatically. 

Format: MODEL_NAME text string 

DEF_GROUPING The default grouping for entry ports in the 

connector, ROUND, WIRE or FLAT. Default value 
ROUND 

DEF_INTERNAL_LEN The default internal length value for all entry ports 

in connector, default value 0.0  

GENDER Required if object type is connector (Male or 
Female.). 

NUM_OF_PINS 

(Required) 

The number of logical pins. The number of visible 

pins is determined by number of nodes in the 

symbol definition. 

Format: NUM_OF_PINS integer 

OBJECT_TYPE 

(Required) 

The object type (COMPONENT OR CONNECTOR). 

Format: OBJ_TYPE text string 

TABLE_AUTO_ASSIGN Optional, True, False, defaults to True. You can 
also set this parameter at the component level so 

that the parameter is applicable to all the pins of 

the component. 

Example: If you set the 

SIGNAL_VALUE_AUTO_ASSIGN parameter to FALSE 
for a terminator table, you cannot set the 

corresponding parameter for that pin. 

Component Pin Parameters 

SIGNAL_NAME Signal name for the pin. Optional and can be 

entered in the ASCII file. 

SIGNAL_VALUE Signal value for the pin. Optional and can be 

entered in the ASCII file. 

ENTRY_PORT If the value is the name of a coordinate system 
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on the designated part in 3D, Pro/CABLING can 

identify the coordinate system as the correct 

entry port when using Logical Ref. If you enter 

this parameter in Pro/DIAGRAM, it is 

automatically included in the 3D assembly 

connector parameters when using Logical 

Ref/Update for the connector. (This parameter 

can also be entered into the 3D connector 

parameters manually.) 

This pin-to-coordinate system association can 

be used when routing cable conductors, to 

highlight the target entry port for each selected 

conductor as you route it.  

Required only for cable autorouting if you use 

more than one entry port coordinate system per 

connector.  

TERM_NAME Specifies the terminator name associated with a 

particular pin. Format: TERM_NAME string 

TERM_AUTO_ASSIGN Specifies the automatic assignment of 

terminator information from a table. 

The value TRUE (default) or FALSE determines if 
the terminator information is automatically 

overwritten by executing a terminator table. 

Example: TERM_NAME 6 TERM6327Y FALSE 

TABLE_AUTO_ASSIGN Optional, True,False, defaults to True. You can 
also set this parameter at the component level 

so that the parameter is applicable to all the 

pins of the component. 

Example: If you set the 

SIGNAL_VALUE_AUTO_ASSIGN parameter to 
FALSE for a terminator table, you cannot set the 
corresponding parameter for that pin. 

SHIELD  

PIN_PLUG  

INTERNAL_LEN The internal length for specific pin, overrides 

def_internal_len.  

GROUPING The grouping for specific pin, overrides 

def_grouping. (ENTRY_PORT is required to use 
this parameter.) 

User Defined Establishes a user-defined parameter. Format 
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<parameter name> text string or value 

Wire Spool Parameters 

The following is a list of spool parameters for wires. Parameters that have no relation 

to a diagram, but that pass values which are used in Pro/CABLING are marked. 

Note: For text values, you cannot use spaces in text strings. 

NAME The name of the spool file (text_string). 

Format: NAME text_string 

TYPE The type of spool used. Wires are of type WIRE. 

Format: TYPE text_string 

COLOR The color of the wire. 

UNDEFINED is the default. 

Format: COLOR text_string 

COLOR_CODE The color code of the wire (text_string. 

Format: COLOR_CODE text_string 

DENSITY The linear density of the spool (in mass/unit 

length). Not used in Pro/DIAGRAM, but used in 

Pro/CABLING when referencing a diagram to 

determine mass properties. 

INSUL_TYPE Insulation type (text_string). 

MASS_UNITS 
(Pro/CABLING) 

The units of mass for a wire. Used to determine 

mass properties of 3D wires that reference the 

diagram. Format: MASS_UNITS text_string 
Example: MASS_UNITS KG 

MIN_BEND_RADIUS 
(Pro/CABLING) 

The minimum bend radius allowed for the wire 

in harness part length units. Example: 

MIN_BEND_RADIUS 0.3 

THICKNESS 
(Pro/CABLING) 

The diameter of the wire. Example: THICKNESS 
0.1 

UNITS 
(Pro/CABLING) 

Specifies the units used for measurement of 

wires. Used by Pro/CABLING when referencing 

a diagram, in conjunction with the DENSITY 
parameter, to determine the mass of a wire. 

The default is the units used in a Pro/CABLING 

assembly. Example: UNITS inch 
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WIRE_CONSTRUCTION Wire construction. (text_string) Example: 

WIRE_CONSTRUCTION SINGLE_STRAND 

WIRE_GAUGE Wire gauge (text_string). 

Example: WIRE_GAUGE 18AWG 

User Defined Establishes a user-defined parameter, which 

can be accessed like other spool parameters. 

Format: <parameter_name> <value> 

Example: MANUFACTURER X_Corp 

Cable Spool Parameters 

The following is a list of predefined parameters that are unique to cable spools. A 

cable has a defined number of conductors, and each conductor has its own defining 

parameters, for example gauge or color, within the spool file. All wire spool 

parameters are valid for cable spools. Required parameters are shown in bold. 

NAME The name of the spool file. 

Format: NAME text_string 

TYPE (read only) Determines a cable spool or wire 

spool. Cables are of type PREFAB. 

NUM_CONDUCTORS The number of conductors 

present in a cable. The default 

value is zero. 

DENSITY The linear density of the spool (in 

mass/unit length). Not used in 

Pro/DIAGRAM, but used in 

Pro/CABLING when referencing a 

diagram to determine Mass 

Properties. 

INSUL_TYPE Insulation type. (Text string) 

NONE is the default. 

SHIELD_TYPE 

(cable spools only) 

The shield type for a cable. (Text 

string) If you set this parameter, 

it alters the cable symbol and 

makes it a dashed line to specify 

shielding. 

CABLE_JACKET_REPORT_NAME Use the default value DEFAULT, in 
which case the name of the cable 

shows in the report table. Any 

other value is interpreted as plain 
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text. For example, &cable_name 
has no special meaning. 

CABLE_SHIELD_REPORT_NAME Use this name for the cable 

symbol if the cable is shielded. 

The default value is SHIELD. 

CABLE_NODE_REPORT_NAME Use this name for the nodes of a 

cable symbol. The default value 

is "-".  

SHIELD_LINEAR_RESISTANCE Specifies linear resistance of the 

wire's shielding. 

OUTER_SHIELD_LINEAR_RESISTANCE Specifies linear resistance of the 

wire's outer shielding. 

LIN_CAP_TO_ITEM Specifies linear electric capacity 

between items. 

LIN_CAP_ITEM_TO_SHIELD Specifies linear electric capacity 

between items and shield. 

LIN_CAP_ASSEM_ITEM_TO_SHIELD Specifies linear electric capacity 

between assembly items and 

shield. 

OUTER_SHIELD_THICKNESS Specifies thickness of the outer 

shielding of the wire. 

Individual Wire and Cable Parameters 

The following table lists the available parameters for individual wires and cables. 

These parameters are established when the wire or cable is created, but are not 

passed from the spool. 

NAME Indicates the name of the wire or cable. This 

value is read-only in the parameter field and 

is created automatically upon creation of a 

wire or cable. Click Edit > Value to change 

the name of the wire or cable. The value of 

this parameter updates automatically in the 

file. 

Format: NAME read-only_string 

Example: NAME CABLE0001 

SPOOL Indicates the spool used for a wire or cable. 

This value is read-only and is created 

automatically upon creation of a wire or 

cable. Select the wire or cable and click Edit 
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> Properties to change the spool of the 

wire or cable. The value of this parameter 

updates automatically. 

Format: SPOOL read-only_string. 

MAX_ALLOWED_LENGTH 
(Pro/CABLING) 

Sets the maximum allowed length of a wire 

or cable. 

Format: MAX_ALLOWED_LENGTH value 

Example: MAX_ALLOWED_LENGTH 12 

MIN_ALLOWED_DISTANCE 
(Pro/CABLING) 

Routes the wire offset from all others at a 

location by the specified distance. This 

physically affects the display of the wires.  

Format: MIN_ALLOWED_DISTANCE value 

Example: MIN_ALLOWED_DISTANCE 2.5 

TARGET_LENGTH 
(Pro/CABLING) 

Sets the ideal length for a wire or cable.  

Format: TARGET_LENGTH value 

Example: TARGET_LENGTH 6.2 

User Defined Establishes a user-defined parameter that 

can be accessed like other wire or cable 

parameters. Value may be 

<parameter_name> or text_string.  

Value: <parameter_name> text_string 

Example: MANUFACTURER X_Corp. 

 

Note: 

• Only required parameters are applied to an individual wire or cable when you 

create it. 

• If a wire is separated from a cable, it does not inherit any parameters from the 

cable. This wire is treated as a newly created wire and has only the default 

required parameters, NAME and SPOOL. 

• Wire and cable parameters can be used to create labels and notes by adding the 

prefix cbl_ for a cable or wire_ for a wire to the wire or cable parameter. 
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Using Model Parameters 

To Add Diagram Parameters 

1. Click Tools > Parameters > Diagram. The Parameters dialog box opens. 

2. Click  or click Parameters > Add Parameter to create a new parameter. 

3. In the Parameters dialog box, type the Name and Value. 

4. Specify the Type by selecting one of the following: 

o Integer—Adds a parameter in the form of an integer. 

o Real Number—Adds a parameter in the form of a real number. 

o String—Adds a parameter in the form of a string. 

o Yes No—Adds a parameter with a value of yes or no. 

Note: The Type cannot be modified after being assigned a value. 

5. Click Designate if you want to designate the parameter. 

6. Click  or click Parameters > Add Parameter to add another parameter. 

7. Click OK. 

To Modify or Delete Existing Diagram Parameters 

1. Click Tools > Parameters > Diagram. The Parameters dialog box opens. 

2. Select an existing parameter that you want to delete. 

3. Click  or Tools > Parameters > Delete Parameter. 

4. Click OK. 

To Show All Current Diagram Parameters and Values 

1. Click Tools > Parameters > Diagram. The Parameters dialog box opens. 

2. Click Show > Info in the Parameters dialog box. An INFORMATION WINDOW 

opens that lists all the parameters and their values. 

Using Notes in Pro/DIAGRAM 

About Notes in Pro/DIAGRAM 

You can add text or parametric drawing notes to the diagram. 
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To Create Parametric Notes 

1. Click Insert > Note. The NOTE TYPES menu appears. 

2. Click On Item. 

3. Click Make Note. 

4. Select the wire to which you want to attach the note using the graphical selection 

methods, or the Diagram Item or Wire filter. The wire is highlighted. 

5. At the prompt, type the note contents and press ENTER. 

6. Click Done/Return to exit the note commands. The note is entered on the wire. 

Note: When a note is created On Item and attached to a wire segment, it can 

include any of the parameters valid for wire labels. 

Showing Diagram Parameters in Notes 

You can use Insert > Note > On Item to display parameter values for selected 

diagram entities. 

For example, to display the color of a cable conductor as defined in the cable spool, 

use the &cond_<parameter> form as &cond_color. If conductor2 has the parameter 
COLOR = BLACK, a note attached to conductor2 with the parameter &cond_color 
displays BLACK in the note. 

If you update the conductor parameter value for that individual cable, the note is 

updated. If there is no value for that cable conductor parameter in the individual 

cable, Pro/DIAGRAM uses the conductor parameter value in the cable spool. 

For example, if you use the note contents string: 

&cbl_name,COND&cond_name,&color 

Bold shows the values the & variables will supply, not bold shows text you included in 
the label. So, your cable label displays: 

CABLE02,COND1,WHITE 

Showing Diagram Parameters for Cables and Cable Conductors 

To show diagram parameters, attach the following parametric note parameters to 

wires in a diagram cable: 

• &spool_name—Shows the name of the parent spool. 

• &spool_<parameter>—Shows the value of a top-level spool parameter, for 
example, Color. 

• &cbl_name—Shows the cable name to which the wire belongs. 

• &cbl_<parameter>—Shows a specific cable parameter, for example target length, 
maximum allowed length, user-defined, and so on. 
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• &cond_name—Shows the name of the spool conductor that has been assigned to 
that wire. 

• &cond_<spool parameter>—Shows a specific spool conductor parameter for that 
wire’s assigned conductor, for example, wire construction, color, user-defined, 

and so on. 

Note: You can set Pro/DIAGRAM to show the cable name and conductor number for 

a wire assigned to a cable by default. If you set the drawing configuration option 

cond_name_from_cable to YES, the wire label shows the cable name and conductor 
name instead of the wire name for any wires added to a cable and assigned a 

conductor number. 

For Cable Symbols 

You can enter &cbl_name, &cbl_<parameter>, &spool_name, and 
&spool_<parameter name> for note to display the cable name, spool name, or any 
cable or spool parameter. 

Showing Diagram Parameters for Wire Breakpoints 

Parametric wire notes can be attached to wiring breakpoints. Use the configuration 

option def_wire_break_label to create a default wire breakpoint note. When a 
variable is entered for this option, all subsequent breakpoints are automatically 

created with a note that contains the defined variable. 

In addition to all existing wiring parameter symbols, such as &wire_name, the 
following parametric symbols can be included in the note: 

• &wire_opp_sheet—Displays the sheet number where the wire routing resumes. 

• &wire_opp_sym—Displays the reference designator of the symbol where the wire 
terminates. 

• &wire_opp_node—Displays the terminating node name. 

• &wire_opp_item—Displays the reference designator of terminating symbol or 
name of terminating rail. 

Defining Label Contents 

Use the setup option pc_ident_label to define a pattern of parameters used as 
contents of a label for the note on a parametric connector. 

For example, if you set the value of pc_ident_label in the setup file to &first-
&second-&third, add the parameters first, second, and third to the parametric 
connector with the values of Parametrics, Designer, and Refdes, respectively, the 
label for the parametric connector becomes Parametrics - Designer - Refdes. 

To Set Up Label Contents by Pattern 

1. Click Tools > Parameters > Pattern. The PARAM PATTERN menu appears. 
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2. Click Add to specify a target parameter name that contains pattern information 

for all the specified objects. The MOD PAT TYPE menu appears. 

3. Click Wires/Cables to modify parameters of wires and cables or Ref Objects to 

modify parameters of components and connectors. You are prompted to specify 

the name of the target parameter that you want to set. 

4. Type a target parameter name to be set that contains pattern information for all 

the specified objects and press ENTER. You are prompted to specify the name of 

the parameter that contains the pattern. 

5. Type a source parameter name that contains the pattern, to override the default 

pattern, if needed. You are prompted to specify a default pattern. 

6. Type a default pattern, for example, &<param_name1>-&<param_name2>. 

Note: The separator can be any valid character. 

7. Click Execute All. The system loops through all the specified objects, evaluates 

the patterns, and sets the target parameter to the value obtained from the 

pattern. 

Use this procedure for both the ref_des pattern and for the wire name or rail name 
pattern. 

Reference Zones and Parametric Notes 

Reference zones are designated areas of a diagram drawing in which views of 

multiple-view components (MVC) can be cross-referenced using parametric notes. 

These notes are used primarily in the construction of ladder diagrams. 

A reference zone consists of either horizontal or vertical division lines, each of which 

is assigned an index or line number. You first determine the physical size of the 

reference zone and then specify the starting index and delta. 

Using MVC Cross References in a Note 

Cross-reference notes are used with multiple view components (MVC) and 

connectors. They identify the physical position of the views by showing the index of 

the division line they lie closest to within the reference zone. Cross-reference notes 

can be evaluated to identify the physical position of all views of an MVC or just those 

views with a specified view name. 

Enter the following into the body of the note: 

&zone_index:<ref_des>:<view_name> 

where <ref_des> is the reference designator of the MVC and <view_name> is the 
name of the view whose position is to be evaluated. The value of this note is the 

index of the division line in the reference zone closest to the view. If the view is not 

in a reference zone, an empty value is returned. If the view is later deleted, the 

value *** is returned. 

If <view_name> is omitted, that is, &zone_index:<ref_des> is used, then the 
position of all views of the MVC are evaluated. 



Pro/DIAGRAM™ - Help Topic Collection 

42 

Cross-reference notes can be used in the rung labels of a ladder diagram to report 

on the position of other views of MVCs. In this case, it is recommended that 

&zone_index is used, without the ref_des or view_name fields. 

You can omit the view name from the cross-reference note if the note is attached to 

the required view. If the view name is omitted and the note is not attached to any 

symbol, then the cross-reference note returns the index of the division line for all 

placed views with each index value separated by a space. 

Tip: Notes Attached to Nodes 

Notes attached to diagram symbol nodes can refer to node parameters (such as, 

&signal_name) and to the node name (&node_name). Other symbol notes can refer 
to top symbol parameters (such as &ref_des). The types of text that can go in a 
node note vary. 

Manipulating Diagram Objects 

About Cutting and Pasting Diagram Objects 

Select an object that you want to cut using the Diagram Item filter or an appropriate 

filter, or select the object graphically using any selection method, and use Edit > 

Cut. 

If you select a conductor to cut, the conductor and the terminal components on 

either end of the conductor are highlighted to identify the pins that are to be 

disconnected. When you execute the cut, only the selected conductors are removed 

from the drawing. 

You can paste the selected objects at another location by selecting the location on 

the drawing and placing them on the drawing using Edit > Paste. 

To Insert a Sheet 

Click Insert > Sheet to insert a blank drawing sheet. The sheet is inserted after the 

last sheet. 

To View a Sheet 

1. Click View > Go to Sheet or double-click the sheet number tag at the bottom of 

the current drawing sheet. The Go to Sheet dialog box opens. 

2. Type the sheet number or click Previous, Next, or Go To, depending on the 

current position of the sheet. 

3. Click Close. 

To Move a Sheet 

1. Click Edit > Move Sheet to move the sheet to the required position. The Move 

Sheet dialog box opens. 
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2. Under Insert sheet after, sheets for the current drawing are displayed. Select a 

sheet after which you want to place the selected sheet. Select Insert at 

beginning to place the sheet at the beginning of the drawing. 

3. Click OK. 

To Delete a Sheet 

1. Click Edit > Remove > Sheet. 

2. At the prompt, type the sheet numbers to delete and press ENTER. 

Note: Sheet numbers must be separated by commas. 

To Move Objects 

1. Select a component, connection, note, or symbol using the graphical selection 

methods or use any of the following filters: 

o Diagram Item 

o Component 

o Connector 

o Table 

o Note 

o Wire 

The selected objects are highlighted. 

Note: Using a Connector filter you can select a Parametric, single view, multi-

view, or Inline type of connector. If you use a Component filter, you can select a 

component group and single view or multi-view type of components. 

2. Drag the item to its new position. 

3. Left-Click to place the item at the new position. 

Alternatively, you can select the objects you want to move and use Edit > Move 

Special to change the x- and y-coordinates of the object. 

Note: When moving components, connectors, and wires, Pro/DIAGRAM retains all 

the established links. Use View > Repaint to regenerate the diagram view after 

moving some items. 

To Move Objects to Another Sheet 

To move components, connectors, and conductors from one sheet to another: 

1. Select the items that you want to move to another sheet using the appropriate 

filter or any graphical selection method. The selected objects are highlighted. 

2. Click Edit > Move Item to Sheet. 
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Note: If the diagram has only one sheet, Pro/DIAGRAM creates a second sheet 

and places the items on the new sheet after you click Move Item to Sheet. 

3. At the prompt, type the number of the sheet to which you want to move the 

item. You can enter a new sheet number to insert a sheet and move the items to 

the new sheet. 

Note: All wires attached to the symbol nodes break at an arbitrary point on the first 

sheet and continue on the destination sheet, with break-off points displayed as "X". 

You can later modify the wire shape and the break-off point location. 

To Rotate Objects in 90-Degree Increments 

To rotate Components or Connectors: 

1. Select the items that you want to rotate using the graphical selection methods, 

the Diagram Item, Component, or Connector filter. The selected objects are 

highlighted. 

2. Click Edit > Properties. The EDIT CONN and CONN VIEW menus appear. the 

SELECT dialog box also opens. 

3. Click Rotate 90 in the CONN VIEW menu. Pro/DIAGRAM rotates each object 

counterclockwise by 90 degrees. 

4. Click Done in the EDIT CONN menu. 

To rotate Symbols: 

1. Select the symbol that you want to rotate, right-click, and select Properties 

from the shortcut menu. The Custom Drawing Symbol dialog box opens. 

2. Under Properties, switch the symbol instance angle between 0, 90, 180, and 

270 degrees. The selected angle appears in the Angle box. 

3. Click OK. 

To Edit Labels or Reference Designators 

1. Click Edit > Value to edit variable text labels or reference designators. 

2. Select the object label or reference designator you want to edit. You are 

prompted to enter the value for editing. 

3. At the prompt, type a new value for the label or reference designator and press 

ENTER. The text value is changed.Click Edit > Value to edit variable text labels 

or reference designators. Click Edit > Value to edit variable text labels or 

reference designators.  

To Delete Diagram Objects 

1. Select an object that you want to delete. Select multiple objects by using a 

selection rectangle around the objects that you want to delete or simultaneously 

hold down the SHIFT key and select the objects. You can also use an appropriate 
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filter to select multiple objects for the selected filter. The selected objects are 

highlighted. 

2. Click Edit > Delete. The selected objects are deleted. 

Note: If you delete components that have wires routed to them, the Confirm 

Delete dialog box opens and you are prompted to take action on the connected 

wires. You can delete the attached wires or leave the wires as unattached. 

3. If you have selected multiple items, clear the Apply to All Selected check box 

and click Apply in the Confirm Delete dialog box. 

or 

If you have selected a single item for deletion and right-click to select Delete 

from the shortcut menu. 

4. To restore the deleted diagram objects, click Edit > Undelete or right-click and 

select Undelete from the shortcut menu. 

Note: Deleted objects are restored only if you perform an Undelete operation 

immediately after a Delete operation. 

Copying Diagram Objects 

Copying Objects 

Using Edit > Copy, you can copy drawing items, not only from within the same 

diagram, but also from one diagram to another. Items that you copy from one 

diagram to another retain the same reference designator. However, if the target 

diagram has an item with a reference designator that is the same as the copied item, 

Pro/DIAGRAM appends the suffix _cN, where N is a number, to the reference 
designator of the copied item in the target diagram. 

The following guidelines can be helpful as you use the Copy option: 

• If you copy a cable or wire, but the spool for the cable or wire does not exist in 

the target diagram drawing, Pro/DIAGRAM copies the spool along with the cable 

or wire. 

• If you copy a cable or wire, but a spool for the cable or diagram has the same 

name as an existing spool in the target diagram, Pro/DIAGRAM compares their 

parameters. 

If the parameters for the two spools are different, it copies the spool from the 

source diagram and gives this spool a nonconflicting name by appending the 

suffix _cN, where N is a number, to the spool name. The copied wire or cable 
references this new spool. It also copies relevant symbol definitions, if they do 

not already exist in the target diagram. 

• When you copy items from one diagram to another, Pro/DIAGRAM does not copy 

layer information from any source items to the target diagram. 
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Note that, because no two items in a diagram can have the same reference 

designator, Pro/DIAGRAM appends the suffix _cN, where N is a number, to the 
reference designator of each copied symbol in the diagram. You can change this 

reference designator later. 

To Copy Items 

1. Select the object or objects that you want to copy using an appropriate filter for 

selection of items or any graphical selection method. 

2. Click Edit > Copy. Use the sheet number box on the menu bar to switch sheets, 

if necessary. 

3. Click Edit > Paste. The Diagram Clipboard window opens showing the copied 

object. 

4. In the Diagram Clipboard window, click on a point in or around the copied 

object where you want it attached to the pointer. A small yellow box marks the 

pick point. 

5. In the diagram, click a point where you want the attach point placed. The copied 

object is added to the diagram at the selected point. 

To Copy Items From One Diagram To Another 

1. Click File > Open to open the diagram from which to copy an object or objects 

to another diagram. 

2. Select the items that you want to copy to another sheet using the graphical 

selection methods or the Diagram Item filter. The selected objects are 

highlighted. 

3. Click Edit > Copy. Use the sheet number box on the menu bar to switch sheets, 

if necessary. 

4. Click Edit > Paste. The Diagram Clipboard window opens showing the copied 

object. The GET POINT menu appears with the following options: 

o select Pnt—Select a point. 

o Vertex—Select an entity end point. 

o On Entity—Select a point on an entity and correct the parameter. 

o Rel Coords—Type the offset from the ruler reference point. 

o Abs Coords—Type the coordinates. 

o Done—Accept this entity. 

o Quit—Reject this entity. 

5. In the Diagram Clipboard window, select a point in or around the copied object 

or objects where you want it attached to the pointer. A yellow box marks the 

selected point. 
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6. Click Window > <Diagram Name> to navigate to the diagram where you want 

to place the copied object or objects, if the copied object or objects belong to a 

different diagram. 

7. In the selected diagram, select a point where you want to place the attached 

point and click OK in the SELECT dialog box. The copied object or objects are 

added to the diagram at the selected point. 

Note: Click Edit > Transform for more advanced copy options, including: 

• Translate—When pasting, defines a directional vector and number of copies. 

• Rotate—When pasting, places a specified number of copies around a center point 

at specified angle points. 

Adding and Editing Components 

About Components 

Components are schematic representations of electromechanical parts or 

subassemblies. Each component symbol uniquely identifies or represents a physical 

model, unless both symbols are part of the same multiple-view component (MVC). 

Two or more occurrences of the same component symbol represent different 

instances of that component. They must have different reference designators and 

can have different attributes. 

A component has a graphical symbol representation and a set of defining 

parameters. Each component symbol must contain a set of predefined attach points 

called nodes, which define wire terminators and pins. You can define your own 

component symbols or retrieve them from the Pro/ENGINEER electrical symbols 

library. 

Nodes are displayed as green circles in Pro/DIAGRAM. The radius of the circle is 

controlled by the node_radius diagram setup option. 

Components vs. Connectors 

A component is a type of symbol with the parameter OBJ_TYPE = COMPONENT 
associated with it. Components use reference designators as unique identifiers and 

include properties for pins. 

Connectors are a sub type of component with the OBJ_TYPE value of CONNECTOR. A 
connector can use two additional parameters; GENDER (MALE or FEMALE) at the 
component level and ENTRY_PORT at the pin level. These parameters are used 
specifically to pass information to Pro/CABLING. The gender is a design reference for 

the intended solid model and is required for connectors. The entry port is the name 

of a coordinate system on the solid model that specifies the beginning or end of a 

connection. In Pro/CABLING, use the ENTRY_PORT parameter to designate pin-to-pin 
wire and cable connections for manual cabling or autorouting. 

 



Pro/DIAGRAM™ - Help Topic Collection 

48 

Automatic Entry Port Designation 

If ENTRY_PORT in Pro/DIAGRAM has a value the same as a valid coordinate system in 
the 3D connector in Pro/CABLING, Pro/CABLING automatically designates the 

coordinate system as an entry port, adding the ENTRY_PORT parameter to the 
connector and using default values of ROUND and 0.0 for the grouping and internal 
length values. This saves you having to enter the values manually after importing a 

logical reference into Pro/CABLING. The Internal length applies to all wires routed to 

pins represented by that entry port, not to individual pins. 

Note: The ENTRY_PORT parameter can be used with both component and connector. 

To Add a New Single View Component 

1. Click Insert > Component > Single View. The DGM SYM TYPE and the GET 

SYMBOL menus appear. When you add a component, you place an instance of a 

predefined symbol into the diagram. 

2. Click one of the following options from the DGM SYM TYPE menu: 

o Free—Places the view as a regular component freely on the diagram. 

o Insert—Inserts the view into a wire. When selected, only components with 

two pins or less are valid components for placement. Insertion causes the 

wire to be broken into two wires. 

o Att Wire—Places the view as a through splice. When selected, only 

components with one pin are valid components for placement. 

o Replace—Replaces a selected component. 

3. Use the Get Symbol options to select the component symbol. If the symbol does 

not have all the appropriate parameters, you are prompted to specify if they 

must be corrected. Enter [Y] to correct them and place the symbol. 

4. If the symbol height is defined as Variable, you are prompted to enter the 

symbol height. 

5. If the symbol definition includes variable text, you are prompted to enter the 

text. 

6. Select a location on the diagram for the symbol origin (specified when defining 

the symbol). 

7. The component symbol appears in the diagram. The Electrical Parameters 

dialog box opens. Enter and modify parameters for the component.  

8. When you are finished, click OK. The Adjust Inst menu appears with the 

following options to adjust the symbol placement: 

o Relocate—Selects a drag point on the symbol (not necessarily the same as 

the symbol origin). Specify its new location. Middle-click to abort. 

o Move Origin—Selects the new symbol origin. The symbol moves 

immediately so that the new origin is in place of the old one. The symbol 

origin determines its position when you move it later using Move. 
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o Rotate 90—Rotates the symbol around its origin 90 degrees 

counterclockwise. 

o Resize—Enter new value for symbol height. This option is only available if 

the symbol is defined as Variable. 

o Done—Completes the component position. 

9. Proceed to create other components, or click Quit from the GET SYMBOL menu. 

Using Components in Multiple Views 

About Multiple View Components 

Use multiple view components (MVCs) when you must show the same component, or 

parts of the same component, more than once in a diagram. The MVC (or connector) 

can appear repeatedly in the diagram, but is a single object in the Bill of Materials. It 

has one reference designator and one set of parameters that apply to all of its views. 

After you have added a MVC or connector, you can add an instance of this 

component or connector to a diagram. The instance is a representation of the MVC. 

Only one view can be added at a time. You can also insert the view in an existing 

wire or a cable. 

When you add instances of the MVC definition, you can place all the symbols defined 

within the view, or you can place selected symbols from the view to show only 

details associated with them. Each item within the MVC definition can be placed 

separately and moved, rotated or positioned as necessary. 

Note: 

• Symbols used to define a MVC can also be used individually as regular 

components that are not associated with a multiple view component. 

• If a symbol is used both individually and as a MVC, any parameters that are set 

for the individual symbol do not affect the multiple view component. 

• You must first create individual symbols and then define a MVC by including the 

individual symbols. 

For example, if a MVC consists of a contact and a coil, both the contact and the 

coil must first be created individually before they can be brought together to 

define a MVC. 

To Create a New Multiple View Definition 

1. Click Format > Multi-View Component Gallery or Multi-View Connector 

Gallery. The MULTI VW DEF menu appears. 

2. Click Define to create a multiple view definition. 

3. Enter a name for it in the information line when prompted and press ENTER. The 

MULTI REDEF and GET SYMBOL menus appear. 
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4. Select an appropriate command from the MULTI REDEF menu. 

Note: 

o The parameter Model_Name for a multiple view component is defined in the 
definition of the MVC and is retained even when a view of an instance of the 

MVC is placed. 

o Parameters that apply to MVCs have no effect on the original symbols. 

5. Click Add View to add a symbol to the MVC definition. You can select a symbol 

by name, select an instance of an existing symbol, or retrieve a symbol from 

disk. Repeat this step until you have added all the symbols required to define 

your MVC. 

Note: You can add the same symbol multiple times. 

6. Click Delete View to remove any unwanted symbols from your MVC definition. 

By default, the pins on the symbols you add to your MVC definition assume the 

names defined in the symbol definitions. Conflicts are automatically resolved 

using extensions _c0, _c1, and so on. 

7. Click Pin Names to re-define the pin names for the MVC. You are given each 

symbol’s name, its pin names, and the corresponding multiple view component 

pin name. Modify any MVC pin name as needed. 

8. Click Done from the MULTI REDEF menu. A new MVC is defined with the name 

you specified using the symbols you added. 

9. To save this MVC to disk, click Write from the MULTI VW DEF menu. Select the 

new MVC definition that you have specified and click OK in the Select MVC 

Definitions dialog box. The MVC definition is saved with a .mvc extension. 

To Add Multiple Views 

1. Click Insert > Component (or Connector) > Multi-View. The Select MVC 

Definitions dialog box opens. 

2. Select the required definition from the dialog box and click OK. You are prompted 

to enter a reference designator. 

3. Enter a reference designator and press ENTER. The VIEW NAMES menu appears 

showing the unplaced views in the selected MVC. 

4. Select the symbol for the view that you want to place. The GET POINT menu 

appears. 

5. Choose the appropriate option and click to place the symbol at a required location 

on the diagram. 

Note: If the selected view contains one or more nodes, the DGM SYM TYPE 

menu appears. Use this menu to place the views in a wire or a cable. 

6. Click Free. The GET POINT menu appears. 
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7. Place the symbol using the placement methods available on the GET POINT 

menu. 

If you use the same symbol more than once in the MVC definition, the 

corresponding views in the MVC have incremented node names, for example _c1, 

_c2, and so on. 

8. Repeat step 4 until you have placed all the required views. Middle-click to 

complete the task. 

Note: All views of a MVC must exist on the same layer of a drawing. However, 

views can exist on different sheets. 

To Delete an MVC Definition 

1. Click Format > Multi-View Connector Gallery or Multi-View Component 

Gallery. The MULTI VW DEF menu appears. 

2. Click Delete from the MULTI VW DEF menu. The Select MVC Definitions 

dialog box opens. 

3. Select the MVC you want to delete. You are prompted to confirm the deletion. 

4. Click Yes at the prompt. 

To Delete a Placed Multiple View Component or Connector from 
the MVC Definition 

1. Click Format > Multi-View Component Gallery or Multi-View Connector 

Gallery. The MULTI VW DEF menu appears. 

2. Click Redefine. The Select MVC Definitions dialog box opens. 

3. Select the required multiple view component instance that you want to remove 

from the diagram sheet. The MULTI REDEF menu appears. 

4. Click Delete View to remove a view from the MVC definition. The VIEW NAMES 

menu appears. 

5. Select the view to be deleted and click Done in the MULTI REDEF menu. 

Alternatively, you can also select a view to be deleted from the diagram sheet 

and right-click to select Delete from the shortcut menu. 

Note: 

• Deleting all views of a MVC from a diagram sheet does not delete its definition. 

• If wires are attached to the view, you are prompted to delete the wires or leave 

them unattached. 

• You cannot delete a symbol definition if an MVC is using it. 
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To Show the Multiple View Component Name 

1. Click Format > Multiple-View Component Gallery. The MULTI VW DEF 

menu appears. 

2. Click Show Name to display the name of the multiple-view component (MVC) to 

which a symbol belongs and then click the symbol in question. 

To Modify a Multiple View Component or Connector 

1. Click Format > Multi-View Component Gallery or Multi-View Connector 

Gallery. The MULTI VW DEF menu appears. 

2. Click Redefine. 

3. Select the multiple-view component (MVC) or connector that you want to modify. 

The MULTI REDEF menu appears. 

4. Use this menu to add or delete symbols to and from your MVC or connector. You 

can also modify the MVCs or connector’s parameters and pin names. 

5. Click Done when you finish modifying the MVC. 

To Modify Multiple View Definition Pin Names 

1. Click Format > Multi-View Component Gallery or Multi-View Connector 

Gallery. The MULTI VW DEF menu appears. 

2. Click MULTI VW DEF > Redefine. The Select MVC Definitions dialog box 

opens. 

3. Select the symbol for the view that you want to redefine. The MULTI REDEF and 

GET SYMBOL menus appear. 

4. Click Pin Names from the MULTI REDEF menu. The text editor opens. 

5. Modify the value of the items in the pin name column to give a different value to 

a pin in your MVC. 

Using Connectors 

About Connectors 

A connector is a specific type of component symbol with the parameter and value 

OBJ_TYPE = CONNECTOR. A connector can use two additional parameters; GENDER 
(MALE or FEMALE) at the component level and ENTRY_PORT at the pin level. 
Connectors may have wires and cables routed between the nodes or pins on the 

symbol. 

There are two types of connectors in Pro/DIAGRAM: 
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• Fixed—The connector appears as a drawn, fixed-shape symbol, either created in 

session or retrieved from a library. Fixed connectors are defined, stored, and 

added like components and differ only in parameters. 

• Parametric—The parametric connector appears as a standard symbol, its shape 

determined by the specified connector attributes, such as gender and number of 

pins. When the connector attributes are modified, the appearance of the symbol 

updates accordingly. 

To Add a Fixed Connector 

To add a fixed connector, you place a predefined symbol into the diagram: 

1. Click Insert > Connector > Single View. The DGM SYM TYPE menu and GET 

SYMBOL menus appear. 

2. Retrieve a previously defined connector symbol. If the symbol does not have all 

the appropriate connector parameters, you are prompted to correct them. Click 

Yes at the prompt to correct the selected symbol and place the symbol in the 
drawing. 

3. If the symbol is defined as Variable, enter the symbol height. 

4. If the symbol definition includes variable text, enter the text as prompted. 

5. Select a location on the diagram. This is where the symbol origin (specified when 

defining the symbol) is placed. The connector symbol appears in the diagram. 

The Electrical Parameters dialog box opens. 

6. Enter the appropriate parameter values into the dialog box, or use File > Read 

to load parameters from a file. You must have values for all required parameters.  

7. Complete the change with the ADJUST INST menu options. 

8. Create other fixed connectors, or click Quit from the GET SYMBOL menu. 

To Move Components and Connectors 

1. Select the symbol that you want to move. The selected symbol is highlighted in 

red. 

2. Click the symbol again to attach it to the pointer. 

3. Drag the symbol to the required location and click to indicate the new location. 

The symbol is placed such that its origin is at the selected point. All wires 

attached to the symbol nodes follow. The shape of the wires is updated 

parametrically with the new vertical and horizontal segments created 

automatically, if needed. 

4. To continue to modify the location of this symbol, select the connector and select 

a new location. 

Alternatively, you can select the objects that you want to move and use Edit > 

Move Special to change the x- and y-coordinates of the object. 
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To Mark a Pin Name as Lowercase 

If you need to have pin names of the same letter, differentiated only by case, use 

the less than symbol (<) before the pin name to mean that the pin name letter is 
lowercase. For example: 

<A means a 

<ABC means abc 

The name is not displayed in lowercase, but you can have two components or 

connectors in the same diagram named <A and A. 

To Show or Hide Node Names 

1. Select a connector from the drawing using the graphical selection methods, the 

Diagram Item, Component, or Connector filter. The selected connector is 

highlighted. 

2. Click Edit > Properties. The EDIT CONN and CONN VIEW menus appear. 

3. Click Param Display. The PARAM DISP menu appears. 

4. Click Show or Erase. 

Note: Clicking Erase hides the node names and does not erase them 

permanently. 

Tip: Switching Node Names 

You can switch node names for fixed connectors and components using the same 

method you would use to switch the node sequence for parametric connectors. Only 

Default and Switch are available in the Edit > Properties > EDIT CONN > Pin 

Sequence menu. 

You can switch two node names as long as the nodes belong to the same connector, 

and you can also switch node names among different views of a multiple view 

component. 

• If you switch a node name in one view of a MVC with a node name from another 

view of the same MVC and delete the original view from the symbol definition, 

Pro/DIAGRAM renames the node in the remaining node to its original name, as 

defined in its symbol definition. 

• If you rename one of the nodes, the node names remain switched. 

Parametric Connectors 

About Parametric Inline Connector 

Pro/DIAGRAM supports inline parametric connectors that consist of one male and one 

female connector with different reference designators, each with an identical number 

of pins, mated together. 
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When you connect two parametric connectors to create an inline connector, perform 

the following tasks: 

• Renames the nodes of the second selected connector to match those of the first 

selected connector. 

• Rearranges the visible pins of the second selected connector to line up with those 

of the first selected connector. 

Multiple parametric connector symbols can be displayed as partial views of the 

connector. The connector views can also be arbitrarily split and merged between any 

two pins and the new views can be placed on different sheets. 

To Add a Parametric Connector 

1. Click Insert > Connector > Parametric. The PARAM CONN menu appears. 

2. Click Male or Female. 

3. Click a location for the symbol in the diagram. You are prompted for the number 

of pins. 

4. Enter the number of pins on the prompt line and press ENTER. The Electrical 

Parameters dialog box opens. 

5. Enter appropriate parameter values into the dialog box, or use File > Read to 

import them from a file. The connector symbol appears in the diagram. 

6. Complete the connector using the options in the EDIT CONN and CONN 

OPTIONS menus. 

Note: 

• The default origin of the symbol is under pin 1. If you change the pin gap, the pin 

location moves, but the origin point remains at its original location. 

• At the prompt, you can enter up to 999 pins for the Num Vis Pins for a 

parametric connector. 

To Create a Parametric Inline Connector 

1. Click Insert > Connector > Inline. 

2. The INLINE CONN menu appears with two options: 

o Select Wires—Lets you click several wires to which to attach the inline 

connector. The selected wires must be parallel to each other. If a wire in a 

cable is selected, all other wires in the cable must be selected as well. If 

you create an Inline connector in this manner, each selected wire splits into 

two wires and places the inline connector at the point where the wires are 

separated. 

o Sel Location—Lets you create an inline connector at a specified location on 

your drawing instead of on selected wires. This is the default option. After 

choosing this option, select the location for the inline connector. 
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3. Enter the number of visible pins for this connector. The Electrical Parameters 

dialog box opens, showing lines for both connectors 

4. Enter the appropriate reference designator and parameter values for each 

connector into the dialog box and click OK. The inline connector appears in the 

diagram. 

5. Use the EDIT CONN and CONN OPTIONS menus to complete the creation of 

the inline connector. 

Note: To create an inline connector from two parametric connectors of opposite 

gender, use the Connect option. 

To Modify the View of a Parametric Connector 

1. Select a parametric connector to modify using the graphical selection methods, 

the Diagram Item, Component, or Connector filter. The selected connector is 

highlighted. 

2. Click Edit > Properties. 

or 

Select the parametric connector to modify and right-click to select Properties 

from the shortcut menu. The EDIT CONN and CONN VIEW menus appear. 

3. Use the EDIT CONN and CONN VIEW menus to modify the connector views. 

Note: You can also use this procedure to modify the gender, visible pins, and pin 

spacing of a parametric connector. 

To Edit the Pin Sequence of a Parametric Connector 

1. Select a parametric connector to modify. 

2. Click Edit > Properties. 

or 

Select the parametric connector to modify and right-click to select Properties 

from the shortcut menu. The EDIT CONN and CONN VIEW menus appear. 

3. Click Pin Sequence from the EDIT CONN menu. 

4. Select one of the following commands at the bottom of the PIN SEQUENCE 

menu before you select the editing method: 

o Fix Wires—Does not change the location of wires as you modify the pin 

sequence. 

o Adjust Wires—Reconnects wires according to the new pin sequence. 

5. Select one of the following commands from the PIN SEQUENCE menu to edit the 

pin sequence. 

o Default—Restores the default pin sequence. 
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o Enter Seq—Displays the current pin sequence in a message window. 

(Number names cannot exceed the value of the NUM_OF_PINS parameter.) 

o Select—Clicks a node to change its number. 

o Switch—Selects two nodes to switch numbers. 

o Reverse—Reverses the current numbering sequence for the connector. 

6. When finished, click Done from the EDIT CONN menu. 

To Modify the Name of a Reference Designator 

1. Click Edit > Value. 

2. Select a reference designator to modify. 

3. At the prompt, type a new value for the reference designator. 

4. Press ENTER. 

Note: Alternatively, click Tools > Parameters > Objects to modify the parameter 

value of the selected object or objects in the Select by Type dialog box. 

To Modify the Pin Gap in Parametric Connectors 

1. Select a parametric connector to modify using the graphical selection methods or 

the Connector filter. The selected parametric connector is highlighted. 

2. Click Edit > Properties. 

or 

Select the parametric connector to modify and right-click to select Properties 

from the shortcut menu. The EDIT CONN and CONN VIEW menus appear. 

3. Click Mod Pin Gaps on the CONN VIEW menu. The GAPS menu appears. You 

can define or modify the distance between selected pins during or after creation 

of a parametric connector. 

4. Click Add to increase the distance between pins in any parametric connector and 

click between any two pins (or between an end pin and the end of the connector 

symbol.) The distance is increased according to the current pin spacing. 

or 

Click Remove to remove gaps between pins. 

To Move Parametric Connector Text 

1. Select the connector containing the text that you want to move. 

2. Click Edit > Properties. The EDIT CONN, CONN OPTIONS, and CONN VIEW 

menus appear. 

3. Click Move Text from the CONN VIEW menu. 
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4. Select the node names or the reference designator text that you want to move. If 

you click a node name, Pro/DIAGRAM automatically selects all node names for 

the connector view. 

5. Select a new location where you want to place the node names or the reference 

designator text. Middle-click to cancel the operation. 

Note: Pro/DIAGRAM labels new pins that are added to a parametric connector using 

the same offset of the labels for existing pins. If two parametric connectors are 

joined to form an inline connector, the labels for the second parametric connector 

revert to their default positions. 

To Modify Parametric Connector Text Height 

1. Select a parametric connector containing the text that you want to change. 

2. Click Format > Text Style. The Text Style dialog box opens 

3. Enter a new value in the Height box. 

4. Click Apply to implement the change and then OK to close the Text Style dialog 

box. 

To Specify the Default Parametric Connector Node Label 

1. Click File > Properties. The Options dialog box opens. 

2. Use the diagram-specific setup option pc_node_label to set the default node 
label of parametric connectors. The value can be any text, a pin parameter, or 

any combination, including a user-defined pin parameter. The default node label 

is &node_name, which corresponds to the pin name for the node. Other valid 
parameter names include: 

o &signal_name 

o &signal_value 

o &entry_port 

o &user_defined 

You must first define a user-defined pin parameter for the connector before its value 

can be shown in the parametric connector node label. If the parameter does not 

exist, then it shows in the note as parameter text, for example, &address. 

To Edit the Parametric Connector Node Name 

1. Click Edit > Value. 

2. Select a node or a node name that you want to modify. 

3. At the prompt, type the new node name. 

4. Press ENTER. 
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Note: Alphanumeric names are valid. 

Grouping Component Symbols 

About Grouping Connector and Component Symbols 

There are groups of symbols that are usually used repeatedly in many different 

diagrams and multiple times in a single diagram. These groups typically consist of a 

component symbol and several connector symbols. You can define a group of single 

view components, connectors, and detail symbols that can move, scale, rotate, and 

mirror all together. 

An example of a symbol group is a cooling fan component, whose symbol is grouped 

with the power and control connectors that always appear with it. 

All symbol parameters, text, and geometry are taken from the individual symbol 

definitions. All symbols that are included in the component group must have the 

option for free placement in their definition. 

Note: You cannot use a multiple-view connector (MVC) to represent the group 

because every item belonging to this group is either a connector or a component and 

must have its own parameters and reference designators. For a multiple-view 

component or connector, the reference designators and the parameters are defined 

across all the views of a MVC definition. 

To Create a Component Group Definition 

1. Click Format > Component Group Gallery. The CMP GRP DEF menu appears. 

2. Click Define. At the prompt, type a component group name. The CMPGRP EDIT 

menu and the CMPGRP_EDIT_<NAME> window opens. 

3. Click Insert > Component Group View from the CMPGRP_EDIT_<NAME> 

window. The GET SYMBOL menu appears. 

4. Click Retrieve to add a detail symbol, connector, or component from disk. You 

can also use the Name and Pick Inst commands to select symbols available in 

the current component group definition. 

5. When you have placed all the symbols for the group in the window, the ADJUST 

INST menu appears. 

6. Use the commands in the ADJUST INST menu to relocate, resize, or rotate the 

component by 90 degrees and click Done. 

7. Click Quit in the GET SYMBOL menu. 

8. Click Set Origin from the CMPGRP EDIT menu to change the origin of the 

component group definition. The GET POINT menu appears. 

9. Use the commands in the GET POINT menu to select a point and set the origin. 

10. Click Done from the CMPGRP EDIT menu. 
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To Save a Group Definition File 

A group definition must exist for this command to be active. 

1. Click Format > Component Group Gallery. The CMP GRP DEF appears. 

2. Click Write. The Select Comp Group Definitions dialog box opens. 

3. Select the definition to save. You are prompted for a path. 

4. Enter a path and press ENTER. The file is saved as <groupname>.cpg. 

Note: If you do not specify a path, Pro/ENGINEER saves the component group 

definition file in the startup directory. 

To Modify a Component Group Definition 

1. Click Format > Component Group Gallery. The CMP GRP DEF menu appears. 

2. Click Redefine. The GET CMPGRPDEF menu appears and the Select Comp 

Group Definitions dialog box opens at the same time. 

3. Select the component group to redefine. It can be a symbol, component, or a 

connector and click OK. The CMPGRP_EDIT_<NAME> window opens and the 

CMPGRP EDIT menu appears at the same time. 

4. If you want to add a new member to the component group, click Insert > 

Component Group View from the CMPGRP_EDIT_<NAME> window. The GET 

SYMBOL menu appears. 

5. Click Retrieve to select the symbol, connector, or component you want to edit. 

You can also use the Name and Pick Inst commands to select existing symbols 

in the diagram from the Select Comp Group Definitions dialog box. 

6. When you have placed all the symbols for the group in the window click Quit. 

The ADJUST INST menu appears. 

7. Use the commands in the ADJUST INST menu to relocate, resize, or rotate the 

component by 90 degrees and click Done. 

8. Click Quit in the GET SYMBOL menu. 

9. If you want to change the origin of the component group, click Set Origin in the 

CMPGRP EDIT menu to change the origin of the component group definition. 

The GET POINT menu appears. 

10. Use the commands in the GET POINT menu to select a point and set the origin. 

Note: You cannot change the location of an individual member after it is placed 

on the diagram sheet. If you move (drag) an individual member of the group, the 

other members of the group also move. This is because the physical location of 

the members in a group is defined at the group definition level. 

11. Click Done from the CMPGRP EDIT menu. 
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Note: You can add symbols that are not components or connector object types to 

the component group, but you must add them as plain symbol instances with no 

parameters. 

To Create a Component Group Instance 

1. Click Insert > Component Group. The Select Comp Group Definitions dialog 

box opens. 

2. Select the component group to redefine. You are prompted to name the instance. 

3. Type a name for the new instance of the component group. The VIEW NAMES 

menu appears showing unplaced views in the group. 

4. Select views to place from the VIEW NAMES menu. The Electrical Parameters 

dialog box opens if you are placing a component or connector view. 

5. Enter a REF_DES name and a MODEL_NAME for each component in the group. 

6. Modify the parameters as required and click OK. 

Note: 

o If you are placing a plain (detail) symbol, no parameters are required, so 

the Parameters dialog box does not open. 

o If you use a plain (detail) symbol, you are unable to route wires to it, even 

if it has nodes. 

7. Select a symbol location in the main diagram window. The view of the instance of 

the object is placed at that location with the new reference designator name. As 

you select additional views to add, they are automatically placed because their 

relative location is defined in the component group definition. You can place some 

or all of the views in a component group instance when you create them. 

8. To display additional views of an existing instance where all views are not placed, 

click Insert > Component Group View and select an existing member of the 

component group. The VIEW NAMES menu appears showing a list of additional 

views in the group. 

9. Select the additional views to place from the VIEW NAMES menu and place 

them in the diagram. 

Note: You can select an instance in the diagram about which to obtain information 

by clicking Info > Component Group. 

• You can use the commands on the Format menu to manipulate component 

group symbol instances. 

• To resize a component group instance, the individual subsymbols must all be of 

variable height. 
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Creating Spools 

About Spools 

Each wire and cable in the design must be created from a predefined spool. Each 

spool has a unique name and a unique set of parameters and values that are passed 

to the wire or cable when the wire or cable is created. The spool is saved within the 

diagram file. It can also optionally be written out to a text file (.spl) that can be 
referenced in new diagram and cabling designs. 

Spools have a certain number of required parameters. You can also include standard 

optional parameters and custom defined informational parameters in the spool 

definition. 

Wire Spools 

Wire spools require values for Name and Type. The name value is the unique 
identifier, the type value is WIRE, to differentiate it from a cable spool. Other 
common but optional parameters defined in the wire spool are color and 
wire_gauge. Some parameters are automatically generated, for example 
min_bend_radius, to provide values for calculations in Pro/Harness Manufacturing. 

Cable Spools 

Cable spools have the same required parameters as wire spools, plus the required 

parameter num_conductors, which defines the number of insulated conductors 
included in the cables that will be created from the spool. When you create a cable 

spool, you edit the new cable spool file using the Electrical Parameters dialog box 

to include an integer for the number of conductors and a <define conductor- 
enddef> section for each conductor. 

Note: Although you can legally create cable spools without the define conductor 

sections, you should set up the conductor definitions if you intend to use the diagram 

as a logical reference for autorouting in Pro/Cabling. 

Active Spool 

When you first start to route a wire or create a cable, you are prompted to select a 

spool from which to create the wire or cable. The selected spool becomes the active 

spool. The spool name is displayed in the lower right corner of the sheet. Any further 

wires or cables you add are created from their respective active spool. You may 

change the active spool to a different spool at any time. 

Note: The information defined in a spool is important for any Pro/REPORT tables and 

wire/cable labels you create. 

You can write a spool file in ASCII format to be retrieved for use in other drawings. 

The configuration file option, pro_spool_dir, lets you specify the directory from 
which spools can be read. If this configuration file option is not set, the current 

working directory is used. 
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To Create a Wire or Cable Spool 

1. Click Format > Spools > Create. 

The SPOOL TYPE menu appears with the following options: 

o Wire—Create a wire spool. 

o Cable—Create a multi-conductor cable spool. 

Click the type of spool you want to create. You are prompted to specify a name 

for the spool. 

2. At the prompt, type a name for the spool. The Electrical Parameters dialog box 

opens. 

3. Click View > Columns and use the Model Tree Columns dialog box to add 

more parameters to the spool, if required. 

4. Select the NUM_CONDUCTORS parameter in the Electrical Parameters dialog 

box and specify an appropriate integer value in the Value box. This parameter 

decides the maximum number of conductors that a cable can have. 

Using the Electrical Parameters dialog box, you can add parameters to wires or 

cables of a connector or to the conductors of a cable spool. 

5. When finished, if you want to save the spool data, click File > Write and then 

OK to close the Electrical Parameters dialog box. 

To Modify Spool Parameters 

1. Click Format > Spools > Edit. The Select Spools dialog box opens with a list 

of all the spools used in the diagram. 

2. Select the name of a spool to edit or hold down the CTRL key and select multiple 

spools from the list. Optionally, use the Spool Filter commands to filter the list 

by type or number of conductors. 

3. Click OK. The Electrical Parameters dialog box opens. 

4. Edit the required parameters. 

5. Save the diagram to save changes to the spool in the current diagram. 

6. Use the File > Write option in the Electrical Parameters dialog box to modify 

the spool definition for use in other diagrams. 

Note: Alternatively, click Tools > Parameters > Objects. In the Select By Type 

dialog box select Spools as the object type. Click Modify and use the Electrical 

Parameters dialog box to modify the spool definition. 

To Rename Spools 

1. Click Format > Spools > Rename. The Select Spools dialog box opens. 
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2. Click a spool name from the spool list. You can use the pull-down menus over the 

list to filter the list by spool type or number of conductors. 

3. Click OK in the Select Spools dialog box. You are prompted for a new spool 

name. 

4. At the prompt, type a new spool name and press ENTER. The spool is renamed. 

5. Click Done/Return in the SPOOLS menu. 

To Save and Retrieve Spools 

1. Click Format > Spools > Write. The Select Spools dialog box opens. 

2. Click a spool name or names from the spool list. Click  to select all the 

spools from the list or hold down the CTRL key and select multiple spools from 

the list. You can use the pull-down menus over the list to filter the list by spool 

type or number of conductors. 

3. Click OK in the Select Spools dialog box to save an existing spool to disk. If the 

spool is written, it is confirmed at the prompt. If multiple spools are written, a list 

of all the spools written to the output files is displayed in the INFORMATION 

WINDOW that confirms that the spools have been written to the default directory. 

To read in a previously written spool (.spl) file: 

1. Click Format > Spools > Read. The Open dialog box opens. 

2. Select a spool file name (.spl). You can hold down the CTRL key and select 
multiple spools from the directory browser. 

3. Click Open in the Open dialog box. 

4. At the prompt, to read an existing spool you are prompted to overwrite the spool. 

If the spool is successfully read, it is confirmed at the prompt. 

Adding Wires 

About Adding Wires 

To add a wire to the design you must have at least one wire spool created in the 

database and selected as the active spool. If no wire spool is selected you are 

prompted to select one. The active spool name is displayed in the lower right corner 

of the sheet. Be sure it is the spool you want to use to create the wire. 

You can use wires to link nodes on one sheet or across multiple sheets. Wire breaks 

across sheets are marked with an X. You can also end wires in space. 

When you complete a wire it is assigned a unique default wire name that you can 

modify later if necessary. By default the wire name is displayed in the wire label. You 

may edit the wire label to read other properties of the wire, for example spool, color 

or strand type. You can also set configuration defaults to adjust the position and 

occurrence of the label on the wire. 
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Before you start it is useful to have Snap to Grid checked in the Environment 

dialog box and the grid set to the width between the pins on your connectors so that 

the pins lie on the grid. 

Tip: Orthogonal and Nonorthogonal Sketching 

Pro/DIAGRAM lets you sketch wires and other items at any angle. By default, wires 

and other items sketched in Pro/DIAGRAM appear in horizontal and vertical 

orientations only. To change this clear the Snap to XY Axes option in the 

Environment dialog box. 

To Create a Wire Path 

Before you start it is useful to have Snap to Grid checked in the Environment 

dialog box and the grid set to the width between the pins on your connectors. 

1. Click Insert > Wire. If you are already working with an active wire spool, the 

CREATE WIRE menu appears.  

If no wire spool is active you are first asked to select or create one. 

2. Click Sketch Path. 

3. Select a node. A red line follows the pointer. You can also select a point on a rail, 

or a point in space. 

4. Left-click to change the direction. 

Middle-click to break the wire and continue it on another sheet. 

Right-click to terminate the wire at the last left click in space. 

5. To complete the wire, click the destination point. Pro/DIAGRAM gives the wire a 

default name (WIREnnnn) that you can modify using the Options dialog box. 

To Change the Active Spool 

When nothing is selected: 

1. Click Format > Default Wire Spool or Default Cable Spool. The Select 

Spools dialog box opens. 

2. Select a spool or click New to define a new spool. 

When inserting a wire: 

1. Click Insert > Wire. The CREATE WIRE menu appears. 

2. Click Change Spool. The Select Spools dialog box opens. 

3. Select a spool or click New to define a new spool. 

The selected spool becomes current. All wires added to the diagram use the 

parameters of the selected spool until you choose Change Spool again. 
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To Make New Wires Follow an Existing Wire 

When adding wires, use this procedure to create a pattern of connections based on 

one selected wire. Once you have selected the pattern wire, you only need to click 

the from-to nodes of new wires. 

1. Click Insert > Wire. The CREATE WIRE menu appears. 

2. Click Follow Wire. 

3. Select a wire, highway, or rail to follow. The wire highlights in red. 

4. Select the start and end nodes for the new wire. The new wire is created by 

offsetting from the selected wire. 

To Change the Wire Path 

1. Click Insert > Jog. You are prompted to select the wire, highway, or rail at the 

position where you want to add a jog. 

2. Select the position for the new jog. Pro/DIAGRAM assumes that you are starting 

to sketch from the end of the original segment that is closer to the position used 

to select the segment. 

You can create one or more jogs by selecting successive points. A jog is added at 

a position wherever you click. If you place additional jogs, it is like resketching 

that one piece of wire, with the end of the sketched section connected with a 

rubberbanding segment to the other end of the originally selected piece. 

3. Middle-click to stop placing the jog. 

Note: To delete a jog, use Edit > Remove > Jogs. 

To Change From-To Direction 

1. Click Format > Conductor Direction. 

2. Select the wire you want to change. To select all wires in the cable, select the 

cable symbol, or one of the connectors. The COND DIRECTION menu appears. 

3. If you select a cable symbol, directional arrows appear showing you the to 

direction for each conductor. 

If you select a connector, use the COND DIRECTION menu to specify all wires 

going to or from the selected connector. 

If you select a single wire, a message, Direction of wire XXX has been 
flipped appears at the prompt. 

You can change the from-to direction of an entire cable or individual wires within the 

cable. 

To change the from-to direction of a wire or cable using a table: 

1. Select a wire or cable in the report table. A message, Direction of wire XXX 
has been flipped appears at the prompt. 
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2. Click Table > Repeat Region > Update Tables to update the table with the 

changed wire direction. 

To Add a Break to a Wire 

1. Click Insert > Break. The SELECT dialog box opens. 

2. Select two points on a wire. A break symbol appears at the two points. The wire 

segment between the two selected points is deleted. If a note is present on the 

wire segment being deleted, the note is also deleted. Wire labels are added to 

wire segments so that all wire segments are labeled. 

3. Click OK in the SELECT dialog box. 

Note: To create leading spaces in default wire-break labels, you must enter two sets 

of quotation marks before the spaces, such as, sht&wire_opp_sheet else, 
Pro/DIAGRAM does not accept the syntax as input, and does not create the leading 

spaces in the label. 

To Rename Wires 

1. Select the wire label and click Edit > Value. 

or 

Select the wire label to modify and right-click to select Edit Value from the 

shortcut menu. 

2. At the prompt, type a new wire label name and press ENTER. 

Note: You cannot modify cable conductor names if the setup option 

cond_name_from_cable is set to Yes. 

To Change the Spool Assigned to a Wire or Cable 

1. Select the wire or cable for which you want to change the spools. 

2. Click Edit > Properties. 

or 

Select the wires or cables and right-click to select Change Spool from the 

shortcut menu. The Select Spools dialog box opens. 

3. Select a spool from the list or click New to define a new spool. 

4. Click OK to update the spool parameters of the wire while not affecting the non-

spool parameters of the wire. 
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Moving Wires 

About Moving Wires 

You can relocate single selected wires or multiple selected wires. When you move 

wires, any cable symbols associated with the wires will stretch lengthwise to include 

the new wire location. However, cable symbols do not change location with wires. It 

is best to delete them and replace them if you need to move wires that have cable 

symbols attached to them. 

To Move a Single Wire 

1. Select a line, segment, or jog. The object is highlighted. 

2. Using the cursor, drag the object to a new location. 

3. Left click to release it. 

To Move Multiple Wires Simultaneously 

You can also select individual run segments as well as highway and rail end points. 

All segments that are selected together will translate together and retain their shape 

and relative position. 

1. Click Edit > Transform > Translate. The SELECT dialog box opens. 

2. Select runs*, run segments**, and highway or rail endpoints in the diagram. 

Alternatively, click Edit > Find. Use the Search Tool dialog box to select 

Wire/Cable in the Look for box and click Find Now. All the wires and cables 

associated with the diagram are listed. Select the wires you want to move, click 

Apply and then OK. 

3. Select multiple wires and then click OK in the SELECT dialog box. The GET 

VECTOR and GET POINT menus appear. 

4. Define the translation vector. Click one of the following commands from the GET 

VECTOR menu: 

Horiz—Enters an offset value along the x-axis. 

Vert—Enters an offset value along the y-axis. 

Ang/Length—Enters the translation vector in polar coordinates. 

From-To—(default) Selects the end points of the translation vector. 

5. Select the first point. 

6. Use the GET POINT options to complete the move to the final destination point. 

The highway segment and wires move simultaneously, and the wires at the other 

end of the highway are updated to attach to the new position, as if they had been 

moved individually. 
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Note: 

*Runs—Wires, cable conductors, rails, and highways. 

**Run Segment—A contiguous piece of a wire, cable conductor, rail, or highway that 

exists between any two components, connectors, cable symbols, rails, highway ends, 

breaks, or a combination of these. For example, a connector and a break, two 

breaks, or a rail and a highway end. 

Note: The way in which Pro/DIAGRAM moves wires and highways may differ 

depending on the Snap to XY Axes setting in the Environment dialog box, which 

may affect the creation of your diagram. You might have to switch the Snap to XY 

Axes setting on and off to achieve the required shape of the wire or highway you are 

moving. 

To Reroute Wires 

1. Click Edit > Attachment. 

2. Select the required wire segment. The wire is unattached from the nearest pin, 

and activated at the cursor. 

3. Sketch the selected wire segment to go to any other termination point. Middle-

click to change the sheet. Left-click to terminate unattached. 

To Reroute Wires to a New Symbol 

Use this procedure to replace one routed connector with another in the diagram. This 

process also applies to component symbols. 

1. Click Insert > Connector > Single View. The DGM SYM TYPE menu appears. 

2. Click Replace and select a component or connector to be replaced. 

You can select a part of a parametric connector, an MVC, or a component group. 

In case of an MVC, only the selected view is replaced. You cannot select a 

through splice. You can select a butt splice, because these cannot be 

distinguished from other components and connectors after they are created. 

3. Use the GET SYMBOL menu suboptions to identify the replacement symbol. 

Pro/DIAGRAM checks if there are any wires in the original symbol instance that 

do not have corresponding nodes of the same name, in the new symbol 

definition. Any such orphaned wires are highlighted in blue. Decide whether you 

want to delete them, or route them as unattached. 

4. The new symbol is attached to the pointer at its origin. Click a point in the design 

to place it. The Electrical Parameters dialog box opens. 

5. Update the parameters of the new component or connector, the REF_DES and 

MODEL_NAME are already filled in with values of the original. 

Note: If the original component or connector instance has two or more placed 

views, then the MODEL_NAME and REF_DES parameters are left blank in the 

dialog box. 
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6. Click OK in the Electrical Parameters dialog box when finished, 

o The old symbol and any wires that were highlighted in blue are deleted. 

o The new symbol is placed. 

o The remaining wires are rerouted to the nodes with the same name on the 

new symbol. 

Note: If the original symbol was the unique placed view of its component or 

connector, then the entire component or connector is deleted else, only one view 

is removed. 

To Automatically Reroute From One Symbol to Another 

1. Click Edit > Transfer All Connections. 

2. Select the view, the entire component or connector (including parametric 

connectors and MVCs) or pins whose attached wires you want to reroute. 

3. Select the destination view or the component, connector, or pins to which you 

want to reroute the wires. 

After selecting the destination component, wires in the first component are 

rerouted to pins with the same name on the second object. Wires terminating to 

a pin which has no corresponding name in the target object are not rerouted to 

the selected target. 

Editing Wire Labels 

About Editing Wire Labels 

The wire label's default contents and position on the wire path are determined by the 

values set for the drawing setup options def_wire_label and 
label_default_position respectively. 

You can also edit individual wire labels and attach additional wire labels as notes. 

To Edit a Wire Label 

1. Select a wire label and click Edit > Properties. The selected wire label is 

highlighted in red. 

or 

Select the wire label, right-click, and select Properties from the shortcut menu. 

or 

Double-click the wire label that you want to modify. 

The Enter Text dialog box opens. You can include system-defined parameters 

such as the spool name or parameters to be displayed adjacent to the wire name. 
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2. Edit selected notes in the window or click Editor to edit the notes in the 

Pro/DIAGRAM text editor. 

Note: The standard Pro/ENGINEER text editing tools are also available to edit the 

wire labels. 

3. Click Save and then OK. 

To Move and Reattach Wire Labels 

1. Click Edit > Attachment and select the wire label to move. 

or 

Select the wire label, right-click, and select Edit Attachment from the shortcut 

menu. 

You can move it anywhere along the wire segment or attach a wire label to 

another segment of the same wire. 

2. Select a new location where you want to place the label. 

To Refresh Labels after Parameter Edit 

1. Click View > Update Labels. The REDO LABELS menu appears. 

2. In the REDO LABELS menu, check the objects you want to include in the 

refresh. When Orientation is checked, you can choose to Keep Positions or 

Reset Positions. 

3. Choose note types. 

4. If you want to change the position, click Reset Positions and then choose a 

selection method. 

5. Select the sheets to refresh. 

6. Click Done/Return. 

To Create an Additional Wire Label 

1. Click Insert > Note. The NOTE TYPES menu appears. 

2. Click On Item and Make Note from the NOTE TYPES compound menu. 

3. Select a wire segment to attach the note to. 

4. At the prompt, type the note text. It can contain regular text, special symbols, 

blank spaces, wire parameters, and so on. To finish entering note text, press 

ENTER twice. 

To Set Up Wire Label Defaults 

1. Click File > Properties to set up the wire label contents and position. The 

Options dialog box opens. 
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2. Use the following setup options: 

label_default_position Position of labels on wire lines. Can be 

START, MIDDLE, END or any combination 
separated by commas. 

label_ends_gap Distance between nodes and labels. 

Numeric value 

label_parallel If YES, the wire label is always parallel to 
the wire, if NO, labels are always parallel 
to the orientation of the sheet. 

def_wire_label  Sets the default string to display in the 

wire label.  

default_wire_label_style Sets the default wire label style, which is 

a user-defined text style. 

default_wire_line_style Sets the default wire line style, which is a 

user-defined text style or a system line 

style. 

wire_default_increment  Defines the increment numerical value 

between two consecutively created wires. 

Used with wire default-prefix and wire-

default suffix. 

wire_default_prefix  Defines the text prefix of default wire 

names. 

wire_default_suffix  Defines the start number or letter of the 

default wirename. If 

wire_default_suffix is 1, and 
wire_default_increment is 2, 
consecutive wires are named wire1, 
wire3, wire5, and so on. If 
wire_default_suffix is A, and 
wire_default_increment is 2, 
consecutive wires are named wireA, 
wireC, wireE, and so on. (Cannot 
contain underscores, dashes, or a mix of 

numerical and alphabetical characters.) 

wire_notes_above  If Yes, the wire notes are set above the 
wire. If No, they intersect the wire. You 
can also enter a real number for exact 

offset from the wire. 
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Parameters for Wire Labels 

You can include the following parameters in a wire label: 

• &wire_name—Displays the name of the wire to which the note is attached. Upon 
creation, wires are assigned default names based on the diagram options. Use 

Edit > Value to modify the parameter value. 

• &spool_name—Displays the name of the spool referenced by the wire. 
Modification of the referenced spool name is not allowed. 

• &spool_<parameter>—Displays the value of a parameter in the wire’s spool. 
Replace <parameter> with any spool parameter, for example, &spool_color. You 
cannot use Edit > Value to edit the value of a parameter. Edit the spool 

parameter file to modify the parameter value. 

• &wire_<parameter>—Displays the value of a parameter in the wire. Replace 
<parameter> with any user-defined wire parameter, for example, 
&wire_circuitid. You cannot use Edit > Value to edit the value of a 
parameter. Edit the wire parameter file to modify the parameter value. 

The default value for def_wire_label is &wire_name. 

Note: If you change the def_wire_label parameter, only new wires are 
affected. You must change the existing wire labels using Edit > Properties to 

modify a single label, or use View > Update Labels to reset all labels according 

to the def_wire_label parameter. 

Alternatively, use the configuration options to determine the wire label position and 

orientation. 

Routing Across Pages 

About Wire Breaks 

Wire breaks let you break a wire or cable into multiple segments. This lets you 

sketch a wire across a number of sheets, or within the same sheet for visual clarity. 

Once a break point has been created, you can continue to sketch the wire at a 

different location, even on other sheets of the drawing. The wire break symbol is a 

large X. 

To Switch Sheets While Routing 

1. Sketch the wire from one node. Middle-click to create a wire break. You are 

prompted to enter a sheet number or create a new sheet. 

2. Select a sheet on which to place the next piece of wire. The default sheet, when 

creating wires, is the current sheet. 

When creating cables, the default sheet, if one of the cable conductors has 

already been sketched, is the sheet containing the other end of the cable. 

Otherwise, the default is the current sheet. 
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3. Press ESC to continue sketching the wire without the break. 

4. The point at which the wire continues on the new sheet is a large X. The break 

point X appears at the location where the wire has been terminated on the first 

sheet. Click on the wire to select a point at which you want the break to continue. 

5. Continue sketching the wire. 

To Add a Break to a Wire 

1. Click Insert > Break. The SELECT dialog box opens. 

2. Select two points on a wire. A break symbol appears at the two points. The wire 

segment between the two selected points is deleted. If a note is present on the 

wire segment being deleted, the note is also deleted. Wire labels are added to 

wire segments so that all wire segments are labeled. 

3. Click OK in the SELECT dialog box. 

Note: To create leading spaces in default wire-break labels, you must enter two sets 

of quotation marks before the spaces, such as, sht&wire_opp_sheet else, 
Pro/DIAGRAM does not accept the syntax as input, and does not create the leading 

spaces in the label. 

Tip: Use Grid Settings to Control Jog Points 

As you use Make Jog, you can set the Snap to Grid and Snap to XY Axes area 

checkboxes in the Tools > Environment dialog box to effect jog point placement: 

• Snap to Grid checked and Snap to XY Axes cleared—the jog point jumps to the 

nearest grid intersections.  

• Snap to Grid checked and Snap to XY Axes checked – if the final jog location is 

within a small offset of horizontal/vertical in relation to the destination point, it 

snaps to the horizontal/vertical position. If not, it snaps to the grid.  

• Snap to Grid cleared and Snap to XY Axes checked—When the jog moves, you 

can sketch only horizontal or vertical segments from the previous placement 

point. The final segment can be a diagonal line.  

• If you click Snap to Grid cleared and Snap to XY Axes cleared in the 

Environment menu, the jog point follows the cursor at any angle. 

To Remove a Break from a Wire 

1. Select one of the wire break symbols or the wire itself and click Edit > Remove 

> Breaks. 

or 

Select the wire that contains breaks, right-click, and select Remove Breaks 

from the shortcut menu. 

This removes all wire breaks. 
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2. Click OK in the SELECT dialog box. The wires whose breaks were removed are 

merged. 

Note: Wire breaks can be removed only if both wire break symbols appear on the 

same sheet. To remove breaks over a number of sheets, use the Switch Sheet 

menu option to move all wire segments and their attached components to the 

same sheet first. 

Tip: The Wire Break Symbol Setup Option 

To control the display of wire break symbols, you set the diagram setup option 

break_point_size to the default setting. 

The value assigned to break_point_size describes one side of a square that 
encloses the break point in drawing units. The current default value for the break 

point size is ~ 0.4 inches in drawing units. 

Note: Keep this value as the default value for the break point size in the diagram 

setup menu. 

When you change the value of break_point_size, all break points in a diagram 
change to that size when you repaint the screen with any View command.  

If you change the size of the break point, the notes associated with the breakpoint 

do not change. 

Display of the green dot associated with the break point is controlled by the setup 

option that controls node radius. 

• If you enter a zero or a very small number for that size value, then the break 

points do not display. 

• If you enter a negative number for break_point_size, the value is automatically 
converted into the value DEFAULT and interpreted that way. 

Note: If break points are not displayed, any notes associated with the breakpoints 

still display. 

Creating Cables 

About Creating and Using Cables 

A cable is a specific number of conductors that will be bound together for 

manufacture. The cable itself has certain parameters, and each conductor within the 

cable has its own parameters. For example, minimum bend radius is a property of 

the cable, but each conductor in the cable can have a color or thickness value. 

You can add wires to the design and then assign them to a cable; or, you can create 

the cable and add the wires to it as you route them, on the fly. 
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The Cable Spool 

In Pro/DIAGRAM cable properties are set up and stored in spools similar to wire 

spools. Cable spools have an additional required parameter for the number of 

conductors the cable has. When you define a cable spool, you use the Electrical 

Parameters dialog box to define parameters describing the properties of each 

conductor. 

Assigning Wires to Conductors 

When you add a cable to the design, you first activate a parent spool based on the 

number of conductors you need in the cable. 

To add a cable to the design: 

1. Select wires to add to the cable, then, 

2. Assign each wire you added to one of the predefined conductor numbers in the 

cable. 

When the cable is complete, the wires reference their associated conductors in the 

cable spool for parameters and values, the wire spool properties no longer apply. 

To Add a Cable to the Diagram 

Use this procedure to add a cable and assign wires to it. If cable spools have not yet 

been defined in the diagram model, you must first create a cable spool. 

1. Click Insert > Cable. The Select Spools dialog box opens. 

2. Click the cable spool from the Cable Spools list. To create a new spool click 

New. The ADD WIRES menu appears. 

3. Click Pick Wire. 

4. From the diagram, select the wires to include in the new cable. You can click 

Sketch Wire or any of the other wire creation commands to create them on the 

fly. 

The number of wires added to the cable must be less than or equal to the 

number of conductors in the cable spool. When the maximum number of wires, 

based on the spool's NUM_CONDUCTORS parameter value, has been added to the 
cable, you receive a warning message. 

5. When you have highlighted the wires you want to add, click ADD WIRES > 

Assign Cond. Follow the prompts to assign each selected wire to a cable 

conductor number. When wires become cable conductor numbers, they ignore 

the wire spool properties and parameters, and assume the properties listed for 

the conductor number in the cable spool. 

Wires selected for the cable that have not been assigned a cable conductor 

number are removed from the cable. 

6. Click Done from the ADD WIRES menu. 
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On the wire label, the individual wire spool names are replaced with the cable 

spool name. Optionally you may add a cable symbol to the diagram. 

To Change the Spool Assigned to a Wire or Cable 

1. Select the wire or cable for which you want to change the spools. 

2. Click Edit > Properties. 

or 

Select the wires or cables and right-click to select Change Spool from the 

shortcut menu. The Select Spools dialog box opens. 

3. Select a spool from the list or click New to define a new spool. 

4. Click OK to update the spool parameters of the wire while not affecting the non-

spool parameters of the wire. 

To Remove Wires from Cables 

1. Click Edit > Cable Contents > Remove Wires. The SELECT dialog box opens. 

2. Click the wires you want to remove and click OK in the dialog box. 

Note: The wires must be reassigned to wire spools. If wires in the cable are to be 

reassigned to different wire spools, only select those that will be assigned to one 

spool. 

3. The Select Spools dialog box opens. 

4. Click the wire spool to assign to the selected wires and click OK. The wires are 

removed from the cable. 

Repeat the routine for wires that must be assigned to different spools. When all wires 

are removed from a cable, the cable and symbol are removed from the design. 

To Modify a Cable Name 

1. Select the Note filter. 

2. Select the required cable name. 

3. Click Edit > Value. 

or 

Select the required cable name, right-click, and select Edit Value from the 

shortcut menu. 

4. At the prompt, type a new name for the cable and press ENTER. As in modifying 

wire names, Pro/DIAGRAM preserves any other text in the altered label. 
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To Delete Diagram Cables 

You can delete a cable and its conductors, or delete the cable and reassign the 

conductors as wires. 

1. Click  to select multiple cables to delete. A list of wires and cables in the 

diagram appears. 

2. Select the name of the cable to delete. The selected cables with the wires and 

cable symbols are highlighted. 

3. Click Edit > Delete to remove the cable and conductors. 

or 

Select all the cable conductors using the Cable Conductor filter, right-click and 

select Delete from the shortcut menu. This deletes the cables as well as the 

conductors. 

4. To restore the deleted cables, click Edit > Undelete or right-click and select 

Undelete from the shortcut menu. 

Note: Deleted objects are restored only if you perform an Undelete operation 

immediately after a Delete operation. 

Using Cable Symbols 

About Cable Symbols 

A cable symbol denotes that all wires passing through it are conductors of a single 

cable. A note on the symbol includes the cable name. The symbol can stretch or 

shrink to accommodate moved conductors. 

Each wire in a cable is required to pass through every cable symbol for the cable. A 

wire cannot belong to more than one cable. To place a cable symbol on a sheet, all 

wires in the cable must have at least one segment on the sheet. 

All wires must go through a cable symbol in parallel. If some wires are not parallel, 

Pro/DIAGRAM gives you the option to let it automatically create jogs so that each 

wire can be included in the cable symbol. The following figure displays a cable 

symbol applied to five conductors. 
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Note: Use the Electrical Parameters dialog box to modify the cable symbol 

parameters. 

Assigning Names to Cable Symbols 

When a table or a neutral wirelist format output lists a cable symbol to which a wire 

is routed, the name assigned to the cable symbol is the exact value of the following 

parameters. No callouts are processed. 

• from_cable_report_name or to_cable_report_name parameter of the wire 
attached to the cable symbol 

• from_to_cable_report_name parameter of the wire attached to the cable symbol 
if the wire does not have parameters mentioned above 

• cable_jacket_report_name or cable_shield_report_name from the cable 
spool parameter list if the wire does not have the from_cable_report_name, 
to_cable_report_name, or from_to_cable_report_name parameters 

• The diagram setup options, cable_jacket_report_name or 
cable_shield_report_name when the parameters mentioned above do not exist 

Note: The cable name is assigned to the cable symbol name when the value of 

the setup option is DEFAULT. 

To Add a Cable Symbol to the Diagram 

1. Click Insert > Cable Symbol. The SELECT dialog box opens. 

2. Select a wire segment in the cable to place the cable symbol. You can add a 

symbol to wires that have already been assigned to a cable.  

3. Click OK. 

If other wires in the cable have parallel segments, the cable symbol is created. Else, 

you are prompted to confirm the automatic creation of jogs (to create enough 

parallel segments) before the symbol is created. 

Note: You can insert cable symbols only for cable conductors. 
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Relocating and Resizing Cable Symbols 

Cable conductors move when you move the symbols that they pass through. To 

relocate or resize the cable symbols, select the required cable symbol and use the 

Edit > Properties menu. Symbols that you can resize are highlighted in red. You 

can also drag the cable symbols to relocate them. 

To Modify the Width of a Cable Symbol 

1. Select the cable symbol to resize. 

2. Click Edit > Properties. 

or 

Select the cable symbol to resize, right-click, and select Properties from the 

shortcut menu. 

The ADJUST INST menu appears. 

3. Click Resize. 

4. Enter a value, for instance, height. Pro/DIAGRAM displays the current value as 

the default and rescales the symbol. 

5. Click Done. 

To Delete a Cable Symbol 

1. Select the cable symbol or symbols you want to delete. 

2. Click Edit > Delete. 

or 

Select the cable symbols, right-click, and select Delete from the shortcut menu. 

The selected cable symbol or symbols are deleted. 

3. To restore the deleted cable symbols, click Edit > Undelete or right-click and 

select Undelete from the shortcut menu. 

Note: Deleted objects are restored only if you perform an Undelete operation 

immediately after a Delete operation. 

Tip: Reports Using Custom Cable Parameters 

You can create user-defined parameters for specific cable conductors within a cable. 

These parameters can then be displayed in the report tables. For example, when you 

specify the end preparation for an individual wire based on the terminator that is 

applied to it, you can capture the parameter information by creating user-defined 

parameters. 

Use Tools > Logical Reference to pass the values between the diagram and the 3D 

harness. 
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Tip: Representing Connections to Shielding 

Wires and cable conductors can be routed up to the arc ends of cable symbols to 

indicate an electrical connection to the shielding. If a wire is routed to a cable symbol 

end, a node shows at the midpoint of the arc at that end of the symbol, and the wire 

is attached to the node. One or both ends of the cable symbol can be routed to and 

have a node. The node display is controlled with the node_radius Drawing setup 
option.  

The symbol does not have any parameters that give it a name. However, the setup 

option cable_shield_report_name is used to specify a name to show in report 
tables as the From-To for wires routed from and to it. 

New optional cable spool parameters and wire parameters can be used to override 

the diagram-wide names specified in the setup option. 

Adding Splices 

About Splices 

You can splice wires together using the splice function. You can create two kinds of 

splices: 

• Butt splices—the wire is split into two separate wires and a one-pin component 

(the butt splice) is placed at the point of separation. 

• Through splices—the one-pin component (the through splice) is placed on the 

wire without splitting the wire. Additional wires can then be routed to the splice. 

Note: Before you create a splice, you must create a symbol with a single node. 

When you create or move a splice, note that: 

• A butt splice splits the wire it is placed on into two separate wires and does not 

move when the wire it is placed on is moved. 

• A through splice does not split the wire it is placed on and moves with it. 

Note: A component or connector that is being placed can also be inserted into an 

existing wire as a splice. 

To Create a Butt Splice 

1. Click Insert > Splice > Butt. The SELECT dialog box opens. 

2. Select the wire to which you want to splice a segment and click OK in the 

SELECT dialog box. The splice is created at the point you select on the wire. The 

GET SYMBOL menu appears. 

3. Use the GET SYMBOL menu to select the single node symbol to place at the 

splice. Use one of the following options: 

o Name—Select from a list of in-session diagram symbols by name. 

o Pick Inst—Select a symbol currently on the diagram. 
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o Retrieve—Browse to a directory containing the symbol. 

4. When you select the symbol it is placed at the splice point. The wire is split and 

the second half of the wire is given a new name. The component created is a 

regular diagram component. 

You can now route additional wires to the butt splice. 

To Create a Through Splice 

1. Click Insert > Splice > Through. The SELECT dialog box opens. 

2. Select the wire to which you want to splice a segment and click OK in the 

SELECT dialog box. The splice is created at the point you select on the wire. The 

GET SYMBOL menu appears. 

3. Use the GET SYMBOL menu to select the single node symbol to represent the 

splice. Use one of the following options: 

o Name—Select from a list of in-session diagram symbols by name. 

o Pick Inst—Select a symbol currently on the diagram. 

o Retrieve—Browse to a directory containing the symbol. 

4. When you select the symbol it is placed at the splice point. The component 

created is a regular diagram component. 

You can now route additional wires to the through splice. 

Using Power and Ground Rails 

About Power and Ground Rails 

Diagram rails are entities used to represent power or ground circuits. Rails are 

created in a manner similar to highways. 

Rails can be attached to components, connectors, other rails, or can be left 

unattached. Multiple wires can be attached to rails. 

Unlike highways, rails can contain parameters. The only required parameter is NAME. 
All other parameters are user-defined and can be modified using the same method 

as the one used to modify wire parameters. Like highways, rails can be broken into 

several views. 

Rail Display Setup Options 

Click File > Properties. Several drawing setup options that control rail display 

follow: 

def_rail_label Sets the default contents of the rail label. 

default_rail_label_style Sets the default rail label style, which can 

be any valid named text style that is user-
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defined. 

default_rail_line_style Sets the default rail line style, which is a 

user-defined text style or a system line 

style. 

rail_default_increment Defines the increment numerical value 

between two consecutively created rails. 

Used with rail default-prefix and rail-

default suffix. 

rail_default_prefix Defines the text prefix of default rail 

names. 

rail_default_suffix Defines the start number or letter of the 

default railname. If rail_default_suffix 
is 1, and rail_default_increment is 2, 
consecutive rails are named rail1, 
rail3, rail5, and so on. If 
rail_default_suffix is A, and 
rail_default_increment is 2, 
consecutive rails are named railA, 
railC, railE and so on. (Cannot contain 
underscores, dashes, or a mix of 

numerical and alphabetical characters.) 

rail_node_radius  Sets the size of the nodes displayed at 

attachment points between two rails or 

between a wire and a rail for printing and 

display. 

rail_notes_above  Places the rail notes a specified real 

number above the highway. The default is 

0.1. Enter NO to center the label on the 
rail. 

To Create a Rail 

1. Click Insert > Rail. The CREATE RAIL menu appears. 

2. Click Sketch Path to draw the rail. Left-click to sketch a path. Middle-click to 

create a break in the rail. Right- click to complete the sketch at the last left click 

point. 

or 

Click Follow Path to draw the rail parallel to the path of the object selected. 

or 

Click Use Wire to replace a segment of wire with a rail, through which the wire is 

routed. 
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3. When the rail is compete, click Done/Return. 

Assigning Rails to a Default Layer 

To assign rails to a default layer, set the configuration file option: 

def_layer layer_dgm_rail <layer_name> 

where <layer_name> is the name of the default layer for rails. 

Note: The default layer can also be set using the SetDefLayer option in the Layers 

menu. 

Using Highways 

About Highways 

Highways let you simplify a schematic visually by showing the path of multiple wires 

as a single line. When you include a wire in a highway, it affects only the graphic 

display of its path. 

To create highways you can: 

• Sketch the highway directly on the drawing, or 

• Use an existing wire path. 

To add wires to a highway you can: 

• Route a wire to a highway as the wire is being created, or, 

• Reroute an existing wire to a highway. 

To Add a Highway 

1. Click Insert > Highway. The CREATE HWAY menu appears. 

2. Click Sketch to draw the rail. Left-click to sketch the path. Middle-click to create 

a break in the rail. Right-click to complete the sketch at the last left click point. 

OR 

Click Follow Path to draw the highway parallel to the path of the object 

selected. 

OR 

Click Use Wire to replace a segment of wire with a highway, through which the 

wire is routed. 

3. When the rail is compete, click Done/Return. 

To Add Routed Wires to an Existing Highway 

1. Click Edit > Highway Wires > Add Wires. 
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2. Select the highway to which you want to add wires. 

3. Select a point on each wire where you want to begin re-routing. You can now 

route from this point to the destination highway. 

4. Select a point on each wire where you want it to exit from the highway. Select 

this point and re-route the wire to the highway. 

Wire labels are added so that all portions have a wire label. These labels can be 

deleted later, if required. 

Note: The Add Wires option remains active until another option is selected. This 

allows you to continue adding wires to an existing highway. 

To Add a Wire to a Highway While Routing 

1. Sketch a wire. While sketching the wire, select a point on the highway where you 

want the wire to enter. 

2. Pro/DIAGRAM informs you that a wire has entered the highway and prompts you 

to select an exit point. 

3. Select a point on the highway where you want the wire to exit and continue 

sketching the wire. 

To Remove Wires from a Highway 

1. Click Edit > Highway Wires > Remove Wires. 

2. Select the highway from which you want to remove wires. 

3. Select the wire or wires you want to remove. Use the Search Tool dialog box to 

choose the wires or multiple wires, you want to remove. 

4. Click Apply and then OK in the Search Tool dialog box. 

Note: When a wire is removed from a highway, the wire’s path remains the same as 

the highway it was removed from. You can move the wire away from the highway by 

selecting the appropriate wire to move. 

To Modify the Highway Entry or Exit Point 

1. Click Edit > Attachment. 

2. Click  or Edit > Find. Use the Search Tool dialog box to select the wire 

whose entry or exit point you want to move. Select the wire segment that is 

directly attached to the highway. 

3. Route the wire to a new attachment point. 

To Modify or Delete Highway Names 

1. Select the Note filter. 
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2. Select the highway name to modify and click Edit > Value. At the prompt, type 

a new name for the highway and press ENTER. 

or 

Select the highway name, right-click, and select Edit Value from the shortcut 

menu. 

3. Select the highway name you want to remove and click Edit > Delete to delete 

the highway name. 

or 

Select the highway name, right-click, and select Delete from the shortcut menu. 

Note: Use the setup configuration option def_highway_label. 

To Reroute a Highway 

1. Click Edit > Attachment. 

2. Select the end segment to reroute and reroute the highway. 

To Delete a Highway 

A highway can be deleted like a wire in a diagram. When a highway is deleted, all 

notes attached to the highway are deleted as well. 

1. Click  to select a single highway or multiple highways to delete. A list of 

highways in the diagram appears. 

2. Select the highway or highways you want to delete and click OK. Ensure that the 

selected highways appear on the same sheet. 

Highways and wires can be deleted simultaneously. 

3. If the selected highway has any wires attached to it, the DEL OPTIONS menu 

appears with the following options: 

o Delete—Removes the highway and all attached wires and cables. 

o Explode—Deletes the highway, but leaves all attached wires and cables in 

place. Select and drag to separate the remaining wires and cables. 

4. To restore the deleted highway, click Edit > Undelete or right-click and select 

Undelete from the shortcut menu. 

Note: Deleted objects are restored only if you perform an Undelete operation 

immediately after a Delete operation. 

Alternatively, you can also select the highway or highways to delete and right click to 

select Delete from the shortcut menu. 
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To Set Up the Highway Label 

To set up the highway label contents and position: 

1. Click File > Properties. The Options dialog box opens. 

2. Use the following setup options: 

def_highway_label Defines the highway label contents. 

This sets the highway label name. 

The default is no label. Enter 

&hway_name as a value to show the 
name; with the assigned prefix, 

suffix, and increment.  

highway_notes_above Places the highway notes a specified 

integer value above the highway. The 

default is .01. Enter NO to center the 
label on the highway. 

highway_default_suffix Defines the start number or letter of 

the highway name that increments as 

you add each new highway. The value 

must be either numerical or 

alphabetical, and cannot contain 

underscores, dashes, or a mix of 

numerical and alphabetical 

characters. The default value is 0001. 

highway_default_prefix Defines the prefix of highway names. 

The default value is HIGHWAY. 

highway_default_increment Defines the increment from 

name_suffix between two 
consecutively created highways. This 

value must be numerical. The default 

value is 1. 

default_highway_label_style Defines the default highway label 

style. This is a user-defined text 

style. 

default_highway_line_style Any valid line style can be specified 

including geometry, hidden, leader, 

cut plane, phantom, and centerline 
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Using Ladder Diagrams 

About Ladder Diagrams 

You can create ladder diagrams using the reference zone and cross-reference note 

functions. When creating a ladder diagram, you are prompted to select an existing 

reference zone. Rails are created along each side of the reference zone. Wires are 

created between the rails, along each of the division lines. Rails and wires can also 

be created manually. 

There are four steps to creating a ladder diagram: 

1. Create a reference zone. 

2. Use the ladder diagram functionality to create the rails and wires that represent 

the ladder diagram. 

3. Create, or retrieve, and place the appropriate single and multiple-view 

components on the wires in your ladder diagram. 

4. Create and place the appropriate rung labels for your ladder diagram. Each rung 

(division line) of a ladder diagram can be labeled with a rung label. Rung labels 

can contain cross reference notes which, for each view on the rung, identify the 

physical position of other views of multiple view components. 

After you create a reference zone, you can add and remove division lines from the 

reference zone. You can also modify the following attributes: 

• The spacing between the division lines 

• The numbering scheme used for the division lines 

• The reference zone’s boundary 

• A division line’s index 

• The position of the index labels 

To Create a Reference Zone 

1. Click Format > Reference Zones. The REF ZONES menu appears. 

2. Click Create to create a reference zone. You are asked to specify a rectangular 

area for your reference zone by selecting corner points. If this rectangular area 

overlaps an existing reference zone, the reference zone you create is truncated. 

The ZONE DIR menu appears. 

3. Click Horizontal in the ZONE DIR menu if you want the division lines in this 

reference zone to be displayed horizontally. Click Vertical if you want the 

division lines to be displayed vertically. 

4. Enter the new grid spacing of the division lines, a starting index, and a delta 

(index difference between the lines). The starting index can be a negative 
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number. Horizontal division lines are used with a default grid spacing of 0.25, a 

starting index of 10, and a delta index of 10. The ZONE SETUP menu appears. 

5. Select an appropriate command from the ZONE SETUP menu. 

o Mod Boundary—Click a new area of your drawing to use as a reference 

zone. Division lines which no longer fit in the area you have specified are 

deleted. New division lines are not created if the new area is larger than the 

old area. 

o Spacing—Enter a new spacing for the division lines in your reference zone. 

This value should be entered in drawing units. 

o Renumber—Specify a new starting index and a new delta. The reference 

zone is modified accordingly. The starting index can be a negative number. 

o Insert—Add a division line to your reference zone. When selected, you are 

prompted to select a point in your reference zone where you want the 

division line to be placed and to enter an index for this division line. A new 

division line is placed parallel to existing division lines at the location you 

specified. This option does not effect the current numbering of the division 

lines. 

o Remove—Deletes an existing division line and its index. This option does 

not effect the current numbering of the division lines. 

o Mod Index— Lets you modify the index of one division line. When 

selected, you are asked to choose the division line whose index you want to 

modify. You are then prompted to enter a new index. This option does not 

effect the current numbering of the division lines. 

o Label Pos—Change the position of all the labels in the reference zone. 

When selected, the Offset Side menu appears, allowing you to indicate the 

side of the reference zone where you want the index labels to appear and 

the index label’s distance from the edge of the zone. 

If the reference zone has vertical division lines, the Offset Side menu has the 

following options: 

o Top—Place all index labels on top of the reference zone. 

o Bottom—Place all index labels on the bottom of the reference zone. 

If the reference zone has horizontal division lines, the Offset Side menu has the 

following options: 

o Left—Place all index labels to the left of the reference zone. 

o Right—Place all index labels to the right of the reference zone. 

6. Click Done/Return first in the ZONE DIR menu and then in the REF ZONES 

menu. 

Note: Check the Zone Labels and Zone Grids options in the ENVIRONMENT 

dialog box to see the reference zone. 
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To Create a Ladder Diagram 

A reference zone must exist before you can create a ladder diagram. Also, a spool 

must be active. If none is active you are prompted to select one. 

1. Create a reference zone. Use this reference zone to create the rails and wires to 

make up the ladder diagram. 

2. Click Insert > Ladder. The CR LADDER menu appears. 

3. Click Make Ladder. The Select Spools dialog box opens. 

4. Select the required spool and click OK. 

5. Select an existing reference zone that you have created. Wires are created over 

the horizontal division lines in your reference zone and rails are created over the 

vertical boundary lines in your reference zone, depending on the type of division 

lines you have selected for the reference zone. 

Note: Check the Zone Labels and Zone Grids options in the ENVIRONMENT 

dialog box to see the reference zone. 

6. If rung label templates are available, you can choose a rung label template to use 

as the default rung label for your ladder diagram. 

7. Click Done/Return in the CR LADDER menu. 

To Create a Rung Label 

1. Click Format > Rung Labels to create, delete, or edit rung labels. The RUNG 

LABEL menu appears.  

2. Click Template. The RUNG TEMPL menu appears. If you chose to create or 

modify a template or create a new rung label, you are prompted to specify a 

name for the rung label template. The MOD RUNG LBL menu appears. This 

menu lets you edit each type of note that appears in the rung label and specify 

the views of a multiple view component. You must consider the views of a 

multiple view component during evaluation of the label. 

3. Select an appropriate command from the MOD RUNG LBL menu and click 

Done/Return in the RUNG TEMPL menu. 

4. If the rung labels in your ladder diagram need to be updated, click Update on 

the RUNG LABEL menu. 

Reference Zone Display Options 

Use the following two Environment dialog box options (Tools > Environment) to 

control the display of reference zones in ladder diagrams: 

• Ref Zone Labels—The labels of reference zone division lines are displayed and 

printed. 

• Ref Zone Lines—The grid lines of the reference zone are displayed and printed. 
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Using Terminator Tables 

About Terminator Tables in Diagrams 

ProCmdDgmTermTable@CMD,auto_param_table@DLG 

ProCmdDgmTermTable@CMD,auto_param_table@DLG 

ProCmdDgmTermTable@CMD,auto_param_table@DLG 

ProCmdDgmTermTable@CMD,auto_param_table@DLG 

ProCmdDgmTermTable@CMD,auto_param_table@DLG,ProCmdDgmElecParams@CM

D 

ProCmdInfoDgmBom@CMD,ProCmdInfoDgmBomLayer@CMD 

ProCmdInfoDgmBom@CMD,ProCmdInfoDgmBomLayer@CMD 

ProCmdInfoDgmWirelist@CMD,ProCmdInfoDgmWlLayer@CMD$$$ 

1. Click Info. 

2. Click Wire List to generate a list for all layers. 

or 

Click Wire List for Layer to generate a list of wires for a selected layer and 

select a layer from the Layer Sel menu. 

The wire list is generated and displayed in the INFORMATION WINDOW. The wire 

list is written to a file, dgm_wirelist.inf.#, where # is the version number in 
your current working directory. 

3. Click Close to close the INFORMATION WINDOW. 

Pro/REPORT Table Reports 

Using REPORT Tables in Pro/DIAGRAM 

Include customized wire lists in your diagrams using the Pro/REPORT table 

functionality. The following example shows how to enter repeat regions in a table to 

produce a from-to wirelist for a simple connection: 
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Use the table editor to enter repeat regions as shown. The table shows the output of 

each repeat region: 

 

A cable listed in the report table shows From-To information only if all cable 

conductors at one or both ends of the cable go to the same ref_des. 

• If the conductors go to different connectors, the report table entry for that end is 

"-", to show that the value has no meaning. 

• If the conductors go to the same connector, the connector information is shown 

appropriately. 

For more information on report tables see the Pro/ENGINEER Drawing Guide. 

To Modify Wire Names with Pro/REPORT 

The name of a wire or cable can be modified through a Pro/REPORT table using the 

following parameters: 

• &dgm.run.name 

• &dgm.run.cond.name 

• &dgm.spool.run.name 

• &dgm.spool.run.cond.name. 

Pro/REPORT Parameters for Pro/DIAGRAM 

There are four different groups of diagram parameters: 

• Parameters that begin with &dgm.run are used to create wire lists. 

• Parameters that begin with &dgm.spool are used to create tables listing 
information by spool. 

• Parameters that begin with &dgm.sym are used to create BOM tables. 

• Parameters that begin with &dgm.layer isolate items on selected layers. 
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Note: If you mix two parameters from different groups in the same repeat region, 

two sets of reports are created in the table, one located below the other. 

A list of system parameters that pertain to Pro/DIAGRAM appear in the following 

table. Parameters specific to Diagram models also appear in this table. If you want to 

enter report symbols into a table after defining a repeat region, click Edit > 

Properties > Enter Text > Report Sym command or double-click on the table 

cells. 

BOM and Family Table Parameters 

&rpt.index Displays the number 

assigned to each 

record in a repeat 

region. 

&rpt.level Shows the recursive 

depth of an item. 

&rpt.qty Displays the quantity 

of an item. 

Layer Parameters  

dgm.layer.name The layer name. 

dgm.layer.sym Duplicates the 

heirarchy under 

dgm.sym. Only 
evaluates to symbols 

on the current layer. 

dgm.layer.run Duplicates the 

heirarchy under 

dgm.run. Only 
evaluates to runs on 

the current layer. 

Diagram Parameters  

&dgm.run.cond.color Lists conductor color 

defined in the spool 

parameter file for 

wires belonging to 

cables. Lists color 

defined in the spool 

parameter file for 

individual wires. 

&dgm.run.cond.from/to.conn.name Lists the reference 

designators of the 

component/connecto



Pro/DIAGRAM™ - Help Topic Collection 

94 

rs or the name of the 

rail that wires (free 

wires or wires 

belonging to cables) 

are run to/from. 

&dgm.run.cond.from/to.conn.<User_Defined> Lists specified 

parameters for the 

component/connecto

rs or rails that wires 

(free wires or wires 

belonging to cables) 

are run to/from. 

Any parameter of the 

connector or rail can 

be entered manually. 

&dgm.run.cond.from/to.pin.name Lists the pin names 

of the connectors 

that the wires 

(except for free 

wires) are run 

to/from. 

&dgm.run.cond.from/to.pin.entry_port Lists the entry port 

of each pin that 

conductors are run 

from or to. 

&dgm.run.cond.from/to.pin.signal.name Lists the pin signal 

names of the 

connectors that the 

wires (free wires or 

wires belonging to 

cables) are run 

to/from. 

&dgm.run.cond.from/to.pin.signal.value Lists the pin signal 

values of the 

connectors that the 

wires (free wires or 

wires belonging to 

cables) are run 

to/from. 

&dgm.run.cond.from/to.pin.<User_Defined> Lists any user-

defined parameter 

that you enter for 

each pin that 

conductors are run 
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from or to.  

&dgm.run.cond.from/to.sheet Lists the sheet 

number on which the 

wires (free wires or 

wires belonging to 

cables) start or 

terminate. 

&dgm.run.cond.name Lists the assigned 

conductor name for 

wires (free wires or 

wires belonging to 

cables) in a diagram. 

&dgm.run.cond.User Defined Lists user-defined 

conductor parameter 

described in the 

spool parameter file 

for wires belonging 

to cables. Lists user-

defined parameter 

described in the 

spool parameter file 

for individual wires. 

&dgm.run.from/to.conn.name Lists the reference 

designators of the 

connector or the 

name of the rail that 

cables and free wires 

are connected 

from/to. 

&dgm.run.from/to.conn.<User_Defined> Lists any parameters 

defined in the 

connector or rail that 

you enter manually.  

&dgm. run. name Lists any wire or 

cable in the diagram. 

&dgm.run.param.<User_Defined> Lists any parameter 

that you enter 

manually as a user 

defined parameter 

for diagram wires or 

cables. 

&dgm.run.spool.name Lists the wire and 

cable spools name 
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parameter run. 

&dgm.run.spool.<User_Defined> Lists any user 

defined parameter 

for wire and cable 

run. 

&dgm.spool.name Lists the spool name. 

&dgm.spool.<User_Defined> Lists any spool 

parameter that you 

enter manually as a 

user defined 

parameter. 

&dgm.spool.run.cond.color Lists conductor color 

parameter for wires 

in cable and wire 

spool color for 

independent wires. 

&dgm.spool.run.cond.from/to.conn.name Lists the name of 

each connector or 

rail that every 

conductor is run 

from/to. 

&dgm.spool.run.cond.from/to.conn.<User_Defined> Lists the specified 

parameter for each 

connector or rail that 

every conductor is 

run from/to that you 

enter manually. 

&dgm.spool.run.cond.from/to.pin.name Lists the pin names 

that conductors are 

run from/to for every 

spool. 

&dgm.spool.run.cond.from/to.pin.signal.name Lists the pin signal 

names that 

conductors are run 

from/to for every 

spool. 

&dgm.spool.run.cond.from/to.pin.<User_Defined> Lists the specified 

user-defined 

parameter for each 

pin that conductors 

are run from or to for 
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every spool.  

&dgm.spool.run.cond.from/to.pin_entry_port Lists the entry port 

of each pin that 

conductors are run 

from or to for every 

spool.  

&dgm.spool.run.cond.from/to.pin.signal.value Lists the pin signal 

values that 

conductors are run 

from/to for every 

spool. 

&dgm.spool.run.cond.from/to.sheet Lists the sheet 

number on which the 

wire starts or 

terminates. 

&dgm.spool.run.cond.name Lists the name of the 

wire in the diagram 

for each spool. 

&dgm.spool.run.cond.<User_Defined> Lists the wire and 

cable specified 

parameters by spool. 

&dgm.spool.run.from/to.conn.name Lists the connector or 

rail names that 

conductors are run 

from/to by spool. 

&dgm.spool.run.from/to.conn.<User_Defined> Lists the connectors 

or rails parameters 

that conductors are 

run from. 

&dgm.spool.run.name Lists the spool names 

for each wire or cable 

in the model. 

&dgm.sym.node.name Lists the name of the 

given symbol node. 

&dgm.sym.node.sheet Lists the sheet 

number on which a 

given node is 

located. 

&dgm.sym.node.<User_Defined> Lists a pin parameter 

such as signal_name 
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for each connector. 

&dgm.sym.<User_Defined> Lists a parameter for 

a component or 

connector symbol. 

&dgm.sym.ref_des Lists the reference 

designator name for 

a component or 

connector. 

An item’s parameters can also be used in a Pro/REPORT table as a user-defined 

parameter. 

The MODEL_NAME parameter of a connector can be used as a user-defined parameter 
in a Pro/REPORT table as &dgm.run.from.conn.model_UserDefined and entered as 

model_name. This is possible even though a system-defined Pro/REPORT parameter 

called &dgm.run.from.conn.model_name does not exist. 

When creating a report, it is important to consider the structuring of the symbols in 

the report. Pro/REPORT provides the definition of each symbol based upon the item 

or items to the left of the description. 

The table below lists the names of all sketched wires and the name of the associated 

spool. 

&dgm.run.name &dgm.run.spool.name 

W21 Spool32 

W33 Spool18W 

Pro/REPORT provides information based upon a hierarchy of specifications.  

In the example above, the parameter &dgm.run.name gives the name of all the runs 
(cables and individual wires) in the harness. The spool name, &dgm.run.spool.name, 
gives the name of the appropriate spool for each run in the harness. 

The next table illustrates the slight differences between similar parameters. 

&dgm.spool.name &dgm.spool.run.name 

Spool32 W21 

Spool18W W33 

Spool12  

In this case, the repeat region parameter &dgm.spool.name lists all spools in the 
diagram, whether or not that spool has an associated run. Because Spool12 has no 

associated wire, it appears in the second table. 

Report Parameters for Connections 
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The following is a complete list of report parameters that work for conductor names, 

connectors names, pin names, and the sheet to which the conductor is routed. 

&dgm.run.from/to.conn.name 
&dgm.run.cond.from/to.conn.name 
&dgm.spool.run.from/to.conn.name 
&dgm.spool.run.cond.from/to.conn.name 
&dgm.run.cond.from/to.pin.name 
&dgm.spool.run.cond.from/to.pin.name 
&dgm.run.cond.from/to.sheet 
&dgm.spool.run.cond.from/to.sheet 

Diagram and the pos_loc callout 

In Pro/DIAGRAM the &pos_loc callout recognizes the following types. 

View <view name> 

parent_note <view name> 

ref_obj <reference designator> 

routed_from <diagram connection name> 

routed_to <diagram connection name> 

For example, to show the location of a view named main_view, type the following in 
the note text box: 

Main view is located in &pos_loc:view:main_view 

Accessing Conductor Parameters in Pro/REPORT 

You can access conductor parameters using the following Pro/REPORT parameters: 

• dgm.run.cond.<User Defined>—This parameter searches first in the conductor 
of the individual cable for the specified parameter. If the parameter is not found 

in the conductor, it searches in the spool conductor parameters for that 

parameter. 

• dgm.run.cond.spool.<User Defined>—This parameter searches in the spool 
conductor parameters for that parameter. 
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Glossary 

Glossary of Terms 

Term Definition 

Components Components are schematic drawings 

of electromechanical parts or sub-

assemblies. A component has a 

graphical symbol drawing and a set 

of defining parameters, such as 

name, type, and reference 

designator. Each component also 

contains a set of predefined attach 

points called nodes. You can retrieve 

components either from user-defined 

libraries, or, if you have a 

Pro/LIBRARYACCESS license, from 

the Pro/ENGINEER library of 

electrical symbols. 

Connectors Pro/DIAGRAM connectors are 

schematic drawings of physical 

connectors. The display of the 

connector can be either through a 

fixed shape symbol (fixed connector) 

or through a parametric definition 

where a standard connector shape is 

determined from specified 

parameters (parametric connector). 

Parameters include the number of 

pins to show, pin sequence, gender, 

partial or full display, size, and 

orientation. 

Pins (Nodes) Valid wire attach points on 

components and connectors are 

called nodes or pins. A pin must have 

a unique ID within the 

component/connector symbol. A pin 

can contain parameters that define 

which conductors are connected to it. 

Pins display as green dots in the 

symbol. 

Wires Wires are used to connect nodes on 

connectors and components. Wires 

may be routed between different 

sheets or as unattached. Wire paths 
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update automatically when the 

components and connectors are 

moved. You can also modify the wire 

paths by moving wire segments or 

vertices. 

Cables Cables are multiple wires, intended 

to be routed together. Cables can 

contain any number of wires. Cables 

can be distinguished from wires with 

a symbol that surrounds the wires 

that the cable contains. 

Conductors Conductors are schematic 

representations of physical 

conductors. They can be individual 

wires, or wires that are added to a 

cable. Conductors in cables are the 

individual wires of varying properties 

that are added to the cable in the 

spool definition. 

Spools All wires and cables are added to the 

diagram from predefined wire or 

cable spools. Properties defined in 

the spool such as thickness, color, 

min bend radius and so on are 

passed to the wire or cable when it is 

added to the design. The properties 

may then be modified for each cable 

or wire as necessary. Cable spools 

have values for the external 

appearance and overall minimum 

bend radius, as well as values 

associated with each of the assigned 

'conductors' within the cable. 

Highways Highways are paths in a 

Pro/DIAGRAM drawing in which any 

number of wires or cables can be 

routed. This simplifies the final 

drawing by allowing multiple wires to 

be represented graphically by a 

single path. This option is for display 

purposes only. It has no physical 

significance. 

Rails Rails are used to represent ground or 

power busses or conductive strips. 

You can route rails between 
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components, connectors, or other 

rails, or leave the ends unattached. 

Splices The Splice functionality lets you 

splice wires together. Two types of 

splices can be created: a butt splice 

and a through splice. When a butt 

splice is placed on a wire, the wire is 

split into two separate wires with 

different reference designations. 

When a through splice is placed on a 

wire, the wire is not split. Once a 

splice has been placed, additional 

wires can be routed to the splice. 
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