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Pro/ECAD 

Using Pro/ECAD 

About Pro/ECAD in the Design Process 

Pro/ECAD lets you import data for printed circuit boards and PCB components into a 

Pro/ENGINEER assembly. After importing, you can view the board and parts in a 3D 

context, for example, the PCB within the metal case that contains it. 

 

Alternatively, the board outline dimensions can be established in Pro/ENGINEER, 

based on the case assembly, and exported for parts placement and routing in the 

ECAD package. 

With Pro/ECAD, you can edit certain physical aspects of the board, for example, 

component positions, keepout areas or mounting holes, and export the edited board 

back to the original ECAD package. 

You can also: 

• Use custom-designed component models, based on part outlines imported from 

your ECAD library, that represent the 3D shape of components more accurately. 

• Use Pro/ENGINEER Assembly commands (or information from the ECAD package) 

to pre-place certain critical components. 

Note: Pro/ENGINEER does not import trace or connectivity data from the ECAD 

package. It deals with the three-dimensional shape and placement of components 

only. 
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Suggested ECAD-MCAD Design Sequence 

To best integrate Pro/ENGINEER with the ECAD design process, use a sequence like 

this: 

1. Create 3D parametric models of components—Import each component 

outline that you will use from the ECAD system library into Pro/ENGINEER, and 

use it as a basis to create a more detailed 3D model as a part file. When you 

import the board outline and placement information into an assembly, you can 

substitute these parts for those that would automatically be created on import. 

2. Parametrically design the board outline—(complete with cuts, mounting 

holes, and keepin and keepout areas) as a part file. You can also define keepin or 

keepout areas for export to the PCB designer. 

3. Create an assembly and place the board part into it—Using the 3D 

component models, place parts whose placement should be determined by heat 

or physical obstruction considerations. 

4. Export the assembly as board outline and component placement 

information—The keepin and keepout outlines are also exported with this 

information. For export, select one of the available ECAD formats. 

When the PCB designer has completed placement, you can import all component 

placement information into Pro/ENGINEER to check for interference between 

components and other physical obstructions in the assembly. 

Use Pro/ENGINEER to make any necessary component placement corrections. Export 

the board back to the PCB designer to demonstrate the new placement. 

Finally, perform a final mechanical analysis of the completed board in Pro/ENGINEER. 

Note: The transfer of electrical routing information on the board is not supported by 

the IDF standard at this time. 

About Setting Defaults for Faster Import 

Click Tools > Options and use the Options dialog box to set defaults for the import 

process. When you set these defaults, you are not prompted for values each time a 

part is imported. 

Component height—Ideally, the ECAD system specifies component height in its 

part information. If it does not, then when you import components through 

Pro/ECAD, you can use the ecad_default_comp_height configuration option  to 
assign a default height to components with a zero height value in the interface file. 

The value for the option should be the value of the default height and its 

corresponding units. 

Coordinate system names—When the board and components are imported, a csys 

is created at the origin of each part that is created. Use the 

ecad_board_csys_def_name and ecad_comp_csys_def_name configuration options to 
assign a default csys name to each object type. 

Default part and assembly templates—During import, you are prompted to 

choose a template for the imported part or assembly. You can specify a default 
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template using the template_ecadpart and template_ecadasm configuration 
options. 

ecad_hint.map file default location—You can use the ecad_mapping_file <path> 
configuration option to set a default location for the ecad_hint.map file. 

Import parts to automatically created layers—When the Preferences option 

ecad_comp_layer_map is set to YES, the import routine creates a new layer for each 
component name and places each newly created reference designator on the 

appropriate layer. 

About Fixing Import Problems in Sketcher 

When you import parts created in an ECAD (2D) system into Pro/ENGINEER, they 

may contain bad contours caused by open or self-intersecting loops.  

Select Sketcher Fix in the Import ECAD Board File dialog box to correct the 

import file. 

If the ECAD import process is unable to create a contour for a board outline, the 

following message appears: 

Do you want to correct <file name> part geometry with Sketcher? [Yes] 

You can either abort the import or enter the Sketcher mode to fix the problem. In 

the Sketcher mode, you can see the imported profile geometry. The sketcher 

regeneration process ensures correct creation (regenerated or nonregenerated 

section). 

You can create dimensions on the section. All tools in Sketcher are available to 

correct any problem, for example, to trim corners. 

After you have corrected the problems in Sketcher, Pro/ENGINEER continues the 

import and automatic creation of the feature. The following is written to the 

ecad.log file: 

If you plan to import this component again, you should export it and 
then insert the corrected outline as a replacement for the problem 
outline in the import files. 

Note: If the outline is corrected on import, it is not automatically corrected in the 

ecad library file. Export the corrected component separately and use the outline to 

update the .emp file to avoid having to correct the same profile repeatedly. 

Tip: The ECAD Log File 

Pro/ECAD interface routines write commentaries, warnings, and error messages to a 

file named ecad.log in your current working directory. Read this file each time you 
use the Pro/ECAD interface. 
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Tip: The Z-Axis Offset in IDF 

When you use Pro/ECAD to import components into Pro/ENGINEER using IDF 2.0, 

the system places components with a z-axis offset of 0.0. After import, you can 

modify the z-axis offset of the component’s placement. 

In IDF 3.0, you can define an offset. 

Tip: Parametric Dimensions in Pro/ECAD 

The dimensions of parts created in ECAD and imported by Pro/ENGINEER are not 

parametric, and you cannot modify them. However, you can go into the Sketcher 

mode and add dimensions by redefining the part base geometry feature. To maintain 

maximum flexibility during the design process, you can create your board outlines 

and components in Pro/ENGINEER. 

After you export parts created in Pro/ENGINEER through Pro/ECAD, you lose 

parametric associativity permanently. If you import them back into Pro/ENGINEER 

later, the outline is not updated. 

Model Parameters 

The following table lists the model parameters along with additional information to 

determine when and how you can use them. 

Parameter Optional 

Value 

Valid 

Format 

Description 

ECAD_OWNER ECAD 

MCAD 

UNOWNED 

IDF 3.0 Shows the owner 

of board or other 

outline. 

ECAD_PART_TYPE Panel 

Board 

Electrical 

Mechanical 

Other 
Outline 

IDF 2.0 

and IDF 

3.0 

Shows the 

component type. 

ECAD_PART_NAME any IDF 2.0 

and IDF 

3.0 

Shows the other 

outline name. 

ECAD_CAPACITANCE any IDF 3.0 

only 

Capacitance value. 
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ECAD_RESISTANCE   Resistance value. 

ECAD_TOLERANCE   Tolerance value. 

ECAD_THETA_JC    

ECAD_POWER    

Feature Parameters 

The following table lists the feature parameters along with additional information to 

determine when and how you can use them. 

Note: All hole parameters are automatically created during import only if you import 

the holes as features. Set the ecad_import_holes_as_features configuration option 
to yes to import holes as features. 

Parameter 
Optional 

Value 

Valid 

Format 
Description 

ECAD_OWNER 
ECAD MCAD 
UNOWNED 

IDF 3.0 

only 
Owner of ECAD area. 

ECAD_HOLE_TYPE 

PTH, NPTH 
PIN, VIA, 
MTG, 
TOOL, 
OTHER 

IDF 2.0 

and IDF 

3.0 

The type of hole 

feature. (if the hole is 

not imported as a 

feature, the 

parameter is not 

imported.) 

ECAD_PLATING_STYLE PTH, NPTH 
IDF 3.0 

only 

Plated through hole, 

non-plated through 

hole. 

ECAD_HOLE_OWNER 
ECAD MCAD 
UNOWNED 

IDF 3.0 

only  

Owner of the hole 

feature. 

BOARD_SIDE 
TOP, 
BOTTOM 
BOTH 

ALL 

(accordin

g to the 

areas) 

The side associated 

with the place region, 

place keepin, or place 

keepout ECAD area. 
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ROUTING_LAYERS 
TOP 
BOTTOM 
BOTH, ALL 

IDF 2.0 

Shows which ECAD 

board routing layers in 

the electrical system 

are included in a 

Pro/ENGINEER routing 

area ECAD feature. (No 

actual routing on the 

board is supported for 

transfer by IDF 

standard.) 

ROUTING_LAYERS 

TOP 
BOTTOM 
BOTH, ALL 
INNER 

IDF 3.0 

Shows which ECAD 

board routing layers in 

the electrical system 

are included in a 

Pro/ENGINEER routing 

area ECAD feature. (No 

actual routing on the 

board is supported for 

transfer by IDF 

standard.) 

COMPONENT_GROUP_NAME Any 

IDF 2.0 

and IDF 

3.0 

Allow adding or 

keeping a name for 

place region ECAD 

area feature. 

ECAD_ASSOCIATED_PART 
BOARD 
NOREFDES 

IDF 2.0 

In the ECAD system, 

this is the part to which 

the Pro/ENGINEER hole 

feature relates. 

ECAD_ASSOCIATED_PART 

BOARD 
NOREFDES 
PANEL 
Reference 

Designator 

IDF 3.0 

In the ECAD system, 

this is the part to which 

the Pro/ENGINEER hole 

feature relates. 

Component Feature Parameters 

This table lists the feature parameters in Assembly mode for components, along with 

additional information to determine when and how you can use them. 
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Parameter 
Optional 

Value 

Valid 

Format
Description 

ECAD_NAME Any ALL 

The ECAD system 

name of the 

component 

(becomes the name 

of the Pro/ENGINEER 

.prt file.) 

ECAD_ALT_NAME Any 

ALL 

except 

Allegro

The ECAD system 

alternative name for 

the component. 

ECAD_REF_DES 
Reference 

Designator 
Any 

The ECAD reference 

designator for the 

component. 

ECAD_PART_TYPE    

ECAD_PART_NAME    

ECAD_PLACEMENT_STATUS 
FIXED 
PLACED 
UNPLACED 

IDF 

2.0 

Shows the placement 

type of the component. 

 

  ECAD_PLACEMENT_STATUS 

 

PLACED 
UNPLACED 
ECAD MCAD 

IDF 

3.0 

Shows the placement 

type of the component. 
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To Perform a Clearance-Interference Check 

Click Analysis > Model Analysis and use the Model Analysis dialog box to run a 

Volume Interference check to detect whether a Pro/ECAD component interferes with 

or falls entirely within a closed quilt representing a Pro/ECAD keepin or keepout area. 

Configuring Pro/ECAD 

About Configuring ECAD 

You can set environment options and other global settings by specifying the required 

settings in a configuration file. To set configuration options, use the Options dialog 

box.  

This help module contains a list of configuration options in alphabetical order. Each 

option contains the following information: 

• Configuration option name. 

• Default and available variables or values. The default values are in italics. 

• Brief description and notes describing the configuration option. 

To Set ECAD Configuration Options 

1. Click Tools > Options. The Options dialog box opens. 

2. Click the Show only options loaded from file check box to see currently 

loaded configuration options or clear to see all configuration options. 

3. Select the configuration option from the list or type the configuration option 

name in the Option box. 

4. In the Value box, type or select a value. 

Note: The default value is followed by an asterisk (*). 

5. Click Add / Change. The configuration option and its value appear in the list. A 

green status icon confirms the change. 

6. When you finish configuring, click Apply or OK. 

dazix_default_placement_unit 

micron, mm, thou 

micron—Specifies the units to be used for data imported in Dazix files. 

dazix_export_mounthole 

yes, no 

yes—Causes the MOUNTHOLE section of a Dazix file to be processed as a mount 
hole.  

no—Causes the MOUNTHOLE section to be processed as a cut. 
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dazix_z_translation 

yes, no 

yes—Passes the objects in the .edn files through z translation. 

ecad_area_default_import 

cosm_area, 3d_volume 

cosm_area—Treats imported ECAD areas as cosmetic area features.  

3d_volume—Imports ECAD areas with z-heights as a 3D enclosed quilt. 

ecad_board_csys_def_name 

Specifies the default coordinate system name added to an ECAD board being 

imported. If you do not set this variable, you are prompted for a name. 

ecad_comp_csys_def_name 

Specifies the default coordinate system name added to an ECAD component being 

imported. If you do not set this variable, you are prompted for a name. 

ecad_comp_layer_map 

yes, no 

yes—Allows layer mapping for the ECAD component's import into Assembly. 

ecad_create_hint_add 

yes, no 

Assists in the creation of the ecad_hint.map file.  

yes—If required, automatically renames components, each time a library of 
component outlines is imported into Pro/ENGINEER. This does not create an 

ecad_hint.map file. It controls the creation of ecad_hint.add file. 

ecad_default_comp_height 

Sets the default value and units for an ECAD component that is being imported. 

Units can be inch, mil (1E-3 inches), thou (1E-6 inches), cm, mm, micron (1E-6 

meters), dsu (1E-8 meters). If not set, the units of the current component are used. 

ecad_default_comp_place_status 

placed, unplaced, fixed, mcad, ecad 

placed—Sets default component placement status for export (parameter setting 
overrides the default). 
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ecad_exp_both_two_areas 

yes, no 

no—Supports the export of ECAD areas with different "Above Board" and "Below 
Board" conditions.  

yes—Enables you to export both-sided keepin or keepout ECAD areas as two 
individual areas (top and bottom). 

ecad_export_holes_as_cuts 

yes, no 

no—Exports Pro/ENGINEER holes as cuts to ECAD systems. 

ecad_import_holes_as_features 

yes, no 

no—Imports sections specified as DRILLED_HOLE as through-all holes. Boards 
created with Pro/ENGINEER drilled holes export with a default value of NPTH for the 
ECAD_HOLE_TYPE parameter. Create this feature parameter if a value of PTH is 
needed (IDF 2.0/3.0). 

ecad_import_relative_accuracy 

0.0012 

Specifies the relative accuracy value to be used during import of ECAD files.   

ecad_mapping_file 

Specifies that the ecad_hint.map file will be used for ECAD operations. 

ecad_missing_component_status 

keep_missing, delete_missing 

keep_missing—Missing components are kept by default. 

delete_missing—Missing components are deleted by default. 

Set up the default status for missing components using the Component 

Investigate dialog box. Using this dialog box, you can keep missing components by 

default or delete missing components by default. 
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ecad_pin_hole_import 

no, yes 

Controls the default setting for the hole filter of type PIN for IDF 3.0 files. 

yes—PIN holes within in the IDF 3.0 file will be imported.  

no—PIN holes within the IDF 3.0 file will not be imported. 

ecad_via_hole_import 

yes, no 

Controls the default setting for the hole filter of type VIA for IDF 3.0 files.  

yes—VIA holes defined in the IDF 3.0 file are imported. 

no—VIA holes defined in the IDF 3.0 file are not imported. 

ecad_other_outl_csys_def_name 

Specifies the default coordinate system name for the OTHER_OUTLINE section of an 

IDF 2.0 ECAD component being imported. If you set this variable, you are prompted 

for a name. 

mentor_ver_2_0 

yes, no 

yes—Exports the file in IDF 2.0 format.  

no—Exports the file in IDF 1.0 format unless you select  IDF 2.0 from the ECAD 
FORMAT menu. 

template_ecadasm 

Specifies that the model will be used as the default ECAD assembly template. 

template_ecadpart 

Specifies that the model will be used as the default ECAD part template. 

Importing ECAD Databases 

About Importing ECAD Databases 

Board Assembly Files and Library Files 

The import routine requires two reference files, the board file and a library file. The 

board file describes the board outline, thickness, any keepin or keepout areas, and 
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the placement positions of all the parts. The library file contains the footprint and 

height information for all parts referenced in the board file. 

In the IDF format, the board file has an .emn extension while the library file uses the 
.emp extension. Proprietary formats from other vendors use their own extensions. 
During the import, you are prompted for the location of both these files. 

Note: When importing a panel assembly, specify the board file (IDF *.emn) instead 
of *.emp when prompted for the library file. 

Automatic or Partial Assembly on Import 

You can import the whole database, including the board, all placed components, and 

keepin or keepout outlines in an automated sequence that produces a completed 

board assembly. Alternatively, you can choose to import the board and parts 

separately and assemble them in the normal way. If you choose the automated 

sequence, you are prompted for any part library files or default dimensions needed 

during the sequence. 

Automatic Part Creation 

When the parts list and placement information are read in, Pro/ECAD uses the 2D 

part outlines it detects to extrude each part into a 3D shape. During the import, if no 

defaults are specified in your config.pro file, you are prompted for a height or for a 
coordinate system name for the part being created. Alternatively, you can reference 

a library of custom-made parts that you have prepared in Pro/ENGINEER that show 

more detail than a simple extrusion. 

As each part is created in 3D and added to the assembly, it is saved as a separate 

.prt file in the working directory. The original component name, for example, 
SN74ALS133N, becomes the file name. One .prt file is created for each reference 
designator. All reference designators appear in the Model Tree. 

Custom Part Substitution 

As an alternative to letting Pro/ENGINEER create the parts automatically, you can 

create a library of more accurately-shaped custom parts and reference it when you 

import the PCB. You use an ASCII map file named ecad_hint.map to reference the 
custom parts as substitutes for the automatically created ones. 

Automatic Layer Assignment 

When the preferences option, ecad_comp_layer_map, is set to yes, the import 
routine creates a new layer for each component name and places each newly created 

reference designator on the appropriate layer. 

If you are referencing an ecad_hint.map file, you can add lines to the file to direct 
layer creation and part-layer assignment. 
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Additional Supported Objects for Import-Export 

In addition to the board and electrical components, Pro/ECAD also imports and 

exports the following objects in accordance with the IDF 3.0 specification: 

Panel Outline—The manufacturing step-and-repeat panel and boards mounted on 

it. The panel outline is described in an optional separate panel file which can 

reference one or more board assemblies described in separate files. Any component 

placed on the panel itself is referenced in a library file. 

Other Outline—Extruded shapes of nonelectrical parts that would not have a 

reference designator, such as a heat sink. 

Holes—Drilled holes 

Keepin and Keepout areas—Separate outlines can show where to place or prohibit 

parts, routing, or vias. 

For complete information on the IDF import file conventions, see the Intermediate 

Format Specification Version 3.0. 

Using Automatic Layer Assignment 

When the ecad_comp_layer_map preferences option is set to yes, the import routine 
creates a new layer for each component name and places each newly created 

reference designator on the appropriate layer. 

If you are referencing an ecad_hint.map file, you can add lines to the file to direct 
layer creation and part-layer assignment. 

New layers are named after the component name, or for .map file references, the 
mapped name. The syntax is ECAD_<comp name or mapped name>. 

If no ecad_hint.map file exists, Pro/ECAD automatically creates a separate layer for 
each component type that is imported and places the component or components on 

that layer. Components with the same name are placed on the same layer. 

Automatic Layer Assignment Example 

 

For a *.emn file containing the following placement record: 

 PLACEMENT 
CC1206-1 151K41000S C1 
1200.00000 1550.00000 90.00000 TOP PLACED 
CC1206-2 151K31001S C2 
1200.00000 550.00000 90.00000 TOP PLACED 
CC1206 151K41000S CC1 
1900.00000 1000.00000 90.00000 BOTTOM PLACED 
RC1206 161F21050S RR1 
1200.00000 1000.00000 270.00000 BOTTOM PLACED 
SO14 104F50074S U1 
1400.00000 1400.00000 0.00000 TOP PLACED 
SO14 104C50000S U2 
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1400.00000 400.00000 0.00000 TOP PLACED 
SO14 104C50004S UU1 
1700.00000 900.00000 0.00000 BOTTOM PLACED 
.END_PLACEMENT 

 

This layer configuration is produced:  

Layer Name Components on this layer 

ECAD_CC1206-1 CC1206-1 

ECAD_CC1206-2 CC1206-2 

ECAD_CC1206 CC1206 

ECAD_RC1206R C1206 

ECAD_SO14 SO14 (u1, u2, uu1) 

Using the ecad_hint.map File 

Using the ecad_hint.map file, you can specify an overriding mapping (over the 
automatic mapping) to produce a new ECAD_<mapped name> layer. The component is 
placed in that layer. 

map_objects_by_name-> 
ECAD_NAME "eesmb" 
ECAD_ALT_NAME "DM7442N" 
ECAD_TYPE "" 
MCAD_NAME "EESMB_DM7442N" 
MCAD_TYPE "part" 
MCAD_LAYER "<ANY>" 
END 

Using Coordinate Systems 

If you create your own component models, you must provide each one with a 

coordinate system that represents the part origin to the ECAD package, and that 

includes the height dimension along the z-axis. If you are creating the component as 

a custom part in Pro/ENGINEER, start the part by placing the (0,0,0) of the 
coordinate system at the intersection of the three default datum planes. 

As Pro/ECAD places components by locating component coordinate systems in 

relation to the board coordinate system, the coordinate system orientation you use 

for placement on the ECAD outline should match that of the custom Pro/ENGINEER 

part. If the replacement is an assembly, an assembly coordinate system must be 

present. Incorrect orientation results in incorrect placement of the replacement 

component. 
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The illustration below shows a custom part, created in Pro/ENGINEER, representing a 

DIP16 with the csys ECAD_DEFAULT located at the part origin (usually pin 1). 

 

In IDF 3.0, the components can be placed using the Mate Offset assembly option. 

For all other formats, the system mates the components to the board. 

You can create a section plane for the component outline as a cross section, or select 

a planar surface for the component outline. The section plane is used as the footprint 

of the extents of the part and must be parallel to the xy-plane of the placement 

coordinate system. You are prompted to identify the section plane as part of the 

export procedure. 

Orient the component so that the z-axis of its chosen coordinate system points in the 

direction normal to the surface of the board, away from the surface: 

• If you place a component on the top surface of the board, the direction of the z-

axis of the component’s coordinate system points in the same direction as the z-

axis of the board’s coordinate system. 

• If you place a component on the bottom surface of the board, its z-axis points in 

the opposite direction from the board’s z-axis. 

You should know how the default component coordinate systems on the parts in your 

ECAD package are positioned.  

Top and Bottom Side 

Pro/ENGINEER uses the coordinate system to distinguish between top and bottom 

surfaces: 

• The z-axis of the coordinate system of the board should be normal to the top and 

bottom planes. 

• The positive z-axis should point from the bottom plane to the top plane. 
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You can select or create any coordinate system where the z-axis is normal to the top 

and bottom planes and the origin is located on either the top or the bottom surface 

of the board part. 

Note: 

• Pro/ENGINEER does not support left-handed coordinate systems. If used, 

component placement will not be as expected. 

• As the direction of the z-axis is normal to the top and bottom, and also points 

toward the top, the bottom and top can be different sides of the same surface. 

• When importing or exporting information that depends on the identification of the 

top and bottom surfaces of the board, the system checks to see if two parallel 

planes are normal to the z-axis. If so, it designates these the top and bottom 

based on the direction of the z-axis. 

• If more than two planes are normal to the z-axis, the system prompts you to 

select a top and a bottom. The bottom surface can be a surface or datum. The 

top can be: 

o A surface or datum (if importing) 

o A surface or datum with a cross-section on it (if exporting) 

Naming Default Coordinate Systems 

During import or export, when Pro/ECAD needs a coordinate system, it first searches 

for a default coordinate system. Pro/ECAD automatically looks for a coordinate 

system with the default name, ECAD_DEFAULT. Pro/ECAD prompts you if it cannot find 
one, or if you have not specified another default name. 

To specify a default name of your own, set these configuration options: 

• ecad_board_csys_def_name—Establishes a default name for the board’s 
coordinate system. 

• ecad_comp_csys_def_name—Establishes a default name for the coordinate 
systems that components use. 

If a default coordinate system exists, Pro/ENGINEER uses it automatically, without 

requesting any additional information about coordinate systems. If you use the 

default coordinate system name for all components, you can assemble all necessary 

components to the board without specifying any additional component placement 

information. 

The part’s outline is imported as an extruded section to create a Pro/ENGINEER part 

when you either place the component for the first time, or when you import it 

separately as a new part. The default coordinate system is located on the plane of 

the extruded section, and the z-axis is parallel to the direction of the extrusion. 
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To Import a PCB or Panel Assembly 

To import the whole assembly from either a board or a panel file: 

1. Click File > Open. The File Open dialog box opens. 

2. Select the ECAD board or panel file to import (IDF *.emn).  

3. Click Open. The Import New Model dialog box opens. 

4. Under Type, select Assembly. The Include ECAD Import Dialog check box is 

available for selection. 

5. If you want to use the ECAD – Import dialog box, select the Include ECAD 

Import Dialog check box and click OK. The ECAD – Import dialog box opens. 

6. Click Yes if you want to edit the board in Sketcher.  

7. The Use Default Template check box is selected by default. Clear the Use 

Default Template check box to select from available templates. A new assembly 

is created with the board imported as the first part. If you reference a panel file, 

the panel is imported as the first part.  

If any components in the assembly are missing, Pro/ENGINEER prompts you to 

select a library file (IDF *.emp file). (For a panel assembly, specify the board file 
(IDF *.emn) instead of the *.emp).  

If the board data contains drilled hole information, under Options, the Hole 

Import list displays the hole information. By default, all hole types, except PIN 
are selected.  

8. Modify hole import selection as required. 

9. Click OK. The Ecad Import dialog box opens.  

10. Click OK. The PCB components are imported and assembled in the panel. 

To Import a Board Outline  

Use this procedure to import a board, with holes and keepin or keepout areas, but 

minus the components, as a Pro/ENGINEER part. You must have an output file from 

one of the supported PCB design systems, or an IDF file of your PCB layout ready to 

read into Pro/ENGINEER.  

1. Click File > Open. The File Open dialog box opens. 

2. Select the ECAD package from the Type list. 

3. Select the ECAD panel file that you want to import from the list of available files. 

4. Click Open. The Import New Model dialog box opens. Under Type, the Part 

check box is selected by default. 

5. Accept the default name or type a name for the new part in the Name box. 

6. Click OK. The ECAD - Import dialog box opens. 
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The import list shows only one part type, that is, the board, though the import 

file contains data of the board and all parts. Import the board as a part first and 

create an assembly using the board as the base part. Import the components into 

the assembly. 

7. Click Yes if you want to edit the board in Sketcher. 

8. The Use Default Template check box is selected by default. Clear the Use 

Default Template check box to select from available templates. A new assembly 

is created with the board imported as the first part. If you reference a panel file, 

the panel is imported as the first part.  

If any components in the assembly are missing, Pro/ENGINEER prompts you to 

select a library file (IDF *.emp file). (For a panel assembly, specify the board file 
(IDF *.emn) instead of the *.emp).  

If you are using a format that complies with the IDF 3.0 standard and the board 

data contains drilled hole information, under Options, the Hole Import list 

displays the holes information. By default, all hole types, except PIN are selected. 

9. Modify the hole import selection as required.  

Note: Only IDF 3.0 supports hole filter.  

10. Click OK. The data is imported and converted to a Pro/ENGINEER part.  

o A coordinate system is created at the ECAD_DEFAULT origin.  

o The z-axis direction is bottom to top. 

Note:  

Use the ecad_board_csys_def_name configuration option to specify a default 
name for the board csys.  

Create an assembly with this part. Use File > Open to add the parts from the 

same input file.  
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The illustration below shows the ECAD_DEFAULT csys with (0,0,0) at the bottom 
of the board. The z-positive direction is bottom to top. 

 

Note: An ECAD import, unless performed through Sketcher Fix, produces sections 

without dimensions (nonregenerated sections). Therefore, the dashboard is not 

available when you redefine extrusions that are created during such an import. 

Instead, the redefinition menu from Pro/ENGINEER Release 2001 opens. The 

dashboard is available only after you regenerate the section. 

To Import a Panel Outline 

Note: Only IDF 3.0 supports panel import. 

1. Click File > Open. The File Open dialog box opens.  

2. Select the ECAD package from the Type list. 

3. Select the ECAD panel file that you want to import from the list of available files 

4. Click Open. The Import New Model dialog box opens. Under Type, the Part 

check box is selected by default. 

5. Accept the default name or type a name for the new part in the Name box. 

6. Click OK. The ECAD - Import dialog box opens. The import list shows only one 

part, that is, the panel. 

7. Click Yes if you want to edit the board in Sketcher. 

8. The Use Default Template check box is selected by default. Clear the Use 

Default Template check box to select from available templates. A new assembly 

is created with the board imported as the first part. If you reference a panel file, 

the panel is imported as the first part. 
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If any components in the assembly are missing, Pro/ENGINEER prompts you to 

select a library file (IDF *.emp file). (For a panel assembly, specify the board file 
(IDF *.emn) instead of the *.emp). 

If you are using a format that complies with the IDF 3.0 standard and the board 

data contains drilled hole information, under Options, the Hole Import list 

displays the holes information. By default, all hole types, except PIN are selected.  

9. Modify the hole import selection as required.  

Note: Only IDF 3.0 supports hole filter. 

10. Click OK. The panel is imported and converted to a Pro/ENGINEER part.  

o A coordinate system is created at the ECAD_DEFAULT origin.  

o The z-axis direction is bottom to top. 

Note: Use the ecad_board_csys_def_name configuration option to specify a 
default name for the board coordinate system of the board. 

To Import Components as Parts 

Use this procedure to create a .prt file for a single component or to bring .prt files 
for all components into session. 

1. Click File > Open. The File Open dialog box opens.  

o Select an ECAD Lib package from the Type list, click the ECAD file that you 

want to import from the list of available files, and click OK. 

o A new part file opens. The Import ECAD Library File dialog box also 

opens. 

2. Use the dialog box to select all components, or a single component. If you select 

a single component, you can select Sketcher Fix to open the part outline in 

Sketcher. You must know the exact name of the part as it appears in the import 

file to specify it in the Component Name box. Otherwise, the part is 

automatically extruded into 3D. 

3. Click OK. 

o If you selected a single component, it is displayed as a .prt file. 

o If you selected All Components, the .prt files are stored in session, but 
are not stored on disk or displayed. Use File > Open and select In 

Session to select the file or files to work on. 

o A coordinate system named ECAD_DEFAULT is created at the part origin. The 
z-axis direction is bottom to top. 

Note: Use the ecad_comp_csys_def_name configuration option to specify a 
default name for the board csys. 
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To Import Components Into an Assembly 

Use this procedure to import ECAD components after the PCB outline has been 

imported or created and opened as the base part of an assembly. 

1. In an assembly file, click Insert > Shared Data > From File. The Open dialog 

box opens. 

2. Click the ECAD package from the Type list, and choose the ECAD file that you 

want to import from the list of available files. (IDF = *.emp) 

3. Click Open to open the new file. Choose from the following check list from the 

IMPORT TYPE menu: 

o Components—Imports all component outlines.  

o Placement—Imports component placement information. 

o Other Outline—(ECAD IDF only) Selects the .OTHER_OUTLINE sections to 
import from the IDF file. ("Other outlines" are volumes representing non-

electrical items that would not have reference designators.) If you select 

this option, a separate menu opens, enabling you to choose the 

.OTHER_OUTLINE sections you want to import. 

o Investig Plc—(ECAD IDF only) Imports placements in investigate mode. 

This option lets you selectively accept or reject the placements of new or 

changed components. You must select Placement to use this option. 

4. Use GET COORD S or SEL COORD S to create or select a coordinate system if 

you did not specify one for the board in your configuration file. You should not 

use Default to create a coordinate system, because that coordinate system 

might not comply with restrictions that pertain to the top and bottom board 

surfaces, or have the correct orientation. 

5. The Open dialog box opens with the library format for the ECAD type you are 

importing in the Type box. Choose the ECAD Lib file that you want to import 

from the list of available files. 

6. Click Open to open the file and start the import process.  

7. If the file you import contains component placement records, use GET COORD S 

or SEL COORD S to create or select a coordinate system for each component, 

unless you specified a default component coordinate system in the configuration 

file. 

Pro/ENGINEER imports the components. If it also imported placement 

information, the system automatically places the components on the board.  

Saving the assembly also saves component placement information when both the 

component outlines and the placement information are present. If only one is 

present, you must retrieve each component separately and save it later when 

you retrieve the assembly.  
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To Substitute Custom Pro/ENGINEER Parts 

To import using custom Pro/ENGINEER parts, place the name of the replacement 

Pro/ENGINEER component in the mcad_name section of the ecad_hint.map file. 

• If changes are necessary during import, the system specifies any additions in a 

file named ecad_hint.add. 

• Specify both ECAD_NAME and ECAD_ALT_NAME when replacing components with 
ecad_hint.map. 

To Import a Non-Electrical Volume 

An other outline is an extruded footprint that represents a solid part, such as a 

heatsink, that would not have a reference designator. It is used only in the IDF 2.0 

and 3.0 transfer formats. 

To import an other outline volume to an assembly: 

1. Click Insert > Shared Data > From File. The Open dialog box opens. 

2. Select the .emn file or file with Other Outline information and click Open. 

3. In the Menu Manager, select Other Outline. 

4. Click Done. You are prompted to select a coordinate system. When you specify a 

coordinate system, the other outline volume is assembled to the board. 

To Specify Parts as Electrical or Mechanical 

1. In a part file, click Tools > Parameters. The Parameters dialog box opens. 

2. Click  and create a string parameter, ECAD_PART_TYPE, with a value of either 
ELECTRICAL (electrical component) or MECHANICAL (mechanical component). 

If no parameter is defined, the part is mechanical by default. 

To Show or Hide Reference Designators 

You can show or hide reference designators using the Environment dialog box. 

1. Click Tools > Environment. The Environment dialog box opens.  

2. Check the Reference Designators box to display the reference designators in 

the model. 

3. Click OK. 

To Assign or Rename a Reference Designator 

Use this procedure to assign a reference designator to components that you design 

and position with Pro/ENGINEER. 

1. In Assembly mode, click Edit > Setup > Name > Component. 

2. Select the component whose name you want to change. 
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3. At the prompt, type a new name. 

4. Click the check box next to the prompt. The name of the reference designator is 

changed to the one you specify. 

You can also assign or rename a reference designator using the Model Tree. 

1. Click Settings > Tree Columns. The Model Tree Columns dialog box opens. 

2. In the Type box, select ECAD Params. 

3. Click ECAD_REF_DES from the list of available columns, then >> to move the 

selected column to the Displayed list. 

4. Click OK. The reference designators appear in a column associated with each part 

in the Model Tree. Assign or rename the reference designator of a part by clicking 

the cell adjacent to the part. 

When the system exports the component from the assembly, it passes on the new 

name to the receiving ECAD system. 

Note:  

• If you do not specify a reference designator for a new component that was placed 

in Pro/ENGINEER, and you use IDF to export the assembly, the neutral file uses 

the NONAME tag as the reference designator for that component. When you import 
the same neutral file back into Pro/ENGINEER, it does not recognize the 

component as the original. Instead, it uses the information in the neutral file to 

place a new component in the assembly. As you have not specified one, the 

reference designator for this new component is not present. 

• You can rename a reference designator in Assembly mode but you cannot 

remove the text note entirely. 

To Manipulate a Reference Designator 

You can manipulate reference designators in: 

• The Assembly mode 

• The Drawing mode 

In the Assembly Mode 

1. Open the Note dialog box by doing one of the following: 

o From the ASSEMBLY menu, click Edit > Setup > Notes > Modify. 

o Right-click a reference designator note in the Model Tree and then click 

Properties from the shortcut menu. 

o Select a reference designator in the graphics screen, click the right mouse 

button and then click Properties from the shortcut menu. 

2. Under Name, you can view the reference designator name. 

3. Under Style, choose the text style. 
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4. Under Placement, click Move to change the location of the reference designator. 

5. Click OK. 

Note: You cannot modify the text of the reference designator. 

You can also use the model tree to manipulate reference designators: 

1. Click Settings > Tree Filters. The Model Tree Items dialog box appears. 

2. Check Notes and click OK. Reference designators are displayed in the model tree 

just as 3D notes but with a different icon for identification. 

3. Select a reference designator note in the Model Tree. 

4. Right-click and select one of the following options and make the necessary 

changes: 

o Add Link 

o Move 

o Erase 

o Text Style 

o Properties 

o Info 

Refer to Pro/LEGACY for more information on these options. The Add Link, 

Move, Erase, Text Style, Properties, and Info options are also available when 

you select a reference designator in the graphics window and right-click. 

In the Drawing Mode 

1. Click View > Show and Erase > and then select the ECAD object, to 

display the reference designators of the object in the drawing. 

2. Select a reference designator note.  

3. Right-click and select one of the following and make the necessary changes: 

o Erase 

o Edit Attachment 

o Move Item to View 

o Insert Jog 

o Arrow Style 

o Save Note 

o Move Special 

o Properties 
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o Add Hyperlink 

Refer to Pro/LEGACY for more information on these options. 

Note: Insert Jog, Arrow Style and Edit Attachment are available on the 

menu if a leader is added to the reference designator note. 

To Import Using Investigate Mode 

In Assembly Mode 

You can use the Investigate mode to examine final component placement before you 

complete the import procedure. In the investigate mode, you can accept or reject 

the placement of an existing component that is modified into your assembly. You can 

select Investig Plc only if you have selected Placement and only if you have 

selected ECAD IDF as your import format. 

To start the investigate placement mode, click Investig Plc from the IMPORT TYPE 

menu during the import procedure. If you have selected this option, the investigate 

placement mode is activated during import. 

In the investigate placement mode, component placement in the imported file is 

compared with its previous placement. Components with reference designators that 

did not exist in the assembly earlier are treated as new components. Each of these 

new or changed components is imported and displayed in Pro/ENGINEER as a 

working component, and the Component Investigate dialog box opens. 

Note: The system compares two components for placement changes only if they 

have the same reference designator. Therefore, if a reference designator has 

changed, any change in its placement is not detected, and the component is treated 

as if it were a new component in the imported file. 

The Component Investigate dialog box lists the reference designators of all 

components that are new, changed, or missing in the assembly along with the 

Pro/ENGINEER model name and its status. The status of each component is one of 

the following: 

• Replace—The placement of this component is replaced with the new component 

placement from the file being imported. 

• Keep—The placement of this component overrides any new component 

placement in the file being imported. 

• Accept New—This new component is placed in the imported assembly. 

• Reject New—This new component is not placed in the imported assembly. 

• Keep Missing—This component is missing in the imported file, but is kept in the 

assembly. 

• Delete Missing—This component is missing in the imported file and is deleted in 

the assembly.  
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Status Color Descriptions 

o Replace status appears in blue showing the new position. 

o Accept New status appears in magenta. 

o Keep Missing components appear in green. 

By default, all changed components are replaced and all new components are 

accepted. 

The ecad_missing_component_status configuration option enables you to keep 
missing components or delete missing components by default, in the Component 

Investigate dialog box. Use the keep_missing option to keep missing components 
by default. 

Filter the components displayed in the Component Investigate dialog box to 

display only new components, changed components, or both, by selecting from the 

list at the bottom of the dialog box. The default is to display both new and changed 

components. If you select a component in the list, it is highlighted in the assembly. 

To change the status of a component, select the component in the dialog box and 

then click Change Status to switch between Replace and Keep for changed 

components or Accept New and Reject New for new components. 

To preview any changes you make to the new or modified components, click 

Preview. The new or modified components change according to the specifications in 

the dialog box. 

When you finish making changes to the status of the component placements, click 

OK to complete the import. 

In Part Mode 

1. Click Insert > Shared Data > From File. The Open dialog box opens. 

2. Click the required ECAD package from the Type list, and select the ECAD file that 

you want to import from the list of available files. The Ecad - Import dialog box 

opens.  

Note: The Ecad - Import dialog box opens only if you have inserted shared data 

from a file. 

3. Click Yes to activate the Investigate Geometry option in the Ecad - Import 

dialog box. 

4. Click OK. The Board Geometry Investigate dialog box opens. The feature 

identified for the geometry update is displayed under Feature Type and its 

status is displayed under Status.  

5. In the Filter drop-down box, select one of the following: 

All—To select the entire part  

Part Section—To select board outlines 

Area Features—To select keepin, keepout areas  
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Depending on your selection in the Filter drop-down list, the relevant feature is 

displayed under Feature Type.  

6. To change the status of a feature type, select the feature type in the dialog box 

and click Change Status to switch between Replace and Keep. Click OK to 

complete the import.  

Configuration File Options 

The following configuration options apply specifically to Pro/ECAD. The default 

settings are listed first. 

dazix_default_placement_unit (mm, thou, micron) 

dazix_export_mounthole (Y/N) 

dazix_z_translation (Y/N) 

ecad_area_default_import (cosm_area, 3d_volume) 

ecad_board_csys_def_name (ecad_default, name) 

ecad_comp_csys_def_name (ecad_default, name) 

ecad_create_hint_add (yes, no) 

ecad_default_comp_height (value unit) - default 
depends on geometry 

ecad_export_holes_as_cuts (yes, no) 

ecad_exp_both_two_areas (yes, no) 

ecad_import_holes_as_features (yes, no) 

ecad_import_relative_accuracy (0.0012) 

ecad_pin_hole_import (no, yes) 

ecad_via_hole_import (yes, no) 

ecad_mapping_file (path for ecad_hint.map) 

ecad_missing_component_status (keep_missing, 
delete_missing) 

ecad_other_outl_csys_def_name (ecad_default, name) 

Mentor_ver_2_0 (yes, no) 
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Using Keepin and Keepout Areas 

About Keepin and Keepout Areas 

ECAD keepin and keepout areas specify where you can or cannot place components 

to avoid interfering with other components or electrical routing. In Pro/ENGINEER, 

create keepin and keepout areas as cosmetic features of a board part. While creating 

cosmetic features, you can select edges of other ECAD areas. An ECAD area can be 

used in Sketcher to create entities from edges or datum curves or to create draft 

entities at an offset from edges by clicking  or , respectively. Pro/ECAD adds 

the necessary commands to the COSMETIC and PROJ SECT menus in the part 

mode. 

In Pro/ENGINEER, keepin and keepout areas can have a closed 3D volume, 

represented by a quilt. Use these quilts to perform a clearance and interference 

check to determine whether an ECAD component violates the keepin and keepout 

areas, even if the component is entirely within the keepout volume.  

The ecad_exp_both_two_areas configuration option enables you to export an ECAD 
area with different heights for above and below board conditions. Use the YES option 
to export both-sided keepin and keepout ECAD areas as two individual areas (top 

and bottom).  

The following table lists the Pro/ENGINEER cosmetic area feature types and the 

corresponding IDF region names. 

PRO/ENGINEER ECAD AREA IDF ECAD AREA 

Place Keepin Placement Outline Section 

Place Keepout Placement Keepout Section 

Place Region Placement Group Area Section 

Route Keepin Route Outline Section 

Route Keepout Route Keepout Section 

Via Keepout Via Keepout Section 

Remember the following characteristics of keepin and keepout areas: 

• As with other sketched cosmetic features, you need not dimension or regenerate 

keepin and keepout areas.  

• Nondimensioned, nonregenerated areas are always nonparametric. 

• Use Name in the PART SETUP menu to name keepin and keepout area features. 

• You can add parameters to the keepin and keepout area features such as 

board_side or routing_layers. 
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• When you export keepin areas from Pro/ENGINEER through Pro/ECAD, the value 

of their height exported to the interface file is 0.0. Manually edit the interface file 
or use the ECAD application to change this to a nonzero value if necessary. 

• You can display keepin and keepout areas as 3D volumes, provided the value of 

their height value is greater than 0.0 by redefining the feature attributes and 
checking or clearing the 3D Volume option. 

Use the ecad_area_default_import configuration option to define how imported 
ECAD areas are treated, that is, as outlines or volumes. 

To Add a Keepin or Keepout Area 

1. In a part, click Insert > Cosmetic > ECAD Area. The OPTIONS menu appears. 

The following commands are available: 

Regular Sec—Use a regular sketching plane for placement of the region. 

Project Sec—Use a section projection on a selected surface for placement of the 

region. 

Xhatch—Mesh the created region. 

No Xhatch—Leave the created region unmeshed. 

3D Volume—Determine whether the area appears with a 3D quilt. Area outline 

and keepin or keepout height define volume. 

Two Sides—Place the area on top and bottom. 

2. In the same menu, define the type of area: (3D Volume and Two Sides are 

available where applicable.) 

Place Keepin—Creates a placement keepin region. You can specify the area 

height above and below the board while creating this region. The default height is 

zero. Place Keepin is not available for the Using_the_Dazix_Format interface. 

Place Keepout—Creates a placement keepout area. You can specify the area 

height above and below the board while creating this region. The default height is 

zero. Place Keepout is not available for the Visula interface. 

Place Region—Creates a placement region. Available only with IDF. 

Route Keepin—Creates a routing keepin region where routing actions are 

permitted. Available only with IDF. 

Route Keepout—Visual way to indicate that you are not to route in this area. 

This option is available only with IDF.  

Via Keepout—Visual way to indicate that you are not to create vias in this area. 

Available only with IDF. 

3. Select a sketching plane and a reference plane. Sketch the area. 

4. Exit Sketcher. If you created an area requiring a height dimension, you are 

prompted for it now. A red arrow shows the direction of the height you are 
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specifying. If you selected Two Sides, you are prompted for both, one after the 

other. The red arrow shows the direction of each height value. 

To Assign a Group Name to an ECAD Area 

Add the Component_Group_Name feature parameter to a keepin area to specify a 
component group name. This parameter corresponds to the Component Group Name 

parameter for IDF. This feature is automatically created when you import a model 

with a placement region group name. 

Exporting Data to ECAD 

About Exporting ECAD Data 

You can export board, part outline, and placement data from the part level or the 

assembly level. You can use any of the available translator formats or the IDF 

format. 

Each component to be exported needs a coordinate system to identify the part 

origin, and a section plane selected to represent the footprint. When you export 

individual parts, you are prompted for each. If you assigned a default value to 

ecad_comp_csys_def_name in the config.pro file, and named the origin csys the 
same value, you are not prompted for the csys. 

When you export from assembly mode, a dialog box handles the csys selection, 

component name and reference designator values, and lets you allow or  not allow 

selected items from the export. 

To Export Board Outline and Component Assembly Data 

You can export a board outline (including any holes) and component placement 

information from Pro/ENGINEER through Pro/ECAD. 

1. In the assembly to be exported, click File > Save a Copy. The Save a Copy 

dialog box opens. 

2. Select the type of the ECAD package to which you want to export information, 

specify a new file name., if required,and click OK. 

3. If you have selected IDF (.emn) type, then in the Menu Manager, select the 
ECAD FORMAT for your export. The ECAD Assembly Export dialog box opens. 

The board and all the components are listed with an export status (yes or no), 
and a csys to be used as an origin. Use the dialog box to disallow any objects 

from the export, or to add or edit coordinate systems. 

Note: If parts do not have coordinate systems, they are not included in the 

export. 

4. Click OK. Pro/ENGINEER performs the export. The ecad.log file contains 
warnings or error messages, if any. 
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To Export Board or Component Parts 

In Part mode, you can export the outline of the current board (including any holes) 

or component. If the part is a board, you can also export its keepin and keepout 

areas. To be exported, a part must be active. You can export a component outline 

only when you are in Part mode. 

1. In the part to be exported, click File > Save a Copy. The Save a Copy dialog 

box opens. 

2. Select the type of ECAD package to which you want to export information, specify 

a new file name, if required, and click OK. 

3. If you have selected the IDF (.emn) type, then in the Menu Manager, select the 
ECAD FORMAT (board or panel) for your export. You are prompted for a 

coordinate system to be used as the board or part origin. 

4. Identify the csys in the Menu Manager. 

5. If you have selected the IDF (.emp) type to export a component, you are 

prompted to export a section plane to represent its outline. Pro/ENGINEER 

prompts you to specify a cross-section or a planar surface to export as the 

outline. Click one of the following from the PLANE/XSECT or ECAD PLANE 

menu: 

o Plane—The ECAD PLANE menu appears with Default, Select, and Quit 

for selecting a planar surface of the component. 

o XSection—The XSEC NAMES menu appears. Select the name of a 

previously created cross-section. 

When you select the plane, Pro/ENGINEER performs the export. 

To Export a Panel File in Assembly Mode 

You can export a panel file from Pro/ENGINEER through Pro/ECAD. The assembly is 

exported as a panel file if the first component of the assembly has the 

ECAD_PART_TYPE model parameter set to PANEL. 

1. In the assembly mode, click File > Save a Copy. The Save a Copy dialog box 

opens. 

2. Select ECAD IDF (*.emn) for the type of ECAD export and click OK. 

3. In the Menu Manager, click IDF 3.0 in the ECAD FORMAT menu. The ECAD 

Assembly Export dialog box opens. 

4. Select the export status and coordinate system to be used. 

5. Click OK. Pro/ENGINEER performs the export. 
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To Export a Panel File in Parts Mode 

You can also export a panel file from Pro/ENGINEER through Pro/ECAD in the part 

mode. 

1. In the part mode, click File > Save a Copy. The Save a Copy dialog box opens. 

2. Change the type to ECAD IDF (*.emn), specify the required name for the output 

file, and click OK. 

3. In the ECAD FORMAT menu in the Menu Manager, select IDF 3.0. 

4. Select Panel in the OBJ TYPE menu. 

5. Select the coordinate system for export from the SEL COORD S menu in the 

Menu Manager. Pro/ENGINEER performs the export. 

Tip: Placing Subassemblies as Components for Export 

When used correctly, the ecad_hint.map file can place a subassembly as a 
component just as you can place a part as a component. You cannot export 

component outlines of assemblies. If you place subassemblies as components, the 

following restrictions apply: 

• If the current directory or session contains a part with the same name as the 

subassembly, the system uses the part rather than the subassembly. 

• You can use a subassembly only if it contains an assembly coordinate system 

with the appropriate datum planes. This assembly coordinate system must be 

built explicitly on three assembly datum planes and have an orientation 

recognized by Pro/ECAD. 

Controlling Import - Export with the ecad_hint.map File 

About the ecad_hint.map File 

The ecad_hint.map file is an ASCII file that you use to control the following 
functions in the ECAD import-export process: 

• Substituting custom-made Pro/ENGINEER parts for automatically extruded parts 

on import. 

• Substituting a custom-made Pro/ENGINEER MCAD assembly for an automatically 

extruded part, that is, an ECAD component, on import. 

• Allowing or disallowing specified parts on import. 

• Allowing or disallowing specified parts on export. 

• Changing an ECAD reference designator to a different string for import. If, for 

example. the ECAD reference designator uses characters that are illegal in 

Pro/ENGINEER. 

• Changing an ECAD other outline string for import. If, for example, the ECAD 

reference designator uses characters that are illegal in Pro/ENGINEER. 
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Pro/ECAD searches the working directory for ecad_hint.map and references it every 
time an import occurs. The file is ignored if it is empty or has no relevant 

information. 

You can use the ECAD_MAPPING_FILE <path> configuration option to set a default 
location for the ecad_hint.map file. If you set a path with this configuration option, 
the working directory is not searched. 

To Create the ecad_hint.map File  

1. Run an automatic import of your ECAD part list into an assembly. This creates a 

log file called ecad_hint.add, that includes entries for each part type in the part 
list. 

2. Edit this file, if required, substituting values as necessary, and save it in the 

working directory as ecad_hint.map. 

3. If you have custom .prt files prepared for substitution, delete the automatically 
generated parts from the assembly and reimport the ECAD part file using the 

newly edited ecad_hint.map file. 

Using the ecad_hint.add File 

When Pro/ECAD creates a component .prt file automatically during import, it: 

• Combines the ecad_name and ecad_alt_name as an mcad_name for the part file, 
and 

• Records the creation of the component in a text file called ecad_hint.add. 

Do not confuse this with the ecad_hint.map file. However, you can use the .add file 
as a template for a .map file. 

In the ecad_hint.add file, each part receives the following entry (examples shown 
as values): 

Map_objects_by_name -> 

ECAD_NAME "CSTCS" 
ECAD_ALT_NAME "N7414N" 
ECAD_TYPE " " 
MCAD_NAME "CSTCS_N7414N" 
MCAD_TYPE "part" 
END 

Component names that include a dollar sign ($), slash (/), period (.), or percent sign 

(%) are not valid. Pro/ENGINEER uses the ecad_hint.add file to change each of 
these characters to an underscore (_). If this adjustment causes the file names to be 

identical, new file names are created. To use the translated names, edit the 

ecad_hint.add file and append it to the ecad_hint.map file. 

If the ecad_hint.map file contains names that are the same except for a symbol that 
Pro/ENGINEER does not use, Pro/ENGINEER creates a new part name and notes this 

in the log file. For example, ecad_name Aaa$ becomes mcad_name AAA_ and 
ecad_name Aaa/ becomes mcad_name AAA_1. 
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When you do not use the ecad_hint.map file to determine the correspondence 
between ECAD part names and Pro/ENGINEER part names, Pro/ENGINEER interprets 

the part names of components in all uppercase letters. For example, Pro/ENGINEER 

searches for a component named AaaA in an ECAD system as AAAA. 

If you do not want the system to create an ecad_hint.add file, set the 
ecad_create_hint_add configuration file option to no. 

Using the ECAD_ALT_NAME 

Pro/ECAD parts may have the same values for ecad_name and different values for 
ecad_alt_name. For example, the resulting .add file from an import may have the 
following entries: 

Resistors entry 1 Resistors entry 2 

Map_objects_by_name-> 

ECAD_NAME "Resistors" 

ECAD_ALT_NAME "R5K" 

ECAD_TYPE "" 

MCAD_NAME "RESISTORS_R5K" 

MCAD_TYPE "part" 

End 

map_objects_by_name-> 

ECAD_NAME "Resistors" 

ECAD_ALT_NAME "R2K" 

ECAD_TYPE "" 

MCAD_NAME "RESISTORS_R2K" 

MCAD_TYPE "part" 

End 

In this case, if you have different models for a R5K and a R2K resistor, (for example, 

they may be of different colors) you can specify the individual .prt names in the 

ecad_alt_name field. For example, if the Pro/ENGINEER part files are called 
resistor1_5k.prt and resistor1_2k.prt, use the entries below: 

Resistors entry 1 Resistors entry 2 

Map_objects_by_name-> 

ECAD_NAME "Resistors" 

ECAD_ALT_NAME "R5K" 

ECAD_TYPE "" 

MCAD_NAME "resistor1_5k" 

MCAD_TYPE "part" 

End 

map_objects_by_name-> 

ECAD_NAME "Resistors" 

ECAD_ALT_NAME "R2K" 

ECAD_TYPE "" 

MCAD_NAME "resistor1_2k " 

MCAD_TYPE "part" 

End 

Map File Standard Conventions and Examples 

In the ecad_hint.map file: 

• The # character is the comment character. 
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• Object and value fields are separated by a space. 

• Spaces are permitted in value strings if the string is surrounded by quotation 

marks. 

• Wildcard (*) is valid for "all", for example: 

mcad_in_ignore -> 
ecad_name "resistor" 
ecad_alt_name "*" 
ecad_type "part"  
ref_des "*" 
end 

• Each section begins with the purpose, followed by "->". 

• Each section ends with "end". For example: 

map_objects_by_name-> 

ECAD_NAME "GEN_DIP" 
ECAD_ALT_NAME "GEN_DIP" 
ECAD_TYPE "" 
MCAD_NAME "PROE_GEN_DIP" 
MCAD_TYPE "part" 
end 

• If you include the string ecad_create_hint_add N in the config.pro file, the 
.add file is not created. 

To Reference Custom Parts During ECAD Import 

1. In a text editor, open the ecad_hint.map file. 

2. Place the name of the replacement Pro/ENGINEER component in the mcad_name 
section of the part's entry. The first line of each entry should be 

map_objects_by_name->. For example, if the Pro/ENGINEER part file you want to 
reference is called resistor1.prt, specify resistor1. 

3. Repeat for each .prt file that you want to reference. When you run the import 
again, your custom parts are substituted for the automatically generated ones. 

Note: Set the value of the parameter MCAD_TYPE  to "ASM" if you want to substitute 
an MCAD assembly for an automatically extruded part. 



Pro/ECAD - Help Topic Collection 

36 

To Control Automatic Layer Assignment 

Using the ecad_hint.map file, you can specify an overriding mapping (over the 
automatic mapping) to produce a new ECAD_<mapped name> layer. The component is 
placed in that layer: 

map_objects_by_name-> 
ECAD_NAME "eesmb" 
ECAD_ALT_NAME "DM7442N" 
ECAD_TYPE "" 
MCAD_NAME "EESMB_DM7442N" 
MCAD_TYPE "part"  
MCAD_LAYER "<ANY> 

Note: The ecad_comp_layer_map preferences option must be set to yes. 

To Change the Other Outline String for Import 

Use an entry such as the following in the ecad_hint.map file to replace an 
.OTHER_OUTLINE name with an MCAD name for import purposes: 

map_other_outline_name-> 

ecad_board_name "board" 
ecad_other_outline ".OTHER_OUTLINE" 
mcad_part_name "heatsink" 

END 

To Change the Reference Designator String for Import 

Use an entry such as the following in the ecad_hint.map file if a reference 
designator contains illegal characters. You can replace the reference designator with 

another string for import. 

reference_designator-> 

ECAD_REF_DESIG "R/1" 
MCAD_REF_DESIG "R1"  
END 

To Exclude Parts From Import or Export 

Use an entry such as the following in the ecad_hint.map file to exclude a part from 
import: 

mcad_in_ignore -> 

ecad_name "resistor" 
ecad_alt_name "resistor_5k" 
ecad_type "part"  
ref_des "*" 

END 
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To exclude a part from export, use an entry such as the following in the 

ecad_hint.map file: 

mcad_out_ignore -> 

mcad_name "HEAT_SINK" 
mcad_type part 
ref_des "HS1" 

END 

Intermediate Data Format (IDF) 

About the Intermediate Data Format (IDF) 

The Intermediate Data Format (IDF) is a data exchange format for printed wire 

assemblies. IDF is available in versions 2.0 and 3.0. Pro/ECAD supports the import 

and export of both versions of IDF file format. 

The IDF 2.0 specification does not support z-axis offset component placement 

information. When you export information from Pro/ENGINEER to the IDF 2.0 format, 

all z-axis offset information is lost. 

IDF 3.0 does support z-offset for component placement. 

About IDF File Sections 

Pro/ENGINEER supports all sections of the IDF 2.0 Board File Format, and all sections 

of the IDF 2.0 Library File Format. All IDF 2.0 functionality supported in IDF 3.0 

continues to be supported. 

IDF files default to the following extensions: 

• .emn—For a neutral file of the board outline and component placement 

• .emp—For a profile file that contains component outlines 

When you import or export with the IDF format, Pro/ENGINEER supports the Library 

File fields .ELECTRICAL and .MECHANICAL. Use these parameters to indicate whether 
an imported or exported component is electrical or mechanical. Use them in the .emp 
(export profile) file to set the type of component. 

The system imports parts from the .OTHER_OUTLINE sections of an IDF file with 
default datum planes and coordinate systems at their origin. The system also 

imports each of them with two part parameters. The first parameter, 

ECAD_PART_TYPE, has the value .OTHER_OUTLINE. The second parameter, 
ECAD_PART_NAME, has a value equal to the name of the .OTHER_OUTLINE section 
where it originated. 

Sometimes when you import a part, a part with the same name already exists in the 

current directory or session. In such cases, the part that already exists is used rather 

than the part specified in the IDF file. 

If you prefer, you can specify another name for the system to use during import. To 

do this, add the lines to the ecad_hint.map file. For example, <board_name> is the 
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name of the board part being imported, <.OTHER_OUTLINE <name>> is the name in 
the .OTHER_OUTLINE section of the IDF file, and <desired_name> is the name you 
want to use. Use this method to specify an alternative name for the .OTHER_OUTLINE 
part or, if the <desired_name> is the same as the name of a part in the current 
directory or session, specify another part to use instead of the part from the IDF file. 

All .OTHER_OUTLINE parts that Pro/ENGINEER imports keep their corresponding 
coordinate system and name. Specify the name of the coordinate system in the 

.OTHER_OUTLINE section with the ecad_other_outl_csys_def_name configuration 
option. If you do not set this option, the system assumes that the name of the 

coordinate system is ECAD_DEFAULT. 

The system uses the units for the ECAD system board from which this part was 

imported as the units for the imported part. 

To export parts that you create in Pro/ENGINEER as an .OTHER_OUTLINE section, 
create a part parameter called ECAD_PART_TYPE, with a value of .OTHER_OUTLINE. To 
specify the name of the .OTHER_OUTLINE section you create when you export this 
part, create a second part parameter called ECAD_PART_NAME. Assign it a value equal 
to the name you want for the .OTHER_OUTLINE section. If you do not specify this 
parameter, the system specifies the name of the part being exported as the name of 

the .OTHER_OUTLINE section. 

Exported components must have two surfaces (TOP and BOTTOM) parallel to the TOP 
and BOTTOM of the board in the assembly. 

To import all sections specified as .DRILLED_HOLE with either the PTH (Plated Holes) 
or the NPTH (Non-Plated Holes) attribute in the IDF file as Through-All Hole features, 
set the ecad_import_holes_as_features configuration option to YES. 

In IDF 2.0, the system stores all imported holes with the ECAD_HOLE_TYPE feature 
parameter. The value of this parameter is either PTH (plated through hole) or NPTH, 
(non-plated through hole) depending on the value of the .DRILLED_HOLE section in 
the IDF file. 

IDF 3.0 uses an ECAD_PLATING_STYLE parameter similar to the ECAD_HOLE_TYPE 
parameter 

The system exports boards with drilled holes, created by Pro/ENGINEER, with a 

default value of NPTH for the ECAD_HOLE_TYPE feature parameter. Create this feature 
parameter to specify a value of PTH. 

Supported ECAD File Formats 

About Supported ECAD File Formats 

Pro/ECAD supports the ECAD systems shown below for import to and export from 

Pro/ECAD. Additionally, you can use the IDF format, either 2.0 or 3.0. 

Using_the_Visula_Format—Uses the Visula ECAD/MCAD Neutral Interface format 

to interface with Visula version 6.0 software from Zuken-Redac Systems. 

Using_the_Allegro_Format—Uses the Allegro Interface format to interface with 

Allegro software version 5.1 and later from Cadence Design Systems. Cadence 

recommends that all users use IDF 2.0. 
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Using_the_Boardstation_Format—Uses versions 1.0 and 2.0 of Intermediate 

Data Format (IDF) from Mentor to interface with Mentor Graphics Board Station 

software. The mentor_ver_2_0 configuration option controls whether Pro/ENGINEER 
data is exported in version 1.0 or version 2.0 format. 

Using_the_Dazix_Format—Supports the interface with: 

o CDX Classic software (formerly Dazix CDX Classic) 

o AT Designer—Intergraph Corporation v 12 through v12.3, (formerly PCB 

Engineer). V12.4 and later use the IDF 2.0 format. 

IDF2.0—Intermediate Data Format (IDF) specifications for version 2.0. 

IDF3.0—Intermediate Data Format (IDF) specifications for version 3.0. 

IDF files default to the following extensions: 

o .emn—For a neutral file of the board outline and component placement 

o .emp—For a profile file that contains component outlines 

About Using the Allegro Format 

Note: Cadence and PTC recommend that you use the IDF format for data exchange, 

not the older direct format. 

Allegro files have one of the following extensions: 

• .mdb—For board outline files 

• .mdc—For component placement files 

• .mdf—For footprint files, such as the ones in component outline libraries  

Allegro cannot read the outlines of components. In part mode, you can only export 

boards to Allegro. 

Allegro represents mounting holes and other such features on a board as 

components. Therefore, component placement files contain their placement 

information. 

To process these features properly, Pro/ENGINEER requires the diameter of the 

holes, even though Allegro does not write this information to these interface files. To 

work around this, include a special record in the ecad_hint.map file. This record is 
called map_hole_component and is formatted as follows:  

map_hole_component -> 

ecad_name "hole_name" 
ecad_type "" 
unit "unit_name" 
diameter "diam_value" 

End 
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For example: 

map_hole_component -> 
ecad_name "MH125" 
ecad_type "" 
unit "mil" 
diameter "125" 

End 

To support the diameter of the holes, write the following units in the ecad_hint.map 
file: 

mm 
in 
mils 

All other Pro/ENGINEER units are converted as follows: 

cm converted to mm 
m converted to mm 
ft converted to mils 
microns converted to mils 

For example, a Pro/ENGINEER part with a hole diameter of 1.5 inches can have an 

Allegro ecad_hint.map mapping file written as follows: 

map_hole_component -> 

ecad_name "kuku" 
ecad_type "" 
unit "ft" 
diameter "0.125" 

End 

or 

map_hole_component -> 

ecad_name "kuku" 
ecad_type "" 
unit "cm" 
diameter "3.81" 

End 

or 

map_hole_component -> 

ecad_name "kuku" 
ecad_type "" 
unit "inch" 
diameter "1.5" 

End 
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When Pro/ENGINEER exports Pro/ECAD models to Allegro, it places a warning in the 

ECAD export log file if the export model contains area types that Allegro does not 

support. Allegro ignores the unsupported area types. 

Note: The Allegro interface format does not specify height information for placement 

keepin and keepout areas; Even if Pro/ENGINEER contains this information, 

Pro/ENGINEER cannot export it to Allegro. 

 

About Using the Boardstation Format 

Boardstation files use the following extensions: 

• .emn—For a neutral file of the board outline and component placement. Pro/ECAD 
neither imports nor exports information other than board outline and component 

placement. When Pro/ENGINEER imports information, it looks for files with the 

.emn extension. However, Boardstation can export these files with the .lib or 

.brd extensions instead. When Pro/ENGINEER exports the file, it uses the .emn 
extension. 

• .emp—For a profile file that contains component outlines. When Pro/ENGINEER 
imports information, it looks for files with the .emp extension. However, 
Boardstation can export these files with the .pro extensions instead. When 
Pro/ENGINEER exports, it uses the .emp extension. 

Pro/ENGINEER accepts exported information from Mentor Graphics that uses the 3D 

Mechanical interface. See your Mentor Graphics documentation for more information. 

About Using the Dazix Format 

Dazix files use the following extensions: 

• .edn—For a neutral file of the board outline and component placement. Dazix 
refers to this as a core file. 

• .edp—For a profile file that contains component outlines. Dazix refers to this as a 
library file. 

Dazix component names are mixed-case, prefixed with Z. Pro/ENGINEER converts 

these names to all uppercase. Dazix does not recognize uppercase names. Thus, to 

effect the transfer of component data, Dazix automatically creates an 

ecad_hint.map file to map between the two. 

Note: The Dazix interface format does not specify placement keepin areas or height 

information for placement keepout areas. Even if Pro/ENGINEER contains this 

information, Pro/ENGINEER cannot export it to Dazix. 
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About Using the Visula Format 

All Visula files use the extension .evs. 

The Visula interface format does not specify package keepout areas. Even if you 

create such an area in Pro/ENGINEER, Pro/ENGINEER does not export it. The IDF 2.0 

format, however, does specify keepout areas. 
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