Pro/ENGINEER®
Wildfire™ 2.0
Mechanism Design Extension
Help Topic Collection

Parametric Technology Corporation
Third-Party Trademarks
Adobe is a registered trademark of Adobe Systems. Advanced ClusterProven, ClusterProven, and the Clu-sterProven design are trademarks or registered trademarks of International Business Machines Corporation in the United States and other countries and are used under license. IBM Corporation does not warrant and is not responsible for the operation of this software product. AIX is a registered trademark of IBM Corporation. Allegro, Cadence, and Concept are registered trademarks of Cadence Design Systems, Inc. Apple, Mac, Mac OS, and Panther are trademarks or registered trademarks of Apple Computer, Inc. AutoCAD and Autodesk Inventor are registered trademarks of Autodesk, Inc. Baan is a registered trademark of Baan Company. CADAM and CATIA are registered trademarks of Dassault Systemes. COACH is a trademark of CADTRAIN, Inc. DOORS is a registered trademark of Telelogic AB. FLEX/min is a trademark of Macrovision Corporation. Geomagic is a registered trademark of Raindrop Geomagic, Inc. EVERSYNC, GROOVE, GROOVEFEST, GROOVE.NET, GROOVE NETWORKS, iGROOVE, PEERWARE, and the interlocking circles logo are trademarks of Groove Networks, Inc. Helix is a trademark of Microcadam, Inc. HOOPS is a trademark of Tech Soft America, Inc. HP-UX is a registered trademark and Tru64 is a trademark of the Hewlett-Packard Company. I-DEAS, Metaphase, Parasolid, SHERPA, Solid Edge, and Unigraphics are trademarks or registered trademarks of Electronic Data Systems Corporation (EDS). InstallShield is a registered trademark and service mark of InstallShield Software Corporation in the United States and/or other countries. Intel is a registered trademark of Intel Corporation. IRIS is a registered trademark of Silicon Graphics, Inc. LINUX is a registered trademark of Linus Torvalds. MatrixOne is a trademark of MatrixOne, Inc. Mentor Graphics and Board Station are registered trademarks and 3D Design, AMPLE, and Design Manager are trademarks of Mentor Graphics Corporation. MEDUSA and STHENO are trademarks of CAD Schroer GmbH. Microsoft, Microsoft Project, Windows, the Windows logo, Windows NT, Visual Basic, and the Visual Basic logo are registered trademarks of Microsoft Corporation in the United States and/or other countries. Netscape and the Netscape N and Ship's Wheel logos are registered trademarks of Netscape Communications Corporation in the U.S. and other countries. Oracle is a registered trademark of Oracle Corporation. OrbixWeb is a registered trademark of IONA Technologies PLC. PDGS is a registered trademark of Ford Motor Company. RAND is a trademark of RAND Worldwide. Rational Rose is a registered trademark of Rational Software Corporation. RetrievalWare is a registered trademark of Convera Corporation. RosettaNet is a trademark and Partner Interface Process and PIP are registered trademarks of "RosettaNet," a nonprofit organization. SAP and R/3 are registered trademarks of SAP AG Germany. SolidWorks is a registered trademark of SolidWorks Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. in the United States and in other countries. Products bearing SPARC trademarks are based upon an architecture developed by Sun Microsystems, Inc. Sun, Sun Microsystems, the Sun logo, Solaris, UltraSPARC, Java and all Java based marks, and “The Network is the Computer” are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and in other countries. TIBCO, TIBCO Software, TIBCO ActiveEnterprise, TIBCO Designer, TIBCO Enterprise for JMS, TIBCO Rendezvous, TIBCO Turbo XM, TIBCO BusinessWorks are trademarks or registered trademarks of TIBCO Software Inc. in the United States and other countries. WebEx is a trademark of WebEx Communications, Inc.

Third-Party Technology Information
Certain PTC software products contain licensed third-party technology: Rational Rose 2000E is copyrighted software of Rational Software Corporation. RetrievalWare is copyrighted software of Convera Corporation. VisTools library is copyrighted software of Visual Kinematics, Inc. (VKI) containing confidential trade secret information belonging to VKI. HOOPS graphics system is a proprietary software product of, and is copyrighted by, Tech Soft America, Inc. G-POST is copyrighted software and a registered trademark of Intercim. VERICUT is copyrighted software and a registered trademark of CGTech. Pro/PLASTIC ADVISOR is powered by Moldflow technology. Moldflow is a registered trademark of Moldflow Corporation. The JPEG image output in the Pro/Web.Publish module is based in part on the work of the independent JPEG Group. DFORM3.DLL is copyrighted software
# Table Of Contents

Mechanism Design Extension .................................................................................................. 1
About Mechanism Design and Mechanism Dynamics ......................................................... 1
Menu Commands and Buttons in Mechanism Design ......................................................... 1
About the Model Tree ........................................................................................................... 3
About the Info Menu............................................................................................................. 6
Example: Detailed Summary ............................................................................................... 7
Object Action ....................................................................................................................... 8
Object Action Shortcut Menu ............................................................................................. 8
About the Mechanism Design Tutorials .............................................................................. 9
Glossary of Terms ............................................................................................................... 10
Using Mechanism Design Kinematics .............................................................................. 11
About Mechanism Design Kinematics .............................................................................. 11
Mechanism Design Kinematics Workflow ......................................................................... 11
Creating a Model for Mechanism Design ......................................................................... 12
Joint Connections in Mechanism Design ......................................................................... 13
Checking Your Model ......................................................................................................... 14
Adding Modeling Entities for Mechanism Design Kinematics ........................................ 14
Preparing for a Repeated Assembly or Kinematic Analysis .............................................. 14
Running a Repeated Assembly or Kinematic Analysis ...................................................... 15
Saving and Viewing Repeated Assembly or Kinematic Analysis Results ....................... 15
Using Mechanism Dynamics ............................................................................................. 16
About Mechanism Design Dynamics ................................................................................. 16
Mechanism Dynamics Workflow ........................................................................................ 17
Creating a Model for Mechanism Dynamics ..................................................................... 18
Checking Your Model ......................................................................................................... 19
Adding Modeling Entities for Mechanism Dynamics ....................................................... 19
Using Servo Motors in Mechanism Dynamics ................................................................... 20
Preparing for Analyses in Mechanism Dynamics ............................................................. 20
Running Analyses in Mechanism Dynamics ...................................................................... 21
Table Of Contents

Saving and Viewing Analysis Results in Mechanism Dynamics ........................................21
  Mechanism Design Settings .........................................................................................22
About Settings..............................................................................................................22
To Define Settings........................................................................................................23
About Icon Visibilities ................................................................................................24
To Set Icon Visibilities................................................................................................25
  Initial Conditions .......................................................................................................26
About Initial Conditions...............................................................................................26
About the Initial Condition Definition Dialog Box ......................................................27
To Create an Initial Condition.....................................................................................27
To Edit an Initial Condition .......................................................................................28
Specifying the Direction of the Velocity Vector............................................................29
Tip: Using Initial Conditions.......................................................................................29
Incompatible Initial Conditions....................................................................................30
Finder Dialog Box.........................................................................................................30
Status ..........................................................................................................................31
Joint Axis Position in Drag .........................................................................................32
To Specify Joint Axis Position for Initial Conditions Using the Drag Dialog Box ..........32
Validation Checks for Initial Conditions......................................................................33
  Mass Properties.........................................................................................................33
About Mass Properties ..............................................................................................33
Mass Properties Dialog Box......................................................................................34
To Specify Mass Properties of a Part .........................................................................35
To Specify Mass Properties of an Assembly .............................................................36
Inertia ..........................................................................................................................36
  Joint Connections .....................................................................................................37
About Joint Connections ............................................................................................37
To Add a Component with Joint Connections ............................................................38
Types of Constraints Required for Joints ....................................................................39
Comparing Rigid and Weld Joints..............................................................................40
Degrees of Freedom ....................................................................................................40

vi
Table Of Contents

Coefficient of Restitution ................................................................................61
Tip: Defining Joint Axis Zero References...........................................................61
   Bodies ......................................................................................................62
About Bodies ................................................................................................62
To Redefine Bodies........................................................................................63
To Define a Body as Ground ...........................................................................64
To Redefine a Component as Ground Body .......................................................64
Tip: Creating Ground Bodies...........................................................................65
Highlight Bodies............................................................................................65
   Cams........................................................................................................65
About Cam-Follower Connections ....................................................................66
To Create a Cam-Follower Connection..............................................................66
To Define Properties for Cam-Follower Connections............................................67
Cam-Follower Connections with Liftoff..............................................................68
Coefficient of Restitution ................................................................................68
Cam-Follower Connection Design.....................................................................68
Surfaces for Cam-Follower Connections............................................................70
Curves for Cam-Follower Connections ..............................................................71
Depth References for Cam-Follower Connections ...............................................71
To Edit Cam-Follower Connections...................................................................72
Using Cam-Follower Connections in Drag Operations..........................................72
Cam-Follower and Slot-Follower Friction...........................................................73
To Delete Cam-Follower Connections ...............................................................73
Tutorial 3: Creating an Oscillating Cam ............................................................73
   Slots ........................................................................................................74
About Slot-Follower Connections ....................................................................74
To Create a Slot-Follower Connection..............................................................75
Coefficient of Restitution ................................................................................76
Curves in Slot-Follower Connections ..............................................................76
Follower Points in Slot-Follower Connections .....................................................76
Slot Endpoints in Slot-Follower Connections ....................................................76
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cam-Follower and Slot-Follower Friction</td>
<td>77</td>
</tr>
<tr>
<td>To Define Properties for Slot-Follower Connections</td>
<td>77</td>
</tr>
<tr>
<td>To Edit Slot-Follower Connections</td>
<td>78</td>
</tr>
<tr>
<td>To Delete Slot-Follower Connections</td>
<td>78</td>
</tr>
<tr>
<td>Using Slot-Follower Connections in Drag Operations</td>
<td>78</td>
</tr>
<tr>
<td>Drag and Snapshots</td>
<td>78</td>
</tr>
<tr>
<td>About Dragging</td>
<td>78</td>
</tr>
<tr>
<td>To Drag a Point</td>
<td>79</td>
</tr>
<tr>
<td>To Drag a Body</td>
<td>79</td>
</tr>
<tr>
<td>About the Drag Dialog Box</td>
<td>80</td>
</tr>
<tr>
<td>Snapshots Tab on the Drag Dialog Box</td>
<td>80</td>
</tr>
<tr>
<td>To Apply Constraints During a Drag Operation</td>
<td>81</td>
</tr>
<tr>
<td>To Orient Planes During a Drag Operation</td>
<td>81</td>
</tr>
<tr>
<td>Constraints Tab on the Drag Dialog Box</td>
<td>82</td>
</tr>
<tr>
<td>Advanced Drag Options</td>
<td>83</td>
</tr>
<tr>
<td>Using Assembly States</td>
<td>84</td>
</tr>
<tr>
<td>Copying Constraints from One Snapshot to Another</td>
<td>84</td>
</tr>
<tr>
<td>To Lock a Body Prior to a Dragging Operation</td>
<td>84</td>
</tr>
<tr>
<td>To Capture a Snapshot</td>
<td>85</td>
</tr>
<tr>
<td>To Use Snapshot Construction</td>
<td>85</td>
</tr>
<tr>
<td>To Edit a Snapshot</td>
<td>86</td>
</tr>
<tr>
<td>To Remove a Snapshot</td>
<td>86</td>
</tr>
<tr>
<td>Tutorial 2C: Dragging and Creating Snapshots</td>
<td>86</td>
</tr>
<tr>
<td>Modeling Entities</td>
<td>87</td>
</tr>
<tr>
<td>Springs</td>
<td>87</td>
</tr>
<tr>
<td>About Springs</td>
<td>87</td>
</tr>
<tr>
<td>About the Spring Definition Dialog Box</td>
<td>87</td>
</tr>
<tr>
<td>To Create a Spring</td>
<td>88</td>
</tr>
<tr>
<td>The U Constant</td>
<td>88</td>
</tr>
<tr>
<td>Joint Axis Spring</td>
<td>89</td>
</tr>
<tr>
<td>Point-to-Point Spring</td>
<td>89</td>
</tr>
</tbody>
</table>
Table Of Contents

Status .......................................................................................................................... 105
To Copy a Modeling Entity ....................................................................................... 105
To Rename a Modeling Entity .................................................................................. 106
To Delete a Modeling Entity .................................................................................... 106
About Graphing ........................................................................................................ 106
  Gravity ................................................................................................................... 107
About Gravity ............................................................................................................ 107
About the Gravity Dialog Box .................................................................................. 108
To Define Gravity ....................................................................................................... 108
To Edit Gravity .......................................................................................................... 108
To Copy a Modeling Entity ....................................................................................... 109
To Rename a Modeling Entity .................................................................................. 109
To Remove Gravity .................................................................................................... 109
Gears .......................................................................................................................... 110
About Gear Pairs ...................................................................................................... 110
To Create Gear Pairs ............................................................................................... 111
To Define Standard Gear Pairs ................................................................................ 111
Defining Standard Gear Pairs .................................................................................. 112
To Define Rack and Pinion Gear Pairs .................................................................... 113
Defining Rack and Pinion Gear Pairs ...................................................................... 114
To Define Gear Pair Orientation ............................................................................. 115
Using Gear Pairs in Mechanism Dynamics Analyses ............................................. 116
To Edit a Gear Pair ................................................................................................... 117
To Copy a Modeling Entity ....................................................................................... 117
To Rename a Modeling Entity .................................................................................. 117
To Delete a Modeling Entity .................................................................................... 118
Servo Motors ............................................................................................................ 118
About Servo Motors ................................................................................................. 118
To Create a Servo Motor ........................................................................................... 118
To Define the Servo Motor Type ............................................................................ 119
About the Type Tab in the Servo Motor Definition Dialog Box ......................... 119
Table Of Contents

To Define the Profile for a Servo Motor ........................................................... 120
About the Profile Tab in the Servo Motor Definition Dialog Box ..................... 121
About Magnitude Settings .................................................................................. 122
Example: Types of Motor Profiles ................................................................. 124
Magnitude Settings for Sine-Constant-Cosine-Acceleration Motion Profile ....... 125
To Specify Servo Motor Magnitude as a Table Function .................................. 126
Magnitude as a Table Function ....................................................................... 126
Magnitude as a User-Defined Function ........................................................... 127
Expression Graph Dialog Box .......................................................................... 128
Functions Dialog Box ...................................................................................... 129
Operators Dialog Box ...................................................................................... 130
Variables Dialog Box ...................................................................................... 130
To Specify Servo Motor Magnitude as a User-Defined Function ...................... 131
Expression Definition Dialog Box ..................................................................... 132
Constants Dialog Box ...................................................................................... 133
Understanding Geometric Motors .................................................................... 134
To Edit a Servo Motor ..................................................................................... 135
Finder Dialog Box .......................................................................................... 135
Status ........................................................................................................... 137
To Copy a Modeling Entity ................................................................................ 137
To Rename a Modeling Entity .......................................................................... 137
To Delete a Modeling Entity ............................................................................ 138
About Graphing ............................................................................................... 138
  Force Motors ................................................................................................ 139
About Force Motors ......................................................................................... 139
To Create a Force Motor .................................................................................. 139
About the Force Motor Definition Dialog Box .................................................. 140
About Magnitude Settings .............................................................................. 140
Magnitude as a Table Function ....................................................................... 142
To Specify Force Motor Magnitude as a Table Function ................................... 143
Magnitude as a User-Defined Function ........................................................... 143
**Table Of Contents**

To Specify Force Motor Magnitude as a User-Defined Function ...........................145

Expression Definition Dialog Box ........................................................................145

Constants Dialog Box ............................................................................................146

To Edit a Force Motor ............................................................................................147

Finder Dialog Box ..................................................................................................148

To Copy a Modeling Entity ....................................................................................149

To Rename a Modeling Entity .................................................................................149

To Delete a Modeling Entity .................................................................................149

Status .....................................................................................................................150

About Graphing ......................................................................................................150

Custom Loads ........................................................................................................151

About Custom Loads ..............................................................................................151

Custom Load ..........................................................................................................152

Custom Load Functions ........................................................................................152

Functions provided by the custom load application and written by the custom load developer: ............................................................................................................152

Functions provided by Mechanism Design and callable by the custom load developer: .............................................................................................................153

Functions and Their Argument Values ...................................................................153

Guidelines for Creating a Custom Load Application ..............................................156

Analyses .................................................................................................................157

About Analyses ......................................................................................................157

About the Analyses Dialog Box .............................................................................157

About the Analysis Definition Dialog Box ............................................................158

To Run an Analysis ...............................................................................................159

From the Analysis Dialog Box ...............................................................................159

From the Analysis Definition Dialog Box .............................................................159

Tip: Running an Analysis .....................................................................................159

Validation Checks for Analyses .............................................................................160

Repeated Assembly Analyses ................................................................................160

About Repeated Assembly Analysis .....................................................................160

To Create a Repeated Assembly Analysis .............................................................161
To Define Preferences for Repeated Assembly and Kinematic Analyses .............. 161
Entering Preferences for Repeated Assembly and Kinematic Analyses .............. 162
About Locked Entities for Analyses ................................................................ 163
To Specify Motors for an Analysis ................................................................. 163
Entering Motors Information ........................................................................ 164
To Copy an Analysis .................................................................................... 165
To Edit an Analysis Definition ...................................................................... 165
To Delete an Analysis .................................................................................. 166

Kinematic Analyses .................................................................................. 166
About Kinematic Analysis ............................................................................ 166
To Create a Kinematic Analysis ..................................................................... 166
To Define Preferences for Repeated Assembly and Kinematic Analyses ........... 167
Entering Preferences for Repeated Assembly and Kinematic Analyses ............. 168
About Locked Entities for Analyses ............................................................... 169
To Specify Motors for an Analysis ................................................................. 169
Entering Motors Information ........................................................................ 170
To Run an Analysis ...................................................................................... 171
   From the Analysis Dialog Box .................................................................. 171
   From the Analysis Definition Dialog Box .................................................. 171
To Edit an Analysis Definition ...................................................................... 171
To Copy an Analysis .................................................................................... 172
To Delete an Analysis .................................................................................. 172
Tutorial 2D: Creating and Running a Kinematic Analysis ............................... 172

Dynamic Analyses .................................................................................. 173
About Dynamic Analysis ............................................................................ 173
To Create a Dynamic Analysis ..................................................................... 174
To Define Preferences for Dynamic Analysis ............................................... 174
Entering Preferences for Dynamic Analyses ................................................. 175
About Locked Entities for Analyses ............................................................... 176
To Specify Motors for an Analysis ................................................................. 177
Entering Motors Information ........................................................................ 177
# Table Of Contents

About Locked Entities for Analyses ................................................................. 191
To Specify Motors for an Analysis ................................................................. 192
Entering Motors Information ........................................................................ 192
To Specify External Loads for an Analysis ..................................................... 194
Entering External Loads Information ............................................................. 194
To Run an Analysis ....................................................................................... 195
  From the Analysis Dialog Box ................................................................. 195
  From the Analysis Definition Dialog Box .................................................... 195
To Copy an Analysis...................................................................................... 195
To Edit an Analysis Definition ..................................................................... 196
To Delete an Analysis .................................................................................. 196
  Results .................................................................................................... 196
  Playback ................................................................................................. 196
About Playback ............................................................................................. 196
About the Playbacks Dialog Box ................................................................. 197
To Play a Result Set ..................................................................................... 198
Interference ................................................................................................. 198
Movie Schedule ............................................................................................ 199
Display Arrows ............................................................................................ 199
Measures Available for Display Arrows........................................................ 200
Input Loads Available for Display Arrows .................................................... 201
To Save a Result Set to a File ....................................................................... 202
To Restore a Saved Result Set File .............................................................. 202
About the Animate Dialog Box .................................................................... 202
To Capture a Playback Result Set ............................................................... 203
Capture Dialog Box ..................................................................................... 204
To Create a Motion Envelope ...................................................................... 205
Create Motion Envelope Dialog Box ............................................................ 206
To Remove a Playback Result Set ............................................................... 208
To Export a Playback Result Set .................................................................. 208
To Track a Measure During Playback ......................................................... 209
Table Of Contents

To Create Gear Pair Reaction Measures ..........................................................234
Net Load Measures..................................................................................................235
Comparing Net Load and Connection Reaction Measures .................................236
To Create Net Load Measures ........................................................................236
Loadcell Reaction Measures ..............................................................................237
To Create Loadcell Reaction Measure ................................................................238
To Create Loadcell Locks .................................................................................239
Impact Measures ..................................................................................................239
To Create Impact Measures ............................................................................239
Impulse Measures ...............................................................................................240
To Create Joint Impulse Measures ...................................................................241
To Create Cam-Follower Impulse Measures .......................................................241
To Create Slot-Follower Impulse Measures .......................................................242
Slip Component for Cam-Follower Connections .................................................242
System Measures ...............................................................................................243
To Create System Measures ...........................................................................244
Body Measures ....................................................................................................245
Components for Body Angular Velocity, Angular Acceleration, and Center of Mass Measures ...........................................................................................................246
Components for Body Orientation Measures .....................................................246
Components for Body Centroidal Inertia Measures ..........................................246
To Create Body Measures ...............................................................................247
Separation Measures ..........................................................................................248
Components for System Linear Momentum, Angular Momentum, and Center of Mass Measures ...........................................................................................................248
Components for System Centroidal Inertia Measures .......................................248
To Create Separation Measures .......................................................................249
Cam Measures .....................................................................................................250
To Create Cam Measures ...............................................................................250
User Defined Measures ....................................................................................251
To Create User-Defined Measures ....................................................................252
Quantity for User-Defined Measures ...............................................................253
# Table Of Contents

Trace Curves ........................................................................................................................253
About Trace Curves .................................................................................................................253
About the Trace Curve Dialog Box ..........................................................................................254
To Create a Trace Curve ..........................................................................................................255
Editing 3D Trace Curves .........................................................................................................256
Load Transfer to Structure ....................................................................................................256
About Load Transfer to Structure ......................................................................................256
Load Export Dialog Box .......................................................................................................257
Load Info List ..........................................................................................................................258
Guidelines for Exporting Loads to Structure .......................................................................258
How Loads Transfer to Structure .......................................................................................259
To Export Loads to Structure ...............................................................................................261
Example: Load Transfer for Cam Assembly .........................................................................261
Graphing ...................................................................................................................................262
About Graphing .......................................................................................................................262
Segmenting a Graph ................................................................................................................263
Managing Graphs ....................................................................................................................264
X Axis and Y Axis Tabs ............................................................................................................264
Data Series Tab ........................................................................................................................265
Graph Display Tab ....................................................................................................................265
Mechanism Design Tutorials .................................................................................................266
About the Mechanism Design Tutorials ................................................................................266
Tutorial 1: Creating a Slider-Crank Mechanism ..................................................................266
Example: Slider-Crank Mechanism .......................................................................................267
Tutorial 1A: Creating a Slider-Crank Mechanism Using Joint Connections .....................267
   Placing the First Part ............................................................................................................268
   Creating the First Pin Joint .................................................................................................268
   Creating the Second Pin Joint ............................................................................................269
   Adding a Fixed Part to the Assembly ................................................................................269
   Closing the Loop on the Slider-Crank Mechanism ..........................................................270
   Adding a Fixed Part to Ground ..........................................................................................270
Table Of Contents

Tutorial 1B: Identifying Ground and Dragging the Mechanism .........................271
Tutorial 1C: Creating a Servo Motor ...............................................................272
Tutorial 1D: Creating and Running a Kinematic Analysis ..............................272
Tutorial 1E: Saving and Reviewing Results ....................................................273
Tutorial 2: Creating a Four-Bar Linkage .........................................................274
Tutorial 2A: Creating a Four-Bar Linkage Using Joint Connections ...............274
  Placing the First Part ..................................................................................275
  Creating the First Pin Joint .........................................................................275
  Creating the Second Pin Joint .....................................................................276
  Redefining the Second Pin Joint .................................................................276
  Adding a Fixed Part to Ground ..................................................................277
  Closing the Loop on the Four-bar Linkage ................................................277
  Entering Mechanism and Identifying Ground ............................................277
Tutorial 2B: Creating Motors, Applying Joint Zeros, and Creating Limits .........278
Tutorial 2C: Dragging and Creating Snapshots ..............................................279
Tutorial 2D: Creating and Running a Kinematic Analysis ..............................280
Tutorial 2E: Reviewing Results ....................................................................280
Tutorial 3: Creating an Oscillating Cam .......................................................282
Tutorial 3A: Creating a Cam-Follower Connection, Spring, and Damper ..........283
Tutorial 3B: Creating a Servo Motor .............................................................285
Tutorial 3C: Creating and Running a Dynamic Analysis ...............................286
Tutorial 3D: Creating and Graphing Measures ............................................287
Tutorial 3E: Saving and Reviewing Results ...................................................289
Tutorial 4A: Creating a User-Defined Measure .............................................289
  Create a Pro/ENGINEER Parameter ..........................................................290
  Create a Standard Measure ......................................................................290
  Create a User-Defined Measure ...............................................................290
  Rerun the Analysis and Graph the Measures ..........................................291
Example: Oscillating Cam ...........................................................................291
Index .........................................................................................................293
Mechanism Design Extension

About Mechanism Design and Mechanism Dynamics

Use Mechanism Design to define a mechanism, make it move, and analyze its motion. With the introduction of Mechanism Design Dynamics Option, Mechanism Design now includes a broad range of motion evaluation functionality. In Mechanism Dynamics, you can create connections between parts to build an assembly with the desired degrees of freedom, then apply motors to generate the type of motion you want to study. Mechanism Design allows you to extend your design with cams, slot-followers, and gears. When you are ready to analyze the movement, you can observe and record the analysis, or measure quantities such as positions, velocities, accelerations, or forces, and graph the measurement. You can also create trace curves and motion envelopes that represent the motion physically.

If you want to study the motion of a mechanism in response to applied forces, use Mechanism Dynamics. If you want to study the motion of a mechanism without regard to applied forces, called a kinematics study, you do not need Mechanism Dynamics.

When you create mechanisms, you can bring your Mechanism Design model into Design Animation to create an animation sequence. Joint connections, cam-follower connections, slot-follower connections, gear pairs, connection limits, servo motors, and joint axis zeros are all supported in Design Animation. However, the modeling entities included in Mechanism Dynamics, springs, dampers, force/torque loads, and gravity, do not transfer to Design Animation.

You can complete most tasks in Mechanism Design either with menu commands or buttons. You can also use the Model Tree and object action for some actions.

Menu Commands and Buttons in Mechanism Design

The following is a list of the commands you will use in Mechanism Design and the menus on which they appear. Also included in the list are buttons that correspond to commands. The shaded items are visible only if you have a license for Mechanism Dynamics Option.

- **Edit Menu**
  - **Redefine Bodies**—Opens the **Redefine Body** dialog box, from which you can remove assembly constraints to the bodies in your assembly.
  - **Settings**—Opens the **Settings** dialog box, from which you can specify the tolerance that Mechanism Design uses to assemble your mechanism, and from which you can also specify the action that Mechanism Design takes when an analysis run fails.
- **View Menu**
  - **Highlight Bodies**—Highlights the bodies, displaying the ground body in green.
Mechanism Design Extension Help Topic Collection

- **Display Settings > Mechanism Display**—Opens the Display Entities dialog box, from which you can turn on or off the visibility of icons on your assembly.

- **Mechanism** Menu

  - **Jt Axis Settings**—Opens the Joint Axis Settings dialog box, from which you can define the zero references, regeneration value, and limit settings for a joint axis.

  - **Cams**—Opens the Cam-Follower Connections dialog box, from which you can create a new cam-follower, or edit or delete an existing one.

  - **Slots**—Opens the Slot-Follower Connections dialog box, from which you can create a new slot-follower, or edit or delete an existing one.

  - **Gears**—Opens the Gear Pairs dialog box, from which you can create a new gear pair, or edit, remove, or copy an existing one.

  - **Servo Motors**—Opens the Servo Motors dialog box, from which you can define a servo motor, or edit, remove, or copy an existing one.

  - **Force Motors**—Opens the Force Motors dialog box, from which you can define a force motor, or edit, remove, or copy an existing one.

  - **Springs**—Opens the Springs dialog box, from which you can define a spring, or edit, remove, or copy an existing one.

  - **Dampers**—Opens the Dampers dialog box, from which you can define a damper, or edit, remove, or copy an existing one.

  - **Force/Torque**—Opens the Forces/Torques dialog box, from which you can define a force or a torque. You can also edit, remove, or copy an existing force/torque load.

  - **Gravity**—Opens the Gravity dialog box, from which you can define gravity.

  - **Initial Conditions**—Opens the Initial Conditions dialog box, from which you can specify initial position snapshots, and define the velocity initial conditions for a point, joint axis, body, or slot.

  - **Mass Properties**—Opens the Mass Properties dialog box, from which you can specify mass properties for a part, or specify density for an assembly.
Mechanism Design Extension

- **Drag**—Opens the Drag dialog box, from which you can drag your mechanism into a desired configuration and take snapshots.

- **Connect**—Opens the Connect Assembly dialog box, from which you can lock or unlock any bodies or connections as desired, and run an assembly analysis.

- **Analyses**—Opens the Analyses dialog box, from which you can add, edit, remove, copy, or run an analysis.

- **Playback**—Opens the Playbacks dialog box, from which you can play back the results of your analysis run. You can also save the results to a file, restore previously saved results, or export the results.

- **Measures**—Opens the Measure Results dialog box, from which you can create measures, and select measures and result sets to display. You can also plot the results or save them to a table.

- **Trace Curve**—Opens the Trace Curve dialog box, from which you can generate a trace curve or cam synthesis curves.

- **Use In Structure**—Opens the Export Loads dialog box, from which you can define a load set based upon a specific time in an analysis.

**Info** Menu

- **Mechanism > Summary**—Opens an information window that provides you with a summary of the kinds of information available in the detailed list (Mechanism > Details).

- **Mechanism > Details**—Opens an information window that provides you with all detailed information available for your assembly.

- **Mechanism > Mass Property**—Opens an information window that provides you with details of the mass properties assigned to your assembly.

**About the Model Tree**

The Model Tree appears when you open a model in Pro/ENGINEER. After you select Mechanism from the Applications menu, you see the MECHANISM portion of the model tree. This lists connections, modeling entities, motors, analyses, and playbacks that are associated with the model. The shaded items in the table below are visible in the Model Tree only if you have a Mechanism Dynamics Option license.

When you select any of the entries referring to individual entities in the Model Tree, Mechanism Design highlights that entity on your model. When you select GRAVITY, Mechanism Design highlights the ground body LCS and displays a shaded arrow in the direction of the gravitational acceleration vector.
**Tip:** If your model is large, with several connections or motors, it is often easier to find a specific connection or motor in the Model Tree than it is to select the connection or motor that you want on the model. For example, if you want to define a servo motor for the rotation joint axis on a cylinder joint, you can highlight the name of the rotation joint axis, then right-click and select **Servo Motor** to open the **Servo Motor Definition** dialog box.

When you right-click the items in the first column, a shortcut menu appears with the items in the column under **Actions**. When you select an action, a dialog box or message box appears as in the **Results** column. You can use object action to access similar menus by selecting certain entities on your model.

<table>
<thead>
<tr>
<th>Name</th>
<th>Actions</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mechanism</td>
<td><strong>Info</strong></td>
<td>Browser window with short summary</td>
</tr>
<tr>
<td></td>
<td><strong>Summary</strong></td>
<td>Browser window with detailed summary</td>
</tr>
<tr>
<td></td>
<td><strong>Details</strong></td>
<td>Browser window with mass property definitions</td>
</tr>
<tr>
<td></td>
<td><strong>Mass Properties</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Settings</strong></td>
<td><strong>Settings</strong> dialog box</td>
</tr>
<tr>
<td>Connections</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td>Joints</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Motors</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gravity</td>
<td><strong>Edit</strong></td>
<td><strong>Gravity</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td><strong>Info &gt; Details</strong></td>
<td>Browser window giving gravity and WCS direction</td>
</tr>
<tr>
<td>Cams</td>
<td><strong>New</strong></td>
<td>Definition dialog box for selected entity</td>
</tr>
<tr>
<td>Slots</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gears</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Servo</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Force</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Springs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dampers</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Forces/torques</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initial conditions</td>
<td>Analyses</td>
<td></td>
</tr>
<tr>
<td>--------------------</td>
<td>----------</td>
<td>---</td>
</tr>
<tr>
<td><strong>Cam_follower_connection_name</strong></td>
<td><strong>Edit, Delete, Copy Info &gt; Details</strong></td>
<td>Definition dialog box for selected entity</td>
</tr>
<tr>
<td>Servo_motor_name</td>
<td></td>
<td>Browser window with detailed summary for selected entity</td>
</tr>
<tr>
<td><strong>Force_motor_name</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Spring_name</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Damper_name</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Force_torque_name</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Initial_condition_name</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Slot_follower_connection_name</strong></td>
<td><strong>Edit, Delete Info &gt; Details Damper</strong></td>
<td><strong>Slot-Follower Connection Definition</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Browser window with detailed summary for the slot-follower connection</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Damper Definition</strong> dialog box</td>
</tr>
<tr>
<td>Gear_pair_connection_name</td>
<td><strong>Edit, Delete Info &gt; Details</strong></td>
<td><strong>Gear Pair Definition</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Browser window with detailed summary for selected gear pair connection</td>
</tr>
<tr>
<td>Rotation Axis, Translation Axis (under <strong>Joint_name</strong> or <strong>Gear_pair_connection_name</strong>)</td>
<td><strong>Joint Setting Servo Motor Force Motor Spring Damper</strong></td>
<td><strong>Joint Axis Settings</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Servo Motors Definition</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Force Motors Definition</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Springs Definition</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Dampers Definition</strong> dialog box</td>
</tr>
<tr>
<td>Rotation Axis, Translation Axis (under Motors)</td>
<td><strong>Joint Setting</strong></td>
<td><strong>Joint Axis Settings</strong> dialog box</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### About the Info Menu

Use the commands on the **Info** menu to view a summary of information for your model. You can use these summaries to better understand a Mechanism model without having to open it and review all the dialog boxes to obtain the required information. The summaries you obtain from the **Info** menu are also useful in situations where you want to understand the changes that have gone into a model and to see how a model has evolved over time. You can do this by comparing the summary information with model summary files obtained for previous versions of the model.

You can access the **Info** menu by clicking **Info > Mechanism**, or by right-clicking on the **Mechanism** node in the Model Tree and selecting **Info**. In both cases, a sub-menu opens with the following commands. Select one of the commands to open the Pro/ENVIEER browser window with summary information.

- **Summary**—A high-level summary of the mechanism, containing information about the mechanism’s entities and number of items present in the model, except where indicated. Inactive entities, wherever listed, include all those entities that are incomplete or suppressed.

- **Details**—Contains all entities and their relevant properties. If a particular entity type is not present—such as Force Motors—the heading is listed with no entries. Inactive entities—suppressed or incomplete—are not listed in the detailed summary.

- **Mass Properties**—A listing of the mass, center of gravity, and inertia components for the mechanism.
Mechanism Design Extension

Mechanism offers an **Info** option for each Mechanism Design entity on the Model Tree. When you right-click and select this option for a particular entity, a browser window opens with the detailed summary specifically for that entity.

The browser window summaries include buttons that highlight entities in the model window or display information sheets. For more information, and an example of a detailed summary file, see Example: Detailed Summary.

For more information on the Pro/ENGINEER browser, search the Fundamentals functional area of the PTC Help system.

**Example: Detailed Summary**

The following is a portion of the detailed summary from the **Info > Mechanism > Details** command.

When you click ![Collapse](image) and collapse the browser window, Mechanism Design highlights the corresponding entity in the model window. When you click ![Expand](image), Mechanism Design displays information about the selected feature in the browser window.

**Note:** To save the information from the embedded browser as a text file, set the configuration option `info_output_format` to `dbg_text`.

<table>
<thead>
<tr>
<th>Mechanism Report: Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Unit System</strong></td>
</tr>
<tr>
<td>Attribute</td>
</tr>
<tr>
<td>Units</td>
</tr>
<tr>
<td>Connections</td>
</tr>
<tr>
<td><strong>ASSEMBLY NAME</strong> FOURBAR.ASM</td>
</tr>
<tr>
<td><strong>ENTITY NAME</strong> CONNECTION_1</td>
</tr>
<tr>
<td><strong>Properties</strong></td>
</tr>
<tr>
<td>Attribute</td>
</tr>
<tr>
<td>Type</td>
</tr>
<tr>
<td><strong>Bodies</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Ground</td>
</tr>
</tbody>
</table>
Object Action

Use Object Action to perform an action on an object that you select in the work area, or in the Model Tree. You can use Object Action to modify, edit, or delete any mechanism entity regardless of its position, whether at the top level, or in lower subassemblies. For objects in the work area, you select an entity icon on your model. You then right-click to display a shortcut menu that lists operations you can perform on the entity.

**Note:** You cannot use object action for Pro/ENGINEER entities such as datum points, axes, and planes, primary items, and geometry while in Mechanism Design.

For objects in your work area, you can perform object action operations on the following Mechanism Design entities:

- **Cam-Follower Connections**—Select either cam-follower connection, or cam geometry.
- **Slot-Follower Connections**—Select a slot-follower connection, a slot curve, or follower point geometry.
- **Gears**—Select the gears icon.
- **Servo Motors**—Select the servo motor icon.
- **Force Motors**—Select the force motor icon.
- **Springs**—Select the spring icon.
- **Dampers**—Select the damper icon.
- **Forces/Torques**—Select the force/torque icon.
- **Joint Axes**—Select any part of the joint icon.

**Object Action Shortcut Menu**
After you select a Mechanism Design entity in the Model Tree or in the work area, you can right-click to show a shortcut menu. To have selectable objects in the work area highlight when you pass the cursor over them, use **Edit > Selection Preferences > Pre-selection Highlighting**.

**Note:** If your assembly includes several entities in close proximity, making it difficult to make a positive selection, you may want to work in query mode. If you select the option to turn on query mode, prehighlighting will no longer work. For more information on selection tools, search the Fundamentals module of the PTC online help.

Shortcut menus for entities in the work area contain some of the following commands, depending on the entity you select and then right-click:

- **Rehighlight**—Use this selection to highlight all previously selected items.
- **Edit**—Use this selection to edit the entity.
- **Delete**—Use this selection to delete the entity.
- **Info**—Use this selection to view information about the entity.
- **Next**—Use this selection to move to the next entry in the query list.
- **Previous**—Use this selection to move to the previous entry in the query list.
- **Pick from List**—Use this selection to display a dialog box with a list of entities near your selection location. The entities in the list are referenced, when you use the **Next** and **Previous** commands even though the **Pick from List** dialog box is not visible.
- **Unselect Last**—Use this selection to deselect the current entity.
- **Joint Settings** (joint axes only)—Use this selection to show the **Joint Axis Settings** dialog box.
- **Servo Motor** (joint axes only)—Use this selection to create a servo motor at the selected joint axis.
- **Force Motor** (joint axes only)—Use this selection to create a force motor at the selected joint axis.
- **Spring** (joint axes only)—Use this selection to create a spring at the selected joint axis.
- **Damper** (joint axes and slot-follower connections)—Use this selection to create a damper at the selected joint axis or slot-follower connection.

**About the Mechanism Design Tutorials**

The Mechanism Design tutorials are meant to be used as interactive examples, providing you with first-hand knowledge of several important elements of functionality.

The first tutorial creates a slider-crank mechanism, and demonstrates making connections, creating a servo motor, running, and viewing a kinematic analysis. The second tutorial creates a four-bar linkage. In addition to the topics covered by the
first tutorial, the second tutorial covers setting joint axis limits, defining time-
conditional servo motors, and creating a trace curve.

The third tutorial demonstrates making a cam connection, adding springs and
dampers, and running a dynamic analysis. The fourth tutorial demonstrates creating
a user-defined measure, using the single-piston engine you created in the first
tutorial. You must have a Mechanism Dynamics Option license to do the third and
fourth tutorials.

The tutorials rely on live versions of the models, and should give you a general idea
of how to use Mechanism Design to model similar problems. You can find the
necessary parts for the tutorials in the Demo area of the installation CD-ROM.

For additional information, preferred techniques, and demonstrations, see the User
Area on the PTC Web site (http://www.ptc.com).

**Glossary of Terms**

You should be familiar with these terms before creating a mechanism:

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Body</td>
<td>Relationships between bodies that define and constrain their relative motion.</td>
</tr>
<tr>
<td>Connections</td>
<td>A component or group of components that do not move with respect to each other.</td>
</tr>
<tr>
<td>Degrees of Freedom</td>
<td>Allowed motion of a mechanical system. Connections act as constraints on the motion of bodies relative to each other, reducing the total possible degrees of freedom of the system.</td>
</tr>
<tr>
<td>Dragging</td>
<td>Using the mouse to grab and move the mechanism on-screen.</td>
</tr>
<tr>
<td>Dynamics</td>
<td>The study of a mechanism's motion in response to applied forces.</td>
</tr>
<tr>
<td>Force Motor</td>
<td>A force applied to a rotational or translation joint axis to cause motion.</td>
</tr>
<tr>
<td>Gear Pair Connection</td>
<td>A velocity constraint applied to two joint axes.</td>
</tr>
<tr>
<td>Ground</td>
<td>A body that does not move. Other bodies move with respect to ground.</td>
</tr>
<tr>
<td>Joints</td>
<td>Specific types of connection (for example, pin joint, slider joint, and ball joint)</td>
</tr>
<tr>
<td>Kinematics</td>
<td>The study of a mechanism's motion without taking into account the forces required to move it.</td>
</tr>
<tr>
<td><strong>LCS</strong></td>
<td>The Local Coordinate System associated with a body. The LCS is the default coordinate system associated with the first part you define in your body.</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Loop Connection</strong></td>
<td>The last connection added to a kinematic loop.</td>
</tr>
<tr>
<td><strong>Motion</strong></td>
<td>The way that a body moves subject to motors or loads.</td>
</tr>
<tr>
<td><strong>Placement Constraint</strong></td>
<td>An entity in an assembly that places a component and that limits the movement of the component in the assembly.</td>
</tr>
<tr>
<td><strong>Playback</strong></td>
<td>The ability to record and replay the motion of an analysis run.</td>
</tr>
<tr>
<td><strong>Servo Motor</strong></td>
<td>The way to define how a body moves relative to another body. You can place motors on joints or on geometric entities, and you can specify the position, velocity, or acceleration motion between bodies.</td>
</tr>
<tr>
<td><strong>UCS</strong></td>
<td>A User Coordinate System. You define a UCS with the command <strong>Insert &gt; Model Datum &gt; Coordinate System</strong>.</td>
</tr>
<tr>
<td><strong>WCS</strong></td>
<td>The World Coordinate System. The global coordinate system for the assembly, this includes the global coordinate system for the assembly and all the bodies in that assembly.</td>
</tr>
</tbody>
</table>

**Using Mechanism Design Kinematics**

**About Mechanism Design Kinematics**

If you do not have a Mechanism Dynamics Option license, only the kinematics menus are available when you start Mechanism Design. In a kinematics study, you can define your mechanism, make it move with servo motors, and analyze the motion without reference to forces acting on the system. Use kinematics to observe the movement of your mechanism, and to measure the change in position, velocity, and acceleration of the bodies. See the workflow illustration for a summary of the process you can use to study your model with Mechanism Design kinematics.

There are two kinematics tutorials to help you become familiar with Mechanism Design. The first tutorial leads you through a study of a single piston assembly, including building the model, applying a servo motor, checking the motion of the model with the drag functionality, running an analysis, and viewing the results. The second tutorial creates a four-bar linkage, then sets joint axis limits, uses time-conditional servo motors, and demonstrates trace curves.

**Mechanism Design Kinematics Workflow**

[Creating your model ➔ Define bodies.]
### Creating a Model for Mechanism Design

Creating a model for a Mechanism Design analysis includes these tasks:

- **Define the bodies in your model**—A body is a group of parts that are rigidly controlled, with no degrees of freedom within the group. If two parts have a Pro/ENGINEER constraint between them, they are part of the same body. You can only place Mechanism Design connections between two distinct bodies. If a mechanism is not moving the way you expect, or if you are not able to create connections because two parts are in the same body, you may need to redefine the bodies in your mechanism. When you redefine bodies in Mechanism Design, you remove the Pro/ENGINEER constraints so that you can replace them with connections.
Mechanism Design connections include joints, cam-follower connections, and slot-follower connections.

- **Assemble your model with joint connections**—You assemble a mechanism by adding components to an assembly using joint connections in the same way you add components to an assembly using placement constraints. Connections define how the components move with respect to each other. Use the Pro/ENGINEER command **Insert > Component > Assemble** to add connections to your mechanism.

  **Note:** A component in Pro/ENGINEER Assembly mode refers to parts and subassemblies. A body is a Mechanism Design term that refers to a single part or two or more parts joined by a Pro/ENGINEER non-joint-type constraint.

- **Specify parameters for the connections**—After you add joints, you can use the **Joint Axis Settings** dialog box to define zero references, a regeneration value for the software to use when it assembles the model, and limits on the allowed motion of the connections.

- **Create special connections**—You can use Mechanism Design to create cam-follower and slot-follower connections. You can create a cam-follower connection or slot-follower connection simply by selecting geometric entities on your model. You do not need to first create special cam geometry.

  You can also use Mechanism Design to create kinematic gear pair connections. You create gear pairs by selecting joint axes, and the gear pair connections constrain the relative velocity of the joint axes. You do not need to create special gear geometry.

**Joint Connections in Mechanism Design**

Adding a component with joints is similar to traditionally assembling a component in the following ways:

- Both methods use Pro/ENGINEER constraints for placement.

- The relationship between assemblies and subassemblies is the same.

Adding a component with joints is different from traditionally assembling a component in the following ways:

- Components placed by connection are underconstrained by design. They retain one or more degrees of freedom.

- When you place a component with Pro/ENGINEER constraints, your goal is to remove all degrees of freedom. You must select the correct constraints to do this. When you add a component with Mechanism Design connections, you want to achieve a particular type of motion. After you decide which connection allows the type of motion you want, the software prompts you to make the constraints needed for that connection.

- To reverse the orientation of a component, you can use \( \theta \) to turn one component 180° with respect to the other. If you want to reverse a fixed
component, you must change the type of constraint, for example from mate to align constraint.

Pro/ENGINEER saves joint connection information in the assembly file, which means that the parent assembly inherits the joint connection definitions in a subassembly.

Checking Your Model

After you create your model, you should verify its motion. This tells you whether the connections you defined will produce the motion you envision. You can make your model move in these ways:

- Run an assembly analysis with the Mechanism > Connect command. This process is also known as connecting the assembly. If your assembly is already connected, running an assembly analysis does not move your mechanism.

- Drag a body interactively. Use dragging to study the general nature of how your mechanism can move and the extent to which bodies can be positioned. Use the options in the Drag dialog box to disable connections, glue bodies, and apply geometry constraints to obtain a specific configuration. You can then record these configurations as snapshots for later reference.

Adding Modeling Entities for Mechanism Design Kinematics

- Add servo motors—After you create your model and make sure the connections allow it to move correctly, you can add servo motors. Use servo motors to define the mechanism’s desired absolute motion. In Mechanism Design, you can apply servo motors to joint axes or geometric entities.

  Note: Servo motors were called Drivers in previous releases of Mechanism Design.

  Use servo motors in a kinematics-type study to specify position, velocity, or acceleration. A servo motor moves your model to satisfy the specified position, velocity, or acceleration requirements without regard for the forces needed or for interference between bodies.

  Because a servo motor defines the absolute rotational or translational motion of a joint axis, the joint axis loses the degree of freedom (DOF) associated with that motion.

- Create measures—If you want to measure position, velocity, or acceleration using the evaluation methods **Maximum**, **Minimum**, **Integral**, **Average**, **Root Mean Square**, or **At Time**, you must create the measure before you run the analysis.

Preparing for a Repeated Assembly or Kinematic Analysis

Here are a few things to do before you run a repeated assembly or kinematic analysis.

- Define initial position snapshot—If you want the kinematic analysis to begin with the parts in specific locations, use the Drag dialog box to record snapshots to use.
• **Create measures**—If you want to measure the position using the evaluation methods **Maximum, Minimum, Integral, Average, Root Mean Square**, or **At Time**, you must create the measure before you run the analysis.

**Running a Repeated Assembly or Kinematic Analysis**

You can run kinematic or repeated assembly analysis in Mechanism Design. When you run a kinematic or repeated assembly analysis, Mechanism Design simulates the motion of your mechanism. You can choose which servo motors to use in these types of analyses, and specify their start and end times during the analysis.

A kinematic or repeated assembly analysis is a series of assembly analyses. However, if Mechanism Design reaches a point during the analysis where it cannot successfully assemble the mechanism, it stops and asks if you want to continue. Depending on the settings you choose in the **Settings** dialog box, you can pause or continue an analysis upon failure while running.

Use a kinematic or repeated assembly analysis to follow the motion of your model as imposed by servo motors. You can choose which servo motors to use during an analysis, and specify their start and end times during the analysis. If you are only interested in the motion of a portion of your model, you can use the body-locking or connection-locking options on the **Preferences** tab of the **Analysis Definition** dialog box to eliminate some of the allowed degrees of freedom.

Kinematic and repeated assembly analyses are similar in their definition. However, there is one important difference. You can use a kinematic analysis to evaluate position, velocity, and acceleration of points or joint axes in your mechanism, whereas you are limited to position measurements with repeated assembly analyses. Because of this feature, any servo motor profiles that you define for a kinematic analysis must be differentiable.

**Saving and Viewing Repeated Assembly or Kinematic Analysis Results**

After you run a repeated assembly or kinematic analysis, there are several ways that you can use the results:

• **Save the results and check for interference**—You must save your analysis results as a playback file if you want to retrieve them in another session. Use the **Mechanism > Playback** command to open the **Playbacks** dialog box. Use the options to save, restore, remove, and export your analysis results. You can also play back the analysis on the **Playbacks** dialog box and check for interference.

• **View the data**—Use the **Mechanism > Measures** command to create and graph measures:
  
  o You can monitor the position of points and joint axes during a repeated assembly analysis by creating a position measure or separation measure using the **Mechanism > Measures** command. If you run a kinematic analysis, you can also measure the velocity or acceleration of points and joint axes. If the position measure is evaluated at each time step of the analysis, you can create and plot its change in value after running one or more analyses. If you want to use any of the other evaluation methods,
including **Maximum, Minimum, Integral, Average, Root Mean Square**, or **At Time**, you must create the measure before you run the analysis.

- You can plot the values of Pro/ENGINEER analysis features during the analysis.
- You can save the graph of measures to a table file.
- You can learn the DOF and number of redundancies in your model.

- **Create a trace curve**—After you run a kinematic analysis, you can use the results to generate a trace curve. Trace curves are a graphical representation of the motion of your mechanism, and can be used to create cam profiles, slot profiles, or Pro/ENGINEER datum curves.

- **Create a motion envelope**—You can save a motion envelope file that represents the volume swept by parts on your mechanism during a motion analysis. You can use the motion envelope file as a part in Pro/ENGINEER.

**Using Mechanism Dynamics**

**About Mechanism Design Dynamics**

If you have a Mechanism Dynamics Option license, you can study the effect that applied forces have on the motion of your mechanism. You must have a license for Mechanism Design in order to use Mechanism Dynamics Option. For more information on Pro/ENGINEER licenses, consult the PTC Help system.

Mechanism Dynamics includes several modeling entities that are not available in the kinematics-based version of Mechanism Design. These include springs, dampers, force/torque loads, and gravity. You can define motors in terms of the forces they apply, as well as in terms of their position, velocity, or acceleration. In addition to repeated assembly and kinematic analyses, you can run dynamic, static, and force balance analyses. You can also create measures to monitor the force on your connections and the velocity or acceleration of a point, vertex, or joint axis. You can determine whether or not impact occurred during an analysis, and use an impulse measure to quantify the change in momentum due to a collision. If you have programming knowledge and a Pro/TOOLKIT license, you can create custom loads. You can also combine the loads experienced by one of the bodies in your model during a dynamic analysis into a loadset and export it to Mechanica Structure. See the workflow illustration for a summary of the process you can use to study your mechanism with Mechanism Dynamics.

Because it must calculate the forces acting on a mechanism, a dynamic analysis requires body mass properties. If you have not assigned these in Pro/ENGINEER, use the **Mechanism > Mass Properties** command to assign mass properties to the parts in your mechanism.

If you create entities such as force motors, springs, dampers, force/torque loads, and gravity, in a session of Pro/ENGINEER with a Mechanism Dynamics Option license, and retrieve the model in another Pro/ENGINEER session without a Mechanism Dynamics Option license, the software ignores the dynamics modeling entities.
There are two tutorials to help you become familiar with Mechanism Design Dynamics. The first tutorial shows you how to add a cam-follower connection, a spring, and a damper to an assembly. You will run a dynamics analysis, and measure the force on the spring and damper during the analysis. The second tutorial guides you through the creation of user-defined measures.

**Mechanism Dynamics Workflow**

| Creating your model | Define bodies.  
|                     | Assign mass properties.  
|                     | Make connections.  
|                     | Define joint axis settings.  
|                     | Make special connections.  
| Checking your model | Drag your assembly.  
| Adding modeling entities | Apply servo motors.  
|                     | Apply springs.  
|                     | Apply dampers.  
|                     | Apply force motors.  
|                     | Define force/torque loads.  
|                     | Define gravity.  
| Analyzing your model | Run a kinematic analysis.  
|                     | Run a dynamic analysis.  
|                     | Run a static analysis.  
|                     | Run a force balance analysis.  
|                     | Run a repeated assembly analysis.  
| Getting results | Play back results.  
|                     | Check for interference.  
|                     | View defined and dynamics measures.  |
Create trace curves and motion envelopes.
Create loadset for transfer to Mechanica Structure

Creating a Model for Mechanism Dynamics

Creating a model for Mechanism Dynamics analyses includes these tasks:

- **Define the bodies in your model**—A body is a group of parts that are rigidly controlled, with no degrees of freedom within the group. If two parts have a Pro/ENGINEER constraint between them, they are part of the same body. You can only place Mechanism Design connections between two distinct bodies. If a mechanism is not moving the way you expect, or if you are not able to create connections because two parts are in the same body, you may need to redefine the bodies in your mechanism. When you redefine bodies in Mechanism Design, you remove the Pro/ENGINEER constraints so that you can replace them with connections using the Pro/ENGINEER Insert > Component > Assemble command.

  Mechanism Design connections include joints, cam-follower connections, slot-follower connections, and gear pair connections.

- **Assign mass properties**—You must assign mass properties to your mechanism before you run a dynamic or static analysis. You must also assign mass properties before you run a force balance analysis if you want to include gravity in the analysis. If you have not assigned the mass properties in Pro/ENGINEER, you can do it in Mechanism Design by using the Mechanism > Mass Properties command.

- **Assemble your model with joint connections**—You assemble a mechanism by adding components to an assembly using joint connections in the same way you add components to an assembly using placement constraints. Connections define how the components move with respect to each other. Use the Pro/ENGINEER Insert > Component > Assemble command to add joints to your mechanism.

  **Note:** A component in Pro/ENGINEER Assembly mode refers to parts and subassemblies. A body is a Mechanism Design term that refers to a single part or two or more parts joined by a Pro/ENGINEER non-joint-type constraint.

- **Specify parameters for the connections**—After you add connections, you can use the Joint Axis Settings dialog box to define zero references, a regeneration value for the software to use when it assembles the model, and limits on the allowed motion of the connections.

- **Create special connections**—You can use Mechanism Design to create cam-follower and slot-follower connections. You can create a cam-follower connection or slot-follower connection simply by selecting geometric entities on your model. You do not need to first create special cam geometry.
You can also use Mechanism Design to create kinematic gear pairs. You create gear pairs by selecting joint axes, and the gear pair connections constrain the relative velocity of the joint axes. You do not need to create special gear geometry.

- **Simulate impact**—You can define a coefficient of restitution for cam-follower connections, and slot-follower connections to simulate impact behavior upon contact. You can define a coefficient of restitution for joints with limits to simulate impact when they reach the limits.

- **Simulate friction**—You can define static and dynamic friction coefficients for cam-follower connections, slot-follower connections, and joint connections to simulate friction losses.

**Checking Your Model**

After you create your model, you should verify its motion. This tells you whether the connections you defined will produce the motion you envision. You can make your model move in these ways:

- Run an assembly analysis with the **Mechanism > Connect** command. This process is also known as connecting the assembly. If your assembly is already connected, running an assembly analysis does not move your mechanism.

- Drag a body interactively. Use dragging to study the general nature of how your mechanism can move and the extent to which bodies can be positioned. Use the options in the **Drag** dialog box to disable connections, glue bodies, and apply geometry constraints to obtain a specific configuration. You can then record these configurations as snapshots for later reference.

**Adding Modeling Entities for Mechanism Dynamics**

After you create your mechanism and make sure the connections allow it to move correctly, you can add any of the following modeling entities:

- **Servo Motors**—Use servo motors in Mechanism Dynamics when you know the relative motion of two bodies. You can also use servo motors to help you to determine the properties of a force motor that produces equivalent motion in your mechanism.

- **Force Motors**—Use force motors when you know how much force to apply to make your mechanism move.

- **Springs**—Use a spring to provide forces proportional to stretching. You can apply a spring to a joint axis or between two points.

- **Dampers**—Use a damper to remove energy from your mechanism's motion. A damper acts to slow down motion. You can apply a damper to a joint axis, to a slot-follower connection, or between two points.

- **Force/Torque Loads**—Use a force to act on a point in a specified direction, or a torque to act on a body. You can also define a point-to-point force. You can define the direction of forces and torques relative to ground, or relative to the body where the force/torque is applied.
• **Gravity**—Define an acceleration vector to simulate gravitational force acting on the entire mechanism in a specified direction.

**Using Servo Motors in Mechanism Dynamics**

You use servo motors in Mechanism Design to impose motion on a model. You define a servo motor as the position, velocity, or acceleration of a joint axis or geometric entity as a function of time. You can use servo motors in Mechanism Dynamics to help you design your force motors.

• **Create the desired motion**—Use servo motors to generate the mechanism’s desired motion. Then run a repeated assembly analysis and use the **Playbacks** dialog box to check for interference.

• **Determine the size of force motors**—Use servo motors to find out how strong a force motor you need if you know in advance the mechanism's ideal motion.

You can find the force needed to run the mechanism as follows:

  o Create a servo motor that produces the desired motion.

  o Run a dynamic analysis, and save the results.

  o Create a measure for the load reaction at the servo motor, and graph the measure with the results from the dynamic analysis. This gives you an idea of the force needed to run the mechanism.

• **Lock the mechanism**—Create a zero-position servo motor to lock the joint, this enables you to find out the force required to hold that position.

If you apply both loads and servo motors to a mechanism, the servo motors will determine the mechanism's motion, but you can still obtain reaction data from the loads.

**Preparing for Analyses in Mechanism Dynamics**

Here are a few things to check before you run an analysis in Mechanism Dynamics.

• **Drag interactively**—You can check the motion by dragging your model. You can observe the motion allowed by any of the joints, cam-follower connections, slot-follower connections, or gear pair connections. Mechanism Dynamics modeling entities such as springs, dampers, force motors, force/torque loads, and gravity do not affect the dragging action.

• **Define initial conditions**—You can define the initial velocity for points, bodies, joint axes, and slot-follower connections with the command **Mechanism > Initial Conditions**. Use initial conditions to specify the velocity of an entity at the start of an analysis. You can define the initial position of the bodies in your mechanism by referencing snapshots. Use the **Drag** dialog box to specify the location of the bodies in your model at the start of an analysis.

• **Connect the assembly**—Run an assembly analysis to connect the mechanism with the defined tolerance settings. If Mechanism Design cannot connect the assembly, you can either rerun it at a higher tolerance, or redefine the connections.
Create measures—If you want to obtain a measure using the evaluation methods Maximum, Minimum, Integral, Average, Root Mean Square, or At Time, you must create the measure before you run the analysis.

Running Analyses in Mechanism Dynamics

You can run the following analyses if you have a Mechanism Dynamics Option license:

- **Kinematic**—Use a kinematic analysis to follow the motion of your model as imposed by servo motors. You can choose which servo motors to use during an analysis, and specify their start and end times during the analysis. If you are only interested in the motion of a portion of your model, you can use the body-locking or connection-locking options on the Preferences tab of the Analysis Definition dialog box to eliminate some of the allowed degrees of freedom. You can use a kinematic analysis to evaluate position, velocity, and acceleration of points or joint axes in your mechanism.

- **Dynamic**—Use a dynamic analysis to analyze the motion generated by applied loads, servo and force motors, and gravity. You can turn force motors on and off during a dynamic analysis, but servo motors, if included, are active for the duration of the analysis. Mechanism Dynamics does not include geometric servo motors in dynamic analysis.

  Be aware that the software does not use the information you enter on the Preferences tab of the Analysis Definition dialog box to calculate time intervals for a dynamic analysis. These values only change the graphical display. To change the accuracy of the dynamic analysis, use the Settings command.

- **Static**—Use a static analysis to find the stable, equilibrium position for your mechanism. You can use this analysis to find a stable configuration before setting your mechanism in motion.

- **Force Balance**—Use a force balance analysis when you want to find the balancing force necessary for your model to remain motionless. This analysis is useful if your model contains applied forces, and you want to bring it to a static equilibrium state. After you run this analysis, you can obtain the magnitude of a force applied at a specified point that will keep your mechanism motionless. You can also obtain the connection or motor reaction force necessary to maintain an equilibrium state.

- **Repeated Assembly**—Use a repeated assembly analysis to determine whether your mechanism can assemble under the requirements of the applied servo motors and connections. You can specify which servo motors are active, and their start and stop times. You can also lock bodies or connections. You might use a repeated assembly analysis as a first step in your design process, to locate interference or points where the assembly analysis fails.

Saving and Viewing Analysis Results in Mechanism Dynamics

After you run an analysis in Mechanism Dynamics, there are several ways that you can use the results:
• **Save the results and check the interference**—You must save your analysis results as a playback file if you want to run them in another session. Use the **Mechanism > Playback** command to open the **Playbacks** dialog box. Use the options to save, restore, remove, and export your analysis results. You can also play back the analysis on the **Playbacks** dialog box and check for interference.

• **View the data**—Use the **Mechanism > Measures** command to create and graph measures:
  
  o You can create several types of measures to help you understand the data from your Mechanism Dynamics analyses. The type of measure you can create depends upon the type of analysis you run. If the measure you create is evaluated at each time step of the analysis, you can create and plot its change in value after running one or more analyses. If you want to use any of the other evaluation methods, including **Maximum**, **Minimum**, **Integral**, **Average**, **Root Mean Square**, or **At Time**, you must create the measure before you run the analysis.
  
  o You can plot the values of Pro/ENGINEER analysis features during the analysis.
  
  o You can save the graph of measures to a table.
  
  o You can learn the DOF and number of redundancies in your model.

• **Create a trace curve**—After you run an analysis, you can use the results to generate a trace curve, using the **Mechanism > Trace Curve** command. Trace curves are a graphical representation of the motion of your mechanism, and can be used to create cam profiles, slot profiles, or Pro/ENGINEER datum curves.

• **Create a motion envelope**—You can save a motion envelope file that represents the volume swept by parts on your mechanism during a motion analysis. You can use the motion envelope file as a part in Pro/ENGINEER.

• **Create a load set to transfer to Mechanica Structure**—After you run an analysis, use the **Mechanism > Use in Structure** command to save the inertial, gravitational, and reaction forces experienced by a body in your mechanism in a load set that you can open and use for a structural analysis.

**Mechanism Design Settings**

**About Settings**

Use the **Settings** command to specify the tolerance that Mechanism Design uses to assemble your mechanism, and to specify the action that Mechanism Design takes when an analysis run fails.

You can also use the tolerance setting to help fix a failed assembly, or when running a dynamic analysis.

When you select the **Edit > Settings** command, the **Settings** dialog box appears. This dialog box includes the following areas:
• **Relative Tolerance**—Select **Default**, or enter a value. The relative tolerance is the multiplier that Mechanism Design uses to scale the characteristic length to derive the absolute tolerance. The default value is 0.001, which represents 0.1% of the characteristic length of your model.

• **Characteristic Length**—Select **Default**, or enter a value. The characteristic length is the sum of all the part lengths divided by the number of parts. A part’s length (or size) is the length of the diagonal of the bounding box that contains the part completely.

The absolute assembly tolerance is the maximum amount that any mechanism position constraint can deviate from a perfectly assembled state. The absolute tolerance is derived from the product of the relative tolerance and the characteristic length.

The formula for absolute tolerance is:

\[
\text{absolute tolerance} = \text{relative tolerance} \times \text{characteristic length}
\]

If you have a mechanism with significant variance in the parts' sizes, or have results that seem incorrect, you may need to change at least one of the settings. If the characteristic length is not representative of the mechanism's moving parts, consider changing the characteristic length. For example, if you are interested in the motion of a small body in a large assembly, change the characteristic length to be closer to that of the smaller body. Otherwise, adjust the relative tolerance.

• **Assembly Failure**—Select the **Issue Warning Upon Failure** check box to receive a warning message whenever the mechanism fails to connect.

• **Run Preferences**—Select **Graphical Display During Run** to have your mechanism display an update as you run an analysis. If you clear this check box, the display does not change, and the calculation is faster relative to the calculation with the graphical display on.

• **Failure Action**—Select **Pause** or **Continue** to choose the action that Mechanism Design takes when an analysis fails. If you select **Pause**, and your mechanism fails to assemble during a run, a dialog box appears that allows you to terminate or continue the analysis, and to choose whether to view further warnings if the analysis fails again. You cannot continue a dynamic run when it fails.

**To Define Settings**

You can change the absolute tolerance by changing the relative tolerance or the characteristic length, or both.

1. Click **Edit > Settings** or ![Settings Icon](image). The **Settings** dialog box appears.

2. If you want to change the **Relative Tolerance** setting for your assembly, clear the check box and enter a value between $10^{-10}$ and 0.1. The default value of 0.001 is usually satisfactory.
3. If you want to change the **Characteristic Length** setting, clear the check box and enter a different value. You should consider changing this setting when the largest part is much larger than the smallest part.

4. Clear the **Assembly Failure** check box if you do not want Mechanism Design to warn you should the assembly fail.

5. Clear the **Graphical display during run** check box in the **Run Preferences** area to improve run performance by turning off the graphical display during the analysis run.

6. Select one of the options under **Failure Action**:

   - Click **Continue** to continue your analysis upon failure while running.
   - Click **Pause** if you want Mechanism Design to stop when your analysis fails, and to offer you the opportunity to terminate or continue.

7. Click **OK**.

### About Icon Visibilities

You can use **View > Display Settings > Mechanism Display** to open the **Display Entities** dialog box. The **Display Entities** dialog box has the following selections that you can turn on and off. The display setting you use persists while switching between Assembly and Mechanism modes with the same model.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Servo Motors</td>
<td>Force Motors</td>
</tr>
<tr>
<td>Joints</td>
<td>Slots</td>
</tr>
<tr>
<td>Cams</td>
<td>Gears</td>
</tr>
<tr>
<td>Gears</td>
<td>Springs</td>
</tr>
<tr>
<td>Dampers</td>
<td>Forces/Torques</td>
</tr>
<tr>
<td>LCS</td>
<td></td>
</tr>
</tbody>
</table>

All icons except LCS are visible by default. After you turn a visibility off, that icon is still visible under the following conditions:
• If any of the entities, such as servo motors, force motors, slots, cams, gears, springs, dampers, or forces/torques is active, its icon becomes visible when you open the corresponding dialog box.

• All joint icons are visible:
  o while the **Joint Axis Settings** dialog box is open
  o when you select **Joint Axis** as a **Driven Entity** on the **Servo Motor Definition** dialog box
  o when you click ![icon] to set the initial velocity for a joint on the **Initial Conditions** dialog box
  o while you are setting the connection status during a dragging operation
  o when you select **Joint Axis** as a **Reference Type** for dampers, springs, or force motors
  o when you click ![icon] to lock a joint on the **Analysis Definition** dialog box

• All slot icons are visible:
  o when you select **Slot** as a **Reference Type** for dampers
  o when you click ![icon] to set the initial velocity for a slot-follower connection on the **Initial Conditions** dialog box

• The current local coordinate system (LCS) is visible:
  o while you perform a dragging operation
  o while you create or edit a force/torque or initial conditions with direction of typed vector
  o while defining a loadcell constraint for a force balance analysis

**To Set Icon Visibilities**

The following steps outline the process of turning the Mechanism Design icons on and off for viewing.

1. Use **View > Display Settings > Mechanism Display** or click ![icon] to open the **Display Entities** dialog box.

2. Turn on the icons that you want to be visible. Your choices are the following:
  o Servo Motors
  o Force Motors
  o Joints
  o Slots
  o Cams
o Gears
o Springs
o Dampers
o Forces/Torques
o LCS

3. If you do not want icons to be visible, you can turn off icon visibilities that are on by default or that have been turned on previously.

4. If you want all the icons to be visible, click 📚.

5. If you do not want any of the icons to be visible, click 📚.

**Initial Conditions**

**About Initial Conditions**

Use the **Mechanism > Initial Conditions** command to define initial conditions. You can define initial conditions for your mechanism if you have a Mechanism Dynamics Option license.

Initial conditions are position and velocity settings you assign the mechanism to use for a dynamic analysis.

You can specify that an initial condition does the following:

- **Position Initial Condition**—Makes sure an analysis starts from a specific position. By default, each analysis starts with the mechanism displayed as the current screen position—the current orientation of the bodies as you see them on the screen. You can use initial conditions to establish a consistent starting configuration for each analysis.

  To reference initial position, Mechanism Design uses a snapshot. The snapshot captures the configuration of existing locked bodies and geometric constraints to define position constraints.

- **Velocity Initial Condition**—Starts the analysis at a particular velocity. Mechanism Design allows you to define point, joint axis, angular, and tangential slot velocity settings.

  For example, if you are modeling a car, you might want—at the start of the analysis—to analyze it moving at 65 mph. Another example of velocity initial condition would be the body angular velocity in deg/sec of a door closing.

The **Mechanism > Initial Conditions** command opens a finder dialog box, which you can use to create, edit, copy, or delete your initial conditions. The dialog box also displays the names of previously created initial conditions.

Before defining your initial conditions, you may want to review some tips on how to use initial conditions effectively. You can also refer to information on position initial conditions for joint axis in drag.
About the Initial Condition Definition Dialog Box

Use this dialog box to create a new initial condition or edit an existing one. To access this dialog box, click Mechanism > Initial Conditions. When the Initial Conditions dialog box appears, click New or Edit.

The Initial Condition Definition dialog box includes the following items:

- **Snapshot**—A snapshot defines the positions of all bodies in your assembly for an initial condition. Make a selection from Current Screen—the orientation of the bodies on the screen at the time the analysis run starts—or previously created snapshots.

- **Velocity**—Use the appropriate option to define the type of velocity initial condition you are interested in and to select a reference entity:
  
  o Click to define the linear velocity at a point or vertex. Select a point or vertex as a reference entity, and define the magnitude (in unit length/sec) and direction of the vector.
  
  o Click to define the rotational or translational velocity of a joint axis. Select a joint axis as a reference analyses and enter the magnitude (in unit length/sec or deg/sec).
  
  o Click to define the angular displacement of the body along the defined vector. Select a body as a reference entity. Enter the magnitude (in deg/sec) and direction of the vector.
  
  o Click to define the initial tangential velocity of the follower point relative to the slot curve. Select a slot-follower connection as a reference entity, and enter a magnitude (in unit length/sec). Use Flip to point the vector in the correct direction.

The velocity icon area displays two additional buttons. With these, you can do the following:

  o Click to evaluate the model with velocity constraints.
  
  o Click to delete highlighted constraints.

You can enable and disable the velocity initial condition using the check box to the left of the condition.

After you select the reference entity, the dialog box expands to display Magnitude and Direction. Use these to define the vector:

- **Magnitude**—Use this area to enter the magnitude for the velocity vector.
- **Direction**—Use this area to choose a direction for the velocity vector.

To Create an Initial Condition
1. Click **Mechanism > Initial Conditions** or \( \text{Initial Conditions} \) dialog box appears.

2. Click **New**. The **Initial Condition Definition** dialog box appears.

3. Enter a new name for the initial condition in the entry box or use the default name (InitCond\(n\)).

4. Accept the **Current Screen** default in the **Snapshot** area or choose a previously created snapshot from the drop-down menu.

5. Define the velocity by clicking one of the following buttons:
   - Click \( \text{Point Velocity} \) to specify point velocity.
   - Click \( \text{Joint Axis Velocity} \) to specify joint axis velocity.
   - Click \( \text{Angular Velocity} \) to specify angular velocity.
   - Click \( \text{Tangential Slot Velocity} \) to specify tangential slot velocity.

6. Use the normal selection methods to select a reference entity from the model. Choose a point, joint axis, vertex, part, or slot-follower connection, depending on the icon selected. If valid, the list area displays the velocity type.

7. Specify the **Magnitude** in the current unit for the velocity vector.

8. For Point **Velocity** and **Angular Velocity**, specify the **Direction** of the velocity vector.

9. Use the check box to the left of the velocity type to enable or disable it.

10. Click \( \text{Compatibility} \) to determine the compatibility and validity of the initial conditions.

11. Click **OK**.

**To Edit an Initial Condition**

1. To edit an initial condition, click **Mechanism > Initial Conditions** or \( \text{Initial Conditions} \) dialog box appears.

2. Select an initial condition set from the list.

3. Click **Edit**. The **Initial Condition Definition** dialog box appears.

4. Select a velocity initial condition in the list box. Mechanism Design highlights the corresponding reference entities on the body.

5. Add or remove a velocity initial condition or change any of the following items:
   - **Snapshot**
   - **Magnitude**
6. If you want to disable an initial condition, clear the check box to the left of the velocity condition.

7. Click OK to save the modified initial condition specifications.

8. To revert to the previously saved initial conditions definition, click Cancel while editing the initial condition.

Specifying the Direction of the Velocity Vector

Use the Direction field on the Initial Conditions Definition dialog box to specify the direction for the velocity vector you are applying. Select one of these options:

- **Typed Vector**—A typed vector is a vector defining direction in three dimensions that you can specify with a Cartesian set of axes x, y, and z. Choose a body and enter coordinates to indicate the direction of the vector. The direction is relative to the origin of the selected body coordinate system. You can select the WCS or a body coordinate system.

- **Straight Edge, Curve, or Axis**—Select a straight edge, a curve, or a datum axis in the assembly to define the direction of the velocity vector.

- **Point-to-Point**—Select two body points or vertices, one for the origin of the vector and another to indicate the direction. If one of the two selected points is not a point, to which you are applying the initial condition, then the velocity vector is parallel to the line between the two points.

A direction arrow displays the direction of the velocity vector. Use the Flip button if you want to reverse the direction of the vector for Point-to-Point or Straight Edge, Curve, or Axis.

**Tip: Using Initial Conditions**

Keep these points in mind when using initial conditions:

- Before using an initial condition in an analysis, always check the validity of the initial condition. Make sure that the initial conditions you create are physically possible and do not conflict with each other. For example, if you set initial conditions on the orientation of two parts that are connected with a joint, be sure that the required body positions are possible with the DOF allowed by the joint.

- Exceptions to the screen start position occur, in an analysis, if you add activated servo motors to your model. The initial position defined by the servo motor overrides the screen start position when the analysis begins.

- When defining angular velocity initial conditions, select a vector that does not conflict with any rotational joint axis connections. The axis of rotation is parallel to the specified vector, depending on the degree of freedom and how it is connected to the assembly.

- Angular velocity initial conditions are most useful for packaged components rather than for components with joint axis connections. Applying these initial conditions to components with joint axis connections will increase the likelihood
of inconsistency of the initial conditions set and the possibility of failure due to conflicts with other constraints.

- You specify initial positions for kinematic, static, and force balance analyses using the initial configuration snapshot in the analysis definition.

See Incompatible Initial Conditions for further clarification.

**Incompatible Initial Conditions**

When you click **OK** in the **Initial Condition Definition** dialog box, Mechanism Design performs a validation check, searching for, as some examples, duplicate names, the last selected velocity constraint, correct direction, vector location, and velocity constraints individually and as a group.

See Validation Checks for Initial Conditions for the specific sequencing of the diagnostic testing.

If the initial condition set has incompatible initial conditions, Mechanism Design displays an error message indicating that the velocity constraints could not be satisfied and the initial conditions are invalid.

Incompatible initial conditions can occur when:

- Initial conditions violate connection constraints.
- Initial conditions conflict with other initial conditions.

Some troubleshooting techniques include:

- For non-packaged components, putting the initial condition on the joint axis rather than on the body.
- After selecting a snapshot initial configuration, applying velocity initial conditions one at a time and clicking **OK** to check for conflicts.

**Finder Dialog Box**

A finder dialog box opens when you select certain modeling entities from the **Mechanism** menu. Use this dialog box to organize and control your force and servo motors, springs, dampers, force or torque loads, cam-follower connections, slot-follower connections, gear pairs, or initial conditions. The dialog box includes a list of the entities you have created in your model. You can use this form to add a new entity, edit an existing entity, copy an existing entity to a new name, or remove an existing entity from your model.

To get information on an entity in the list, place the cursor over the item's name without clicking. A message box appears with a summary of the parameters used to define the entity.

The finder form includes the following fields:

- **Name**—The default name is based on the entity type with a number appended. For example, the default name for the first spring you create will be **Spring1**. If you want to change the name, highlight it, and edit it.
It is a good idea to use more meaningful names to help you keep track of what you have created.

- **Status**
- **New**—Use this button to create one of the following types of entities:
  - Cam-follower connection
  - Slot-follower connection
  - Servo motor
  - Force motor
  - Gear pair
  - Spring
  - Damper
  - Force/torque load
  - Initial condition
- **Edit**—Use this button to change the definition of one of the following entities:
  - Cam-follower connection
  - Slot-follower connection
  - Servo motor
  - Force motor
  - Gear pair
  - Spring
  - Damper
  - Force/torque load
  - Initial condition
- **Copy**—Use this button to copy one of the entities in the list to a new name. This option is not available for cam-follower connections or slot-follower connections.
- **Delete**—Use this button to delete an entity from the model. You can also delete several entities at once. Hold the SHIFT key, highlight the entities, and press DELETE.

**Status**

The **Status** column on the finder dialog box gives current information on the part, assembly, or feature that the modeling entity references.

- **Suppressed**—The modeling entity references:
  - A part, assembly, or feature that is suppressed in Pro/ENGINEER.
A part, assembly, or feature in which the geometry is not included in the currently used simplified representation, family table, instance, or interchange assembly.

- **Incomplete**—The modeling entity references a part, assembly, or feature that you have changed or deleted.

You cannot edit the definition of a suppressed entity.

### Joint Axis Position in Drag

A dynamic analysis allows you to specify initial positions, using snapshots. You can specify an exact value for a joint axis initial configuration by using joint axis position constraints in the drag environment. The joint axis constraint defines the starting position of the bodies connected by the joint for a dynamic analysis. You can assign multiple constraints on the same joint axis. However, only one can be enabled at any given time.

To specify joint axis positions, click on the **Constraints** tab of the **Drag** dialog box. When you select a joint axis, the constraint is added to the **Type** list with a **Status** of **Enabled**. The **Value** box displays the current value of the joint axis in the current screen configuration. You can edit the value by highlighting the constraint in the list, entering the desired position value, and pressing the ENTER key. You can specify a positive or negative value.

If you want to save a constraint, take a snapshot to save the configuration of the mechanism with specified constraints. The snapshot lists the constraints associated with it. Constraints are defined in the context of the snapshot. If a snapshot is not saved, the constraints are not saved.

When changing the name or updating a snapshot to the current configuration, remember to update by clicking .

### To Specify Joint Axis Position for Initial Conditions Using the Drag Dialog Box

1. Click **Mechanism > Drag** or . The **Drag** dialog box opens to the **Snapshots** tab.

2. On the **Snapshots** tab, choose one of the following:

   - Select a previously created snapshot from the list.
   - Use the current screen configuration.
   - Drag the bodies to the desired configuration.

3. Click the **Constraints** tab.

4. Click . Use the normal selection methods to select a joint axis. The **Status** column now indicates that the condition is enabled.

**Note:** Use if you want to change the **Status** of a constraint to **Disabled**.
5. To change the position, do the following:
   a. Select and highlight the constraint in the **Type** list window.
   b. Select and highlight the value in the **Value** entry box and enter a positive
      or negative numerical value.
   c. Press ENTER. The position of the joint axis changes to the value you
      entered.

6. If you want to save the configuration with this joint axis constraint, click
   ![Snapshot](image). Mechanism Design creates a new snapshot with an incremented number on the
   **Snapshots** tab. You can modify or accept the default name.

7. If the mechanism constraint cannot be satisfied, an **Error Assembly Failed**
   message appears. Click **Undo** to retry or **Continue** to continue making changes
   with the mechanism unassembled.

**Validation Checks for Initial Conditions**

When you click **OK** in the **Initial Condition Definition** dialog box, Mechanism
Design performs the following validation checks in the order shown:

1. **Validate name**—Checks if there are any other initial conditions with the same
   name.

2. **Validate the inputs of the last selected velocity constraint**—Checks if the
   direction is entered correctly, for example, if the entered vector is not equal to
   (0, 0, 0), if an edge selection is valid, if point-to-point selections are valid.
   This validation check is usually done when you select another velocity constraint,
   but since this is the last operation in the dialog box, you can also perform this
   check at this juncture.

3. **Validate all velocity constraints**—Checks if the selection is valid, for example,
   a valid point if you are specifying point velocity.

4. **Run a velocity analysis in the engine**—Checks that the velocity constraints
   are valid as a group.

**Mass Properties**

**About Mass Properties**

To be able to run dynamic and static analyses in Mechanism Dynamics, you need to
assign mass properties for your mechanism. You can specify mass properties in
either Pro/ENGINEER or Mechanism Dynamics. If you have not assigned the mass
properties in Pro/ENGINEER, you can do it in Mechanism Dynamics by using the
**Mechanism > Mass Properties** command.

Mass properties determine how your mechanism resists any change in its speed or
position upon the application of a force. The mass properties of a mechanism consist
of its density, volume, mass, center of gravity, and moment of inertia. When you
select the **Mechanism > Mass Properties** command, the **Mass Properties** dialog
box appears, which enables you to select a part, an assembly, or a body to specify or review its mass properties.

- For a part, you can specify its mass, center of gravity, and inertia. If the part has non-zero volume, you can specify its density, and Mechanism Dynamics calculates the mass accordingly.
- For an assembly, you can only specify its density for the mass to be calculated.
- If you select a body, you are only able to review its mass properties, but you cannot edit them.

Mass property information that you define in Mechanism Dynamics is valid only in Mechanism Dynamics and overrides Pro/ENGINEER mass definitions within any Mechanism Dynamics session.

You can view your mechanism's mass property information by clicking Info > Mechanism > Mass Properties. The Pro/ENGINEER embedded browser opens with a file containing the information.

**Mass Properties Dialog Box**

Use this dialog box to specify mass properties for your mechanism or to review mass properties assigned in Pro/ENGINEER. To access this dialog box, click Mechanism > Mass Properties.

The following fields on the dialog box allow you to select the type of mechanism for which you specify or review mass properties. They also allow you to select the method that you use to specify them.

- **Reference Type**—Use to select one of the following entities from the drop-down menu:
  - **Part**—You can select any part in the assembly, including component parts of subassemblies, to specify or review its mass properties.
  - **Assembly**—You can select a component subassembly or a top-level assembly from the model window or from the Model Tree. Mechanism Dynamics allows you to assign mass properties or edit existing ones.
  - **Body**—Mechanism Dynamics does not allow you to edit mass properties of the selected body. You can only review them.

- **Define Properties by**—Use to select a method to define the mass properties. Based on the previous selection of the reference type, your options change.
  - **Default**—This option is available to all three of the reference types. If you select this option, all input fields remain inactive. The dialog box displays mass property values based on the density or mass properties file defined in Pro/ENGINEER. If neither density nor mass properties have been assigned to the model in Pro/ENGINEER, Mechanism Dynamics displays the default values.
  - **Density**—This option is available if you have selected a part or an assembly as the reference type. Use this option to define mass properties by density. Because density is the ratio of the mechanism's mass to its volume, you
can only select a part or an assembly with a volume greater than zero. When you select this option, all input fields except **Density** remain inactive.

- **Mass Properties**—This option is only available if you have selected a part as the reference type. Using this option, you can define mass, center of gravity, and moment of inertia.

- **Coordinate System**—Use to select a coordinate system for the part or body. This option is not available if you select an assembly as the reference type.

Depending on your previous selections, the aspect of the dialog box changes. If you have selected a body as the reference type, the following items remain inactive and you can only review them. If your selection is an assembly, you can only see the **Density** field on the dialog box. When you change the entries in any of the following fields, Mechanism Dynamics automatically updates the values that are dependent on the value you have changed.

- **Density**—Use this field to enter a density value for the selected part or assembly when you define mass by the density.

- **Volume**—This field displays the volume of the selected mechanism. You cannot edit the entry.

- **Mass**—Use this field to enter a mass value for the selected part when defining its mass by the mass properties.

- **Center of Gravity**—Use this field to define the location of the center of gravity with respect to a specified coordinate system. Center of gravity is an imaginary point in the mechanism where, for convenience in certain calculations, the total mass of the mechanism may be thought to be concentrated.

- **Inertia**—Use this area to calculate the moment of inertia. Moment of inertia is a quantitative measure of the rotational inertia of the mechanism—in other words, the tendency of a body rotating about a fixed axis to resist a change in this rotating motion. You can select one of the following locations for the axis about which the selected mechanism rotates:
  - **At Coordinate System Origin**—Measures the moment of inertia relative to the current coordinate system.
  - **At Center of Gravity**—Measures the moment of inertia relative to the principal inertial axis of the mechanism.

**To Specify Mass Properties of a Part**

1. Click **Mechanism > Mass Properties** or ![Mass Properties](image). The **Mass Properties** dialog box appears.

2. Select **Part** from the drop-down menu.

3. Click ![Select](image) and select a part on the model. For information on the Pro/ENGINEER selection methods, search the PTC Help system.

4. From the **Define Properties by** menu, select one of the following methods:
5. Select a coordinate system.

6. If you are defining mass properties by the density, follow these steps:
   a. Enter a value in the **Density** field.
   b. In the **Inertia** field, select the moment of inertia relative to either the current coordinate system or the center of gravity.
   c. Click **Apply**. Mechanism Design updates the mass and the moment of inertia values.

7. If you have selected **Mass Properties** from the **Define Properties by** menu, follow these steps:
   a. Enter a value in the **Mass** field.
   b. In the **Center of Gravity** field, enter the coordinates for the location of the center of gravity.
   c. Modify moment of inertia values in the **Inertia** field.
   d. Click **Apply**.

8. Click **OK** to close the dialog box.

**To Specify Mass Properties of an Assembly**

1. Click **Mechanism > Mass Properties** or 
   The **Mass Properties** dialog box appears.

2. Select **Assembly** from the drop-down menu.

3. Click 
   and select an assembly on the model. For information on the Pro/ENGINEER selection methods, search the PTC Help system.

4. From the **Define Properties by** menu, select one of the following methods:
   o **Default**
   o **Density**

5. Click 
   and select a coordinate system on the model.

6. If you are defining the mass properties by the density, enter a value in the **Density** field.

7. Click **OK** to close the dialog box.

**Inertia**
In Mechanism Dynamics, a moment of inertia is one of the mass properties of a mechanism, describing its resistance to changes in rotational acceleration. The moment of inertia is expressed as the integral over the body's volume of its density, multiplied by the square of the distance to the axis. The axis could be located at either coordinate system origin or at the mechanism's center of gravity. The Inertia area of the Mass Properties dialog box has six fields, in which you can enter values for the various possible moments of inertia.

- **Ixx**—Enter the value for the moment of inertia aligned with the local X axis.
- **Iyy**—Enter the value for the moment of inertia aligned with the local Y axis.
- **Izz**—Enter the value for the moment of inertia aligned with the local Z axis.
- **Ixy**—Enter the value for the moment of inertia aligned with the local X and Y axes.
- **Ixz**—Enter the value for the moment of inertia aligned with the local X and Z axes.
- **Iyz**—Enter the value for the moment of inertia aligned with the local Y and Z axes.

### Joint Connections

#### About Joint Connections

You use the **Connect** tab on the **Component Placement** dialog box to specify the joint connection type that Mechanism Design uses to place a component in an assembly.

Joint connections serve three purposes:

- To define which placement constraints Mechanism Design uses to place the component in the model
- To restrict the motion of bodies relative to each other, reducing the total possible degrees of freedom (DOF) of the system
- To define the kind of motion a component can have within the mechanism

The main assembly inherits all connection, motor, spring, damper, slot, and cam definitions from the new subassembly, except for ground body and motion definitions.

Before selecting a joint, you should understand how Mechanism Design uses placement constraints and degrees of freedom in defining movement. Use this information to select the right joints for the way you want your mechanism to move.

Each joint type is associated with a unique set of geometric constraints, such as points and datum axes. These constraints are based on existing constraints used in Pro/ENGINEER Assembly mode. If you convert your Assembly model into a Mechanism model, the software applies implied connections determined by the constraints you placed. Conversely, after you define a model in Mechanism Design, it
behaves the same way as any other model in Pro/ENGINEER Assembly mode, except that the components are not fully constrained. These components are connected and not considered packaged.

The set of constraints for each joint type is associated with specific DOF. DOF define the allowed motion of a mechanical system in terms of translation and rotation.

Joint connections differ from the traditional Pro/ASSEMBLY approach. The primary differences are summarized below:

- The types of allowable placement constraints depend on the type of joint being created. For example, a pin joint allows rotation about the axis you select in the joint definition.

- Multiple placement constraints are grouped together to define single connections. For example, rigid joints enable you to group a valid set of placement constraints in a single joint.

- The placement constraints defined do not fully constrain the model except in the case of rigid connections. Based on the type of joint, the component is allowed to move in specific ways.

- Multiple connections can be added to a component. This is how you could close a loop in your system. The first connection is used to place the component and the second connection is referred to as the loop connection.

You can use the **View > Display Settings** > Mechanism Display command to turn on or off the display of connection icons in your mechanism.

**To Add a Component with Joint Connections**

When you add a component to the current assembly using connections, you define the type of movement you are allowing the assembled parts to make.

1. Click **Insert > Component > Assemble**. The **Open** dialog box appears.

2. Select or enter the name of the component you want to add to the assembly.

3. Click **Open**. The **Component Placement** dialog box appears. The component appears in the assembly window.

4. If you want the component to appear in a separate window, click ![Separate Window Icon]

5. Click the **Connections** tab.

6. A default name, _Connection_n_, appears in the **Connections** list. If you want to change the name, highlight the connection name and edit it.

7. Under **Type**, double-click and select the type of joint you want to use to connect the component to the assembly.

8. If you chose **Rigid, General, or Weld**, perform the following steps:

   a. Choose how you want the joint constrained by selecting a **Constraint Type**. If you chose **Weld**, you can only constrain a coordinate system to a coordinate system.
b. Select a reference on the component and a reference on the assembly, in either order, to define the placement constraint.

For additional information about the constraint types, see the information for the Component Placement dialog box in the PTC Help system.

9. If you chose any other type of joint, Pro/ENGINEER displays the appropriate constraints for you to define. As you do so, Pro/ENGINEER automatically updates the status column in the Constraints box corresponding to the constraint. If you have chosen Assembly from the Display Component In box, the component moves within the model window to reflect the constraint.

As you add constraints to the joint, the Placement Status window is updated to indicate whether the joint is completely constrained.

10. Add as many joints as necessary to place the component in the assembly.

11. Click OK to accept the joint connection and close the Component Placement dialog box.

Note: If you click Cancel, Pro/ENGINEER cancels the operation and deletes the component from the assembly.

When you accept the joint connections and close the dialog box, the software runs a connect analysis verifying that the connections are valid.

Types of Constraints Required for Joints

The following table shows the geometric constraints required to define each joint connection type:

<table>
<thead>
<tr>
<th>Joint Type</th>
<th>Constraints Required</th>
<th>Available Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ball</td>
<td>Point alignment to point</td>
<td></td>
</tr>
<tr>
<td>Bearing</td>
<td>Point alignment to edge or axis</td>
<td></td>
</tr>
<tr>
<td>Cylinder</td>
<td>Axis alignment</td>
<td>Flip</td>
</tr>
<tr>
<td>Pin</td>
<td>Axis alignment</td>
<td>Flip mate/align</td>
</tr>
<tr>
<td></td>
<td>Planar mate/align or point alignment</td>
<td>Offset of planar mate/align</td>
</tr>
<tr>
<td>Planar</td>
<td>Plane alignment</td>
<td>Offset of planes</td>
</tr>
<tr>
<td>Rigid</td>
<td>One or more constraints</td>
<td></td>
</tr>
<tr>
<td>Slider</td>
<td>Axis alignment</td>
<td>Flip mate/align</td>
</tr>
<tr>
<td></td>
<td>Planar mate/align to restrict rotation along axis</td>
<td></td>
</tr>
</tbody>
</table>
## Weld Coordinate system alignment

<table>
<thead>
<tr>
<th>General*</th>
<th>One or two constraints</th>
</tr>
</thead>
<tbody>
<tr>
<td>6DOF</td>
<td>Coordinate system alignment, but no constraints</td>
</tr>
</tbody>
</table>

* Rigid and general connections allow you to choose any valid placement constraint you want to include. This flexibility enables you to build a connection with a number of the Pro/ENGINEER constraints under one category.

Note, however, that you cannot use the following constraints when defining a general connection:

- Tangency constraint
- Point on a curve
- Point on a nonplanar surface

In addition, Mechanism Design does not allow combinations of constraints that result in non-orthogonal degrees of freedom.

### Comparing Rigid and Weld Joints

When you want to connect two components so they do not move relative to one another, you can select from either a rigid or weld joint. These joints appear similar—they both glue the two components together. However, the underlying connection definitions make it important to use the two joints in the correct circumstances.

- Rigid joints enable you to group any valid set of assembly constraints into a joint type. These constraints can be a fully constrained set or a partially constrained subset that leaves the assembled component packaged.
- Rigid joints can be used when assembling a part, a subassembly that does not contain connections, or a component attached to different bodies.
- Weld joints behave similar to other joint types. However, the placement of the part or subassembly is fixed by aligning coordinate systems. A weld joint enables Mechanism Design to adjust open degrees of freedom in the subassembly.
- Weld joints should be used when assembling a subassembly that contains connections but requires multiple connections to the same body. The weld connection enables the component to be adjusted based on the open DOF to fit the master assembly.
- If you use a rigid joint to assemble a subassembly with Mechanism Design connections to a master assembly, the subassembly connections lose their motion. If you use a weld connection to assemble a subassembly with Mechanism Design connections to a master assembly, the subassembly references the same coordinate system as the master assembly, and its subassembly motion will still be active.

### Degrees of Freedom
Understanding degrees of freedom is critical to selecting the appropriate joints for your mechanism. In mechanical systems, the number of degrees of freedom (DOF) represents the number of independent parameters required to specify the position or motion of every body in the system.

Joint connections act as constraints, or restrictions on the motion of bodies relative to each other, reducing the total possible degrees of freedom of the system.

For example, a completely unconstrained body has six degrees of freedom, three translational and three rotational. If you apply a pin joint to the body, you restrict the body's movement to rotation about the axis, and the degrees of freedom for the body reduce from six to one.

Before you select a joint to apply to your model, you should know what movement you want to restrict for the body and what movement you want to allow. The following table describes the joint connections you can create in Mechanism Design and the degrees of freedom corresponding to each. Note that for the general connection types, the table displays sets of Pro/ENGINEER constraints associated with specific DOF.

<table>
<thead>
<tr>
<th>Total DOF</th>
<th>R</th>
<th>T</th>
<th>Connection Type</th>
<th>General Connection (Constraints Associated with DOF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Weld — Glues two bodies together.</td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Rigid — Glues two parts together while changing the underlying body definition. Parts constrained by a rigid connection constitute a single body.</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>Slider — Translates along an axis.</td>
<td>Plane–plane align/mate Plane–plane align/mate</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>Pin — Rotates about an axis.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>0</td>
<td></td>
<td>Point–point align if the point is on an edge Edge on plane</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>1</td>
<td>Cylinder — Translates along and rotates about a specific axis.</td>
<td>Point on line Plane–plane orient</td>
</tr>
<tr>
<td>ID</td>
<td>Type</td>
<td>Description</td>
<td>Specific Axis</td>
<td></td>
</tr>
<tr>
<td>----</td>
<td>------</td>
<td>-------------</td>
<td>---------------</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>2 Edge on plane provided the plane is neither perpendicular or parallel to the edge</td>
<td>Plane–plane orient</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>0 <strong>Ball</strong>—Rotates in any direction.</td>
<td>Point–point align</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>1 Edge on plane</td>
<td>Point on line (line and edge must align)</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>2 <strong>Planar</strong>—Bodies connected by a planar joint move in a plane with respect to each other. Rotation is about an axis perpendicular to the plane.</td>
<td>Plane–plane align/mate</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>3 Plane–plane orient</td>
<td>Plane–plane orient (not parallel to the first set of planes)</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>1 <strong>Bearing</strong>—Combines a ball joint and a slider joint.</td>
<td>Point on line</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td>2 Edge on plane</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>3 Plane–plane orient</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>2 Point on plane</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>3</td>
<td>3 <strong>6DOF</strong>—Rotates and translates in any direction.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In addition to the constraints from connections, you must consider any servo motors you apply to your model. Servo motors are enforced displacements, velocities, and accelerations that remove degrees of freedom.

Be careful to apply only as many connections as you need to restrict your mechanism's movement. If you overconstrain the mechanism, you will have redundancies, which can give inaccurate reaction results in dynamic analyses.
6DOF Connections

You can use a 6DOF connection to model a joint that has three rotational and three translational joint axes. The joint does not affect the motion of your model's components relative to one another because no Pro/ENGINEER constraints are being applied. The 6DOF connection can be later used as a place to apply servo motors or to model any desired joint type.

To define the 6DOF connection, you need to select coordinate systems on the component and assembly. Mechanism Design aligns the two coordinate systems and uses the X, Y, and Z axes as the joint axes of the connection allowing rotation around and translation along them.

General Connections

Use the general connection to represent any desired number of degrees of freedom for your model's component. After you decide on the number of degrees of freedom, you can create the required type of general connection by selecting one or two placement constraints in the Component Placement dialog box. For detailed information on the constraint types, search Assembly and Welding area of the PTC Help system.

Most of the Pro/ENGINEER constraints and relevant references are allowed for your selection when you define the general connection. However, some restrictions apply:

- You cannot select the following constraint types to define a general connection:
  - Point on a non-linear curve
  - Point on a non-planar surface
  - Tangency constraint
- You can select the following constraints only after you select another constraint that defines a cylinder connection:
  - Align angle with offset—planes
  - Mate angle with offset—planes

Some constraints can create a general connection that has the same number of degrees of freedom as other connection types, such as ball, cylinder, or pin. If you select a combination of two placement constraints, Mechanism Design groups them together into a single connection according to specific rules. For more information on how Mechanism Design interprets single and double constraints that you select, see Constraint Conversion.

After you create a general connection, Mechanism Design places an icon showing degrees of freedom for the connection. The icon is a coordinate system that indicates the degrees of freedom using translational and rotational arrows.

Constraint Conversion
When you create a general connection, its type and the number of degrees of freedom it has depend on the type of placement constraint you select. Some constraints can produce a general connection that matches another connection type, such as ball or pin. The rules in the table below describe how Mechanism Design interprets single constraints as different types of general connection.

Note that the same rules apply during automatic constraint conversion when you transfer your Pro/ASSEMBLY model into Mechanism Design. If you created your assembly with packaged components, Mechanism Design uses a general connection to represent any combination of degrees of freedom that you left unconstrained.

When you select two sets of placement constraints, Mechanism Design merges them into a single connection. Click the specific connection in the table to see how the merge proceeds.

<table>
<thead>
<tr>
<th>Constraint</th>
<th>Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Axis-axis align</td>
<td>General Connection (Slider)</td>
</tr>
<tr>
<td>Insert/mate (cylinder, cone, torus)</td>
<td>General Connection (Cylinder)</td>
</tr>
<tr>
<td>Plane–plane align/mate</td>
<td>General Connection (Planar)</td>
</tr>
<tr>
<td>Point–point align</td>
<td>General Connection (Ball)</td>
</tr>
<tr>
<td>Point on straight line</td>
<td>General Connection (Bearing)</td>
</tr>
<tr>
<td>Point on planar surface</td>
<td>General Connection (2T/3R DOF)</td>
</tr>
<tr>
<td>Edge on planar surface</td>
<td>General Connection (2T/2R DOF)</td>
</tr>
<tr>
<td>Orient (planes)</td>
<td>General Connection (3T/1R DOF)</td>
</tr>
<tr>
<td>Default</td>
<td>General Connection (Weld)</td>
</tr>
<tr>
<td>Fix</td>
<td>General Connection (Weld)</td>
</tr>
<tr>
<td>Csys–csys</td>
<td>General Connection (Weld)</td>
</tr>
<tr>
<td>Align angle offset or mate angle offset</td>
<td>General Connection (Slider); requires a pre-existing constraint that defines a cylinder connection</td>
</tr>
</tbody>
</table>

Mechanism Design does not convert point on curve, point on any surface, or tangent constraints to general connections.

**Double Constraint Conversion—2T/3R DOF and 2T/2R DOF General Connections**

When you select two sets of placement constraints while creating a general connection, Mechanism Design groups them together into a single connection. If the first constraint is a point on plane general connection with two translational and three rotational degrees of freedom or a general connection with two translational and two rotational degrees of freedom, the merge with a second constraint proceeds according to the rules presented in the table below. The same rules apply when the
software automatically converts Pro/ASSEMBLY placement constraints into connections capable of displaying kinematic behavior.

<table>
<thead>
<tr>
<th>First Constraint/Connection</th>
<th>Second Constraint</th>
<th>Resulting Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>2T/2R DOF</td>
<td>Edge on plane</td>
<td>Invalid—planes not on the same body</td>
</tr>
<tr>
<td>2T/2R DOF</td>
<td>Edge on plane</td>
<td>Edge on plane—edges aligned; planes parallel</td>
</tr>
<tr>
<td>2T/2R DOF</td>
<td>Planar—planes aligned; edges are not aligned</td>
<td></td>
</tr>
<tr>
<td>2T/2R DOF</td>
<td>Planar—planes parallel</td>
<td></td>
</tr>
<tr>
<td>2T/2R DOF</td>
<td>Cylinder—edges aligned; planes not parallel</td>
<td></td>
</tr>
<tr>
<td>2T/2R DOF</td>
<td>Invalid—otherwise (non-orthogonal DOF)</td>
<td></td>
</tr>
</tbody>
</table>

Double Constraint Conversion—Ball

When you select two sets of placement constraints while creating a general connection, Mechanism Design groups them together into a single connection. If the first constraint you select produces a ball type connection, the merge with a second constraint proceeds according to the rules presented in the table below. The same rules apply when the software automatically converts Pro/ASSEMBLY placement constraints into connections capable of displaying kinematic behavior. Connection
types in the first and second columns of the table substitute constraints associated with them.

<table>
<thead>
<tr>
<th>First Constraint/Connection</th>
<th>Second Constraint/Connection</th>
<th>Resulting Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ball</td>
<td>Ball</td>
<td>Ball—points coincident</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pin—otherwise</td>
</tr>
<tr>
<td>Ball</td>
<td>Bearing</td>
<td>Ball—points coincident</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pin—otherwise</td>
</tr>
<tr>
<td>Ball</td>
<td>Plane orient</td>
<td>Pin</td>
</tr>
<tr>
<td>Ball</td>
<td>Point on surface</td>
<td>Ball—points coincident</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pin—otherwise</td>
</tr>
<tr>
<td>Ball</td>
<td>Edge on surface</td>
<td>Ujoint—point on edge</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pin—otherwise</td>
</tr>
</tbody>
</table>

**Double Constraint Conversion—Bearing**

When you select two sets of placement constraints while creating a general connection, Mechanism Design groups them together into a single connection. If the first constraint you select produces a bearing connection, the merge with a second constraint proceeds according to the rules presented in the table below. The same rules apply when the software automatically converts Pro/ASSEMBLY placement constraints into connections capable of displaying kinematic behavior.

Note that connection types in the first and second columns of the table substitute constraints associated with them.

<table>
<thead>
<tr>
<th>First Constraint/Connection</th>
<th>Second Constraint/Connection</th>
<th>Resulting Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bearing (point on line)</td>
<td>Bearing</td>
<td>Bearing—points coincident; lines aligned</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Ball—points coincident but lines not aligned</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cylinder—lines aligned</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Invalid—lines parallel (non-orthogonal DOF)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pin—otherwise</td>
</tr>
<tr>
<td>Bearing</td>
<td>Plane orient</td>
<td>Cylinder—line and plane perpendicular</td>
</tr>
<tr>
<td></td>
<td></td>
<td>General (1T/1R)—line and plane parallel; can</td>
</tr>
</tbody>
</table>
Mechanism Design Extension

simulate the action of a wheel
Invalid—otherwise (non-orthogonal DOF)

| Bearing | Point on surface | Bearing—points coincident; line and surface parallel
|         |                 | Ball—points coincident; line and surface are not parallel
|         |                 | Cylinder—line on surface; points on line, but not coincident
|         |                 | Invalid—otherwise (non-orthogonal DOF)

| Bearing | Edge on surface | General (1T/2R)—line and edge aligned
|         |                 | General (1T/1R)—line and surface parallel
|         |                 | Ujoint—otherwise

**Double Constraint Conversion—Cylinder**

When you select two sets of placement constraints while creating a general connection, Mechanism Design groups them together into a single connection. If the first constraint you select produces a cylinder connection, the merge with a valid second constraint proceeds according to the rules presented in the table below. The same rules apply when the software automatically converts Pro/ASSEMBLY placement constraints into connections capable of displaying kinematic behavior. The first and second columns of the table contain either a constraint type or a connection type resulting from a corresponding constraint combination.

<table>
<thead>
<tr>
<th>First Constraint/Connection</th>
<th>Second Constraint/Connection</th>
<th>Resulting Connection</th>
</tr>
</thead>
</table>
| Cylinder                    | Cylinder                     | Cylinder—axes coincident
|                             |                              | Slider—axes parallel |
|                             |                              | Weld—otherwise       |
| Cylinder                    | Planar                       | Pin—axis and plane perpendicular
|                             |                              | Slider—axis and plane parallel
|                             |                              | Weld—otherwise       |
| Cylinder                    | Ball                         | Pin—ball point on cylinder axis |
|                             |                              | Weld—otherwise       |
| Cylinder                    | Bearing                      | Cylinder—axis and line parallel; point on axis |
### Double Constraint Conversion—Planar

When you select two sets of placement constraints while creating a general connection, Mechanism Design groups them together into a single connection. If the first constraint you select produces a planar connection, the merge with a second constraint proceeds according to the rules presented in the table below. The same rules apply when the software automatically converts Pro/ASSEMBLY placement constraints into connections capable of displaying kinematic behavior. Note that connection types in the first and second columns of the table substitute constraints associated with them.

<table>
<thead>
<tr>
<th>First Constraint/Connection</th>
<th>Second Constraint/Connection</th>
<th>Resulting Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planar</td>
<td>Planar</td>
<td>Planar—planes parallel</td>
</tr>
</tbody>
</table>
Double Constraint Conversion—3T/1R DOF General Connection

When you select two sets of placement constraints while creating a general connection, Mechanism Design groups them together into a single connection. If the first constraint is a plane/plane orient general connection with three translational and one rotational degree of freedom, the merge with a second constraint proceeds according to the rules presented in the table below. The same rules apply when the software automatically converts Pro/ASSEMBLY placement constraints into connections capable of displaying kinematic behavior.

<table>
<thead>
<tr>
<th>First Constraint/Connection</th>
<th>Second Constraint/Connection</th>
<th>Resulting Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>3T/1R DOF General Connection</td>
<td>Point on plane</td>
<td>Planar—plane and planar surface parallel</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Invalid—otherwise (non-orthogonal DOFs)</td>
</tr>
<tr>
<td>3T/1R DOF General Connection</td>
<td>Point on line</td>
<td>Cylinder—line and plane perpendicular</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Invalid—otherwise (non-orthogonal DOFs)</td>
</tr>
<tr>
<td>3T/1R DOF General Connection</td>
<td>Edge on surface</td>
<td>Planar—plane and surface parallel</td>
</tr>
<tr>
<td></td>
<td></td>
<td>General (2T/1R)—edge and plane perpendicular</td>
</tr>
<tr>
<td></td>
<td></td>
<td>General (2T)—otherwise</td>
</tr>
</tbody>
</table>
Calculating Degrees of Freedom and Redundancies

In most mechanical systems or models, you can determine the degrees of freedom using the following formula:

\[ \text{DOF} = 6 \times (\text{number of bodies not including Ground}) - \text{Constraints} \]

Suppose you model a door by using two pin joints to represent the two hinges.

This model has one body. Each of the two pin joints has 5 constraints. The equation becomes:

\[ \text{DOF} = (6 \times 1) - (2 \times 5) \]

The result is −4, but a negative DOF is physically unrealistic.

In this case, you want DOF to equal 1. A door swinging has only one degree of rotational freedom. If you want to obtain reaction results for this model, you also need to take redundancies into account. The formula becomes:

\[ \text{DOF} = 6 \times (\text{number of bodies not including Ground}) - \text{Constraints} + \text{Redundancies} \]

You can use this formula to solve for the redundancies in the door model with two pin joints:

\[ 1 = (6 \times 1) - 10 + \text{Redundancies} \]
1 = – 4 + Redundancies
5 = Redundancies

To have one DOF, you must eliminate the five redundancies from the model. A possible solution is to replace the pin joints with alternative joints that have fewer constraints. For example, you can use a planar joint, with three total constraints, and a bearing, with two constraints. Keep in mind that you must choose joint axes for these connections that allow the rotational motion that you want.

The calculation below shows that this substitution reduces the redundancy to zero.

\[
\text{DOF} - \text{Redundancy} = 6 \times (\text{number of bodies not including Ground}) - \text{Constraints}
\]

\[
\text{DOF} - \text{Redundancy} = 6 \times 1 - [(1 \times 2) + (1 \times 3)]
\]

1 - Redundancy = 1
Redundancy = 0

Use the Measure Results dialog box to get information on the redundancies in your mechanism.

**Redundancies**

Redundancies are excess constraints. A connection becomes an excess constraint when it does not introduce any further restrictions on a body's motion.

If you place a connection on your mechanism that applies certain constraints to the motion, and then add another connection that constraints the same bodies, limiting the same degrees of freedom, the second joint is redundant.

It is important that you eliminate redundancies from your model when you do dynamic analyses. If you do not take redundancies into account, you may not get accurate values when you measure connection reactions or load reactions.

For example, if you model a door using two pin joints for the hinges, the second pin joint does not contribute to constraining the door's motion. The software detects the redundancies and ignores one of the pin joints in its analysis. The outcome is incorrect reaction results, yet the motion is correct. For complete and accurate reaction forces, it is critical that you eliminate redundancies from your mechanism.

Alternatively, for strictly kinematic problems where you are interested in displacement, velocity, and acceleration, redundancies in your model do not alter the design and performance of the mechanism.

You can control the redundancies in your model by your choice of connection joints. These joints must be able to restrict the same DOF, but not duplicate each other. After you decide which connections you want to use, you can use a simple formula to calculate the DOF and redundancies.

Mechanism Design calculates the DOF and redundancies for your model by default each time you analyze its motion. To check if your model has redundancies, first run a dynamic, static, or force balance analysis. You can calculate the DOF on the Analysis Definition dialog box when you run a force balance analysis. You can also
use the **Measure Results** dialog box to calculate the DOF and redundancies in your mechanism.

---

**To Assemble a Mechanism**

When you have added or changed servo motors or changed the connection definitions, you should check that the resulting mechanism can be assembled with the constraints and DOF provided by the connections.

1. Click **Mechanism > Connect** or ![Connect Assembly](image). The **Connect Assembly** dialog box appears.

2. Lock or unlock any bodies or connections as desired. Locked bodies do not move, and locked connections do not change their current position. These settings are valid only for the assembly analysis run from this dialog box.

3. Click **Run**.

If all the connections are valid, the mechanism repositions itself into its completely assembled state.

**Tip: Fixing a Failed Assembly**

Occasionally, the **Connect** operation, dragging, or running a repeated assembly analysis may fail to find an assembled configuration. This may happen because connection information is specified incorrectly, or because the initial placement of bodies is too far from their final assembled location.

If the assembly fails to connect, you should examine your connection definitions and make sure you have specified them correctly. You should examine how all the connections combine within the mechanism to ensure that there is no lack of compatibility. You can also lock bodies or connections and remove loop connections (joints that connect a loop of parts back onto itself) to see if the mechanism can assemble if it is less complex. Finally, you can look at subsystems of the mechanism individually by creating new submechanisms and investigating how they work alone.

By working up methodically from a working mechanism, adding small subsystems one at a time, very complex mechanisms can be created and run successfully.

When a repeated assembly analysis fails to assemble during some part of the sequence, it is most likely due to invalid servo motor values. If the function used to specify a servo motor has a value at a certain time that causes the mechanism to come apart because the servo motor value is outside the achievable range, the system will state that the mechanism could not be assembled. In this case evaluate the range and start and end times given for all servo motors in the mechanism.

Making the amplitude of the servo motor function smaller is a good way to start experimenting to determine a valid range.

Servo motors may also try to push joints past their limits. You can turn off limits for suspect joints and rerun the analysis to investigate this possibility.

The following are some guidelines that may help:
If you have a mechanism with joint limits, one of your servo motors may be trying to drive it past the limits. Use the **Mechanism > Jt Axis Setting** command to change the limits.

Check your assembly tolerance to determine whether it should be tighter or looser, especially if the assembly succeeds but the mechanism does not behave as expected. To change the absolute tolerance, you can adjust the characteristic length or the relative tolerance, or both. The Pro/ENGINEER accuracy setting on the assembly level and on the part level can also affect your assembly's absolute tolerance.

Check to see if there are any locked bodies or connections. This can cause the mechanism to fail.

Try dragging the bodies close to their assembled positions.

If you change the units for your assembly, the value of mechanism entities such as servo motor profiles and regeneration values for translational joint axes also change. Be aware of the units on the dialog boxes as you specify your motors and connections. Use the Pro/ENGINEER **Edit > Setup > Units** command to check your units.

As a last resort, try disabling a loop connection by using the **Drag** dialog box, repositioning the mechanism close to the desired position, and then enabling the loop connection.

**Tutorial 2A: Creating a Four-Bar Linkage Using Joint Connections**

This tutorial shows you how to create a four-bar linkage using Mechanism Design connections. It is the first part of the second Mechanism Design tutorial.

This tutorial is broken into the following topics:

- Placing the first part
- Creating the first pin joint
- Creating the second pin joint
- Redefining the second pin joint
- Adding a fixed part to ground, and redefining ground
- Closing the loop on the four-bar linkage

For information on the tutorials and the parts you need before you start them, see Creating a Four-Bar Linkage.

**Placing the First Part**

1. Create a new assembly. Accept the default template, and assume that the units are inches.

2. Click **Insert > Component > Assemble**. The **Open** dialog box appears.
Creating the First Pin Joint

1. Click Insert > Component > Assemble.
2. Choose crank.prt. The Component Placement dialog box appears.
3. Click Connections to expand the dialog box.
4. Under Connection Type, select Pin (if necessary, double-click the default connection type to display the option menu).
5. For Axis Alignment, choose axis A-1 on block.prt and axis A-1 on crank.prt.
   Note: Datum planes, axes, and points are stored in layers for each of the parts. You will need to display the appropriate layer to see these entities.
6. For the translation constraint, select Datum3 on both parts.
7. Look at the model configuration. Crank.prt should rest on top of block.prt.
8. If the configuration is incorrect, highlight the axis alignment constraint, and click Flip, so that crank.prt rests on block.prt.
9. Select the Move tab.
10. Choose Rotate as the Motion Type.
11. Select Entity/Edge as the Motion Reference.
12. Select the A_1 axis on the crank.prt.
13. Drag the crank until it lies at about 75° relative to block.prt.
14. Click OK to accept the position and the connection.

Your model should look similar to the following graphic:

Creating the Second Pin Joint
1. Click Insert > Component > Assemble and choose triangle_abc.prt. The Component Placement dialog box appears.

2. Click Connections to expand the dialog box.

3. Under Connection Type, select Pin.

4. Select the long edge on top of crank.prt, which contains PNT2.

5. Select the edge on triangle_abc.prt that contains PNT2 and PNT3.

6. Select PNT2 on crank.prt and PNT2 on triangle_abc.prt as translation references.

7. Click OK to accept the connection.

Your model should look similar to the following graphic:

Redefining the Second Pin Joint

1. Select triangle_abc.prt, then click Edit > Definition. The Component Placement dialog box appears.

2. Modify the translation constraint. Highlight Translation, and change the component reference from PNT2 to PNT3 on triangle_abc.prt.

3. Highlight the Axis alignment and click Flip to realign the part.

4. Select the Move tab.

5. Accept View Plane as the Motion Reference. Under Motion Type, click Rotate. Drag the triangle until it lies at about 90° relative to the end of the crank.

6. Click OK to accept the connection.

Your model should look similar to the following graphic:
Adding a Fixed Part to Ground
1. Click Insert > Component > Assemble and select block2.prt. The Component Placement dialog box appears.
2. In the Constraint area, select Align. Be sure the Offset check box is selected.
3. Select DTM1 on block.prt and DTM1 on block2.prt as the references. Enter 4 for the offset when prompted.
4. Align DTM2 to DTM2, and DTM3 to DTM3.
5. Click OK to accept the orientation.

Closing the Loop on the Four-bar Linkage
1. Click Insert > Component > Assemble and select triangle_bde.prt. The Component Placement dialog box appears.
2. Click Connections to expand the dialog box.
3. Select Ball as the connection type. Select PNT1 on triangle_abc.prt and PNT3 on triangle_bde.prt.
4. Click + under Connections to add a loop joint. Change the connection type from Ball to Cylinder.
5. Choose the edge defined by PNT2 and PNT4 on triangle_bde.prt as the component reference. Choose axis A-1 on block2.prt as the assembly reference.
6. Click OK to accept the connections. If all of the connections have been correctly created, the mechanism assembles by completing the loop connection.

Entering Mechanism and Identifying Ground
2. Click View > Highlight Bodies. Mechanism Design displays the ground body in green. This body is stationary during drag and servo motor operations.
3. Click Mechanism > Drag.
4. Pick any part and drag the mechanism to see if it moves as you expected. To place the mechanism in the dragged configuration, pick with the left mouse button.

Your model should look similar to the following graphic:

**Joint Axis Settings**

**About Joint Axis Settings**

The **Mechanism > Jt Axis Settings** command opens the **Joint Axis Settings** dialog box. You can use this dialog box to specify parameters that control the joint axes in your mechanism. Use the options on this dialog box to control:

- the relative orientation or configuration of the bodies joined by the joint axis connection
- the geometric references used to define the zero position of the joint axis
- the position at which the joint axis will regenerate during an assembly analysis
- limits to the motion allowed by the joint axis
- the friction force resisting the motion of the joint

A joint axis displays a zero setting when the zero references on the two bodies are aligned. If you do not define geometric references for your joint axis zero, Mechanism Design chooses a default reference on each body.

You cannot create more than one joint axis zero on any joint axis. You cannot define joint axis settings for a ball joint. In addition, you cannot edit the joint axis settings for a rotational joint axis that belongs to a multiple-rotation DOF joint, such as a 6DOF or certain general connections.

Mechanism Design references the settings you define in the **Joint Axis Settings** dialog box when it drags your mechanism, and during analysis runs. When you specify a servo motor profile or the unstretched length of a spring, it uses the zero definition for reference.

**About the Joint Axis Settings Dialog Box**

The **Joint Axis Settings** dialog box enables you to view the joint axis defining a connection, and apply or edit the zero positions, regeneration values, and limits of the joint axis. The following options are available:

- **Select Joint Axis**—Use to select the joint axis you want to view.
- **Joint Axis Position**—This text box shows the current value of the angle or distance between the zero references for the joint axis. This value corresponds to the current screen configuration.

When you enter a value and press ENTER, the orientation of the bodies on the screen also changes temporarily. For rotational joint axes, the value must be between \(-180^\circ\) and \(180^\circ\).
Mechanism Design Extension Help Topic Collection

- **Make Zero**—Defines the current position as the joint axis zero, from which other orientations are measured. This button is not active if you select **Specify References**.

- **Specify References**—Select this check box if you want to define geometric references for the zero position.

- **Zero Refs Tab**—Use to specify geometric references for the zero position of the joint axis.

- **Regen Value Tab**—Use to specify a value for the joint axis position, which the software uses in assembly analyses.

- **Properties Tab**—Use to apply limits to the range of motion of the joint axis, and to specify friction.

- **Preview**—Applies all of the entries from the dialog box, and runs an assembly analysis.

**To Specify Joint Axis Settings**

1. Click **Mechanism > Jt Axis Settings** or . The **Joint Axis Settings** dialog box appears.

2. Select a joint axis.

3. If you want to use the current orientation of the mechanism as the zero reference position:
   a. Clear the **Specify References** check box on the **Zero Refs** tab.
   b. Click **Make Zero**.
      
      Mechanism Design sets the current joint axis position to zero, and makes the reference portion of the dialog box unavailable.

4. If the current orientation is not what you want:
   a. Enter a value for angle or distance in the **Joint Axis Position** field. For angles, you can enter any value between −180° and 180°. If a value is entered outside this range, or outside the **range limits**, the software will convert it to an acceptable value.
   b. Press ENTER. The orange body temporarily moves to show the configuration with the new position value.
   c. Click **Make Zero** again to reset the **Joint Axis Position** field to zero. The current configuration of the bodies is now considered to be the zero reference.

5. If you want to use geometric entities on the bodies to specify the zero position:
   a. Select the **Specify References** check box on the **Zero Refs** tab.
   b. Select a point, vertex, surface, or plane for the **Green Body Reference**.
   c. Select a point, vertex, surface, or plane for the **Orange Body Reference**.
6. Click the **Regen Value** tab, and provide the information.

7. Click the **Properties** tab to set limits for the joint's motion and to specify friction.

8. Click **Preview** to run an assembly analysis using the information in all of the fields of the dialog box.

9. Click **OK** to accept the configuration.

### About the Zero Refs Tab

You use the **Zero Refs** tab on the **Joint Axis Settings** dialog box to specify the reference entities for the joint axis zero.

- **Specify References**—When you select this option, Mechanism Design uses the green body reference and orange body reference to define the zero position for your joint axis.

  When you select this check box, the bodies in your mechanism currently defined as the green body and orange body are highlighted. In addition, Mechanism Design displays planes or vectors indicating the references it uses to define the zero. For translational joint axes, a green and an orange plane appear. For rotational joint axes, a green and an orange arrow appear. A second green arrow indicates the direction of positive measurement. These references change orientation to reflect the value in the **Joint Axis Position** text box.

- **Green Body Reference**—Select a geometric reference on the first body.

- **Orange Body Reference**—Select a geometric reference on the second body.

You may select points, vertexes, datum planes, or surfaces as references for joint axes.

When you join bodies together with connections in Pro/ENGINEER, the first body is the assembly, and the added body is the component. The green body on the **Zero Refs** tab refers to the assembly body in the component placement process, and the orange body refers to the component.

If you do not specify references, Mechanism Design arbitrarily selects geometric references on each body connected by the joint to define the zero. You may want to specify geometric references to make it easier to relate the joint axis zero with other modeling entities in your mechanism.

### To Specify a Configuration for Assembly Regeneration

1. On the **Regen Value** tab of the **Joint Axis Settings** dialog box, select the **Specify Regeneration Value** check box.

2. To specify an assembly configuration setting for a joint axis, enter a value for the offset in the **Regeneration Value** field.

3. Click **OK**.

### About the Regen Value Tab

You use the **Regen Value** tab to set the values for regeneration in Pro/ENGINEER.
• **Specify Regeneration Value**—Check this box if you want a value other than the joint axis zero to be used for regeneration.

• **Regeneration Value**—Set an orientation of the joint axis, relative to the joint axis zero, that will be used when the assembly is regenerated. In effect, this constrains the joint's degrees of freedom during regeneration. If joint axis limits are set, the assembly configuration setting must be within the limits specified.

**To Set a Range Limit**

1. On the **Properties** tab of the **Joint Axis Settings** dialog box, select the **Enable Limits** check box.

2. Enter a value for the following:
   - **Minimum**
   - **Maximum**
   - **Coefficient of Restitution**

    **Note:** To check whether the limits you specified for the joint axis provide the range of movement you expected, use the **Drag** command.

3. Click **OK**.

**About the Properties Tab**

You use the **Properties** tab to control the range of motion of the joint, and to specify friction.

• **Enable Limits**—Set limits beyond which the joint cannot move.

• **Minimum**—Set the minimum range of motion at the joint. For rotational axes, this is a value between −180 and 180 degrees, and it should not be greater than the maximum value.

• **Maximum**—Set the maximum range of motion at the joint. For rotational axes, this is a value between −180° and 180°, and it should be greater than the minimum value.

• **Coefficient of Restitution**—The software uses the coefficient of restitution to simulate impact forces when the joint axis hits the limits.

• **Enable Friction**—Simulate friction, a resistive force that restricts motion of the joint's surfaces against each other. The force acts in the direction opposite to the direction of the joint’s motion. A coefficient of friction, static or kinetic, controls the magnitude of the force. Both coefficients depend on the type of material in contact. You can find charts with the coefficients for typical surface combinations in physics and engineering texts.

• **Static Coefficient of Friction**—Specify the static coefficient of friction. The static coefficient describes the friction force that prevents the surfaces of the joint from moving against each other up until a limit where motion begins. The static coefficient of friction is larger than the kinetic coefficient of friction.
- **Kinetic Coefficient of Friction** $\mu_k$—Specify the kinetic coefficient of friction. The kinetic coefficient describes the friction force that prevents the joint surfaces from moving freely against each other slowing down the motion.

- **Contact Radius** (for a rotational axis only)—Specify the value for the distance between the joint axis and the point of contact. The value should be greater than zero. Mechanism Design uses this value to define the radius of a circular area on which the friction torque acts.

**To Specify Friction**

1. On the **Properties** tab of the **Joint Axis Settings** dialog box, select the **Enable Friction** check box.

2. Enter a value for the following:
   - $\mu_s$ (**Static Coefficient of Friction**)
   - $\mu_k$ (**Kinetic Coefficient of Friction**)
   - $R$ (**Contact Radius**)

3. Click **OK**.

**Coefficient of Restitution**

If you want to simulate impact forces for your cam-follower connection, slot-follower connection, or joint, specify a value for the coefficient of restitution. The coefficient of restitution is defined as the ratio of the velocity of two entities after and before a collision. Typical coefficients of restitution can be found in engineering textbooks, or from empirical studies. Coefficients of restitution depend upon factors including material properties, body geometry, and impact velocity. Applying a coefficient of restitution to your mechanism is a way to simulate non-rigid properties in a rigid body calculation.

For example, a perfectly elastic collision has a coefficient of restitution of 1. A perfectly inelastic collision has a coefficient of restitution of 0. A rubber ball has a relatively high coefficient of restitution. A wet lump of clay has a value very close to 0.

**Tip: Defining Joint Axis Zero References**

Be aware of the following when defining joint axis zero references for a rotational axis:

- **Point–Point Zero Reference**—Mechanism Design draws a vector from each of the two points in a direction normal to the rotational axis. These two vectors should coincide for the joint zero. The points cannot lie on the joint axis.

- **Point–Plane Zero Reference**—The plane containing the point and the rotational joint axis should be parallel to the selected plane for the joint zero. The point cannot lie on the joint axis.

- **Plane–Plane Zero Reference**—The two planes are parallel at the joint zero. Both planes must be parallel to the axis of rotation.
Be aware of the following when defining joint axis zero references for a translation axis:

- **Point–Point Zero Reference**—The distance between the two points in the direction of the translation joint axis will be zero at joint zero.

- **Point–Plane Zero Reference**—The distance between the plane and the point in the direction of the translation joint axis will be zero at joint zero. The plane must be perpendicular to the joint axis.

- **Plane–Plane Zero Reference**—The distance between the planes is zero at joint zero. Both planes must be perpendicular to the joint axis.

Be aware of the following restrictions when defining joint axis zero references for planar or bearing connections:

- **Planar Connection**—To avoid unpredictable behavior, you can only define point–point or point–plane zero references for planar translation axes. Also, you can only define plane–plane zero references for planar rotation axes.

- **Bearing Connection**—You must select a point or plane on the body that contains the direction definition of the bearing joint—in other words, the line in the point–line constraint. Mechanism Design aligns this reference to the point defining the bearing joint.

**Bodies**

**About Bodies**

A body is a group of parts that are rigidly controlled, with no degrees of freedom within the group. The constraints you use to place a component determine which parts belong to a body. Mechanism Design defines bodies automatically based on these constraints.

You create an assembly in Pro/ENGINEER by combining components including parts and subassemblies. You use the **Component Placement** dialog box in Assembly mode to define the relationship of the component you are adding to your assembly. There are two types of connections on the **Component Placement** dialog box. You can use Pro/ENGINEER constraints, such as mate and align, or you can use Mechanism Design joint connections. If you connect two components using partial constraints, Mechanism will assume a joint connection.

**Note:** If you want two parts to belong to the same body if they are both referenced by a non-connected constraint that was created in Pro/ENGINEER Assembly mode, use the `mdx_freeze_package_comp=yes` configuration option.

The way that you define the bodies in your mechanism impacts the way you create joint connections in the following ways:

- You can create joint connections only between distinct bodies.

- When specifying the constraints for a Mechanism Design connection on the **Component Placement** dialog box, you can reference only a single body in the assembly and a single body in the component being placed.
• When you select the first assembly feature for a connection, you can select features only from the same body for the remaining constraints of that connection. This is also true when selecting features in the component—you can select features only from within the same body.

To review bodies, select one of the following options:

• **View > Highlight Bodies**—Highlights the bodies in the assembly. Ground is always highlighted in green.

• **Edit > Redefine Bodies**—If a mechanism is not moving the way you expect, or if you are not able to create joints because two parts are in the same body, then you can use **Redefine Bodies** to do the following:
  
  o Find out what the bodies are.
  o Find out what constraints cause a part to belong to a particular body.
  o Remove a constraint from a body.
  o View the offset.

Ground components (parts and bodies) in a mechanism do not move with respect to the assembly. You can include several parts or bodies in the ground body. To define a ground body, place a component with Pro/ENGINEER constraints that reference the default assembly datums or a part/assembly already in ground. Note that if you use Mechanism Design connections rather than Pro/ENGINEER constraints, you can still drag the component.

**Note:** Because of an improvement in ground body functionality, Mechanism Design models created prior to Release 2001 may lose ground body associations for certain components. In that case, you must redefine the ground body.

**To Redefine Bodies**

Follow these steps to redefine a body:

1. Click **Edit > Redefine Bodies** or . The **Redefine Body** dialog box appears.

2. Select a part. Mechanism Design displays information about the constraints used to place this part in the body.

   Under **Constraints**, the **Type** field displays the type of constraint and the **Reference** field displays the reference part with which the selected part is constrained.

   **Note:** The **Constraints** list box does not list constraints used to define connections. It displays fixed constraints that were defined in the **Component Placement** dialog box using **Insert > Component > Assemble** in Pro/ENGINEER.

3. Select a constraint from the **Constraints** list box.

   Mechanism Design displays the component and assembly references for that constraint in the text boxes under **Component Reference** and **Assembly Reference**. On your assembly, the component reference highlights in magenta
and the assembly reference highlights in cyan. The software also displays the value of any offset used in assembling the component under **Offsets**

Mechanism Design lists the part name followed by the geometry type, for example, BLOCK:Surface.

4. If you want to remove a constraint, select a constraint from the list and click **Remove**.

   You typically remove a constraint to redefine a Pro/ENGINEER assembly into a Mechanism Design model with connections. Based on the Mechanism Design body creation rules, when you bring a model into Mechanism Design with constraints, the result is that parts are combined into one body. To change the body's definition, you can remove the constraints.

5. If you want to remove all the constraints, click **Remove All**. Mechanism Design removes all the constraints and the part becomes packaged.

6. Click **OK**.

**To Define a Body as Ground**

Before defining your ground body, you may find the tips helpful.

If you are adding a new part or subassembly that should be ground, follow these steps:

1. On the Pro/ENGINEER menu bar, click **Insert > Component > Assemble**. The **Open** dialog box appears.

2. Select a component (part or subassembly).

3. Click **Open**. The **Component Placement** dialog box appears.

4. Click ![ ] to assemble the component at the default location.

5. Click **OK** to accept your definition and close the dialog box.

**Note:** Because of an improvement in ground body functionality, Mechanism Design models you created prior to Release 2001 may lose ground body associations for certain components. In that case, you must redefine the component.

**To Redefine a Component as Ground Body**

If you created your mechanism in a release prior to Release 2001, ground body definitions may have been lost. To define a component as ground in a previous mechanism model, use one of the following procedures:

**Procedure 1**—If the first component in the model should be ground, follow these steps:

1. Using the Model Tree, select the first component, which you will redefine as ground.

2. Click **Edit > Definition**. One of the following occurs:
The Component Placement dialog box appears. Proceed to step 3.

A dialog box appears stating that only a default placement can be done. Click Yes to make the first component ground.

3. Click to assemble the component at the default location.

4. Click OK.

Procedure 2—If an additional existing component should be ground, follow these steps:

1. Using the model tree, select the additional component that should be ground.

2. Click Edit > Definition. The Component Placement dialog box appears.

3. If any connections exist, click Remove to delete each connection.

4. Click the Connections arrow to collapse the dialog box.

5. Click to add a Pro/ENGINEER constraint that is directly between the component and assembly-level features, or other components already in ground.

6. Select a constraint from the Constraint Type option menu.

7. Click OK.

Tip: Creating Ground Bodies

Keep the following in mind if you are creating a new assembly, or adding new components (parts or bodies) to ground:

- If creating a new assembly, use the templates so that a default coordinate system and datum planes are automatically created.

- The assembly and its features (coordinate system and datum planes) are ground. Assembling a component to these components with Pro/ENGINEER constraints (for example, mate and align rather than pin or slider joint connections) will place that component in ground.

- As long as a component is partially constrained with references to assembly features or to a component already in ground, that component becomes part of ground.

Highlight Bodies

Click View > Highlight Bodies to highlight all the bodies in your mechanism. Different bodies appear in different colors. The ground body is green. Mechanism Design uses a limited color palette for this operation. In mechanisms with many bodies, therefore, Mechanism Design may highlight some bodies in the same color.

Cams
About Cam-Follower Connections

Use the Mechanism > Cams command to create, edit, or delete a cam-follower connection. You define a cam-follower connection by specifying surfaces or curves on two bodies. You do not have to define special cam geometry before you create the cam-follower connection.

When you click Mechanism > Cams, the Cam-Follower Connections dialog box appears. When you click New, the Cam-Follower Connection Definition dialog box appears. If you want to allow your cam-follower connection to separate during a drag operation or analysis run, you must select the Enable Liftoff option on the Properties tab on this dialog box. If you have a Mechanism Dynamics Option license, you can define friction coefficients and a coefficient of restitution for cams with liftoff.

When defining and using cam-follower connections in Mechanism Design, keep the following points in mind:

- You can use cam-followers in drag operations.
- Mechanism Design sees cams as extending infinitely in the extrusion direction. To help you get the best results from your cam-follower connection, read Cam-Follower Connection Design.
- If you have a cam-follower connection, it does not prevent the cam from tipping. You must add additional joints to one of the parts to prevent tipping.
- You cannot define multiple followers for one cam. Each cam can have only one follower. If you want to model a cam with multiple followers, you must define a new cam-follower connection for each new pair, selecting the same geometry for one of the cams in each connection if necessary.

For example, suppose you wanted to model a cam-follower connection comprising of a cylinder rolling along an L-bracket. At the point where the cylinder reaches the right angle of the L-bracket, you may want to ensure simultaneous contact between the cylinder and both the horizontal and vertical portions of the bracket. To do this, make one cam-follower connection between the cylinder and the horizontal bracket plate, and a second cam-follower connection between the cylinder and the vertical bracket plate.

You can use the View > Display Settings > Mechanism Display command to switch on or off the display of cams in your mechanism.

To Create a Cam-Follower Connection

You can create a cam-follower connection from the surfaces or curves on two bodies in your mechanism. It is not necessary to define either body as a cam before starting this procedure.

1. Click Mechanism > Cams or ○. The Cam-Follower Connections dialog box appears.
2. Click New. The Cam-Follower Connection Definition dialog box appears.
3. Either accept the default name (CamConnection1) for the cam-follower or enter a new name in the entry box.

4. Select the **Cam1** tab.

5. Click ![select](image) and select surfaces or curves on the first body to define the first cam. Middle-click to confirm your selection, or select the desired surface in the **Pick from List** dialog box if you are using query mode. Be aware of the following when selecting cams:

   - If you select the **Autoselect** toggle, Mechanism Design automatically chooses surfaces for your cam after you select the first surface. If there is more than one possible adjacent surface, Mechanism Design prompts you to select a second surface.
   - When you select cam surfaces, the program indicates the surface normal direction with a purple arrow.
   - If you select a straight curve or edge, the dialog box expands, making the **Working Plane** field active. Use the selection arrow to select a point, vertex, planar solid surface, or datum plane to define a working plane for the cam. You can select a straight curve or edge for only one of the two cams.

6. If you want to reverse the direction of the surface normal for the cam, click **Flip**. If the selected surfaces are on a volume, the default normal direction will be out, and the **Flip** button will be inactive. The surface normal direction indicates the side of the cam that Mechanism Design will use for cam contact.

7. If you select a surface, the following items in the **Depth Display Settings** area of the dialog box are active. Use these items to specify references to orient the cam on the surface.

   - **Automatic**—This option is not available if you select a curve, edge, or a flat planar surface.
   - **Front & Back**
   - **Front, Back & Depth**
   - **Center & Depth**
   - **Depth**

8. Select the **Cam2** tab and follow steps 5 through 7 to fill out the information.

9. Fill out the information on the **Properties** tab.

10. Click **OK** to accept the definition and close the dialog box. The cam-follower icon appears on your mechanism.

**To Define Properties for Cam-Follower Connections**

This procedure assumes that you have opened the **Cam-Follower Connection Definition** dialog box, and have selected the **Properties** tab.
1. Select the **Enable Liftoff** check box.

2. Enter a value for the coefficient of restitution in the \( \ell \) entry box.

3. If you want to simulate friction, select the **Enable Friction** check box.

4. Enter a value for the coefficient of static friction in the \( \mu_s \) entry box.

5. Enter a value for the coefficient of kinetic friction in the \( \mu_k \) entry box.

**Cam-Follower Connections with Liftoff**

You can specify whether the two bodies in your cam-follower connection remain in contact during a drag operation or motion run.

- If you select **Enable Liftoff** on the **Cam-Follower Connection Definition** dialog box, the two cams will be allowed to separate and collide during a drag operation or analysis run. The cams do not interpenetrate if they collide.

- If you enable liftoff, you can also define a coefficient of restitution for your cam-follower connection. This value determines the energy loss due to the impact when cams collide after separating.

- If you do not select **Enable Liftoff**, the two cams remain in contact.

**Coefficient of Restitution**

If you want to simulate impact forces for your cam-follower connection, slot-follower connection, or joint, specify a value for the coefficient of restitution. The coefficient of restitution is defined as the ratio of the velocity of two entities after and before a collision. Typical coefficients of restitution can be found in engineering textbooks, or from empirical studies. Coefficients of restitution depend upon factors including material properties, body geometry, and impact velocity. Applying a coefficient of restitution to your mechanism is a way to simulate non-rigid properties in a rigid body calculation.

For example, a perfectly elastic collision has a coefficient of restitution of 1. A perfectly inelastic collision has a coefficient of restitution of 0. A rubber ball has a relatively high coefficient of restitution. A wet lump of clay has a value very close to 0.

**Cam-Follower Connection Design**

To successfully design your cam-follower connection, you should understand the concept of working planes. Mechanism Design treats any cam you create from a surface or curve as a two-dimensional cam when it performs an analysis. When you select a surface, the software interprets the surface as extending infinitely in the depth direction. When you select a curve, you must specify a depth direction, and the software extrudes the cam in this direction for visualization purposes. Mechanism Design defines a working plane that is orthogonal to the depth, or extrusion direction.

**Note:** The cam normal, which Mechanism Design displays as a magenta arrow during the cam-follower connection creation process, is within the working plane.
When you design your cam-follower connection, it may be helpful to visualize the two cams as two-dimensional figures in the working plane. You will get better results if the two cams contact each other at a point in the working plane. Try to avoid a design with a connection along a line in the working plane.

In this illustration, assume that the working plane coincides with the viewing plane. The extrusion direction is into (perpendicular to) the viewing plane. In the top image, the connection between the two cams in the working plane occurs at a point. In the three-dimensional view, the connection is a line that is perpendicular to the working plane.

In the bottom image, the connection between the two cams in the working plane occurs at a line that is in the working plane. In the three-dimensional view, the connection is a plane.

Keep in mind:

- You will obtain better results if you model your cams (in three dimensions) so that they contact along a line that is perpendicular to the working plane. This usually means that you should avoid having flat surfaces on both cams.

- To ensure correct and reliable behavior, the working planes containing the two-dimensional cams that Mechanism Design sees should always remain parallel. To fulfill this requirement, you should define constraints or additional connections between the cam bodies to keep the extrusion directions parallel.
Surfaces for Cam-Follower Connections

You can select any set of contiguous, extruded surfaces belonging to a single body. Extruded surfaces must be perpendicular to the plane that the defining curve lies in. Also, the surfaces can curve in only one direction. In other words, they cannot bow.

For example:

<table>
<thead>
<tr>
<th>Acceptable Surface</th>
<th>Unacceptable Surface</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Acceptable Surface" /></td>
<td><img src="image2" alt="Unacceptable Surface" /></td>
</tr>
</tbody>
</table>

Surface curves in one direction | Surface is bowed

When selecting surfaces, be aware of the following:

- You can select a surface that has arbitrary trimming, including such things as interior holes and extrusion depth variations.
- You can select surfaces with different extrusion depths.
- If you select the **Autoselect** check box before you select a curved surface, Mechanism Design will include any surfaces adjacent to the selected surface. The adjacent surfaces that are included may not be continuous, so be sure to examine them to determine whether you need to smooth the geometry. You cannot use the **Autoselect** option with curves or flat surfaces.
- Mechanism Design does not smooth discontinuous or sharp corners between adjacent surfaces. If your cam bodies have sharp or discontinuous surface transitions, you should modify the geometry before creating the cam-follower connection to avoid poor performance. For example, you can create a small round feature on the sharp corner.
- The side of the cam that interacts with a second cam is indicated by the direction of the cam normal. If you select an open curve or surface, a magenta arrow appears indicating the cam normal, which extends from the interacting side. If you want to change the cam interaction to the back of the cam, click **Flip** on the **Cam-Follower Definition** dialog box. Keep in mind that changes to the cam interaction must satisfy the geometry and assembly constraints of the model.
- You can select planar surfaces, but for flat surfaces you must also specify additional references for the cam extrusion direction. To explicitly specify the cam direction, click **Front Reference** and **Back Reference** on the **Cam-Follower Connection Definition** dialog box.
If you want to change the cam surface definition on an existing cam, click **Mechanism > Model > Cams** and then **Edit** on the **Cam-Follower Connections** dialog box. You can select a surface or curve to remove from either cam by holding down the CTRL key as you select, or you can **Flip** the surface normal.

**Curves for Cam-Follower Connections**

You can select a planar datum curve or an edge on a body for cam formation. The extrusion direction for a cam generated from a curve is assumed to extend infinitely in the direction normal to the plane of the curve.

If a curve or edge that you select is straight, Mechanism Design prompts you to select a point, vertex, planar solid surface, or datum plane on the same body to define a working plane for the cam. The point you select must not be collinear with the selected line. Mechanism Design places the cam's normal in the working plane and creates the cam's depth perpendicular to the working plane. The cam normal determines the interacting side of the cam, where cam interaction occurs unless the interaction is not allowed due to assembly constraints.

The example shows a datum curve used as a cam. When you select a straight edge or datum curve, the software forces you to select a plane or point to specify the working plane. The magenta arrow, indicating the cam normal, is in the working plane. The extrusion direction of the cam then extends infinitely in a plane perpendicular to the working plane.

**Note:** You can select a straight curve or edge for only one of the two cams.

**Depth References for Cam-Follower Connections**
Keep in mind that Mechanism Design sees the cams you create as being of infinite depth in the extrusion direction. If you select a curved surface for your cam, the software displays it with an appropriate depth.

If you select a flat surface for one of your cams, you must use the references on the **Depth Display Settings** portion of the **Cam-Follower Connection Definition** dialog box to define the orientation of the cam. If you select a straight edge or straight curve for one of your cams, you must select a point, vertex, planar surface or datum plane to define the working plane, and you can use the depth references to change the visual display of your cam.

Select one of these methods, and specify the **Front Reference**, **Back Reference**, **Center Reference**, and **Depth**, as described.

- **Automatic**—The program automatically calculates an appropriate cam depth based on the cam surfaces you selected. This option is not available if you select a flat planar surface as a reference.
- **Front & Back**—Click the selector arrows beside **Front Reference** and **Back Reference** and select two points or vertices to serve as references for the depth. These references also orient the cam. The program determines a cam depth equal to the distance between the references you select.
- **Front, Back & Depth**—Click the selector arrows beside **Front Reference** and **Back Reference** and select two points or vertices to serve as references for the depth. Enter a value for the **Depth**.
- **Center & Depth**—Click the selector arrow beside **Center Reference** and select a point or vertex. Enter a value for the **Depth**.

**To Edit Cam-Follower Connections**

1. Click **Mechanism > Cams**. The **Cam-Follower Connections** dialog box appears.
2. Select an existing cam from the list.
3. Click **Edit**. The **Cam-Follower Definition** dialog box appears.
4. Make any of the following changes on either cam:
   - Add surfaces.
   - Remove surfaces.

**Using Cam-Follower Connections in Drag Operations**

You can use cam-follower pairs in the Mechanism Design or Design Animation drag operation. Keep the following in mind when using cam-followers:

- You can select either cam body in the follower connection to drag.
- You can choose to have Mechanism Design maintain the connection and co-tangency between the two cams, or you can allow them to separate and collide.
You can enable or disable the cam-follower connection during the drag operation, but you cannot lock it. You can, however, lock the bodies used to define the cams.

**Cam-Follower and Slot-Follower Friction**

Friction occurs when two surfaces move against each other, or relative to one another, and results in a loss of energy. You can add friction to simulate this loss. Friction, once added, will resist the motion of your cam-follower or your slot-follower. You define coefficients to simulate friction on the Properties tab of the Cam-Follower Connection Definition dialog box or the Slot-Follower Connection Definition dialog box. Friction is available for cams with liftoff and for all slots.

**Note:** You must apply friction to your cam-follower connection to be able to calculate cam slip measures in force balance analyses.

Friction coefficients depend on the type of material in contact, as well as the experimental conditions. Tables of typical friction coefficients are often found in physics and engineering texts.

You can specify static and kinetic friction for your cam-follower or slot-follower connection.

- The coefficient of static friction for two surfaces must be larger than the coefficient of kinetic friction for the same two surfaces.
- The coefficient of static friction describes the amount of energy that is needed to initiate movement in your model.
- The coefficient of kinetic friction describes the amount of energy that is lost to friction while keeping your model in motion.

**To Delete Cam-Follower Connections**

1. Click Mechanism > Cams. The Cam-Follower Connections dialog box appears.
2. Select an existing cam-follower connection from the list.
3. Click Remove.

**Tutorial 3: Creating an Oscillating Cam**

This tutorial shows you how to model a cam-follower connection with a spring and damper to achieve an oscillating motion. You will run a dynamics analysis, and measure the force on the spring and damper during the analysis. You must have a Mechanism Dynamics Option license to do this tutorial.

This tutorial describes how to do the following tasks:

- **3A**—Create a cam-follower connection, a spring, and a damper.
- **3B**—Create a servo motor.
- **3C**—Create and run a dynamic analysis.
- **3D**—Create and graph measures.
This tutorial assumes you have the following part and assembly files, which are located in the Demo area of the installation CD-ROM. The part colors correspond to those in the figure below.

- **cam_follower.asm**—an assembly comprised of a cam and a roller follower
- **base.prt**—the ground body, comprised of two parts (blue)
- **cam.prt**—a rounded, elongated solid with flat faces (purple)
- **roller.prt**—a wheel with flat faces with that serves as the second cam (green)
- **follower.prt**—a holder for the roller (brown)
- **follower.asm**—a subassembly connecting roller.prt and follower.prt with a pin joint

## Slots

### About Slot-Follower Connections

A slot-follower is a point-curve constraint between two bodies. Body 1 has a 3D curve (the slot) bound to it and Body 2 has a point (the follower) bound to it. The follower point follows the slot in all three dimensions. You can use an open or closed curve to define the slot. The slot-follower constrains the follower point to the interior
of the defining curve. If you want the slot curve to be shorter than the size defined by the default endpoints, you can define slot endpoints.

Mechanism Design does not check for interference on the geometry containing the follower point and the slot curve. You do not have to ensure that the geometry of the slot and the slot-follower fit together precisely.

Use the **Mechanism > Slots** command to create, edit, or delete a slot-follower connection. If you have a license for Mechanism Dynamics Option, you can simulate the impact force when the slot-follower hits the end of the slot by defining a coefficient of restitution. You can also define friction coefficients.

When defining slot-follower connections in Mechanism Design, keep the following points in mind:

- If you delete the geometry used to define the follower point, slot, or slot endpoint, the slot-follower is deleted.
- You can use slot-follower connections in drag operations.

You can use the **View > Display Settings > Mechanism Display** command to switch on or off the display of slot-follower connections in your mechanism.

**To Create a Slot-Follower Connection**

1. Click **Mechanism > Slots** or . The **Slot-Follower Connections** dialog box appears.
2. Click **New**. The **Slot-Follower Connection Definition** dialog box appears.
3. Either accept the default name (SlotConnection1) for the slot-follower or enter a new name in the entry box.
4. Select the **Entities** tab.
5. Click under **Follower Point** and select a datum point or vertex on one body. The body name and point name appear.
6. Click under **Slot Curves** to select one or more continuous curves for the slot on a different body. The body name and entity name appear. The curve is highlighted in blue.
7. If you want to have endpoints on your curve, click under **Slot Endpoints** and select two datum points or vertices on the curve. If you do not select endpoints, the default curve endpoints are the extreme ends of the first and last curves you select.
8. If you want to interchange the first and second endpoints, click **Flip**.
9. If you want to remove the endpoint selection, click **Clear**.
10. Fill out the information on the **Properties** tab.
11. Click **OK**.
The slot-follower icon appears with a dotted line connecting the slot and the follower point.

Coefficient of Restitution

If you want to simulate impact forces for your cam-follower connection, slot-follower connection, or joint, specify a value for the coefficient of restitution. The coefficient of restitution is defined as the ratio of the velocity of two entities after and before a collision. Typical coefficients of restitution can be found in engineering textbooks, or from empirical studies. Coefficients of restitution depend upon factors including material properties, body geometry, and impact velocity. Applying a coefficient of restitution to your mechanism is a way to simulate non-rigid properties in a rigid body calculation.

For example, a perfectly elastic collision has a coefficient of restitution of 1. A perfectly inelastic collision has a coefficient of restitution of 0. A rubber ball has a relatively high coefficient of restitution. A wet lump of clay has a value very close to 0.

Curves in Slot-Follower Connections

You can select any of these types of curves to define the slot:

- Planar or non-planar curves
- Edges
- Datum curves
- Open
- Closed

The selected curves must be adjacent, but do not have to be smooth. You can select multiple curves that are not continuous.

Follower Points in Slot-Follower Connections

Keep the following in mind when selecting follower points:

- The follower point must be on a different body from the slot curve.
- You can select a datum point or a vertex.
- Your datum point must belong to a single body—assembly-level datum points cannot be used for follower points.
- To create a part-level datum point, you do not have to close or regenerate your assembly. Open the part and define the point. When you close the part, the body in the assembly contains the point you just created.

Slot Endpoints in Slot-Follower Connections

You can select datum points, vertices, curves/edges, and surfaces for slot endpoints. If you select a curve, edge, or surface, the slot endpoint is at the intersection of the selected entity with the slot curve.
If you do not select endpoints, the default endpoints for a slot-follower are the extreme ends of the first and last curves selected for the slot.

If you select a closed curve, or a series of curves that form a closed loop, for your slot-follower, you do not need to specify endpoints. However, if you choose to define endpoints on a closed curve, the resulting slot will be an open slot. Click Flip to specify which portion of the original closed curve will become the open slot. Click Clear if you want to delete the endpoint selection.

Cam-Follower and Slot-Follower Friction

Friction occurs when two surfaces move against each other, or relative to one another, and results in a loss of energy. You can add friction to simulate this loss. Friction, once added, will resist the motion of your cam-follower or your slot-follower. You define coefficients to simulate friction on the Properties tab of the Cam-Follower Connection Definition dialog box or the Slot-Follower Connection Definition dialog box. Friction is available for cams with liftoff and for all slots.

Note: You must apply friction to your cam-follower connection to be able to calculate cam slip measures in force balance analyses.

Friction coefficients depend on the type of material in contact, as well as the experimental conditions. Tables of typical friction coefficients are often found in physics and engineering texts.

You can specify static and kinetic friction for your cam-follower or slot-follower connection.

- The coefficient of static friction for two surfaces must be larger than the coefficient of kinetic friction for the same two surfaces.
- The coefficient of static friction describes the amount of energy that is needed to initiate movement in your model.
- The coefficient of kinetic friction describes the amount of energy that is lost to friction while keeping your model in motion.

To Define Properties for Slot-Follower Connections

This procedure assumes that you have opened the Slot-Follower Connection Definition dialog box, and have selected the Properties tab.

1. Enter a value for the coefficient of restitution in the \( \epsilon \) entry box.
2. If you want to simulate friction, select the Enable Friction check box.
3. Enter a value for the coefficient of static friction in the $\mu_s$ entry box.
4. Enter a value for the coefficient of kinetic friction in the $\mu_k$ entry box.

**To Edit Slot-Follower Connections**

1. Click **Mechanism > Slots**. The **Slot-Follower Connections** dialog box appears.
2. Select a slot-follower from the list.
3. Click **Edit**. The **Slot-Follower Connection Definition** dialog box appears.
4. Change any of the following items:
   - Slot curve
   - Follower point
   - Slot endpoints

**To Delete Slot-Follower Connections**

1. Click **Mechanism > Slots**. The **Slot-Follower Connections** dialog box appears.
2. Select a slot-follower from the list.
3. Click **Remove**.

**Using Slot-Follower Connections in Drag Operations**

After you define a slot-follower, you can use it in drag operations. Keep the following in mind when using slot-followers:

- You can move the body with the follower point, and the follower will move from one endpoint of the slot to the other.
- You can enable or disable the slot-follower during a drag operation, but you cannot lock it.

**Drag and Snapshots**

**About Dragging**

Dragging is a powerful way to move your mechanism through an allowable range of motion. This feature enables you to gain insight into how your assembly behaves or to place it in a particular configuration. You can use a snapshot to create a starting point for an analysis or place an assembly in a particular configuration. You can use joint-disabling and body locking capabilities to study the motion of either the entire mechanism or a portion of it.

Using the **Drag** command in Mechanism Design, you can select either a body that is not defined as ground or a point on a part and drag it with the mouse. The entity that you grab will be positioned as close as possible to the current cursor location while keeping the rest of the mechanism assembled. As you drag the entity, Mechanism Design displays the X, Y, and Z coordinates of the drag point location in real time.
When you select the **Mechanism > Drag** command, the **Drag** dialog box appears. You can control how the mechanism behaves during the drag operation by specifying geometric constraints, locking and unlocking bodies, enabling and disabling connections, and selecting a specific drag mode. The constraints are valid only during the drag operation.

After you have moved your mechanism to the desired configuration, use the items on the **Drag** dialog box to save snapshots of your mechanism in different positions and orientations. Snapshots capture the existing locked bodies, disabled connections, and geometric constraints. You can also use the **Drag** dialog box to specify that your snapshots are available as Pro/ENGINEER exploded view in drawing mode, and to edit or delete previously saved snapshots.

### To Drag a Point

1. Click **Mechanism > Drag** or ![Drag icon]. The **Drag** dialog box appears.
2. Click ![Drag icon].
3. Select a location on a body within the current model and left-click on this location. A circle appears. This is the exact location on the body that you will drag.
4. Move the cursor, and the selected point follows the location of the cursor.
5. To complete the operation, click one of the following mouse buttons:
   - Left mouse button—to accept the current body positions and begin dragging another body
   - Middle mouse button—to cancel the drag just performed
   - Right mouse button—to terminate the drag operation, leaving the bodies where you have just dragged them

**Note:** You cannot select ground for point dragging.

### To Drag a Body

When you drag a body, its position onscreen changes but its orientation remains fixed. If the mechanism requires the body to be reoriented in conjunction with a change in position, then the body does not move at all since the mechanism would not be able to be reassembled in the new position. Should this happen, try using point dragging instead.

1. Click **Mechanism > Drag** or ![Drag icon]. The **Drag** dialog box appears.
2. Click ![Drag icon].
3. Select a body within the current model.
4. Move the cursor, and the selected body follows the location of the cursor.
5. To complete the operation, click one of the following mouse buttons:
Mechanism Design Extension Help Topic Collection

- Left mouse button—to accept the current body positions and begin dragging another body
- Middle mouse button—to cancel the drag just performed
- Right mouse button—to terminate the drag operation, leaving the bodies where you have just dragged them

About the Drag Dialog Box

Use this dialog box to move components of the mechanism and take snapshots. You can also use this dialog box to apply or remove constraints and to turn the constraints on and off. To access this dialog box, click Mechanism > Drag.

The dialog box displays the following buttons and fields at the top:

- Click to take a picture of your mechanism. The Snapshots list updates. The snapshot includes the relative orientation and location of all parts and bodies, the connection status, and any body locks that were defined at the time you took the snapshot.
- Click to select a point to drag. The point highlights and follows the cursor movement while maintaining connections.
- Click to select a body to drag. The body highlights and follows the cursor movement while maintaining connections. The current orientation of the body with respect to the assembly coordinate system is held fixed.
- When you left-click to accept a dragged configuration, the configuration is saved to a buffer. Click to display the previous configuration from the buffer. This button acts as an undo command, displaying the part positions as of the start of the last drag sequence. Mechanism Design adds configurations to the buffer until you terminate the drag operation by right-clicking.
- Click to display the next configuration in the buffer. The button acts as a redo command.
- **Current Snapshot**—Use this field to rename the displayed snapshot.

The Drag dialog box also contains the following tabs:
- Snapshots
- Constraints

To have more options for the drag operations, click the arrow next to Advanced Drag Options.

Snapshots Tab on the Drag Dialog Box

Use the Snapshots tab on the Drag dialog box to display the list of saved snapshots. To work with a snapshot, select its name from the list and then click one of the following buttons on the left:
• Click 📷 to display the selected snapshot.

• Click 📷 to open the **Snapshot Construction** dialog box, from which you can select part positions from other snapshots to use in a new snapshot.

• Click 🔄 to change the name of the selected snapshot to that in the **Current Snapshot** entry box. This item also updates the snapshot with the current onscreen configuration.

• Click 📷 to make the selected snapshots available as Pro/ENGINEER explode states. The explode states can then be used in a Pro/ENGINEER drawing view. When you click this button, Mechanism Design places an icon next to the snapshot on the list.

• Click ✗ to delete the selected snapshot(s) from the list.

**To Apply Constraints During a Drag Operation**

This procedure assumes you are on the **Drag** dialog box and have selected the **Constraints** tab.

1. Select the snapshot. The name appears in the **Current Snapshot** entry box.

2. Select one of these options to create a temporary constraint:
   - Click 📷 and select two points, two lines, or two planes. The entities remain aligned during the drag operation.
   - Click 📷 and select two planes. The planes remain mated during the drag operation.
   - Click 📷 to orient two planes at an angle to each other.
   - Click 📷 and select a joint axis to specify joint axis position.
   - Click 📷 and select a body to lock or unlock in its current position.
   - Click 📷 and select a connection. The connection is disabled.

3. Use the check boxes beside a constraint to enable or disable it.

4. Click 📷 to assemble the model using the temporary constraints you applied.

5. If you want to copy a constraint to a snapshot other than the current snapshot, see Copying Constraints From One Snapshot to Another.

**To Orient Planes During a Drag Operation**

This procedure assumes you are in the **Drag** dialog box and have selected the **Constraints** tab.
1. Click 

2. Use the normal selection methods to select two planes or surfaces on your mechanism.

3. If you want to change the angle between the two planes, enter a value in Offset. If Mechanism Design cannot assemble the mechanism with the offset value, an error message appears.

**Constraints Tab on the Drag Dialog Box**

Use the Constraints tab on the Drag dialog box to apply or remove constraints. After you apply a constraint, Mechanism Design places its name on the list of constraints. You can turn the constraints on and off by selecting and clearing the box next to the constraint selected from the list. You can right-click to copy, cut, paste, or delete the constraint.

You can also choose from the following options:

- Click 
  to align two entities. Select points, lines, and planes to create a temporary constraint to align the entities. This constraint is valid only during the drag operation, but is associated to a snapshot and is enforced when the snapshot is shown or updated.

- Click 
  to mate two entities. Select planes to create a temporary constraint to mate them. This constraint is valid only during the drag operation, but is associated to a snapshot and is enforced when the snapshot is shown or updated.

- Click 
  to orient two surfaces. Select planes to orient two surfaces at an angle or parallel to each other. You can also enter an offset.

- Click 
  to specify an exact value for a joint axis initial configuration.

- Click 
  to lock one body relative to another body. Lock or unlock a body in its current position. The selected bodies will be locked relative to ground or another selected body.

- Click 
  to disable a connection. Select connections to temporarily disable from the mechanism. This status is saved with the snapshot. If you use this setting on the last snapshot in the list and do not change the status later, the rest of the snapshots will have the connection disabled.

- Click 
  to delete the selected constraints from the list.

- Click 
  to assemble your model. Re-apply the selected mate or align constraint to regenerate a snapshot.

- **Offset**—Enter the value for an offset if you are creating a mate or align constraint. If you are creating an orientation constraint, you can enter a value for angle or distance.
Advanced Drag Options

You can expand the Drag dialog box by clicking the arrow on Advanced Drag Options.

The advanced options include the following buttons:

- Click to open the Move dialog box, allowing you to perform a package move. Mechanism Design does not honor drag constraints in package move. For more information, search for package move in the PTC Help system.

- Click to specify the current coordinate system for advanced drag operations. Select a coordinate system by choosing the body whose default coordinate system is the one you want to use. X, Y, or Z translation or rotation will be in this coordinate system.

- To specify X, Y, and Z translation, click one of the following buttons to select a coordinate direction, then select a body on your model. Your selection reduces the movement of the body to the selected direction for drag operations. Translation in other directions, as well as rotation of the body, is locked.
  - Click to specify translation in the X direction of the current coordinate system.
  - Click to specify translation in the Y direction of the current coordinate system.
  - Click to specify translation in the Z direction of the current coordinate system.

- To specify X, Y, and Z rotation, click one of the following buttons to select a coordinate direction, then select a body on your model. Your selection reduces the movement of the body to rotation about the selected axis for drag operations.
  - Click to specify rotation around the X axis of the current coordinate system.
  - Click to specify rotation around the Y axis of the current coordinate system.
  - Click to specify rotation around the Z axis of the current coordinate system.

The dialog box also displays these fields:

- **Reference Coordinate System**—Use the selector arrow to select a coordinate system in the model.
- **Drag Point Location**—Displays X, Y, and Z coordinates of the drag point in real time with respect to the selected coordinate system.
Using Assembly States

You can use the Drag dialog box to make snapshots available as explode states in Assembly and Detail.

To make the snapshots available, select one or more snapshots, then click \[\text{Explode State}\]. The Explode State column on the Drag dialog box displays an "X" next to the snapshot's name, indicating it is available. If you want to turn off the availability of a snapshot state later, you can highlight the snapshot and click \[\text{Explode State}\] to turn the availability off.

These assembly states (snapshots) will be available in Assembly and Detail as explode states.

**Note:** The snapshot and the explode state are linked together. If you change the snapshot, the explode state changes. When modifying or deleting a snapshot in which the explode state is in use, be aware of the following:

- Any changes you make to the snapshot will be reflected in the explode state.
- Deleting the snapshot causes the explode state to become unlinked. The explode state is still available, but is independent of any snapshot. If you then create a snapshot with the same name as the deleted snapshot, the explode state associates itself with the new snapshot.

Consult the PTC Help system for more information on explode states.

Copying Constraints from One Snapshot to Another

You can use the Copy and Paste commands to copy constraints from one snapshot and paste them into a different snapshot. You can access these commands by right-clicking the selected constraint on the Constraints tab of the Drag dialog box.

**Note:** You should have the snapshot you want to copy from and the snapshot you want to paste into available from the Drag dialog box's Snapshot list.

1. On the Snapshots tab, select the snapshot (for example, snapshot A) where the constraints are defined.
2. On the Constraints tab, select the constraints that you would like to copy, and click the Copy command on the right mouse button pop-up menu.
3. On the Snapshots tab, select the snapshot (snapshot B) where the constraints need to be restored.
4. On the Constraints tab, click Paste to copy the constraints from the original snapshot (snapshot A).

Mechanism Design ignores duplicate constraints from the paste operation. Therefore, if you pasted the constraints from snapshot A to snapshot A, nothing should change.

To Lock a Body Prior to a Dragging Operation
Lock bodies to fix bodies relative to one lead body. The bodies will act as if they are glued together, allowing no movement between them. The bodies do not need to be touching or adjacent to be locked together.

1. From the **Drag** dialog box, click ![image].

2. Select the lead body, then a set of follower bodies to be locked during the dragging operation. The follower bodies stay fixed relative to the lead body.

   **Note:** Clicking **Close** from the **Drag** dialog box removes all locks. When you begin a new dragging session, no bodies or connections will be locked.

**To Capture a Snapshot**

1. Click **Mechanism > Drag** or ![image]. The **Drag** dialog box opens to the **Snapshots** tab.

2. Position the mechanism in the desired configuration using one of these methods:
   - dragging points
   - dragging bodies

3. If you want to move the mechanism by translating or rotating with respect to coordinate system axes, or use Pro/ENGINEER package move, click the arrow beside **Advanced Drag Options**.

4. If you want to constrain the mechanism, click the **Constraints** tab.

5. Click ![image] to save the current mechanism configuration to the list of snapshots.

6. If you want to use the configuration of parts from another snapshot, you can borrow part positions.

7. If you want to change the name from the default Snapshot\textsubscript{n}, select the name you want to replace, then type a new name in the **Current Snapshot** text field.

**To Use Snapshot Construction**

Use the **Snapshot Construction** dialog box when you are creating a snapshot that can use part positions from other, previously-saved snapshots.

1. Click **Mechanism > Drag** or ![image]. The **Drag** dialog box appears.

2. Click ![image]. The **Snapshot Construction** dialog box appears.

3. In the **Snapshots** list, select the snapshot you want to borrow from. The configuration of parts from the selected snapshot appears in the display window.

4. Select the parts whose configuration you want to borrow. When you accept your selections, Mechanism Design takes the selected parts' positions and merges them into the original snapshot.
5. If you like the new display, click **OK** to accept the new positions. You can then take a new snapshot using **on the Drag dialog box.**

6. If you do not like the new positions, click **to return to the original positions.**

**To Edit a Snapshot**

1. On the **Snapshot** tab of the **Drag** dialog box, select a name from the list of saved snapshots.

2. Click **. The configuration depicted in that snapshot appears in the model window.

3. If you want to rename the snapshot, enter a new name in the **Current Snapshot** entry box.

4. Edit the assembly configuration by dragging it to a new configuration.

5. Click **. The snapshot is updated to the current configuration.

6. If you want to delete the selected snapshot, click **.

**To Remove a Snapshot**

1. On the **Snapshot** tab of the **Drag** dialog box, select a name from the list of saved snapshots.

2. Click **. Mechanism Design deletes the snapshot name from the list.

**Tutorial 2C: Dragging and Creating Snapshots**

This tutorial shows you how to use the drag functionality to position your model and how to create snapshots. You can use snapshots as the starting point for kinematic analyses. It is the third part of the second Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start them, see **Creating a Four-Bar Linkage.**

1. Click **Mechanism > Drag** or click **. In the **Drag** dialog box, create a snapshot by clicking **. Mechanism Design includes the snapshot in the list with the default name **Snapshot1.**

2. Click ** and select **crank.prt** by clicking the part with the left mouse button.

3. Drag the mouse, and observe how the linkage moves. Note how the connection limits restrict the drag movement.

4. Middle-click when you are finished.

5. Drag the mechanism again, this time choosing **triangle_abc.prt. Drag the mechanism to a new position, and right-click to accept the position. If the
mechanism enters a kinematic lock-up state, you can exit this state by middle-clicking to return to the original starting configuration.

6. Create a snapshot in the new position by clicking  

7. Review Snapshot1 and Snapshot2 by highlighting each name and clicking  

8. Click Close to exit the Drag dialog box.

**Modeling Entities**

**Springs**

**About Springs**

Use the Mechanism > Springs command to work with your springs. You use a spring to generate a linear spring force in your mechanism. You can create springs for your mechanism if you have a Mechanism Dynamics Option license. The spring produces a linear spring force when being stretched or compressed. The force acts to bring the spring back to the equilibrium (relaxed) position. The magnitude of the spring force is proportional to the amount of displacement from the equilibrium position. For example, if you double the displacement, you double the force.

The Mechanism > Springs command opens a finder dialog box, which you can use to create, edit, copy, or delete your springs.

The Springs dialog box also displays the status of already created springs. If your spring is fully defined, the Status column on the Springs dialog box is blank. For more information, see Status.

You can use the View > Display Settings > Mechanism Display command to turn on or off the display of springs in your mechanism.

**About the Spring Definition Dialog Box**

Use this dialog box to create a new spring or to edit an existing one. To access this dialog box, click Mechanism > Springs. When the Springs dialog box appears, click New or Edit.

The Spring Definition dialog box displays the following information:

- **Reference type**—Use this area to select the type of spring you want to apply and one or two reference entities for the spring.
  - **Joint Axis**—Applies a spring on a joint axis. You select a joint axis as a reference entity.
  - **Point-to-Point**—Applies a spring between two bodies that are not connected by a joint. You select two points or two vertices as reference entities.
• **Properties**—Use this area to specify the values for the following constants:
  
  o **k**—The spring stiffness constant that usually comes from the manufacturer specifications or from your own empirical data. This constant must be positive.
  
  o **U**—The value for the unstretched length of the spring.
  
  Both constants are components of the expression that defines the spring force magnitude:
  
  \[ \text{Force} = k (x - U) \]
  
  You can also enter their values in scientific notations.
  
• **Icon Diameter**—This field becomes active when you select **Point-to-Point** as a reference type. Use this field to specify a diameter value for the point-to-point spring icon that Mechanism Design displays on your mechanism after the spring is defined. The **Default** diameter value is 0.15 of the unstretched length.

**To Create a Spring**

1. Click **Mechanism > Springs** or ![Springs Icon](image). The **Springs** dialog box appears.
2. Click **New**. The **Spring Definition** dialog box appears.
3. Specify a name for the spring or accept the default name.
4. Select a reference type:
   
   o **Joint Axis**
   
   o **Point-to-Point**

5. Click ![Reference Selection Icon](image) and use the normal selection methods to select a reference entity on the model. For a point-to-point spring, select two entities.
6. Specify a value for \( k \), the spring stiffness constant.
7. Enter a positive value for \( U \), the unstretched length of the spring.
8. For the icon of a point-to-point spring, either accept the default value or specify a value for the icon diameter.
9. Click **Apply** to add the spring to the model and review its placement. Mechanism Design places the new spring icon on your mechanism.
10. Click **OK** when you have finished defining your springs.

   The **Springs** dialog box reappears with the new spring listed.

**The U Constant**

When you enter the value for \( U \), the unstretched length of the spring, follow these guidelines:

• For a translational joint axis, enter the value in units of length.
For a rotational joint axis, enter the value in units of angular measurement.

For a point-to-point spring, Mechanism Design automatically displays the value of the U constant as a distance between the two selected reference entities. If you need to modify the value, enter it in units of length.

**Joint Axis Spring**

When you select **Joint Axis** as a reference type, the U and the x in the expression Force = k (x – U) have the following meanings:

- **U**—The angular position of the spring measured from the joint axis zero position when the spring is neither stretched nor compressed.
- **x**—The angular position of the spring measured from the joint axis zero position when the spring is either stretched or compressed during the mechanism's motion.

**Point-to-Point Spring**

When you select **Point-to-Point** as a reference type, the U and the x in the expression Force = k (x – U) have the following meanings:

- **U**—The distance between the two points when the spring is neither stretched nor compressed.
- **x**—The separation between the two points when the force is applied during the mechanism's motion.

**Finder Dialog Box**

A finder dialog box opens when you select certain modeling entities from the **Mechanism** menu. Use this dialog box to organize and control your force and servo motors, springs, dampers, force or torque loads, cam-follower connections, slot-follower connections, gear pairs, or initial conditions. The dialog box includes a list of the entities you have created in your model. You can use this form to add a new entity, edit an existing entity, copy an existing entity to a new name, or remove an existing entity from your model.

To get information on an entity in the list, place the cursor over the item's name without clicking. A message box appears with a summary of the parameters used to define the entity.

The finder form includes the following fields:

- **Name**—The default name is based on the entity type with a number appended. For example, the default name for the first spring you create will be **Spring1**. If you want to change the name, highlight it, and edit it.

  It is a good idea to use more meaningful names to help you keep track of what you have created.

- **Status**
- **New**—Use this button to create one of the following types of entities:
Mechanism Design Extension Help Topic Collection

- Cam-follower connection
- Slot-follower connection
- Servo motor
- Force motor
- Gear pair
- Spring
- Damper
- Force/torque load
- Initial condition

- **Edit**—Use this button to change the definition of one of the following entities:
  - Cam-follower connection
  - Slot-follower connection
  - Servo motor
  - Force motor
  - Gear pair
  - Spring
  - Damper
  - Force/torque load
  - Initial condition

- **Copy**—Use this button to copy one of the entities in the list to a new name. This option is not available for cam-follower connections or slot-follower connections.

- **Delete**—Use this button to delete an entity from the model. You can also delete several entities at once. Hold the SHIFT key, highlight the entities, and press DELETE.

**Status**

The **Status** column on the finder dialog box gives current information on the part, assembly, or feature that the modeling entity references.

- **Suppressed**—The modeling entity references:
  - A part, assembly, or feature that is suppressed in Pro/ENGINEER.
  - A part, assembly, or feature in which the geometry is not included in the currently used simplified representation, family table, instance, or interchange assembly.
- **Incomplete**—The modeling entity references a part, assembly, or feature that you have changed or deleted.

You cannot edit the definition of a suppressed entity.

**To Edit a Spring**

1. Click **Mechanism > Springs**. The **Springs** dialog box appears.
2. Select a spring from the list of existing springs.
3. Click **Edit**. The **Spring Definition** dialog box appears. Mechanism Design highlights the spring icon and corresponding reference entities on your model.
4. Change any of the following items:
   - **Reference Type**
   - **Properties**
5. Change the **Icon Diameter** for the point-to-point spring.
6. Click **Apply** to update the model and examine the changes.
   - Click **OK** to save the modified spring definition.

**Note:** To revert to the previously saved spring definition, click **Cancel** while editing the spring.

**To Copy a Modeling Entity**

Use this procedure to copy a previously defined gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to copy. A dialog box appears.
2. Select a previously defined entity from the list.
3. Click **Copy**. A new entity appears in the list, with **Copy of** appended to the name of the copied entity. This entity has the same definition as the entity from which it was copied.
4. Change the definition of the newly copied entity as needed by editing the appropriate information on any of the tabs in the definition dialog box.

**To Rename a Modeling Entity**

Use this procedure to rename a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to rename. A dialog box appears.
2. Select a previously defined entity from the list. If you place the cursor over the entity without clicking, a message box appears with the definition information for the entity.
3. Click **Edit**. A definition dialog box appears, and Mechanism Design highlights the model, showing the selected entity and an icon representing the entity.

4. Change the name in the text field. The name must be unique for each entity type.

5. Click **OK**.

**To Delete a Modeling Entity**

Use this procedure to delete a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to delete. A dialog box appears.

2. Select a previously defined entity from the list.

3. Click **Delete**. The selected entity is removed from the list and from the model.

**Dampers**

**About Dampers**

Use the **Mechanism > Dampers** command to work with your dampers.

A damper is a type of load you can create to simulate real world forces on your mechanism. You can create dampers for your mechanism if you have a Mechanism Dynamics Option license. The force generated by the damper removes energy from a moving mechanism and dampens its motion. For example, you can use the damper to represent the viscous force that slows down the movement of a piston pushing fluid into a cylinder. The damper force is always proportional to the velocity magnitude of the entity on which you are applying the damper, and acts in the opposite direction to movement.

The **Mechanism > Dampers** command opens a finder dialog box, which you can use to create, edit, copy, or delete your dampers.

The dialog box also indicates the status of already created dampers. If your damper is fully defined, the **Status** column on the dialog box is blank. For more information, see **Status**.

You can use the **View > Display Settings >** Mechanism Display command to turn on or off the display of dampers in your mechanism.

**About the Damper Definition Dialog Box**

Use this dialog box to create a new damper or edit an existing one. To access this dialog box, click **Mechanism > Dampers**. When the **Dampers** dialog box opens, click **New** or **Edit**.

The **Damper Definition** dialog box displays the following information:

- **Reference type**—Use this area to select the type of damper you want to apply and corresponding reference entities.
Mechanism Design Extension

- **Joint Axis**—Applies a damper on a joint axis. You select a joint axis as a reference entity.
- **Point-to-Point**—Applies a damper on two bodies that are not connected by a joint. You can either select two points or two vertices or a point and a vertex as reference entities.
- **Slot**—Applies a damper on a slot-follower. You select a slot-follower connection as a reference entity.

**Properties**—Use this area to specify a value for $C$, the damping coefficient.

The damping coefficient is a component of the expression that defines the magnitude of the force in relation to velocity:

$$\text{Force} = C \times \text{Velocity}$$

The damping coefficient usually comes from manufacturer specifications or from your own empirical measurements. You can enter this value in scientific notation, but the constant must be positive.

**To Create a Damper**

1. Click **Mechanism > Dampers** or . The **Dampers** dialog box appears.
2. Click **New**. The **Damper Definition** dialog box appears.
3. Specify a name for the damper or accept the default name.
4. Select a reference type:
   - **Joint Axis**
   - **Point-to-Point**
   - **Slot**
5. Select a reference entity from the model. For a point-to-point damper, select two entities. For information on selection methods, search the PTC Help system.
6. Specify a value for $C$, the damping coefficient.
7. Click **Apply** to add the damper to the model and review its placement. Mechanism Design places the new damper icon on your mechanism.
8. Click **OK** when you have finished defining your damper.

   The **Dampers** dialog box reappears with the new damper listed.

**To Edit a Damper**

1. Click **Mechanism > Dampers**. The **Dampers** dialog box appears.
2. Select a damper from the list of existing dampers.
3. Click **Edit**. The **Damper Definition** dialog box appears. Mechanism Design highlights the damper and corresponding reference entities.

4. Change any of the following items:
   - **Reference Type**
   - **Properties**

5. Click **Apply** to update the model and examine the changes.

6. Click **OK** to save the modified damper specification.

**Note:** To revert to the previously saved damper definition, click **Cancel** while editing the damper.

### Joint Axis Damper

You choose the **Joint Axis** option in the **Damper Definition** dialog box to apply a damper that produces a linear damping force along a translational joint axis or a torsional damping force about a rotational joint axis. The force dissipates energy by acting in a direction opposite to the direction of the motion.

You can select one of the following joint axes as a reference entity for your mechanism:

- **Rotational**—pin, cylinder, planar
- **Translational**—slider, cylinder, bearing, planar

### Point-to-Point Damper

You choose the **Point-to-Point** option in the **Damper Definition** dialog box to create a point-to-point damper force. This force resists the relative motion between two points. For example, if motion causes two points to separate, the point-to-point damper force applied between the points, resists their separation. On the contrary, if motion causes two points to come together, the point-to-point damper force opposes the points' contraction. The force is equally applied in opposite directions to two points on different bodies.

The reference selection for the point-to-point damper is two points or vertices. You cannot select points or vertices from the same body. If you do so, Mechanism Design displays an error message and does not proceed until you select valid reference entities.

### Slot Connection Damper

When you choose the **Slot** option in the **Damper Definition** dialog box, select a slot-follower connection icon as a reference entity for your damper. A slot-follower connection is a point-curve connection between two bodies. Body 1 has a 3D curve (the slot) bound to it and Body 2 has a point (the follower) bound to it. The follower point follows the slot in all three dimensions. The slot damper generates a damping force that slows down the movement of Body 2 relative to Body 1. The direction of the damping force is tangent to the curve (the slot) and opposite to the direction of the follower's movement.

### Finder Dialog Box

94
A finder dialog box opens when you select certain modeling entities from the Mechanism menu. Use this dialog box to organize and control your force and servo motors, springs, dampers, force or torque loads, cam-follower connections, slot-follower connections, gear pairs, or initial conditions. The dialog box includes a list of the entities you have created in your model. You can use this form to add a new entity, edit an existing entity, copy an existing entity to a new name, or remove an existing entity from your model.

To get information on an entity in the list, place the cursor over the item's name without clicking. A message box appears with a summary of the parameters used to define the entity.

The finder form includes the following fields:

- **Name**—The default name is based on the entity type with a number appended. For example, the default name for the first spring you create will be *Spring1*. If you want to change the name, highlight it, and edit it.

  It is a good idea to use more meaningful names to help you keep track of what you have created.

- **Status**

- **New**—Use this button to create one of the following types of entities:
  
  - **Cam-follower connection**
  - **Slot-follower connection**
  - **Servo motor**
  - **Force motor**
  - **Gear pair**
  - **Spring**
  - **Damper**
  - **Force/torque load**
  - **Initial condition**

- **Edit**—Use this button to change the definition of one of the following entities:
  
  - **Cam-follower connection**
  - **Slot-follower connection**
  - **Servo motor**
  - **Force motor**
  - **Gear pair**
  - **Spring**
  - **Damper**
Mechanism Design Extension Help Topic Collection

- Force/torque load
- Initial condition

- **Copy**—Use this button to copy one of the entities in the list to a new name. This option is not available for cam-follower connections or slot-follower connections.

- **Delete**—Use this button to delete an entity from the model. You can also delete several entities at once. Hold the SHIFT key, highlight the entities, and press DELETE.

**Status**

The **Status** column on the finder dialog box gives current information on the part, assembly, or feature that the modeling entity references.

- **Suppressed**—The modeling entity references:
  - A part, assembly, or feature that is suppressed in Pro/ENGINEER.
  - A part, assembly, or feature in which the geometry is not included in the currently used simplified representation, family table, instance, or interchange assembly.

- **Incomplete**—The modeling entity references a part, assembly, or feature that you have changed or deleted.

You cannot edit the definition of a suppressed entity.

**To Copy a Modeling Entity**

Use this procedure to copy a previously defined gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to copy. A dialog box appears.
2. Select a previously defined entity from the list.
3. Click **Copy**. A new entity appears in the list, with *Copy of* appended to the name of the copied entity. This entity has the same definition as the entity from which it was copied.
4. Change the definition of the newly copied entity as needed by editing the appropriate information on any of the tabs in the definition dialog box.

**To Rename a Modeling Entity**

Use this procedure to rename a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to rename. A dialog box appears.
2. Select a previously defined entity from the list. If you place the cursor over the entity without clicking, a message box appears with the definition information for the entity.

3. Click **Edit**. A definition dialog box appears, and Mechanism Design highlights the model, showing the selected entity and an icon representing the entity.

4. Change the name in the text field. The name must be unique for each entity type.

5. Click **OK**.

To Delete a Modeling Entity

Use this procedure to delete a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to delete. A dialog box appears.

2. Select a previously defined entity from the list.

3. Click **Delete**. The selected entity is removed from the list and from the model.

Forces/Torques

About Force/Torque

Use the **Mechanism > Force/Torque** command to introduce or modify external forces or torques. You can create external forces and torques for your mechanism if you have a Mechanism Dynamics Option license.

You can apply a force/torque to simulate external influences on the motion of a mechanism. The force/torque usually represents a dynamic interaction of your mechanism with another body and can arise from a contact between parts belonging to the mechanism and entities external to the mechanism.

A force is always a push or a pull, causing objects to change their translation motion, for example, the force of your finger pushing a box causes the box to move according to the direction of the push. A torque is a turning or twisting force, such as the one applied to spin the top of a box.

The **Mechanism > Force/Torque** command opens a finder dialog box, that you can use to create, edit, copy, or delete your force/torque.

The **Force/Torque** dialog box also displays the status of an already created force/torque. If the force/torque is fully defined, the **Status** column on the dialog box is blank. For more information, see **Status**.

You can use the **View > Display Settings > Mechanism Display** command to turn on or off the display of any force/torque in your mechanism.

About the Force/Torque Definition Dialog Box
Use this dialog box to create a new force/torque or edit an existing one. To access this dialog box, click Mechanism > Force/Torque. When the Forces/Torques dialog box opens, click New or Edit.

The Force/Torque Definition dialog box displays the following information:

- **Type**—Use this field to select the type of force you want to apply and a reference entity for the force:
  - **Point Force**—Applies a force at a particular point on a body. You select a point or a vertex as a reference entity.
  - **Body Torque**—Applies a torque at the center of mass of the body. You select a body as a reference entity.
  - **Point to Point Force**—Applies a force to two points on different bodies. The force acts equally in opposite directions moving the two points toward each other when negative and away from each other when positive. If the two points are coincident, the magnitude of the force is equal to zero. You select two points or vertexes as reference entities. The first point is the origin of the force, the second indicates the direction. Mechanism Design reports results for the force acting on the first body you select when creating the force.

- **Magnitude**—Use this tab to specify the magnitude of the force/torque.

- **Direction**—Use this tab to specify the direction of the force/torque. This tab is not available when you select Point to Point as the type of your force.

**To Create a Force/Torque**

1. Click Mechanism > Force/Torque or the Forces/Torques dialog box appears.

2. Click New. The Force/Torque Definition dialog box appears.

3. Specify a name for the force/torque.

4. Select one of the following from the option menu in the Type field:
   - Point Force
   - Body Torque
   - Point to Point Force

5. Click and use the normal selection methods to select a reference entity on the model. To apply a point force, select a point or a vertex. For a body torque, select a body.

6. On the Magnitude tab, make one of the following selections for the function type:
   - If you select Constant, enter a value for the force/torque magnitude.
   - If you select Table, go to this procedure.
If you select **User Defined**, follow this procedure.

If you select **Custom Load**, specify the name of the custom load you want to use.

7. Select a **Variable** for table or user-defined functions.

8. On the **Direction** tab, specify the direction of the force/torque vector.

9. If you want to reverse the direction of the force/torque, click **Flip**.

10. Select one of the following from the **Direction Relative to** field:
    - **Ground**
    - **Body**

11. Click **OK** when you have finished defining your force/torque.

    The **Forces/Torques** dialog box reappears with the new force/torque listed.

**Magnitude Tab on the Force/Torque Definition Dialog Box**

Use the **Magnitude** tab of the **Force/Torque Definition** dialog box to specify the magnitude of the force or torque. The tab displays these fields:

- **Function**—Select one of the following functions that Mechanism Design uses to generate the magnitude of the force or torque. Depending on your selection in this field, the appearance of the tab changes.
  - **Constant**—Specify magnitude as a constant value. Enter the magnitude value in the **Constant** field.
  - **Table**—Generate the magnitude of the force/torque with values from a two-column table. The first column contains the values of the independent variable \( x \) that can relate to time or measure. The second column contains the values of the dependent variable that represents magnitude of the force/torque. Use the area under **Table** to work with the table.
  - **User Defined**—Generate the magnitude of the force/torque with the function you create. Use the area under **User Defined** to construct the function’s expression.
  - **Custom Load**—Apply complex, externally-defined set of loads to your model.
  - **Variable**—This drop-down menu appears when you select **Table** or **User Defined** as the function type. Use selections in this menu to specify the independent variable represented by \( x \) in the function defining magnitude.
    - **Time**—Define the magnitude as a function of the time of the analysis. Mechanism Design substitutes the time for any \( x \) variables in the function’s expression.
    - **Measure**—Define the magnitude as a function of any position or velocity measure that you created previously. Mechanism Design substitutes the value of the measure for any \( x \) variables in the function’s expression.


Mechanism Design Extension Help Topic Collection

- Click to view and format a graph of the magnitude function.

**Magnitude as a Table Function**

**Table** generates the magnitude of a servo motor, force motor, or force/torque with values you enter or import into a two-column table.

When you select **Table** as an option for the magnitude definition of a servo motor, force motor, or force/torque, the corresponding dialog box expands, displaying the following information:

- Click to add a new row to the table. The table has a two-column format:
  - **Time** or **Measure**—The first column displays the name of an independent variable \( x \), that, depending on your selection in the **Variable** field, could be **Time** or **Measure** for forces/torques and force motors, and is always **Time** for servo motors. Enter values for the independent variable in this column. The values must be in either increasing or decreasing sequence.
  - **Magnitude**—The second column displays the magnitude. Enter magnitude values in each row of the column.

- Click to delete highlighted rows. To highlight a consecutive series of rows, hold down the SHIFT key as you select the rows. To highlight several non-consecutive rows, hold down the CTRL key as you select the rows.

- **File**—Use this area to specify the name of an ASCII file with an extension of **.tab**. You can enter the name, or click the file selector button and browse to find an existing **.tab** file. Then click one of the following buttons:
  - Click to import table data from a **.tab** file that you previously created with any text editor. The file must contain two columns of equal length separated by spaces. Mechanism Design places the data from your file in the table, adding or deleting rows as needed to match the number of rows in the file.
  - Click to write data from the table on the dialog box to the specified **.tab** file.

- **Interpolation**—Use this area to select the interpolation method:
  - If you choose **Linear Fit**, Mechanism Design uses a straight line to connect the table points. If you define a profile that includes discontinuities, and you select **Linear Fit** when you graph the velocity or acceleration, Mechanism Design displays a warning message, and the graph may be inaccurate.
  - If you choose **Spline Fit**, Mechanism Design fits a cubic spline to each set of points. Using spline fit prevents sharp changes in the motion of the driven quantity.

  **Note:** For acceleration servo motors, only linear fit interpolation is available.
To Specify Force/Torque Magnitude as a Table Function

This procedure assumes that you are specifying **Magnitude** on the **Force/Torque Definition** dialog box.

1. Select **Table** from the **Magnitude** drop-down menu.

2. Click ![add_row_icon] to add a row to the table.

3. Select a **Variable** for your function. Depending on your selection, the first column of the table displays either **Time** or **Measure**.

4. Enter numerical values in the **Time** or **Measure** column. Values in this column must be in either increasing or decreasing sequence.

5. Enter numerical values in the **Magnitude** column.

6. If you need to remove a row from the table, highlight the row and then click ![remove_row_icon].

7. Click ![save_table_icon] to save the table information to the file listed under **File**.

8. To import table data from a previously created `.tab` file, select the name of the file and click ![import_table_icon]. The data from the file appears in the table columns.

9. Select either **Linear fit** or **Spline fit** to select the **Interpolation** scheme.

To Specify Force/Torque Magnitude as a User-Defined Function

This procedure assumes that you are specifying **Magnitude** on the **Force/Torque Definition** dialog box.

1. Select **User Defined** from the **Function** drop-down menu.

2. Select a measure name from the **Variable** drop-down list if you do not want to use time \( t \) as the independent variable.

3. Click ![add_row_icon] to add a row containing a default expression using \( t \) or the selected measure name, with no domain.

4. If you want to edit the expression select the row and click ![edit_expression_icon] to display the **Expression Definition** dialog box.

5. On the **Expression Definition** dialog box, enter an expression in the text-entry box, or use these options to define an expression:

   - Click ![operators_icon] to display the **Operators** dialog box.
   - Click ![constants_icon] to display the **Constants** dialog box.
   - Click ![functions_icon] to display the **Functions** dialog box.
• Click to display the **Variables** dialog box.

• Click to validate your expression and display the **Expression Graph** dialog box.

6. Check the **Specify domain** box to specify boundaries for the independent variable if needed. For the upper and lower domain bounds, select < from the drop-down list and enter a number for an exclusive bound, or select <= from the drop-down list and enter a number for an inclusive bound.

7. Click **OK**. The expression and domain values appear in the **Expression** and **Domain** columns on the **Magnitude** tab.

8. If you want to change an **Expression** or **Domain** value, click the value and edit it.

9. If you need to remove one or more rows from the table, highlight the rows and click .

**Magnitude as a User-Defined Function**

**User Defined** generates the magnitude of a servo motor, force motor, or force/torque with a function you create using sets of expressions and domain constraints.

For servo motors, you must define magnitude as a function of analysis time.

For force motors and forces/torques, you can define magnitude as a function of time, or as a function of multiple variables that may include time and one or more existing measures. For example, to define a force that decreases directly as the inverse of the separation between two points, first create a distance separation measure named *septn1*. Then define the force magnitude with the expression $1/septn1$.

When you select **User Defined** as an option for the magnitude definition of a servo motor, force motor, or force/torque, the corresponding dialog box expands displaying the following buttons and fields:

• Click to add a new row to the table. The table has a two-column format:

  o **Expression**—When you add a new row, this column contains a default expression, representing either time or, if applicable, a measure. You can edit the default expression directly in the table cell.

  o **Domain**—When you add a new row, this column contains no values for the expression domain. You can specify the domain values directly in the cell. For example, to enter a range of time between 1 and 10, enter $1 < t < 10$. Be aware that you must define each domain segment in the expression using only the primary variable.

• Click if you need to delete selected rows from the expression table.
• Click to edit the selected expression or domain. The **Expression Definition** dialog box appears. Use the dialog box to enter a new algebraic expression and domain. After you enter the new values, Mechanism Design places them in the expression table on the **Servo Motor Definition**, **Force Motor Definition**, or **Force/Torque Definition** dialog box.

• **Primary Variable**—Use the drop-down list to select time or a predefined measure. The selected variable appears in the formula in the **Expression** column here and in the **Expression Definition** dialog box. This field is available only on the **Force Motor Definition** and **Force/Torque Definition** dialog boxes.

For Mechanism Design to provide a two-dimensional plot of your expression, you must select one variable as a primary variable. Mechanism Design uses the primary variable for the X axis when it graphs your expression, and requires you to supply constant values for the other variables—the secondary variables—in the expression. In addition, you must use the primary variable to specify all domain segments in the expression.

• **Unit Conversion Factor**—This uneditable field becomes visible only when you initially defined the user-defined function in a unit system different from the current one. The field lists the variables included in the expression and the magnitude of the expression and displays the multiplication factors that Mechanism Design uses to convert the numerical values to the current unit system.

**Direction Tab on the Force/Torque Definition Dialog Box**

Use the **Direction** tab of the **Force/Torque Definition** dialog box to specify the direction for the force/torque vector you are applying. The tab displays these fields:

• **Define Direction by:**
  - **Typed Vector**—Choose a coordinate system and enter coordinates to indicate the direction of the vector. You can select either the LCS or the WCS.
  - **Straight Edge, Curve, or Axis**—You select a straight edge, a curve, or an axis on the body to place the vector along or parallel to your selection. Use the **Flip** button if you want to reverse the direction of the force/torque.
  - **Point-to-Point**—You select two body points or vertices to indicate the direction of the vector. Use the **Flip** button if you want to reverse the direction of the force/torque.

• **Direction Relative to:**
  - **Ground**—Creates a force/torque with its direction relative to the fixed ground body.
  - **Body**—Creates a force/torque with its direction relative to the moving part.

**To Edit a Force/Torque**

1. Click **Mechanism > Force/Torque**. The **Force/Torque** dialog box appears.
2. Select a force/torque from the list.

3. Click **Edit**. The **Force/Torque Definition** dialog box appears. Mechanism Design highlights the force/torque icon and corresponding reference entities on the body.

4. Change any of the following items:
   - **Type**
   - **Magnitude**
   - **Direction**
   - **Direction Relative to**

5. Click **Apply** to update the mechanism and examine any changes.

6. Click **OK** to save the modified force/torque specification.

**Note:** To revert to the previously saved force/torque definition, click **Cancel** while editing the force/torque.

**Finder Dialog Box**

A finder dialog box opens when you select certain modeling entities from the **Mechanism** menu. Use this dialog box to organize and control your force and servo motors, springs, dampers, force or torque loads, cam-follower connections, slot-follower connections, gear pairs, or initial conditions. The dialog box includes a list of the entities you have created in your model. You can use this form to add a new entity, edit an existing entity, copy an existing entity to a new name, or remove an existing entity from your model.

To get information on an entity in the list, place the cursor over the item's name without clicking. A message box appears with a summary of the parameters used to define the entity.

The finder form includes the following fields:

- **Name**—The default name is based on the entity type with a number appended. For example, the default name for the first spring you create will be **Spring1**. If you want to change the name, highlight it, and edit it.

  It is a good idea to use more meaningful names to help you keep track of what you have created.

- **Status**
- **New**—Use this button to create one of the following types of entities:
  - **Cam-follower connection**
  - **Slot-follower connection**
  - **Servo motor**
  - Force motor
  - Gear pair
Mechanism Design Extension

- **Spring**
- **Damper**
- **Force/torque load**
- **Initial condition**

- **Edit**—Use this button to change the definition of one of the following entities:
  - **Cam-follower connection**
  - **Slot-follower connection**
  - **Servo motor**
    - **Force motor**
    - **Gear pair**
  - **Spring**
  - **Damper**
  - **Force/torque load**
  - **Initial condition**

- **Copy**—Use this button to copy one of the entities in the list to a new name. This option is not available for cam-follower connections or slot-follower connections.

- **Delete**—Use this button to delete an entity from the model. You can also delete several entities at once. Hold the SHIFT key, highlight the entities, and press DELETE.

**Status**

The **Status** column on the finder dialog box gives current information on the part, assembly, or feature that the modeling entity references.

- **Suppressed**—The modeling entity references:
  - A part, assembly, or feature that is suppressed in Pro/ENGINEER.
  - A part, assembly, or feature in which the geometry is not included in the currently used simplified representation, family table, instance, or interchange assembly.

- **Incomplete**—The modeling entity references a part, assembly, or feature that you have changed or deleted.

You cannot edit the definition of a suppressed entity.

**To Copy a Modeling Entity**

Use this procedure to copy a previously defined gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to copy. A dialog box appears.
2. Select a previously defined entity from the list.

3. Click **Copy**. A new entity appears in the list, with *Copy of* appended to the name of the copied entity. This entity has the same definition as the entity from which it was copied.

4. Change the definition of the newly copied entity as needed by editing the appropriate information on any of the tabs in the definition dialog box.

**To Rename a Modeling Entity**

Use this procedure to rename a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to rename. A dialog box appears.

2. Select a previously defined entity from the list. If you place the cursor over the entity without clicking, a message box appears with the definition information for the entity.

3. Click **Edit**. A definition dialog box appears, and Mechanism Design highlights the model, showing the selected entity and an icon representing the entity.

4. Change the name in the text field. The name must be unique for each entity type.

5. Click **OK**.

**To Delete a Modeling Entity**

Use this procedure to delete a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to delete. A dialog box appears.

2. Select a previously defined entity from the list.

3. Click **Delete**. The selected entity is removed from the list and from the model.

**About Graphing**

Use the **Graph tool** window to display plots of measure results and the functions that define motor and force profiles. After you display your graph, you can interact with it in several ways. To find out the x and y values for any graph point, click on the point and a dialog box appears showing the values. To work with the graph and manage its appearance, use toolbar buttons or the following menu commands:

- **File**
  - **Export Excel**—This option is available on Windows only. Use it to save the graph data as a Microsoft Excel spreadsheet. When you click this command, Mechanism Design displays the **Export To Excel** dialog box. Enter a path
and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a `.xlc` extension. The file contains a pictorial rendition of the graph as well as a numeric table of graph values.

- **Export Text**—Save the graph data as a text file. When you click this command, Mechanism Design displays the **Export To Text** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a `.grt` extension.

- **Print**—Send your graph to a printer. When you click this command, a dialog box appears that allows you to output your graph to several print and graphic formats, or save it as a file.

- **Exit**—Close the **Graphtool** window.

### View

- **Toggle Grid**—Display grid lines for your graph or turn them off.

- **Repaint**—Refresh the view of your graph.

- **Refit**—Restore a graph to its original state. Use this command after you zoom in on a particular graph segment to return to an unsegmented state. Mechanism Design automatically redraws the complete graph in the current window.

- **Zoom In**—Zoom in on the graph to get a close-up view. This command is especially useful when your graph contains too many points, 100 or more. Zooming in on a section of the graph helps you to display a specific segment of interest.

### Format

**Graph**—Open the **Graph Window Options** dialog box to manage your graph and its display window.

### Gravity

#### About Gravity

Use the **Mechanism > Gravity** command to specify the acceleration vector due to gravity for your model. The **Gravity** command allows you to simulate the effect of a gravitational force on the motion of your assembly. You can define gravity if you have a Mechanism Dynamics Option license.

Gravity is a fundamental physical force that pulls one body toward another. The **Gravity** command simulates this interaction. Bodies in your assembly, with the exception of the ground body, will move in the direction of the specified gravitational acceleration.

Mechanism Design applies one uniform gravitational force to the entire top-level assembly.

The **Gravity** command opens the **Gravity** dialog box, which you use to define the magnitude and direction for gravitational acceleration. You can also use this dialog
box to edit or remove gravity. When you use the Gravity command, a WCS icon and an arrow showing the direction of the gravitational acceleration appear on your model.

If you want Mechanism Design to include gravity in the calculations when doing a dynamic, static, or force balance analysis, select the Enable Gravity check box on the Ext Loads tab of the Analysis Definition dialog box. If you do not select this box, Mechanism Design does not apply a gravitational force during the analysis.

**About the Gravity Dialog Box**

Use the Gravity dialog box to define a gravitational acceleration vector for your model. The dialog box contains the following information:

- **Magnitude**—Enter a positive value for the magnitude of the acceleration for your gravitational force in distance/second\(^2\). The distance measurement depends on the units you have chosen for your assembly. To change the units, use the Pro/ENGINEER command Assembly > Set Up > Units.

  The default value for Magnitude is the gravitational constant expressed in default Pro/ENGINEER units (for example, 386 in/second\(^2\)).

- **Direction**—Enter X, Y, and Z coordinates to define the vector of the gravitational acceleration and force. The direction is defined with respect to the default coordinate system of the top-level assembly in your mechanism.

  The default direction for the gravitational acceleration is the negative Y direction of the World Coordinate System (WCS), as shown by the directional vector.

**To Define Gravity**

1. Click Mechanism > Gravity or \(\text{ Gravity}\). The Gravity dialog box appears. A WCS icon and an arrow showing the direction of the gravitational acceleration also appear.

2. Enter a positive value for the magnitude of the gravity acceleration vector.

3. Enter the directional coordinates for the vector.

4. Click OK.

   **Note:** To apply gravity to your mechanism during an analysis, you must select the Enable Gravity check box on the Ext Loads tab of the Analysis Definition dialog box.

**To Edit Gravity**

1. Click Mechanism > Gravity or \(\text{ Gravity}\). The Gravity dialog box appears. A WCS icon and an arrow showing the direction of the gravitational acceleration also appear.
2. Edit the magnitude of the gravity acceleration vector.
3. Edit the directional coordinates for the vector.
4. Press ENTER. The direction of the arrow changes to match the current directional vector.
5. Click OK.

Note: If you do not select the Enable Gravity check box on the Ext Loads tab of the Analysis Definition dialog box, Mechanism Design does not apply a gravitational force during an analysis.

To Copy a Modeling Entity

Use this procedure to copy a previously defined gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click Mechanism and the type of entity you want to copy. A dialog box appears.
2. Select a previously defined entity from the list.
3. Click Copy. A new entity appears in the list, with Copy of appended to the name of the copied entity. This entity has the same definition as the entity from which it was copied.
4. Change the definition of the newly copied entity as needed by editing the appropriate information on any of the tabs in the definition dialog box.

To Rename a Modeling Entity

Use this procedure to rename a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click Mechanism and the type of entity you want to rename. A dialog box appears.
2. Select a previously defined entity from the list. If you place the cursor over the entity without clicking, a message box appears with the definition information for the entity.
3. Click Edit. A definition dialog box appears, and Mechanism Design highlights the model, showing the selected entity and an icon representing the entity.
4. Change the name in the text field. The name must be unique for each entity type.
5. Click OK.

To Remove Gravity
1. Click **Mechanism > Gravity** or . The **Gravity** dialog box appears. A WCS icon and an arrow showing the direction of the gravitational acceleration also appear.

2. Enter zero for the magnitude of the gravity acceleration vector.

3. Click **OK**.

   Note: If you do not select the **Enable Gravity** check box on the **Ext Loads** tab of the **Analysis Definition** dialog box, Mechanism Design does not apply a gravitational force during an analysis.

---

**Gears**

**About Gear Pairs**

Use gear pairs when you want to control the velocity relationship between two joint axes. Each gear in a gear pair requires two bodies with a joint connection. The first body, designated the carrier, typically remains stationary. The second body moves, and may be called a gear, pinion, or rack, depending upon the type of gear pair you create. The gear pair connection constrains the velocity of the two joint axes, but not the relative spatial orientation of the bodies that are connected by the joints. If you want to change the orientation of the bodies in your gear pair to satisfy other physical constraints in the mechanism, for assembly regeneration, or to specify servo motor profiles, use the **Drag** dialog box to configure the beginning orientation of the gear bodies in your gear pair.

You can also change the settings of the joint axes. It is not necessary for the surfaces of the two moving bodies in a gear pair to be in contact for the gear pair to work. Because gear pairs in Mechanism Design are velocity constraints, and are not based on your model’s geometry, you can specify the gear ratio directly. This means that you can change gear ratios easily without creating new geometry.

The presence of a gear pair in your mechanism may affect the results of an analysis in which mass is taken into account, including dynamic, force balance, or static analysis.

You can create two types of gear pairs in Mechanism Design.

- **Standard**—Use a standard gear pair when you want your two gears to rotate in the same or opposite directions, for example to simulate a spur-spur or worm and wheel gear.

- **Rack and Pinion**—Use a rack and pinion gear pair when you want to translate rotational motion into translational motion.

Note that gear pairs you create in Mechanism Design are available in Design Animation. You can create an animation displaying the relative velocity of the two gear bodies, and choose to disable the gear-pair connection during a portion of the animation.
The **Mechanism > Gears** command opens a finder (the **Gear Pairs**) dialog box, which you can use to create, edit, copy, or delete your gear pairs.

The **Gear Pairs** dialog box also displays the status of already created gear pairs. If your gear pair is fully defined, the **Status** column on the **Gear Pairs** dialog box is blank. For more information, see **Status**.

You can use the **View > Display Settings > Mechanism Display** command to turn on or off the display of gear pair icons in your mechanism.

**To Create Gear Pairs**

1. Select **Mechanism > Gears** or click ![image](image). The **Gear Pairs** dialog box appears.
2. Click **New**. The **Gear Pair Definition** dialog box appears.
3. Accept the default name, or enter a descriptive name for your gear pair.
4. Select one of the **Types** from the drop-down menu. The items on the dialog box change depending upon the type of gear pair you select. Click below for more information.
   - **Standard**
   - **Rack & Pinion**
5. Fill in the information on the tabs.
6. Click **Apply** to accept your changes without closing the dialog box.
7. Click **Cancel** to discard your changes and close the dialog box, or **OK** to accept your definition and close the dialog box.

**To Define Standard Gear Pairs**

This procedure assumes you have selected **Standard** under **Type** on the **Gear Pair Definition** dialog box.

1. On the **Gear1** tab, click ![image](image) and select a rotational joint axis of a pin, cylinder, bearing, or planar joint.
2. Mechanism Design designates the first body in the joint connection the **Carrier** and the second body the **Gear**. Click ![image](image) to switch the body definition.
3. Enter a value for the diameter of the pitch circle. Mechanism Design displays a circle with the entered diameter, which is centered around the selected joint axis. A straight line from the center of the circle to the circumference indicates the zero reference point of the joint axis.
4. Click ![image](image) under **Icon Location** and select a point or vertex for the offset of the pitch circle.
5. On the **Gear2** tab, click ![image](image) and select a rotational joint axis of a joint.
6. Fill in the remaining information on the Gear2 tab as described in steps 2, 3, and 4.

7. On the Properties tab, select a Gear Ratio from the drop-down list.

8. If you select Pitch Circle Diameter, Mechanism Design displays the values you entered for the pitch circles on the Gear1 and Gear2 tabs.

9. If you select User Defined, enter real number values for relative pitch circle diameters under Gear1 and Gear2 in the Gear Ratio area.

Defining Standard Gear Pairs

Use standard gear pairs to represent gear pairs in which the movement of both gears is rotational. Use standard gear pairs to simulate for example, spur-spur, bevel-bevel, helical-helical, worm and wheel, and epicyclical gears. You can control the direction of rotation of the joint axis for Gear2. By doing so, you can simulate gears that rotate in the same (internal) or opposite (external) direction.

When you select Standard on the Gear Pair Definition dialog box, you must specify information for the following items:

- Gear1 tab
  - Select a rotational joint axis. A double-headed shaded arrow appears on the joint, indicating the positive direction for the axis. Use the right-hand rule to determine the direction of rotation.

  Mechanism Design displays the names of the bodies connected by the joint in the Body area of the tab. By default, the first body in the connection is called the Carrier, the second body the Gear. If you want to reverse the body order, click You can view the body order associated with a given connection in the Model Tree by expanding Connections > Joints > Connection_name.

  Enter a value for the diameter of the pitch circle icon. When you click ENTER, the size of the pitch circle icon changes to match your entry. You can set the gear pair velocity ratio equal to the inverse of the ratio of pitch circles on the Properties tab, but the graphic display of the pitch circle does not affect the gear pair definition.

  Use the selector arrow beside Icon Location to select a point for the offset of the pitch circle icon from the joint axis zero, or middle-click to accept the default location. Mechanism Design displays the pitch circle and joint axis zero reference.

- Gear2 tab
  - Select a rotational joint axis. A double-headed shaded arrow appears on the joint, indicating the positive direction for the axis. Use the right-hand rule to determine the direction of rotation. If you want to change the direction of rotation of the joint axis, click .
Mechanism Design also displays the names of the bodies connected by the joint in the **Body** area of the tab. By default, the first body in the connection is called the **Carrier**, the second body the **Gear**. If you want to reverse the body order, click ![Reverse](image)

- Enter a value for the diameter of the pitch circle icon. When you press ENTER, the size of the pitch circle icon changes to match your entry. You can set the gear pair velocity ratio equal to the ratio of pitch circles on the **Properties** tab, but the graphic display of the pitch circle does not otherwise affect the gear pair definition.

- Use the selector arrow beside **Icon Location** to select a point for the offset of the pitch circle icon from the joint axis zero, or middle-click to accept the default location. Mechanism Design displays the pitch circle and joint axis zero reference.

**Properties tab**

- The **Gear Ratio** area defines the relative velocity of the two gears in your gear pair. If you want to use the inverse of the ratio of the pitch circle diameters that you defined on the **Gear1** and **Gear2** tabs as the velocity ratio, select **Pitch Circle Diameter** from the drop-down list. Mechanism Design displays the ratio in uneditable fields under **D1** and **D2**.

You can also select **User Defined** and enter values for pitch circle diameters under Gear1 and Gear2. The ratio of the gear velocities is equal to the inverse of the ratio of the pitch circle diameters.

\[
\frac{\text{Gear 1 velocity}}{\text{Gear 2 velocity}} = \frac{\text{Diameter 2}}{\text{Diameter 1}}
\]

When you click **Accept** or **OK**, Mechanism Design displays a gear pair icon on your model.

**To Define Rack and Pinion Gear Pairs**

This procedure assumes you have selected **Rack & Pinion** under **Type** on the **Gear Pair Definition** dialog box.

1. On the **Pinion** tab, click ![Select](image) and select a rotational joint axis of a pin, cylinder, bearing, or planar joint. A double-headed shaded arrow appears indicating the positive rotation axis.

2. Mechanism Design designates the first body in the joint connection the **Carrier** and the second body the **Pinion**, and displays the names in the **Body** area. Click ![Switch](image) to switch the body definition.

3. Enter a real number for the diameter of the pitch circle. Mechanism Design displays a circle with the entered diameter centered around the selected joint axis.

4. Click ![Select](image) under **Icon Location** and select a point for the offset of the pitch circle.
5. On the **Rack** tab, click and select a translational joint axis of a planar, slider, or cylinder joint. A shaded arrow appears on the joint, indicating the positive translation direction.

6. Mechanism Design designates the first body in the joint connection the **Carrier** and the second body the **Rack**. Click to switch the body definition.

7. Click under **Icon Location** and select an offset location for the pitch line.

8. On the **Properties** tab, select a **Rack Ratio** from the drop-down list.

9. If you select **Pitch Circle Diameter**, Mechanism Design displays values based on the pitch circle diameter you entered on the **Pinion** tab.

10. If you select **User Defined**, enter a value for the **Rack Ratio**.

### Defining Rack and Pinion Gear Pairs

A rack and pinion gear pair converts rotational to translational motion. To model a rack and pinion gear pair, your model must include a rotational joint axis and a translational joint axis. Note that the joint axis limits on the translational joint axis do not affect the rack and pinion gear pair movement. To define limits on the translational motion, you must use servo motor definition. For example, you can define a position servo motor or a table servo motor on the translational joint axis in such a way that the translational motion stops at the end of the rack.

When you select **Rack & Pinion** in the **Type** area of the **Gear Pair Definition** dialog box, you must specify information for the following items:

- **Pinion tab**
  - Select a rotational joint axis. A double-headed, magenta, shaded arrow appears on the joint, indicating the positive direction for the axis. Use the right-hand rule to determine the direction of rotation.

    Mechanism Design displays the names of the bodies connected by the joint in the **Body** area of the tab. By default, the first body in the connection is called the **Carrier**, the second body the **Pinion**. If you want to reverse the body order, click . You can view the body order associated with a given connection in the Model Tree by expanding **Connections > Joints > Connection_name**.

    - Enter a value for the diameter of the pitch circle icon. When you press ENTER, the size of the pitch circle icon changes to match your entry. Theoretically, a pitch circle represents the diameter of a perfect cylinder that obeys the kinematic gearing equation. However, in Mechanism Design, the pitch circle is used only for graphic display, and the diameter does not affect the gear velocity ratio.

    - Use the selector arrow beside **Icon Location** to select a point for the offset of the pitch circle from the joint axis zero, or middle-click to accept the
default location. Mechanism Design displays the pitch circle and the joint axis zero reference.

- **Rack tab**
  - Select a translational joint axis. A shaded arrow appears indicating the positive translation direction. If you want to reverse the direction, click \[ \text{\textbullet} \]. Mechanism Design also displays the names of the bodies connected by the joint in the **Body** area of the tab. By default, the first body in the connection is the **Carrier**, the second is the **Rack**. If you want to reverse the body order, click \[ \text{\textbullet} \].
  - The default length for the pitch line is the pitch circle diameter you entered on the **Pinion** tab, and by default it is tangent to the pinion pitch circle. Use the selector arrow beside **Icon Location** to select a point for the offset of the pitch line.

- **Properties tab**
  - The **Rack Ratio** area defines the ratio of the length of the rack’s translation axis per revolution of the rotational axis. This represents the relationship between linear translation and pinion revolutions. You can use the value based upon the **Pitch Circle Diameter** from the **Pinion** tab, which is the circumference of the pitch circle, or you can select **User Defined** and enter a number for the ratio.

**To Define Gear Pair Orientation**

Use this procedure to adjust the relative spatial orientation of the bodies in your gear pair. You should have completed the procedure to create the gear pair.

1. Click **Mechanism > Drag** or \[ \text{\textbullet} \]. The **Drag** dialog box appears.

2. Select the **Constraints** tab and click \[ \text{\textbullet} \]. Select the icon of the gear connection that you want to disable. The constraint appears in the list.

3. Click \[ \text{\textbullet} \] and drag the bodies in the gear pair to the desired configuration.

4. Clear the check box beside the constraint that you created in step 2. This enables the gear pair connection. If you want to delete the constraint, highlight it and click \[ \text{\textbullet} \].

5. Click \[ \text{\textbullet} \] to record a snapshot. Mechanism Design adds the snapshot to the list on the **Snapshots** tab.

6. If you are running a kinematic, repeated assembly, force balance, or static analysis, select the snapshot for the **Initial Configuration**.

7. If you are running a dynamic analysis, use the snapshot to define an **Initial Condition** for your analysis.
You can also use the **Joint Axis Settings** dialog box to redefine the joint axis zeros.

**Using Gear Pairs in Mechanism Dynamics Analyses**

The presence of a gear pair in your mechanism may affect the results of an analysis in which mass is taken into account, including dynamic, force balance, or static analysis.

Each gear in a gear pair comprises one body, called a gear, rack, or pinion, and a second body called the carrier, connected by a joint. One way to ensure that the geometry in your gear pair maintains the desired spatial orientation during an analysis is to use the same body as the carrier body for both gears. This can be ground or another body in the mechanism. The figure shows a simple standard gear pair in which the two parts used for the carrier bodies (purple blocks) belong to the same Mechanism Design body.

Be aware that if you create a gear pair in which the gears do not have a common carrier body, it may affect the results of a dynamic, force balance, or static analysis. For gear pairs without a common carrier body, Mechanism Design creates an invisible internal body to serve as a common carrier body, and assigns it a mass equal to 0.001 times the mass of the smallest body in the assembly. When you run a dynamic, force balance, or static analysis, a message appears stating that one of the gear-pair connections does not have a common carrier body. If you feel that using the mass of the invisible internal body will adversely affect your analysis results, stop the analysis and redesign your mechanism so that the gear pair includes a common carrier body. Otherwise, you can continue the analysis with the invisible internal body.
To Edit a Gear Pair

1. Click **Mechanism > Gears**. The **Gear Pairs** dialog box appears.
2. Select a gear pair from the list of existing gear pairs.
3. Click **Edit**. The **Gear Pair Definition** dialog box appears. Mechanism Design highlights the gear pair connection and the bodies in each gear, and displays the gear pair icon.
4. Change the text in the **Name** entry box to rename your gear pair.
5. If you are editing a **Standard** gear pair, change any of the information on the **Gear1**, **Gear2**, or **Properties** tab.
6. If you are editing a **Rack & Pinion** gear pair, change any of the information on the **Pinion**, **Rack**, or **Properties** tab.
7. Click **Apply** to update the model and examine the changes.
8. Click **OK** to save the modified damper specification.

**Note:** To revert to the previously saved gear pair definition, click **Cancel** while editing the gear pair.

To Copy a Modeling Entity

Use this procedure to copy a previously defined gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to copy. A dialog box appears.
2. Select a previously defined entity from the list.
3. Click **Copy**. A new entity appears in the list, with **Copy of** appended to the name of the copied entity. This entity has the same definition as the entity from which it was copied.
4. Change the definition of the newly copied entity as needed by editing the appropriate information on any of the tabs in the definition dialog box.

To Rename a Modeling Entity

Use this procedure to rename a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to rename. A dialog box appears.
2. Select a previously defined entity from the list. If you place the cursor over the entity without clicking, a message box appears with the definition information for the entity.
3. Click **Edit**. A definition dialog box appears, and Mechanism Design highlights the model, showing the selected entity and an icon representing the entity.
4. Change the name in the text field. The name must be unique for each entity type.

5. Click OK.

To Delete a Modeling Entity

Use this procedure to delete a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click Mechanism and the type of entity you want to delete. A dialog box appears.

2. Select a previously defined entity from the list.

3. Click Delete. The selected entity is removed from the list and from the model.

Servo Motors

About Servo Motors

You use servo motors to impose a particular motion on a mechanism. Servo motors cause a specific type of motion to occur between two bodies in a single degree of freedom. You add servo motors to your model to prepare it for analysis.

Servo motors specify position, velocity, or acceleration as a function of time, and can control either translational or rotational motion. For example, a servo motor starts in a specific configuration. After one second, another configuration is defined for the model. The difference between the two configurations is the motion of the model.

By specifying your servo motor's function, such as constant or ramp, you can define the motion's profile. You can select from several predefined functions, or input your own function. You can define as many servo motors on an entity as you like.

Note: If you select or define a position or velocity function for your servo motor profile that is not continuous, be aware that it will be ignored if you run a kinematic or dynamic analysis. However, you can use a discontinuous servo motor profile in a repeated assembly analysis. When you graph a discontinuous servo motor, Mechanism Design displays messages indicating the discontinuous points.

You can place servo motors on joint axes or on geometric entities such as part planes, datum planes, and points. You can use the following types of servo motors:

- **Joint Axis Servo Motors**—Use to create a well-defined motion in one direction.
- **Geometric Servo Motors**—Use to create complex 3D motions such as a helix or other space curves.

The Mechanism > Servo Motors command opens a dialog box that you use to create, edit, copy, or delete your servo motors. You cannot copy or delete incomplete servo motors.

The dialog box also indicates the status of any servo motors that are already created. If your servo motor is fully defined, the Status column is blank.

To Create a Servo Motor
1. Click **Mechanism > Servo Motors** or  
   The **Servo Motors** dialog box appears.

2. Click **New**. The **Servo Motor Definition** dialog box appears.

3. Enter a name for the servo motor.

4. Fill in the information on the following tabs:
   - Type
   - Profile

5. Click **OK** when you have completed the form.

   The **Servo Motors** dialog box re-appears with the new servo motor listed, and a servo motor icon appears on your mechanism. The icon points in the direction of the motion.

**To Define the Servo Motor Type**

1. Click the **Type** tab in the **Servo Motor Definition** dialog box.

2. From the **Driven Entity** drop-down menu, click either Joint Axis, Point, or Plane.

   **Note:** If you select points or planes to define the servo motor, you are creating geometric servo motors.

3. Click and use the normal selection methods to select an entity from the model. This entity moves when you activate the servo motor, unless it is grounded. It may also initiate movement in other entities of the model.

4. If you selected a point or plane as the driven entity, select Point or Plane from the **Reference Entity** area. Click and use the normal selection methods to select an entity from the model.

5. If you selected a point as the reference entity, click under **Motion Direction** and select an edge or datum axis on the model. A magenta arrow appears, pointing in the direction the driven entity will move relative to the reference entity.

6. If you want to change the direction of the motion, click **Flip**.

7. Click either Translation or Rotation (in degrees) to determine the type of motion. If you select an entity, such as a joint type, that has only rotational or translational freedom, this option may be changed automatically if it is not set correctly.

**About the Type Tab in the Servo Motor Definition Dialog Box**

The servo motor **Type** tab displays the following information:
• **Driven Entity**—The driven entity is the entity that actually moves in the model when the motor activates.
  
  o **Joint Axis**—Causes a joint to make a specific motion.
  
  o **Point**—Causes a point in your model to make a specific motion.
  
  o **Plane**—Causes a plane in your model to make a specific motion.

  **Note**: For servo motors on a point or plane, the reference entity may also move if it is not grounded. The servo motor simply specifies the relative motion of the driven entity with respect to the reference entity.

• **Reference Entity**—The driven entity moves relative to the reference entity according to the information you specify on the Profile tab of the Servo Motor Definition dialog box.
  
  o **Point**—Uses a point as the reference entity for the motion of your model.
  
  o **Plane**—Uses a plane as the reference entity for the motion of your model.

• **Motion Direction**—If you select a point as a reference entity, you must select an edge or datum axis to define the direction. If your servo motor has rotational motion, the entity you select is the axis of rotation.

• **Flip**—This button changes the motion direction of a servo motor that has a point or plane as a reference entity.

  The positive rotation direction is assumed using the right-hand rule. When your thumb is aligned with the joint axis, and points in the direction of the joint axis arrow, your fingers curl in the direction of the positive rotation.

• **Motion Type**—The motion type establishes a directional basis for the motion of the entity.
  
  o **Translational**—Select this if you want your model to move in a line without rotation.
  
  o **Rotational**—Select this if you want your model to move about an axis.

**To Define the Profile for a Servo Motor**

1. Click the **Profile** tab in the Servo Motor Definition dialog box.

2. Select one of the following choices for **Specification**:
  
  o **Position**
  
  o **Velocity**
  
  o **Acceleration**

3. If you select **Velocity** or **Acceleration**, you can specify an **Initial Position**.
  
  o The **Current** position is the position displayed on screen. This is the default.
If you clear the **Current** check box, you can enter a value for the initial position. Click to view the model with the entered value.

4. If you select **Acceleration**, you can specify an **Initial Velocity**.

5. Select one of the choices for **Magnitude**. Separate procedures exist for table servo motors and servo motors as a user-defined function.

6. Specify the values of magnitude for the motor.

7. If you want to graphically view the profile of the servo motor with your current settings, use the **Graph** section to define the layout in the **Graphtool** window.
   - Select the appropriate check box to graph your servo motor profile as a function of **Position**, **Velocity**, or **Acceleration**.
   - Select the **In separate figures** check box if you want each type of graph to display in a separate figure.

8. Click to display the **Graphtool** window.

9. If you want to change the profile, do not close the graph window. Redefine the specification and magnitude, and click again to update the graph display. When you see the profile you want, close the graph window and accept the servo motor.

### About the Profile Tab in the Servo Motor Definition Dialog Box

The servo motor **Profile** tab displays the following information:

- **Specification**—The specifications define the type of movement you get from your servo motor.
  - Click to change the position of the joint axis to the currently defined zero position. This button allows you to set or modify the zero position of the selected joint axis.
  - Select **Position** from the drop-down list to specify the servo motor motion in terms of the position of the selected entity.
  - Select **Velocity** from the drop-down list to specify the servo motor motion in terms of its velocity. By default, Mechanism Design uses the current position of the servo motor when it begins the motion. If you want to specify another **Initial Position**, clear the **Current** check box and specify a value relative to the joint axis zero for a velocity servo motor.
  - Select **Acceleration** from the drop-down list to specify the servo motor motion in terms of its acceleration. You can also enter values for the **Initial Position** and **Initial Velocity** for an acceleration servo motor.

If you set an initial position for velocity or acceleration, Mechanism Design uses this initial position when running the motion analysis. Select the
**Current** check box to use the current position of the model as the starting position.

- **Initial Position**—This defines the starting position for your servo motor, and only becomes available if **Velocity** or **Acceleration** is chosen.

- **Initial Velocity**—This defines the velocity of the servo motor at the beginning of the analysis, and only becomes available if **Acceleration** is chosen.

- **Magnitude**—This area defines the magnitude of the servo motor. The magnitude can be a constant value, or it can be defined by one of the functions you select. Mechanism Design uses this function to generate the magnitude.

- **Graph**—Defines the layout of the graph display.
  
  - **Position**—Graphs the position profile of the servo motor.
  - **Velocity**—Graphs the velocity profile of the servo motor.
  - **Acceleration**—Graphs the acceleration profile of the servo motor.
  - **In Separate Figures**—Displays the profiles in separate graphs.
  
  - Click to open the **Graphtool** window, which displays the graphs you have defined.

**About Magnitude Settings**

Depending on the type of motion you want to impose on your mechanism, you can define the magnitude of your servo motors or force motors in many ways. The following table lists different types of functions that Mechanism Design uses to generate the magnitude. You need to enter the values of the coefficients for the functions. The value of \( x \) in the function expressions is supplied by the simulation time or, for force motors, by either the simulation time or a measure you select.

<table>
<thead>
<tr>
<th>Function Type</th>
<th>Description</th>
<th>Required Settings</th>
</tr>
</thead>
</table>
| Constant      | Use if you want a constant profile. | \( q = A \)  
where  
\( A = \text{Constant} \) |
| Ramp          | Use if you want a profile that changes linearly over time. | \( q = A + B*x \)  
where  
\( A = \text{Constant} \)  
\( B = \text{Slope} \) |
| Cosine        | Use if you want to assign a cosine wave value to the motor profile. | \( q = A\cos(360*x/T + B) + C \)  
where |
### Mechanism Design Extension

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Equation</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sine-Constant-Cosine-Acceleration (SCCA)</td>
<td>Use to simulate a cam profile output. SCCA can only be used when Acceleration is chosen. This profile is not applicable for force motors.</td>
<td>For more information, see Magnitude Settings for Sine-Constant-Cosine-Acceleration Motor Profile.</td>
<td>A = Amplitude, B = Phase, C = Offset, T = Period</td>
</tr>
<tr>
<td>Cycloidal</td>
<td>Use to simulate a cam profile output.</td>
<td>q = L<em>x/T – L</em>sin(2<em>Pi</em>x/T)/2*Pi where L = Total rise, T = Period</td>
<td></td>
</tr>
<tr>
<td>Parabolic</td>
<td>Can be used to simulate a trajectory for a motor.</td>
<td>q = A*x + 1/2 B(x^2) where A = Linear coefficient, B = Quadratic coefficient</td>
<td></td>
</tr>
<tr>
<td>Polynomial</td>
<td>Use for generic motor profiles.</td>
<td>q = A + B<em>x + C</em>x^2 + D*x^3 where A = Constant term coefficient, B = Linear term coefficient, C = Quadratic term coefficient, D = Cubic term coefficient</td>
<td></td>
</tr>
<tr>
<td>Table</td>
<td>Use to generate the magnitude with values from a two-column table. If you have output measure results to a table, you can use that table here.</td>
<td>For more information, see Magnitude as a Table Function.</td>
<td></td>
</tr>
<tr>
<td>User Defined</td>
<td>Use to specify any kind of complex profile defined by multiple expression segments.</td>
<td>For more information, see Magnitude as a User-Defined Function.</td>
<td></td>
</tr>
<tr>
<td>Custom Load</td>
<td>This option is only available for the force motor definition. Use it to apply a complex,</td>
<td>For more information, see Custom Load.</td>
<td></td>
</tr>
</tbody>
</table>
Use a single profile if possible. But you can use a combination of profiles to generate certain types of motion. For example, a combination of ramp and cosine generates a sinusoidal motion that ramps up over time. For more information, see this example, which shows different types of motion the motor creates.

**Example: Types of Motor Profiles**

The following graph depicts different types of motion the motor creates.

Following are the values from the formulas that were used to generate the profiles in this graphic:

<table>
<thead>
<tr>
<th>Constant</th>
<th>Ramp</th>
<th>Cosine</th>
<th>Cycloidal</th>
<th>SCCA</th>
<th>Parabolic</th>
<th>Polynomial</th>
</tr>
</thead>
<tbody>
<tr>
<td>A = 8</td>
<td>A = 18</td>
<td>A = 6</td>
<td>L = 12</td>
<td>0.4</td>
<td>A = 4</td>
<td>A = 7</td>
</tr>
</tbody>
</table>
Magnitude Settings for Sine-Constant-Cosine-Acceleration Motion Profile

This motion profile is only available for acceleration servo motors.

The parameters of an SCCA magnitude setting are defined as follows:

- **A** = Fraction of normalized time for increasing acceleration
- **B** = Fraction of normalized time for constant acceleration
- **C** = Fraction of normalized time for decreasing acceleration

where

\[ A + B + C = 1 \]

You must provide values for **A** and **B**, as well as the amplitude and period of the SCCA profile.

- **H** = Amplitude
- **T** = Period

The value of the SCCA setting is computed as shown in the following table:

<table>
<thead>
<tr>
<th>( y )</th>
<th>( \text{for } 0 \leq t &lt; A )</th>
</tr>
</thead>
<tbody>
<tr>
<td>( y = H \times \sin \left( \frac{t \pi}{2A} \right) )</td>
<td>( y = H ) ( \text{for } a \leq t &lt; (A + B) )</td>
</tr>
</tbody>
</table>
| \( y = H \times \cos \left( \frac{(t - A - B)\pi}{2C} \right) \) | \( y = -H \times \cos \left( \frac{(t - A - 2B - 2C)\pi}{2A} \right) \) \( \text{for } (A+B+2C) \leq t \leq 2(A + B + C) \)

where \( t \) is the normalized time and is computed by

\[ t = \frac{t_a \times 2}{T} \]

where

- \( t_a = \text{Actual time} \)
- **T** = Period of the SCCA profile
The profile repeats itself if the actual time is longer than the period of the SCCA profile.

To Specify Servo Motor Magnitude as a Table Function

This procedure assumes that you are specifying **Magnitude** in the **Profile** tab of the **Servo Motor Definition** dialog box.

1. Select **Table** from the **Magnitude** drop-down menu.
2. Click **+** to add a row to the table.
3. Enter numerical values in the **Time** column. Values in this column must be in either increasing or decreasing sequence.
4. Enter numerical values in the **Magnitude** column.
5. If you need to remove one or more rows from the table, highlight the rows and click **-**.
6. Click **\(\) to save the table information to the file listed under **File**.
7. To import table data from a previously created .tab file, select the name of the file and click **\(\)\(\) The data from the file appears in the **Time** and **Magnitude** columns.
8. Select either **Linear fit** or **Spline fit** to select the **Interpolation** scheme.

Magnitude as a Table Function

**Table** generates the magnitude of a servo motor, force motor, or force/torque with values you enter or import into a two-column table.

When you select **Table** as an option for the magnitude definition of a servo motor, force motor, or force/torque, the corresponding dialog box expands, displaying the following information:

- Click **+** to add a new row to the table. The table has a two-column format:
  - **Time** or **Measure**—The first column displays the name of an independent variable \(x\), that, depending on your selection in the **Variable** field, could be **Time** or **Measure** for forces/torques and force motors, and is always **Time** for servo motors. Enter values for the independent variable in this column. The values must be in either increasing or decreasing sequence.
  - **Magnitude**—The second column displays the magnitude. Enter magnitude values in each row of the column.
- Click **-** to delete highlighted rows. To highlight a consecutive series of rows, hold down the SHIFT key as you select the rows. To highlight several non-consecutive rows, hold down the CTRL key as you select the rows.
**Mechanism Design Extension**

- **File**—Use this area to specify the name of an ASCII file with an extension of `.tab`. You can enter the name, or click the file selector button and browse to find an existing `.tab` file. Then click one of the following buttons:
  - Click to import table data from a `.tab` file that you previously created with any text editor. The file must contain two columns of equal length separated by spaces. Mechanism Design places the data from your file in the table, adding or deleting rows as needed to match the number of rows in the file.
  - Click to write data from the table on the dialog box to the specified `.tab` file.

- **Interpolation**—Use this area to select the interpolation method:
  - If you choose **Linear Fit**, Mechanism Design uses a straight line to connect the table points. If you define a profile that includes discontinuities, and you select **Linear Fit** when you graph the velocity or acceleration, Mechanism Design displays a warning message, and the graph may be inaccurate.
  - If you choose **Spline Fit**, Mechanism Design fits a cubic spline to each set of points. Using spline fit prevents sharp changes in the motion of the driven quantity.

  **Note:** For acceleration servo motors, only linear fit interpolation is available.

**Magnitude as a User-Defined Function**

**User Defined** generates the magnitude of a servo motor, force motor, or force/torque with a function you create using sets of expressions and domain constraints.

For servo motors, you must define magnitude as a function of analysis time.

For force motors and forces/torques, you can define magnitude as a function of time, or as a function of multiple variables that may include time and one or more existing measures. For example, to define a force that decreases directly as the inverse of the separation between two points, first create a distance separation measure named `septn1`. Then define the force magnitude with the expression `1/septn1`.

When you select **User Defined** as an option for the magnitude definition of a servo motor, force motor, or force/torque, the corresponding dialog box expands displaying the following buttons and fields:

- Click to add a new row to the table. The table has a two-column format:
  - **Expression**—When you add a new row, this column contains a default expression, representing either time or, if applicable, a measure. You can edit the default expression directly in the table cell.
o **Domain**—When you add a new row, this column contains no values for the expression domain. You can specify the domain values directly in the cell. For example, to enter a range of time between 1 and 10, enter $1 < t < 10$. Be aware that you must define each domain segment in the expression using only the primary variable.

- Click if you need to delete selected rows from the expression table.

- Click to edit the selected expression or domain. The Expression Definition dialog box appears. Use the dialog box to enter a new algebraic expression and domain. After you enter the new values, Mechanism Design places them in the expression table on the Servo Motor Definition, Force Motor Definition, or Force/Torque Definition dialog box.

- **Primary Variable**—Use the drop-down list to select time or a predefined measure. The selected variable appears in the formula in the Expression column here and in the Expression Definition dialog box. This field is available only on the Force Motor Definition and Force/Torque Definition dialog boxes.

  For Mechanism Design to provide a two-dimensional plot of your expression, you must select one variable as a primary variable. Mechanism Design uses the primary variable for the X axis when it graphs your expression, and requires you to supply constant values for the other variables—the secondary variables—in the expression. In addition, you must use the primary variable to specify all domain segments in the expression.

- **Unit Conversion Factor**—This uneditable field becomes visible only when you initially defined the user-defined function in a unit system different from the current one. The field lists the variables included in the expression and the magnitude of the expression and displays the multiplication factors that Mechanism Design uses to convert the numerical values to the current unit system.

**Expression Graph Dialog Box**

You access this dialog box from the Expression Definition dialog box. Use this dialog box to specify the variables that Mechanism Design uses when it plots your user-defined function. The software generates a preview plot of the expression by using the primary variable for the X axis over the given Range, and constant values for the other variables in the expression. When you select a primary variable, the software categorizes any other variables in the expression as secondary variables. The Expression Graph dialog box includes these items:

- A non-editable **Primary Variable** area
  - for servo motors, force motors, forces or torques, this displays the variable you selected in the Servo Motor Definition, Force Motor Definition, or Force/Torque Definition dialog box
for user-defined measures, this area includes a drop-down list with all of the variables in the expression. Select the variable that you want to use as the independent variable for the plot.

- **A Range** area including entry boxes for **Start** and **End** values that Mechanism Design uses to plot the primary variable.

- **A Secondary Variables** area listing the other variables included in the expression. This area appears only for expressions with more than one variable.

Enter a value for each secondary variable. Mechanism Design plots the value of the expression against the primary variable keeping the secondary variables fixed at the entered values.

When you click **OK**, the Graphtool window appears with the defined plot.

### Functions Dialog Box

You access this dialog box from the **Expression Definition** dialog box, or when creating a user defined measure in the **Measure Definition** dialog box. When you select one of the following functions, it appears as part of your definition in expression area.

The default variable $x$ for the functions is time, $t$. You can select another variable, such as a measure, from the $x =$ drop-down list at the top of the dialog box. You can also enter a constant value or an expression in the entry box. You can select a function by double-clicking, or by single-clicking and closing the dialog box. The function appears in the expression area with the selected variable or entered expression.

<table>
<thead>
<tr>
<th>Functions</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>sin(x), cos(x), tan(x)</td>
<td>standard trigonometric functions</td>
</tr>
<tr>
<td>asin(x)</td>
<td>arc sine in range $-90$ to $90$</td>
</tr>
<tr>
<td>acos(x)</td>
<td>arc cosine in range $0$ to $180$</td>
</tr>
<tr>
<td>ln(x)</td>
<td>natural (base e) logarithm</td>
</tr>
<tr>
<td>log(x)</td>
<td>base 10 logarithm</td>
</tr>
<tr>
<td>abs(x)</td>
<td>absolute value. If $x &gt; 0$, the function returns $x$, otherwise it returns $-x$.</td>
</tr>
<tr>
<td>sqrt(x)</td>
<td>square root</td>
</tr>
<tr>
<td>ceil(x)$^1$</td>
<td>round toward positive infinity</td>
</tr>
<tr>
<td>floor(x)$^1$</td>
<td>round toward negative infinity</td>
</tr>
</tbody>
</table>

1. The functions ceil(x) and floor(x) are not available for servo motors.
Operators Dialog Box

You access this dialog box from the **Expression Definition** dialog box, or when creating a user defined measure in the **Measure Definition** dialog box. When you select one of the arithmetic operators from this dialog box, it appears as a part of your definition in the expression area.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>add</td>
</tr>
<tr>
<td>-</td>
<td>subtract, unary minus, negate</td>
</tr>
<tr>
<td>*</td>
<td>multiply</td>
</tr>
<tr>
<td>/</td>
<td>divide</td>
</tr>
<tr>
<td>^</td>
<td>exponentiate</td>
</tr>
<tr>
<td>( )</td>
<td>parentheses, grouping</td>
</tr>
<tr>
<td>&lt;¹</td>
<td>greater than</td>
</tr>
<tr>
<td>&lt;=¹</td>
<td>greater than or equal to</td>
</tr>
<tr>
<td>&gt;¹</td>
<td>less than</td>
</tr>
<tr>
<td>&gt;=¹</td>
<td>less than or equal to</td>
</tr>
<tr>
<td>==¹</td>
<td>equal to</td>
</tr>
<tr>
<td>!=¹</td>
<td>not equal to</td>
</tr>
<tr>
<td>&amp;&amp;¹</td>
<td>Boolean &quot;and&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. These operators are not available for servo motors.

Variables Dialog Box

You access this dialog box from the **Expression Definition** dialog box, or when creating a user-defined measure in the **Measure Definition** dialog box. Use this dialog box to select a variable to use in your expression. You can select time (t) or a predefined measure. The list includes only valid measures. These requirements apply to measures you select for expression variables:

- You can include one or more measures as part of your expression definition for force motors, forces, torques, or user-defined measures.
- You can include one or more parameters as part of your expression. You can use any Pro/ENGINEER parameter, including those based on measures you derive from Mechanism analyses or from analysis feature measures such as distance.
Mechanism uses the value of the parameter at analysis start time as the basis for the expression.

- The measure name must contain only alphanumeric characters or underscores (_ ) and the first character must be alphabetic. The alphanumeric characters can be in any language, including Asian-language characters. Measure names cannot include blank spaces.

- When defining an expression for force motors, forces or torques, you may select a position, velocity, or system measure, or a user-defined measure that contains only position, velocity, or system measures.

- If you are working at the top assembly level, Mechanism Design lists only measures created for the top-level assembly. If you are working with a subassembly or component, Mechanism Design lists only measures created for the current subassembly or component.

- Mechanism Design lists only valid measures in the drop-down list on the Variables dialog box.

Select a variable by double-clicking, or by highlighting the variable and clicking Close to return to the Expression Definition or Measure Definition dialog box. When you close the Variables dialog box, the selected variable appears as part of your expression definition.

To Specify Servo Motor Magnitude as a User-Defined Function

This procedure assumes that you are specifying Magnitude in the Profile tab of the Servo Motor Definition dialog box.

1. Select User Defined from the Magnitude drop-down menu.

2. Click to add a row containing a default expression with time \( t \) and no domain.

3. If you want to edit the expression, select the row and click to open the Expression Definition dialog box.

4. On the Expression Definition dialog box, enter an expression in the text box, or use the following options to create an expression:

   - Click to display the Operators dialog box.
   - Click to display the Constants dialog box.
   - Click to display the Functions dialog box.
   - Click to display the Variables dialog box.
   - Click to validate your expression and display the Expression Graph dialog box.
5. Specify a domain for the expression if needed. For the upper and lower domain bounds, select < from the drop-down list and enter a number for an exclusive bound, or select <= from the drop-down list and enter a number for an inclusive bound.

6. Click OK. The expression and domain values appear in the Expression and Domain columns on the Servo Motor Definition dialog box.

7. If you want to change an Expression or Domain value, click the value and edit it.

8. If you need to remove one or more rows from the table, highlight the rows and click .

Expression Definition Dialog Box

You access this dialog box by clicking while describing the profile of your servo motor, force motor, or force/torque as a user-defined function. Use the items on this dialog box to create a function for the profile. Enter an expression in the entry box, or use the following options to create your expression:

- [ ]—Display the Operators dialog box and select an arithmetic operator for your expression.

- [ ]—Display the Constants dialog box and select a constant or Pro/ENGINEER parameter for your expression.

- [ ]—Display the Functions dialog box and select a mathematical function for your expression.

- [ ]—Display the Variables dialog box and select a previously defined measure or variable for your expression.

- [ ]—Validate your expression and display the Expression Graph dialog box.

When you select one of the items from the Operators, Constants, Functions, or Variables dialog boxes, it appears as part of your definition in the expression entry area.

- Use the items in the Domain area to specify the range for the primary variable in your expression. If you selected a measure name for your primary variable, it appears in the Domain area. You can select exclusive or inclusive upper and lower domain bounds. You can make your function open-ended by specifying only the lower limit of the domain for the last expression segment. When the function consists of only one expression segment, domain is optional. The time you specify for the domain for force/torques and force motors is relative to the beginning of your analysis.

When you click OK and close the dialog box, Mechanism Design copies the function to the Expression column and the domain values to the Domain column on the
Servo Motor Definition, Force Motor Definition, or Force/Torque Definition dialog box.

Constants Dialog Box

You access this dialog box from the Expression Definition dialog box, or when creating a user defined measure in the Measure Definition dialog box. You can use this dialog box to select constants or add Pro/ENGINEER parameters to your expressions. You can select these constants:

<table>
<thead>
<tr>
<th>Constants</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>pi</td>
<td>3.14159</td>
</tr>
<tr>
<td>e</td>
<td>2.71828</td>
</tr>
</tbody>
</table>

The Constants dialog box also includes these items:

- Click to add a predefined Pro/ENGINEER parameter as a constant. The Select Parameter dialog box appears listing acceptable parameters in a read-only table. When you select a parameter, the parameter name and its current value appear in the list. When using Pro/ENGINEER parameters, keep the following points in mind:
  - The parameter type must be integer or real number.
  - The parameter name must contain only alphanumeric characters, underscores (_), or colons (:). The alphanumeric characters can be in any language, including Asian-language characters.
  - The parameter name must not include spaces.
  - The parameter name cannot be any of the reserved words e, pi, or t.
  - You can add Pro/ENGINEER parameters from any level—top-level assembly, sub-assembly, or component.
  - The value of the constant is the value of the Pro/ENGINEER parameter at the beginning of the analysis. The value does not change during the analysis.
  - If you change a parameter value in Pro/ENGINEER after including it in the user-defined function, Mechanism Design also updates the value in the profile of your force motor, servo motor, or force/torque, or in your user-defined measure expression.
  - If you include a Pro/ENGINEER parameter in a user-defined expression, and then delete it in Pro/ENGINEER, the measure, servo motor, force motor, or force/torque based on that expression becomes incomplete.

For more information on creating parameters, search for parameters in the Fundamentals functional area of the PTC Help system.
Click to remove a selected constant or Pro/ENGINEER parameter that you previously added as a constant from the table.

After you close the **Constants** dialog box, the parameter name appears as part of your expression definition on the **Expression Definition** or **Measure Definition** dialog box.

**Understanding Geometric Motors**

If you select points and planes to define the motor, you are creating a geometric motor.

**Plane–Plane Translation Motor**—A plane–plane translation motor moves a plane in one body with respect to a plane on another body, keeping one plane parallel to the other. The shortest distance between the two planes measures the position value of the motor. The zero position occurs when the driven and reference planes are coincident.

In addition to the prescribed motion, the driven plane is free to rotate or translate in the reference plane. Thus, a plane–plane motor is less restrictive than a motor on a slider or a cylinder joint. If you want to explicitly tie down the remaining degrees of freedom, specify additional constraints such as a connection or another geometric motor.

**Tip:** One application of a plane–plane translation motor would be to define a translation between the last link of an open-loop mechanism and ground.

**Plane–Plane Rotation Motor**—A plane–plane rotation motor moves a plane in one body at an angle to a plane in another body. During a motion run, the driven plane rotates about a reference direction, with the zero position defined when the driven and reference planes are coincident.

Because the axis of rotation on the driven body remains unspecified, a plane–plane rotation motor is less restrictive than a motor on a pin joint or cylinder joint. Thus, the location of the axis of rotation in the driven body may change in an arbitrary way.

**Tip:** Plane–plane rotation motors can be used to define rotations around a ball joint. Another application of a plane–plane rotation motor would be to define a rotation between the last body of an open-loop mechanism and ground, such as a front loader.

**Point–Plane Translation Motor**—A point–plane translation motor moves a point in one body along the normal of a plane in another body. The shortest distance from the point to the plane measures the position value of the motor.

You cannot define the orientation of one body with respect to the other using only a point–plane motor. Also note that the driven point is free to move parallel to the reference plane, and may thus move in a direction unspecified by the motor. Lock these degrees of freedom using another motor or connection. By defining X, Y, and Z components of motion on a point with respect to a plane, you can make a point follow a complex, 3D curve.

**Plane–Point Translation Motor**—A plane–point motor is the same as a point–plane motor, except that you define the direction in which a plane moves relative to a
point. During a motion run, the driven plane moves in the specified motion direction while staying perpendicular to it. The shortest distance from the point to the plane measures the position value of the motor. At a zero position, the point lies on the plane.

You cannot define the orientation of one body with respect to the other using only a plane-point motor. Also, note that the driven plane is free to move perpendicularly to the specified direction. Lock these degrees of freedom using another motor or connection. By defining X, Y, and Z components of motion on a point with respect to a plane, you can make a point follow a complex, 3D curve.

**Point–Point Translation Motor**—A point–point motor moves a point in one body in a direction specified in another body. The shortest distance measures the position of the driven point to a plane that contains the reference point and is perpendicular to the motion direction. The zero position of a point–point motor occurs when both the reference and driven point lie in a plane whose normal is the motion direction.

**Note:** The point–point translation motor is a very loose constraint that must be used carefully to get a predictable motion. You cannot define the orientation of one body with respect to the other using only one point–point motor. In reality, you would need six point–point motors for this.

Also note that the driven point is free to move perpendicularly to the specified direction, and may do so if you do not specify otherwise. Lock these degrees of freedom using another motor or connection. By defining X, Y, and Z components of motion on a point with respect to a plane, you can make a point follow a complex, 3D curve.

**To Edit a Servo Motor**

1. Click **Mechanism > Servo Motors**.

2. In the **Servo Motors** dialog box, select a servo motor from the list of existing servo motors.

3. Click **Edit**. The **Servo Motor Definition** dialog box opens, and Mechanism Design highlights the model, showing the driven entity, and the translation vector or rotation axis entity.

4. Use the following tabs to edit the values of the servo motor:
   - **Type**
   - **Profile**

5. Click **OK** to save the modified servo motor specification.

**Finder Dialog Box**

A finder dialog box opens when you select certain modeling entities from the **Mechanism** menu. Use this dialog box to organize and control your force and servo motors, springs, dampers, force or torque loads, cam-follower connections, slot-follower connections, gear pairs, or initial conditions. The dialog box includes a list of the entities you have created in your model. You can use this form to add a new
entity, edit an existing entity, copy an existing entity to a new name, or remove an existing entity from your model.

To get information on an entity in the list, place the cursor over the item's name without clicking. A message box appears with a summary of the parameters used to define the entity.

The finder form includes the following fields:

- **Name**—The default name is based on the entity type with a number appended. For example, the default name for the first spring you create will be *Spring1*. If you want to change the name, highlight it, and edit it.

  It is a good idea to use more meaningful names to help you keep track of what you have created.

- **Status**

- **New**—Use this button to create one of the following types of entities:
  
  - Cam-follower connection
  - Slot-follower connection
  - Servo motor
  - Force motor
  - Gear pair
  - Spring
  - Damper
  - Force/torque load
  - Initial condition

- **Edit**—Use this button to change the definition of one of the following entities:
  
  - Cam-follower connection
  - Slot-follower connection
  - Servo motor
  - Force motor
  - Gear pair
  - Spring
  - Damper
  - Force/torque load
  - Initial condition

- **Copy**—Use this button to copy one of the entities in the list to a new name. This option is not available for cam-follower connections or slot-follower connections.
- **Delete**—Use this button to delete an entity from the model. You can also delete several entities at once. Hold the SHIFT key, highlight the entities, and press DELETE.

**Status**

The **Status** column on the finder dialog box gives current information on the part, assembly, or feature that the modeling entity references.

- **Suppressed**—The modeling entity references:
  - A part, assembly, or feature that is suppressed in Pro/ENGINEER.
  - A part, assembly, or feature in which the geometry is not included in the currently used simplified representation, family table, instance, or interchange assembly.

- **Incomplete**—The modeling entity references a part, assembly, or feature that you have changed or deleted.

You cannot edit the definition of a suppressed entity.

**To Copy a Modeling Entity**

Use this procedure to copy a previously defined gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to copy. A dialog box appears.
2. Select a previously defined entity from the list.
3. Click **Copy**. A new entity appears in the list, with *Copy of* appended to the name of the copied entity. This entity has the same definition as the entity from which it was copied.
4. Change the definition of the newly copied entity as needed by editing the appropriate information on any of the tabs in the definition dialog box.

**To Rename a Modeling Entity**

Use this procedure to rename a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to rename. A dialog box appears.
2. Select a previously defined entity from the list. If you place the cursor over the entity without clicking, a message box appears with the definition information for the entity.
3. Click **Edit**. A definition dialog box appears, and Mechanism Design highlights the model, showing the selected entity and an icon representing the entity.
4. Change the name in the text field. The name must be unique for each entity type.
5. Click **OK**.

**To Delete a Modeling Entity**

Use this procedure to delete a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to delete. A dialog box appears.
2. Select a previously defined entity from the list.
3. Click **Delete**. The selected entity is removed from the list and from the model.

**About Graphing**

Use the **Graphtool** window to display plots of measure results and the functions that define motor and force profiles. After you display your graph, you can interact with it in several ways. To find out the x and y values for any graph point, click on the point and a dialog box appears showing the values. To work with the graph and manage its appearance, use toolbar buttons or the following menu commands:

- **File**
  - **Export Excel**—This option is available on Windows only. Use it to save the graph data as a Microsoft Excel spreadsheet. When you click this command, Mechanism Design displays the **Export To Excel** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a .xlc extension. The file contains a pictorial rendition of the graph as well as a numeric table of graph values.
  - **Export Text**—Save the graph data as a text file. When you click this command, Mechanism Design displays the **Export To Text** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a .grt extension.
  - **Print**—Send your graph to a printer. When you click this command, a dialog box appears that allows you to output your graph to several print and graphic formats, or save it as a file.
  - **Exit**—Close the **Graphtool** window.

- **View**
  - **Toggle Grid**—Display grid lines for your graph or turn them off.
  - **Repaint**—Refresh the view of your graph.
  - **Refit**—Restore a graph to its original state. Use this command after you zoom in on a particular graph segment to return to an unsegmented state. Mechanism Design automatically redraws the complete graph in the current window.
  - **Zoom In**—Zoom in on the graph to get a close-up view. This command is especially useful when your graph contains too many points, 100 or more.
Zooming in on a section of the graph helps you to display a specific segment of interest.

- **Format**
  
  **Graph**—Open the **Graph Window Options** dialog box to manage your graph and its display window.

**Force Motors**

**About Force Motors**

You use force motors to impose a particular load on a mechanism. You can create force motors for your mechanism if you have a Mechanism Dynamics Option license. Force motors cause a specific type of load to occur between two bodies in a single degree of freedom. You add force motors to your model to prepare it for a dynamic analysis.

Force motors cause motion by applying a force on a translational or rotational joint axis.

You can place force motors on joint axes. You can define as many force motors on a model as you like. You can turn force motors on and off within the definition of each dynamic analysis.

The **Mechanism > Force Motors** command opens a dialog box that you use to create, edit, copy, or delete your force motors. You cannot copy or delete incomplete force motors. The dialog box also indicates the status of any force motors that are already created. A force motor has three possible status conditions. If one or more of the entities associated with the force motor is suppressed, the status is **Suppressed**. If the joint axis is deleted due to joint removal, the status is **Incomplete**. If you create a force motor profile based upon a variable, then edit or delete the measure you select for the independent variable, the status of the force motor is **Incomplete**. If your force motor is fully defined, the **Status** column is blank.

**Note:** If you select or define a function for your force motor profile that is not continuous, be aware that it will be ignored if you run a kinematic or dynamic analysis.

**To Create a Force Motor**

1. Click **Mechanism > Force Motors** or The **Force Motors** dialog box appears.
2. Click **New**. The **Force Motor Definition** dialog box appears.
3. Enter a name for the force motor.
4. Select a joint axis on which the motor will be applied.
5. Select one of the choices for **Magnitude**. Separate procedures exist for table force motors and force motors as a user-defined function.
6. Enter magnitude values.
7. Select a Variable.
8. If you want to graphically view the profile of the force motor with your current settings, click to display the Graphtool window.
9. If you want to modify the data to change the profile, do not close the graph window. Redefine the magnitude, and click again to update the graph display. When you see the profile you are interested in, close the graph window and accept the force motor.
10. Click OK when you have completed the dialog box.

A force motor icon appears on your mechanism.

About the Force Motor Definition Dialog Box

The Force Motor Definition dialog box displays the following information:

- **Joint Axis**—Use to select the connection axis for the force motor.
- **Magnitude**—Use this area to specify the magnitude of the force motor. The magnitude can be a constant value, or it can be defined by one of the functions you select. Mechanism Design uses the function to generate the magnitude.
- **Variable**—Use this drop-down menu to specify the independent variable represented by \( x \) in the function defining magnitude. This menu does not appear when the magnitude is a constant value.
  - **Time**—Define the magnitude as a function of the time of the analysis. Mechanism Design substitutes the time for any \( x \) variables in the function's expression.
  - **Measure**—Define the magnitude as a function of any position or velocity measure that you created previously. Mechanism Design substitutes the value of the measure for any \( x \) variables in the function's expression.
- Click to display the Graphtool window. Use this window to graphically view the magnitude of the force motor as a function of time or measure.

About Magnitude Settings

Depending on the type of motion you want to impose on your mechanism, you can define the magnitude of your servo motors or force motors in many ways. The following table lists different types of functions that Mechanism Design uses to generate the magnitude. You need to enter the values of the coefficients for the functions. The value of \( x \) in the function expressions is supplied by the simulation time or, for force motors, by either the simulation time or a measure you select.
<table>
<thead>
<tr>
<th>Mechanism Design Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constant</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Ramp</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Cosine</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Sine-Constant-Cosine-Acceleration (SCCA)</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Cycloidal</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Parabolic</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Polynomial</strong></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Use a single profile if possible. But you can use a combination of profiles to generate certain types of motion. For example, a combination of ramp and cosine generates a sinusoidal motion that ramps up over time. For more information, see this example, which shows different types of motion the motor creates.

**Magnitude as a Table Function**

**Table** generates the magnitude of a servo motor, force motor, or force/torque with values you enter or import into a two-column table.

When you select **Table** as an option for the magnitude definition of a servo motor, force motor, or force/torque, the corresponding dialog box expands, displaying the following information:

- **Click** to add a new row to the table. The table has a two-column format:
  - **Time** or **Measure**—The first column displays the name of an independent variable \( x \), that, depending on your selection in the **Variable** field, could be **Time** or **Measure** for forces/torques and force motors, and is always **Time** for servo motors. Enter values for the independent variable in this column. The values must be in either increasing or decreasing sequence.
  - **Magnitude**—The second column displays the magnitude. Enter magnitude values in each row of the column.

- **Click** to delete highlighted rows. To highlight a consecutive series of rows, hold down the SHIFT key as you select the rows. To highlight several non-consecutive rows, hold down the CTRL key as you select the rows.

- **File**—Use this area to specify the name of an ASCII file with an extension of .tab. You can enter the name, or click the file selector button and browse to find an existing .tab file. Then click one of the following buttons:
Mechanism Design Extension

- Click to import table data from a .tab file that you previously created with any text editor. The file must contain two columns of equal length separated by spaces. Mechanism Design places the data from your file in the table, adding or deleting rows as needed to match the number of rows in the file.

- Click to write data from the table on the dialog box to the specified .tab file.

- **Interpolation**—Use this area to select the interpolation method:
  - If you choose **Linear Fit**, Mechanism Design uses a straight line to connect the table points. If you define a profile that includes discontinuities, and you select **Linear Fit** when you graph the velocity or acceleration, Mechanism Design displays a warning message, and the graph may be inaccurate.
  - If you choose **Spline Fit**, Mechanism Design fits a cubic spline to each set of points. Using spline fit prevents sharp changes in the motion of the driven quantity.

  **Note:** For acceleration servo motors, only linear fit interpolation is available.

**To Specify Force Motor Magnitude as a Table Function**

This procedure assumes that you are specifying **Magnitude** on the **Force Motor Definition** dialog box.

1. Select **Table** from the **Magnitude** drop-down menu.
2. Click to add a row to the table.
3. Select a **Variable**. Depending on your selection, the first column of the table displays either **Time** or **Measure**.
4. Enter numerical values in the first column. Values in this column must be in either increasing or decreasing sequence.
5. Enter numerical values in the **Magnitude** column.
6. If you need to remove any of the selected rows from the table, click .
7. Click to save the table information to the file listed under **File**.
8. To import table data from a previously created .tab file, enter the name of the file, or use the file selector to open the file, and click . The data from the file appears in the table columns.
9. Select either **Linear fit** or **Spline fit** to select the **Interpolation** scheme.

**Magnitude as a User-Defined Function**
**User Defined** generates the magnitude of a servo motor, force motor, or force/torque with a function you create using sets of expressions and domain constraints.

For servo motors, you must define magnitude as a function of analysis time.

For force motors and forces/torques, you can define magnitude as a function of time, or as a function of multiple variables that may include time and one or more existing measures. For example, to define a force that decreases directly as the inverse of the separation between two points, first create a distance separation measure named `septn1`. Then define the force magnitude with the expression `1/septn1`.

When you select **User Defined** as an option for the magnitude definition of a servo motor, force motor, or force/torque, the corresponding dialog box expands displaying the following buttons and fields:

- Click ![Add Row](image) to add a new row to the table. The table has a two-column format:
  - **Expression**—When you add a new row, this column contains a default expression, representing either time or, if applicable, a measure. You can edit the default expression directly in the table cell.
  - **Domain**—When you add a new row, this column contains no values for the expression domain. You can specify the domain values directly in the cell. For example, to enter a range of time between 1 and 10, enter `1 < t < 10`. Be aware that you must define each domain segment in the expression using only the primary variable.

- Click ![Delete Rows](image) if you need to delete selected rows from the expression table.

- Click ![Edit Expression](image) to edit the selected expression or domain. The **Expression Definition** dialog box appears. Use the dialog box to enter a new algebraic expression and domain. After you enter the new values, Mechanism Design places them in the expression table on the **Servo Motor Definition**, **Force Motor Definition**, or **Force/Torque Definition** dialog box.

- **Primary Variable**—Use the drop-down list to select time or a predefined measure. The selected variable appears in the formula in the **Expression** column here and in the **Expression Definition** dialog box. This field is available only on the **Force Motor Definition** and **Force/Torque Definition** dialog boxes.

  For Mechanism Design to provide a two-dimensional plot of your expression, you must select one variable as a primary variable. Mechanism Design uses the primary variable for the X axis when it graphs your expression, and requires you to supply constant values for the other variables—the secondary variables—in the expression. In addition, you must use the primary variable to specify all domain segments in the expression.

- **Unit Conversion Factor**—This uneditable field becomes visible only when you initially defined the user-defined function in a unit system different from the current one. The field lists the variables included in the expression and displays the multiplication factors that
Mechanism Design Extension

Mechanism Design uses to convert the numerical values to the current unit system.

To Specify Force Motor Magnitude as a User-Defined Function

This procedure assumes that you are specifying Magnitude on the Force Motor Definition dialog box.

1. Select User Defined from the Magnitude drop-down menu.
2. Select a measure name from the Primary Variable drop-down list if you do not want to use time \( t \) as the independent variable.
3. Click \( \text{Add Row} \) to add a row containing a default expression using \( t \) or the selected measure name, with no domain.
4. If you want to edit the expression, select the row and click \( \text{Edit Expression} \) to open the Expression Definition dialog box.
5. On the Expression Definition dialog box, enter an expression in the text box, or use the following options to create an expression:
   - Click \( \text{Operators} \) to display the Operators dialog box.
   - Click \( \text{Constants} \) to display the Constants dialog box.
   - Click \( \text{Functions} \) to display the Functions dialog box.
   - Click \( \text{Variables} \) to display the Variables dialog box.
   - Click \( \text{Validate Expression} \) to validate your expression and display the Expression Graph dialog box.
6. Check the Specify domain box and enter boundaries for the primary variable if needed. For the upper and lower domain bounds, select < from the drop-down list and enter a number for an exclusive bound, or select <= from the drop-down list and enter a number for an inclusive bound.
7. Click OK. The expression and domain values appear in the Expression and Domain columns on the Force Motor Definition dialog box.
8. If you want to change an Expression or Domain value, click the value and edit it.
9. If you need to remove a row, highlight the row and click \( \text{Remove Row} \).

Expression Definition Dialog Box

You access this dialog box by clicking \( \text{Add Definition} \) while describing the profile of your servo motor, force motor, or force/torque as a user-defined function. Use the items on this
dialog box to create a function for the profile. Enter an expression in the entry box, or use the following options to create your expression:

- Display the Operators dialog box and select an arithmetic operator for your expression.
- Display the Constants dialog box and select a constant or Pro/ENGINEER parameter for your expression.
- Display the Functions dialog box and select a mathematical function for your expression.
- Display the Variables dialog box and select a previously defined measure or variable for your expression.
- Validate your expression and display the Expression Graph dialog box.

When you select one of the items from the Operators, Constants, Functions, or Variables dialog boxes, it appears as part of your definition in the expression entry area.

Use the items in the Domain area to specify the range for the primary variable in your expression. If you selected a measure name for your primary variable, it appears in the Domain area. You can select exclusive or inclusive upper and lower domain bounds. You can make your function open-ended by specifying only the lower limit of the domain for the last expression segment. When the function consists of only one expression segment, domain is optional. The time you specify for the domain for force/torques and force motors is relative to the beginning of your analysis.

When you click OK and close the dialog box, Mechanism Design copies the function to the Expression column and the domain values to the Domain column on the Servo Motor Definition, Force Motor Definition, or Force/Torque Definition dialog box.

**Constants Dialog Box**

You access this dialog box from the Expression Definition dialog box, or when creating a user defined measure in the Measure Definition dialog box. You can use this dialog box to select constants or add Pro/ENGINEER parameters to your expressions. You can select these constants:

<table>
<thead>
<tr>
<th>Constants</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>pi</td>
<td>3.14159</td>
</tr>
<tr>
<td>e</td>
<td>2.71828</td>
</tr>
</tbody>
</table>

The Constants dialog box also includes these items:
• Click \( \text{Constant} \) to add a predefined Pro/ENGINEER parameter as a constant. The **Select Parameter** dialog box appears listing acceptable parameters in a read-only table. When you select a parameter, the parameter name and its current value appear in the list. When using Pro/ENGINEER parameters, keep the following points in mind:

  o The parameter type must be integer or real number.

  o The parameter name must contain only alphanumeric characters, underscores (_), or colons (:). The alphanumeric characters can be in any language, including Asian-language characters.

  o The parameter name must not include spaces.

  o The parameter name cannot be any of the reserved words \( e \), \( pi \), or \( t \).

  o You can add Pro/ENGINEER parameters from any level—top-level assembly, sub-assembly, or component.

  o The value of the constant is the value of the Pro/ENGINEER parameter at the beginning of the analysis. The value does not change during the analysis.

  o If you change a parameter value in Pro/ENGINEER after including it in the user-defined function, Mechanism Design also updates the value in the profile of your force motor, servo motor, or force/torque, or in your user-defined measure expression.

  o If you include a Pro/ENGINEER parameter in a user-defined expression, and then delete it in Pro/ENGINEER, the measure, servo motor, force motor, or force/torque based on that expression becomes incomplete.

For more information on creating parameters, search for parameters in the Fundamentals functional area of the PTC Help system.

• Click \( \text{Remove} \) to remove a selected constant or Pro/ENGINEER parameter that you previously added as a constant from the table.

After you close the **Constants** dialog box, the parameter name appears as part of your expression definition on the **Expression Definition** or **Measure Definition** dialog box.

**To Edit a Force Motor**

1. In the **Force Motors** dialog box, select a force motor from the list of existing force motors.

2. Click **Edit**. The **Force Motor Definition** dialog box opens, and Mechanism Design highlights the model, showing the driven entity, and the translation vector or rotation axis entity.

3. Edit the magnitude of the force motor.

4. Click **OK** to save the modified force motor specification.
Finder Dialog Box

A finder dialog box opens when you select certain modeling entities from the **Mechanism** menu. Use this dialog box to organize and control your force and servo motors, springs, dampers, force or torque loads, cam-follower connections, slot-follower connections, gear pairs, or initial conditions. The dialog box includes a list of the entities you have created in your model. You can use this form to add a new entity, edit an existing entity, copy an existing entity to a new name, or remove an existing entity from your model.

To get information on an entity in the list, place the cursor over the item’s name without clicking. A message box appears with a summary of the parameters used to define the entity.

The finder form includes the following fields:

- **Name**—The default name is based on the entity type with a number appended. For example, the default name for the first spring you create will be *Spring1*. If you want to change the name, highlight it, and edit it.

  It is a good idea to use more meaningful names to help you keep track of what you have created.

- **Status**

- **New**—Use this button to create one of the following types of entities:
  
  - Cam-follower connection
  - Slot-follower connection
  - Servo motor
  - Force motor
  - Gear pair
  - Spring
  - Damper
  - Force/torque load
  - Initial condition

- **Edit**—Use this button to change the definition of one of the following entities:
  
  - Cam-follower connection
  - Slot-follower connection
  - Servo motor
  - Force motor
  - Gear pair
  - Spring
- Damper
- Force/torque load
- Initial condition

- **Copy**—Use this button to copy one of the entities in the list to a new name. This option is not available for cam-follower connections or slot-follower connections.

- **Delete**—Use this button to delete an entity from the model. You can also delete several entities at once. Hold the SHIFT key, highlight the entities, and press DELETE.

**To Copy a Modeling Entity**

Use this procedure to copy a previously defined gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to copy. A dialog box appears.
2. Select a previously defined entity from the list.
3. Click **Copy**. A new entity appears in the list, with *Copy of* appended to the name of the copied entity. This entity has the same definition as the entity from which it was copied.
4. Change the definition of the newly copied entity as needed by editing the appropriate information on any of the tabs in the definition dialog box.

**To Rename a Modeling Entity**

Use this procedure to rename a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.

1. Click **Mechanism** and the type of entity you want to rename. A dialog box appears.
2. Select a previously defined entity from the list. If you place the cursor over the entity without clicking, a message box appears with the definition information for the entity.
3. Click **Edit**. A definition dialog box appears, and Mechanism Design highlights the model, showing the selected entity and an icon representing the entity.
4. Change the name in the text field. The name must be unique for each entity type.
5. Click **OK**.

**To Delete a Modeling Entity**

Use this procedure to delete a previously defined cam, slot, gear pair, servo motor, force motor, spring, damper, force/torque load, or initial condition.
1. Click **Mechanism** and the type of entity you want to delete. A dialog box appears.

2. Select a previously defined entity from the list.

3. Click **Delete**. The selected entity is removed from the list and from the model.

**Status**

The **Status** column on the finder dialog box gives current information on the part, assembly, or feature that the modeling entity references.

- **Suppressed**—The modeling entity references:
  - A part, assembly, or feature that is suppressed in Pro/ENGINEER.
  - A part, assembly, or feature in which the geometry is not included in the currently used simplified representation, family table, instance, or interchange assembly.

- **Incomplete**—The modeling entity references a part, assembly, or feature that you have changed or deleted.

You cannot edit the definition of a suppressed entity.

**About Graphing**

Use the **Graphtool** window to display plots of measure results and the functions that define motor and force profiles. After you display your graph, you can interact with it in several ways. To find out the x and y values for any graph point, click on the point and a dialog box appears showing the values. To work with the graph and manage its appearance, use toolbar buttons or the following menu commands:

- **File**
  - **Export Excel**—This option is available on Windows only. Use it to save the graph data as a Microsoft Excel spreadsheet. When you click this command, Mechanism Design displays the **Export To Excel** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a .xlc extension. The file contains a pictorial rendition of the graph as well as a numeric table of graph values.

  - **Export Text**—Save the graph data as a text file. When you click this command, Mechanism Design displays the **Export To Text** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a .grt extension.

  - **Print**—Send your graph to a printer. When you click this command, a dialog box appears that allows you to output your graph to several print and graphic formats, or save it as a file.

  - **Exit**—Close the **Graphtool** window.

- **View**
  - **Toggle Grid**—Display grid lines for your graph or turn them off.
- **Repaint**—Refresh the view of your graph.

- **Refit**—Restore a graph to its original state. Use this command after you zoom in on a particular graph segment to return to an unsegmented state. Mechanism Design automatically redraws the complete graph in the current window.

- **Zoom In**—Zoom in on the graph to get a close-up view. This command is especially useful when your graph contains too many points, 100 or more. Zooming in on a section of the graph helps you to display a specific segment of interest.

- **Format**

  - **Graph**—Open the **Graph Window Options** dialog box to manage your graph and its display window.

### Custom Loads

#### About Custom Loads

Mechanism Design users may need to load their mechanisms with force and force motor definitions of great internal complexity. Examples are tires, aerodynamics, fluids, gravity gradients, pressure of light, combustion, nonlinear bushings, surface interactions, and active control systems.

These sophisticated custom loads are usually produced by a code-writing analyst and are in the form of a Pro/TOOLKIT application. Pro/TOOLKIT is the PTC application programmer's interface (API), which provides a large library of C language functions. It gives you the ability to write custom loads in the C programming language and then integrate the resulting application into Mechanism Design in a seamless way.

The Mechanism Design user neither has to understand the internal workings of these complex loads nor needs to have analyst-like skills to be able to use them. When the Mechanism Design user sees these custom load models, they are packaged in a way that demands little interaction.

Thus there are usually two different communities for custom loads. The first is a code-writing analyst who authors the custom loads and needs a Pro/TOOLKIT license to write the code. The second is a non-programming Mechanism Design user who applies analyst-developed loads to drive mechanisms. The latter type of custom load user does not need the license for Pro/TOOLKIT.

The goal of the following information is to assist you, the code-writing analyst, in producing custom loads that can be successfully employed by Mechanism Design users:

- For requirements on how to create custom loads, see [Guidelines for Creating a Custom Load Application](#).

- For information on the functions specific to the custom load application, see [Custom Load Functions](#).
Look for sample programs and makefiles in the CustomLoad directory of the Mechanism Design installation directory. These makefiles are based on the Pro/TOOLKIT installation test program. The CustomLoad directory also includes a readme.txt file that describes the sample makefiles.

**Custom Load**

Use this option to apply a complex, externally-defined set of loads to your model. For information on creating custom loads, see About Custom Loads.

When you select this option, the **Magnitude** tab expands to display the **Name of Custom Load** field. Use this field to specify the custom load you want to use for the torque or force motor you are defining.

After you select **OK**, prompts and dialog boxes created by the custom load's author may appear. After you have supplied all required parameters, Mechanism Design displays the appropriate icon for each load produced by the custom load.

When you run an analysis that includes motors or force/torques, the solver completes a series of discrete steps in time. At each step, it determines the values for the forces, torques, or motors. These values, in turn, determine the dynamic state of the system. The difference between a standard motor or force/torque and one that is based on a custom load is that the solver queries an external system—the custom load program—to determine the time step values instead of calculating the time step values on its own.

For each time step, the solver calls the custom load program and passes it the current time, the name of the custom load, and the name of the motor or force/torque. The custom load program then returns the value of the motor or force/torque at that time. The custom load program can evaluate any **Position** or **Velocity** measure to determine the correct value to pass to the solver.

**Custom Load Functions**

When a Mechanism Design user starts a custom load application, exchanges between the application and Mechanism Design are made through direct function calls. Some functions are called from the custom load application by Mechanism Design. Others are provided by Mechanism Design and can be called in by the custom load application. Each function may have a number of optional arguments that you can add to your function definition when needed.

The following briefly describes the functions specific to the custom load application. For more information, refer to the Pro/TOOLKIT online documentation.

**Functions provided by the custom load application and written by the custom load developer:**

- CLUSEREvalCustomLoad
- CLUSERDefineInit
- CLUSERRunInit
Mechanism Design Extension

- CLUSERGetStateVariablesSize
- CLUSERInitStateVariables
- CLUSERGetStateVariableDerivatives

Functions provided by Mechanism Design and callable by the custom load developer:

- CLEvalMeasure
- CLEvalStateVariables

CLUSEREvalCustomLoad is the only function that must always be present in the custom load application. When the Mechanism Design user runs an analysis that references the custom load, this function is called at each time step of the analysis. It returns the value for the custom load at that time. Mechanism Design uses this value to calculate forces and accelerations for this time step. Since CLUSEREvalCustomLoad passes the custom load name as an argument, many different custom loads may be supported by the same custom load executable.

Within CLUSEREvalCustomLoad, the user may call CLEvalMeasure. CLEvalMeasure takes the name of a measure, that exists in the model, as an input argument. When developing the custom load application, make sure to indicate in your custom load documentation the type of measure you want the user to create in the model.

Another important function is CLUSERDefineInit. It is called when the Mechanism Design user creates a new force motor or external force/torque. The function allows the custom load application to query the user for data specific to that custom load. The data can be stored and later used in the CLUSEREvalCustomLoad function. For example, if the custom load is for a spring, the CLUSERDefineInit function can ask the user to provide the spring constant for this load.

CLUSERRunInit is called before the Mechanism Design user runs any analysis that references the custom load.

The remaining functions can help to implement control systems using the custom load. The custom load application can provide a set of derivative values that Mechanism Design integrates at each time step.

Mechanism Design calls CLUSERGetStateVariablesSize before running an analysis. If the custom load application provides a non-zero state variable size, Mechanism Design calls CLUSERInitStateVariables before running the analysis. Then, at each time step, Mechanism Design calls CLUSERGetStateVariableDerivatives to get the current derivative values. The custom load application can then call CLEvalStateVariables to get the integral of the derivatives.

Functions and Their Argument Values

A custom load function is called with a number of arguments that you can optionally add to your definition of the function if you need them.

The following provides a detailed description of the arguments each function may have:
- **CLUSEREvalCustomLoad**

  ```c
  int CLUSEREvalCustomLoad (char* CustomLoadName, char* ForceName, double
  CurrentTime, double* value);
  ```

<table>
<thead>
<tr>
<th>Inputs:</th>
<th>CustomLoadName</th>
<th>Name of the custom load.</th>
</tr>
</thead>
<tbody>
<tr>
<td>ForceName</td>
<td>Name of the force motor or external force the custom load is used in.</td>
<td></td>
</tr>
<tr>
<td>CurrentTime</td>
<td>The current time of the analysis.</td>
<td></td>
</tr>
<tr>
<td>Outputs:</td>
<td>Value</td>
<td>The value of the custom load returned by the custom load application.</td>
</tr>
<tr>
<td>Returns:</td>
<td></td>
<td>0 if successful. Any non-zero value means that there is an error in the custom load and the analysis will not proceed.</td>
</tr>
</tbody>
</table>

- **CLEvalMeasure**

  ```c
  extern int CLEvalMeasure (char*, double* MeasureValue);
  ```

<table>
<thead>
<tr>
<th>Inputs:</th>
<th>meaName</th>
<th>Name of the measure to be evaluated. The measure must exist in the model and must be a position or velocity measure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outputs:</td>
<td>MeasureValue</td>
<td>The value of the measure at the current time.</td>
</tr>
<tr>
<td>Returns:</td>
<td></td>
<td>0 if successful. 1 if the measure does not exist or if the measure is not a position or velocity measure.</td>
</tr>
</tbody>
</table>

- **CLUSERDefineInit**

  ```c
  int CLUSERDefineInit (char* CustomLoadName, char* ForceName, double*
  value);
  ```

<table>
<thead>
<tr>
<th>Inputs:</th>
<th>CustomLoadName</th>
<th>Name of the custom load.</th>
</tr>
</thead>
<tbody>
<tr>
<td>ForceName</td>
<td>Name of the force motor or external force the custom load is used in.</td>
<td></td>
</tr>
<tr>
<td>Returns:</td>
<td></td>
<td>0 if successful. Any non-zero value means that there is an error in the custom load and the analysis will not proceed.</td>
</tr>
</tbody>
</table>

- **CLUSERRunInit**

  ```c
  int CLUSERRunInit (char* CustomLoadName, char* ForceName);
  ```

<table>
<thead>
<tr>
<th>Inputs:</th>
<th>CustomLoadName</th>
<th>Name of the custom load.</th>
</tr>
</thead>
<tbody>
<tr>
<td>ForceName</td>
<td>Name of the force motor or external force the custom load is used in.</td>
<td></td>
</tr>
</tbody>
</table>

154
the custom load is used in.

| Returns: | 0 if successful. Any non zero value means that there is an error in the custom load and the analysis will not proceed. |
|-------------------------------------|

- **CLUSERGetStateVariablesSize**

```c
int CLUSERGetStateVariablesSize (char* CustomLoadName, char* forceName, int* size);
```

<table>
<thead>
<tr>
<th>Inputs:</th>
<th>CustomLoadName</th>
<th>Name of the custom load.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ForceName</td>
<td>Name of the force motor or external force the custom load is used in.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Outputs:</th>
<th>Size</th>
<th>The size of the state variable vector.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Returns:</th>
<th>0 if successful. Any non zero value means that state variables are not used for this custom load.</th>
</tr>
</thead>
</table>

- **CLUSERInitStateVariables**

```c
int CLUSERInitStateVariables (char* CustomLoadName, char* forceName, double* StateVar);
```

<table>
<thead>
<tr>
<th>Inputs:</th>
<th>CustomLoadName</th>
<th>Name of the custom load.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ForceName</td>
<td>Name of the force motor or external force the custom load is used in.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Outputs:</th>
<th>StateVar</th>
<th>The vector of initial state variable values. The memory is allocated by Mechanism Design.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Returns:</th>
<th>0 if successful. Any non zero value means that there is an error in the custom load and the analysis will not proceed.</th>
</tr>
</thead>
</table>

- **CLUSERGetStateVariableDerivatives**

```c
int CLUSERGetStateVariableDerivatives (char* CustomLoadName, char* forceName, double CurrentTime, double* StateVar);
```

<table>
<thead>
<tr>
<th>Inputs:</th>
<th>CustomLoadName</th>
<th>Name of the custom load.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ForceName</td>
<td>Name of the force motor or external force the custom load is used in.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CurrentTime</th>
<th>The current time of the analysis.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Outputs:</th>
<th>StateVar</th>
<th>The vector of state variable values at this time. The memory is allocated by</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Returns:</th>
<th>0 if successful. Any non zero value means that there is an error in the custom load and the analysis will not proceed.</th>
</tr>
</thead>
</table>

### Guidelines for Creating a Custom Load Application

To effectively write custom loads, you should be familiar with the Pro/TOOLKIT application and have a thorough knowledge of the C programming language. You must also have in-depth experience using Mechanism Design and a good understanding of how forces, measures, and all other modeling entities work.

A typical custom load application includes two phases:

- **Initialization routine**—Requests the user for parameters to set up the custom load. You can also include error checking in this routine to ensure that the user has correctly defined the input.

- **Evaluation routine**—Evaluates the custom load based on customized logic or the current value of existing measures in the Mechanism Design model.

Keep in mind the following when creating a custom load:

- You should understand how the Mechanism Design user perceives and interacts with the custom load. If you plan and design the custom load properly, it appears to the user almost as a built-in feature of Mechanism Design.

- You must specify what inputs to request from the user and what additional data to request from Mechanism Design. You should also define what outputs are produced by the custom load, and what error conditions can occur.

- You should always provide a help file with any custom load you make. Each help file you create enables you to communicate detailed information about a specific
custom load to the user of the custom load. You can put this information in a simple ASCII file that is accessible when the user applies the custom load.

**Analyses**

**About Analyses**

You define the way that a mechanism should move by adding modeling entities, such as motors, forces, torques, and gravity to your mechanism. When you run an analysis, you define a combination of constraints, modeling entities, gravity, and friction that Mechanism Design uses to calculate your mechanism's response.

You can create multiple analysis definitions, using different motors or forces, and locking different entities, to organize your investigation of the motion of a particular mechanism into unique studies, without having to build separate assembly models. Save each result in a named playback sequence to replay at a later time.

Use the Analyses command to create and manage analyses. You can choose from five types of analyses:

- **Kinematic**—Use a kinematic analysis to make your mechanism move with servo motors, and analyze the motion without reference to forces acting on the system.

- **Dynamic**—Use a dynamic analysis to study the relationship between the inertial, gravitational, and external forces acting on the mass of bodies in your mechanism.

- **Static**—Use a static analysis to study forces acting on a body when it has reached equilibrium.

- **Force Balance**—Use a force balance analysis to determine the forces required to keep a mechanism fixed in a particular configuration.

- **Repeated Assembly**—Use a repeated assembly analysis to determine whether your mechanism can assemble under the requirements of the applied servo motors and connections.

You can run any of these types of analyses if you have a Mechanism Dynamics Option license. If you do not have a license for the Mechanism Dynamics Option, you can only run Repeated Assembly and Kinematic analyses.

After you run your analysis, you can evaluate your results quantitatively by creating measures.

**About the Analyses Dialog Box**

The Analyses dialog box opens when you click Mechanism > Analyses. Use this dialog box to organize and control your analyses. The dialog box includes a list of the analyses in your model. You can use this form to add a new analysis, edit an existing analysis, copy an existing analysis to a new name, or remove an existing analysis from your model.

The dialog box includes the following fields:

- **New**—Use this button to create a new analysis.
• **Edit**—Use this button to rename or change the definition of an analysis in the list.

• **Copy**—Use this button to copy one of the analyses in the list to a new name. Mechanism Design adds an analysis named Copy of analysis_name, and highlights it. Click **Edit** to change the name.

• **Run**—Use this button to run your analysis.

• **Delete**—Use this button to delete a highlighted analysis from the list. You can also delete several analyses at once. Hold the SHIFT key, highlight the analyses, and click **Delete**.

You may want to review tips before running an analysis.

**About the Analysis Definition Dialog Box**

Use this dialog box to create a new analysis or edit an existing one. To access this dialog box, click **Mechanism > Analyses**. When the **Analyses** dialog box opens, click **New** or **Edit**.

The **Analysis Definition** dialog box includes the following items:

• **Type**—Aspects of the dialog box change, depending on the type of analysis you select, because the different analyses require different input. Choose from the following five analysis types:
  
  o **Kinematic**
  
  o **Dynamic**
  
  o **Static**
  
  o **Force Balance**
  
  o **Repeated Assembly**

The **Analysis Definition** dialog box contains three tabs:

• **Preferences** tab
  
  o for repeated assembly and kinematic analyses
  
  o for dynamic analyses
  
  o for static analyses
  
  o for force balance analyses

• **Motors** tab

• **Ext Loads** tab (inactive for repeated assembly and kinematic analyses)

The dialog box contains a **Run** button so that you can run an analysis immediately after defining it. By clicking this button, you perform the same error checking as the **OK** button does to complete the definition of an analysis. The **Run** button runs the defined analysis but does not add it to the model. When you click **OK**, the software finishes the definition, creates the analysis, and adds the analysis definition to the model.
You may want to review Tip: Running an Analysis before creating an analysis.

**To Run an Analysis**

You can run an analysis from both the Analyses and the Analysis Definition dialog boxes.

**From the Analysis Dialog Box**

1. Select an analysis definition from the Analyses dialog box list and click Run. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

2. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

**From the Analysis Definition Dialog Box**

1. Click Run. The Run dialog box opens and the analysis run begins.

2. click Run from the Analysis Definition dialog box. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

3. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

4. If you prefer to accept the analysis definition and run the analysis later, click OK.

**Tip: Running an Analysis**

Here are some key points that may help in analyzing your model:

- If the mechanism does not behave as expected, the problem may be caused by too many or too few DOFs. Add or remove constraints, using the locked entities section of the analysis definition to resolve the problem.

- The analysis run is stored as a results set and you can play it back in the same session by clicking Mechanism > Playback. This results set may be saved as a file and restored for future use.

- If the analysis run indicates that the mechanism could not assemble at particular frames, you may have defined motors that require the mechanism to assemble in an impossible configuration. This could be due to an error in the way you defined the motor, a conflict between multiple motors, or motors attempting to move a joint past its limits. Examine the mechanism at the last successfully assembled frame and determine if the motor definitions are appropriate.
• After you have run an analysis, you can animate the mechanism to ensure the mechanism moves as desired and check for interference between parts. You can also create graphs for key quantities, including reaction measures, or joint axis positions, velocities, and accelerations. For information regarding the results of your analysis run, see Saving and Viewing Repeated Assembly or Kinematic Results or Saving and Viewing Analysis Results in Mechanism Dynamics.

Validation Checks for Analyses

Error handling in analyses occurs when you click the Run or OK button:

• Each input field is validated when the focus is moved out of the field. For example, a validation check looks at the From and To times for the duration of the analysis to ensure they are not the same value.

Run includes some of the same error checks as the OK button, such as for duplication of motors, but it does not check for name duplication.

• When you click OK, a check is done for duplicate, overlapping motors and forces, and for name validation. The validation check automatically updates the frame rate, count, and interval for time-conditional motors and external loads.

Repeated Assembly Analyses

About Repeated Assembly Analysis

Use the Mechanism > Analyses command to work with your analysis.

Repeated Assembly analysis was called Kinematic analysis in previous releases of Mechanism Design. It is a series of assembly analyses driven by servo motors. Only joint axis or geometric servo motors can be included for repeated assembly analyses. Force motors do not appear in the list of possible motor selections when adding a motor for a repeated assembly analysis.

Note: If you edit an analysis that you created as a Kinematic analysis in a previous release of Mechanism Design, the definition will now specify it as a Repeated Assembly analysis.

A repeated assembly analysis simulates the mechanism's motion, satisfying the requirements of your servo motors profiles and any joint, cam-follower, slot-follower, or gear-pair connections, and records position data for the mechanism's various components. It does not take force and mass into account in doing the analysis. Therefore, you do not have to specify mass properties for your mechanism. Dynamic entities in the model, such as springs, dampers, gravity, forces/torques, and force motors, do not affect a repeated assembly analysis.

Use a repeated assembly analysis to study:

• positions of components over time
• interference between components
• trace curves of the mechanism's motion
The **Mechanism > Analyses** command opens a dialog box, which you can use to create, edit, copy, delete, or run your analyses. If you move the cursor over a given analysis in the **Analyses** dialog box, a message box appears with a summary of that analysis.

**To Create a Repeated Assembly Analysis**

1. Click **Mechanism > Analyses** or [Image]. The **Analyses** dialog box appears.
2. Click **New**. The **Analysis Definition** dialog box appears.
3. Enter a meaningful name for the analysis in the **Name** window or accept the default name, **AnalysisDefinition1**. You can enter a name of up to 31 characters.
4. Under **Type**, select **Repeated Assembly**.
5. Complete the **Preferences** tab.
6. Select the **Motors** tab. Enter the desired information.
7. Select one of the following options:
   - If you want to run the analysis you just created, click **Run**.
   - If you want to accept the analysis definition and run it later, click **OK**. Mechanism Design returns you to the **Analyses** dialog box.

**To Define Preferences for Repeated Assembly and Kinematic Analyses**

This procedure assumes you are on the **Preferences** tab of the **Analysis Definition** dialog box, and have selected either **Repeated Assembly** or **Kinematic** under **Type**.

1. Enter the **Start Time** in the **Graphical Display** area.
2. Select from the three choices in the drop-down menu:
   - **Length and Rate**
   - **Length and Frame Count**
   - **Rate and Frame Count**
3. Enter the relevant information in the **End Time**, **Frame Count**, **Frame Rate** and **Minimum Interval** fields.
4. You can use the following options in the **Locked Entities** area:
   - Click [Image] and select a lead body, then a set of follower bodies to be locked to the lead body.
   - Click [Image] and select a joint or cam-follower connection to be locked.
Mechanism Design adds the name of the new constraint to the list of constraints in the **Analysis Definition** dialog box.

**Note:** Click to delete unwanted constraints.

5. Select one of these options under **Initial Configuration** to set the starting point for the analysis:
   - Click **Current** to use the current screen configuration.
   - Click **Snapshot** and choose a previously saved snapshot.

6. If you have clicked **Snapshot**, click to preview the specified configuration.

**Entering Preferences for Repeated Assembly and Kinematic Analyses**

Use the **Preferences** tab on the **Analysis Definition** dialog box to specify time domain, locked entities, and initial configuration information for repeated assembly and kinematic analyses.

Use the items in the **Graphical Display** area to specify the time domain for your analysis. Enter a **Start Time**, and then choose one of the items from the drop-down menu. The parameters that you use to specify the time domain depend upon which item you select. Enter values as explained below to specify the time domain:

- **Length and Rate**—Enter the **End Time** and **Frame Rate** or **Minimum Interval** to define the analysis time domain. The **Frame Count** area is unavailable.

- **Length and Frame Count**—Enter the **End Time** and **Frame Count** to define the analysis time domain. The **Frame Rate** and **Minimum Interval** areas are unavailable.

- **Rate and Frame Count**—Enter the **Frame Count** and **Frame Rate** or **Minimum Interval** to define the analysis time domain. The **End Time** area is unavailable.

**Note:** **Frame Rate** and **Minimum Interval** are complements of each other. The length, frame rate, frame count, and interval of the motion run are related by the following formulas:

Frame Rate = 1/Interval

Frame Count = Frame Rate * Length + 1

Use the **Locked Entities** area to specify which bodies or connections in your mechanism remain locked during your analysis. Locking bodies fixes the position of one body relative to another during the defined analysis. Locking connections removes the motion associated with that connection’s DOF during the defined analysis.

Use the **Initial Configuration** area to specify a configuration for the start of your repeated assembly or kinematic analysis. The configuration describes the relative orientation of the parts and bodies in your mechanism. Select one of these options:
- Click **Current** to use the positions of the bodies in the screen configuration.
- Click **Snapshot** to select a snapshot saved using the **Drag** dialog box. Only the position of bodies in your mechanism is used from a selected snapshot. Any constraints saved in the snapshot are ignored.

A **Run** button allows you to run the analysis directly after creating it. When you click the **Run** button, Mechanism Design performs the same error checking as when you click the **OK** button—to ensure the analysis information has been entered appropriately—before running the analysis.

**About Locked Entities for Analyses**

You can select one of these options on the **Preferences** tab of the **Analysis Definition** dialog box to perform the following actions:

- To lock bodies, click and choose the lead body. Then select all bodies that you want locked to the lead body. To lock all bodies to ground, middle-click when asked to pick the lead body. The two locked bodies are added to the **Locked Entities** list.

  The body lock constraint is used when you want bodies to remain fixed relative to one another. When created, the check box to the left of the label is selected by default. You can clear this item if you do not want to include it in the current analysis.

- To lock a connection, click and choose a connection to lock. This constraint is used when you want a connection to remain in its current configuration for the duration of an analysis. Note that cam and slot connections can also be locked. You cannot select a gear-pair connection to be locked. To lock a gear pair, you must select one of the joint connections in the gear pair. The locked connection is added to the **Locked Entities** list.

  When created, the check box to the left of the label is selected by default. You can clear this locked connection to not include it in the current analysis.

- To define a loadcell lock, click and choose a point or vertex, a body on which to apply the loadcell, and a direction vector. Specify components of the direction vector in terms of the previously selected body coordinate system.

  You typically use the loadcell lock constraint when you run a force balance analysis.

- To delete one or more entities, highlight a row or rows and click to remove the entity or entities from the list.

**To Specify Motors for an Analysis**

This procedure assumes that you are adding motors to your model, and are on the **Motors** tab of the **Analysis Definition** dialog box.

1. To include motors, choose from the following options:
Mechanism Design Extension Help Topic Collection

- Select a motor and click to add another instance of the motor.
- Click to add all motors available for your model.

**Note:** Select one or more rows and click to remove undesired changes.

2. If you want to change the time that an external load will be active, select a load from the list and click on the area under From or To to edit the times.

3. Click OK or Run.

**Entering Motors Information**

You can add or delete motors on the Motors tab for all analysis types. Use the Motors tab on the Analysis Definition dialog box to select which motors will be used in the analysis definition.

You use the Motors tab slightly differently for the different types of analysis.

**All analyses:**

- By default, Mechanism Design includes all motors that exist in the model at the time that you create the analysis. To include motors created after completing the analysis definition, edit the analysis definition and click to explicitly include them.

- When you click on the Motors tab, you are adding a previously defined motor to be included in the analysis. This motor is, by default, the first entry in the list. When you select , you are adding one instance of every motor that exists in the model to be included in the analysis.

- The default values for the From and To times are the Start and End times of the analysis time domain.

- Click the column headings on the Motors tab to sort motors alphabetically or to sort the From and To times numerically.

**Kinematic and repeated assembly analyses:**

- You can control the start and end times of servo motors for kinematic and repeated assembly analyses. By doing so, you can start one motor, turn it off, and start another within your analysis run. This allows you more flexibility when creating your analysis. Control your servo motors by editing the From and To time domains on the Motors tab.

- You cannot use geometric servo motors in kinematic analyses. These motors do not appear in the list of possible servo motors for kinematic analyses.

- You can either give a numeric value for From or choose Start—representing the start time of the analysis—from the drop-down menu in the From column. The To column is also an input field with a drop-down option to select End—representing the end of the analysis.
• If an invalid value is specified for the time, the value is set to the **Start** or **End** of the analysis, as appropriate.

**Dynamic, static, and force balance analyses:**

• You can use both servo and force motors for dynamic, static, and force balance analyses. Servo motors are active for the duration of these analyses. The **From** and **To** times for servo motors are uneditable.

• Geometric servo motors (servo motors that drive points or planes) do not appear in the list of possible motors in dynamic, static, or force balance analysis. They have no effect on these analyses.

• All motors are active for the duration of static and force balance analyses.

Because you can define multiple motors for an entity, be sure to keep track of which motors are included or excluded at any time. To avoid analysis failure and inaccurate results, activate only one motor for an entity at a time.

For example, if you create a zero position servo motor and a constant non-zero velocity servo motor on the same rotational joint axis, do not activate both motors for the same analysis. Also, if you define two force motors on the same joint axis and activate both in the same dynamic analysis, the resulting applied force will be the sum of both motors.

**To Copy an Analysis**

Use this procedure to copy a previously defined analysis.

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.

2. Select a previously defined analysis from the list.

3. Click **Copy**. A new entry appears in the list, with **Copy of** appended to the name of the copied analysis. This analysis has the same definition as the analysis from which it was copied.

4. Change the definition of the newly copied analysis as needed by editing the appropriate information on any of the tabs in the **Analysis Definition** dialog box.

**To Edit an Analysis Definition**

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.

2. Select the desired analysis definition from the list of existing analyses.

3. Click **Edit**. The **Analysis Definition** dialog box appears. Change the name, or any of the items on the **Preferences**, **Motors** and **Ext Loads** tabs, if available, as needed.

4. Click **OK** to save the modified analysis specification.

   **Note:** To revert to the previously saved analysis definition, click **Cancel** before leaving the analysis definition.
To Delete an Analysis

Use this procedure to delete a previously defined analysis.

1. Click Mechanism > Analyses. The Analyses dialog box appears.
2. Select a previously defined analysis from the list.
3. Click Delete. The selected analysis is removed from the list and from the model definition.

Kinematic Analyses

About Kinematic Analysis

Use the Mechanism > Analyses command to work with your analysis.

Use a kinematic analysis to evaluate the motion of your mechanism as driven by servo motors. You can use any joint axis servo motors with a profile that will result in finite acceleration.

Note: The analysis type that was called Kinematic analysis in previous releases of Mechanism Design is now called Repeated Assembly.

Kinematics is a branch of dynamics that deals with aspects of motion apart from consideration of mass and force. A kinematic analysis simulates the mechanism's motion, satisfying the requirements of your servo motor profiles and any joint, cam-follower, slot-follower, or gear-pair connection. A kinematic analysis does not take forces into account. Therefore, you cannot use force motors, and you do not have to specify mass properties for your mechanism. Dynamic entities in the model, such as springs, dampers, gravity, forces/torques, and force motors, do not affect a kinematic analysis.

Be aware that if your servo motor has a non-continuous profile, Mechanism Design tries to make the profile continuous before running a kinematic analysis. If the profile is such that the software cannot make it continuous, the motor is not used for the analysis.

Use a kinematic analysis to obtain information on:
- position, velocity, and acceleration of geometric entities and connections
- interference between components
- trace curves of the mechanism's motion
- motion envelopes that capture the mechanism's motion as a Pro/ENGINEER part

The Mechanism > Analyses command opens a dialog box, which you can use to create, edit, copy, delete, or run your analyses. If you move the cursor over a given analysis in the Analyses dialog box, a message box appears with a summary of that analysis.

To Create a Kinematic Analysis

1. Click Mechanism > Analyses or . The Analyses dialog box appears.
2. Click **New**. The **Analysis Definition** dialog box appears.

3. Enter a descriptive name for the analysis in the **Name** window or accept the default name, **AnalysisDefinition1**. You can enter a name of up to 31 characters.

4. Under **Type**, verify that the analysis type is **Kinematic**.

5. Complete the **Preferences** tab.

6. Select the **Motors** tab. Enter the desired information.

7. Select one of the following options:
   - If you want to run the analysis you just created, click **Run**.
   - If you want to accept the analysis definition and run it later, click **OK**.
     Mechanism Design returns you to the **Analyses** dialog box.

---

**To Define Preferences for Repeated Assembly and Kinematic Analyses**

This procedure assumes you are on the **Preferences** tab of the **Analysis Definition** dialog box, and have selected either **Repeated Assembly** or **Kinematic** under **Type**.

1. Enter the **Start Time** in the **Graphical Display** area.

2. Select from the three choices in the drop-down menu:
   - **Length and Rate**
   - **Length and Frame Count**
   - **Rate and Frame Count**

3. Enter the relevant information in the **End Time**, **Frame Count**, **Frame Rate** and **Minimum Interval** fields.

4. You can use the following options in the **Locked Entities** area:
   - Click ![Locked Body](image) and select a lead body, then a set of follower bodies to be locked to the lead body.
   - Click ![Locked Joint](image) and select a joint or cam-follower connection to be locked.
     Mechanism Design adds the name of the new constraint to the list of constraints in the **Analysis Definition** dialog box.

   **Note:** Click ![Delete](image) to delete unwanted constraints.

5. Select one of these options under **Initial Configuration** to set the starting point for the analysis:
   - Click **Current** to use the current screen configuration.
Click **Snapshot** and choose a previously saved snapshot.

6. If you have clicked **Snapshot**, click to preview the specified configuration.

**Entering Preferences for Repeated Assembly and Kinematic Analyses**

Use the **Preferences** tab on the **Analysis Definition** dialog box to specify time domain, locked entities, and initial configuration information for repeated assembly and kinematic analyses.

Use the items in the **Graphical Display** area to specify the time domain for your analysis. Enter a **Start Time**, and then choose one of the items from the drop-down menu. The parameters that you use to specify the time domain depend upon which item you select. Enter values as explained below to specify the time domain:

- **Length and Rate**—Enter the **End Time** and **Frame Rate** or **Minimum Interval** to define the analysis time domain. The **Frame Count** area is unavailable.

- **Length and Frame Count**—Enter the **End Time** and **Frame Count** to define the analysis time domain. The **Frame Rate** and **Minimum Interval** areas are unavailable.

- **Rate and Frame Count**—Enter the **Frame Count** and **Frame Rate** or **Minimum Interval** to define the analysis time domain. The **End Time** area is unavailable.

**Note:** **Frame Rate** and **Minimum Interval** are complements of each other. The length, frame rate, frame count, and interval of the motion run are related by the following formulas:

Frame Rate = 1/Interval

Frame Count = Frame Rate * Length + 1

Use the **Locked Entities** area to specify which bodies or connections in your mechanism remain locked during your analysis. Locking bodies fixes the position of one body relative to another during the defined analysis. Locking connections removes the motion associated with that connection’s DOF during the defined analysis.

Use the **Initial Configuration** area to specify a configuration for the start of your repeated assembly or kinematic analysis. The configuration describes the relative orientation of the parts and bodies in your mechanism. Select one of these options:

- Click **Current** to use the positions of the bodies in the screen configuration.

- Click **Snapshot** to select a snapshot saved using the **Drag** dialog box. Only the position of bodies in your mechanism is used from a selected snapshot. Any constraints saved in the snapshot are ignored.

A **Run** button allows you to run the analysis directly after creating it. When you click the **Run** button, Mechanism Design performs the same error checking as when you click the **OK** button—to ensure the analysis information has been entered appropriately—before running the analysis.
About Locked Entities for Analyses

You can select one of these options on the Preferences tab of the Analysis Definition dialog box to perform the following actions:

- To lock bodies, click \[\text{lock body}\] and choose the lead body. Then select all bodies that you want locked to the lead body. To lock all bodies to ground, middle-click when asked to pick the lead body. The two locked bodies are added to the Locked Entities list.

  The body lock constraint is used when you want bodies to remain fixed relative to one another. When created, the check box to the left of the label is selected by default. You can clear this item if you do not want to include it in the current analysis.

- To lock a connection, click \[\text{lock connection}\] and choose a connection to lock. This constraint is used when you want a connection to remain in its current configuration for the duration of an analysis. Note that cam and slot connections can also be locked. You cannot select a gear-pair connection to be locked. To lock a gear pair, you must select one of the joint connections in the gear pair. The locked connection is added to the Locked Entities list.

  When created, the check box to the left of the label is selected by default. You can clear this locked connection to not include it in the current analysis.

- To define a loadcell lock, click \[\text{loadcell lock}\] and choose a point or vertex, a body on which to apply the loadcell, and a direction vector. Specify components of the direction vector in terms of the previously selected body coordinate system.

  You typically use the loadcell lock constraint when you run a force balance analysis.

- To delete one or more entities, highlight a row or rows and click \[\text{remove entity}\] to remove the entity or entities from the list.

To Specify Motors for an Analysis

This procedure assumes that you are adding motors to your model, and are on the Motors tab of the Analysis Definition dialog box.

1. To include motors, choose from the following options:
   - Select a motor and click \[\text{add motor}\] to add another instance of the motor.
   - Click \[\text{add all motors}\] to add all motors available for your model.

     **Note:** Select one or more rows and click \[\text{remove undesired changes}\] to remove undesired changes.

2. If you want to change the time that an external load will be active, select a load from the list and click on the area under From or To to edit the times.
3. Click **OK** or **Run**.

**Entering Motors Information**

You can add or delete motors on the **Motors** tab for all analysis types. Use the **Motors** tab on the **Analysis Definition** dialog box to select which motors will be used in the analysis definition.

You use the **Motors** tab slightly differently for the different types of analysis.

**All analyses:**

- By default, Mechanism Design includes all motors that exist in the model at the time that you create the analysis. To include motors created after completing the analysis definition, edit the analysis definition and click **Motors** to explicitly include them.

- When you click **Motors** on the **Motors** tab, you are adding a previously defined motor to be included in the analysis. This motor is, by default, the first entry in the list. When you select **Motors**, you are adding one instance of every motor that exists in the model to be included in the analysis.

- The default values for the **From** and **To** times are the **Start** and **End** times of the analysis time domain.

- Click the column headings on the **Motors** tab to sort motors alphabetically or to sort the **From** and **To** times numerically.

**Kinematic and repeated assembly analyses:**

- You can control the start and end times of servo motors for kinematic and repeated assembly analyses. By doing so, you can start one motor, turn it off, and start another within your analysis run. This allows you more flexibility when creating your analysis. Control your servo motors by editing the **From** and **To** time domains on the **Motors** tab.

- You cannot use geometric servo motors in kinematic analyses. These motors do not appear in the list of possible servo motors for kinematic analyses.

- You can either give a numeric value for **From** or choose **Start**—representing the start time of the analysis—from the drop-down menu in the **From** column. The **To** column is also an input field with a drop-down option to select **End**—representing the end of the analysis.

- If an invalid value is specified for the time, the value is set to the **Start** or **End** of the analysis, as appropriate.

**Dynamic, static, and force balance analyses:**

- You can use both servo and force motors for dynamic, static, and force balance analyses. Servo motors are active for the duration of these analyses. The **From** and **To** times for servo motors are uneditable.
• Geometric servo motors (servo motors that drive points or planes) do not appear in the list of possible motors in dynamic, static, or force balance analysis. They have no effect on these analyses.

• All motors are active for the duration of static and force balance analyses.

Because you can define multiple motors for an entity, be sure to keep track of which motors are included or excluded at any time. To avoid analysis failure and inaccurate results, activate only one motor for an entity at a time.

For example, if you create a zero position servo motor and a constant non-zero velocity servo motor on the same rotational joint axis, do not activate both motors for the same analysis. Also, if you define two force motors on the same joint axis and activate both in the same dynamic analysis, the resulting applied force will be the sum of both motors.

To Run an Analysis

You can run an analysis from both the Analyses and the Analysis Definition dialog boxes.

From the Analysis Dialog Box

1. Select an analysis definition from the Analyses dialog box list and click Run. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

2. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

From the Analysis Definition Dialog Box

1. Click Run. The Run dialog box opens and the analysis run begins.

2. click Run from the Analysis Definition dialog box. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

3. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

4. If you prefer to accept the analysis definition and run the analysis later, click OK.

To Edit an Analysis Definition

1. Click Mechanism > Analyses. The Analyses dialog box appears.

2. Select the desired analysis definition from the list of existing analyses.
3. Click **Edit**. The **Analysis Definition** dialog box appears. Change the name, or any of the items on the **Preferences**, **Motors** and **Ext Loads** tabs, if available, as needed.

4. Click **OK** to save the modified analysis specification.

   **Note:** To revert to the previously saved analysis definition, click **Cancel** before leaving the analysis definition.

**To Copy an Analysis**

Use this procedure to copy a previously defined analysis.

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.

2. Select a previously defined analysis from the list.

3. Click **Copy**. A new entry appears in the list, with **Copy of** appended to the name of the copied analysis. This analysis has the same definition as the analysis from which it was copied.

4. Change the definition of the newly copied analysis as needed by editing the appropriate information on any of the tabs in the **Analysis Definition** dialog box.

**To Delete an Analysis**

Use this procedure to delete a previously defined analysis.

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.

2. Select a previously defined analysis from the list.

3. Click **Delete**. The selected analysis is removed from the list and from the model definition.

**Tutorial 2D: Creating and Running a Kinematic Analysis**

This tutorial shows you how to create and run a motion analysis for a four-bar linkage. It is the fourth part of the second Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start them, see Creating a Four-Bar Linkage.

1. Create a kinematic motion analysis. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.

2. Click **New**. The **Analysis Definition** dialog box appears.

3. Under **Type**, select **Kinematic**.

4. Change the **End Time** to 5 seconds on the **Preferences** tab, and click **OK** to accept the analysis definition.

5. Click **Run**.
Note: If your mechanism is overconstrained or incorrect, the analysis will stop. In this case, the analysis fails because a joint axis limit is reached and the servo motor is trying to force the connection beyond its limit.

Tip: You can define the action that Mechanism Design takes when a run stops by using the Settings command.

6. Click Abort on the error message box.

7. Select the Motors tab on the Analysis Definition dialog box.

8. Select the servo motor. Change the value under To from End to 2.5.

9. Highlight ServoMotor1 in the Motor list and click to add another instance of the motor to the list.

10. Highlight the second instance of ServoMotor1. Change the value under From from Start to 2.51.

11. Rerun the motion analysis.

Dynamic Analyses

About Dynamic Analysis

Use the Mechanism > Analyses command to work with your analysis.

Dynamic analysis is a branch of mechanics that deals with forces and their relation primarily to the motion, but sometimes also to the equilibrium, of bodies. You can use a dynamic analysis to study the relationship between the forces acting on a body, the mass of the body, and the motion of the body.

Keep the following key points in mind when running a dynamic analysis:

- Joint-axis-based servo motors are active for the entire duration of a dynamic analysis. For this reason, the From and To times, derived from the time domain for the analysis, appear as the uneditable values Start and End.

- You can add both servo and force motors.

- If your servo or force motor has a non-continuous profile, Mechanism Design tries to make the profile continuous before running a dynamic analysis. If the profile is such that the software cannot make it continuous, the motor is not used for the analysis.

- You can add forces/torques using the Ext Loads tab.

- You can turn gravity and friction on or off.

You can evaluate the positions, velocities, accelerations, and reaction forces at the beginning of your dynamic analysis by specifying a zero time duration and running as usual. In this case, Mechanism Design determines a suitable time interval for the calculations. If you graph any measures from this type of analysis, the graph will contain only a single line.
The **Mechanism > Analyses** command opens a dialog box, which you can use to create, edit, copy, delete, or run your analyses. If you move the cursor over a given analysis in the **Analyses** dialog box, a message box appears with a summary of that analysis.

**To Create a Dynamic Analysis**

1. Click **Mechanism > Analyses** or 📐. The **Analyses** dialog box appears.
2. Click **New**. The **Analysis Definition** dialog box appears.
3. Enter a descriptive name for the analysis in the **Name** window or accept the default name, *AnalysisDefinition1*. You can enter a name of up to 31 characters.
4. Under **Type**, select **Dynamic**.
5. Complete the **Preferences** tab.
6. Click the **Motors** tab. Enter the desired information.
7. Click the **Ext Loads** tab. Enter the desired information.
8. Select one of the following options:
   - If you want to run the analysis you just created, click **Run**.
   - If you want to accept the analysis and run it later, click **OK**. Mechanism Design returns you to the **Analyses** dialog box.

**To Define Preferences for Dynamic Analysis**

This procedure assumes you are on the **Preferences** tab of the **Analysis Definition** dialog box, and have selected **Dynamic** under **Type**.

1. Select from the three choices in the drop-down menu under **Graphical Display**:
   - **Length and Rate**
   - **Length and Frame Count**
   - **Rate and Frame Count**
2. Enter the relevant information in the **Duration**, **Frame Count**, **Frame Rate**, and **Minimum Interval** fields.
3. You can select one of the following options in the **Locked Entities** area:
   - Click 🔄 and select a lead body, then a set of follower bodies to be locked.
   - Click 🔄 and select a joint or cam-follower connection to be locked.

Mechanism Design adds the name of the new constraint to the list of constraints in the **Analysis Definition** dialog box.
Note: Click to delete unwanted constraints.

4. Select one of these options under Initial Condition to set the model's starting conditions:
   - Click Current to use the current screen configuration.
   - Click IC State and choose a previously saved initial condition.

5. If you selected IC State, click to preview the configuration associated with that state.

Entering Preferences for Dynamic Analyses

Use the Preferences tab on the Analysis Definition dialog box to specify time domain, locked entities, and initial configuration information for dynamic analyses.

You cannot specify a start time for dynamic analyses. Servo motors, springs, dampers, and gear pairs are active for the entire dynamic analysis. It is necessary to begin the analysis from the time these entities are turned on, to take into account any effects from these entities.

Select one of the options from the drop-down menu under Graphical Display. The parameters that you use to specify the time domain depend upon which item you select. Enter values as explained below to specify the time domain for your analysis:

- **Length and Rate**—Enter the Duration and Frame Rate or Minimum Interval to define the analysis time domain. The Frame Count area is unavailable.
  
  Note: If you want to evaluate the positions, velocities, accelerations, and reaction forces of the entities in your mechanism at the beginning of your dynamic analysis, enter 0 for Duration. You can use this method as a quick check before running a longer dynamic analysis. When you enter zero, the drop-down list, and the text entry boxes for Frame Rate, Frame Count, and Minimum Interval are unavailable.

- **Length and Frame Count**—Enter the Duration and Frame Count to define the analysis time domain. The Frame Rate and Minimum Interval areas are unavailable.

- **Rate and Frame Count**—Enter the Frame Count and Frame Rate or Minimum Interval to define the analysis time domain. The Duration area is unavailable.

  Note: Frame Rate and Minimum Interval are complements of each other. The length, frame count, frame rate, and interval of the motion run are related by the following formulas:

  \[
  \text{Frame Rate} = \frac{1}{\text{Interval}}
  \]

  \[
  \text{Frame Count} = \text{Frame Rate} \times \text{Length} + 1
  \]
Use the **Locked Entities** area to specify which bodies or connections in your mechanism remain locked during your dynamic analysis. Locking bodies fixes the position of one body relative to another during the defined analysis. Locking connections removes the motion associated with the connection’s DOF during the defined analysis.

Use the **Initial Condition** area to select configuration and velocity conditions for the start of your dynamic analysis. Select one of these options:

- Click **Current** to use the positions of the bodies in the current screen configuration
- Click **Initial Condition** to select a previously saved initial condition. You can also preview the configuration associated with a selected initial condition.

A **Run** button allows you to run the analysis directly after creating it. When you click the **Run** button, Mechanism Design performs the same error checking as when you click the **OK** button—to ensure the analysis information has been entered appropriately—before running the analysis.

### About Locked Entities for Analyses

You can select one of these options on the **Preferences** tab of the **Analysis Definition** dialog box to perform the following actions:

- **To lock bodies**, click ![image](image1.png) and choose the lead body. Then select all bodies that you want locked to the lead body. To lock all bodies to ground, middle-click when asked to pick the lead body. The two locked bodies are added to the **Locked Entities** list. The body lock constraint is used when you want bodies to remain fixed relative to one another. When created, the check box to the left of the label is selected by default. You can clear this item if you do not want to include it in the current analysis.

- **To lock a connection**, click ![image](image2.png) and choose a connection to lock. This constraint is used when you want a connection to remain in its current configuration for the duration of an analysis. Note that cam and slot connections can also be locked. You cannot select a gear-pair connection to be locked. To lock a gear pair, you must select one of the joint connections in the gear pair. The locked connection is added to the **Locked Entities** list.

  When created, the check box to the left of the label is selected by default. You can clear this locked connection to not include it in the current analysis.

- **To define a loadcell lock**, click ![image](image3.png) and choose a point or vertex, a body on which to apply the loadcell, and a direction vector. Specify components of the direction vector in terms of the previously selected body coordinate system.

  You typically use the loadcell lock constraint when you run a force balance analysis.
To delete one or more entities, highlight a row or rows and click \( \text{\textcolor{red}{\text{X}}} \) to remove the entity or entities from the list.

**To Specify Motors for an Analysis**

This procedure assumes that you are adding motors to your model, and are on the **Motors** tab of the **Analysis Definition** dialog box.

1. To include motors, choose from the following options:
   - Select a motor and click \( \text{\textcolor{blue}{+}} \) to add another instance of the motor.
   - Click \( \text{\textcolor{blue}{\text{all}}} \) to add all motors available for your model.
     
     **Note:** Select one or more rows and click \( \text{\textcolor{red}{\text{X}}} \) to remove undesired changes.

2. If you want to change the time that an external load will be active, select a load from the list and click on the area under **From** or **To** to edit the times.

3. Click **OK** or **Run**.

**Entering Motors Information**

You can add or delete motors on the **Motors** tab for all analysis types. Use the **Motors** tab on the **Analysis Definition** dialog box to select which motors will be used in the analysis definition.

You use the **Motors** tab slightly differently for the different types of analysis.

**All analyses:**

- By default, Mechanism Design includes all motors that exist in the model at the time that you create the analysis. To include motors created after completing the analysis definition, edit the analysis definition and click \( \text{\textcolor{blue}{+}} \) to explicitly include them.

- When you click \( \text{\textcolor{blue}{+}} \) on the **Motors** tab, you are adding a previously defined motor to be included in the analysis. This motor is, by default, the first entry in the list. When you select \( \text{\textcolor{blue}{\text{all}}} \), you are adding one instance of every motor that exists in the model to be included in the analysis.

- The default values for the **From** and **To** times are the **Start** and **End** times of the analysis time domain.

- Click the column headings on the **Motors** tab to sort motors alphabetically or to sort the **From** and **To** times numerically.

**Kinematic and repeated assembly analyses:**

- You can control the start and end times of servo motors for kinematic and repeated assembly analyses. By doing so, you can start one motor, turn it off, and start another within your analysis run. This allows you more flexibility when
creating your analysis. Control your servo motors by editing the **From** and **To**
time domains on the **Motors** tab.

- You cannot use geometric servo motors in kinematic analyses. These motors do
  not appear in the list of possible servo motors for kinematic analyses.

- You can either give a numeric value for **From** or choose **Start**—representing the
  start time of the analysis—from the drop-down menu in the **From** column. The
  **To** column is also an input field with a drop-down option to select **End**—
  representing the end of the analysis.

- If an invalid value is specified for the time, the value is set to the **Start** or **End** of
  the analysis, as appropriate.

**Dynamic, static, and force balance analyses:**

- You can use both servo and force motors for dynamic, static, and force balance
  analyses. Servo motors are active for the duration of these analyses. The **From**
  and **To** times for servo motors are uneditable.

- Geometric servo motors (servo motors that drive points or planes) do not appear
  in the list of possible motors in dynamic, static, or force balance analysis. They
  have no effect on these analyses.

- All motors are active for the duration of static and force balance analyses.

Because you can define multiple motors for an entity, be sure to keep track of which
motors are included or excluded at any time. To avoid analysis failure and inaccurate
results, activate only one motor for an entity at a time.

For example, if you create a zero position servo motor and a constant non-zero
velocity servo motor on the same rotational joint axis, do not activate both motors
for the same analysis. Also, if you define two force motors on the same joint axis and
activate both in the same dynamic analysis, the resulting applied force will be the
sum of both motors.

**To Specify External Loads for an Analysis**

This procedure assumes that you are on the **Ext Loads** tab of the **Analysis
Definition** dialog box. Mechanism Design lists all loads that exist in the model at the
time that you define the analysis.

1. To include an external load, choose from the following options:
   - Select an existing load and click to add another instance of the load.
   - Click to add all loads available for your model.

   **Note:** Select one or more rows and click to remove undesired loads.

2. If you want to change the time that an external load will be active, select a load
   from the list and click in the area under **From** or **To** to edit the times.
3. If you click the name of any load in the list you can use a drop-down list to select another load. You can use this method if you want more than one instance of an external load, where the instances are active for different times in an analysis.

4. Accept or clear the check box for Enable Gravity. For additional information on applying gravity, see About Gravity.

5. Accept or clear the check box for Enable All Friction. For additional information on applying friction, see Cam-Follower Friction.

6. Click OK to return to the Analyses dialog box or click Run.

### Entering External Loads Information

Use the Ext Loads tab to specify external loads information for dynamic, static, and force balance analysis types. The Ext Loads tab is inactive for repeated assembly and kinematic analyses. External loads include forces, torques, gravity, and friction.

By default, all external loads that exist in the model at the time that you define the analysis are included in the analysis. To include external loads created after completing the analysis definition, click to explicitly include them.

If you click the name of any load in the list, you can select another load. You can use this method if you want more than one instance of an external load, where the instances are active for different times in an analysis.

When you enter external loads information, consider the following:

- **From and To Times**
  - All external forces are active by default from Start to End of the analysis.
  - You can select the Start and End times from the drop-down menu or specify a numeric value for a dynamic analysis.
  - You cannot apply Start and End times for static and force balance analyses.
  - The validation check initiated by the OK or Run command resets any inappropriate values to the Start or End values.

- The check box for Enable Gravity is not selected by default. Gravity is zero if the check box is not selected.

- The check box for Enable All Friction is not selected by default. No friction is applied if in the check box is not selected.

### To Run an Analysis

You can run an analysis from both the Analyses and the Analysis Definition dialog boxes.

### From the Analysis Dialog Box
1. Select an analysis definition from the **Analyses** dialog box list and click **Run**. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

2. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

**From the Analysis Definition Dialog Box**

1. Click **Run**. The **Run** dialog box opens and the analysis run begins.

2. Click **Run** from the **Analysis Definition** dialog box. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

3. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

4. If you prefer to accept the analysis definition and run the analysis later, click **OK**.

**Enabling All Friction**

When you use the check box for **Enable All Friction** on the **Ext Loads** tab of the **Analysis Definition** dialog box, you indicate whether or not Mechanism Design uses the friction coefficients that you specify for cam-follower connections, slot-follower connections, or joint connections in dynamic or force balance analyses.

The check box for **Enable All Friction** is selected by default. In this case, Mechanism Design uses any friction coefficients that you enabled for cam-follower, slot-follower, or joint connections when it runs the analysis. If you clear the **Enable All Friction** box, no friction is applied during the analysis even if you included it in the definition of any connections.

**Enabling Gravity**

Use the **Enable Gravity** check box on the **Ext Loads** tab of the **Analysis Definition** dialog box when you are calculating DOF or running a dynamic, static, or force balance analysis. The check box for **Enable Gravity** is not selected by default. The effect of enabling gravity is slightly different depending upon the type of analysis you run.

**Dynamic and static analyses:**

- If your mechanism includes a body with volume, and you did not specify a density value for the body in Pro/ENGINEER or with the **Mechanism > Mass Properties** command in Mechanism Design, the Mechanism Design software assigns a default density of 1.

- If your mechanism includes bodies for which you have not assigned mass, you will not be able to run a dynamic or static analysis. This includes bodies and
subassemblies comprised entirely of datum curves or surface features, as well as massless volumetric bodies.

- If you do not select the check box for **Enable Gravity**, gravity will be zero, regardless of the values specified in the **Gravity** dialog box.

**Force balance analysis:**
- If you do not select the check box for **Enable Gravity**, Mechanism Design assumes a mass of 1 for bodies with no mass. You can run a force balance analysis without assigning mass to all bodies if you do not select the check box for **Enable Gravity**.
- If you select the check box for **Enable Gravity**, you must specify a mass value for all bodies in your mechanism in order to run a force balance analysis.

### To Copy an Analysis

Use this procedure to copy a previously defined analysis.

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.
2. Select a previously defined analysis from the list.
3. Click **Copy**. A new entry appears in the list, with *Copy of* appended to the name of the copied analysis. This analysis has the same definition as the analysis from which it was copied.
4. Change the definition of the newly copied analysis as needed by editing the appropriate information on any of the tabs in the **Analysis Definition** dialog box.

### To Edit an Analysis Definition

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.
2. Select the desired analysis definition from the list of existing analyses.
3. Click **Edit**. The **Analysis Definition** dialog box appears. Change the name, or any of the items on the **Preferences**, **Motors** and **Ext Loads** tabs, if available, as needed.
4. Click **OK** to save the modified analysis specification.

   **Note:** To revert to the previously saved analysis definition, click **Cancel** before leaving the analysis definition.

### To Delete an Analysis

Use this procedure to delete a previously defined analysis.

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.
2. Select a previously defined analysis from the list.
3. Click **Delete**. The selected analysis is removed from the list and from the model definition.

**Static Analyses**

**About Static Analysis**

Use the **Mechanism > Analyses** command to work with your analysis.

Statics is the branch of mechanics that deals with forces acting on a body when it is at equilibrium. Use a static analysis to determine the state of a mechanism when it is subject to known forces. Mechanism Design searches for a configuration in which all the loads and forces in your mechanism balance and the potential energy is zero. A static analysis can identify a static configuration faster than a dynamic analysis can because it does not consider velocity in the calculation.

Although the result of a static analysis is a steady state configuration, you should compare the situations in these examples with your model to understand your results.

Keep the following key points in mind when running a static analysis:

- If you do not specify an initial configuration, the static analysis starts from the currently displayed position of the model when you click the **Run** button.

- When you run a static analysis, a graph of acceleration versus iteration number appears, showing the maximum acceleration of the mechanism's entities. As the analysis calculation proceeds, both the graph display and the model display change to reflect the intermediate positions reached during the calculation. When the maximum acceleration for the mechanism reaches 0, your mechanism has reached a static configuration.

- You can adjust the maximum step size between each iteration of the static analysis by changing the **Maximum Step Factor** on the **Preferences** tab of the **Analysis Definition** dialog box. Reducing this value reduces the positional change between each iteration and can be useful when analyzing mechanisms incorporating large accelerations.

- If Mechanism Design cannot find a static configuration for your mechanism, the analysis ends and the mechanism remains in the last configuration reached during the analysis.

- Any measures computed will be for the final times and positions, not a time history for the settling process.

The **Mechanism > Analyses** command opens a dialog box, which you can use to create, edit, copy, delete, or run your analyses. If you move the cursor over a given analysis in the **Analyses** dialog box, a message box appears with a summary of that analysis.

**Examples: Static Analysis**
The result of a static analysis is a steady state configuration. Before you run your static analysis, consider the following examples:

- **Pendulum**—The static configuration for a pendulum raised to an initial height would be the pendulum's lowest point at which all forces are balanced and the potential energy is zero. The pendulum would not swing as in a dynamic analysis.

- **Bouncing ball**—The static configuration for a ball raised to an initial height above a plane and released would be the position of the ball at rest on the plane at which all forces are balanced and potential energy is zero. A static analysis in this case does not consider bouncing of the ball after impact.

### To Create a Static Analysis

1. Click **Mechanism > Analyses** or ![Analyses](image). The **Analyses** dialog box appears.
2. Click **New**. The **Analysis Definition** dialog box appears.
3. Enter a descriptive name for the analysis in the Name window or accept the default name, AnalysisDefinition1. You can enter a name of up to 31 characters.

4. Under Type, select Static.

5. Complete the Preferences tab.

6. Click the Motors tab. Enter the desired information.

7. Click the Ext Loads tab. Enter the desired information.

8. Select one of the following options:
   - If you want to run the analysis you just created, click Run.
   - If you want to accept the analysis and run it later, click OK. Mechanism Design returns you to the Analyses dialog box.

9. When you run the analysis, a graph displays the change in maximum acceleration, and the model displays the intermediate positions reached.

To Define Preferences for Static Analysis

This procedure assumes you are on the Preferences tab of the Analysis Definition dialog box, and have selected Static under Type.

1. Select from the following options in the Locked Entities area:
   - Click and select a lead body, then a set of follower bodies to be locked to the lead body.
   - Click and select a joint or cam-follower connection to be locked.

   The name of the locked entity is added to the list in the Locked Entities window.

   Note: Click to remove undesired constraints.

2. Select one of these options under Initial Configuration to set the starting point for the analysis:
   - Click Current to use the current screen configuration.
   - Click Snapshot and choose a previously saved snapshot.

3. If you clicked Snapshot, click to preview the specified configuration.

4. If you want to change the default step size for the static analysis, clear the Default check box under Maximum Step Factor and enter a real number between 0 and 1.
Use the Preferences tab on the Analysis Definition dialog box to specify general information for static analyses.

The Preferences tab contains a Locked Entities area. You can select from three buttons to define locked bodies and locked connections, and delete locked entities. Locked bodies do not move relative to one another during the defined analysis run. Locked connections lose the motions associated with their DOFs during the defined analysis.

Use the Initial Configuration area to select a starting point for your static analysis. The configuration describes the relative orientation of the parts and bodies in your mechanism. Select one of these options:

- Click Current to use the positions of the bodies in the screen configuration.
- Click Snapshot to select a snapshot saved using the Drag dialog box. Only the position of bodies in your mechanism is used from a selected snapshot. Any constraints saved in the snapshot are ignored.

Use the Maximum Step Factor area to change the maximum step size for your static analysis. If your model includes very large accelerations, you may get more accurate results by using a smaller step size. You must clear the Default check box and enter a real number between 0.0 and 1.0. This factor limits the largest step size that Mechanism Design uses in finding a static configuration.

A Run button allows you to run the analysis directly after creating it. When you click the Run button, Mechanism Design performs the same error checking as when you click the OK button—to ensure the analysis information has been entered appropriately—before running the analysis.

To Specify Motors for an Analysis

This procedure assumes that you are adding motors to your model, and are on the Motors tab of the Analysis Definition dialog box.

1. To include motors, choose from the following options:

   - Select a motor and click to add another instance of the motor.
   - Click to add all motors available for your model.

     **Note:** Select one or more rows and click to remove undesired changes.

2. If you want to change the time that an external load will be active, select a load from the list and click on the area under From or To to edit the times.

3. Click OK or Run.

Entering Motors Information

You can add or delete motors on the Motors tab for all analysis types. Use the Motors tab on the Analysis Definition dialog box to select which motors will be used in the analysis definition.
You use the **Motors** tab slightly differently for the different types of analysis.

**All analyses:**
- By default, Mechanism Design includes all motors that exist in the model at the time that you create the analysis. To include motors created after completing the analysis definition, edit the analysis definition and click ![Include Motor](https://example.com/include-motor.png) to explicitly include them.
- When you click ![Include Motor](https://example.com/include-motor.png) on the **Motors** tab, you are adding a previously defined motor to be included in the analysis. This motor is, by default, the first entry in the list. When you select ![Select Motor](https://example.com/select-motor.png), you are adding one instance of every motor that exists in the model to be included in the analysis.
- The default values for the **From** and **To** times are the **Start** and **End** times of the analysis time domain.
- Click the column headings on the **Motors** tab to sort motors alphabetically or to sort the **From** and **To** times numerically.

**Kinematic and repeated assembly analyses:**
- You can control the start and end times of servo motors for kinematic and repeated assembly analyses. By doing so, you can start one motor, turn it off, and start another within your analysis run. This allows you more flexibility when creating your analysis. Control your servo motors by editing the **From** and **To** time domains on the **Motors** tab.
- You cannot use geometric servo motors in kinematic analyses. These motors do not appear in the list of possible servo motors for kinematic analyses.
- You can either give a numeric value for **From** or choose **Start**—representing the start time of the analysis—from the drop-down menu in the **From** column. The **To** column is also an input field with a drop-down option to select **End**—representing the end of the analysis.
- If an invalid value is specified for the time, the value is set to the **Start** or **End** of the analysis, as appropriate.

**Dynamic, static, and force balance analyses:**
- You can use both servo and force motors for dynamic, static, and force balance analyses. Servo motors are active for the duration of these analyses. The **From** and **To** times for servo motors are uneditable.
- Geometric servo motors (servo motors that drive points or planes) do not appear in the list of possible motors in dynamic, static, or force balance analysis. They have no effect on these analyses.
- All motors are active for the duration of static and force balance analyses.

Because you can define multiple motors for an entity, be sure to keep track of which motors are included or excluded at any time. To avoid analysis failure and inaccurate results, activate only one motor for an entity at a time.
For example, if you create a zero position servo motor and a constant non-zero velocity servo motor on the same rotational joint axis, do not activate both motors for the same analysis. Also, if you define two force motors on the same joint axis and activate both in the same dynamic analysis, the resulting applied force will be the sum of both motors.

**To Specify External Loads for an Analysis**

This procedure assumes that you are on the **Ext Loads** tab of the **Analysis Definition** dialog box. Mechanism Design lists all loads that exist in the model at the time that you define the analysis.

1. To include an external load, choose from the following options:
   - Select an existing load and click to add another instance of the load.
   - Click to add all loads available for your model.
   
   **Note:** Select one or more rows and click to remove undesired loads.

2. If you want to change the time that an external load will be active, select a load from the list and click in the area under From or To to edit the times.

3. If you click the name of any load in the list you can use a drop-down list to select another load. You can use this method if you want more than one instance of an external load, where the instances are active for different times in an analysis.

4. Accept or clear the check box for **Enable Gravity**. For additional information on applying gravity, see About Gravity.

5. Accept or clear the check box for **Enable All Friction**. For additional information on applying friction, see Cam-Follower Friction.

6. Click **OK** to return to the **Analyses** dialog box or click **Run**.

**Entering External Loads Information**

Use the **Ext Loads** tab to specify external loads information for dynamic, static, and force balance analysis types. The **Ext Loads** tab is inactive for repeated assembly and kinematic analyses. External loads include forces, torques, gravity, and friction.

By default, all external loads that exist in the model at the time that you define the analysis are included in the analysis. To include external loads created after completing the analysis definition, click to explicitly include them.

If you click the name of any load in the list, you can select another load. You can use this method if you want more than one instance of an external load, where the instances are active for different times in an analysis.

When you enter external loads information, consider the following:

- **From** and **To** Times
All external forces are active by default from **Start** to **End** of the analysis.

- You can select the **Start** and **End** times from the drop-down menu or specify a numeric value for a dynamic analysis.
- You cannot apply **Start** and **End** times for static and force balance analyses.
- The validation check initiated by the **OK** or **Run** command resets any inappropriate values to the **Start** or **End** values.

- The check box for **Enable Gravity** is not selected by default. Gravity is zero if the check box is not selected.
- The check box for **Enable All Friction** is not selected by default. No friction is applied if in the check box is not selected.

**To Run an Analysis**

You can run an analysis from both the Analyses and the Analysis Definition dialog boxes.

**From the Analysis Dialog Box**

1. Select an analysis definition from the Analyses dialog box list and click **Run**. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

2. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

**From the Analysis Definition Dialog Box**

1. Click **Run**. The Run dialog box opens and the analysis run begins.

2. Click **Run** from the Analysis Definition dialog box. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

3. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

4. If you prefer to accept the analysis definition and run the analysis later, click **OK**.

**To Copy an Analysis**

Use this procedure to copy a previously defined analysis.

1. Click **Mechanism > Analyses**. The Analyses dialog box appears.
2. Select a previously defined analysis from the list.

3. Click Copy. A new entry appears in the list, with Copy of appended to the name of the copied analysis. This analysis has the same definition as the analysis from which it was copied.

4. Change the definition of the newly copied analysis as needed by editing the appropriate information on any of the tabs in the Analysis Definition dialog box.

To Edit an Analysis Definition

1. Click Mechanism > Analyses. The Analyses dialog box appears.
2. Select the desired analysis definition from the list of existing analyses.
3. Click Edit. The Analysis Definition dialog box appears. Change the name, or any of the items on the Preferences, Motors and Ext Loads tabs, if available, as needed.
4. Click OK to save the modified analysis specification.

   Note: To revert to the previously saved analysis definition, click Cancel before leaving the analysis definition.

To Delete an Analysis

Use this procedure to delete a previously defined analysis.

1. Click Mechanism > Analyses. The Analyses dialog box appears.
2. Select a previously defined analysis from the list.
3. Click Delete. The selected analysis is removed from the list and from the model definition.

Force Balance Analyses

About Force Balance Analysis

Use the Mechanism > Analyses command to work with your analysis.

A force balance analysis is an inverse static analysis. In a force balance analysis, you derive the resulting reaction forces from a specific static configuration, whereas, in a static analysis, you apply forces to a mechanism to derive the resulting static configuration.

Use a force balance analysis to determine the forces required to keep a mechanism fixed in a particular configuration.

A force balance analysis can only be run for a zero degree of freedom system. Before you can run this analysis, you must reduce the number of degrees of freedom in a mechanism to zero for the purposes of this analysis, using connection locks, body locks between two bodies, a loadcell lock at a point, or with active servo motors applied to connection axes. You can use the items on the Analysis Definition dialog...
box to evaluate the DOFs on your mechanism and apply constraints to it until you achieve zero DOF.

The **Mechanism > Analyses** command opens a dialog box, which you can use to create, edit, copy, delete, or run your analyses. If you move the cursor over a given analysis in the **Analyses** dialog box, a message box appears with a summary of that analysis.

**To Create a Force Balance Analysis**

1. Click **Mechanism > Analyses** or ☐. The **Analyses** dialog box appears.
2. Click **New**. The **Analysis Definition** dialog box appears.
3. Enter a meaningful name for the analysis in the **Name** window or accept the default name, *AnalysisDefinition1*. You can enter a name of up to 31 characters.
4. Under **Type**, select **Force Balance**.
5. Complete the **Preferences** tab.
6. Click the **Motors** tab. Enter the desired information.
7. Click the **Ext Loads** tab. Enter the desired information.
8. Select one of the following options:
   - If you want to run the analysis you just created, click **Run**.
   - If you want to accept the analysis and run it later, click **OK**. Mechanism Design returns you to the **Analyses** dialog box.

**To Define Preferences for Force Balance Analysis**

This procedure assumes you are on the **Analysis Definition** dialog box and have selected **Force Balance** under **Type**.

1. Click ☐. The software calculates and displays the DOF.
2. Decrease the DOF to 0 by using these options:
   - Click ☐ and select a lead body, then a set of follower bodies to be locked. The follower bodies stay fixed relative to the lead body during the analysis.
   - Click ☐ and select a joint or cam-follower connection. The software locks the connection’s allowed movements during the analysis.
   - Create a loadcell lock.
3. Check the DOF as described in step 1 after applying each constraint until you reach 0 DOF.
4. If you want the analysis to use the current screen configuration, click **Current** under **Initial Configuration**.

5. If you want to use a previously created snapshot for the initial condition, click **Snapshot** under **Initial Configuration**, and select a snapshot from the list.

   Click to view the configuration.

### Entering Preferences for Force Balance Analyses

Use the **Preferences** tab of the **Analysis Definition** dialog box to specify the following information for force balance analyses:

- Use the **Locked Entities** area to specify constraints for the force balance analysis. You can select from four buttons to create locked bodies and locked connections, create a loadcell lock, or to delete locked entities. Locking bodies fixes the position of one body relative to another during the defined analysis. Locking connections removes the motion associated with their degree of freedom.

   Note that only one loadcell lock can be active in a force balance analysis. You can define multiple loadcell locks but you can activate only one in the list. When you create a loadcell lock or highlight a previously defined one in the locked entities list, a shaded arrow appears at the selected point and in the specified direction. To view loadcell reaction results, you can create a loadcell reaction measure.

- Click to calculate the degrees of freedom (DOF) for your mechanism before you run a force balance analysis. Before you run the analysis, you must reduce the DOF to zero by applying body locks, connection locks, or loadcell locks.

- You specify an **Initial Configuration** for a force balance analysis. The configuration describes the relative orientation of the parts and bodies in your mechanism. Mechanism Design uses the current screen configuration by default for the configuration at which to calculate the balance of forces. A **Snapshot** is available from an initial configuration drop-down list of available snapshots. Select a snapshot you saved in the **Drag** dialog box. Only the position of bodies in your mechanism is used from a selected snapshot. Any constraints saved in the snapshot are ignored.

- A **Run** button allows you to run the analysis directly after creating it. When you click the **Run** button, Mechanism Design performs the same error checking as when you click the **OK** button—to ensure the analysis information has been entered appropriately—before running the analysis.

### About Locked Entities for Analyses

You can select one of these options on the **Preferences** tab of the **Analysis Definition** dialog box to perform the following actions:

- To lock bodies, click and choose the lead body. Then select all bodies that you want locked to the lead body. To lock all bodies to ground, middle-click when
asked to pick the lead body. The two locked bodies are added to the Locked Entities list.

The body lock constraint is used when you want bodies to remain fixed relative to one another. When created, the check box to the left of the label is selected by default. You can clear this item if you do not want to include it in the current analysis.

- To lock a connection, click \( \text{\includegraphics[width=0.05\textwidth]{lock_icon.png}} \) and choose a connection to lock. This constraint is used when you want a connection to remain in its current configuration for the duration of an analysis. Note that cam and slot connections can also be locked. You cannot select a gear-pair connection to be locked. To lock a gear pair, you must select one of the joint connections in the gear pair. The locked connection is added to the Locked Entities list.

When created, the check box to the left of the label is selected by default. You can clear this locked connection to not include it in the current analysis.

- To define a loadcell lock, click \( \text{\includegraphics[width=0.05\textwidth]{loadcell_icon.png}} \) and choose a point or vertex, a body on which to apply the loadcell, and a direction vector. Specify components of the direction vector in terms of the previously selected body coordinate system.

You typically use the loadcell lock constraint when you run a force balance analysis.

- To delete one or more entities, highlight a row or rows and click \( \text{\includegraphics[width=0.05\textwidth]{delete_icon.png}} \) to remove the entity or entities from the list.

**To Specify Motors for an Analysis**

This procedure assumes that you are adding motors to your model, and are on the Motors tab of the Analysis Definition dialog box.

1. To include motors, choose from the following options:
   - Select a motor and click \( \text{\includegraphics[width=0.05\textwidth]{add_motor_icon.png}} \) to add another instance of the motor.
   - Click \( \text{\includegraphics[width=0.05\textwidth]{all_motors_icon.png}} \) to add all motors available for your model.

   **Note:** Select one or more rows and click \( \text{\includegraphics[width=0.05\textwidth]{remove_icon.png}} \) to remove undesired changes.

2. If you want to change the time that an external load will be active, select a load from the list and click on the area under From or To to edit the times.

3. Click OK or Run.

**Entering Motors Information**

You can add or delete motors on the Motors tab for all analysis types. Use the Motors tab on the Analysis Definition dialog box to select which motors will be used in the analysis definition.
You use the **Motors** tab slightly differently for the different types of analysis.

**All analyses:**
- By default, Mechanism Design includes all motors that exist in the model at the time that you create the analysis. To include motors created after completing the analysis definition, edit the analysis definition and click ▶️ to explicitly include them.
- When you click ▶️ on the **Motors** tab, you are adding a previously defined motor to be included in the analysis. This motor is, by default, the first entry in the list. When you select ✅, you are adding one instance of every motor that exists in the model to be included in the analysis.
- The default values for the **From** and **To** times are the **Start** and **End** times of the analysis time domain.
- Click the column headings on the **Motors** tab to sort motors alphabetically or to sort the **From** and **To** times numerically.

**Kinematic and repeated assembly analyses:**
- You can control the start and end times of servo motors for kinematic and repeated assembly analyses. By doing so, you can start one motor, turn it off, and start another within your analysis run. This allows you more flexibility when creating your analysis. Control your servo motors by editing the **From** and **To** time domains on the **Motors** tab.
- You cannot use geometric servo motors in kinematic analyses. These motors do not appear in the list of possible servo motors for kinematic analyses.
- You can either give a numeric value for **From** or choose **Start**—representing the start time of the analysis—from the drop-down menu in the **From** column. The **To** column is also an input field with a drop-down option to select **End**—representing the end of the analysis.
- If an invalid value is specified for the time, the value is set to the **Start** or **End** of the analysis, as appropriate.

**Dynamic, static, and force balance analyses:**
- You can use both servo and force motors for dynamic, static, and force balance analyses. Servo motors are active for the duration of these analyses. The **From** and **To** times for servo motors are uneditable.
- Geometric servo motors (servo motors that drive points or planes) do not appear in the list of possible motors in dynamic, static, or force balance analysis. They have no effect on these analyses.
- All motors are active for the duration of static and force balance analyses.

Because you can define multiple motors for an entity, be sure to keep track of which motors are included or excluded at any time. To avoid analysis failure and inaccurate results, activate only one motor for an entity at a time.
For example, if you create a zero position servo motor and a constant non-zero velocity servo motor on the same rotational joint axis, do not activate both motors for the same analysis. Also, if you define two force motors on the same joint axis and activate both in the same dynamic analysis, the resulting applied force will be the sum of both motors.

**To Specify External Loads for an Analysis**

This procedure assumes that you are on the **Ext Loads** tab of the **Analysis Definition** dialog box. Mechanism Design lists all loads that exist in the model at the time that you define the analysis.

1. To include an external load, choose from the following options:
   - Select an existing load and click ![add load](image) to add another instance of the load.
   - Click ![add all loads](image) to add all loads available for your model.
   
   **Note:** Select one or more rows and click ![remove load](image) to remove undesired loads.

2. If you want to change the time that an external load will be active, select a load from the list and click in the area under **From** or **To** to edit the times.

3. If you click the name of any load in the list you can use a drop-down list to select another load. You can use this method if you want more than one instance of an external load, where the instances are active for different times in an analysis.

4. Accept or clear the check box for **Enable Gravity**. For additional information on applying gravity, see About Gravity.

5. Accept or clear the check box for **Enable All Friction**. For additional information on applying friction, see Cam-Follower Friction.

6. Click **OK** to return to the **Analyses** dialog box or click **Run**.

**Entering External Loads Information**

Use the **Ext Loads** tab to specify external loads information for dynamic, static, and force balance analysis types. The **Ext Loads** tab is inactive for repeated assembly and kinematic analyses. External loads include forces, torques, gravity, and friction.

By default, all external loads that exist in the model at the time that you define the analysis are included in the analysis. To include external loads created after completing the analysis definition, click ![include load](image) to explicitly include them.

If you click the name of any load in the list, you can select another load. You can use this method if you want more than one instance of an external load, where the instances are active for different times in an analysis.

When you enter external loads information, consider the following:

- **From** and **To** Times
All external forces are active by default from **Start** to **End** of the analysis.

- You can select the **Start** and **End** times from the drop-down menu or specify a numeric value for a dynamic analysis.
- You cannot apply **Start** and **End** times for static and force balance analyses.
- The validation check initiated by the **OK** or **Run** command resets any inappropriate values to the **Start** or **End** values.

- The check box for **Enable Gravity** is not selected by default. Gravity is zero if the check box is not selected.
- The check box for **Enable All Friction** is not selected by default. No friction is applied if in the check box is not selected.

**To Run an Analysis**

You can run an analysis from both the **Analyses** and the **Analysis Definition** dialog boxes.

**From the Analysis Dialog Box**

1. Select an analysis definition from the **Analyses** dialog box list and click **Run**. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

2. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

**From the Analysis Definition Dialog Box**

1. Click **Run**. The **Run** dialog box opens and the analysis run begins.

2. Click **Run** from the **Analysis Definition** dialog box. The analysis run begins. Mechanism Design displays the run progress in the bottom bar of the model window. For dynamic analyses, the elapsed time is also shown in the model window.

3. If you want to stop an analysis prematurely, click on the bottom bar of the model window.

4. If you prefer to accept the analysis definition and run the analysis later, click **OK**.

**To Copy an Analysis**

Use this procedure to copy a previously defined analysis.

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.
2. Select a previously defined analysis from the list.

3. Click **Copy**. A new entry appears in the list, with *Copy of* appended to the name of the copied analysis. This analysis has the same definition as the analysis from which it was copied.

4. Change the definition of the newly copied analysis as needed by editing the appropriate information on any of the tabs in the **Analysis Definition** dialog box.

**To Edit an Analysis Definition**

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.

2. Select the desired analysis definition from the list of existing analyses.

3. Click **Edit**. The **Analysis Definition** dialog box appears. Change the name, or any of the items on the **Preferences**,** Motors** and **Ext Loads** tabs, if available, as needed.

4. Click **OK** to save the modified analysis specification.

   **Note:** To revert to the previously saved analysis definition, click **Cancel** before leaving the analysis definition.

**To Delete an Analysis**

Use this procedure to delete a previously defined analysis.

1. Click **Mechanism > Analyses**. The **Analyses** dialog box appears.

2. Select a previously defined analysis from the list.

3. Click **Delete**. The selected analysis is removed from the list and from the model definition.

**Results**

**Playback**

**About Playback**

Use the **Mechanism > Playback** command to review mechanism analyses that you have previously run. Mechanism Design stores a separate set of results for every analysis you run. Save this result set in a file, which you can run in other sessions. You may play back the results you save for a master assembly on its simplified representations or vice versa. You can use the **Playback** command to view the interference between the parts in your mechanism, combine different portions of the analysis into a movie, visualize the effect of forces and torques on your mechanism, and track the value of a measure during the analysis.

You can capture a playback result set as an MPEG file, or as a series of JPEG, TIFF, or BMP files. You can also save a motion envelope that captures a representation of the volume swept by your mechanism during an analysis.
When you select the **Playback** command, the **Playbacks** dialog box appears. Use this dialog box for the following tasks:

- **Play**
- **Restore**
- **Save**
- **Remove**
- **Export**
- **Create a Motion Envelope**

### About the Playbacks Dialog Box

Use the **Playbacks** dialog box to view an analysis result set. You can use the options on this dialog box to change the display of your result set, check for interference, specify the amount of time the result set plays, and save it in several different formats.

This dialog box includes the following items:

- Click to play back an analysis. The **Animate** dialog box appears. Use the options on this dialog box to control the speed of the playback.

- Click the file selector button to restore a result set. A dialog box appears with a list of previously saved result set files. Browse and select a saved result set from disk.

- Click the file save button to save a file to disc. The **Save** dialog box appears. Accept the default name, or enter a new name for the result set. You can save it in the default directory, which is the current working directory, or browse to select another directory.

  Mechanism Design saves the file with the extension `.pbk`. You can retrieve this file in the current or a later session to play back the results or calculate measures. The saved file includes the **Display Arrows** and **Movie Schedule** settings.

- Click to remove the current results from the session.

- Click to export a result set. Mechanism Design saves the current result set as a frame file with the extension `.fra`. You can use the `.fra` file to create a motion envelope after you exit Mechanism Design. Use the **Motion Envlp** option from the Pro/ENGINEER **File > Save a Copy** command. For more information, search the PTC Help System.

- Click to open the **Create Motion Envelope** dialog box. This button is available when you have a result set in the current session, or when you have restored a `.pbk` file. Use this command to shrinkwrap the swept volume created by your mechanism during an analysis. Mechanism Design creates a faceted
motion envelope model that represents the full motion of the model, as the motion is captured in the frame file during the analysis. You can use the motion envelope export in the same manner as a standard Pro/ENGINEER part.

- **Result Set**—Mechanism Design displays analysis results and saved playback files from the current session.

- **Interference**—Use the options on this tab to specify whether your result set playback includes interference checking, and what type.

- **Movie Schedule**—Use the options on this tab to specify the start and end times for your playback.

- **Display Arrows**—Use the options on this tab to select measures and input loads. Mechanism Design displays the selected measures and loads as three-dimensional arrows during the playback.

### To Play a Result Set

1. Click **Mechanism > Playback** or . The **Playbacks** dialog box appears.

2. From the **Result Set** drop-down list, choose a result set to play by selecting the name of the analysis that created those results. Only analyses created in the current session are included.

   **Note:** If you saved a result set as a playback file in the current session, the playback file name is included in the list and can be selected.

3. Fill in the information in the following areas:
   - **Interference**
   - **Movie Schedule**
   - **Display Arrows**

4. Click . The **Animate** dialog box appears.

5. Use the tools in the **Animate** dialog box to set the speed, direction, and duration of the motion playback. You can also capture the animation for playback in other software.

6. Click **Close** when you are finished observing the motion.

### Interference

Use the following options on the **Interference** tab of the **Playbacks** dialog box to specify what type of interference checking Mechanism Design does during an analysis.

- **Mode**—Gives the type of interference to check for during the playback.
  - **No Interference**—Performs no interference checking.
  - **Quick Check**—Does a low-level check for interference. Automatically selects **Stop Playback** as an option.
Mechanism Design Extension

- **Two Parts**—Allows you to specify two parts for which to check the interference. Mechanism Design highlights the areas of interference.

- **Global Interference**—Checks for any kind of interference in the entire assembly. Mechanism Design highlights the areas of interference.

- **Options**—Gives the options available for the type of interference check.
  - **Include Quilts**—Includes surfaces as a part of the interference check.
  - **Stop Playback**—Stops the playback if there is any interference detected. This option is active only for **Two Parts** or **Global Interference**.

**Movie Schedule**

When you play back the results of your analysis, you can specify which portion you would like to view, and whether you want to display the elapsed time during the playback on the **Movie Schedule** tab of the **Playbacks** dialog box.

- The **Default Schedule** check box controls whether you see the entire analysis. Turn this off to specify which portion of the analysis you want to see.

- The **Display Time** check box controls whether you see the elapsed time in the model window during the playback. Turn this off to view the playback without a time display.

If you want to see a specific portion of the run, turn off the **Default Schedule** check box. You can now choose from the following options:

- **Start Time**—Specify the start time of the segment you want to view. The start time can be greater than the end time, enabling you to play the movie in reverse.

- **End Time**—Specify the end time of the segment you want to view.

- After you specify a start and end time, click to add the segment to the list for playback. You can replay this segment multiple times by adding it to the list multiple times.

- To change the start or end time of a playback segment, select that segment and edit the values. Click to update the segment in the list.

- To delete the movie segment, select that segment and click .

**Display Arrows**

When you play back your analysis results, you can display three-dimensional arrows that represent the magnitude and direction of the measures, forces, torques, gravity, and force motors associated with your analysis. Use display arrows to see the relative effect of loads on your mechanism. Mechanism Design displays single-headed arrows for force, linear velocity, and linear acceleration vectors, and double-headed arrows for moment, angular velocity, and angular acceleration vectors. The color of the arrow depends on the type of measure or load. You must have a Mechanism Dynamics Option license to use display arrows.
As you play back your analysis results, the size of the arrow changes to reflect the calculated value of the measure, force, or torque. The direction of the arrow changes as the calculated vector direction changes.

If you select several measures or input loads, Mechanism Design displays the selection with the largest value within each type as the largest arrow. In addition, your model size affects the initial arrow size. The default arrow size, which is the size of the largest arrow within a type at 100% scale, is proportional to the characteristic length of the model.

**Tip:** The default size is based on the value of the measure or input load at the beginning of the analysis. If your measure or input load covers a large range of values during an analysis, the display arrows may become unacceptably large or disappear. You may, therefore, need to readjust the scale and rerun the analysis to get a more useful animation. If you are preparing an animation for a presentation, you may want to use the Movie Schedule tab to remove those parts of the analysis in which the display arrows become too big or too small.

Use these items on the Display Arrows tab of the Playbacks dialog box to select, label, and change the size of your display arrows:

- **Measures**—Select a measure from the list. The list includes measures that you defined for the analysis. Mechanism Design includes in the list only those measures that use the Each Time Step evaluation method.

- **Input Loads**—Select an input load from the list. The list includes loads that you defined for the selected analysis or playback.

- **Scale**—Select a category from the drop-down list and adjust the initial size of the arrows in that category by entering a value in the entry box or by turning the wheel. The minimum value is 0%, and at that value Mechanism Design does not display an arrow. There is no maximum limit to the size. You can select from Force, Moment, Velocity, Acceleration, or Separation.

- **Annotation**—Select Name to include the names of measures or input loads on the display during the playback. Select Value to include the value. The displayed value updates as it changes during the playback.

You can select an individual item from the Measures or Input Loads field by clicking the check box beside its name. You can also highlight a group of items in either list by holding down the SHIFT key as you select. When you right-click, a menu appears with the following commands:

- **Toggle**—Clear every selected check box, and select every unselected check box.

- **Select**—Select every check box.

- **Unselect**—Clear every check box.

**Measures Available for Display Arrows**

Mechanism Design displays the following types of measures on the Display Arrows tab of the Playbacks dialog box:
• Connection reaction (joints)—cyan arrow with the tip at the specified joint axis, and pointing in the direction of the joint's DOF

• Connection reaction (cams)—cyan arrow. For normal reaction forces, the tip is at the point of contact between the two cams, pointing normal to the cam. For tangential reaction forces, the tip is at the point of contact between the two cams, pointing in a direction tangential to the cam.

• Connection reaction (slots)—cyan arrow with the tip pointing to the contact between the follower point and the slot

• Connection reaction (gear pairs)—cyan arrow with the tip pointing to the gear body that the force or torque is exerted on

• Net load—magenta arrow pointing at the joint axis for motors, at the point for forces, at the body's COM for torques or, for point-to-point springs and dampers, extending between the points used to define the entity. The arrow points in the direction of the applied force.

• Loadcell reaction—dark green arrow with the tip at the point where force is applied, and pointing in the direction of the force

• Velocity—yellow arrow with the tip at the specified point or joint axis and pointing in the specified direction

• Acceleration—red arrow with the tip at the specified point or joint axis and pointing in the specified direction

• Weight—brown arrow pointing in the direction of the gravitational acceleration

• Distance separation—two collinear magenta arrows pointing away from each other, with the tips at the specified points

• Speed separation—two collinear yellow arrows with the tips at the specified points. When the points move away from each other, the velocity is negative and the display arrows point toward each other. When the points move towards each other, the velocity is positive and the display arrows point away from each other.

• Change of speed separation—two collinear red arrows with the tips at the specified points, pointing towards each other for negative values, and away from each other for positive values

**Input Loads Available for Display Arrows**

Mechanism Design displays the following types of forces and torques on the **Display Arrows** tab of the **Playback** dialog box:

• Gravity—brown arrow with the tip at the center of mass for each body, and pointing in the direction of the gravitational acceleration

• Force motor—green arrow with the tip at the specified joint axis, and pointing in the direction of the joint's DOF

• Force—orange arrow with the tip at the point of application
• Torque—double-headed orange arrow pointing toward the center of mass of the body

• Point to point forces—two collinear magenta arrows with the tips at the specified points or vertexes, pointing towards each other for negative forces, and away from each other for positive forces

**To Save a Result Set to a File**

1. Click **Mechanism > Playback**. The **Playbacks** dialog box appears.
2. Select a result set.
3. Click ![icon]. The **Save Analysis Results** dialog box appears.
4. Accept the highlighted file name or enter a desired name for the saved result set.
5. Accept the current working directory or browse for a specific directory.
6. Click **OK**. Mechanism saves the result set to a file with the extension `.pbk`.

**To Restore a Saved Result Set File**

1. Click **Mechanism > Playback**. The **Playbacks** dialog box appears.
2. Click ![icon]. The **Select Playback File** dialog box appears.
3. Select a result file.
4. Click **Open**. The analysis results from the playback file are read in session if the current model matches the model in the playback file.

   **Note:** If there already is a result set in session with the same name as the playback file, a warning message appears. You can overwrite the results in session or choose not to load the results from the playback file.

**About the Animate Dialog Box**

Use this dialog box to control the speed and direction as you play back your result set. The **Animate** dialog box appears when you play a result set from the **Playbacks** dialog box. The **Animate** dialog box contains the following items:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame sliding bar</td>
<td>List the frame that is currently displayed.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Play backwards.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Stop.</td>
</tr>
</tbody>
</table>
## To Capture a Playback Result Set

You can use the **Capture** dialog box to record your analysis results and use them for your presentation. This procedure assumes that you have started to play a result set on the **Playbacks** dialog box.

1. Click **Capture** on the **Animate** dialog box. The **Capture** dialog box appears.

2. Enter a name, or accept the default name. Mechanism Design saves the file in the current working directory.

3. If you want to replace an existing file, or if you want to select another directory to save the file, click **Browse** and select a directory or file.

4. Select the format you want to use under the **Type** drop-down list. You can record your results in these formats:
   - MPEG
   - JPEG
   - TIFF
   - BMP

5. If you select **JPEG**, **TIFF**, or **BMP**, Mechanism Design creates a series of images with file names that are incremented from 1 to \( x \).
6. If you select MPEG, select one of these frame rates for the animated file:
   - 25 fps
   - 30 fps
   - 50 fps

7. Select the Photorender Frames check box in the Quality area if you want to use Pro/ENGINEER photorendering functionality to record.

8. Enter the width and height in pixels of the output file(s) in the Image Size field.

9. If you want Mechanism Design to use the width-to-height ratio of the current model window, select the Lock Aspect Ratio check box. When you change the width or height value, the software calculates the second dimension based upon the current aspect ratio.

10. Click OK to begin the result playback and recording.

Capture Dialog Box

Use the Capture dialog box to record your analysis results. You can use the options on this dialog box to select an image file format for recording, and to specify the height and width of the saved file(s). This dialog box appears when you click Capture on the Animate dialog box, and includes the following items:

- **Name**—Mechanism Design enters a default name, with the extension determined by the image type. The default directory to save the file is the current working directory. You can change the name in the Name entry box. You can click Browse and select a previously saved file, or select another directory to save the file.

- **Type**—You can record your results in MPEG, JPEG, TIFF, or BMP file format. Mechanism Design saves a single MPEG file. If you select one of the other formats, Mechanism Design saves a series of files, one for each frame of your analysis results. The files in the series are named filename_x, where x is a number from 1 to the number of frames. You can use the options on the Preferences tab of the Analysis Definition dialog box if you want to change the number of frames in your analysis. Use graphics software to combine these files into an animated file, or inspect them separately.

   The file name extension is based on the file type, as follows:
   - MPEG files have extension .mpg
   - TIFF files have extension .tif
   - JPEG files have extension .jpg
   - BMP files have extension .bmp

- **Image Size**—Mechanism Design captures your analysis results in image files with the width and height values in this area. The default values are the
dimensions of the current model window, excluding the navigation window. The width and height values are updated if you resize the model window while the **Capture** dialog box is open.

- **Lock Aspect Ratio**—Select this check box to change either the width or height, and have the width-to-height ratio remain the same as that in the current model window. If you do not select this check box, and you change one value, the other value is not affected.

- **Photorender Frames**—Use Pro/ENGINEER photorendering functionality to record the frames. For information on photorendering, search the Pro/ENGINEER Help System.

- **Frame Rate**—Select a frame rate from the drop-down list. This option is available only for MPEG files. You can use a slower frame rate to observe more details in an analysis. You can select one of these frame rates (in frames per second):
  - 25 fps
  - 30 fps
  - 50 fps

### To Create a Motion Envelope

Use the **Create a Motion Envelope** command to create a faceted motion envelope model that represents the full motion of your mechanism during an analysis. This procedure assumes that you are in the **Playbacks** dialog box, and that there is a result set available in the current session, or that you have restored a saved .pbk file.

1. Click ![image]. If this is the first time you have created a motion envelope with this result set, a message box appears asking you to confirm that you want to create a frame file named `result_set_name.fra`.
2. Click **Yes** to continue. The **Create Motion Envelope** dialog box appears.
3. In the **Quality** area of the dialog box, specify the quality level for the system to use when creating the motion envelope model, by entering an integer from 1 to 10 (the default value is 1).
4. Click ![image] under **Select Components** to select or deselect subassemblies, parts, or bodies in your assembly to include in your motion envelope.
5. If you do not want the software to ignore any skeletons or quilts in your model, clear **Ignore Skeletons** or **Ignore Quilts** under **Special Handlings**.
6. In the **Output Format** area of the dialog box, specify one of the following output file formats:
   - **Part** (selected by default)—Creates a Pro/ENGINEER part with normal geometry.
Mechanism Design Extension Help Topic Collection

- **LW Part**—Creates a lightweight Pro/ENGINEER part with lightweight, faceted geometry.
- **STL**—Creates an STL file.
- **VRML**—Creates a VRML file.

7. In the **Output File Name** area of the dialog box, accept the default file name, or enter another name.

8. Select or clear **Use default template** (selected by default for Part and LW Part file formats). This option is not available for STL or VRML file formats.

9. Click **Preview** to obtain a shaded representation of the triangles that Mechanism Design will create for the motion envelope. The Pro/ENGINEER message window reports the number of triangles produced.

10. If you want to adjust the motion envelope model, click beside **Invert Triangle Pairs**. When you click the shaded representation, the triangle edges are highlighted. Click the edge between two triangles. The software replaces the triangles with the other two triangles that make up the tetrahedron defined by the triangles' four vertices. Use this method if the automatically-computed motion envelope does not accurately reflect your model's motion.

11. Click **Undo Last** or **Undo All** if you want to reverse any of the triangle inversions.

12. When you have finished making adjustments, click **Preview** again.

13. Click **Create**.

   - If you selected the **Part** or **LW Part** output format, the system creates a solid motion envelope model, and displays it in its own window. Select **Window > Activate**, select the motion envelope model file name, and use the **File > Save** command to save it to a part file.
   
   - If you selected the **STL** or **VRML** output format, the system saves a .stl or .wrl file to the current working directory. The **Create Motion Envelope** dialog box remains open, and the source model remains in session as the current object.

14. Click **Close**. The **Create Motion Envelope** dialog box closes.

**Create Motion Envelope Dialog Box**

After you run a Mechanism Design analysis, you can create a faceted solid motion envelope model that represents the full motion of the mechanism. You can use the motion envelope export in the same manner as a standard Pro/ENGINEER part.

You can also create a motion envelope by first creating a frame file and then using the **Motion Envlp** option from the Pro/ENGINEER **File > Save a Copy** command.
If you have run an analysis in the current session of Mechanism Design, or have restored a .pbk file, when you click  on the Playbacks dialog box the **Create a Motion Envelope** dialog box appears. This dialog box includes the following items:

- **Quality**—Specify the quality level for Mechanism Design to use when creating the motion envelope model, by entering an integer from 1 to 10.

  Quality is inversely proportional to the size of the triangles used to create the faceted model. At a lower setting, the system creates fewer, larger triangles faster, producing a roughly accurate representation of the motion envelope. At a higher setting, the system creates many smaller triangles, producing a more detailed, more accurate representation of the motion envelope. Increasing the quality level makes for a more complete representation but also increases the creation time.

  The recommended method for creating a motion envelope model is to set a low quality setting and preview the results, only gradually increasing the quality level as necessary. When you raise the setting, the system initially displays a warning message: "At high quality levels, creating a Motion Envelope may take a long time and require a lot of memory. It is best to try low levels first, and move up only if the results at those levels are unsatisfactory. To disable this warning, use the configuration option MOTION_ENVLP_ALERT NO."

- **Select Components**—Choose the parts, bodies, or subassemblies on your mechanism that you want to use for the motion envelope. Mechanism Design selects all components in your assembly by default, and displays the number of components in the text box. If you do not want to include all the components in the motion envelope, click  and use the normal selection methods to deselect components.

- **Special Handlings**—The check boxes **Ignore Skeletons** and **Ignore Quilts** are selected by default. If you want Mechanism Design to use any skeletons or quilts in your model when it creates the motion envelope, clear these check boxes. For more information on quilts and skeletons, search the PTC Help System.

- **Invert Triangle Pairs**—After you preview the motion envelope, you can use the options in this area to adjust the motion envelope model. The faceted motion envelope model consists of a set of contiguous triangles. If the automatically-computed motion envelope does not accurately represent the motion of your mechanism, click  and click the edge between two triangles. Mechanism Design replaces the triangles with the other two triangles that make up the tetrahedron defined by the triangles' four vertices.

- **Output Format**—You can save your motion envelope model in one of four formats. For more information on these formats, search for *tessellated files* in the PTC Help system.
  
  - **Part** (default)—Creates a Pro/ENGINEER part with normal geometry. Mechanism Design appends the extension .prt to the file name.
Mechanism Design Extension Help Topic Collection

- **LW Part**—Creates a lightweight Pro/ENGINEER part with lightweight, faceted geometry. Mechanism Design appends the extension .prt to the file name.

- **STL**—Creates an STL (Stereolithography) file. Mechanism Design appends the extension .stl to the file name.

- **VRML**—Creates a VRML file. Mechanism Design appends the extension .wrl to the file name.

- **Output File Name**—The system assigns the motion envelope model a default file name based on the name of the source model, in the format model_name_env0001. When the source model is a simplified representation of an assembly, the default name of the motion envelope model is simplifiedrepname_env0001. The system automatically appends the extensions .prt to part file names, .stl to STL file names, and .wrl to VRML file names.

- **Use default template**—If you have specified a default template in Pro/ENGINEER, the system uses that template, or start model, for the motion envelope part. You can use the Tools > Options command to set the configuration file option start_model_dir to specify the location for the default template. Using a template as a start model allows you to include critical layers, datum features, and views in the motion envelope model. It is possible but difficult to do this after the motion envelope model has been exported.

- **Preview**—Click this button to obtain graphical and textual feedback about the information that will be captured in the motion envelope model. Mechanism Design displays a shaded representation of the motion envelope model and the Pro/ENGINEER message window reports the number of triangles that make up the facets of the model.

- **Create**—If you selected the Part or LW Part output format, when you click this button, the system creates a solid motion envelope model, and displays it in its own window. Activate this window and use the File > Save command to save it to a part file.

  If you selected the STL or VRML output format, the system saves a .stl or .wrl file to the current working directory. The Create Motion Envelope dialog box remains open, and the source model remains in session as the current object.

To Remove a Playback Result Set

1. Click Mechanism > Playback. The Playbacks dialog box appears.

2. Select a result set.

3. Click \[ \] . The result set disappears from the drop-down list, and the information associated with it is removed from the system.

To Export a Playback Result Set
1. Click **Mechanism > Playback** or . The **Playbacks** dialog box appears.

2. Select a result set.

3. Click . Mechanism Design exports the information to a .fra file.

4. If you want to use the .fra file to create a motion envelope, exit Mechanism Design.

5. Select **File > Save a Copy**, and use the **Motion Envl** option. For more information on this procedure, search the PTC Help System.

### To Track a Measure During Playback

You can simultaneously view the playback of a result set and follow the change in a measure's value as the playback progresses.

1. Run an analysis or restore a result set.

2. Create a graph of a measure in the **Measure Results** dialog box.

3. Close the **Measure Results** dialog box, but do not close the **Graphtool** window. You can move or resize the **Graphtool** window if necessary.

4. Select **Mechanism > Playback** or click . The **Playbacks** dialog box appears.

5. Select the result set or in-session analysis associated with the measure that you created in step 2.

6. Enter the information required to complete the dialog box.

7. Click . The **Animate** dialog box appears.

8. Use the tools in the **Animate** dialog box to set the speed, direction, and duration of the analysis playback.

9. When you play back the result set, as your mechanism moves, a red vertical line simultaneously moves across the graph, tracking the measure's value.

   **Note:** Actions you carry out with the options on the Animate dialog box also control the measure tracking line. For example, to sample the measure at a specific point in the analysis, click to stop the playback, and move the cursor to the position of the tracking line. A message box appears with information about the measure's value.

### Tutorial 2E: Reviewing Results

This tutorial shows you how to review the results of a motion analysis for a four-bar linkage. It is the fifth and final part of the second Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start them, see Creating a Four-Bar Linkage.
1. Replay results. Click **Mechanism > Playback**. On the **Playbacks** dialog box, click ►. The **Animate** dialog box appears. Click ► to begin. Click ■ to stop the playback, and click **Close** to quit.

2. On the **Interference** tab of the **Playbacks** dialog box, select the **Global Interference** option, then click ►. The **Animate** dialog box appears.

3. Click ► to begin. Note that any interference is highlighted in red. Click **Close** to quit.

4. Click in the **Playbacks** dialog box to save your results as a .pbk file. In the **Save** dialog box, accept the default name or change to another name. The default directory is the current working directory. You can also browse to find another directory to save your file. You can open the .pbk file in future sessions by clicking on the **Playbacks** dialog box and selecting the playback file. Click **Close** to quit.

5. Click **Analysis > Measure**. The **Measure** dialog box appears.

6. Change **Type** to **Angle**. Change **First Entity** to **Plane**. Select **DTM2** on block.prt.

7. Change **Second Entity** to **Plane**. Select **DTM2** on crank.prt.

8. Click **Compute** to calculate the current angle. The value appears under **Results**.

9. Click **Add Feature**. Accept the default name for the measure or enter a new name. Close the dialog box.

10. Click **Mechanism > Measures**. Highlight the angle measure and the result set from the kinematic analysis.

11. Click ✗. When the calculation is complete, the graph window opens.

12. Click **File > Export** on the graph tool window to create a text file of the measure data. Enter a file name for the text file, which will be saved with the extension .grt. Close the dialog box.
13. Click **Mechanism > Trace Curve**. Select `block.prt` as the **Paper Part**. Use the selector arrow under **Point, Vertex, or Curve Endpoint** to select `pnt0` on `triangle_abc.prt` as the trace point.

14. Make sure **2D** is the **Curve Type**, and that **Trace Curve** is selected under **Trace**.

15. Highlight **Analysis1** as the **Result Set** and click **OK** to close the dialog box. The trace curve appears on your model.

16. Expand `block.prt` in the Model Tree and notice the last feature is the trace curve. The trace curve is created in the paper body.

   **Note:** If features are not visible in the Model Tree, select **Settings > Tree Filters**, and then select the **Features** check box on the **Model Tree Items** dialog box.

**Measures**

**About Measure Results**

Measures can help you understand and analyze the results of moving a mechanism and provide information that you can use to improve the mechanism's design.

Before you can calculate and view measure results in Mechanism Design, you must have run, or saved and restored, results from one or more analyses for your mechanism in Mechanism Design.

You can create these types of measures:

- Create Mechanism Design position, distance separation, velocity, acceleration, or cam measures using the **Measure Results** dialog box. You can also create system and body measures that do not require a mass definition.

- You can create several additional types of dynamics measures using the **Measure Results** dialog box, if you have a Mechanism Dynamics Option license.

- Create analysis measure features using the Pro/ENGINEER **Analysis > Measure** command. Distance and angle analysis measures are the most useful types of datum analyses for graphing measure results in Mechanism Design.

  For information on creating an analysis measure, search the Model Analysis functional area in the PTC Help system.

The measures you create in Mechanism Design are available for you to use as parameters when you run a Behavioral Modeling Extension (BMX) motion analysis. For more information, search the Model Analysis functional area of the PTC Help system.

The following table tells you which measures give the most useful information for each analysis type:

<table>
<thead>
<tr>
<th>Analysis</th>
<th>Measures</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Category</td>
<td>Measures</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Kinematic</td>
<td>Position, Velocity, Acceleration</td>
</tr>
<tr>
<td></td>
<td>Separation</td>
</tr>
<tr>
<td></td>
<td>Pro/ENGINEER features</td>
</tr>
<tr>
<td></td>
<td>Degrees of Freedom</td>
</tr>
<tr>
<td></td>
<td>Redundancies</td>
</tr>
<tr>
<td></td>
<td>Time</td>
</tr>
<tr>
<td></td>
<td>Body orientation</td>
</tr>
<tr>
<td></td>
<td>Body angular velocity</td>
</tr>
<tr>
<td></td>
<td>Body angular acceleration</td>
</tr>
<tr>
<td>Dynamic</td>
<td>All except Loadcell</td>
</tr>
<tr>
<td>Static</td>
<td>Position</td>
</tr>
<tr>
<td></td>
<td>Connection reaction</td>
</tr>
<tr>
<td></td>
<td>Net load</td>
</tr>
<tr>
<td></td>
<td>All system measures</td>
</tr>
<tr>
<td></td>
<td>All body measures</td>
</tr>
<tr>
<td></td>
<td>Pro/ENGINEER features</td>
</tr>
<tr>
<td>Force Balance</td>
<td>Connection reaction</td>
</tr>
<tr>
<td></td>
<td>Net load</td>
</tr>
<tr>
<td></td>
<td>Loadcell</td>
</tr>
<tr>
<td></td>
<td>All system measures</td>
</tr>
<tr>
<td></td>
<td>All body measures</td>
</tr>
<tr>
<td></td>
<td>Pro/ENGINEER features</td>
</tr>
<tr>
<td>Repeated Assembly</td>
<td>Position</td>
</tr>
<tr>
<td></td>
<td>Separation (distance)</td>
</tr>
<tr>
<td></td>
<td>Degrees of Freedom</td>
</tr>
<tr>
<td></td>
<td>Redundancies</td>
</tr>
<tr>
<td></td>
<td>Time</td>
</tr>
<tr>
<td></td>
<td>Body orientation</td>
</tr>
<tr>
<td></td>
<td>Body angular velocity</td>
</tr>
<tr>
<td></td>
<td>Body angular acceleration</td>
</tr>
</tbody>
</table>
You can graph the results of a measure for one or more specified Mechanism Design or Mechanism Dynamics analyses. You can retrieve a saved results file, save the measure results to a table file, or print them.

It is normally more efficient to create measures before you run an analysis. Measures that you create after running an analysis require that Mechanism Design compute the evaluations before it creates the graph, so these measures will take more time to graph when compared with measures that you create before running an analysis.

Use graphing to plot a measure over time or a measure against another measure. You have the option of creating a graph that displays multiple measure curves for one set of analysis results, or you can see how a single measure varies with different result sets. You can also graph multiple measures with multiple analyses.

Tip: Use display arrows for a visual representation of the changes your measures make during an analysis.

To Graph Measure Results

Before you can graph measure results, you must run an analysis, or restore results from a previous analysis. If you select certain evaluation methods for dynamics measures, you must create the measure before you run the analysis.

1. Click Mechanism > Measures or . The Measure Results dialog box appears.

2. From the Graph Type option list, click either Measure vs. Time or Measure vs. Measure.

3. From the list of available measures, select one or more measures for which you want to graph results. For measure vs. measure graphs, select a measure for the X axis and one or more measures for the Y axis of the graph.

4. Under Result Set, select one or more analysis result sets from the current session that you want to use.

5. If you want to use a saved result set, click and select a saved results file from the Select Playback File dialog box.

6. If you selected multiple measures or multiple result sets, choose a display method:
   - If you want to display each graph as a separate figure, select Graph measures separately.
   - If you want to display all of the graphs on one figure, do not select the Graph measures separately check box.

7. Click to display the graph.
If this is the first time in this session that you are graphing a measure for a result set, Mechanism Design displays the progress of the measurement in the bottom bar of the model window. When the measure results are complete, the Graphtool window appears.

8. If you want to stop the measurement calculation, click on the bottom bar of the model window. The Measure Results dialog box appears.

9. If you want to select options for the graph, click on the Graphtool window.

10. If you want to save the measures results as a table file, click File > Export Text on the Graphtool window.

   Note: If you graph multiple measures or multiple result sets, the format of the saved data may change.

11. If you want to print the graph, click on the Graphtool window and fill out the Print dialog box.

12. If you want to simultaneously view an analysis playback and track the value of your measure, when the measurement calculation is complete, close the Measure Results dialog box, but do not close the Graphtool window.

To Track a Measure During Playback

You can simultaneously view the playback of a result set and follow the change in a measure's value as the playback progresses.

1. Run an analysis or restore a result set.

2. Create a graph of a measure in the Measure Results dialog box.

3. Close the Measure Results dialog box, but do not close the Graphtool window. You can move or resize the Graphtool window if necessary.

4. Select Mechanism > Playback or click . The Playbacks dialog box appears.

5. Select the result set or in-session analysis associated with the measure that you created in step 2.

6. Enter the information required to complete the dialog box.

7. Click . The Animate dialog box appears.

8. Use the tools in the Animate dialog box to set the speed, direction, and duration of the analysis playback.

9. When you play back the result set, as your mechanism moves, a red vertical line simultaneously moves across the graph, tracking the measure's value.

   Note: Actions you carry out with the options on the Animate dialog box also control the measure tracking line. For example, to sample the measure at a specific point in the analysis, click to stop the playback, and move the cursor
to the position of the tracking line. A message box appears with information about the measure's value.

**Multiple Graphs**

When you graph measure results from the **Measure Results** dialog box, you have several display options. You can graph multiple measures for one result set, or one measure with multiple result sets. You get a different display depending upon whether you select the **Graph measures separately** check box. The way you select multiple measures or result sets also affects the format of the table that Mechanism Design saves when you save the graph data as a table. Use the table below to help you decide the best way to display your measure or save your data as a table.

**Note:** The graph window remains until you explicitly close it, or until you exit Mechanism Design.

<table>
<thead>
<tr>
<th>Number of measures</th>
<th>Number of result sets</th>
<th>Graph measures separately</th>
<th>Graph display</th>
<th>Table format</th>
</tr>
</thead>
<tbody>
<tr>
<td>One</td>
<td>One</td>
<td>Yes, No</td>
<td>One graph figure</td>
<td>Single table with one column for Y axis values, and one for each measure</td>
</tr>
<tr>
<td>Two or more</td>
<td>One</td>
<td>No</td>
<td>One graph figure with one graph line for each measure</td>
<td>Single table with one column for Y axis values, and one for each measure</td>
</tr>
<tr>
<td>Two or more</td>
<td>One</td>
<td>Yes</td>
<td>More than one graph figure—one for each measure</td>
<td>Single table with one column for Y axis values, and one for each measure</td>
</tr>
<tr>
<td>One</td>
<td>Two or more</td>
<td>No</td>
<td>One graph figure with one graph line for each result set</td>
<td>One table for each result set</td>
</tr>
<tr>
<td>One</td>
<td>Two or more</td>
<td>Yes</td>
<td>More than one graph figure—one for each result set</td>
<td>One table for each result set</td>
</tr>
</tbody>
</table>
Two or more | Two or more | No | One graph figure with a graph line for each measure–result set combination | One table for each result set
---|---|---|---|---
Two or more | Two or more | Yes | One graph figure for each measure. Each graph figure includes one line for each result set. | One table for each result set

**About Graphing**

Use the **Graphtool** window to display plots of measure results and the functions that define motor and force profiles. After you display your graph, you can interact with it in several ways. To find out the x and y values for any graph point, click on the point and a dialog box appears showing the values. To work with the graph and manage its appearance, use toolbar buttons or the following menu commands:

- **File**
  - **Export Excel**—This option is available on Windows only. Use it to save the graph data as a Microsoft Excel spreadsheet. When you click this command, Mechanism Design displays the **Export To Excel** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a `.xlc` extension. The file contains a pictorial rendition of the graph as well as a numeric table of graph values.
  - **Export Text**—Save the graph data as a text file. When you click this command, Mechanism Design displays the **Export To Text** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a `.grt` extension.
  - **Print**—Send your graph to a printer. When you click this command, a dialog box appears that allows you to output your graph to several print and graphic formats, or save it as a file.
  - **Exit**—Close the **Graphtool** window.

- **View**
  - **Toggle Grid**—Display grid lines for your graph or turn them off.
  - **Repaint**—Refresh the view of your graph.
  - **Refit**—Restore a graph to its original state. Use this command after you zoom in on a particular graph segment to return to an unsegmented state. Mechanism Design automatically redraws the complete graph in the current window.
o **Zoom In**—Zoom in on the graph to get a close-up view. This command is especially useful when your graph contains too many points, 100 or more. Zooming in on a section of the graph helps you to display a specific segment of interest.

- **Format**
  - **Graph**—Open the **Graph Window Options** dialog box to manage your graph and its display window.

### About the Measure Results Dialog Box

You can view measure results and create new measures by selecting the **Mechanism > Measures** command and using the options on the **Measure Results** dialog box.

The **Measure Results** dialog box contains the following areas:

- **Graph Type**—Select **Measure vs. Time** or **Measure vs. Measure**. The dialog box displays different options for selecting measures depending on the graph type you specify.

- **Measures**—Select one or more measures for the Y axis of the plot. Mechanism Design lists any existing measures, and their values and status for a selected result set. If you select multiple measures, the graph displays a different colored curve for each measure.

- **Measure for X axis** (for Measure vs. Measure graphs only)—Select one measure for the X axis of the plot.

- **Graph Measures Separately**—If you select this check box, Mechanism Design displays each plot on a separate graph. If you do not select this check box, Mechanism Design displays all the plots on a single graph. You can display up to 9 graphs in separate figures. For more information on the ways you can display your measures, see Multiple Graphs.

- **Result Set**—Select one or more result sets from previously run analyses. If you select multiple result sets, the graph displays a different colored curve for each result set.

Use the buttons at the top of the dialog box for these actions:

- If you want to use a result set from a saved analysis run for the model, click the file selector and the **Select Playback File** dialog box appears. Select a file from the list of saved result sets and click **Open**. The selected file appears in the list of result sets in the **Measure Results** dialog box.

- Click to graph the selected measure for the selected result set. If you have selected the result set for the first time in this session of Mechanism Design, when you click **Graph**, Mechanism Design displays the progress of the measurement in the bottom bar of the model window. Click to stop the measurement calculation.
After the measure results are complete, the **Graphtool** window appears. Use the items on this window to change the display of your graph, print it, or save it in tabular form.

Note that if you select one or more measures whose status is "Not Computed," the graph button is disabled.

- Click [ ] to create a Pro/ENGINEER parameter from the selected measure and selected analysis. The parameter has the name **MDO_measure_name**. When you first create a parameter from a measure, Mechanism Design gives it the value of the measure at the last time step of the analysis. The value of the Pro/ENGINEER parameter remains constant until you update it on the **Measure Results** dialog box or until you return to Pro/ENGINEER and change the value.

  If you create a parameter, and then rerun an analysis, select the measure and analysis and click [ ] to update the value of the parameter with the value from the new analysis.

  For information on Pro/ENGINEER parameters, search the Fundamentals functional area of the PTC Help system.

You can also use the **Measure Results** dialog box to create, edit, copy, and delete measures.

### Creating Measures

Use the following items on the **Measure Results** dialog box to create, edit, copy, and delete measures:

- [ ]—Create a new measure. The **Measure Definition** dialog box appears. If you have a Mechanism Dynamics Option license, you can create several types of measures. Depending on the evaluation method you select, you may have to create your measure before running the analysis.

  If you do not have a Mechanism Dynamics Option license, the only measures you can create are **Position**, **Velocity**, **Acceleration**, **Separation**, or **Cam** measures, and any **System** and **Body** measures that do not require mass definition.

- [ ]—Edit a measure. When you select a measure from the list and click [ ], the **Measure Definition** dialog box appears with the information for that measure.

- [ ]—Copy a selected measure. A copy of the selected measures with the name **copy of measure_name** appears in the list. Measures are listed in alphabetical order.

- [ ]—Delete one or more selected measures from the list.

**Note:** In previous releases, Mechanism Design listed **Degrees of Freedom** and **Redundancies** as default measures when you opened the **Measure Results**
dialog box. If you created your mechanism in a previous Mechanism Design release, the predefined **Degrees of Freedom** and **Redundancies** measures appear in the list when you open your model in the current release, but you can now edit them or delete them from the list.

**Measures Associated with Model Entities**

This table organizes Mechanism Design measures according to the type of model entity that you select to define the measure.

<table>
<thead>
<tr>
<th>Entity</th>
<th>Measures</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point(s)</td>
<td>Position, Velocity, Acceleration, Separation—distance, speed, change in speed</td>
</tr>
<tr>
<td>Joint axis</td>
<td>Position, Velocity, Acceleration, Net load</td>
</tr>
<tr>
<td>Joint connection</td>
<td>Connection reaction, Impact, Impulse</td>
</tr>
<tr>
<td>Cams</td>
<td>Cam—curvature, pressure angle, slip velocity</td>
</tr>
<tr>
<td>Cam-follower connection</td>
<td>Connection reaction, Impact, Impulse</td>
</tr>
<tr>
<td>Slot-follower connection</td>
<td>Connection reaction, Impact, Impulse</td>
</tr>
<tr>
<td>Gear-pair connection</td>
<td>Connection reaction</td>
</tr>
<tr>
<td>Spring, damper, force, torque, servo motor, force motor</td>
<td>Net load</td>
</tr>
</tbody>
</table>
Types of Measures

When you click on the Measure Results dialog box, the Measure Definition dialog box appears. You can create measures for specific model entities, or for the entire mechanism. You can also include measures in your own expressions for user-defined measures.

You can create any of these measures if you have a Mechanism Dynamics Option license. If you do not, you can only create Position, Velocity, Acceleration, Separation, Cam measures, and any System and Body measures that do not require mass.

- **Position**—Measure the location of a point, vertex, or joint axis during the analysis.
- **Velocity**—Measure the velocity of a point, vertex, or joint axis during the analysis.
- **Acceleration**—Measure the acceleration of a point, vertex, or joint axis during the analysis.
- **Connection Reaction**—Measure the reaction forces and moments at joint, gear-pair, cam-follower, or slot-follower connections.
- **Net Load**—Measure the magnitude of a force load on a spring, damper, servo motor, force, torque, or joint axis. You can also confirm the force load on a force motor.
- **Loadcell Reaction**—Measure the load on a loadcell lock during a force balance analysis.
- **Impact**—Determine whether impact occurred during an analysis at a joint limit, slot end, or between two cams.
- **Impulse**—Measure the change in momentum resulting from an impact event. You can measure impulses for joints with limits, for cam-follower connections with liftoff, or for slot-follower connections.
- **System**—Measure several quantities that describe the behavior of the entire system.
- **Body**—Measure several quantities that describe the behavior of a selected body.
- **Separation**—Measure the separation distance, separation speed, and change in separation speed between two selected points.
- **Cam**—Measure the curvature, pressure angle, and slip velocity for either of the cams in a cam-follower connection.
- **User Defined**—Define a measure as a mathematical expression that includes measures, constants, arithmetical operators, and algebraic functions.

Evaluation Methods
When you define dynamics measures, you can choose from several evaluation methods. The graph of the measure and the quantity displayed under Value on the Measure Results dialog box are different for different evaluation methods. These options are not available for loadcell reactions, or for the cam reaction measure slip component.

<table>
<thead>
<tr>
<th>Evaluation Method</th>
<th>Value</th>
<th>Graph</th>
</tr>
</thead>
<tbody>
<tr>
<td>Each Time Step</td>
<td>Value of the measure at the last time step</td>
<td>The value of the measure, calculated at each time interval of the analysis</td>
</tr>
<tr>
<td>Maximum</td>
<td>Maximum value over analysis</td>
<td>The maximum value attained so far in the analysis</td>
</tr>
<tr>
<td>Minimum</td>
<td>Minimum value over analysis</td>
<td>The minimum value attained so far in the analysis</td>
</tr>
<tr>
<td>Integral</td>
<td>The integrated value of the measure at the last time step</td>
<td>The integration of the function up to a given point in time</td>
</tr>
<tr>
<td>Average</td>
<td>The value of the average at the last time step</td>
<td>The average value of the measure up to each time step of the analysis</td>
</tr>
<tr>
<td>Root Mean Square</td>
<td>The root mean square value at the last time step</td>
<td>The root mean square of the measure up to that point at a given time step See the example for a comparison of root mean square and average graphs.</td>
</tr>
<tr>
<td>At Time</td>
<td>The value of the measure at a specified time</td>
<td>The value of the measure represented as a bar at the specified time</td>
</tr>
</tbody>
</table>

For Each Time Step, you can define your measure after you run the analysis. For the other methods, you must define the measure before running an analysis. If you define a measure with Maximum, Minimum, Integral, Average, Root Mean Square or At Time evaluation methods after you run an analysis, the Status column on the Measure Results dialog box reports Not computed when you select the analysis.

Mechanism Design reports the values found at each interval at which it performs calculations. These are not necessarily equivalent intervals. Keep in mind that the time intervals on a measure results graph are not the time intervals that Mechanism Design uses to calculate results. Also, the software may not use the exact intervals you specify when you define a dynamic analysis. The software adjusts its calculations to ensure accurate results.
For analyses in which the quantities measured are changing quickly, the sampling rate is greater. For example, to accurately calculate an impact event, the software uses a greater sampling rate close to the time that the impact occurs. The software uses the intervals you specify when you define a dynamic analysis as the maximum time interval step size. The actual interval may be smaller, depending upon the demands of the calculation.

The software uses the assembly tolerance settings to determine the time intervals it uses for analysis calculations. The lower the tolerance, the more precise the calculations are.

If you want to verify the accuracy of a minimum or maximum value, rerun the analysis at a lower (more precise) tolerance and repeat until the reported minimum or maximum values do not change significantly from run to run.

**At Time Evaluation Method**

When you select **At Time** on the **Measure Definition** dialog box, you must also specify a time during the analysis. Mechanism Design reports the measure on the **Measure Results** dialog box for a selected result set at the specified time.

**Integral Evaluation Method**

The **Integral** value is the integral of the quantity of interest up to a point in time. If you plot this value, the value at a given point on the **Integral** curve corresponds to the area under the curve plotted for **Each Time Step** for the same quantity at the same point in the analysis.

The unit for an **Integral** measure is the unit of the measure quantity multiplied by time. For example, if the measure is velocity, with the unit m/sec, the unit for the integral measure would be m/sec * sec.

**Example: Evaluation Methods**

The **Root Mean Square** value is useful if your mechanism's motion includes values that oscillate symmetrically around zero.

The figure graphs the velocity of a rotational joint axis. The three plots used three **Evaluation Methods**—**Each Time Step**, **Average**, and **Root Mean Square**. The **Average** value tends toward zero over time, but the **Root Mean Square** value remains positive and gives an indication of the magnitude of the velocity.
Position, Velocity, and Acceleration Measures

You can create measures to evaluate position, velocity, or acceleration for points or joint axes in your assembly.

To define position, velocity, or acceleration measures on the Measure Definition dialog box, you must specify a joint axis or a point on your model, a component of the direction vector, and an evaluation method.

If you select a point, you must also select a coordinate system as a frame of reference for the direction of the position, velocity, or acceleration vector. You can select the WCS, an LCS, or a UCS. A shaded, magenta arrow appears on the selected point indicating the direction of the X, Y, or Z axis that Mechanism Design actually uses in the calculation. No arrow appears if the component is Magnitude. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the measurement.

If you select a joint axis, the value of the measure is the position, velocity, or acceleration in the direction allowed by the joint axis' DOF. When you select the joint axis, a shaded, magenta arrow appears. The arrow points in the direction of the DOF for translational joint axes. For rotational joint axes, Mechanism Design displays a double-headed arrow parallel to the joint axis, indicating the rotational direction.
You can create position measures, for example, if you want to determine the maximum and minimum position of a piston stroke. If you define a piston with force motors, you can use a velocity or acceleration measure to follow the changes in velocity or acceleration during a dynamics analysis. For example, if you are sizing a motor, use these measures to verify that the joint axis has enough speed and acceleration. If you graph the velocity and acceleration and it indicates that the joint axis is moving too slowly, you may not have enough force applied to the mechanism.

**To Create Position, Velocity, or Acceleration Measures**

1. Select **Mechanism > Measures** or click ![Measures](image). The **Measure Results** dialog box appears.

2. Click ![Create Measure](image). The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select one of these **Types**:
   - Position
   - Velocity
   - Acceleration

5. Click ![Select Measure Location](image) and select the point or joint axis in your assembly for which you want to define a measure. After you select the joint axis, or select the point and a **Component**, a shaded arrow appears on your model indicating the direction of the vector.

6. If you select a point, use the arrow button in the coordinate system area to select a **Coordinate System**. The default coordinate system is the WCS. You can also select an LCS or UCS.

7. If you select a point, select one of these **Components** to measure:
   - Magnitude—the magnitude of the position, velocity, or acceleration vector
   - X–component—the X component in the selected coordinate system
   - Y–component—the Y component in the selected coordinate system
   - Z–component—the Z component in the selected coordinate system

8. Select one of these **Evaluation Methods**:
   - Each Time Step
   - Maximum
   - Minimum
   - Integral
   - Average
9. If you select **At Time**, enter a real-number value greater than zero in the **Time** entry box.

10. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

11. Graph the measure.

**Connection Reaction Measures**

A reaction measure evaluates the load generated at a connection in response to external forces. You can use a joint reaction measure, for example, to verify that you are within the load rating for a bearing.

When you define your connection reaction measure on the **Measure Definition** dialog box, in some cases you can specify which coordinate system to use as the frame of reference for Mechanism Design to report the measure, and on which of the bodies joined by the connection to measure the exerted reaction force. However, the coordinate system axes used in calculating reaction loads may or may not correspond to the WCS or selected LCS axes. When you select a connection and a component of force or moment to measure, a shaded, magenta arrow appears on the selected connection, indicating the X or Y direction that Mechanism Design actually uses in the calculation. No arrow appears if you select a component that gives the magnitude of the force or moment. Be sure to look at this direction carefully to decide whether it is actually the direction that you want for the force or moment.

You can create reaction measures for these types of connections:

- **Joints**—Evaluate the reaction force on a joint axis due to reaching a joint axis limit and due to friction. The force or moment component that you can measure depends upon the type of joint.

  **Note:** To measure the sum of applied forces on a joint, such as motors and springs, use a net load measure. For more information, see Comparing Net Load and Connection Reaction Measures.

- **Cam-Follower Connections**—Evaluate the force at the contact point between the two cams in a cam-follower connection.

  **Note:** Be aware that the reaction measure for a cam-follower connection does not include the calculation of impact forces. You can measure reaction forces on a cam-follower connection with liftoff while the cams are in contact, but reaction force values will be zero if the cams separate. If your cams liftoff and contact several times during an analysis, that is, the cams bounce, use an impact or impulse measure to monitor the contact events.

You can measure the following components for cam-follower connections:

- **Normal Force**—the reaction force perpendicular to the cam-follower connection at the point of contact. In a given frame of reference, a positive
reaction force works to push the two cams in the connection together, and a negative force works to pull them apart.

- **Tangential Force**—the reaction force tangential to the cam-follower connection at the point of contact. A tangential force acts to slide the cams past each other.

- **Slip**—a check for whether a cam-follower connection slipped during a force balance analysis. If a slip occurred during the analysis, the measure returns a value of 1. If not, it returns a value of 0.

- **Slot-Follower Connections**—Evaluate the force exerted when a slot follower reaches one of the endpoints of the slot or the force due to friction.

- **Gear Pairs**—Evaluate the reaction force or torque exerted on one of the bodies in a gear pair. For a gear with a rotational joint, you can measure the torque on either of the gear bodies. For a gear with a translational joint, such as the rack in a rack and pinion gear pair, you can measure the linear force exerted on one of the bodies. The force or torque is expressed in the LCS of the carrier body attached to the selected gear.

**To Create Joint Reaction Measures**

1. Select **Mechanism > Measures** or click . The **Measure Results** dialog box appears.

2. Click . The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Connection Reaction** under **Type**.

5. Select **Joint** under **Connection Type** and use to select a joint axis. Mechanism Design displays the name of the joint, displays the units for the reaction measure under **Type**, and lists the force or moment component that you can measure for that joint.

   **Tip:** To reliably select a particular joint axis, use query mode. When you highlight a connection on your model and right-click, the **Pick From List** dialog box appears with a list of the possible joint axes. Use the arrow to select the desired axis and click **Accept**.

6. Select a **Component** from the drop-down list. After you select the joint and a component, a shaded arrow appears on your model indicating the direction of the component. Click one of the following joint types for information on the available components:

   - **Pin**
   - **Slider**
   - **Cylinder**
   - **Planar**
Mechanism Design Extension

- Ball
- Weld
- Bearing
- General
- 6DOF

7. Select **Body 1 LCS** or **Body 2 LCS** in the **Expressed In** area. Mechanism Design highlights the LCS of the body you select. It uses this LCS to report the measure.

8. Select **Body 1** or **Body 2** in the **Exerted On** area. Mechanism Design highlights the body, and reports the reaction force on the body you select.

   **Tip:** Body 1 refers to the first body in the connection. For example, if the two bodies joined by the joint connection are Ground and Body 3, Ground is the first body, and Body 3 is the second body. If the two bodies are Body 1 and Body 2, Body 1 is the first body in the joint. The Model Tree lists the two bodies associated with each joint connection. To highlight Ground or another body on your assembly, select **Connections > Joints > Joint_name > Body_name** in the Model Tree.

9. Select one of these **Evaluation Methods**:
   - Each Time Step
   - Maximum
   - Minimum
   - Integral
   - Average
   - Root Mean Square
   - At Time

10. If you select **At Time**, enter a real-number value greater than zero in the **Time** entry box.

11. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

12. Graph the measure.

**Components for Pin Joint Reaction Measures**

A pin joint allows rotation around one axis. You can measure one of the following quantities for pin joints:

- **Axial Force**—the component of the force in the direction of the axis of rotation (Z)
- **Axial Moment**—the moment around the axis of rotation (Z)
• **Radial Force**—the magnitude of the force in the plane perpendicular to the axis of rotation. This works to pull the two bodies connected by the pin towards or away from each other.

• **Radial Force X**—the component of the force in the X direction

• **Radial Force Y**—the component of the force in the Y direction

• **Radial Moment**—the magnitude of the moment in the plane perpendicular to the axis of rotation. This moment works to tilt the pin joint axis away from its defined position.

• **Radial Moment X**—the X component of the moment in the plane perpendicular to the axis of rotation

• **Radial Moment Y**—the Y component of the moment in the plane perpendicular to the axis of rotation

When you select the pin joint and any component other than **Radial Force** or **Radial Moment**, a magenta arrow appears on the connection indicating the positive direction of action. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force or moment.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the **Wireframe**, **Hidden Line**, or **No Hidden Line** display option to make the arrow visible.

**Components for Slider Joint Reaction Measures**

A slider joint allows translation along one axis. The software labels the translation axis Z. You can measure one of the following quantities for slider joints:

• **Axial Force**—the component of the force in the direction of the translation axis (Z)

• **Axial Moment**—the moment about the translation axis (Z)

• **Lateral Force**—the magnitude of the force in the plane perpendicular to the translation axis

• **Lateral Force X**—the component of the force in the X direction

• **Lateral Force Y**—the component of the force in the Y direction

• **Lateral Moment**—the magnitude of the moment in the plane perpendicular to the translation axis

• **Lateral Moment X**—the moment around the slider X axis

• **Lateral Moment Y**—the moment around the slider Y axis

When you select the slider joint and any component other than **Lateral Force** or **Lateral Moment**, a magenta arrow appears on the connection indicating the positive direction of action. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force or moment.
Use lateral force measures if you are interested in the reaction forces perpendicular to the direction of translation. Use lateral force moments if you are interested in the moments perpendicular to the direction of translation. Use axial moment measures if you are interested in torques causing rotation around the translation axis.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the **Wireframe**, **Hidden Line**, or **No Hidden Line** display option to make the arrow visible.

### Components for Cylinder Joint Reaction Measures

A cylinder joint allows rotation around and translation along one axis. You can measure one of the following quantities for cylinder joints:

- **Axial Force**—the component of the force in the direction of the rotation and translation axis (Z)
- **Axial Moment**—the moment around the rotation and translation axis (Z)
- **Radial Force**—the magnitude of the force in the plane perpendicular to the axis of rotation
- **Radial Force X**—the component of the force in the X direction
- **Radial Force Y**—the component of the force in the Y direction
- **Radial Moment**—the magnitude of the moment in the plane perpendicular to the axis of rotation
- **Radial Moment X**—the X component of the moment in the plane perpendicular to the axis of rotation
- **Radial Moment Y**—the Y component of the moment in the plane perpendicular to the axis of rotation

When you select the cylinder joint and any component other than **Radial Force** or **Radial Moment**, a magenta arrow appears on the connection indicating the positive direction of action. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force or moment.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the **Wireframe**, **Hidden Line**, or **No Hidden Line** display option to make the arrow visible.

### Component for Ball Joint Reaction Measures

A ball joint allows rotation in any direction. Only one component is allowed for a ball joint. You can measure the **Radial Force**, which is the total magnitude of the force on the connection.

### Components for Planar Joint Reaction Measures

A planar joint allows rotation around one axis (Z) and translation along two axes perpendicular to the rotation axis. You can measure one of the following quantities for planar joints:
• **Normal Force**—the force perpendicular to the plane defined by the two translation axes. A normal force acts to pull apart the two bodies joined by the planar connection, or force them together, depending upon the sense of the force.

• **Normal Moment**—the moment around the rotation axis (Z)

• **Planar Force X**—the X component of the force in the plane containing the joint’s translation axes

• **Planar Force Y**—the Y component of the force in the plane perpendicular to the rotation axis

• **Planar Moment X**—the moment along the X translation axis

• **Planar Moment Y**—the moment along the Y translation axis

When you select the planar joint and any component, a magenta arrow appears on the connection indicating the positive direction of action. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force or moment.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the Wireframe, Hidden Line, or No Hidden Line display option to make the arrow visible.

**Components for Bearing Joint Reaction Measures**

A bearing joint allows rotation around and translation along one axis, and rotation around the two axes perpendicular to the first axis. You can measure one of the following quantities for bearing joints.

• **Axial Force**—the component of the force along the translation axis.

• **Radial Force**—the component of the force in the plane perpendicular to the first axis of the connection

When you select the bearing joint and Axial Force, a magenta arrow appears on the connection indicating the positive direction. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the Wireframe, Hidden Line, or No Hidden Line display option to make the arrow visible.

**Components for Weld Joint Reaction Measures**

A weld joint connects two bodies with no degrees of freedom. Weld joints do not have joint axes. You can measure one of the following quantities for weld joints:

• **Total Force**—the magnitude of the reaction force

• **Force X**—the component of the force in the X direction

• **Force Y**—the component of the force in the Y direction

• **Force Z**—the component of the force in the Z direction
• **Total Moment**—the magnitude of the reaction moment
• **Moment X**—the moment around the X axis
• **Moment Y**—the moment around the Y axis
• **Moment Z**—the moment around the Z axis

When you select the weld joint and any component other than **Total Force** or **Total Moment**, a magenta arrow appears on the connection indicating the positive direction of the component. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force or moment.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the **Wireframe, Hidden Line, or No Hidden Line** display option to make the arrow visible.

**Components for 6DOF Joint Reaction Measures**

A 6DOF joint allows rotation and translation around three axes. You can measure one of the following quantities for 6DOF joints:

• **Total Force**—the magnitude of the reaction force
• **Force X**—the component of the force in the X direction
• **Force Y**—the component of the force in the Y direction
• **Force Z**—the component of the force in the Z direction
• **Total Moment**—the magnitude of the reaction moment
• **Moment X**—the X component of the moment around the X axis
• **Moment Y**—the Y component of the moment around the Y axis
• **Moment Z**—the Z component of the moment around the Z axis

When you select the 6DOF joint and any component other than **Total Force** or **Total Moment**, a magenta arrow appears on the connection indicating the positive direction of action. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force or moment.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the **Wireframe, Hidden Line, or No Hidden Line** display option to make the arrow visible.

**Components for General Connections**

A general joint connection allows various degrees of freedom, depending upon the way you define it. You can measure one of the following quantities for general joints:

• **Total Force**—the magnitude of the reaction force
• **Force X**—the component of the force in the X direction
• **Force Y**—the component of the force in the Y direction
• **Force Z**—the component of the force in the Z direction
- **Total Moment**—the magnitude of the reaction moment
- **Moment X**—the X component of the moment around the X axis
- **Moment Y**—the Y component of the moment around the Y axis
- **Moment Z**—the Z component of the moment around the Z axis

When you select the joint and any component other than **Total Force** or **Total Moment**, a magenta arrow appears on the connection indicating the positive direction of action. Be sure to look at this direction carefully to decide whether it is actually the direction for which you want the force or moment.

**Tip:** If your model is shaded, the shading may hide the arrow. Select the **Wireframe**, **Hidden Line**, or **No Hidden Line** display option to make the arrow visible.

**Components for Slot-Follower Reaction Measures**

You can select one of the following components for a slot-follower connection reaction. All components are relative to a Cartesian coordinate system.

- **Force X**—Measure the force along the X axis exerted when a slot follower reaches one of the endpoints of the slot.
- **Force Y**—Measure the force along the Y axis exerted when a slot follower reaches one of the endpoints of the slot.
- **Force Z**—Measure the force along the Z axis exerted when a slot follower reaches one of the endpoints of the slot.
- **Total Force**—Measure the total force that is exerted when a slot follower reaches one of the endpoints of the slot.
- **Normal**—Measure the force due to friction that is exerted normal to the slot follower at the point of contact with the slot curve.
- **Tangential**—Measure the force due to friction that is exerted tangent to the slot curve, in a direction opposing the movement of the follower along the slot curve.

**Note:** You must specify friction coefficients when you create your slot-follower connection, and enable friction for the analysis, to measure **Normal** and **Tangential** components.

**To Create Slot-Follower Reaction Measures**

1. Select **Mechanism > Measures** or click 📊. The **Measure Results** dialog box appears.
2. Click 📊. The **Measure Definition** dialog box appears.
3. Enter a descriptive name for your measure, or accept the default name.
4. Select **Connection Reaction** under **Type**.
5. Select **Slot-follower** under **Connection Type** and use \( \text{\textbullet} \) to select a slot-follower connection. Mechanism Design displays the name of the slot-follower connection and displays the units for the reaction measure under **Type**. A magenta, shaded arrow appears indicating the direction of the component.

6. Select one of the following **Components**:
   - Force X
   - Force Y
   - Force Z
   - Total Force
   - Normal
   - Tangential

7. Select **Slot Body LCS** or **Follower Body LCS** in the **Expressed In** area. Mechanism Design uses the LCS of the body that you select to report the measure.

8. Select **Slot Body** or **Follower Body** in the **Exerted On** area. Mechanism Design highlights the body.

9. Select one of these **Evaluation Methods**:
   - Each Time Step
   - Maximum
   - Minimum
   - Integral
   - Average
   - Root Mean Square
   - At Time

10. If you select **At Time**, enter a real-number value greater than zero in the **Time** entry box.

11. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

12. Graph the measure.

**To Create Cam-Follower Reaction Measures**

1. Select **Mechanism > Measures** or click \( \text{\textbullet} \). The **Measure Results** dialog box appears.

2. Click \( \text{\textbullet} \). The **Measure Definition** dialog box appears.
3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Connection Reaction** under **Type**.

5. Select **Cam-follower** under **Connection Type** and use :arrow_right: to select a cam-follower connection. Mechanism Design displays the name of the cam-follower connection and displays the units for the reaction measure under **Type**. A magenta, shaded arrow appears indicating the direction of action on the selected body. (No arrow appears if you select **Slip** as the **Component**).

6. Select one of these **Components**:
   - Normal Force
   - Tangential Force
   - Slip

7. Select **Cam 1** or **Cam 2** in the **Exerted On** area. Mechanism Design uses the LCS of the body that you select to report the measure.

8. Select one of the following **Evaluation Methods**:
   - Each Time Step
   - Maximum
   - Minimum
   - Integral
   - Average
   - Root Mean Square
   - At Time

9. If you select **At Time**, enter a real-number value greater than zero in the **Time** entry box.

10. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

11. Graph the measure.

**To Create Gear Pair Reaction Measures**

1. Select **Mechanism > Measures** or click :gear:. The **Measure Results** dialog box appears.

2. Click :gear:. The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Connection Reaction** under **Type**.
5. Select **Gear Pair** under **Connection Type** and use \( \text{select} \) to select a gear pair. Mechanism Design displays the name of the gear pair and displays the units for the reaction measure under **Type**.

6. Select **Gear1** or **Gear2** in the **Exerted On** area. Mechanism Design references the LCS of the carrier body associated with the gear you select when it calculates the measure.

7. Select one of these **Evaluation Methods**:  
   - Each Time Step
   - Maximum
   - Minimum
   - Integral
   - Average
   - Root Mean Square
   - At Time

8. If you select **At Time**, enter a real-number value greater than zero in the **Time** entry box.

9. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

10. Graph the measure.

**Net Load Measures**

A net load measure evaluates the force applied by a motor, spring, damper, force, or torque, or the net force experienced by a joint axis. You can create this measure to determine whether the load exerted by one of these entities during an analysis meets your criteria for the mechanism. You can also use this measure to confirm a force motor profile or to confirm that a user-defined force or torque reaches the desired value at the desired time.

For example, assume you have defined a servo motor to reach a certain velocity in a certain amount of time, and you want to know how much force to apply to attain the same velocity in the same amount of time. You can run a dynamic analysis with the servo motor, create a net load measure that displays the force variation with time, and create a force motor with the same force profile.

You define a spring by specifying the unstretched length and a stiffness constant. You define a damper by specifying a damping coefficient. The actual forces felt by a spring or damper will be the result of other reactions present in the mechanism. In both cases, you can use a net load measure to calculate the force on the spring or damper during an analysis, and adjust your definitions to meet the needs of your mechanism.
Note: If your model includes a gear pair connection, the reaction measures on the joints used to create the gears will not include a contribution from gear tooth contact.

You can select the following entities for net load measures:

- **Servo motor**—Measure the total load applied by the servo motor to cause the specified motion.
- **Force motor**—Measure the value of the force applied by the force motor.
- **Spring**—Measure the applied value of the spring load.
- **Damper**—Measure the applied value of the damper load.
- **Force/Torque**—Measure the applied value of the force or torque. Use this measure, for example, if you define a table force or user-defined force that varies with time, to confirm that the force reaches the desired value at a given time during the analysis.
- **Joint axis**—Measure the sum of all the applied loads, including forces, motors, springs, and dampers, acting on the joint axis. This sum does not include forces, torques, or connection reactions.

### Comparing Net Load and Connection Reaction Measures

Be sure you understand the difference between the values that you obtain when you apply net load measures or connection reaction measures to joint axes.

- A net load measure for a joint axis measures the sum of all the applied loads defined on the joint axis. It only includes friction force or force due to springs, dampers, force motors, and servo motors.

- The connection reaction measure along the degrees of freedom is the sum of all the forces on the joint due to friction or due to reaching a joint axis limit. For example, in a pin joint, the axial moment measure provides friction and joint limit force, whereas, in slider joints, the axial force measure provides friction and joint limit force. The connection reaction measure along the degrees of freedom does not take other applied forces into account.

    If you lock the joint connection in an analysis, the measure value includes the force from all other load entities, including springs and force motors, that act along this joint axis. Damper forces are zero in this case.

### To Create Net Load Measures

1. Select **Mechanism > Measures** or click [ ] . The **Measure Results** dialog box appears.

2. Click [ ]. The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Net Load** under **Type**.
5. Click under Reference and select one of the following entities on your model. Mechanism Design displays the name of the entity and displays the units for the load reaction measure under Type. A shaded arrow appears on your mechanism indicating the direction of action.

- Spring
- Damper
- Servo motor
- Force motor
- Force
- Torque
- Joint Axis

6. Select one of these Evaluation Methods:

- Each Time Step
- Maximum
- Minimum
- Integral
- Average
- Root Mean Square
- At Time

7. If you select At Time, enter a real-number value greater than or equal to zero in the Time entry box.

8. Click OK to accept your definitions and return to the Measure Results dialog box.

9. Graph the measure.

**Loadcell Reaction Measures**

Use a loadcell reaction measure when you run a force balance analysis. You must create the loadcell lock on the Preferences tab of the force balance Analysis Definition dialog box, and run the analysis, before you can get the value of the measure in the Measure Results dialog box.

You can think of a force balance analysis as an inverse static analysis. When Mechanism Dynamics runs a static analysis, it searches for a configuration in which all the loads and forces in your mechanism are balanced. A force balance analysis is a way to obtain information on the loads needed to balance your mechanism before running a static analysis. The loadcell lock is a device to isolate a portion of your model and obtain a balancing load for it.
Your goal is to reach a state in which all loads and forces balance so that the mechanism cannot move. Before you run a force balance analysis, you must reduce your mechanism to zero DOF. You do this by locking bodies and connections, or by creating a loadcell lock. Keep in mind that any servo motors, springs, or dampers you have applied to a connection also reduces the connection's DOF. You then run the force balance analysis. If you have applied a loadcell lock, a message box appears with the magnitude of the force required to balance the mechanism at the specified point in the specified direction. You can also view this quantity by creating a loadcell reaction measure.

A loadcell lock requires that you specify a point or vertex, a body, and a force direction.

- Mechanism Design applies the balancing force at the point or vertex you select. The point or vertex must be associated with a non-ground body.

- The software uses the LCS of the selected body to reference the direction vector. This body, and the body associated with the point where the force is applied, can be different.

- After you select the body for the LCS, Mechanism Design prompts you to enter the coordinates for the direction vector. Mechanism Design displays a shaded, magenta arrow indicating the direction of the force vector.

Here are some points to keep in mind when defining a loadcell lock:

- You can define several loadcell locks, but only one can be active during the force balance analysis.

- Once you define the direction of the force vector, you cannot edit it. If you want to change the direction of the force, create another loadcell lock.

**To Create Loadcell Reaction Measure**

This procedure assumes you have used the **Analysis Definition** dialog box to create a loadcell lock, and either run a force balance analysis, or saved the results of a previous analysis.

1. Select **Mechanism > Measures** or click \(\text{\[Measure Results\]}\). The **Measure Results** dialog box appears.

2. Click \(\text{\[Measure Definition\]}\). The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Loadcell Reaction** under **Type**, and click **OK** to return to the **Measure Results** dialog box.

5. If there is no result set in the list, click \(\text{\[Result Set\]}\) and browse to find one.

6. Select the result set(s) you want, and click **OK**.

7. Select a result set from the list, and select the loadcell reaction measure. The magnitude of the force is displayed under **Value**.
To Create Loadcell Locks

This procedure assumes you are on the Analysis Definition dialog box, and have selected Force Balance under Type.

1. Click and select a body point or vertex where the balancing force will be applied.
2. Select a body. The software uses the LCS of this body to reference the direction vector. The point you select does not have to be on this body.
3. Define the direction vector for the force by entering X, Y, and Z components. A magenta arrow appears at the point, showing the direction of the force.
   
   Note: You may not be able to see the arrow if your model is shaded.
4. If you want to create another loadcell lock, repeat steps 1 through 3. The loadcell locks are named Loadcell Lock#, where # is a number that is incremented as each loadcell lock is added.
   
   Note: Only one loadcell lock can be active in a given analysis.

Impact Measures

An impact event measure reports whether or not contact occurs during an analysis. The contact may occur when a connection reaches its limits, or when two cams come in contact.

Mechanism Design checks for an impact event at each time interval and reports a value of 1 if an event has occurred, 0 if it has not occurred. The graph of an impact event displays a vertical line of magnitude 1 indicating that impact occurred at a given time during the analysis.

You can create impact measures for the following types of connections:

- **Joints**—Measure the impact when a joint axis contacts its limits. Before you create an impact measure, you must specify joint axis limits.
- **Cam-follower connections**—Measure the contact between two cams. Before you create an impact measure, you must enable the liftoff option when you define your cam-follower connection.
- **Slot-follower connections**—Measure the impact when a slot-follower reaches its endpoints.

To Create Impact Measures

1. Select Mechanism > Measures or click . The Measure Results dialog box appears.
2. Click . The Measure Definition dialog box appears.
3. Enter a descriptive name for your measure, or accept the default name.
4. Select Impact under Type.
5. Click \( \text{ } \) and select one of the following types of connection. Mechanism Design displays the name of the connection.
   - Joint with limits
   - Cam-follower connection with liftoff enabled
   - Slot-follower connection


7. Click \textbf{OK} to accept your definitions and return to the \textbf{Measure Results} dialog box.

8. Graph the measure.

**Impulse Measures**

An impulse measure returns the change in momentum due to a collision. This measure is a more quantitative way to track impact events.

An object’s momentum changes when a time-dependent force acts on it during a collision. The change in momentum is related to the force of collision by the following equation:

\[
\Delta \text{momentum} = \int F(t) \, dt
\]

You can create impulse measures for the following types of connections:

- **Joints**—Measure the momentum change after a joint axis contacts its limits. To measure impulse, you must specify joint axis limits and a coefficient of restitution for your joint. For each type of joint, you can measure impulse in the direction of the joint’s DOF.

- **Cam-follower connections**—Measure the momentum change after a cam-follower separates and reconnects. You must enable the liftoff option and specify a coefficient of restitution to measure impulse. You can measure the impulse for these components:
  - **Normal force**—Measure the component of the impulse in the direction perpendicular to the cam curves at the point of contact between the two cams.
  - **Tangential force**—Measure the component of the impulse that is tangential to the cam curves at the point of contact between the two cams.

- **Slot-follower connections**—Measure the momentum change after impact when a slot-follower contacts its endpoints. You must specify a coefficient of restitution to measure impulse. You can choose the starting or ending endpoints.

The coordinate system axes used in calculating impulse may or may not correspond to the WCS or any LCS in the mechanism. When you select a connection and a component to measure, a shaded, magenta arrow appears on the selected connection indicating the X or Y direction that Mechanism Design actually uses in the
calculation. Be sure to look at this direction carefully to decide whether it is actually
the direction for which you want the impulse measurement.

To Create Joint Impulse Measures

1. Select **Mechanism > Measures** or click . The **Measure Results** dialog box
   appears.

2. Click . The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Impulse** under **Type**.

5. Select **Joint** under **Connection Type** and use to select a joint on your
   model. Mechanism Design displays the name of the joint and displays the units
   for the impulse measure under **Type**.

6. Select a **Component**. The component that you can measure depends upon the
   type of joint you select. After you select a component, the first body in the
   connection is highlighted, and a shaded arrow appears indicating the direction of
   the component.
   
   o **Pin joint**—Axial Moment
   o **Slider joint**—Axial Force, Axial Moment
   o **Cylinder joint**—Axial Force, Axial Moment
   o **Planar joint**—Planar Force X, Planar Force Y, Normal Moment
   o **Bearing joint**—Axial Force

7. Select **Maximum** or **Minimum** in the **Computed at Limit** area.

8. Accept **Each Time Step** as the Evaluation Method.

9. Click **OK** to accept your definitions and return to the **Measure Results** dialog
   box.

10. Graph the measure.

To Create Cam-Follower Impulse Measures

1. Select **Mechanism > Measures** or click . The **Measure Results** dialog box
   appears.

2. Click . The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Impulse** under **Type**.
5. Select **Cam-follower** under **Connection Type** and use to select a cam-follower connection on your model. Mechanism Design displays the name of the cam-follower connection and displays the units for the impulse measure under **Type**.

6. Select one of the following **Components**. After you select a component, a shaded arrow appears indicating the normal or tangential direction.
   - Normal Force
   - Tangential Force

7. Accept **Each Time Step** as the Evaluation Method.

8. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

9. Graph the measure.

**To Create Slot-Follower Impulse Measures**

1. Select **Mechanism > Measures** or click . The Measure Results dialog box appears.

2. Click . The Measure Definition dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Impulse** under **Type**.

5. Select **Slot-follower** under **Connection Type** and use to select a slot-follower connection on your model. Mechanism Design displays the name of the slot-follower connection and displays the units for the impulse measure under **Type**.

6. Select **Start** or **End** in the **Computed at Limit** area.

7. Accept **Each Time Step** as the Evaluation Method.

8. Click **OK** to accept your definitions and return to the Measure Results dialog box.

9. Graph the measure.

**Slip Component for Cam-Follower Connections**

Use the slip component of the cam-follower reaction measure with a force balance analysis to determine whether the tangential force on a locked cam-follower connection is sufficient to make the connection move, or "slip." The connection slips when the following condition is met:

\[
\text{Tangential Force} > \text{Static Friction Coefficient \times Normal Force}
\]
The tangential force is the resultant of any components of the applied loads that are tangent to the cam-follower connection at the point of contact between the two cams. The normal force is the resultant of any components of the applied loads that are perpendicular to the cam curves at the point of contact. Applied loads can include force motors, springs, dampers, forces, torques, and gravity.

Before creating this measure you must:

- Assign a static friction coefficient to your cam-follower connection. To assign a static friction coefficient, you must enable liftoff for your cam. Be aware, however, that during the force balance analysis, the cam is not allowed to lift off.
- Define a force balance analysis with a cam-follower connection lock. You must check the Enable All Friction box on the Ext Loads tab of the Analysis Definition dialog box. Otherwise, Mechanism Design ignores the static friction coefficient and slippage always occurs.
- Run the analysis, (or restore a saved analysis).

When you select a cam slip measure and a result set on the Measure Results dialog box, the Value column indicates whether slippage occurred. If slippage occurred during the force balance analysis, the value of the measure is 1. If no slip occurred, the value is 0.

System Measures

Mechanism Design provides several standard, predefined measures that track the overall behavior of your mechanism. You can create all of the following System measures if you have a Mechanism Dynamics Option license. If you do not have a Mechanism Dynamics Option license, you can only create Degrees of Freedom, Redundancies, or Time measures.

- **Degrees of Freedom**—Measure the number of degrees of freedom (DOF) in your mechanism. In most cases, the degrees of freedom does not change during an analysis. An exception is if you are modeling cams with liftoff. In this case, the DOF changes when the cams separate, and you may wish to graph the degrees of freedom.

  **Note:** In previous releases, Mechanism Design listed Degrees of Freedom and Redundancies as default measures when you opened the Measure Results dialog box. If you created your mechanism in a previous Mechanism Design release, these default Degrees of Freedom and Redundancies measures appear in the list when you open your model in the current release, but you can now edit them or delete them from the list.

- **Redundancies**—Measure the number of redundancies your mechanism contains.
- **Time**—Measure the time at each step of the analysis.
- **Kinetic Energy**—Measure the total kinetic energy for the mechanism. The kinetic energy is a scalar sum of the kinetic energy for each body, relative to the ground body WCS.
• **Linear Momentum**—Measure the total linear momentum of the mechanism. The linear momentum is the sum over all bodies in the mechanism of the global velocity of each body’s center of mass multiplied by its mass.

• **Angular Momentum**—Measure the total angular momentum of the mechanism. The angular momentum is the sum over all bodies in the mechanism of the inertial angular momentum for each body. For each body, this is the product of the moment of inertia at the center of mass times the angular velocity of the body. Mechanism Design reports the system angular momentum relative to the ground body WCS.

• **Total Mass**—Measure the sum of the masses for all bodies, including the ground body, in your mechanism.

• **Center of Mass**—Measure the distance to the center of mass of the mechanism relative to the ground body WCS.

• **Total Centroidal Inertia**—Measure the total centroidal inertia of the mechanism relative to the center of mass of the mechanism. Mechanism Design calculates the centroidal inertia by regarding all bodies, including the ground body, in the mechanism as a single body with the same mass distribution as the mechanism. Mechanism Design then computes the inertial properties of this single body with respect to the mass center of this body, which is the system mass center.

**To Create System Measures**

1. Select **Mechanism > Measures** or click ![Measures](image). The **Measure Results** dialog box appears.

2. Click ![Add Measure](image). The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **System** under **Type**.

5. Select a **Property** from the drop-down list. Mechanism Design displays the units for the property under **Type**, and lists any components you can measure for that property. Click one of the following links for information:
   - **Degrees of Freedom**
   - **Redundancies**
   - **Time**
   - **Kinetic Energy**
   - **Linear Momentum**
   - **Angular Momentum**
   - **Total Mass**
   - **Center of Mass**
Mechanism Design Extension

- **Total Centroidal Inertia**

6. If necessary, select a component to measure, and a frame of reference to express the measure.

7. Select one of these **Evaluation Methods** for **Kinetic Energy**, **Linear Momentum**, **Angular Momentum**, **Center of Mass**, or **Centroidal Inertia** measures:
   - **Each Time Step**
   - **Maximum**
   - **Minimum**
   - **Integral**
   - **Average**
   - **Root Mean Square**
   - **At Time**

8. If you select **At Time**, enter a real-number value greater than zero in the **Time** entry box.

9. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

10. Graph the measure.

### Body Measures

Mechanism Design provides several predefined measures that allow you to measure the behavior of a selected body in your mechanism. You can create all of the following types of body measures if you have a Mechanism Dynamics Option license. If you do not have a Mechanism Dynamics Option license, you can only create **Orientation**, **Angular Velocity**, or **Angular Acceleration**.

- **Orientation**—Measure the orientation of the body LCS with respect to a selected coordinate system.

- **Angular Velocity**—Measure the absolute angular velocity of the body with respect to a selected coordinate system.

- **Angular Acceleration**—Measure the absolute angular acceleration of the body with respect to a selected coordinate system.

- **Mass**—Measure the total mass of the body.

- **Weight**—Measure the total weight of the body. Mechanism Design calculates the weight as the product of the mass and the defined gravity. You must enable gravity for your analysis to measure body weight.

- **Center of Mass**—Measure the location of the body's center of mass with respect to a selected coordinate system.
• **Centroidal Inertia**—Measure the inertia about the body’s center of mass.

**Components for Body Angular Velocity, Angular Acceleration, and Center of Mass Measures**

You can measure one of these components for body angular velocity, angular acceleration, and center of mass measures:

• **Mag**—the magnitude of the angular velocity, angular acceleration, or center of mass location

• **X**—the component of the angular velocity, angular acceleration, or center of mass location in the X direction of the selected coordinate system

• **Y**—the component of the angular velocity, angular acceleration, or center of mass location in the Y direction of the selected coordinate system

• **Z**—the component of the angular velocity, angular acceleration, or center of mass location in the Z direction of the selected coordinate system

The default coordinate system is the ground body WCS. You may also select a coordinate system on another body in the mechanism.

**Components for Body Orientation Measures**

The body **Orientation** measure reports the orientation of the body LCS with respect to a selected reference coordinate system. You can measure one of three Euler rotation angles. Mechanism Design defines the rotations in this order:

• Rotation **1** around the X axis of the reference coordinate system

• Rotation **2** around the new Y axis

• Rotation **3** around the new Z axis

The default coordinate system is the ground body WCS. You may also select a coordinate system on any body.

**Components for Body Centroidal Inertia Measures**

The body **Centroidal Inertia** measure reports the centroidal inertia of the body with respect to a selected frame of reference, and as expressed in a selected coordinate system. When you create a centroidal inertia measure, you must specify the following options:

• **Components**
  
  o **Ixx**—the component aligned with the X axis in the selected coordinate system
  
  o **Iyy**—the component aligned with the Y axis in the selected coordinate system
  
  o **Izz**—the component aligned with the Z axis in the selected coordinate system
  
  o **Ixy**—the component in the XY plane of the selected coordinate system
Mechanism Design Extension

- **Ixz**—the component in the XZ plane of the selected coordinate system
- **Iyz**—the component in the YZ plane of the selected coordinate system

**Reference**
- **COM**—Mechanism Design calculates the centroidal inertia at the body’s center of mass.
- **LCS Origin**—Mechanism Design calculates the centroidal inertia at the selected body’s local coordinate system.

**Coordinate System**—Accept the default, which is the ground body WCS, or select a coordinate system on another body in the mechanism. Mechanism Design expresses the centroidal inertia values in the selected coordinate system.

**To Create Body Measures**

1. Select **Mechanism > Measures** or click . The **Measure Results** dialog box appears.

2. Click . The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Body** under **Type** and use to select a body.

5. Select one of the options from the drop-down list under **Property**. Mechanism Design displays the units for the property under **Type**, and lists any components you can measure for that property. Click on the links for more information:
   - **Orientation**
   - **Angular Velocity**
   - **Angular Acceleration**
   - **Mass**
   - **Weight**
   - **Center of Mass**
   - **Centroidal Inertia**

6. If necessary, select a component to measure, and a frame of reference to express the measure.

7. If you selected **Orientation**, **Angular Velocity**, **Angular Acceleration**, or **Centroidal Inertia**, select one of these **Evaluation Methods**:  
   - **Each Time Step**
   - **Maximum**
   - **Minimum**
8. If you select *At Time*, enter a real-number value greater than zero in the *Time* entry box.

9. Graph the measure.

10. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

### Separation Measures

A separation measure reports values based on the separation between two points or vertices you select on your mechanism. You can create separation measures of the following types:

- **Distance**—Measure the absolute value of the distance between two selected points in the mechanism.

- **Speed**—Measure the rate of change of the separation distance. This value is positive when the points are moving away from each other, and negative when moving toward each other.

- **Change in Speed**—Measure the rate of change of the separation speed.

### Components for System Linear Momentum, Angular Momentum, and Center of Mass Measures

You can measure one of these components for system linear momentum, angular momentum, or center of mass measures:

- **Mag**—the magnitude of the linear momentum, angular momentum, or center of mass location

- **X**—the component of the linear momentum, angular momentum, or center of mass in the X direction of the selected coordinate system

- **Y**—the component of the linear momentum, angular momentum, or center of mass in the Y direction of the selected coordinate system

- **Z**—the component of the linear momentum, angular momentum, or center of mass in the Z direction of the selected coordinate system

Mechanism Design reports the measures relative to the ground body WCS.

### Components for System Centroidal Inertia Measures

When you create a total centroidal inertia measure, you must specify the following options. Mechanism Design expresses all components in the WCS coordinate system.

- **Components**
o $I_{xx}$—the component aligned with the X axis in the ground body WCS
o $I_{yy}$—the component aligned with the Y axis in the ground body WCS
o $I_{zz}$—the component aligned with the Z axis in the ground body WCS
o $I_{xy}$—the component in the XY plane of the ground body WCS
o $I_{xz}$—the component in the XZ plane of the ground body WCS
o $I_{yz}$—the component in the YZ plane of the ground body WCS

o Reference
  o WCS Origin—Mechanism Design calculates the centroidal inertia at the origin of the ground body WCS.
  o COM—Mechanism Design calculates the centroidal inertia at the mechanism's center of mass.

To Create Separation Measures

1. Select Mechanism > Measures or click . The Measure Results dialog box appears.
2. Click . The Measure Definition dialog box appears.
3. Enter a descriptive name for your measure, or accept the default name.
4. Select Separation from the Type drop-down list.
5. Click and use the normal selection methods to select two datum points or vertices on your mechanism.
6. Select a Separation Type from the drop-down list:
   o Distance
   o Speed
   o Change in Speed
7. Select one of these Evaluation Methods:
   o Each Time Step
   o Maximum
   o Minimum
   o Integral
   o Average
   o Root Mean Square
   o At Time
8. If you select **At Time**, enter a real-number value greater than or equal to zero in the **Time** entry box.

9. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

10. Graph the measure.

**Cam Measures**

Use cam measures to obtain information on the individual cams in a cam-follower connection. When you create your cam measure, you must select one of the cams in the connection.

**Note:** You can also measure reaction forces and momentum changes at a cam-follower connection.

You can measure these components for cams:

- **Curvature**—Measures the curvature (1/radius) at the point of contact for the specified cam surface. This measure is positive when the center of curvature lies toward the interior of the cam, and negative when the center is toward the exterior. A flat cam surface has a curvature of zero.

  **Note:** When you produce a graph for a cam measure—curvature, pressure angle, or slip velocity—be aware that the graph value goes to zero if your cams separate during the analysis. This is possible only for cams with liftoff. To decide whether the zero value on a graph of a curvature measure is due to a flat portion of the cam or due to cam liftoff, run the analysis with liftoff disabled.

- **Pressure Angle**—Measures the angle in degrees between the normal on the specified cam and the velocity vector at the contact point. Enter a value between 0 and +90°. A high pressure angle may indicate that the cam will jam or experience excessive wear.

- **Slip Velocity**—Measures the tangential velocity of the contact points on the selected cam surface relative to the contact point on the second cam. Cam 1 and Cam 2 have velocities of equal magnitude and opposite direction. Slip Velocity measures indicate the relative direction of the slip by expressing the velocity as a negative or positive number relative to the positive tangent shown when you create the **Slip Velocity** measure.

**To Create Cam Measures**

1. Select **Mechanism > Measures** or click 📊. The **Measure Results** dialog box appears.

2. Click 📊. The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **Cam** from the **Type** drop-down list.
5. Click and select a cam-follower connection on your mechanism. Mechanism Design displays the name of the cam-follower connection.

6. Select a Property from the drop-down list. Mechanism Design displays the appropriate units for the property in the Type area.
   - Curvature
   - Pressure Angle
   - Slip Velocity

7. Select Cam 1 or Cam 2 from the Cam drop-down list. Mechanism Design highlights the selected cam geometry.

8. Select one of these Evaluation Methods from the drop-down list:
   - Each Time Step
   - Maximum
   - Minimum
   - Integral
   - Average
   - Root Mean Square
   - At Time

9. If you select At Time, enter a real-number value greater than zero in the Time entry box.

10. Click OK to accept your definitions and return to the Measure Results dialog box.

11. Graph the measure.

**User Defined Measures**

You can create a customized measure by defining an expression including Pro/ENGINEER parameters, constants, and existing standard or user-defined measures. Create a user-defined measure when you want Mechanism Design to measure values that cannot be easily calculated through the standard measures. Mechanism Design provides a library of arithmetical operators and mathematical functions that you can use to define your expression. You can create your expression as a function of one or more variables including time and measures.

**Note:** You cannot include a Pro/ENGINEER analysis feature in a user-defined measure expression.

For example, suppose you want to calculate the area of a circle whose diameter is defined by the separation between two points on your model. First create the distance separation measure, sep_point. Then define an expression for the user-defined measure, as:
\[ \pi \times (0.5 \times \text{sep\_point})^2 \]

This expression uses the multiplication operator, \( \times \), the exponentiation operator, \( ^\)\), and the constant \( \pi \), as well as the separation measure that you defined.

**Note:** If you initially defined the measure in a unit system different from the current one, Mechanism Design automatically recalculates the magnitude of the user-defined measure and of any other measures that you use in the expression. When you review the **Measure Definition** dialog box after a unit conversion, you can expand the **Unit Conversion Factor** area to see the values that Mechanism Design uses in recalculating the measures and parameters.

To Create Separation Measures

**To Create User-Defined Measures**

1. Select **Mechanism > Measures** or click \( \text{\textbullet} \). The **Measure Results** dialog box appears.

2. Click \( \text{\textbullet} \). The **Measure Definition** dialog box appears.

3. Enter a descriptive name for your measure, or accept the default name.

4. Select **User Defined** under **Type**.

5. Select a Quantity to specify the units for your measure.

6. Enter an expression in the entry box, or use these options to define an expression:
   - Click \( \text{\textbullet} \) to display the **Operators** dialog box.
   - Click \( \text{\textbullet} \) to display the **Constants** dialog box.
   - Click \( \text{\textbullet} \) to display the **Functions** dialog box.
   - Click \( \text{\textbullet} \) to display the **Variables** dialog box.

7. When your expression is complete, click \( \text{\textbullet} \) to display the **Expression Graph** dialog box and view a graph of your expression.

8. Select one of these **Evaluation Methods** from the drop-down list:
   - **Each Time Step**
   - **Maximum**
   - **Minimum**
   - **Integral**
   - **Average**
   - **Root Mean Square**
**Mechanism Design Extension**

- **At Time**

9. If you select **At Time**, enter a real-number value greater than zero in the **Time** entry box.

10. If you are reviewing the definition after changing the units for your model, expand the **Unit Conversion Factor** area to see the scaling factors that Mechanism Design applied to the variables in your expression.

11. Click **OK** to accept your definitions and return to the **Measure Results** dialog box.

12. Graph the measure.

**Quantity for User-Defined Measures**

Use these options on the **Measure Definition** dialog box for **User Defined** measures to tell Mechanism Design which units to apply to your measure. The table includes sample units in the Pro/ENGINEER default system, which expresses length in inches, mass in lbm, and time in seconds.

<table>
<thead>
<tr>
<th>Dimensionless (default) (none)</th>
<th>Energy (in^2 lbm/sec^2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Length (in)</td>
<td>Density (lbm/in^3)</td>
</tr>
<tr>
<td>Angle (deg)</td>
<td>Mass (lbm)</td>
</tr>
<tr>
<td>Velocity (in/sec)</td>
<td>Moment of Inertia (in^2 lbm)</td>
</tr>
<tr>
<td>Rotational Velocity (deg/sec)</td>
<td>Area (in^2)</td>
</tr>
<tr>
<td>Acceleration (in/sec^2)</td>
<td>Volume (in^3)</td>
</tr>
<tr>
<td>Rotational Acceleration (deg/sec^2)</td>
<td>Translational Stiffness (lbm/sec^2)</td>
</tr>
<tr>
<td>Force (in lbm/sec^2)</td>
<td>Rotational Stiffness (in^2 lbm/(sec^2 deg))</td>
</tr>
<tr>
<td>Torque (in^2 lbm/sec^2)</td>
<td></td>
</tr>
</tbody>
</table>

**Trace Curves**

**About Trace Curves**

Use the **Trace Curve** command to:

- record a trace curve. A trace curve graphically represents the motion of a point or vertex relative to a part in your mechanism.

- record cam synthesis curves. Cam synthesis curves graphically represent the motion of curves or edges relative to a part in your mechanism.
You must create a result set from an analysis run before you can make these curves. You can generate a trace curve or cam synthesis curves using a result set from the current session or by loading a results file from a previous session.

Mechanism Design generates trace curves and cam synthesis curves for position only.

You can use a trace curve to create the following:

- A cam profile in Mechanism Design
- A slot curve in Mechanism Design
- Solid geometry in Pro/ENGINEER

When you select the Mechanism > Trace Curve command, the Trace Curve dialog box appears.

### About the Trace Curve Dialog Box

Use the Mechanism > Trace Curve command to generate a trace curve or cam synthesis curves. When you select this command, the Trace Curve dialog box opens with the following items:

- **Paper Part**—Select a body on your assembly or subassembly to serve as the reference on which to trace the curve. If you visualize a pen tracing on paper, you can think of this part as the paper. The trace curve you generate will be a feature of the part you select as the paper part. You can access trace curves and cam synthesis curves from the model tree.

  To trace the motion of a body relative to ground, select a body that is in ground for the paper part.

- **Trace**—Select the type of curve you want to generate from the drop-down list in this area.

  - **Trace Curve**—If you select this option, use the selector arrow to select a point, vertex, or curve endpoint on your assembly. The point must be on a different body from the one you selected for the paper part. Mechanism Design uses the trajectory of this point to define the trace curve. If you visualize a pen tracing on paper, this location is like the tip of the pen.

  - **Cam Synthesis Curves**—If you select this option, use the selector arrow to select a curve or edge on your assembly. The curve must be on a different body from the one you selected for the paper part.

    Mechanism Design uses the trajectory of this curve to generate an internal and external curve for the envelope. Each resulting cam synthesis curve must define a plane.

    You can select an open curve or closed loop. You can also select multiple continuous curves or edges. Mechanism Design automatically smoothes the curves you select.

    If you select an open curve, at each time step in the motion run, Mechanism Design determines the two points on the curve that are closest
and farthest from the rotational axis. Mechanism Design generates two spline curves, one from the series of closest points, and the other from the series of farthest points.

- **2D or 3D**—Select the type of trace curve that you want to make.
  - 2D—You can only generate 2D cam synthesis curves.
  - 3D—You can edit the display of 3D trace curves.

- **Result Set**—Select a motion run result set from the list of available sets.

- Click the file selector to load a saved result set from a file on your disk. When the **Select Playback File** dialog box appears, select a result set from a previous session and click **Open**. The selected result set appears in the list of result sets on the **Trace Curve** dialog box. Select the result set you want to use for the trace curve.

- **OK**—Click to create a datum curve feature in the paper part showing the trace curve or planar cam synthesis curves for the selected result set. To save the datum curve feature, you must save the part.

- **Preview**—Click to start the analysis and generate the trace curve or cam synthesis curves.

- **Cancel**—Click to exit the **Trace Curve** dialog box.

### To Create a Trace Curve

Before creating a trace curve of the movement of a part of your mechanism, you must generate a result set from an analysis.

1. Click **Mechanism > Trace Curve** or \( \text{Mechanism Design Extension} \). The **Trace Curve** dialog box appears.
2. Under **Paper Part**, click \( \text{Paper Part} \) and use the normal selection methods to select a body as the reference for tracing the curve.
3. Under **Trace**, select **Trace Curve** or **Cam Synthesis Curves**.
4. If you select **Trace Curve**:
   a. Click \( \text{Trace Curve} \) and use the normal selection methods to select a point or vertex on another body.
   b. Under **Curve Type**, select **2D** or **3D**.
5. If you select **Cam Synthesis Curves**, select a curve or edge, or a series of continuous curves or edges, on another body.
6. Select a **Result Set** from the list of available sets. If you want to use a previously saved result set, you can click \( \text{Select Playback File} \) and select a result set from the **Select Playback File** dialog box.
7. Click **Preview** if you want to look at the trace curve or cam synthesis curves.
8. Click **OK** to create a datum curve feature in the paper body for the current trace curve.

   **Note:** If you want to save the datum curve feature, you must save the part in Mechanism Design.

**Editing 3D Trace Curves**

When you generate a 3D trace curve, the software saves a series of hidden datum points and puts them in a group with the trace curve and datum planes. Mechanism Design saves the trace curve group as a feature of the paper part.

You can access this group in Pro/ENGINEER to delete or modify the coordinates of the datum points. Select the feature that contains the points and click **Edit > Definition**. Use the dialog box that appears to edit the trace curve.

Using the **Show** tab on the Model Tree, click **Layer Tree** to change and save the display status of the trace curve layer.

For more information, search for information about layers and redefining features in the PTC Help system.

**Load Transfer to Structure**

**About Load Transfer to Structure**

After you run one of the dynamic-type analyses in Mechanism Design, you can transfer the reaction forces and moments computed for a body to use as loads in Mechanica Structure. You can transfer loads to Structure if you have a Mechanism Dynamics Option license. To transfer loads to Structure you must specify an in-session analysis, a body, the loads associated with the body, and the times during the analysis to evaluate the loads. You must also select a part, subassembly, or top-level assembly that contains the body to save the loads. The software saves the loads in a load set that you can apply to the same model in Structure. For more information, see Guidelines for Exporting Loads to Structure.

This transfer requires that you:

- run an analysis in Mechanism Design, or recover a saved analysis. You can use dynamic, force balance, or static analyses.
- define how you want to export the load set
- save the component file in Mechanism Design
- import the results as a load set in Structure

Mechanism Design includes the following loads in the transfer to Structure:

- cam, slot, gear, servo motor, and joint reaction forces
- force motor, spring, and damper loads
- loadcell lock loads
- gravitational loads
• inertial loads

• external forces and torques

When you select the **Mechanism > Use in Structure** command, the **Load Export** dialog box opens, provided you have a result available in your Mechanism Design session. Use this dialog box to specify the result set, analysis time, and component to use to create a Mechanism Design load set.

To use the transferred loads, select **Applications > Mechanica**, make sure you are working in native mode Structure, and use the **Insert > Load Transfer** command. The load set will be named **MechanismLoadSetx**, where *x* is a number. For information on importing the loads into Structure, see Mechanism Loads in the Structural and Thermal Simulation module of the PTC Help system.

**Load Export Dialog Box**

Use the items on this dialog box to define a load set based upon a dynamic-type analysis. When you select the **Mechanism > Use in Structure** command, the **Load Export** dialog box opens with the following items:

- **Result Set**—Select one of the analysis result sets you generated in the current session. You can use results from dynamic, static, or force balance analyses.

- **Body**—Select the body on your assembly that Mechanism Design uses to evaluate the loads during the selected analysis.

- **Component**—Select a part, subassembly, or assembly. Mechanism Design saves the load set as part of the component's file. You must select a component that is part of the body you selected for load evaluation.

- **Evaluate At**—Select one of the following options from the drop-down list to specify how the software will evaluate the loads you include in the transfer load set. Note that for force balance and static analyses, this area is inactive, and **End** is the default.

  o **Start** or **End**—The software displays the beginning or ending time for the analysis, and the load list displays values for all loads at that time.

  o **Time**—Enter a positive real-number value for the time in the entry box. The load list displays the load values for that time, and the model changes to the appropriate position for that analysis time.

  o **Single Load Max**—The software determines the time during the analysis when a particular load is at its maximum, and evaluates all the loads at that time. When you select this option, another drop-down list appears containing all the available loads. Select the load of interest to display the analysis time when the load value is the greatest. The load list displays the maximum value for the selected load, and the value for all other loads at the same analysis time.

  o **Max for All Loads**—The software displays the maximum value for each load in the list, regardless of when this occurs during the analysis.
Load Info — A list of the loads associated with the selected Body, with the Magnitude for each load as specified by the Evaluate At option. Check the boxes beside the loads that you want to include in the load set to transfer to Structure.

When you highlight a load, a shaded arrow appears on your model indicating the direction of action for the force, moment, velocity, or acceleration.

- **Select All** — Select all the load check boxes.
- **Deselect All** — Clear all the load check boxes.

**Load Info List**

The following types of loads are available in the Load Export dialog box when you define a load set for transfer to Structure. In most cases, the name of the load is the same as the name used to define the force or moment. There are a few exceptions to this naming protocol:

- **Joint connections** — Reaction forces and moments are listed separately, with "_Force" and "_Moment," respectively, appended to the connection name as assigned in the Component Placement dialog box. For example, if your model has two joint connections named Connection1 and Connection2, there will be four loads—Connection1_Force1, Connection1_Moment1, Connection2_Force1, and Connection2_Moment1.

- **Gravity acceleration** — The load includes gravitational acceleration and the translational component of inertial acceleration. The combined load is named Gravity_Accel in the Load Export dialog box.

- **Inertial loads** — These include the angular velocity and acceleration components of a centrifugal load, and are listed as Centrifugal1_Vel and Centrifugal1_Acc, respectively. Upon transfer to Structure, these two loads are combined into a single centrifugal load.

Be aware that Structure imposes specific naming rules on loads, constraints, boundary conditions, and other modeling entities. The rules for Structure load names are more restrictive than the Mechanism Design naming rules. Structure does not accept names longer than 32 characters, names that contain non usascii characters, names that include spaces or special characters, or names that start with a numeric character. If you transfer a load whose name violates any of these rules, the software changes the name so that it complies with the Structure naming rules.

For information on the form that Mechanism Design loads take after transfer to Structure, see How Loads Transfer to Structure.

**Guidelines for Exporting Loads to Structure**

Keep the following in mind when you create load sets to transfer to Structure:

- You can only save one load set with each component file. Part files have .prt extensions, and assembly files have .asm extensions.
• If you save a Mechanism load set in a component file a second time (in the same or a different session of Mechanism Design), the second export will overwrite the first one.

• If you create a Mechanism load set for a particular analysis, and then rerun the analysis, the software does not automatically update the values of the load set with the new analysis results. You must explicitly create the load set again.

• Each load set includes only measurable loads for a single body.

• The software uses the same units for the loads as the units of the component used to save the load set.

• You must run an analysis in the same session of Mechanism Design that you create a Mechanism load set.

• After you save a Mechanism load set with a component file, you must open that component file in Structure to access the load set. If the component is a part or subassembly that is part of a top-level assembly, you cannot open the top-level assembly and access the Mechanism load set.

• This option is not available for FEM mode Structure.

**How Loads Transfer to Structure**

This table describes the forms taken by the various loads available in Mechanism Design when you use the Load Export dialog box to create a load set for export to Structure.

<table>
<thead>
<tr>
<th>Mechanism Load</th>
<th>Exported Structure Load</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Joint connections</strong></td>
<td></td>
</tr>
<tr>
<td>Joint reaction force</td>
<td>Unassociated TLAP(^1) force at joint point location</td>
</tr>
<tr>
<td>Joint reaction moment</td>
<td>Unassociated TLAP moment at joint point location</td>
</tr>
<tr>
<td><strong>Springs and Dampers</strong></td>
<td></td>
</tr>
<tr>
<td>Point-to-point spring or damper reaction force</td>
<td>Unassociated TLAP force at attachment point</td>
</tr>
<tr>
<td>Spring or damper reaction force on translational joint axis</td>
<td>Unassociated TLAP force at center of joint axis</td>
</tr>
<tr>
<td>Spring or damper reaction force on rotational joint axis</td>
<td>Unassociated TLAP moment at center of joint axis</td>
</tr>
<tr>
<td><strong>Damper on slot-follower connection</strong></td>
<td></td>
</tr>
<tr>
<td>Combined normal and tangential reaction forces on slot damper</td>
<td>Unassociated TLAP force at slot point location</td>
</tr>
<tr>
<td><strong>Servo Motors and Force Motors</strong></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Servo or force motor reaction force and moment on translational joint axis</td>
<td>Unassociated TLAP force at intersection of zero reference plane and translation axis</td>
</tr>
<tr>
<td>Servo or force motor reaction moment on rotational joint axis</td>
<td>Unassociated TLAP moment at center of joint axis</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Cam-follower Connections</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Combined normal and tangential reaction forces at cam contact point</td>
<td>Unassociated TLAP force at cam contact point</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Slot-follower Connections</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Reaction force on slot connection</td>
<td>Unassociated TLAP force at center of slot</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Gear Pairs</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Reaction moment for standard gear pair on rotational joint axis</td>
<td>Unassociated TLAP moment at center of joint axis</td>
</tr>
<tr>
<td>Reaction force for rack and pinion gear pair on translational joint axis</td>
<td>Unassociated TLAP force at center of joint axis</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Force/Torque</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Forces applied to points</td>
<td>Unassociated TLAP force at point</td>
</tr>
<tr>
<td>Point-to-point forces</td>
<td>Unassociated TLAP force at starting point</td>
</tr>
<tr>
<td>Torques applied to bodies</td>
<td>Unassociated TLAP moment at body center of gravity</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Gravity</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Combined gravitational force and translational component of inertial acceleration</td>
<td>Gravity acceleration at body center of gravity</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Inertial Forces</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Angular velocity (as Centrifugal1_Vel)</td>
<td>Combined centrifugal load with velocity and acceleration components</td>
</tr>
<tr>
<td>Angular acceleration (as Centrifugal1_Acc)</td>
<td></td>
</tr>
<tr>
<td>TLAP = Total Load at Point</td>
<td></td>
</tr>
</tbody>
</table>
To Export Loads to Structure

This procedure assumes you have an assembly open in Mechanism Design, and you have run an analysis.

1. Select **Mechanism > Use in Structure** or 
   The **Load Export** dialog box appears.

2. Select a result set from the **Result Set** drop-down list.

3. Click in the **Body** area and use the normal selection methods to select a body on your model. Mechanism Design displays the body name and lists all available loads for this body and result set in the **Load Info** area.

4. Click in the **Component** area and use the normal selection methods to pick a part or subassembly on your model or in the Model Tree. The software displays the component name.

5. Select one of the following methods in the **Evaluate At** area:
   - **Time**—Enter a real-number value for the analysis time.
   - **Start**—The software displays the analysis start time.
   - **End**—The software displays the analysis end time.
   - **Single Max Load**—Select a load from the drop-down list for which you want the maximum. The software displays the analysis time at which that maximum occurred.
   - **Max for All Loads**—The software displays the maximum values for all loads.

6. If you do not want to include a listed load in the transferred load set, clear the check box beside the load in the **Load Info** list. All loads are selected by default.

7. Click **OK** to accept your load set definition and close the dialog box.

8. Select **File > Save** to save the model before you leave Mechanism Design.

**Example: Load Transfer for Cam Assembly**

The figure below shows a playback of a dynamic analysis of a cam-follower assembly. The shaded arrows represent the magnitude and direction of measures created for the analysis. The double-headed magenta arrow represents the net load on the servo motor, and the cyan arrow the normal force exerted on the cam.
When you create the load set to transfer to Structure, the dialog box lists several loads, including forces on the pin joint, and gravity. For this example, only the cam load and the servo motor load were selected. The cam load includes both normal and tangential forces on the cam, but in this analysis, the tangential force is zero.

The figure below shows the cam part opened in Structure. When the Mechanism loads are imported, the software creates two datum points to apply the loads. The datum point for the cam load is created at the contact point between the two cams at the selected time. The datum point for the servo motor is created at the zero point for the servo motor. After the loads are imported, the software displays icons on the part showing the direction and magnitude of the imported loads.

**Graphing**

**About Graphing**

Use the Graphtool window to display plots of measure results and the functions that define motor and force profiles. After you display your graph, you can interact with it...
in several ways. To find out the x and y values for any graph point, click on the point and a dialog box appears showing the values. To work with the graph and manage its appearance, use toolbar buttons or the following menu commands:

- **File**
  - **Export Excel**—This option is available on Windows only. Use it to save the graph data as a Microsoft Excel spreadsheet. When you click this command, Mechanism Design displays the **Export To Excel** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a .xlc extension. The file contains a pictorial rendition of the graph as well as a numeric table of graph values.
  - **Export Text**—Save the graph data as a text file. When you click this command, Mechanism Design displays the **Export To Text** dialog box. Enter a path and a file name on the dialog box. When you click **OK**, Mechanism Design creates a file with a .grt extension.
  - **Print**—Send your graph to a printer. When you click this command, a dialog box appears that allows you to output your graph to several print and graphic formats, or save it as a file.
  - **Exit**—Close the **Graphtool** window.

- **View**
  - **Toggle Grid**—Display grid lines for your graph or turn them off.
  - **Repaint**—Refresh the view of your graph.
  - **Refit**—Restore a graph to its original state. Use this command after you zoom in on a particular graph segment to return to an unsegmented state. Mechanism Design automatically redraws the complete graph in the current window.
  - **Zoom In**—Zoom in on the graph to get a close-up view. This command is especially useful when your graph contains too many points, 100 or more. Zooming in on a section of the graph helps you to display a specific segment of interest.

- **Format**
  - **Graph**—Open the **Graph Window Options** dialog box to manage your graph and its display window.

**Segmenting a Graph**

When your graph has too many points and looks crowded, you can segment it to display a specific section of interest. Segmenting a graph is especially useful when your graph contains 100 or more points. You can use one of the following methods to segment your graph:
• **Zoom In**—Use the **View > Zoom In** command, or click on the graphtool window to get a close-up view of a specific graph segment you select. Select the command, then click and drag a box around the area you want to zoom in on.

• **Change the Axis Range**—Change minimum and maximum values for the graph range to define a segment you want to display. The x minimum should display the x coordinate, that is, at the left edge of the graph segment, the x maximum at the right edge, the y maximum at the top edge, and the y minimum at the bottom edge. Mechanism Design then redraws the graph to show the specified segment.

After you finish studying a particular graph segment, you can restore a graph to its original, unsegmented state. Use the **View > Refit** command, or click . After you select the command, Mechanism Design redraws the full graph in the current window.

### Managing Graphs

When you click the **Format > Graph** command, Mechanism Design displays the **Graph Window Options** dialog box. You can also access this dialog box by clicking , or by right-clicking any item, such as a legend or axis, in the graph display and selecting **Format** from the pop-up menu.

Use the **Graph Window Options** dialog box to define the visual characteristics of the graph display window. For example, you can change the background color of the window or the color of the X and Y axes to improve the overall appearance of your graph. You can also specify new axis labels or adjust the scale for the graph to have a better view. The data form contains the following tabs:

• **Y Axis**—Use to modify the appearance of the graph’s Y axis, its label and grid lines, and to change the scale for the graph.

• **X Axis**—Use to modify the appearance of the graph’s X axis, its label and grid lines, and to change the scale for the graph.

• **Data Series**—Use to control the appearance of data series for the graph you select and to turn the legend on or off.

• **Graph Display**—Use to control the display of the graph’s title and to change the background color of the window.

### X Axis and Y Axis Tabs

Use the **X Axis** and the **Y Axis** tabs on the **Graph Window Options** dialog box to customize the appearance of the X and Y axes, specify new axis labels, and adjust the scale for the graph. The tabs display the following fields:

• **Graph**—This field appears on the **Y Axis** tab only and displays a list of subgraphs when they are available. Mechanism Design uses subgraphs to plot multiple sets of data that share a common X axis but have different Y axes. From the list, select a subgraph for which you want to customize the Y axis.
Mechanism Design Extension

- **Axis Label**—Use the input field to edit an axis label. The label is a textual line that appears next to each axis. You can change the style, color, and size of the label's font by clicking the **Text Style** button. Use the **Display Axis Label** check box to turn the axis label on or off.

- **Range**—Change the range of the axis. You can use this area to modify minimum and maximum values so that the window displays a specified segment of the graph.

- **Tick Marks**—Set the number of major and minor tick marks on the axis.

- **Tick Labels**—Change the alignment of value labels for the major tick marks. If you want to change the style, color, and size of the font, click the **Text Style** button.

- **Grid Lines**—Select the style for the grid lines. If you want to change their color, click the color selection button.

- **Axis**—Modify the thickness of the axis. If you want to change the axis color, click the color selection button.

- **Scaling**—Use this area to adjust the scale for your graph:
  - **Log Scale**—Change the values on the axis to a logarithmic scale. Using a logarithmic scale can provide you with additional information that you may not be able to see on a normal scale.
  - **Scale**—This field appears on the **Y Axis** tab only. You can use it to change the scale of the Y axis.

**Data Series Tab**

Use the **Data Series** tab on the **Graph Window Options** dialog box to change the appearance of data series. Mechanism Design can display multiple data series that share common X and Y axes in a single graph window. Use the following fields to work with the data series:

- **Graph**—Select a graph or subgraph whose data series you want to customize.

- **Data Series**—Use the input field to edit the label for the selected data series. To change the color of the graph's points and lines, click the color selection buttons. You can also modify the points' style and interpolation and the lines' thickness.

- **Legend**—Use this area to turn the legend on and off. If you want to change the style, color, and size of the font, click the **Text Style** button.

**Graph Display Tab**

Use the **Graph Display** tab on the **Graph Window Options** dialog box to specify the graph's title and to change the background color of the window. The following fields appear on the tab:

- **Label**—Edit the graph's label. If you want to change the style, color, and size of the title's font, click the **Text Style** button. Use the **Display Label** check box to display the title or turn the display off.
Mechanism Design Extension Help Topic Collection

- **Background Color**—Modify the background color. Click the **Edit** button to customize the blended background color. If you clear the **Blended Background** check box, click the color selection button to change the background color.

- **Selection Color**—Change the color you use to highlight points on your graph.

**Mechanism Design Tutorials**

**About the Mechanism Design Tutorials**

The Mechanism Design tutorials are meant to be used as interactive examples, providing you with first-hand knowledge of several important elements of functionality.

The first tutorial creates a slider-crank mechanism, and demonstrates making connections, creating a servo motor, running, and viewing a kinematic analysis. The second tutorial creates a four-bar linkage. In addition to the topics covered by the first tutorial, the second tutorial covers setting joint axis limits, defining time-conditional servo motors, and creating a trace curve.

The third tutorial demonstrates making a cam connection, adding springs and dampers, and running a dynamic analysis. The fourth tutorial demonstrates creating a user-defined measure, using the single-piston engine you created in the first tutorial. You must have a Mechanism Dynamics Option license to do the third and fourth tutorials.

The tutorials rely on live versions of the models, and should give you a general idea of how to use Mechanism Design to model similar problems. You can find the necessary parts for the tutorials in the Demo area of the installation CD-ROM.

For additional information, preferred techniques, and demonstrations, see the User Area on the PTC Web site (http://www.ptc.com).

**Tutorial 1: Creating a Slider-Crank Mechanism**

This tutorial shows you how to model a single piston engine as a slider-crank mechanism.

This tutorial describes how to do the following tasks:

- **1A**—Create a slider-crank mechanism using connections.
- **1B**—Identify ground and drag the mechanism.
- **1C**—Create a servo motor.
- **1D**—Create and run a kinematic analysis.
- **1E**—Save the analysis, view results, and view measures.

This tutorial assumes you have the following six parts, which are located in the Demo area of the installation CD-ROM.
• block.prt—a rectangular cover for the mechanism used as one of the ground bodies
• crank_shaft.prt—a rod used as the crank
• con_rod.prt—a long solid used as the slider of the mechanism
• end_cap.prt—a small semi-circular solid that connects the slider part to the crank
• piston_head.prt—a cylinder that connects the slider to the ground body
• base.prt—a flat solid used as the other ground body

You can view an animated simulation of the creation of the model and the way it moves.

**Example: Slider-Crank Mechanism**

The animation simulates the creation of the slider-crank model, and shows its motion during a kinematic analysis run.

To start and stop the animation, use the right mouse button, or the buttons on your browser.

---

**Tutorial 1A: Creating a Slider-Crank Mechanism Using Joint Connections**

As you follow the steps in this tutorial, keep these points in mind:

• Use normal Pro/ENGINEER selection methods to select hidden geometry and datum entities. As you move the cursor over the various entities on your model,
Mechanism Design Extension Help Topic Collection

- each selectable entity is highlighted and its name displayed in the message area. Right-click to sequentially select other entities close to the cursor location. You can also use query mode and the selection dialog box to help you select hidden entities. For information on Pro/ENGINEER selection, search the Fundamentals functional area of the PTC Help system.

- Datum planes, axes, and points are stored in layers for each of these parts. On the Model Tree, select the Show > Layer Tree command. Use the Layer Tree to control the display of these entities.

- Always select placement references from the component parts, not from the assembly.

This tutorial includes the following topics:

- Placing the first part
- Creating the first pin joint
- Creating the second pin joint
- Adding a fixed part
- Closing the loop on the slider-crank mechanism
- Adding a fixed part to ground

**Placing the First Part**

1. Create a new assembly. Assume that the units are inches.

2. Click Insert > Component > Assemble or . The Open dialog box appears.


4. Click to assemble the part at the default location. This defines the block as the ground body.

5. Click OK to accept the definition.

**Creating the First Pin Joint**

1. Click Insert > Component > Assemble. The Open dialog box appears.

2. Choose crank_shaft.prt. The Component Placement dialog box appears.

3. Select the Connect tab to display Mechanism Design joint connection definitions.

4. Under Type, accept the default connection, which is Pin (if necessary, double-click the connection type to display the option menu).

5. For Axis Alignment, choose axis A-3 on block.prt and A-1 on crank_shaft.prt.

6. For the translation constraint, select Pnt0 on both parts.

268
7. Click **OK** to accept the connection.

**Creating the Second Pin Joint**

1. Click **Insert > Component > Assemble** and choose `con_rod.prt`. The **Component Placement** dialog box appears.
2. Select the **Connect** tab.
3. Under **Type**, accept or select **Pin**.
4. Select the `A-2` axis on both `crank_shaft.prt` and `con_rod.prt`.
5. Select Pnt1 on `crank_shaft.prt` and Pnt2 on `con_rod.prt` as translation references.
6. Click **OK** to accept the connection.

**Adding a Fixed Part to the Assembly**

1. Click **Insert > Component > Assemble**, and select `end_cap.prt`. The **Component Placement** dialog box appears.
2. Select axis `A-4` on both `end_cap.prt` and `con_rod.prt`. The figure below shows the end cap beside the mechanism. (Accept the default type **Automatic**.) An **Align** constraint appears in the constraint list.
3. Select axis `A-5` on both `end_cap.prt` and `con_rod.prt`. A second **Align** constraint appears in the constraint list.
4. Select the flat surface on both `end_cap.prt` and `con_rod.prt`. A coincident mate constraint appears in the constraint list. The component is fully constrained.
5. Click **OK** to accept the orientation.
Closing the Loop on the Slider-Crank Mechanism

1. Click Insert > Component > Assemble and select piston_head.prt. The Component Placement dialog box appears.

2. Select the Connect tab.

3. Select Cylinder as the connection type. Select axis A-2 on piston_head.prt and axis A-1 on con_rod.prt.

4. Click and leave the type as Cylinder. Choose axis A-1 on both piston_head.prt and block.prt.

5. Click OK to accept the connections.

If all the connections have been correctly created, Mechanism Design will be able to assemble by completing the loop connection.

6. Click Applications > Mechanism. When the Mechanism menu appears, click Mechanism > Connect. The Connect Assembly dialog box appears.

7. Click Run on the Connect Assembly dialog box. A message box appears with information on whether the mechanism assembled successfully.

8. Click Applications > Standard to exit Mechanism Design.

Adding a Fixed Part to Ground

1. Click Insert > Component > Assemble, and select base.prt. The Component Placement dialog box appears.

2. Select the surfaces of base.prt and block.prt as shown in red in the figure below. A coincident mate constraint appears in the constraint list.

3. Click and select Align as the constraint type.

4. Select the RIGHT datum plane on both base.prt and block.prt. Enter zero for the offset when the software prompts you.

5. Click and select the FRONT datum plane on both base.prt and block.prt. An Align constraint appears in the constraint list. The placement is now fully constrained.

6. Click OK to accept the orientation.
Tutorial 1B: Identifying Ground and Dragging the Mechanism

This tutorial shows you how to enter Mechanism Design, identify the ground body in your model, and use the drag dialog box to test the movement of the mechanism. This is the second part of the first Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start, see Creating a Slider-Crank Mechanism.

1. Click **Applications > Mechanism**. Mechanism Design begins.

2. Click **View > Highlight Bodies**.

   Mechanism Design displays the ground body in green. This body remains stationary during drag and servo motor operations.

3. Click ▶️ and choose **FRONT** from the saved view list to move the model to the front orientation.
4. Click **Mechanism > Drag**, or ![icon]

5. Click ![icon] on the **Drag** dialog box and select a point on `con_rod.prt` by left-clicking. To drag the mechanism easily, choose a point near the bottom away from the center vertical axis. Without clicking the mouse again, drag the point to confirm that it moves as you expect.

6. Right-click when you are finished dragging, and click **Close** to exit the dialog box.

---

**Tutorial 1C: Creating a Servo Motor**

This tutorial shows you how to create a velocity servo motor (called a driver in previous releases). This is the third part of the first Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start, see Creating a Slider-Crank Mechanism.

1. Click **Mechanism > Servo Motors**. The **Servo Motors** dialog box appears.

2. Click **New**. The **Servo Motor Definition** dialog box appears.

3. On the **Type** tab, for the **Driven Entity**, select **Joint Axis**, and choose the pin joint connecting `crank_shaft.prt` to `block.prt` (`connection_1._axis_1`).

4. On the **Profile** tab, change the **Specification** to **Velocity**.

5. The **Magnitude** should be **Constant**. Enter the value **72** for \( A \).

6. Select the **Position** check box, clear the **Velocity** check box, and click ![icon]. The plot shows that the servo motor will go through two full rotations in 10 seconds.

7. Click **OK**.

---

**Tutorial 1D: Creating and Running a Kinematic Analysis**
This tutorial shows you how to define and run a kinematic analysis for a slider-crank mechanism. This is the fourth part of the first Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start, see Creating a Slider-Crank Mechanism.

1. Select **Mechanism > Analyses**. The **Analyses** dialog box appears.
2. Click **New**. The **Analysis Definition** dialog box appears.
3. Under **Type**, select **Kinematic**. Accept the default name, **AnalysisDefinition1**.
4. On the **Preferences** tab, accept the default values.
5. On the **Motors** tab, be sure **ServoMotor1** is listed. If it is not, click **ServoMotor1**.
6. Click **Run**. The progress of the analysis is shown at the bottom of the model window, and the model moves through the specified motion.

To view the analysis results in later sessions of Mechanism Design, you must save them as a playback file.

**Tutorial 1E: Saving and Reviewing Results**

This tutorial shows you how to save a kinematics analysis as a playback file and review the results for a slider-crank mechanism. This is the fifth part of the first Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start, see Creating a Slider-Crank Mechanism.

1. Replay results. Click **Mechanism > Playback**. The **Playbacks** dialog box appears with **AnalysisDefinition1** in the **Result Set** field.
2. Click **Start**. The **Animate** dialog box appears.
3. Click **Stop**. Click **Close** to quit.
4. On the **Playbacks** dialog box, click **Save** to save your results as a .pbk file. In the **Save Analysis Results** dialog box, accept the default name or specify another name. The default directory is the current working directory. You can also browse to find another directory to save your file. You can open the .pbk file in future sessions by clicking **Open** and selecting the playback file. Click **Close** to quit.
5. Click **Mechanism > Measures**. The **Measure Results** dialog box appears.
6. Click **Measure Definition**. The **Measure Definition** dialog box appears. Accept **measure1** as the name.
7. Under **Type**, select **Position**.
8. Select a vertex on the piston head.
9. Select **Y-component** in the **Component** area, and accept the WCS for the **Coordinate System**. Under **Evaluation Method**, accept **Each Time Step**. Mechanism Design displays a magenta arrow showing the Y direction.

10. Click **OK**.

11. On the **Measure Results** dialog box, select **measure1** under **Measures**, and **AnalysisDefinition1** under **Result Set**. (If you changed the result set name, select the appropriate name.) The **Graph Type** should be **Measure vs. Time**.

12. Click the plot of the measure. The plot should be a cosine curve.

**Tutorial 2: Creating a Four-Bar Linkage**

This tutorial describes how to do the following tasks:

- **2A**—Create a four-bar linkage.
- **2B**—Create a servo motor, apply joint zeros, and create limits.
- **2C**—Drag your mechanism and take snapshots.
- **2D**—Create and run a kinematic analysis with time-conditional servo motors.
- **2E**—View results, create and view measures, and create a trace curve.

This tutorial assumes you have the following five parts, which are located in the Demo area of the installation CD-ROM.

- **block.prt**—a rectangular solid used as one of the ground parts for the linkage
- **block2.prt**—a rectangular solid used as the other ground part for the linkage
- **crank.prt**—a rectangular solid used as the linkage crank
- **triangle_abc.prt**—a triangular solid used as one of the linkage arms
- **triangle_bde.prt**—a triangular solid used as the other linkage arm

**Tutorial 2A: Creating a Four-Bar Linkage Using Joint Connections**

This tutorial shows you how to create a four-bar linkage using Mechanism Design connections. It is the first part of the second Mechanism Design tutorial.

This tutorial is broken into the following topics:

- Placing the first part
- Creating the first pin joint
- Creating the second pin joint
- Redefining the second pin joint
- Adding a fixed part to ground, and redefining ground
- Closing the loop on the four-bar linkage
Placing the First Part
1. Create a new assembly. Accept the default template, and assume that the units are inches.
2. Click Insert > Component > Assemble. The Open dialog box appears.
4. Click and click OK to exit the dialog box. This defines the block as the ground body.

Creating the First Pin Joint
1. Click Insert > Component > Assemble.
2. Choose crank.prt. The Component Placement dialog box appears.
3. Click Connections to expand the dialog box.
4. Under Connection Type, select Pin (if necessary, double-click the default connection type to display the option menu).
5. For Axis Alignment, choose axis A-1 on block.prt and axis A-1 on crank.prt.
   Note: Datum planes, axes, and points are stored in layers for each of the parts. You will need to display the appropriate layer to see these entities.
6. For the translation constraint, select Datum3 on both parts.
7. Look at the model configuration. Crank.prt should rest on top of block.prt.
8. If the configuration is incorrect, highlight the axis alignment constraint, and click Flip, so that crank.prt rests on block.prt.
9. Select the Move tab.
10. Choose Rotate as the Motion Type.
11. Select Entity/Edge as the Motion Reference.
12. Select the A_1 axis on the crank.prt.
13. Drag the crank until it lies at about 75° relative to block.prt.
14. Click OK to accept the position and the connection.
Your model should look similar to the following graphic:
Creating the Second Pin Joint

1. Click **Insert > Component > Assemble** and choose `triangle_abc.prt`. The **Component Placement** dialog box appears.
2. Click **Connections** to expand the dialog box.
3. Under **Connection Type**, select **Pin**.
4. Select the long edge on top of `crank.prt`, which contains PNT2.
5. Select the edge on `triangle_abc.prt` that contains PNT2 and PNT3.
6. Select PNT2 on `crank.prt` and PNT2 on `triangle_abc.prt` as translation references.
7. Click **OK** to accept the connection.

Your model should look similar to the following graphic:

![Creating the Second Pin Joint](image)

Redefining the Second Pin Joint

1. Select `triangle_abc.prt`, then click **Edit > Definition**. The **Component Placement** dialog box appears.
2. Modify the translation constraint. Highlight **Translation**, and change the component reference from PNT2 to PNT3 on `triangle_abc.prt`.
3. Highlight the **Axis alignment** and click **Flip** to realign the part.
4. Select the **Move** tab.
5. Accept **View Plane** as the **Motion Reference**. Under **Motion Type**, click **Rotate**. Drag the triangle until it lies at about 90° relative to the end of the crank.

6. Click **OK** to accept the connection.

Your model should look similar to the following graphic:

![Model Diagram]

**Adding a Fixed Part to Ground**

1. Click **Insert > Component > Assemble** and select `block2.prt`. The **Component Placement** dialog box appears.

2. In the **Constraint** area, select **Align**. Be sure the **Offset** check box is selected.

3. Select `DTM1` on `block.prt` and `DTM1` on `block2.prt` as the references. Enter 4 for the offset when prompted.

4. Align `DTM2` to `DTM2`, and `DTM3` to `DTM3`.

5. Click **OK** to accept the orientation.

**Closing the Loop on the Four-bar Linkage**

1. Click **Insert > Component > Assemble** and select `triangle_bde.prt`. The **Component Placement** dialog box appears.

2. Click **Connections** to expand the dialog box.

3. Select **Ball** as the connection type. Select `PNT1` on `triangle_abc.prt` and `PNT3` on `triangle_bde.prt`.

4. Click under **Connections** to add a loop joint. Change the connection type from **Ball** to **Cylinder**.

5. Choose the edge defined by `PNT2` and `PNT4` on `triangle_bde.prt` as the component reference. Choose axis `A-1` on `block2.prt` as the assembly reference.

6. Click **OK** to accept the connections. If all of the connections have been correctly created, the mechanism assembles by completing the loop connection.

**Entering Mechanism and Identifying Ground**
1. Click **Applications > Mechanism**. Mechanism Design opens.

2. Click **View > Highlight Bodies**. Mechanism Design displays the ground body in green. This body is stationary during drag and servo motor operations.

3. Click **Mechanism > Drag**.

4. Pick any part and drag the mechanism to see if it moves as you expected. To place the mechanism in the dragged configuration, pick with the left mouse button.

Your model should look similar to the following graphic:

**Tutorial 2B: Creating Motors, Applying Joint Zeros, and Creating Limits**

This tutorial shows you how to create and edit servo motors for a four-bar linkage. It is the second part of the second Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start them, see Creating a Four-Bar Linkage.

1. Create a velocity servo motor. Click **Mechanism > Servo Motors**. The Servo Motors dialog box appears.

2. Click **New**. The Servo Motor Definition dialog box appears.

3. For the **Driven Entity**, select **Joint Axis**, and choose `connection_1.axis_1` (created between block.prt and crank.prt).

4. On the **Profile** tab, change the **Specification** to **Velocity**.

5. Clear the **Current** check box under **Initial Position**.

6. Change the **Magnitude** from **Constant** to **Cosine**. Enter the following values: A=100, B=0, C=0, and T=5.

7. Clear the **Velocity** check box and select the **Position** check box. Click to see a graph of the servo motor function over 10 seconds.

8. Close the graph window, Servo Motor Definition dialog box, and Servo Motors dialog box.

9. Select **Mechanism > Jt Axis Settings** to specify the zero reference. The Joint Axis Settings dialog box appears.

10. On the **Zero Refs** tab, select the joint axis with the servo motor, and select **Specify References**.

11. Select **DTM2** on crank.prt as the Orange Body Reference.

12. Select **DTM2** on block.prt as the Green Body Reference.

13. On the **Regen Value** tab, select **Specify Regeneration Value**, and enter 0 for the Regeneration Value.
14. On the **Limits** tab, select **Enable Limits** and enter 0 for **Minimum** and 180 for **Maximum**. All connection limits have to be between $-180^\circ$ and $180^\circ$. These limits are measured from the connection's current zero position.

15. Click **OK** to accept the joint axis settings.

16. Run the connection analysis by clicking **Mechanism > Connect** and then **Run**. You do not need to lock any of the bodies or connections. Mechanism Design uses the regeneration value you entered to assemble the mechanism.

---

**Tutorial 2C: Dragging and Creating Snapshots**

This tutorial shows you how to use the drag functionality to position your model and how to create snapshots. You can use snapshots as the starting point for kinematic analyses. It is the third part of the second Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start them, see Creating a Four-Bar Linkage.

1. Click **Mechanism > Drag** or click ![Drag](image). In the **Drag** dialog box, create a snapshot by clicking ![Snapshot](image). Mechanism Design includes the snapshot in the list with the default name **Snapshot1**.

2. Click ![Crank](image) and select **crank.prt** by clicking the part with the left mouse button.

3. Drag the mouse, and observe how the linkage moves. Note how the connection limits restrict the drag movement.

4. Middle-click when you are finished.

5. Drag the mechanism again, this time choosing **triangle_abc.prt**. Drag the mechanism to a new position, and right-click to accept the position. If the mechanism enters a kinematic lock-up state, you can exit this state by middle-clicking to return to the original starting configuration.

6. Create a snapshot in the new position by clicking ![Snapshot](image).

7. Review **Snapshot1** and **Snapshot2** by highlighting each name and clicking ![Snapshot](image).

8. Click **Close** to exit the **Drag** dialog box.
Tutorial 2D: Creating and Running a Kinematic Analysis

This tutorial shows you how to create and run a motion analysis for a four-bar linkage. It is the fourth part of the second Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start them, see Creating a Four-Bar Linkage.

1. Create a kinematic motion analysis. Click Mechanism > Analyses. The Analyses dialog box appears.

2. Click New. The Analysis Definition dialog box appears.

3. Under Type, select Kinematic.

4. Change the End Time to 5 seconds on the Preferences tab, and click OK to accept the analysis definition.

5. Click Run.

   Note: If your mechanism is overconstrained or incorrect, the analysis will stop. In this case, the analysis fails because a joint axis limit is reached and the servo motor is trying to force the connection beyond its limit.

   Tip: You can define the action that Mechanism Design takes when a run stops by using the Settings command.

6. Click Abort on the error message box.

7. Select the Motors tab on the Analysis Definition dialog box.

8. Select the servo motor. Change the value under To from End to 2.5.

9. Highlight ServoMotor1 in the Motor list and click to add another instance of the motor to the list.

10. Highlight the second instance of ServoMotor1. Change the value under From from Start to 2.51.

11. Rerun the motion analysis.

Tutorial 2E: Reviewing Results

This tutorial shows you how to review the results of a motion analysis for a four-bar linkage. It is the fifth and final part of the second Mechanism Design tutorial.

For information on the tutorials and the parts you need before you start them, see Creating a Four-Bar Linkage.

1. Replay results. Click Mechanism > Playback. On the Playbacks dialog box, click . The Animate dialog box appears. Click to begin. Click to stop the playback, and click Close to quit.

2. On the Interference tab of the Playbacks dialog box, select the Global Interference option, then click . The Animate dialog box appears.
3. Click to begin. Note that any interference is highlighted in red. Click Close to quit.

4. Click in the Playbacks dialog box to save your results as a .pbk file. In the Save dialog box, accept the default name or change to another name. The default directory is the current working directory. You can also browse to find another directory to save your file. You can open the .pbk file in future sessions by clicking on the Playbacks dialog box and selecting the playback file. Click Close to quit.

5. Click Analysis > Measure. The Measure dialog box appears.


8. Click Compute to calculate the current angle. The value appears under Results.

9. Click Add Feature. Accept the default name for the measure or enter a new name. Close the dialog box.

10. Click Mechanism > Measures. Highlight the angle measure and the result set from the kinematic analysis.

11. Click . When the calculation is complete, the graph window opens.

12. Click File > Export on the grahtool window to create a text file of the measure data. Enter a file name for the text file, which will be saved with the extension .grt. Close the dialog box.

13. Click Mechanism > Trace Curve. Select block.prt as the Paper Part. Use the selector arrow under Point, Vertex, or Curve Endpoint to select pnt0 on triangle_abc.prt as the trace point.

14. Make sure 2D is the Curve Type, and that Trace Curve is selected under Trace.

15. Highlight Analysis1 as the Result Set and click OK to close the dialog box. The trace curve appears on your model.
16. Expand block.prt in the Model Tree and notice the last feature is the trace curve. The trace curve is created in the paper body.

**Note:** If features are not visible in the Model Tree, select **Settings > Tree Filters**, and then select the **Features** check box on the **Model Tree Items** dialog box.

**Tutorial 3: Creating an Oscillating Cam**

This tutorial shows you how to model a cam-follower connection with a spring and damper to achieve an oscillating motion. You will run a dynamics analysis, and measure the force on the spring and damper during the analysis. You must have a Mechanism Dynamics Option license to do this tutorial.

This tutorial describes how to do the following tasks:

- **3A**—Create a cam-follower connection, a spring, and a damper.
- **3B**—Create a servo motor.
- **3C**—Create and run a dynamic analysis.
- **3D**—Create and graph measures.
- **3E**—Save the analysis and review results.

This tutorial assumes you have the following part and assembly files, which are located in the Demo area of the installation CD-ROM. The part colors correspond to those in the figure below.

- **cam_follower.asm**—an assembly comprised of a cam and a roller follower
- **base.prt**—the ground body, comprised of two parts (blue)
- **cam.prt**—a rounded, elongated solid with flat faces (purple)
- **roller.prt**—a wheel with flat faces with that serves as the second cam (green)
- **follower.prt**—a holder for the roller (brown)
- **follower.asm**—a subassembly connecting roller.prt and follower.prt with a pin joint
Tutorial 3A: Creating a Cam-Follower Connection, Spring, and Damper

This tutorial shows you how to add three modeling entities to your mechanism. This is the first part of the third Mechanism Design tutorial.

For information on the tutorials and the files you need before you start them, see Creating an Oscillating Cam.

Creating a Cam-Follower Connection

1. Click File > Open. Select cam-follower.asm.

2. Click Applications > Mechanism. Mechanism Design begins.

3. Click Mechanism > Drag or . The Drag dialog box appears.

4. Click and use the normal selection methods to select the narrow end of cam.prt. When an open circle appears on the model, move the cursor to rotate the cam. Notice that the cam's motion does not affect the position of the follower subassembly. Middle-click to stop dragging, and click Close to exit the Drag dialog box.

5. Click Mechanism > Cams. The Cam-Follower Connections dialog box appears.

6. Click New. The Cam-Follower Connection Definition dialog box appears.
7. On the **Cam1** tab, select the **Autoselect** check box. This instructs Mechanism Design to complete the selection of a set of surfaces after you select enough surfaces to define a cam.

8. Use the selector arrow in the **Surfaces/Curves** area to select the curved surface on **cam.prt**.

9. Select the **Cam2** tab.

10. Select the **Autoselect** check box.

11. Use the selector arrow to select the curved surface on **roller.prt**.

12. Click **OK** to accept the definition, and **Close** to exit the **Cam-Follower Connections** dialog box. Mechanism Design adds a cam-follower icon to your mechanism.

13. Click **Mechanism > Drag**. The **Drag** dialog box appears.

14. Click **and rotate cam.prt**. Note that the motion of the follower subassembly is now linked to the motion of the cam.

**Creating a Spring**

There is a cylinder joint connecting **follower.prt** to the top portion of **base.prt**. In the following sections you add a point-to-point spring and a point-to-point damper between the follower and the base.

1. Click **Mechanism > Springs** or **. The **Springs** dialog box appears.

2. Click **New**. The **Spring Definition** dialog box appears.

3. Select **Point-to-Point** under **Reference Type**, and use the selector arrow to select **BASE_PNT0** on **base.prt** and **FOLLOWER_PNT** on **follower.prt**.

4. In the **Properties** area enter 100 for **k**, the spring stiffness constant, and 60 for **U**, the unstretched spring length.

5. Clear the **Default** check box and enter 15 in the **Icon Diameter** area.

6. Click **OK** to accept the definition, and **Close** to exit the **Springs** dialog box. Mechanism Design adds a spring icon to your mechanism.

**Creating a Damper**

1. Click **Mechanism > Dampers** or **. The **Dampers** dialog box appears.

2. Click **New**. The **Damper Definition** dialog box appears.

3. Select **Point-to-Point** in the **Reference Type** area, and use the selector arrow to select **BASE_PNT0** on **base.prt** and **FOLLOWER_PNT** on **follower.prt**.

4. Enter 100 for **C**, the damping coefficient, in the **Properties** area.

5. Click **OK** to accept the definition, and **Close** to exit the **Dampers** dialog box. Mechanism Design adds a damper icon to your mechanism.
Tutorial 3B: Creating a Servo Motor

This tutorial shows you how to add a servo motor to your mechanism. This is the second part of the third Mechanism Design tutorial.

For information on the tutorials and the files you need before you start them, see Creating an Oscillating Cam.

1. On the Model Tree, under Connections > Joints, expand Joint_2 (cam-follower) by clicking the plus sign (see figure below). Highlight Rotation Axis, right-click, and select Servo Motor. The Servo Motor Definition dialog box appears. On the Type tab, for the Driven Entity, the joint axis you selected is listed.

2. On the Profile tab, under Specification, select Velocity.

3. Accept the default Magnitude, which is Constant. Enter the value 72 for A.

4. Select the Position check box and click to see a graph plotting position versus time for your servo motor.

5. Close the graph and click OK to accept your servo motor definition.
Tutorial 3C: Creating and Running a Dynamic Analysis

This tutorial shows you how to create and run a dynamic analysis for your mechanism. This is the third part of the third Mechanism Design tutorial.

For information on the tutorials and the files you need before you start them, see Creating an Oscillating Cam.
1. Click Mechanism > Analyses. The Analyses dialog box appears.
2. Click New. The Analysis Definition dialog box appears.
3. Under Name, enter Dynamic Oscillation. Under Type, select Dynamic.
4. On the Preferences tab, accept the default values.
5. On the Motors tab, be sure ServoMotor1 is listed. If it is not, click .
6. Click Run. The model moves through the specified motion, Mechanism Design displays the progress of the analysis and the time elapsed at the bottom of the model window.

   Tip: If you do not see the model move as the analysis runs, click Edit > Settings. In the Run Preferences area of the Settings dialog box, be sure the Graphical display during run check box is selected.

To view the analysis results in later sessions of Mechanism Design, you must save them as a playback file. You will do this in part 3E of this tutorial.

Tutorial 3D: Creating and Graphing Measures
This tutorial shows you how to create and graph measures results for your dynamic analysis. You will create five measures. This is the fourth part of the third Mechanism Design tutorial.

For information on the tutorials and the files you need before you start them, see Creating an Oscillating Cam.

1. Click **Mechanism > Measures**. The **Measure Results** dialog box appears. Note that **Dynamic Oscillations** is listed under **Result Set**.

2. Accept **Measure vs. Time** as the **Graph Type**.

3. Click . The **Measure Definition** dialog box appears.

4. Enter **Follower Position** under **Name**, and select **Position** under **Type**.

5. Use the selector arrow to select **FOLLOWER_PNT** on **follower.prt**. Accept the WCS as the **Coordinate System**.

6. Select **Y-component** under **Component**, and **Each Time Step** under **Evaluation Method**. A shaded arrow appears with its tip on the selected point showing the Y direction.

7. Click **OK** to accept the definition and return to the **Measure Results** dialog box.

8. On the **Measure Results** dialog box, select **Follower Position** in the **Measures** list and make a copy by clicking . Select **copy of Follower Position**, and click to edit the definition. The **Measure Definition** dialog box appears.

9. Change the **Name** entry to **Follower Velocity**, and select **Velocity** for the **Type**.

10. Click **OK** to accept the definition.

11. On the **Measure Results** dialog box, select **Follower Position** in the **Measures** list and click to make a copy. Select **copy of Follower Position**, and click .

12. On the **Measure Definition** dialog box, change the **Name** entry to **Follower Acceleration**, and select **Acceleration** for the **Type**.

13. Click **OK** to accept the definition and return to the **Measure Results** dialog box.

14. Click .

15. On the **Measure Definition** dialog box, enter **Spring Load** under **Name**, and select **Load Reaction** under **Type**. Use the selector arrow to select the spring on your mechanism, and accept **Each Time Step** as the **Evaluation Method**.

16. Click **OK** to accept the definition and return to the **Measure Results** dialog box.

17. Use Steps 14–16 as a guide to create a load reaction measure on the damper. Name the measure **Damper Load**.
18. Create a load reaction measure on the servo motor. Name the measure Servo Load.

19. On the Measure Results dialog box, select Follower Position, Follower Velocity, and Follower Acceleration under Measures. Select Dynamic Oscillation under Result Set. Click to see a graph that compares the three measures.

**Tutorial 3E: Saving and Reviewing Results**

This tutorial shows you how to save a dynamics analysis as a playback file and review the results. You must save your analysis results as a playback file if you want to review them in future sessions of Mechanism Design. This is the fifth and final part of the third Mechanism Design tutorial.

For information on the tutorials and the files you need before you start them, see Creating an Oscillating Cam.

1. Replay results. Click Mechanism > Playback. The Playbacks dialog box appears, with Dynamic Oscillations listed under Result Set.

2. Click . The Animate dialog box appears.

3. Click to begin the animation. Click Close to quit.

4. On the Playbacks dialog box, click to save the result set to a file. Accept the default name, which is based on the analysis name, or change it. The default directory is the current working directory. You can accept it, or browse to find another directory to save the file. When you click OK, Mechanism Design saves the file with the extension .pbk. You can retrieve this file in future sessions by clicking on the Playbacks or Measure Results dialog box.

5. On the Display Arrows tab, select Spring Load, Damper Load, and Servo Load under Measures. Under Scale, select Force and change the value to 150%.

6. Accept the defaults on the Movie Schedule and Interference tabs.

7. Click to display the Animate dialog box, and click again to begin the analysis playback. As the dynamic analysis runs, the size of the arrows changes to reflect the size of the measures. Click here to see an example of the dynamic analysis with three display arrows.

**Tutorial 4A: Creating a User-Defined Measure**

This tutorial shows you how to create a measure that calculates the volume displacement of the piston from Tutorial 1. You must have a license for Mechanism Dynamics Option to do this tutorial.

For information on the tutorials and the parts you need before you start, see Creating a Slider-Crank Mechanism.
This tutorial is divided into four parts:

- Create a Pro/ENGINEER parameter.
- Create simple measures.
- Create user-defined measures.
- Rerun the analysis and graph the measures

### Create a Pro/ENGINEER Parameter

1. Select **Analysis > Measure**. The **Measure** dialog box appears.
2. Select **Area** under **Type** and **Surface** under **Entity**.
3. Click ![surface](image.png) and select the top surface on `piston_head.prt`. Mechanism Design displays the surface area, 3.14159, under **Results**. Make a note of the value and close the dialog box.

   **Note**: To select the top, it may be helpful to use the **Drag** dialog box to raise the piston.

4. Go to Pro/ENGINEER by selecting **Applications > Standard**.
5. Select **Tools > Parameters**. The **Relations** dialog box appears.
6. Add a row to the table by clicking ![add_row](image.png), and change the default name to **AREA_TOP**. Click **OK** to close the dialog box.
7. Close the dialog box and return to Mechanism Design by selecting **Application > Mechanism**.

### Create a Standard Measure

1. Click **Mechanism > Measures**. The **Measure Results** dialog box appears.
2. Click ![measure](image.png). The **Measure Definition** dialog box appears. Enter **length_max** as the name.
3. Under **Type**, select **Separation**.
4. Select the two points **BLOCK_TOP1** and **PISTON_TOP1**.
5. Select **Distance** under **Separation Type** and **Maximum** under **Evaluation Method**.
6. Click **OK** to return to the **Measure Results** dialog box.

### Create a User-Defined Measure

1. Click ![measure](image.png). The **Measure Definition** dialog box appears. Enter **volume_max** as the name.
2. Select **User Defined** under **Type** and **Volume** under **Quantity**. The dialog box changes to display several buttons that you use to create an expression for your measure.

3. Click **AB**. The **Constants** dialog box appears.

4. Click **+** and select **AREA_TOP** from the list of Pro/ENGINEER parameters in the **Select Parameter** dialog box. The name appears on the **Constants** dialog box. Double-click it to add it to your expression on the **Measure Definition** dialog box.

5. Click **\(\text{\textbf{lm}}\)**. The **Operators** dialog box appears. Double-click \(\times\) to add it to your expression.

6. Click **\(\text{\textbf{lm}}\)**. The **Variables** dialog box appears. Double-click **length_max** to add it to your expression.

7. Accept **Each Time Step** as the **Evaluation Method**.

8. Click **OK** to return to the **Measure Results** dialog box, and **Close** again to exit.

**Rerun the Analysis and Graph the Measures**

Because one of your measures used an evaluation method other than **Each Time Step**, you must rerun the analysis.

1. Select **Mechanism > Analyses** or \(\text{\textbf{lm}}\). The **Analyses** dialog box appears.

2. Highlight **AnalysisDefinition1** and click **Run**. When the run is complete, close the dialog box.

3. Select **Mechanism > Measures** or \(\text{\textbf{lm}}\). The **Measure Results** dialog box appears.

4. Highlight **volume_max** and **length_max** in the **Measures** list, and

\(\text{\textbf{lm}}\) **AnalysisDefinition1** in the **Result Set** list and click \(\text{\textbf{lm}}\) to open the Graphtool window with a plot of both measures. The maximum volume displacement is in the **Value** column beside **volume_max**.

**Example: Oscillating Cam**

The animation shows a wireframe representation of the cam-follower assembly as the dynamic analysis runs. The double-headed display arrow represents a load reaction measure on the servo motor. Display arrows are double-headed for rotational motion. The vertical arrow pointing up at the beginning of the animation represents the spring load reaction measure, and the vertical arrow pointing down represents the damper load reaction measure.

To start and stop the animation, use the controls on your browser, or use the right mouse button.
Index

6
6DOF connections .........................44
A
acceleration measure
  creating ..................................234
acceleration measure ....................233
analyses
  locked entities ... 170, 176, 184, 200
  validation checks ......................167
analyses ....................................164
analysis
  dialog box ...............................165
  dynamic ..................................181
  example ..................................284
  force balance ...........................198
  kinematic ................................174
  repeated assembly ....................167
  running ...... 166, 179, 188, 196, 204
  static ..................................190
analysis .....................................164
analysis definition dialog box
  external loads tab ......187, 196, 203
  motors tab . 171, 178, 185, 194, 201
preferences for dynamic analyses 183
preferences for force balance
  analyses ..................................199
preferences for repeated assembly
  analyses ..................................169, 175
preferences for static analyses ... 193
analysis definition dialog box .........165
analysis definition editing .......173, 179, 189, 197, 205
animate dialog box ......................212
B
ball joint ..................................39
bearing joint ................................39
bodies in Mechanism Design
  dragging ..................................83
  ground......................................66
  highlighting .............................68
  redefining ................................65
bodies in Mechanism Design ..........64
body measures ...................................256
C
cam measures ................................261
cam-followers
  allowing liftoff .........................70
  creating ..................................69
  deleting ..................................76
  depth .....................................74
  editing ....................................75
  friction ..................................76, 80
  impact ....................................70
  reaction force measure ..............244
  selecting curves .......................74
  selecting surfaces ......................72
  using drag ...............................75
cam-followers ................................68
coefficient of restitution ..........63, 71, 79
coefi
connections
cam-follower .............................68
slot-follower ..............................77
cam-follower .............................68
connections..................................39
constraint conversion.....................45
copying
dampers .....95, 101, 111, 114, 123, 143, 156
force motors 95, 101, 111, 114, 123, 143, 156
forces..95, 101, 111, 114, 123, 143, 156
motors.95, 101, 111, 114, 123, 143, 156
servo motors95, 101, 111, 114, 123, 143, 156
springs 95, 101, 111, 114, 123, 143, 156
torques 95, 101, 111, 114, 123, 143, 156
copying ..95, 101, 111, 114, 123, 143, 156
curves
using in cam-follower connections 74
using in slot-follower connections .79
curves.........................................74
custom loads..............................158
cylinder joint ..............................39
D
damper
creating ...................................97
definition .................................97
editing.................................98
joint axis.................................98
point-to-point .........................99
slot connection.........................99
damper ......................................96
degrees of freedom
calculating...............................51
degrees of freedom ........39, 42, 51
deleting
dampers96, 102, 111, 123, 144, 157
force motors 96, 102, 111, 123, 144, 157
forces...96, 102, 111, 123, 144, 157
motors..96, 102, 111, 123, 144, 157
servo motors96, 102, 111, 123, 144, 157
springs .96, 102, 111, 123, 144, 157
torques.96, 102, 111, 123, 144, 157
deleting...96, 102, 111, 123, 144, 157
display arrows ...........................209
DOF ............................................42
drag
creating snapshots .....................89
locking bodies.........................88
tutorial ............................. 90, 291
drag................................. 90, 291
drag dialog box
advanced options ......................86
constraints tab.........................85
initial condition
specifying joint axis position......33
joint axis initial condition ........33
snapshots tab .........................84
drag dialog box.........................83
dynamic analysis
creating .................................. 182
defining preferences ................ 182
dynamic analysis ..................... 181
dynamic measures
  evaluation methods ............. 230
types................................. 229
dynamic measures ................. 230
dynamics option in Mechanism Design ............................................. 16
E
evaluation methods .................. 230
exporting results ..................... 218
ext loads for analyses
  defining ......................... 186, 195, 202
ext loads for analyses .... 186, 195, 202
F
failed mechanism
  fixing................................. 54
failed mechanism..................... 54
finder dialog box 31, 93, 99, 109, 142, 155
force balance analysis
  creating .......................... 198
  defining preferences ............ 199
force balance analysis ........... 198, 199
force load .......................... 102
force motors
  adding ............................. 146
  defining .......................... 146
  editing ............................. 154
  graphing .... 112, 144, 157, 226, 274
  table ................................ 150
user-defined ........................ 151
force motors ........................ 145
force/torque
  creating .......................... 103
definition .......................... 102
direction ............................ 108
editing ............................... 109
graphing .... 112, 144, 157, 226, 274
magnitude ........................... 104
table .................................. 106
user-defined ......................... 106
force/torque ........................ 102
friction
  cam-follower ..................... 76, 80
  enabling for analysis .......... 188
friction ............................. 76, 80
G
gear pairs
  creating ............................. 116
  rack and pinion .................... 119
  standard .......................... 117
  using in dynamic analyses ...... 121
gear pairs ............................ 115
general connections ............... 45
geometric motors ................... 140
graph
  managing .......................... 275
  measure results ................... 223
graph .................. 112, 144, 157, 226, 274
gravity
  defining .......................... 113

295
enabling for analyses .................. 188
removing .................................. 115
gravity ........................................ 113
ground body
  defining .................................. 66
ground body ................................ 64
H
highlighting bodies .......................... 68
I
icon visibilities
  setting .................................. 26
icon visibilities .............................. 25
impact measure
  creating .................................. 250
impact measure ................................. 250
impulse measure
  cam-follower
    creating .................................. 252
joint
  creating .................................. 251
slot-follower
  creating .................................. 253
impulse measure ................................. 251
inertia .......................................... 38
initial conditions
  creating .................................. 28
definitions dialog box ...................... 27
  editing ..................................... 29
  incompatible conditions .................. 31
  joint axis .................................. 33
  specifying joint axis position in the
drag dialog box .............................. 33
tips
  using ...................................... 30
  validation checks .......................... 34
velocity ......................................... 30
initial conditions ............................... 27
interference modes for playback ....... 207
J
joint axis reaction measure ............. 236
joint axis settings
  geometric references ..................... 63
  regeneration values ....................... 61
  setting .................................... 60
  zeros ....................................... 60
  joint axis settings ........................ 58
joint axis spring ............................. 93
joint axis zeros .............................. 60
joint connections
  ball joint .................................. 42
  bearing joint ............................... 42
  cam-follower ............................... 68
  constraints required ...................... 41
  creating .................................... 40
  cylinder joint ............................... 42
  degrees of freedom ....................... 42
  example .................................... 55, 286
  overview .................................... 13
  pin joint .................................... 42
  planar ....................................... 42
  rigid and weld .............................. 42
slider joint.................................42
slot-follower ..............................77
tutorial ...................................279
joint connections...............13, 39, 42
joints ..........................................39
K
kinematic analysis
  creating ..................................174
defining preferences ..........169, 175
kinematic analysis...............174
kinematics ...................................11
L
load reaction measure
  creating ..................................247
load reaction measure ...........246
load transfer .........................267
loadcell lock
  creating ..................................249
loadcell lock ...............................249
loadcell reaction measure
  creating ..................................249
loadcell reaction measure.....199, 248
M
magnitude
  constants .........................139, 153
example ...............................130
expression definition ..........138, 152
table ........................105, 132, 149
user-defined ..............107, 133, 150
magnitude .........................128, 147
mass properties
assigning .................................37
specifying for assemblies ..........38
mass properties .......................35
measures
acceleration ..........................233
body ........................................256
cam .........................................261
cam reaction .........................244
connection reaction ..........235
cylinder connection components .239
dynamic .................................229
gear pair reaction ..............245
graphing .... 112, 144, 157, 226, 274
graphing results ......................223
impact .................................250
impulse ................................251
joint reaction .......................236
load reaction .........................246
loadcell reaction .............199, 248
pin connection components....238
planar connection components ...240
plotting results.. 112, 144, 157, 226, 274
position .................................233
separation ............................259
slider connection components ....238
system ..................................254
user-defined .............................262
velocity .................................233
viewing results .......................221
measures .................................221
mechanism
adding a connected component ....40
assembly ..................................53
creating dampers ........................97
creating force motors ...................146
creating servo motors ....................124
creating springs ..........................92
defining bodies ............................65
dragging .....................................82
mechanism ..................................40
Mechanism Design
assembling the mechanism ..........53
bodies ......................................64
capturing snapshots ...................89
changing the tolerance ...............24
commands .....................................1
constructing a snapshot ..........89
creating force motors .................146
creating servo motors ....................124
defining servo motor profiles ......126
dragging a body .........................83
dragging a mechanism ..................82
dragging a point .........................82
dynamics option .........................16
editing snapshots .......................90
exporting results .......................218
fixing a failed mechanism ...........54
graphing measure results ...........223
graphing the motor profile ...........223
graphing the servo motor profile ...223
highlighting bodies ........................68
joint axis zeros ............................58
kinematics .....................................11
measure results ............................221
motion envelope ............................214
movie schedule ................................208
moving a mechanism ........................82
playing a result set .........................207
playing back motion definitions ......205
redefining bodies ............................65
saving results ..............................211
servo motor profiles .....................127
servo motors ................................124
setting joint limits .......................62
specifying joint axis settings ...........60
toolbar buttons .............................1
understanding geometric motors ......140
Mechanism Design Kinematics
adding modeling entities .............14
preparing for analyses .................15
running analyses .........................15
saving and viewing results ...........15
summary ......................................12
Mechanism Design menu ............... 1
Mechanism Design tutorials ...... 9, 277
Mechanism Dynamics Option
adding modeling entities .............20
license ........................................ 1
preparing for analyses .................21
running analyses .........................21
saving and viewing results........22
summary ............................17
using servo motors...............20
Mechanism Dynamics Option ......16
model
  checking .........................14, 19
connections ......................13
creating ..........................12, 18
model ............................12, 14, 19
Model Summary....................6
Model Tree ..........................3
motion envelope ...................214
motors
  force ..........................145
  servo ..........................124
motors information
  defining ........................171, 177, 185, 194, 201
motors information 171, 177, 185, 194, 201
movie schedule ....................208
O
object action ........................8
P
pin joint ..........................39
planar ............................39
plane-plane rotation motor ......140
plane-plane translation motor ....140
playback
  display arrows ...................209
  exporting results ................218
interference modes...............207
movie schedule ....................208
options ............................207
results of motion run ............208
saving result set ..................211
playback ............................205
point-plane translation motor ...140
point-point translation motor ...140
point-to-point damper .............99
point-to-point spring .............93
position measure
  creating ........................234
position measure ................233
R
redundancies
  calculating ........................51
redundancies .....................51, 53
renaming
  dampers ........................96, 101, 111, 114, 123, 144, 156
  force motors 96, 101, 111, 114, 123, 144, 156
  forces ..........................96, 101, 111, 114, 123, 144, 156
  motors 96, 101, 111, 114, 123, 144, 156
  servo motors 96, 101, 111, 114, 123, 144, 156
  springs 96, 101, 111, 114, 123, 144, 156
  torques 96, 101, 111, 114, 123, 144, 156
  renaming 96, 101, 111, 114, 123, 144, 156
repeated assembly analysis
  creating ........................................... 168
  defining preferences .................. 169, 175
repeated assembly analysis .......... 167
results
  exporting ............................................ 218
  measure ............................................. 221
  playing .............................................. 211
  saving .............................................. 212
  trace curves ...................................... 265
results .................................................. 221
run preferences ................................. 23
S
separation measures ........................ 259
servo motors
  copying 95, 101, 111, 114, 123, 143, 156
  creating .............................................. 124
  defining entities ................................... 125
  defining the profile ............................... 126
  deleting 96, 102, 111, 123, 144, 157
  editing .................................................. 141
  entities .............................................. 125
  example ............................................. 284
  graphing .... 112, 144, 157, 226, 274
  magnitude............................................ 128, 147
  renaming .... 96, 101, 111, 114, 123, 144, 156
SCCA ................................................... 131
table ................................................. 105, 132, 149
user-defined ......................... 107, 133, 150
using in Mechanism Dynamics Option
  .......................................................... 20
servo motors ........................................... 124
Sine-Constant-Cosine-Acceleration
  Servo Motors ....................................... 131
slider joint ........................................... 39
slip ....................................................... 253
slot connection damper ..................... 99
slot-followers
  creating .............................................. 78
  deleting .............................................. 81
  editing ................................................. 81
  selecting curves ................................. 79
  selecting endpoints ............................. 80
  using drag .......................................... 81
  using follower points ........................... 79
slot-followers ........................................ 77
snapshot construction ...................... 89
snapshots
  capturing ............................................ 89
  copying constraints .............................. 88
  creating .............................................. 89
  creating from other snapshots ............ 89
  editing ................................................. 90
  removing ............................................. 90
  tutorial .............................................. 90, 291
use as explode states ..................... 87
using for initial conditions ............. 33
snapshots ............................................. 87
springs
  creating .............................................. 92
  definition .......................................... 91
Index

editing ........................................ 95
springs .................................... 91
static analysis
  creating ................................ 192
  defining preferences ............... 192
static analysis ........................ 190
status .................................. 33, 95, 100, 110, 143, 157
system measures ..................... 254
T
  table profile
    force motor .......................... 150
    force/torque ........................ 106
    servo motor ......................... 132
  table profile ....................... 105, 132, 149
tolerance settings
    defining ............................. 24
  tolerance settings .................. 23
torque .................................. 102
trace curve dialog box ............ 265
trace curves
  creating ................................ 266
  editing 3D ............................ 267
trace curves .......................... 265
transfer loads to Structure ........ 267
U
  U constant for springs .......... 93
user-defined measures ............ 262
user-defined profile
  force motor .......................... 151
  force/torque ........................ 106
  servo motor .......................... 137
user-defined profile ...... 107, 133, 150
V
  velocity
    specifying direction .............. 30
  velocity ............................ 30
  velocity measure
    creating .......................... 234
  velocity measure .................. 233