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Pro/PIPING (Non Specification-Driven) 

Using Pro/PIPING (Non Specification-Driven) 

About Pro/PIPING and Piping Systems (Non Spec-Driven) 

Pro/PIPING is an optional Pro/ENGINEER module. Accessed through Assembly mode, 

Pro/PIPING enables you to generate 3-D piping systems in Pro/ENGINEER 

assemblies. You can create piping systems in either the specification-driven or non 

specification-driven piping design modes. Creating a piping system involves 

establishing pipeline parameters, routing lines, and inserting fittings. 

A piping system consists of pipelines, fittings, and equipment.  

• A pipeline is composed of pipe segments and fittings. A segment of line may 

consist of one or more consecutive sections, that is, straight pieces of pipe with 

bends or miter cuts or a section of flexible tube, between breaks. The system 

creates a break whenever you create a fitted corner or insert an internal fitting in 

the pipeline. 

• A fitting is a part or assembly that you use to connect lines to other lines, fittings, 

and equipment, or to perform specific functions in the piping system (for 

example, flow valves). 

• Equipment in the working assembly (for example, a coil or a tank) is represented 

by assembly components with predefined entry ports. 

Tailoring the Pro/PIPING Working Environment 

You can tailor your Pro/PIPING work environment to your specific needs using 

various tools: 

• Using simplified representations, you can create a special version of a piping 

assembly that includes only those components that you need to route a pipeline.  

Using simplified representations can improve regeneration, retrieval, and display 

time, which allows you to work more efficiently. Simplified representations 

simplify a view by controlling which members of an assembly the system 

retrieves into a session and shows. 

The By Rule functionality enables you to exclude piping solids and fittings from a 

simplified representation by assigning a parameter and then excluding all 

components that have a particular value for that parameter.  

Although you cannot exclude assembly features, you can easily place all piping 

features on a layer by type.  

• Using top-down design tools, you can set up a well-structured design using 

advanced component creation tools containing skeleton models and copied 

geometric and datum references.  
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• Using reference control and investigation tools, you can view and manage the 

complex web of dependencies (references) that evolve as you make features in a 

design.  

• Using viewing and environment control settings, you can set different 

visualization (display) modes for components in an assembly. You can assign 

wireframe, hidden line, no hidden line, shaded, or blanked display modes to 

components. 

• The Piping System Tree provides an intuitive pipeline-level visual representation 

of a Pro/PIPING piping project. You can use show/blank and centerline/solid 

display modes, and also highlight pipelines. These display modes are accessed 

from this fully customizable piping interface. 

About Pro/PIPING Piping Design Modes (Non Spec-Driven) 

Pro/PIPING allows you to create complex piping systems based on the piping design 

mode you choose. You set the piping design mode by setting the 

piping_design_method configuration option. The following design modes are 

available: 

• Non Specification-Driven—Creates piping systems using manual tasks. All line 

stocks must be manually created and associated to a routed pipeline. All fittings 

must also be manually inserted. The Non-Specification-Driven piping design 

mode does not use project-specific data during pipe modeling. Furthermore, this 

design mode does not support design compatibility checks such as size mismatch 

detection, end type mismatch, and so on.  

• Specification-Driven—Creates piping systems based on the piping design 

method practiced by the Plant, Shipbuilding, and Aerospace design industries. 

Pro/PIPING creates specification-driven piping systems using piping specifications 

and automated modeling tasks. These tasks use archived piping data and 

project-specific data from the Specification Database. Pro/PIPING creates all line 

stocks on-the-fly and automatically associates them to the appropriate pipelines. 

All fittings are selected automatically during fitting insertion. The Specification-

Driven piping design mode supports intelligent design rule checking during 

modeling. 

• User-Driven—Enables you to switch between Non Specification-Driven and 

Specification-Driven piping modes and convert your piping assemblies at any 

time in the design process. Select or clear the Spec Driven check box on the 

PIPING menu to control the project piping design mode and convert piping 

assemblies to the selected mode. 

To Access the Non Specification-Driven Design Mode 

1. Configure Pro/PIPING for the Non Specification-Driven or User-Driven piping 

design modes. 

2. Create or open a piping assembly. 
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3. Click Applications > Piping. The PIPING menu appears. If you are using the 

User-Driven mode, clear the Spec Driven check box on the PIPING menu.  

You use the PIPING menu to design your non specification-driven piping system. 

About the Pro/PIPING User Interface 

The Pro/PIPING user interface has features that increase usability, decrease mouse 

picks, and eliminate the need to use Pro/TABLE.  

Pro/PIPING includes many dialog boxes and a Model Tree. For example, the Report 

Pipeline dialog box controls several important Pro/PIPING functions. In many of the 

dialog boxes, there is a select the active assembly option that you use first to 

orient yourself correctly before you initiate an action on the assembly. You can also 

choose an assembly with the Pro/ENGINEER menus or the Model Tree. 

The Model Tree lets you bypass traditional menu structures by right-clicking and 

accessing the shortcut menu that contains multiple Pro/PIPING functions. 

The COMPONENT menu is accessible while in Piping mode.  

The View tab in the Model Tree allows you to change views. 

Using the PIPING Menu (Non Spec-Driven) 

The PIPING menu contains the following Pro/PIPING commands: 

• Active Asm—Opens the SELECT dialog box that allows you to change the 

current active assembly. Select the active assembly from either the Model Tree, 

Piping System Tree, or the working window. The name of the currently active 

assembly appears in the graphics window.  

• Component—Opens the COMPONENT menu that allows you to manipulate 

assembly components.  

For more information on components, refer to the topics about basic assemblies 

in the Using Foundation Modules portion of Pro/ENGINEER help. 

• Pipeline—Opens the OPER PIPE LINE menu on which you can create and 

immediately route a new pipeline or delete, rename, suppress, or resume 

existing pipelines.  

• Route—Opens the SELECT menu on which you can add to or edit the path of an 

existing pipeline assembly. 

• Fitting—Opens the FITTING menu on which you can insert pipe fittings into a 

current active assembly. 

• Modify Pipe—Opens the MODIFY PIPELINE dialog box in which you can 

modify several piping options in the active assembly. 

• Modify Dim—Opens the MODIFY menu on which you can modify the active 

assembly component dimensions. 

• Regenerate—Opens the PRT TO REGEN menu on which you can update 

modified objects and assembly dimensions. 
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• Fabrication—Opens the FABRICATION menu on which you can cut pipes, 

number pipe segments, and create pipe solids and insulation. 

• Drawing—Opens the Generate Isometric dialog box in which you can use the 

Pro/PIPING drawing tool. 

• Set Up—Opens the PIPE SETUP menu on which you can set up how Pro/PIPING 

creates piping systems.  

• Info—Opens the Report Pipeline dialog box in which you can retrieve piping 

system information and save your analyses for future retrieval. 

Piping System Tree 

About the Piping System Tree (Non Spec-Driven) 

The Pro/PIPING Piping System Tree allows you to control your pipeline display. This 

tree-based interface organizes all pipelines in the active assembly and its 

subassemblies by piping system (categories) and orders pipelines according to their 

names. The ability to include all subassemblies streamlines the pipeline display 

process. This is especially important if you create pipelines based on the "one 

pipeline per assembly" modeling method.  

The Piping System Tree does the following: 

• Displays all pipelines in the top level assembly and the subassemblies below it.  

• Organizes pipelines in a collapsible and expandable hierarchy according to the 

value assigned to the piping_system_tree_format configuration option. The 

pipelines are grouped according to the MNEMONIC configuration option by default. 

This organization provides a clear and intuitive visual representation of the piping 

project that allows immediate piping system recognition and pipeline selection. 

For example, you can group and display all water pipes or all specification 12A 

pipelines. 

• Allows for efficient pipeline selection. You can quickly select pipelines and perform 

the required tasks. Note that unlike the Pro/ENGINEER Model Tree, the pipelines 

and assembly components cannot be sequentially reordered using the Piping 

System Tree. 

Viewing the Piping System Tree 

on the top menu bar allows selection between the standard Model Tree and the 

Piping System Tree with pipeline view. 

Pipeline Selection and Display Features 

The Piping System Tree provides the following dynamic pipeline selection and display 

options:  

• Pipeline—Displays or hides a pipeline. 
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• Label—Creates, deletes, displays, or hides a pipeline label. 

• Solid—Creates, deletes, displays, or hides a pipe solid. 

• Insulation—Creates, deletes, displays, or hides pipe insulation. 

• Flow—Displays and allows the reversal of the flow direction of the pipeline or 

pipe segment nodes. 

Customize the Pro/PIPING Piping System Tree 

The Piping System Tree is fully customizable. You can reorganize pipelines in multiple 

ways by setting the piping_system_tree_format configuration option. 

To Access the Piping System Tree (Non Spec-Driven) 

1. Open or create a Pro/PIPING assembly. 

2. Click Applications > Piping. The Piping System Tree opens. From the Piping 

System Tree, you can select pipelines and display modes. 

If the Piping System Tree does not open, do the following: 

o Click . The Piping System Tree opens.  

o Click Show > Expand All to expand the Piping System Tree and display all 

its components. 

Note:  

If you expand a pipeline with no components, a warning message is 

displayed. 

The sequence of components is based on the direction of flow of the 

network. 

To Select Pipelines (Non Spec-Driven) 

1. Click . The Piping System Tree opens. 

2. Select one of the following: 

o PIPING SYSTEM TREE—Selects all pipelines in the active assembly 

including those in the subassemblies. 

o Piping System (Category)—Selects all pipelines in the piping system. For 

example, if a piping system is configured for MNEMONIC and you select 

WATER, all water pipelines in the active assembly and also from the top 

assembly are selected.  

o Pipeline—Selects one pipeline. 

You can also select individual pipelines in the Pro/ENGINEER graphics 

window. 
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To Display the Pipeline Component View 

1. Click . The Piping System Tree opens. 

2. Click the plus sign (+) adjacent to the branch node or double-click the branch 

node. The branch node expands to show the pipeline components. 

3. Click a pipeline to select it in the expanded Piping System Tree. The pipeline is 

highlighted in the Pro/ENGINEER graphics window. 

To Display or Blank Pipelines (Non Spec-Driven) 

1. Click . The Piping System Tree opens. 

2. Select one or more pipelines from the Piping System Tree and right-click. A 

shortcut menu appears. 

3. Click Pipeline > Show from the menu to display the pipeline in the graphics 

window or click Pipeline > Hide to hide the pipeline in the graphics window. 

To Create or Delete Pipeline Labels from the Piping System Tree 

1. Click . The Piping System Tree opens. 

2. Select one or more pipelines from the Piping System Tree and right-click. A 

shortcut menu appears. 

3. Click Label > Create to create a label for the pipeline or click Label > Delete to 

delete the labels of the selected pipelines. 

Note: Delete is available only if a label is created for a pipeline. 

To Display or Hide Pipeline Labels 

1. Click . The Piping System Tree opens. 

2. Select one or more pipelines from the Piping System Tree and right-click. A 

shortcut menu appears. 

3. Click Label > Show to display all the labels of the selected pipeline or click 

Label > Hide to hide the labels of the selected pipelines. 

Note: Show and Hide are available for a pipeline only if a label is created for the 

pipeline. 

To Create or Delete Pipe Solids from the Piping System Tree 

1. Click . The Piping System Tree opens. 
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2. Select one or more pipelines from the Piping System Tree and right-click. A 

shortcut menu appears. 

3. Click Solid > Create on the shortcut menu to create solids for the entire pipeline 

or pipe segments or click Solid > Delete to delete the solids for the entire 

pipeline or pipe segments. 

Note: Delete is available only if the selected pipe segment nodes have solids. 

To Display or Hide Pipe Solids 

1. Click . The Piping System Tree opens. 

2. Select one or more pipelines from the Piping System Tree and right-click. A 

shortcut menu appears. 

3. Click Solid > Show on the shortcut menu to show solids for the entire pipeline or 

pipe segments or click Solid > Hide to hide solids for the entire pipeline or pipe 

segments. 

Note: Hide is available only if the selected pipe segment nodes have 

unsuppressed solids. 

To Create or Delete Pipe Insulation Quilts 

1. Click . The Piping System Tree opens. 

2. Select one or more pipelines from the Piping System Tree and right-click. A 

shortcut menu appears. 

3. Click Insulation > Create to create pipe insulation quilts for the entire pipeline.  

To delete the pipe insulation quilts for the entire pipeline, click Insulation > 

Delete. 

Note: The Insulation option is available in the Piping System Tree and in the 

graphics window only if a pipe solid has been created. 

To Display or Hide Pipe Insulation Quilts 

1. Click . The Piping System Tree opens. 

2. Select one or more pipelines from the Piping System Tree and right click. A 

shortcut menu appears. 

3. Click Insulation > Show in the shortcut menu to show pipe insulation quilts for 

the entire pipeline.  

To hide pipe insulation quilts for the entire pipeline, click Insulation > Hide. 

Note: The Insulation option is available only if the selected pipe segment nodes 

have unsuppressed pipe insulation quilts. 
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 To Display Centerlines or Solids (Non Spec-Driven) 

1. Click . The Piping System Tree opens. 

2. Select one or more pipelines and right-click. A shortcut menu appears. 

3. Click Solid > Show to display pipe centerlines for the selections. The selected 

pipelines appear. 

Piping System Tree Centerline and Solid Display Modes 

The Piping System Tree centerline and solid display modes differ from the centerline 

and solid display capabilities in Set Display and the mode set by the 

pipe_solid_centerline configuration option in the following ways: 

• The Piping System Tree centerline and solid display modes allow you to select 

one or more pipelines in the active assembly, including subassemblies. You can 

display the selected pipeline with a pipe solid or centerline. If you are creating 

pipelines based on the "one pipeline per assembly" modeling method, it is 

recommended that you use this centerline and solid display mode. 

• The Set Display centerline and solid display modes (PIPING > Set Up > Set 

Display) enables you to select only pipeline in the active assembly, but not in 

the subassemblies. You can display the selected pipeline with a pipe solid or 

centerline. 

• The mode set by the pipe_solid_centerline configuration option indicates the 

center of the pipe solid geometry with a line. This is a global setting for all 

pipelines.   

To Highlight Pipelines (Non Spec-Driven) 

1. Click Show > Highlight Model. 

2. Select pipelines from Piping System Tree. The selected pipelines are highlighted 

in the Piping System Tree and in the Pro/ENGINEER graphics window. 

3. Repeat this process to turn off the Highlight Model display mode. 

About Customizing the Piping System Tree (Non Spec-Driven) 

Customizing the Piping System Tree gives you the flexibility to display and organize 

your piping projects in the following ways: 

• Reorganize Pipelines—Reorganize pipelines in multiple ways by setting the 

piping_system_tree_format configuration option to modify categories.  

• Modify the Column Display—Display informational columns and select items to 

display in these Piping System Tree columns. 

To Reorganize Pipelines (Non Spec-Driven) 

1. Click Tools > Options. The Options dialog box opens. 
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2. In the Option box, type the piping_system_tree_format configuration option. 

3. In the Value box, type one or any combination of the following values:  

o SIZE 

o SPECIFICATION 

o MNEMONIC 

o NUMBER 

o INSULATION 

o Any ASCII characters (default is MNEMONIC).  

Delimiter characters must be enclosed by commas (,), omitting any white space. 

For example, MNEMONIC,-,SPECIFICATION groups all pipelines according to fluid 

carried and piping specification. 

To Modify the Column Display (Non Spec-Driven) 

1. Click . The Piping System Tree opens.  

2. Click Settings > Tree Columns. The Model Tree Columns dialog box opens.  

3. In the Model Tree Columns dialog box, under Not Displayed, select the items 

you want to display and click . The selected items now appear under 

Displayed.  

4. Click OK. The selected items and their respective values are displayed in the 

columns of the Piping System Tree. 

Configuring Pro/PIPING (Non Specification-Driven) 

About Configuring Pro/PIPING (Non Spec-Driven) 

You can customize the way the Non Specification-Driven piping design mode 

operates by entering config.pro configuration file options and their values in the 

Options dialog box (Tools > Options). For example, you can modify piping design 

modes, pipeline formats, file names and directory locations, and configure the 

Pro/PIPING ISOGEN interface. 

Pro/PIPING provides a list of configuration options arranged in alphabetical order. 

Each option contains the following information:  

• Configuration option name. 

• Default and available variables or values. All default values are in italics. 

• Brief description and notes describing the configuration option. 
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ISOGEN Configuration Options 

Pro/PIPING allows you to create isometric pipeline drawings by providing an 

isometric drawing generation (ISOGEN) interface. Using the Generate Isometric 

dialog box (PIPING > Drawing), you can create ISOGEN .pcf files for use with an 

ISOGEN drawing tool. The following configuration options must be set in the 

Pro/PIPING config.pro file to use the ISOGEN interface: 

• isogen_mandatory_attr_file 

• isogen_symbol_map_file  

• isogen_output_files_dir  

• isogen_nominal_size_map_file  

• isogen_pcf_filename_format 

• isogen_endtype_map_file 

Note:  

• After you set the configuration options, all settings take effect immediately in the 

current Pro/ENGINEER session. 

• The Symbol Map, Endtype Map, and Nominal Size ISOGEN Map files are required 

to map Pro/PIPING component information to ISOGEN component information. 

To Set Pro/PIPING Configuration Options (Non Spec-Driven) 

1. Locate the configuration option you want to set using the configuration topics. 

2. Click Tools > Options. The Options dialog box opens. 

3. Select the configuration option from the list or in the Option field, type the 

configuration option name. 

4. In the Value field, enter the value. You can use the Value list to see which 

values are available. If the value requires an integer, type it. 

5. Click Add / Change. The configuration option and its value appear in the list. A 

green status icon confirms the change. 

6. When you finish configuring Pro/PIPING, click Apply or OK.  

Note: It is recommended that you set the Pro/PIPING configuration options before 

starting a new piping project. 

isogen_endtype_map_file (Non Spec-Driven) 

<proe_load_directory>/text/piping_data/isodata/isogen_endtype_map.ptd,  

<absolute directory path and valid file name> 

Specify a path and name for the file that maps Pro/PIPING endtypes with ISOGEN 

endtypes. 
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isogen_mandatory_attr_file (Non Spec-Driven) 

isogen.fls, <valid file name> 

Specify a name for the file that contains ISOGEN mandatory attribute files. 

isogen_nominal_size_map_file (Non Spec-Driven) 

<proe_load_directory>/text/piping_data/isodata/isogen_nominal_size_map.
ptd, <absolute directory path and valid file name> 

Specify a path and name for the file that maps Pro/PIPING sizes with ISOGEN 

nominal sizes in millimeters and inches. 

isogen_output_files_dir (Non Spec-Driven) 

<proe_run_directory>, <absolute directory path> 

Specify a directory path for archiving the ISOGEN output files. 

isogen_pcf_filename_format (Non Spec-Driven) 

MNEMONIC-SPECIFICATION-NUMBER, <a combination of the following keywords: SIZE, 

SPECIFICATION, MNEMONIC, NUMBER, INSULATION, and any valid file name 

characters>. Delimiter characters must be enclosed by commas (,) omitting any 

white space. For example MNEMONIC,-,SIZE. 

Specify a name format for ISOGEN (.pcf) files. Pro/PIPING creates ISOGEN file 

names from the values assigned to the keywords. See the following example: 

ISOGEN File Name Format Assigned Values ISOGEN (.pcf) File 

Name 

MNEMONIC-NUMBER-
INSULATION 

WATER,1001,IS WATER-1001-IS.PCF 

SHIP1-MNEMONIC-NUMBER-
INSULATION 

WATER,1001,IS SHIP1-WATER-1001-
IS.PCF 

isogen_symbol_map_file (Non Spec-Driven) 

<proe_load_directory>/text/piping_data/isodata/isogen_symbol_map.ptd, 

<absolute directory path and valid file name> 

Specify a path and name for the file that maps Pro/PIPING fitting library part names 

with ISOGEN component names and symbol keys (SKEY). 

pipe_3D_bend_theor_int_pts (Non Spec-Driven) 

yes, no 

Set the theoretical intersections and bends in three-dimensional piping models. 
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• yes—Pro/PIPING displays theoretical intersections and bends in three-

dimensional models. 

• no—Pro/PIPING does not display theoretical intersections and bends in three-

dimensional models. 

pipe_extend_dim_scheme (Non Spec-Driven) 

cartesian, cylindrical, spherical 

Specify a dimension scheme for piping extend segment. 

pipe_pre_22_bendinfo_conv 

<user-defined directory>, <absolute directory path> 

Convert bend report information generated prior to Pro/ENGINEER 200i-2 to current 

saved analysis format. 

pipe_solid_centerline (Non Spec-Driven) 

yes, no 

Set the pipe solid centerline display mode. Pro/PIPING displays a pipe solid centerline 

in the graphics window to indicate the center of the pipe solid. After you set this 

option, the display changes immediately in the current session of Pro/ENGINEER 

• yes—Pro/PIPING displays pipe solid centerlines. 

• no—Pro/PIPING does not display pipe solid centerlines. 

Note: The pipe_solid_centerline mode differs from the centerline or solid display 

capabilities in both the Set Display and the Piping System Tree in the following 

ways: 

• The mode set by the pipe_solid_centerline configuration option indicates the 

center of the pipe solid geometry with a line. This is a global setting for all 

pipelines. 

• The Set Display centerline or solid display mode (PIPING > Set Up > Set 

Display) enables you to select pipelines in both the active assembly as well as in 

the subassemblies. You can display the selected pipeline with a pipe solid or 

centerline. 

• The Piping System Tree centerline or solid display mode allows you to select one 

or more pipelines in the active assembly, including subassemblies. You can 

display the selected pipeline with a pipe solid or centerline. Note that if you are 

creating pipelines based on the "one pipeline per assembly" modeling method, it 

is recommended that you use this centerline/solid display mode. 
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pipe_update_pre_20_int_pts (Non Spec-Driven) 

yes, no 

Pro/PIPING can update pipelines created prior to Pro/PIPING Release 20.0. This 

enables users to get intersection point entities. Pro/PIPING creates these entities in 

session (Info > Regen Info) or when you retrieve the piping model.  

• yes—Pro/PIPING updates pipelines created prior to Pro/PIPING Release 20.0. 

• no—Pro/PIPING does not update pipelines created prior to Pro/PIPING Release 

20.0. 

piping_design_method (Non Spec-Driven) 

non_spec_driven, spec_driven, user_driven 

Specify the piping design method for the piping project.  

• non_spec_drivenActivates the Non Specification-Driven piping design mode. 

• spec_drivenActivates the Specification-Driven piping design mode. 

• user_drivenActivates the User-Driven piping design mode. This mode allows 

you to switch between Specification-Driven and Non Specification-Driven piping 

design modes and convert existing assemblies at any time in the design process. 

piping_fluid_parameter (Non Spec-Driven) 

yes, no 

Specify pipeline fluid parameter availability. 

• yesPro/PIPING sets the Parameters tab in the Create Pipeline dialog box as 

available. 

• noPro/PIPING sets the Parameters tab in the Create Pipeline dialog box as 

unavailable. 

piping_system_tree_format (Non Spec-Driven) 

MNEMONIC, <one or a combination of the following keywords: SIZE, SPECIFICATION, 

MNEMONIC, NUMBER, INSULATION, and any ASCII characters>. Delimiter characters 

must be enclosed by commas (,) omitting any white space. For example 

MNEMONIC,-,SIZE.  

Specify the piping system tree format. Pro/PIPING creates piping systems or 

categories from the values assigned to the keywords. These categories organize all 

pipelines in the Piping System Tree. The following table describes the format: 

Piping System Tree 

Format 

Pipeline Values Piping System 

(Category) Name   

MNEMONIC-SPECIFICATION WATER, 11C WATER-11C 
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MNEMONIC-NUMBER-
INSULATION 

WATER, 1001, IS WATER-1001-IS 

SHIP1-MNEMONIC-NUMBER-
INSULATION 

WATER, 1001, IS SHIP1-WATER-1001-IS 

piping_wildfire_convert (Non Spec-Driven) 

automatic, never, manual 

Specify a value for this configuration option when working with piping assemblies 

that are created using versions of Pro/PIPING earlier than Wildfire. 

• automatic—Automatically converts all piping assemblies that are under the 

active top assembly when you invoke the Pro/PIPING application. 

• never—Does not convert piping assemblies. 

• manual—Displays the Piping Assemblies Conversion dialog box when you 

invoke the Pro/PIPING application. This is the default value. 

Note: A piping assembly gets modified if it is updated to the Wildfire format. 

pro_insulation_dir 

<user-defined directory>, <absolute directory path> 

Specify the directory to search for insulation files used in Pro/PIPING. 

pro_pip_fitt_dir (Non Spec-Driven) 

<user-defined directory>, <absolute directory path> 

Specify the fitting library directory path. Pro/PIPING uses this library during fitting 

insertion. 

pro_pip_lnstk_dir (Non Spec-Driven) 

<user-defined directory>, <absolute directory path> 

Specify the line stock library directory path. Pro/PIPING uses this library during 

pipeline creation. 

Non Specification-Driven Pipelines 

About Pipelines 

Pro/PIPING defines a pipeline as a set of pipe segments that can be straight or 

flexible. A piping system typically has several pipelines composed of non-branching 

chains of pipe segments. You may declare necessary pipelines in advance, and then 

select one for routing. 
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Pro/PIPING stores pipelines in an assembly as assembly features. You can route and 

modify them in subassemblies, referencing components from any level of the current 

simplified representation. Using the Component command in the PIPING menu, 

you can create and delete subassemblies using the same functionality available in 

Assembly mode.  

To define a piping system, you assign characteristics such as line stocks, pipeline 

parameters, allowable line shapes, and corner types.  

• When you assign a line stock to pipe segments, you define material, outside 

diameter, line shape and corner types, and other pipe parameters. The system 

can write line stock parameters to a file for storage in libraries.  

• Each pipeline has a set of parameters that define the pipe name, the type of fluid 

or gas to be carried, and user-defined parameters such as flow direction and 

pressure.  

The following restriction applies to the use of parameters in Pro/PIPING:  

In report relations, you cannot use piping report parameters that are longer 

than 64 characters. 

• The line shape of pipe segments varies. It can be straight (that is, rigid), flexible, 

or composed of alternating straight and flexible segments. You would typically 

use alternating segments only when you are routing a hose and need to control 

tangency for a short section, as when leaving a fitting or going through a 

bulkhead. 

• Specify a corner fitting. Corners can be fitted, mitered, or bent.  

To Create a Piping System 

1. Retrieve an assembly that contains all required components with coordinate 

systems and entry ports. You can also create an assembly that contains only 

piping.  

2. You can copy surfaces in advance and route by referencing them in a 

subassembly.  

You can either route up to previously assembled fittings or route pipelines and 

insert fittings later. 

3. Click Applications > Piping to access the Pro/PIPING module. 

4. From the PIPING menu, create or read in line stock files. 

5. Create pipelines by choosing Pipeline > Create/Route and typing a name.  

6. Choose LINE STOCK NAMES > Create. Enter a new line stock name. The 

LineStock dialog box opens. 

7. Assign a line stock. 
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8. Route pipelines and add branches between pipelines. While routing, pipeline 

segments do not have to be continuous; you can create individual segments and 

later connect them using intermediate segments, or leave them unconnected.  

9. Insert fittings. 

10. Make a solid pipe. 

11. Extract a model, if needed, to retrieve a pipeline with equipment and/or assembly 

components. 

To Delete a Pipeline (Non Spec-Driven) 

1. Click PIPING > Pipeline > Delete. 

2. Select a pipeline to delete. The CONFIRMATION menu appears. 

3. Click Confirm. The CHILD OPTS menu appears. 

4. Select one of the following menu commands: 

o Delete All—Deletes all highlighted children. The CONFIRMATION menu 

appears. Click Confirm. 

o Suspend All—Suspends all highlighted children. The children remain 

displayed in the graphics window. 

o Child Info—Displays all information about the children to be deleted or 

suspended in the INFORMATION WINDOW. 

To Rename a Pipeline (Non Spec-Driven) 

1. Click PIPING > Pipeline > Rename. 

2. Select a pipeline to rename. 

3. Enter a new name for the pipeline and click . Pro/PIPING confirms the status 

of this task in the message area. 

To Suppress a Pipeline (Non Spec-Driven) 

1. Click PIPING > Pipeline > Suppress. 

2. Select the pipeline to suppress. The CONFIRMATION menu appears. 

3. Click Confirm. Pro/PIPING suppresses the selected pipeline and all of its 

highlighted children. 

To Resume a Suppressed Pipeline (Non Spec-Driven) 

1. Click PIPING > Pipeline > Resume. The SEL MENU appears and lists all 

suppressed pipelines by name. 
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2. Select a suppressed pipeline. Pro/PIPING resumes the pipeline. You can view the 

resumed pipeline in either the Model Tree, the Piping System Tree, or the 

graphics window. 

Non Specification-Driven Piping Assemblies 

About Piping Assemblies (Non Spec-Driven) 

Pro/PIPING organizes all pipelines, fittings, and equipment for a piping system in 

assemblies and subassemblies. Pro/PIPING creates piping assemblies after you 

create pipelines. All subsequent modeling occurs within the currently active 

assembly. Pro/PIPING allows you to do the following: 

• Change active assemblies at any time in the piping design process by selecting a 

pipeline in the graphics window.  

• Convert existing piping assemblies created in one piping design mode to the 

other mode on-the-fly using the User-Driven piping design mode. 

To Make a Piping Assembly Active (Non Spec-Driven) 

You can change the currently active assembly at any time in the piping design 

process. 

1. Create or open a piping assembly. 

2. Click Applications > PIPING. The PIPING menu appears. 

3. Click PIPING > Active Asm. 

4. Select a pipeline from the graphics window. The assembly associated with the 

selected pipeline becomes the active assembly. Pro/PIPING displays the active 

assembly name in the graphics window.  

You can also select an assembly from the Model Tree or the Piping System Tree. 

About Converting Piping Assemblies (Non Spec-Driven) 

The User-Driven piping design mode allows you to convert piping assemblies at any 

time in the piping design process using the Spec Driven check box on the PIPING 

menu. You can convert existing Non Specification-Driven or Specification-Driven 

piping assemblies to the other design mode on-the-fly and continue designing your 

piping system.  

After setting the piping_design_method configuration option to the User-Driven 

mode, the following actions occur: 

• If a piping assembly is not open, Pro/PIPING defaults to the Non Specification-

Driven design mode. Select the Spec Driven check box to switch to the 

Specification-Driven design mode. 

• If an existing piping assembly is open or after you open an existing piping 

assembly, Pro/PIPING switches to the piping design mode in which the assembly 
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was created. The Spec Driven check box indicates the design mode. You can 

always convert the assembly to switch design modes. 

Assembly Conversion Processes 

Pro/PIPING executes two different piping assembly conversion processes based on 

the piping assembly type. 

Assembly Type Conversion Process 

Specification-Driven to Non 

Specification-Driven 

Clear the Spec Driven check box on the 

PIPING menu. After this process, 

Pro/PIPING considers all pipelines as Non 

Specification-Driven.  

All existing fittings will remain Specification-

Driven. 

Non Specification-Driven to 

Specification-Driven 

Select the Spec Driven check box on the 

PIPING menu. You must assign 

specification-specific data in the Convert 

Pipeline dialog box for each pipeline in the 

active assembly. After entering this data, 

the Pro/ENGINEER message area displays 

each pipeline and its conversion status. All 

pipelines must be converted to 

Specification-Driven. 

All existing fittings will remain Non 

Specification-Driven. 

Note: 

• The piping assembly conversion processes occur on a pipeline basis only. Fittings 

are not converted. 

• Mixed models are not allowed. Non Specification-Driven and Specification-Driven 

pipelines cannot be included in the same piping assembly.  

• Mixed assemblies are allowed. Non Specification-Driven and Specification-Driven 

assemblies and subassemblies can be grouped. 

• All existing line stocks are automatically deleted. The Non Specification-Driven 

mode permits different line stock assignments to each pipe segment. 

• Pipe solids failure can occur due to pipeline size changes. 

To Convert Non Specification-Driven Piping Assemblies (Non Spec-
Driven) 

You can convert Non Specification-Driven Piping assemblies to Specification-Driven 

Piping assemblies. This allows you to use existing pipe systems in the Specification-

Driven Piping design mode. 



Pro/PIPING (Non Specification-Driven) 

19 

1. Configure Pro/PIPING for the User-Driven piping design mode. 

2. Create or open a Non Specification-Driven piping assembly to convert. 

3. Click Active Asm on the PIPING menu and select a piping assembly from either 

the Piping System Tree or the graphics window.  

4. Select the Spec Driven check box on the PIPING menu. The Convert Pipeline 

dialog box opens. Pro/PIPING displays the active assembly under Active 

Assembly. 

5. If you have set the piping_schematic_driven configuration option to yes the 

Schematic Driven option will be available under Pipeline. To convert a pipeline 

using the schematic information, perform the following steps: 

a. Check the XML File option under Schematic Driven to make  active. 

b. Click  and select an XML file from the directory path specified by the 

piping_schematic_xml_dir configuration option or your current working 

directory. You can browse to any required directory to select the XML file. 

c. The Schematic Label option under Schematic Driven lists all the eligible 

pipelines for conversion, based on the information in the specified XML file. 

Select a pipeline from the eligible list.  

d. Click the Label tab. The Specification, Size, Schedule, Mnemonic, 

Number, and Insulation boxes get updated. 

e. Click the Parameters tab. The Oper. Pressure, Oper. Temperature, 

Design Pressure, and Design Temperature boxes get updated if the 

schematic information contains the respective operating and design pipeline 

parameters. 

f. Click the Defined tab. The User Defined Parameters get updated. 

Note: To convert a pipeline without the schematic information, clear the XML File 

option and perform the following steps. 

6. Select a pipeline to convert from the Select Pipeline box. If only one pipeline is 

available, Pro/PIPING displays its name beside Pipeline. 

7. Click the Label tabbed page. Under Pipeline Label, do the following: 

o Select a specification, size, and schedule for the selected pipeline. 

o If applicable, select Mnemonic, Number, and Insulation. Note that a 

pipeline number uniquely identifies a pipeline and it is needed for the Piping 

System Tree to organize pipelines (by their number) in a piping system. 

8. If applicable, enter pipeline parameter values. Select the Parameters tabbed 

page. Under Pipeline Parameters, enter the parameter values. By default, 

Pro/PIPING makes the pipeline parameters unavailable. The 

piping_fluid_parameter configuration option sets the pipeline parameter 

availability (default is no). 
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9. If applicable, enter user-defined pipeline parameters. Select the Defined tabbed 

page. Under User Defined Parameters, do one of the following: 

o Type a parameter name in the Name box (must begin with a letter) and a 

corresponding value in the Value box. Click  to add the parameter to 

the pipeline.  

o Retrieve existing user-defined pipeline parameters from a file. Click . 

The Open dialog box opens. Select the file to retrieve and double-click.  

Pro/PIPING displays the user-defined parameters.  

10. Click  to save the parameters to a file. 

11. Click  to accept all pipeline data and begin the conversion process. 

The Pro/ENGINEER message area displays the pipeline conversion status. Pro/PIPING 

generates new line stocks based on the assigned specification.  

Note:  

• You must perform this conversion process each time you switch from the Non 

Specification-Driven to the Specification-Driven design mode. 

• You must select each assembly to convert. Mixed assemblies are allowed. 

• Every pipeline in the active assembly must be converted. 

• All existing fittings remain Non Specification-Driven. 

• All existing line stocks are automatically deleted. 

• Pipe solids failure can occur due to pipeline size changes. 

To Convert Specification-Driven Piping Assemblies (Non Spec-
Driven) 

You can convert Specification-Driven Piping assemblies to Non Specification-Driven 

Piping assemblies. This allows you to use the existing pipe systems in the Non 

Specification-Driven piping design mode. 

1. Configure Pro/PIPING for the User-Driven piping design mode. 

2. Create or open a Specification-Driven piping assembly to convert. 

3. On the PIPING menu, clear the Spec Driven check box. Pro/PIPING considers 

all pipelines as Non Specification-Driven.  

Note:  

• Every pipeline in the active assembly must be converted because the Non 

Specification-Driven mode permits different line stock assignments for each pipe 

segment. 
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• All existing fittings remain Specification-Driven. So, if you convert the pipeline to 

Specification-Driven, Pro/PIPING selects and inserts all Specification-Driven 

fittings according to the pipeline specification.  

• Pipe solids failure can occur due to pipeline size changes.  

Converting Piping Assemblies to Pro/ENGINEER Wildfire Format 

When you work with piping assemblies that are created in versions of Pro/PIPING 

earlier than Pro/ENGINEER Wildfire, the piping data stored in the assembly needs to 

be updated or converted to the Wildfire format. Otherwise, you cannot check design 

rules, display flow direction, or perform automatic reorder of the piping model. If 

parameters such as STOCKNUMBER and MATERIALDATA are stored in the fitting 

component features that are created in versions of Pro/PIPING earlier than 

Pro/ENGINEER Wildfire, then these parameters must be converted to appropriate 

parameters in the Wildfire format. For example, STOCKNUMBER must be converted 

to STOCKNO and MATERIALDATA must be converted to MATERIALCODE and 

MATERIALDESC in the Wildfire format. 

When you specify automatic as a value for the piping_wildfire_convert 

configuration option, piping assemblies are automatically converted when you invoke 

the Pro/PIPING application. If you set the piping_wildfire_convert configuration 

option to manual, you can use the Piping Assemblies Conversion dialog box and 

select one of the following conversion types to convert pipeline assemblies. The 

Piping Assemblies Conversion dialog box opens when you click Applications > 

Piping. 

• Automatic—Automatically converts all the piping assemblies in the current 

Pro/PIPING session. 

• Never—Piping assemblies are not converted in the current Pro/PIPING session. 

• Manual—Selects the piping assemblies to convert from the Select Pipeline 

Assembly to Convert list. All the assembly names are selected by default. You 

can select any assembly that you want to convert from the list. 

Note: When you convert piping assemblies, the assembly revision number is 

updated automatically.  

Non Specification-Driven Parameters 

About Non Specification-Driven Parameters 

You set up non specification-driven piping by adding and modifying various 

parameters. Pro/PIPING provides the following parameters: 

• Line Stock Parameters—Enables you to modify the line stock data. 

• Pipeline Parameters—Allows you to modify pipelines. 

• Bend Parameters—Enables you to change bend tables. 

• Design Rule Parameters—Allows you to change the design rules. 
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Line Stock Parameters 

About Line Stock Parameter Files 

 

A line stock is a set of parameters that define material, grade, outside diameter, and 

other parameters of pipeline segments. Pro/PIPING stores the parameters in the line 

stock feature. Before you create a pipeline, you must define a line stock.  

You can assign different line stocks to different line segments of the same pipeline 

because they may have different outside diameters, materials, and grades. Keep in 

mind that the system determines a pipeline’s physical (solid) shape based on the line 

stock from which it actually derived the pipe.  

You can edit line stock parameters using the LineStock dialog box, and you can add 

user-defined attributes to the list. You can also read and write a line stock to a .stk. 

file. 

You can set up a library of line stocks that you can retrieve to route a particular 

pipeline. These files have the extension .stk. You can also create line stocks on the 

fly whenever you assign a new line stock to a line segment. Add the 

pro_pip_lnstk_dir line stock configuration file option to your configuration file. 

This directory is the path to your library of line stocks. 

When a line stock parameter has multiple values, the first value is the default, and 

all specified options are available when you work with a pipeline.  

The system uses the parameters identified as check pipe to compare the 

characteristics of a pipeline when you check for line stock violations. 

To Add Line Stock Parameter Files 

1. Click PIPING > Set Up > Line Stock > Create. 

2. Enter the new line stock name. The LineStock dialog box opens with the default 

line stock parameters. 

3. Edit the line stock parameters as desired and click  to apply the line stock 

changes or  to save the line stock into file.  

4. A dot and message appear at the bottom of the LineStock dialog box, informing 

you of the destination of the saved parameters. 

Using the LineStock Dialog Box 

The LineStock dialog box has three tabs: LineStock, DesignRule, and Defined. 

The tabs separate and identify the parameters and allow you to add and modify line 

stock and bend parameters. The variable type (integer, double or string) is 

automatically assigned based on the syntax of the entry for the user defined 

parameters only. 
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LineStock 

The LineStock tabbed page consists of several areas in which you can change line 

stock parameters. 

• General Parameters 

o Stock No—Pipe is the default. You can change this value to any continuous 

string, for example, plastic_tubing. 

o Material—Steel is not a required value. You can change this value to any 

continuous string, for example, solid_brass. 

o Grade—A123 is not a required value. You can change this value to any 

continuous string. 

• X Section—Rectangular or Circular. When you select one of these, a square or 

round pipe example is displayed in the Section Parameters box. 

• Section Type—Hollow or Solid. 

• Section Parameters—Height, Width, Angle, and Thickness if the X Section 

option is set to Rectangular. Pipe OD and Thickness if the X Section option is 

set to Circular.  

• Shape Type—Straight or Flexible is indicated by an option button that 

specifies the default setting. 

o When the Shape Type is Straight, the Corner Type is active, and you 

can select one of the three Corner Types, Bend, Fitting, or Miter Cut. 

o When the Shape Type is Flexible, the Corner Type and Bend information 

are not active. 

You can also edit the following values: 

• Weight/Length (WT_LEN)—The weight per unit length parameter that defines 

the density of any pipe solid part that is created on the pipe line.  

• Bend Radius, Bend Angle, Miter Cut Length, and Miter Cut Number for the 

Corner Type you have chosen. 

• Corner Type—Bend, Fitting, or Miter Cut.  

The indicator dot assigns the default corner type. 

DesignRule 

The DesignRule tabbed page contains the default Design Rule parameters. You can 

change active parameters. If you click , all the Line Stock parameters are saved 

to a file. If you click , the changes to the Design Rule parameters are applied to 

the routed pipe. 
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When the Line Stock parameter is set to Shape Type/Straight, all of the Design 

Rule parameters are active. If it is set to Shape Type/Flexible, some of the Design 

Rule parameters are not available.  

Defined  

The Defined tabbed page contains user defined parameters. You can add user-

defined Line Stock or Bend parameters by typing a name and value, and then 

clicking .  

• If you click , the Line Stock is saved to a file.  

• If you click , the Line Stock is created with the assembly.  

While you are editing, the parameter is not applied to the routed pipe parametrically. 

The parameter name should begin with a letter. 

Design Rule Parameters 

Use the DesignRule tab in the LineStock dialog box to verify that parameters of a 

routed pipe are within limitations.  

 Design Rule Parameter Value Checked 

MAX_OVERALL_LENGTH Length of a pipe segment. 

MAX_BENDS_NUMBER Number of bends in a pipe segment. 

MIN_BEND_SEPARATION Minimum distance between bends in 

one continuous pipe segment. 

MIN_STRAIGHT_LENGTH Minimum distance (in assembly units) 

allowable from the pipe end to the 

next bend or endpoint. 

MIN_BEND_RADIUS Minimum radius allowable in a bend. 

MAX_BEND_RADIUS Maximum radius allowable in a bend. 

MIN_BEND_ANGLE Minimum angle allowable in a bend. 

MAX_BEND_ANGLE Maximum angle allowable in a bend. 

BEND_ARC_THRESHOLD Angle at which Pro/PIPING defines the 

dimensioning scheme for large angle 

bends, such as 180 degrees. 

MIN_BRANCH_SEPARATION Minimum distance between branches 

in one continuous pipe segment. 
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MIN_BRANCH_ANGLE Minimum angle allowable in a branch. 

BEND_TABLE_NAME Name of the bend table. 

 

Additional Features of the LineStock Dialog Box 

Other features of the LineStock dialog box are: 

• A right click in the Model Tree that lets you edit parameters in the LineStock 

dialog box. 

• An indicator dot in Shape Type and Corner Type options to denote the default 

type. 

• A new configuration file option for the line stock directory: pro_pip_lnstk_dir 
<full path to user directory>. 

• Standard values for Diagonal Miter Cut corners. Line stock variables like WT_LEN 

can now be used in Pro/REPORT relations as numeric values. 

Example: Typical Line Stock Parameter File 

TYPE PIPE  

MATERIAL Steel  

GRADE A123  

SECTION_TYPE HOLLOW  

OD 0.25  

THICKNESS 0.032  

SHAPE TYPE STRAIGHT FLEXIBLE  

CORNER_TYPE BEND FITTING MITER_CUT  

WT/LEN 10 

BEND_RADIUS 1.5 2 3  

BEND_ANGLE 90 45 60  

MITER CUT LENGTH 0.05 0.1 0.5 

MITER CUT NUMBER 1 2 3  

Writing Relations 

You can access piping line stock parameters, pipeline parameters, and pipeline bend 

parameters through writing relations. The syntax for the relation is the same as that 

for part modeling. 

The feature name of the ID must refer to the line stock, pipeline feature, or pipe 

bend for the pipe, not to the pipe routing feature. You cannot set their values 

through the relations you create, but you can control dimension values. 

The following file is an example of how to write a relation to control the width of a 

channel in a pipeline. The following relations control the width of the channel, d7:0, 
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to keep it equal to the outer diameter of the pipe, as specified in the pipeline 

feature’s line stock parameters (assuming that the only two fluids in use are oil and 

H2O and that each gets assigned a single line stock): 

IF fluid:fid_LINE1 = ‘oil’ 

d7:0 = OD:fid_OIL_STK 

ELSE 

d7:0 = OD:fid_H2O_STK 

ENDIF 

If this pipeline (LINE1) has oil as the value for the fluid parameter, make the 

channel width equal to the outer diameter in the line stock OIL_STK. Otherwise, the 

channel width should be equal to the outer diameter of the line stock H2O_STK.  

Because the outer diameter of the pipeline, OD, is a parameter of a line stock (in this 

case OIL_STK or H2O_STK), the system uses the feature ID of the appropriate line 

stock in the relation.  

Also, because this is an assembly relation, not a part relation referencing an 

assembly, a component ID is not required in the relation. Keep in mind that the 

system determines a pipeline’s physical (solid) shape based on the line stock from 

which it actually derives the pipe.  

Example: Using Relations in Pro/PIPING 

 

You can write a relation to control the width of the channel, d7:0, to keep it equal to 

the outer diameter of the pipe, which is specified in the line stock parameters of the 

pipe feature. 



Pro/PIPING (Non Specification-Driven) 

27 

Setting the WT_LEN Parameter 

WT_LEN is a line stock parameter from which the piping solid generates the density 

value for mass property calculations. Pro/ENGINEER sets the density value for a 

piping solid using the following equation: 

Density = WT_LEN / A; A = PI/4 * (OD^2 - (OD - 2*WT) ^2) 

where  

^ is power 

OD is outline diameter (from line stock) 

WT is wall thickness (from line stock) 

When you regenerate the piping solid in Assembly mode, the solid checks the current 

line stock for the segment and looks at the OD and WT_LEN values to verify that the 

current density is correct.  

However, if you regenerate the piping solid in Part mode, the density value remains 

frozen because the line stock parameters are not available.  

To Assign a Default Line Stock for New Line Segments 

 

1. Click PIPING > Route. 

2. Select the pipeline to route. The ROUTE PIPE menu appears.  

3. Click Pipe Envrnmt. The PIPE ENV menu appears.  

4. Click Line Stock. In the message window, the system indicates the name of the 

current line stock, and the LINE STOCK NAMES menu appears. 

5. Choose a line stock to assign to the next line segment or use Create to create a 

new line stock.  

To Assign the Default Corner Type for New Line Segments 

 

1. Click PIPING > Route. 

2. Select the pipeline to route. The ROUTE PIPE menu appears.  

3. Click Pipe Envrnmt. The PIPE ENV menu appears.  

4. Click Corner Type. The CORNER TYPE menu appears.  

5. From the CORNER TYPE menu, click one of these commands: 

o Fitting—Creates sharp corners so that you may later add corner fittings. 

Fitted corners create breaks in a pipeline. 
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o Bend—Creates each corner by bending a tube. Type a bend radius by 

selecting any of the predefined values, or click New Value and type a 

desired value. If you are not changing the corner type, but only want to 

reassign default bend corner values, click PIPE ENV > Corner Vals, select 

a value from the SEL VALUE menu, and type the replacement bend radius 

value. 

o Miter—Creates a corner by adding a miter cut. Select a value from the SEL 

VALUE menu to specify the number of miter cuts. To select values other 

than 1, 2, or 3, select New Value and enter the number of miter cuts 

required. 

To Assign a Line Shape as a Default for New Line Segments 

 

1. In the ROUTE PIPE menu, click Pipe Envrnmt > Line Shape.  

2. Using the LINE SHAPE menu, do one of the following: 

o Click Flexible and Free Length to have the system determine the length 

of the flexible pipe segment. 

o Click Flexible and Set Length to specify a length for the flexible pipe after 

creating each segment. 

o Click Straight. 

Free Length and Set Length are only available when you have set Flexible in 

the LINE SHAPE menu.  

3. Click Done. 

Assigning a Flexible Line Shape 

As with all piping environment commands, these settings take effect beginning with 

the next routed pipeline segment until you change them. The default length for a 

new segment is the length the segment would be if you used Free Length.  

• Once you click type a value for a pipe segment length, the system constrains the 

flexible segment length at that value. Use the Modify Pipeline dialog box to 

reroute a fixed length segment as a free length. 

• A dimension controls the fixed length. You can modify it as you would any other 

dimension. Because the pipeline controls the corresponding solid pipe feature, 

you must select the pipeline to modify a fixed length, not the solid (if there is 

one). 

• You cannot set fixed lengths for straight segments even if the straight segments 

are part of a segment that is routed mostly as flexible pipe. 
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Pipeline Parameters 

About Pipeline Parameters 

Every pipeline has a set of associated parameters, in addition to the parameters in 

the referenced line stock, that apply to that individual pipeline. You may write the 

pipeline parameters to a file and may include system parameters (such as the name 

of the line parameter file and fluid or gas type), as well as user-defined parameters.  

The values for the pipeline parameters that you write to the file automatically define 

the parameter types such as string, integer, or double. This is valid for the pipeline, 

line stock, and insulation parameters.  

To Create User Defined Pipeline Parameters 

1. Click Piping > Modify Pipe. The Modify Pipeline dialog box opens. 

2. Click Parameters and then under Pipe Line Parameters click Pipe Line. The 

Edit Pipeline dialog box opens.  

3. Select a pipeline from the drop-down list box. Under User Defined Parameters, 

type a new name and value. 

4. Click  and . The new parameter is applied to the pipeline. 

Note:  

• You can also Delete and Read in parameters from a file in this dialog box.  

• The parameter’s name should begin with a letter. 

Using the Modify Pipeline Dialog Box 

The Modify Pipeline dialog box lets you modify several options in the active 

assembly, the corners, parameters, line stocks, and flex shapes. In the Active 

Assembly area of this dialog box, click  to activate the assembly in the 

Pro/ENGINEER window. 

In the Modify Options area, the following choices appear. 

• Corner—Select types and values of single or multiple corners. 

• Line Stock—Set the values of selected single or multiple segments. 

• Parameters—Modify Pipeline and Bend parameters. 

• Flex Shape—Modify the line shape of a flexible hose between Fixed and Free 

length. 

• Flow Direction—Select the flow unit and change the direction of the flow. 

When you click an option under Modify Options, the last area in the dialog box 

changes. For example, if you click Corner, a Corner group box appears. You need to 
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select a pipe segment corner to change it to a Bend, Fitting, or Miter Cut  in the New 

Type box and to modify the value of the bend or fitting in the New Value box. 

If you click the Parameters option, the Parameters group box opens. 

In the Parameters area, you can select Pipe Line Parameters > Pipe Line or  

Bend Parameters > Bend to modify these parameters. If you click Pipe Line, 

the Edit Pipeline dialog box opens. If you click Bend, the Bend Parameters 

Model Tree opens. 

If you click the Line Stock option, the Line Stock group box opens. 

Modify the line stock listed in the Modify Linestock drop-down box with the Edit 

option or create a new line stock with the Create new option. If you click Create 

new, enter the line stock name at the command prompt. 

If you click the Flex Shape option, the Flex Shape group box opens. 

Modify the Flex Shape by selecting a flexible pipe segment. The Modify Shape 

group box contains two shapes that you can change, Fixed Length and Free 

Length. If you click Fixed Length, the Length box activates with a number you 

can modify. 

Using the Edit Pipeline Dialog Box 

The Edit Pipeline dialog box opens after you click Parameters in the Modify 

Pipeline dialog box. The Edit Pipeline dialog box lets you perform the following 

tasks: 

• Select a pipeline parameter from the Pro/ENGINEER window. 

• Give the parameter a new name. 

• Add the parameter to the pipeline. 

• Save the parameter to a file. 

• Read in the parameter as a .ppl file. 

• Delete the parameter from the pipeline. 

• Cancel changes made to the pipeline. 

• Modify an existing pipeline label. 



Pro/PIPING (Non Specification-Driven) 

31 

Pro/REPORT Pipeline Parameters 

 

Pro/REPORT Parameters Applicable to Pro/PIPING 

Linestock Parameters 

Parameter Name Definition 

&asm.mbr.pipe.stock.name Lists name(s) of line 

stock(s). 

&asm.mbr.pipe.stock.User Defined  Lists specified parameters 

for the line stock. 

&asm.mbr.pipe.stock.line.name Lists names of all pipelines 

using each line stock.  

&asm.mbr.pipe.stock.line.User Defined Lists parameters for the 

pipeline using the specified 

line stock. 

&asm.mbr.pipe.stock.material Lists material for all line 

stocks. 

&asm.mbr.pipe.stock.OD Lists outer diameter for 

line stocks. 
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&asm.mbr.pipe.stock.wallthick Lists wall thickness for line 

stocks.  

&asm.mbr.pipe.stock.len.pre_cut Lists total precut length of 

each line stock.  

&asm.mbr.pipe.stock.len.center Lists total centerline length 

of each line stock. 

Pipeline Parameters 

Parameter Name Definition 

&asm.mbr.pipe.line.segment.stock.name Lists names of line stocks 

for each segment in the 

pipeline. 

&asm.mbr.pipe.line.segment.stock.User 
Defined 

Lists parameters for line 

stocks of which the 

pipeline is made. 

&asm.mbr.pipe.line.name Lists names of all 

pipelines. 

&asm.mbr.pipe.line.User Defined Lists parameters for each 

pipeline. 

&asm.mbr.pipe.line.stock.name Lists names of line stocks 

used in each pipeline. 

&asm.mbr.pipe.line.stock.User Defined Lists parameters for line 

stocks used in pipeline. 

&asm.mbr.pipe.line.len.pre_cut Lists precut length of each 

pipeline. 

&asm.mbr.pipe.line.len.center Lists centerline length of 

each pipeline. 

&asm.mbr.pipe.line.segment.name Lists names of all 

segments in pipeline. 

&asm.mbr.pipe.line.segment.solid_name Lists names of all solids (if 

defined) in pipeline. 

&asm.mbr.pipe.line.segment.len.pre_cut Lists precut length of 

segments in pipeline. 

&asm.mbr.pipe.line.segment.len.center Lists centerline length of 
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segments in pipeline.  

&asm.mbr.pipe.line.segment.clk_ang.ang Lists clocking angle value 

from evaluate feature. 

&asm.mbr.pipe.line.segment.clk_ang.cs1 Lists name of initial 

coordinate system for 

each clocking angle. 

&asm.mbr.pipe.line.segment.clk_ang.cs2 Lists name of final 

coordinate system for 

each clocking angle. 

Pipe Segment Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.name Lists system default name 

of the pipeline segments. 

&asm.mbr.pipe.segment.solid_name Lists solid part name for 

each segment (if defined). 

&asm.mbr.pipe.segment.stock.name Lists line stock used in 

each segment. 

&asm.mbr.pipe.segment.stock.User 
Defined 

Lists parameters in line 

stocks assigned to each 

segment. 

&asm.mbr.pipe.segment.line.name Lists name of pipeline to 

which each segment 

belongs. 

&asm.mbr.pipe.segment.line.User 
Defined 

Lists pipeline parameters 

for each segment. 

&asm.mbr.pipe.segment.len.pre_cut Lists precut length of each 

segment. 

&asm.mbr.pipe.segment.len.center Lists centerline length of 

each segment. 

&asm.mbr.pipe.segment.segfrom Lists location from which 

each pipeline segment in 

the assembly is routed. 

This is the component to 

which the from entry port 
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belongs. 

&asm.mbr.pipe.segment.segto Lists the location to which 

each pipeline segment in 

the assembly is routed. 

This is the component to 

which the to entry port 

belongs. 

&asm.mbr.pipe.segment.clk_ang.ang Lists clocking angle value 

of evaluate feature. 

&asm.mbr.pipe.segment.clk_ang.cs1 Lists name of initial 

coordinate system for each 

clocking angle. 

&asm.mbr.pipe.segment.clk_ang.cs2 Lists name of final 

coordinate system for each 

clocking angle. 

Pipeline Segment Bend Information Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.csys.bend.User Defined Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.csys.bend.loc_angle  Lists bend 

angle. 

&asm.mbr.pipe.segment.csys.bend. loc_num Lists bend 

location bend 

number. 

&asm.mbr.pipe.segment.csys.bend.loc_radius  Lists bend 

radius. 

&asm.mbr.pipe.segment.csys.bend.loc_x Lists x-offset 

bend location 

information. 
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&asm.mbr.pipe.segment.csys.bend.loc_y Lists y-offset 

bend location 

information. 

&asm.mbr.pipe.segment.csys.bend.loc_z Lists z-offset 

bend location 

information. 

&asm.mbr.pipe.segment.csys.bend. mach_bend Lists bend 

machine bend 

angle. 

&asm.mbr.pipe.segment.csys.bend.mach_num Lists bend 

machine bend 

number. 

&asm.mbr.pipe.segment.csys.bend.mach_offset Lists bend 

machine 

offset. 

&asm.mbr.pipe.segment.csys.bend.mach_radius Lists bend 

machine bend 

radius. 

&asm.mbr.pipe.segment.csys.bend.mach_twist Lists bend 

machine twist 

angle. 

&asm.mbr.pipe.segment.csys.name Lists 

coordinate 

system name 

for segment 

bend 

information. 

&asm.mbr.pipe.segment.mach_csys.bend.User 
Defined 

Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.mach_csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_bend Lists bend 

machine bend 

angle. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_num Lists bend 

machine 

number. 
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&asm.mbr.pipe.segment.mach_csys.bend.mach_offset Lists bend 

machine 

offset. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_ 

radius 

Lists bend 

machine 

radius. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_twist Lists bend 

machine twist 

angle. 

&asm.mbr.pipe.segment.mach_csys.name Lists name of 

coordinate 

system with 

bend machine 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.User Defined Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.loc_csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_angle Lists bend 

location bend 

angle. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_num Shows bend 

location bend 

number. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_radius Lists bend 

location bend 

radius. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_x Lists x-offset 

bend location 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_y Lists y-offset 

bend location 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_z Lists z-offset 

bend location 

information. 



Pro/PIPING (Non Specification-Driven) 

37 

&asm.mbr.pipe.segment.loc_csys.name Lists 

coordinate 

system name 

for segment 

bend location 

information. 

Holes Report Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.holes.holes_params.hole_num List holes 

report 

 number. 

&asm.mbr.pipe.segment.holes.holes_params.hole_offset List holes 

report 

offset. 

&asm.mbr.pipe.segment.holes.holes_params.hole_angle List holes 

report 

angle. 

&asm.mbr.pipe.segment.holes.holes_param..hole_diam List holes 

report 

diameter. 

Bend Parameters 

About Bend Parameters 

Bend parameters are parameters that determine the size of pipe bends in an 

assembly. 

To Create Bend Parameters in a Pipeline Segment 

1. Click PIPING > Modify Pipe. The MODIFY PIPELINE dialog box opens. 

2. Under Modify Options click Parameters and then under Parameters click  

Bend Parameters > Bend. The Bend Parameters window opens. 

3. Expand the view of the Bend Parameters window by choosing View > Expand 

All or any other view you want. 

4. Click  to select one or more bends from the active assembly on the screen, or 

choose one or more bends directly from the list in the Model Tree.  

5. Click Edit > Columns > Add/Remove. Only selected bends are available for 

editing. The Add/Remove Columns dialog box opens. 
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6. Make the following changes, as necessary: 

o Add parameters to the bend by specifying a value in the column for the 

appropriate parameter.  

o Add columns to the table to include new parameters. 

o Delete parameters from the bend by removing the parameter value, and 

from all bends by selecting all bends and then removing the entire column. 

o Rename parameters by editing the column heading, and rename the 

parameter values by editing the table cells. 

7. To update the bend parameters, click Apply. To update and exit, click OK. 

User-Defined Bend Parameters in Pro/REPORT Tables 

Using the LineStock dialog box, you can view and modify parameters for all pipe 

bends in an assembly. You can access these parameters in report tables using the 

following parameter: &asm.mbr.pipe.segment.csys.bend.User Defined. 

You can create default user-defined bend parameters by specifying them in the line 

stock file. When you specify them in the line stock file, the system applies them only 

when creating the bend during routing or when you change a corner to a bend when 

the line stock is active.  

These parameters have no effect on an existing bend if you assign a new line stock 

to the segment, change the value of the default bend parameter in the current line 

stock, or add a bend parameter to or delete one from the current line stock.  

Any new bends that you create after changing or modifying the line stock of the 

pipeline have the new default parameters and values of the current line stock.  

Bends that you create by modifying a corner to type Bend acquire their default bend 

parameters from the current line stock for the segment.  

As an alternative to creating default bend parameters in every bend, you can choose 

to assign parameters only to bends that vary from the standard, and then use report 

relations to assign a default value for bends without the parameter for the report 

table.  

Pro/REPORT Parameters Applicable to Pro/PIPING 

Linestock Parameters 

Parameter Name Definition 

&asm.mbr.pipe.stock.name Lists name(s) of line 

stock(s). 

&asm.mbr.pipe.stock.User Defined  Lists specified parameters 

for the line stock. 
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&asm.mbr.pipe.stock.line.name Lists names of all pipelines 

using each line stock.  

&asm.mbr.pipe.stock.line.User Defined Lists parameters for the 

pipeline using the specified 

line stock. 

&asm.mbr.pipe.stock.material Lists material for all line 

stocks. 

&asm.mbr.pipe.stock.OD Lists outer diameter for 

line stocks. 

&asm.mbr.pipe.stock.wallthick Lists wall thickness for line 

stocks.  

&asm.mbr.pipe.stock.len.pre_cut Lists total precut length of 

each line stock.  

&asm.mbr.pipe.stock.len.center Lists total centerline length 

of each line stock. 

Pipeline Parameters 

Parameter Name Definition 

&asm.mbr.pipe.line.segment.stock.name Lists names of line stocks 

for each segment in the 

pipeline. 

&asm.mbr.pipe.line.segment.stock.User 
Defined 

Lists parameters for line 

stocks of which the 

pipeline is made. 

&asm.mbr.pipe.line.name Lists names of all 

pipelines. 

&asm.mbr.pipe.line.User Defined Lists parameters for each 

pipeline. 

&asm.mbr.pipe.line.stock.name Lists names of line stocks 

used in each pipeline. 

&asm.mbr.pipe.line.stock.User Defined Lists parameters for line 

stocks used in pipeline. 

&asm.mbr.pipe.line.len.pre_cut Lists precut length of each 

pipeline. 
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&asm.mbr.pipe.line.len.center Lists centerline length of 

each pipeline. 

&asm.mbr.pipe.line.segment.name Lists names of all 

segments in pipeline. 

&asm.mbr.pipe.line.segment.solid_name Lists names of all solids (if 

defined) in pipeline. 

&asm.mbr.pipe.line.segment.len.pre_cut Lists precut length of 

segments in pipeline. 

&asm.mbr.pipe.line.segment.len.center Lists centerline length of 

segments in pipeline.  

&asm.mbr.pipe.line.segment.clk_ang.ang Lists clocking angle value 

from evaluate feature. 

&asm.mbr.pipe.line.segment.clk_ang.cs1 Lists name of initial 

coordinate system for 

each clocking angle. 

&asm.mbr.pipe.line.segment.clk_ang.cs2 Lists name of final 

coordinate system for 

each clocking angle. 

Pipe Segment Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.name Lists system default name 

of the pipeline segments. 

&asm.mbr.pipe.segment.solid_name Lists solid part name for 

each segment (if defined). 

&asm.mbr.pipe.segment.stock.name Lists line stock used in 

each segment. 

&asm.mbr.pipe.segment.stock.User 
Defined 

Lists parameters in line 

stocks assigned to each 

segment. 

&asm.mbr.pipe.segment.line.name Lists name of pipeline to 

which each segment 

belongs. 

&asm.mbr.pipe.segment.line.User 
Defined 

Lists pipeline parameters 

for each segment. 



Pro/PIPING (Non Specification-Driven) 

41 

&asm.mbr.pipe.segment.len.pre_cut Lists precut length of each 

segment. 

&asm.mbr.pipe.segment.len.center Lists centerline length of 

each segment. 

&asm.mbr.pipe.segment.segfrom Lists location from which 

each pipeline segment in 

the assembly is routed. 

This is the component to 

which the from entry port 

belongs. 

&asm.mbr.pipe.segment.segto Lists the location to which 

each pipeline segment in 

the assembly is routed. 

This is the component to 

which the to entry port 

belongs. 

&asm.mbr.pipe.segment.clk_ang.ang Lists clocking angle value 

of evaluate feature. 

&asm.mbr.pipe.segment.clk_ang.cs1 Lists name of initial 

coordinate system for each 

clocking angle. 

&asm.mbr.pipe.segment.clk_ang.cs2 Lists name of final 

coordinate system for each 

clocking angle. 

Pipeline Segment Bend Information Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.csys.bend.User Defined Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.csys.bend.loc_angle  Lists bend 

angle. 

&asm.mbr.pipe.segment.csys.bend. loc_num Lists bend 

location bend 



Pro/PIPING (Non Spec-Driven) - Help Topic Collection 

42 

number. 

&asm.mbr.pipe.segment.csys.bend.loc_radius  Lists bend 

radius. 

&asm.mbr.pipe.segment.csys.bend.loc_x Lists x-offset 

bend location 

information. 

&asm.mbr.pipe.segment.csys.bend.loc_y Lists y-offset 

bend location 

information. 

&asm.mbr.pipe.segment.csys.bend.loc_z Lists z-offset 

bend location 

information. 

&asm.mbr.pipe.segment.csys.bend. mach_bend Lists bend 

machine bend 

angle. 

&asm.mbr.pipe.segment.csys.bend.mach_num Lists bend 

machine bend 

number. 

&asm.mbr.pipe.segment.csys.bend.mach_offset Lists bend 

machine 

offset. 

&asm.mbr.pipe.segment.csys.bend.mach_radius Lists bend 

machine bend 

radius. 

&asm.mbr.pipe.segment.csys.bend.mach_twist Lists bend 

machine twist 

angle. 

&asm.mbr.pipe.segment.csys.name Lists 

coordinate 

system name 

for segment 

bend 

information. 

&asm.mbr.pipe.segment.mach_csys.bend.User 
Defined 

Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.mach_csys.bend.bend_name Lists the bend 

name created 
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by the system. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_bend Lists bend 

machine bend 

angle. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_num Lists bend 

machine 

number. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_offset Lists bend 

machine 

offset. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_ 

radius 

Lists bend 

machine 

radius. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_twist Lists bend 

machine twist 

angle. 

&asm.mbr.pipe.segment.mach_csys.name Lists name of 

coordinate 

system with 

bend machine 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.User Defined Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.loc_csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_angle Lists bend 

location bend 

angle. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_num Shows bend 

location bend 

number. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_radius Lists bend 

location bend 

radius. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_x Lists x-offset 

bend location 
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information. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_y Lists y-offset 

bend location 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_z Lists z-offset 

bend location 

information. 

&asm.mbr.pipe.segment.loc_csys.name Lists 

coordinate 

system name 

for segment 

bend location 

information. 

Holes Report Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.holes.holes_params.hole_num List holes 

report 

 number. 

&asm.mbr.pipe.segment.holes.holes_params.hole_offset List holes 

report 

offset. 

&asm.mbr.pipe.segment.holes.holes_params.hole_angle List holes 

report 

angle. 

&asm.mbr.pipe.segment.holes.holes_param..hole_diam List holes 

report 

diameter. 

Using the Modify Pipeline Dialog Box 

The Modify Pipeline dialog box lets you modify several options in the active 

assembly, the corners, parameters, line stocks, and flex shapes. In the Active 

Assembly area of this dialog box, click  to activate the assembly in the 

Pro/ENGINEER window. 

In the Modify Options area, the following choices appear. 

• Corner—Select types and values of single or multiple corners. 

• Line Stock—Set the values of selected single or multiple segments. 
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• Parameters—Modify Pipeline and Bend parameters. 

• Flex Shape—Modify the line shape of a flexible hose between Fixed and Free 

length. 

• Flow Direction—Select the flow unit and change the direction of the flow. 

When you click an option under Modify Options, the last area in the dialog box 

changes. For example, if you click Corner, a Corner group box appears. You need to 

select a pipe segment corner to change it to a Bend, Fitting, or Miter Cut  in the New 

Type box and to modify the value of the bend or fitting in the New Value box. 

If you click the Parameters option, the Parameters group box opens. 

In the Parameters area, you can select Pipe Line Parameters > Pipe Line or  

Bend Parameters > Bend to modify these parameters. If you click Pipe Line, 

the Edit Pipeline dialog box opens. If you click Bend, the Bend Parameters 

Model Tree opens. 

If you click the Line Stock option, the Line Stock group box opens. 

Modify the line stock listed in the Modify Linestock drop-down box with the Edit 

option or create a new line stock with the Create new option. If you click Create 

new, enter the line stock name at the command prompt. 

If you click the Flex Shape option, the Flex Shape group box opens. 

Modify the Flex Shape by selecting a flexible pipe segment. The Modify Shape 

group box contains two shapes that you can change, Fixed Length and Free 

Length. If you click Fixed Length, the Length box activates with a number you 

can modify. 

Using the Edit Pipeline Dialog Box 

The Edit Pipeline dialog box opens after you click Parameters in the Modify 

Pipeline dialog box. The Edit Pipeline dialog box lets you perform the following 

tasks: 

• Select a pipeline parameter from the Pro/ENGINEER window. 

• Give the parameter a new name. 

• Add the parameter to the pipeline. 

• Save the parameter to a file. 

• Read in the parameter as a .ppl file. 

• Delete the parameter from the pipeline. 

• Cancel changes made to the pipeline. 

• Modify an existing pipeline label. 
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About Bend Notes 

Bend notes are similar to other notes. You can resize them, orient them horizontally, 

vertically, or angularly, change the font, move them, and so on. By default, the 

system places bend notes horizontally with a leader attachment. When you modify a 

pipe bend, the system edits the text in the note, not the values themselves.  

In Drawing mode, you can automatically display information for routed pipeline 

segments with bend type corners (for example, bend user-defined parameters, spool 

parameters, and the solid name of the segment to which the bend belongs).  

You can automatically display this information by specifying a default note to attach 

to each pipe bend type corner and to each end of the segment.  

To Create Piping Bend Notes 

1. In Drawing mode, when you attach a note to a pipe bend, add the extension 

:att_pipe_bend to the parameter name. Doing this indicates that the parameter 

value should refer to the bend to which the note is attached (for example, 

"&bend_radius:att_pipe_bend, &material:att_pipe_bend).  

2. When you enter a parameter using this format, the system initially searches the 

pipe bend parameters for that bend, then line stock parameters for that segment, 

pipeline parameters for that pipeline, and pipe solid parameters (if there is an 

existing solid), in that order. If the system cannot find a value, it maintains the 

text. 

Labeling Piping Bends Automatically 

In Drawing mode, the system determines the default pipe bend note and determines 

whether to place pipe bend notes at all, according to the setting of the drawing setup 

file option default_pipe_bend_note. 

• If you set the option to no (the default), the system does not show bend notes in 

the drawing. 

• If you set the value as text within quotation marks, the system uses that value 

when creating the bend notes. For single line notes, the text can include bend 

parameters &bendname:att_pipe_bend," "&bend_radius:att_pipe_bend" and 

"&bend_num:att_pipe_bend." The text can also include all user-defined bend 

parameters, all default linestock parameters and all user-defined linestock 

parameters. 

• If you specify a directory path as the value, the system references a previously 

created note saved as a file to create single or multiple line bend notes, for 

example, in UNIX: 
". /mybendnote.txt." 

As there are no defined bends in a flexible pipe, this functionality applies only to 

straight pipes with bent corners and to the ends of such pipes. 
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Tip: Generating Bend Information 

You can generate bend location and bend machine information by using Segment 

under Definition in the Report Pipeline dialog box or setting up report information 

in the assembly in which the pipe segment was created. 

Bend Tables 

About Bend Tables (Non Spec-Driven) 

 

Pro/PIPING uses bend tables to accurately calculate the length of straight pipe 

(developed length) required to make a bend of a specific bend radius and angle.  

The developed pipe length for the same bend can differ due to different materials 

and pipe outside diameters (OD). 

Bend tables are normalized for 90 degree bends. For other than 90 degree bends, 

Pro/ENGINEER takes those values and multiplies them by A/90, where A represents 

the specific bend angle in degrees. 

Bend Table Menu 

The Bend Table menu allows you to access all Pro/PIPING bend tables for creation 

and modification. 

From the BEND TAB menu (PIPING > Set Up > Bend Allow), you can perform 

the following tasks: 

• Define—Create Pro/PIPING bend tables. 

• Delete—Delete Pro/PIPING bend tables. 

• Edit—Modify Pro/PIPING bend tables. You can update a bend table at any time. 

• Show—View Pro/PIPING bend tables. You can confirm bend table data. 

• Read—Read a bend table from a file to a part. 

• Write—Write a bend table from a part to a file. 

Defining Bend Tables (Non Spec-Driven) 

Pro/PIPING allows you to define new bend tables. You define bend tables for 90 

degree bends. For other than 90 degree bends, Pro/ENGINEER takes those values 

and multiplies them by A/90 where Α represents the specific bend angle in degrees. 

You do not have to insert a bend allowance value (A) in every cell in a bend 

allowance table. If you leave a particular cell blank, the system calculates the length 

value using interpolation.  

The following table describes the Pro/PIPING bend table format:  
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Column 1 Column 2 Column 3 Column 4 …  

FORMULA      

equation      

...      

ENDFORMULA      

!      

CONVERSION      

equation      

...      

START MATERIALS      

MATERIAL      

...      

END MATERIALS      

!      

TABLE      

radius  radius  radius  radius radius 

outside diameter  bend allow  bend 

allow  

bend 

allow  

... 

outside diameter  ... ... ... ... 

Note:  

• Enter the words FORMULA, END FORMULA, CONVERSION, END CONVERSION, 

START MATERIALS, END MATERIALS and TABLE exactly as shown. 

• The following definitions apply for the above bend table format: 

o FORMULA—An equation for the developed length. 

o TABLE—A combination of pipe outer diameter (OD) and bend radius table 

data that will never be encountered in your pipe assembly. For example, 

0.25 bend radius with an OD of 0.5 inches. 

• Comment lines can appear anywhere in a bend table. Each comment line in the 

table must start with an exclamation point (!). 

To Define a Bend Table 

1. From the PIPING menu, click Set Up > Bend Allow > Define. 

2. Enter a bend table name and click . A Pro/TABLE window opens containing a 

table outline. 
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3. Enter the data in the table or select File > Read to use an existing bend table as 

a baseline. The Read File dialog box opens. 

4. Enter the name of the existing bend table file and click . The system reads 

the file data and writes it to the current bend table file. Modify the bend table 

data, if needed.  

5. Click File > Save and Exit to save and close the bend table. You must now 

assign the new bend table to a pipe segment or line stock to use it. 

To Modify a Bend Table 

Pro/PIPING allows you to modify bend tables. You can edit only those bend tables 

created in the current assembly or applied to the current assembly. To modify a 

bend table within Pro/PIPING, do the following: 

1. From the PIPING menu, click Set Up > Bend Allow > Edit. The TBL NAMES 

menu appears. 

2. Select the bend table to modify from the TBL NAMES menu. This menu lists all 

bend tables that were applied to the assembly or were created when the 

assembly was currently in session.  

3. A Pro/TABLE window opens and displays the selected table. 

4. Modify the bend table. 

5. Click File > Save or Exit. Pro/PIPING saves the bend table in the current 

directory.  

Note: You must assign a bend table to a pipe segment or line stock to use it. 

To Delete a Bend Table 

1. From the PIPING menu, click Set Up > Bend Allow > Delete. 

2. Select the bend table to delete from the TBL NAMES menu. This menu lists all 

bend tables that were applied to the assembly or were created when the 

assembly was currently in session. Pro/PIPING deletes the selected bend table.  

To Read a Bend Table to a Model 

You can read a bend table from a bend table (.bnd) file into a model. Pro/PIPING 

creates a bend table from the file data and applies it to the current model.  

1. From the PIPING menu, click Set Up > Bend Allow > Read. The DATA FILES 

menu appears. 

2. Select a bend table name. Pro/PIPING lists all saved bend tables. If you select 

Names, the Open dialog box opens in which you select a bend table (.bnd) file 

to read. The Pro/ENGINEER message area confirms the action.  
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To Assign a Bend Table 

A Bend Table is assigned to each segment through the Line Stock.  

1. Click PIPING > Set Up > Line Stock > Edit. The Line Stock Names menu 

appears.  

2. Click a line stock name. The LineStock dialog box appears.  

3. Click the Design Rule tab. The Design Rule Parameters dialog box appears.  

4. Select a bend table from the Bend Table Name box. The default value is 

 NO_TABLE. This box lists all bend tables defined for the pipe segment or line 

stock. 

5. Click  to apply the bend table. The Design Rule Parameters dialog box 

closes. 

6. Click  to close the Design Rules dialog box. 

Formula Equations (Non Spec-Driven) 

Formula is an equation used to calculate the developed length for any radius or 

outside diameter (OD) that falls outside the range of the table data. Pro/PIPING 

provides the following variables for use in the table: 

• L—Developed straight length of the bend. 

• R—Bend radius. 

• T—Pipe outer diameter (OD). 

• ANGLE—Bend Angle (in degrees). 

Formula Equation Rules 

Follow these rules when you enter the formula equation in a bend table: 

• The formula must be the first equation in the table.  

• The formula must begin with the descriptor FORMULA, in the first column. 

o If an equation is simple, write it in the second column on the same line as 

the descriptor, as in the following examples: 

FORMULA L = (0.55*T) + (PI*R)/2.0 

FORMULA L = (ANGLE*PI/180)*(R+T/2) 

o If the formula is more complex and/or contains some logic statements, then 

the FORMULA descriptor must precede the actual formula on its own line. 

The formula must also be concluded by the descriptor END FORMULA, on its 

own line and in the first column. The following example illustrates this 

process: 
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FORMULA 

IF (R/T) < 1.10 | (R/T) > 1.83 

L = (PI*R*T)/2.0 

ELSE 

L = (PI/2)*(R + (T*0.35)) 

END FORMULA 

In a multi-statement formula like this, you can enter the statements in columns 

other than column one. 

Conversion Equations (Non Spec-Driven) 

The conversion equation tells the system how table data (A) is related to the 

developed length (L). If no conversion equation is defined, the system assumes that 

the table data equals the required length (L = A). For example, if the table data 

represents the bend deduction value, the equation might look like the following: 

L = 2*(T + R) - A 

Note: L must never be negative.  

Conversion Equation Variables 

You can use the following variables in a conversion equation: 

• L—Developed straight length of stock. 

• R—Bend radius. 

• T—Material thickness. 

• ANGLE—Bend Angle (in degrees). 

• A—Bend allowance value contained in the table data section. 

Conversion Equation Rules 

Follow these rules when you enter the conversion equation in a bend table: 

• Only use a conversion equation when the developed length L is not equal to your 

table values A. 

• The conversion must begin with the descriptor CONVERSION, in the first column. 

o If the equation is a simple one, then it can be written in the second column 

on the same line as the descriptor, as in this example: 

CONVERSION L = 2*(T +R) - A 

o If the formula is more complex and/or contains some logic statements, then 

the CONVERSION descriptor must precede the actual formula on its own line 
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and the formula must be concluded by the descriptor END CONVERSION, 

again on its own line and in the first column. 

Design Rule Parameters 

About Design Rule Parameters 

In Pro/PIPING, Design Rule parameters are line stock parameters that check selected 

pipelines to ensure that the pipes stay within their limitations. If there are any 

violations, this is considered a Line Stock violation. The system compares the 

characteristics of a selected pipeline with the values of the Design Rule parameters. 

If there are any violations, the pipeline highlights, which gives you the opportunity to 

correct the pipeline parameters. 

To Define Design Rule Parameters (Non Spec-Driven) 

You use design rule parameters to verify whether the parameters of a routed pipe 

are within limitations. Design Rule Parameters are available in the LineStock dialog 

box.  

1. Open the LineStock dialog box (Piping > Set Up > Line Stock > Create) and 

go to the DesignRule tab. 

2. The following list of the Design Rule parameter values appears.  

o Max Overall Length—Maximum allowable overall length of a continuous 

pipe segment.  

o Min Segment Length—Minimum allowable length of a continuous pipe 

segment.  

o Max Segment Length—Maximum allowable length of a continuous pipe 

segment. 

o Max Bends Number—Maximum allowable number of bends in a 

continuous pipe segment. 

o Min Bend Separation—Minimum allowable distance, in assembly units, 

between bends in one continuous pipe segment. 

o Min Straight Length—Minimum allowable length of a straight pipe 

segment. 

o Min Bend Radius—Minimum allowable bend radius, in assembly units, for 

a pipe segment. 

o Max Bend Radius—Maximum allowable bend radius, in assembly units, for 

a pipe segment. 

o Min Bend Angle—Minimum angle of the bend, in assembly units, for a 

continuous pipe segment. 

o Max Bend Angle—Maximum angle of the bend, in assembly units, for a 

continuous pipe segment. 
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o Bend Arc Threshold— Angle at which Pro/PIPING defines the 

dimensioning scheme for large angle bends, such as 180 degrees (Default 

value in degrees: 165. You can enter a value between 0 and 360.) 

o Min Branch Separation—Minimum separation distance between two 

branches in a continuous pipe segment. 

o Min Branch Angle—Minimum allowable angle between a branch and the 

main.  

o Bend Table Name—Assign a bend table to the line stock. You can create a 

bend table at any time (Default value: NO_TABLE). 

3. Click in any of the boxes and change the values, if required .  

4. Click  to apply the design rule parameters and close the LineStock dialog 

box. 

5. Click  to close the LineStock dialog box.  

Note: All bend radius and bend angle boxes are unavailable. Pro/PIPING retrieves 

this bend data from the Specification Database Bend Master Catalog (MCAT) file.  

To Check for Line Stock Violations 

1. Click PIPING > Info. The Report Pipeline dialog box opens. 

2. Click Check Pipe in the Info Type box. 

3. Click  to select a pipe line.  

4. The dialog box displays violations in Line Stock parameter.  

The system highlights the pipeline if the violation applies to the entire pipeline. If it 

only applies to certain geometry of the pipe (such as a bend), it highlights that 

geometry in a different colour. 

You can also click Info, and an INFORMATION WINDOW opens. This window displays 

the Line Stock name, the parameter name, the value of the parameter, and the 

value of the violation (if there is one). You can save, edit, and search in this 

information window. 

About the Bend Arc Threshold 

The Bend Arc Threshold is a Design Rule parameter that appears in the 

LineStock dialog box. It is the angle at which Pro/PIPING defines the dimensioning 

scheme for large angle bends such as 180 degrees. The dimensioning scheme for the 

bend refers to how the bend is located along the pipe. Pro/PIPING can locate the 

bend by either the Theoretical Intersection Point or the Bend Arc Center Point. 

• Bend angles that are larger than or equal to 180 degrees get dimensioned based 

on the Bend Arc Center Point.  
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• Bend angles that are smaller than 180 degrees get dimensioned based on the 

Theoretical Intersection Point of the bend. 

For a 180 degree bend, one bend value is reported for the location of the center of 

the arc of the 180 degree bend.   

To Set the Bend Arc Threshold 

1. Open the LineStock dialog box and go to the DesignRule tab.  

2. The default value of Bend Arc Threshold is 165 degrees. Modify this parameter 

as desired between 0 and 360. 

Example: Bend Arc Threshold 

IF 

BEND_ARC_THRESHOLD = 165 (default) 

THEN 

Route a 180-degree bend—Gets reported as one 180-degree bend from the arc 

center of the bend. 

IF 

BEND_ARC_THRESHOLD = 180 

THEN 

Route a 180-degree bend—Gets reported as one 180-degree bend from the arc 

center of the bend. 

IF 

BEND_ARC_THRESHOLD = 181 

THEN 

Route a 180-degree bend—Gets reported as two 90-degree bends from the 

theoretical intersection points. 

Design Rules Checking 

About Design Rules Checking 

You can enable or disable the design rule check during the pipe modeling process. 

When you enable the design rule check, the location of violations can be displayed 

and you can rectify them at an early stage. The modeling process then proceeds with 

greater accuracy.  

Use the design rule checking functionality to: 
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• Select the design rules to check whenever violations can occur due to a specific 

pipe modeling operation. You can select all design rules or only a few design 

rules.  

• Indicate the location of a design rule violation. 

Note: To enable the checking of design rules for piping assemblies that are created 

using versions of Pro/ENGINEER earlier than Wildfire, set the 

piping_wildfire_covert configuration option to automatic or manual. 

To Check for Design Rule Violations (Non Spec-Driven) 

1. Click . The Design Rules Check dialog box opens. 

Note: The Design Rules Check dialog box opens only when: 

o An active assembly contains a pipeline for which you can check design 

rules.  

o The pipe_allow_design_check configuration option is set to on if you are 

working with a pipeline assembly that has been created using versions of 

Pro/ENGINEER earlier than Wildfire. 

2. Under Setup, click one or more of the following design rules to check: 

o Missing Fitting—Checks for missing fittings in the assembly. Under 

Design Rules Tree, click a missing fitting violation type to display the 

violation information under Violation Details. 

o Segment Violations—Checks for violations in segment length. Under 

Design Rules Tree, click a segment violation type to display the violation 

information under Violation Details. 

o Bend Violations—Displays the bend violation results for a pipeline. Under 

Design Rules Tree, click a bend violation type to display the violation 

information under Violation Details. 

o Branch Violations—Displays the branch violations in a pipeline. Under 

Design Rules Tree, click a branch violation type to display the information 

under Violation Details. 

o Flow Violations—Checks for conflicts in the flow direction. Under Design 

Rules Tree, click Flow Violations to display the name of the datum point 

feature at the location of flow conflict under Violation Details.. 

The number of violations are displayed in parentheses next to the appropriate 

tree node under Design Rules Tree. 

Note: If you do not want to check for any of the previous design rule violations, 

clear the appropriate design rule from the Setup list. 

3. If required, click Tree and select one of the following: 

o Expand All—Expands all the tree nodes. 
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o Expand One—Expands only the selected tree node and not its component 

child nodes. 

o Expand Branch—Expands the selected tree node and all its component 

child nodes. 

o Collapse All—Collapses all the tree nodes. 

o Collapse One—Collapses only the selected tree node or a child node of a 

tree node. 

o Collapse Branch—Collapses the selected tree node and all its component 

child nodes. 

Note: A tree node and its child nodes represent design rules in all the above 

cases. 

4. Click  or  to select a record under Violation Details. 

5. Click  to display the design rule violation information in the INFORMATION 

WINDOW. 

Displaying Missing Fitting Violations 

Missed fitting types are displayed under Design Rules Tree in the Design Rules 

Check dialog box as Corner Fitting. Violation results for missing corner fittings are 

displayed under Violation Details. 

Displaying Segment Violations 

Segment violation types are displayed under Design Rules Tree in the Design 

Rules Check dialog box as follows:  

• Min Segment Length—Displays violation results if you create a pipe segment 

with a length shorter than the minimum segment length. 

• Max Segment Length—Displays violation results if you create a pipe segment 

with a length greater than the maximum segment length.  

Note: The violation results are displayed in the following columns under 

Violation Details when you click Min Segment Length or Max Segment 

Length:  

o Line Stock—The name of the line stock. 

o Current—The current segment length.  

o Required—The required minimum or maximum segment length. 

• Total Segment Length—Displays violation results if you create pipe segments 

of a pipe in the active assembly where the pipe segments have length greater 

than the total pipe length. The violation results are displayed in the following 

columns under Violation Details: 



Pro/PIPING (Non Specification-Driven) 

57 

o Line Stock—The name of the line stock.  

o Current—The current segment length.  

o Required—The required total segment length. 

Displaying Bend Violations 

Bend violation types are displayed under Design Rules Tree in the Design Rules 

Check dialog box as follows:  

• Max Bend Numbers—Displays violation results if you create bends on a pipe 

segment greater than the specified maximum bend number value.  

• Start Clamp Length—Displays violation results if you create a pipe segment 

with its start clamp length less than the specified value. 

• Middle Clamp Length—Displays violation results if you create a pipe segment 

with its middle clamp length less than the specified value. 

• End Clamp Length—Displays violation results if you create a pipe segment with 

its end clamp length less than the specified value. 

• Min Bend Radius—Displays violation results if you create a pipe bend with its 

radius less than the specified value. 

• Max Bend Radius—Displays violation results if you create a pipe bend with its 

radius greater than the specified value. 

• Min Bend Angle—Displays violation results if you create a pipe bend with its 

angle less than the specified value. 

• Max Bend Angle—Displays violation results if you create a pipe bend with its 

angle greater than the specified value. 

In all the previous cases, the violation results are displayed in the following columns 

under Violation Details: 

• Line Stock—The name of the line stock.  

• Current—The current bend number, start clamp length, middle clamp length, 

end clamp length, bend radius, or the bend angle. 

• Required—The required bend number, start clamp length, middle clamp length, 

end clamp length, minimum bend radius, maximum bend radius, minimum bend 

angle, or the maximum bend angle. 

Displaying Branch Violations 

Branch violations are displayed under Design Rules Tree in the Design Rules 

Check dialog box as follows:  

• Min Branch Separation—Displays violation results if you create branches on a 

pipe segment with the distance between the branches less than the specified 

minimum branch separation. 
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• Min Branch Angle—Displays violation results if you create a branch with the 

angle between the branch and the main pipeline less than the specified minimum 

branch angle value. 

In the previous cases, the violation results are displayed in the following columns 

under Violation Details. 

o Line Stock—The name of the line stock.  

o Current—The current branch separation or the branch angle. 

o Required—The required minimum branch separation or the minimum 

branch angle. 

Checking Design Rules 

Pro/PIPING determines whether any related design-rule check has been enabled at 

the end of each of the pipe modeling operations as discussed in the following table. 

Use the Define Design Rules dialog box to change the default values specified in 

the table below. 

Design 

Rule 

Where to Define 

in the SpecDB 

Where to Store 

in the Model 

Check After 

Missing 

Fitting 

 

Corner 

fitting 

 

  Route Pipe, Modify 

Corner Type, Delete 

Fitting 

Segment 

Violations 

 

Minimum 

segment 

length 

MIN_LEN column 

of the Pipe 

Manufacture 

 Directory file 

MIN_SEGMENT_

LENGTH line 

stock parameter 

Route Pipe, Modify 

Dimension, Modify 

Pipe, Modify Corner 

Type, Insert Fitting, 

Replace Fitting, 

Redefine Fitting, Cut 

Pipe 

Maximum 

segment 

length 

MAX_LEN column 

of the Pipe 

Manufacture 

Directory file 

MAX_SEGMENT

_LENGTH line 

stock parameter 

 

Route Pipe, Modify 

Dimension, Modify 

Pipe, Modify Corner 

Type, Insert Fitting, 

Delete Fitting, Replace 

Fitting, Redefine 

Fitting, Delete Cut 
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Total 

segment 

length 

MAX_OVERALL_LE

N column of the 

Pipe Manufacture 

Directory file 

MAX_OVERALL_

LENGTH line 

stock parameter  

Route Pipe, Modify 

Dimension, Modify 

Pipe, Modify Corner 

Type, Insert Fitting, 

Delete Fitting, Replace 

Fitting, Redefine 

Fitting, Delete Cut 

Bend 

violations 

 

Maximum 

bend 

numbers 

MAX_BENDS 

column of the 

Pipe Manufacture 

Directory file 

MAX_NUMBER_

BENDS line 

stock parameter 

Route Pipe, Modify 

Corner Type, Delete 

Fitting, Delete Cut 

Start 

clamp 

length 

START_CLAMP_LE

N column of the 

Bending Machine 

file 

The first 

element of the 

MIN_STRAIGHT

_LENGTH_END 

line stock 

parameter 

Route Pipe, Modify 

Dimension, Modify 

Pipe, Modify Corner 

Type, Insert Fitting, 

Replace Fitting, 

Redefine Fitting, Cut 

Pipe 

Middle 

clamp 

length 

MID_CLAMP_LEN 

column of the 

Bending Machine 

file 

MIN_BEND_SEP

ARATION line 

stock parameter 

Route Pipe, Modify 

Dimension, Modify 

Pipe, Modify Corner 

Type 

End clamp 

length 

END_CLAMP_LEN 

column of the 

Bending Machine 

file 

The second 

element of the 

MIN_STRAIGHT

_LENGTH_END 

line stock 

parameter 

Route Pipe, Modify 

Dimension, Modify 

Pipe, Modify Corner 

Type, Insert Fitting, 

Replace Fitting, 

Redefine Fitting, Cut 

Pipe 

Minimum 

bend 

radius 

MIN_RADIUS 

column of the 

Bend file 

MIN_BEND_RAD

IUS line stock 

parameter 

Modify Corner Type, 

Update Bend 

Parameters 

Maximum 

bend 

radius 

MAX_RADIUS 

column of the 

Bend file 

MAX_BEND_RA

DIUS line stock 

parameter 

Modify Corner Type, 

Update Bend 

Parameters 

Minimum 

bend angle 

MIN_ANGLE 

column of the 

Bend file 

MIN_BEND_ANG

LE line stock 

parameter 

Route Pipe, Modify 

Dimension, Modify 

Corner Type, Update 

Bend Parameters 
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Maximum 

bend angle 

MAX_ANGLE 

column of the 

Bend file 

MAX_BEND_AN

GLE line stock 

parameter 

Route Pipe, Modify 

Dimension, Modify 

Corner Type, Update 

Bend Parameters 

Branch 

violations 

 

Minimum 

branch 

separation 

 MIN_BRANCH_S

EPARATION line 

stock parameter 

The default 

value is 50 mm 

or its equivalent 

in the pipeline 

assembly length 

unit. 

Route Pipe Branch To, 

Route Pipe Branch 

From, Modify 

Dimension 

Minimum 

branch 

angle 

 MIN_BRANCH_A

NGLE line stock 

parameter 

The default 

value is 30 

degrees. 

Route Pipe Branch To, 

Route Pipe Branch 

From, Modify 

Dimension 

Flow 

conflict 

  Route Pipe, Modify 

Pipeline, Extension or 

Series Flow Direction 

Non Specification-Driven Pipe Fabrication 

About Fabricating Pipes 

The Non Specification-Driven method of modeling includes the following Pipe 

Fabrication functionality: 

• Pipe piece cutting functionality that allows you to insert or delete a cut. 

• Create a solid representation for piping insulation and store the information in the 

model.  

• Create a pipe solid for a pipe segment or the entire pipeline in the current active 

assembly.  

• Extract or delete a model. 
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Cutting Pipe Pieces 

About Cutting Pipe Pieces 

Use Cut Pipe to split a pipeline into pieces that can be manufactured. Cut Pipe 

allows you to alter the length of pipelines by splitting a straight segment into shorter 

raw pipe blanks, or cutting the pipe at a specific location to generate the desired 

spool. 

The piece cutting functionality allows you to perform the following tasks: 

• Cut a pipeline at a specified location.  

• Cut a straight pipeline segment at multiple locations by specifying the stock 

length or using a user-specified length of pipe. 

• Specify a cut location by referencing other objects such as an adjacent pipe 

segment, or a data reference plane. 

• Specify a cut location by an offset distance. 

• Cut all parallel pipe segments at locations identical to the reference pipe 

segment. 

• Assign shop or field weld attributes.  

To Cut Pipe at a Single Location Using Placement 

Use Cut Pipe to cut a pipeline at a specified location using distance or ratio 

placement.  

1. Click Applications > Piping > Fabrication > Cut Pipe. The Cut Pipe dialog 

box opens.  

2. Under Piece Cutting Options, select . 

3. Select the pipe segment in which you want to insert a cut. By default, the 

selected location is the placement location of the cut. The pipeline label is 

displayed under Select Pipe Segment as read only information. The distance of 

the selected location on the pipe segment is displayed in the thumb wheel input 

panel. 

4. Under Cut Placement Options, click one of the following:  

o —Distance Placement. Use the thumb wheel to reposition the cut 

location along the pipe segment or specify the distance in the input panel.  

Note: By default, Pro/PIPING considers the reference location from the 

start end of the pipe segment. Click  under Location Parameter to flip 

the location with reference to the end of the pipe segment. Pro/PIPING 

changes  to  to indicate the change in the reference location.  
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o —Ratio Placement. Specify a distance ratio from the upstream end of 

the specified pipe segment. 

Note: By default, Pro/PIPING considers the reference location from the 

start end of the pipe segment. Click  under Location Parameter to flip 

the location with reference to the end of the pipe segment. Pro/PIPING 

changes  to  to indicate the change in the reference location.  

5. To assign a weld attribute to this cut, under Weld Type, select Field or Shop. 

6. Do one of the following: 

o Click to insert a cut at the defined location, generate the specified 

weld attribute, and close the Cut Pipe dialog box.  

o Click to insert a cut at the defined location, generate the specified 

weld attribute, and continue inserting cuts with the Cut Pipe dialog box. 

o Click  to cancel the action and close the dialog box. 

Note: You can control the display format of the linear dimension and the incremental 

step value for the thumb wheel movement using the 

piping_thumb_wheel_increment configuration option. 

To Cut Pipe at a Single Location Using a Plane Reference 

Use the following procedure to insert a cut at a defined distance from a specified 

plane and generate a weld attribute. 

1. Click Applications > Piping > Fabrication > Cut Pipe. The Cut Pipe dialog 

box opens. 

2. Under Piece Cutting Options,  is selected by default. If it is not, select it. 

3. Select an approximate location on the pipe segment in which you want to insert a 

cut. The pipeline label is displayed under Select Pipe Segment as read-only 

information. 

4. Under Cut Placement Options, click . 

5. Select a datum plane that is perpendicular to the pipe segment. The name of the 

reference is displayed under Location Parameter. 

6. Use the thumb wheel to position the cut location along the pipe segment or 

specify the  distance in the input panel.  

7. Under Weld Type, the Field option is selected by default. If it is not, select it to 

assign a field weld attribute to this cut.  
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8. To insert the cut, do one of the following: 

o Click  to insert a cut at the defined location, generate the specified 

weld attribute, and close the Cut Pipe dialog box.  

o Click  to insert a cut at the defined location, generate the specified 

weld attribute, and continue inserting cuts with the Cut Pipe dialog box.  

To Cut Pipe at a Single Location Using a Pipe Reference 

In the following procedure, you place a cut at the specified location on a segment 

and then create a reference from an adjacent upstream pipe segment that is 

perpendicular to the segment where the cut is defined.  

1. Click Applications > Piping > Fabrication > Cut Pipe. The Cut Pipe dialog 

box opens. 

2. Under Piece Cutting Options,  is selected by default. If it is not, select it. 

3. Select an approximate location on the pipe segment in which you want to insert a 

cut. The pipeline label is displayed under Select Pipe Segment as read-only 

information. 

4. Under Cut Placement Options, select .  

5. Use the thumb wheel to position the cut location along the pipe segment or 

specify the  distance in the input panel. 

6. Under Weld Type, the Weld option is selected by default. If it is not, select it to 

assign a field weld attribute to this cut. 

7. To insert the cut, do one of the following: 

o Click  to insert a cut at the defined location, generate the specified 

weld attribute, and close the Cut Pipe dialog box.  

o Click  to insert a cut at the defined location, generate the specified 

weld attribute, and continue inserting cuts with the Cut Pipe dialog box. 

To Cut Pipe at Multiple Locations Based on Pipe Stock or User 
Specified Length 

Use this procedure to cut a straight pipeline segment automatically at multiple 

locations by specifying the stock length or based on a user-specified length of pipe. 

When you cut at multiple locations, the specified length is applied at intervals along 

the straight pipe segment.  

After you create multiple cuts in this manner, they are treated as individual cuts. You 

can manipulate them and delete them individually. 
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1. Click Applications > Piping > Fabrication > Cut Pipe. The Cut Pipe dialog 

box opens. 

2. Under Piece Cutting Options select . 

3. Select a straight pipe segment in which you want to insert multiple cuts. The 

pipeline label is displayed under Select Pipe Segment as read-only information. 

4. Under Interval Length, specify the desired Pipe Stock or Length to cut the 

pipe segment at multiple locations.  

5. Under Weld Type, the Field option is selected by default. If it is not, select it to 

assign a field weld attribute to this cut. Field Welds with unique identification 

numbers will be created at each cut location.  

6. To insert the cut, do one of the following: 

o Click  to insert cuts at the defined location, generate the specified 

weld attribute, and close the Cut Pipe dialog box.  

o Click  to insert cuts at the defined location, generate the specified 

weld attribute, and continue inserting cuts with the Cut Pipe dialog box. 

To Cut Parallel Pipes at Locations Identical to the Reference Pipe 

Use the following procedure to cut a group of parallel pipe segments in a single 

operation. All cuts on the selected parallel pipelines are created at locations that are 

identical to the locations of cuts on the reference pipeline.  

1. Click Applications > Piping > Fabrication > Cut Pipe. The Cut Pipe dialog 

box opens. 

2. Click  to cut parallel pipes at locations identical to locations on the 

reference pipe. 

3. Select a pipe segment that is part of a pipe run and has one or many pipe cuts. 

The pipeline label is displayed under Select Reference Pipe Run as read-only 

information. 

Note: Pro/PIPING does not allow selection of pipe segment of a pipe run that has 

no pipe cuts on it. 

4. Select the pipe segments parallel to the reference pipe run. The pipeline label of 

the selected pipe segments is displayed under Select Target Pipe Run as read-

only information. 

Note: Pro/PIPING does not allow selection of pipe segments that are not parallel 

to the reference pipe run. 

5. To insert cuts on parallel pipe runs at locations identical to locations on the 

reference pipe run, do one of the following: 
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o Click  to insert cuts on the parallel pipe runs and close the Cut Pipe 

dialog box.  

o Click  to insert cuts on the parallel pipe runs and then continue 

inserting cuts with the Cut Pipe dialog box. 

Tip: Selecting a Reference Pipe for Cutting Parallel Pipes 

Cuts on the target pipe runs are created using the placement type information 

associated with the corresponding cut on the reference pipe run. 

To create cuts on the target pipe runs at identical locations identical to locations on 

the reference pipe run: 

• Select only those pipe runs that are parallel to the reference pipe run as the 

target pipe runs. 

• Select the pipe run with multiple cuts as the reference pipe run. All these cuts on 

the reference pipe run must be created using the Length, Ratio Placement, or 

Distance Placement options. If the cuts on the reference pipe run are created 

using any other placement type option, Pro/PIPING creates cuts on the target 

pipe runs using the default Length placement type option. 

Assigning a Weld Type 

You can assign a shop weld attribute or field weld attribute at pipe piece cut 

locations.  

The Piping Isometric Drawing functionality uses both the shop weld and field weld 

information to mark the shop or field welds on isometric drawings.  

The shop or field welds are graphically represented and have a unique identification 

number which is automatically generated. For example, shop weld numbers are 

SW1, SW2, and so on.  

At any time during modeling, you can use the standard datum point creation 

tool, , on the Pro/ENGINEER toolbar to display or hide the shop or field welds. 

When cutting a set of parallel pipe runs at a location identical to the location on the 

reference pipe run, the cut on the target pipe runs is created with the same weld 

type as that of the corresponding cut on the reference pipe run. 

To Delete a Pipe Piece Cut 

Use this procedure to delete a single pipe cut piece or to delete all cuts on a single 

segment, overall pipe run, entire pipeline, or in a block. 

1. Click PIPING > Fabrication > Delete Cut. The Delete Cut dialog box opens.  

2. Based on the location of the cuts to be deleted, do one of the following: 

o Select Selected Cut to delete only the selected cut. The name of the 

selected cut location is displayed under Select Pipe Cut. 
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o Select All Cuts in Pipe Segment to delete the cuts on a pipe segment. 

The pipeline label of the selected pipe segment and the pipe segments' ID 

are displayed under Select Pipe Segment. 

o Select All Cuts in Pipe Run to delete all the cuts existing on an pipe run. 

The pipeline label of the selected pipe segment and the pipe segments' ID 

are displayed under Select Pipe Segment. 

o The pipe run includes all pipe segments between two consecutive free ends 

along a straight line, or a free end and a corner, or a corner and a free end, 

or a corner and another corner of a pipeline. 

o Select All Cuts at Block Boundary to delete all the pipe cuts on the 

boundaries of the selected block. Under Select Block Name, select a block 

name from the list.  

o Select All Cuts on Pipeline to delete the cuts in a pipeline. Select any pipe 

segment on the pipeline whose cuts are to be deleted. The pipeline label of 

the selected pipe segment is displayed under Select Pipeline. 

3. To delete the selected cuts, do one of the following: 

o Click  to delete all the selected cuts and close the Delete Cut dialog 

box.  

o Click  to delete the selected cuts. The pipeline automatically 

repaints with the cut deleted and the Delete Cut dialog box remains open 

for further cuts, if any. 

Pipeline Insulation 

About Pipeline Insulation (Non Spec-Driven) 

 

With Pro/PIPING you can assign insulation to a pipeline, part of a pipeline, and 

fittings. After you assign the insulation, Pro/PIPING creates insulation features that 

can be accessed in the Pro/ENGINEER Model Tree.  

You can perform the following insulation tasks at any time in the piping design 

process:  

• Assign insulation to an entire pipeline during pipeline creation or during piping 

design. 

• Assign insulation to any part of a selected pipeline. Target and insulate specific 

pipeline areas. 

• Modify any insulation assignment in your piping system. 

• Delete any insulation assignment in your piping system. 



Pro/PIPING (Non Specification-Driven) 

67 

• Create solid representations of insulation for immediate graphical identification 

and confirmation. 

• Generate detailed insulation reports for further insulation analysis. 

To Modify Insulation Assigned to a Pipeline (Non Spec-Driven) 

1. Click PIPING > Modify Pipe. The Modify Pipeline dialog box opens. 

2. Under Active Assembly, Pro/PIPING displays the current active assembly. If the 

pipeline to insulate is in a different assembly, click  and select the assembly 

that contains the pipeline. You can select the assembly from either the Model 

Tree or the Piping System Tree, or by selecting the pipeline in the graphics 

window. 

3. Under Modify Options,click Parameters and then under Pipe Line 

Parameters click Pipe Line. The Edit Pipeline dialog box opens.  

4. If active assembly contains multiple pipelines, select the pipeline to insulate from 

the Select Pipeline box. 

5. Click the Label tab.  

6. Under Pipeline Label, modify the insulation code for the selected pipeline. Two 

conditions apply for insulation modification: 

o If an insulation code was assigned to the pipeline, the Insulation box 

displays the code. You can select another insulation code from the list to 

change the insulation. 

o If an insulation code was not assigned to the pipeline, select the 

Insulation check box and select an insulation code from the list to insulate 

the pipeline. 

7. Click  to save the selections. Pro/PIPING modifies the insulation data in the 

insulation feature in the active assembly.  

8. Retrieve insulation information (PIPING > Info) to view the assigned insulation 

data. 

9. Click PIPING > Regenerate to regenerate the assembly to update the model 

display. 

Note: Pro/PIPING creates insulation quilts automatically after you create pipe solids. 

To Delete Insulation (Non Spec-Driven) 

Note: The Model Tree view must be set to display features in order to delete 

insulation features from within it. Click Settings > Tree Filters. The Model Tree 

Items dialog box opens. Under Display, check the Features box and click OK. 

1. Open the assembly containing the pipeline and the insulation to be deleted. 
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2. Click . The Model Tree opens. 

3. In the Model Tree, locate the assembly containing the insulated pipeline and 

corresponding the insulation feature. You can delete the following types of 

insulation features: 

o Insulation Features—Stores the insulation data (codes, names, thickness, 

sizes, and so on) for a pipeline. Pro/PIPING identifies the insulation features 

by insulation code. 

o Insulation Segment Features—Stores the start and end points for 

insulation on part of a pipe segment. Note that the insulation segment 

feature is a child of the related insulation feature. If you delete an 

insulation feature, Pro/PIPING deletes all related children, including the 

insulation segment feature, if applicable. If you delete the insulation feature 

from an insulated pipeline that also contains a partially insulated segment, 

all insulation data will be deleted.  

4. To locate the insulation segment feature to delete: 

a. Select the insulation feature and right-click.  

b. From the shortcut menu, select Info > Parent/Child. The Reference 

Information Window opens. Under Children of Current Feature, 

Pro/PIPING lists all children of the selected insulation feature. Insulation 

segment features are labeled Insulation Seg id <number>. 

5. Select the insulation feature to delete from the Model Tree. The feature is 

highlighted on the pipeline in the graphics window. Right-click, and a shortcut 

menu appears.  

6. Click Delete. A warning appears to confirm the action. 

7. Click . Pro/PIPING deletes the selected insulation feature from the Model 

Tree and the graphics window. 

To Report Insulation Information (Non Spec-Driven) 

1. Assign insulation to a pipeline or part of a pipeline. 

2. Click PIPING > Info. The Report Pipeline dialog box opens. 

3. Under Info Type, select General. 

4. Under Definition, select Insulation. 

5. Click  and select an insulated pipeline or insulated pipe segment from which 

to retrieve information. You can select from either the Model Tree, the Piping 

System Tree, or the graphics window.  

Pro/PIPING displays the selected pipe data in the box under Definition and 

displays the insulation information under Results. 
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6. Scroll to view the entire report or click  and view the report in the separate 

INFORMATION WINDOW. 

About Assigning Insulation to Part of a Pipeline (Non Spec-Driven) 

Pro/PIPING allows you to assign insulation to part of a pipeline (insulation segment) 

using the Create Insulation dialog box (PIPING > Fabrication > Insulation). 

During piping design, the following special cases can arise and necessitate an 

insulation segment: 

• Pipe Insulation in a Special Area—Pipelines and fittings not normally insulated 

require insulation inside special areas such as purifier rooms. 

• Pipe Insulation near Equipment—Pipelines can produce condensation and 

extreme temperatures. Insulate pipelines near equipment to prevent damage. 

To Assign Insulation to Part of a Pipeline (Non Spec-Driven) 

1. Click PIPING > Active Asm and select the active assembly that contains the 

pipeline to partially insulate.  

2. Click PIPING > Fabrication > Insulation. The Create Insulation dialog box 

opens. Start under Insulation Segment Points is selected by default. 

3. Follow these steps to select insulation start and end points. Start and end points 

must be on the same pipeline: 

a. Under Select Start Point, click  and select a pipe segment to specify 

the insulation start point. Crosshairs indicate the start point on the pipe 

segment, and the pipe segment ID populates the Select Start Point box. 

b. Click End under Insulation Segment Points.  

c. Under Select End Point, click  and select the insulation end point. 

Crosshairs indicate the end point on the pipe segment, and the pipe 

segment ID is displayed in the Select End Point box. 

4. Under Location Type, select one of the following options to specify both start 

and end point placement.  

Note: You must select the Start and End options under Insulation Segment 

Points to place the appropriate points. 

—Specifies the start or end point distance ratio from the pipe segment's 

upstream end. 

—Specifies the distance ratio of the start or end point from the pipe segment's 

upstream end. 
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Note: By default, Pro/PIPING considers the reference location from the start end of 

the pipe segment. Click  under Location Parameter to flip the location with 

reference to the end of the pipe segment. Pro/PIPING changes  to  to 

indicate the change in the reference location. 

—Places a start or end point on the pipe segment perpendicular to that pipe 

segment.  

Note: The pipe segment's start point must be perpendicular to the pipe segment's 

end point to make this option available. 

—Places a start or end point from a specified datum plane. The datum plane 

must be perpendicular to the pipe segment's start or end points. Pro/PIPING creates 

a reference to the datum plane. 

—Places a start or end point from a specified fitting. The selected fitting must 

exist in the same pipeline and in the same straight pipe piece. Click  under 

Location Parameter to flip the reference port. 

5. Under Location Parameter, specify the point location parameters based on the 

selected placement option. Use the thumb wheel to move the point placement or 

type a value in the thumb wheel box for exact placement. 

If you clicked , select a datum plane from the graphics window. Pro/PIPING 

displays the datum place name in the Location Parameter box. 

6. Under Insulation Parameters, select or enter the insulation name of the 

insulation assigned between the two specified points. 

7. Under Specify Insulation Parameters, the following parameters are displayed: 

o Material—Displays name of the insulation material  

o Stock No—Displays the Line Stock number   

o Thickness—Displays the thickness of the insulation 

o Color Name—Displays the insulation colour name  

You can change the parameters as per your requirements.  

8. Click  to save the selections. Pro/PIPING saves the insulation data in an 

insulation feature in the active assembly.  

9. Retrieve insulation information (PIPING > Info) to view the assigned insulation 

data. 
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Note: Pro/PIPING creates insulation quilts automatically after you create pipe solids. 

To Redefine Insulation Assigned to Part of a Pipeline (Non Spec-
Driven) 

Pro/PIPING creates insulation segment features after you assign insulation to part of 

a pipeline. You can redefine insulation segment features at any time in the piping 

design process. 

1. Open the assembly associated with the pipeline containing the insulation segment 

feature to be redefined. 

2. Click . The Model Tree opens. 

3. In the Model Tree, locate the insulation segment feature to redefine. The Model 

Tree lists the following insulation features: 

o Insulation Features—Stores the insulation data (codes, names, thickness, 

sizes, and so on) for a pipeline. Pro/PIPING identifies the insulation features 

by insulation code. Select the feature to highlight it in the graphics window. 

Note that you cannot redefine insulation features from the Model Tree (you 

must modify the database insulation files). 

o Insulation Segment Features—Stores the start and end points for 

insulation on part of a pipe segment.  

4. Select the insulation segment feature to redefine from the Model Tree. The 

feature is  highlighted on the pipeline.  

5. Right-click and a shortcut menu appears.  

6. Click Edit Definition. The Redefine Insulation dialog box opens with the 

insulation segment selected. 

7. Select Start under Insulation Segment Points and perform any of the 

following tasks: 

o Change the insulation start point. Under Select Start Point, click  and 

select a pipe segment to specify the insulation start point. Crosshairs 

indicate the start point on the pipe segment and the pipe segment ID is 

displayed in the Select Start Point box. 

o Change the insulation end point. Select End under Insulation Segment 

Points. Under Select End Point, click  and select the insulation end 

point. Crosshairs indicate the end point on the pipe segment and the pipe 

segment ID is displayed in the Select End Point box. 

o Change the start and end point placement. Under Location Type, select 

one of the following options to specify both start and end point placement. 

Note that you must select Start and End under Insulation Segment 

Points to place the appropriate points: 
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—Specifies the start or end point distance from the pipe segment's 

upstream end. 

—Specifies the start or end point distance ratio from the pipe 

segment's upstream end. 

—Places a start or end point on the pipe segment perpendicular to 

that pipe segment. Note that the pipe segment's start point must be 

perpendicular to the pipe segment's end point to make this option available. 

—Places a start or end point from a specified datum plane. The datum 

plane must be perpendicular to the start or end point pipe segment. 

Pro/PIPING creates a reference to the datum plane. 

—Places a start or end point from a specified fitting. The selected 

fitting must exist in the same pipeline and in the same straight pipe piece.  

Under Location Parameter, specify the point location parameters based 

on the selected placement option. Use the thumb wheel to move the point 

placement or enter a value in the thumb wheel box for exact placement.  

If you selected , select a datum plane from the graphics window. 

Pro/PIPING displays the datum place name in the Location Parameter 

box. 

o Change the insulation. Under Insulation Parameters, select a new 

insulation code to assign new insulation between the specified placement 

points. 

8. Click  to assign new insulation to the pipe segment. Pro/PIPING creates a 

new insulation feature and reassigns the insulation segment feature to it. 

Note: 

• The Model Tree must display features to redefine insulation segment features 

from the Model Tree. Click View > Model Tree Setup > Item Display. Under 

Display, check the Features box and click OK. 

• Pro/PIPING creates insulation quilts automatically after you create pipe solids. 
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Routing 

About Routing 

A physical pipeline consists of pipes and fittings. Before routing a new line, you must 

create a pipeline feature by assigning its name, line stock, and pipeline parameters.  

When creating new routing features, the system takes the default settings for shape 

and corner type from the current line stock parameter file for the pipeline being 

routed.  

Parameters that are set in a line stock determine routing commands. While routing, 

you can assign another line stock for segments that start after a fitting or from a 

new start point.  

You can also change line shape and corner type for subsequent segments.  

While routing lines or after routing is completed, you may insert fittings or modify 

pipeline properties according to your design needs. You can route pipelines only 

within the assembly or subassembly to which they belong. 

When routing, keep in mind the following: 

• You should create meaningful references to equipment or component geometry 

to allow pipeline segments to adjust their location whenever a piece of equipment 

or an assembly component moves. 

• You can use any coordinate system as a piping port (which eliminates the prior 

requirement of names needing to begin with PORT) in the working assembly and 

define them before assembling the equipment and fittings. The system 

determines the From/To report information for a pipe segment based on the 

entry ports to which it is attached at each end:  

o If the coordinate system belongs to the top-level assembly, it lists the top-

level assembly.  

o If the coordinate system belongs to the part, it lists the part; if it is not 

routed to an entry port, it does not show an entry. 

About Routing Pipelines 

To route pipelines parametrically, you can reference existing assembly components. 

Pro/PIPING offers flexibility by enabling you to route lines continuously or to join 

segments as the design intent develops.  

To route a pipeline, you locate the centerline by referencing assembly geometry. You 

can also use specific fittings and equipment with entry ports as locating points. Entry 

ports enable you to specify the orientation of contact points in fittings, equipment, 

and connecting lines.  

There is a Select Any command for routing reference. You do not have to specify 

port, pipe end, and so on, before you make a selection. The system figures it out for 

you and allows you to use Query Select if necessary. 
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Depending on the line shape (straight or flexible), you may employ different routing 

strategies. 

To Route a Typical Pipeline 

1. Set a start point. 

2. Create segments using the selected routing action. You may create individual 

unconnected segments. Indicate to the system a new start point where 

necessary. 

When routing segments continuously, the endpoint that was just created 

automatically becomes the start point for the next routing operation. 

3. Connect individual segments of the same pipeline.  

4. Create other pipelines to add branches to the main pipeline; then create 

branches.  

Using the Route Pipe Menu 

The following commands are available on the ROUTE PIPE menu to route and 

manipulate line segments: 

• Pipe Envrnmt—Set the default shape and corner type. 

• Set Start—Set a start point or create a branch start point. 

• Extend—Create a new pipe segment by extending in the specified direction. 

• To Pnt/Port—Create a pipe piece from the current start point to the selected 

point, port, or pipe end. 

• Follow—Create a pipeline by following an axis, curve, existing pipeline, or 

sketched path. 

• Connect—Connect entry ports and/or individual unconnected segments of the 

same pipeline. 

• Branch—Create a section that taps into a pipeline at the point you have 

specified.  

• Insert Point—Insert point in the previously routed pipe segment. 

• Delete Last—Delete the last routing operation. 

• Redefine—Redefine references of the routing operation. 

• Suppress—Suppress the pipe segments. 

• Resume—Resume the suppressed pipe segment. 

• Modify Dim—Change dimensions of any piping features or assembly 

components. 

• Replace—Replace selected pipeline segment with a routing operation. 
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These commands are available in both the Non Specification-Driven and 

Specification-Driven modes. 

About External References 

When you route pipes, the system automatically creates external references if 

necessary.  

An external reference (or an external dependency) is a relationship between a 

Pro/ENGINEER object (part, subassembly) and some information from another object 

that is not inherently available to the referencing objects all of the time.  

Pro/ENGINEER always creates an external reference in the context of an assembly, 

where some information is referenced that is external to the model you are 

changing.  

Whenever you retrieve the subassembly, the system automatically retrieves all of 

the components that belong to it. Therefore, information needed to place features 

and components is available.  

However, if the subassembly existed among some other components in a higher 

level assembly, and some of those other components that are members of the higher 

level assembly—but not the subassembly where the feature is being added—were 

referenced, the subassembly would have an external reference.  

The subassembly would never know exactly where the feature should be placed 

unless the subassembly was currently in session in the context of the top-level 

assembly. 

For example, if you create a Pipe To Point feature using a datum point in a part that 

is in a subassembly other than the one with the piping feature, the pipe routing 

feature now has an external reference.  

This feature belongs to the assembly where it was created and every time you 

regenerate the assembly, Pro/ENGINEER looks for this feature’s references in the 

part in the other subassembly.  

All of the information from the assembly is available during this regeneration. 

However, this dependency of the pipe routing is accurately and completely updated 

when it is in the context of the assembly containing both.  

To Manage External References 

The Reference Viewer and Reference Control tools (available with the Design 

Manager functionality) enable you to manage these external references by doing the 

following: 

1. Define the scope in which to create external references to other models in the 

context of an assembly. You can restrict any component to reference only the 

skeleton model of the subassembly to which this component belongs, or only 

components within that subassembly. 

2. Define how the system will behave when you attempt to create an external 

reference that violates the defined scope. 
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3. Identify the features in a model that have external references as well as the 

chain of dependencies from the feature to the referenced entity.  

4. Obtain information about those models that have external references to a 

specified model.  

5. To control the settings of these reference control and investigation tools, set the 

configuration file options allow_ref_scope_change, default_ext_ref_scope, 

and scope_invalid_refs. 

About Setting a Start Point 

Before you can route a pipe segment from one point to another, extend a pipe 

segment, or branch a segment into a pipeline at a specified point, you must set a 

start point.  

You can set a start point using an existing point, entry port, or pipe end; or you can 

create a new point. The system displays a start point as a highlighted circle.  

To Set a Start Point Using a Point, Entry Port, or Pipe End 

 

1. Click Piping > Route. The system prompts you to select a pipeline.  

2. Select a pipeline. The ROUTE PIPE menu appears.  

3. Click Set Start. The PIPE SELECT menu appears.  

4. Do one of the following:  

o Click Select Any to select any appropriate point, port or pipe end.  

o Click Point/s and select a datum point. 

o Click Entry Port and select an entry port at a fitting or equipment. You can 

also set start at a created entry port. 

o Click Branch Point and create a datum point using Make Datum. 

o Click Pipe End and select a pipe end. 

5. The system informs you that it has defined the start point and highlights it. 

Proceed to route a line using other routing commands. 

Routing Techniques 

With Pro/PIPING, you can route a new line or an existing line by using one of the 

following techniques: 

• Create a pipe segment by routing it from the current start point to a selected 

point or entry port. You can select multiple points through which to route. If 

necessary, set a start point first. 

• Create a new pipe segment by extending in the specified direction or up to 

specified geometry. If necessary, set a start point first. 
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• Connect entry ports or individual unconnected segments of the same pipeline.  

• Create a segment that taps into a pipeline at a specified point.  

• Create a pipeline by following an axis, cylinder, existing pipeline, or sketched 

geometry (this functionality is not available for flexible pipes). 

About Branching to Another Pipeline 

Using the Branch command in the ROUTE PIPE menu, you can create a branch in 

the piping system from one of the following: 

• Datum point or entry port to a pipeline 

• Pipe end of another pipeline 

• Branch point on a pipe centerline to another pipeline 

When a branch is attached to a pipeline, the system automatically creates cuts in the 

solids that meet at the branch point. The point of connection is located on a pipe 

centerline. 

You can create a branch starting from the end of an unconnected segment or from a 

point or entry port. However, you can not branch to a pipeline in another assembly 

or to another segment of the same pipeline. (This functionality is not available at all 

for flexible pipes.) 

To Create a Branch 

1. Click Route > Set Start to set a start point; then click Route > Branch. 

2. Using the BRANCH TO menu, do one of the following: 

o Click To Point. Select a connect point or create one using these commands 

in the PNT DIM MODE menu: 

Offset—Measures the distance from a selected reference plane. 

Length Ratio—Expresses the distance from the point to the end of the 

segment nearest the selected point as a ratio of the segment’s total length. 

Represents the resulting fraction in decimal form. The point retains the 

relative position along the length of the segment corresponding to any 

changes that you make in its length. 

Actual Len—Measures the distance from the nearest end of the segment. 

The point stays at that fixed distance from the end regardless of any 

changes you make to the length of the segment. 

o Click Perpendicular to create a branch perpendicular to a pipeline. 

3. Select a straight portion of a segment in the same assembly and part of a 

different pipeline.  

Fittings cannot be placed at branch points. A straight break tee fitting can be 

used if desired. 
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Example: Creating a Branch 

You cannot branch to a pipeline in a different subassembly or to a different segment 

of the same pipeline. 

 

1 Create a branch using this entry point as a start point 

2 Branch has been added perpendicular to a pipeline 

About Connecting Entry Ports or Unconnected Segments 

You can connect disconnected segments of the same pipeline or entry ports using the 

Connect command in the ROUTE PIPE menu. The system does not place a 

restriction on the orientation of the segments; it connects them even if they are not 

coplanar or parallel.  

You can create four possible types of straight segments: 
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• Collinear Segments—System extends the selected segments until they meet, 

forming a single segment. You can not modify this type of connection and the 

system does not create a dimension. 

• Coplanar Parallel Segments—System extends the two segments and adds an 

intermediate segment. You can modify the extension endpoints and the angles of 

the corners. If the current corner type is Bend, the system automatically adds 

bends. You can control the extension distances at both ends, or the extension 

distance and angle at one end. 

• Nonplanar Segments—System extends two segments and adds an 

intermediate segment. You can modify the extension endpoints and the angles of 

the corners as for coplanar parallel segments. 

• Coplanar Nonparallel Segments—System extends each segment until they 

intersect, creating a single corner. You can move the new endpoints of the 

connected segments to create an intermediate segment. 

To Connect Pipeline Segments 

1. Click ROUTE PIPE > Connect.  

2. For the first end, click Entry Port or Pipe End from the PIPE SELECT menu, 

and select the connect point.  

3. Do the same for the other end. The system connects the two selected ends with 

line segments as above. 

4. Click CONNECT > Change. 

5. Using the CHG CONNECT menu, change the conditions of the connect feature by 

modifying the settings for the operation: 

o Use Sel Connect to reselect connect end points. 

o Use Set Angle to set the angle at a corner. 

o Use Set Ends to extend connect ends. 

Driven dimensions is the default for newly created connect features—the 

dimensions of connect ends are driven by connected geometry, and the extension 

value updates when you relocate connected components. However, you can 

specify a fixed dimension value instead—the extension value does not change 

when you relocate connected components—and you can toggle between driven 

and fixed dimensions. 

When you modify the extension dimension of a connect feature using Mod Dim 

from the PIPE MODIFY menu, the EXT LENGTH menu appears and provides 

two options:  

o Enter Value—Defines a connect end dimension as fixed and allows you to 

specify the extension value (as is the case when you use Set Ends) 

o Rtrn to Driven—Defines a connect end dimension as driven by connected 

geometry and returns the selected dimension to its default driven value 
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Example: Straight Segments 

 

1 Collinear 

2 Coplanar 

3 Noncoplanar 

4 Coplanar Nonparallel 

You can control a1, d1, a2, d2, or d1, d2.  
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About Routing Flexible Pipes 

When routing flexible segments of pipelines, you can alternate line shape between 

straight and flexible segments on the same pipeline to control the resulting shape.  

For example, to make sure a hose exits from a fitting, goes through a hole without 

interfering, and so on, the physical hose would be all flexible, constrained by the 

fitting or the hole.  

Only the To Pnt/Port or Extend routing commands are available for flexible pipes; 

therefore, for routing that models the physical constraint, you may need to make a 

section straight to use commands such as Axis or Extend. 

When routing flexible pipes, keep in mind the following: 

• To route a flexible pipe though a hole, add a straight portion by changing the 

shape in the PIPE ENV menu, or route it by choosing Axis from the PIPE 

FOLLOW menu, and switch the line shape of subsequent segments back to 

flexible. 

• You can route flexible pipes from an entry port of a fitting. However, you can not 

insert fittings on flexible pipes. To ensure that a hose leaves a fitting without 

interfering, you can use a straight segment with an extend where it leaves the 

fitting. 

To Create Pipe Routing Using To Pnt/Port 

1. Using the To Pnt/Port command, route a pipeline from the currently active pipe 

end, entry port, or Set Start feature to a datum point, entry port, or a pipe end.  

2. If there is no currently active start point, you must create one. 

Tip: Routing Pipelines 

• You typically route pipelines between pieces of equipment and then insert 

fittings, but you can just as easily assemble the fittings first and route between 

them.  

• Pipeline routing in the assembly is highlighted. 

• You can now have straight routing follow a datum curve. 
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Example: Routing 

 

Routing to Datum Points 

About Routing to Datum Points 

When you create a datum point array in a piping assembly it is important to note 

that the resultant pipe segment will be routed through the datum points in the order 

the points were created. 

To Route a Pipeline to a Datum Point 

Note:  

While routing a pipeline, you can reassign line shape for pipe segments using the 

Pipe Envrnmt command in the ROUTE PIPE menu.  

On-the-fly datum points can be created in all routing options that require datum 

selection. 

1. Click Route > To Pnt/Port. The PIPE SELECT menu appears.   

2. Click Select Any to select any appropriate point, port or pipe end.  

Click Point/s to select a point.  

Click Entry Port to select an entry port. 
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Click Pipe End to select a pipe end. 

3. If you choose a point, the system asks if you want to route through the whole 

datum point array. If you click Yes, 

For straight segments, the BEND RAD menu appears.  

o Click Single Rad to route through the datum point feature using the 

default bend radius from the active line stock and click Quit. 

o Click Multiple Rad to specify the desired bend radius for each bend while 

routing, using the SEL VALUE menu and click Quit.   

For flexible segments with set length, the FIX LENGTH menu appears. 

o Click Single Val to route through the datum points, using the default 

length. 

o Click Multiple Val to specify the desired length for each segment while 

routing. 

The PIPE TO POINT feature is created.  

Creating a Datum  

Routing Command Create Datum Feature 

To Pnt/Port Point, Csys 

Extend – Direction Axis, Csys 

Extend – Up To Plane, Point 

Connect Csys 

Set Start Point, Csys 

Routing with Follow 

About Routing with Follow 

When you create pipe segments by following an axis/cylinder or sketched geometry, 

you do not need to set a start point. 

Using the PIPING > Route > ROUTE PIPE > Follow command, you can use one 

of the routing methods listed in the PIPE FOLLOW menu: 

• Sketch—Create a line segment based on sketched geometry. 

• Curve—Create a line segment based on a curve. 

• Pipe Line—Create a line segment based on an existing pipe line. 

• Axis—Create a line segment coincident with an axis. 
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Creating Pipeline Routing with Follow 

Using the Follow command in the ROUTE PIPE menu, you can create line segments 

based on sketched geometry, a curve, an existing pipeline, or coincident with an axis 

without having to set a start point.  

Following Sketched Geometry 

You can create pipe line segments according to your sketch with the Sketch 

command. This routing action can be useful when routing a pipe line with respect to 

equipment or some structural elements. The new segments must lie in the same 

plane. The following rules apply: 

• Following sketched geometry does not create a connection between the existing 

pipe end and new sketched segments, even if both end points are coincident. To 

join two endpoints, even if they are immediately on top of each other, use the To 

Pnt/Port or Connect commands. 

• Bend radii or miter corners are added automatically to sketched geometry.  

Example: Generating Sketched Geometry 

 

1 Sketched geometry 

2 After the line was generated 

To Route a Pipe by Following an Axis/Cylinder 

1. Click Piping > Route > Follow > Axis > Done. 

2. Select an axis or cylinder to follow. 

3. Adjust the segment ends on-the-fly by choosing Change > Ends > Done > Mod 

End. A cross indicates the selected end of the segment.  

4. From the CHOOSE menu, select Accept or Next.  

5. Using the END COND menu, do one of the following: 

o Click On End to constrain the pipe segment by the length of a cylinder or 

axis selected to follow; then click Done. 

or 

o Click Drag to extend the selected end of the pipe segment by dragging. 

Extend the line; then press the left mouse button to end the line. Adjust the 

length of the extension segment. 
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6. Adjust the other end of the segment by repeating Steps 1 through 5.  

7. Click Done > Done Follow. 

Following an Axis or Cylinder 

To create a pipeline segment by following an axis or a cylinder, use the Axis 

command in the PIPE FOLLOW menu. When you select a cylinder, the system 

creates an internal axis for the segment to follow.  

By default, the ends of the routed segment correspond to the endpoints of the axis it 

followed. However, you may extend the ends beyond the axis that it follows. 

To Route a Pipeline to Follow an Existing Pipeline 

1. Click Route > Follow > Pipe Line > Done.  

2. Select an existing pipe segment to follow. 

3. From the START/END menu, click Specify or Entire Line to specify if the 

routed pipeline should follow only a portion of the pipeline segment or the entire 

pipeline. 

4. From the CONSTRAINT menu, click a command to constrain the pipeline to 

route 

o Thru Point—Selects or creates a point through which the routed pipeline 

must pass. This point should lie relatively near the starting point of the pipe 

length selected to follow. 

o Start Point—Selects or creates a point at which the routed pipeline must 

start. 

o DistInPlane—Selects a reference plane parallel to the starting segment of 

the reference pipeline, and defines the distance between the reference 

pipeline and the pipeline to route on this reference plane. The value of this 

distance must be at least the sum of the radii of the pipe being routed and 

the pipe followed to prevent the pipes from intersecting. 

5. Do one of the following: 

o If you used Thru Point or Start Point to constrain the routed pipe, click 

Create or Select from the PIPE POINT to specify a point to serve as the 

through point or start point for the routed pipeline. The newly routed 

pipeline appears. 

o If you used DistInPlane to constrain the routed pipe, use the SETUP 

PLANE menu to select or make a datum plane through the pipe you are 

following on which the new routing will appear. Specify the direction from 

the reference pipeline the system should offset the routed pipeline, and 

type the distance. The newly routed pipeline appears. 

6. Click INT FOLLOW > Change to modify the conditions for the follow operations, 

if desired, and click Done Follow. 
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Following an Existing Pipeline 

To route a pipeline segment by following an existing pipeline, use the Pipe Line 

command in the PIPE FOLLOW menu. You would typically use this method when 

routing pipelines that are very close together with similar geometry, as with a heat 

exchanger or pipes grouped to pass through a bulkhead. 

Non Specification-Driven Piping Flow Direction 

About Non Specification-Driven Piping Flow Direction 

A pipeline has specific flow direction requirements based on the process flow 

requirements of the fluid inside the pipeline, such as gas, water, or fuel. 

Pro/PIPING automatically assigns a default flow direction to each pipeline you create 

during modeling. A set of Flow Direction Rules determines the flow of direction. You 

can enable or disable the display of flow direction during the modeling of the pipeline 

in the active assembly.  

Using Flow Direction, you can perform the following tasks: 

• Display the currently assigned flow direction of the following: 

o Specified pipeline series 

o All series in a pipeline 

o Specified extension 

• Reverse the assigned flow direction of all series in the specified pipelines. 

• Reverse the assigned flow direction of specified pipeline extensions. 

Default Flow Direction Determination Rules 

When you create a pipeline in any sequence, the flow direction function assigns 

default flow directions automatically based on the following rules: 

• Rule 1—The flow direction of a pipeline series is automatically determined by the 

direction of the first pipe segment in the series. 

Note:  

o You can create a pipeline series by concatenating several independent 

segments that were created with the Extend, Follow, and Connect 

commands. Each of these commands can have opposing flow directions. 

When you connect the segments to form a pipeline series, the flow direction 

of the series is assigned based on the direction of the pipe segment that 

was created first. 

o If you create the first segment in the correct flow direction, this ensures the 

correct flow direction for the entire series. Otherwise, you must reverse the 

resulting series. 
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• Rule 2—The flow direction of a new series, which is split and created as a result 

of inserting a branch fitting or stub-in, is the same as the original series from 

which it is created. 

To Display or Hide the Flow Direction of a Pipeline 

1. Click   to switch between displaying and hiding the flow direction of the 

pipelines in the active assembly. 

2. Click  to display the Piping System Tree. Select a pipe segment in the 

graphics window or a node from the Piping System Tree and right-click. A 

shortcut menu appears. Click Flow > Show to display the flow direction of the 

selected pipe series or pipeline.  

Note: If you are working with pipeline assemblies that have been created using the 

earlier versions of Pro/ENGINEER, the toolbar option  appears only if you set the 

pipe_allow_design_check configuration option to on.  

To Display the Flow Direction of a Pipeline 

1. Click PIPING > Modify Pipe. The Modify Pipeline dialog box opens. 

2. Under Active Assembly select the active assembly. 

3. Under Modify Options, click Flow Direction.  

4. Under Flow Direction, select the flow unit you want to modify by selecting from 

the list. The options are: 

o Pipeline 

o Extension 

o Series 

Select the unit. In the graphics window the flow direction is indicated by arrows 

along the pipeline. 

5. Under Flow Reversal, click  to reverse the flow direction.   

6. Click  to close the dialog box.  
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Example: Displaying the Flow Direction of a Specified Pipeline 
Series 

 

Flow Direction Violations 

You can view warning messages about violations in the Design Rules Check dialog 

box. The location of flow violation is marked on the screen with a dot.  

You can encounter following flow violations: 

• Converging flow at a junction. 

• Diverging flow at a junction. 

• Converging pipelines (two different pipelines that share a physical connection 

point but are opposed in direction). 

• Diverging pipelines (two different pipelines that share a physical connection point 

but are opposed in direction). 

• Pipelines with dead loops (loops that feed back into the pipeline and have no 

outlet). 

Suppressing and Resuming Pipe Segments 

About Suppressing and Resuming Pipe Segments 

When you route pipelines, you can suppress or resume one or more pipe segments 

to modify the pipeline trajectory. 
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Note: 

• The pipe segments that you want to suppress must belong to the same pipeline 

that you are currently routing. 

• You can suppress pipe solids. 

• Fittings of type break, cut, or elbow, that are placed on the ends of a suppressed 

pipe segment, are automatically changed to type "on end." 

• All the suppressed components are resumed during the resume operation. 

• You cannot resume a suppressed pipe segment if its end is used by a new 

segment due to routing. 

• You cannot suppress pipe segments that have insulation, branch points, pipeline 

labels, or spools. 

To Suppress and Resume Pipe Segments 

1. Click Piping > Route > Suppress. 

2. Select the pipe segment to suppress. Pro/PIPING suppresses the selected 

pipelines and all the highlighted children. 

3. Click Piping > Route > Resume. 

4. Select the suppressed pipe segments that you want to resume. Pro/PIPING 

resumes all the suppressed segments and their associated components. If the 

selected pipe segment cannot be resumed, it is highlighted in red. 

Example: Suppressing and Resuming Pipe Segments 

The original pipeline trajectory is shown in the next figure. 

 

If you suppress segments #1 and #3, Pro/PIPING suppresses the associated flanges 

and gaskets that are mated, as shown next: 
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If you click Resume, all the segments that were previously suppressed are 

highlighted in yellow. 

 

If you select segment # 3, Pro/PIPING resumes segment #3, the flange, and the 

gasket. 

 

Pro/PIPING uses the free segment end for the new routing. 
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If you click Resume again, segment #1 is not resumed, because its end is occupied 

by an elbow of type "on end." 

 

Pipe Extends 

About Non Specification-Driven Routing with Extend 

You can route a new pipe segment by extending the segment in a selected direction. 

To extend a pipe segment, the reference coordinate system can be one of the 

following:  

• Any coordinate system in the active assembly or any other assembly 

• The global coordinate system in the active assembly 

• The routing coordinate system 

By default, Pro/PIPING uses the reference coordinate system that was used for the 

previous extend operation in the active assembly. If an extend operation was not 

performed earlier in the active assembly, the global coordinate system is used by 

default. 
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To Extend a Pipeline by Referencing a Plane or a Point (Non Spec-
Driven) 

1. Click PIPING > Route > Set Start, and specify the start point for the pipeline 

extension. 

2. Click PIPING > Route > Extend. The Extend dialog box opens. 

3. Under Select Reference, do the following: 

o Under Selection, click  to select the reference coordinate system for 

the pipe segment to be routed or select one of the following from the list 

adjacent to  to specify the reference coordinate system: 

Global Csys—Selects the global coordinate system as the reference 

coordinate system. 

Route Csys—Selects the routing coordinate system as the reference 

coordinate system. 

Other coordinate systems that you have used for the previous extend 

operations in the same extend session. 

o Under Type, select the extend type as Plane/Point to specify that the 

pipe segment will be extended up to the selected plane or a point. 

o Select a plane or a point as the reference. 

4. Under Upto Plane/Point, select one of the following from the Options list: 

o Length—Extends the pipe segment to the given length up to a reference 

plane or a point. Specify a value for length in the Value box.  

o Offset—Extends the pipe segment up to the reference plane or point until 

the end of the pipe segment is at a given offset distance from the reference 

plane or point. By default, Pro/PIPING displays the distance between the 

start of the pipe segment and the reference plane or point in the Value 

box. Change this value if required. 

o Offset Fm Ref—Extends the pipe segment up to the reference plane or 

point until the end of the pipe segment is at a given offset distance from 

another selected reference plane or coordinate system. Do each of the 

following: 

Under Select Plane/Csys, select the reference plane or coordinate 

system. 

Specify a value for the offset distance in the Value box or click  and 

drag the pipe segment to the required length. Pro/PIPING displays a 

preview of the pipe segment that is extended using the drag operation, in 

the graphics window. 

If a coordinate system is selected, use the Projection list to specify an axis 

as the projection axis. If you project the end of the pipe segment to the 
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selected projection axis, the corresponding coordinate value will be equal to 

the given offset distance.  

Note: The Projection box is not available if you select a plane under 

Select Plane/Csys. 

o Offset Edge—Extends the pipe segment up to the reference plane or point 

until the end of the pipe segment is at a calculated offset distance from the 

reference plane or point. Specify a value for the offset distance in the 

Value box. 

Note: Calculated offset distance = offset distance (+) or (-) 1/2 pipe outer 

diameter, depending on the offset direction.   

o Offset Edge Fm Ref—Extends the pipe segment up to the reference plane 

or point until the end of the pipe segment is at a calculated offset distance 

from another selected reference plane or pipe edge. 

o Stop At—Extends the pipe segment up to the reference plane or point. 

5. Click  to extend the pipe segment up to the reference plane or point with 

the required length. 

To Extend a Pipeline by Referencing an Edge, Axis, or a Segment 
(Non Spec-Driven) 

1. Click PIPING > Route > Set Start, and specify the start point for the pipeline 

extension. 

2. Click PIPING > Route > Extend. The Extend dialog box opens. 

3. Under Select Reference, do the following: 

o Under Selection, click  to select the reference coordinate system for 

the pipe segment to be routed or select one of the following from the list 

adjacent to  to specify the reference coordinate system: 

Global Csys—Selects the global coordinate system as the reference 

coordinate system. 

Route Csys—Selects the routing coordinate system as the reference 

coordinate system. 

Other coordinate systems that you have used for the previous extend 

operations in the same extend session. 

o Under Type, select the extend type as Axis/Edge/Segment to specify 

that the pipe segment will be extended parallel to the selected axis, edge, 

or pipe segment. 

o Select an axis, edge, or a pipe segment as the reference. 
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4. Under Parallel to Axis/Edge/Pipe Segment, select one of the following from 

the Options list: 

o Length—Extends the pipe segment to the given length along the reference 

axis, edge, or a pipe segment. Specify a value for the length in the Value 

box. 

o Offset Fm Ref—Extends the pipe segment along the reference axis, edge, 

or a pipe segment till the end of the pipe segment is at a given offset 

distance from another selected reference plane or csys. Do each of the 

following: 

Under Select Plane/Csys, select the reference plane or coordinate 

system. 

Specify a value for the offset distance in the Value box or click  and 

drag the pipe segment to the required length. Pro/PIPING displays a 

preview of the pipe segment that is extended using the drag operation, in 

the graphics window. 

If a coordinate system is selected, use the Projection list to specify an axis 

as the projection axis. If you project the end of the pipe segment to the 

selected projection axis, the corresponding coordinate value will be equal to 

the given offset distance.  

Note: The Projection box is not available if you select a plane under 

Select Plane/Csys.  

Note: The options Offset, Offset Edge, Offset Edge Fm Ref, and Stop At are 

not available if you use an axis, edge, or a pipe segment as a reference to extend 

the pipeline. 

5. Click  to extend the pipe segment along the reference axis, edge, or a pipe 

segment with a required length. 

To Extend a Pipeline Using a Csys Axis Reference (Non Spec-
Driven) 

1. Click PIPING > Route > Set Start, and specify the start point for the pipeline 

extension. 

2. Click PIPING > Route > Extend. The Extend dialog box opens. 

3. Under Select Reference, do the following: 

o Under Selection, click  to select the reference coordinate system for 

the pipe segment to be routed or select one of the following from the list 

adjacent to  to specify the reference coordinate system: 

Global Csys—Selects the global coordinate system as the reference 

coordinate system. 
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Route Csys—Selects the routing coordinate system as the reference 

coordinate system. 

Other coordinate systems that you have used for the previous extend 

operations in the same extend session. 

o Under Type, select the extend type as Csys Axis to specify that the pipe 

segment will be extended along the selected axis of the reference 

coordinate system. 

4. Under Along Csys Axis, do the following: 

a. Under Select Axis, select one of the reference coordinate system axes as 

the reference axis. 

b. Under Options, select one of the following to specify the length of the pipe 

segment: 

Length—Extends the pipe segment to the given length along the reference 

axis. Specify a value for the length in the Value box. 

Offset Fm Ref—Extends the pipe segment along the reference axis until its 

end is at a given offset distance from another selected reference plane or 

coordinate system.  Do each of the following: 

5. Under Select Plane/Csys, select the reference plane or coordinate system. 

o Specify a value for the offset distance in the Value box or click  and 

drag the pipe segment to the required length. Pro/PIPING displays a 

preview of the pipe segment that is extended using the drag operation, in 

the graphics window. 

o If a coordinate system is selected, use the Projection list to specify an axis 

as the projection axis. If you project the end of the pipe segment to the 

selected projection axis, the corresponding coordinate value will be equal to 

the given offset distance.  

Note: The Projection box is not available if you select a plane under 

Select Plane/Csys. 

Note: The options Offset, Offset Edge, Offset Edge Fm Ref, and Stop At are 

not available if you use the Csys Axis extend type. 

6. Click  to extend the pipe segment along the reference axis with the required 

length. 

To Extend a Pipeline Using a Csys Reference (Non Spec-Driven) 

1. Click PIPING > Route > Set Start, and specify the start point for the pipeline 

extension. 

2. Click PIPING > Route > Extend. The Extend dialog box opens. 

3. Under Select Reference, do the following: 
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o Under Selection, click  to select the reference coordinate system for 

the pipe segment to be routed or select one of the following from the list 

adjacent to  to specify the reference coordinate system: 

Global Csys—Selects the global coordinate system as the reference 

coordinate system. 

Route Csys—Selects the routing coordinate system as the reference 

coordinate system. 

Other coordinate systems that you have used for the previous extend 

operations in the same extend session. 

o Under Type, select the extend type as Csys to specify that the pipe 

segment will be extended to the given coordinates of the reference 

coordinate system. 

4. Under To Coordinates, select the following dimension options: 

o Select the system as Spherical, Cylindrical, or Cartesian, and use the 

Angle box to specify whether you want the angles in the selected system 

to be represented in degrees, as a gradient ratio, or as a gradient 

percentage. 

Note: 

If you select the system as Cartesian, you cannot edit the angle. 

The value that you specify for the angle as a ratio or as a percentage is not 

a limited value. 

o Select one of the following dimension types: 

Relative—The extension of the end of the segment to be extended is 

referenced to the start of the segment. 

Absolute—The extension of the end of the segment to be extended is 

referenced to the selected reference coordinate system. 

o Under Locking Axes, select the extend directions along the x-, y-, or z- 

axes, or along all the three axes. 

o Under Coordinates, type the coordinate values along the respective axes 

in the available boxes or use the thumb wheel increments to specify the 

values. You can also click , and drag the pipe segment to the 

required length. Pro/PIPING displays a preview of the pipe segment that is 

extended using the drag operation, in the graphics window. Click  to lock 

the required coordinate boxes. The display changes to  to indicate that 

the boxes are locked. 

Note: The coordinates displayed under Coordinates vary depending on 

the selection that you make in the System box. If you select the system as 

Spherical, the coordinates displayed are r, theta, and phi. If you select the 
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system as Cylindrical, the coordinates displayed are r, theta, and z. If you 

select the system as Cartesian, the coordinates displayed are x, y, and z. 

5. Click  to extend the pipe segment to the specified coordinates. 

Example: Extend up to a Surface or Point 

 

1 Select this surface to extend up to 

2 Start from this point 

3 Enter the offset distance from the selected surface 

4 A new segment is created 
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Example: Extend a Pipeline in a Particular Direction 

 

1 Select this entry point as a start point 

2 A segment is created in the direction of Z-axis with the specified length 

3 Select this edge to indicate the extension direction. A red arrow indicates positive 

  direction 

4 To create this segment, type a negative length value 

5 The edge in whose direction the segment has to be created 

6 Create this segment in the direction of the specified edge  
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Routing Flexible Hoses with Minimum Bend Radius 

About Routing Flexible Hoses with Minimum Bend Radius 

You can route a pipeline with a minimum bend radius, defined for different gauges to 

ensure accurate representation of a flexible hose.  

Using Min Bend Radius in the LineStock dialog box, you can: 

• Define the minimum bend radius for routing flexible hose lines 

• Replace the linestock of existing hoses and automatically update the minimum 

bend radius values for those hoses 

• Verify that no bend radius violations exist using the Design Rules Check dialog 

box. 

To Route Flexible Hoses with Minimum Bend Radius 

1. Click Applications > Piping > Set Up > Line Stock > Create. 

2. Type the new line stock name and click . The LineStock dialog box opens.  

3. Click the DesignRule tab in the LineStock dialog box.  

4. Type a value for the Minimum Bend Radius under Design Rule Parameters. 

The parameter value is used as a guideline to maintain an accurate 

representation of the flexible hose. 

5. Route the flexible hose. 

6. Check for bend radius violations using the Design Rules Check dialog box or 

click Info > Geometry Checks. 

Note: Depending on the hose configuration, the specified minimum bend radius 

value can be violated during routing. A message appears when a violation has 

occurred. All violations of the bend radius are reported by both the Design Rules 

Check dialog box and the standard Pro/ENGINEER Geometry Check tool.    

Points on a Segment 

About Adding Points to Existing Routing 

Using the Insert Point command in the ROUTE PIPE menu, you can add a new 

point to existing straight routing and drag it to the new position. 

Note:  

• Straight routing can follow a datum curve. 

• You cannot use the Insert Point command on a pipe segment that is created 

using the Follow or Connect commands.  
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To Add Static Points to Existing Routing 

1. Click ROUTE PIPE > Insert Point. 

2. Select a straight pipeline segment to modify.  

3. To modify a free-length flexible pipe, go to Step 6. A theoretical bend intersection 

point appears on the screen as 'x.'  

4. Using the CHOOSE POINT menu, do one of the following: 

o Click Select and select an existing datum point. The pipe segment is 

reshaped to pass through the selected datum point. 

o Click Create and Static, and click Done. The DATUM POINT dialog box 

opens. Create a datum point. 

Note: To create a datum point using any other datum point creation tool, do the 

following: 

a. Open a datum point creation dialog box by clicking a datum point creation 

tool. For example, open the Offset CSys Datum Point dialog box without 

closing the DATUM POINT dialog box that you have opened earlier. 

b. Create a datum point using the Offset CSys Datum Point dialog box. 

c. Select the newly created datum point so that it appears as a reference in 

the DATUM POINT dialog box and click Ok. 

5. Use the Offset Surf or the Offset Csys commands in the OFFSET PNT menu to 

define the dimensioning references of the datum point. 

The selected pipe segment is replaced with new points and Pipe to Point features. 

6. Select a free-length flexible pipeline. You can add, delete, and move interpolation 

points as needed or move the control polygon points using the Modify Curve 

dialog box.  

To Add Dynamic Points to Existing Routing 

1. Click ROUTE PIPE > Insert Point. 

2. Select a straight pipe segment to insert the points. The ends of the pipe segment 

are highlighted.  

3. Click Create and Dynamic in the CHOOSE POINT menu and click Done. An 

additional point is highlighted between the ends of the pipe segment.  

4. Select a point or segment or a section on the pipe to move. Two points are 

highlighted on the pipe segment based on your selection.  

5. Click No or Yes in the message area depending on whether you want to create a 

single break point or two break points.  

6. Define the motion plane using the SETUP PLANE menu. 
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7. Use the sliders in the MOVE DRAG SEGMENT thermo tool to move the break 

point as well as the selected piece of the pipe segment. You can move the 

selected section of the pipe segment normal to the plane as well as normal to the 

pipe segment. The new shape of the pipeline is displayed dynamically according 

to the slider movement.  

Note:  

Set the sensitivity slider to 100 before you use the other sliders to move the 

point or the pipe segment.  

A section of the pipe segment is marked between the highlighted points as 

discussed in step 4.  

After setting the slider values, left-click in the area above the first slider in the 

MOVE DRAG SEGMENT thermo tool control area to accept the new shape, 

middle-click to abort the operation, or right-click to reset the MOVE DRAG 

SEGMENT thermo tool.  

8. Use the Offset Surf or the Offset Csys options in the OFFSET PNT menu to 

define the dimensioning references of the datum point. 

The original pipe segment is replaced with Pipe to Point features. The position of 

this point determines the position of the segment split when you create a 

dynamic point on a straight segment. 

Creating a Dynamic Point 

While modifying a pipeline segment, you can now insert two points on the segment. 

Working directly in the Pro/ENGINEER window, you can click and drag the straight 

segment until you define the shape that you want. 

Fittings 

About Fittings 

A fitting is a part or assembly that you add to a piping system to perform specific 

functions. You can store fittings in libraries so that you can easily retrieve them when 

you need to insert them in the pipeline. Generally, you can create four types of 

fittings:  

• Corner 

• End 

• Straight Break 

• Straight Continues 

Pro/PIPING treats a fitting as an assembly component. To be used as a fitting, a 

model must have the following features: 
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• Entry ports created at the connect points. An entry port is a coordinate system 

that you create in an assembly, in a part, or at the topmost level of a fitting (that 

is, at the highest level in a fitting assembly).  

Entry ports are specially named coordinate systems that can be referenced by 

certain piping routing features. By choosing Entry Port from the PIPE SELECT 

menu, you can select such a coordinate system. It allows you to define contact 

points, a direction for line routing, and the orientation of fittings.  

When creating an entry port, keep in mind the following:  

o The direction of the z-axis determines the direction for routing. In fittings, 

the z-axis always points out of the fitting and the pipeline enters or exits 

the fitting parallel to the z-axis. 

o In a fitting, entry ports are located along the centerline; the desired 

penetration distance of the pipe solid determines the offset of the entry port 

from the face of the fitting. The system trims pipe segments that go into 

the fitting at the entry ports, although the pipe centerline may continue 

through the pipe fitting. 

• A defined datum point for the system to use to align the fitting with the 

centerline of connecting pipe segments or at the end of a pipe segment. The 

alignment point is typically located along the z-axis at the center of symmetry of 

the fitting.  

Using commands in the FITTING menu, you can insert a fitting, delete it, redefine 

it, and replace it.  

You can also perform these operations using the Info, Edit Definition, Reroute, 

and Delete options from the shortcut menu that appears in the graphics window 

when you right-click. 



Pro/PIPING (Non Specification-Driven) 

103 

Example: Fittings 

 

1 Elbow 

2 Flange 

3 Miter 

Example: Tee Fitting with Required References 

For fittings with three defined entry ports, the alignment point should lie at the 

intersection of the z-axes. The z-axis of an entry port must point out of the fitting. 
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1 Three entry points are defined in this fitting 

2 Datum point is created along the centerline 

About Inserting a Fitting 

You can insert a fitting at a pipe end, at a fitting type corner of a pipeline, and along 

a straight segment of a pipeline. When inserting a fitting, keep in mind the following: 

• You must place fittings using special techniques. You cannot click Assemble from 

the COMPONENT menu to insert a fitting. You can assemble fittings as 

components and route up to them as for other equipment. However, fitting-

specific functionality will not apply. 

• Once you have inserted a fitting in a pipeline, it becomes associated with this 

pipeline. You can use only two of a fitting’s entry ports to insert the fitting in a 

pipeline. If there are more than two entry ports (as in a tee fitting, for example), 

you must twist the fitting to the desired orientation and then route a pipe 

segment to the third entry port. 

To Insert a Fitting  

1. Click Fitting > Insert.  

2. Using the INSERT TYPE menu, do one of the following: 

o To insert a fitting at a pipe end, click End. Select a pipe end at which to 

attach the fitting, an entry port on the fitting from which you want the pipe 

to come, and a point on the fitting to align with the pipe end.  

o To insert a fitting at a corner, click Corner. Select a fitting-type pipe 

corner, and go to Step 5. 
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o To insert a fitting that breaks the pipeline at a point on a straight segment 

of pipe, such as a valve, click Straight Brk. Select or create a point on a 

pipe segment. 

This changes the number of solids required for the pipeline. 

o To insert a fitting that does not break the pipe at a point on a straight 

segment of pipe, such as a support, click Straight Cont. Select or create a 

point on a pipe segment. 

3. Select a fitting from the Open dialog.  

4. Select a point on the fitting to align with the pipe centerline.  

5. The system places the fitting automatically. Adjust the orientation using 

commands in the ORIENT FIT menu (Fitting > Redefine). 

6. When you have placed the fitting properly, click ORIENT FIT > Done. 

Note: You can also insert a missing fitting node using the standard Model Tree 

Options. 
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Example: Pipe End Fitting and Straight Break 

 

1 Sample of Pipe End Fitting 

2 Sample of Straight Break 

About Deleting a Fitting 

Using the Delete command in the FITTING menu, you can remove a fitting and all 

subsequent segments. However, when removing a fitting, keep in mind the 

following: 

• If you delete a straight break fitting, the Straight Brk feature remains, unless 

you specifically delete it. This feature causes a break in the piping solid for the 

pipeline at that point. Thus, a straight segment of pipe has two solids, one on 

either side of the break.  

When the system asks you if you want to remove the pipe break as well, if you 

type [yes], it deletes the datum point and pipe joint feature. However, you also 
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have to specify whether you want to delete the solids as well, if they exist, since 

the centerline segments they referenced will no longer exist. There is now only 

one segment. 

• The Delete command works only on inserted fittings and does not remove other 

components. When you remove a straight-continuous fitting, you may also want 

to delete the datum point used for placement if you created it while placing the 

fitting.  

• If you delete a pipe joint on a segment that has other fitting children, the system 

asks you if you want to automatically reroute the fitting child to keep the current 

location along the pipe segment.  

If you type [yes], it automatically reroutes the point used for placement to the 

new pipeline segment that it created when you deleted the pipe joint so that it 

maintains the same position. If you type [no], use the Fix Model environment to 

fix the fitting child. 

To Redefine the Orientation of a Fitting 

 

1. Click Fitting > Redefine. 

2. Select a fitting to redefine. 

3. Click REDEF FITT > Orientation. To flip the fitting, go to Step 4. To twist it, go 

to Step 5. 

4. Click ORIENT FIT > Flip. The system flips the position of the entry ports. 

5. Click Twist and do one or all of the following, as necessary: 

o Using Set Zero Ref, set an edge or axis as the zero angular reference for 

the x-axis orientation of the highlighted port. 

You cannot twist internally inserted corner fittings. 

o Using Clear Zero Ref, remove a previously set zero reference by changing 

the fitting twist to be relative to its current position. The fitting maintains its 

position, and any twist dimension disappears.  

To modify twist dimensions, click Assembly > Modify > Value, Piping > 

Modify, or Piping > Route > Select > Query Sel. A Query Bin window opens. 

Click Accept. Then click Route Pipe> Mod Dim.  

o Using Enter Value, specify the rotation of the highlighted port in degrees 

about the reference-port z-axis. If there is no zero reference, this angle is 

relative to the current position. If there is a zero reference, the angle is 

between the zero reference and the x-axis on the highlighted entry port. 

o Using Align X, align the x-axis of the highlighted entry port to the 

geometry reference. 

o Using Align Y, align the y-axis.  
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The system updates the dimension and changes the position of the fitting 

accordingly. 

Example: Redefine the Orientation of a Fitting 

 

1 Reorient the fitting by flipping these entry ports 

About Redefining a Fitting 

Using the Redefine command in the FITTING menu, you can redefine the point of 

the fitting and place it, and you can change the orientation of the fitting while 

inserting it by flipping or twisting it.  

To Redefine the Point of a Fitting 

1. Click Fitting > Redefine. 

2. Select a fitting. The REDEF FITT menu appears. 
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3. Click Point. The FITT PNT menu appears. 

4. Click  Place Point. The Select menu appears.  

5. Select a point and click Done. 

6. If required, click FITT PNT > Align Point to change the alignment of the point. 

About Replacing a Fitting 

You can manually replace a fitting with another one or replace a fitting using a 

functional interchange member, family table, or layout.  

To Replace a Fitting 

1. Click Fitting > Replace. 

2. Select a fitting on the screen or Model Tree, or use Sel By Menu to select one 

from the namelist menu. 

3. From the REPLACE WITH menu, click a command to replace the fitting. 

4. Adjust the fitting orientation, using commands in the ORIENT FIT menu. 

Replacing a fitting can occasionally create conflicts with existing pipeline segments. 

For example, when you replace an internal fitting with one that has fewer entry 

ports, regeneration may fail.  

Or, when you replace a fitting after routing a line segment from an entry port of this 

fitting, this segment is a child of the original fitting from which it was routed.  

When you create such a conflict, the system suspends the replacement process and 

Pro/PIPING enters a special resolve environment. You can usually resolve the conflict 

by reselecting the contact points (entry ports).  

To Modify Penetration Distance 

Pipe solids associated with a fitting terminate at the entry port of the fitting’s 

coordinate system.  

1. To control the penetration distance in a fitting, modify the location of the entry 

port coordinate system in the fitting model.  

2. Regenerate the fitting model, and the system updates the solid pipe. 
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Modifying 

Modifying in Routing 

About Modifying in Routing 

Using commands in the ROUTE PIPE menu, you can delete the last routing 

operation, redefine the references of a routing operation, modify dimensions, and 

replace one or more contiguous pipeline segments with new routing.  

Alternatively, use the Modify Dim option from the Piping menu to modify 

dimensions. 

To Redefine the References of a Routing Operation 

1. Click ROUTE PIPE > Redefine. 

You can also redefine the references of a routing feature in the standard 

assembly environment using Redefine or Reroute in the ASSY FEAT menu, or 

from the Model Tree Window. 

2. Select a pipe segment to replace. The selected routing feature and all subsequent 

features temporarily disappear. 

3. Reroute the segment using the same type of routing action as the original. After 

you enter routing specifications, the pipeline regenerates and the subsequent 

features reappear referencing the newly created routing feature. 

To Modify Dimensions of Routing Features of a Pipeline 

1. Click Piping > ROUTE and select a pipeline segment to route. The ROUTE PIPE 

menu appears.  

2. Click Modify Dim. Select a pipeline. 

Solid pipe dimensions are read-only. You must select the pipeline of the segment 

that has the dimensions you want to modify. When you modify these dimensions 

and regenerate the assembly, the system updates the solid pipe feature to reflect 

any changes in the underlying routing. Thus, you cannot modify the dimensions 

of pipe solids, although you can view reference dimensions and show them in 

drawings of the solid. 

3. Select a dimension to modify and type a new value and press ENTER. 

4. Continue to modify other dimensions or click SELECT > Done Sel. The system 

automatically regenerates the assembly to update the pipeline with the new 

dimensions. 

To Replace One or More Contiguous Pipeline Segments 

1. Click PIPING > Route and select a pipeline segment to route. The ROUTE PIPE 

menu appears.  
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2. Click Replace > Enter Replace. 

3. Select routing features to replace, then click Done Sel. The selected features and 

all child routing features temporarily disappear. 

4. Route the new pipe using any combination of routing commands. 

5. When you have finished replacing the segments, click ROUTE PIPE > Replace. 

6. Click either Done Replace to confirm your changes, or Quit Replace to cancel 

them. The temporarily rolled-back pipeline reappears attached to the new end of 

the routing that replaced the old one. 

Changing Line Stock and Line Shape Parameters While Routing 
Pipelines 

At the outset of routing a pipeline, the system uses default parameters from the 

current line stock of the pipeline being routed. These environment settings are 

modal; that is, they remain set for all further routing until you change them.  

While routing a pipeline, you can reassign line stock, corner type, and line shape for 

subsequent segments using the Pipe Envrnmt command in the ROUTE PIPE menu. 

You can reassign a line stock for segments that start from a new start point or after 

a fitting. 

Rerouting a Routing Feature Attached to a Set Start Feature 

If you want to start a pipeline from a different Set Start feature, instead of deleting 

a routing feature attached to the Set Start feature and creating new routing, you 

can do one of the following: 

• Redefine or reroute the initial Set Start feature to the desired reference by 

selecting it by ID or from the Model Tree. 

• Replace the routing that is attached to the Set Start feature with another Set 

Start feature in the desired position plus another segment routed to connect it to 

the rest of the pipeline. 

Modifying Pipe Options 

About Modifying Pipe Options 

You can modify pipes in an active assembly with the Modify Pipeline dialog box. 

To modify existing segments: 

• Change dimensions of a feature created by a single routing action. Only 

dimensions created when routing the pipeline will be available for modification. 

• Assign a different line stock to a pipeline segment. 

• Change pipeline parameters. 

• Change bend parameters. 



Pro/PIPING (Non Spec-Driven) - Help Topic Collection 

112 

• Change the corner type. 

To Modify Pipeline Parameters 

1. Click PIPING > Modify Pipe. The Modify Pipeline dialog box opens. 

2. Click the Parameters button. The Parameters portion of the dialog box opens. 

3. Click Pipe Line. The Edit Pipeline dialog box opens. 

4. Using the Delete button, you can delete pipeline parameters. When removing 

pipeline parameters, if you select a pipeline that has children (any routing 

features, inserted fittings, pipe solids, branches, and so on), you must confirm if 

you want the system to delete them. 

5. Using the Add button, you can add user-defined pipeline parameters. Type in a 

name and value. 

To Modify Line Stock Parameters 

You can display line stock parameters and modify them in the Model Tree.  

1. Select and right-click on the parameter in the Model Tree. The shortcut menu 

appears. 

2. Choose the Modify command from the menu. The LineStock dialog box opens.  

To Modify Bend Parameters 

To modify bend parameters, use the Model Tree-like user interface. To access the 

Model Tree, follow this procedure. 

1. In the Modify Pipeline dialog box, click Modify Options > Parameters. The 

dialog box changes to show Pipe Line Parameters and Bend Parameters. 

2. Click Bend. The Bend Parameters Model Tree window opens. 

3. Select the bend parameter you want to change and press the right mouse button 

to activate the menu. Click the Modify command. 

Using the Modify Pipeline Dialog Box 

The Modify Pipeline dialog box lets you modify several options in the active 

assembly, the corners, parameters, line stocks, and flex shapes. In the Active 

Assembly area of this dialog box, click  to activate the assembly in the 

Pro/ENGINEER window. 

In the Modify Options area, the following choices appear. 

• Corner—Select types and values of single or multiple corners. 

• Line Stock—Set the values of selected single or multiple segments. 

• Parameters—Modify Pipeline and Bend parameters. 
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• Flex Shape—Modify the line shape of a flexible hose between Fixed and Free 

length. 

• Flow Direction—Select the flow unit and change the direction of the flow. 

When you click an option under Modify Options, the last area in the dialog box 

changes. For example, if you click Corner, a Corner group box appears. You need to 

select a pipe segment corner to change it to a Bend, Fitting, or Miter Cut  in the New 

Type box and to modify the value of the bend or fitting in the New Value box. 

If you click the Parameters option, the Parameters group box opens. 

In the Parameters area, you can select Pipe Line Parameters > Pipe Line or  

Bend Parameters > Bend to modify these parameters. If you click Pipe Line, 

the Edit Pipeline dialog box opens. If you click Bend, the Bend Parameters 

Model Tree opens. 

If you click the Line Stock option, the Line Stock group box opens. 

Modify the line stock listed in the Modify Linestock drop-down box with the Edit 

option or create a new line stock with the Create new option. If you click Create 

new, enter the line stock name at the command prompt. 

If you click the Flex Shape option, the Flex Shape group box opens. 

Modify the Flex Shape by selecting a flexible pipe segment. The Modify Shape 

group box contains two shapes that you can change, Fixed Length and Free 

Length. If you click Fixed Length, the Length box activates with a number you 

can modify. 

Using the Edit Pipeline Dialog Box 

The Edit Pipeline dialog box opens after you click Parameters in the Modify 

Pipeline dialog box. The Edit Pipeline dialog box lets you perform the following 

tasks: 

• Select a pipeline parameter from the Pro/ENGINEER window. 

• Give the parameter a new name. 

• Add the parameter to the pipeline. 

• Save the parameter to a file. 

• Read in the parameter as a .ppl file. 

• Delete the parameter from the pipeline. 

• Cancel changes made to the pipeline. 

• Modify an existing pipeline label. 

To Modify a Corner Type 

1. Click Piping > Modify Pipe. The Modify Pipeline dialog box opens. 

2. Under Active Assembly select the active assembly. 
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3. Under Modify Options, select Corner Type.  

4. Under Corner, select the corners you want to modify.  

5. In the New Type box, select a new corner type from the list.  

Note: The New Type box displays only those corner types that are specified in 

the line stock of the selected pipe. 

o If you select a corner of type Bend, the Bend Radius box displays the 

default values for the bend radius defined in the line stock. Select the 

required bend radius value from the Bend Radius list. 

The values in Bend Radius reflect the values present in the line stock. You 

can also enter a new value by typing. 

Note: The Bend Radius box is available only when you select the new 

type as bend. 

o If you select a corner of type Miter Cut, the Cut Length box displays a 

default value for the miter cut length. The Cut Number box displays the 

default value for the cut number. If more than one value is specified for the 

cut number in the line stock, select the required cut number value from the 

Cut Number list. 

o The Cut Length and the Cut Number fields are available only when you 

select the new type as miter cut. 

6. Click  to apply the changes and close the dialog box. 

To Modify the Line Shape of a Flexible Hose 

1. Using the Modify Pipeline dialog box, select an active assembly with the arrow. 

2. Under Modify Options, click Flex Shape. 

3. Under Flex Shape, select a pipeline segment with the arrow. 

4. Under Modify Shape, click Fixed Length or Free Length and type a value in 

the Length option. 

5. Click Apply, OK, and Close. 

Changing Pipelines 

Using the PIPING > Pipeline > OPER PIPE LINE menu, you can perform the 

following operations on pipelines: 

• Create/Route 

• Delete 

• Rename 

• Suppress 
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• Resume 

Resolving a Failed Regeneration 

Sometimes changes you make to pipelines conflict with other geometry or feature 

parameters. As a result, your attempt to regenerate the assembly may fail.  

When a regeneration fails, you must resolve the problem before continuing with 

normal model processing. To facilitate this, Pro/ENGINEER provides a special error 

resolution environment, that is, the Resolve environment to help you correct the 

problem.  

All Pro/PIPING processing resides in Assembly mode, therefore, follow the Assembly 

mode recovery procedure. All assembly functionality is available to repair the model.  

For example, if the failure lies in the creation or modification of a solid pipe, you can 

repair the underlying pipe routing feature using Pro/PIPING functionality.  

Modifying Line Segments 

About Creating Line Segments Based on Sketched Geometry 

To create pipeline segments by referencing a sketch, use the Sketch command in 

the PIPE FOLLOW menu. You may find this routing action useful when routing a 

pipeline with respect to equipment or some structural elements, provided the new 

segments lie in the same plane.  

When using this routing technique, remember these points: 

• Following sketched geometry does not create a connection between the existing 

pipe end and new sketched segments even if both endpoints are aligned. To join 

two endpoints (even if they are immediately on top of each other), use the To 

Pnt/Port or Connect commands after finishing the sketched sections. 

• You do not have to add bend radii or miter corners to sketched geometry. The 

system does this automatically. 

To Create Pipeline Segments by Sketching 

1. Click Follow > Sketch > Done. 

2. Select a sketching plane. 

3. Specify a horizontal or vertical reference for sketching. 

4. Sketch geometry, following a pipe centerline. Use the current sketching 

techniques. Remember to locate sketched geometry with respect to the assembly 

geometry to which the pipe placement references. 

If the current corner type of the line stock is set to Bend, you can sketch arcs in 

addition to straight lines. However, you should use them to route pipelines 

around objects rather than to create bends in a pipeline. The system 

automatically creates bends in a pipeline at corners after you finish sketching. 
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5. After the sketch regenerates successfully, click SKETCHER > Done.  

6. Click INT FOLLOW > Change and modify the conditions for the follow 

operations if desired. 

7. Finalize the feature by choosing Done Follow.  

8. The system prompts you to connect the sketched segment to another pipe 

segment at each free end. If you do not want to connect the segment, click 

CONNECT > Quit Connect.  

Solids 

About Creating a Solid Pipe 

Initially, you route pipes by routing centerlines. Once you have completed the 

routing, you can use the Pipe Solid command in the PIPING menu to make a solid 

pipe based on the green pipe routing centerline.  

A solid pipe appears as a solid cylinder of the correct diameter and wall thickness. 

When the system makes a pipe solid, it cuts holes into it at the location of each 

incoming or outgoing branch and trims the incoming and/or outgoing branches back 

to accommodate inserted fittings. 

You must make a pipeline solid for the following tasks: 

• Showing pipe solid parts in the Bill of Materials 

• Retrieving a solid pipe in Part, Assembly, or Drawing mode without the original 

reference assembly  

• Performing engineering calculations such as mass property calculations and 

interference calculations 

• Creating brackets and other parts that reference the pipe’s solid geometry 

You should create piping solids near the end of the process because each time the 

number of solids changes (by deleting a straight break fitting, for example), you 

must define or delete solids.  

To Create a Solid Pipe 

1. Click PIPING > Fabrication > Pipe Solid. The Pipe Solid dialog box opens. 

2. Select a piping assembly under Active Assembly. 

3. Under Segment Tree and SEGMENT, click a pipe segment in the piping 

assembly that you want to make solid (all segments appear with a default name). 

The Make and Erase buttons get activated. 

4. Click Make. The pipe becomes solid. In the Segment Tree, a pipe solid icon 

replaces the segment.  
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5. If you want to remove the solid pipe effect and go back to the pipeline, click the 

segment and then click Erase (Erase also deletes the solid part from the 

session). The screen updates immediately. 

Working with Solid Pipes 

When working with solid pipes, keep in mind the following issues: 

• Regenerating after modifying a pipe centerline—A solid pipe updates to 

match a modification to the pipe centerline when the system regenerates it. To 

update the solid pipe, perform an automatic regeneration or specifically select the 

solid pipe to regenerate.  

• Assigning names to new pipe solids—Each pipe solid that you create using 

Pipe Solid must have a different name even if it is exactly the same as another 

solid.  

You can assemble multiple instances of the same solid if the shape remains the 

same. However, if you need fifteen 10 1/4-inch diameter hoses with different 

shapes, for example, you will need fifteen solid names. If all similar shapes must 

have the same name in the BOM for ordering parts, you can use parameters and 

report relations. 

• Deleting a solid and recreating it—If you want to use the same name when 

you delete and recreate a solid, you must delete the pipe solid from the 

assembly, from memory, and from the working directory. However, when using 

Pro/PDM, if you delete the solid or recreate it and it uses the same name, you 

still cannot submit it to Pro/PDM.  

If you create a new piping solid, you must use a new name in order to submit it. 

If you delete the part and submit a new one with the same name, the system 

recognizes that it is not the same part because all of the revision/status 

information is different from the part with that name in the database. 

• Viewing pipe solid dimensions—Making a pipe solid creates read-only 

dimensions that define the pipe’s straight pipeline lengths between bend 

locations, diagonal miter lengths, and corner radii. You can show these 

dimensions in Part and Drawing modes.  

The system provides the solid dimensions for information purposes only. To 

modify the pipe solid dimensions, you must modify the dimensions of the 

underlying green routing centerline.  

Using the Pipe Solid Dialog Box 

The Pipe Solid dialog box performs several functions: 

• Creates a pipe solid from a segment in an assembly 

• Uses a Start Part in the Copy From box to create a new pipe solid  

• Creates a pipe solid with a new name in the SOLID NAME column 

The Pipe Solid dialog box has the following options: 
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• Active Assembly—Contains the name of the active assembly you select under 

Select Assembly. 

• Segment Tree—Displays the tree structure and the names of the pipe segments 

in the assembly you have selected. 

o SEGMENT—Segment names in the piping assembly 

o SOLID NAME—New name that you have changed from the original Piping 

solid part name. 

o START PART—Name of the original part that is in the template directory. 

The Segment Tree also displays an icon of the new pipe solid. 

• Make—Creates a new pipe solid that appears in the Pro/ENGINEER window. 

• Erase—Reverts the pipe solid to a pipeline segment and erases all parts from the 

session. 

• Copy From—Goes to a template directory of Piping template parts from which 

you choose a part. 

• —Sets the chosen Start Part to all selected pipe segments. 

About Naming a Pipe Solid Segment 

All of the pipelines in the active assembly filter out existing pipe solids and allow the 

part name and Start Part to be modified.  

The system automatically assigns a default name for pipe solids based on the 

segment name. 

 

To Name a Pipe Solid Segment 

1. Choose PIPING > Fabrication > Pipe Solid. The Pipe Solid dialog box opens. 

2. Under Active Assembly, select the active assembly with the arrow. In the 

Segment column, all of the segments in the piping assembly appear. 

3. Click on one of the segments, for example, PL2001. The Make and Erase buttons 

get activated. 

4. Type a new name in the SOLID NAME box and click OK. The pipe segment 

becomes a pipe solid and updates automatically in the Pro/ENGINEER window. 

The dialog box closes. 

To Turn Off the Display of Piping Solids 

1. Click PIPING > Set Up > Set Display. 

2. Select the pipeline.  
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3. From the PIPE DISPLAY menu, click Center Line. This will turn off the display 

of solids.  

To prevent the display of piping solid centerlines, set the configuration file option 

pipe_solid_centerline = NO or place the solid on a layer at the part level and 

blank it. The piping solid remains, but the system does not display the dashed center 

axis.  

If you prefer to see the solid centerline, set this option to YES and control its display 

using Wireframe, Hidden Line, and No Hidden in the top menu bar.  

About Setting the Display of Pipeline Solids 

On the PIPE DISPLAY menu, you can simplify the display by turning off piping 

solids. In some cases, depending on the assembly, this can dramatically improve 

repaint times. 

To Make Solid Square Pipes 

1. Open the LineStock dialog box with the PIPING > Pipeline > Create/Route 

command. 

2. Under General Parameters, select the type, material, and the grade of the line 

stock. 

3. Under X Section, select Rectangular and under Section Type, select Solid. An 

example of a solid, square pipe appears under Section Parameters. 

4. You can change the height, weight, and angle of the pipe in the boxes. 

5. Click Save and OK. 

Making Solid Square Pipes 

You can create solid or hollow pipes with a rectangular or square shape. This 

functionality allows the use of piping for square or rectangular tubing for furniture 

and some HVAC ductwork. You can also create a solid or hollow circular shape. 

Use the LineStock dialog box to create solid or hollow pipes with a rectangular or 

square shape. 

About Extraction of a Model 

You can retrieve a collection of contiguous pipe solids, fittings, and/or assembly 

members as a part in Part mode. However, you must first extract a model from the 

current assembly.  

When extracting a model, the system creates a part out of designated components, 

merging them by reference to preserve the associativity between the new part and 

the piping assembly. Therefore, whenever the piping system changes in the working 

assembly, the extracted model also changes. 

After you have created the extracted part, you can store it to disk as an individual 

model. The system also stores it as a component within the piping assembly. You 
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can use it to create views in drawings without retrieving an entire piping assembly. 

However, you cannot show dimensions in a drawing or obtain piping report 

information.  

By extracting a model, you can retrieve a merged part that may contain piping 

solids, fittings, and equipment as well as any other assembly components that you 

choose to include.  

To Extract a Model 

1. Click PIPING > Fabrication > Extract Mdl > Extract. 

2. Assign a part name by entering a name. 

3. Select contiguous line segments and equipment components. 

4. When you have finished, click Done Sel. The system informs you that it has 

created a merged part containing all selected components.  

The merged part overlays the original assembly component and may affect 

shaded display; therefore, you may want to place it on a layer and blank it. 

Piping Template Parts 

About Piping Template Parts 

With Pro/PIPING you can now specify a template part that will be used for the 

creation of pipe solids. The piping template part may contain datum features, 

parameters, saved views, and colors, but cannot contain any geometry features. This 

functionality also helps you to orient piping features while in Drawing mode. 

Set the start_model_dir configuration file option to specify a complete path to the 

directory where template parts and assemblies can be stored. This directory will be 

the default directory. When you select a Piping template part from which to copy, the 

File Open dialog box goes to this directory by default. 

This functionality also helps you to orient piping features in Drawing mode. 

The Pipe Solid dialog box supports this functionality. In this dialog box, you can 

perform the following functions: 

• Assign a standard template part with the Copy From command. 

• Pipe solid parts have default names based on the pipeline name that can be 

Renamed in the Solid Name dialog box. 

• Create the pipe solid with the Make or OK command. 

• Remove the pipe solid with the Erase command. 

The Pro/ENGINEER window updates immediately when you use the Make and Erase 

commands. The dialog box also shows a sample of a solid pipe after you click Make. 
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To Use a Piping Template Part 

1. In the Pipe Solid dialog box (Piping > Fabrication > Pipe Solid), under 

Active Assembly, click Select Assembly to select a pipeline segment in the 

assembly. The pipeline segment is highlighted.  

2. Under Segment Tree the tree structure and the names of the pipe segments in 

the assembly you have selected appear. 

o SEGMENT—Segment names in the piping assembly 

o SOLID NAME—New name that you have changed from the original Piping 

solid part name. 

o START PART—Name of the original part that is in the template directory. 

o Copy From—Goes to a template directory of Piping template parts from 

which you choose a part. 

3. Click Make to create a new pipe solid that appears in the Pro/ENGINEER window. 

o SOLID NAME—Allows you to change the name of the Piping solid part to a 

new pipe solid name before you make the pipe solid. 

o —Sets the chosen Piping template part to all selected pipe segments. 

Using the Pipe Solid Dialog Box 

The Pipe Solid dialog box performs several functions: 

• Creates a pipe solid from a segment in an assembly 

• Uses a Start Part in the Copy From box to create a new pipe solid  

• Creates a pipe solid with a new name in the SOLID NAME column 

The Pipe Solid dialog box has the following options: 

• Active Assembly—Contains the name of the active assembly you select under 

Select Assembly. 

• Segment Tree—Displays the tree structure and the names of the pipe segments 

in the assembly you have selected. 

o SEGMENT—Segment names in the piping assembly 

o SOLID NAME—New name that you have changed from the original Piping 

solid part name. 

o START PART—Name of the original part that is in the template directory. 

The Segment Tree also displays an icon of the new pipe solid. 

• Make—Creates a new pipe solid that appears in the Pro/ENGINEER window. 

• Erase—Reverts the pipe solid to a pipeline segment and erases all parts from the 

session. 
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• Copy From—Goes to a template directory of Piping template parts from which 

you choose a part. 

• —Sets the chosen Start Part to all selected pipe segments. 

Copying from Piping Template Parts 

A Piping template part is a standard part which you can copy to create new parts or 

assemblies. Piping template parts can contain datums, color, relations, layers, saved 

views, and parameters subject to the following conditions: 

• A Piping template part must not have any external dependencies. 

• A Piping template part cannot have any solid geometry. 

• A Piping template assembly must contain only assembly features. 

When copying from a Piping template part, Pro/ENGINEER allows you to browse your 

directory structure and select a part or assembly to copy from, as appropriate.  

Drawings 

About Drawings 

In Drawing mode, you can display piping items and manipulate the display of 

centerlines and dimensions, and you can use Pro/REPORT functionality to obtain 

information related to your piping assembly. This section explains how to manipulate 

the display of piping items in drawings, generate bend information tables, and use 

Pro/REPORT with Pro/PIPING. 

To Show and Manipulate Pipe Bend Notes in a Drawing 

1. In Drawing mode, add an assembly to your session. 

2. Click View > Show and Erase, and then click the Note icon in the Show / 

Erase dialog box. 

3. Specify the pipe segments within which to show the bend notes by clicking 

Feature, Part, View, Feature and View, or Part and View. The system 

attaches the notes to the theoretical bend intersection if it is showing, or to the 

green pipeline routing centerline bend arc if it is not.  

If a default text style has been set before creating the notes, the system applies 

it to these automatic notes. 

4. Manipulate the notes by doing the following, as necessary: 

o Update their placement (after modifying the theoretical bend intersections) 

by clicking View > Update > Drawing View.  

o Blank or unblank the note leader by choosing MOD OPTIONS > Del Ref.  
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Using the Report Pipeline Dialog Box 

The Report Pipeline dialog box combines the traditional piping information tools 

with Results and allows you to define and use Saved Analyses for future use. The 

Report Pipeline dialog box displays Info Type, Definition, Results, and Saved 

Analyses. 

The Info Type box displays the following information: 

• General 

o Pipeline, pipe segment, and insulation under Definition 

o Length 

o Pipeline, line stock, and segment under Definition 

o Length Type consists of pre/cut and centerline 

o Bill of Materials Generated for the Active Assembly 

o Bend Location 

o Bend Machine 

o Holes Report 

o Clocking Angle 

o Output File Interchange Format 

o Check Pipe 

o Pipeline under Definition.  

o Show Report Setup 

o Insulation Location 

The Definition box displays a pipe segment, pipeline, or insulation. 

The Results box displays the name of the pipe segment, pipeline, or assembly that 

you selected with . 

  displays the INFORMATION WINDOW with the extended information from the 

Results box. 

The Saved Analyses box displays the names of the saved analysis files, which are 

based on the information in the Results box. 

Displaying Dimensions and Bend Notes in Drawing Mode 

To display dimensions and bend notes in Drawing mode after making the pipe solid, 

Click Show and Erase from the View menu. You must click View, Feature, or 

Feature and View to view the solid model’s dimensions or the routing feature 

dimensions.  
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You can manipulate the display of pipe solid centerlines, pipe solid dimensions, and 

bend notes in drawings using the following methods: 

• To control the display of pipe solid centerlines in drawings, 

o Blank the centerlines by setting the configuration file option 

pipe_solid_centerline to no. 

o Include pipe solid centerlines in the hidden line removal process by setting 

the drawing setup file option hlr_for_pipe_solid_cl to yes. 

• To display drawing dimensions for isometric drawings of piping assemblies, set 

the drawing setup file option allow_3d_dimensions to yes.  

In a 3-D view, the system does not show any dimensions that are not in the view 

plane of the drawing unless you have set this drawing setup file option.  

• To display bend notes in your piping assemblies, set the drawing setup file option 

default_pipe_bend_note. 

About Showing Piping Parameters in Drawing Notes 

You can attach a note to a pipe centerline, a pipe solid, a pipe bend, or a pipe solid 

centerline. 

To Show Piping Parameters in Drawing Notes 

1. Define a new assembly parameter. 

2. Accept the default value. 

3. Add a relation setting the new parameter to the desired line stock parameter 

using the following syntax: 

<param_name>=<linestock_param>:fid_<LINESTOCK_ID>: 
<SESSION_ID 

or 

<param_name>=<linestock_param>:fid_<LINESTOCK_NAME>: 
<SESSION_ID>  

An example of how to set a new parameter is this: 

param1 = OD:fid_54:7  

where 

o param1 is a new assembly parameter 

o 54 is line stock ID 

o 7 is session ID of the assembly where the line stock resides 

o OD is line stock parameter 

4. Regenerate the assembly to update the new parameter value. 
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5. Create the drawing note referencing the new parameter, for example, &param1 to 

include the OD from the example above in a note. 

Showing Theoretical Bend Intersections on a Drawing 

Using drawing setup file options, you can control the display of theoretical 

intersections and bends for bent tubes in a drawing: 

• show_pipe_theor_cl_pts controls the centerlines and intersection points: 

o To show centerlines with bends only, specify the value as bend_cl (the 

default). 

o To show only centerlines with theoretical bend intersection points, specify 

the value as theor_cl. 

o To show both bends and theoretical intersection points, specify the value as 

both.  

• pipe_pt_shape controls the display of the intersection points. To specify the 

display, set it to cross (the default), dot, circle, triangle, or square.  

• pipe_pt_size controls the size of the intersection points. To change the size, 

modify the numerical value. 

When you change the setting of any of these options in the drawing setup file, 

Pro/ENGINEER updates all centerline and point intersection displays in the drawing, 

but you must repaint or regenerate the view to update the views.  

If you create a dimension to an intersection point and then change the setup options 

to turn off their display, the dimension remains and is associative.  

To control the hidden line display of the pipe centerline in drawings, set the drawing 

setup file option hlr_for_pipe_solid_cl.  

To update pipelines created in previous releases, set configuration file option 

pipe_update_pre_20_int_pts = yes to get intersection points entities. These 

entities are created in session by Info > Regen Info or when the model is 

retrieved.  

Installation Drawing Generation 

About Installation Drawing Generation 

Piping Installation drawing shows different views of a piping model with dimensions 

and various annotations. All the hidden lines are removed in the Installation drawing. 

Installation drawing is used to guide the piping installation work. 

Pro/PIPING allows you to automatically display all pipe segments in the Installation 

drawing using a single line or double line representation. You can insert a pipe slope 

symbol on the pipe segments to display the slope of pipe segments in the Installation 

drawing. 
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To Select Display Style for Pipe Segments 

Use this procedure to specify the display style for pipe segments in the Installation 

drawing. 

1. Click File > Open and select the drawing to be activated. 

2. Choose Applications > Piping. 

3. Click View > Pipeline Display > Style from the top menu bar. The Display 

Style dialog box opens. 

4. Under Select View, click one of the following options to select views from the 

drawing: 

o Click View to interactively select a view or multiple views from the drawing. 

Click  and select a view or multiple views from the drawing. 

o Click Sheet to automatically select all the views from the current drawing 

sheet. 

o Click All Sheets to automatically select all the views from all the drawing 

sheets.  

The names of the selected views are displayed in the selection list. 

5. Under Select Style, click one of the following options to specify the style for 

displaying pipe segments in the drawing: 

o Click Single Line to display pipe segments in single line representation. 

o Click Double Line to display pipe segments in double line representation. 

o Click Double Line Above to display pipelines of different sizes in different 

display styles. Type a value for the pipe size in the adjacent field.  

Note: To display a pipe in double line style, its solid representation must be 

present in the pipeline assembly. 

Pro/PIPING displays all pipelines with a size greater than the specified size 

in double line representation and all pipelines with a size smaller than or 

equal to the specified size in single line representation. 

6. Click OK to display the pipelines in the selected views in the specified style, and 

close the dialog box.  

Click Cancel to cancel the action and close the dialog box. 

Click Apply to display the pipelines in the selected views in the specified style, 

and keep the dialog box open for further selections. 

Pipe Display Style 

You can display pipelines in the selected views in single line representation or double 

line representation. You can also choose to display all pipelines with a size greater 
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than the specified size in double line representation and all pipelines with a size 

smaller than or equal to the specified size in single line representation. 

The following figure shows all the pipe segments of a pipeline, irrespective of their 

sizes, displayed in single line representation. 

 

The following figure shows all the pipe segments of a pipeline, irrespective of their 

sizes, displayed in double line representation. 

 

To Select Slope Symbol for Pipe Segments 

Use this procedure to select a symbol for displaying the slope of pipe segments in 

the Installation drawing. 

1. Click File > Open and select a drawing. 
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2. Click Insert > Piping Symbol > Slope from the top menu bar. The Slope Mark 

dialog box opens. 

3. Under Select View, click one of the following options to select views from the 

drawing: 

o Click View to interactively select a view or multiple views from the drawing. 

Click  and select a view or multiple views from the drawing. 

o Click Sheet to automatically select all the views from the current sheet. 

o Click All Sheets to automatically select all the views from all the sheets.  

The names of the selected views are displayed in the selection list. 

4. Under Select Symbol, use one of the following methods to select a symbol for 

displaying the slope of pipe segments in the drawing: 

o Select a symbol from the adjacent selection list. All symbols in the current 

drawing are displayed in the list.  

Alternatively, enter a symbol name in the adjacent field. Before loading the 

specified symbol, Pro/PIPING searches the directories in the following order: 

The current working directory 

The path specified using the search_path configuration option 

The symbols directory under the project data directory specified using the 

piping_project_data_dir configuration option 

o Click  to browse the directory specified by the pro_symbol_dir 

configuration option and select a symbol. 

Note: The default symbol for pipe slope is  slope.sym and is located under the 

$PTCSRC/text/piping_data/sample_project/symbols directory. 

5. Under Select Symbol Parameter, specify the parameters for the selected 

symbol. 

o Click Symbol Height to specify the height of the pipe slope symbol on the 

drawing. Enter a value in the adjacent field. The unit for this value is the 

active drawing unit. 

Note: If you do not specify the height for the slope symbol, Pro/PIPING 

considers the height to be equal to the outer diameter of the pipe.  

o Click Interval Between Symbols to specify the distance between two 

consecutive pipe slope symbols. Enter a value in the adjacent field. The unit 

for this value is the active drawing unit. 

Note: The default value is 5 mm or its equivalent in the active drawing 

units. 
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6. Click OK to display the pipelines in the selected views in the specified style and 

close the dialog box.  

Click Cancel to cancel the action and close the dialog box. 

Click Apply to display the pipelines in the selected views in the specified style, 

and keep the dialog box open for further selections. 
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Example: Piping Installation Drawing 

 

Pipe Slope Symbol 

Pro/PIPING allows you to display the slope of pipelines in each view of the piping 

Installation drawing using a slope symbol mark. 
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If a pipe segment is not parallel to the selected view, the slope of the pipeline can 

not be shown in the selected view of the drawing. To display the slope of a pipeline, 

a set of slope symbols are placed along the pipe segment. The direction of the 

symbols indicate the slope direction. 

Front View of the Pipeline 

 

Top View of the Pipeline 

 

1 Slope Direction 

2 Slope Symbol 

3 Pipe Slope Symbol Interval 

The pipe slope symbol is created as a Pro/DETAIL drawing symbol. When the location 

of the pipe segment on the drawing is changed, the pipe slope symbol also changes 

its location. 

When the outer diameter of the pipe segment in the model is changed, use 

Regenerate > Draft to update the diameter of the pipe slope symbol. 
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Isometric Drawing Generation (ISOGEN) 

About Isometric Drawing Generation (Non Spec-Driven) 

Pro/PIPING provides an Isometric Drawing Generation (ISOGEN) interface allowing 

you to create isometric drawings of pipelines. The ISOGEN Interface exports material 

and geometrical data from a Pro/PIPING model to a readable ISOGEN .pcf (Piping 

Component File) format. This format serves as an input to ISOGEN for creating 

pipeline, spool and system isometric drawings.  

The Generate Isometric dialog box (PIPING > Drawing) allows you to create 

isometric drawings from Pro/PIPING models. Using this dialog box, you can select 

pipelines, set up file names and directories, and export the data to an intermediate 

.pcf file. ISOGEN reads this .pcf file data and generates the isometric drawings in 

various standard data formats. 

Note: You must first set the ISOGEN configuration options to use the ISOGEN 

interface generation tool. 

To Generate an Isometric Drawing (Non Spec-Driven) 

Note: You must first set the ISOGEN configuration options to use the ISOGEN 

interface generation tool. 

1. Click PIPING > Drawing. The Generate Isometric dialog box opens and 

prompts you to select a pipeline. The Selection tab is selected by default. 

2. Under Select Isometric Drawing Type, specify the isometric drawing type:  

o Pipeline—Generates a pipeline isometric for each selected pipeline. 

Pro/PIPING writes data related to each selected pipeline in a separate PCF 

file and generates as many PCF files as the number of selected pipelines. 

o System—Generates a system isometric for each selected pipeline system, 

which consists of physically connected pipelines. For each selected pipeline, 

the data for connected pipelines is exported to a PCF file. If two or more of 

the selected pipelines belong to one network, Pro/PIPING ignores any 

pipeline data that has already been exported.  

3. Under Reference Csys, click  and select the reference coordinate system for 

the coordinate output in the PCF files. All the coordinates in the PCF file are based 

on the selected coordinate system. By default, the default coordinate system in 

the top assembly will be used. 

4. Under Select pipeline(s), click  and select one or more multiple  pipelines 

to generate the isometric. You can select pipeline features or segment features 

from the Model Tree, the Piping System Tree, or the graphics window. 

Pro/PIPING displays all selected pipelines under Select pipeline(s). 

5. Under Options, use the following boxes to override any of the ISOGEN 

configuration options.  
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Note: Any changes to these four options will remain in effect throughout the 

Pro/ENGINEER session unless you change them during the session. 

o Output Directory—The value of the isogen_output_files_dir 

configuration option appears in the input panel. If you want to store the 

PCF file in another directory, click . The Select Directory to place 

output PCFs dialog box opens. Browse for the directory and click . If 

there is no value for isogen_output_files_dir, this input panel will be 

blank and all files generated by the interface will be written to the working 

directory.  

o Isogen File—The value of the isogen_mandatory_attr_file configuration 

option appears in the input panel. To select a different ISOGEN file click 

. The Select ISOGEN File dialog box opens. Browse for the file and 

double-click.  

o Symbol Map File—The value of the isogen_symbol_map_file 

configuration option appears in the input panel. To change to a different 

symbol map file click . The Select Symbol Map File dialog box 

opens. Browse for the file and double-click. 

o Endtype Map File—The value of the isogen_endtype_map_file 
configuration option appears in the input panel. To change the endtype map 

file click . The Select Endtype Map File dialog box opens. Browse for 

the file and double-click it. 

6. Click the General Attr tab. These attributes are supported by ISOGEN and can 

be used to determine various isometric drawing options.  

7. Under Specify General Attributes, click the System Attr tab. Optional ISOGEN 

system attributes are displayed: 

o Date—Specify the date. Pro/PIPING displays the current system date by 

default. You can change the value using the format --/--/--. The value 

entered here is written to the PCF file for the DATE-DMY ISOGEN attribute. 

o Project Identifier—Specify the project number or name. 

o Revision Number—Specify the revision number.   

o Area or Batch—Specify the sections of a project. 

o Replot—Specify the number of isometric drawings to be replotted. 

o Spool Prefix—Specify the spool prefix. 

o Weld Prefix Erection—Specify the erection weld prefix. 

o Weld Prefix Fabrication—Specify the fabrication weld prefix. 

o Weld Prefix General—Specify the weld prefix. 
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o Weld Prefix Offshore—Specify the offshore weld prefix. 

8. Click the User Attr tab for ISOGEN attributes. Select from the option list to 

specify the user attributes. The list contains all the available user attributes 

supported by ISOGEN. They are MISC-SPEC1 to MISC-SPEC5 and ATTRIBUTE1 to 

ATTRIBUTE99. Select an attribute, specify a corresponding value, and ENTER. 

Pro/PIPING displays the attributes.   

9. Click the Pipeline Attr tab. The attributes under Specify Pipeline Attributes 

are usually applicable to one pipeline, but you can also use them for multiple 

pipelines. ISOGEN supports all of the following attributes. However, not every 

attribute is available for every Pro/PIPING model. 

0. Pipeline Type—Select the pipeline construction type. All the valid types 

are listed. Note that you should be informed about the other ISOGEN 

pipeline construction types before changing this value to anything other 

than General.  

1. Bend Radius—Specify the standard pulled bend radius. 

2. Painting Spec—Specify the painting specification. 

3. Tracing Spec—Specify the tracing specification. 

4. Start Coords—Specify the pipeline replot start coordinates. 

5. Specific Gravity—Specify the gravity of the pipeline contents.  

6. Output File Name—Specify the name of the drawing output file. The value 

tered is used only when a single pipeline is selected. If pipeline isometric or 

multiple pipelines are selected, the value is ignored. 

7. Highest Part Number—Specify the highest material list part number 

generated on the previous run of the pipeline. 

8. Highest Weld Number—Specify the highest weld number generated on 

the previous run of the pipeline. 

Note: If you select multiple pipelines and data exists on this tabbed page (other 

than the default General in the Pipeline Type option), the following message 

appears: 

Multiple Pipelines Selected. Use data in Pipeline Attr tab for all 
pipelines? 

10. Click  to export the data or  to ignore the data. If you click , the 

Output File Name attribute is not exported.  

11. Click  to apply the specified options on the selected pipelines, create the 

necessary PCF files, and close the dialog box.  
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Component Material Description (Non Spec-Driven) 

The material description of each extracted Pro/PIPING component appears in the bill 

of materials section of the isometric drawing. The material description in the PCF file 

format requires an item code and description as shown below:  

MATERIALS  

ITEM-CODE data  

DESCRIPTION data (Single line Description)  

ITEM-CODE data  

DESCRIPTION data (Multiple line Description)  

DESCRIPTION data 

Note: Pro/PIPING uses the STOCKNO (stock number) as the ITEM-CODE. The 

STOCKNO uniquely identifies each Pro/PIPING component. 

Creating Pipe Component Information (Non Spec-Driven) 

The ISOGEN drawing generation tool allows you to create pipe component 

information. The coordinate information of pipe segments and other components is 

converted to millimeters if the corresponding assembly uses metric units. If the 

corresponding assembly uses imperial units, the coordinate information of pipe 

segments and other components is converted to inches. Use the ISOGEN switches to 

display the units on the isometric drawing during the isometric drawing generation. 

The nominal size information is extracted from the Pro/PIPING component.  

The ISOGEN component identifier and the information extracted is shown in the next 

table. 

PCF Identifier Description 

BRANCH1-POINT 

BRANCH2-POINT 

Identifies branch points on various components. For 

example, a typical record using millimeter (mm) 

coordinates and an inch bore is as follows: 

BRANCH1-POINT 125.0 25.0 0.0 6 BW 

Note: The data string after the identifier BRANCH1-

POINT includes coordinates, a nominal size, and an 

endtype as expected by PCF file format. 

CENTRE-POINT Identifies the center point on various components. 

For example, a typical record using millimeter (mm) 

coordinates and an inch bore is as follows: 

CENTRE-POINT 125.0 0.0 0.0  

Note: The data string after the identifier CENTRE-

POINT includes coordinates. 
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END-POINT Identifies end-points on various components. For 

example, a record using millimeter (mm) 

coordinates and an inch bore is as follows: 

END-POINT 150.0 25.0 0.0 6BW 

Note: The data string after the identifier END-

POINT includes coordinates, a nominal size, and an 

endtype as expected by the PCF file format. 

SKEY Represents a ISOGEN SKEY (Symbol Key). For 

example, a record identifying SKEY is as follows: 

SKEY VGBW 

ITEM-CODE Represents a unique identifier for each component. 

Pro/PIPING component STOCKNO (stock number) is 

used as ITEM-CODE. The ITEM-CODE and the 

description are used to populate the bill of 

materials. For example, a record identifying ITEM-

CODE is as follows: 

ITEM-CODE GATVAA050 

ANGLE Identifies the angle value if the angle is other than 

90 or 180 degrees for ELBOW, BEND, OLET, TEE, 

CROSS, and ELBOW-TEED type components. Angle 

values are in hundredths of degrees. For example, a 

record identifying an ANGLE of 60 degrees is as 

follows:  

ANGLE 6000 

SPINDLE-

DIRECTION 

Direction of Spindle (Operator) on VALVE. Defines 

primary direction only. Valid directions values are 

NORTH, SOUTH, EAST, WEST, UP and DOWN. For 

example, a record identifying SPINDLE-DIRECTION 

is as follows: 

SPINDLE-DIRECTION NORTH 

FLAT-DIRECTION Direction of Flat side of Eccentric Reducers (ERED). 

Defines primary direction only. Valid directions 

values are NORTH, SOUTH, EAST, WEST, UP and 

DOWN. For example, a record identifying FLAT-

DIRECTION is as follows: 

FLAT-DIRECTION NORTH 

DIRECTION 

 

Used to indicate VALVE Spindle direction and 

Eccentric Reducer Flat direction that is in primary 

plane. Value in a form Up 45 deg. North will be 

shown as a graphical output in primary direction. 



Pro/PIPING (Non Specification-Driven) 

137 

For example, a record identifying DIRECTION is as 

follows: 

Up 45 deg. North 

Note: ISOGEN identifiers BRANCH1-POINT, BRANCH2-POINT, and CENTRE-POINT 

are specific to components and are not applicable for pipe segments. 

Example: ISOGEN Identifiers on a Component (Non Spec-Driven) 

ISOGEN identifiers on a cross component are displayed in the following example. 

 

B1P: BRANCH1-POINT 

B2P: BRANCH2-POINT   

CP: CENTRE-POINT 

EP: END-POINT 

ISOGEN Symbol Map File (Non Spec-Driven) 

The ISOGEN Symbol Map file is a Pro/TABLE file that maps a Pro/PIPING fitting 

generic name against a corresponding symbol key (SKEY) and the ISOGEN 

component name. Pro/PIPING uses symbol keys for all fitting generic part sizes. You 

can modify the ISOGEN Symbol Map file by using a text editor.  

The ISOGEN Symbol Map file format is described in the following table. 

Field Name Field  Type Description 

FITTING_GENERIC_NAME Character Pro/PIPING fitting generic 

name 

ISOGEN_COMPONENT_NAME Character ISOGEN component name 

ISOGEN_SKEY Character 

 

ISOGEN component 

symbol key (SKEY) 

ISOGEN_ITEM Character ISOGEN component 

material item type. It 

must be one of the 

following or empty:x 
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ERECTION-ITEM x 

FABRICATION-ITEM x 

OFFSHORE-ITEM 

Note: If no material item type is found for a fitting, Pro/PIPING checks all the end 

types of the fitting ports. If any of the end type is welded (an end type that contains 

'W' or 'w' character) or slip on (an end type that contains the 'SO' or 'so' string), the 

FABRICATION-ITEM type is assigned to that fitting. Otherwise the ERECTION-ITEM 

type is assigned. 

Symbol Key Selection  

Pro/PIPING extracts the SKEY from the ISOGEN Symbol Map file by matching the 

generic name of the fitting with the name in the FITTING_GENERIC_NAME column. 

Pro/PIPING extracts the symbol key name in the ISOGEN_SKEY column and then the 

endtype string from the ISOGEN Endtype Map file.  

SKEY selection occurs according to the following conditions: 

• If the SKEY is only two characters long, Pro/PIPING appends the endtype string 

to the symbol key to form the final SKEY used in the PCF file.  

• If the SKEY has the double asterisks (**) as a substring and an endtype string is 

found, the endtype string replaces the double asterisks in the SKEY to form the 

final SKEY.  

• If either of these cases fail, the default SKEY is used. 

Example: ISOGEN Symbol Map File (Non Spec-Driven) 

Default Path:  

<ProE load directory>/text/piping_data/isodata/isogen_symbol_map.ptd 

Fitting_Generic_Name Isogen_Component_

Name 

Isogen_Skey ISOGEN_ITEM 

vl_gate_flrf VALVE VGFL ERECTION-ITEM 

vl_swing_check_flrf VALVE VSFL ERECTION-ITEM 

vl_angle_flff VALVE-ANGLE AVFL FABRICATION-

ITEM 

flange_neck_rf FLANGE FLFL FABRICATION-

ITEM 

elbow_90long_bw_steel ELBOW ELBW FABRICATION-

ITEM 

elbow_45long_bw_steel ELBOW ELBW FABRICATION-
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ITEM 

tee_reducing_bw_steel TEE TEBW FABRICATION-

ITEM 

tee_straight_bw_steel TEE TEBW FABRICATION-

ITEM 

red_concentric_bw_steel REDUCER-

CONCENTRIC 

RCBW FABRICATION-

ITEM 

red_eccentric_bw REDUCER-ECCENTRIC REBW FABRICATION-

ITEM 

ISOGEN Endtype Map File (Non Spec-Driven) 

The ISOGEN Endtype Map file is a Pro/TABLE file that maps Pro/PIPING end types to 

corresponding ISOGEN end types. You can modify the ISOGEN Endtype Map file by 

using a text editor.  

The ISOGEN Endtype Map file format is described in the following table. 

Field Name Field Type Description 

ENDTYPE Character Pro/PIPING end type 

ISOGEN_ENDTYPE Character ISOGEN end type 

Default End Type Mapping 

If you do not provide an ISOGEN Endtype Map file or if you do not list the entries for 

the end types used by the Pro/PIPING fitting components in the Endtype Map file, 

Pro/PIPING maps the end types by default. 

The string matching rules for default end type mapping are listed in the next table. 

Endtype Isogen Endtype 

endtype string starting with B BW 

endtype string starting with C CP 

endtype string starting with F FL 

endtype string starting with P PL 

endtype string starting with SC SC 

endtype string starting with SW SW 

No match found BW 
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Note: The default mapping is internal to the interface. 

Example: ISOGEN Endtype Map File (Non Spec-Driven) 

Default Path:  

<ProE load directory>/text/piping_data/isodata/isogen_endtype_map.ptd 

Endtype Isogen_Endtype 

PE PL 

FLFF FL 

GKFF FL 

FLRF FL 

SWLD SW 

BWLD BW 

ISOGEN Nominal Size Map File (Non Spec-Driven) 

The ISOGEN Nominal Size Map file is a Pro/TABLE file that maps the Pro/PIPING sizes 

used for modeling to the industry standard nominal size or nominal bore (NB). 

Nominal bore can be measured in millimeters (mm) or inches.  

Pro/PIPING extracts the component size and its units from the model using the 

following conditions: 

• If the units are metric, UNITS-BORE is selected as MM. 

• If the units are in inches, UNITS-BORE is selected as INCH. 

Pro/PIPING matches the extracted size against the nominal size in either the NB_MM 

or NB_INCH column. The nominal size must correspond to the model size in the SIZE 

column.  

You can modify the ISOGEN Nominal Size Map file by using a text editor. The 

ISOGEN Nominal Size Map file format is described in the following table. 

Field Name Field Type Description 

SIZE Character Pro/PIPING Size String 

NB_MM Character Nominal Bore (NB) Value 

NB_INCH Character Nominal Bore (NB) Value 
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Note: 

• Pro/PIPING allows you to specify any character as a nominal size. However, the 

ISOGEN PCF file format expects a number as the pipe nominal size. 

• For NB values, use only numbers from 0 to 9, the period (.), or the slash (/).  

• For NB values in millimeters, only integers can be entered.  

• For NB values in inches, you can use fractions (for example, 1-1/2 for a one and 

one-half inch bore). 

• NB values cannot include white spaces. 

• For NB values, do not use the inch symbol (") for inches. 

Default Nominal Size Mapping 

If you do not list a size in the SIZE column or if you do not define the nominal size in 

the selected NB column, Pro/PIPING outputs the model size to the PCF file by default 

where NB is needed. If a nominal size map file does not exist, the same result 

occurs. 

Note: An invalid nominal size may result from a wrong isometric size annotation or 

from an ISOGEN PCF file export malfunction. 

Example: ISOGEN Nominal Size Map File (Non Spec-Driven) 

 Default Path:  

<ProE load 
directory>/text/piping_data/isodata/isogen_nominal_size_map.ptd 

Size Nb_inch Nb_mm 

10A ¼ 10 

15A ½ 15 

20A ¾ 20 

25A 1 25 

32A 1-1/4 32 

40A 1-1/2 40 

50A 2  50 

¼" ¼ 10 

½" ½ 15 

¾" ¾ 20 
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1" 1 25 

1-1/4" 1-1/4 32 

1-1/2" 1-1/2 40 

2" 2  50 

For the complete ISOGEN nominal size map file, see the default path. 

ISOGEN Mandatory Attribute File (Non Spec-Driven) 

The ISOGEN Mandatory Attribute file contains attributes that correspond to the 

ISOGEN mandatory attributes listed in ISOGEN-FILES. The configuration option 

isogen_mandatory_attr_file sets the ISOGEN Mandatory Attribute File name. The 

default is isogen.fls. You can use the default file provided by the ISOGEN package 

or create a file. 

Example: ISOGEN Mandatory Attribute File (Non Spec-Driven) 

Default Path:  

<ProE load directory>/text/piping_data/isodata/isogen.fls 

Attributes Directory Path 

PLOT FILE-

PREFIX 

C:\PISOGEN\PROJECTS\abc\SPOOLS\OUTPUT\PLOT 

OPTION-

SWITCHES-

LONG 

C:\PISOGEN\PROJECTS\abc\SPOOLS\SPOOLS.OPL 

MESSAGE C:\PISOGEN\PROJECTS\abc\SPOOLS\OUTPUT\SPOOLS.MES 

DRAWING-

FRAME 

C:\PISOGEN\PROJECTS\abc\SPOOLS\SPOOLS.DXF 

DRAWING-

DEFINITION 

C:\PISOGEN\PROJECTS\abc\SPOOLS\SPOOLS.DDF 

ALTERNATIVE-

TEXT 

C:\PISOGEN\PROJECTS\abc\SPOOLS\SPOOLS.ALT 

POSITIONED-

TEXT 

C:\PISOGEN\PROJECTS\abc\SPOOLS\SPOOLS.POS 
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WELDING-

DEFINITION 

C:\PISOGEN\PROJECTS\abc\SPOOLS\SPOOLS.WDF 

MATERIAL-

LIST-

DEFINITION 

C:\PISOGEN\PROJECTS\abc\SPOOLS\SPOOLS.MLD 

ISOGEN Error Log File (Non Spec-Driven) 

If Pro/PIPING encounters errors while processing pipelines during isometric drawing 

generation, Pro/PIPING creates a log file named isointf.err. The error log file 

contains a collection of error logs from multiple sessions. The 

isogen_output_files_dir configuration option sets the directory in which 

Pro/PIPING stores this log file.  

Pro/PIPING creates the following two types of error log entries: 

• Errors—Identifies problem pipeline segments, components, and fittings that 

caused the errors. Pro/PIPING highlights these items in red and displays them in 

the Pro/ENGINEER graphics window. To restore these components to their 

original color, click .  

• Warnings—Identifies issues that occur due to processing errors. 

Example: ISOGEN Error Log File (Non Spec-Driven) 

Date : 25-4-2000 

ERROR LOG file for **ISOMETRIC DRAWING GENERATION INTERFACE** 

ERROR : Processing Fitting TEE_RED_BW-STEEL-65X50 in Pipeline 65A-SPEC-
STEAM-1. 

WARNING : Material Description not found for 3 item(s) in Pipeline 65A-
SPEC-STEAM-1. 

ERRORS : ISOGEN may fail to process intermediate output PCF files. 

REPAINT to restore Highlighted components in case of error. 

WARNINGS : ISOGEN may not fail to process but some of the desirable 

data may be missing. 

This file may be appended with errors occurring in future sessions. 

Piping Information 

About Gathering Piping Information 

Piping information is available from the main Pro/ENGINEER menu. When you choose  

Info > Piping, the Report Pipeline dialog box opens. If you are in the Piping 
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module, choose Piping > Info, and the same dialog box opens. In this dialog box 

you can perform the following actions: 

• Show general information for a pipe segment or a pipe line. 

• Display the length of pipelines, pipe segments, or line stocks. 

• Generate a bill of materials (BOM) for the active assembly. 

• Generate bend location information for a selected segment. 

• Generate bend machine information for a selected segment. 

• Generate holes report information for a selected segment. 

• Calculate the clocking angle between two csys on a flexible pipe segment. 

• Generate a File Interchange Format file (FIF) for a selected segment. 

• Check a pipeline for line stock parameter violations. 

• View and remove designated report setup information. 

• Use the Saved Analyses tool to name, retrieve, and designate piping objects for 

report setup. 

To Obtain Piping Information 

Click PIPING > Info. The Report Pipeline dialog box opens. 

From the main Pro/ENGINEER menu, you can also click Info > Piping to obtain the 

same results. 

Obtaining Engineering Information 

Through Pro/PIPING, you can obtain various forms of engineering information 

concerning piping systems. Specifically, you can do the following: 

• Determine the length of pipelines and segments, including the length of each 

stock type. 

• Generate manufacturing information for a selected pipe, as well as generate 

information about xyz bend locations. 

• Generate a Bill of Materials listing each pipe solid and fitting, including a 

breakdown by pipeline.  

• Access information about a pipeline such as the name of the working assembly, 

the pipeline, and the current line stock. 

• Access information about a pipeline segment such as the name of the working 

assembly, pipeline, and current line stock, the material, the diameter, the length, 

and the wall thickness. 

• Check for line stock violations. 
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Using the Report Pipeline Dialog Box 

The Report Pipeline dialog box combines the traditional piping information tools 

with Results and allows you to define and use Saved Analyses for future use. The 

Report Pipeline dialog box displays Info Type, Definition, Results, and Saved 

Analyses. 

The Info Type box displays the following information: 

• General 

o Pipeline, pipe segment, and insulation under Definition 

o Length 

o Pipeline, line stock, and segment under Definition 

o Length Type consists of pre/cut and centerline 

o Bill of Materials Generated for the Active Assembly 

o Bend Location 

o Bend Machine 

o Holes Report 

o Clocking Angle 

o Output File Interchange Format 

o Check Pipe 

o Pipeline under Definition.  

o Show Report Setup 

o Insulation Location 

The Definition box displays a pipe segment, pipeline, or insulation. 

The Results box displays the name of the pipe segment, pipeline, or assembly that 

you selected with . 

  displays the INFORMATION WINDOW with the extended information from the 

Results box. 

The Saved Analyses box displays the names of the saved analysis files, which are 

based on the information in the Results box. 
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General Information 

About Obtaining Pipeline Information 

Using the Info Type option in the Report Pipeline dialog box, you can select the 

pipeline you want. All the pertinent information about this pipeline appears in the 

Results box.  

To Obtain Pipeline Information 

1. In the Report Pipeline dialog box, click Info Type > General  

2. Under Definition, click Pipe Line.  

3. Click  in the Pipe Line option. 

4. Select a pipeline in the Pro/ENGINEER window. 

The Results box for the selected pipeline provides the name of the working 

assembly, the pipeline, and the current line stock. 

5. Click . The INFORMATION WINDOW opens and displays the pipeline 

information. 

About Obtaining Pipeline Segment Information 

  

The Segment option in the Report Pipeline dialog box provides information about 

a selected pipeline segment.  

If you click Info Type > General, you can obtain the name of the working 

assembly, pipeline, and current line stock, the material, the diameter, the length, 

and the wall thickness. Height and width are also shown for square pipes. 

You can also obtain the clocking angle between two fittings on a flexible pipe 

segment, and create bend machine or locations tables. The Clocking Angle and 

Bend Information table defines the kind of information you can obtain for a 

particular type of segment. 

To Obtain Pipeline Segment Information 

1. From the PIPING menu, click PIPING > Info. The Report Pipeline dialog box 

opens. 

2. Under Info Type, click General or Length and under Definition, click 

Segment.  

3. Click  to select a segment. Pipeline segment information appears in the 

Results window. 
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4. Click . The INFORMATION WINDOW opens and displays the pipe segment 

information.  

Clocking Angle and Bend Information 

Type of Segment Bend 

Information 

Clocking 

Angle 

All flexible NO YES 

Flexible with bends or a miter cut NO NO 

Flexible with straight sections NO YES 

All bends YES NO 

All miter cuts NO NO 

Single straight segment NO NO 

Bend/miter cut mix YES NO 

Pipe Length Information 

About Obtaining Pipe Length Information 

Using the Length option in the Report Pipeline dialog box, you can determine the 

length of pipelines and segments, including the length of each stock type.  

To Obtain Pipe Length Information 

1. In the Report Pipeline dialog box, under Info Type, click Length.  

2. Under Definition, click Pipe Line, Line Stock, or Segment. 

o If you click Pipe Line, select a name from the LINE NAMES menu, and 

click Done Sel. Go to Step 3. 

o If you click Segment, click  and select a segment from the screen. Go 

to Step 3. 

o If you click Line Stock, select a name from the STOCK NAMES menu, and 

click Done Sel. The system displays the stock length information in the 

Results box. 

3. Using commands in the Length Type box, do one of the following: 

o Click Pre-Cut to calculate the true pipeline length, the green centerline 

length plus the extra needed for miter cuts and branches. The system 

calculates the farthest extent of the solid along the direction of the pipeline 



Pro/PIPING (Non Spec-Driven) - Help Topic Collection 

148 

to take into account miter cuts or branch cuts. Therefore, for precut length, 

it provides the minimum length of stock that should be purchased to make 

the piping, including complex cut geometry. 

o Click Center Line to calculate the pipeline length along its centerline, the 

length of the green centerline of the selection (segment or entire line) 

minus any cut-back operations for inserted fittings or branches. The length 

is always equal to the length of the green centerline of the branch to the 

reference centerline.  

4. Click . The INFORMATION WINDOW opens and displays the requested 

information.  

5. To save the information from the Results box and create a data file, click  

Saved Analyses, type a name for the file, and click Save. You can retrieve the 

saved analysis with the Retrieve button or delete it after you have closed the 

dialog box. The file is saved with an extension .dat in the working directory. 

Piping Bill of Materials 

About Generating a Piping Bill of Materials 

Using the Info Type > Bill of Materials option in the Report Pipeline dialog box, 

you can generate a Piping Bill of Materials for the active assembly that lists pipelines, 

solids, lengths, stocks, parts, and assembly components. You may have to scroll 

down in the window to see all of the information. 

To Generate a Piping Bill of Materials 

1. Click PIPING > Info. The Report Pipeline dialog box opens. 

2. Click Info Type > Bill of Materials. 

3. The Results window shows the piping BOM information. 

4. Click . The INFORMATION WINDOW opens. This window contains the piping 

BOM information table that displays the assembly name, quantity, pipeline or 

segment name, line stock, length, and part name. 

Piping Bend Information 

About Bend Machine Information 

When you collect data for pipe segment Bend Machine information, Pro/ENGINEER 

automatically selects the coordinate system at the beginning of the segment where 

the measurements are taken. 
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Bend Machine information generates a table of information about the bend number, 

offset, bend angle, bend radius, and twist angle. This information is based on the 

structure of the pipe segment and depends on the direction and start point. 

To Generate a Bend Machine Table 

1. Click Piping > Info. The Report Pipeline dialog box opens. 

2. Under Info Type, click Bend Machine. 

3. Under Definition, click  and select a pipe segment. 

4. Click the Designate for Report Setup box to make the information available in 

Pro/REPORT. The bend machine information is displayed under Results. 

5. Click . The INFORMATION WINDOW opens. This window contains the bend 

machine information table which displays the bend number, offset, twist angle, 

bend angle, and bend radius. 

6. Under Saved Analyses, specify a name for the saved information and click 

Save. The name appears in the Saved Analyses box.  

Note: You can regulate the number of decimal places displayed under Results by 

specifying the value for the default_dec_places configuration option. The default 

value is 2. 

To Generate a Bend Location Table 

1. Click Piping > Info. The Report Pipeline dialog box opens. 

2. Under Info Type, click Bend Location. 

3. Under Definition, click  to select a pipe segment and a coordinate system. 

The bend machine information is displayed in the Results box .  

4. Click the Designate for Report Setup check box to make the information 

available in Pro/REPORT. 

5. Click . The INFORMATION WINDOW opens. This window contains the bend 

location information table that displays the bend number, bend angle, bend 

radius, and the XYZ coordinates. 

6. Under Saved Analyses, type a name for the saved information and click Save. 

The name appears in the Saved Analyses box.  

Note: You can regulate the number of decimal places displayed under Results by 

specifying the value for the default_dec_places configuration option. The default 

value of this configuration option is 2. 
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About Setting Up Bend Information for Use in Pro/REPORT 

To generate bend tables, set up report information in the assembly in which the pipe 

segment was created. The information in the table references this predefined 

information from that assembly.  

To avoid generating blank bend information in a table, first use Show Report Setup 

in the piping assembly to define which information should be available in the drawing 

tables. Because information appears for each assembly level, you must filter the 

table by level to display information about a subassembly only. 

When you use Show Report Setup to create or select a coordinate system, keep in 

mind the following restrictions: 

• The selected coordinate system must be contained in the same assembly within 

which the pipe segment was created. You may need to copy a coordinate system 

from a different subassembly in order to reference the correct position. You can 

copy one from another coordinate system and have the report information 

reference the copy. 

• The z-axis of the coordinate system must lie along the starting line segment of 

the pipe. The direction of the z-axis must be the same as that of the starting line 

segment of the pipe. 

To Set Up Piping Bend Information for Use in Pro/REPORT 

1. To link the coordinate system to the correct pipe segment, click PIPING > Info. 

The Report Pipeline dialog box opens.  

2. Click Info Type > Show Report Setup. 

3. Select a segment with . 

4. Select a coordinate system in the active assembly or create a new one. The 

Results box displays the piping segment bend information for Pro/REPORT and 

the bend location information. 

You can select multiple coordinate systems for each type of bend information. To 

set up bend information for another segment or for additional coordinate 

systems, repeat Steps 2 and 3.  

The information marked by clicking the Designate for Report Setup check box 

while generating the bend machine or location table and the holes report is 

available in the Names Designated for Report Setup box. 

5. Click . The INFORMATION WINDOW with the piping segment bend 

information for Pro/REPORT and the bend location information opens. You can 

now access this information in a Pro/REPORT table in Drawing mode. 

6. Create a drawing with a repeat region table, adding the appropriate pipe segment 

parameters.  

7. Set the table to the appropriate active assembly, set the attributes to Recursive, 

and update the table. 
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Holes Report Information 

About Generating Holes Report Information 

Using the Holes Report option in the Report Pipeline dialog box, you can generate 

holes report information for a selected segment. Holes report information is 

generated only for the holes that are placed on the straight pipe section. The holes 

that intersect the bend pipe section are not reported. The holes to be reported must 

have the following: 

• Circular cross section. 

• The axis of the hole should be normal to the pipe centerline. 

The holes report is generated for the holes created by: 

• Branch sections of the considered pipe segment 

• Hole and Cut features affecting pipe solid geometry 

To Generate Holes Report Information 

1. Click Piping > Info. The Piping Info dialog box opens. 

2. Under Info Type, click Holes Report. 

3. Under Definition, select a pipe segment. 

Check the Designate for Report Setup box to make the information available 

in Pro/REPORT. 

4. The holes report information is displayed in the Results box. Click . The 

INFORMATION WINDOW opens and the holes report information is displayed. 

5. Under Saved Analyses, enter a name for the saved information and click Save. 

The name appears in the Saved Analyses box.  

Note: You can regulate the number of decimal places displayed under Results by 

specifying the value for the default_dec_places configuration option. The default 

value of this configuration option is 2. 

Setting Up Holes Report Information for Use in Pro/REPORT 

To generate holes report, set up report information in the assembly in which the pipe 

segment was created. The information in the table references this predefined 

information from that assembly.  

To avoid generating blank holes report, first use Show Report Setup in the piping 

assembly to define which information should be available.  

When creating or selecting a coordinate system when using Show Report Setup, 

the selected coordinate system must lie within the same assembly within which the 

pipe segment was created or in any of it's subassemblies . You may need to copy a 

coordinate system from a different subassembly in order to reference the correct 
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position. You can copy one from another coordinate system and have the report 

information reference the copy. 

To Set Up Holes Report Information for Use in Pro/REPORT 

1. To link the coordinate system to the correct pipe segment, click PIPING > Info. 

The Report Pipeline dialog box opens.  

2. Click Info Type > Show Report Setup. 

3. Select a segment with . 

4. Select a coordinate system in the active assembly or create a new one. 

The information marked by checking the Designate for Report Setup box while 

generating the holes report is available in the Names Designated for Report 

Setup box. 

5. The Results box displays the holes report information. 

6. Click . The INFORMATION WINDOW with the piping segment bend 

information for Pro/REPORT and the holes report information opens. You can now 

access this information in a Pro/REPORT table in Drawing mode. 

7. Create a drawing with a repeat region table, adding the appropriate pipe segment 

parameters.  

8. Set the table to the appropriate active assembly, set the attributes to Recursive, 

and update the table.  

Clocking Angle Information 

About Clocking Angle Information 

The system determines the clocking, or twist, angle between fittings on the ends of a 

flattened hose. The selected segment may not have any bends or miter cuts, but 

may have straight sections included that control the tangency of the shape. This 

information is necessary to manufacture hoses. 

You can access clocking angle information through a Pro/REPORT parameter, an 

evaluate feature, or by the Report Pipeline dialog box. 

To Set Up Clocking Angle Information for Pro/REPORT Tables 

1. In a 3-D assembly, click PIPING > Info. The Report Pipeline dialog box opens.  

2. Under INFO TYPE, click Clocking Angle.  

3. Under Definition, click Segment and select a pipe segment with flexible 

portions.  

You cannot select a segment with a bend or miter cut.  
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4. Click 1st Coordinate System to select the first coordinate system. The 

coordinate system origin must be coincident with the highlighted end of the 

selected pipe segment, and the z-axis of the coordinate system must be aligned 

pointing inward along the pipe segment from that end.   

5. Click 2nd Coordinate System to select the final coordinate system. It must lie 

at the highlighted end of the specified segment. If an evaluate feature does not 

exist for the clocking angle for the segment, the system creates one. 

An evaluate feature is described in the Part Modeling online Help. 

6. Check the Designate for Report Setup box. The Saved Analyses box opens. 

Specify the name you want and click .  

7. The system displays an INFORMATION WINDOW and writes it to a file. In a 

drawing table, use parameters under report parameter using clk_ang.  

Accessing Clocking Angle as a Pro/REPORT Parameter 

Using pipeline and pipe segment Pro/REPORT parameters, you can access clocking 

angle information specific to particular segments.  

Accessing Clocking Angle as a System Parameter 

When you set up clocking angle information for use in Pro/REPORT, the system 

automatically creates an evaluate feature in the active assembly containing the pipe 

segment. The measurement name is clk_ang_id##, where id## is the ID number of 

the evaluate feature.  

The session ID is of the parent assembly in which the clock angle evaluate feature is 

created. You can access the clocking angle as a system parameter by making notes, 

relations, and other parameters evaluate on the following: 

clk_ang:fid_<EVALUATE_ID>:<SESSION_ID>  

or  

clk_ang:fid_<EVALUATE_NAME>:<SESSION_ID> 

Clocking Angle and Bend Information 

Type of Segment Bend 

Information 

Clocking 

Angle 

All flexible NO YES 

Flexible with bends or a miter cut NO NO 

Flexible with straight sections NO YES 

All bends YES NO 
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All miter cuts NO NO 

Single straight segment NO NO 

Bend/miter cut mix YES NO 

Example: Clocking Angle 

This is an example of how to show this value in a 3-D note: 

1. Create a clock angle feature in piping mode. 

2. Create an assembly parameter, clockangle, that is driven by the following 

relation: 

clockangle = clk_ang:fid_30:57 

where  

30 is the evaluate_ID 

57 is the session_ID 

3. Create an assembly 3-D bend note: The clock angle is &clockangle.  

A seg_name feature parameter is created in the evaluate feature to identify its parent 

segment. Upon regeneration, the system updates an evaluate feature for a particular 

segment of pipe to a new value if the segment changes.  

You can redefine the feature by choosing either: 

Feature > Redefine > References > Segment  

or  

 

Under Info, click Clocking Angle and under Definition, click Segment in the 

Report Pipeline dialog box. 

To Access the Clocking Angle as General Information 

1. Click Applications > Piping > Info. The Report Pipeline dialog box opens. 

2. Under Info Type, click Clocking Angle and under Definition, click  and 

select a pipe segment in the Pro/ENGINEER window.  

3. Select a pipe segment with flexible portions.  

You cannot select a pipe segment with a bend or miter cut.  

4. Select or create a coordinate system at the highlighted end of the segment.  

o The coordinate system origin must be coincident with the highlighted end of 

the selected pipe segment. 

o The z-axis of the coordinate system must be aligned pointing inward along 

the pipe segment from that end.  
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o The coordinate system should belong to the active assembly. 

5. Select the final coordinate system at the highlighted end of the selected segment, 

using the same constraints as before.  

The system displays an INFORMATION WINDOW and writes the information to a 

file. 

Calculating Clocking Angle Between Fittings 

Within Pro/ENGINEER, you can obtain information about the clocking angle between 

fittings in a flexible hose. When two end fittings of a flexible pipe (or hose) are 

assembled to a hose and the hose is taken from its routed state to a flattened state, 

the fittings must be assembled to the hose correctly twisted relative to each other. 

This is done so that they will fit in the assembly properly without requiring the hose 

itself to twist. Many fittings are not axially symmetric and require a specific 

orientation when they are assembled.  

The system calculates the clocking angle by sliding the initial coordinate system 

along the flexible pipe segment in the orientation of least energy until its origin is 

coincident with the final coordinate system at the other end of the segment. It then 

determines the angle between the two x-axes of the coordinate systems.  

Using Pro/ENGINEER, you can access this information as general information or as a 

system parameter. You can also show clocking angle information using Pro/REPORT 

parameters. 

File Interchange Format Information 

About Output FIF 

You can generate a file interchange format (FIF) file for a selected pipeline segment 

that contains Bend information. This FIF file is formatted with the necessary 

commands to drive an Eagle Eaton Leonard bending machine. 

To Generate an FIF File 

1. In the Report Pipeline dialog box under Info Type, click Output FIF. 

2. Click the Segment arrow. The SELECT menu appears. 

3. Select a pipe segment in the Pro/ENGINEER window. 

4. The Results box lists the file interchange format (FIF) bend information for that 

segment. 

5. To view the results in a larger window, click . 
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Check Pipe Information 

About Checking Pipelines for Line Stock Violations 

Use the Check Pipe option in the Report Pipeline dialog box to determine if any 

violations of the corresponding line stock exist in selected pipelines. By isolating 

potentially problematic areas, you can take the necessary measures to prevent 

failures. The system compares the characteristics of the selected pipeline with the 

values of the parameters set in the line stock file, and then highlights all locations on 

the pipe curve where violations occur. 

To Check a Pipe for Line Stock Violations 

1. Click PIPING > Info. The Report Pipeline dialog box opens. 

2. Under Info Type, click Check Pipe. 

3. Under Definition, select a pipe line to check. 

4. The Results box shows any Line Stock parameter violations it has detected. 

The system highlights the pipeline in the following cases:  

o If the violation applies to the entire pipeline. 

o If the violation applies to certain geometry of the pipe, for example, a bend. 

You can also click  to open the INFORMATION WINDOW. This window displays 

the Line Stock name, the parameter name, the value of the parameter, and the 

value of the violation (if there is one). You can save, edit, and search in this 

information window. 

Using the Report Pipeline Dialog Box 

The Report Pipeline dialog box combines the traditional piping information tools 

with Results and allows you to define and use Saved Analyses for future use. The 

Report Pipeline dialog box displays Info Type, Definition, Results, and Saved 

Analyses. 

The Info Type box displays the following information: 

• General 

o Pipeline, pipe segment, and insulation under Definition 

o Length 

o Pipeline, line stock, and segment under Definition 

o Length Type consists of pre/cut and centerline 

o Bill of Materials Generated for the Active Assembly 

o Bend Location 
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o Bend Machine 

o Holes Report 

o Clocking Angle 

o Output File Interchange Format 

o Check Pipe 

o Pipeline under Definition.  

o Show Report Setup 

o Insulation Location 

The Definition box displays a pipe segment, pipeline, or insulation. 

The Results box displays the name of the pipe segment, pipeline, or assembly that 

you selected with . 

  displays the INFORMATION WINDOW with the extended information from the 

Results box. 

The Saved Analyses box displays the names of the saved analysis files, which are 

based on the information in the Results box. 

Report Setup 

About Using Show Report Setup 

You can use Pro/REPORT functionality with Pro/PIPING to view and remove report 

setups. 

When you use Show Report Setup in a piping assembly, remember the following: 

• The system creates pipe segment bend information and stores it in the piping 

assembly. You do not generate the bend information directly in the drawing. 

However, you can access it automatically by using the Pro/REPORT functionality 

in Drawing mode after you use Show Report Setup in Assembly/Piping mode. 

You can format the Pro/REPORT table in any way that you click.  

• To create a piping report, be sure to set the repeat region attribute to 

Recursive. 

• To create a report that contains only piping information in the top-level assembly, 

set the Recursive attribute in the repeat region and add the filter 

[&rpt.level==1].  

• You cannot use report parameters that contain more than 32 characters in report 

relations, for example, as filters for what is shown in a table. 
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To Show Report Setup 

1. Click PIPING > Info. The Report Pipeline dialog box opens. 

2. Under Info Type, click Show Report Setup.  

3. Select a pipe segment in the Pro/ENGINEER window. 

4. To view reports which have been defined for bend machine, bend location, or 

clocking angle information, see the Names Designated for Report Setup box. 

If you click , the INFORMATION WINDOW opens.  

Saved Analyses 

About Saved Analyses 

The Saved Analyses function allows you to gather piping information with selected 

object references (segment, csys, and so on). You can easily name and retrieve 

them for subsequent analysis, and designate them for report setup. 

To Save an Analysis 

1. In the Report Pipeline dialog box, save the information from the Results box. 

2. Click Saved Analyses and type a name for the file with an extension ".dat" in 

the working directory. 

3. Click Save. After you have closed the dialog box, you can retrieve the saved 

analysis.  

4. In the Saved Analyses box, select the name and click Retrieve. 

You can also save the file again or delete it.  

To Retrieve Object Selections 

You can retrieve a saved analysis with the Retrieve button in the Report Pipeline 

dialog box. You can also delete the saved analysis in the dialog box. The file is saved 

with an extension .dat in the working directory. 

Pro/REPORT with Pro/PIPING 

About Pro/REPORT Functionality in Pro/PIPING 

You can use Pro/REPORT functionality with Pro/PIPING to create a customized table 

or Bill of Materials (BOM) for a piping assembly. A piping assembly drawing is the 

same as a drawing of any other Pro/ENGINEER object, except that it uses special 

parameters. The customized table updates automatically to reflect changes in the 

piping assembly. You can customize drawing tables to reflect the standard practices 

of your company. 
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When you use Pro/REPORT functionality in a piping assembly, keep in mind the 

following: 

• The system creates pipe segment bend information and stores it in the piping 

assembly. You do not generate the bend information directly in the drawing. 

However, you can access it automatically by using the Pro/REPORT functionality 

in Drawing mode after you use  

Show Report Setup in Assembly/Piping mode. You can format the Pro/REPORT 

table in any way that you choose. 

• To create a piping report, be sure to set the repeat region attribute to 

Recursive.  

• To create a report that contains only piping information in the top-level assembly, 

set the Recursive attribute in the repeat region and add the filter 

[&rpt.level==1] 

• You cannot use report parameters that contain more than 32 characters in report 

relations, for example, as filters for what is shown in a table. 

To Set Up Piping Bend Information for Use in Pro/REPORT 

1. To link the coordinate system to the correct pipe segment, click PIPING > Info. 

The Report Pipeline dialog box opens.  

2. Click Info Type > Show Report Setup. 

3. Select a segment with . 

4. Select a coordinate system in the active assembly or create a new one. The 

Results box displays the piping segment bend information for Pro/REPORT and 

the bend location information. 

You can select multiple coordinate systems for each type of bend information. To 

set up bend information for another segment or for additional coordinate 

systems, repeat Steps 2 and 3.  

The information marked by clicking the Designate for Report Setup check box 

while generating the bend machine or location table and the holes report is 

available in the Names Designated for Report Setup box. 

5. Click . The INFORMATION WINDOW with the piping segment bend 

information for Pro/REPORT and the bend location information opens. You can 

now access this information in a Pro/REPORT table in Drawing mode. 

6. Create a drawing with a repeat region table, adding the appropriate pipe segment 

parameters.  

7. Set the table to the appropriate active assembly, set the attributes to Recursive, 

and update the table. 
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About Setting Up Bend Information for Use in Pro/REPORT 

To generate bend tables, set up report information in the assembly in which the pipe 

segment was created. The information in the table references this predefined 

information from that assembly.  

To avoid generating blank bend information in a table, first use Show Report Setup 

in the piping assembly to define which information should be available in the drawing 

tables. Because information appears for each assembly level, you must filter the 

table by level to display information about a subassembly only. 

When you use Show Report Setup to create or select a coordinate system, keep in 

mind the following restrictions: 

• The selected coordinate system must be contained in the same assembly within 

which the pipe segment was created. You may need to copy a coordinate system 

from a different subassembly in order to reference the correct position. You can 

copy one from another coordinate system and have the report information 

reference the copy. 

• The z-axis of the coordinate system must lie along the starting line segment of 

the pipe. The direction of the z-axis must be the same as that of the starting line 

segment of the pipe. 

Pro/REPORT Parameters Applicable to Pro/PIPING 

Linestock Parameters 

Parameter Name Definition 

&asm.mbr.pipe.stock.name Lists name(s) of line 

stock(s). 

&asm.mbr.pipe.stock.User Defined  Lists specified parameters 

for the line stock. 

&asm.mbr.pipe.stock.line.name Lists names of all pipelines 

using each line stock.  

&asm.mbr.pipe.stock.line.User Defined Lists parameters for the 

pipeline using the specified 

line stock. 

&asm.mbr.pipe.stock.material Lists material for all line 

stocks. 

&asm.mbr.pipe.stock.OD Lists outer diameter for 

line stocks. 

&asm.mbr.pipe.stock.wallthick Lists wall thickness for line 

stocks.  
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&asm.mbr.pipe.stock.len.pre_cut Lists total precut length of 

each line stock.  

&asm.mbr.pipe.stock.len.center Lists total centerline length 

of each line stock. 

Pipeline Parameters 

Parameter Name Definition 

&asm.mbr.pipe.line.segment.stock.name Lists names of line stocks 

for each segment in the 

pipeline. 

&asm.mbr.pipe.line.segment.stock.User 
Defined 

Lists parameters for line 

stocks of which the 

pipeline is made. 

&asm.mbr.pipe.line.name Lists names of all 

pipelines. 

&asm.mbr.pipe.line.User Defined Lists parameters for each 

pipeline. 

&asm.mbr.pipe.line.stock.name Lists names of line stocks 

used in each pipeline. 

&asm.mbr.pipe.line.stock.User Defined Lists parameters for line 

stocks used in pipeline. 

&asm.mbr.pipe.line.len.pre_cut Lists precut length of each 

pipeline. 

&asm.mbr.pipe.line.len.center Lists centerline length of 

each pipeline. 

&asm.mbr.pipe.line.segment.name Lists names of all 

segments in pipeline. 

&asm.mbr.pipe.line.segment.solid_name Lists names of all solids (if 

defined) in pipeline. 

&asm.mbr.pipe.line.segment.len.pre_cut Lists precut length of 

segments in pipeline. 

&asm.mbr.pipe.line.segment.len.center Lists centerline length of 

segments in pipeline.  
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&asm.mbr.pipe.line.segment.clk_ang.ang Lists clocking angle value 

from evaluate feature. 

&asm.mbr.pipe.line.segment.clk_ang.cs1 Lists name of initial 

coordinate system for 

each clocking angle. 

&asm.mbr.pipe.line.segment.clk_ang.cs2 Lists name of final 

coordinate system for 

each clocking angle. 

Pipe Segment Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.name Lists system default name 

of the pipeline segments. 

&asm.mbr.pipe.segment.solid_name Lists solid part name for 

each segment (if defined). 

&asm.mbr.pipe.segment.stock.name Lists line stock used in 

each segment. 

&asm.mbr.pipe.segment.stock.User 
Defined 

Lists parameters in line 

stocks assigned to each 

segment. 

&asm.mbr.pipe.segment.line.name Lists name of pipeline to 

which each segment 

belongs. 

&asm.mbr.pipe.segment.line.User 
Defined 

Lists pipeline parameters 

for each segment. 

&asm.mbr.pipe.segment.len.pre_cut Lists precut length of each 

segment. 

&asm.mbr.pipe.segment.len.center Lists centerline length of 

each segment. 

&asm.mbr.pipe.segment.segfrom Lists location from which 

each pipeline segment in 

the assembly is routed. 

This is the component to 

which the from entry port 

belongs. 
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&asm.mbr.pipe.segment.segto Lists the location to which 

each pipeline segment in 

the assembly is routed. 

This is the component to 

which the to entry port 

belongs. 

&asm.mbr.pipe.segment.clk_ang.ang Lists clocking angle value 

of evaluate feature. 

&asm.mbr.pipe.segment.clk_ang.cs1 Lists name of initial 

coordinate system for each 

clocking angle. 

&asm.mbr.pipe.segment.clk_ang.cs2 Lists name of final 

coordinate system for each 

clocking angle. 

Pipeline Segment Bend Information Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.csys.bend.User Defined Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.csys.bend.loc_angle  Lists bend 

angle. 

&asm.mbr.pipe.segment.csys.bend. loc_num Lists bend 

location bend 

number. 

&asm.mbr.pipe.segment.csys.bend.loc_radius  Lists bend 

radius. 

&asm.mbr.pipe.segment.csys.bend.loc_x Lists x-offset 

bend location 

information. 

&asm.mbr.pipe.segment.csys.bend.loc_y Lists y-offset 

bend location 

information. 
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&asm.mbr.pipe.segment.csys.bend.loc_z Lists z-offset 

bend location 

information. 

&asm.mbr.pipe.segment.csys.bend. mach_bend Lists bend 

machine bend 

angle. 

&asm.mbr.pipe.segment.csys.bend.mach_num Lists bend 

machine bend 

number. 

&asm.mbr.pipe.segment.csys.bend.mach_offset Lists bend 

machine 

offset. 

&asm.mbr.pipe.segment.csys.bend.mach_radius Lists bend 

machine bend 

radius. 

&asm.mbr.pipe.segment.csys.bend.mach_twist Lists bend 

machine twist 

angle. 

&asm.mbr.pipe.segment.csys.name Lists 

coordinate 

system name 

for segment 

bend 

information. 

&asm.mbr.pipe.segment.mach_csys.bend.User 
Defined 

Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.mach_csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_bend Lists bend 

machine bend 

angle. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_num Lists bend 

machine 

number. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_offset Lists bend 

machine 

offset. 
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&asm.mbr.pipe.segment.mach_csys.bend.mach_ 

radius 

Lists bend 

machine 

radius. 

&asm.mbr.pipe.segment.mach_csys.bend.mach_twist Lists bend 

machine twist 

angle. 

&asm.mbr.pipe.segment.mach_csys.name Lists name of 

coordinate 

system with 

bend machine 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.User Defined Lists a user-

defined bend 

parameter. 

&asm.mbr.pipe.segment.loc_csys.bend.bend_name Lists the bend 

name created 

by the system. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_angle Lists bend 

location bend 

angle. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_num Shows bend 

location bend 

number. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_radius Lists bend 

location bend 

radius. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_x Lists x-offset 

bend location 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_y Lists y-offset 

bend location 

information. 

&asm.mbr.pipe.segment.loc_csys.bend.loc_z Lists z-offset 

bend location 

information. 
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&asm.mbr.pipe.segment.loc_csys.name Lists 

coordinate 

system name 

for segment 

bend location 

information. 

Holes Report Parameters 

Parameter Name Definition 

&asm.mbr.pipe.segment.holes.holes_params.hole_num List holes 

report 

 number. 

&asm.mbr.pipe.segment.holes.holes_params.hole_offset List holes 

report 

offset. 

&asm.mbr.pipe.segment.holes.holes_params.hole_angle List holes 

report 

angle. 

&asm.mbr.pipe.segment.holes.holes_param..hole_diam List holes 

report 

diameter. 
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Pro/REPORT Pipeline Parameters 

 

Pro/REPORT Pipe Stock Parameters 
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Pro/REPORT Pipe Segment Parameters 
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