User and training documentation from Parametric Technology Corporation (PTC) is subject to the copyright laws of the United States and other countries and is provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes.

Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.

The software described in this document is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC. UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

Registered Trademarks of Parametric Technology Corporation or a Subsidiary

Trademarks of Parametric Technology Corporation or a Subsidiary

Patents of Parametric Technology Corporation or a Subsidiary
Registration numbers and issue dates follow. Additionally, equivalent patents may be issued or pending outside of the United States. Contact PTC for further information.

<table>
<thead>
<tr>
<th>Patent Number</th>
<th>Issue Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>6,605,569 B1</td>
<td>16-December-2003</td>
</tr>
<tr>
<td>6,625,607 B1</td>
<td>23-September-2003</td>
</tr>
<tr>
<td>6,580,428 B1</td>
<td>17-June-2003</td>
</tr>
<tr>
<td>GB2354684B</td>
<td>02-July-2003</td>
</tr>
<tr>
<td>GB2384125</td>
<td>15-October-2003</td>
</tr>
<tr>
<td>GB2354096</td>
<td>12-November-2003</td>
</tr>
<tr>
<td>6,608,623 B1</td>
<td>19 August 2003</td>
</tr>
<tr>
<td>GB2353376</td>
<td>05-November-2003</td>
</tr>
<tr>
<td>GB2354686</td>
<td>15-October-2003</td>
</tr>
<tr>
<td>GB2356855B</td>
<td>18-June-2003</td>
</tr>
<tr>
<td>6,605,569 B1</td>
<td>16-December-2003</td>
</tr>
<tr>
<td>6,625,607 B1</td>
<td>23-September-2003</td>
</tr>
<tr>
<td>GB2354683B</td>
<td>04-June-2003</td>
</tr>
<tr>
<td>GB2354684B</td>
<td>02-July-2003</td>
</tr>
<tr>
<td>GB2384125</td>
<td>15-October-2003</td>
</tr>
<tr>
<td>GB2354096</td>
<td>12-November-2003</td>
</tr>
<tr>
<td>6,608,623 B1</td>
<td>19 August 2003</td>
</tr>
<tr>
<td>GB2353376</td>
<td>05-November-2003</td>
</tr>
<tr>
<td>GB2354686</td>
<td>15-October-2003</td>
</tr>
<tr>
<td>GB2356855B</td>
<td>18-June-2003</td>
</tr>
<tr>
<td>4,310,615</td>
<td>21-December-1998</td>
</tr>
<tr>
<td>4,310,614</td>
<td>30-April-1999</td>
</tr>
<tr>
<td>4,310,614</td>
<td>30-April-1999</td>
</tr>
<tr>
<td>5,297,053</td>
<td>22-March-1994</td>
</tr>
<tr>
<td>5,513,316</td>
<td>30-April-1999</td>
</tr>
<tr>
<td>5,689,711</td>
<td>18-November-1997</td>
</tr>
<tr>
<td>5,506,950</td>
<td>09-April-1996</td>
</tr>
<tr>
<td>5,428,772</td>
<td>27-June-1995</td>
</tr>
<tr>
<td>5,850,535</td>
<td>15-December-1998</td>
</tr>
<tr>
<td>5,557,176</td>
<td>09-November-1996</td>
</tr>
<tr>
<td>5,561,747</td>
<td>01-October-1996</td>
</tr>
</tbody>
</table>

Third-Party Trademarks
Adobe is a registered trademark of Adobe Systems. Advanced ClusterProven, ClusterProven, and the ClusterProven design are trademarks or registered trademarks of International Business Machines Corporation in the United States and other countries and are used under license. IBM Corporation does not warrant and is not responsible for the
operation of this software product. AIX is a registered trademark of IBM Corporation. Allegro, Cadence, and Concept are registered trademarks of Cadence Design Systems, Inc. Apple, Mac, Mac OS, and Panther are trademarks or registered trademarks of Apple Computer, Inc. AutoCAD and Autodesk Inventor are registered trademarks of Autodesk, Inc. Baan is a registered trademark of Baan Company. CADAM and CATIA are registered trademarks of Dassault Systemes. COACH is a trademark of CADTRAIN, Inc. DOORS is a registered trademark of Telelogic AB. FLEXlm is a trademark of Macrovision Corporation. Geomagic is a registered trademark of Raindrop Geomagic, Inc. EVERSINC, GROOVE, GROOVEFEST, GROOVE.NET, GROOVE NETWORKS, iGROOVE, PEERWARE, and the interlocking circles logo are trademarks of Groove Networks, Inc. Helix is a trademark of Microcadam, Inc. HOOPS is a trademark of Tech Soft America, Inc. HP-UX is a registered trademark and Tru64 is a trademark of the Hewlett-Packard Company. I-DEAS, Metaphase, Parasolid, SHERPA, Solid Edge, and Unigraphics are trademarks or registered trademarks of Electronic Data Systems Corporation (EDS). InstallShield is a registered trademark and service mark of InstallShield Software Corporation in the United States and/or other countries. Intel is a registered trademark of Intel Corporation. IRIX is a registered trademark of Silicon Graphics, Inc. LINUX is a registered trademark of Linus Torvalds. MatrixOne is a trademark of MatrixOne, Inc. Mentor Graphics and Board Station are registered design marks and 3D Design, AMPLE, and Design Manager are trademarks of Mentor Graphics Corporation. MEDUSA and STHENO are trademarks of CAD Schroer GmbH. Microsoft, Microsoft Project, Windows, the Windows logo, Windows NT, Visual Basic, and the Visual Basic logo are registered trademarks of Microsoft Corporation in the United States and/or other countries. Netscape and the Netscape N and Ship's Wheel logos are registered trademarks of Netscape Communications Corporation in the U.S. and other countries. Oracle is a registered trademark of Oracle Corporation. OrbixWeb is a registered trademark of IONA Technologies PLC. PDGS is a registered trademark of Ford Motor Company. RAND is a trademark of RAND Worldwide. Rational Rose is a registered trademark of Rational Software Corporation. RetrievalWare is a registered trademark of Convera Corporation. RosettaNet is a trademark and Partner Interface Process and PIP are registered trademarks of “RosettaNet,” a nonprofit organization. SAP and R/3 are registered trademarks of SAP AG Germany. SolidWorks is a registered trademark of SolidWorks Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. in the United States and in other countries. Products bearing SPARC trademarks are based upon an architecture developed by Sun Microsystems, Inc. Sun, Sun Microsystems, the Sun logo, Solaris, UltraSPARC, Java and all Java based marks, and “The Network is the Computer” are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and in other countries. TIBCO, TIBCO Software, TIBCO ActiveEnterprise, TIBCO Designer, TIBCO Enterprise for JMS, TIBCO Rendezvous, TIBCO Turbo XML, TIBCO Business Works are the trademarks or registered trademarks of TIBCO Software Inc. in the United States and other countries. WebEx is a trademark of WebEx Communications, Inc.

Third-Party Technology Information

Certain PTC software products contain licensed third-party technology: Rational Rose 2000E is copyrighted software of Rational Software Corporation. RetrievalWare is copyright software of Convera Corporation. VisTools library is copyrighted software of Visual Kinematics, Inc. (VKI) containing confidential trade secret information belonging to VKI. HOOPS graphics system is a proprietary software product of, and is copyrighted by, Tech Soft America, Inc. G-POST is copyright software and a registered trademark of Intericm. VERICUT is copyright software and a registered trademark of CGTech. Pro/PLASTIC ADVISOR is powered by Moldflow technology. Moldflow is a registered trademark of Moldflow Corporation. The JPEG image output in the Pro/Web.Publish module is based in part on the work of the independent JPEG Group. DFORMD.DLL is copyright software from Compaq Computer Corporation and may not be distributed. METIS, developed by George Karypis and Vipin Kumar at the University of Minnesota, can be researched at http://www.cs.umn.edu/~karypis/metis. METIS is © 1997 Regents of the University of Minnesota. LightWork Libraries are copyright protected by LightWork Design 1990–2001. Visual Basic for Applications and Internet Explorer is copyright software of Microsoft Corporation. Parasolid © Electronic Data Systems (EDS). Windchill Info*Engine Server contains IBM XML Parser for Java Edition and the IBM Lotus XSL Edition. Pop-up calendar components Copyright © 1998 Netscape Communications Corporation. All Rights Reserved. TIBCO Business Works are the trademarks or registered trademarks of TIBCO Software Inc. in the United States and other countries. WebEx is a trademark of WebEx Communications, Inc.

Oracle programs provided herein are subject to a restricted use license and can only be used in conjunction with the PTC software they are provided with. Apache Server, Tomcat, Xalan, and Xerces are technologies developed by, and are copyrighted software of, the Apache Software Foundation (http://www.apache.org) – their use is subject to the terms and limitations at: http://www.apache.org/LICENSE.txt. Acrobat Reader is copyright software of Adobe Systems Inc. and is subject to the Adobe End-User License Agreement as provided by Adobe with those products. UnZip (© 1990-2001 Info-ZIP, All Rights Reserved) is provided “AS IS” and WITHOUT WARRANTY OF ANY KIND. For the complete Info-ZIP license see ftp://ftp.info-zip.org/pub/infozip/license.html. Gecko and Mozilla components are subject to the Mozilla Public License Version 1.1 at http://www.mozilla.org/MPL. Software distributed under the MPL is distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either expressed or implied. See the MPL for the specific language governing rights and limitations. The Java™ Telnet Applet
## Table Of Contents

Pro/MOLDESIGN and Pro/CASTING ........................................................................................................... 1

Using Moldesign and Casting .................................................................................................................. 1

What You Can Do with Pro/MOLDESIGN and Pro/CASTING .......................................................... 1

To Perform a Typical Pro/MOLDESIGN Session .............................................................................. 2

More about Pro/MOLDESIGN .............................................................................................................. 3

Typical Mold Design Workflow ........................................................................................................... 4

To Perform a Typical Pro/CASTING Session .................................................................................... 6

More about Pro/CASTING .................................................................................................................. 7

Example: Simulating the Opening of a Die ......................................................................................... 7

Example: Emulating the Casting Process ............................................................................................ 8

Configuring for Moldesign and Casting ............................................................................................... 8

About Configuration File Options .......................................................................................................... 8

To Set Moldesign and Casting Configuration Options .................................................................. 9

accuracy_lower_bound ............................................................................................................................ 9

default_abs_accuracy .......................................................................................................................... 9

allow_shrink_dim_before ..................................................................................................................... 9

default_mold_base_vendor .................................................................................................................. 10

default_shrink_formula ....................................................................................................................... 10

enable_absolute_accuracy ................................................................................................................... 10

mold_layout_origin_name ................................................................................................................... 10

mold_vol_surf_no_auto_rollback ........................................................................................................ 10

pro_catalog_dir ................................................................................................................................. 11

pro_cav_lay_rule_dir .......................................................................................................................... 11

save_instance_accelerator .................................................................................................................. 11

show_all_mold_layout_buttons ......................................................................................................... 11

shrinkage_value_display ...................................................................................................................... 11

template_mfgcast .............................................................................................................................. 12

template_mfgmold ............................................................................................................................ 12

Working in Mold or Cast Mode ........................................................................................................... 12
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the Mold or Cast Model Structure</td>
<td>12</td>
</tr>
<tr>
<td>Example: Mold or Cast Model</td>
<td>13</td>
</tr>
<tr>
<td>To Create a New Mold or Cast Model</td>
<td>13</td>
</tr>
<tr>
<td>Creating New Mold or Cast Models</td>
<td>13</td>
</tr>
<tr>
<td>The Cavity Design Toolbar</td>
<td>14</td>
</tr>
<tr>
<td>MOLD and CAST Menu Selections</td>
<td>15</td>
</tr>
<tr>
<td>MOLD MODEL and CAST MODEL Menus</td>
<td>16</td>
</tr>
<tr>
<td>To Enter Mold or Cast Mode with an Existing Model</td>
<td>17</td>
</tr>
<tr>
<td>Mold or Cast Model Files</td>
<td>17</td>
</tr>
<tr>
<td>Working with Mold or Cast Files</td>
<td>17</td>
</tr>
<tr>
<td>To Create Ordinate Dimensions Automatically</td>
<td>18</td>
</tr>
<tr>
<td>Design Models</td>
<td>19</td>
</tr>
<tr>
<td>About Design Models</td>
<td>19</td>
</tr>
<tr>
<td>Example: Design Model for Casting</td>
<td>20</td>
</tr>
<tr>
<td>To Create a Mold Assembly with Multiple Design Models</td>
<td>20</td>
</tr>
<tr>
<td>Shrinkage</td>
<td>20</td>
</tr>
<tr>
<td>About Applying Shrinkage</td>
<td>20</td>
</tr>
<tr>
<td>To Specify a Shrinkage Formula</td>
<td>21</td>
</tr>
<tr>
<td>Selecting the Shrinkage Formula</td>
<td>21</td>
</tr>
<tr>
<td>To Apply Shrinkage by Dimension</td>
<td>22</td>
</tr>
<tr>
<td>Applying Shrinkage by Dimension</td>
<td>23</td>
</tr>
<tr>
<td>Example: Applying Shrinkage by Dimension</td>
<td>24</td>
</tr>
<tr>
<td>Tip: Shrinkage and UDFs</td>
<td>25</td>
</tr>
<tr>
<td>Tip: Resolving Relations When Applying Shrinkage</td>
<td>25</td>
</tr>
<tr>
<td>To Apply Shrinkage by Scaling</td>
<td>25</td>
</tr>
<tr>
<td>Applying Shrinkage by Scaling</td>
<td>26</td>
</tr>
<tr>
<td>To View Shrinkage Information</td>
<td>26</td>
</tr>
<tr>
<td>Reference Parts</td>
<td>27</td>
</tr>
<tr>
<td>About Reference Parts</td>
<td>27</td>
</tr>
<tr>
<td>To Assemble the Reference Part to the Mold or Cast Assembly</td>
<td>27</td>
</tr>
<tr>
<td>To Create a New Reference Part</td>
<td>28</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Design Part and Reference Part Relationship</td>
<td>28</td>
</tr>
<tr>
<td>Reference Part Layout</td>
<td>29</td>
</tr>
<tr>
<td>Inherited Reference Part</td>
<td>33</td>
</tr>
<tr>
<td>Adding Workpieces</td>
<td>37</td>
</tr>
<tr>
<td>About Workpieces or Die Blocks</td>
<td>37</td>
</tr>
<tr>
<td>To Assemble the Workpiece or Die Block into the Mold or Cast Assembly</td>
<td>38</td>
</tr>
<tr>
<td>To Create Manual Workpieces</td>
<td>38</td>
</tr>
<tr>
<td>Cutting Out Reference Parts of a Workpiece</td>
<td>38</td>
</tr>
<tr>
<td>Automatic Workpiece Creation</td>
<td>39</td>
</tr>
<tr>
<td>Mold Parting Surfaces</td>
<td>40</td>
</tr>
<tr>
<td>About Creating Parting Surfaces</td>
<td>40</td>
</tr>
<tr>
<td>Parting Surface Rules</td>
<td>41</td>
</tr>
<tr>
<td>Creating Parting Surfaces</td>
<td>41</td>
</tr>
<tr>
<td>Adding a Skirt Parting Surface</td>
<td>42</td>
</tr>
<tr>
<td>Adding a Shadow Surface</td>
<td>45</td>
</tr>
<tr>
<td>Adding Advanced Parting Surfaces</td>
<td>49</td>
</tr>
<tr>
<td>Filling a Hole in a Parting Surface</td>
<td>50</td>
</tr>
<tr>
<td>Using a Quilt as a Reference for a Parting Surface Feature</td>
<td>56</td>
</tr>
<tr>
<td>Pro/SURFACE Features in Mold Parting Surface</td>
<td>57</td>
</tr>
<tr>
<td>Modifying Mold Parting Surfaces</td>
<td>58</td>
</tr>
<tr>
<td>Mold Volumes</td>
<td>73</td>
</tr>
<tr>
<td>Splitting to Volumes</td>
<td>73</td>
</tr>
<tr>
<td>Creating Volumes</td>
<td>87</td>
</tr>
<tr>
<td>Operating on Components</td>
<td>88</td>
</tr>
<tr>
<td>Gathering Volumes</td>
<td>89</td>
</tr>
<tr>
<td>Sketching Volumes</td>
<td>98</td>
</tr>
<tr>
<td>Modifying Volumes</td>
<td>99</td>
</tr>
<tr>
<td>Sliders</td>
<td>101</td>
</tr>
<tr>
<td>About Sliders</td>
<td>101</td>
</tr>
<tr>
<td>To Create a Slider</td>
<td>102</td>
</tr>
<tr>
<td>Using the Slider Functionality</td>
<td>103</td>
</tr>
</tbody>
</table>
# Table Of Contents

- Dealing with Slider Extension Failure ................................................................. 103
- Example: Creating a Slider ................................................................................... 103
- Example: Selecting a Projection Plane for a Slider ............................................... 106
- Extracting Mold Components ................................................................................ 107
  - About Extracting Mold Components or Die Blocks ........................................ 107
  - To Extract a Mold Component or Die Block .................................................. 107
  - Example: Extracting a Component or Die Block .......................................... 108
- Sand Cores ......................................................................................................... 108
  - About Sand Cores .......................................................................................... 108
  - To Create a Sand Core Using Pro/CASTING.................................................. 108
  - Tip: Splitting Sand Cores............................................................................. 109
- Working with Mold or Cast Results ....................................................................... 109
  - About Creating the Mold or Cast Result ...................................................... 109
  - To Create a Mold or Cast Result ..................................................................... 109
  - To Delete a Mold or Cast Result ....................................................................... 109
- Mold or Cast Base Components ............................................................................ 110
  - About Mold Base Components and Fixtures................................................ 110
  - To Assemble the Mold Base Component or Fixture into the Mold or Cast Assembly ........................................................................................................... 110
  - To Create a New Mold Base Component or Fixture ....................................... 110
  - To Create a Mold Component .......................................................................... 111
  - Creating a Mold Component ........................................................................... 111
  - To Assemble a Mold or Die Component .......................................................... 111
  - To Remove a Component ................................................................................. 111
  - Deleting a Component or Die Block.................................................................. 112
  - To Add an Assembly to a Mold or Cast Model ............................................. 112
  - To Reclassify an Assembly Component.......................................................... 112
- Using the Ejector Pin Catalog............................................................................... 113
  - About Using the Ejector Pin Catalog............................................................... 113
  - To Use the Ejector Pin Catalog ....................................................................... 113
- Component Set Menu ......................................................................................... 113
The Define Parameters Dialog Box............................................................114
To Add an Ejector Pin Set........................................................................114
The Define Set Dialog Box.......................................................................115
To Create Holes for Ejector Pins ...............................................................115
To Generate an Ejector Pin Component Name..........................................116
To Redefine All Ejector Pin Set Members....................................................116
To Delete an Ejector Pin Set ....................................................................116
To Trim an Ejector Pin Set.......................................................................117
To Create Clearance Holes.......................................................................117
Using Pro/LIBRARY Components .................................................................118
About Assembling Pro/LIBRARY Components .............................................118
To Use a Component from the MOLD BASE LIBRARY...................................118
Using a Component from the MOLD BASE LIBRARY.....................................118
Tip: Modifying Mold Base Plates ...............................................................119
Tip: Using Additional Plates ....................................................................119
Regenerating Mold or Cast Models...............................................................119
About Regeneration in Mold or Cast Mode..................................................119
To Regenerate in Mold or Cast Mode..........................................................119
Model Accuracy ........................................................................................119
About the Accuracy of Models ..................................................................119
To Control the Accuracy of Models............................................................120
To Change the Accuracy of Models............................................................120
Reasons for Changing the Accuracy ..........................................................121
Working with Absolute and Relative Accuracy.............................................121
Simplified Representations .........................................................................122
About Simplified Representation in Mold and Casting ...............................122
To Create a Simplified Rep ......................................................................122
Blanking and Unblanking............................................................................123
About Blanking and Unblanking.................................................................123
To Blank an Object .................................................................................123
To Unblank an Object ..............................................................................123
Verifying Models ........................................................................................... 124
   About the Mold Analysis Dialog Box ...................................................... 124
   To Perform a Mold Analysis on Draft Check or Waterlines ................. 124
   About Draft .......................................................................................... 125
   About Draft Checking .......................................................................... 125
   To Perform a Draft Check ..................................................................... 125
   About Determining the Optimal Pull Direction .................................... 126
   Example: Display of a Draft Check ....................................................... 127
   To Perform a Thickness Check .............................................................. 127
   To Perform a Thickness Check Using Make Slices ................................ 128
   Example: Thickness Check Performed Using Sel Plane ...................... 129
   Example: Defining the First Slice for Checking Thickness .................... 130
   To Calculate the Surface Area of a Cavity .......................................... 130
   To Perform a Parting Surface Check ..................................................... 130
Mold or Casting Information ...................................................................... 131
   About Mold or Cast Information ......................................................... 131
   To Display Mold or Cast Information .................................................... 131
   Requesting Specific Information .......................................................... 131
Creating Mold and Cast Features ............................................................. 132
   About Creating Features....................................................................... 132
   To Add a Regular Feature to a Mold or Cast Component ...................... 132
   To Create Features and Redefine Layout Using the Model Tree ............ 133
   To Insert Features Using Insert Mode................................................. 133
Feature Menus .......................................................................................... 134
   To Set the Default Pull Direction ......................................................... 134
Silhouettte Curves .................................................................................... 135
Draft Curves and Parting Curves ............................................................. 138
Tangent Draft .......................................................................................... 141
Creating an Offset ................................................................................... 155
RefPart Cutout ....................................................................................... 156
Trim to Geom ....................................................................................... 157
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Runners</td>
<td>159</td>
</tr>
<tr>
<td>User-Defined Features</td>
<td>162</td>
</tr>
<tr>
<td>Working in the Mold/Cast Part Application</td>
<td>164</td>
</tr>
<tr>
<td>Waterlines</td>
<td>165</td>
</tr>
<tr>
<td>About Water Lines</td>
<td>165</td>
</tr>
<tr>
<td>To Create Water Lines</td>
<td>165</td>
</tr>
<tr>
<td>To Check Waterline Circuits</td>
<td>165</td>
</tr>
<tr>
<td>The Mold or Die Opening Process</td>
<td>166</td>
</tr>
<tr>
<td>About the Mold or Die Opening Process</td>
<td>166</td>
</tr>
<tr>
<td>To Define a Mold or Die Opening Sequence</td>
<td>166</td>
</tr>
<tr>
<td>Example: Defining a Move</td>
<td>167</td>
</tr>
<tr>
<td>The MOLD/CAST OPEN Menus</td>
<td>167</td>
</tr>
<tr>
<td>Rules for Defining a Move</td>
<td>167</td>
</tr>
<tr>
<td>To Check for Interference</td>
<td>167</td>
</tr>
<tr>
<td>To Display Exploded Geometry</td>
<td>168</td>
</tr>
<tr>
<td>Example: Simulating a Mold Opening</td>
<td>168</td>
</tr>
<tr>
<td>Working in the Mold Layout Assembly Application</td>
<td>168</td>
</tr>
<tr>
<td>Mold Layout</td>
<td>168</td>
</tr>
<tr>
<td>Cavity Layout</td>
<td>172</td>
</tr>
<tr>
<td>Mold Bases</td>
<td>181</td>
</tr>
<tr>
<td>Injection Molding Machines (IMMs)</td>
<td>183</td>
</tr>
<tr>
<td>About Injection Molding Machines (IMMs)</td>
<td>183</td>
</tr>
<tr>
<td>Example: Customizing an IMM</td>
<td>184</td>
</tr>
<tr>
<td>To Assemble an Injection Molding Machine (IMM)</td>
<td>184</td>
</tr>
<tr>
<td>To Customize an Injection Molding Machine (IMM)</td>
<td>184</td>
</tr>
<tr>
<td>To Set Up IMM Filters for Complex Machine Searches</td>
<td>185</td>
</tr>
<tr>
<td>To Replace an Injection Molding Machine</td>
<td>185</td>
</tr>
<tr>
<td>Number Parameters</td>
<td>185</td>
</tr>
<tr>
<td>Parameter Text File</td>
<td>186</td>
</tr>
<tr>
<td>Catalogs</td>
<td>186</td>
</tr>
<tr>
<td>About Catalogs</td>
<td>186</td>
</tr>
</tbody>
</table>
Table Of Contents

To Create a New Component Catalog .......................................................... 187
To Set the Index File .............................................................................. 187
The Mold Catalog Engine ...................................................................... 187
Creating the Template Part ..................................................................... 188
Creating the Layout .............................................................................. 190
Using the Component Catalog .............................................................. 203
Customizing the Catalog ....................................................................... 206
Glossary .................................................................................................. 207
Glossary of Terms .................................................................................. 207
Index ......................................................................................................... 213
Pro/MOLDESIGN and Pro/CASTING

Using Moldesign and Casting

What You Can Do with Pro/MOLDESIGN and Pro/CASTING
Pro/Moldesign is an optional module for Pro/ENGINEER that provides the tools to simulate the mold design process within Pro/ENGINEER. This module lets you create, modify, and analyze the mold components and assemblies, and quickly update them to the changes in the design model.

Pro/CASTING provides tools to design die assemblies and components and prepare castings for manufacturing.

Pro/MOLDESIGN and Pro/CASTING, together with Pro/ENGINEER Foundation, provide tools to do the following:

Design Part Creation and Modification
- Create models in Pro/ENGINEER including features requiring Pro/SURFACE
- Import and repair geometry if necessary
  The import functionality can be used with the following: See Data Doctor Option and Interface for Pro/ENGINEER
- Analyze if a design part is moldable, using Draft Check and Thickness Check capabilities
- Automatically create parting lines and detect undercuts using Silhouette Curve functionality
- Fix problem areas by creating draft, rounds, and other features as needed

Cavity Creation
- Assemble and orient design model dynamically while checking draft and projected area
- Apply a shrinkage that corresponds to design part material, geometry, and molding conditions
- Automatically create the workpiece stock from which core, cavity, and inserts will be split
- Create parting geometry, including sliders, inserts, automatic parting lines, and automatic parting surfaces
- Automatically split the workpiece to create cores, cavity, and inserts as solid models
- For casting, create and assemble sand cores
Mold Layout Creation

- Create top level mold assembly
- Placement and patterning of mold cavities to allow multi-cavity molding
- Online selection and automatic assembly of standard mold bases
- Modification of mold base plates to allow for assembly of mold cavity
- Online selection and automatic assembly of ejector pins and other Mold Catalog items
- Automated creation of runners
- Automated creation of waterlines, including 3-D waterline interference checks
- Define and simulate mold opening and check for interference between mold components

Drawing Creation

- Create complete production drawings, including dimensions, tolerances, automatic bill of materials (BOMs) with or without balloon notes
- Use of drawing templates

To Perform a Typical Pro/MOLDESIGN Session

The Pro/MOLDESIGN process may consist of the following steps:

1. Create a mold model. Assemble or create reference models and workpieces.
   
   Or
   
   Retrieve a mold model.

2. Perform a draft check on the reference model to determine if it has sufficient draft to be ejected from the mold cleanly. Define additional draft features in the design model or reference model as required.

3. Create shrinkage for your mold model. You can create isotropic scale shrinkage or shrink coefficients for some or all dimensions. You can apply shrinkage by dimension to your design model to leave the design model unchanged for use in other applications.

4. Define volumes or parting surfaces to split the workpiece into separate components.

5. Extract mold volumes to produce mold components. Once extracted, the mold components are fully functional Pro/ENGINEER parts, which you can bring up in Part mode, use in Drawings, machine with Pro/NC, and so on.

6. Add gates, runners, and waterlines as mold features. They will be considered when creating the molded part, as well as for interference checking during the mold opening process.
7. Fill the mold cavity to create the molding. The system creates the molding automatically by determining the volume remaining in the workpiece after subtracting the extracts.

8. Define steps for mold opening. Check interference with static parts for each step. Modify mold components if necessary.


10. Estimate the preliminary size of the mold and select an appropriate mold base.

11. Assemble mold base components, if desired. The mold base components are the mold base parts (for example, top clamping plate, support plate, ejectors, and so on). The system displays them along with the mold model, and they are useful for visualizing the process of mold opening. With the optional module Pro/LIBRARY and the optional MOLD BASE library, you can view and assemble many standard mold fixtures.

12. Complete the detailed design, which includes laying out the ejection system, waterlines, and drawing.

13. Bring the mold components into Pro/NC for machining.

During the molding process, changes to the design model may occur. When these changes are made to the design model, they will propagate throughout all aspects of the design to engineering drawings, finite element models, assembly models, and molding information. Because the mold design engineer references the parametric design model directly, changes are reflected throughout all the intermediate process steps and captured in the molding model.

**More about Pro/MOLDESIGN**

Pro/MOLDESIGN lets you create extract components that you can then use to create mold details during actual mold production. After creating a mold model, you can use these extracted mold components with Pro/NC to create CNC toolpaths.

You can create final extract components that reflect the geometry of the design model along with shrinkage considerations, adequate drafting, ejector pinholes, runners, and cooling systems.

You can also verify that the components do not interfere with each other during the mold opening process. You can also perform different tests to check validation of your design: draft check, thickness check, projection area check, waterline clearance check, and components interference check.
Typical Mold Design Workflow

Pro/MOLDESIGN

Part Design

Mold Assembly Design
- add ref. models
- add workpieces

Apply Shrinkage

Analyze Ref. Parts for Draft, Thickness

Does part need additional draft, thicker, thinner, sections for moldability?

Change design model or add mold features to reference parts.

NO

Define Parting Surfaces and/or Volumes

Start Assembly Production Drawings
To Perform a Typical Pro/CASTING Session

A typical Pro/CASTING session may include the following steps:

1. Create or retrieve a cast model. To create a new cast model, you must first create a design model representing the part to be manufactured. This design model must then be added or created as part of the cast model. When the design model is added to the cast model, it is replaced by a reference model (a copy of the same model).

2. Determine the optimal pull direction (the direction in which the die opens with the minimum amount of draft) for the reference model. You can determine the optimal pull direction by performing a draft check on the reference model that uses a datum plane, edge, axis, curve, or coordinate system as a reference for determining pull direction.

3. Determine regions that require additional draft.

4. Add or create a die block as part of the cast model.

5. Create a silhouette curve on the reference model. The silhouette curve is a Cast feature that is used to determine the location of the parting surface on the reference model.

6. Create a parting surface on the reference model.

7. Add draft and rounds to the reference model surfaces as required. When adding tangent draft to model surfaces, you must first create draft lines.

8. Set up the shrinkage of your reference model. You can set up isotropic or anisotropic shrinkage for the whole model; you can also specify shrink coefficients for individual dimensions.

9. Fill any holes that are machined in the reference model.

10. Design sand cores and core prints are required to create cavities within the cast result.

11. Add gates, runners, and sprue to the cast model. These are added as assembly features, and are considered by the system when it creates the cast result, as well when it evaluates the die opening process.

12. Split the die block into separate die volumes along the parting surface.

13. Extract die volumes from the die block to produce die components. Once extracted, the die components are fully functional Pro/ENGINEER parts. For example, they can be brought up in Part mode, used in drawings, or machined with Pro/NC.

14. Define steps for the die opening sequence. Check interference with static parts for each step. Modify the cast model if necessary.

15. Fill the die cavity to create the cast result. The cast result is created automatically by merging the volume of the die block cavity with the gates and runners present in the model.
16. Check the wall thickness and shape of the cast result. Modify the cast model if necessary.

17. After the Pro/CASTING session is over, you can bring the die components into Manufacturing mode for machining.

During the casting process, changes to the design model may occur. Any changes to the design model are propagated throughout all aspects of the design to engineering drawings, finite element models, assembly models, sand core models, and casting information.

**More about Pro/CASTING**

The basic casting process involves pouring molten metal into a die block containing a cavity resembling the part to be manufactured. Using Pro/ENGINEER in combination with Pro/CASTING, this process can be modeled successfully to produce castings that are free from defects and meet all design specifications.

When emulating the casting process using Pro/CASTING, all operations are performed on the cast model. The cast model is an assembly consisting of the design model, die block, fixtures, sand core, and cast result.

The design model, die block, and sand core are the basic elements of the cast model assembly. The design model is the original part created in Pro/ENGINEER that is to represent a portion of the final cast result. When added to the cast model, a reference model replaces the design model. The die block is a Pro/ENGINEER part created to represent the overall volume of the closed die.

You can check the reference model to verify that its surfaces have been drafted sufficiently to allow it to be removed from the die cleanly. If additional draft is required, Pro/CASTING provides tools to add draft to its surfaces.

Pro/CASTING allows you to break the die block into separate die components and analyze the die opening sequence. It does this by providing the tools to impress the design model geometry upon the die block, and then separate the die block by user-defined die volumes and parting surfaces.

**Example: Simulating the Opening of a Die**

1. Sand core
2. Die blocks
3. Cast result

**Example: Emulating the Casting Process**

The following figure summarizes the casting process.

![Casting Process Diagram](image)

**Configuring for Moldesign and Casting**

**About Configuration File Options**

You can preset environment options and other global settings by entering the settings you want in a configuration file. To set configuration file options use the **Options** dialog box (**Tools > Options**).

This help module contains a list of configuration options specific to Moldesign and Casting, in alphabetical order, showing for each option or group of related options:
To Set Moldesign and Casting Configuration Options

1. Click **Tools > Options**. The **Options** dialog box opens.
2. Click the **Show only options loaded from file** check box to see currently loaded configuration options or clear this check box to see all configuration options.
3. Select the configuration option from the list or type the configuration option name in the **Option** box.
4. In the **Value** box type or select a value.
   
   **Note:** The default value is followed by an asterisk (*).
5. Click **Add/Change**. The configuration option and its value appear in the list. A green status icon confirms the change.
6. Click **Apply** or **OK**.
   
   **Note:** It is recommended that you set the Moldesign and Casting configuration options before starting a new Moldesign or Casting project.

**accuracy_lower_bound**

<value> *(between 1.0e-6 and 1.0e-4)*

Enter an accuracy value to override the default lower limit of 0.0001. The upper limit is fixed at 0.01.

When working in Moldesign or Casting, it is recommended that you set this option to a very small number, such as 0.0000001.

**default_abs_accuracy**

<value>

Defines the default absolute part or assembly accuracy.

When working in Moldesign or Casting, it is recommended that you use this option only if your company uses the same standard accuracy for all models. Otherwise, do not set this option. Designate the smallest reference model as the base model and assign its accuracy to other models in the Mold or Cast assembly.

**allow_shrink_dim_before**

yes, no
Determines whether Calculation Order options are visible in the Shrinkage By Dimension dialog box or not. Calculation order is the order that determines if shrinkage is to be applied after evaluating the relations set up for dimensions or before evaluating these relations.

**default_mold_base_vendor**

*futaba_mm, dme, hasco, dme_mm, hasco_mm*

Default value for Mold Base vendor is *futaba_mm*.

**default_shrink_formula**

*simple, ASME*

Determines the shrinkage formula to be used by default.

- **simple**—Sets \((1+S)\) as the shrinkage formula to be used by default.
- **ASME**—Sets \(1/(1-S)\) as the shrinkage formula to be used by default.

**enable_absolute_accuracy**

*yes, no*

Generally, if set to *yes*, enables you to switch from relative to absolute accuracy for a part or assembly.

In Moldesign and Casting, additionally, setting this option to *yes* helps you maintain uniform accuracy for the reference model, the workpiece (dieblock), and the mold or cast assembly. At the time you add the first reference model to the mold or cast assembly, the system will inform you if a discrepancy exists between the assembly model accuracy and the reference model accuracy. You can then accept or reject setting the assembly model accuracy to equal the reference model accuracy. If you create the workpiece or dieblock in Mold or Cast mode, its accuracy is automatically the same as the accuracy of the assembly model.

It is strongly recommended that you set this option to *yes* when working in Moldesign or Casting.

**mold_layout_origin_name**

*<name>*

Sets a specified coordinate system as the default for the cavity layout origin.

**mold_vol_surf_no_auto_rollback**

*yes, no*

This option affects feature rollback when modifying a parting surface or mold volume:

- **no**—The parting surface or mold volume is rolled back on modification.
The parting surface or mold volume is not automatically rolled back on modification, however, the you are prompted to rollback or not. This option takes effect at the time of creation of a specific parting surface or mold volume.

**pro_catalog_dir**

*<directory name>*

Sets the path to the catalog directory where the catalog menu and the names of other catalog files, such as ejector pins are located. Use the full path name.

**pro_cav_lay_rule_dir**

*<directory name>*

Sets the default directory for cavity layout rules. Use the full path name.

**save_instance_accelerator**

*none, explicit, always*

Used with family tables of solid parts to determine how instances are saved.

- **none**—Instance accelerator files are not used.
- **explicit**—Save instance accelerator files only when instances are explicitly saved.
- **always**—Always save instance accelerator files (whether you are saving an instance explicitly or you are saving it through a higher-level object).

You can override this configuration option at run time by clicking **File > Instance Operations**, and then clicking another option on the associated **INST DBMS** menu.

If you use family tables to handle symmetric components in multi-part molding, it is recommended that you set this option to **always**, to be able to retrieve workpiece instances without having to retrieve the mold model first.

**show_all_mold_layout_buttons**

*no, yes*

Controls the Mold Layout toolbar and menu configuration for users who have an EMX licence. By default, if EMX license is detected, the Mold Layout toolbar and menus display only functionality that is not duplicated by EMX, to avoid confusion. If you want to see all the Mold Toolbar icons and menu options, set this configuration option to **yes**.

**shrinkage_value_display**

*final_value, percent_shrink*

Determines how dimensions are displayed when shrinkage is applied to a model.

If it is set to **percent_shrink**, the dimension text is displayed in the following form:

nom_value (shr%)
If it is set to `final_value`, the dimension simply shows the shrunk value. For example, if the nominal dimension is 10 and shrinkage equals 1%, the dimension will be displayed as follows:

- `10 (1%)` — if set to `percent_shrink`
- `10.1` — if set to `final_value`

### template_mfgcast

<table>
<thead>
<tr>
<th><code>inlbs_mfg_cast.mfg</code>, empty, <code>&lt;file name&gt;</code></th>
</tr>
</thead>
</table>

Specifies the file name of the default cast manufacturing model template. After you set this option, it takes effect immediately in the current session of Pro/ENGINEER. When set to `empty`, no template is used.

### template_mfgmold

<table>
<thead>
<tr>
<th><code>inlbs_mfg_mold.mfg</code>, empty, <code>&lt;file name&gt;</code></th>
</tr>
</thead>
</table>

Specifies the file name of default mold manufacturing model template. After you set this option, it takes effect immediately in the current session of Pro/ENGINEER. When set to `empty`, no template is used.

### Working in Mold or Cast Mode

#### About the Mold or Cast Model Structure

The mold or cast model is the model you work on while in Mold (Cast) Cavity Design mode. The mold (cast) model is an assembly that usually consists of one or more reference models that can represent the following:

- Molded parts
- One or more workpieces (die blocks) that represent overall size of cavity inserts
- Several mold (die) components that represent cavity inserts
- One molding (cast result) component that represents a product of the molding or die process
- Mold base components (fixtures) that represent those components that do not form the shape of a molded part

The Cast model can also contain one or more sand cores. Workpieces (die blocks) and mold base components (fixtures) can be parts or subassemblies. Reference models, sand cores, mold and die components are usually parts. You can assemble general subassemblies into Mold (Cast) models as well. Their components are classified as workpieces (die blocks) or mold base components (fixtures).

Mold models usually contain one or more parting surfaces (quilts) that are needed for splitting core and cavity. Mold or Cast models can contain one or several volumes
Pro/MOLDESIGN and Pro/CASTING

(closed quilts) that define a geometry of mold or die components. In addition, Mold or Cast models can contain an unlimited number of regular Pro/Engineer features as well as Mold or Cast specific features such as **Tangent Draft, Silhouette Curve, RefPart CutOut, Trim To Comp, Runner, Waterline**, and others.

You perform most mold and cast operations by retrieving the `.mfg` file in Mold or Cast mode. You can also use the Mold/Cast application in Part mode and the Mold Layout application in Assembly mode.

**Example: Mold or Cast Model**

![Mold or Cast Model Diagram](image)

1. Workpiece for molds or Die block for casts
2. Reference model

**To Create a New Mold or Cast Model**

1. Click **File > New**. The **New** dialog box opens.

2. Under **Type**, select **Manufacturing**.

3. Under **Sub-type**, select **Mold Cavity (Cast Cavity)**.

4. Specify the name of the new `.mfg` file you are creating and click **OK**. A new Pro/ENGINEER window opens and displays the **MOLD (CAST)** menu and the Mold Cavity toolbar, as well as the Model Tree for the model.

**Creating New Mold or Cast Models**

In order to start designing ejection mold or cast tooling, you create a new Mold or Cast model. While creating this model Pro/ENGINEER creates an empty Assembly model file (name.asm) and Manufacturing (name.mfg) file. Both the files are needed for working in Mold or Cast mode. Use template models to create new Mold or Cast
models with predefined settings (such as views, layers, datums, parameters, and so on).

The Cavity Design Toolbar
The Cavity Design toolbar appears in the Mold Cavity or the Cast Cavity mode. You can click and drag the toolbar, that is displayed in a vertical position when you open the Cavity Design mode, to place it horizontally.

Click the icons, as shown here from left to right, to open the following menus and perform the following operations:

- Define Reference Part layout—Opens the **CAV LAYOUT** menu.
  
  Define part placement and orientation in the mold.

- Apply shrinkage—Opens the **SHRINKAGE** menu.
  
  Select shrinkage by dimension or by scaling and apply shrinkage to the part.

- Create a Workpiece—Opens the **Automatic Workpiece** dialog box.
  
  Create a workpiece based on offsets from molded part, or based on its overall dimensions, or both.

  Two options are available in the Mold Volume/Mold Component icon expanded menu:
  
  - Perform operations with Mold Volumes—Opens the **MOLD VOLUME** dialog box.
    
    Add a cavity insert as a mold volume, or edit a mold volume, or do both.

  - Perform operations with Mold Components—Opens the **Component Create** dialog box.
    
    Add a cavity insert as a mold component, or edit a mold component, or do both.

- Create parting line—Opens the **SILHOUETTE CURVE** dialog box.
  
  Define a silhouette curve that will be used in creating a parting line for a Skirt parting surface.

  Two options are available in the Skirt icon expanded menu:
  
  - Create Skirt—Opens the **Skirt Surface** dialog box.
    
    Create an automatic parting surface using Skirt feature.

  - Create a parting surface—Opens the **MOLD>SURF DEFINE** menu.
    
    Perform parting surface operations using general surfacing tools.
Two options are available in the Split icon expanded menu.

- **Split volume**—Opens the **SPLIT VOLUME** menu.
  
  Split the workpiece, mold volume, or selected components into one or two volumes.

- **Split part consuming its geometry**—Opens the **Solid Split Options** dialog box.
  
  Split the selected part retaining accessibility to the solid geometry of the original part.

- **Create cavity insert parts from mold volumes**—Opens the **Create Mold Component** dialog box.
  
  Create mold components by extracting mold volumes.

- **Perform mold opening analysis**—Opens the **MOLD OPEN** dialog box.
  
  Define the steps for opening of the mold and performing a draft check.

- **Trim part by surface**—Opens the **MOLD>MOLD MDL TYP** menu.
  
  Trim part where it intersects with the first or last selected surface of another part, quilt, or plane.

- **Go to Mold Layout**—Opens the **New** model dialog box, so that you can create or modify a Mold Layout assembly in Mold Layout mode.
  
  - If the Mold Layout assembly already exists, the window switches to the assembly model.
  
  - If the corresponding Mold Layout assembly does not exist, the system prompts you to confirm its creation.

### MOLD and CAST Menu Selections

The following commands appear in the MOLD menu or CAST menu:

- **Mold Model**—Add, remove, and manipulate mold assembly components.
- **Cast Model**—Add, remove, and manipulate cast assembly components.
- **Feature**—Create, remove, and manipulate assembly level and components level features.
- **Shrinkage**—Specify shrinkage for the reference model.
- **Parting Surf**—Add, remove or change parting surfaces for the mold.
- **Mold Volume**—Add, remove, or change mold volume.
- **Die Volume**—Add, remove, or change die volume.
- **Mold Comp**—Extract or erase mold component.
Die Comp—Extract or erase die component.

Mold Opening—Specify steps for mold opening and check for interference.

Die Opening—Specify steps for die opening and check for interference.

Molding—Create or remove the molded part.

Mold Layout—Create or open a mold layout.

Integrate—Compare two different versions of the same model and, if necessary, integrate the differences.

**MOLD MODEL and CAST MODEL Menus**

The functions listed here are similar to those available in Assembly mode.

If you select Mold Model or Cast Model from the MOLD or CAST menus, respectively, the MOLD MODEL or CAST MODEL menu appears with the following commands for working with components of the mold or cast assembly:

- **Assemble**—Add an existing model to the current mold or cast assembly.
- **Create**—Create a new component directly in the current mold or cast assembly.
- **Locate RefPart**—Add, remove, or change a layout (flat pattern) of reference parts.
- **Catalog**—Add, remove, or change a set of standard components.
- **Delete**—Remove a component from the current assembly.
- **Suppress**—Temporarily remove a component from the current assembly.
- **Resume**—Restore a previously suppressed component.
- **Redefine**—Redefine a selected component placement.
- **Reroute**—Reselect component references.
- **Reorder**—Reorder the sequence of component regeneration.
- **Insert Mode**—Enter Insert mode.
- **Pattern**—Create a pattern of a selected component.
- **Del Pattern**—Remove a pattern of components.
- **Simplfd Rep**—Work with a simplified representation of the assembly.
- **Reclassify**—Change component classification.
- **Adv Utils**—Display the ADV COMP UTL menu, from which you can copy components, merge material of one set of parts to or from another set of parts, and cut out material of one set of parts from another set of parts.
- **Done/Return**—Return to the MOLD (CAST) menu.
When you select **Assemble**, **Create**, or **Delete**, the **MOLD MDL TYP** or **CAST MDL TYP** menu appears with a list of those component types that are allowed for selected operation.

**To Enter Mold or Cast Mode with an Existing Model**

1. Click **File > Open**. The **Open** dialog box opens.
2. Select the Mold or Cast Manufacturing model file (**name.mfg**) that you want to edit.
3. Click **Open**.

**Mold or Cast Model Files**

A mold or cast model includes the following files:

- **Mold or cast assembly file—****modelname.asm**—The mold or cast assembly is created automatically when the mold or cast model is created. Typically, the assembly consists of the reference model(s), workpiece(s) or die block(s), and other components (parts and subassemblies) that are usually classified according to their purpose in the mold or cast. Typically, the assembly contains parting surface(s), volume(s), and Mold/Cast specific and general Pro/Engineer features. You can retrieve and modify the mold or cast assembly in Assembly mode if you open this assembly file.

- **Mold or cast process file—****modelname.mfg**—The process file contains pertinent mold or cast information. You can retrieve and modify the mold or cast assembly in Mold or Cast mode if open corresponding process file. When you open an existing model, the system opens a window containing the .mfg file and also displays the MOLD or CAST menu and the Model Tree for the model.

- **Design model file—****filename.prt**—The design part file.

- **Other model files—****name.prt or name.asm**—The part or assembly files that Pro/ENGINEER creates for parts and subassemblies that are components of mold or cast assembly.

**Working with Mold or Cast Files**

A mold or die model consists of several files.

When a model is stored, the new versions of ".mfg" and ".asm" files are written to disk whether or not any changes to the mold model have been made:

- **Mold or die assembly—****name.asm**
- **Mold or die design file—****name.mfg**

The appropriate part files are saved only if they have been changed:

- **Design model(s)—****filename.prt**
- **Reference model(s)—****filename.prt**
Workpiece or die block—*filename*.prt

In addition to these required files, optional files can be created:

- Extracted component(s)—*filename*.prt
- Molding or casting—*filename*.prt

When you create a new model or open an existing one, the files are listed in the Model Tree.

When using **File** menu commands, note the following:

- **Save As**—Copies the ".mfg" and the ".asm" files. You can specify if you want to create copies of the part files (the same as when copying an assembly). You can specify the new names for the parts; the assembly has the same name as the new mold model.

- **Rename**—Renames the ".mfg" and ".asm" files. To rename a ".mfg" file and its ".asm" file:
  a. Retrieve the mold or cast model (the ".mfg" file) into session.
  b. Rename the.mfg file.
  c. Rename the .asm file.
  d. Save the .mfg file to disk.

- **Erase**—Presents you with the list of objects to be erased (same as in Assembly mode). Because of the way Pro/MOLDESIGN and Pro/CASTING information is stored, however, you have to select both the workpiece or die block and the assembly in order to remove any mold or die volumes created in this session. If any components have been extracted, you must select them as well; otherwise, the volume information is not erased.

---

**To Create Ordinate Dimensions Automatically**

1. Create a drawing of the part for which you want to create ordinate dimensions automatically.

2. In the drawing window, click **Insert > Dimension > Auto Ordinate**. You are prompted to select one or more surfaces.

3. Select one or more surfaces for which you want to create ordinate dimensions. The **AUTO ORDINATE** menu appears.

   **Note:** You must select surfaces belonging to the same view of the drawing.

4. Click **Select Base Line**.

5. In the same view from which you selected the surface or surfaces, select a reference line (edge, curve, or datum plane) to create the ordinate dimensions. The ordinate dimensions are created automatically and are displayed in that view.
Design Models

About Design Models
The Mold or Cast design model usually represents the product designer’s vision of his final product. Typically, the design part geometry contains all necessary design elements that are required for the functioning product, but does not contain the elements that molding or casting technology requires. Usually, the design part is not shrunk, it does not contain all needed drafts and fillets, but it may contain geometry elements that require post-molding or post-casting machining.

The design part geometry is a source for Mold or Cast reference part geometry. The relationship between the design part and reference part depends on the method used to create the reference part.

While assembling a reference part, you can inherit all geometry and feature information from the design part to the reference part. Inheritance allows a one-way associative propagation of geometry and feature data from a design part to a reference part. An inheritance feature begins with its geometry and data identical to the part from which it is derived. You can identify the geometry and feature data that you want to modify on the inherited feature, without changing the original part. Inheritance provides greater freedom to modify the reference part without changing the design part.

You can also copy (merge by reference) design part geometry into the reference part. In this case, only the geometry and layers are copied from the design part. You can apply shrinkage to the reference part, create a draft, round, and other features - all these changes do not affect the design model. However, all changes in the design model are automatically reflected in the reference part.

As an alternative, you can designate a design part to be a Mold or Cast reference part. In this case, they are the same models.

In all cases, using the geometry of a reference model while working in Mold or Cast sets up a parametric relationship between the design model and the mold or cast components. Because of this relationship, when the design model is changed, any associated mold or cast components are updated to reflect the change.
Example: Design Model for Casting

To Create a Mold Assembly with Multiple Design Models
1. Create or retrieve a mold model.
2. Click **MOLD > Mold Model > Assemble > Ref Model**.
3. Select the name of the design model in the browser window. Pro/ENGINEER retrieves the design model.
4. Assemble the new design model using **Component Placement** dialog box.
5. At the prompt, enter the name of the new reference model. Each additional design model creates a new reference model in the mold assembly.
6. Repeat Steps 2 through 5 to assemble additional design models, or use the **Pattern** command.
7. Regenerate the assembly and the workpiece to update the mold cavity.

Shrinkage

About Applying Shrinkage
You must consider the shrinkage of the material and proportionally increase dimensions of the reference model before you start molding the reference model. You can apply shrinkage to the reference model in Mold (Cast) mode and depending on the method of applying shrinkage, it may propagate to the design model. You can also apply shrinkage to the design model or reference model in Part mode.

The two methods of applying shrinkage are:
• **By Dimension**—Allows you to set up one shrink coefficient for all model dimensions, and specify shrink coefficients for individual dimensions. You can choose to apply shrinkage to the design model.

• **By Scaling**—Allows you to shrink the part geometry by scaling it with respect to a coordinate system. You can specify different shrinkage ratio for the X-, Y-, and Z-coordinates. If you apply shrinkage in Mold (Cast) mode, it applies only to the reference model and does not affect the design model.

Pro/ENGINEER uses two formulae to calculate shrinkage. The formula \( \frac{1}{1-S} \) allows you to specify a shrinkage factor that is based upon the final geometry of the reference part once shrinkage is applied. The formula \( 1+S \) uses a pre-calculated shrinkage factor that is based upon the original geometry of the part.

To view information on shrinkage applied to the part, click *Shrink Info* on the **SHRINKAGE** menu or click *Info > Mold* and select *Shrinkage* on the **MOLD INF** dialog box.

**To Specify a Shrinkage Formula**

1. Click **MOLD (CAST) > Shrinkage**. The **SHRINKAGE** menu appears.  
   
   **Note:** If you are in the part mode, click *Edit > Setup*. The **PART SETUP** menu appears. Click *Shrinkage*. The **SHRINKAGE** menu appears.

2. Click **By Dimension** or **By Scaling**. Alternatively, you can click \[ x \] or \[ y \] on the toolbar. The **Shrinkage by Dimension** or **Shrinkage by Scale** dialog boxes open, respectively.

3. Under **Formula**, select **1+S** or **1/(1-S)** to calculate the shrinkage ratio.
   
   - **1+S**—Specifies a pre calculated shrinkage ratio based on the original geometry of the part. This is the default.
   - **1/(1-S)**—Specifies a shrinkage ratio based on the resulting geometry of the part, after shrinkage is applied.

**Selecting the Shrinkage Formula**

You can specify a shrinkage ratio that is based upon the final geometry of the reference part once shrinkage is applied, or a pre-calculated shrinkage ratio that is based upon the original geometry of the part.

Pro/ENGINEER uses two formulae to apply shrinkage (S stands for the shrinkage ratio):

- **1 + S**—The shrinkage ratio is based upon the original geometry of the model. This is set as the default.
- **1/(1-S)**—The shrinkage ratio is based upon the resulting geometry of the model.

If shrinkage is specified, a modification of the formula causes all the dimension values or scale values to be updated. For example, if shrinkage by dimension has
been defined with the initial formula \((1 + S)\), and if you change the formula to \(\frac{1}{1-S}\), the model regenerates from the first affected feature, if the shrinkage is applied by dimension, or from the shrinkage by scale feature, if appropriate.

**To Apply Shrinkage by Dimension**

1. Click MOLD (CAST) > Shrinkage in Mold (Cast) mode. The SHRINKAGE menu appears.

   **Note:** If you are in the part mode, click Edit > Setup. The PART SETUP menu appears. Click Shrinkage. The SHRINKAGE menu appears.

2. Click **By Dimension**. The Shrinkage By Dimension dialog box opens.

   Alternatively, you can click [Shrinkage By Dimension] on the toolbar to access the Shrinkage By Dimension dialog box directly.

   **Note:** To view the options available under **Calculation Order** on the Shrinkage By Dimension dialog box, ensure that the configuration option allow_shrink_dim_before is set to yes.

3. Under **Formula**, click \((1+S)\) or \(\frac{1}{1-S}\) to specify the formula that you want to use to calculate shrinkage.

4. Clear the **Change Dimensions of Design Part** check box if you do not want shrinkage to be applied to the design part.

5. Under **Calculation Order**, select one of the following to determine the order in which shrinkage is applied:

   - **After Relations**—Applies shrinkage after evaluating the relations set on dimensions. This is the default. If the relations depend on parameters or reference dimensions, Pro/ENGINEER warns you that shrinkage may not be applied correctly after the relations are evaluated.
   - **Before Relations**—Applies shrinkage before evaluating the relations set on dimensions.

6. Under **Shrinkage Ratio**, click any of the following to insert dimensions to the table.

   - Select a dimension in the part on which shrinkage is being applied. The selected dimension is inserted as a new row in the table. In the ratio column, specify a shrink ratio, \(S\), for the dimension or in the final Value column, specify a value that you want the shrunk dimension to have.

   - Select a feature in the part on which shrinkage is being applied. All the dimensions of the selected feature are inserted as separate rows in the table. In the ratio column, specify a shrink ratio, \(S\), for the dimension or in the final Value column, specify a value that you want the shrunk dimension to have.
Switches the display of dimensions between their numeric values and symbolic names.

**Note:** To apply an overall shrinkage to the part, specify a shrink ratio against *All Dimensions*. The shrink ratio you specify is applied to all the dimensions of the part.

7. If required, click to add a new row to the table or to delete a row from the table.

8. To remove shrinkage, click **Clear** on the **Shrinkage By Dimension** dialog box. The **CLEAR SHRINK** menu appears and lists all the dimensions on which shrinkage is applied.

9. Click the appropriate check box to clear the shrinkage applied to that dimension. The following are also available.

   - **Select All**—Selects all the dimensions on which shrinkage is applied.
   - **Unsel All**—Clears the selection of all the dimensions on which shrinkage is applied.
   - **Done Sel**—Completes the selection of dimensions for which you want to clear shrinkage.
   - **Quit Sel**—Discards the selection of dimensions for which you want to clear shrinkage.

10. Click to apply shrinkage by dimension to the part.

    **Note:** To remove the shrinkage feature, right-click the shrinkage feature created in the model tree. A shortcut menu appears. Click **Delete**. The shrinkage feature is removed from the part.

11. If required, in the **Shrinkage By Dimension** dialog box, click **Feature > Info** to obtain information about the shrinkage applied or **Feature > References** to obtain information about the references used by the part.

### Applying Shrinkage by Dimension

When specifying shrinkage values, keep in mind:

- Entering a negative shrink ratio shrinks the dimension, while a positive shrink ratio expands it.

- Shrinkage by dimension values are *not* cumulative. For example, if you specify 1.5 as overall shrinkage factor for a cube 10x10x10, and then specify 2.0 for one of the sides, the distance along the side is 20, not 30. Individual shrinkage values for dimensions always supersede the overall model shrink value.

- The configuration file option **shrinkage_value_display** determines how dimensions are displayed when shrinkage is applied to a model. The two options are:
By default, whenever a part has shrinkage information associated with it, the nominal dimension values are displayed followed by the shrinkage value in parentheses. In this case, shrinkage is represented as percentage of the nominal dimension. You can also display the final value of the shrunk dimensions by changing the value of the configuration file option `shrinkage_value_display` to `final_value`.

- If the part is shrunk, dimensions appear in magenta; if the part is not currently shrunk, dimensions remain displayed in yellow.

**Notes:**

- If you want shrunk dimensions to be displayed as their final values, you must specify the configuration file option in the drawing setup file.

- The shrinkage percent value is displayed for information purposes only; you cannot change the value by selecting it.

- You should not specify overall dimension shrinkage for a model if the model contains external references or imported data.

- For multi-model molds or castings, when dimension shrinkage is applied to a specific reference model, all merged reference models in the current mold or cast model that are based on the same design model are shrunk. The other reference models in the mold or cast model remain unaffected. On the other hand, if you have several reference models inherited from a design model, they are shrunk independently.

- Shrinkage by dimensions affects only features created or reordered prior to the shrinkage feature.

- You can suppress or delete Shrinkage features. The shrinkage value then disappears.

**Example: Applying Shrinkage by Dimension**

1. -.2 entered for shrinkage. The dimension decreases by 20%.

2. .2 entered for shrinkage. The dimension increases by 20%.
Tip: Shrinkage and UDFs
If a feature that is included in a UDF has dimensions which have had shrinkage applied to them, the feature is stored in its unshrunk state. If a destination part, in which a UDF has been placed, has been shrunk using All Dimensions, new dimensions for the group are shrunk with the shrinkage factor of the part.

Tip: Resolving Relations When Applying Shrinkage
By default, relations are computed based upon dimensions that are not shrunk. If relations are driven by parameters generated by evaluate features or by reference dimensions, the right hand side of the relation depends on the size of the geometry that is regenerated with the shrunk dimensions. Such relations are computed based on shrunk dimensions.

You have an option to compute relations based upon shrunk dimensions. To do this you should first set the configuration option allow_shrink_dim_before to yes (the default value for the configuration option is no). This will make visible the Calculation Order pane on the Shrinkage By Dimension dialog box. Selecting Before Relations on this pane will lead to computing dimensions based upon shrunk dimensions.

Table-driven dimension values behave the same as relation-driven dimension values. Table-driven dimensions are shrunk after or before propagation through the family table, depending on your selection of After Relations or Before Relations under the Calculation Order in the Shrinkage By Dimension dialog box.

To Apply Shrinkage by Scaling
1. Click MOLD (CAST) > Shrinkage in Mold (Cast) mode. The SHRINKAGE menu appears.
   
   Note: If you are in the part mode, click Edit > Setup. The PART SETUP menu appears. Click Shrinkage. The SHRINKAGE menu appears.

2. Click By Scaling. The Shrinkage By Scale dialog box opens. Alternatively, you can click on the toolbar to access the Shrinkage By Scale dialog box directly.

3. Under Formula, click $1+S$ or $1/(1-S)$ to specify the formula that you want to use to calculate shrinkage.

4. Select a coordinate system that the shrinkage feature uses as a reference. The selected coordinate system appears in the Coordinate System box.

5. Under Type, specify one or both of the following:
   
   o Isotropic—Sets the same shrinkage ratio for the X-, Y-, and Z- directions.

   Note: Clear the Isotropic check box to specify different shrinkage ratios for the X-, Y-, and Z- directions.
Forward References—Shrinkage does not create new geometry but changes the existing geometry so that all existing references continue to be a part of the model.

Note: If you clear the Forward References check box, Pro/ENGINEER creates new geometry for the part on which you are applying shrinkage.

6. Type a value for the shrink ratio in the Shrink Ratio box and click to apply shrinkage by scaling to the part. Pro/ENGINEER recalculates the part geometry. A negative value shrinks the part, while a positive value expands it.

7. To remove shrinkage applied by scaling, right-click the shrinkage feature created in the model tree. A shortcut menu appears.

8. Click Delete. The shrinkage feature is removed from the part.

9. If required, in the Shrinkage By Scale dialog box, click Feature > Info to obtain information about the shrinkage applied or Feature > References to obtain information about the references used by the part.

Applying Shrinkage by Scaling
Shrinkage by scaling is applied by creating a new feature of type Shrinkage. When you apply shrinkage in Mold or Cast mode, the Shrinkage feature is created in the reference model, not in the design model. Therefore, if shrinkage by scaling is applied in Mold or Cast mode:

- It is never reflected in the design model.

- If shrinkage by scaling is applied to the design model in Part mode, then the Shrinkage feature belongs to the design model, not to the reference model. Shrinkage is accurately reflected by the reference model geometry, but it cannot be cleared in Mold or Cast mode.

- Shrinkage by scaling should be applied prior to the definition of parting surfaces or volumes.

- Shrinkage by scaling affects part geometry (surfaces and edges) and datum features (curves, axes, planes, points, and so on).

To View Shrinkage Information
1. Click MOLD (CAST) > Shrinkage. The SHRINKAGE menu appears.

2. Click Shrink Info. The INFORMATION WINDOW (Srinkage.inf) opens and displays the following information:
   - The name of the design model.
   - Status of the design model, that is, shrunk or not shrunk.
   - The formula used for calculating shrinkage.
   - For shrinkage by scaling, the name of the coordinate system.
All shrinkage values set for the model.

You can also view information on shrinkage applied to the part by another method:
1. Click Info > Mold. The MOLD INF dialog box opens.
2. Under Show Info About, ensure that the Shrinkage check box is selected and click Apply. The INFORMATION WINDOW opens and displays information on all the components and the shrinkage applied to the model.

Reference Parts

About Reference Parts
The Mold or Cast reference part usually represents a part that should be molded. The reference part is needed to imprint corresponding geometry on mold or die components.

Typically, the reference part geometry is based on geometry of the design part. Usually the reference part and design part are not identical. The design part does not always contain all necessary design elements that molding or casting technology requires. Namely, the design part is not shrunk, and it does not contain all needed drafts and fillets. Shrinkage and missing design elements are usually created on the reference part.

Sometimes the design part contains the design elements that require post-molding or post-casting machining. In this case, the elements should be changed on the reference part. The reference part can be created in three different ways:

- **Inherited**—The reference part inherits all geometry and feature information from the design part. You can specify the geometry and the feature data that you want to modify on the inherited part without changing the original part. Inheritance provides greater freedom to modify the reference part without changing the design part.

- **Merge by Reference**—Pro/ENGINEER copies design part geometry into the reference part. In this case, only the geometry and layers are copied from the design part. It also copies datum plane information from the design model to the reference model. If a layer with one or more datum planes associated with it exists in a design model, the layer, its name, and the datum planes associated with it are copied from the design model to the reference model. The display status of the layer is also copied to the reference model.

- **Same Model**—Pro/ENGINEER uses the selected design part as a mold or cast reference part.

To Assemble the Reference Part to the Mold or Cast Assembly
1. On the MOLD (CAST) menu, click Mold Model (Cast Model) > Assemble > Ref Model. The Open dialog box opens.
2. Select the .prt file that represents the existing design model and click Open. The Component Placement dialog box opens.
3. Define the component placement using the Component Placement dialog box and click OK. The Create Reference Model dialog box opens. Select from one of the following:

   - **Inherited**—The reference part inherents all geometry and feature information from the design part. You can specify the geometry and the feature data that you want to modify on the inherited part without changing the original part. Inheritance provides greater freedom to modify the reference part without changing the design part.

   - **Merge by Reference**—Pro/ENGINEER copies design part geometry into the reference part. It also copies datum plane information from the design model to the reference model. If a layer with one or more datum planes associated with it exists in a design model, the layer, its name, and the datum planes associated with it are copied from the design model to the reference model. The display status of the layer is also copied to the reference model.

   - **Same Model**—Pro/ENGINEER uses the selected design part as a mold or cast reference part.

4. Click OK. The reference part is assembled to the mold or cast assembly.

---

**To Create a New Reference Part**

1. Click **MOLD (CAST) > Mold Model (Cast Model) > Create**. The MOLD MDL TYP (CAST MDL TYP) menu appears.

2. Click **Ref Model**. The Component Create dialog box opens.

3. Specify the **Type** and **Sub-type** of the reference part.

4. Specify a name for the reference part and click OK. The Creation Options dialog box opens.

5. Select a **Creation Method** and click OK.

---

**Design Part and Reference Part Relationship**

The relationship between the design part and the reference part depends on the method used to create the reference part. While assembling a reference part, you can inherit geometry and feature information from the design part to the reference part. Inheritance allows a one-way associative propagation of geometry and feature data from a design part to a reference part. Initially, an inheritance feature has its geometry and data identical to the part from which it is derived. You can identify the feature data that you want to modify on the inherited feature, without changing the original part. This provides greater freedom to modify the reference part without changing the design part.

You can also copy (merge by reference) design part geometry into the reference part. In this case, only the geometry and layers are copied from the design part. You can apply shrinkage to the reference part, create a draft, round, and other features
that do not affect the design part. However, all changes in the design part are automatically reflected in the reference part.

As an alternative, you can designate a design part to be a Mold or Cast reference part. In this case, they are the same models.

In all cases, using the geometry of a reference model while working in Mold or Cast sets up a parametric relationship between the design part and the mold or cast components. Because of this relationship, when the design part is changed, the reference part and all associated mold or cast components are updated to reflect the change.

Reference Part Layout

About Reference Part Layout

Reference Part Layout is the automated assembly mode for Mold designers. This mode provides a way to arrange reference parts in a pattern within a particular mold model. You can create, add, remove, and reposition reference parts in the layout of the model.

To Access the Layout Dialog Box

1. Click on the toolbar, or click MOLD > Mold Model > Locate RefPart. The Layout dialog box and the Open dialog boxes open.

2. Select a part from the open dialog box and click Open. The part you select appears in the Reference Model box on the Layout dialog box.

To Create a Simple Reference Part Layout

1. Click MOLD > Mold Model > Locate Ref Part. The Layout dialog box and the Open dialog box open.

2. In the Open dialog box, select a .prt file reference model and click Open. The Create Reference Model dialog box opens.

3. In the Create Reference Model dialog box, select the Reference Model Type and the reference part file name, and click OK.

4. In the Layout dialog box:
   a. Click under Ref. Model Origin and Orient. The GET CSYS TYPE menu appears, and a Pro/ENGINEER window displays the reference model
   b. Click Dynamic or Standard in the GET CSYS TYPE menu:
      If you click Dynamic, the Ref Model Orientation dialog box opens. Change settings as needed and click OK.
      If you click Standard, select the coordinate system in the second Pro/ENGINEER window.
c. Click **Layout Origin**, and select a coordinate system.

d. Define the layout. For example, a mold that produces six parts in a rectangular layout:

   Under **Layout**, click **Rectangular**. Under **Orientation**, click **Constant**.

   In the **Cavities** box, set the x value to 2 and the y value to 3.

   In the **Increment** box, set the x value to 10 and the y value to 20.

e. Click **Preview** to check your increment values. Adjust the values if necessary.

f. Click **OK**.

5. Assemble or create a workpiece.

6. Create a parting surface.

7. To split the workpiece by parting surface, create core and cavity split volumes.

8. To extract the volumes, create core and cavity inserts.

---

**The Reference Model Orientation Dialog Box**

The **Ref. Model Orientation** dialog box contains the following elements.

- **Projected Area**—Displays the projected area of the current orientation each time you click **Update**.

- **Draft Check**—Input a draft angle and display a shaded reference model based on that angle each time you click **Shade**. If you click **Repaint**, the shading is removed, and the model returns to its original orientation.

- **Bounding Box**—This information is displayed during Ref Model origin (csys) manipulation and represents the maximum dimensions of a reference model.

- **Coordinate System Move/Orient**—Modify the location and orientation of the reference model.

The new coordinate system is created as an offset of the previously defined origin, or from the default coordinate system. Use the dialog box to define the offset rotation and translation.

You can calculate a projected area and check draft angles according to the current coordinate system orientation. The reference part bounding box is updated dynamically according to the current coordinate system orientation.

---

**Designating the Reference Part Layout**

**Reference Part Origin and Reference Part Layout Origin**

In a reference part layout operation, you must designate the origins of two coordinate systems, one for the reference part itself and one for the reference part
layout. These coordinate systems allow you to place the reference parts within the mold assembly.

The reference part origin defines the orientation of the reference part within the layout. The default origin is the first coordinate system in the reference part.

The reference part layout origin defines the general location of the reference part layout in the mold or cast assembly. You can redefine the location of the entire layout by redefining this coordinate system.

Use the configuration file option `mold_layout_origin_name` to set a specified coordinate system as the default for the reference part layout origin.

**Population Rules**

Positioning a single reference part multiple times within a reference part layout is called populating the layout. There are four population rules, or ways to position reference parts within a layout. Access these population rules through the Layout dialog box.

**Single Rule**

Use this rule to place the reference part with zero "rectangular" dimensions, and to create an empty pattern table.

When you place a reference part in a mold assembly using reference part origin and reference part layout origin, the system recognizes this as a single rule population. You can then redefine the placement using the Layout dialog box.

**Rectangular Rule**

Use this rule to place the reference part in a rectangular layout. Specify the following information:

- **Orientation**—Constant, X-Symmetric or Y-Symmetric.
- **Cavities**—the total number of reference parts in the X and Y directions.
- **Increment**—the distance between origins of reference parts in the X and Y directions.

**Circular Rule**

Use this rule to place the reference part in a circular layout. Specify the following information:

- **Orientation**—Constant or Radial.
- **Cavities**—the total number of reference parts.
- **Radius**—the radius of the circular layout.
- **Start Angle**—the angular coordinate of the first reference part.
- **Increment**—the angular distance between reference parts.
Variable Rule
Use this rule to place the reference part according to a user-defined pattern table in the X and Y directions.

You can modify dimensions of each reference part directly from the dialog, or add, remove, or replace any individual model (except for the pattern leader).

- Use the **File** menu in the Layout dialog box to store or retrieve a variable population rule in a file on disk.
- You can copy reference part layout rules to create libraries of user-defined population rules.

To Create a Reference Part Coordinate System on the Fly
Use the **Ref Model Orientation** dialog box to create a coordinate system that defines the reference model orientation.

1. From within the mold assembly, click **MOLD > Mold Model > Locate RefPart > Create**. The **Layout** dialog box opens.
2. Click **Ref Model Origin and Orient** on the **Layout** dialog box.
3. Click **GET CSYS TYPE > Dynamic**. The **Ref Model Orientation** dialog box opens.

To Allow the Same Model
1. Click **MOLD MODEL > Locate RefPart > Create**. The **Layout** dialog box opens.
2. Under **Reference Model**, click ![folder icon] to select the reference model. The **Create Reference Model** dialog box opens.
3. Under **Reference Model Type**, click **Inherited**, **Merge by Reference**, or **Same Model**.
4. If you click **Same Model**, the name of the design model appears in the **Reference Model Name** box. The Pro/ENGINEER window updates with the mold reference part.

Allowing the Same Model
You can designate a design part directly as the mold reference part. By using the **Same Model**, Mold level features can reference the features of the design model directly. You can access **Same Model** in the **Create Reference Model** dialog box under **Reference Model Type** when you assemble a reference part or when you create a reference part layout with **MOLD MODEL > Ref Part Layout**.
Inherited Reference Part

About the Inherited Reference Part
A reference model that is created using Inherited in the Create Reference Model dialog box, inherits all the geometry and features from the design part. Inheritance allows one way associative merge of geometry and feature data from a design part to the reference part. Initially, an inheritance feature has its geometry and data identical to the part from which it is derived. You can identify the feature data that you want to modify on the inherited feature, without changing the original part. Inheritance provides greater freedom to modify the reference part without changing the design part.

Inheritance Features Capabilities
Inheritance features capabilities include:

- Access to parameters and features of the inherited models and their usage, provided the prefix "IID_" is used for them.
- Access to dimensions of the inheritance features in drawing mode as well as part and assembly mode.
- Multilevel nesting of inheritance features.
- Support of Reference Pattern.
- Identification of the different systems of units being used by the reference part and the design part.
- Special resolve mode for inheritance failure cases.
- Ability to copy non-geometry elements in addition to 3D notes, surface finish, and so on.
- Parent-child relationship.
- Ability to change the inherited reference part to the instance/generic of the family table.
- Ability to modify dimensions, features, references, parameters, tolerances, dimension boundaries, annotations (geometry tolerance, surface finish, 3D notes, 3D symbols) dependency, shrinkage by dimension, and so on, of the inherited model.
- Ability to modify all varied items except annotations, by defining associate parameters that can be accessed through the family tables.
- Ability to replace references from inside or outside the inheritance feature.
- Ability to specify shrinkage by dimension in the reference part, without affecting the design part.
- Different status for varied items (dimensions) such as Locked, Not Applied, Erased, Restored, and so on.
To Redefine Elements of an Inherited Reference Part
1. Click MOLD > Feature. The MOLD MDL TYP menu appears.
2. Click Ref Model. The FEAT OPER menu appears.
3. Click Feature Oper > Redefine. The SELECT FEAT menu appears and you are prompted to select a feature.
4. Click on the reference model. The EXTERNAL INHERITANCE dialog box opens and the reference part opens in a separate window. Use the EXTERNAL INHERITANCE dialog box to modify varied elements as dimensions, features, parameters, shrinkage, references and so on.

You can also access the EXTERNAL INHERITANCE dialog box by the following method:
1. In the model tree, right-click the inheritance feature. A shortcut menu appears.
2. Click Edit Definition. The EXTERNAL INHERITANCE dialog box opens and the reference part opens in a separate window.

To Define Varied Dimensions in an Inheritance Reference Part.
1. Click MOLD > Feature. The MOLD MDL TYP menu appears.
2. Click Ref Model. The FEAT OPER menu appears.
3. Click Feature Oper > Redefine. The SELECT FEAT menu appears and you are prompted to select a feature.
4. Click the reference model. The EXTERNAL INHERITANCE dialog box opens and the reference part opens in a separate window.

   Note: You can also access the EXTERNAL INHERITANCE dialog box as follows:
   In the model tree, right-click the inheritance feature. A shortcut menu appears.
   Click Edit Definition. The EXTERNAL INHERITANCE dialog box opens and the reference part opens in a separate window.

5. Click Var Dims > Define. The Varied Dimensions dialog box opens.
6. In the window that displays the reference part, select the dimensions of the inheritance model that you want to redefine. The selected dimensions appear in the Varied Dimensions dialog box.
7. In the New Value column, type the new value for that dimension.
8. Click OK. The status of the Var Dims changes to Defined on the EXTERNAL INHERITANCE dialog box.

To Suppress, Resume, Erase or Restore Varied Features in an Inherited Reference Part
1. Click MOLD > Feature. The MOLD MDL TYP menu appears.
2. Click **Ref Model**. The **FEAT OPER** menu appears.

3. Click **Feature Oper > Redefine**. The **SELECT FEAT** menu appears and you are prompted to select a feature.

4. Click the reference model. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

   **Note:** You can also access the **EXTERNAL INHERITANCE** dialog box as follows:

   In the model tree, right-click the inheritance feature. A shortcut menu appears.

   Click **Edit Definition**. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

5. Click **Var Feats > Define**. The **Varied Features** dialog box opens.

6. In the separate window that displays the reference part, select the features of the inheritance model that you want to modify. Information about the selected features appears in the **Varied Features** dialog box.

7. In the **New Status** column, select **Suppressed**, **Resumed**, **Erased**, or **Restored** and click **OK**.

**To Define Varied Parameters in an Inherited Reference Part**

1. Click **MOLD > Feature**. The **MOLD MDL TYP** menu appears.

2. Click **Ref Model**. The **FEAT OPER** menu appears.

3. Click **Feature Oper > Redefine**. The **SELECT FEAT** menu appears and you are prompted to select a feature.

4. Click the reference model. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

   **Note:** You can also access the **EXTERNAL INHERITANCE** dialog box as follows:

   In the model tree, right-click the inheritance feature. A shortcut menu appears.

   Click **Edit Definition**. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

5. Click **Var Params > Define**. The **Varied Parameters** and **Select Parameter** dialog boxes open.

6. In the **Select Parameter** dialog box, select parameters in the reference model that you want to redefine and click **OK**. The selected parameters appear in the **Varied Parameters** dialog box.

7. In the **New Value** column, type the new value for that parameter and click **OK**.

**To Define Varied Shrinkage in an Inherited Reference Part**

You can modify shrinkage applied to the part only if it is applied using the **Shrinkage By Dimension** method.
1. Click **MOLD > Feature.** The **MOLD MDL TYP** menu appears.

2. Click **Ref Model.** The **FEAT OPER** menu appears.

3. Click **Feature Oper > Redefine.** The **SELECT FEAT** menu appears and you are prompted to select a feature.

4. Click the reference model. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

   **Note:** You can also access the **EXTERNAL INHERITANCE** dialog box as follows:

   In the model tree, right-click the inheritance feature. A shortcut menu appears.

   Click **Edit Definition.** The **EXTERNAL INHERITANCE** dialog box appears and the reference part opens in a separate window.

5. Click **Var Shrink > Define.** The **Shrinkage By Dimension** dialog box opens.

6. Use the **Shrinkage By Dimension** dialog box to modify the shrinkage you have applied to the part.

**To Define Varied References in an Inherited Reference Part**

1. Click **MOLD > Feature.** The **MOLD MDL TYP** menu appears.

2. Click **Ref Model.** The **FEAT OPER** menu appears.

3. Click **Feature Oper > Redefine.** The **SELECT FEAT** menu appears and you are prompted to select a feature.

4. Click the reference model. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

   **Note:** You can also access the **EXTERNAL INHERITANCE** dialog box as follows:

   In the model tree, right-click the inheritance feature. A shortcut menu appears.

   Click **Edit Definition.** The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

5. Click **Var Refs > Define.** The **Varied Reference** dialog box opens.

6. Select the reference within the inheritance feature that you want to replace.

7. Select the new reference from inside or outside the inheritance feature to replace the reference you have selected. The **Sub-features definition** dialog box opens.

8. Select sub-features within the inheritance feature that need to have their references replaced.

9. Click **OK.** The original references that you have selected are replaced with the new ones.

**To Define the Dependency of an Inherited Reference Part**

1. Click **MOLD > Feature.** The **MOLD MDL TYP** menu appears.
2. Click **Ref Model**. The **FEAT OPER** menu appears.

3. Click **Feature Oper > Redefine**. The **SELECT FEAT** menu appears and you are prompted to select a feature.

4. Click the reference model. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

   **Note:** You can also access the **EXTERNAL INHERITANCE** dialog box as follows:
   
   In the model tree, right-click the inheritance feature. A shortcut menu appears.
   
   Click **Edit Definition**. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

5. Click **Dependency > Define**. The **Feature Dependency** dialog box opens.

6. Select **Dependent** or **Independent** and click **OK**.

   **Note:** The inheritance feature is dependent on the reference model by default. If you select **Independent**, the inherited feature is not updated upon changes to the reference model but can be modified independently.

---

**To Redefine the Placement of the Inherited Reference Part**

1. Click **MOLD > Feature**. The **MOLD MDL TYP** menu appears.

2. Click **Ref Model**. The **FEAT OPER** menu appears.

3. Click **Feature Oper > Redefine**. The **SELECT FEAT** menu appears and you are prompted to select a feature.

4. Click the reference model. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

   **Note:** You can also access the **EXTERNAL INHERITANCE** dialog box as follows:

   In the model tree, right-click the inheritance feature. A shortcut menu appears.
   
   Click **Edit Definition**. The **EXTERNAL INHERITANCE** dialog box opens and the reference part opens in a separate window.

5. Click **Location > Define**. The **Inheritance Placement** dialog box opens.

6. Use the **Inheritance Placement** dialog box to modify the location of the reference model.

---

**Adding Workpieces**

**About Workpieces or Die Blocks**

The workpiece represents the overall volume of the mold components that directly participate in shaping the molten material (for example, the top and bottom inserts together). The workpiece can be an assembly of A & B plates with inserts or simply an insert that is split into multiple components. The workpiece can have standard
overall dimensions to fit in the standard base, or it can be custom-made to accommodate the geometry of the design model.

The die block represents the overall volume of the cast components that shape the molten material: the top half and bottom half of the die.

If the workpiece or die block is a pre-existing part, you can add it to the mold or cast assembly, or, you can create the workpiece or die block directly in the mold or cast assembly.

If you create a workpiece or die block in the mold or cast assembly, the workpiece or die block automatically uses the same accuracy as the reference model.

You cannot create a workpiece or a die block as the first component of the assembly without first creating assembly datum features.

**To Assemble the Workpiece or Die Block into the Mold or Cast Assembly**

1. Click **MOLD (CAST) > Mold Model (Cast Model) > Assemble.**
2. Click **MOLD MDL TYP (CAST MDL TYP) > Workpiece (Die Block).** The Open dialog box opens.
3. Select the .prt or .asm file that represents the workpiece (die block) and click Open.
4. Define the component placement using the Component Placement dialog box.
5. Click Ok.

**To Create Manual Workpieces**

Using a Start Part template.

1. Click **Mold Model (Cast Model) > Create.** The MOLD MDL TYP (CAST MDL TYP) menu appears.
2. Click **Workpiece (Die Block).** The CREATE WORKPIECE menu appears.
3. Click **Manual.** The Component Create dialog box opens.
4. Specify the **Type** and **Sub-type** and click OK. The Creation Options dialog box opens.
5. Select the required component creation method under Creation Method.
6. Click Ok.

**Cutting Out Reference Parts of a Workpiece**

After creating the workpiece, you can cut the reference part geometry from the workpiece or the mold volume by clicking Feature > Workpiece > RefPart Cutout.
With **RefPart Cutout**, Pro/ENGINEER automatically subtracts the reference model from the current workpiece.

**Automatic Workpiece Creation**

**About Automatic Workpiece Creation**
The Automatic Workpiece (WP) creation functionality gives you the ability to create a workpiece based on the reference model's size and position. You can:

- Orient the workpiece in relationship to the mold base parting plane and pull direction
- Create a custom size workpiece or select from standard sizes
- Save offsets used during the automatic workpiece creation to a file for future use

**To Create an Automatic Workpiece**

1. Create or open a mold or cast manufacturing assembly.
3. Click **Mold > Mold Model > Create > Workpiece > Automatic**. The **Automatic Workpiece** dialog box opens.
4. Under **Reference Models**, click ![select](image). By default, all the reference parts are listed. The **Select** menu appears.
5. Click the reference model or models around which you want to create your workpiece.
6. Under **Mold Origin** click ![select](image). The **Select** menu appears, allowing you to select the coordinate system for workpiece orientation.
7. Click the coordinate system you want to use. A rectangular bounding box appears around the reference part.
8. Accept the default standard rectangular box shape, click ![rectangle](image) for a standard round shape, or click ![rectangle](image) to create a customized bounding box. If you are creating a custom box, select the type of box from the **Shape** list.
9. In the **Units** list, click **mm** or **in**.
10. In the **Uniform Offsets** box, specify the offset value you want added to the dimensions of the workpiece. When you change the value of **Uniform Offsets**, the **X**, **Y**, and **Z direction** values and **Overall Dimensions** values change automatically.
If you select a round workpiece, **Uniform Offsets, Radial, and Z direction** appear under **Offsets** and **Diameter** appears under **Overall Dimensions**. **X and Y direction** are not available.

11. You can change **Overall Dimensions** values or accept the default values. Other values that are affected in the **Automatic Workpiece** dialog box automatically change.

12. Under **Translate Workpiece**, use the **X direction** and **Y direction** thumbwheels to position the workpiece at the appropriate position around the reference part.

13. Click **OK**.

**Workpieces**

The initial size of the workpiece is determined by the bounding box size of the reference model(s). The bounding box is, by default, a rectangular representation of the reference models showing its size envelope in x, y, and z directions. In the case of multiple reference models, a single bounding box, including all reference models, is used for workpiece creation. The location of the workpiece is dependent on the reference model’s x, y, and z coordinates. Only the z coordinate has a unique positive and negative value. A rectangular workpiece uses the center of its bounding box as its center. A cylindrical workpiece uses the selected coordinate system as its center.

The orientation of the workpiece is determined by the mold model or mold assembly coordinate system (mold origin). You can move the workpiece coordinate system in relation with the mold assembly coordinate system using the thumbwheels in the **Translate Workpiece** area of the **Automatic Workpiece** dialog box.

**Mold Parting Surfaces**

**About Creating Parting Surfaces**

A quick way to break down a workpiece or die block is to define parting surfaces and then split the workpiece using these surfaces.

A parting surface is a surface feature, which can be used to split either a workpiece or die block, or an existing volume, including surfaces of one or more reference parts.

The finished parting surface must completely intersect the workpiece, the die block, or the volume to be split.

A parting surface is a powerful surface feature because merged surfaces are automatically attached to them; therefore, the parting surface becomes the parent feature of any attached surface patches.
**Parting Surface Rules**
- A parting surface must intersect the workpiece or mold volume completely. Multiple surfaces can be merged together.
- A parting surface cannot intersect itself.
- Any surface can be used as a parting surface as long as the first two criteria are met.
- Parting surface features are created at the assembly level.

**Creating Parting Surfaces**

**To Create a Parting Surface**

1. Click **MOLD > Parting Surf > Create**. For a cast assembly, click **CAST > Cast Feature > Cast Assem > Surface**.
2. Specify a name for the surface. The **SURF DEFINE** menu appears.
3. On the **SURF DEFINE** menu click **Add**.
4. Click one of the following on the **SRF OPTS** menu and click **Done**.
   - **Extrude**—Create the surface by extruding the sketched section to a specified depth in the direction normal to the sketching plane.
   - **Revolve**—Create the surface by rotating the sketched section by a specified angle around the first centerline sketched when sketching the section.
   - **Sweep**—Create the surface as a result of sweeping a sketched section along a specified trajectory.
   - **Blend**—Create a straight or smooth blended surface connecting several sketched sections.
   - **Flat**—Create a planar datum surface by sketching its boundaries.
   - **Offset**—Create a datum surface by offsetting a surface of the reference part.
   - **Copy**—Create a datum surface by copying surfaces of the reference part.
   - **Copy by Trim**—Create a copy of the trimmed surface.
   - **Fillet**—Create a quilt by creating a fillet surface.
   - **Shadow**—Create a parting surface and component geometry using a light projection technique.
   - **Skirt**—Create a "Swiss cheese" style parting surface by selecting the curve and identifying the pull direction.
Advanced—Create a complex surface; for example, using datum curves, multiple trajectories, and so on.

5. Use the dialog box displayed for the command that you selected to define the parting surface.

6. After the first surface patch is created, you can use other MOLD > PARTING SURF > SURF DEFINE (QUILT SURF) commands to extend its edges, trim and offset it, or add other patches and include them in the parting surface definition by merging.

To Create a Surface by Copying

Copying surfaces is especially useful, since it allows you to reference geometry of the design model.

1. Click MOLD > Parting Surf > Create. The Parting Surface Name dialog box opens. Specify a name for the parting surface.

2. In the SURF DEFINE menu, click Add. The SURF OPTS menu appears.

3. Click Copy > Done.

4. The SURFACE: Copy dialog box opens. Select surfaces that you want to copy.

5. If you want to exclude loops from the surfaces to be copied, select Excl Loops from the SURFACE: Copy dialog box and click Define. The FEATURE REFS menu appears, enabling you to select the edges of loops that you want to exclude from the surface definition.

6. If you want to fill the inner contours of the surfaces to be copied, select Fill Loop and click Define. The GATHER FILL menu appears.

7. Specify the loops to be filled or excluded.

8. Click OK. The edges of the surface copy feature are highlighted: outer (one-sided) edges in yellow and inner edges in magenta.

Adding a Skirt Parting Surface

About Adding a Skirt Surface

In creating a parting surface, the Skirt parting surface feature automatically does the following:

- Fills holes in the surface using closed loops of the Silhouette curve.
- Extends datum curves created by Silhouette curve to the boundaries of the workpiece.

You can use the CLOSURE TYPE menu to control the process of closing inner loops or holes in a Skirt or Shadow parting surface. You begin the process of defining a loop closure type by selecting the Loop Closure element in the Skirt Surface dialog box, and then clicking the Define button to display the LOOP CLOSURE menu. If
you click **Closures > Add** on the **LOOP CLOSURE** menu and then select one or more inner loops in the graphical display, the **CLOSURE TYPE** menu appears. This menu allows you to accept the standard default surface or to select another type of closure that is offset from the default surface.

You can use the **Extension Control** dialog box to remove segments of a silhouette curve, define a curve, and change the extension direction of the curve. You display the **Extension Control** dialog box by selecting the **Extension** element in the **Skirt Surface** dialog box and clicking the **Define** button.

### To Add a Skirt Surface

1. Click ![Cavity Design toolbar icon](image) on the Cavity Design toolbar, or click **MOLD > Parting Surf > Create**. Specify a name, click **OK**, and then click **Add > Skirt > Done**.

2. Define the elements that are labeled **Defined** or **Defining** in the order listed. You can define the **Optional** elements in any order or not define them at all.

3. Click the **Direction** element in the **Skirt Surface** dialog box and click **Define**.

   **Note:** If Pull Direction has been defined for the model, the default Direction is automatically opposite of the Pull Direction.

4. To specify the light direction, select one of the following:
   - **Plane**—To select a plane in the Pro/ENGINEER window to which the direction is perpendicular
   - **Crv/Edg/Axis**—To select along the linear edge, axis, or 3D curve
   - **Csys**—To select along an x, y, or z axis

   **Note:** If you cannot find a reference from which to set the light direction, you can create a reference on the fly using **Insert > Datum > Plane Curve**.

5. If you click **Plane**, you can select **Datum** or **Surface**. A red arrow appears along the plane. Click **Okay**, or change the direction of the arrow by clicking **Flip**.

6. Select existing curves that form a silhouette on the reference part. The curves might have internal loops (for future filling) and an external loop (for future extension). Use the **Curves > Feat Curves** command to select one or more silhouette curves.

   **Note:** If you have not defined a parting curve, you can do it now asynchronously. Click the icon labeled Insert a datum curve on the Datum toolbar, and then click an option in the **CRV OPTIONS** menu. For example, click **Silhouette** and then click **Done** to open the **SILHOUETTE CURVE** dialog box and create a Silhouette curve.

7. If you want to exclude some curves from the extension, specify tangent conditions, or change extension directions, click **Extension** and then click **Define** to display the **Extension Control** dialog box.
8. If you want to change methods of handling inner loops, click Loop Closure and then click Define to display the LOOP CLOSURE menu.

9. Use the ShutOff Ext and ShutOff Plane if you want to define shut-off extension and drop the surface extension onto a parting plane. Use Draft Angle to define shut-off angle.

10. Click Ok to complete skirt feature creation.

The Skirt Surface Dialog Box

The Skirt Surface dialog box opens in Mold Manufacturing mode after you click the Create Skirt icon on the Cavity Design toolbar. It also opens after you click MOLD > Parting Surf > Create, enter the name of the surface, and click Add > Skirt > Done.

The Skirt Surface dialog box contains the following elements:

- **Ref Model**—Selects the reference model geometry for skirt.
- **Workpiece**—Selects one or more workpieces to define skirt boundaries.
- **Direction**—Defines the imaginary light direction.
- **Curves**—Defines corresponding segments of the Silhouette curve.
- **Extension**—Changes the extension direction of selected points on a curve and lets you exclude selected curves from extension.
- **Loop Closure**—Defines inner loop closure on skirt parting surfaces.
- **ShutOff Ext**—Defines shut-off extension.
- **Draft Angle**—Defines shut-off draft angle.
- **ShutOff Plane**—Selects or creates the shut-off plane.

Creating Skirt Parting Surfaces with Undercut Conditions

In instances where the design part has an undercut in the direction of the light, the slide volumes or solid components will be correctly interpreted by the MOLD FEAT > Silhouette > Slides.

These slides can be either an additional volume or another component in the assembly.

Curve loops that represent slides geometry are automatically considered during the creation of Skirt parting surfaces.

Feature Curve Requirements

Skirt parting surfaces use datum curves created by the Silhouette Curve feature. You can select Boundary Curves, Holes, and Closed Loops. If some of the silhouette curve segments do not produce the desired parting surface geometry or
cause overlapping of parting surface extension, you can exclude them and manually create a projected curve.

To Exclude Failed Curves or Undesired Curves from Extension

1. In the SELECT SURFACE menu, click Curves > Define.
2. Click CHAIN > Unselect to exclude the curves.

Example: Skirt Parting Surface

Adding a Shadow Surface

About Adding a Shadow Surface
You can create shadow once you add the properly drafted and shrunk design model to a workpiece or die block, and determine the pull direction. That is, you must completely draft the reference model prior to using the shadow feature. You perform the shadow feature on one workpiece or die block. You can then perform usual split operations, or create a special type of cut—called the Shadow Cut Out—which is a one-sided split.

A parting surface created by shadow is an assembly feature. If you delete a set of edges, remove a surface, or change the number of loops, the system regenerates this feature correctly.

A parting surface cannot be created unless the workpiece or die block is unblanked.

To Add a Shadow Surface
1. For a mold assembly, click MOLD > Parting Surf > Create. The Parting Surface Name dialog box opens.
2. Specify a name for the surface and click OK.
3. In the **SURF DEFINE** menu, click **Add > Shadow > Done**. The **Shadow Surface** dialog box opens.

   For a cast assembly, click **CAST > Cast Feature > Cast Assem > Surface > Shadow > Done**. The **Shadow Surface** dialog box opens.

4. Specify the shadow parts. You can select either single or multiple reference model(s). If there is only one reference model present, the system selects it by default.

5. If there are multiple reference models present, the **FEATURE REFS** menu appears. Select the reference models you want to use. If many reference parts are selected, you must select a **ShutOff** plane.

6. Click **Done/Return**.

7. Specify the workpiece or die block component. You must select one component on which Pro/ENGINEER creates the shadow feature. If there is only one workpiece or die block in the assembly, the system selects that component by default.

8. Define the direction for the light source. Click one of the following commands from the **GEN SEL DIR** menu:
   - **Plane**—Use a plane normal to the direction.
   - **Crv/Edge/Axis**—Use a curve, edge, or axis as the direction.
   - **Csys**—Use an axis of the coordinate system as the direction.

9. The system displays an arrow, along with the **DIRECTION** menu. Click **Flip** and **Okay** or just **Okay**.

10. If you want to use a datum plane to control the shadow clipping (the system does not copy surfaces from the clip plane downward in the direction of the light source), select **Clip Plane** from the **Shadow Surface** dialog box.

11. If you want to define the loop closure and cap plane for any loops in the preliminary shadow surface, select **Loop Closure** from the **Shadow Surface** dialog box. The system extends the loops up to the cap plane.

   If the shadow feature contains multiple inner loops, the system opens the **GATHER FILL** menu with the following commands:
   - **Cap Plane**—Specify a plane to seal off or enclose the mold volume. This option is selected by default.
   - **All Inner Lps**—Seal the openings of all inner loops in a selected surface. This option is selected by default.
   - **Sel Loops**—Seal the openings of selected holes in a selected surface.

The system assumes that on any given part, the area of most change occurs on the inner loops, and that all inner loops are closed to the same extension.
12. If you have defined a ShutOff plane and want to extend the shadow surface beyond the edges of the reference model before it drops down to the ShutOff plane, select **ShutOff Ext** from the **Shadow Surface** dialog box. The **SHUTOFF EXT** menu appears.

This process is known as general loop offset and is similar to the skinner loop offset. However, the result must always be a surface defined by the closed loop from the original shadow curve.

- Select **ShutOff Dist** and then enter a positive value to extend each edge of the shadow surface the same distance from the reference model.
- Select **Boundary** to define each edge of the shadow surface. The system opens the **SHADOW BOUND** menu.
- Click **Sketch** to sketch a boundary for the surface extension.
- Click **Select** to select a closed loop of edges for the surface extension.
- The **CHAIN** menu appears with the following commands:
  - **One By One** (default)—Select individual curves or edges.
  - **Tangnt Chain**—Select a chain of tangent edges.
  - **Curve Chain**—Select a chain of tangent curves.
  - **Bndry Chain**—Select a chain of one-sided edges that belong to the same surface list.
  - **Surf Chain**—Select a chain of surfaces.
  - **Intent Chain**—Select a chain of

The system allows you to select or create a boundary loop, which should be perpendicular to the pull direction.

13. If you want to specify the draft angle of the transitional surface between the shutoff extension and the shutoff plane, select **Draft Angle** from the **Shadow Surface** dialog box. A draft angle of 0.0 degrees is the default value.

14. If you want to specify how far to extend the drafted surface, select **ShutOff Plane** from the **Shadow Surface** dialog box. By default, the system extends the shadow surface to the inside perimeter of the selected workpiece or die block. In the case of multiple workpieces or die blocks and multiple reference models, this is a required field.

15. Click **OK**. The system regenerates the shadow surface feature.

16. Click **Preview** to preview the feature geometry. The shadow surface appears in magenta.

17. Click **Done/Return**.
The Shadow Surface Dialog Box

The **Shadow Surface** dialog box contains the following elements:

- **Shadow Parts**—Selects the reference part(s) for shadow.
- **Workpiece**—Selects workpiece(s) to define shadow boundaries.
- **Direction**—Defines the imaginary light direction.
- **Clip Plane**—Selects or creates the clipping plane to define the shadow boundary.
- **Loop Closure**—Closes inner loops on preliminary shadow surfaces.
- **ShutOff Ext**—Defines shut-off extension.
- **Draft Angle**—Defines shut-off draft angle.
- **ShutOff Plane**—Selects or creates the shut-off plane.
- **Shadow Slides**—Selects volume(s) that represents the slide(s).

Creating Shadow Parting Surfaces with Undercut Conditions

If undercuts exist in the reference model and you want to specify slide parts to attach to the shadow part(s), select **Shadow Slides** from the **Shadow Surface** dialog box.

The **SHADOW SLIDES** menu appears with the following commands:

- **Part Sel**—Specify slide parts to attach to the shadow parts.
- **Volume Sel**—Specify slide volumes to attach to the shadow parts.

Example: Parting Surface by Shadow

Drape Style
Comparing Skirt and Shadow

<table>
<thead>
<tr>
<th>Skirt</th>
<th>Shadow</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creates swiss cheese type of surface, based on Silhouette curve functionality</td>
<td>Creates Drape type surface using reference model geometry</td>
</tr>
<tr>
<td>Design part may have vertical surfaces</td>
<td>Design part must be fully drafted</td>
</tr>
<tr>
<td>Allowed to exclude failed segments</td>
<td>Failed segments cannot be excluded</td>
</tr>
<tr>
<td>Allows extension direction control</td>
<td>Does not allow extension direction control</td>
</tr>
<tr>
<td>Allows convenient selection of hole closing and choice of closing on upper or lower curve chain</td>
<td>Does not allow this selection and choice</td>
</tr>
</tbody>
</table>

Adding Advanced Parting Surfaces

To Add Advanced Parting Surfaces
1. Click **MOLD > Parting Surf > Create.**
2. Accept or change the name in the **Parting Surface Name** dialog box, and then click **OK.** The **SURF DEFINE** menu appears.
3. Click **Add.** The **SRF OPTS** menu appears.
4. Click **Advanced > Done.** The **ADV FEAT OPT** menu appears.
5. Select one of the following:
   - **Var Sec Swp**—To create a quilt using the variable section sweep geometry.
   - **Swept Blend**—To create a quilt using a swept blend geometry.
   - **Helical Swp**—To create a quilt using the helical sweep geometry.
   - **Boundaries**—To create a quilt from its boundaries.
   - **Sect to Srfs**—To create a quilt as a blend from a section to tangent surfaces.
   - **Sfts to Srfs**—To create a quilt as a blend from a surface to tangent surfaces.
   - **From File**—To create a blend from file.
To Create a Transitional Surface

Use the Sect to Srf option to create a transitional surface or solid between a set of tangent surfaces and a sketched contour. The set of surfaces selected for the tangent boundary must be closed.

1. Click ADV FEAT OPT > Sect to Srf > Done. The SURFACE: Section to Surfaces Blend dialog box opens.
2. Select surfaces to form the tangent boundary. The surfaces must be tangent to each other.
3. Click Done Sel. The SETUP SK PLN menu appears.
4. Set up the new sketching plane for the section boundary.
5. Specify the direction of feature creation and enter Sketcher mode.
6. Sketch the section boundary. The section must be closed.
7. Click Done on the SKETCHER menu.

Filling a Hole in a Parting Surface

About Filling a Hole in a Parting Surface

When creating parting surfaces that will separate the workpiece model into two mold volumes during split feature creation, you can use any of the following methods for filling holes in a parting surface:

- **Loop Closure** element in the Skirt Surface or the Shadow Surface dialog box for filling holes in the reference part.
- the Fill Loop element in the SURFACE: Copy dialog box to fill a hole in a surface that is being copied.
- Insert mode, create surfaces using copies that were made before creating a hole in the design model.

To Fill the Hole Using the Fill Command

1. Create the surfaces using Indiv Surfs or Surf & Bnd from the SURF OPTIONS menu.
   
   This method works if the hole crosses as many as three internal edges, or any number of simple surfaces.

2. Select Fill Loop from the SURFACE: Copy dialog box and click Define. The GATHER FILL menu appears with the commands All and Loops.
3. When you click **Loops**, select the yellow edge created by the hole in the surface. Pro/ENGINEER extends the surface definition to fill in the hole.

**To Fill the Hole with a Flat or Revolved Surface**

1. Create other surface features, such as flat or revolved surfaces.
2. Merge these surface features into the parting surface.
   
   Alternatively, you may copy the bottom surface with the hole filled, then merge this bottom surface into the parting surface.

**To Fill a Complex Cut**

You use this procedure when you have multiple quilts that cannot be filled with regular Pro/MOLDESIGN tools. You must go back to the design model and insert a copied surface feature to fill the complex surface cut.

1. Retrieve the design model into Part mode.
2. Click **Feature > Insert Mode** to insert a surface copy feature before you create the cuts.
3. Cancel **Insert Mode**.
4. Retrieve the mold model.

The new surface is visible in the mold model after regeneration, and you can copy it into the parting surface.

**Filling Inner Loops in Skirt and Shadow**

**About Filling Inner Loops in a Skirt Parting Surface**

Surface filling is the automatic process of closing inner loops or holes in a Skirt or Shadow parting surface.

You can use the **Standard** (default) closure type for an inner loop, or you can use one of the following closure types:

- **Middle Plane**
- **Middle Surface**
- **Cap Plane**
- **Cap Surface**
- **None**

The system uses the reference part geometry in the vicinity of each loop to implement the closure method.
To Define Inner Loop Closure in a Skirt Parting Surface

1. In the Skirt Surface dialog box, after the silhouette curves element has been defined, click Loop Closure and then click Define.

2. Click Closures > Add In the LOOP CLOSURE menu.

3. In the graphic display of the Mold model, select one or more inner loops that you want to close, and then click Done Sel.

4. In the CLOSURE TYPE menu, accept the a Standard default surface, or select one of the following closure types to define an inner loop parting surfaces that is offset from the default surface:
   - Middle Plane
   - Middle Surface
   - Cap Plane
   - Cap Surface

5. If you want to cap your loops, select the Cap Plane or Cap Surface option.

6. If you want to offset a selected surface (plane) with an average distance between the loop and the selected surface, select the Middle Surface (Middle Plane) option. You will be prompted to enter a value for the offset between the loop and the middle surface.

7. For the Middle Plane method, you can specify a specific plane, or you can specify that Average Plane is to be used.

8. When you have finished defining the loop closure, click OK in the Skirt Surface dialog box. The graphic display shows the new parting surface lines for the loop surface just defined.

You can define any additional inner loop closures in the Skirt parting surface by using the above steps.

Note: In the Mold model graphic display, you can easily identify inner loop Skirt surface areas. When you drag your cursor over any area, including inner loops, a SKIRT SURFACE label identifies these areas.

Example: Loop Closure: Case 1

The hole is located in a single surface of the part, even if the hole is adjacent to the edge of the surface. This surface fills the hole.
**Example: Loop Closure: Case 2**

All edges of the loop are in the same plane, even if the plane is not among part surfaces. The plane fills the hole.
**Example: Loop Closure: Case 3**

The hole intersects several surfaces of the part with no part vertices inside the hole. The adjacent surfaces fill the hole.
Example: Loop Closure: Case 4
The hole intersects three surfaces of the part with one part vertex inside the hole. The adjacent surfaces fill the hole.

Example: Loop Closure: Case 5
All other geometry is filled with the default patch, a boundary blend that extends from the hole boundary to the central point of the hole. The default patch was developed for the Skirt function and is not available in Shadow.

Using a Quilt as a Reference for a Parting Surface Feature

About Using a Quilt as a Reference for a Parting Surface Feature
When creating Parting Surface with the Copy command, you can use Quilt Surfs to select a quilt as a reference.

To Use a Quilt as a Reference for a Parting Surface Feature
1. Select MOLD > PARTING SURF > Create. The Parting Surface Name dialog box opens.
2. Specify a name and click OK. The SURF DEFINE menu appears.
3. Click Add. The SURF OPTS menu appears.
4. Click **Copy > Done**. The **SURFACE: Copy** dialog box opens.

5. Select the surfaces you want to copy and click **OK**.

**Pro/SURFACE Features in Mold Parting Surface**

**To Use Transform in Parting Surface**

Transforming a surface enables you to translate, rotate, or mirror datum curves and surface features. You can manipulate the surface feature itself or its copy, leaving the original feature intact.

Surface features and datum curves can be selected in any combination. All entities selected together make one surface feature.

To apply transforming operations to a surface:

1. Click **MOLD > Parting Surf > Modify**.
2. Select a surface and click **Transform**.

**To Use Draft in Parting Surface**

The **Draft** feature adds draft angles to the vertical portions of a Parting Surface to improve the moldability of a design model.

To apply transforming operations to a surface:

1. Click **MOLD > Parting Surf > Modify**.
2. Select a surface and click **Draft**.

**To Use Draft Offset in Parting Surface**

The **Draft Offset** command allows you to create a surface offset with drafted sides.

To apply transforming operations to a surface:

1. Click **MOLD > Parting Surf > Modify**.
2. Select a surface and click **Draft Offset**.

**To Use Area Offset in Parting Surface**

The **Area Offset** feature allows material to be added or removed from a mold component.

To apply transforming operations to a surface:

1. Click **MOLD > Parting Surf > Modify**.
2. Select a surface and click **Area Offset**.
Modifying Mold Parting Surfaces

About Modifying Mold Parting Surfaces
A parting surface in a mold assembly is not a single feature; rather, it is a name of a set of features. A parting surface may be easier to work with than a volume, since a surface does not have to be closed to be a valid feature. The first feature created in a parting surface is called the base quilt. Additional features (created by adding, merging, extending, and so on) are called patches. For example, if you add a surface, silhouette trim it, and then extend the edges, you will have a base quilt with two patches.

Parting surfaces, or their portions, can be deleted or suppressed by deleting or suppressing the appropriate feature(s) on the assembly. Features can be selected by feature number, through the Model Tree, or by selecting the patches. Dimensions of a parting surface can be modified using Edit.

The display of parting surfaces defined for the mold model can be turned off in the Model Tree or using Blank in the PARTING SURF menu. After you select Blank, the namelist menu of existing parting surfaces appears; select the surface name. Blanked parting surfaces can later be displayed using Unblank.

Parting surfaces can be reordered as assembly features using the Reorder command in the MOLD MODEL menu. The whole set of features included in the parting surface is moved to the specified position in the workpiece feature sequence.

To select a parting surface for reordering, you can either select its first feature (the base quilt), or use Sel By Menu and select the surface name.

To Rename a Parting Surface
1. Click MOLD > Parting Surf > Rename.
2. Select a parting surface.
3. Enter a new surface name.

To Redefine a Parting Surface
1. Click MOLD > Parting Surf > Redefine.
2. Select a parting surface.
3. Change the parting surface definition by adding new patches, merging, trimming, extending and so on.

To Shade a Parting Surface
1. Click MOLD > Parting Surf > Shade.
2. Select the parting surface to shade. The parting surface changes appearance.
3. Click CntVolSel > Continue to select more parting surfaces to shade or click Done/Return.
Merging the Parting Surface

About Merging the Parting Surface
When you create additional patches using the Add command, they are not automatically included into the parting surface definition. You have to connect them with the base quilt (the one including the first added surface) by joining or intersecting.

Example: Selecting Sides When Merging Surfaces Using Intersect

1. The first surface
2. The second surface
3. Intersection lines
4. Select this side for the first surface.
5. Select this die for the second surface.
6. The resulting quilt
Example: Merge the Parting Surface

To Merge a New Surface into the Current Parting Surface Definition
1. Click Merge on the MOLD > PARTING SURF > SURF DEFINE (QUILT SURF) menu.

2. Click one of the following:
   - **Join**—Use when two surfaces have a common edge. Pro/ENGINEER does not calculate the surface intersections, making the process a little faster.
   - **Intersect**—Use when two surfaces intersect. Pro/ENGINEER creates the intersection and asks you which parts of the surfaces you want to keep.

   The current parting surface definition is highlighted: surface edges appear in cyan; silhouette and intersection lines are blue.

3. Select the surface to be merged. The intersection boundary appears in blue. One of the surfaces (active) stays cyan, the other (inactive) turns gray.

4. Select the portion of the surface to keep by selecting **Side1** or **Side2** in **Additional Quilt Side** layout of **Surface Merge**. You can select the portion to keep using **Flip** and **Okay**. Then the procedure is repeated for the other surface.

Trimming Parting Surfaces

About Trimming Parting Surfaces
The Trim command on the SURF DEFINE (QUILT SURF) menu allows you to trim a parting surface.

To Trim Parting Surfaces
1. Click MOLD > Parting Surf > Modify.
2. Click **SURF DEFINE (QUILT SURF) > Trim**. The FORM menu appears.
3. Select one of the following to trim a parting surface:
   - **Use Curves**—Trims a surface using selected curves.
   - **Vertex Round**—Trims a surface by rounding and filleting selected corners.
   - **Silhouette**—Trims a surface by its silhouette from a specified direction.

**To Trim a Surface by Using Vertex Round**

A datum plane or an existing surface can be trimmed by rounding or filleting selected corners.

1. Click **Trim** on the **SURF DEFINE (QUILT SURF)** menu.
2. Click **Vertex Round** or **Solid** on the **FORM** menu.
3. Click **Done**.
4. Select the corner vertex(s) to be rounded or filleted.
5. Select the datum plane or surface references to be added.
6. Enter the trimming radius. Pro/ENGINEER displays a default value; for example, 0.1000. The selected surface is trimmed to the fillet radius.

**To Trim to a Silhouette Edge**

When splitting a volume, you might want to create a parting surface along the silhouette edge of a design model. A silhouette edge is the line of a curved surface as it appears in a particular view orientation. The silhouette edge is a desirable edge along which to split a volume. Because it is the contour, there is no overhang along this edge in a particular view orientation.

1. On the **SURF DEFINE (QUILT SURF)** menu, click **Trim > Silhouette > Done**.
   The **SURFACE TRIM: Silhouette** dialog box opens.
2. Select the surface to be trimmed (for Cast assemblies only).
3. Select or create a plane (planar surface or datum plane) to specify the viewing direction. The viewing direction is normal to this plane.
4. An arrow appears, indicating which side of the surface is to be kept. Click **Flip** or **Okay**.

   The entire current definition of the parting surface is trimmed. It is, therefore, recommended that you start creating a parting surface by copying just the surface(s) you want to silhouette trim, and then add more surfaces merging them with the base quilt as necessary.
5. Using the **Extend** command, extend the edges created by silhouette trimming up to a specified plane.
Example: Silhouette Trimming

1. Copy this surface.
2. Click **Trim** and select this plane.
3. Confirm side to keep.
4. This is the silhouette line.
5. This side is kept.

To Trim a Surface Using Form Features

When extruding, revolving, sweeping, or blending during the process of trimming, you are creating a surface definition that does not appear in the model. It is like creating a datum plane on-the-fly.

1. Click **MOLD > Parting Surf > Create** and specify a name for the parting surface.
2. Click **SURF DEFINE (QUILT SURF) > Trim**.
3. Click **Extrude, Revolve, Sweep,** or **Blend**.
4. Select the attributes from the **ATTRIBUTES** dialog box.
5. Click **Done**.
6. Select the appropriate options to create this surface.
7. Select the surface feature to be trimmed.
8. Specify a sketching plane and a reference plane for the trim feature.
9. When you have finished sketching the new surface, an arrow appears to indicate which side of the surface is to be removed. Click **Flip** or **Okay**.
10. The selected surface is trimmed to the new surface.

To Trim a Surface Using an Existing Surface Feature

A datum plane or an existing surface feature can be selected to trim another surface.

1. Click **MOLD > Parting Surf > Modify**. The **SURF DEFINE** menu appears.
2. Click **Trim**.
3. Select **Use Quilt** or **Use Curves** from the **FORM** menu.
4. Click **Done**.
5. Select the surface that is to be trimmed.
6. Select the datum plane or surface to which the first surface is trimmed. An arrow appears to indicate side of the surface that is to be removed.
7. Click **Material Side > Side1, Side2, or Both Sides** to indicate the correct direction.
8. The first surface selected is trimmed at its intersection with the other.

**Example: Trimming to an Existing Surface**

1. This is the surface to be trimmed.
2. This is the surface to trim to.
3. This arrow points to the position of the surface that will be removed.
4. Note that the surface used for trimming is consumed.
Extending Parting Surface Edges

About Extending Parting Surface Edges
The `Extend` command allows you to extend all or specified edges of the current parting surface by a specified distance or up to a selected planar surface or datum plane.

When constructing parting surfaces in Pro/MOLDESIGN, you often need to extend all or portions of existing surfaces to span the workpiece or merge to other surfaces. Pro/ENGINEER allows for several types of surface extensions depending on the design requirement:

- A parting surface that has been started by gathering only the insides of the part.
- A parting surface has been extended laterally and then needs to span the workpiece in the other direction.
- A part has been imbedded in a workpiece that will be split into extracts.
- Individual edges can also be extended with enhanced functionality that controls the shape of the extension.

To Extend Parting Surface Edges to a Specified Plane
1. Click `MOLD > Parting Surf > Modify` and select a parting surface to extend.
2. Click `Extend > Along Dir > Up To Plane > Done`.
3. For a mold assembly, click `All` or `Chain`.
4. If you click `Chain`, select the chain of edges to offset by selecting the from and to vertices. One of the possible paths between the vertices is highlighted. Select the desired chain.
5. For a cast assembly, click `One By One`, `Tangent Chain`, or `Bndry Chain`.
6. If you click `One By One`, select the individual curves or edges.
   - If you click `Tangent Chain`, select a chain of tangent edges.
   - If you click `Bndry Chain`, select a chain of one-sided edges that belong to the same surface list.
7. Select a planar surface or create a datum plane using `Make Datum`. The appropriate surfaces are created by extending specified edges normal to this plane and up to it. The new surfaces are already included in the parting surface definition; you don’t have to merge them.
Example: Creating Extended Edges

1. Original surface is gathered using **Surf & Bnd** to select all surfaces shown.
2. Select the top plane.
3. Select "to" vertex.
4. Select "from" vertex.
5. Accept this chain to select the chained surfaces shown.

**To Begin the Parting Surface Extension**

1. Click **Extend > Along Dir > Up To Plane > Done**.
2. Select an edge.
3. Click **Bndry Chain** because all of the edges to extend belong to the same quilt.
4. Click **From-To** to extend only a portion of the quilt.
5. Select vertices 1 and 2 for the From and To vertices. The possible paths that connect the two vertices are highlighted.
6. Click **Accept** and then **Done** for the shortest path.
7. When prompted to select a plane up to which you will extend the surface, select the surface BB on the workpiece, then select **Done Extend**. The parting surface is now extended between the two vertices up to the perimeter of the workpiece.
8. Repeat this procedure for the surface opposite BB.

**To Span the Workpiece in Another Direction**

The surface is extended laterally and now needs to span the workpiece in the other direction. Creating the surface extend in this direction is very similar to the parting surface extension procedure, except you must select different start and end vertices.

1. **Click Extend > Along Dir > Done > Bndry Chain, and select the one-sided edge of the parting surface.**

   Notice the extension created is now considered as a component of the parting surface.

2. Select vertices 3 and 4 for the from and to points, and extend to surface AA on the workpiece.

3. Repeat this procedure for the surface opposite AA.

Once completed, the entire parting surface appears.

All of the one-sided (yellow) edges reside on the perimeter of the workpiece, indicating that the parting surface is completely and correctly merged—contains two-sided magenta edges internally—for splitting.

**Example: Controlling the Shape of the Extension**

The following figure shows how Pro/ENGINEER highlights available vertices to define the limits for the extension.

![Example: Controlling the Shape of the Extension](image)

**To Gather Only the Insides of the Part**

If you define the core and cavity extracts as splitting the workpiece in a plane that passes through the top of the box, then you need to extend the parting surface outward to the perimeter of the workpiece. Surface extensions can only alter one-sided (yellow) edges and cannot alter two-sided (magenta) edges where two surfaces meet and have been merged.

**Example: Gather Only the Insides of the Part**

Illustrating the simplest case, the following figure shows a box-like part where a parting surface has been started by gathering only the insides of the box.
To Select the Entire Boundary Edge Chain
Create a parting surface that copies the cylindrical surface of the reference part.

1. Click MOLD > Parting Surf > Modify.
2. Select the parting surface and click Extend.
3. Click Same Surf > Done.
4. Click Bndry Chain > Done and select the entire boundary edge chain.
5. Click Accept for the chain that is closest to workpiece surfaces.
6. Click Select All from the CHAIN menu and Tang Srf, Done to continue until the GET EXT DIST menu appears.
7. Click Accept for the chain that is closest to workpiece surfaces. Click Select All from the CHAIN menu and Tang Srf > Done to continue until the GET EXT DIST menu appears.
8. Click Vert By Vert to allow each vertex of the chain to highlight and enter an Along Edge distance large enough to have the surface extend outside the workpiece.
9. Repeat the distances until you have defined all vertices.

The following figure shows the resulting surface if Same Surf is used instead of Tang Surf. Either can be used depending on the design intent. Once the surface is complete, you can create another parting surface to split the resulting volumes into core and cavity halves with an insert.
Example: Completing the Parting Surface

1. Select this edge.
2. Extend up to this datum plane.
3. Copy these two surfaces. Merge by Joining, and Extend All Edges up to the front of the workpiece.
4. Resulting mold volume (after splitting and extracting).

Extending the Skirt Parting Surface

About Customizing the Skirt Surface Extension
You can customize the Skirt surface extension in order to eliminate problematic areas in Skirt parting surface extension, such as overlapping geometry. For example, when the default direction of the extension causes self-intersection, you can change the extension direction so that the self-intersection is avoided.

The Extension Control dialog box allows you to do the following:
- Change the default extension direction of direction arrows that project from one or more curves that are used to create the Skirt parting surface.
- Create new extension control locations along the curves by creating datum points on the fly.
- Remove curve segments from being considered in the extension of the surface.
- Set one or more extension direction arrows to be tangent to bottom surfaces of the reference part.
Extension direction arrows become visible when you select **Extension Control** in the **Skirt Surface** dialog box. By default, these arrows emanate from vertices found along the curves. By creating new datum points or selecting existing ones along the curve, you can create more extension arrows. You can then select vertices and datum points individually, or several at a time, using **Pick Many**. Finally, you can set the new direction of the arrow by selecting planes, coordinate systems, edges or curves, and datum points to establish a new direction for the extension.

You can specify tangent conditions for selected curves. If neither extension directions nor tangent conditions are defined, each extended surface is normal to the light direction. If tangent conditions for some curve segments are specified, the surfaces that extend these curve segments will be tangent to the surfaces that are selected as the reference for tangent conditions.

Additionally, you can set the directions for extending the parting surface that is tangent to bottom surfaces of the reference part. If no direction is specified, each ruling for the extension is normal to the parting curve. If directions are specified and you look at the resulting surface from above, rulings at the surface points where directions are specified coincide with the directions.

**To Customize the Skirt Surface Extension**

Use the **Extension Control** dialog box as follows:

1. Click **Extension > Define** in the **Skirt Surface** dialog box. The **Extension Control** dialog box opens.

2. Click the **Extend Curves** tab. The **Include Curve** list shows all entities of the outer loop, that will extend. To exclude any of the curves, select the curve and click the double arrow to move it to the **Exclude Curve** list.

3. Click the **Tangent Conditions** tab. Select bottom surfaces of the reference part for setting the tangent conditions and automatically selecting silhouette curve segments that will be extended using this tangent condition. The **Include Curve** list shows all entities of the outer loop that will be extended using the tangent conditions. To exclude any of these curves, select the curve and click the double arrow to move it to the **Exclude Curve** list.

4. Click the **Extension Directions** tab. In the model that appears in the graphics window:
   - Curves excluded when using the **Extend Curves** tab appear in brown and are unavailable for applying extension directions.
   - Curves included when using the **Extend Curves** tab appear in cyan. Yellow arrows indicate the default direction for these curves. Magenta arrows indicate user-defined directions.
   - Curves included when using the **Tangent Conditions** tab appear in blue and are available for applying extension directions. Blue arrows indicate the directions of tangent extension.
5. Using the command buttons on the **Extension Directions** tab, add, remove, and redefine point sets in a silhouette curve and apply the direction for building the geometry of the extension. In the model that appears in the graphics window:
   - A magenta arrow indicates your selection when you assign a direction to a point.
   - A blue arrow doubled in length indicates the tangent direction corrected by your defined direction.

**Extending a Parting Surface Tangent to the Reference Part**
For parting curve segments that fully belong to the bottom surface of a reference part, you can create a skirt parting surface extension that is tangent to this surface.
- If no tangent conditions are defined, each extended surface will be normal to the light direction.
- If tangent conditions are specified for silhouette curve segments, the surfaces that extend these segments will be tangent to the bottom surface of the reference part. This bottom surface should be selected as the reference for tangent conditions.

**Transforming Casting Surfaces and Datum Curves**

**About Transforming Casting Surfaces and Datum Curves**
Transforming a surface enables you to translate, rotate, or mirror datum curves and surface features. You can manipulate the surface feature itself or its copy, leaving the original feature intact.

Surface features and datum curves can be selected in any combination. All entities selected together make one surface feature.

**To Mirror Surface Features**
Use the **Mirror** command to create mirrored surface features.
1. Click **SURF DEFINE > Transform > Mirror > Copy | No Copy > Done**.
2. Select the curves and surfaces to mirror.
3. Click **Done Sel**.
4. Select or create a datum plane about which to mirror the entities.
Example: Mirroring a Surface Feature Using Mirror and Copy

1. Select this plane.

2. Select this surface.

To Rotate Surface Features
Rotated surface features can have their rotation dimension modified. If the surface feature is created using No Copy, you must first select it using Sel By Menu.

1. Click SURF DEFINE > Transform > Move > Copy | No Copy > Done.

2. Select the curves and surfaces to rotate.

3. Click Done .

4. Click Rotate from the MOVE FEATURE menu.

5. Select or create a plane, curve, edge, axis, or coordinate system to which the direction of rotation is perpendicular. Use Flip or Okay to indicate the direction.

6. Specify the angle of rotation.

7. Click Done Move on the MOVE FEATURE menu to complete the rotation.
Example: Rotating a Surface Feature Using Rotate and Copy

1. Select this surface.

To Translate Surface Features
Translated surface features can have their translation dimension modified. If the surface feature was created using No Copy, you must first select it using Sel By Menu.
1. Click SURF DEFINE > Transform > Move > Copy | No Copy > Done.
2. Select the parting surface and click Done.
3. Select the curves and surface features to translate. The MOVE FEATURE menu appears.
4. Click Translate.
5. Select or create a plane, curve, edge, axis, or coordinate system that is normal to the direction in which the surface is moved.
6. Specify the distance for surface translation.
7. Click Done Move to complete the translation.
Example: Translating a Surface Feature

1. Select this surface.

Mold Volumes

Splitting to Volumes

About Splitting to Volumes
Instead of creating a volume, you can split the workpiece into one volume or two volumes using one of the following Split commands:

- **MOLD > Feature > Workpiece > Solid Split**
- **MOLD > Mold Volume > Split**

Features resulting from the splitting are created as assembly features.

Splitting does not alter workpiece or die block geometry. Whenever a workpiece or die block is split, the system copies the workpieces or die blocks into one or two volumes that you can then use in creating mold components or die blocks.

You can split the workpiece or die block, or a mold or cast volume using a surface, a parting surface, or a volume. You can specify that you want to ignore one of the volumes and create a volume to one side of the parting surface only.

How a Split Works
When you specify the parting surface to be used for splitting the workpieces or die blocks and select All Wrkpcs from the SPLIT VOLUME menu, Pro/ENGINEER:

- Calculates the volume of workpiece or die block material to one side of the parting surface
- Turns the split off volume into a mold or die volume
- Repeats the process for another side
This procedure also automatically subtracts the volume of the reference part(s) from the workpiece or die block. This subtraction is called trimming.

For mold or cast assemblies with multiple workpieces, you can select the workpiece or die block to split or select all of them. When the split is executed, all workpieces or die blocks selected are summed, and the split is carried out on the result.

When the workpieces or die blocks are split, their geometry is copied and the reference model and features are cut out of the copied geometry. Gates, runners, and sprues are also cut out if they are present. When the system calculates the split volume, all these cavities are taken into account.

**Example: Difference Between Create Vol and Split**

You can use the **MOLD > Mold Volume > Create** command or one of the **Split** commands to create a volume:

The difference between splitting the workpiece or die block into volumes and defining them using the **Create Vol** command is demonstrated in the following figure. When you define a volume, the mold component or die block is created by filling this whole volume with solid material regardless of any overlap with the reference model. When you split the workpiece or die block, the mold or die cavity remains. Once the split is created, there is no difference between the volumes obtained by those two methods.

1. Create Volume.
2. Split.

To create a volume by sketching (without trim):
1. Use **Extract > Make Solid** to create a volume.
2. Use **Split** (using this volume or Identical surface) and **Extract > Make Solid**.
As you split the workpiece or die block, the reference model is automatically cut out to create the mold or cast cavity.

Splitting the workpiece or die block with parting surfaces ensures that the mold components or die blocks add up to the desired volume, with no extra or missing pieces.

**To Split to One Volume**

Since volumes consist of datum surfaces, you can select a surface of a volume as a parting surface. In this case, you might want to calculate only one of the new volumes, since the other one (the one inside the surface) would coincide with the original volume.

1. Click **MOLD (CAST) > Mold Volume (Die Volume) > Split**.

2. Click **One Volume** on the **SPLIT VOLUME** menu. If any mold volumes are already defined, click **All Wrkpcs (All Die Bicks), Mold Volume (Die Volume)**, or **Sel Comp**.

3. Click **Done**. The **Split** dialog box opens.

4. Select an existing surface or volume to split.

5. If a failure occurs, click **Show Errors > Item Info**. The information window opens with the error message.

6. You can include or omit the highlighted volumes by clicking **Include** or **Omit**.

7. Specify the name of the new volume in the **Volume Name** dialog box.
Example: One-Component Split Followed by Two-Component Split

1. Create a volume.
2. Split workpiece or die block:
   - Select One Volume.
   - Select the volume.
   - Omit the volume.
   - Include the rest of the workpiece or dieblock.
3. Sketch an extruded parting surface and split the second volume into two components.

To Split into Two Volumes

You can use volumes to split workpieces, die blocks, or volumes. However, unlike parting surfaces, volumes do not modify existing geometry, they reproduce it. This reproduction of geometry enables you to perform a one-component (one volume) split. If a parting surface is used, the workpieces or die blocks are divided into two or more separate components. The one component split enables you to extract your
result without altering the workpiece or die block. You can modify the workpiece or die block later, or split it using a parting surface.

1. Click MOLD (CAST) > Mold Volume > Split (Split Die).

2. Click Two Volumes > Done on the SPLIT VOLUME menu.
   - If there are any volumes already defined, select All Wrkpcs (All Die Blcks), Mold Volume (Die Volume), or Sel Comp.
   - If you click Mold Volume (Die Volume), select a volume from the namelist menu.

3. Select one or more parting surfaces that completely intersect the workpiece or die block, or the selected volume.
   - Ensure that the surfaces you select, either by menu or by clicking on the screen, are unblanked first.
   - The parting surface is not be blanked.

4. Pro/ENGINEER computes the two new volumes, highlights each in turn, and prompts you to specify a name for each.

5. To turn the resulting volumes into solid mold components or die blocks, click MOLD COMP (DIE COMP) > Extract (Make Solid).

**Example: Splitting the Workpiece or Die Block**

1. Create a parting surface: sketch this parting line and extrude it.

2. Split the workpiece or die block, extract the components, and create the opening.

**To Split Using Multiple Parting Surfaces**

You can use multiple parting surfaces to split a workpiece or die block into multiple components.
1. Create the desired parting surfaces.

2. Click **MOLD (CAST) > Mold Volume > Split (Split Die)**. The **SPLIT VOLUME** menu appears.

3. Click **Two Volumes** to use the parting surface to split the workpiece into two components, or **One Volume** to perform a one component split.

4. Click **All Wrkpcs (All Die Blcks)** to split the workpiece or die block directly, or click **Mold Volume (Die Volume)** to perform the split upon a volume. Pro/ENGINEER trims the reference model from the workpiece or die block. The **Split** dialog box opens, listing elements of the split feature that need to be defined (the parting surface and the classification of the resulting volumes).

5. Select the parting surface that you want to use to split the workpiece or die block. The first volume that is created by the split is highlighted.

6. Specify a volume name. The second volume that is created by the split is highlighted.

7. Specify a volume name. The first split of the workpiece or die block is completed.

8. Repeat this procedure for another parting surface.

9. Specify the name of the volume to split. The **Split** dialog box opens.

10. Select the parting surface that you want to use to split the volume. The first volume created by the split is highlighted.

11. At the prompt, enter the name of the first volume. The second volume that is created by the split is highlighted.

12. At the prompt, enter the name of the second volume.

**Note:** A parting surface must intersect the workpiece or die block completely. It cannot intersect itself.

**The SPLIT VOLUME Menu**

When splitting a volume, the **SPLIT VOLUME** menu appears with the following commands:

- **Two Volumes**—Split the workpiece, die block, or volume into two volumes.
- **One Volume**—Split the workpiece, die block, or volume, but create only one volume.
- **All Wrkpcs**—Split the workpieces. The geometry of all workpieces is added together, and all reference part geometry is subtracted from that sum.
- **All Die Blcks**—Split the die blocks. The geometry of all die blocks is added together, and all reference part and sand core geometry are subtracted from that sum.
- **Mold Volume**—Split the volume.
• **Die Volume**—Split the volume.

• **Sel Comp**—Specify any part (other than the reference part) in the assembly to split.

**To Create a Solid Split**

1. Click **MOLD > Feature > Workpiece > Solid Split**. The **Solid Split Options** dialog box opens.

2. Select the **Cut by Reference Parts** check box to build the RefPart CutOut on the workpiece.

3. Select a method from the **Removed Material Options** list. Pro/ENGINEER creates islands out of the geometry of the original part, from which you can select the ones to keep in the original part. The system cuts out the ones that are not kept and creates a quilt from them.

4. Select **Don’t use** in the **Solid Split Options** dialog box if you do not want to use the quilt created from the cut-out islands.

5. To define split surfaces, a new volume, and classification of the volume, complete the following operations in the **Split** dialog box:
   a. Select one or more parting surfaces for splitting the workpiece.
   b. Select the islands you want to keep in the original part. To highlight the geometry of each island in the graphical display, drag the mouse over each island in the list that appears.

6. Depending on the option selected in the first step, do one of the following:
   o Select a component to which material will be added
   o Specify a name for the newly created solid
   o Specify a name for the newly created volume

**Creating a Solid Split**

Volume splitting does not alter workpiece or die block geometry. On the contrary, when you create a **Solid Split**, the system mainly does the following as it cuts the material from the workpiece or die block:

• Trims the reference model from the solid (if you set the **RefPart CutOut** split option)

• Intersects the split component by one or more parting surfaces. (You select any quilt as a parting surface, or you can proceed without selecting any quilt.)

• Creates islands in the original part as a result of the previous operations

From the islands that are created by these operations, you can select the islands to be kept in the original part. From the islands that are not kept in the original part, the system cuts out the geometry and creates a quilt. The system can use this quilt as follows:
• Add the quilt to an existing component as an **Extract** feature
• Create a new component and extract the quilt geometry into it
• Create a new volume
• Do nothing with the quilt

**Creating Advanced Features for Volume Splits**

For some types of volumes, you might need to create merge, cut out, or copy features to ensure a successful volume split. You can use the **Adv Util** option on the **MOLD MODEL** or **CAST MODEL** menu to create these features. You create these features in the same way as in Assembly mode.

**Note:** A reference part cannot be a result of **Merge** and **Cutout** operations.

Before performing the volume split, make sure that the new components have correct geometry and orientation.

You can reclassify a part or assembly component after a **Copy** operation.

**Understanding Split Failure Diagnostics**

**About Split Failure Diagnostic Messages**

Messages can appear while you are using the **Split** dialog box in Pro/ENGINEER.

If the Split function fails, messages appear in the Pro/ENGINEER window to describe and explain the failure and a recommended action to fix the failure. The **FEAT FAILED > Geom Check > SHOW ERRORS** menu appears and lets you view the messages. Choices on this menu are **Feature Info**, **Item Info**, **Hide Item**, and **Done**.

**To Create Intersection Curves**

Create datum curves from the green intersection curves for further analysis of the intersection.

1. Click **Feat Failed > Redefine**. The **SEL ELEMENT** menu appears.
2. In the **Split** dialog box, click **Geom Option** and **Define**. The **GEOM OPTION** menu appears.
3. Click **Make Curves**. This selection creates the reference curve and saves it as an assembly feature.

   If there are gaps in the curves, datum points are automatically created at the endpoints of curves so that you can easily identify gap endpoints.

**Note:** If you click **GEOM OPTION > Make Volume**, the split redefine process will continue.
The Split Dialog Box

Use the Split dialog box with the Geom Option command to help you resolve split failures.

The Split dialog box contains:

<table>
<thead>
<tr>
<th>Element</th>
<th>Info</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split Srfs</td>
<td>Defined</td>
</tr>
<tr>
<td>Geom Option</td>
<td>Make Volume</td>
</tr>
<tr>
<td>Classify</td>
<td>Defining</td>
</tr>
</tbody>
</table>

If you click Geom Option and OK, the GEOM OPTION menu appears.

- **Make Volume**—Lets you create a volume when a split fails.
- **Make Curves**—Lets you create the intersection curves as datum curves when a split fails.

Split Failure Message 1

**Message Explanation**
Complete intersection of the parting geometry with the mold volume has failed. The parting geometry does not divide the mold volume completely.

**Display Explanation**
The display explanation describes the view of your failed split and references the actual view of the failed split. See the example here.

**Message**
The split feature has failed due to intersection problems (most likely gaps) somewhere along the green, highlighted, intersection curves. The red points indicate gap endpoints on the green curves.
**Recommended Actions**

1. Examine the green intersection curves. Any gaps, indicated by red endpoints, or irregular geometry found along the curves, can be the problem areas.

2. Set absolute accuracy with **ASSEM SETUP > Accuracy**.

3. Check your config.pro file and verify that **absolute_accuracy** is set to **yes** and **accuracy_lower_bound** is set to **value**.
   - Set the value low enough to allow the regeneration of all models at the necessary absolute accuracy.
   - Set all of the components in your mold (.mfg) assembly as well as the mold assembly file itself to the absolute accuracy value of the design part.

4. If the use of absolute accuracy does not resolve the failure, redefine the parting geometry or the reference part so that complete intersection is possible.

5. Create datum curves from the green intersection curves for further analysis of the intersection. Use **Geom Option > Make Curves** in the **Split** dialog box and click **OK**.

6. When you resolve the problem, set **Geom Option > Make Volume** to create the actual volumes instead of curves.

7. Check parting surface contours using **Mold Check > PartSurfCheck**.
Split Failure Message 2

Message Explanation
Intersection succeeds, but only one volume is created. The parting geometry does not divide the mold volume completely.

Display Explanation
The green curves show a hole in the parting geometry (parting surface or parting mold volume) that needs to be filled.

Message
Split feature has failed. The volume cannot be split due to a hole in the parting surface. The hole is highlighted in green.

Recommended Actions
Redefine the parting surface to patch the hole.

Split Failure Message 3

Message Explanation
Intersection succeeds, but only one volume is created.
Display Explanation

The problem area is located somewhere along the cyan curve with the red points, which indicate the end of the curve. The cyan curve represents a possible path from one side of the parting geometry to the other, which indicates a hole in the reference part.

Message

Split feature has failed. The volume cannot be split for one of the following reasons:

- A hole in the reference part is not closed off by the parting surface
- The gap between the reference part and the workpiece has not been closed off by a single parting surface quilt.

The hole or gap is located somewhere along the cyan curve with red endpoints. The curve starts at one side of the parting surface, goes through the hole or gap, and ends at the other side of the parting surface.

Recommended Actions

1. Redefine the parting surface and create geometry to close the hole or bridge the gap.
2. If you use multiple parting surface quilts to bridge the gap, merge the parting surfaces into one quilt.
Split Failure Message 4

Message Explanation
Volume and parting surface do not intersect.

Display Explanation
None.

Message
Split feature has failed. The Parting Surface does not intersect the volume anywhere.

Recommended Actions
Fix the parting surface so that it correctly intersects the volume.

Classifying Volumes

About Classifying Volumes
Pro/MOLDESIGN and Pro/CASTING create a maximum of two volumes when a workpiece or die block is split. If you use a complex parting surface for splitting, and that parting surface divides the workpiece or die block into more than two portions, the system prompts you to classify the resulting volumes by including the volume you want to create and excluding the volumes you do not want. Classification is the process by which a volume that is created during such a split is assigned to one of the two volumes (the core or the cavity) that finally result from the split.

After you select the parting surface and the resulting volumes are calculated, the SPL CLASS menu appears with the following commands:

- **First Vol**—Assign the highlighted region to the first mold volume.
- **Second Vol**—Assign the highlighted region to the second mold volume.

If you are creating only a single volume (one-component split), the SPL CLASS menu contains the following commands:

- **Include Vol**—Assign the highlighted region to the mold volume.
- **Omit Vol**—Indicate that the highlighted region is not included in the mold volume.

If you begin to redefine a classified volume, the Split dialog box opens with the following commands:

- **Split Srfs**—Redefine the parting surface used to create the volumes. Selecting this command also selects **Classify**.
- **Geom Option**—Creates a volume or intersection curves to resolve split failures.
- **Classify**—Redefine the classification of volumes in the workpiece.

During redefinition, **Same** is included in the **SPL CLASS** menu, enabling you to indicate that the highlighted region should remain classified as it was prior to redefinition.

**To Classify Volumes to the Core or Cavity**

1. Click **MOLD > Mold Volume > Split**. The **SPLIT VOLUME** menu appears.
2. Click **SPLIT VOLUME > Two Volumes** or **One Volume** and **Done**. The **Split** dialog box opens.
3. Click **Classify** after you define the **Split Sfrs** element.
   
   If there are any errors in the split you create, the **Troubleshooter** dialog box opens. You must resolve the errors before you can continue.
4. If the split that you create is successful, the **ISLAND LIST** menu appears. Each island corresponds to a mold volume, upper or lower. When you pass the pointer over the **ISLAND LIST**, the color of the corresponding mold volume changes.
5. After the volumes are classified, extract the mold components or die blocks by clicking **Mold Comp > Extract**.

**Improving Split Classification**

When you split a mold by parting surface or by volume, a significant number of volumes is created. You must classify (assign) each of these volumes to the core or the cavity of the mold. The **ISLAND LIST** dialog box lets you select these volumes by checking a box. You can select an individual island or all the islands with the **Select All** menu command. When you bring the cursor over a specific island in the list, the corresponding volume in the Pro/ENGINEER window highlights in red.
1. Workpiece or die block.
2. Reference model.
3. Parting the surface (intersects the workpiece or die block multiple times).

When the workpiece or die block is split using this parting surface, it is divided into five portions. Each portion must be classified, or assigned to one of the two volumes that results from the split.

**Creating Volumes**

**About Creating and Defining a Volume**

A mold or die volume has no solid material. It consists of surfaces that locate a closed volume of space in the workpiece model or die block. Volumes are intermediate steps in proceeding from the workpiece or die block and reference model geometry to the final extract components.

You create mold components and die blocks by building volumes, and then filling the volumes with solid material to turn the volumes into fully functional Pro/ENGINEER parts. You can also create internal cavities, or sand cores, in a casting.

To define a single volume, you can:
- Reference the geometry of the design model
- Sketch a volume to be added or excluded
- Intersect the volume with the reference model
Offset surfaces

You can use one or more features, including:

- Selecting a mold base and its parameters
- Trimming the reference model out of the volume
- Splitting the workpiece (or dieblock) into another volume

**To Create and Define a Volume**

1. Click **MOLD (CAST) > Mold Volume (Die Volume)**. The **MOLD VOLUME** menu appears.
2. Click **Create** and specify a name for the mold volume in the **VOLUME NAME** dialog box. The **MOLD VOL** menu appears.
3. After defining the volume, you can perform various functions on it such as name, blank, or shade the workpiece (or die block) individually without relying on layer functionality.

**To Create a Constant Radius Round**

As a refining touch, you can create rounds on volume edges.

1. Click **MOLD VOLUME > Modify**. The **MOD VOL** menu appears and the **ROUND: General** dialog box opens.
2. Select a volume from the **Search Tool** dialog box.
3. Click **MOD VOL > Round**. The **ROUND TYPE** menu appears.
4. Select the type of round as **Simple** or **Advanced** and specify the attributes of the round.
5. Specify the round radius and click **OK** on the **ROUND: General** dialog box.

**Operating on Components**

**About Operating on Mold Components**

You can use a defined mold volume to create a solid part and cut away a workpiece component.

**To Create a Solid Part**

To create a solid part for a Mold or Cast, do one of the following:

- Click **Die Comp > Make Solid** on the **CAST** menu.
- Click **Mold Comp > Extract** on the **MOLD** menu.
About Shadow Cut Out
Use the Shdw Cut Out command to cut away a workpiece or die block component above or below the shadow surface opposite to the light direction.

To Cut Away a Workpiece Component
The Shdw Cut Out command allows you to cut away a workpiece or die block component above or below the shadow surface opposite to the light direction.

1. On the MOLD (CAST) menu, click Mold Comp (Die Comp) > Shdw Cut Out.
2. Specify a single workpiece or die block part for trimming. The CUT: Use Quilt dialog box opens.
3. Specify the shadow parting surface to use for the cut.
4. Pro/ENGINEER displays the DIRECTION menu and an arrow that points toward the area to be removed. Click Flip or Okay.
5. Click Preview to preview the feature geometry.
6. Click OK. Pro/ENGINEER cuts away the indicated portion of the workpiece or die block.

Gathering Volumes

About Gathering Volumes
Gathering allows you to copy surfaces and reference edges of the design model.

To Gather a Volume
1. Click MOLD (CAST) > Mold Volume > Create > Gather > Define.
2. In the GATHER STEPS menu, click the check boxes that apply.
   - Select—Select surfaces or features from the ref part
   - Exclude—Exclude loops of edges or surfaces from the volume definition
   - Fill—Fill inner contours or holes on surfaces in volume
   - Close—Close the gathered volume by specifying Top Surf or Bottom
3. Click Surf & Bnd or Surfaces.
4. Add the FEATURE REFS using the Select menu.
5. Close the volume by specifying its end loop. The volume is created by extruding the base quilt up to the top surface. You also have an option to extrude some of the edges downward.
6. If you click **Select** for the first time, the **GATHER SEL** menu appears. Once the gather references have been selected, click **Select**. The **GATHER SPEC** menu appears with the following:

   - **Type**—Respecify the type (for example, **Surf & Bnd** instead of **Surfaces**). Whenever you change the type, Pro/ENGINEER prompts for confirmation.
   - **References**—Reselect the feature references. This brings up the **SURF BND** menu if the gather type is **Surf & Bnd**, and the **FEATURE REFS** menu in all other cases.

**Tip: Combining Sketch and Gather**

You can use **Sketch** after gathering part references to extend the volume, or to exclude some areas.

**To Select Surface Types**

1. Click **Select** on the **GATHER STEPS** menu to select reference surfaces for gathering the volume. There are two ways to select reference surfaces:

   - **Surf & Bnd**—Select one surface to be the seed surface for the feature, and then select the bounding surfaces. The system includes the selected surface and all its neighboring surfaces until the ones selected as bounding.
   - **Surfaces**—Explicitly select a set of continuous surfaces. The system includes all the selected surfaces.

**Surf & Bnd** and **Surfaces** are mutually exclusive methods of selecting surfaces. If you select either command from the **GATHER SEL** menu, the previous selections are discarded.

All surfaces included in the volume definition are "sewn" together to form a single quilt, which you can modify later using **Exclude** and **Fill**. The commands available and modification techniques depend on the way of selecting surfaces.

2. When you select **Surf & Bnd** as the gather type, the **SURF BND** menu appears with the following commands:

   - **Seed Surface**—Select a seed surface. If a seed surface has already been selected, the system prompts you to confirm your selection if you try to select a different one.
   - **Bndry Srfs**—Select bounding surfaces using the **FEATURE REFS** menu commands.
   - **Bndry Loops**—Select bounding loops using the **FEATURE REFS** menu commands.

3. When you select **Surfaces** as the gather type, or when you begin selecting bounding surfaces, the **FEATURE REFS** menu appears with the following:
Pro/MOLDESIGN and Pro/CASTING

- **Add**—Select additional references (this is the only command available when you start defining the volume or surface).
- **Remove**—Clear some of the references. Select surfaces or loops you want to clear.
- **Remove All**—Clear all references of the current type. For example, if **Bndry Srfs** is highlighted, click **Remove All** to clear the definition of bounding surfaces.

### Example: Selecting Surfaces

![Diagram showing surfaces selection]

Select the surfaces:

1. Central plane and both halves of the cone
2. Top surface (workpiece or die block)
3. Volume

### Selecting Surfaces

If the gather references for a mold volume have been selected already, and **Select** is chosen from the **GATHER STEPS** menu a second time, the **GATHER SPEC** menu, with the commands **Type** and **References**, appears, rather than the **GATHER SEL** menu. You can then reselect the type—**Surf & Bnd** or **Surface**—and the reference surfaces.

### The OFFSET Menu

You can extend a gathered or sketched volume by an offset, with the following on the **OPTIONS** menu:

- **Horizontal**—Offset edges of the volume in the direction normal to the selected surface that is being offset.
- **Tangential**—Offset edges of the volume tangent to the selected surface that is being offset.
Example: Selecting Surf & Bnd

1. Select bounding surface as shown in 1.
2. Select seed surface as shown in 2.
3. Top surface (workpiece or die block) is shown in 3.
4. Volume is shown in 4.
5. Select bounding surfaces (a, b, and c) using Query Sel as shown in 5.

Excluding Surfaces and Outer Loops

About Excluding Surfaces and Outer Loops

For each method of gathering a volume, you can selectively exclude some loops or edges from the definition of the volume:

<table>
<thead>
<tr>
<th>Gathering Method</th>
<th>Option for Excluding Loops or Edges</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surf &amp; Bnd</td>
<td>Bndry Loops in SURF BND menu</td>
</tr>
<tr>
<td>Surfaces</td>
<td>Exclude in GATHER STEPS menu</td>
</tr>
</tbody>
</table>

The Bndry Loops command, available only if you gather using the Surf & Bnd option, appears in the SURF BND menu. Use Surf & Bnd after you have selected bounding surfaces for the volume. After choosing Bndry Loops, select any edges from the bounding surface that you want to exclude from the volume definition.

The Exclude command, available only if you gather using the Surfaces command, causes the GATHER EXCL menu to appear with the following commands:
- **Surfaces**—Exclude some of the selected surfaces by selecting each of them individually.

- **Loops**—Exclude outer loops. Use this option to delete unwanted portions of surfaces selected for gathering.

**Example: Excluding Outer Loops**

1. Select the multiple surfaces of the cylinder as shown in 1.
2. Select the top surface of the cylinder as shown in 2.
3. Click **Exclude > Loops** and select the edge of the outer cylinder volume as shown in 3.

**Filling Inner Loops**

**About Filling Inner Loops in a Volume**

Filling an inner loop of edges on a surface selected for gathering is equivalent to "patching" the base quilt of the mold volume. The volume is built as if there were a smooth surface with no perforations.

**To Fill Inner Loops**

1. Click **Fill** on the **GATHER STEPS** menu. The **GATHER FILL** menu appears. The following are available:
   - **All**—Fill all loops on a selected surface.
Loops—Select loops to be filled. For each loop to be filled, you have to select only one edge. If you gather using Surf & Bnd, the edges must lie on the bounding surfaces.

2. Select a surface. All inner loops on this surface are filled, whether they belong to bounding surfaces or not.

Closing the Volume

About Closing the Volume
Click GATHER STEPS > Close to give the system final instructions on how to gather the volume. Close enables you to specify how a volume should be capped or enclosed, as well as whether to close internal loops in the volume such as hole openings in bounding surfaces. When you define a mold volume, the menu for closure appears automatically after you indicate that you have completed defining the volume. Once you have specified the closure instructions, the Close command appears in the GATHER STEPS or VOL GATHER menu, enabling you to redefine or delete the closure instructions.

To Close a Volume
1. On the CLOSE LOOP menu, click Define. The CLOSURE menu appears.
2. Select one or more of the following from the CLOSURE menu:
   - Select or create a Cap Plane (to which the volume is closed).
   - All Loops—Select all holes in selected surfaces to close
   - Sel Loops—Select holes by selecting bounding loops to close
3. Click Done when you are satisfied with the closure.
4. Click Done/ Return on the CLOSE LOOP menu to complete the closure.

The Close Loop Menu
The CLOSE LOOP menu contains the following commands:
- Define—Define closure instructions for the volume.
- Delete—Remove the closure instructions for the volume.
- Redefine—Redefine a closure instruction.
- Show—Display the closures on the current volume.

The CLOSURE check boxes specify how the current volume should be enclosed.
- Cap Plane—Specify a plane to "seal off" or enclose the volume.
- All Loops—Seal the openings of all holes in a selected surface.
- Sel Loops—Seal the openings of selected holes in a selected surface.
While other referenced geometry necessarily has to belong to the reference model, (the workpiece or die block geometry is not available for the first two steps or bottom edges), the cap plane can be any planar surface or datum plane. You can select a plane that belongs to the workpiece or the reference model, or create a datum plane by clicking **Make Datum** on the **SETUP PLANE** menu.

**Example: Specifying Closure Instructions**

1. Click **Surf & Bnd** and select the seed surface.
2. Select the top and the bottom as bounding surfaces.
3. Click **Sel Loops** and select this edge.
4. Click **Cap Plane** and select this surface on the workpiece.
   a. **Volume**.
   b. The volume is created all the way down to the bottom of the feature.

**Displaying the Volume Definition**

**About Displaying the Volume Definition**

The **Show Volume** command allows you to check the current volume definition, to see if you need to exclude more loops, close differently, and so on. The volume appears in magenta. As you gather more references, the volume shows changes.

**To Display the Volume Definition**

1. Click **VOL GATHER > Show Volume** to display the gathered volume.
2. To view the changes, repaint the screen and click **Show Volume** again.
3. After you click **Done** on the **VOL GATHER** menu, the volume you have defined appears in magenta.

4. You can add and remove elements of volume using **Sketch**, offset the sides, round some edges, and so on.

   When regenerating, the system treats each "chunk" of volume as a separate feature. For example, if you gather references, add a sketched volume, and offset walls, three features are added.

### Cutting Out Reference Parts of a Volume

#### About RefPart Cutout of a Volume

When you define a volume by sketching, you can take up some of the reference part volume. When creating the component or die block, the system fills with solid material all the indicated volume as it is defined. Therefore, in order to correctly define the component or die block geometry, you must be able to subtract the volume of the reference model from the component or die block volume.

To cut out the reference model volume from a sketched volume, use the **Ref Part Cutout** command in the **MOLD VOL** menu for molds, or the **COMP VOL** menu for casts.

#### To Cut Out Reference Parts of a Volume

Click **MOLD VOL > Ref Part Cutout**.

When you click **Ref Part Cutout**, the system automatically subtracts the reference model from the current volume definition. Only the remaining volume is considered.

#### Tip: On Cutting Out Reference Parts of a Volume

- After the cutout without additional modifications to the volume, the system makes the **Ref Part Cutout** option unavailable; therefore, you cannot cut out a volume twice.

- When more than one reference part is present, the system prompts you to select one.

- Do not use **Ref Part Cutout** after defining the volume by gathering, because **Ref Part Cutout** uses the same references as **Gather** does, so no changes take place.
Example: Using Sketch and Ref Part Cutout

1. Sketching plane
2. Sketch and Align
3. Use Edge
4. Sketch Line
5. Volume after Sketch
6. Volume after Ref Part Cutout
7. Component created by this volume

To Create An Attach Volume Feature

Use attach volume features to annex one volume to another to create a combined volume. When two volumes are attached, they behave as a single volume.

1. Click **MOLD (CAST) > Mold Comp (Die Comp) > Attach**.
2. Select from the displayed menu the name of the base (first) volume.
3. Select from the displayed menu the name of the volume to attach to the first volume.

   Pro/ENGINEER updates the display to show the union of the first and second volumes. The new volume has the name of the first (base) volume that was selected; the second volume is consumed. You can add additional volumes.

4. Click **Done Attach** when you are finished attaching mold volumes.

An attach volume feature belongs to the mold assembly level. It looks for mold volumes at assembly level for attachment. You can also split an attach volume feature.
Sketching Volumes

To Sketch a Volume
You can define a volume by sketching, similar to the way you create regular features (protrusions and cuts) in Pro/ENGINEER. If you click Sketch from the MOLD VOL menu, the sketched volume is added automatically. If a volume is already present in the current definition, you must specify if you want to Add or Remove the volume you are about to sketch.

You can define the whole volume by sketching, or combine sketching with other tools, such as Gather or Trim.

1. Click MOLD (CAST) > Mold Volume (Die Volume) > Create. Specify a name for the volume.
2. Click MOLD VOL > Sketch. The SOLID OPTS menu appears.
3. If a volume is already present in the current definition, click Add to add a protrusion to the current volume or Remove to subtract the sketched volume from the current volume (as a cut). If no volume is present, a volume protrusion is automatically created.
4. Select one of the following from the SOLID OPTS menu:
   o Extrude—Create a feature which is formed by projecting the section straight away from the sketching plane.
   o Revolve—Create a feature by revolving the sketched section around a centerline from the sketching plane into the part.
   o Sweep—Create a feature by sketching a trajectory and then sweeping a cross section along it.
   o Blend—Create a feature that consists of a set of planar sections which are connected by transition surfaces to form a solid.
   o Use Quilt—Create a feature by referencing a surface feature.
   o Advanced—Create a complex shape feature, for example, using datum curves or multiple trajectories.
   o Solid—Create a solid geometry. Default for the above forms.
   o Thin—Create a thin feature.
5. Specify attributes appropriate for the selected form, such as depth option and degrees of rotation.
6. Specify or create the sketching plane, select the feature direction, and specify the sketcher reference plane.
7. Sketch the section. Volume sections are sketched the same as are regular features (protrusions and cuts). Sketched entities can be aligned and dimensioned both to part geometry and to the entities of other volume elements.
8. Regenerate and click Done. The volume is added or subtracted. You can use Sketch as many times as you like within a single volume definition.

The OFFSET Menu
You can extend a gathered or sketched volume by an offset, with the following on the OPTIONS menu:
- **Horizontal**—Offset edges of the volume in the direction normal to the selected surface that is being offset.
- **Tangential**—Offset edges of the volume tangent to the selected surface that is being offset.

Modifying Volumes

To Modify a Volume
1. Click MOLD (CAST) > Mold Volume. The MOLD VOLUME menu appears.
2. Select the name of the volume from the name list menu. The current volume definition appears in magenta.
3. Use commands from the MOLD VOLUME menu to change the volume as desired.
   - You can turn off the display of any volume defined for the model using Blank on the MOLD VOLUME menu.
   - You can display blanked volumes later by using Unblank. In addition, you can display a volume in solid color using Shade on the MOLD VOLUME menu.

In order to be selectable, the volume must be displayed. Unblank it first.

To Reorder a Volume
Click MOLD > Feature > Cavity Assem > Feature Oper > Reorder.
Reorder moves the entire set of features included in the volume to the specified position in the workpiece or die block feature sequence.

To Rename a Volume
1. Unblank the volume that you want to rename.
2. Click Edit > Set Up > Name > Other.
3. Select the volume and specify a new name. The volume is renamed.

**Note:** Changing the name of the base feature of a volume does not change the name of the corresponding volume.
To Rename a Mold or Die Volume
Changing the name of a mold or die volume does not affect the name of a mold component or die block that has already been extracted from the volume. The associativity between the component or die block and the volume still exists, even if the names are different. However, if you want the names to correspond:
1. If the component or die block has not been stored, delete it and extract again.
2. If it has been stored, retrieve it in Part mode (with the mold model in session), rename the part, and store the mold or cast model.

To Blank or Unblank a Volume
1. Click the Blank-Unblank icon on the menu bar or click MOLD VOLUME > Blank.
2. Select the volume that you want to blank. Pro/ENGINEER blanks the selected volume.
3. To unblank a volume, click MOLD VOLUME > Unblank. The Names dialog box opens and lists all the volumes.
4. Select the volume name that you want to blank and click OK. The color of the volume you select changes.

You can also blank or unblank a volume as follows:
3. Under Visible Volumes, click the name of the volume you want to blank and click Blank. The volume color changes.
4. To unblank a volume click the Unblank tab, select the name of the volume, and click Unblank.

To Shade a Volume
1. Click Mold Volume > Shade and select the volume that you want to shade. Pro/ENGINEER shades the volume you select.
2. Click CntVolSel > Continue to shade other volumes.

To Trim a Volume
1. Click MOLD > Mold Volume > Modify. The MOLD VOL menu appears.
2. Click Trim to Geom. The TRIM TO GEOM dialog box opens.
3. Use the TRIM TO GEOM dialog box to trim the volume.
To Replace a Mold Volume Surface

1. Use the **MOLD > Mold Volume > Modify** command to open the **Sel by Menu** dialog box, in which you can select a mold volume on which you are replacing a surface.

2. In the **MOLD > Mold Volume** menu, click **Replace Surface**. The **REPLACED SURFACE** dialog box opens with **Replace Surf** selected in a **Defining** status.

3. On the mold volume in the graphic display, select the surface that is to be replaced, and then click **Accept** in the **Query Bin** dialog box. The **REPLACED SURFACE** dialog box shows:
   - **Replace** in a **Defined** status
   - **Quilt** selected in a **Defining** status

4. On the mold model assembly in the graphic display, select the quilt surface that is to replace the previously selected volume surface, and then click **Accept** in the **Query Bin** dialog box.

5. In the **REPLACED SURFACE** dialog box, click **OK**.

The graphic display shows the volume surface replaced with the quilt surface geometry.

**Sliders**

**About Sliders**

Slider components in Mold design are used to form undercuts in the final product. During mold opening and closing, sliders may move in from a side to create the necessary shape and facilitate ejecting the part.

The process of slider creation consists of the following steps:

1. The system performs geometry analysis, based on the given Pull Direction, to identify the black volumes. Black volumes are undercuts in the reference part, that is, areas that would generate trapped material during mold opening, unless a slider is created. They are defined as areas of the reference part where a light shining in the Pull Direction, and in the opposite direction, does not reach.

2. When the system identifies and displays all the black volumes, you select a volume or group of volumes to be included in a single slider.

3. You specify the projection plane. The system extends the selected black volumes up to the projection plane, in the direction normal to the plane. This is the final slider geometry.

You can create a slider as a Mold Volume and then extract it to create a Mold Component. Or you can create a slider as a feature of a mold base component, such as a cavity insert.

You can create sliders in Casting as well, using similar techniques.
To Create a Slider
You can create a slider as a Mold Volume or as a Mold Feature.

1. On the MOLD (CAST) menu, click Mold Volume (Die Volume) > Create and specify the volume name. The MOLD VOLUME (DIE VOLUME) menu appears.

2. Click Slider. The Slider Volume dialog box opens.

   **Note:** You can also access the Slider Volume dialog box by clicking MOLD (CAST) > Feature (Cast Feature) > Workpiece (Die Block) > Slider.

3. If your mold model has only one reference part, its name is selected and displayed in the Reference Part text box of the dialog box. Otherwise, because you can select only one part, select a reference part to check for undercuts.

4. If you have already defined the Pull Direction for your model, it is selected automatically. You can select a different Pull Direction by clearing the Use Default check box and specifying a Pull Direction using a plane, edge, axis, or coordinate system. You also have to specify Pull Direction if it has not been defined in your model prior to creating a slider.

5. Click Calculate Undercut Boundaries. The system performs geometry analysis by shining a light on the reference part in the Pull Direction. The areas where the light does not reach are undercuts, or black volumes. After the check is complete, the system generates default names for the boundaries of the black volumes (such as Quilt 1) and displays the boundary quilts of the volumes in purple, while placing their names in the Exclude list of the Slider Volume dialog box.

6. Select a boundary quilt or quilts to be used for creating a slider by moving their names into the Include list. When you place your cursor over a quilt name, its edges are highlighted in dark red. For better visibility, you can also select a quilt name and click  to mesh the corresponding boundary surface, or click  to shade it.

   To move a quilt name, select it in the Exclude list and click <<. The quilt name moves into the Include list. Once you move a quilt name into the Include list, its edges are displayed in blue.

7. Select a projection plane to define the slider extension. At the time of feature creation, the system extends the black volumes whose boundary quilts are listed in the Include list up to the projection plane, in the direction normal to the plane.

8. Click  to preview the slider geometry. In some cases, the system is unable to generate the extension. It then issues a message and gives you an option to deselect the projection plane (using the button) and create a slider volume based on the undercut geometry. Later, you can manually manipulate this slider volume, as any other Mold Volume, to create a slider component.

9. Click  when satisfied with the slider geometry. Clicking  cancels the slider creation.
Using the Slider Functionality
You can create a slider as a Mold Volume or as a solid feature of a mold base component.

To create a slider as a Mold Volume:
1. Create a Mold Volume, or select an existing Mold Volume and click **Modify**.
2. On the **MOLD VOLUME (DIE VOLUME)** menu, click **Slider**.
3. Specify the black volumes you want to include in the slider geometry.
4. Optionally, you can select a planar surface, such as the side of the workpiece, as the projection plane. If you are modifying an existing volume, make sure the projection plane lies inside the volume being modified (so that the slider is connected to the Mold Volume). The system creates the slider as a Mold Volume.
5. You can use any Mold Volume operations on the slider, as needed.
6. Extract the Mold Volume to create a slider component.

Dealing with Slider Extension Failure
When you select the black volumes to be included in the slider geometry and specify the projection plane, the system tries to extend the selected black volumes up to the plane, in the direction normal to it. Depending on the black volume geometry, and on the location of the projection plane, sometimes the system is unable to generate the extension. In this case, the system issues an error message that the boundaries could not be extended, and gives you an option to create a slider volume based on the undercut geometry without the extension.

To create a slider if the boundary extension fails:
1. Create the slider as a Mold Volume.
2. When the boundary extension fails, click **X** under **Projection Plane** to deselect the projection plane.
3. Click **✓** to create the slider volume based on the undercut geometry.
4. Use the standard Mold Volume operations, such as **Sketch** or **Trim To Geom**, to extend the slider volume as needed.
5. Extract the final volume to create a slider component.

Example: Creating a Slider
The model where you are going to create a slider is shown in the following illustration. It contains one reference part, with the Pull Direction defined as shown.
1. On the **MOLD** menu, click **Mold Volume > Create**, type *slider1* as Mold Volume name and click **OK**. On the **MOLD VOLUME** menu, click **Slider**. The **Slider Volume** dialog box opens. The reference part and the Pull Direction are selected automatically.

2. Click **Calculate Undercut Boundaries**. The system identifies the two black volumes, lists *Quilt 1* and *Quilt 2* in the **SLIDER VOLUME** dialog box, and displays the boundary quilts in purple, as shown in the following illustration.

3. Select *Quilt 1* in the **Exclude** list (the corresponding boundary quilt is highlighted in dark red) and click **<<**. The system displays the included boundary
quilt in blue, as shown in the next illustration.

4. Click under **Projection Plane** and select the side surface of the workpiece (highlighted in red in the following illustration) as the projection plane.

5. Click . The system displays the slider geometry, as shown in the following illustration. Click to create the slider.
Repeat the procedure to create a second slider for the black volume on the other side.

**Example: Selecting a Projection Plane for a Slider**

The projection plane determines the pull direction of a slider. Select the projection plane so that the slider volume can be pulled out of the reference part in the direction normal to the projection plane.

The following schematics show examples of the correct placement of the projection plane.

1. Reference part
2. Slider
3. Projection plane

The next schematics show examples of incorrect placement of the projection plane.
Extracting Mold Components

About Extracting Mold Components or Die Blocks

Mold components or die blocks are produced by filling previously defined mold volumes with solid material. This process, performed automatically, is called extracting.

An extract feature looks for mold or die volumes at the assembly level for extraction into parts. When a split results in more than two volumes, the system prompts you to classify the extracted part as belonging to one volume or another.

Once extracted, the mold components or die blocks are fully functional Pro/ENGINEER parts; they can be retrieved in Part mode, used in drawings, machined with Pro/NC. New features can be added, such as chamfers, rounds, cooling passages, draft, gating, and runners.

To Extract a Mold Component or Die Block

1. Click MOLD (CAST) > Mold Comp (Die Comp) > Extract (Make Solid). The Create Mold Component dialog box opens.
2. Click the name of the mold volume (die block) to extract and click OK.
3. The system fills the designated volume with solid material. The component (die block) appears in white. The name of the resulting part is the same as the name of the volume. This name appears in the Model Tree. If a part with this name

1. Reference part
2. Slider
3. Projection plane
already exists in active memory, the system prompts you to select another name for the component.

An extracted component or die block retains associativity with the parent volume; if the volume is modified, the component or die block is updated when the mold model is regenerated.

To display the dimensions of an extracted component or die block in any Pro/ENGINEER mode click **Query Sel** to select geometry that references the reference model.

**Example: Extracting a Component or Die Block**

1. Split the component or die block.
2. Extract the component or die block.
3. Extracted component or die block (displays in white).

**Sand Cores**

**About Sand Cores**

Sand cores are used to produce internal cavities in a casting.

**To Create a Sand Core Using Pro/CASTING**

1. On the **CAST** menu, click **Cast Model > Create > Sand Core**. The **Component Create** dialog box opens.
2. Specify the type of sand core to create.
3. Click **Gather Vol**.
4. From the **VOLUME TYPE** menu, select either **Solid Volume** or **Surf Volume**, depending on whether you want the sand core to be created as solid or surface geometry.
5. Follow the techniques described to gather the volume, fill inner loops, and close the volume.
Tip: Splitting Sand Cores
To split a sand core, create multiple parting surfaces, and then use the Use Quilt command to make solid cuts in the sand core.

Working with Mold or Cast Results

About Creating the Mold or Cast Result
Once all the volumes have been defined, you can extract them from the workpiece or die block to produce mold components or solidified die blocks. You can also create the molding or the cast result by filling the mold or cast cavity through the sprue, runners, and gates. You need not extract all volumes; sometimes you can produce intermediate volumes.

To Create a Mold or Cast Result
This step allows you to produce a real molding or cast result by filling the mold or die cavity, as it is currently defined through the sprue, runners, and gates, with the molten material.

Note: The molding or cast result may be created only after the extract components or die blocks have been created.

The result is created by determining the volume remaining in the workpiece after subtracting the extracts. It can then be brought into Pro/NC to remove excess material; or brought into Part mode, where you can calculate its mass properties, check for suitable draft, and generate a mesh (FEM) for flow analysis.

The molding or cast result is computed using the following formula:

\[ \text{molding or cast result} = (\text{sum of all current workpiece or die block geometry} - \text{assembly level cuts that intersect workpiece or die block} - \text{all extracted parts} - \text{ejector pin clearance holes}) \]

1. For a mold assembly, click MOLD > Molding > Create.

   There can only be one molding part in the model at a time, so Create and Delete appear depending on the current status of the molding. See How to Delete an Existing Molding or Cast Result.

   For a cast assembly, click CAST > Cast Model > Create > Cast Result.

2. Enter the name of the molding or cast result. The molding or cast result is created.

To Delete a Mold or Cast Result
1. For a mold assembly, click MOLD > Mold Model > Delete.

   For a cast assembly, click CAST > Cast Model > Delete > Cast Result.

2. Confirm your request to delete the molding or cast result by entering y in response to the prompt.
If the molding or cast result has already been stored, the part file is not deleted by this operation. Use the appropriate file management command to delete the part from the database.

**Mold or Cast Base Components**

**About Mold Base Components and Fixtures**

Mold base components (fixtures) are components of the mold (cast) assembly that do not directly shape the molten material.

Examples of mold base components include the top plate, support plate, and ejector plates.

Examples of fixtures include a flask in sand casting and a die support structure in die casting. Their presence in a cast model is optional. Fixtures can be moved and checked for interference during die opening.

You can create and save mold base components and fixtures in Part or Assembly mode, and retrieve them in Mold or Cast mode during the assembly of the model.

You can temporarily blank mold or cast base components to make the model uncluttered for other operations, such as parting surface creation. The Status column in the Model Tree indicates if a component is blanked.

**To Assemble the Mold Base Component or Fixture into the Mold or Cast Assembly**

1. Click **Mold Model (Cast Model) > Assemble** on the **MOLD (CAST)** menu.
2. Click **MOLD MDL TYP (CAST MDL TYP) > Mld Base Cmp (Fixture)**. The **Open** dialog box opens.
3. Select the .prt or .asm file that represents the component and click **Open**.
4. Define the component placement using the **Component Placement** dialog box and click **OK**.

**To Create a New Mold Base Component or Fixture**

1. Click **Mold Model (Cast Model) > Create** on the **MOLD (CAST)** menu.
2. Click **MOLD MDL TYP (CAST MDL TYP) > Mld Base Cmp (Fixture)**. The **Component Create** dialog box opens.
3. Select whether the component should be a part or subassembly, enter the component name, and click **OK**.
4. Select a component creation option in the **Creation Options** dialog box and click **OK**.
To Create a Mold Component
1. Click MOLD > Mold Model (Cast Model) > Create.
2. Click MOLD MDL TYP > Mold Comp. The Component Create dialog box opens.
3. Enter the component name and click OK.
4. Select a component creation method from the Creation Options dialog box and click OK.

Creating a Mold Component
Mold or die components are components of the mold or cast assembly which shape a molten material.
You can create mold or die components in Mold or Cast mode by extracting mold or die volumes or using the Component Create dialog box.
The Component Create dialog box and the Creation Options dialog box are available through the MOLD MODEL (CAST MODEL) > Create > Mold (Die) Comp menus and from the Model Tree. These are the same dialog boxes that the Assembly mode uses. The advantages of using these dialog boxes are that you can use templates, predefined layers, views, and customized parameters.

To Assemble a Mold or Die Component
1. Click Mold Model (Cast Model) > Assemble on the MOLD (CAST) menu.
2. Click MOLD MDL TYP (CAST MDL TYP) > Mold Comp (Die Comp). The Open dialog box opens.
3. Select the .prt file that represents the component and click Open. The Component Placement dialog box opens, and the part file appears in the Pro/ENGINEER window.
4. Define the component placement using the Component Placement dialog box and click OK.

To Remove a Component
1. Click MOLD MODEL (CAST MODEL) > Delete. The MOLD MDL TYP menu appears.
2. Click Ref Model or Workpiece to specify the type of component you want to delete.
3. Select the component to be removed. The component disappears from the screen. The ASSY REPLACE menu opens.
4. If required, select one of the following:
   o Place Again
Deleting a Component or Die Block
If you are not satisfied with an extracted component, you can delete it from the mold assembly. Click MOLD COMP > Delete. If you decide to remove the component from the session, the part is also removed from the database.

To Add an Assembly to a Mold or Cast Model
You can add an existing assembly to a mold or cast model and then classify its component parts as either workpiece (die block) or mold base component (fixture). Note that you cannot classify a part from a general assembly as a reference model.

1. On the MOLD (CAST) menu, click Mold Model (Cast Model) > Assemble > Gen Assem. The Open dialog box opens.
2. Select the .asm file that represents the existing general assembly and click Open.
3. Define the assembly placement using the Component Placement dialog box and click OK.
4. Classify components in the general assembly by selecting the component (part or subassembly) and clicking one of the following on the MOLD CLASS (CAST CLASS) menu:
   - Workpiece (Die Block)—To use the selected component as a workpiece (die block).
   - Mld Base Cmp (Fixture)—To use the selected component as a mold base component (fixture).

To Reclassify an Assembly Component
1. Click Reclassify on the MOLD MODEL or CAST MODEL menu.
2. Select the component(s) that you want to reclassify.
3. Redefine the classification of a component in the assembly by selecting one of the following on the MOLD RECLASS (CAST RECLASS) menu:
   - Workpiece (Die Block)—To use the selected component (part or subassembly) as a workpiece (die block).
   - Mld Base Cmp (Fixture)—To use the selected component (part or subassembly) as a mold base component (fixture).
   - Mold Comp (Die Comp)—To use the selected component (part only) as a mold component (die component).
   - Gen Assem—To use the selected subassembly as a general assembly.
Using the Ejector Pin Catalog

About Using the Ejector Pin Catalog
The Catalog functionality works with sets of objects, for example, ejector pins. Each set is defined by a datum feature. Every member component in a set references a point entity from the point feature for placement. Members in a set can be identical or different.

You work with ejector pins within the Catalog environment.

The configuration option pro_catalog_dir must be set to [Proe loadpoint]/apps_data/mold_data/catalog to find the pin templates.

To Use the Ejector Pin Catalog
- To access the catalog environment from Mold or Cast mode, click Mold Model (Cast Model) > Catalog > Ejector Pin.
- If you are working in the Mold Layout application in Assembly mode, click Catalog > Ejector Pin.

A typical procedure for creating a set of ejector pins includes the following steps:
1. Create or select datum points to locate ejector pins.
2. Select an ejector pin from the catalog by defining all required parameters, or select an ejector pin from the ones that exist in the model.
3. Select the placement and orientation planes for the ejector pins.
4. Trim ejector pins as required.
5. Create clearance holes for ejector pins by specifying the cutting quilt parameters.

Component Set Menu
You can access the Catalog Engine through the MOLD > Mold Model > Catalog menu or the Applications > MOLD LAYOUT > Catalog menu. When you select the catalog type (for example, Ejector Pin), the Component Set menu appears.

The Component Set menu consists of the following items:
- **Add Set**—Allows the selection, placement, and naming of a set of standard components, such as ejector pins, with the Define Set dialog box and the Define Parameters dialog box.
- **Redefine Set**—Redefines a set of standard components, such as ejector pins, with the Define Set dialog box and the Define Parameters dialog box.
- **Delete Set**—Deletes a set of standard components, such as ejector pins.
- **Trim to Geom**—Trims a set of standard components, such as ejector pins, with the Trim to Geom functionality.
• **Clearance Cut**—Creates a clearance cut on some or all of the component set members using the **Clearance Cut** dialog box. The **Define Parameters** dialog box can be used to select clearance values.

**The Define Parameters Dialog Box**

The **Define Parameters** dialog box has the following layout:

- **Filter** area—Lists all parameters that you can define for the component.
- **Parameters** area—Shows a drawing of the selected component indicating all required parameters and listing parameters and their values.
- **Component Name**—Displays the current component name and allows you to rename it here.

**To Add an Ejector Pin Set**

You can add individual ejector pins or a set of ejector pins by selecting an ejector pin component from the catalog or from the ejector pins present in the session.

1. Click **Mold Layout > Catalog > Ejector Pin > Add Set**. The **Define Set** dialog box opens.

2. Select or create a datum point feature to locate the ejector pin set.

3. Click the set type: **Identical** or **Variable**.

4. If you select **Variable**, you can specify different settings for each ejector pin: the ejector pin type, base plane, and orientation plane. The **Set Members** table opens within the dialog box, listing all selected datum points. To add or change an ejector pin at each selected location, highlight a row in the table and continue with the procedure. As you define each pin, the table shows the selected settings.

5. Select the ejector pin to add. You can select an ejector pin from the catalog or from the ejector pins in the model.

6. To select from the catalog, click the Catalog icon. The **Define Parameters** dialog box opens. Specify all parameters for the ejector pin: UNITS, VENDOR, TYPE, DIAMETER, LENGTH, and HEAD. A drawing shows the selected ejector pin with all required parameters. A table under the drawing lists all parameter values. After you have defined all parameters, specify the name for the ejector pin set.

7. Click **OK** to return to the **Define Set** dialog box.

8. To select from the model, click the **From Session** icon, and select an ejector pin from the Model list. Click **OK** to return to the **Define Set** dialog box.

9. Select the base plane for placement of the ejector pins.

10. Select a plane to use for the orientation of the ejector pins.

11. Click **OK** to add an ejector pin set.
The Define Set Dialog Box

The Define Set dialog box contains several functional areas.

**Point Feature**—Selects, creates, or redefines a datum point feature that you use to place members of a set.

**Point Feature Rules:**
- You cannot select a datum point feature that is already in use in another set of the current catalog.
- When you delete a datum point item, the system deletes the standard component that uses this point item for placement.
- When you create or select a datum point, the Variable ejector pin set automatically resets to the Identical set that uses the settings of the first set member.
- When you add an item to the datum point feature, the current component is added to the Identical ejector pin set, but no components are added to the Variable set.

**Set Type**—Switches between the Identical or Variable set type; Identical is the default set type. If you click Identical, Pro/ENGINEER performs all operations for all set members. If you click Variable, Pro/ENGINEER performs all operations for selected components.

**Note:** You must select a point feature before you can set the Variable type.

**Component**—Selects catalog set members from the session so that you can change the name, or defines new set members using a catalog and the Define Parameters dialog box.

**Base Plane**—Selects a plane that is used as an assembly reference for the Align constraint.

**Orient Plane**—Selects a plane that is used as an assembly reference for the Orient constraint.

To Create Holes for Ejector Pins

After you add ejector pins, you must create holes for the ejector pins by cutting the assembly components with the quilt.

1. Click Mold Layout > Catalog > Ejector Pin > Clearance Cut.
2. Select an ejector pin from the set. The selected set is highlighted. The Clearance Cut dialog box opens.
3. For a Variable set, select an ejector pin from the Set Members window to perform the operation.
4. For an Identical set, specify the type of the cut: Identical or Variable.
5. Specify the parameters for the hole. Click the Catalog icon from the Quilt Parameters field.
6. The **Define Parameters** dialog box opens. Specify all parameters for the ejector pin hole. A drawing shows a section of a hole for the ejector pin with all required parameters. A table under the drawing lists all parameter values. After you have defined all parameters, click **OK** to return to the **Define Set** dialog box.

7. Specify assembly components to intersect. Click **Define** from the **Intersect Components** field. The **INTRSCT OPER** menu opens. You can select the components automatically or manually.

8. To select components automatically, click **INTRSCT OPER > Add Model > Auto Sel**. The system highlights the intersected components. Click **Confirm**. The system creates a cut through the selected components, excluding the mold and reference parts.

   If you select components with **Auto Sel**, the cutting quilt intersects all components.

9. To select components manually, click **INTRSCT OPER > Add Model > Manual Sel**. Select the components to intersect.

10. Click **OK** to finish.

**To Generate an Ejector Pin Component Name**

After you define parameters for the ejector pin, specify the component name using one of the following methods:

- Type in a component name in the **Component Name** field.
- Generate a component name using its order number. To do this, click the icon in the **Component Name** field.

**To Redefine All Ejector Pin Set Members**

You can redefine an ejector pin set to: replace one ejector pin with another, modify its parameters, or change the placement of a member in an ejector pin set. To redefine an ejector pin set, use the Catalog functionality.

Redefining a set with the **Redefine Set** command preserves children features and references of the ejector pin set.

1. Click **MOLD MODEL > Catalog > Ejector Pin > Redefine Set**.

2. Select an ejector pin from the set. The selected set is highlighted. The **Define Set** dialog box opens.

3. For an identical set, to redefine the settings. For a variable set, select an ejector pin from the **Set Members** window and redefine its settings.

4. Click **OK** to finish.

**To Delete an Ejector Pin Set**

1. Click **Mold Layout > Catalog > Ejector Pin > Delete Set**.
2. Select an ejector pin from the set.

To Trim an Ejector Pin Set

The Trim to Geom feature is a part-level feature.

1. Click Mold Layout > Catalog > Ejector Pin > Trim To Geom.

2. Select an ejector pin from the set. The selected set is highlighted. The Trim Components dialog box opens.

3. For a variable set, select an ejector pin from the Set Members window to perform the operation.

4. Specify the type of object to use for trimming. Click Part, Quilt, or Plane.

5. Select a bounding object.

6. If you are trimming by a part or by a closed quilt, click Trim Type. You can trim by the first or the last intersecting surface.

7. If you want to trim with an offset from the bounding surface, type the offset value in the Offset field.

8. Click OK to finish.

If a trimming plane intersects ejector pins from an Identical set at different heights (for example, if the trimming plane is inclined), you must redefine the set to Variable so you can trim each ejector pin correctly.

To Create Clearance Holes

After you add ejector pins, you must create holes for the ejector pins by cutting the assembly components with the quilt.

1. Click Mold Layout > Catalog > Ejector Pin > Clearance Cut.

2. Select an ejector pin from the set. The selected set is highlighted. The Clearance Cut dialog box opens.

3. For a variable set, select an ejector pin from the Set Members window to perform the operation.

4. For an identical set, specify the type of the cut: Identical or Variable.

5. Specify the parameters for the hole. Click the Catalog icon from the Quilt Parameters field.

6. The Define Parameters dialog box opens. Specify all parameters for the ejector pin hole. A drawing shows a section of a hole for the ejector pin with all required parameters. A table under the drawing lists all parameter values. After you have defined all parameters, click OK to return to the Define Set dialog box.

7. Specify assembly components to intersect. Click Define from the Intersect Components field. The INTRSCT OPER menu opens. You can select the components automatically or manually.
8. To select components automatically, click **INTRSCT OPER > Add Model > Auto Sel**. The system highlights the intersected components. Click **Confirm**. The system creates a cut through the selected components, excluding the mold and reference parts.

9. If you select components with **Auto Sel**, the cutting quilt intersects all components.

10. To select components manually, click **INTRSCT OPER > Add Model > Manual Sel**. Select the components to intersect.

11. Click **OK** to finish.

**Using Pro/LIBRARY Components**

**About Assembling Pro/LIBRARY Components**

If you have a Pro/LIBRARY license, you can use the Pro/ENGINEER MOLD BASE LIBRARY, which contains components of DME company standard and metric mold bases, HASCO company standard and metric components, FUTABA metric components, and NATIONAL components. Any of these components can be used as fixtures in your mold assemblies.

**To Use a Component from the MOLD BASE LIBRARY**

1. Click **File > Open**. The **File Open** dialog box opens.

2. Select **LIBRARIES** in the **Look In** box. Pro/ENGINEER shows the Pro/LIBRARY directory (this directory should be mounted on your machine, and the `pro_library_dir` configuration option should contain the full path to this directory).

3. Browse the directory and select the `.prt` or `.asm` file that represents the component and click **Open**.

4. Select the instance using the instance browser and click **OK**. Pro/ENGINEER opens the selected instance.

5. Copy the instance to a new model using **Save As**, renaming all of its components.

6. Use the copied and renamed models for modifications (instead of original Pro/LIBRARY model) assembling these models into the mold or cast assembly and changing them.

**Using a Component from the MOLD BASE LIBRARY**

The mold bases included in the MOLD BASE LIBRARY contain blank plates, which have not been machined, and can accommodate a mold insert. You can use these mold bases by creating your own pockets in the plates, making them large enough to hold the size of mold insert that is needed. You must then add your mold insert to the mold base assembly.
Important Information

To view the mold base catalog as HTML, you must first have the latest mold base CD for 2000i or higher. You can open the HTML file located at Pro/LIBRARY_loadpoint/moldlib/mold_library.htm and select vendor headings such as DME, HASCO, FUTABA, and NATIONAL on the left side of the screen.

At this time, there are no assemblies in the online HTML version of the library.

Tip: Modifying Mold Base Plates

Regardless of how you decide to modify the mold base plates, you must create copies of the mold bases before you make modifications to them. Saving modifications to the library assemblies or parts (either generic objects or instances) will permanently alter them.

Do not make modifications to the assemblies in the library. Make modifications only to copies of the assemblies and parts. Set the configuration file options override_store_back to yes and save_objects to all to ensure that the copied models are not saved in their library directory, and that any objects which use the copied models are also saved.

Tip: Using Additional Plates

If your molding operation requires using more plates than are included in the library mold bases, you can add extras to the mold base you are using, as necessary.

Regenerating Mold or Cast Models

About Regeneration in Mold or Cast Mode

Regeneration in Mold or Cast mode works exactly the same as it does in Assembly mode.

To Regenerate in Mold or Cast Mode

Click Edit > Regenerate. The model gets regenerated automatically.

Note: To regenerate the model with specific features or components that you have modified, click Custom Regenerate.

Model Accuracy

About the Accuracy of Models

When you work with Mold or Cast models, it is important that the absolute accuracy of the reference model, the workpiece (dieblock), and the mold or cast assembly are the same, to maintain a uniform computational accuracy of geometry calculations. If you set the configuration file option enable_absolute_accuracy to yes, the system will inform you, at the time you add the first reference model to the mold or cast
assembly, if a discrepancy exists between the assembly model accuracy and the reference model accuracy. You can then accept or reject setting the assembly model accuracy to equal the reference model accuracy.

If you create the workpiece or dieblock in Mold or Cast mode, its accuracy is automatically the same as the accuracy of the assembly model. If you assemble a workpiece or dieblock, it is strongly recommended that you manually set its accuracy to correspond to that of the reference part and assembly model.

**To Control the Accuracy of Models**

The following technique helps you easily set the correct accuracy when creating Mold or Cast models.

1. Before you begin, set the configuration file option `enable_absolute_accuracy` to `yes`.
2. Create a new Mold or Cast model. It receives a default (relative) accuracy value.
3. Add the first reference model. If a discrepancy exists between the assembly model accuracy and reference model accuracy, the system issues a warning and prompts you to confirm changing the assembly model accuracy. Click **OK**. The system switches the assembly model accuracy from relative to absolute, and sets it to the value corresponding to the accuracy of the reference model.
4. Create the workpiece using the automatic workpiece creation functionality. Its accuracy is automatically set to be the same as the accuracy of the assembly model.

**To Change the Accuracy of Models**

Do not change the accuracy of your model unless you have a reason to do so. It is also strongly recommended that you use absolute accuracy when working with Mold or Cast models.

1. To use absolute accuracy, set the configuration file option `enable_absolute_accuracy` to `yes`.
2. Click **Edit > Set Up > Accuracy**. The **ACCURACY** menu appears.
3. Click **Relative** or **Absolute**.
4. If you click **Relative**, type a new value for accuracy or accept the default value of 0.0012.
5. If you click **Absolute**, select one of the following on the **ABS ACCURACY** menu:
   - **Enter Value**—Type a new value for accuracy and press **ENTER**, or press **ESC** to return to the **ACCURACY** menu without changing the accuracy. If the previous accuracy type was **Relative**, the default value for absolute accuracy is the value specified by `default_abs_accuracy` (if no value is specified, the prompt shows only **units** inside the brackets). If the previous accuracy type was **Absolute**, the default value is the current absolute value.
o **Select Model**—Assign an absolute accuracy value from a different part in session. In this case, the browser window opens with a list of parts currently in session. Select one of them. Pro/ENGINEER informs you of the absolute accuracy of that model and prompts you to accept it.

**Note:** The recommended technique is to designate one of the reference models (perhaps the smallest one) as the base model and then use the **Select Model** command to assign its accuracy to the other components of the Mold or Cast assembly.

6. If you specify a new value for accuracy, Pro/ENGINEER informs you that the model needs to be fully regenerated and asks if you want to continue. Click **Yes**.

**Reasons for Changing the Accuracy**

The **Accuracy** command modifies the computational accuracy of geometry calculations. The accuracy of a mold or cast assembly is relative to the size of the resultant molding or cast result.

The valid range is 0.01 to 0.0001, and the default value is 0.0012. The configuration file option `accuracy_lower_bound` can override the lower boundary of this range. The specified values for the lower boundary must be between 1.0000e-6 and 1.0000e-4.

If you increase the accuracy, the regeneration time also increases. Use the default accuracy unless you need to increase it. In general, you should set the accuracy to a value less than half the ratio of the length of the smallest edge on the model to the length of the largest diagonal of a box that would contain the model. Use the default accuracy until you have a reason not to do so.

In the following situations, you might need to change the accuracy:

- Placing a small feature on a model.
- Intersecting (through merge or cutout) two models of very different size. For the two models to be compatible, they must have the same absolute accuracy. To achieve this, estimate each model size and multiply each by its respective current accuracy. If the results differ, enter a value for the accuracy of the models that yields the same results for each. You might need to increase the mold accuracy of the larger model by entering a smaller decimal number.

For example, if the size of the smaller model is 100 and the accuracy is .01, the product of these numbers is 1. If the size of the larger model is 1000 and the accuracy is .01, the product of these numbers is 10. Change the accuracy of the larger model to .001 to yield the same product.

**Working with Absolute and Relative Accuracy**

Relative accuracy is specified as a fraction of the longest diagonal of the bounding box of a model (default value 0.0012).

Absolute accuracy improves the matching of models of different sizes or different accuracies (for example, imported models created on another system).
To avoid potential problems when adding new features to a model, it is recommended that you set the reference model to absolute accuracy before adding additional parts to the model.

Absolute accuracy is useful when you are:

- Copying geometry from one mold to another during core operations, such as **Merge** and **Cutout**.
- Designing models for manufacturing and mold design.
- Matching accuracy of imported geometry to its destination model.

You can match the accuracies of a set of models in two ways:

- Give them all the same absolute accuracies.
- Designate one of them (perhaps the smallest) as the base model and assign its accuracy to the other models.

**Simplified Representations**

**About Simplified Representation in Mold and Casting**

When you create a Simplified Rep, you can create a Simplified Rep that consists of only the extracted models. You can also add or remove the components from the Simplified Rep using a rule. This rule selects all components classified as a mold component, and includes all extracted models in the mold assembly.

You use the **By Rule** dialog box to set up a rule for component selection.

**To Create a Simplified Rep**

1. Click **MOLD MODEL > Simplfd Rep > Create**, and give a name to the simplified rep.

2. Click **DEFAULT RULE > Include Comp** or **Exclude Comp** to start setting up the rule.

3. On the Menu Manager menu, click **EDIT REP > Exclude** or **Substitute > Pick Mdl**.

4. Select a model with the **GET SELECT** menu.

5. On the Menu Manager menu, click **Default > By Rule**. The **By Rule** dialog box opens.

6. Click the **Exterior Comps** button, which lets you select those components that contribute to the external shape of the assembly.

The following message appears when you position the cursor over the menu button:

```
Select unblanked mold components.
```
This message is important because blanked mold or die components can not be selected since they do not exist in the model.

Blanking and Unblanking

About Blanking and Unblanking

Using either Model Setup > Mold Display in the View menu or the Blank/Unblank toolbar icon, you can blank or unblank components, parting surfaces, or volumes to remove or add them to the current display of the model.

You can blank and unblank objects:

- Using the Blank-Unblank dialog box at any time during your work in Mold or Cast mode, even when another dialog box is on the screen.
- Using the filtered tree that is built into the dialog box.
- From the assembly Model Tree.
- By selecting the objects from the graphics window.

If an object can be blanked, its status column indicates if it is blanked.

When you select objects for unblanking, the display status of all items of the currently selected item type is reversed. For example, if you select the Volume object type in the selection filter and click the Select button, all the currently blanked volumes are unblanked, and all of the currently unblanked volumes become blanked. You can then select items for unblanking directly from the graphics window.

To Blank an Object

1. Click View > Model Setup > Mold Display. The Blank-Unblank dialog box opens.
2. Click the Blank or Unblank tab, or click the Blank/Unblank toolbar icon.
3. Select the Blank tab.
4. Set the filter to the necessary object class.
5. Under Visible Components select the objects you want to blank. Click select if you want to select items directly from the graphics window or from the Model Tree.
6. Click Blank.
7. Click Close.

To Unblank an Object

1. Click View > Model Setup > Mold Display. The Blank-Unblank dialog box opens.
2. Select the Unblank tab.

3. Set the filter to the necessary object class.

4. Under **Visible Components** select the objects you want to unblank.

5. Click **Unblank**.

6. Click **Close**.

### Verifying Models

#### About the Mold Analysis Dialog Box

The **Mold Analysis** dialog box is displayed when you click the **Mold Analysis** command in the Pro/ENGINEER Analysis top menu.

The **Mold Analysis** dialog box opens in all mold-related modules: Mold Cavity mode, Cast Cavity mode, Mold Layout, Mold/Casting Part-mode application. In Part mode, the part is selected automatically, and you cannot select the corresponding element in the **Mold Analysis** dialog box.

Use the **Mold Analysis** dialog box to apply the following checks:

- **Waterlines**—Select all waterlines, individual circuits, or the surface of any feature.
- **Draft Check**—Check to see if your parts are drafted properly for mold opening or molding removal, or both.

#### To Perform a Mold Analysis on Draft Check or Waterlines

1. Click **Analysis > Mold Analysis**. The **Mold Analysis** dialog box opens.

2. Under **Type**, select **Waterlines** or **Draft Check**.

3. Under **Definition**, select one of the following:

   - **Waterlines**—Specify the part on which you want to perform the analysis. On the **Waterline** menu, select **All Waterlines**, **Select Waterlines**, or **Select Surfaces**. Type a value defining the minimum clearance for the waterlines in the **Minimum Clearance** box.

   - **Draft Check**—Specify the part, surface, or quilt on which to perform the draft check. Use the **Pull Direction** menu to define the pull direction (the direction in which the mold or die opens) by selecting a face, datum plane, curve, edge, axis, or coordinate system. Type a value for the **Draft angle** and specify the direction for draft check as **One Direction** or **Both Directions**.

4. Click **Computation Settings** and under **Resolution**, the following are available:

   - You can define the resolution by setting the density of points. You can use the slider to increase the quality of the analysis.
You can define the resolution by setting the exact number of points to be used for conducting the analysis.

You can define the resolution by setting the distance between two adjacent points in the model units.

**Result Refinement**—Increases the accuracy of the results for the analysis.

**Dynamic Update**—The results are updated automatically as you change the value of the parameters.

5. Click **Compute** to perform the analysis and **Display** to set the display options for the analysis.

6. To save the analysis, click **Saved Analysis**, type a name for the analysis to be saved, and click .

**About Draft**

If your reference part does not already have draft and shrinkage applied, you must apply these features before proceeding with your mold or cast model.

Use the **Mold Analysis** command in the **Analysis** menu to check draft. Parts with complex geometry typically require draft lines before you can create draft.

**About Draft Checking**

Use draft checking to determine if a part within the model is drafted properly to allow the molding or cast result to be removed cleanly.

Draft checking is based on a user-specified draft angle and pull direction (the direction in which the mold or die opens). To determine if the surfaces of a selected part should be modified with draft, the system checks the angle between the planes that are normal to the surfaces of the part and the pull direction.

If the draft check is based on one side, then sufficiently drafted surfaces appear in magenta. If the draft check is based on both sides, then one side appears in magenta and the other side (the opposite side of the pull direction) appears in blue. Surfaces that require draft appear in a range of other colors to indicate how much they deviate from the required draft angle.

To perform a draft check, use the **Mold Analysis** dialog box, available by clicking on the **Mold Analysis** command on the **Analysis** menu in the Pro/ENGINEER top menu bar.

**To Perform a Draft Check**

1. Click **Analysis > Mold Analysis**. The **Mold Analysis** dialog box opens.

2. In the **Type** pull down menu, select **Draft Check**.

3. Confirm or modify the following values:
Pull Dir—Set up the pull direction using MOLD > Set Up > Pull Direction. The system calculates and uses the value as the current interface default. The value is not parametric.

Draft Angle—Set up the draft angle. The system checks off this option by default.

Both Sides—Apply the draft check to both sides of the parting line. This is the default.

One Side—Apply the draft check to one side of the parting line.

Full Color—Display the draft check using a full color spectrum. This is the default.

Three Color—Display the draft check using three colors; magenta, yellow, and cyan. Magenta indicates areas of positive value, and greater draft (up to 90°). Cyan indicates areas of negative value and lower draft (up to -90°). Yellow indicates all areas outside of the magenta and cyan values.

4. Specify the pull direction (in other words, the direction in which the mold or die opens) by selecting a face, datum plane, curve, edge, axis, or coordinate system.

5. Click Flip or Okay in response to the indicated direction.

6. Type a draft angle.

7. Specify the part, surface, or volume on which to perform the draft check. select one of the following:

Part—Specify a part on which to perform the draft check.

Surface—Specify a surface on which to perform the draft check.

Volume—Specify a mold or die volume on which to perform the draft check.

8. Click Compute. Regions that are drafted sufficiently appear in magenta or blue. Regions that require additional draft appear in other colors, according to how much they deviate from the required draft angle. The Color Range window displays the value associated with each color.

9. Click Close.

About Determining the Optimal Pull Direction

The optimal pull direction is achieved when the draft check indicates that no draft (or the least amount of draft) needs to be added to model surfaces to allow the molding or cast result to be ejected from the workpiece or die block cleanly. Sometimes, you must use multiple pull directions for complex molds or casts.
Example: Display of a Draft Check

1. Full spectrum
2. Cyan
3. Yellow
4. Magenta

To Perform a Thickness Check

To determine if a specified region in a mold or cast model has a thickness that is greater than or less than a specified maximum or minimum value, click Analysis > Model Analysis. The Model Analysis dialog box opens.

1. In the Type pull down menu, click Thickness.
2. Select one or more planes for performing the thickness check.
3. Under Thickness, click Max or Min to provide values upon which to base the check.
4. If you select a datum plane for a thickness check and the datum plane is a member of a pattern, the PLANE PAT menu appears with the commands Single and Pattern, allowing you the option of selecting the other datum planes in the pattern.
5. Click Done to initiate the thickness check.
6. Select the part on which to perform the check; the part is highlighted.
7. Select or create one or more datum planes to be used in the thickness check, and click Done Plane when you are finished.
8. If you click MaxThickness, type a value for the maximum allowable wall thickness and press ENTER.
9. If you click MinThickness, type a value for the minimum allowable wall thickness and press ENTER.

The cross section of the part along the first selected plane appears (see Thickness Check Performed Using Sel Plane for an example), and the THICK DISP menu appears. Regions of the model that are thicker than the allowable maximum are cross-hatched in red, and regions where the thickness of the model is less than the allowable minimum are cross-hatched in blue.

If you select more than one plane, you can use any of the following in the THICK DISP menu:
  - Next, Previous, Go To—To toggle from one cross section to another.
  - All—To display all of the cross-sections at a single time.
  - Clear—To remove all of the cross-sections (except the current one) from the display.

10. Click Info to bring up the Information Window, displaying slices that are above or below maximum or minimum values, the area of the region which violates the value, the plane, and the value that was violated.

To Perform a Thickness Check Using Make Slices
1. Click Analysis > Thickness Check. The Model Analysis dialog box opens.

2. Start Point, End Point, Slice Dir, and Slice Offset become accessible and are chosen (checked off) automatically.

3. Click MaxThickness or MinThickness.

4. Click Done to initiate the thickness check.

5. Select the part on which to perform the check. The part is highlighted.

6. On the part, select a starting point and then an ending point for defining the first slice.

7. The line defined by these two points will be projected through the part to define a plane to be used as the first slice in the thickness check.

8. The GEN SEL DIR menu appears, with the commands Plane, Crv/Edge/Axis, Csys, and Quit.

9. Select an entity to which the direction of slice creation is normal. An arrow appears, originating at the selected entity.

10. Click Flip or Okay to indicate the direction of the thickness check, which is the direction in which slices are created.

11. At the prompt, type a value for the offset (interval) between slices and press Enter.

12. At the prompt, type a value for the maximum allowable wall thickness and press Enter.
13. At the prompt, type a value for the minimum allowable wall thickness and press ENTER.

The system creates a series of cross-sections, each separated from the other by the slice offset value (see the following figure for an example of a slice). The THICK DISP menu also appears. Regions of the model that are thicker than the allowable maximum are cross-hatched in red, and regions where the thickness of the model is less than the allowable minimum are cross-hatched in blue.

14. Once the cross section appears, you can use any of the following commands in the THICK DISP menu:
   - **Next, Previous, GoTo**—To toggle from one cross section to another.
   - **All**—To display all of the cross-sections at a single time.
   - **Clear**—To remove all of the cross-sections from the display.
   - **Info**—To display the Information Window, which lists any slices that are above or below maximum or minimum values, the area of the region which violates the value, the slice number, the slice offset, and the value that was violated.

### Example: Thickness Check Performed Using Sel Plane

1. Regions within the cross section that violate the maximum thickness are cross-hatched in red.

2. The cross section of the model is cross-hatched in yellow.
Example: Defining the First Slice for Checking Thickness

1. This plane has been selected as the entity to which the slices are created normal.
2. This arrow indicates the direction in which slices are created.
3. The first point selected to define the slice.
4. The second point selected to define the slice.
5. The line that is defined by the selected points is projected all the way through the model to define the first slice.

To Calculate the Surface Area of a Cavity

To properly calculate the clamping force required to keep a mold or die set closed during operation, you need to calculate the total surface area of the mold or die cavity.

1. Click MOLD (CAST) > Mold Check (Cast Check) > Proj. Area. The GEN SEL DIR menu appears, with Plane, Crv/Edge/Axis, Csys, and Quit.
2. Select an entity that is perpendicular to the direction of projection. The system calculates the projected area of the reference part(s) for the model and displays the result in the prompt area in square units.

To Perform a Parting Surface Check

1. Click MOLD (CAST) > Mold Check (Cast Check) > Part Sft Check.
2. Click Self-int Ck to check the parting surface for self intersection, or Contours Ck to look at the contours to make sure that there are no holes.

If there are intersections or holes, the system indicates their location in the Pro/ENGINEER window. You must fix these imperfections before proceeding.
**Mold or Casting Information**

**About Mold or Cast Information**
You can display mold or cast information by clicking the boxes in the MOLD (CAST) Inf dialog box. When you click **Apply**, a large information window opens.

**To Display Mold or Cast Information**
1. Click **Info > Mold**. The MOLD (CAST) INF dialog box opens.
2. Click the boxes next to the elements that you want to see displayed in an information window. Select from:
   - BOM
   - Components
   - Cavity Layouts
   - Split Volumes
   - Created Volumes
   - Parting Surf
   - Split
   - Last Volume
   - Screen
   - File
3. Click **Apply**. The INFORMATION WINDOW opens and displays the information that you selected in the dialog box.

**Requesting Specific Information**
Click **Info** on the Pro/ENGINEER menu bar to display a list of options. One of the options is the name of the product you are currently using, in this case, either **Mold** or **Cast**. Click **Mold** or **Cast** to display a dialog box containing several check boxes for information display.

- **BOM**—Display the bill of materials for the mold model.
- **Components**—Display the name of the assembly to which each component belongs, as well as the component number and ID, part name, and children, if any.
- **Cavity Layouts**—Provides the names of mold cavities according to rectangular, circular, and user defined patterns.
- **Split Volumes**—List the names of any volumes created by splitting the workpiece. The information includes the name of the volume, the references used to create it, the display status of the volume, and its feature ID.
• **Created Volumes**—List the names of any volumes in the workpiece that were created by sketching or gathering. The information includes the volume name, the references used to create it, its display status, and its feature ID.

• **Parting Surf**—Display the name and display status of any parting surfaces present in the mold model.

• **Split**—Display information on any splits present in the mold or cast model, including the reference volume, parting surface, and result name.

• **Last Volume**—List the latest volume to be created in the assembly, including the volume name, the references used to create it, its display status, and its feature ID.

• **Shrinkage**—Display information on the type of shrinkage applied and the formula used for applying shrinkage.

• **Screen**—Write results to the screen.

• **File**—Write the results to a file.

To clear an item that is checked or to select an unchecked item, click its check box.

The selected information is displayed in the information window or output to a file, depending on your output choice.

**Creating Mold and Cast Features**

**About Creating Features**

Mold and cast features exist at the assembly level. There are two classifications of features: regular features and user-defined features.

Regular features are special features added to a model to facilitate the molding or casting process. These features include silhouette curves, ejector pin holes, runners, waterlines, draft lines, offset areas, volumes, and trimming features.

User-defined features are created in part mode and used to create commonly used structures in the workpiece or die block. A user-defined feature is created once and used multiple times by modifying the dimensions each time it is copied into an assembly.

**To Add a Regular Feature to a Mold or Cast Component**

1. Select the component to which you want to add the feature from the MOLD (CAST) MDL TYP menu. The FEAT OPER menu appears.

2. Click **Mold (Cast)** on the FEAT OPER menu. The MOLD FEAT (CAST FEATURE) menu appears.
   - **Silhouette**
   - **Draft Line**
   - **Draft**
Tan Draft
Offset Area
RefPart Cutout
Trim to Geom
Water Line
Runner
Slider

3. Select the type of feature you would like to add. Dialog boxes and menus used for feature creation will appear as described in other sections of this Help system.

To Create Features and Redefine Layout Using the Model Tree
You can create features and redefine layout for a part or assembly listed in the Model Tree.

To create a feature
1. Select a part or assembly in the Model Tree, then click and hold the right mouse button down.
2. In the pop-up menu that appears, select Feature Create. The FEAT OPER menu appears.
3. Continue with feature creation as described in other Help topics.

To redefine a layout
1. Select a ref.part layout member in the Model Tree, then click and hold the right mouse button down.
2. In the pop-up menu that appears, select Redefine. The LAYOUT dialog box appears.
3. Continue with layout operations as described in other Help topics.

To Insert Features Using Insert Mode
New features are added after the last existing feature in the part, including suppressed features. You can use Insert mode to add a new feature prior to any existing feature except the base feature.
1. On the FEAT OPER menu, click Feature Oper > Insert Mode > Activate.
2. Select the feature after which to insert the new feature. All features after this feature are automatically suppressed.
3. Create the new feature.
4. To return to the previously active menu without leaving Insert mode, click **Return** from the **INSERT MODE** menu.

5. To quit Insert mode:
   - Click **FEAT > Resume** and select the features suppressed when Insert mode was activated.
   - Click **INSERT MODE > Cancel**. The system prompts you whether the features that were suppressed upon activation of Insert mode should be resumed. Pro/ENGINEER automatically regenerates the model.

**Feature Menus**

To create features in Pro/MOLDESIGN, click **MOLD > Feature**. The **MOLD MDL TYP** menu appears with the following commands:

- **Cavity Assem**—Add a feature to the cavity assembly.
- **Ref Model**—Add a feature to the reference model.
- **Workpiece**—Add a feature to the workpiece.
- **Mld Base Cmp**—Add a feature to the mold base component.
- **Mold Comp**—Add a feature to a mold component.

To create features in Pro/CASTING, click **Cast Feature** on the **CAST** menu. The **CAST MDL TYP** menu appears with the following commands:

- **Cast Assem**—Add a feature to the cast assembly.
- **Ref Model**—Add a feature to the reference model.
- **Sand Core**—Add a feature to the sand core.
- **Die Block**—Add a feature to the die block.
- **Die Comp**—Add a feature to a component of the cast assembly.
- **Cast Result**—Add a feature to the cast result.
- **Fixture**—Add a feature to a fixture.

You can also create features in both Mold and Cast mode using the Model Tree.

**To Set the Default Pull Direction**

The default pull direction is visible on the model at all times as a double set of arrows. It is used as a default direction for all mold-specific features and analysis depending on the pull direction. The light direction, indicated by a single arrow, is visible when the **SILHOUETTE CURVE** dialog box or the **Skirt Surface** dialog box is open. The light direction is opposite of the pull direction. You can apply the following settings to these arrows:

1. Click **Tools > Environment** to switch the light direction arrow on and off.
2. Click **Edit > Setup > Pull Direction** to set or reset the pull direction for each newly created mold- or cast-specific feature that requires this setting.

The pull direction value is not parametric. This means that features built before resetting the default pull direction use the earlier direction value. They are not updated when you reset the default pull direction.

**Silhouette Curves**

**About Creating Silhouette Curves**

A silhouette curve produces a valid parting line.

To determine where the parting surface for the model should be placed, you can create a silhouette curve on the reference part.

When the system creates a silhouette curve, it places the curve on the part where the part surface is normal to the pull direction. The resulting curve may consist of several closed loops (including inner loops) and can be used to create a Skirt parting surface.

**To Create a Silhouette Curve**

1. Click **MOLD (CAST) > Feature (Cast Feature) > Ref Model > Mold (Cast) > Silhouette**. The **SILHOUETTE CURVE** dialog box opens.

2. Specify a name for the silhouette curve you want to create.

3. Select a plane, curve, edge, axis, or coordinate system to specify the light direction.

4. If required, specify any of the following on the **SILHOUETTE CURVE** dialog box:
   - **Slides**—Specify volumes and-or components to handle undercut zones in the reference part
   - **Gap Closure**—Handles gaps in the preliminary silhouette
   - **Loop Selection**—Manually selects loops or chains or both to resolve ambiguities in undercut and non-drafted zones.

5. Click **Preview** to see the silhouette curve you created. A message indicates that the silhouette curve has been created successfully.

6. Click **OK**.

**Closing a Silhouette Curve Gap**

This functionality is helpful when you create a silhouette curve that will be used as a parting line for Skirt parting surface creation. When a silhouette curve has a break, a small gap, or short almost vertical edges due to inaccurate geometry, manipulation of the curve is now permitted. Manual manipulation of the curve involves aligning curve endpoints between the curves. There are several methods of aligning:
From the lower endpoint to the upper endpoint
From the upper endpoint to the lower endpoint
From the two endpoints to a point along the shared edge that is half way between the two points

The gap can also be left open.

The Gap Closure dialog box supports all of this functionality.

Gap Closure Dialog Box

The Status options in the Gap Closure dialog box concern the end points of curves. You can highlight and manipulate the end points of curves that are not coincident after silhouette curve creation.

You can select:
- **Open**—Allows you to leave the gap open.
- **Upper**—The lower end point to the upper end point.
- **Lower**—The upper end point to the lower end point
- **Middle**—The two end points to a point along the shared edge that is halfway between the two points.

You can select highlighted gaps by clicking on the Pro/ENGINEER screen or by selecting from the dialog box. The gaps highlight in red as you select the entry in the dialog box.

Handling Loops

The reference part intersects each of the slides that you specify. When you create this intersection, one or more intersection loops results from this action. Each loop is handled separately by the system.

- If the loop does not intersect the existing silhouette curve, the system discards it.
- If the loop does intersect the silhouette curve, the system removes the portion of the silhouette curve inside the loop.

Points of intersection with the silhouette curve split the loop into upper and lower chains. These chains are added to the existing upper and lower chains of the silhouette curve and treated the same way.

To Create a Silhouette Curve to Handle Mold Undercuts

1. Click **MOLD (CAST) > Feature (Cast Feature) > Ref Model > Mold (Cast) > Silhouette**. The SILHOUETTE CURVE dialog box opens.
2. Enter a silhouette curve name for the curve to be created in the Pro/ENGINEER window.
3. Select a plane, curve, edge, axis, or coordinate system to specify the direction.
4. Click **Slides** in the dialog box to select an additional volume or another component in the assembly.

5. If an intersection occurs between the slider and the reference part silhouette curves, use the **Loop Selection** option in the **SILHOUETTE CURVE** dialog box.

   The silhouette feature creation does not fail when you change and regenerate the model, and if:
   
   o The undercut condition disappears through the evolution of the part.
   
   o You delete the previously included slide.

   If you do delete the slide insert while the undercut condition persists, the silhouette curve feature will include the new reference part loops. As a result, any skirt feature (or other child features) created from the silhouette curve may fail or create unwanted geometry.

**Creating Silhouette Curves to Handle Undercuts**

You can now include volumes and other solid components as reference geometry when creating silhouette curves. The volume or component will be used as slide geometry to handle the undercut situation. If you use the **Slides** option in the **SILHOUETTE CURVE** dialog box, the system prompts you to include the slides that are defined to compensate for the undercuts.

**Example: Silhouette Curves**

An example of silhouette curves is shown in the following figure.

![Silhouette Curves Diagram](image)

1. Silhouette curve
2. Silhouette curve
3. 0 degree Surface normal
4. Pull direction
Draft Curves and Parting Curves

About Draft Lines, Draft Curves, and Parting Curves

A draft line is a collection of features used to create tangent draft for parts with complex geometry. A draft line consists of any draft curves, parting curves, and datum curves used to create the draft. The draft line acts as a trajectory to drive a tangent draft feature.

A draft curve is a curve on the reference model created from a locus of points where a surface, oriented at a specified draft angle to the pull direction, is tangent to the part. In other words, it indicates where the edge of the draft becomes tangent to the drafted surface.

A parting curve is located on the parting surface and is created from a locus of points where a surface, tangent to the part surfaces and oriented at the specified draft angle to the pull direction, intersects the parting surface. Before you can create parting curves, you must define a parting surface for the reference model.

You can create a draft line feature on a reference model regardless of whether a workpiece or die block is present.

Before you can create draft line features, such as draft and parting curves, you must define the draft environment.

To Define the Draft Environment

Before you can create draft line features, such as draft and parting curves, you must define the draft environment, which consists of a Pull Direction and a parting surface. If you have a default Pull Direction defined in the model, the system will implicitly use it for draft environment. You need only Pull Direction to create draft curves, but you have to define a parting surface to be able to create parting curves.

1. Click MOLD (CAST) > Feature > Ref Model (Workpiece) > Draft Line.
2. Specify a name for the draft line. The DRAFT LINE menu appears with Dft Envrmnt chosen automatically; this causes the SEL ELEMENT menu to appear.
3. Select Pull Dir and Parting Surf, and then click Done on the SEL ELEMENT menu to specify the draft line elements.
4. Specify the pull direction by selecting a plane to define the pull direction, and click Flip or Okay in response to the indicated pull direction.
5. Select the parting surface. Any quilt in the reference model may be selected as the parting surface.

To Create a Draft Curve

A draft curve is a curve on the reference model created from a locus of points where a surface, oriented at a specified draft angle to the pull direction, is tangent to the part. Before you create a draft curve, you have to define the draft environment.
1. On the **DRAFT LINE** menu, click **Draft Crv**. The **CURVE** dialog box opens, listing the elements **Draft Angle**, **Surface Refs**, and **Direction**.

2. Specify a value for the draft angle.

3. Select the reference surfaces.

4. Click **OK**.

5. An arrow is displayed, indicating the side of the parting surface on which to create the draft curve. Click **Flip** or **Okay** in response to the indicated direction.

6. When all of the feature’s elements have been defined, click **OK** in the **CURVE** dialog box. Pro/ENGINEER creates the curve on the specified surface or surfaces.

**To Create a Parting Curve**

A parting curve is located on the parting surface and is created from a locus of points where a surface, tangent to the part surfaces and oriented at the specified draft angle to the pull direction, intersects the parting surface. Before you can create parting curves, you must create a parting surface in the reference model and define the draft environment.

1. On the **DRAFT LINE** menu, click **Parting Crv**. The **CURVE** dialog box opens, listing the elements **Draft Angle**, **Surface Refs**, and **Direction**.

2. Enter a value for the draft angle.

3. Select the reference surfaces. Click **OK** when finished.

4. An arrow is displayed, indicating the side of the parting surface on which to create the parting curve. Click **Flip** or **Okay** in response to the indicated direction.

5. When all of the feature’s elements have been defined, click **OK** in the **CURVE** dialog box. The system creates the curve on the parting surface.

**Modifying Parting Curves**

The endpoints of parting curves that the system creates for adjacent part surfaces may not always coincide. In these cases you should modify the parting curves to create a single curve that always represents the maximum amount of draft required.

Several options are available from the **DRAFT LINE** menu to modify draft lines and parting curves:

- **Project**—Create and place parting curves manually. Sketch datum curves on a plane and project them onto the parting surface.

- **Split**—Split the draft curves or parting curves. You have the option to remove unwanted curves.

- **Connect**—Connect sections of the split parting curves.

- **Include**—Include a user defined datum curve as part of the draft line.
• **Exclude**—Delete unneeded curve portions.
• **Delete Last**—Delete the last draft line action.
• **Redefine**—Change the definition of a draft line segment.
• **Show Crv**—Show the parting curve.
• **Info**—Open a window listing reference part name, draft line name, draft line feature ID, and draft line feature number.

**To Create an Automatic Parting Curve**

The **Auto PrtgCrv** command calculates a best-fitting parting curve based on existing user-created parting curves and a minimum radius.

1. On the **DRAFT LINE** menu, click **Auto PrtgCrv**.
2. Pick one or more segments of a parting curve for a given pull direction.
3. Pick one or more segments of another parting curve for the opposite pull direction.
4. An arrow appears on one endpoint of the parting curve, and the system prompts you to specify the outside direction of the curve.
5. Repeat Step 4 for the arrow that appears on the other endpoint of the parting curve.
6. When prompted, enter a value for the minimum radius of curvature for joining the parting curves. The system constructs the automatic parting curve.

**Creating Automatic Parting Curves**

The **Auto PrtgCrv** command lets you automatically create smooth parting curves by calculating a best-fitting parting curve based on existing user-created parting curves and a minimum radius. When the model is regenerated, the system remembers the parent parting curves and the radius of curvature, so that it can update the final parting curve.

The **Auto PrtgCrv** command produces a single continuous curve representing either a minimum or maximum tangent draft condition with a user-specified minimum radius. The system requires two parting curves representing two pull directions, each curve may consist of multiple segments.

In the following illustration, parting curve 1 and parting curve 2 are on the same part, share the same parting surface, but have different pull directions. The system created the automatic parting curve 3 based on the user-specified minimum radius 4.
Tangent Draft

About Tangent Draft
Tangent Draft features can add or remove material tangent to the selected surfaces of a reference part on one or both sides of a parting surface. Tangent drafts can be created as either solid or surface features. You can also create neutral curves based on the tangent draft geometry. You may need to create a parting surface and a reference curve, such as a draft line, prior to using the Tangent Draft functionality.

The types of tangent drafts are:

- **Curve-driven tangent draft**—Adds material on one or both sides of a parting surface between a reference curve (such as parting curve or sketched curve) and selected surfaces of the reference part, tangent to these surfaces. The reference curve must lie outside of the reference part.

- **Constant-angle tangent draft**—Adds material by following the trajectory of the reference curve and creating surfaces at a specified constant angle to the Pull Direction. Use this feature to add draft to surfaces that cannot be drafted with the regular Draft feature. You can also use this feature if you need to add drafts to a rib with rounded edges and preserve tangency to the reference part.

- **Tangent draft cut**—Removes material on one or both sides of a reference curve (such as draft curve or silhouette curve) at a specified angle to the reference part surfaces and provides a rounded transition between the draft surfaces and the adjacent surfaces of the reference part.

When you create a tangent draft, you select the draft type, geometry, and side options, and specify the Pull Direction. If a Pull Direction has already been defined in the mold or cast model, you can either accept the default direction or specify a different one. Then you select a reference curve and define other draft references,
such as tangent surfaces or draft angle and radius, depending on the tangent draft type.

The optional elements of a tangent draft are:

- **Spine Curves**—Lets you specify an additional curve that controls the orientation of normals to the sectioning plane. Use this element if using the reference curve alone results in geometry intersecting itself.

- **Closing Surfaces**—Lets you trim (or, in some cases, extend) the tangent draft up to selected surfaces. Use this element when adjacent surfaces are located at an angle to the surface being drafted.

  **Note:** A closing surface must always be a solid surface. A datum plane or a surface geometry cannot be a closing surface.

- **Cap Angle**—For one-sided curve-driven tangent drafts, controls the draft angle for additional planes created automatically when a draft line does not extend to the surface borders and the Closing Surfaces have not been specified. If no value is specified, a zero angle is used.

Finally, you can edit the reference curve by using the **Curves** tabbed page. Select the reference curve segments to include in draft line or exclude from draft line. Use this functionality when the system has trouble creating the tangent draft, for example, when the reference curve intersects itself.

**To Create a Curve-Driven Tangent Draft**

A curve-driven tangent draft adds material on one or both sides of a parting surface between a reference curve (such as a parting curve or a sketched curve) and surfaces of the reference part, tangent to these surfaces. In order to create a curve-driven tangent draft, you must first create a reference curve (see examples).

1. On the **MOLD** menu, click **Feature > Ref Model > Tan Draft**. The **Tangent Draft** dialog box opens, with selected by default.

2. If the **Pull Direction** has not been specified yet, define it.

3. Select the type of geometry:
   - **Solid Draft**—The draft is created as a solid feature, by adding material to the reference part.
   - **Surface Draft**—The draft is created as a surface feature.
   - **Draft Curve**—The system does not add material or create surfaces. It just calculates the draft curves resulting from intersection of the tangent draft surfaces with the reference part geometry.

4. Select the **Direction** option:
- **One Sided**—The draft is created only on one side of the reference curve. If you are creating a solid draft, use the parting surface to contain the material.

  **Note:** In this case, the parting surface is simply a surface that parts the core and the cavity. It is not the same assembly level parting surface in molds.

- **Two Sided**—The draft is created on both sides of the reference curve.

5. Click the **References** tab, click ![Draft Line](image) under **Draft Line**, and select the reference curve. The reference curve must lie outside of the reference part geometry.

6. You do not have to select the surfaces to which the draft will be tangent, the system will determine them automatically. However, if you are not satisfied with the automatic selection, you can click ![Tangent To](image) under **Tangent To** and select the appropriate surfaces on the reference part.

7. Click ![Preview](image) to preview the tangent draft geometry. You can change the draft geometry, if necessary, by specifying the **Spine Curves**, **Closing Surfaces**, or **Cap Angle**, located on the **Options** tabbed page. You can also edit the reference curve by using the **Curves** tabbed page.

8. If required, in the **TANGENT DRAFT** dialog box, click **Feature > Info** to obtain information about the tangent draft or **Feature > References** to obtain information about the references used to create the tangent draft.

9. When satisfied with the feature geometry, click ![OK](image) to close the dialog box and create the feature.

**Reference Curve Requirements for Curve-Driven Tangent Drafts**

In order to create a curve-driven tangent draft, you must first create a reference curve. The reference curve must be continuous, tangent, and non-intersecting. It can be created as a sketched curve, a parting curve, or a silhouette curve with offset.

The reference curve must lie outside of the reference part. Normally, it lies in the parting surface, but this is not necessary, unless you create a solid one-sided draft. However, the reference curve must be visible along the Pull Direction from both sides of the part.

The following example shows the correct placement of the reference curve.
Example: Creating a Curve-Driven Tangent Draft

This example shows how to add a 15-degree tangent draft on both sides of the parting surface (1). You can use any type of curve to create a curve-driven tangent draft, but if you want to control the draft angle, create the curve as a parting line with the appropriate angle, as shown in this example.
1. On the MOLD menu, click Feature > Ref Model > Draft Line. Accept the default name for the draft line. The menu manager opens and the DRAFT LINE menu appears with the Parting Surf check box selected.

2. Click Done.

3. Select the parting surface.

   **Note:** The parting surface must belong to the reference part.

4. On the DRAFT LINE menu, click Parting Crv. The CURVE dialog box opens.

5. Enter 15 for the draft angle (the draft angle of the parting curve defines the future draft angle of the tangent draft).

6. Select both halves of the rounded surface (1) of the reference part, as shown in the following illustration.

7. Click Okay to accept the direction of feature creation.

8. In the CURVE dialog box, click OK. Then click Done on the DRAFT LINE menu. The system creates the parting curve, shown in orange in the next illustration.
9. On the MOLD menu, click **Feature > Ref Model > Tan Draft**. The **Tangent Draft** dialog box opens. Accept the default **Pull Direction** and the **Geometry** and **Direction** defaults on the **Results** tabbed page.

10. Click the **References** tab and select the draft line. On the **CHAIN** menu, click **Curve Chain**, select the parting line created in Step 8, then click **Select All** and **Done**.

11. Click ![✓](checkmark.png). The tangent draft cut is created as shown in the following illustration.

**Example: Specifying Cap Angle and Closing Surfaces**

This example shows creating a curve-driven solid tangent draft on one side of the sketched reference curve (1). In this example, the feature is added in Part mode.
1. Create a flat surface through the middle of the part, as shown in the following illustration.

2. On the top menu bar, click Applications > Mold/Casting.


4. To specify the Pull Direction, select the surface created in Step 1 and click Okay.

5. Select One Sided under Direction. Accept the other defaults.

6. Click the References tab and select the reference curve, then click Done.

7. Click under Parting Surface and select the surface created in Step 1.

8. Click . The tangent draft is created on one side of the reference curve, according to the Pull Direction, as shown in the following illustration.
9. Click the **Options** tab, type 30 in the **Cap Angle** text box and press **ENTER**.

10. Click [ ]. The system changes the angle of the planar surfaces (1) on both sides of the tangent draft feature, as shown in the next illustration.

Depending on your design intention, you may want the tangent draft to extend the complete length of the part. Then, instead of specifying the **Cap Angle**, click [ ] under **Closing Surfaces** on the **Options** tabbed page and select the two side surfaces of the part (1 and 2).

The resulting tangent draft geometry is shown in the following illustration.
Note: Depending on the draft line geometry, the system sometimes may not be able to extend it up to the closing surfaces. It is recommended that you use appropriate tools for creating and modifying curves to make sure that the draft line extends up to or past the intended closing surfaces, and then create a tangent draft.

To Create a Constant-Angle Tangent Draft
A constant-angle tangent draft adds material by following the trajectory of the reference curve and creating surfaces at a specified constant angle to the Pull Direction. Use this feature to add draft to surfaces that cannot be drafted with the regular Draft feature. You can also use this feature to add drafts to ribs with rounded edges (see example).

2. If the Pull Direction has not been specified yet, define it.
   Note: If you are creating a one-sided draft, the Pull Direction must point from the reference curve in the same direction that the draft is being created.
3. Select the icon.
4. Select the type of geometry:
   o Solid Draft—The draft is created as a solid feature, by adding material to the reference part.
   o Surface Draft—The draft is created as a surface feature.
   o Draft Curve—The system does not add material or create surfaces. It just calculates the draft curves resulting from intersection of the tangent draft surfaces with the reference part geometry.
5. Select the Direction option:
   o One Sided—The draft is created only on one side of the reference curve.
   o Two Sided—The draft is created on both sides of the reference curve.
6. Click the **References** tab, click under **Draft Line**, and select the reference curve. It can be any chain of edges or curves (such as a draft curve). The reference curve must lie on a surface of the reference part.

   **Note:** You cannot select an assembly level silhouette curve as a reference curve for a tangent draft. To create a tangent draft in the reference model, you must create a silhouette curve in the reference model itself.

7. In the **Angle** text box, enter the value for the draft angle.

8. In the **Radius** text box, enter the value for the radius of the round connecting the drafted surfaces with the adjacent surfaces of the reference part.

9. Click to preview the tangent draft geometry. You can change the draft geometry, if necessary, by specifying the **Spine Curves** or **Closing Surfaces**, located on the **Options** tabbed page. You can also edit the reference curve by using the **Curves** tabbed page.

10. If required, in the **TANGENT DRAFT** dialog box, click **Feature > Info** to obtain information about the tangent draft or **Feature > References** to obtain information about the references used to create the tangent draft.

11. When satisfied with the feature geometry, click to close the dialog box and create the feature.

**Example: Creating a Constant-Angle Tangent Draft**

In this example, you have to add a 5-degree draft to a rib, which has 0.4" rounds at the bottom, as shown in the following illustration. To preserve the round at the bottom, you will add a constant-angle tangent draft (in this example, the feature is added in Part mode).

1. On the top menu bar, click **Applications > Mold/Casting**.
2. Click **Insert > Tangent Draft**. The **Tangent Draft** dialog box opens.
3. Click [Image]. Note that the **Direction** default changes to **One Sided**.

4. Specify the **Pull Direction**. Select the top surface of the housing. The system displays a red arrow pointing up. Click **Flip** to make the red arrow point down, because the Pull Direction must point from the reference curve in the direction of the tangent draft creation. Click **Okay**.

5. Click the **References** tab and select the top edge of the rib (1), as shown in the next illustration, then click **Done**.

![Diagram](image1)

6. In the **Angle** text box, type 5 and press **ENTER**.

7. In the **Radius** text box, type .4 and press **ENTER** (the radius value is the same as the radius at the bottom of the rib).

8. Click [Image]. The feature geometry is shown in the following illustration.

![Diagram](image2)

9. To make the tangent draft extend all the way to the side of the rib, click the **Options** tab, click [Image] under **Closing Surfaces**, and select the side of the rib (1), as shown in the previous illustration. You can also notice that there is a gap between the tangent draft geometry and the central cylinder of the housing. To
avoid this, hold the CTRL key and select the side surface of the central cylinder (2) as the second closing surface. Click OK in the SELECT dialog box.

10. Click . The new feature geometry is shown in the next illustration.

11. Click . The constant-angle tangent draft is created.

12. Repeat the procedure to create a constant-angle tangent draft on the other side of the rib. The completed feature is shown in the following illustration.

**To Create a Tangent Draft Cut**

A tangent draft cut removes material on one or both sides of a reference curve (such as a draft curve or a silhouette curve) at a specified angle to the reference part surfaces and provides a rounded transition between the drafted surfaces and the adjacent surfaces of the reference part.


2. If the Pull Direction has not been specified yet, define it.
3. Select the icon.

4. Select the type of geometry:
   - **Solid Draft**—The draft is created as a solid feature, by removing material from the reference part.
   - **Surface Draft**—The draft is created as a surface feature.
   - **Draft Curve**—The system does not remove material or create surfaces. It just calculates the draft curves resulting from intersection of the tangent draft surfaces with the reference part geometry.

5. Select the **Direction** option:
   - **One Sided**—The draft is created only on one side of the reference curve.
   - **Two Sided**—The draft is created on both sides of the reference curve.

6. Click the **References** tab, click under **Draft Line**, and select the reference curve. It can be any chain of edges or curves (such as a draft line). The reference curve must lie on a surface of the reference part.

7. In the **Angle** text box, enter the value for the draft angle.

8. In the **Radius** text box, enter the value for the radius of the round connecting the drafted surfaces with the adjacent surfaces of the reference part.

9. Click to preview the tangent draft geometry. You can change the draft geometry, if necessary, by specifying the **Spine Curves** or **Closing Surfaces**, located on the **Options** tabbed page. You can also edit the reference curve by using the **Curves** tabbed page.

10. When satisfied with the feature geometry, click to close the dialog box and create the feature.

**Example: Creating a Tangent Draft Cut**

In this example, you have to draft the walls of the reference part by 5 degrees, while maintaining the dimensions at the bottom of the part and preserving the 0.4” round at the top.
1. On the **MOLD** menu, click **Feature > Ref Model > Tan Draft**. The **Tangent Draft** dialog box opens.

2. Click ![direction_icon](image1.png). Note that the **Direction** default changes to **One Sided**. Accept the default **Pull Direction**.

3. Click the **References** tab and select the draft line. On the **CHAIN** menu, click **Tangnt Chain**, select a bottom edge of the reference part, as shown in the following illustration, then click **Done**.

4. In the **Angle** text box, type 5 and press **ENTER**.

5. In the **Radius** text box, type 0.4 and press **ENTER** (the radius value is the same as the radius of the top round).

6. Click ![done_icon](image2.png). The tangent draft cut is created as shown in the next illustration.
Creating an Offset

About Creating an Offset
The offset area feature is provided to allow material to be added or removed from components to facilitate the mold or cast opening process. A positive offset value adds material to the surface and a negative offset value subtracts material from the surface.

You can select several surfaces to offset.

To Create a Whole Offset
1. Click MOLD FEAT > Workpiece > Offset Area.
2. Click References on the dashboard. The Offset surface sets panel appears.
3. Select any number of surface sets to offset.
4. Click Options and select one of the following:
   - Normal to Surface—Creates the offset feature normal to the surface being offset.
   - Translate—Creates the offset feature normal to another indicated plane.
5. Specify an offset value.

To Create an Area Offset
Use Area Offset to create new surfaces by offsetting an area of a quilt. The procedure for creating area offsets is the same as for solid features.
1. Click MOLD FEAT > Offset Area.
2. Click References on the dashboard. The Offset surface sets panel appears.
3. Select any number of surface sets to offset.
4. Click **Options** and specify the following:
   a. Under **Expand area**, click **Sketched Region**. A sketched region allows you to offset a portion of the surface using a sketched section. The section is projected from the sketching plane onto the selected surface or surfaces, and the offset value is applied to give the depth to the feature.
   b. Select a sketched curve.
   c. Select one of the following under **Side surface normal to**:
      - **Surface**—The direction of the area offset is normal to the surface.
      - **Sketch**—The direction of the area offset is normal to the sketching plane.
5. Select the surface to offset.
6. Sketch the section.
7. Click **Done**.
8. Click **Flip** or **Okay** to specify the side of the feature sketch that you want to use.
9. Specify the value of the offset.

**The OFFSET Menu**

You can extend a gathered or sketched volume by an offset, with the following on the **OPTIONS** menu:

- **Horizontal**—Offset edges of the volume in the direction normal to the selected surface that is being offset.
- **Tangential**—Offset edges of the volume tangent to the selected surface that is being offset.

**RefPart Cutout**

**About RefPart Cutout of a Volume**

When you define a volume by sketching, you can take up some of the reference part volume. When creating the component or die block, the system fills with solid material all the indicated volume as it is defined. Therefore, in order to correctly define the component or die block geometry, you must be able to subtract the volume of the reference model from the component or die block volume.

To cut out the reference model volume from a sketched volume, use the **Ref Part Cutout** command in the **MOLD VOL** menu for molds, or the **COMP VOL** menu for casts.

**To Use RefPart Cutout**

1. Click **MOLD FEAT > RefPart Cutout**. A **CONFIRMATION** menu appears, and a warning message: Trimming workpiece will affect future Molding. Please confirm.
2. Click **Confirm** or **Cancel**. If you click **Confirm**, a message appears that the operation has been successful.

**Trim to Geom**

**About the Trim to Geom Feature**

The **Trim to Geom** feature in Pro/MOLDESIGN and Pro/CASTING allows the trimming of part or volume geometry that is the result of an intersection with reference geometry. References for the Trim to Geom feature can be a part, quilt, or plane. If the intersected referenced object is a part or closed quilt, then you can select the first or last intersection for trimming using **Trim Type** in the **TRIM TO GEOM** dialog box. The **Direction** bar in the dialog box lets you select the side of the trimmed solid to cut.

- When you trim a part, a part-level feature is created on the part.
- When you trim a mold or cast volume, a feature is created at the Pro/MOLDESIGN assembly level.

**The Trim to Geom Dialog Box**

The **TRIM TO GEOM** dialog box opens when you select the Trim to Geom feature from Mold mode, Cast mode, Mold Layout Assembly or Mold/Casting. The items in this dialog box are:

- **Ref Type**—Click the type of object to use as a reference. In Part mode, Part is unavailable.
- **Reference**—Select an object to use as a reference for trimming. To select the object, use the **GET SELECT** menu.
- **Direction**—Define the direction of the cut using the standard Pro/ENGINEER direction utility.
- **Trim Type**—Click **From First** to trim geometry after the first intersection with reference geometry. Click **From Last** to trim geometry after the last intersection with reference geometry. **Trim Type** is available only when using Part as a reference.
- **Offset**—Enter a positive or negative value that defines the offset from the bounding surface. The default value is 0.
- **Tree**—The tree lists the elements of the feature. Use the tree to select elements you want to redefine.

**To Use the Trim to Geom Feature in Mold Mode**

1. Click one of the following:
   - **Feature > Workpiece > Mold > Trim to Geom**
   - **Feature > Mld Base Cmp > Mold > Trim to Geom**
The TRIM TO GEOM dialog box opens.

2. Click **Part**, **Quilt**, or **Plane** to specify the type of object to use for trimming.

3. To select a bounding object, click under **Reference** and select a reference part.

4. If you are trimming by a part, click the **Trim Type**. Click **From First** to trim from the first intersecting surface of the part or **From Last** to trim from the last intersecting surface of the part.

5. To trim with an offset from the bounding surface, type the value in the **Offset** box.

6. To preview the feature before you create it, click .

7. To create the feature, click . To cancel the operation click .

**To Use the Trim to Geom Feature in Cast Mode**

1. Click one of the following:
   - **Cast Feature > Sand Core > Mold > Trim to Geom**
   - **Cast Feature > Die Block > Mold > Trim to Geom**
   - **Cast Feature > Die Comp > Mold > Trim to Geom**
   - **Cast Feature > Fixture > Mold > Trim to Geom**

   The **Trim to Geom** dialog box opens.

2. Click **Part**, **Quilt**, or **Plane** to specify the type of object to use for trimming.

3. To select a bounding object, click under **Reference** and select a reference part.

4. If you are trimming by a part, click the **Trim Type**. Click **From First** to trim from the first intersecting surface of the part or **From Last** to trim from the last intersecting surface of the part.

5. To trim with an offset from the bounding surface, type the value in the **Offset** box.

6. To preview the feature before you create it, click .

7. To create the feature, click . To cancel the operation click .

**To Use the Trim to Geom Feature in Mold Layout Assembly**

1. Click **MOLD > Feature > Mold Comp**. The **MOLD FEAT** menu appears.
2. Click **Trim to Geom**. The **TRIM TO GEOM** dialog box opens.

3. Click **Part**, **Quilt**, or **Plane** to specify the type of object to use for trimming.

4. To select a bounding object, click 🔄 under **Reference** and select a reference part.

5. If you are trimming by a part, click the **Trim Type**. Click **From First** to trim from the first intersecting surface of the part or **From Last** to trim from the last intersecting surface of the part.

6. To trim with an offset from the bounding surface, type the value in the **Offset** box.

7. To preview the feature before you create it, click 📹.

8. To create the feature, click ✔️. To cancel the operation click ❌.

**To Use the Trim to Geom Feature in Mold or Casting**

1. Click **MOLD > Feature > Mold Comp**. The **MOLD FEAT** menu appears.

2. Click **Trim to Geom**. The **TRIM TO GEOM** dialog box opens.

3. Click **Quilt** or **Plane** to specify the type of object to use for trimming.

4. Select a bounding object

5. To trim with an offset from the bounding surface, type the value in the **Offset** field.

6. To preview the feature before you create it, click 📹.

7. To create the feature, click ✔️. To cancel the operation click ❌.

**Runners**

**About Nonplanar Runners**

Runners define a path of trajectory for a feature. You can define a flow path for a feature by either sketching it on a plane, or selecting any datum curve as the flow path. This curve can be a simple 2-D sketch or a complex 3-D curve generated using any of the methods currently available in Pro/ENGINEER.

A runner's cross-section must be constant. To maintain a constant cross-section along any specified geometry, position the section of the runner so its origin is located normal or perpendicular to the flow path it is placed on. For simple 2-D planar runners, always position the section parallel to the pull direction. For complex 3-D runners, always position the section normal to the curve that defines its flow path.
To Create a Runner

Runners are assembly-level features used to distribute molten material to fill the mold or casting.

1. Click **Feature > Cavity Assem > Runner**. The **Runner** dialog box opens.

2. Enter the desired runner name at the system prompt or press Enter to accept the default.

3. Select the shape of the runner from the **Shape** menu. Available runner shapes are as follows:
   - **Round**
   - **Hexagon**
   - **Half Round**
   - **Trapezoid**
   - **Round Trapezoid**

4. Enter the dimensions that control the runner shape based on your selection in Step 3. For example, if you select a round trapezoid shape the system prompts:
   
   "Enter runner diameter: "

   "Enter runner angle: "

5. Sketch the runner flow path.

6. Select the parts that the runner feature will intersect. This can be done automatically or manually.

7. If you want to modify the shape dimensions of the displayed flow path, select **Segment Sizes** from the **Runner** dialog box and click **Define**. Select an individual segment or a set of segments.

8. Click **OK** to create the runner feature.
Example: Non-planar Runners

1. Section positioned normal to the surface.
2. Section positioned parallel to the pull direction.

To Define a Non-Planar Runner by Sketching a Path
1. Click MOLD > Feature > Cavity Assem > Runner. The Runner dialog box opens.
2. Enter a name for the runner.
3. Select the shape of the runner.
4. Define the size of the runner.
5. Click FLOW PATH > Sketch Path. The SETUP SK PLN menu appears.
6. Sketch the path of the runner.
7. Define the direction, segment sizes, and intersecting parts for the runner.
8. Click OK. The runner will appear in the Mold Cavity Assembly

To Create a Non-Planar Runner by Selecting a Path
1. Click MOLD > Feature > Mold Assem > Runner. The Runner dialog box opens.
2. Enter a name for the runner.
3. Select the shape of the runner.
4. Define the size of the runner.
5. Click FLOW PATH > Select Path. The CHAIN menu appears.
6. Select all the existing curves that the runner will follow using one of the following commands:
   - **One By One**—Select individual curves or edges
   - **Curve Chain**—Select chain of curves
   - **Feat Curves**—Select all curves that belong to the specified feature

7. Define the direction, segment sizes, and intersecting parts for the runner.

8. Select **OK**. The runner will appear in the Mold Cavity Assembly.

**User-Defined Features**

**About User-Defined Features**

User-defined features (UDFs) can be created from regular cuts or slots in the mold or cast model. UDFs allow you to create a standard feature once. You can then use it in different models simply by changing its references and dimensions.

A library of user-defined features can be set up to handle commonly used geometry. This library should be created in advance using the usual technique for defining a user-defined feature.

**To Define a User-Defined Feature (UDF)**

Features used to model sprue, runner, and gate systems should be modeled as assembly features that intersect the workpiece or die block, or the mold or cast components. These features can then be made into UDFs for later use in other models.

1. Create an assembly feature(s) intersecting required components of the desired geometry.

2. Sketch the desired section using the edges and surfaces of the reference part as necessary.
   - You should use the same reference multiple times because complimentary references will need to be specified when the UDF is used. You will be asked to create a prompt message for each reference.
   - You should set up relations for the feature where possible. For example, the height is always 1.5 times the width. This reduces the number of variable dimensions you will need to enter every time you place the feature.

3. Click **Feature**. The **MOLD MDL TYP** menu appears.

4. Select a type from the **MOLD MDL TYP** menu and click **Feature Oper > UDF Library > Create**.

5. Specify the name of the user-defined feature.

6. Select one of the following on the **UDF OPTIONS** menu:
• **Stand Alone**—The UDF is functional by itself.
• **Subordinate**—The UDF depends on the part in which it is being created.

7. Select the features that you want to include in the UDF.

**To Place a User-Defined Feature**

User-defined features can be added to the workpiece or die block and to the mold or cast assembly.

Before placing a user-defined feature make sure that the appropriate references (datum planes, axes) are in place.

1. Click **Feature > Cavity Assem > User Defined**.

2. Retrieve the desired UDF into your session using the **Open** dialog box and follow the prompts to locate it in the current model.

   If the group has a reference model, it is retrieved in a separate window.

3. From the **PLACE OPTS** menu:
   - Select **Independent** if you want to be able to modify the feature.
   - Select **UDF Driven** if you want the feature to update if the reference group is modified.
   - In addition, select **Same Size, Same Dims**, or **User Scale** to determine if the dimensions of the group may be modified.

4. Specify dimension values as necessary and locate the UDF. When all references have been provided, the UDF is placed.

**To Create Ejector Pin Clearance Holes**

1. Click **MOLD (CAST) > Feature > Cavity Assem > EJ Pin Holes**.

2. Specify the placement type by selecting one of the following from the **PLACEMENT** menu:
   - **Linear**—Place the reference(s) at linear offsets from two planes.
   - **Radial**—Place the reference(s) at a radial offset from an axis and at an angle from a plane.
   - **Coaxial**—Place the reference(s) coaxial to an axis.
   - **On Point**—Place the reference(s) on a datum point. Use this command to create multiple ejector pin holes as one feature.

3. Select the datum or surface placement points.

4. Specify the location and direction of the ejector pin clearance hole(s) relative to the placement plane.
5. Specify which components the ejector pin clearance hole(s) should intersect. This can be done automatically or manually.

For each intersected component, enter the diameter of the ejector pin clearance hole in that component. The system displays the default diameter value.

6. Click **Intsct Parts > Done** when you have selected all components that should be intersected.

7. Specify the counterbore diameter and depth. The system displays the default values.

8. Click **OK**. The system regenerates the ejector pin clearance hole(s) as one feature.

**Note:** Remember to select the axis of the ejector pin hole and not the axis of the assembly cut feature when selecting a hole for patterning or as a reference.

**Tip: Ejector Pin Clearance Holes in a UDF**

Ejector pin clearance holes are used to show where the ejector pins that will eject the molding or casting are placed. They have no effect on the geometry of a molding or cast result.

You can include ejector pin clearance holes in a UDF. When you place a group with such a feature, the system prompts you to select the radial value for each feature individually. After each radius is selected for the ejector pin hole, its axis is highlighted.

**Working in the Mold/Cast Part Application**

**About Creating Mold and Cast Features in Part Mode**

You can create many Mold and Cast features while working in Part mode in the same way you use these features in Assembly mode. When you are in Part mode, the Mold application is activated if you click **Applications > Mold/Casting**.

You must have purchased the license for Pro/MOLDESGN to access these functions.

**To Create Mold and Cast Features in Part Mode**

You can create mold features while in Part mode.

1. In Part mode, click **Applications > Mold/Casting**.

2. Click **Part > Feature > Create > Mold**. The MOLD FEAT menu opens.

3. Select the feature that you want to create:
   - **Silhouette**—Create a Silhouette Curve feature.
   - **Draft Line**—Create a Draft line feature.
   - **Draft**—Create a Mold Draft feature.
- **Tan Draft**—Create a Mold Tangent Draft feature.
- **Offset Area**—Create an offset of one or several surfaces.
- **Trim to Geom**—Trim a feature by a first or last intersecting surface.
- **Water Line**—Create a Waterline feature.
- **Runner**—Create a Runner feature.

### Waterlines

**About Water Lines**

Waterlines are assembly-level features used to lay out water channels (drilled holes) to convey cooling water through the mold or cast components to cool down the molten material. The speed of cooling down the mold is directly related to the profitability of the entire mold product line.

**To Create Water Lines**

1. Click **Feature > Cavity Assem > Water Line**. The **Water Line** dialog box opens.
2. Specify the waterline diameter or accept the default value.
3. Sketch the path of the waterline circuit using the **SETUP PLANE > Plane**.
   
   **Note:** The section cannot contain any non-linear entities.
4. Select the parts that the waterline feature will intersect. This can be done automatically or manually.
5. To specify the end condition, select **End Condition** from the **Water Line** dialog box and click **Define**.
6. Select the corners from segments on which you want to specify the end condition and the type of end condition. The options are **None, Blind, Thru**, and **Thru w/Cbore**.
7. Click **Done/Return** to create the waterline feature.

**To Check Waterline Circuits**

1. Click **Analysis > Mold Analysis**. The **Mold Analysis** dialog box opens.
2. In the **Type** pull down menu, select **Waterlines**, and under **Definition > Part**, select a part.
3. Under **Waterline**, select one of the options:
   - **All Waterlines**
   - **Select Waterlines**
Select Surfaces

4. Under Clearance, click and enter a minimum clearance for the waterline.

5. Click Compute. The results appear in the Results box.

Red indicates that the water line is closer than the clearance; green indicates that the water line is farther than the clearance.

The Mold or Die Opening Process

About the Mold or Die Opening Process

Simulation of a mold or the die opening process allows you to check the correctness of your design. You can specify moves for any member of the assembly, except the reference model, the workpiece, or die block.

It is convenient to add the reference model and the workpiece or die block to a blanked layer before opening the mold or die.

The mold or die opening process is a series of steps, each containing one or more moves. A move is an instruction to move one or more members, offsetting them in a specified direction by a specified value.

To Define a Mold or Die Opening Sequence

1. Make sure that all the mold or die components are extracted, the molding or cast result is created, and the reference part and workpiece or die block are blanked.

2. Click Analysis > Mold Opening (Die Opening) or MOLD > Mold Opening > Define Step > Define Move.

3. Select member(s) to move.

4. Select a linear edge, axis, or plane to indicate the direction. The member(s) move parallel to the edge or axis, or normal to the plane.

5. Enter the offset value. The red arrow indicates the positive direction. If you want to move in the opposite direction, enter the negative offset value.

6. Check interference for the current move if desired.

7. Define more moves for this step or click Done on the DEFINE STEP menu. The selected members move to their new positions.

8. Proceed to define steps for mold opening. After each step, the mold model is redrawn.

9. When finished, click Done/Return. The mold components are brought together to their original position.
Example: Defining a Move

1. Select this edge for direction. Enter a positive offset.
2. Select this member.

The MOLD/CAST OPEN Menus

The MOLD OPEN (DIE OPEN) menu contains the following commands:

- **Define Step**—Define a step of a mold or die opening by specifying moves for the mold or die members. You can check interference and draft for each move.
- **Delete**—Delete an existing step. Enter the step number.
- **Modify**—Modify an existing step. Enter the step number. Use the Define Step menu commands to add or delete moves, or to check interference.
- **Mod Dim**—Modify the offset values. Select a translated member to display offset. If you modify an offset value, all members included in this move are affected.
- **Reorder**—Reorder the mold or die opening steps. Enter the number of the step to reorder, then enter its new number.
- **Explode**—Step through the mold or die opening process as currently defined.

Rules for Defining a Move

The rules to remember when defining steps for mold opening are:

- Each step may contain several moves, which are performed simultaneously.
- A member can be included in only one move per step.
- A move may include several members, but they are all offset in the same direction and by the same value.

To Check for Interference

You can make Pro/ENGINEER check moving parts for interference with the static ones for each move you define.

1. After you have defined a move, click **DEFINE STEP > Interference**.
2. Click **Static Part** and select the part to check against. Pro/ENGINEER checks moving member(s) for interference with the static part and reports the results. If an interference is detected, it is indicated by highlighting the curves in yellow.

3. Click **Static Part** again to perform the interference check with respect to another static part, or click **Done/Return** on the MOLD INTER menu.

If interference is detected, you can delete the move and try another way of mold opening. Sometimes, you may have to redefine your mold components.

**To Display Exploded Geometry**

1. After you define the mold opening sequence and check for interference, click **MOLD OPEN > Explode**, and all mold or die members are brought into their original position.

2. Click **Open Next** to display the first step. Members included in the moves of the first step are translated according to specified offsets.

3. Continue to click **Open Next** to display all steps in the sequence. A message finally indicates that all assembly components have been successfully exploded.

**Example: Simulating a Mold Opening**

1. Mold Components

2. Molding

**Working in the Mold Layout Assembly Application**

**Mold Layout**

**About Mold Layout**

The Mold Layout application provides a dynamic environment for designing and assembling single or multi-cavity tooling in an assembly. Mold Layout also provides efficient tools for fast and robust design of single or multi-cavity molds. You can easily populate your assembly with cavity subassemblies, a mold base assembly,
standard components, and an injection molding machine. You can also create some mold-specific features.

The Mold Layout application is mold functionality that is accessible from Assembly mode. You create or open a regular assembly (\.asm) file to use this application.

You can switch from working on a multi-cavity mold assembly to working on an individual cavity. To do this, use a regular assembly structure where the multi-cavity mold assembly model is a top level assembly and each cavity model is a subassembly. These cavity subassemblies are represented by Mold or Cast assemblies.

You can make changes in one cavity assembly model appear in all cavity assembly models in the multi-cavity mold assembly.

The cavity population tool allows flexible patterning of the cavities according to rectangular, circular, and user defined pattern rules. You can add, remove, move, or reorient each cavity pattern member individually, or even replace any cavity model with a family table instance.

Other functions specific to Mold Layout are as follows:

- Selecting and placing mold bases with the **Mold Base Selection** dialog box
- Selecting and placing Injection Molding Machine models
- Creating runners at the assembly level
- Creating waterlines at the assembly level
- Creating ejector pin holes at the assembly level
- Using the standard component Catalog to add, redefine, delete, trim, and cut components
- Opening the mold by defining steps, deleting, modifying, reordering, and exploding

The Mold Layout application contains the same basic Mold Opening information as the Mold or Die Opening process. Click Mold or Die Opening Process in the Help Table of Contents for more information.

**The Mold Layout Toolbar**

The Mold Layout toolbar appears in the Mold Layout application that is available in Assembly mode. You can click and drag the toolbar, which is displayed in a vertical position when you open the Mold Layout application, to place it horizontally.

Click the icons, as shown here from left to right, to open the following menus and perform the following operations:

- Place a Mold Cavity model in Mold Layout—Opens the **MOLD LAYOUT > CAV LAYOUT** menu.
  
  Create, redefine, or replace a Mold Cavity model in a cavity layout.
Perform operations with Mold Bases—Opens the **Mold Base Selection** dialog box.

Add, replace, or delete a mold base using the **Mold Base Selection** dialog box. You can select the vendor, series, size, and parameter of the mold base, and control the orientation of the mold base assembly.

Create a Cut—Opens the **SOLID OPTS** menu.

Create a Pocket cut; for example, a clearance cut for cavity insert or other component.

Subtract Reference Parts from other parts—Opens the **CutOut** menu.

Cut Out selected parts (for example workpieces) from moldbase plates or other parts.

Access Catalog functionality—Opens the **MOLD LAYOUT > CATALOG** menu.

Add, redefine, delete, or trim a component set in a catalog, for example an Ejector Pin in a catalog supplied by PTC or your custom catalog.

Create a Runner feature—Opens the **Runner** dialog box.

Define the name, shape, default size, flow path, direction, and intersecting parts of the runner.

Create a Waterline feature—Opens the **Water Line** dialog box.

Define the diameter, circuit, and intersecting parts of the water line.

Create a User-defined feature—Invokes the UDF functionality.

Place a user-defined feature in the Mold Layout.

Create/Open Mold Cavity—Opens the **Select Mold/Cast Cavity** dialog box.

Switch into Mold Cavity mode for the Mold cavity that corresponds to the currently displayed Mold layout.

The **Pocket Cut, Runner, Waterline**, and **User Defined** command buttons are active in Modify Part mode or in Modify Subassembly mode, so that you remain in these modes. All other functions in the Mold Layout toolbar interrupt the Modify Part or Modify Subassembly mode.

### The Mold Layout Menu

- **Cavity Layout**—Creates, redefines, or replaces an item in a cavity layout.

- **Mold Base**—Adds, replaces, or deletes a mold base. Uses the **Mold Base Selection** dialog box to help you select the vendor, series, size, and parameter of the mold base; allows you to control the orientation of the mold base assembly.
- **Inj Machine**—Adds, replaces, or deletes an Injecting Molding Machine component; uses the Injecting Molding Machine Selection dialog box to allow selection by various parameters.

- **Catalog**—Adds, redefines, deletes, trims, cuts, and verifies a component set in a customized catalog.

- **Runner**—Creates the runners. Uses the Runner dialog box.

- **Waterline**—Creates the waterlines. Uses the Water Line dialog box.

- **Ej Pin Hole**—Creates ejector pin holes, either straight, sketched, or standard.

- **Mold Opening**—Defines the steps for the mold opening process. Also deletes, modifies, reorders, and explodes (simulates the mold opening).

  The Mold Layout application contains the same basic Mold Opening information as the Mold or Die Opening process.

**To Access the Layout Dialog Box**

1. Click on the toolbar, or click MOLD > Mold Model > Locate RefPart. The Layout dialog box and the Open dialog boxes open.

2. Select a part from the open dialog box and click Open. The part you select appears in the Reference Model box on the Layout dialog box.

**To Use the Layout Dialog Box**

1. Click Mold Layout > Catalog > Create. The Layout dialog box opens.

2. Click Mold Model (Cast Model) to select or create a mold or cast model for patterning.

3. Click Mold Model Origin (Cast Model Origin) to select or create a coordinate system that will represent the mold or cast model origin.

4. Click Cavity Layout Origin to select or create a coordinate system to use as the base for dimensions that define the location of cavities.

5. Under Layout, click and select a rule for the positioning of mold or cast models. You can:
   - Modify dimensions of each pattern member directly from the dialog box or add, remove, or replace any individual model (except for the pattern leader).
   - Use the File menu in the Layout dialog box to store or retrieve a population rule in a file on disk.
   - Copy cavity layout rules to create libraries of population rules.
Mold Layout Information

In Pro/ASSEMBLY mode, you can obtain Mold Layout information while you are in the Mold Layout application. Use the Info > Mold Layout menu that appears in the toolbar menu. This menu is available only when the Mold Layout application is active.

The MOLD LAYOUT INFO window contains the following check boxes under Show Info About:

- **Cavity Layouts**
  
  The cavity layout section contains a list of information related to the currently defined cavity layouts.

- **Injection Molding Machine (IMM)**
  
  The Injection Molding Machine section contains a list of the parameters for the currently defined injection machine.

- **Mold Base**
  
  The mold base section contains a list of the parameters for the currently defined mold base.

- **Runners, Waterlines, and Ejector Pin Holes**
  
  These sections contain standard feature information for each feature type.

- **Catalog Sets**
  
  The Catalog Sets section contains specific information about the catalog sets that exist in the model.

The MOLD LAYOUT INFO window also contains the following check boxes under Output Results:

- **Screen**
  
  The screen displays the information in an information window.

- **File**
  
  A file contains the information that you requested to see. The system gives the file a name with a .inf extension.

Cavity Layout

About Cavity Layout

Cavity Layout provides a quick and easy way to place mold cavities according to rectangular, circular, and user defined patterns. You can add, remove, move, or reorient each pattern member or even replace any cavity model with a family table instance.
**Example: Multi-Cavity Mold Structure**

The following Model Tree shows the structure of a multi-cavity mold on the assembly model level.

![Model Tree Image]

**To Create a Typical Multi-Cavity Mold**

1. Create a mold model in Pro/MOLDESIGN that contains a combination of reference model or models and workpieces.

2. Create an assembly model in Pro/ASSEMBLY.

3. Assemble the mold model into the assembly model using the **MOLD LAYOUT > Cavity Layout** command. In the **Layout** dialog box, select the previously created mold model as the cavity model for population.

4. Select a population rule such as **Single**, **Rectangular**, **Circular**, or **Variable** and define the location of the cavities in the **Layout** dialog box.

5. Select and assemble a mold base and an injection machine using the **MOLD LAYOUT > Mold Base** command and the **MOLD LAYOUT > Inj Machine** command.

6. Complete the cavity design in Pro/MOLDESIGN. Create parting surfaces and volumes to define the individual mold components. Split the workpiece with these volumes and surfaces. Create all necessary cavity components and features.

7. Create instances of the reference part if the reference part geometry is different in different cavities. Use **Merge Part** FAMILY TABLE item when the instances of
the reference part should merge their geometry from instances of the design part.

8. Create instances of the mold model, if the geometry in the cavities is different. You can add any component of the mold assembly (including the reference part) as a Component item into the mold FAMILY TABLE to be able to suppress, resume, or replace the component in the mold instances. You can add any mold feature (including parting surface and volume features) to be able to suppress or resume the feature in the mold instances.

9. Use Switch External References or Configure Assembly Component FAMILY TABLE functionality to create instances of extracted components with proper geometry that corresponds to geometry of mold assembly instances where these extracted components are used. (You can use these commands also to create molds with exchangeable inserts.)

10. Create instances of the mold model, if the geometry in the cavities is different.

11. In Pro/ASSEMBLY, replace desired mold models that have been populated by the cavity layout function with an instance from that model.

12. Complete the design in Pro/ASSEMBLY. Create runners, waterlines, and ejector pin holes. Assemble ejector pins from the catalog. Assemble any additional components and create features using the standard assembly commands.

To Create a Simple Six-Cavity Layout

1. Create a new assembly.
2. Select Applications > Mold Layout.
3. Select MOLD LAYOUT > Cavity Layout > Create.
4. Select an existing mold (cast) model.
5. Select the Mold/Cast Model origin.
6. Select the Cavity Layout origin.
7. Click Circular and Radial.
8. Set Cavities to 6.
9. Set Radius to 100.
10. Set Start Angle to 0.
11. Set Increment to 60.
12. Click Preview to check the values. Make any appropriate adjustments.
13. Click OK. The layout will appear in the assembly.

You can also use the MOLD LAYOUT menu to add a mold base, injection machine, waterlines, runners, and ejector pins to the top-level assembly.
To Create a Mold or Casting Model on the Fly
Cavity Layout functionality supports a top-down approach to mold design. When you create a new cavity layout, you can create the cavity model for this layout on the fly.

1. Create a new assembly model. Retrieve the newly created model in the Mold/Casting mode.

2. Select Applications > Mold Layout.

3. Select MOLD LAYOUT > Cavity Layout > Create.

4. Click New to create a new Mold or Cast model on the fly.

5. Specify model name; select an existing mold or cast model template to be used as a template model and enter the outer extents of the new mold or cast model.

To Create a Four-Cavity Mold with Different Core Pins
The task is to create a four-cavity mold that produces four different plastic parts.

1. PLUG (generic model)
2. HEXAGON
3. SQUARE
4. STAR6
5. STAR8

These plastic parts are instances of one generic part as shown in the illustration. The design part instance names are: HEXAGON, SQUARE, STAR6, and STAR8. Four different core pins are needed to produce different hole shapes.

1. Create a mold. Use Pro/MOLDESIGN to create a mold model.

2. Build the RefPart layout. Create the reference part layout with Mold Model > RefPart Layout. Use the HEXAGON instance as the design part required by the dialog. Enter HEXAGON_REF name for the reference part. Select the Rectangle layout type, specify increment (2 items in the both directions), and the distance between the reference parts.

3. Create reference part instances. Retrieve the HEXAGON_REF reference part in Part mode. Create 3 family table instances (SQUARE_REF, STAR6_REF and STAR8_REF) of the reference part. Add the HEXAGON model as a Merge Part family table item and replace it with SQUARE, STAR6 and STAR8 models for corresponding instances.
4. Adjust PefPart layout to take instances into account. Redefine the reference part layout with **RefPart Layout > Redefine**. Switch the layout type to **Variable**. Replace the HEXAGON_REF reference parts with SQUARE_REF, STAR6_REF, and STAR8_REF instances, as appropriate.

5. Add a workpiece. Assemble or create a workpiece as shown in the illustration:

6. Build a parting surface. Create a shadow parting surface with **Parting Surf > Create**. Select all reference parts for Shadow creation. Define the Shut-Off plane (XY plane) in this case. Blank the reference parts: Square_ref, Star6_ref, and Star8_ref with the **Blank** icon on the toolbar.
7. Build volume for core insert. Make sure that `MOLD_VOL_SURF_NO_AUTO_ROLLBACK` config.pro option is set to `YES`. Create a core pin volume for the `HEXAGON_REF` reference part as shown in the illustration and name it `HEXAGON_INSERT`.

8. Trim the volume to reference part geometry. Click **RefPart Cutout** to trim the volume by the reference part.
9. Create a Pattern for the volume. Pattern the HEXAGON_INSERT volume to create volumes representing inserts for all the other reference parts. To do this, create a Pattern for all features in the volume.

10. Split the mold. Create the A_CAVITY volume with the Mold Volume > Split menu. Click One Volume and select the shadow parting surface. Select the upper island (a) from the ISLAND LIST as shown in the illustration. The upper island appears in red.

11. Second split. Create the B_CAVITY volume with Mold Volume > Split. Click One Volume. Select the shadow parting surface and all volumes that represent inserts. Select the lower island (b) from the ISLAND LIST as shown in the illustration. The lower island appears in red.
12. Extract all of the volumes with **Mold Comp > Extract**.

When you complete the extract operation, the four-cavity mold with different core pins appears.

**Mold Model Origin and Cavity Layout Origin**

In a cavity layout operation, you must designate the origins of two coordinate systems, one for the mold model and one for the cavity layout. These coordinate systems allow you to place the cavity subassemblies within the top-level assembly.

The mold model origin defines the orientation of the cavity subassemblies within the layout. The default origin is the first coordinate system in the mold model.

The cavity layout origin defines the general location of the cavity layout in the top-level assembly. You can redefine the location of the entire layout by redefining this coordinate system.
Use the configuration file option `mold_layout_origin_name` to set a specified coordinate system as the default for the cavity layout origin.

**Representing Multi-Cavity Molds in Pro/ENGINEER**

There are two main ways to represent multi-cavity molds in Pro/ENGINEER on the mold model level, and on the assembly model level.

**Mold Model Level**

Use RefPart Layout to create a mold that contains many reference parts. This is best for molds where common core and cavity inserts are used for all cavities.

**Assembly Model Level**

Use the Mold Layout application in a top-level assembly and assemble each cavity as a separate mold model. This technique is best for molds where separate core and cavity pairs are used for each cavity.

In this model structure, you can work on the top assembly and on each cavity subassembly.

- In the top assembly, using the Mold Layout application, you can create a cavity layout, then add a mold base and mold specific features.
- In the top assembly, using standard assembly options, you can design the entire multi-cavity mold (add components, features, and so on).
- In each cavity subassembly, using Mold or Cast mode, you can design the features of that cavity (create parting surface, splits, and so on).

**Rules for Populating the Cavity Layout**

**About Population Rules in a Cavity Layout**

Positioning a single mold (cast) model multiple times within a cavity layout is called populating the layout. There are four population rules, or ways to position cavity subassemblies within a cavity layout. The following population rules are available under **Layout** in the **Layout** dialog box.

- Single Rule
- Rectangular Rule
- Circular Rule
- Variable Rule

**Single Rule**

Use this rule to place the model with zero rectangular dimensions, and to create an empty pattern table. This rule is a way to create a general structure of the model before populating the layout.
When you place a mold or cast assembly in a top assembly using a mold or cast coordinate system and top assembly coordinate system, the system recognizes this as a single rule population. You can then redefine the placement using **CAV LAYOUT > Redefine** and the **Layout** dialog box.

**Circular Rule**
Use this rule to place the model in a circular layout. Specify the following information:
- **Orientation**—Constant or Radial.
- **Cavities**—the total number of models.
- **Radius**—the radius of the circular layout.
- **Start Angle**—the angular coordinate of the first cavity layout member.
- **Increment**—the angular distance between origins of models.
You can define or redefine the placement using the **Layout** dialog box.

**Rectangular Rule**
Use this rule to place the model in a rectangular layout. Specify the following information:
- **Orientation**—Constant, X-Symmetric or Y-Symmetric.
- **Cavities**—the total number of populated models in the X and Y directions.
- **Increment**—the distance between origins of populated models in the X and Y directions.
You can define or redefine the placement using the **Layout** dialog box.

**Variable Rule**
Use this rule to place the model according to a user-defined pattern table. Start values of the pattern table depend on the rule used previously.
You can modify dimensions of each layout member directly from the dialog or add, remove, or replace any individual model (except for the pattern leader).
You can define or redefine the placement using the **Layout** dialog box.

**Mold Bases**

**About Mold Bases**
You can select Mold Base assemblies from the Pro/ENGINEER Mold Base Library and place them in the Mold Layout application. Using the **Mold Base Selection** dialog box, you can then customize the selected mold bases.
To Select and Place a Mold Base

1. Set the `pro_library_dir` configuration file option before performing this procedure.

2. Click **MOLD LAYOUT > Mold Base > OPTION > Add**. The **Mold Base Selection** dialog box opens.

3. Click a Vendor from the list, a Series, Width, and Length.

4. Click a Mold Base from the Mold Bases list.

5. In the **Parameters and Value** list, click the parameter you want and change the value in the text box under the list, if you want to.

6. Under **Mold Base Origin**, select the mold origin.

7. You control the Mold Base Origin by setting the rotation about the Z axis.

8. Click **OK**. The mold base assembly appears in the Pro/ENGINEER window.

To Customize the Mold Base Parameter File

You can customize the parameters in the **Parameters** and **Value** list box.

After changing mold bases (Pro/ENGINEER models from MOLD BASE LIBRARY) make corresponding changes in the mold base parameters file:


2. Edit this file, specify parameters values for corresponding instances.

3. Save the file.

Customizing the Mold Base Parameter File

The original MOLD BASE LIBRARY contains mold bases from the DME, HASCO, and FUTABA companies.

You can customize this library (change existing mold bases or add new ones) changing corresponding Pro/ENGINEER models. If you want to reflect your changes in the **Mold Base Selection** dialog box, you must also change the mold base parameters file because contents of the **Mold Base Selection** dialog box are controlled by this file.

The Mold Base Selection Dialog Box

Use the Mold Base Selection dialog box to select a mold base assembly from the Pro/ENGINEER Mold Base Library, and place it into the Mold Layout application.

You select mold bases using the following parameters:

- Vendor
- Series type
• Length
• Width
• Plate Thickness
• Configuration

You control the Mold Base Origin by setting the rotation about the Z axis.

**To Replace a Mold Base**

The **Replace** command replaces a mold base from the current assembly model.

1. Click **MOLD LAYOUT > Mold Base > OPTION**.
2. Click **Replace**. The **Mold Base Selection** dialog box opens.

**To Delete a Mold Base**

The **Delete** command deletes a mold base from the current assembly model.

1. Click **MOLD LAYOUT > Mold Base > OPTION**.
2. Click **Delete**. The **Mold Base Selection** dialog box opens.

**Injection Molding Machines (IMMs)**

**About Injection Molding Machines (IMMs)**

During the mold layout process, you must know the limits of your injection molding machine to define which mold base you will use. You can now change the user interface to

• Search through a user-defined list of injection molding machines.
• Select a machine.
• Assemble it automatically to the top-level assembly model.

The Injection Molding Machine (IMM) representation must be an assembly model.
Example: Customizing an IMM

To Assemble an Injection Molding Machine (IMM)
1. Select **MOLD LAYOUT > Inj Machine > Add**.
2. The **IMM Selection** dialog box appears. This box contains all the UI required to define and select an IMM.
3. Under **Filters** sort the list by Tie Bars, Pressure, or other parameters.
4. The **Search** command invokes the **Machine Filters** dialog box, which is used to select other parameters for sorting machine list.
5. Select an IMM from the Machine List box.
6. The parameters for the selected machine appear in the Parameter list box.
7. In the IMM Origin box, create or select a coordinate system from the current model. By default, it should use the coordinate system specified in the **MOLD_LAYOUT_ORIGIN_NAME** configuration option or the first coordinate system created in the model.
8. Click **OK** to accept the machine selection and close the dialog box.

**To Customize an Injection Molding Machine (IMM)**
Creating an IMM requires a coordinate system as well as two datum planes, both parallel to the XY plane.
1. Make sure that you are in Assembly mode.
2. Locate the coordinate system at the origin and give the feature string parameter imm_orig_csys=imm_orig_csys.

3. Make sure that the origin is located directly in the center of the intended IMM opening distance or daylight.

4. Offset one datum plane in the positive Z direction from the imm_orig_csys.

5. Give this datum the feature string parameter top_datum= top_datum and the offset dimension top_dim.

6. Offset the other datum from the imm_orig_csys in the negative Z direction.

7. Give this datum the feature string parameter bottom_datum= bottom_datum and offset dimension bottom_dim.

To Set Up IMM Filters for Complex Machine Searches
1. In the IMM Selection dialog box, click More.
2. Select a parameter, an operator, and a value in the option menus.
3. Click Add/Change.
   
   The expression appears in the expression list.
4. Click the expression to select it.
5. Click the option menus to modify the expression.
6. Click Add/Change.
7. Select an expression to populate the parameter, operator, and value option menus with the values of the selected expression.
8. Click Add/Change.
9. To accept the changes, click Close.

To Replace an Injection Molding Machine
2. Select the desired injection molding machine and click OK.

Number Parameters
To customize an IMM, you must set three number parameters. Set the number parameter "max_open" and give it the value of the greatest distance the IMM can be opened, also known as the max daylight. You must also set the number parameter "open_dim" and give it the value of 0 (zero), since it is the value used to open and close the IMM. When assembled with a mold base, this value will be changed programatically. Finally, set the number parameter "fix_dim" and give it any arbitrary value k, since it will also be changed programatically.
You must also set two relations. The first relation is "top_dim=fix_dim". The second relation is "bottom_dim=open_dim".

**Parameter Text File**

The contents of the IMM dialog box are controlled by the file, rmdt_imm_params.txt. You will find this file in the <installation_dir>/text/mold_data directory. This file contains the descriptions of the IMM models and their parameters. The data within this file is organized per assembly model. That is, there is an entry for each model that will be retrieved using this dialog box.

Make sure that the first line of an IMM description is labeled ASSEMBLY, followed by the name of the Pro/ENGINEER assembly file that represents the IMM. Make sure the next line is labeled NAME, followed by the name that will be listed in the dialog box. If the IMM is from a family table, add an additional line labeled FT_INSTANCE, followed by the name of the instance. When creating an entry for a instance of a generic model, give the ASSEMBLY the name of the generic assembly.

**Catalogs**

**About Catalogs**

The catalog functionality has been added to allow you to easily place mold catalog type items such as ejector pins, core pins, screws, and so on, by using an adaptive dialog box that is totally customizable. The Mold Catalog Engine supports the selection, placement and replacement, naming and renaming, and replacement of standard and user-defined catalog mold components. This functionality also supports several specific actions and manipulations that you can perform on these mold components once you place them, including trimming and creating clearance cuts.

The Mold Catalog Engine has the following capabilities:

- Selects the type and specific dimensions and parameters of a component
- Performs all of the engine actions on several standard components at one time
- Groups several components into a component set and provides the ability to manipulate one, some, or all of its members
- Generates a standard name for a standard component with the ability to use a customized name
- Modifies or replaces a component by batch modifying dimensions and parameters
- Trims the component to size by using a quilt, a plane, or another part
- Specifies clearance dimensions and creates clearance cuts

Until the Mold Component Catalog functionality is totally complete (including mold bases), you will still need access to the original Mold Base Library.

To view the Mold Base Library as html, you must first have the latest mold base CD for 2000i or higher. You can open the html file located at
To Create a New Component Catalog
1. You must set the pro_catalog_dir configuration option in the config.pro file before trying to create a new catalog. For example:

    pro_catalog_dir /proe_catalogs/mold_catalog

Or

    pro_catalog_dir r: \proe_catalogs\mold_catalog

By default, the pro_catalog_dir configuration option is set to pro_catalog_dir [proe loadpoint]/apps_data/mold_data/catalog

2. Click MOLD (CAST) > Mold Model (Cast Model) > Catalog or MOLD LAYOUT > Catalog.

You can create a new catalog on the fly or customize an existing catalog by creating or editing catalog objects. These objects must comply with the Catalog Engine conventions and correspond with all other catalog objects.

With the new customizable Mold Catalog supported by the Mold Catalog Engine, you can define and register customized catalogs of mold components like core pins, screws, leader pins, and so on. This customized catalog can then be accessible along with the system supplied mold catalogs. In addition, you can modify any of these catalogs, whether you define them or the system supplies them.

To Set the Index File
1. Place the Index.mnu file in the same directory as the Config.pro file under the Pro_Catalog_Dir option. The Index.mnu file specifies the directory where a certain catalog will be placed, and the name will appear in the Applications—Mold Layout—Catalog menu.

Example: C:/Mold_Catalog_Basic/Catalog

2. Set the Catalog location and name in the Index.mnu file. Set the format as follows:

    CATALOG # # /Catalog_Directory Catalog_name # /Catalog_Directory_2 Catalog_Name_2 #

Example: CATALOG # # /Ejpin Ejector Pin #

The Mold Catalog Engine
The Mold Catalog Engine is specially created Pro/ENGINEER functionality that builds an adaptive user interface (dialog box) that lets you create and modify standard solids using catalog objects and your own input.
The Catalog Engine works with any template model that follows the conventions for a catalog. No special user interface is needed to register a new catalog, and no user interface is needed to customize an existing catalog.

The Catalog Engine uses the following files:

- Menu file (catalog.mnu)—Specifies names for catalogs and paths to catalog objects or to another catalog.mnu file. Located in the pro_catalog_dir directory.
- Template solid file—Located in a directory specified in the catalog.mnu file.
- Layout files—Located in the directory specified in the catalog.mnu file. These files form a tree-like structure.

Creating the Template Part

About the Template Part

The template part is a start part template model used to create a standard solid. It has a relation set that drives its geometry. You should locate this part in the directory that is specified in the catalog.mnu file.

About Naming a New Template Part

Before you create the template part and its associated features, you must name the template part as follows: Catalog Directory Name_universal

About Template Files

You use the catalog template models as templates to create any similar models in a particular catalog. For example, one ejector pin template model is used to create 7000+ different ejector pins supplied in the new Ejector Pin Catalog. These models must contain the necessary geometry to locate the pins as well as the necessary relations to drive the geometry changes. Layout files must also be defined for all model types and sizes according to the Catalog Engine conventions. You can customize and use the template models as start part files for new catalog creation. All changes that you make in the catalog template models are automatically reflected in the Catalog dialog boxes.

To Create the Template Part

1. Name all datums and axis correctly. Name one Datum Plane BASE_PLANE.
2. Name either of the other two perpendicular Datums ORIENT_PLANE. Orient_Plane is the datum you want to use to orient your part within the assembly.
3. Create an axis through the center of your part and name it CENTER_AXIS.

To Create Template Features and Parameters

You build the template part so that all variations of one type of part can be created, for example, there are three types of ejector pins: Regular, Shouldered, and Flat.
The head can be regular or Flat. All Features for all three types and both features for the head must be created in one part.

1. Create all features for all types of parts you wish to create
2. Assign **Dimension_Parameters** to all dimensions you want in the dialog box.
3. Create and Assign any relations needed to drive dimensions not driven through user input.
4. Create **Type_Parameters** according to the types of features you want to turn on and off through each instance.
   For example: If there are Regular, Shouldered, and Flat types of Ejector pins, you might want to create a **Class** parameter, representing the type each instance may be.
5. Assign features with **Type_Parameters** through the part program option. This is how you control the features you want turned on and off through layouts.

**To Control Features Through Layouts**

To control a cut in the universal template model that represents the shouldered ejector pin, follow this procedure.

1. In Part mode click **Tools > Program > Edit Design**.
2. In the Notepad window, find the feature text which controls the cut created for the shouldered ejector pin.
3. Add the following relation above the Add Feature text:
   
   \[
   \text{relation IF Class == "Shouldered"}
   \]
4. Make sure the feature text always ends with **END ADD**.
5. Exit Part mode and click **File > Save** to keep the changes.
6. Test the part by manually changing the **Class** parameter to Shouldered and then regenerate.

**To Create Quilts or Trims in the Model**

1. Assign **Dimension_Parameters**, as you would like to see in the dialog box, relating them to their corresponding dimensions.
2. Assign **Type_Parameters** to features you want to turn on and off. For example, if there are Regular, Shouldered, and Flat types of ejector pins, you might want to create a **Class** parameter, which represents the type each instance can be.
Default Values of Quilt Dimensions

<table>
<thead>
<tr>
<th>Quilt Dimension</th>
<th>Default Value in Millimeters</th>
<th>Default Value in Inches</th>
</tr>
</thead>
<tbody>
<tr>
<td>Head Free Clearance</td>
<td>0.5 mm;</td>
<td>.020</td>
</tr>
<tr>
<td>Chamfer Clearance</td>
<td>0.1</td>
<td>.004</td>
</tr>
<tr>
<td>Shoulder Clearance</td>
<td>0.05</td>
<td>.002</td>
</tr>
<tr>
<td>Free Clearance</td>
<td>0.5</td>
<td>.020</td>
</tr>
<tr>
<td>Working Clearance</td>
<td>0.025</td>
<td>.001</td>
</tr>
<tr>
<td>Plate Thickness</td>
<td>20</td>
<td>.80</td>
</tr>
<tr>
<td>Working Length</td>
<td>10</td>
<td>.40</td>
</tr>
<tr>
<td>Head Flat Clearance</td>
<td>0.025</td>
<td>.001</td>
</tr>
</tbody>
</table>

The following are also default values:

- Head Chamfer Angle 45°
- Leading Chamfer Angle 59°

Creating the Layout

About Creating the Layout Files

The Layout files are files used by the Catalog Engine to build standard solids from the template solid.

- Create all layout files under the Catalog_Directory you specified in your Index.mnu file.
- Create all layout files in the order you want to see them in your dialog box.
- It is essential that all Layout file values in the Parameter tables match the layout file names created for the next level of layouts.

For example: If you have a Parameter in a layout file named Length_Lay_File, and its value for one instance is set to 3_Length.Len, you must create a layout file named 3_Length_len for the next level of Layouts. The 3_length_len layout file would then contain parameters for the length dimensions of the part.

- Catalog Functionality allows you to view GIF images based on the type of part you are selecting. Create as many GIF Images as there are types of parts. These GIF Images can have dimensions or pictures. We recommend that you create a GIF file for each type of part you want in the catalog. You should also create a GIF file for each type of quilt, if you want to add one to your model.
Empty Layout File

- Create a layout file and call it **Catalog Directory Name_Empty**. Do nothing with this layout.

- Use the **EMPTY** Layout file for any values you do not wish to have in your catalog engine.

  For example: If you only have Inch parts, use the Empty Layout for all Metric Values. This way, only the inch option will appear in the Catalog engine.

**Examples: Parameter Tables for Ejector Pin Layouts**

*Layout Param Table Examples for Hasco Shoulder Ejector Pin*  

Main Layout File

```plaintext
! Layout name: EJPIN_MAIN
! Name       UNIT_LAY_FILE      PERFORM_TRIM      PERFORM_CUT
!
! ================================================
! CURRENT       EJPIN_UNITS       YES           YES
```

Units Layout File: EJPIN_UNITS

```plaintext
! Layout name: EJPIN_UNITS
! Name       UNIT_LAY_DESCR    PRO_UNIT_SYS   VENDOR_LAY_FILE   HEAD_LAY_FILE   QUILT_LAY_FILE
!
! ================================================
! CURRENT       UNIT_SYSTEM   MINS        EJPIN_MIN_VENDOR   EJPIN_MIN_VENDOR   EJPIN_MIN_VENDOR
MINS       UNIT_SYSTEM   MINS        EJPIN_MIN_VENDOR   EJPIN_MIN_VENDOR   EJPIN_MIN_VENDOR
MINS       UNIT_SYSTEM   MINS        EJPIN_MIN_VENDOR   EJPIN_MIN_VENDOR   EJPIN_MIN_VENDOR
```

For Head_Lay_File and Quilt_Lay_File structure, see below Ejector Pin LEN File

Vendor Layout File: EJPIN_INCH_VENDOR

```plaintext
! Layout name: EJPIN_INCH_VENDOR
! Name       VENDOR_LAY_DESCR    VENDOR      TYPE_LAY_FILE
!
! ================================================
! CURRENT       VENDOR      HASCO       EJPIN_HASCO_INCH_TYPE
HASCO       VENDOR      HASCO       EJPIN_HASCO_INCH_TYPE
UME        VENDOR      UME         EJPIN_UME_INCH_TYPE
PROGRESSIVE      VENDOR      PROGRESSIVE     EJPIN_PROGRESSIVE_INCH_TYPE
NATIONAL      VENDOR      NATIONAL     EJPIN_NATIONAL_INCH_TYPE
DMS          VENDOR      DMS         EJPIN_DMS_INCH_TYPE
```

Type Layout File: EJPIN_HASCO_INCH_TYPE
| Size Layout File: EJPIN_HASCO_INCH_ZI-44_SIZE |

<table>
<thead>
<tr>
<th>Name</th>
<th>TYPE</th>
<th>LENGTH</th>
<th>DIAMETER</th>
<th>SIZE</th>
<th>LAY_FILE</th>
<th>DIA_FILE</th>
<th>HEAD_DIA</th>
<th>HEAD_THK</th>
<th>RADIUS</th>
</tr>
</thead>
<tbody>
<tr>
<td>ZI-41</td>
<td>TYPE</td>
<td>ZI-41</td>
<td>REGULAR</td>
<td>EJPIN_HASCO_INCH_ZI-41_SIZE</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZI-416</td>
<td>TYPE</td>
<td>ZI-416</td>
<td>REGULAR</td>
<td>EJPIN_HASCO_INCH_ZI-416_SIZE</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>/44</td>
<td>TYPE</td>
<td>/44</td>
<td>SHOULDER</td>
<td>EJPIN_HASCO_INCH_44_SIZE</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>71 445</td>
<td>TYPE</td>
<td>71 445</td>
<td>SHOULDER</td>
<td>EJPIN_HASCO_INCH_71 445_SIZE</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Size Layout File: EJPIN_HASCO_INCH_ZI-44_SIZE

<table>
<thead>
<tr>
<th>Name</th>
<th>TYPE</th>
<th>LENGTH</th>
<th>DIAMETER</th>
<th>SIZE</th>
<th>LAY_FILE</th>
<th>DIA_FILE</th>
<th>HEAD_DIA</th>
<th>HEAD_THK</th>
<th>RADIUS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1,44X1B</td>
<td>NUMBER</td>
<td>1,44X1B</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_ZI-44X1B_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3 1/4X1</td>
<td>NUMBER</td>
<td>3 1/4X1</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_3 1/4X1_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3 1/4X3</td>
<td>NUMBER</td>
<td>3 1/4X3</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_3 1/4X3_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1 1/4X1B</td>
<td>NUMBER</td>
<td>1 1/4X1B</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_1 1/4X1B_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1 1/4X3</td>
<td>NUMBER</td>
<td>1 1/4X3</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_1 1/4X3_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5 1/4X1</td>
<td>NUMBER</td>
<td>5 1/4X1</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_5 1/4X1_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5 1/4X3</td>
<td>NUMBER</td>
<td>5 1/4X3</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_5 1/4X3_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7 1/4X1</td>
<td>NUMBER</td>
<td>7 1/4X1</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_7 1/4X1_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7 1/4X3</td>
<td>NUMBER</td>
<td>7 1/4X3</td>
<td>DIAMETER</td>
<td>EJPIN_HASCO_INCH_7 1/4X3_LEN</td>
<td>0.000000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SCALE_PER DIAMETER</th>
<th>HEAD DIAMETER</th>
<th>HEAD THICKNESS</th>
<th>RADIUS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1:125</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>1:25</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>1:5</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>1:10</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>1:20</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>1:5</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>1:10</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>1:20</td>
<td>0.25</td>
<td>0.125</td>
<td>0.125</td>
</tr>
</tbody>
</table>
Length Layout File: EJPIN_HASCO_ZI44_3_64X1_2_LEN

Quilt Layout Files: EJPIN_QUILT_INCH

Head Layout File: EJPIN_HEAD_INCH

Head Flat Layout File: EJPIN_HEAD_FLAT

Quilt Head Layout File: EJPIN_QUILT_HEAD_INCH
To Create the Main Layout File

1. Create a file named Catalog Directory Name_Main. You create three Parameters in this Layout File.

2. Name the first parameter Unit_Lay_File.

3. Name the second parameter Perform_Trim.

4. Name the third parameter Perform_Cut.

5. All three parameters must be added to the Param_Table and set accordingly.
   - Set the Unit_Lay_File parameter to: Catalog Directory Name_Units.
   - Set the Perform_Trim parameter to Yes or No depending on whether or not you have a trim in your universal model.
   - If set to Yes, Mold Layout functionality will allow you to place a trim.
   - If set to No, the option will be blanked out.
   - Set the Perform_Cut parameter to Yes or No depending on whether or not you have a Cut Quilt in your universal model.
   - If set to Yes, Mold Layout functionality allows you to place a Cut Quilt and modify its dimensions.
   - If set to No, the option will be blanked out.
To Create the Unit Layout File

1. Name this file Catalog Directory Name_Units.

2. Create two parameters in this Layout File.

3. Name the first Parameter Unit_Lay_Descr.

4. Name the second Parameter Pro_Unit_Sys.

5. Create a Layout File Parameter for the next level of layouts you wish to see in your dialog box. Name it (Desired name for next level )_Lay_File. For Example: If the next Item you want to select in the dialog box is by Vendor, I would create a parameter named Vendor_Lay_File.

6. Create any Layout Files you wish to use to control a feature independent from all other controlled dimensions in your model.

   For Example: If you want a cut on the head of an ejector pin, and it can be used on any ejector pin, regardless of size, length, or type, you can create a layout file specifically to control the head cut alone. Use the same convention described above. If you want a cut in the head, I might name the parameter Head_Lay_File.

7. If the Perform_Cut Parameter was set to Yes in the Main Layout File, you must create a parameter called Quilt_Lay_File.

8. Add all parameters to the Param Table.

9. Edit the Param Table and add two instances: one for inch and the other for metric. These are the two values you will see in the dialog box under the Unit Title.

10. Set Unit_Lay_Descr to your desired Title name for the Units option in the dialog box. Type this name for both the inch and metric instances. An example is Unit System.

11. Set the Pro_Unit_Sys values as follows: MMNS for Metric Instance and PROE_DEF for Inch instances. This setting indicates to Pro-E that you are working in Inch or Metric.

12. Set the (Desired name for next level )_Lay_File values as follows:

   o Catalog Directory Name_MM_(Desired name for next level) for the metric instance

   o Catalog Directory Name_INCH_( Desired name for next level ) for the inch instance

13. Set the Instance values for independent feature layout files.

   For example: If I have a Head_Layout_File parameter, I would set the instances as follows.

   o Directory Name_Head_MM for metric instance

   o Directory Name_Head_INCH for inch instance
14. If Quilt_Lay_File exists, instance values should be set as follows: Directory Name_Quilt_MM for metric instance and Directory Name_Quilt_INCH for inch instance.

To Create the Quilt Layout File
1. If the Perform_Cut Parameter was set to Yes in the Main Layout File, a quilt parameter should have been created in the Unit Layout file. Two values for the Quilt_Layout_File should have been created - one for inch and one for metric.

2. Create two Layout files, using the same name as the two values for Quilt_Layout_File parameter in the Unit_Layout_File. Directory Name_Quilt_MM for metric instance and Directory Name_Quilt_INCH for inch instance.

3. For each new layout, create two parameters for each value you want to control in your quilt.

4. The first of these two parameters should have the same name as the parameter you created in your universal model to drive a certain value of the quilt. For Example: If you have a diameter value on your quilt, and you related a parameter equaling it called Quilt_Diameter in your universal model, you need to create a parameter in my Directory Name_Quilt_(Inch or Metric) Layout named Quilt_Diameter_UI. If you add the letters UI to the end of the Parameter, the catalog program recognizes it as a dimension you want to control using the catalog.

5. Set this new dimension Parameter with a default value and add it to the Param_Table.

The second of these two parameters should have the same name as the first parameter with the addition of the word _Header on the end of it. This allows the Catalog program to create a selection for the desired driven dimension

6. Set the value of the second parameter, as you would like to see it in the dialog box. For Example: In the second parameter described earlier, it would be named Quilt_Diameter_Header, and you could set the value as (Diameter). When you select the Quilt Cut option in the catalog, you now see a Diameter option with your default value underneath it.

7. Make sure you create both of these parameters for each dimension you want to control in the catalog engine.

8. Perform step three for both Inch and Metric layouts.

To Create the Next Level Layout File
1. Create the next level Layout File parameter in the Unit_Layout File. You should use Vendor as the next level for the following directions and examples.

2. Create two values for the Vendor_Lay_File - one for inch and one for metric.

3. Create two Layout files, using the same name as the two values for Vendor_Lay_File parameter in the Unit_Layout_File.
To Create the Type Layout File

The Type Layout file consists of the type of ejector pin.

1. Create the parameters that describe the type of part in the universal model. For the ejector pin example, there are three types: Regular, Shouldered, and flat.
2. These type parameters should be related to features, through program function, in the universal model. These parameters are assigned to features so they can be turned on and off according to the type of part you want to select.

3. Create the Type_Lay_File parameter in the Last Level Layout file. In this case, it is the Vendor Layout File.

4. Create Layout files for each instance in the Vendor_Layout_File, using the same name as the values found under the Type_Lay_File parameter. In this case, create five New Layout files for each Vendor Layout Type. There are a total of 10 files: 5 for each Vendor Layout file, and 5 for the Metric Vendor Layout File.

**To Create Parameters in the New Layout File**

1. Name the first parameter Type_Lay_Descr in the Type Layout.

2. Name the second parameter Type in new Layout.

3. Create a Layout File Parameter for the next level of layouts you want to see in the dialog box, the same as the Vendor_Layout_File.

4. At this next level of layouts, add the dimension parameters from your model. Name it (Desired name for next level)_Lay_File. For Example: If the next Item you want to select in the dialog box is by the Diameter Size of Ejector Pin, create a parameter named Size_Lay_File.

5. Create Type_Parameters according to the exact Type_Parameters you created in your universal model. In this Example: I created a type parameter named Class for the Regular, Shouldered, and Flat types of Ejector pins. This means I must create a parameter named Class in each of my New Type Layout Files.

6. Create GIF File Parameters, if desired. GIF Images can be added to the Catalog.

7. Name the first GIF parameter (Type_Parameter)_GIF_File in the Type Layout. In this Example: there is a type parameter named Class for the Regular, Shouldered, and Flat types of ejector pins. This means I should create a GIF parameter named Class_GIF_File in each of the New Type Layout files.

8. If Perform_Cut Parameter has been set to Yes, create the Quilt GIF Parameter in Type Layout and name it Quilt_GIF_File.

9. Add all parameters to the Param Table.

10. Edit the Param Table and add instances.

11. Create an instance for every type of part you have under the last level of Layouts.

12. For Example: Hasco is a Vendor that makes Ejector Pins. In the ejpin_hasco_in_type Layout file, add four instances, one for each type of ejector pin that Hasco makes. The types are ZI 41, ZI 416, ZI 44, and ZI 446.

13. Set the Type_Lay_Descr to your desired Title name for the Type option in the dialog box. Type this name in the Param Table for all instances, for example, (Type).
14. In the template model there is a parameter called Type. The Type Parameter in the Type_Layout_File corresponds with the parameter in the template model. Enter the Type name for each instance with the same value as the instance name.

15. The (Desired name for next level) _Lay_File values should be set as follows: Catalog Directory Name_Previous Level Name_(Units)_Current Level Name _(Desired name for next level).

It does not matter what value you use to describe the next set of layouts. This is the recommended way of doing it since it shows the following:
- Type of part you are working on
- Level (In this case Vendor)
- Units (Inch or Metric)
- Level you are currently in (In this case Type)
- Level you want to see next (In this case Size).

16. So in the example for the ejpin_hasco_in_type Layout file, use the following name for the first instance: ejpin_hasco_in_zi41_Size.

17. Set the Class parameter to the values you created in the template model. This parameter controls features that are turned on and off in the model. Enter the value exactly as you did in Part mode. In the test case, the ZI41 is a regular ejector pin. For this instance, type REGULAR for the parameter Class, the same as IF Class == "REGULAR" in the universal part program for the universal part corresponding feature.

18. Set the Class_GIF_File parameter values to the exact name you used for the GIF Files. A GIF File should have been created for each type (Regular, shouldered, or Flat in this case).

19. Set the Quilt_GIF_File parameter values (if applicable) to the exact name you used for your Quilt GIF Files. A Quilt GIF File should have been created for each type of part you are creating (Regular, shouldered, or Flat in the test case).

To Create the First Level Dimension Parameter Layout File

The First Level Dimension Parameter Layout File is created after Type Layouts.

1. The (Desired name for next level) _Lay_File values in the type layout file determine the Dimension of first level Dimension layouts. In this test case, the ejector pin Diameter size.

2. Create Layout files for each instance in the Type_Layout_FILE, using the exact same name as the values for (Desired name for next level) _Lay_File (Size_Layout_File in the test case) parameter. In the test case, Hasco Inch has four types, so create four Size Layout files.
3. The size of the ejector pin diameter is the first dimension you may want to use to search. You can now create parameters in the new layout file. Size is the example for the desired name for the next level.

4. Name the first parameter Size_Lay_Descr created in Size Layout.

5. Name the second parameter in the new Layout with the name of the parameter for the dimension you are using to control this level of Layouts. Control this level by the diameter of the ejector pin.

6. Create a parameter named Dimension. This parameter should also exist in the template model, and should be related to the dimension that drives the dimension you want to control by selection. In this case, the diameter name is the dimension of the universal ejector pin model.

7. As with the Type_Layer_File, create a Layout File parameter for the next level of layouts you wish to see in the dialog box. This is the next dimension you want to use to search.

8. The next level of layouts should not be a dimension that is controlled by the first dimension. Name it (Desired name for next level)_Lay_File. For Example: If the next Item you want to select in the dialog box is by the Length of Ejector Pin, create a parameter named Len_Lay_File.

9. Create Dimension Parameters for any dimensions controlled by the dimension you select to lead this level of layouts.

10. For example: In the test case of ejector pins, the dimension you can select to search with first is the diameter of the ejector pin. Based on catalog pages, the Head Diameter, Head Thickness, and Radius at the Head are all controlled by the diameter of the pin.

11. Create a parameter for each of these dimensions. These Parameter names must also exist in the universal model.

12. Name these parameters exactly as they are written in the universal model. These parameters should be related to their corresponding dimensions in the universal model. This is how the catalog knows what dimensions to change in the universal model according to the layouts.

13. Add all Parameters to the Param Table.

14. Edit the Param Table and add instances. Create an instance for every different dimension that changes in the type of part you is working on.

   For example: ZI 41 type has many diameters. So, in the ejpin_hasco_in_zi41_size Layout file, add twenty-five instances, one for each diameter size ejector pin that Hasco makes for the ZI 41 Type.

   The name of the instance should correspond to the dimension by which you would like to select (in this case Diameter). Since the name of the instance is a dimension, and decimals, spaces, or slashes cannot be entered as the instance name, create a convention of underscores and dashes to recognize decimal and fractional values. For inch fractional values, use underscores in place of slashes,
and dashes in place of spaces. For example: 1/16 would be 1_16. 1-1/2 would be 1-1_2. For decimal and metric values, use zeros for spaces, and underscores for decimals.

For example: 0.117 becomes 0_117, or 3.3 millimeters become 3_3

15. Set the Size_Lay_Descr to your desired Title name for the Size option in the dialog box. Type this name in the Param Table for all instances, for example, Diameter.

16. Set the (Desired name for next level)_Lay_File values as follows:

   Catalog Directory Name_Pre Previous Level Name_(Units)_Previous Level Name_Current Level Name_(Desired name for next level)

   It does not matter what value you use to describe the next set of layouts. This is the recommended way of doing it since it shows the type of part you are working on.
   
   o First level (in this case Vendor ) under which you are creating this layout
   o Units (Inch or Metric)
   o Last level (in this case Type ) under which you are creating this layout
   o Level you are currently in (In this case size)
   o Level you want to see next (in this case length )

17. In the example case for the ejpin_hasco_in_zi41_size Layout file, use the following name for the first instance: ejpin_hasco_in_zi41_1_16_Len.

18. Enter the values for dimension parameters. These values are the actual values that drive the model along with the values you will see in the dialog box. Make sure you enter real numbers for the second parameter you created (Dimension) rather than the instance name. The instance name is what the user will select, but the second parameter actually drives the template model.

19. Continue with the above steps until the last searchable dimension.

**To Create the Final Level Layout File**

1. The Controlling Dimension of the Final level Dimension layouts is already determined by the name of the (Desired name for next level)_Lay_File values in the dimension layout file before this level, for example, the ejector pin length.

2. Create Layout files for each instance in the Last (Size in this case)_Layout_File, using the exact name as the values for (Desired name for next level)_Lay_File (Len_Layout_File in the test case) parameter. In the test case, Hasco Inch has 25 diameter sizes, so create 25 Len Layout files.

3. When creating the parameter in the new layout file (for example purposes use Len as an example for the desired name for the final level) since the length of the ejector pin is the dimension on which you want to search.

5. The second parameter created in the new Layout should be the name of the parameter for the dimension you are using to control this level of Layouts. To Control the final level by the length, create a parameter named Length. This Parameter should also exist in the template model, and should be related to the dimension that drives the dimension you want to control by selection. In this case, this dimension is the Length dimension of the universal ejector pin model.

6. Create a parameter Order_Number in the Final Layout files. This Parameter should also be included in your universal model.

7. Create Dimension Parameters for any dimensions controlled by the dimension you select to lead this level of layouts.

For example: In the test case of ejector pins, the dimension I want to search with is the length of the ejector pin. Based on catalog pages, there are no other dimensions driven by the length for the regular size. However, if I were working with a Shouldered type ejector pin, the overall length of the ejector pin would control the shoulder length. Thus, I would add the Shoulder Length Parameter to the len layout file.

- These Parameter names must also exist in the universal model.
- Name these parameters exactly as they are written in the universal model.
- These parameters should be related to their corresponding dimensions in the universal model. This is how the catalog knows what dimensions to change in the universal model according to the layouts.

8. Add all Parameters to the Param Table.

9. Edit the Param Table and add instances. Create an instance for every different dimension that changes in the type of part you are working on. For Example: ZI 41 type. 5/32 diameter pin has 5 length. So, in my ejpin_hasco_in_zi41_5_32_len Layout file, add 5 instances, one for each ejector pin length that Hasco makes for the ZI 41 Type, 5/32-diameter ejector pin.

10. The name of the instance should correspond to the dimension you would like to finally select by (in this case Length). Since the name of the instance is a dimension, and decimals, spaces or slashes cannot be entered as the instance name, a convention of underscores and dashes should be created to recognize decimal and fractional values. For inch fractional values, I recommend using underscores in place of slashes and dashes in place of spaces. For example: 1/16 would be 1_16. 1 1/2 would be 1-1_2. For Decimal and metric values I recommend using zeros for spaces and underscores for decimals. For example: 0.117 would be 0_117, or 3.3 millimeters would be 3_3.

11. Set the Len_Lay_Descr to the desired Title name for the Length option in the dialog box. Type this name in the Param Table for all instances, for example, Length.

12. Enter values for dimension parameters. These values are the actual values that will drive the model, along with the values you will see in the dialog box. Make sure you enter real numbers for the second parameter you created (Dimension)
rather than the instance name. The instance name is what you will use to select, but the second parameter actually drives the universal model.

13. Enter the part number under the parameter Order_Number for each instance in the last level layout file.

**To Create Additional Feature Layouts**

1. Follow the same rules as described for the other Layout files to control any feature not related to the other layouts. This feature needs to have its first Layout Parameter in the Units Layout, for example, Flat Cut in the ejector pin head.

2. Create GIF Images for the additional features.

3. Create Quilts for the additional feature.

4. Add UI at the end of any parameter you want to manually control in the catalog. This parameter must be accompanied with a header as well.

5. Create dimension Layouts for any dimensions you want to select while using the catalog.

**To Create Quilts or Trims in the Model**

1. Assign Dimension_Parameters, as you would like to see in the dialog box, relating them to their corresponding dimensions.

2. Assign Type_Parameters to features you want to turn on and off. For example, if there are Regular, Shouldered, and Flat types of ejector pins, you might want to create a Class parameter, which represents the type each instance can be.

**Using the Component Catalog**

**About Using the Component Catalog**

Using the Catalog Engine, you can maintain a component catalog that performs the following functions:

- Selects and places standard components
- Redefines and places set members
- Trims the standard components
- Creates standard clearance holes for standard components

**To Select and Place a Catalog Component**

The **Mold Layout** or **Mold Model > Add Set** command allows you to select, place, and name a set of standard components, such as ejector pins, using the **Define Set** dialog box and the **Define Parameters** dialog box.
1. Click **Mold Layout > Catalog > [Ejector Pin] > Add Set**. The **Define Set** dialog box opens.

2. Select a datum point feature to define the location of catalog set members.

3. Click the set type: **Identical** or **Variable**.

4. If you select **Variable**, you can specify the following settings for each component: the type, base plane, and orientation plane. The Set Members table opens within the dialog box, listing all selected datum points. To add or change a component at each selected location, highlight a row in the table and continue with the procedure. As you define each component, the table shows the selected settings.

5. Select the component to add. You can select a component from the catalog or from the components in the model.

6. To select from the catalog, click the Catalog icon under **Component**. The **Define Parameters** dialog box opens.

7. Specify all parameters for the component: **UNITS**, **VENDOR**, **TYPE**, **DIAMETER**, **LENGTH**, and **HEAD**.

   A drawing shows the selected component with all required parameters. A table under the drawing lists all parameter values. After you define all parameters, specify the name for the component set. Click OK to return to the Define Set dialog box.

8. To select from the model, click the **From Session** icon, and select a component from the Model list. Click **OK** to return to the **Define Set** dialog box.

9. Select the base plane for placement of the components.

10. Select a plane to use for the orientation of the components.

11. Click **OK** to add the component set.

**Component Set Menu**

You can access the Catalog Engine through the **MOLD > Mold Model > Catalog** menu or the **Applications > MOLD LAYOUT > Catalog** menu. When you select the catalog type (for example, **Ejector Pin**), the **Component Set** menu appears.

The **Component Set** menu consists of the following items:

- **Add Set**—Allows the selection, placement, and naming of a set of standard components, such as ejector pins, with the **Define Set** dialog box and the **Define Parameters** dialog box.

- **Redefine Set**—Redefines a set of standard components, such as ejector pins, with the **Define Set** dialog box and the **Define Parameters** dialog box.

- **Delete Set**—Deletes a set of standard components, such as ejector pins.

- **Trim to Geom**—Trims a set of standard components, such as ejector pins, with the **Trim to Geom** functionality.
• **Clearance Cut**—Creates a clearance cut on some or all of the component set members using the **Clearance Cut** dialog box. The **Define Parameters** dialog box can be used to select clearance values.

**To Trim a Catalog Component**

You can select components to trim. Select **Trim to Geom** references, select a trim type, and enter an offset value using these steps:

1. Click **Mold Layout > Catalog > Ejector Pin > Trim to Geom**.
2. Select a component from the set. The selected set is highlighted. The **Trim Components** dialog box opens.
3. For a variable set, select a component from the **Set Members** window to perform the operation.
4. Specify the type of object to use for trimming. Click **Part**, **Quilt**, or **Plane**.
5. Select a bounding object.
6. If you are trimming by a part or by a closed quilt, click **Trim Type** and select the type. You can trim by the first or the last intersecting surface.
7. If you want to trim with an offset from the bounding surface, type the offset value in the **Offset** field.
8. Click **OK** to finish.

If a trimming plane intersects components from an identical set at different heights (for example, if the trimming plane is inclined), you must redefine the set to **Variable** so you can trim each component correctly.

**To Create Holes for Catalog Components**

After you add components, you must create holes for them by cutting them with the quilt using the **Clearance Cut** command.

1. Click **Mold Layout > Catalog > [Component Name] > Clearance Cut**.
2. Select a component name from the set. The selected set is highlighted. The **Clearance Cut** dialog box opens.
3. For a variable set, select a component from the Set Members window to perform the operation.
4. For an identical set, specify the type of the cut: **Identical** or **Variable**.
5. Specify the parameters for the hole. Click the Catalog icon from the **Quilt Parameters** field.

The **Define Parameters** dialog box opens. Specify all parameters for the component hole. A drawing shows a section of a hole for the component with all required parameters. A table under the drawing lists all parameter values. After you have defined all parameters, click **OK** to return to the **Define Set** dialog box.
6. Specify assembly components to intersect. Click **Define** from the **Intersect Components** field. The **INTRSCT OPER** menu opens. You can select the components automatically or manually.

   - To select components automatically, click **INTRSCT OPER > Add Model > Auto Sel**. The system highlights the intersected components. Click **Confirm**. The system creates a cut through the selected components, excluding the mold and reference parts.
     
     If you select components with **Auto Sel**, the cutting quilt intersects all components.

   - To select components manually, click **INTRSCT OPER > Add Model > Manual Sel**. Select the components to intersect.

7. Click **OK** to finish.

**The Define Parameters Dialog Box**

The **Define Parameters** dialog box has the following layout:

- **Filter area**—Lists all parameters that you can define for the component.
- **Parameters area**—Shows a drawing of the selected component indicating all required parameters and listing parameters and their values.
- **Component Name**—Displays the current component name and allows you to rename it here.

**Customizing the Catalog**

**About Customizing the Catalog**

You can create a new catalog or customize an existing one by creating or editing the catalog objects. The new and customized catalog objects must correspond to:

- All catalog objects
- Catalog engine conventions

**To Add a New Command to Pull-Down Menu in the UI Dialog Box**

1. Retrieve a layout where the pull-down menu is defined as a parameter table.
2. Add the new parameter set into the table.
3. Save the layout.

**To Change a Default Selection of the Pull-Down Menu**

1. Retrieve a layout where the pull-down menu is defined as a parameter table.
2. Apply a parameter set that is a default selection in the pull-down menu.
3. Save the layout.

**To Add a New Input Panel**
1. Retrieve a layout.
2. Create a user input (_UI) parameter in this layout.
3. Create a corresponding user input description parameter (_UI_DESCR).
4. Add these parameters to the parameter table, if necessary.
5. Retrieve the template part model.
6. Create the necessary part or feature relations.
7. Save the layout and template part.

**To Change a Default Value of the Input Panel**
1. Retrieve a layout where this input panel is defined as a UI parameter.
2. Change the value of the parameter to a new default value.
3. Save the layout.

**To Change a Layout-Driven Component Dimension**
This dimension is driven by the layout, but not reflected in the UI.
1. Retrieve a layout where the driving parameter is defined.
2. Change the value of the parameter.
3. Save the layout.

**To Change a Non-layout Driven Component Dimension**
1. Retrieve the template part model.
2. Modify the dimension.
3. Save the model.

**Glossary**

**Glossary of Terms**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>BASE_PLANE</td>
<td>A datum plane in the template model that is needed for Mate placement constraint.</td>
</tr>
<tr>
<td><strong>Base quilt</strong></td>
<td>First feature created in a parting surface</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td><strong>Black volume</strong></td>
<td>Undercuts in the reference part, that is, areas that generate trapped material during mold opening (unless a slider is created). They are defined as areas of the reference part where a light shining in the Pull Direction does not reach.</td>
</tr>
<tr>
<td><strong>Catalog</strong></td>
<td>Set of information used to represent one catalog type. For example, Ejector Pin Catalog, Nut Catalog.</td>
</tr>
<tr>
<td><strong>Catalog command</strong></td>
<td>A top-level menu item in Mold and Cast modes and in the Mold Layout application.</td>
</tr>
<tr>
<td><strong>Catalog_Directory</strong></td>
<td>Represents the directory name where the catalog parts and layouts are created.</td>
</tr>
<tr>
<td><strong>Catalog Engine</strong></td>
<td>Pro/Engineer functionality that builds an adaptive user interface and enables creation and modification of standard solids using catalog objects and user interaction.</td>
</tr>
<tr>
<td><strong>Catalog.mnu</strong></td>
<td>A text file that specifies names for catalogs and paths to catalog objects or to other catalog.mnu files. Located in a directory specified in PRO_CATALOG_DIR. Format of this file should be consistent with menu files in Pro/Library. This file establishes the CATALOG menu.</td>
</tr>
<tr>
<td><strong>Catalog_Name</strong></td>
<td>Represents the name that appears in the Applications-Mold Layout-Catalog dialog box.</td>
</tr>
<tr>
<td><strong>Catalog objects</strong></td>
<td>All files that are needed to create and modify a standard solid. This is a common term used to refer to template solid, layout files, and GIF bitmap files.</td>
</tr>
<tr>
<td><strong>CATALOG SET Menu</strong></td>
<td>Contains the commands that maintain a catalog set.</td>
</tr>
<tr>
<td><strong>CENTER_AXIS</strong></td>
<td>An axis in the template model that is used by the Catalog Engine for the Point on Line placement constraint.</td>
</tr>
<tr>
<td><strong>Clearance Cut command</strong></td>
<td>Located on the CATALOG SET menu, this command is activated by the PERFORM_CUT parameter.</td>
</tr>
<tr>
<td><strong>Comp Trim command</strong></td>
<td>Located on the CATALOG SET menu, this command is used to trim a standard solid.</td>
</tr>
<tr>
<td><strong>GIF bitmap files</strong></td>
<td>Bitmaps used by Catalog Engine in user interface dialog boxes.</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>GIF File Parameter</strong></td>
<td>Special parameter that defines a GIF bitmap image file shown in the user interface. The type of this parameter is STRING. For example, XXX_GIF_FILE</td>
</tr>
<tr>
<td><strong>Index.mnu file</strong></td>
<td>Specifies the directory where a certain catalog will be placed along with the name that will appear in the Applications-Mold Layout-Catalog dialog box.</td>
</tr>
<tr>
<td><strong>Layout Description Parameter</strong></td>
<td>Special description parameter for layout where this parameter exists. The type of this parameter is STRING. For example, _LAY_DESCR</td>
</tr>
<tr>
<td><strong>Layout files</strong></td>
<td>Pro/Notebook layouts used by Catalog Engine to build standard solid(s) from template solid. Usually, layout used by Catalog Engine can have parameter table with several parameter sets.</td>
</tr>
<tr>
<td><strong>Layout File Parameter</strong></td>
<td>Special parameter that defines the layout file to be parsed next, declared to standard solid, and used to build user interface. For example, _LAY_FILE.</td>
</tr>
<tr>
<td><strong>LENGTH_UI_CHECK</strong></td>
<td>In Relations, a validation check parameter that checks the value of the LENGTH_UI parameter.</td>
</tr>
<tr>
<td><strong>_main layout file</strong></td>
<td>Activates the CATALOG SET menu; located in the directory specified in the catalog.mnu file; contains unlimited number of parameters.</td>
</tr>
<tr>
<td><strong>Order Number Parameter</strong></td>
<td>Special parameter that generates a name in the catalog. The type of this parameter is STRING. For example, ORDER_NUMBER</td>
</tr>
<tr>
<td><strong>ORIENT_PLANE</strong></td>
<td>A datum plane in the template model that is needed for Orient placement constraint; to orient your part within the assembly.</td>
</tr>
<tr>
<td><strong>Patches</strong></td>
<td>Additional features created in a parting surface after the first one.</td>
</tr>
<tr>
<td><strong>PERFORM_CUT Parameter</strong></td>
<td>Set in the main layout file. Controls the Clearance Cut command. Must be set to Yes type and defined.</td>
</tr>
<tr>
<td><strong>PERFORM_TRIM Parameter</strong></td>
<td>Set in the main layout file. Controls the Company Trim command. Must be set to Yes type and defined.</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>PRO_CATALOG_DIR</strong></td>
<td>The config option that sets where the catalog directory is located; all parts and layouts are located here.</td>
</tr>
<tr>
<td><strong>Pull Direction</strong></td>
<td>The direction of mold opening.</td>
</tr>
<tr>
<td><strong>Quilt</strong></td>
<td>A “patchwork” describing the geometry and intersection of a single or multiple non-solid surfaces.</td>
</tr>
<tr>
<td><strong>QUILT_FOR_CUT</strong></td>
<td>A quilt feature in the catalog that is needed to have the Clearance Cut command and the assembly cut feature.</td>
</tr>
<tr>
<td><strong>Quilt GIF File Parameter</strong></td>
<td>Special quilt parameter that defines a GIF bitmap image file shown in the quilt parameters dialog box. For example, QUILT_GIF_FILE.</td>
</tr>
<tr>
<td><strong>Quilt Layout File Parameter</strong></td>
<td>A layout file parameter that must be defined so that the Catalog Engine will process layout file parameters, user input parameters, and GIF file parameters that exist in a quilt layout. For example, QUILT_LAY_FILE.</td>
</tr>
<tr>
<td><strong>Quilt User Input Parameter</strong></td>
<td>Special quilt parameter that creates an input panel in a special dialog box for quilt parameters. For example, QUILT_UI.</td>
</tr>
<tr>
<td><strong>REAL NUMBER</strong></td>
<td>A type of _UI parameter.</td>
</tr>
<tr>
<td><strong>Shrinkage</strong></td>
<td>Contraction of the molding or metal casting as it solidifies and cools.</td>
</tr>
<tr>
<td><strong>Silhouette Curve</strong></td>
<td>Curve intended to produce a valid parting line edge. A silhouette edge is the contour of a model in a specific viewing; a desirable edge to split a mold along because, since it is the contour, there is no overhang along this edge in the specified viewing orientation.</td>
</tr>
<tr>
<td><strong>Sprue</strong></td>
<td>Primary feed channel from the injection unit to the runner channel.</td>
</tr>
<tr>
<td><strong>Standard solid</strong></td>
<td>Pro/Engineer model that represents an item (line) from some catalog book.</td>
</tr>
<tr>
<td><strong>STRING</strong></td>
<td>Type of LAY_FILE parameter.</td>
</tr>
<tr>
<td><strong>Template solid model</strong></td>
<td>Pro/Engineer solid model which will be copied and &quot;morfed&quot; into standard model by Catalog Engine; located in a directory specified in the catalog.mnu file.</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>TRIM_FEATURE</strong></td>
<td>A feature in the catalog that is needed to activate the <strong>Comp Trim</strong> command for trimming a standard solid.</td>
</tr>
<tr>
<td><strong><em>UI</em> CHECK</strong></td>
<td>In Relations, a validation check parameter postfix that checks values of user input. For example, LENGTH__UI_CHECK.</td>
</tr>
<tr>
<td><strong>Unit System Parameter</strong></td>
<td>Special parameter that defines the unit system of a standard solid. The type of this parameter is STRING, and the value is a name of the unit system. For example, PRO_UNIT_SYS.</td>
</tr>
<tr>
<td><strong>User Input Description Parameter</strong></td>
<td>Special description parameter that describes input panel in a dialog box. Corresponds to the same _UI name postfix. For example, _UI_DESCR.</td>
</tr>
<tr>
<td><strong>User Input Parameter</strong></td>
<td>A parameter that creates one input panel in a user interface dialog box. The type of this parameter is STRING. For example, _UI.</td>
</tr>
<tr>
<td><strong>User Interface</strong></td>
<td>Menus and dialog boxes that are needed for user interaction while working with standard solids. The user interface built by the Catalog Engine is adaptive; it is based on catalog objects and is sensitive to user interaction and creation of strings.</td>
</tr>
<tr>
<td><strong>Validation Check Parameter</strong></td>
<td>Special validation check parameter that checks the value of user input. The type of this parameter is Yes or No. For example, _UI_CHECK LENGTH__UI_CHECK checks the value of the LENGTH__UI parameter.</td>
</tr>
<tr>
<td><strong>YES or NO</strong></td>
<td>The type of validation check parameter.</td>
</tr>
</tbody>
</table>
Index

A
accuracy
  absolute ....................................... 119
  relative ....................................... 119
accuracy ....................................... 119
Accuracy command
  ASSEM SETUP menu ................ 119
Add
  SKETCH VOL ................................ 98
  SURF DEFINE ............................. 41
Add ........................................... 41, 98
Add Set command
  EJECTOR PIN menu ................. 114
Add Set command ...................... 114
Adv Utils
  CAST MODEL............................ 15
  MOLD MODEL............................ 15
Adv Utils ..................................... 15
Advanced
  SOLID OPTS.......................... 98
  SRF OPTS ............................... 41
Advanced ................................... 41, 98
After Rels command ................. 22
All
  GATHER FILL......................... 93
All ........................................... 93
All Dims
  SHRINK SET.......................... 22
All Dims .................................. 22
All Wrkpcs  
  SPLIT VOLUME........................... 78
  All Wrkpcs.............................. 78
area offset feature
  in mold or casting................... 155
  area offset feature................... 155
Assemble command
  CAST MODEL menu .................. 110
  MOLD MODEL menu................. 110
  Assemble command.................. 110
assembling
  mold or cast model................. 27
  assembling............................. 27
  assembly component............... 112
Attach command
  DIE COMP menu....................... 97
  MOLD COMP menu.................... 97
  Attach command.................... 97
  Attach Volume feature............ 97
Automatic Workpieces
  Automatic Workpiece dialog box 39
  creating ...................... 39
  Automatic Workpieces ............. 39
B
Before Rels command .......... 22
Blank
  CAST MODEL ......................... 15
  MOLD COMP ......................... 99
  MOLD MODEL ......................... 15
  Blank.............................. 15, 99
Blank dialog box .................. 100, 123
Blend
  SOLID OPTS ...................... 98
  SRF OPTS .......................... 41
Blend ................................ 41, 98
BOM
  Mold or Cast Info .............. 17
BOM .................................. 17
By Feature
  SHRINK SET ........................ 22
By Feature .......................... 22
By Table
  SHRINK SET ...................... 22
By Table ............................ 22
C
Cast Assem
  CAST MDL TYP .................... 134
Cast Assem ........................ 134
Cast Check
  CAST MODEL ........................ 15
Cast Check ........................ 15
Cast Feature
  CAST ................................ 15
Cast Feature ........................ 15
cast features
  cast results ...................... 109
die block ........................... 37
fixture .............................. 110
overview ........................... 134
reference parts .................... 27
sand core .......................... 108
cast features ........................ 27, 37, 108, 109, 110, 134
Cast Mod ........................... 15
Cast mode
  entering .......................... 17
Cast mode ........................... 17
Cast Model
  CAST ................................ 15
Cast Model ........................... 15
Cast Result
  CAST MDL TYP .................... 15
Cast Result .......................... 15, 109
Cast Result command ............ 109
casting
  typical session .................. 6
casting .............................. 6
Cavity Design toolbar ........... 14
cavity layout
  circular rule ...................... 181
  creating a mold or cast model .... 175
  multi-cavity mold ................ 173
  origin ............................. 179
  overview .......................... 172
  rectangular rule ................ 181
  rules .............................. 180
  single rule ....................... 180
  six-cavity layout ................ 174
  variable rule ..................... 181
cavity layout. 172, 173, 174, 175, 179, 180, 181
Cavity Layout command
  MOLD LAYOUT menu ............... 173
Cavity Layout command .......... 173
Clear
  SHRINK SET......................... 22
  SHRK BY SCALE.................25
Clear................................. 22, 25
Clearance Cut command
  EJECTOR PIN menu............... 115
Clearance Cut command...... 115, 117
Close command
  GATHER STEPS menu.............. 94
Close command.................... 94
component catalog
  creating a new................. 187
  in mold.......................... 203
  obtaining information .......... 131
  setting the index file......... 187
component catalog ...... 131, 187, 203
Component Placement dialog box
  creating mold components ..... 111
  deleting mold components ..... 112
  removing mold components ...... 111
Component Placement dialog box 110, 111, 112
Coord SYS
  SCALE FACTORS ................. 25
Coord SYS ................................ 25
Copy
  SRF OPTS ......................... 41
Copy.................................... 41
core prints.......................... 108
Create
  CAST MODEL ...................... 15
  MOLD MODEL ................... 15
  PARTING SURF................... 45
Create ................................ 45
Create command
  MOLD VOLUME menu ............ 88
  MOLDING menu ......... 109
Create command ...... 88, 109
Cs y
  GEN SEL DIR .................... 45
Cs y..................................... 45
Curve dialog box
  closing silhouette curve gap.... 135
gap closure dialog box .......... 135
  handling undercuts ............ 137
Loop Selection command........ 135
  Slides command............... 137
Curve dialog box .......... 135, 136, 137
D
datum curve
  transforming in casting .......... 70
datum curve......................... 70
Del Pattern
  CAST MODEL ...................... 15
  MOLD MODEL ................... 15
Del Pattern......................... 15
Delete
  CAST MODEL ...................... 15
  MOLD COMP ................ 112
  MOLD MODEL ................... 15
  MOLDING ...................... 109
Delete ......................................... 15
Delete Set command
   EJECTOR PIN menu .................. 116
Delete Set command ................. 116
design model in mold or casting
   overview.................................. 19
   workflow................................. 4
design model in mold or casting .... 19
Determining the Optimal Pull Direction
   ............................................. 126
Dft Envrnmt command
   DRAFT LINE menu..................... 138
Dft Envrnmt command .............. 138
Die Block
   CAST MDL TYP ............................. 15
   CAST RECLASS ........................... 112
Die Block ..................................... 15
die block in molding or casting
   creating automatically .............. 39
creating manually .................... 38
cutting out a workpiece ............ 89
making solid ............................ 109
with cavity ................................ 79
die block in molding or casting .38, 79, 89
Die Comp
   CAST ......................................... 15
   CAST MDL TYP ............................. 15
Die Comp ..................................... 7
die component
   assembling ............................ 111
die component .......................... 111
Die Opening
   CAST ......................................... 15
   CAST menu .............................. 166
   Die Opening ......................... 166
dimension ................................ 18
Draft Check
   CAST CHECK ............................. 125
   MOLD CHECK ............................. 125
Draft Check .................. 125
draft checking ......................... 125
draft environment in mold or cast
   defining .................................. 138
draft environment in mold or cast.. 138
Draft Line command
   FEATURE menu .......................... 138
Draft Line command ................ 138
E
ejector pin
   adding a set .......................... 114
catalog (overview) ................. 113
clearance holes ...................... 115
creating a set ......................... 114
deleting a set ......................... 116
name ...................................... 116
redefining a set ...................... 116
trimming .................................. 117
ejector pin .................. 114, 115, 116
Ejector Pin Catalog
   accessing ................................ 113
   overview ................................ 113
Ejector Pin Catalog .................. 113
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>ejector pin clearance holes</td>
</tr>
<tr>
<td>creating ........................................................................... 163</td>
</tr>
<tr>
<td>ejector pin clearance holes ............. 163</td>
</tr>
<tr>
<td>Ejector Pin command ............. 113</td>
</tr>
<tr>
<td>Erase</td>
</tr>
<tr>
<td>FILE ............................................................................. 17</td>
</tr>
<tr>
<td>Erase ............................................................................. 17</td>
</tr>
<tr>
<td>extending a parting surface ......69, 70</td>
</tr>
<tr>
<td>Extract command</td>
</tr>
<tr>
<td>DIE COMP menu ............. 107</td>
</tr>
<tr>
<td>MOLD COMP menu ............. 107</td>
</tr>
<tr>
<td>Extract command ............. 107</td>
</tr>
<tr>
<td>Extrude</td>
</tr>
<tr>
<td>SOLID OPTS ..................... 98</td>
</tr>
<tr>
<td>SRF OPTS ..................... 41</td>
</tr>
<tr>
<td>Extrude ......................41, 98</td>
</tr>
<tr>
<td>F</td>
</tr>
<tr>
<td>Family Tab</td>
</tr>
<tr>
<td>CAST ............................................................................. 15</td>
</tr>
<tr>
<td>MOLD ............................................................................. 15</td>
</tr>
<tr>
<td>Family Tab .......... 15</td>
</tr>
<tr>
<td>Feature</td>
</tr>
<tr>
<td>MOLD ............................................................................. 15</td>
</tr>
<tr>
<td>Feature .................................. 15</td>
</tr>
<tr>
<td>feature layout in mold ................. 203</td>
</tr>
<tr>
<td>Fill</td>
</tr>
<tr>
<td>GATHER STEPS ................. 93</td>
</tr>
<tr>
<td>Fill .................................. 93</td>
</tr>
<tr>
<td>Fillet</td>
</tr>
<tr>
<td>SRF OPTS ..................... 41</td>
</tr>
<tr>
<td>Fillet ..................... 41</td>
</tr>
<tr>
<td>Final Value</td>
</tr>
<tr>
<td>SHRINK SET ......................................................... 22</td>
</tr>
<tr>
<td>Final Value .................................................................. 22</td>
</tr>
<tr>
<td>Fixture</td>
</tr>
<tr>
<td>CAST MDL TYP ......................... 15</td>
</tr>
<tr>
<td>CAST RECLASS ..................... 112</td>
</tr>
<tr>
<td>Fixture .................................................................. 110</td>
</tr>
<tr>
<td>fixture in casting</td>
</tr>
<tr>
<td>creating a new ................................................................ 110</td>
</tr>
<tr>
<td>fixture in casting ................................................................ 110</td>
</tr>
<tr>
<td>Flat</td>
</tr>
<tr>
<td>SRF OPTS .................................................. 41</td>
</tr>
<tr>
<td>Flat .................................. 41</td>
</tr>
<tr>
<td>G</td>
</tr>
<tr>
<td>gap closure</td>
</tr>
<tr>
<td>silhouette curve .................................. 135</td>
</tr>
<tr>
<td>skirt parting surface ...................................... 135</td>
</tr>
<tr>
<td>using the Gap Closure dialog box ................................ 136</td>
</tr>
<tr>
<td>gap closure ................................................................ 135, 136</td>
</tr>
<tr>
<td>Gap Closure command .................................. 135</td>
</tr>
<tr>
<td>Gather command ......................... 89</td>
</tr>
<tr>
<td>gathering volume</td>
</tr>
<tr>
<td>combining with sketching .................................. 98</td>
</tr>
<tr>
<td>displaying volume definition ................................... 95</td>
</tr>
<tr>
<td>filling inner loops ................................................................ 93</td>
</tr>
<tr>
<td>gathering volume ................................................................ 93, 95, 98</td>
</tr>
<tr>
<td>Gen Assem</td>
</tr>
<tr>
<td>CAST MDL TYP ......................... 15</td>
</tr>
<tr>
<td>CAST RECLASS ..................... 112</td>
</tr>
<tr>
<td>MOLD MDL TYP ......................... 15</td>
</tr>
<tr>
<td>MOLD RECLASS ..................... 112</td>
</tr>
</tbody>
</table>
Gen Assem ........................... 15, 112
H
Horizontal
OFFSET SURF ...................91, 99, 156
Horizontal ...................91, 99, 156
I
information
obtaining ................. 131
on molding or casting ....... 131
information ................. 131
inherited reference part
redefine
dependency ............ 36
placement ............ 37
shrinkage ............ 35
redefine ............ 34
inherited reference part .... 33
Injection Molding machines (IMMs)
assembling ............... 184
customizing ............... 184
number parameters .......... 185
parameter text file ........... 186
replacing ........... 185
setting up filters .......... 185
Injection Molding machines (IMMs)........ 184, 185, 186
inner loop closure in skirt surfaces .. 52
Integrate
CAST ..................................15
MOLD ..................................15
Integrate ..................... 15
Interface
CAST .................................15
MOLD .................................15
Interface ..................... 15
Interference
in mold ...................... 167
Interference .............. 167
Interference command
DEFINE STEP ................. 167
Interference command .... 167
L
Layer
CAST .................................15
MOLD .................................15
Layer ..................... 15
layout file in mold
creating ...................... 190
creating parameters in a new.... 198
final level parameter ....... 201
first level dimension parameter .. 199
main ......................... 194
next level ..................... 196
type ......................... 197
unit ......................... 195, 196
layout file in mold 190, 194, 195, 196, 197, 198, 199, 201
layout of mold cavity .......... 169
Loop Closure command ......51
loop selection
intersecting the silhouette curve. 136
lower chain ................... 136
upper chain............................. 136
loop selection............................. 136
Loop Selection command............. 135
Loops
    GATHER FILL............................. 93
Loops.......................................... 93
M
Merge by Ref
    REF MDL.................................. 27
Merge by Ref ................................ 27
Mld Base Cmp
    MOLD MDL TYP.......................... 15
Mld Base Cmp.............................. 15
Modify
    CAST........................................ 15
    MOLD....................................... 15
Modify......................................... 15
mold analysis............................. 124
Mold Assem
    MOLD MDL TYP.......................... 134
Mold Assem............................... 134
mold base
    deleting.................................. 183
    placing.................................... 182
    replacing.................................. 183
mold base ......................... 182, 183
Mold Base command
    MOLD LAYOUT.............................. 182
Mold Base command.................. 182
mold base component
    assembling into mold or cast
        assembly................................. 110
    creating a new........................... 110
    mold base component.................. 110
MOLD BASE Library
    components................................ 118
    fixtures................................... 118
    selecting a component from........... 203
MOLD BASE Library ......................... 118
mold base parameter file
    customizing............................... 182
mold base parameter file........... 182
Mold Catalog Engine..................... 187
mold cavity design.................... 14
mold cavity layout.................... 169
Mold Cavity Model
    checking interference.................. 167
Mold Cavity Model ....................... 17, 167
Mold Check
    MOLD MODEL............................... 15
Mold Check................................. 15
Mold command
    INFO menu............................... 131
Mold command........................... 131
Mold Comp
    MOLD MDL TYP.......................... 134
Mold Comp................................. 134
mold design
    typical session.......................... 2
mold design............................... 2
mold features
mold base............................... 182
mold results............................ 109
overview................................. 134
reference parts.......................... 27
workpiece ................................ 37
mold features.... 27, 37, 109, 134, 182
mold layout application
obtaining information ............... 172
overview................................. 168
placing a mold base ................. 182
trim to geom feature ............... 157
mold layout application . 168, 172, 182
Mold Layout toolbar .................... 169
Mold mode
entering ................................... 17
Mold mode................................... 17
Mold Model
creating a multi-cavity mold ...... 173
extracting components .......... 109
origin ..................................... 179
Mold Model ......................... 173, 179
Mold Opening command
MOLD menu ............................ 166
Mold Opening command .............. 166
mold or cast assembly
adding a shadow surface.......... 45
adding a skirt surface .......... 43
assembling a die block........... 38
assembling a mold component... 110
assembling a mold or die component ........................................ 111
assembling a reference part ....... 27
assembling a workpiece .......... 38
creating parting surfaces ........ 41
cutting out a workpiece or die block ........................................ 89
cutting out reference parts ....... 96
die block ................................... 37
modifying volume....................... 99
regenerating............................. 119
removing a component ............. 111
sand core ................................ 108
shadow surface ....................... 45
workpiece .................................. 37
mold or cast assembly . 27, 37, 38, 41, 43, 45, 89, 96, 99, 108, 110, 111
mold or cast component
adding regular features .......... 132
assembling ................................. 111
from MOLD BASE library ............. 118
reclassifying ............................ 112
removing ................................ 111
mold or cast component 111, 118, 132
mold or cast features
overview .................................. 164
mold or cast features ................. 164
mold or cast information
obtaining................................. 131
mold or cast information ............. 131
mold or cast model
accuracy .................................. 120
creating a new ......................... 13
creating a new reference part ...... 28
creating a silhouette curve ........ 135
creating a simple reference part layout ........................................ 29
creating features .......................... 134
design model .............................. 19
displaying exploded geometry ... 168
draft environment .......................... 138
files ........................................ 17
inserting features .......................... 133
parting surfaces .......................... 40
reference part layout ...................................... 29
regenerating ................................... 119
shadow surface .......................... 45
skirt surfaces .................................. 42
structure ........................................ 12
mold or cast model 12, 13, 17, 19, 28, 29, 40, 42, 45, 119, 133, 134, 135, 138, 168
mold or cast result
producing ........................................ 109
mold or cast result .................................. 109
mold or die opening sequence
defining ...................................... 166
mold or die opening sequence ..... 166
Mold Volume
SPLIT VOLUME ................. 78
Mold Volume ............................ 78
Molding
MOLD ....................................... 15
Molding ....................................... 15
multi-cavity mold
creating ...................................... 173
multi-cavity mold ......................... 173
N
next level layout file in mold ........... 196
number parameters for IMMs ........... 185
O
Offset
COMP VOL ...................... 91, 99, 156
MOLD VOL ...................... 91, 99, 156
SRF OPTS .............................. 41
Offset ...................................... 41
One Volume
SPLIT VOLUME ...................... 78
One Volume ............................. 78
One Volume command
SPLIT VOLUME menu ............. 75
One Volume command ............. 75
opening sequence
defining .............................. 166
opening sequence ..................... 166
P
parting curves
automatic .............................. 140
create ...................................... 139
modifying .............................. 139
parting curves ......................... 69, 70, 138
Parting Surf
MOLD ....................................... 15
Parting Surf .................................. 15
parting surfaces
advanced .............................. 49
check ............................ 130
creating a new.......................... 41
creating by copying.................... 42
extending ...................... 64, 69, 70
extending to a plane .............. 65
filling a complex cut .............. 51
filling a hole in ................. 50
merging................................. 60
modifying ................................. 58
overview............................... 40
redefining ................................. 58
renaming .................................. 58
spanning .................................. 66
tangent to reference part ....... 70
trimming by vertex round ....... 61
trimming methods .................. 60
trimming to a silhouette edge ... 61
trimming using basic forms ...... 62
trimming using existing features .. 62
using a draft feature ............ 57
using a draft offset feature ...... 57
using a quilt ......................... 56
using a transform feature ....... 57
using an area offset feature ...... 57
parting surfaces 40, 41, 42, 50, 51, 56, 57, 58, 60, 61, 62, 64, 65, 66, 69, 70

Pattern
CAST MODEL ............................. 15
MOLD MODEL ............................ 15

Pro/MOLDESIGN
product overview ................. 1
Pro/CASTING ......................... 1, 207
Pro/MOLDESIGN ....................... 1, 207
glossary ............................... 207
pull direction

determining optimal................ 125

Q
quilt layout file in mold ............ 196

R
Reclassify

assembly components ............... 112
Redefine
CAST MODEL ............................. 15
MOLD MODEL ............................ 15
Redefine ...................................... 15
Redefine Set command
EJECTOR PIN menu .................. 116
Redefine Set command ............. 116

Ref Model
CAST MDL TYP ............................ 15
MOLD MDL TYP ............................ 15
Ref Model ............................... 15

Ref Part
MOLD MDL TYP ............................ 27
Ref Part ............................... 27

reference model
inherited ............................ 33
same model .................................. 32
reference model ........................... 32
reference part ................................ 33
reference part layout
creating a simple layout............... 29
reference part layout.................. 29
References
GATHER SPEC ........................... 89
References ................................. 89
Regenerate
CAST........................................ 15
MOLD....................................... 15
Regenerate .................................. 15
regular features
adding to a mold or cast component
............................................. 132
regular features .......................... 132
Relations
CAST........................................ 15
MOLD....................................... 15
Relations ..................................... 15
Remove
SKETCH VOL .............................. 98
Remove ....................................... 98
Rename
FILE......................................... 17
Rename ...................................... 17
Revolv e
SOLID OPTS................................ 98
SRF OPTS .................................. 41
Revolv e ..................................... 41, 98
Round
CREATE VOL .................................. 88
Round ........................................ 88
runner
creating .................................... 160
creating by selecting.................... 161
creating by sketching................... 161
overview .................................... 159
shapes ....................................... 160
runner ....................................... 159, 160, 161
Runner command
MOLD ASSEM menu ..................... 160
Runner command .......................... 160
S
Same Model
REF MDL .................................. 27
Same Model ................................. 27
sand core
creating .................................... 108
sand core ................................... 108
Sand Core command
CAST MDL TYP menu ................... 108
Sand Core command ..................... 108
Save As
file .......................................... 17
Save As ...................................... 17
Sel Comp
SCALE FACTORS menu .................. 25
SPLIT VOLUME menu ................... 78
Sel Comp ................................. 25, 78
Set Up

223
CAST........................................ 15
MOLD....................................... 15
Set Up ........................................ 15
Shadow command
SRF OPTS menu ........................ 45
Shadow command ........................ 45
shadow surface
adding a new ................. 45
filling inner loops .......... 51
shadow surface .......... 45, 51
Shdw Cut Out
MOLD COMP.............................. 89
Shdw Cut Out ...................... 89
Show Volume command
VOL GATHER ....................... 95
Show Volume command .......... 95
Shrink Info command.......... 26
Shrink Ratio......................... 22
shrinkage
applying by dimension .......... 22
applying by scaling ............ 25
formula ............................. 21
specifying ......................... 21
shrinkage ................ 21, 22, 25
Shrinkage command
CAST menu............................... 21
MOLD menu ............................. 21
Shrinkage command .......... 21
shrinkage formula .......... 21
shrinkage information .......... 26
silhouette curve in mold or cast
closing a gap ...................... 135
creating .......................... 135
silhouette curve in mold or cast .... 135
Simplfd Rep
CAST MODEL ....................... 15
MOLD MODEL ....................... 15
Simplfd Rep ......................... 15
Sketch
CREATE VOL .......................... 98
Sketch ................................. 98
skirt surfaces
adding a new ............. 43
defining inner loop closure .... 52
filling inner loops .......... 51
overview ......................... 42
skirt surfaces ........ 42, 43, 51, 52
sliders
creating ......................... 102
troubleshooting ................ 103
using ................................. 103
sliders ............................... 101
Solid
SOLID OPTS ....................... 98
Solid .................. 98
solid split ......................... 79
Specify
formula .......................... 21
Specify ..................... 25
split feature
failure diagnostic messages .... 80
split feature ..................... 80
Index

Split Vols
Mold or Cast Info .................. 17
Split Vols .................. 17
Static Part
DEFINE STEP .................. 167
Static Part .................. 167
Sweep
SOLID OPTS .................. 98
SRF OPTS .................. 41
Sweep .................. 41, 98
Switch Dim
SHRINK SET .................. 22
Switch Dim .................. 22
T
tangent draft
constant angle .......... 149, 150
curve driven .......... 142, 143, 144
cut .................. 152, 153
tangent draft .......... 141
Tangential
OFFSET SURF ........... 91, 99, 156
Tangential ........... 91, 99, 156
tangential parting surface extension 69, 70
template features in mold ........ 188
template part in mold ........ 189
To Replace a Mold Volume Surface 101
To Use RefPart Cutout ........ 156
toolbar
Cavity Design ................ 14
toolbar ................ 14
Transitional Surface ........ 50
Trim Components dialog box
component set ........ 205
trimming ejector pins ........ 205
Trim Components dialog box .......... 205
Trim to Geom command
EJECTOR PIN menu .......... 117
Trim to Geom command .......... 117
Trim to Geom feature
Cast mode ................ 158
Mold mode ................ 157
overview ................ 157
trimming a volume ........ 100
trimming in the Catalog .......... 205
Trim to Geom feature .. 100, 157, 158, 205
Two Volumes command
SPLIT VOLUME menu .......... 76
Two Volumes command .......... 76
Type
GATHER SPEC ................. 89
Type ................ 89
type layout file in mold .......... 197
U
UDF
defining
  in mold or cast ...................... 162
placing
  in mold or cast ...................... 163
UDF ................................... 162, 163
Unblank
  CAST MODEL ............................ 15
  DIE COMP ................................ 99
  MOLD COMP ................................ 99
  MOLD MODEL ............................ 15
Unblank .................................. 99
unit layout file ........................ 195
V
varied
  dimensions ............................. 34
  features ................................ 34
  parameters .............................. 35
  references ............................... 36
varied .................................... 34
verifying model design .............. 124
volume
  classifying ............................ 86
  closing .................................. 94
  creating a round
    constant radius ...................... 88
  creating an attach volume feature 97
defining ................................. 88
displaying .................................. 95
gathering ................................. 89
modifying ................................. 99
renaming .................................. 100
sketching ................................. 98
splitting (overview) .................. 73
splitting into one ....................... 75
splitting into two ....................... 76
splitting methods ...................... 78
splitting using parting surfaces ....... 77
volume 73, 75, 76, 77, 78, 86, 88, 89, 94, 95, 97, 98, 99, 100
W
water lines
  checking circuits .................... 165
  creating ............................... 165
water lines .............................. 165
workflow
  designing a mold ...................... 4
workflow ..................................... 4
workpiece in mold or cast
  assembling into mold or cast
    assembly ................................ 38
  creating automatically ................ 39
  creating manually ...................... 38
  cutting out a reference part .. 38, 96
workpiece in mold or cast ............. 38
Workpieces .............................. 40