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Introduction 
 
This is a basic tutorial is designed to expose the user to the most common functionality within Routed Systems Designer 5.0. 
If you have not upgraded from Routed Systems Designer Lite or have not purchased the full version please do not continue with this tutorial. RSD 5 Basic 
Tutorial – Lite.pdf is the recommended tutorial to learn about the capabilities of Routed Systems Designer Lite 
 
Please note to become fully proficient with Routed Systems Designer please contact you local account representative for details of an RSD training 
course. 
 
 
 
Conventions 
 
Select  – Click with left hand mouse button  
LMB  – Left Hand Mouse Button 
MMB – Middle Mouse Button 
RMB – Right Hand Mouse Button 
CSV – Comma Separated Variable File 
* > * – Task 1 > Task 2 > etc > etc 
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About View Controls 
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XP Style UI 

Cursor options 
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Background Color 

Highlight Color 

Editing the color pallet 

Auto-save 
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Directory Defaults 

To improve the usability of saving and retrieving files there is the ability to set the directory defaults. 
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SETTING UP STANDARD PROPERTIES FOR A DRAWING SHEET 

Creating Subtypes 

Using properties with catalog templates 

Creating a new sheet 

Using CSV files 

CIRCUIT DIAGRAMS 

Creation a new sheet 

Placing Shapes 
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About Signal Networks 
To Instance Signals 
To manipulate Signals 

About Context-sensitive cursors 
Create 
Edit 

Routing Signals 

Branching - Set-up 
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LOCATION SETS 

About Location Sets 

To Create or Edit Location Sets 
Creating a new location Set 
Setting label visibility 
Setting the label function 
Setting sequential sheet numbering 
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To Set the Column Width or Row Height 

To Set the Labeling Datum’s 

To Move Sheets Between Location Sets 

To Delete a Location Set 

To Remove a Sheet From a Location Set 
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Using Java in location sets 

WIRING DIAGRAMS 

Creating a sheet 
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Sort 
Criteria 

Placing Groups with the report tool 
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DEFINING CATALOG ITEMS 
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Defining a port artifact 

Defining a port shape 

Grids 
About Grid Icons 
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DATATABLE EXPLORER 
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About Managing Datatables Using the Datatable Explorer 
Folder actions 
Load actions 
Miscellaneous actions 

About CSV files 

About Datatables 

About Membermaps 

About Portmaps 

Creating Folders 

Loading CSV Files 

FIBERS 

Creating a Template Fiber 

About Fiber End Geometry 

Setting Fiber End Details & Auto Wiring Wire 

TO WIRE A SIGNAL NETWORK 

Wiring the signal network 

Port Manipulation Mode 

Link Manipulation Mode 
Example: Use of the Wire and Core Assignment Editor 

WIRE & CORE ASSIGNMENT EDITOR – CIRCUIT DIAGRAMS 

AUTO-GENERATING WIRES 

APPLYING PROPERTIES TO A FIBRE 
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WIRE AND CORE ASSIGNMENT EDITOR - WIRING DIAGRAMS 

Auto wiring 

TRAIL FILES 

About Trail Files 
To Record a Trail File 
To Play a Trail File 
To Automatically Run a Trail File When You Start RSD 
To Control the Display During Trail File Playback 
To Compare Trail Files 

CUSTOMIZING THE USER INTERFACE 
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MAPKEYS 

About Mapkeys 
To Create a Mapkey 
To Delete a Mapkey 

Creating a Mapkey 

UPDATING PROTOTYPE INSTANCES 

ABOUT UPDATING VARIABLE GROUPSHAPES 

Changing the Circuit Diagram 

APPLYING DATA SETS 

ABOUT ADDING, REMOVING, AND REORDERING MEMBERS IN VARIABLE GROUPS 
To Add a member 
To remove a member 
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To reorder a member 

Re-ordering RL-01 

CREATING A CABLE DEFINITION 

About Cables 

Methods of instancing cables 
Bundling cores 
Creating a predefined cable 
Example: Simple Cable 
Example: Multi-level Cable 

To Instance a Cable By Bundling Cores 

To Instance a Cable By Creating a Predefined Cable 
Routing a single core 
Routing between two connectors 
Routing between Selected ports 

About Spare Cores 

About Shields 

Ways in which a Shield can be connected 

Reporting Shields 
Direct Link 
Through drain wires 

Example: Ways in Which a Shield Can be Connected 

To Add a Shield to a Cable 
To draw the shield port shapes 
To draw the shield wires 
Example: Multiple Shield Port Shapes 

To Create a Cable Group Definition 
To create a cable in the catalog for bundling cores together 
To create a Predefined cable in the catalog 

About Cable Decorations 
To Add a Cable Decoration 
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To Change the Type of a Cable Decoration 
To Move a Cable Decoration 
To Delete a Cable Decoration 

Creating a 3 Conductor Cable 

Using the new cable 

SETTING UP FOR PRO/CABLING 

About the Model Explorer 
Preview 
Folder Properties, Sheet Properties 
Artifact Properties, Shape Properties 
Property Set Properties 

About Using the Model Explorer 

Setting Port information 

WIRING FROM TO LIST 

EXPORTING XML DATA TO PRO/CABLING 

About Exporting a Design to Pro/CABLING 
Connectors 
Cables 
Ports 
Wires 

About Exporting a Design to Pro/PIPING 
Pipelines (Groups) 
Equipment 
Nozzles 
Branches 
Fittings 
Ports 

Exporting to an XML file 

IMPORTING XML DATA INTO PRO/CABLING 2001 
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Introduction 
About Routed Systems Designer 
 
Routed Systems Designer helps designers and engineers to quickly and easily create complex interconnected routed systems diagrams as an integrated 
part of the total product development process. Routed Systems Designer allows the creation of the following types of diagrams: 

o Wiring 
o Piping 
o Process and instrumentation design (P&ID) 
o Block 
o Functional 
o Schematic 

Routed Systems Designer is a standalone package. However, it is an integrated part of Pro/ENGINEER and allows the reuse of diagrams to drive 3D 
cabling and piping routing using the Pro/ENGINEER Piping Design and Cabling Design Options. It allows multiple designers to work at the same time, 
while assuring the consistency of interconnection data and the corresponding 3D routing information. 
Routed Systems Designer uses an object-oriented display. You can select any object in the work area and work on it through a context-sensitive command 
menu. You can search and Select within the database by object type or associated properties. 
 

Diagram type separation 
 
All design shapes and the sheets themselves have a diagram type property Set to one of the diagram types.  
By default, the catalog explorer shows shapes of the current diagram type of the sheet. However, you can set the catalog explorer to show shapes 
of other diagram types. Routed Systems Designer does not stop you from placing a shape of a different diagram type if you choose one from the 
catalog explorer. 
 
User interface 
 
Use the tool trays on the left of the screen to create, Add, and edit design elements. The list box contains all the tool tray types, including object 
and line creation for different design types, the object catalogs, and special Selection tools. The buttons above the list update to show the most 
recently accessed tool trays. 
Use the icons under the main menu to access viewport controls, for example, pan, zoom, and grid display.  
Click the main menu commands to show subcommands covering setup and display options, macro recording, layer control, and so on. 
All the pull down menus can also be selected using the keyboard. Press the ALT key and then the letter that has been underlined in the menu name. 
For example, press ALT, E, A to Open the Appearance dialog box. 
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View Controls 
About View Controls 
 
You often need to magnify or reduce an area of a sheet when drawing complicated areas.  
Note: The dimensions of any element drawn on the sheet do not change when you use view controls. They only enable you to view the elements at 
different magnifications. 
 
Use the following tools to modify the view as required.  

 
In order from left to right, these tools allow you to: 

o Refresh graphics 
o Zoom in 
o Zoom out 
o View the full sheet 
o Magnify a rectangular area of the sheet 
o Adjust the view (dynamic pan and zoom). Left-Click to zoom or middle-Click to pan. 

Alternatively, you can also hold down CTRL and the middle mouse button, move the pointer upward to zoom in and downward to zoom out & 
hold down SHIFT and the middle mouse button, move the pointer in any direction to center the view on a selected .  

o Open the previous window (as defined by magnification). 
o Open the next window. 

The following additional options are also available from the View menu.  
 

o Pan Centers the view around the probed point. 
o Pan Fiber  Navigates to alternate ends of a Selected fiber (CTRL – E only in edit mode) 
o Zoom top left Zooms the top left quadrant of the sheet. 
o Zoom top right Zooms the top right quadrant of the sheet. 
o Zoom bottom left Zooms the bottom left quadrant of the sheet. 
o Zoom bottom right Zooms the bottom right quadrant of the sheet. 
o Zoom maximum Displays the maximum sheet area, as specified in the Sheet Properties dialog box. 
o Zoom Factors  Sets the zoom factor 
o Zoom half Zooms the view to half size. 
o Zoom double Zooms the view to double the current size.  
o Shape Zoom   Zoom to Selected shape or shapes 
o Zoom to scale Zooms the view about the probed point by a Set scale. The scale is specified in the Zoom Factors dialog box. 
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Creating a New Design 
 
The first thing we need to do is create a new design. 
 

1. Select  to create a new design 
 

2. In the new dialog Enter the following 

 
 

3. Close the next window 

This button will auto generate a new design name 

This button will allow you to navigate your disk/s 

Close this window 
when it pops up 
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Setting up the working environment 
 
Before we commence any schematic work lets set-up our working environment, this is one time operation. 
 
XP Style UI 
 
With the windows release, there is the option to have a windows XP look and feel. 
 

4. Select Options > Switches  
 

5. Select XP Style windows  
 

6. Select OK from the message prompt  
 

7. Do not Close the Switches Control Panel dialog 
 
Do not re-start RSD just yet 
 
Cursor options 
 
There is the option to have either the cross hairs turned either on or off. 
 

8. To turn off the cross hairs (current default) Select No X Hair 
 

9. Select OK from the message prompt  
 
Do not re-start RSD just yet 
 
Turning off RSD Lite 
 
There is an option to use the full version of RSD (providing a valid license is available) 
 

10. To use the full version of RSD Select Enable Advanced Schematic at Start-up 
 

11. From the Switches Control Panel dialog Select Close. 
 

 

10 

5 

8 
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Background Color 
 
Lets change the background color to white 
 

12. Select Options > Background color  
 

13. Select White from the color pallet  
 

14. From the color pallet dialog Select OK  
 
Highlight Color 
 
The highlight color may also be changed 
 

15. Select Options > Highlight color > Select a desired color 
 

16. From the color pallet dialog Select OK 
 
Editing the color pallet 
 
The default color setting for lines and text is white.  We have changed the background color to white thus we 
will not be able to see any of our work.  To change the default line and text color we need to edit the color 
pallet 
 

17. Select Options > Edit Color Pallet  
 

18.  Select color No. 1 > Select Edit  
 

19. Select the color black   
 

20. From the Select a color dialog Select OK  
 

21. From the edit color pallet dialog Select OK 
 
You will now see the text No Sheet Open in the center of your screen 
 

13 

18 
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Auto-save 
 
To ensure that we do not loose any work lets ensure that auto-save is enabled 
 

22. Select Options > Design Auto-save 
 

23. Ensure enable Auto-save has a tick 
 

24. Set the number of edits between auto-saves to be 20  
 

25. From the auto-save dialog Select OK  
 
Message Window 
 
To obtain the maximum feedback from RSD lets modify the message box properties 
 

26. Select Options > Message Box Properties 
 

27. Select Display at top (the message box will appear above the graphics window) 
 

28. Select All (display all the messages) 
 

29. From the Message box dialog Select OK 

23 
24 

 

27 

28 
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Directory Defaults 
 
To improve the usability of saving and retrieving files there is the ability to set the directory defaults.   
 

30. Select Options > Directory Defaults 
 

31. Set the working directories to where your files reside.  In this example the all the 
files reside under D:\ptc\rsd5\rsdesigner\basic_tutorial\advanced\ 
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About Probe Specifiers  
 

To the right of the graphics window are the probe specifiers.  The system default is Auto Probe how this may be changed by placing the cursor over the desired probe specifier & and 
Selecting the RMB.  To Set a different probe specifier for one mouse action place the cursor over the desired probe specifier & and Select the LMB 
 

Auto  

The Auto probe specifier  creates a point by automatically selecting one of the six probes.  
The order in which the probe is attempted is:  

o Near  
o Intersection  
o Perpendicular  
o Tangent  
o Segment  
o Free  

If there is an existing point within the radius of the cursor, a Near probe is given. If there are no points within the radius, the next type of probe is attempted. If the first five 
probe types cannot be used then a Free probe is Selected.  
As soon as a probe is made, a message appears in the startup window notifying you which type of probe specifier has been given.  
The Auto probe specifier usually supplies the probe specifier you need. However, you should note that it is most likely to produce the wrong result when the cursor is in an area 
of dense lines. You can ensure that the correct type of probe is used by windowing in on the area.  
When you start up ROUTED SYSTEMS DESIGNER, the Auto probe specifier is set as the default. Therefore, you do not have to choose the Auto probe specifier from the 
toolbox. You can position the cursor where you want the point to be placed and Click SELECT.  If you wish to change the default, place the cursor over the desired probe 
specifier, Click Right Hand Mouse Button, & Select Set as Default. 
 
Free  

The Free probe specifier  allows you to create a point at any location on the sheet irrespective of any previously created point.  
A Free probe specifier creates a point at the current cursor position unless the grid is active. When the grid is active ROUTED SYSTEMS DESIGNER creates a point at the 
closest grid intersection. The coordinates of the point are then taken as the coordinates of the grid line intersection.  
 
Grid Probe Specifier 

The Grid probe specifier  lets you create a point that snaps to the nearest grid intersection even if the grid is inactive. 
 
Intersection  

The Intersection probe specifier  allows you to create a point at the intersection of two existing lines.  
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Near Probe Specifier  

The Near probe specifier  enables you to locate the nearest existing point and to create a new point at that location. This means that a Near probe specifier enables you to 
position a point at exactly the same coordinates as a point in an existing line or at the Datum Point of a text element.  
 

Segment  

The Segment probe specifier  allows you to create a point on an existing line so that the new point lies as Close to the cursor as possible.  
 

Perpendicular  

The Perpendicular probe specifier  allows you to create a perpendicular line between the current point and the line nearest the cursor.  
You can use this probe specifier once you have started to create or edit a line.  
 

Center  

The Center probe specifier  locates the center point of the nearest curved line segment.  
For circles or arcs, the probe locates the defined center point. For other types of arcs a center point is inferred as the intersection of the two perpendiculars from the tangents at 
the ends of the arc, see below No position is located if the perpendiculars do not intersect inside the arc.  
 

Mid Segment  

The Mid Segment probe specifier  locates the middle of the straight or curved line segment nearest to the position that you probe.  
 

Tangent  

The Tangent probe specifier  allows you to create a point on the nearest arc or circle such that the line segment joining the new point to the previous point is tangential to the 
arc or circle.  
You can only use this probe specifier once you have started to create or edit a line.  
 

Last  

The Last probe specifier  locates the most recent current point. This enables you to create a number of lines that pass through the same point without having to define that 
point for each line. 
 

Locating the Datum of an Element  

The Datum probe specifier  allows you to use the datum point of the Selected element, for example to place a point in a line. To do this:  
1. Select a tool, for example a create line tool.  
2. Choose the datum probe specifier.  
3. Point to the element and Click SELECT. 
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For this tutorial we will be working with a grid, therefore using the RMB we can set the snap default to be to Grid 
 

32. Place the cursor over   
 

33. Click RMB 
 

34. With the LMB Select Set As Default  
 
Saving Default Settings 
 
To enable the options we have just as well as save them as default we must now re-start RSD. 
 

35. Select Save  
 

36. Select File > Exit 
 

37. Select Save from the defaults prompt 

 
 

38. Re-start RSD and Open Design-1 
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Importing a Package 
 
Currently we have a new design that does not have any catalog items.  We are going to use the packaging functionality to import a catalog. 
 
About the Export Package Manager 
 

About Exporting Parts of a Design 
You can export the following parts of a design in Routed Systems Designer to another design. Note that this functionality is not available in Routed Systems Designer Lite. 

o Catalog objects 
o Datatables and maps 
o Design sheets 
o Design snippets 
o Shapeless artifacts 

To export these parts, create an export package that stores the exported objects. Other designs can interpret the contents of the package and import the objects. 
Use the Export Package Manager to create the export package. 

  
To Export Parts of a Design 

o Click File > Export > Package. The Export Package Manager dialog box opens. 
o To add an object to the export package, in the left panel, select the object to be exported and click >>. 

The selected objects are added to the export package and are displayed in the top right panel. 
o To add the complete contents of the design and catalog to the export package, click >>>>. 
o To delete an object from the export package, in the top right panel, select the object to be deleted and click <<. 
o To remove all items from the export package, click <<<<. 
o To store all the information about the export package in a file, specify the location and the filename in the Export to file box. Alternatively, click Browse to browse to 

the file location.  
The default extension of a package file is .pkg. To save the structure of the export package to a file with a .lst extension, click Contents > Save, specify a file name in the File 
Select dialog box, and click OK. 

o By default, all the dependencies of an object are exported. For example, if a design sheet is exported, all the objects on that sheet have prototypes. By default, the 
prototype objects are automatically included in the export package. This applies to datatables and maps too. If you do not want to export all the dependencies, click 
Options > No dependents. 

o Click Export. 
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About the Import Package Manager 
 

About Importing Parts from a Design 
You can import the following parts of a design into an existing design: 

o Catalog objects 
o Datatables and maps 
o Design sheets 
o Design snippets 
o Shapeless artifacts 

To import these parts, you need an export package file that stores all the exported objects. Use the Import Package Manager to import parts from the export package file. 
An unique identifier of an object, SYS_ID, allows Routed Systems Designer to identify objects that have already been imported and exported and report this information. If an 
object already exists when importing, a difference and merge operation is performed between the two sets of data, resulting in one of the following situations: 

o The original object is retained and the new one is discarded. 
o The original object is discarded and the new one is used. 
o The properties of the original and imported object are merged. 
o While importing: 
o If two designs are created separately using the same imported catalog, they can be merged later and the catalogs are not duplicated. 
o If a subsystem is imported into two or more designs, and the designs are subsequently merged, the artifact representing the subsystem can be identified as having two 

representations. 
o If two designs are merged and names clash (two objects with the same name, one originally existing, the other being imported), Routed Systems Designer 

automatically reassigns names based on the sequence numbers, or informs you of such a clash in names. 
To Import Parts from a Design 

o Click File > Import > Package. The Import Package Manager dialog box opens. 
o In the Import from file box, specify the location and filename of the package file from which you want to export objects. Alternatively, click Browse to browse to the 

file location. The default extension of a package file is .pkg. 
o To import an object, select the object in the left panel and click >>. The selected objects are displayed in the right panel. 
o To import all objects from the package, click >>>>. 
o To delete an object from the import list, select the object from the right panel and click <<. 
o To delete all objects from the import list, click <<<<. 
o If you do not want dependent objects to be automatically imported from the import package, click Options > No dependents. 
o By default, objects in the import package or the current design are automatically imported and new objects are merged. If you do not want the new objects to be 

merged, click Options > No merge. The new objects appear as conflicts in the Import package comparator dialog box. 
o Click Import.  

If the objects being imported already exist, the Import package comparator dialog opens. Routed Systems Designer automatically merges the objects if possible. If not, it displays 
the differences and allows you to select the version of the object to be used. The differences are displayed in a tree format, showing the original design structure versus the structure 
after the import. The differences and similarities are indicated differently allowing you to identify what to keep and what to discard. 

Click Next to move to the next unresolved difference. Accept the original value (or object) or the value from the imported package. If the properties of an object are listed as 
UNSET, the object was not present in the original design or in the import package, depending on which side of the list they appear on. 

When all differences are resolved, Import on the Import Package Manager dialog box is enabled.  

Note: The Import package comparator dialog box may open several times, depending on how many sheets are being imported and whether the sheets have differences. 

. 
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1. Select  from the main tool bar to Open the Catalog Explorer 
 

Notice that the catalog explorer is currently empty. 
 

2. Close the catalog explorer 
 

3. Select File > Import > Package. 
 

4. Browse to the package directory and Select new-catalog.pkg. 
 

5. Select OK from the file selector dialog. 
 

6. Select the Catalog tab. 
 
The catalog tab displays a folder structure; it is from here that you may select 
individual items that you wish to import or a complete folder structure. 
 

7. Select Datatable and Maps Tab. 
 

8. We also have some datatables.  To ensure that we import all of the package Select 

. 
 
The import area on the right hand side has now populates with all the items we 
wish to import. Drag and drop of items between package contents and items for 
import is also available. 
 

9. Select Import. 
 

4 

6 
7 

8 

9 
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The import package comparator will now open.  This is telling you that there are number of differences between the base design (the design you have created) and the imported data.  
We would expect there to be a number of differences between the import data as the base design is empty.  
 

10. Select import.  The dialog will disappear once the import is complete and a 
message will indicate that the transaction is complete. 

 

11. Select  to Open the Catalog Explorer. 
 
Notice that we now have some catalog items. 
 

 

10 
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Global Properties 
We now want to set-up Routed Systems Designer so that when a new design sheet is created it contains information pertinent to the project and the designer.  To do this Routed Systems 
Designer uses properties.   
 
About Properties 
 

About Object Types 
 
An object type is a hierarchical property used to identify the family to which an object belongs. The predefined types are: component, connection, dataset, document, spool, and 
port. You can define new subtypes of the predefined types. A set of default properties and values are associated with each type.  
Blocks, groups, fibers, ports, sheets, and datasets have types. The type of a block must be a subtype of the component type. The type of a fiber must be a subtype of the 
connection type. The type of a group must be a subtype of either the component type or the connection type. The type of a port must be a subtype of the port type. The type of a 
sheet must be a subtype of the document type. The type of a dataset must be a descendent of either the dataset type or the spool type 
 
To Set an Object Type 
 

o Select the object. You can select a block, group, fiber, port, or a sheet.  
o Right-click and select Properties from the shortcut menu. 
o Click Set beside the Type box. The Select type dialog box opens. 
o Select the type and click OK. 

You can also set the type of an object in the Model Explorer. 
 
To Define an Object Type 

o In the Diagramming tool tray, click . The Define types dialog box opens. 

o Click  in the left panel to create a new subtype of the currently selected type. Specify a name for the new type and click OK.  
The new type has a copy of the properties of the parent type. The top right panel, Type Properties, shows the properties of the current type. 

o Click OK. The new type is added to the global list. The top right panel, Type Properties, shows the properties of the current type. 
o Add properties to the type, as required. 

 
To Rename an Object Type 

o In the Diagramming tool tray, click . The Define types dialog box opens. 
o Select the type to be renamed. 

o Click . The Rename type dialog box opens.  
o Specify the new name and click OK. 

Note: You cannot rename predefined types. 
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To Delete an Object Type 

o In the Diagramming tool tray, click . The Define types dialog box opens. 
o Select the type to be deleted. 

o Click . 
Note: You cannot delete predefined types. 
 

About Object Properties 
 
Blocks, fibers, groups, and ports can have a user-defined set of properties and values associated with them, at both the definition and the instance level. When you instance a catalog 
definition, the instance inherits the definition's properties. You can change the value of properties on the instance, if necessary. 
Sheets and datasets can also have a user-defined set of properties and values.  
Before you can assign a property to an object, you must first create the global definition of the property for use in the design. Any property can be added to any type. 

Click  in the Diagramming tool tray to view or edit global properties. The Define types dialog box opens. 
The left panel displays existing types in the design. You can add properties to these types using the options in the right panel. 
 

Options in the top right panel 
 
The options in the top right panel of the Define types dialog box are: 

o New Launches the Property definition dialog box to create a new property in the property pool.  
o Delete Deletes the selected properties, in either the type properties or the property pool, from the design.  
o Modify Launches the Property definition dialog box to modify the selected property.  
o Copy Launches the Property definition dialog box to create a copy of the selected property. 
o Import Imports a .csv property definition file.  
o Value options Sets a default value for a type property. 
 

Options in the lower right panel 
 
The lower right panel, Property Pool, shows properties that are defined but not used in the current type. You can either Add properties to the current type or remove properties 
from the current type using the appropriate options. 

o Add Property - Adds the Selected property to the current type in the property pool. 
o Remove Property - Removes the Selected property from the current type and returns it to the property pool. 
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To Add Property Definitions 

o the Diagramming tool tray, click . The Define types dialog box opens. 
o Click New in the right panel of the Define types dialog box. The Property definition dialog box opens. 
o Specify the following property definition items in the Property definition dialog box:  
 

Ø Name—Identifies the property definition in the design. Examples include Nphases, MaxPowerRating, Color, and Standard. 
Ø Value Type—Integer, Real, String, or List. Examples are 3, 3.142, Red, and [Iso, DIN] respectively. A list can consist of a list of strings. 
Ø Description—Describes the property. 
Ø Units—Specifies the units of the property. 
Ø Derived property—Sets a property as derived. Use a function format that is similar to a label format to calculate such properties.  
Ø Constrain to value list—Constrains property definitions to a list of values.  
Ø For a Value Type of String or List, you can constrain the property to a Set of values specified in the Value List field.  
Ø For a Value Type of Real or Integer, you can constrain the property to a list of values specified in the Value List field and also a range of values specified in the 

Value Range box.  
 

o Click OK. The new property is added to the global list. 
 

To Add, Modify, or Delete Properties 
 
After you have defined a property globally, you can add it to a selected block, fiber, group, or port, and set a value for it. The properties can be added when the object is created 
and added to the catalog, when the object is instanced or after it is instanced.  

o Select the object. To select multiple instances of the same object type, hold down the SHIFT key and select the objects as required.  
o Right-click and select Properties from the shortcut menu. The Properties dialog box opens. The current values are displayed in the respective boxes. 
o To add a new property: 

Ø Click Add. The Property selector dialog box opens, listing all previously defined properties.  
Ø Select a property from the list to be added to the selected objects, and click OK or Apply. The property is added to the object's property list. 

Ø With the property still highlighted in the list, type a value for it in the Value box. Click  to confirm the value. 
o To delete an existing property: 

Ø Select the property to be deleted. 
Ø Click Remove. 

o To modify a property:  
Ø Select the property to be modified. 

Ø With the property still highlighted in the list, specify a value for it in the Value box. Click  to confirm the value. 
o Click Apply or OK. 
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Depending on the type of object selected, you can also change the following object properties: 
 

o Name Format— Specifies the format for the name of the object. 
o Serial Number— Specifies the serial number to use when generating the name from the name format 
o Global Name— Specifies that the name must be globally unique 
o Autogen/Serial/Free Format/Unset— Specifies how the name of the object should be generated. 
o Has Direction— —(for a fiber) Specifies that fiber has a direction, which means that internal connectivity of a fiber is one-way only. For example, consider a fiber 

going from A to B. If the fiber is without direction, A is connected to B through the fiber, and B is connected to A through the fiber. If the fiber has direction, then A is 
connected to B through the fiber, but B is not connected to A through the fiber. 

o Internally Connected— —(for a block) Specifies that all the ports on selected block are connected together through the block. 
o Fix member identities— for a group) Specifies that the group is fixed, not parametric. It can only be changed on a catalog group without instances. 

 
Depending on the type of shape selected, you can change the following shape properties: 
 

o Layer—Specifies the layer on which the shape is placed. 
o Color—Allows you to choose a color for the shape. 
o Cross ref shape—Specifies that the shape is a cross reference shape, so will not show in cross reference labels. 
o Diagram Type—Specifies the diagram type of the shape and can only be set on a catalog shape without instances. 
o Linked to cross-ref shape— (for a parametric group) allows the shape to be linked to a cross-reference shape, which displays graphically the locations within the design 

of shapes of other members of the group. It can only be changed on a catalog group shape. 
o Associated cross-ref type— (for a group) Specifies the type of cross-reference shape, which is linked with the group shape. Options are:  

Ø Other instanced members Shows the locations of all other shapes of this group, which have been placed in the design.  
Ø Member map Shows all other members of the group as defined by a member map, including those, which have no shapes (yet) in the design.  
Ø Master / Slaves Shows the location of the master shape within the design or, if this shape is the master shape, show the locations of all other shapes 

(its slaves) within the design 
 

In addition to the previous properties, for a fiber, you can specify shape properties such as line type, pitch, point function, and width. You can also specify label properties such 
as the position, format, type, layer, font, height, angle, and color. 
. 
 
Note: 

o The object property dialog boxes work across all modes. You can keep them open as you go from selection to selection. If you switch object types, the Properties 
dialog box changes accordingly.  

o If you have selected multiple objects of a type, the dialog box shows a list of all properties defined for all the selected objects. If the value of a property is the same for 
all selected objects, the relevant box shows that value. Otherwise, the box is empty.  

o When editing properties of a single selected shape, the shape's attributes are displayed at the bottom of the dialog box
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Global Properties Dialog Overview 
 
1 Creates a new subtype. 
2 Deletes created subtypes. 
3 Re-names created subtype. 
4 Adds a new property to the pool. 
5 Deletes a user-defined property. 
6 Modifies a user-defined property. 
7 Copies Properties. 
8 Imports properties from a *.CSV file. 
9 Type property list. 
10 Default value for Selected property. 
11 Unset’s Selected property value. 
12 Choose value from a pre-defined list. 
13 Adds a new value to property list. 
14 Add Selected properties to types from property pool. 
15 Remove Selected property from type. 
16 Property Pool. 
17 Types –Default types are as follows; 

New Block COMPONENT 
New Group COMPONENT 
New Port PORT 
New Fiber CONNECTION 
New Sheet DOCUMENT 

2 3 4 5 6 7 8 

9 

10 11 12 13 
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Setting up standard properties for a Drawing Sheet 
We shall use properties to ensure that for every time a new sheet is created within the design explorer Routed Systems Designer automatically includes the properties Drawn by, 
Checked by & Project name 
 
Note: This only has to be done once and may be stored within the company standard catalog. 

1. Select Global Properties  from the Diagramming Tool Tray  
 

2. Select New 
 

3. Set the Name to Checked by 
 

4. Select OK to Close the property definition dialogue 
 

5. Repeat steps 2 to 4 for to create two new properties 
Ø Drawn by 
Ø Project name 

 
The three new properties we have just created now exist 
within the Property Pool 
 

6. From the Type menu Select DOCUMENT  
 

7. Using CTRL Select three new properties (Checked By, 
Drawn by, Project name) 

 
8. Select Add property,  

The three properties shall now move from the property pool 
into the type list

2 3 

4 

6 

7 8 7 7 
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9. From the Type Properties pool Select project_name 
 

10. In Value Enter RSD 5 Basic > Select  to confirm the entry 
 

11. RSD 5 Basic is now set to the default selection 

 
We have now set up 3 new properties that shall always be added when a sheet with type document is created.  In this example we have Set RSD 5 Basic to be the default setting for 
Project name. 
 
Later we shall create a new sheet and find that the properties of the sheet will have 3 new properties added automatically, and the property project name will automatically have its value 
set to RSD 5 Basic

9 

10 10 
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Creating Subtypes 
 
We can take global properties a stage further and have subtypes.  We shall now create some subtypes for Document that would only be relevant for sheets of a particular size. 

12. Select Global Properties  from the Diagramming Tool Tray  
 

13. From the type list Select Document 
 

14. Select Add new subtype  
 

15. Enter A2 for name 
 

16. From the rename type dialog Select OK 
 

17. Select subtype A2  
 

18. Select sheet_size from the property pool  
 

19.  Select Add Property 
 

20. Re-Select sheet_size from the type list 
 

21. Select Choose > Select A2 > Select OK to Close the List value dialogue  
 

22. Select  to confirm the value 
 

23. Repeat steps 14 – 22 and create a subtype A3 
 

24. From the Define types dialog Select Close 

13 

14 

15 

17 
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Using properties with catalog templates 
 
We have setup 3 new properties for type DOCUMENT and one new property for subtypes A2 and A3. We shall now setup our catalog template to ensure that each time a user creates a 
new A2 and A3 sheet the new properties are always included.  
 

25. Select  from the main tool bar to Open the Catalog Explorer  
 

26. Select Design Templates from the pull down menu 
 

27. Select A3 > Click RMB > Select Properties  
 

28. Select Set > Select A3 
 

29. From the select type dialogue Select OK 
 
Notice that 4 new properties are added. 
 

30. From the properties dialogue Select OK  
 

31. Close the catalog explorer 
 

27 
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Creating a new sheet 
 
Now we have setup our A3 design template lets create a new A2 and A3 sheet to check our settings. 
 

32. From the main tool tray Select  to Open the Design Explorer  
 

33. From the design explorer Select  to create a new sheet 
 

34. Select template size A3 
 

35. Select Sheet_1 > Click RMB > Select Properties 
 
You will see that Sheet 1 has 4 properties 2 of which have 
values that are unset 
 

36. Repeat Steps 33 – 35 but this time use template A2  
 
You will notice that sheet_2 has only 3 properties,  
 

37. Select Set 
 

38.  Select A2 
 
You will now see that property sheet size has been added 
with a value of A2 automatically 
 

39. Set-up the A2 template sheet so that property sheet size is automatically added 
when an A2 sheet is created 
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Using CSV files 
 
 
We can also use CSV files to import global properties. 
 

40. Select the Global Properties  from the Diagramming Tool Tray  
 

41. Select IMPORT 

 
 

42. From folder CSV Files \ Global properties Select global_properties.csv 

 
 

43. From the select property dialogue Select OK. 
 
You will now notice that the global properties has been populated with information from the CSV file 
 

44. Close the Global Properties Dialog 



Routed Systems Designer Release 5.0 Basic Tutorial
 

38 of 139 

Circuit Diagrams 
 

Creation a new sheet 
 

In this diagram type you can perform the following activities: 
o Create fiber networks, often called signal networks 
o Inline internally connected blocks without breaking the signal network 

 

1. Select  to Open the Design Explorer  
 

2. Select folder Design  
 

3. Select  to create a new folder 
 

4. Select the new folder  
 

5. Select  to edit the folder properties 
 

6. Set the folder name to Circuit Diagrams 
 

7. Select folder Design 
 

8. Click RMB > Select New Folder 
 

9. Select the new folder 
 

10. Click RMB > Select Properties 
 

11. Set the folder name to Wiring Diagrams 
 

12. Select Folder Circuit Diagrams  
 

13. Select  to create a new sheet 
 

14. Select A3 & OK from the Catalog Selector 
 

15. Select the new sheet > Select  
 

16. Set the sheet name to Circuit Diagram 
 

17. Set the Diagram type to Circuit 
 

18. Select OK from the sheet properties dialog 
 

19. Double Click with LMB on the sheet to Open 
 

20. Close the Catalog Explorer 

3 5/15 4/12 2 13 
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Placing Shapes 
 

About shortcut options 
During the placement of shapes the following shortcuts are available 
The MMB allows free rotation 
On the RMB you have the option to 
Turn Left Rotates the shape left 
Turn Right Rotates the shape right 
Straight Set the shape to the default orientation 
Set Rotation 0, +90, -90,180, user defined value 
Magnify  LMB Proportional / RMB Free 
Mirror H Mirror the shape horizontally 
Mirror V Mirror the shape vertically 
Drag by port Select a port to attached cursor to for placing 
Exit Tool Cancels placement 
 

21. Select  to Open the Catalog Explorer  
 

22. Select Blocks from the pull down menu 
 

23. Select folders Electrical > Ground  
 

24. Select block Ground  
 

25. Select  place an instance of the shape 
 

26. The ground shape is now on your cursor, place down using the LMB 
 

27. Click RMB > Select Exit Tool 
 

28. Repeat steps 22 to 27 for Power box from the Power directory (rotate 180 during 
placement), and Signal Lamp, from the Indicators directory. 

 

29. Select Groups from the pull down menu 
 

30. Select the Relays Folder 
 

31. Select the Coil shape form the Variable Relay group  
 

32. Select  to place and instance of the coil 
 

33. Select Cancel from the New Reorder Dialog 
 

34. Place the coil down 
 

35. Click RMB > Select Exit Tool 
 

36. Select Close from the catalog explorer dialog

26 
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About Signal Networks 
 

A signal network is made up of multisegment fibers created in circuit diagrams when a network shape has been specified. A fiber network is a signal network. Any fiber shape 
with a diagram type of circuit is regarded as a signal network. 
A circuit diagram consists of components, represented either by block graphics or group graphics, connected together by signal networks. A signal network represents the 
logical connection between the component’s ports. Generally, a network of wires is created in the wiring diagram that is equivalent to the signal networks in the circuit diagram. 
Signal networks can be simple or complex. 
o Simple signal network—A circuit diagram consisting of only two pins with a single fiber connecting the two ports. A simple signal network may correspond to multiple 

wires connected via intermediate connectors. 
o Complex signal network—A circuit diagram signal network consisting of three or more ports is a complex network. 
The minimum number of wires required to connect a number of ports is one less than the number of ports connected. For example, two ports require one wire, three ports 
require two wires, four ports require three wires, and so on. 

 
To Instance Signals 

In the Diagramming tool tray, Click . The Catalog Selector dialog box opens. 
o Click a fiber definition and then a fiber shape. 
o Click OK in the Catalog Selector dialog box or double-Click the fiber. The cursor assumes a circle and dot shape, ready to trace the fiber onto the sheet. Specify the start 

point by Selecting a port or clicking Free Point on the right mouse button menu to start the fiber anywhere. The fiber is shown tracked in a dotted line.  
Ø To use automatic routing, click the terminal port. Routed Systems Designer Selects a route for the fiber. Automatic routing routes the fiber to avoid crossing the two 

blocks being connected, but does not necessarily avoid any intervening blocks or other fibers. 

Ø To use manual routing, left-Click to install a corner where desired. Click to terminate on a port. To terminate "in space," Click Terminate from the right mouse button 
menu. 

While placing a fiber, use the right mouse button menu to switch sheets or to change to a new instance.  
o If you route a fiber shape on a sheet, then Select Same instance from the right mouse button menu, and then route another fiber shape (on the same sheet), a single fiber 

artifact is created. This artifact contains three ports, two segments, and two fiber shapes associated with it. The first fiber shape shows the first segment and its two ports. 
The second fiber shape shows the second segment and its two ports. The port that is common to both segments has portshapes in both fibershapes. 

o If you route a fiber shape on a sheet, then Select Change sheet from the right mouse button menu, and then route another fiber shape (on another sheet), a single fiber 
artifact is created. This artifact contains three ports, two segments, and two fiber shapes associated with it. In this case, the fiber shapes are on different sheets. 

If you choose new instance before routing a fiber shape, a new fiber artifact is created. 
 
Note: 
o You can use manual routing with automatic routing. For example, if you know that you want to route in a particular direction, you can start to manually route a fiber, 

placing several points in space. At any time you can position the cursor over the destination port, and the router will illustrate the autoroute from the current point in space 
to the destination port as a solid line. If you are satisfied with the remainder of this route, Click on the port and the fiber will be routed. 

o Fiber end geometry is always created if a fiber port is connected to a non-fiber port. 
o You can customize a shortcut tool to instance a specific fiber and shape each time you Select the shortcut tool, rather than selecting it from the catalog each time. 
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To manipulate Signals 

To manipulate a fiber either double Click the fiber with the LMB or Select  from the diagramming tool tray. 
 
To edit a fibre path; 
o Double-Click the target fiber path. The path is shown as a centerline with dots at each corner. When the fiber is in this mode, you can: 

Ø Use the right mouse button menu to Add points (corners).  
Ø Drag Selected segments as necessary.  
Ø Delete a point by moving it to coincide with another point.  
Ø Move a fiber from one port to another by placing the cursor over the port until you see a red box with a blue dot in it. Press the left mouse button and drag the fiber to 

the new port.  
o To finish, Click Exit Tool from the right mouse button menu. 

 

In this figure, the fiber path is in Edit mode. 

 
When the cursor is over a segment, you can drag it. You can also add a crossing (gap or hoop) where the fiber crosses another fiber. 
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About Context-sensitive cursors  
 

Create 
 

Unix Win Meaning 

  
Auto-portshape 

  
Connect to portshape immediately to the right of the cursor 

  
Connect to the portshape under the cursor 

  
Cannot connect to the portshape under the cursor because its diagram type does not 
match that of the fibershape prototype 

  
Cannot connect to the fiber under the cursor because the branch-shape being used won’t 
fit into the line segment 

  
Cannot insert a point under the cursor because free-point has not been enabled  

  
Cannot connect to the portshape under the cursor because such a connection is 
disallowed by the user-defined Java 

  
Insert a network shape 

  
Insert a branch shape 

  
Free-point has been enabled 

 
Edit 

 
Unix Win Meaning 

  
Slide network portshape along the fiber 

  
Move a point on a fiber 

  
Move a point on a fiber such that the two adjacent line segments are both at angles that 
are multiples of 15 degrees 

  
Move a line segment 

  
Move and reconnect a fiber end, set when the cursor is over the Fiber’s end-geometry 

  
Select fiber segment 

  
Cursor not over a selectable part of the fiber being edited 

  
Only add-point is available because the cursor is over the first or last line segments – not 
including the end-geometry 
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Routing Signals 
 

37. Select  from the diagramming tool tray. 
 

38. Select Signals > GND 
 

39. Select OK 
 

40. Using LMB start at GND-01  
 

41. Move to the right > Place with LMB 
 

42. Click RMB > Select Terminate 
 

43. Click RMB > Select Exit Tool 
 

44. Select label G01 on the fibre just created 
 

45. Click RMB > Select Delete 
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Branching - Set-up 
 
We now need to branch into the G01 Before we can do this we need to set the Network shape 
 
You can set a branch or a network shape for a diagram type. 
 
The Branch Shape Selector dialog box displays the branch shape types and the names that you have selected. Only valid branch shapes are available for selection and are displayed in the 
Branch Shape Selector dialog box. A valid branch shape is the one that matches the selected diagram type and has three ports, at 0°,-90°, and 180°. The 0° and 180° ports must be on the 
same horizontal line. The -90° port must not be above the other two ports.  
If a branch shape is already set for a diagram type, it is already selected and it appears in the viewer. If the branch shape is not set, the viewer is empty. Click Branch or Network on the 
Branch Shape Selector dialog box to select a branch or a network shape for a fibershape in the catalog. The shape is used when branching a fiber from another fiber. 
You can also select Branch or Network in the Fiber Properties dialog box to set the branch or network shape for a fibershape in the catalog. 
 

46. Select File > Design Properties 
 

47. Select Branch Shape 
 

48. Select Circuit 
 

49. Select Network 
 

50. Select branch_sch276 
 

51. From the Networks shape dialog Select OK  
 

52. From the Branch shape Selector dialog Select OK  
 

53. From the design properties dialog Select OK  
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Branching – Routing Signals 
 

54. Select  from the Diagramming tool tray. 
 

55. From folder Signals Select GND  
 

56. Select OK 
 

57. Route from PB-01 Pin 3 & branch into G-01 
 
Note: If you cannot branch check that you have set the branch shape correctly 
 

58. Route from L-01 and branch into G-01 
 

59. Route from RL-01 and branch into G-01 
 

60. Click RMB > Select Exit Tool 
 

61. Select  from the diagramming tool tray. 
 

62. Select Signals > PWR > Select OK 
 

63. Click RMB > Select Free Point > Place with LMB 
 

64. Move to the right > Place with LMB 
 

65.  Click RMB > Select Terminate 
 

66. Connect Pin 1 of PB-01 and branch into signal P-01 
 

67. Connect Pin1 of RL-01 and branch into the Vertical section of signal P-01 
 

68. Connect Pin 2 of PB-01 to the remaining pin on L-01 
 

69. Click RMB > Select Exit Tool 
 

70. Delete any unwanted labels 
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Group Shapes 
 
Groups are used to associate multiple blocks, fibers, groups, or ports together in a single object, for example, to represent several logical components that are all in the same part. An 
example of this is the individual contacts and coils in a relay 
 
We shall now place down a NCC and a NOC to complete RL-01 our group shape 
 

71. Select RL-01 

72. From the Diagramming Tool Tray Select  
 

73. Select Variable Relay!ncc1_1 > Select OK 
 

74. Place to the right of RL-01 
 

75. Select Variable Relay!noc1_1 > Select OK 
 

76. Place to the right of NCC  
 

77. Select cancel from the Select member shape to 
place dialog  

 

78. Select the coil > Click RMB >Select Properties 
 

79. Select Assign master 
 

80. Select Coil1 > Select OK 
 

81. From the group properties dialog Select OK 
 

Notice that the NCC and NOC label is now reporting 

the position of the coil. You may need to Select  to 
update the labels 
 

82. Select the coil 

83. From the Diagramming Tool Tray Select  
 

84. Select Shape1 > Select OK 
 

85. With the LMB Place the Cross Reference Shape 
near the coil. 

 

Cross-reference shapes are visual aids that help keep 
track of the relative locations of the various members of 
a variable unconstrained group throughout the design. 
Cross-reference shapes show those members of the 
group that are placed at the time the cross-reference 
shape is created or last updated. 
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Location Sets 
About Location Sets 
Routed Systems Designer uses location sets to control how sheet columns and rows are defined and sequenced on sheets. A location set is used to group sheets together for cross-
reference purposes. Three location setup tools (under one button set) are available in the Catalog tool tray: 

o Create and Manage Location Sets 

o Set Sheet Column and Row Width 

o Set Sheet Column and Row Labeling Datums 

Routed Systems Designer has a default location set. All design sheets are placed in this location set by default. You can use the Location Set Explorer to create new location sets and to 
move a sheet from one location set to another. A sheet can exist only in one location set at a time. 
For each sheet in the location set, you can define: 

o The number of columns per sheet 

o The number of rows per sheet 

o The width of each column 

o The width of each row 

o The start and end positions to place the column or row labels on the sheet 

Define these settings for all the design template sheets in your catalog. You can subsequently modify the settings for a design sheet, if required.  
 
To Create or Edit Location Sets 

Click  in the Catalog tool tray to create location sets or modify the behavior of an existing location set. The Location Set Explorer dialog box opens. 
The Location sets list displays all location sets defined for this design. The Sheets list displays the sheets that are currently assigned to the selected location set, its order in the set, and 
the starting column number for the sheet. The entry <<No location set>> shows the sheets that are currently not assigned to a location set. 

 
Creating a new location Set 
 
To create a new location Set, Click Create new. A new entry is listed in the location sets, with a default name. Type a new name in the Name box and Click Apply.  
 
Setting label visibility 
 
To specify whether the sheets must display row or column labels and to specify where on the sheet border the labels should be displayed, select the appropriate check boxes 
under Label position. 
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Setting the label function 
 
To specify user-defined label formats for a row or column using a Java function call, select the appropriate check box under Label function, and specify the function to be called 
in the box. 
The following default function is provided: 
{rsdesigner/component/Label.alpha()} 
This method results in the row or column text Set as A, B, C through Z corresponding to row or column numbers 1, 2, 3, through 26 respectively.  
Other example label functions are: 

o {rsdesigner/component/Label.alpha(ROW)}.  This method precedes the alphanumeric string with a user-specified string. In this example, the row text is ROW A, 
ROW B, ROW C and so on. 

o {rsdesigner/component/Label.NFPA(name)}.  This method precedes the alphanumeric string with the value of a specified string property of the current sheet. In this 
example, the row text is Sheet_1 A, Sheet_1 B, Sheet_1 C and so on. 

 
Setting sequential sheet numbering 
 
Select the Sequential Sheet Numbering check box to number the columns starting at 1 for the first column of the first sheet, then increasing continuously across all sheets in the 
sheet set. 

To remove gaps in sequential numbers, click . 
 

To Set the Column Width or Row Height 

o Click  in the Catalog tool tray. The Set Sheet Columns and Rows dialog box opens. 

o Type the number of columns and rows in the Num columns and Num Rows boxes respectively, and Click  to update the list with the specified number of columns or rows.  
The dialog box lists each column and row with its current width or height. The labeling datum’s define the area that the rows and columns are defined for, so the sum of the 
column widths must equal the distance between the labeling datum’s. If the sum does not equal the distance then the difference is shown in the Deficit label. Ensure that the 
number is zero before you Click OK. To get a deficit of zero, you can: 
Ø Click Equal widths or Equal heights. The column widths or row heights are distributed equally among all columns or rows. 
Ø Select a row in the list and Click Add to Selected. The deficit value is added to the Selected row, the row is updated to reflect the new value, and the deficit is changed to 

zero. 

Ø Manually alter the value of each width. Select the column to be altered, type a new value in the Width box, and Click .  
o Click OK or Apply. The new column and row definitions are stored for the sheet. The labels are displayed around the borders of the sheet, between the two labeling datum 

positions, dependent on the Label Position choices in the Location set Explorer. 
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To Set the Labeling Datum’s 

o Click  in the Catalog tool tray.  
o Select the point of the first labeling datum and a position for the last one. These two points are treated as defining a diagonal line. The column labels are positioned along 

horizontal lines at the top and bottom of the diagonal line; the row labels are positioned along vertical lines at the left and right of the diagonal line. When you select the second 
point, the set Sheet Columns and Rows dialog box opens. 

o Complete the set Sheet Columns and Rows dialog box as described in "To set the Column or Row Width". 
 

To Move Sheets Between Location Sets 

o Click  in the Catalog tool tray. The Location Set Explorer dialog box opens. 
o In the Sheets list, Select the sheet that you want to move and Click one of the following: 

Ø Moves the sheet up in the sequence 

Ø Moves the sheet down in the sequence 

Ø Moves Selected sheet to another location set. A list of the possible location sets into which the sheet could be moved is displayed. Select a location set from the list 
and Click OK. The sheet is moved into the new location set. Alternatively, you can select a location set into which you want to Add a sheet, and Click Add Sheet. A list is 
displayed showing all sheets that are not already in the Selected set. Select a sheet and Click OK. The Selected sheet is moved from its previous set into the Selected one. 

Note: Moving sheets between location sets can affect the column numbers of the sheet itself, as well as column numbers of other sheets in the affected location sets. This in turn can 

affect cross-references on the sheet itself, as well as any other sheet that contains cross-references to the affected sheets. Click  to update cross-references on the Selected sheet. The 
sheet is updated only if it is Open. Update All Sheets updates all sheets in the Selected location set. Closed sheets do not need to be updated because they are automatically updated when 
they are opened in Routed Systems Designer. 
 

To Delete a Location Set 

o Click  in the Catalog tool tray. The Location set Explorer dialog box opens. 
o In the Sheets list, select the sheet that you want to delete.  
o Click Delete. The Selected location set is deleted. All the sheets that were in the location set are moved to the <<No Location set >> list. 

 

To Remove a Sheet From a Location Set 

o Click  in the Catalog tool tray. The Location Set Explorer dialog box opens. 

o In the Sheets list, Select the sheet that you want to move and Click . The select location set dialog box opens. 
o Select <<No location set >> and Click OK. 

 

Row & Column Text 
To control the height, color and font of row and column text Select File > Design Properties > Set Row/Column text 
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Using Java in location sets 
 
Using Java it is possible to have a user defined sequence for example alphanumeric. We are going to set our rows to an Alpha sequence using Java alpha sequence that is supplied with 
RSD (not available in RSD Lite). 
 

1. Select the catalog tool tray 
 

2. Select the location set explorer icon  
 

3. Select location Default 
 

4. Set the label position to be Left, Top and Right 
 

5. Turn on the label function (this is calling the Java alpha sequence) for the rows 
 

6. Select Apply 
 

7. Select Sheet Circuit Diagram >Select  to update the cross reference 
information > Select close 

 
You will now see that you have alpha rows and numeric columns and that your relay members and xref shape our now reporting the updated row column locations 
.
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Wiring Diagrams 
Now that we have created a part of a circuit diagram lets start to create the wiring diagram. 
 
Creating a sheet 

1. Select the Design Explorer Icon  
 

2. Select Folder Wiring Diagrams >Click RMB > Select New Sheet  
 

3. From the catalog Selector dialog Select A3 > Select OK 
 

4. Within the Design Explorer Select the new sheet > Click RMB > Select 
Properties 

 
5. Set the sheet name to Wiring Diagram 

 
6. Set the Diagram type to Wiring 

 
7. From the sheet properties dialog Select OK 

 
8. Select the renamed sheet > Click RMB > Select Open Sheet 

 
9. Close the Catalog Explorer 
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Placing Groups with the report tool 
We are now going to use the report tool to place the wiring shape 
About the report tool 
 
You can generate reports in Routed Systems Designer. You can include the layout of the report and the items to be included in the format. You can also name and save the format for 
future use. 
You can generate the report as a dialog box display, or a text file that you can print, or as a table in the current sheet. If you generate the dialog box display, you can use the dialog box to 
probe the diagram to find and highlight reported objects. 

Click  in the Diagramming tool tray. The Format report dialog box opens. At the top of the dialog box is a toolbar with the following tools: 

 creates a new report format. 

 opens a file selector that is used to select a previously saved format.  

 saves the current report format. 

 deletes the file of the current report format. The dialog box is reset to its default state. 

 generates the report, sending the report to the specified target. 
The tabs below the toolbar allow you to switch between the different panels described below. Use the tabs that are appropriate for your report: General, Column, Sort, Criteria, and 
Destination. The Trace and Trace Criteria tabs are enabled when creating connection reports only. The Table Style tab is enabled when the destination is sheet. 
 

General 
Use this panel to set the report title, type of report, column separator, and classes of object on which to report. There are three report types: 
o Properties—generates a report with a line for every object that satisfies all the criteria. This type of report may result in identical lines in the output.  
o Inventory—generates a report in which every line is unique and adds a column to indicate the number of objects that generated the line.  
o Connection—generates a report showing the connectivity between objects. The Trace and Trace Criteria panes are used to control the output of this type of report. 
 

Line number 
To show line numbers in the report, check the Show checkbox beside the Line Numbers Column box. To set the line number style in an inventory report, select Incremental or 
Hierarchical from the Style list box. 
Select General > Item Selection > Criteria to include items that satisfy the specified criteria in the report. Select General > Item Selection > Selected Items to include the 
currently selected items in the report. 

 

Column 
Use the Column panel to set which fields are to be shown in the report, along with up to three heading lines and the width of the column. Click Add Property Column to select a 
property to be displayed as a field in the report, and Delete to remove a field from the report. The Move Up and Move Down control the order of the fields in the report. 
Click Add <Label> Column to add a new column whose value is generated from a label format. Use the Property Format text box and the Column Heading text box to edit both 
the property format and the column heading after adding the new column. 
Click [fn(x)] to incorporate a predefined function into the label format text of a label column.  
Note: The Property Format label/text and the [fn(x)] buttons are disabled when you select an item in the column list that is a normal property column. These buttons are enabled 
when you select a label format type column or add a new column of this type. Values change automatically in the list as you type in either of these text boxes. 
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Sort 
Use the Sort panel to set properties that are used for sorting, and specify whether the order is ascending or descending.. 
 
Criteria 
Use the Criteria panel to set the criteria by which objects are selected. Only objects that satisfy all the criteria are selected.  
Note: The properties named in the criteria used to qualify an object for inclusion in a report do not need to appear in the columns list.  
Most properties can be used as criteria in reports. The criteria that can be used depend on the type of the property. 
 
Criteria for Integer and Real Properties 
 

Criterion Description 
Equal Property value is equal to the specified value 
Not Equal Property value is not equal to the specified value 
Less Than Property value is less than the specified value 
Less Than or Equal Property value is less than or equal to the specified value 
Greater Than Property value is greater than the specified value 
Greater Than or Equal Property value is less than or equal to the specified value 
Note: The value of an integer or property can be null (or unset) value. If the specified value is unset (that is the unset check box is selected), only the Equal and Not Equal 
criteria are available. 
 
Criteria for String Properties 
 

Criterion Description 
Equal Property value is equal to the specified value 
Not Equal Property value is not equal to the specified value 
Less Than Property value is less than the specified value 
Less Than or Equal Property value is less than or equal to the specified value 
Greater Than Property value is greater than the specified value 
Greater Than or Equal Property value is less than or equal to the specified value 
Match Property value matches the specified pattern in which wild cards can be used. Wildcard characters are: 

* denotes any number of any character.  
? denotes any single character.  
\ is the escape character. 

Note: The value of a string property can be null (or unset) value. If the specified value is unset (that is the unset check box is selected), only the Equal and Not Equal criteria are 
available. 
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Criteria for List Properties 
 
Criterion Description 
Equal List equals specified list 
Not Equal List does not equal specified list 

Contains List contains elements in specified list 
Not Contains List does not contain elements in specified list 
Match List matches the specified list with which you can use wildcards. Wildcards that can be used are: 

* denotes any number of any character.  
? denotes any single character.  
\ is the escape character. 

Some built-in properties have their own, specific, criteria. 
 
Criteria for "sheets" Property 
 

Criterion Description 
On The artifact that owns the property has shapes on one or more of the specified sheets. 
On Any The artifact that owns the property has at least one shape on a sheet. 
Not On The artifact that owns the property does not have shapes on any of the specified sheets. 
Not On Any The artifact that owns the property has no shapes, so is not represented on any sheet. 
 
Criteria for the "type" Property 
 

Criterion Description 
Equal The type of the artifact that owns the property is equal to the specified type. 
No Equal The type of the artifact that owns the property is not equal to the specified type. 
Ancestor The type of the artifact that owns the property is equal to, or is a supertype of, the specified type. 
Not Ancestor The type of the artifact that owns the property is not equal to, and is not a supertype of, the specified type. 
Descendent The type of the artifact that owns the property is equal to, or is a subtype of, the specified type. 
Not Descendent The type of the artifact that owns the property is not equal to, and is not a subtype of, the specified type. 
Related The type of the artifact that owns the property is equal to, or has a common ancestor with, the specified type. 
Not Related The type of the artifact that owns the property is not equal to, and does not have a common ancestor with, the specified type. 
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Placing Groups with the report tool 

10. From the Diagramming Tool Tray Select  
 

11. Set the report to Inventory 
 

12. Set the Diagram type to Circuit 
 

13. Set the class to Group & de-Select Block 
 

14. Select   
 

15. From the report results Select RL-01 
 

16. From the report results Select  
 

17. Select Overall > Select OK 
 

18. Place the Relay  
 

19. Close the report results 
 

20. Close the Report tool 
 
Notice that the wiring shape has 1 coil, 1 NCC & 1 
NOC as defined in the circuit Diagram. 
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Placing Blocks with the report tool 
 

21. Select  from the diagramming tool tray 
 

22. Select Open  
 

23. From the reports directory Select Unplaced-blocks.rep 
 

24. Select the Criteria tab 
 

25. Select Sheets 
 

26. Select Not On 
 

27. Select Wiring Diagram 
 

28. Select  to generate the report  
 

29. Close the Format Report Dialog 
 

30. From the report results dialog Select GND-01  
 

31. From the report results dialog Select  to place the wiring shape. 
 

32. Select ground_sch480 
 

33. Place in the bottom left hand corner of the sheet 
 

34. From the report results dialog Select .  
 

Notice that due to the criteria settings GND-01 is no longer in the report results.  
 

35. Place the remaining shapes 
 
 
Now that we created the wiring view of the circuit diagram lets now 
create our own catalog items to finish our design.
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Defining Catalog Items 
 
About the Catalog Explorer 
The Catalog Explorer is the tool for creating and adding design element definitions to catalogs. These defined elements can then be added to the design.  
In the Catalog Explorer, element definitions are classified in a hierarchy of folders. You can add or delete folders, or cut, copy, and paste elements between folders. 
All designs have a catalog, which is an integral part of the design. A new design has an empty catalog. Once you start creating items in the catalog, these items are automatically stored 
with the design. You must have a design open during this process.
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The Catalog Explorer icons 
 

1. Catalog filter 
2. Creates a new folder 
3. Creates a new prototype artifact.  
4. Cuts either a folder or a prototype artifact 
5. Links either a folder or a prototype artifact 
6. Pastes either a folder or a prototype artifact 
7. Copies either a folder or a prototype artifact 
8. Deletes either a folder or a prototype artifact 
9. Properties of either a folder or a prototype artifact 
10. Creates a new prototype shape that represents the currently Selected prototype artifact.  
11. Package Tool 
12. The Selection filter defaults to the current Open sheet type (e.g. wiring) and filters out components of types that do not match. 
13. Sets the default template settings 
14. Properties of prototype shape  
15. Deletes prototype shape 
16. Opens prototype shape for editing 
17. Updates instanced prototype shapes 
18. Instancing tool 

o  create an instance of a block 

o  create an instance of a port 

o  create an instance of a group 

o  create an unconstrained instance of a group 

o  create an instance of a fiber 

o  create an instance of a cable 
19. Preview 
20. Artifact shapes  
21. Artifact list 
22. Folder structure 
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Defining a port artifact 
 
An artifact is a block, group, fiber or port that can have properties. It is graphically represented on a sheet as a shape. An artifact need not always be represented on a sheet. For example, 
fibers created using the auto wiring dialog box do not have shapes, and so, do not appear on any sheet 
 
A port is a terminal or pin that can be connected to zero or more ports. A port always has a parent or an owner. The parent can be a block, a group, or a fiber.  
A port can connect to any port irrespective of the parent. For example, you can connect a port on a block to a port on another block, a port on a fiber, or a port on a group. A port from a 
block, a port from a fiber, and a port from a group can all be connected together in a single connection. 
Ports are of two types, rigid and scaleable. A rigid port does not scale when the parent is scaled. A scaleable port scales when the parent is scaled. 
 

1. Open the Catalog Explorer.  
 

2. Select Ports from the pull down menu. 
 

3. Select  to create a new Port Artifact.  
 

4. Select the newly created Artifact PORT_1  
 

5. Click RMB > Select Properties 
 

6. Set the name to be General_Port 
 

7. Select Add 
 

8. Select entry_port from the property Selector Dialog  
 

9. From the property selector dialog Select APPLY 
 

10. Select name_format 
 

11. From the property selector dialog Select OK  
 

12. Select name_format 
 

13. In Property Value Enter # 
 

14. Select  to confirm the entry > Select OK. 
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Defining a port shape 
 
A shape is a graphical representation of an artifact on a sheet. A block shape represents a block, a group shape represents a group, a fiber shape represents a fiber, and a port shape 
represents a port.  
A shape has a prototype and an instance.  

 

15. Select  to create a new port shape. 
 

16. Select NEWPORT for the shape template. 
 

17. From the Catalog selector dialog Select OK 
 

18. Select  to Open the port shape for editing  
 

19. Close the Catalog Explorer  



Routed Systems Designer Release 5.0 Basic Tutorial
 

61 of 139 

Grids 
 

About Grid Icons 

To modify the grid properties select  from the main toolbar.  

To view the grid select  from the main toolbar. 

To snap to the grid select  from the main toolbar. 
 

Setting the grid 
 

20. Select  to display the grid.  
 

21. Select  to open the grid dialog. 
 

22. Select draft. 
 

23. Select Modify. 
 

24. Set the grid Spacing to 1 & the Pen to 2. 
 

25. From the grid properties dialog Select OK 
 

26. Set the grid Drawing Interval to 1  
 

27. Select OK to exit the Grid Dialog 
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28. Select the Line tool tray 
 

29. Select  to draw a circle  
 

30. Probe with the LMB on the sheet 
 

31.  Enter 1 for the diameter > Select  to confirm the entry. 
 

32. Select  from the main tool bar > Place the origin of the port to be in the 
centre of the circle 
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Creating Port Labels  
Use labels to display text for blocks, ports, or fibers on a sheet. The label can display values of properties of the object it is associated with, as well as those of associated objects. A 
configurable format string governs the content of the text that is displayed in the label. You can add labels to catalog definitions, objects, and sheets.  
Labels can be configured as either rigid or scalable. Rigid labels retain their original shape when their parents are scaled. Scalable labels scale along with their respective parent 
components. All labels are rigid by default 
 

33. Select the Diagramming tool tray. 
 

34. Select  to add a label. 
 

35. Select . 
 

36. Select name from the property 
selector dialog. 

 
37. From property selector dialog 

Select OK 
 

38. Set the Height to be 1. 
 

39. Set the text justification to be 
centre. 

 
40. Select Apply 

 
41. Place the text in the selector of the 

circle. 
 

42. Select  to close the shape. 
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43. Open the Catalog Explorer  
 

44. Select the new port shape 
 

45. Click RMB > Select Sheet Properties. 
 

46. Set the sheet name to Text Centre  
 

47. From the sheet properties dialog Select OK. 
 

48. Select the  to create a new shape 
 

49. Select NEWPORT for the shape template  
 
50. From the catalog selector dialog Select OK 

 
51. Select the new port shape > Click RMB > Select Sheet Properties. 

 
52. Set the sheet name to Text Bottom > Select OK 

 

53. Select  to open the new shape. 
 

54. Close the Catalog Explorer. 
 

55. Select  to edit the grid properties. 
 

56. Set the grid spacing to 1 & the pen to be 2. 
 

57. Select the Line tool tray and draw a circle with a diameter of 1.  
 

58. Select  from the Diagramming Tool Tray to add a label. 
 

59. Ensure format is Set to <name> 
 

60. Place the label below the circle 
 

61. Select  from the main tool bar > Place the origin of the port to be in 
the centre of the circle. 

 

62. Select  to close the shape. 
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Defining a Block Artifact 
 
A block is an object that can contain ports. The ports can 
accept connections 
 

1. Open the Catalog Explorer. 
 

2. Select Blocks from the pull down menu. 
 

3. Select folder Blocks > Click RMB > Select New 
Folder. 

 
4. Select the newly created folder > Click RMB > Select 

Properties  
 

5. Set the folder name to Switches. 
 

6. Select  to create a new block in the switched 
Directory 

 
7. Select the newly created block > Click RMB > Select 

Properties. 
 

8. Change the name to Push Button Switch. 
 

9. Select the Add button 
 

10. Using the CTRL button Select the following properties 
• def_grouping 
• def_internal_len 
• model_name 
• name_format  
• Object_type  

 
11.  Select OK from the property selector 
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Modifying the artifact properties 
 

12. Select property def_grouping. 
 

13. Select Choose Value. 
 

14. From the Select a string dialog Select ROUND.  
 

15. From the Select a string dialog Select OK. 

16. Select  to confirm the entry. 
 

17. Select property def_internal_len  
 

18. Enter 0 into Property Value . 
 

19. Select  to confirm the entry. 
 

20. Select property model_name  
 

21. Enter PUSH_BUTTON into Property Value 

. 
 

22. Select  to confirm the entry. 
 

23. Select property obj_type.  
 

24. Select Choose Value. 
 

25. From Select a string dialog Select COMPONENT > OK 
 

26. Select  to confirm the entry  
 

27. Set property name_format to be SW-## (Each time the switch is instanced the 
value will increment by 1 i.e. SW-01, SW-02 

etc).  
 

28. Select  to confirm the entry   
 

29. Select OK to close the block properties dialog.
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Creating a Circuit shape 
 

1. Set the diagramming filter to Circuit. 
 

2. Select  to create a new shape. 
 

3. From the Catalog selector Select catalog template NEWBLOCK.  
 

4. From the Catalog selector Select OK. 
 

5. Select  to open the new shape for editing. 
 

6. Close the Catalog Explorer. 
 

7. Select  to edit the grid Properties. 
 

8. Set the drawing interval to 1  
 

9. From the grid dialog Select OK. 
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Creating Lines 
 
Before we can define the shape we need to understand how to create and edit lines within Routed Systems Designer. 
 

About The Line Tool Tray 
 

 Thin, medium & thick solid lines   Ellipses using working line type and base angle 

 Thin, medium & thick dotted line  Boxes using working line type and base angle 

 Thin, medium & thick chain lines  Circles using working line type and base angle 

 Thin, medium & thick short dash lines  Polygons using working line type and base angle 

 Thin, medium & thick long dash lines  Slots constrained to 0/90 degrees from base angle using working line type 

 Centre lines  Free slots using working line type 

 Construction lines  Query or change properties of Closed geometry tools 

 Lines of any type  Create hatching 

 Delete construction lines  Modify Selected hatching 
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About Creating a Line 
 

A line should be thought of as a sequence of points, beginning with point1. When you create a line, the sequence in which you specify the points defines the direction of the 
line. This is shown below. The current point marker indicates the direction of the lines.  
 
 

 
Line Direction 
Knowing the direction of a line is vital when you want to Add a new point to the line as it affects the result that you achieve.  
 
Positioning the cursor at the first point in the line and clicking LMB creates the first point of a line.  The next point in the line is created at the second position of the cursor and 
a line is drawn between the first point and the new point. As you work you can use any of the edit line tools, you can adjust the XY-coordinates of each point by choosing Move 
Point or Line Point Properties... from the popup menu, you can also change the point function by choosing either Line Point Properties from the popup menu or Point Functions 
from the Utilities menu  
When you have finished, you can choose New Line from the popup menu to draw another line, or choose Exit Tool to leave the line Selected ready for the next operation.   If 
you choose none of these, then any further points you create will be joined to the existing line.  
When creating closed geometry, you can also specify the following properties for the closed geometry tools:  

o Working line type  
o Centerline and the amount of overlap beyond the boundary of the geometry  
o Base angle (not free slot tools) 
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About Base angle 
 

The base angle, Set to +0.00000 degrees by default, determines the angle of Closed geometry elements to be drawn on the sheet as shown below.  
 

 
Elements Created Using Different Base Angles 
You can change the angle either by:  

o Choosing Base Angle from the popup menu and entering a new angle in the Angle field. The Closed geometry element you are currently creating will use this base 
angle, as will any subsequent element while the tool remains active.  

o  Choosing the Closed geometry properties tool to display the Closed Geometry Properties box, typing a new angle (either positive or negative) in the Base angle 
field, and then clicking OK. (This sets it for all the closed geometry tools.)  

Please note: You can prefix the angle with either a plus or a minus sign (optional). 
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About Centerlines and centerline overlap 
 

You can choose to display centerlines on the closed geometry that you create. The centerlines indicate the horizontal and vertical axis of the geometry rotated by the amount of 
the base angle.  For the slot tools, the centerlines also pass through the center of the round-slot ends as shown below  
 

 
Displaying Centerlines on Slots 
You can specify whether centerlines are displayed either by:  

o Choosing Switch Centerlines ON/OFF from the popup menu. Centerlines will be displayed, or not displayed, for the next closed geometry element you create with the 
current active tool only.  

o Choosing the Closed geometry properties tool to display the Closed Geometry Properties box, clicking the Add Centerlines at time of creation button, and then 
clicking OK. Centerlines will be displayed, or not displayed, for all subsequent closed geometry elements you create.  

The Centerlines overlap determines the amount by which the Centerlines extend beyond the boundary of the element. You can query or change the overlap in the Closed 
Geometry Properties box. 
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About Editing a Line 
 

You can make changes to a single point, to one or more line segments, or to the whole line. For example, you can edit a line by adding a point to the line, deleting a point from 
the line, or moving a point as shown below.  
 

 
Changing Line Shape by Editing a Line 

 You can edit a line at any time; during or after its creation, when the icon, shown opposite, is displayed in the status area.  
You can use the items on the popup menu for basic line editing or the tools in the Edit Line tool tray for more complex editing tasks 
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Procedure for editing a line 
Select the line for editing using one of the following methods:  

o Choose the Select tool and then with the cursor positioned in the presentation area:  
o Move the cursor to the line you want to edit.  
o Click the SELECT mouse button.  
o Choose Edit from the popup menu. The current point marker appears against one of the points in the line. If there is a coordinate displayed in the X and Y Coord fields, 

the current point marker appears against the point nearest to this. If there is no coordinate, then it appears at the first point.  
o Move the cursor to the point in the line that you want to edit, then double Click the SELECT mouse button.  
o Routed Systems Designer displays the icon, shown opposite, in the status area to show that you are now editing the Selected line.  

 
 
Choose one of the following menu items from the popup menu or any of the edit line tools. 

o New Line ends the line you are currently creating and leaves you ready to start a new line.  
o Close Line Closes the first and last points in the line with a line segment. The last point in the line remains current.  
o Close and New Line creates a line segment between the first and last points in the line, then Closes the line, and ends it leaving you ready to start a new line.  
o Move Point enables you to move the current point to a probed position.  
o Delete Point deletes the current point in a line.  
o Flip reverses the line function. For example, changes a clockwise arc to counterclockwise arc.  
o Reverse Points in Line reverses the direction of the points in a Selected line, that is the first point in the line becomes the last point. 
o Undo undoes any changes that you have made and returns the line to its original state.  
o Redo undoes the result of choosing Undo.  
o Line Point Properties calls up the Line Point Property box for the Selected line. 
o Exit Tool enables you to exit from the active tool and automatically choose the Select tool you used last.  
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Complex line editing 
 

Other changes that you can make to a line include:  
o Adding an arc to a line segment  
o Changing a line segment to a specified angle  
o Changing the length of the line segment  

You carry out these types of tasks using the edit line tools 
 
About the Edit Line Tool Tray 

Extended segment tools Extend segment tools 

Fit curve through points Orthogonalize segments or line 

Divide segment Split or join segments 

Create fillet Create chamfer 

Rotate segment tools Rotate segment tools 

Create tangent point arcs Circular arcs 

Reverse points in line Show or hide segment 

Move point Delete point 

Modify tangent arcs Convert circular arcs 

Create tangent segments Trace lines 
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Defining a circuit shape 
 

10. Select the Line tool tray. 
 

11. Select Medium solid line  
 

12. Draw the four lines 
 

a) Click LMB 
b) Click LMB 
c) Click LMB > Click RMB > Select New Line 
d) Click LMB 
e) Click LMB > Click RMB > Select New Line 
f) Click LMB 
g) Click LMB > Click RMB > Select New Line  
h) Click LMB 
i) Click LMB > Click RMB > Select Exit Tool 

 

13. Select Medium solid line  
 

14. Draw the curve 
 

j) Click LMB 
k) Select Edit Line Tool Tray 

l) Select  to create an Arc 
m) Click LMB 
n) Click LMB > Click RMB > Select Exit Tool 
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Placing Ports & Labels 
 

15. From the Diagramming Tool Tray Select . 
 

16. Select General_Port > Text Bottom. 
 

17. Select OK. 
 

18. Place Port 1 to the right of the shape 
 

19. Click RMB > Select Mirror V. 
 

20. Place Port 2. 
 

21. Click RMB > Select Exit Tool. 
 

22. Select  and Set the Datum to port 1. 
 

23. Select  from the Diagramming tool tray. 
 

24. Select Property <name> 
 

25. Set the text height to 3 > Select Apply 
 

26. Set the text justification to centre. 
 

27. Select Appy 
 

28. Place the text under the shape. 
 

29. Select  to close the sheet. 
 
Now that we have created an artifact Push 
Button Switch and a circuit shape we now 
need to create a wiring shape. 
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Creating a Wiring Shape 
 

1. Open the Catalog Explorer. 
 

2. Select Blocks > Push Button Switch. 
 

3. Set the Diagramming filter to Wiring  
 
Notice that when the filter is set to wiring the circuit shape is 
hidden. 
 

4. Select  to create new shape. 
 

5. From the Catalog selector dialog Select template NEWBLOCK.  
 

6. From the Catalog selector dialog Select OK. 
 

7. Select  to open the new shape for editing. 
 

8. Close the Catalog Explorer dialog. 
 

9. Select  to edit the grid Properties. 
 

10. Set the drawing interval to 1.  
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Utilizing DWG files 
 

11. Select File > Import > DWG  
 

12. From the DWG files folder Select Push Button Switch.dwg > Select OK 
 

13. Select  to view the whole sheet > Zoom into Shape 
 

14. Click and hold the LMB and make a box around the shape to select all of the 
imported geometry.  

 

15. From the Diagramming Tool Tray Select  to move the shape. 
 

16. Select  for Centre Probe 
 

17. Select the circle in the centre of the shape 
 

18. Select the nearest grid intersection  
(ensure that grid snap is on) 

 

19. Click RMB > Select Exit Tool 
 

20. Click RMB > Select De-Select all 
 

21. Select  from the diagramming tool tray. 
 

22. For the name format Select property name  
 

23. Set the text height to 3  
 

24. Set the text justification to centre 
 

25. Place the label as shown 
 

26. Select  from the diagramming tool tray. 
 

27. For the name format Select property 
model_name.  

 

28. Place the label as shown  
 

29. Click RMB >Select Exit Tool 
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About Place Shape for Member 
The Add Member Shapes dialog box displays in the top list the members that already have a shape and in the bottom list the members that do not have a shape.  

Selecting a shapeless member from the bottom list and clicking  or double-clicking a shapeless member in the list displays a shape Selection viewer.  Selecting a shape from the 
viewer allows the shapeless member to be instanced. Once instanced the member will move from the bottom to the top list as it is no longer shapeless. For ports, a shape can be selected 
from all the ports in the catalog. For groups and block members, you can select a shape of the Selected prototype only. 
 
Placing Multi-Ports  
 

30. Select the catalog tool tray 
 

31. Select Place Shape for member  
 

32. Select Add shape  
 

33. Select Text Centre > Select OK 
 

34.  Place in the centre of the right hand circle 
 

35. Select 2 from the shapeless members list 
 

36. Select Add shape  
 

37. Select Text Centre > OK 
 

38. Click RMB > Select MirrorV 
 

39. Place in the centre of the right hand circle 
 

40. Close the Add member Shapes Dialog 
 

41. Select  for the Label Selection tool 
 

42. Using MMB Select text 1 & 2 
 

43. Click RMB > Select Move > Move the text below 
the geometry 

 

44. Select  and Set the datum to be on port 1  
 

45. Select  to close the sheet. 
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Placing the new circuit shape 
 
Now that we have now completed our circuit and wiring shape lets use them 
 
About Block Inlining 
 
Instancing a block automatically inserts the block into a fiber if a pair of opposing ports on the block coincides with a fiber segment. The fiber itself is split into two separate fibers with 
identical properties. This operation is called inlining. If several sets of opposing ports on a block also coincide with fiber segments, then these sets of opposing ports are also inserted into 
the fiber.  
During instancing, while the block is floating on the pointer, the tool shows you whether a pair of ports will be inlined by drawing an X on the relevant ports. This also works with 
groups, for which all the ports in the group and its members are taken into account.  To make the component assume the orientation of an inclined fiber, use the middle mouse button for 
the initial orientation followed by the right or left relative turns, as necessary. 
 

1. Open Circuit Diagram 
 

2. From the Diagramming menu Select  
 

3.  Select Switches > Select the circuit shape of Push Button Switch 
 

4. Select OK 
 

5. Click RMB > Select Turn Left 
 

6. Inline the switch into the vertical section of P-01 
 

7. Select  to update the labels 

6 
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Placing the new wiring shape 
 

1. Open the wiring Diagram 
 

2. Select  from the diagramming tool tray 
 

3. Select Open  
 

4. Select Unplaced-blocks.rep 
 

5. Select the Criteria tab 
 

6. Select Sheets 
 

7. Select Not On 
 

8. Select Wiring Diagram 
 

9. Select  to generate the report  
 

10. Close the Format Report Dialog 
 

11. From the report results dialog Select SW-01  
 

12. From the report results dialog Select  
 

13. Select Push button > Select OK 
 

14. Place to the left of the sheet 
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Datatable Explorer 
 
We are now going to use csv files to apply properties to our shapes. 
 
About Managing Datatables Using the Datatable Explorer 

The Datatable Explorer allows you to manage datatables. To Open the Datatable Explorer, Click  on the toolbar. The Datatable Explorer dialog box opens.  
You can perform various operations using the icons provided in the Datatable Explorer. You first click an item in the tree in the left pane. Depending on the type of node Selected in the 
tree, appropriate information is displayed in the right pane.  
A summary of the actions you can perform follows. These operations can also be initiated from a menu opened by clicking the right mouse button while the cursor is over an item in the 
tree. 

Folder actions 

 Navigates one level up in the tree hierarchy. This icon is enabled only when the currently Selected node is not a root node. 

 Creates a new folder in the currently Selected folder. This icon is enabled only when a folder node is selected in the tree. 
 

Load actions 

 Loads a datatable. This icon is enabled only when a folder node is selected. 
 
A file Selector is displayed after you click one of the load icons. Select a file and Click OK. The Reload dialog box opens. This dialog box displays: 

o The files that will be loaded. 
o The files that already exist in the design and will be reused.  

Click OK and the Selected file is reloaded. To reload multi-level files, either delete the original file first, or reload each file explicitly. 
 

Miscellaneous actions 

 Reloads the Selected table from the file. This icon is enabled only when a datatable, membermap, or portmap is selected in the tree. 

 Saves the Selected table to a CSV file. This icon is enabled only when a membermap or portmap is selected in the tree.  

 Deletes the Selected table. This icon is enabled only when a datatable, membermap, or portmap is selected in the tree and the Selected table does not have any references.
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About CSV files 
 
For this task we shall create a generic fiber and use a datatable to have many different instance properties. 
 

1. Open wires.csv from the CSV Files folder & review the format of the csv files 
 
 
 
 
 
 Header row Type:Datatable 

must be present for Routed 
Systems Designer to identify the 
type of CSV file 

The column $$datasettype$$ MUST be 
present in order for Pro/CABLING to be 
able to create the spools from the logical 
reference 

Min_bend_radius, thickness & units are required properties for Pro/CABLING 

This line is for 
the generic fiber 

Name format is used by Routed Systems Designer 
to auto assign wire names. This can be included 
in the CSV file if naming convention is the same 
for all wires, or it can be added to each wire spool 
individually in the fiber catalog (if you want to 
add it manually DO NOT include it in the CSV 
file – values that are read in from a CSV file can 
NOT be modified in Routed Systems Designer. 
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About Datatables  
 
In Routed Systems Designer, properties provide objects with a way of storing information that is specific to an instance of the object. Some object properties are related. The relationship 
between such properties is captured in a dataset. A collection of datasets for the same object makes up a datatable. 
You use datatables to provide a selection of datasets for a specific type of component and to provide datasets that can be applied to descendents. For example, if you want to indicate that 
a resistor in a circuit diagram has an electrical resistance, you can define the property Resistance that holds the value for that resistor (for example,150 ohms). Because resistors are 
commonly supplied with set values for resistance, you may need to constrain the resistance to a list of preferred values. Additionally, you may also want to provide the name of the 
manufacturers and material. Because different manufacturers can make their resistors from different materials, it may be useful to specify manufacturer and material at the same time 
 
A datatable is created in a Spreadsheet .csv file containing columns of properties and rows representing different combinations of those properties called "Datasets". 
 

 
 
In Routed Systems Designer we can create a Catalog of generic graphical component symbols and link them to datatables such that we can have a single graphical representation of a 
component with many possible sets of parameters. 



Routed Systems Designer Release 5.0 Basic Tutorial
 

85 of 139 

After creating the spreadsheet, datatables can be loaded into Routed Systems Designer using the Datatable Explorer: 
 

 
 
Once loaded, datatables can be linked to Catalog components by using the Select datatable command under object properties in the Catalog Explorer: 
 
 
 



Routed Systems Designer Release 5.0 Basic Tutorial
 

86 of 139 

During placement of instances of the Catalog component on a diagram sheet a dataset (row) from the datatable can be applied to each component using the Dataset Selector: 
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About Membermaps 
 
Most components and connectors in Routed Systems Designer have at least two levels  (the component level and the ports level that lives inside the component) and so we can have 
nested datatables that can be used to apply unique datasets throughout the component structure. 
 
To do this we need to have a "Membermap" file to define the structure of the component (which is also another spreadsheet .csv file) 
 

 
 
Note the membermap file doesn't define any properties, just the names of the members, the level they live on, and optionally reference pointers to datasets for the members within other 
external datatables. 
 
The above membermap is for a variable connector having a maximum of 6 internal blocks, each of which has a single port. 
 
Logical Name is the “index position” of the object in the Catalog definition sheet (see the Datatables tutorial doc for more information on index position) 
 
Physical Name is the desired name to be applied to the object instance on the diagram sheet 
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About Portmaps 
 
A Portmap is identical to a Membermap, but can only be used with Block components, having a two level structure (i.e. Block-->Port). 
Historically, Portmaps preceded Membermaps in RSDesigner.  A Membermap can do all that a Portmap can do and more, essentially making Portmaps now obsolete.  Portmap 
functionality has been maintained for those that have created them and are accustomed to using them. 
 

 
 
Note the use of a Portmap/Membermap is an either/or situation.  In Datatable Explorer, the last two columns displayed for a Datatable are "Member Map" and "Port Map".  For any 
given Dataset (row), there should never be references to both a Membermap and a Portmap in these columns.  Although loadable in Datatable Explorer, Selection of a datatable in 
Catalog Explorer containing any rows defined this way will result in "cannot apply dataset" errors. 
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Creating Folders 

2. Select the data table Explorer icon . 
 

3. Select folder Datatables. 
 

4. Select  to create a new folder. 
 

5. Select the new folder. 
 

6. Select  to edit the folder properties. 
 

7. Set the name of the folder to Wires.  
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Loading CSV Files 
 
Now lets import a CSV files into the wires folder. 

 
8. Select folder Wires. 

 

9. Select  to load a Datatable. 
 

10. Select Wire.csv from the CSV files \ wire datatables directory  
 

11. Select OK from the Load Datatable Dialog 
 

12. Select OK from the second Load Datatable dialog. 
 
You will now see that the Wires folder has been populated with data 
from the CSV file. 
 

13. Close the Datatable Explorer. 
 
We have now loaded data from CSV files into RSD to store in a central 
location.  We can now utilise these datatable’s at any time. 
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Fibers 
 
A fiber is a component such as a wire, a signal network or a pipeline, that can be routed. A fiber can have two or more ports joined by a network of segments. The network does not 
contain loops. 
A fiber is specific to a diagram type, unlike blocks and groups, which can be represented by multiple shapes with different diagram types. 
A fiber may exist on its own, without being connected. 
 
Creating a Template Fiber 
 

1. Select  to Open the Catalog 
Explorer  

 

2. Select Fibres from the pull down 
menu 

 

3. Select  to create a new fibre 
 

4. Select the new fibre  
 

5. Click RMB > Select Properties  
 

6. Set the fibre name to Template Wire 
 

7. Select Apply 
 

8. Select, <Select Datatable> button 
 

9. From the Datatable explorer Select 
wire from the wires folder 

 

10. Select OK from the datatable 
explorer dialog. 

 

11. From the properties dialog Select 
Apply  

 

12. Select Apply Dataset 
 

13. From the Dataset Selector dialog 
Select Line 1 

 
14. Select OK from the Dataset Selector 

dialog 
 

15. Select OK from the properties dialog 
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16. Select  to create new shape 
 

17. Select the new shape 
 

18. Select Properties  
 

19. Select Set 
 

20. From the Select type dialog Select CONNECTION \ 
WIRE \ WIRING_WIRE 

 
21. Select the Shape Tab 

 
22. Set the Diagram type to Wiring 

 
23. Set the color to be black 

 
24. Select the Label Tab 

 
25. Set the text position to be at Both Ends 

 
26. Set label format to <name> 

 
It is optional to set the label decoration and font 
 

27. Set the text height to 2  
 

28. Set the text justification to 
centre 

 
29. Select OK  

 
30. Close the Catalog Explorer 

20 
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About Fiber End Geometry 
 
When a fiber port is connected to another port that does not belong to a fiber, a section of fiber leading from that port is fixed regardless of where the fiber is routed. This section of the 
fiber, called the end geometry, is oriented in the direction of the port to which the fiber’s port is connected and cannot be edited. 
The following figure shows the three basic end-geometries currently defined in Routed Systems Designer. You can also define the number of fans, that is, the number of pairs of non-
straight end-geometries (the figure below shows one fan). The total number of separate routes into a port is 1+2*<number of fans>. 

 
The first fiber to be connected uses the middle (straight) geometry. The second and subsequent fibers to be connected use the remaining routes such that each created fiber has minimal 
length. If there are more connections allowed than available separate routes then all the extra routes use the middle (straight) geometry. 
 
Setting Fiber End Details & Auto Wiring Wire 
 

31. Select File > Design Properties 
. 

32. Select Fibre End Details 
 

33. Select Wiring from the pull down list 
 

34. Set the max connections per port to 5 
 

35. Set the number of fans to 2 
 

36. Select OK 
 

37. Select Auto Wiring Fibre 
 

38. Select Template Wire 
 

39. Select OK 
 

40. Select OK 

33 34 35 
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To Wire a Signal Network 
 
The Wire and Core Assignment Editor allows you to create and connect wiring diagram wires that correspond to the connections of a circuit diagram fiber. The wires created by this tool 
are instances of the designated auto wire fiber prototype.  
To wire a signal network, you can either select the ports or edit the links between the ports in the network. You cannot select ports from multiple networks or edit links across multiple 
networks. You can only select ports and edit links of a single signal network. The network may be simple or complex. 
To designate a wiring diagram catalog fiber as the auto wire fiber prototype, select File > Design Properties > Auto Wiring Fiber. Select the required fiber using the Catalog Selector. If 
you have not designated a wiring diagram catalog fiber, one is created if required. 
 
Wiring the signal network 
 

o Click  in the Diagramming tool tray. The Signal Network Selector dialog box opens.  
Note: Any fiber shape with a diagram type of Circuit is regarded as a signal network. 
o Click Previous or next on the Signal Network Selector dialog box to navigate through multiple networks. The shapes of the current network on the current sheet are highlighted 

to aid Selection. 
o To choose a network to edit from the multiple networks that exist, select a component or a port that is part of the signal network.  
o Click Show Simple or Show Complex on the Signal Network Selector dialog box to select either a simple network or a complex network. 
 

The status of the network wiring is one of the following: 
Ø Under One or more ports that are connected in the circuit diagram are not connected in the wiring diagram. 
Ø Over All the additional ports that are connected in the circuit diagram are connected in the wiring diagram. But some pins are connected by two or more paths. 
Ø Exactly All ports that are connected in the circuit diagram are connected in the wiring diagram by exactly one path. However, some ports may have more than two wires 

connected to it. For example, port 1 can be wired to port 2, port 3, and port 4. All ports are connected by exactly one path. But port 1 has three wires connected to it. 
o Click Display the wire assignment editor. The Wire and Core Assignment Editor dialog box opens. 
o In the Wire and Core Assignment Editor dialog box, Click Edit Ports to select ports in the network or Click Edit links to edit the links between the ports in the signal network.  
 

A link is the gap between ports. Links are of the following type:  
Ø Proposed link When a network that is not wired is selected, the wiring proposal list appears and the gap between the pins is a proposed link. A proposed link is represented 

by dotted lines. 
Ø Approved link The link changes to approved when you accept the wiring proposal.  
Ø Drawn link The drawn link exists as fiber graphics on a wiring diagram and cannot be modified using the Wire and Core Assignment Editor. 
 

Port Manipulation Mode 
 
In the Port Manipulation mode, you can 

o Select ports to change the order of the ports in the network or rework the network. 
o Select ports not in the current block to work on a new network.  
o Select one or more ports that are connected by approved or drawn links, or both. 
 

Note: You cannot select ports across signal networks. 
You can move, flip, cut, copy, or paste the Selected ports.
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Link Manipulation Mode 
 
In the Link Manipulation mode, you can: 

o Apply Proposal Change the Selected proposed links to approved links. 
o Approval Remove Change the Selected approved links to proposed links. 
o Add Proposal Change Selected "no links" to proposals. 
o Remove Link Change proposed or approved links to "no links". 
o Edit Properties 
o Edit Cable 
o Click: 
Ø OK or Apply to apply the changes to the signal network and exit the wire edit session. 
Ø Abort to discard the changes that you made so that the network reverts to the state when the edit session was initiated. 

 
Example: Use of the Wire and Core Assignment Editor 
 
Consider the following example of how to display the wiring proposal list: 

 
If you Select component A, the initial list proposal is as follows: 
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After edits, accept the proposal on the first network and edit the properties to add a wire datatable/dataset.  
Change the proposal so that A;3 has a core running from it to each of D;1 D;2 and D;3. Assign core and cable data tables/data sets. 
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Wire & Core Assignment Editor – Circuit Diagrams 
1. Open Sheet Circuit Diagram 

 
2. Select signal G-01  

 

3. Select  
 

4. Select GND-01 
 

5. Select  
 

6. Select  
 

7. Select the copied GND-01 
 

8. Select  
 

9. Select GND-01 at top of list 
 

10. Select  
 

11. Select Edit links 
 

12. Select the link between RL-01!coil1 2 and PB-01 
 

13. Select  
 

14. De-Select the link between RL-01!coil1 2 and PB-01 
 

15. Select all the remaining links 
 

16. Select  
 

17. Select OK 
 
We have now created three wires. 

You need to 
obtain this 
setup 
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Auto-generating Wires 
 

1. Open Sheet Wiring Diagram 
 

2. Select  
 

3. Select new report  
 

4. Select Inventory 
 

5. Select Wiring 
 

6. De-Select Block & Group & Select Fibre 
 

7. Select the column tab 
 

8. Add properties name and sheets 
 

9. Select  to generate the report. 
 
You will see that three wires are reporting the sheet name as unset 
 

10. Select the three wires 
 

11. Select  from the report results menu to automatically place down the 3 
Selected fibres. 

 

12. Select  
 
You will now see that the wires and now reporting to be on sheet Wiring Diagram 
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Applying properties to a fibre 
 

1. Select the fibre filter tool  
 

2. Select all three wires coming from G01 > RMB > Properties 
 

3. Select Apply Dataset 
 

4. Enter grn in color and 16 in wire gauge 
 

5. Select Update 
 

6. From the data Selector dialog Select OK 
 

7. Select Apply 
 

8. Select Shape Tab 
 

9. Set the colour to green 
 

10. Select Apply 
 

11. Select OK 
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Wire and Core Assignment Editor - Wiring Diagrams 

1. Select the general Selection tool  
 

2. Select SW-01 
 

3. Select  
 

4. Select SW-01 and move into middle of list 
 

5. Select Apply to create the links (wires) and OK to close the dialogue. 
 

6. Select L-01 
 

7. Select  
 

8. Select Next > OK 
 

9. Select Apply > Select OK  
 
We have now created a further three wires 

 

2 
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Auto wiring  
 

10. Select  
 

11. Select generate  (assuming that the report Set up has not been changed since 
the last wire report) 

 
You will see that the three new wires are reporting the sheet name as unset 
 

12. Select the three new wires 
 

13. Select  from the report results menu to automatically place down the Selected 
fibre. 

 

14. Select  
 
You will now see that the wire is now reporting to be on sheet Wiring Diagram 
 

15. Quickly tidy the fibres up 
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Trail files  
To set the properties and the color of the first three fibres involved a number of mouse clicks.  Using a of trail file we can automate common tasks 
 
About Trail Files 
A trail file is a record of all menu choices, dialog-box choices, selections, and keyboard entries for a particular working session. Trail files allow you to view the record of activity so that 
you can reconstruct a previous working session or to recover from an abrupt termination of a session. Trail files are editable text (.txt) files. 
When you run a trail file, the system replays the selections in the exact order in which they were originally made 
 

To Record a Trail File 
o Click Utilities > Trail File > Record Trail File. The Record Trail File dialog box opens. 
o Type a name for the trail file in the Filename box. The file is placed in the current working directory. To place the file in a different location, Click File Selector and 

Browse to the new location.  
o Note: The file must have a .bac extension.  
o To add a header to the top of the trail file, type the value in the Macro Name box.  
o To control the accuracy of the probe points, type a numeric value in the Decimal places box. 
o To record the elapsed time of the trail file, Select Log Elapsed Time. 
o Click OK. 
o To stop recording the trail file, Click Utilities > Trail File > Close Trail File. 

  
To Play a Trail File 
 
o Click Utilities > Trail File > Play Trail File. The Play Trail File dialog box opens. 
o Type the file name in the Filename box. 
o Click OK. 
 
To Automatically Run a Trail File When You Start RSD 
 
o Click Options > Set startup trail. The Startup trail dialog box opens. 
o Select the trail file that you want to run automatically when you start Routed Systems Designer. 
o Click OK. 
 
To Control the Display During Trail File Playback 
 
o Minimize Routed Systems Designer during trail file playback so that dialog boxes do not appear. Minimizing the application also facilitates the quicker playback of the trail 

files.  
o To stop all dialog boxes from appearing in the graphics area during trail file playback, Click Options > Switches, Select Suppress dialog when playing trails, and Click OK. 
o The main window, however, remains Open. The dialog boxes appear when the trail file completes the replay.  
o To restore the visibility of the application, if minimized, when the trail file completes the replay, Click Options > Switches, Select Restore Main Window after playing 

trails and Click OK. 
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To Compare Trail Files 
o To compare trail files and record the comparison in another trail file: 
o Click Utilities > Trail File > Compare Files. The Compare Files dialog box opens. 
o Specify the file names: 
o File 1—Specifies the file to be compared. 
o File 2—Specifies the file to be compared with. 
o Result File—Specifies the output file for the comparison. 
o Specify the comparison type: 

Ø Exact—Compares files exactly. 
Ø Numeric—Compares numeric values in a line as numeric values. 

o Specify the type of action to be taken: 
Ø Compare and Record—Compares and records the comparison in a trail file. 
Ø Record Only—Records the comparison in a trail file.  
Ø Click OK. 

 
 

1. Select fibre W-04 
 

2. Select Utilities > Trail Files> Record Trail File 
 

3. Enter c:\fibre-blue.bac for file name 
 

4. Select OK 
 

5. Click RMB > Select Properties 
 

6. Under the shape tab Set the color to Blue 
 

7. Under the fibre tab Select Apply Dataset 
 

8. Filter for color blu and a wire gauge of 16 
 

9. Select Apply > OK 
 

10. Select Utilities > Trail Files> Close Trail File  
 

11. Repeat steps 1 to 10 for fibre W-05. Create a trail file that sets the color to be red 
with a wire gauge of 16. 
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Customizing the User Interface 
 
Now we have created our trail files we create a button for them on the 
diagramming tool tray.  We are going to use some user-defined icons.  To 
do this we can use gif files and place them in resource directory (you may 
need your system administrator to do this for you) 
 

1. Within windows explorer copy the 5 gif files (fibre-black.gif, fibre-blue.gif, fibre-
red.gif, fibre-yellow.gif, fibre-green.gif ) in the icons directory to 
<loadpoint>\i486_nt\rsdesigner\ui\cursors\text\resource 

 

About Customizing the User Interface 
 
The User interface can be customized by clicking Utilities > Customize UI 
 
The dialogue displays the following 
 

a) Tooltray : Displays the currently selected tool tray. To change the current tool tray, 
select the required tool tray from the list. 

b) Show custom button only : Restricts the display in the list below this check box to only 
those buttons that can be copied. 

c) Button Position : Displays the buttons in the current tool tray. When you select a button 
in this list, the relevant information is displayed in the boxes below the list. 

d) Name : Displays the name of the button 
e) Copy : Copies the button that is currently displayed. To make a copy of the button in 

another tool tray, use Tooltray to change the current tool tray and click Copy 
f) X, Y : Specifies the X and Y position in the tool tray measured from the top left side. 
Note : Gaps are not supported in the X or Y sequence of button positions for a tool tray. 
Any gap in the sequence is automatically removed. 
g) Description :  Displays the description of the button 
h) Icon : Displays the icon associated with the button. 
i) Report Format : Displays the report format associated with the button. This option is 

enabled for report buttons only. 
j) Java : Specifies the name of the Java procedure that the button calls. This option is 

enabled for Java buttons only. 
k) Trail File : Specifies the name of the trail file to be run by the button. This option is 

enabled for trail file buttons only. 
l) Save Definitions : Specifies the location where the customization information is stored. 
m) The … buttons on the right of the fields can be used to Set values 
n) To delete a button, click Delete 
o) The Properties button is used to set the item that will be instanced for an instance 

shortcut button. 
 

 

a 

b 

c 

g 

h 

i 

j 

k 

l 

e 

d 

f 

m 

f 

0 n 



Routed Systems Designer Release 5.0 Basic Tutorial
 

105 of 139 

Creating Button 
 

2. Select Utilities > Customise UI 
 

3. Select User Tool Tray 
 

4. Select dgui_default_trail_button 
 

5. Select Copy  
 

6. Select Diagramming 
 

7. Enter 13in Y 
 

8. Select Apply 
 

9. Select icon fibre-blue.gif 
 

10. Select trail file c:\fibre-blue.bac 
 

11. Select Apply 
 

12. Repeat steps for the red fibre (place in X1 Y13 
 

13. Select OK to overwrite shortcuts.dat 

3 

5 

6 

9 

9 

7 
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Mapkeys 
 
About Mapkeys 
 
Mapkeys are unique, and their stem must not consist of other mapkey sequences. For example, the following are valid sets of mapkeys: 
 
Valid mapkeys nd, no, hell, help 
Invalid mapkeys h, hi, hello, no, 

nod 
Valid mapkey characters for 
use with the calculator 

+, -, *, /, =, . 

 
Note: The calculator, by default, can be controlled by the keyboard. 
 
You can Set mapkeys for the following buttons through the mapkey.dat configuration file. 

o Choice 
o Toggle 
o Action 
o Tool 
 

The mapkey_sequence is either a string of alphanumeric characters or of the form $f1 to $f12 for function keys. You cannot combine function keys with other keys. You can only 
have a single function key for an action.  
 
Mapkey functions may not always be available. There are times when keyboard input must go to the text object, rather than be targeted to a mapkey sequence, for example, a tool prompt 
for parameter input in the main window status area. 
 
A part of an application cannot assume what mapkeys are used elsewhere in the application. Two parts may use the same mapkey. Therefore, mapkeys must be taken as a whole by the 
application. Mapkey functions are an application-wide utility 
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To Create a Mapkey 
 

o Click Edit > Mapkeys. The Mapkey Editor dialog box opens. 

o Drag  and place it over the required menu button. The menu button name appears in the Button. 
o In Mapkey, Enter a mapkey sequence by typing it or selecting it from the keypad in the Mapkey Editor dialog box.  
o On Entering further mapkeys, keys on the keypad may turn blue indicating that they have already been used and that the key sequence may not end with that particular 

key. For example, if a mapkey sequence we already exists, on Entering w as the first key, e disappears from the list. On entering another key, say c, e can be 
selected again. 

o A  indicates that the currently shown mapkey is valid. A  indicates that the currently shown mapkey is invalid. 

o To delete the last character from the mapkey sequence, Click . 
o Click OK. 
 

To Delete a Mapkey 
 

o Click Edit > Mapkeys. The Mapkey Editor dialog box opens. 
o Select the mapkey to be deleted. 
o Right-Click and Select Delete Mapkey. 
o Click OK or Click Close to close the dialog box. 
 

Creating a Mapkey 
 
We can now automate the trail file even further by creating a mapkey 
 

1. Select Edit > Mapkeys 
 

2. Select with the LMB, > Keeping the LMB pressed drag the cursor over the 
blue fibre icon and release. 

 
You will now see that the button entry has populated with dgui_custom_1 
 

3. Enter BF for the mapkey sequence 
 

4. Select Apply 
 

5. Repeat steps 2 to 4 for the red fibre 
 

6. Use one of the new mapkeys to Set W-06 

2 

3 
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Updating Prototype Instances 
 

To update instances of the Selected prototype shape with the current state of the prototype, Select from the Catalog Explorer. The Update Instances dialog opens. You can update all 
instances on the current sheet, on all sheets, or Selected sheets.  
 

1. Select SW-01 > Select CTRL S to Zoom in 
 

2. Open the Catalog Explorer  
 

3. Select Blocks from the pull down menu 
 

4. Select Switches > Push Button Switch >  
 

5. Using the MMB Select the four highlighted lines > Click RMB > Select Delete 
 

6. Select  to Close the shape 
 

7. Open the Catalog Explorer  
 

8. Select the block shape we have just edited 
 

9. Select  
 

10. Select Update all Instances on All Sheets > OK 
 

11. Close the Catalog Explorer 
 
Notice that the switch shape has updated 

? ? ? 5 
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About Updating Variable Groupshapes 
 
You can reorder variable shapes, even when other shapes of the same group exist on other sheets. However, the other shapes are not automatically updated.  

Click  to update the variable groupshapes on the current sheet. 

Click  to update the variable groupshapes on all the sheets in the current design. 

Click  to update the Selected variable groupshape. 
 
Note: A shape is automatically updated when it is reordered. 
 
Changing the Circuit Diagram 
 

1. Open the circuit diagram 
 

2. Select RL-01 
 

3. From the Diagramming Tool Tray Select  
 

4. Select Variable Relay!ncc1_1 
 

5. Place onto the sheet 
 

6. Select Variable Relay!noc1_1 
 

7. Place onto the sheet  
 

8. From the Select member shape to place dialog Select cancel  
 

9. From the Diagramming Tool Tray Select update cross reference shapes  
 

10. From the Diagramming Tool Tray Select update multiple shapes on all sheets 

 
 

11. Open the wiring diagram 
 
Notice that the wiring shape of the Relay has updated 
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Applying data sets  
 
 

1. Select RL-01> Select CTRL S 
 

2. Click RMB > Select Properties 
 

3. Select Apply Dataset 
 

4. Enter 2 for ncc_count and 2 for noc_count 
 

5. Select update 
 

6. Select OK 
 

7. Select Apply 
 

8. Select OK  
 
9. Notice that the port name have updated 

 
             After 

 
                         Before 
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About Adding, Removing, and Reordering Members in Variable Groups 
After you have created an instance of a variable group, you can add, remove, or reorder members of that instance. You can also reorder variable groupshapes that have multiple instances 
of the shape on multiple sheets.  

o Select the group using the Selection tool. 
o From the right mouse button menu, Click Reorder Members. The New Reorder dialog box opens. 
 

To Add a member 
Choose a prototype member from the Prototype list. Specify the number of members to be added in the number field and Click Add. The new member appears in the Members 
list. The number of members of a particular prototype that have been added to a group are displayed in the Added column. 
To add one member of all the prototypes displayed in the top list, Click Add All. 
 
To remove a member 

Select the member you want to delete and Click .  
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To reorder a member 
Select the members to be reordered. The following Selection tools help in easier and quicker Selection. 

 Clear the Selection. 

 Invert the Selection.  

 Select all members. 

 Cutaway members.  
Any members located between the first and last Selected member are set to be visible while the rest of the members are Set to be cutaway. Members that are cutaway are 
marked with an asterisk (*) in the Cut column. 

 Make all members visible. 

 Specify a cutaway range.  
Specify the range of members that are to be made visible in the Cutaway visible cells dialog box. 

 Move to the top of the list. 

 Move up one level. 

 Invert the order of Selection.  
For example, if you have Selected members A, B, C, and D in the list box in that order, this option changes the order to D, C, B, and A. 

 Move down one level. 

 Move to the bottom of the list. 

 Modify width of instanced cells.  
In the Enter Cell Width dialog box, you can enter the cell width or enter a factor by which the current width is to be modified. When a cell width is changed, the cell decoration 
graphics are multiplied or truncated along the group definition direction vector so that the new cell has a continuous decoration pattern throughout. The width of the instanced 
cells is measured in instance sheet units while the width of the prototype cell is measured in prototype sheet units. 

 Cut Selected member. 

 Copy Selected member. 

 Paste copied or cut member.  
The new member is inserted at the position after the last Selected member. If no cells are selected, new members are inserted at the top of the list. 
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When satisfied with your changes, Click Apply. Note the operation of Apply in the following modes: 
o Instancing in the Place mode—Clicking Apply updates only the image displayed on the cursor. No database changes occur until you instance the group.  
o If the Reorder Update option in the Options > Switches > Switches Control Panel is selected, the image displayed on the cursor is updated automatically. If the Reorder Update 

option is not selected, the image on the cursor is not updated automatically. 
o Reordering instanced groups in the Reorder mode—Clicking Apply applies the changes to the instance.  
o  

If you have Selected the Reorder Update option in the Options > Switches > Switches Control Panel, the graphics of the group are updated as you make changes in the dialog box. If you 
have not Selected the Reorder Update option, the graphics are updated only when you Click Apply. 
Note: Clicking OK in both the Place and Reorder mode is equivalent to clicking Apply followed by Cancel. 
 
Re-ordering RL-01 
 

1. Select Rl-01 > Click RMB > Select Reorder members 
 

2. Select Coil 1 
 

3. Select  to move the member to the bottom of the group 
 

4. Select OK 
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Creating a cable definition 
 
We now want turn the 3 of the wires into a cable. 
 
About Cables 
 
In the physical world, cables are conductors comprising individually insulated cores. In Routed Systems Designer, cables are represented by groups of fibers. The cable group carries 
physical property information for the cable itself and for each fiber in the group. The fibers in the cable group represent the cores and carry the properties of the cores. 
To add information or parameters associated with individual cores in the group, use a datatable imported into the group, or Set properties on the cable’s cores.  
You can use the cable tools in the Diagramming Tool Tray to perform the following tasks: 
Instance cables on a sheet 

o Add, edit, and remove decorations 
o Add and remove cores 
o Add shields 
o Disband that is, remove all cores (or child cables) from a cable and then remove the cable. 
 

Methods of instancing cables 
 
You can create a cable on a sheet by:  

o Bundling cores 
o Creating a predefined cable on the sheet 
 

Bundling cores 
 
In this method, cores are placed individually on the sheet. They are then Selected and bundled together into a cable. Cable decorations are then applied manually. This method 
allows for creation of cables on an ad-hoc basis and is suitable for creation of harnesses.  
 
Creating a predefined cable 
 
In this method, the number of cores and their decorations are defined in the catalog first. You can then choose where the cable is to be routed and Routed Systems Designer 
automatically draws the cores and the cable decorations. This method is most useful for routing between connectors. 
You can instance a predefined cable as follows: 

o Routing one core of the cable and the remaining cores are created automatically 
o Selecting two connectors to connect between 
o Selecting the ports on connectors to connect between 

The predefined cable to be instanced can be a multi-level cable. 
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Example: Simple Cable 
 
The following is an example of a simple cable with two decorations. The structure of the cable, as seen in the Model Explorer, is shown on the right.  

 
Cable1 has seven cores and is displayed with two cable decorations surrounding all the cores. The Model Explorer shows the entry for the shape on the cable. 
 
Example: Multi-level Cable 
 
The following is an example of a multi-level cable. The structure of the cable, as seen in the Model Explorer, is shown on the right.  

 
Cable MC1 bundles two 3-core cables, Cable1 and Cable2. The Model Explorer shows the shapes for MC1, Cable1, and Cable2. 
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To Instance a Cable By Bundling Cores 
 

o Select the cores to be bundled into a cable. 

o Click  in the Diagramming tool tray. The Select Cable dialog box opens. A list of cables that can be created is displayed. 
o Select a cable and Click OK. The cable is created and the wires are added to it. 

Note: If the cable is a predefined one with decorations, the decorations are drawn on the cable if the prototypes of the cores match those used in the predefined cable. If the prototypes do 
not match, the Add Cable Decoration mode is started and you can add a decoration to the cable.  
Also, if the cable is a predefined one and has more cores than were Selected, the remaining cores are created as spares. You can view them in the Model Explorer or in a report. 
 
To Instance a Cable By Creating a Predefined Cable 
 

Routing a single core 
 

o Click . 
o Right-Click and Select Deselect All. 
o From the Catalog Explorer, choose a cable to instance. You can also use the group shortcut tool in the Diagramming tool tray. 

The cable instancing works like the fiber-instancing tool to route between ports on connectors or in free space. Once the core has been routed, the other cores are created 
automatically and cable decorations are applied. 
Note: As many cores will be created as there are on the connectors that the first core is routed between. Any remaining cores will be created as spares with no shapes, which can 
be viewed in the Model Explorer or in a report. 
 
Routing between two connectors 
 

o Select the two connectors that the cable is to be created between. 
o Choose the cable place tool from the Catalog Explorer. You can also use the group shortcut tool in the Diagramming tool tray. 

The cable is automatically created and cable decorations are applied. 
Note: As many cores will be created as there are on the Selected connectors. Any remaining cores will be created as spares with no shapes, which can be viewed in the Model 
Explorer or in a report. 
 
Routing between Selected ports 
 

o Select the ports that the cable is to be routed between. The ports may be on more than two connectors. 
o Note: One end of the cable must be routed from a single connector, so the number of cores that will be drawn will be the highest number of ports Selected on one 

connector. 
o Choose the cable place tool from the Catalog Explorer. You can also use the group shortcut tool in the Diagramming tool tray. 

The cable is automatically created and cable decorations are applied. 
 
Note: As many cores will be created as the number of ports that are Selected on one connector. Any remaining cores will be created as spares with no shapes, which can be 
viewed in the Model Explorer or in a report. 
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About Spare Cores 
When a dataset is applied to a cable, any core specified by the dataset that does not exist in the cable, is created as a spare core. This spare core is an instance of the spare core 
catalog fiber specified in the Design Properties dialog box.  
The Spare Core field in the Design Properties dialog box displays the name of the catalog fiber that has been designated as the spare core. To designate a different catalog fiber 
as the spare core, Click … and Select the required catalog fiber. If a spare core has not been designated, Routed Systems Designer creates one, if required. 
Note: Spare cores can also be created when a predefined cable is instanced but not all the cores have shapes. This can occur when the connectors that are routed between do not 
have as many ports as there are cores in the cable. 
 

About Shields 
 

A shield is an extra core that has a different graphical representation and type from the other cores in a cable. Shields are usually drawn from cable decorations and can be 
connected to components in different ways.  
A shield can be identified by its type, that is, connection!wire!wiring_wire!shield.  
Note: Only one shield can be added to a cable at each level in the group hierarchy. Use the Model Explorer to view the group hierarchy and to see which cables have shields. 
 

Ways in which a Shield can be connected 
 
Shields can be connected in the following ways: 
o Shield not connected 
o Shield connected to back shell 
o Shield connected through connector 
o Shield connected to the ground 
o Shield connected to the daisy chain 
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Reporting Shields 
 

Shields can be reported in a From-To list in the following ways: 
 

Direct Link 
 
The following figure shows an example where the shield wire is reported as a direct link between two connectors. 

 
The shield can be reported in the following way: 
  From   To   
Wire Component Pin Component Pin 
Cable3!SHLD CON-5 1 CON-6 1 
 
Through drain wires 
 
The following figure shows an example where the shield wire is reported through drain wires. 

 
The shield connections can be reported in the following way: 
  From   To   
Wire Component Pin Component Pin 
Drain1 CON-7 1 Cable4 SHLD 
Drain2 CON-8 1 Cable4 SHLD 
From this report it is clear that extra wires are attached to the connectors and subsequently attached to the shield of Cable4. 
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Example: Ways in Which a Shield Can be Connected 
 
Examples of the different ways in which a shield can be connected on a diagram are shown below.  
Connection Type Diagram and Run List 
Not connected 

 
Connected to back shell 

 
Connected through connector 

 
Connected to the ground 
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Connected to the daisy chain 

 
 
To Add a Shield to a Cable 

To draw the shield port shapes 
To draw shields on the cable shape, the shield must exist at the artifact level of the cable. This is achieved by drawing a shield core in the catalog cable before it is instanced or 
by applying a dataset to the cable with a member map that specifies a shield.  

o Select the cable to which you want to add the shield. 

o Click  in the Diagramming tool tray.  
o Place the shield on a decoration in the Selected cable.  
o Note: The probing mechanism automatically chooses a suitable position on the cable as you move the cursor near it. If you would like to use the probe tools instead, 

right-Click and choose Use Probe Tools. 
o Right-Click and choose Exit to stop adding shield port shapes. 

After the shield port shapes are placed on cable decorations, you can route shield wires as necessary. You can also add multiple shield port shapes to a decoration thereby 
allowing for daisy chaining of cable decorations.  
 
To draw the shield wires 
 
Shield wires can be drawn as follows: 
Direct link 

o Select the cable from which the shield wire is to be drawn. 

o Click  in the Diagramming tool tray. 
o Click on the shield port shape of a decoration to start the fiber. 
o Create a normal fiber.  
o Click on the port of a component to terminate the fiber  (or) Click in free space, right-Click, and Select Terminate. 

Through drain wires 
Drain wires are created by routing a standard wire from the shield port shape on a cable decoration to the point where the wire is to terminate. 
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Example: Multiple Shield Port Shapes 
A sample of a cable decoration with multiple shield port shapes is shown below. Adding multiple shield port shapes allows for daisy chaining of cable decorations. 

 
 

To Create a Cable Group Definition 
 
You can instance a cable by bundling existing fibers or by creating a complete cable. 
 

To create a cable in the catalog for bundling cores together 
 

o Open the Catalog Explorer and Select Groups from the list. 

o Click . A new group is added to the list with a default name. 

o Click . The Properties dialog box opens.  
Ø Specify the name the cable and Set the type to connection!cable, or its subtype.  
Ø Select a datatable for the cable if necessary. 
Ø Click OK to close the dialog box. 

Ø Click  in the Catalog Explorer. A new shape is added to the Group Shapes list with a default name.  

Ø Click . The shape opens in the graphics window.  
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o A cable prototype for bundling cables without a shield should not have any children. If the cable must have a shield (screen), draw a short piece of fiber in the group 
shape to represent the shield wire type. The type of the fiber should be connection!wire!wiring_wire!shield, or its subtype. 

o Close the shape. The group is complete. 
 

To create a Predefined cable in the catalog 
 

o Create a new fiber and Set the property type to CONNECTION!WIRE!WIRING_WIRE. 

o Click  in the Catalog Explorer and create a shape for the fiber. A new shape is added to the Fiber Shapes list with a default name. 
o Create as many fibers as are required for the different types of cable core. 
o Switch to the Groups folder in the Catalog Explorer. 
o Create a group in the Catalog Explorer and Set the property type to CONNECTION!CABLE. 

o Click  in the Catalog Explorer to create a shape for the group. A new shape is added to the Group Shapes list with a default name. 

o Click . The shape opens in the graphic window.  
o Use construction lines (3 vertical lines) to represent the edges of the connector and the middle of the cable. 
o Draw primary cores, other cables (to make multi-level cables), and shield cores as follows:  

Ø Click  in the Catalog tool tray. The Select a core fiber dialog box opens. 
Ø If you want to instance a fiber, select a core to be placed. 
Ø If you want to place a cable or a shield, Click Cancel. In the main window, right-Click and select new cable or Select shield core. Then, Select the required object. 
Ø The new core or cable is automatically shown between the rightmost and leftmost construction line and follows the vertical movements of the cursor. 
Ø Place the new core as required. 
Ø When all cores have been placed, right-Click and Select Exit. 

o Add cable decorations and shield ports if required. 
Cable decorations placed between the left and middle constructions lines apply to the start side of the fiber route. Cable decorations placed between the right and middle 
constructions lines apply to the end side of the fiber route. This allows the user to create a mirrored (or non-symmetric) look for multi-decorated cables. 

o Click  and place the datum for routing. Choose one of the cores as the core to route when instancing the cable and place the datum on it to signify the choice. 
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About Cable Decorations 
When a cable is created with cores, you can add a cable decoration to give a graphical grouping of the cores of the cable. Cable decorations can be added and modified on cables both in 
the catalog and on design sheets. 
Some sample cable decorations are shown below (for twisted triple, twisted overall and over braiding).  

    
Shields are usually drawn from cable decorations. 
 

To Add a Cable Decoration 
o Select the cores of the cable to which the decoration is to be added. If a cable splits then only select the cores that split from the main cable. 

o Click  in the Diagramming Tool Tray to add a decoration. 
o Right-Click and Select cable geometry. The Select Cable Geometry dialog box opens.  
o Select the type of cable decoration symbol and Click OK. 
o Click in the main window to place the cable decoration symbol. 

Note: All Selected fiber segments must be parallel to be decorated. 
 
To Change the Type of a Cable Decoration 

o Select the cable with the decoration to be edited. 

o Click  in the Diagramming tool tray. 
o With the cursor over the decoration, use the shortcut menu to select alternative cable decoration symbols. 

Note: You cannot change cable decorations with shield port shapes.  
 
To Move a Cable Decoration 

o Select the cable with the decoration. 

o Click  in the Diagramming tool tray.  
o Select the decoration and drag it to the new position.  

Note: All fiber segments Selected must be parallel to be decorated. 
 
To Delete a Cable Decoration 

o Select the cable with the decoration to be deleted. 

o Click  in the Diagramming tool tray.  
o Select the decoration to be deleted.



Routed Systems Designer Release 5.0 Basic Tutorial
 

124 of 139 

Creating a 3 Conductor Cable 
 

1. Open the Datatable explorer 
 

2. Create a new folder and re-name to Cables 
 

3. Load dataset 3xawg16-cable.csv from CSV 
files\cable dataset \ 3 conductor 

 
4. Open the catalog explorer 

 
5. Select Groups from the pull down menu 

 
6. Create a new folder and rename to cables 

 
7. Create a new Group 

 
8. Rename the group to 3xAWG16 

 
9. Select Datatable 3xAWG16 

 
10. Apply the new dataset 

 
11. Select OK 

 
12. Create a new group shape & Open 

 
13. Select the Construction tool tray and place 3 

vertical construction lines 

13 

? ? 13 

13 
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14. Select the Catalog tool tray 

 
15. Select Define the Contents of a Cable Icon 

 
16. From the catalog explorer Select Template Wire 

 
17. Place the fibre 3 times 

 
18. Select RMB > Exit Tool 

 
19. Select the Diagramming tool tray 

 
20. Select the 3 placed fibres 

 
21. Select the Add Cable Decoration to Selected 

Cables 
 

22. Place the cable decoration that is on the cursor on 
the left of the cable 

 
23. Repeat Steps 21 –22 to place a second cable 

decoration on the right of the cable 
 

24. Set the datum to be at the bottom cable on the left.  
By placing the datum point at the bottom the cable 
will be created upwards 

 
 

 

14 

15 21 

? ? 17/20 
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22 
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Using the new cable 
 

25. Select Wires W-05 & W-06  
 

26. From the Diagramming menu Select create cable  
 

27. Place the decoration 
 

28. Now we have created a2 conductor cable, we now want to 
Add the third conductor 

 
29. Select W-06 

 

30. Select Add Selected cores to cable  
 

31. Select the cable decoration 
 

32. Re-Select the cable > Select delete cable decoration  
 

33. Select the cable decoration 
 

34. Select all the cores of the cable 
 

35. Select Add cable decoration  > By clicking the RMB you 
are able to Select alternative cable decoration 

 
36. You may want to edit the conductor colors. 
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Setting up for Pro/Cabling 
 
Now that we have finished our wiring diagram lets use the model explorer to set the port information that is required for sending connectivity information to Pro/Cabling 

 
About the Model Explorer 
The Model Explorer provides a hierarchical representation of a design and allows you to manage various aspects of the model. You can select multiple objects and perform actions on 
them. For example, you can Select multiple sheets and delete them.  
The Model Explorer consists of the following: 

o A Folders tree on the left that displays a hierarchical view of the currently Open design. 
o A pane on the right that displays information about the item Selected in the Folders tree. This pane consists of the following tabs. These tabs may or may not be displayed 

depending on the item selected in the Folders tree. 
o Contents—Displays the contents of the item selected in the Folders tree.  
 

If multiple objects are selected in the Folders tree, the contents of all the objects are displayed. By default, the contents are grouped by class and sorted alphabetically. 
 
Note: You can select objects either in the Folders tree or the right pane (within the contents tab). However, only one Selection is active at any point of time. If an item is selected in the 
right pane, the text in the Folders tree is highlighted in blue. 
 

Preview 
 
Displays a preview of the Selected sheet. 
If multiple objects are selected in the Folders tree, the Preview tab is enabled only if all the Selected objects are on the same sheet. If all the Selected objects are on the same 
sheet, the window zooms such that it contains all the Selected objects. 
The Preview tab shows the latest version of the sheet. If the Selected sheet is Open, changes made to the sheet are reflected in the Preview tab. If the Selected sheet is not open, 
the Preview tab shows the current saved state of the sheet. If an unopened sheet is subsequently opened, the Preview tab reflects the subsequent changes. 
 
Folder Properties, Sheet Properties 
 
Displays the properties of the folder or sheet that is selected in the Folders tree and allows you to modify them. If different types of objects are selected, only those properties 
that are common to all objects are displayed. 

 
Artifact Properties, Shape Properties 
 
Displays the properties of the artifact or shape that is selected in the Folders tree and allows you to modify them. 
 
Property Set Properties 
 
Displays the common properties of a Selection that includes artifacts, shapes or sheets, in the Folders tree and allows you to modify them. 
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About Using the Model Explorer 

The Model Explorer is available only after you have opened a design. To open the explorer, click .  
You can perform various operations using the icons provided in the Model Explorer. You must first click an item in the Folders tree. Icons are enabled or disabled depending on the item 
Selected in the Folders tree. A summary of the operations you can perform follows. 

 Create a new folder in the Selected folders 

 Create a new sheet in the Selected folders 

 Delete Selected items 

 Move to the common parent of the Selected items 

 Cut the Selected item 

 Copy the Selected item 

 Link the Selected item 

 Paste the current clipboard item 

 View the Selected item in the main window 

 Place another shape of the Selected item  
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Setting Port information 
 

1. Open the Model Explorer  
 

2. Select Sheet Wiring Diagram & Expand 
 

3. Expand folder Shape 
 

4. Expand SW-01 
 

5. Select Port 1 
 

6. Select the Artifact Properties Tab 
 

7. Set Property entry_port to 1 
 

8. Select  to confirm the change 
 

9. Select Apply 
 

10. Select Port 2 
 

11. Set Property entry_port to 2 
 

12. Select  to confirm the change 
 

13. Select Apply 
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Wiring from to list 
 
To finish our schematic lets create a from to list 
 

14. Select  from the diagramming tool tray 
 

15. Select to generate a new report  
 

16. Open wiring_from_to.rep from the reports 
folder 

 
17. Investigate the column tab for the settings 

 
18. Select Generate a report table icon 

 
19. Select Load Report Layout Icon 

 
20. Load XHTML.fmt from the report directory 

 
21. Select Open Target Selector Icon 

 
22. Select the XHTML Tab 

 
23. Set the destination of the file 

 
24. Select Generate Report 

 
25. Open the generated  report in a Web 

Browser 
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26. Load a new report format named Sheet.fmt 
 

27. Select Open Target Selector Icon 
 

28. Select the Sheet Tab 
 

29. Select Generate Report 
 

30. Select OK from the Place Table on Sheet Dialog 
 

31. Place the table on the sheet 
 
 
 
 

 

30 

31 
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Exporting XML Data to Pro/Cabling 
 

About Exporting a Design to Pro/CABLING 
To export a Routed Systems Designer design to Pro/CABLING as an XML file, you must specify certain properties for connectors, spools, and cables. Specifying these properties 
enables you to use the logical reference seamlessly. 
 

Connectors 
 
Name Description Type Value_list 

model_name Pro/ENGINEER part name. string   
def_internal_len Default length of internal connector. string   
def_grouping Default connecter grouping. string [round, flat, wire] 
num_of_pins Number of pins in the connector. string   
obj_type Type of component. string [component, connector, wire, prefab] 

 
Cables 
 
Name Description Type Units 
spool_name Name of the cable spool. string   
num_cond Number of individual conductors. real   
min_bend_radius Minimum bend radius. real   
thickness Outside diameter of the cable. real   
units As required, millimeters or inches. real MM 

 
Ports 
 

Name Description Type 
entry_port Name of the Pro/ENGINEER csys the wire will 

attach to. 
string 

 
Wires 
 
Name Description Type Units 
spool_name Name of the wire spool. string   
min_bend_radius Minimum bend radius. real MM 
thickness Outside diameter of the wire. real MM 
obj_type WIRE. string   
units As required, millimeters or inches. real MM 
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About Exporting a Design to Pro/PIPING 
To export a Routed Systems Designer design to Pro/PIPING as an XML file, you must specify certain properties for connectors and pipes. Specifying these properties enables you to use 
the logical reference seamlessly. 
In Pro/ENGINEER, Schematic-Driven Pipeline Modeling works based upon a relationship with Routed Systems Designer. The information from Routed Systems Designer is used in 
conjunction with the Pro/ENGINEER SpecDB. If a fitting, pipeline, or piping specification does not exist or is not correct in the Pro/ENGINEER SpecDB, Schematic-Driven Pipeline 
Modeling does not work. Therefore, ensure that the properties used in Routed Systems Designer match those in the Pro/ENGINEER SpecDB. 
In all cases, the Routed Systems Designer property Name is used as the component’s reference designator in Pro/ENGINEER. 
 

Pipelines (Groups) 
 
Spec The value of this parameter must match the name of the SPEC parameter defined in the piping_spec_dir.ptd file in the SpecDB. Properties defined in the 

piping_spec_dir.ptd file take priority over those defined in Routed Systems Designer. Properties read from the XML file are added to the pipeline as user-
defined properties. 

 
Equipment 
 
Category To classify a Routed Systems Designer component as equipment, specify CATEGORY = EQUIPMENT. 
Model_Name This property is required and is used by Pro/ENGINEER to match components in the 3D assembly with those in the schematic during designation. If this 

property is not specified, match the components manually. 
 
Nozzles 
 
Category To classify a Routed Systems Designer component as a nozzle, specify CATEGORY = NOZZLE. 
Model_Name This property is required and is used by Pro/ENGINEER to match components in the 3D assembly with those in the schematic during designation. If this 

property is not specified, match the components manually. 
 
Note: Nozzles often belong to a piece of equipment. 
 
Branches 
 
Category To classify a Routed Systems Designer component as a branch, specify CATEGORY = BRANCH. 
Sname  The presence of this property is NOT required and it should only be used if the actual type of branch is known, i.e.: olet, bran, etc. If this property is used it 

MUST match the Sname parameter found in the piping_mcat_dir.ptd file in the SpecDB for the branch being used. 
Model_Name This property is optional and is used by Pro/ENGINEER to match components in the 3D assembly with those in the XML during designation. If this 

property is not specified, match the components manually. 
 
Note: Branches can be created in several ways; tees and stub-ins are common branches. Many times, the component to be used in the assembly is not known at the time of the 
schematic’s creation. Therefore, the Model_Name property is not often used and the branch is manually designated in the assembly. In the case of tees, designate the 
Pro/ENGINEER part as the component. In the case of stub-ins, designate the Pro/ENGINEER point as the component. 
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Fittings 
 
Category The value of this parameter must match the value found in the piping_mcat_dir.ptd file for the fitting being used. For example a reducer’s category property 

is set to REDUCER. A valve’s category property is set to VALVE. 
Sname The value of this parameter must match the value found in the piping_mcat_dir.ptd file for the fitting being used. For example, a concentric reducer’s sname 

property is set to CRED. A gate valve’s sname property is set to GATE and a check valve’s sname property is set to CHECK as defined in the 
piping_mcat_dir.ptd file. 

Model_Name This property is required and provides extra insurance that the component selected for insertion in Pro/ENGINEER is exactly the fitting defined in the 
schematic. 

Size This property is optional but it is recommended to use the Size property as found in each individual fitting’s .ptd file in the Pro/ENGINEER SpecDB. This 
property is used to automatically select the correct fitting for insertion. 

Nsize/Bsize These properties (reducer and branch properties) are optional and can be added to the Routed Systems Designer component as found in each individual 
fitting’s .ptd file in the Pro/ENGINEER SpecDB. These properties are used to automatically select the correct fitting for insertion. If these properties are not 
specified, you may need to select some fittings manually.  

 
Ports 
 
Entry_Port This property is optional and can be added to the port of a fitting or nozzle. The value of this property must match the name of the coordinate system in the 

3D component that the pipeline needs to be attached to.
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Exporting to an XML file 
 

32. Select File > Export > XML 
 

33. Select File Selector 
 

34. Enter xml.xml for file name 
 

35. Select OK 
 

36. Select Pro/CABLING 
 

37. Select Current Sheet 
 

38. Select OK 
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Importing XML Data into Pro/CABLING 2001 
 

39. Start Proe 2001 in proe 2001 models directory 
 

40. Open Assembly.asm 
 

41. Select Applications Cabling 
 

42. Select Harness > HARNESS 
 

43. Select Logical Ref > Import > PTC Neutral 
 

44. Select xml.xml 
 

45. Select Components > AutoDesignate > Apply >OK 
 

46. Select Route > Create > Wire > From Logical  
 

47. Select All > Done Sel > Done Sel 
 

48. Select Autoroute > Accept 
 

49. Select Route > Create > cable > From Logical 
 

50. Select All > Done Sel > Done Sel 
 

51. Select Autoroute > Accept 
 

52. Select Logical Ref Compare 
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Importing XML Data into Pro/CABLING Wildfire 
 

53. Start Wildfire in proe wildfire models directory 
 

54. Open Assembly.asm 
 

55. Select Applications Cabling 
 

56. Select Harness > HARNESS 
 

57. Select Logical Ref > Import > PTC Neutral 
 

58. Select xml.xml 
 

59. Select Components > AutoDesignate > Apply >OK 
 

60. Select Route > Create > Wire > From Logical  
 

61. Select All > Done Sel > Done Sel 
 

62. Select Autoroute > Accept 
 

63. Select Route > Create > cable > From Logical 
 

64. Select All > Done Sel > Done Sel 
 

65. Select Autoroute > Accept 
 

66. Select Logical Ref Compare 
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Glossary of Terms 
 

Term Definition 
Artifact An artifact is a block, group, fiber or port that can have properties. It is graphically represented on a sheet as a shape. An artifact need not 

always be represented on a sheet. For example, fibers created using the auto wiring dialog box do not have shapes, and so, do not appear on 
any sheet.  
An artifact has a prototype and an instance. (See Prototype and Instance.) 

Block A block is an object that can contain ports. The ports can accept connections. (See Port) 
Catalog The library of prototype and shape definitions. (See Prototype and Shape) 
Circuit Diagram A diagram that consists of components, represented either by block graphics or group graphics, connected together by signal networks. It is a 

schematic diagram type. 
Cross-reference Shapes Visual aids that help track the relative locations of the members of a variable unconstrained group throughout the design.  
CSV Files Comma Separated Variable files. Use CSV files to specify tables of information. The CSV file contains numbers or strings (lines of text). Data 

elements (or fields) are separated by a comma.  
Datasets A fixed set of properties and values that can be applied to an object are termed as a dataset. These are created by the selection from a 

datatable. 
Datatables Datatables are tables of properties, usually derived from real-world manufactured parts, that can be applied to Routed Systems Designer 

components. Datatables are imported from Comma Separated Variable (CSV) files. 
Design A design consists of sheets that are organized into folders. A design also holds the catalog. 
Design Sheet Sheets that are organized (linked) into folders that comprise a design. A sheet may appear in several folders. Several folders may be linked to 

it. 
Design Snippet A collection of shapes from various design sheets. 
Fiber A fiber is a component such as a wire, a signal network or a pipeline, that can be routed. A fiber can have two or more ports joined by a 

network of segments. The network does not contain loops. 
A fiber is specific to a diagram type, unlike blocks and groups, which can be represented by multiple shapes with different diagram types. 
A fiber can exist on its own, without being connected. 

Folder A container object that contains links to sheets that exist in the design. A folder contains links to other folders and sheets in the design. When 
you create a folder, it is automatically linked to the currently selected folder. 
Folders are also used in the Catalog Explorer, where they contain blocks, groups, fibers and ports, and in the Datatable Explorer, where they 
contain datatables. 

Groups Groups are used to associate multiple blocks or fibers together in a single object, for example, contacts and coils in a relay. 
Groups can contain blocks, fibers, groups, and ports. 

Healing The automatic closing of a gap in a fiber after deletion of a shape. 
Inlining The insertion of block and group shapes into fibers. 
Instance An instance is a copy of a prototype that retains a link to the prototype from which it was created. This enables it to be updated from the 

original prototype. 
Both artifacts and shapes have instances and prototypes. 

Location Set A set of drawings that cross-reference each other. 
Mapkeys A shortcut tool used to map a sequence of keys to a tool or command. Mapkeys are generally used to activate tools in the application's main 

window. 
Membermap An entity, that applies to a hierarchical object, and defines the properties for each element in the hierarchy.  

A membermap must specify a name for every member in the group. If the member is a group, member names must be specified for the 
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members of the group also. The member mappings can also specify a dataset for each member. (See Portmap.) 
Mnemonics A tool that allows keyboard short cuts. 
Multi-level Cable A cable that contains many cables. 
P&ID Process and Instrumentation Design, a commonly used type of Piping diagram. 
Port A port is a terminal or pin that can be connected to zero or more ports. A port always has a parent or an owner. The parent can be a block, a 

group, or a fiber.  
A port can connect to any port irrespective of the parent. For example, you can connect a port on a block to a port on another block, a port on a 
fiber, or a port on a group. A port from a block, a port from a fiber, and a port from a group can all be connected together in a single 
connection. 
Ports are of two types, rigid and scaleable. A rigid port does not scale when the parent is scaled. A scaleable port scales when the parent is 
scaled. 

Portmap Applying a dataset to an instance not only sets properties on that instance, but also (optionally) renames and sets the properties of all the ports 
for that instance. This is called a portmap. Portmaps can be applied to blocks or fibers. The port mappings can also specify a dataset for each 
port. (See Membermap.) 

Prototype A prototype is a definition object from which instances are created in the design. (See Instance.)  
Scenery Miscellaneous 2D graphics such as sheet border. These 2D graphics are not a part of the shape.  
Shape A shape is a graphical representation of an artifact on a sheet. A block shape represents a block, a group shape represents a group, a fiber 

shape represents a fiber, and a port shape represents a port.  
A shape has a prototype and an instance. (See Prototype and Instance.) 

Shield An extra core that has a different graphical representation and type than the other cores in a cable. There can be more than one shield in a 
cable. 

Signal Network A signal network is a fiber network with a diagram type of "circuit" that represents the connections between block and group ports. It is 
independent of any fibers in other diagram types, such as wiring or block. 

Spare Core When a dataset is applied to a cable, any core specified by the dataset and not existing in the cable, is created as a spare core. 
Spool Synonymous with a dataset combined with a membermap. 
Template Basic sheet format, paper size, associated graphics, and so on. 
 


